Date validation problem

7 posts, 0 answers
  1. Modern
    Modern avatar
    12 posts
    Member since:
    Mar 2009

    Posted 09 Jul 2015 Link to this post

    Dears,

    http://demos.telerik.com/aspnet-ajax/datepicker/functionality/validation/defaultcs.aspx 

    When I try to use the above demo, and set start date as "7/9/2015" and End Date as "7/31/2015" I get the invalid message "The second date must be after the first one." while it should not appear. as I tested to set the end date to "7/30/2015" and it worked (Valid condition).

    I think the problem is caused by the timeZone of my computer as it's set to "Egypt Standard Time"

    can you please help.

     

     

  2. Modern
    Modern avatar
    12 posts
    Member since:
    Mar 2009

    Posted 13 Jul 2015 Link to this post

    Dears,

    Any updates?

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Kostadin
    Admin
    Kostadin avatar
    1708 posts

    Posted 14 Jul 2015 Link to this post

    Hello Modern,

    I am afraid I was unable to replicate the issue on my side by setting Egypt Standard Time time zone. Please check out the following video which demonstrates how it works on my end. Could you please check whether the issue remains if you use some other time zone?

    Regards,
    Kostadin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Modern
    Modern avatar
    12 posts
    Member since:
    Mar 2009

    Posted 14 Jul 2015 Link to this post

    Hi Kostadin,

    The issue is gone when I change the timezone to any other timezone, but still not valid when I select Cairo, kindly check the below video:

    AVI format:

    https://drive.google.com/file/d/0B0rULF2sIZsNUjRhR1hXc2xickU/view?usp=sharing

    SWF format:

    https://drive.google.com/file/d/0B0rULF2sIZsNdUpwLTdrbzZEOVU/view?usp=sharing

     ​​

  6. Kostadin
    Admin
    Kostadin avatar
    1708 posts

    Posted 17 Jul 2015 Link to this post

    Hi Modern,

    This is really strange behavior. I tried to replicate the issue by using the exact steps that you have performed and also the same browser but I was unable to. Could you please try the demo on another machine and let me know whether the issue remains? Also can you plese try with another UTC+2 time zone, for instance Helsinki?​

    Regards,
    Kostadin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. Modern
    Modern avatar
    12 posts
    Member since:
    Mar 2009

    Posted 17 Jul 2015 in reply to Kostadin Link to this post

    Hi,

    I have tested it on another machine joining the same domain with Cairo TimeZone, and it worked fine, it seems the problem is on the first machine though it is joining the same domain, what do you think is causing this problem on the first machine?

  8. Kostadin
    Admin
    Kostadin avatar
    1708 posts

    Posted 22 Jul 2015 Link to this post

    Hi Modern,

    You can check whether you are not specify some custom date format in the Region settings of your computer. Otherwise I am afraid I could not provide you with another solution since you are the first user who is reporting such issue.

    Regards,
    Kostadin
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017