d.wrapper.on is not a function

3 posts, 0 answers
  1. King Wilder
    King Wilder avatar
    240 posts
    Member since:
    Oct 2007

    Posted 08 Feb 2012 Link to this post

    I just upgraded my KendoUI CSS classes and javascript files from 2011.3.1129 to 2011.3.1407 and started getting this error.

    I'm using ASP.NET MVC 3 and I updated my StyleSheetsRegistrar and ScriptRegistrar to reference the new folders.  When I change them back to the 1129 version the errors go away.

    Is anyone else getting these errors?

    I'm getting them when I'm loading a view that has both a Kendo DropDownList and a Kendo TreeView on it.


    King Wilder
  2. Atanas Korchev
    Atanas Korchev avatar
    8462 posts

    Posted 09 Feb 2012 Link to this post


     You are using an older version of jQuery. 1.7.1 is required by Kendo UI.

    Atanas Korchev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Alexander
    Alexander avatar
    19 posts
    Member since:
    Jun 2012

    Posted 27 Jun 2012 Link to this post


    Thanks for responding to that - I was having the same issue on my project and now realize I need to upgrade jQuery.

    As a side note, I can't find anything on the website (in the FAQ or otherwise) explaining that Kendo UI requires jQuery 1.7.1, you may want to consider reviewing the online documentation. Along those lines, there is little explanation of some of the newer features, like Grid Column resizing and reordering.

Back to Top