Custom plugin not added to the plugins folder

3 posts, 1 answers
  1. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 19 Mar 2014 Link to this post

    I try to import a custom plugin (this one) and use it instead of the built-in Capture plugin. The problem is that I can't import it. It weights 2.3MB, and when I import the plugin, after a few seconds I get no project refresh and I can't see the plugin folder in the plugins directory.

    This might be due to a timeout, but I have no way to check it out. Can you please help me solve this. Thanks.
  2. Idan
    Idan avatar
    76 posts
    Member since:
    Oct 2012

    Posted 19 Mar 2014 in reply to Idan Link to this post

    The other weird thing is that I disabled the Capture plugin, and although the media-capture plugin wasn't imported, I was able to use the camera to capture photos.
  3. Answer
    Iva Koevska
    Admin
    Iva Koevska avatar
    286 posts

    Posted 19 Mar 2014 Link to this post

    Hello Idan,

    You can refer to my reply in your other thread about the import of the plugin.

    Regarding being able to use the camera - this is expected. The camera plugin relies on the capture plugin and AppBuilder automatically resolves such dependencies at build times. Meaning that if you have the Camera plugin enabled, at build time AppBuilder will include the Capture plugin, either from the core or as a custom plugin (whichever is available).

    Regards,
    Iva Koevska
    Telerik
     
    Icenium is now Telerik AppBuilder, and is part of the Telerik Platform. Learn how to build cross-platform mobile apps using Visual Studio and .NET at the Telerik Platform webinar.
Back to Top