ctrl+k then ctrl+d shortcut

2 posts, 0 answers
  1. SIMC
    SIMC avatar
    3 posts
    Member since:
    Jun 2009

    Posted 23 Mar 2012 Link to this post

    I've always used the above shortcut to reformat my code. When I've installed JustCode the shortcut was overridden and does some seemingly random actions. Either the shortcut now corresponds to a valid command  and I don't know what the command is, or reformatting command is somehow corrupted. I've checked JustCode->KeyMappings and didn't see anything there.
    Just discovered the ctrl+u doesn't work either! That's arguably the most often used command!
    I'm really tempted to uninstall the product. Friends, what am I doing wrong?
  2. Yanaki Yanakiev
    Yanaki Yanakiev avatar
    16 posts

    Posted 26 Mar 2012 Link to this post


    JustCode shouldn't interfere with Visual Studio formatter and doesn't override those 2 shortcuts(ctrl + k, ctrl + d(Edit.FormatDocument) and ctrl + u(Edit.Makelowercase)). You can check on what command the shortcuts are assigned by going to Tools -> Options -> General -> Keyboard and pressing the shortcut in "Press shortcut keys:".

    Its possible that some other addin beside JustCode is interfering. If reassigning the shortcuts to the correct commands doesn't solve your issue. Please open a support ticket and provide us your JustCode logs located at %LocalAppData%\JustCode\Logs and information about the type of your project and the formatted file.

    Also feel free to check out JustCode's formatter(ctrl + alt + f), it's more customizable and has more features than the built-in.

    Kind regards,
    Yanaki Yanakiev
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
  3. DevCraft banner
Back to Top