Crosstab vertical text alignment issue

6 posts, 0 answers
  1. Sunita
    Sunita avatar
    25 posts
    Member since:
    May 2009

    Posted 31 Aug Link to this post

    In crosstab when I set the angle to 270, the text alignment is ignored and is always right aligned. Please see the attached screenshots. Is there a way for the report to actually align as set on design?
  2. Katia
    Admin
    Katia avatar
    299 posts

    Posted 31 Aug Link to this post

    Hello Sunita,

    The attached screenshot shows that the text is aligned correctly. With setting TextAlign=Left the text is aligned to the left side of the TextBox as expected.

    To align the text as shown in the second screenshot, set TextAlign=Right for the TextBoxes.


    Regards,
    Katia
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Sunita
    Sunita avatar
    25 posts
    Member since:
    May 2009

    Posted 31 Aug Link to this post

    My issue is no matter what alignment I choose in the designer, the output is always the same. Please see the image attached.

     

    Thanks,

    Sunita

     

  5. Katia
    Admin
    Katia avatar
    299 posts

    Posted 01 Sep Link to this post

    Hi Sunita,

    If you are using an older version of the product test upgrading to the latest version.
    Check the attached report demonstrating that the text is aligned according to the TextAlign settings when you preview the report.

    If the problematic behavior occurs only when the report is displayed in one of the Report Viewers but not in the Designer's preview, check if there are any custom styles applied for the viewer.

    In case, the issue persists please open a support ticket and attach a demo project reproducing the problematic behavior so we can test it locally and provide you further suggestions.


    Regards,
    Katia
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Sunita
    Sunita avatar
    25 posts
    Member since:
    May 2009

    Posted 01 Sep in reply to Katia Link to this post

    I am using version Q1 2015 SP1.It happens only when the CanShrink is set to true, other wise it works .
  7. Katia
    Admin
    Katia avatar
    299 posts

    Posted 02 Sep Link to this post

    Hi Sunita,

    When you set CanShrink=True for the TextBox it will shrink to the size of the inner text - check this screenshot with the result that occurs when CanShrink is set to true using version Q1 2015 SP1 9.0.15.324.

    It is not clear why the empty space occurs on the left side of the text in your example. You can test trimming the string data filed using Trim() built-in function.

    To provide you further suggestion, please share more details regarding your scenario, if this behavior is only reproducible in the Report Viewer specify which viewer you use, also attach a sample project with test data in a support ticket so we can check the settings.


    Regards,
    Katia
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top
DevCraft banner