Could not load file or assembly 'System.Windows.Browser

4 posts, 0 answers
  1. Anwar Arakkal
    Anwar Arakkal avatar
    21 posts
    Member since:
    Nov 2007

    Posted 31 Jul 2009 Link to this post

    Hi,
    I am getting below error when I use Panel Bar in in my silverlight application

    The "ValidateXaml" task failed unexpectedly.
    System.IO.FileNotFoundException: Could not load file or assembly 'System.Windows.Browser, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e' or one of its dependencies. The system cannot find the file specified.
    File name: 'System.Windows.Browser, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e'

    How can I resolve this issue?
    I am using 2009.1.526.1020 version

    Thanks,
    Anwar
  2. Tihomir Petkov
    Admin
    Tihomir Petkov avatar
    576 posts

    Posted 03 Aug 2009 Link to this post

    Hello Anwar,

    What are you trying to build your application on - Silverlight 2 or Silverlight 3? Our 2009 Q1 binaries are targeting Silverlight 2. If you want to build a Silvrelight 3 application, please download the latest internal build of our 2009 Q2 controls.

    If you give me more details I hope I will be able to help.

    Kind regards,
    Tihomir Petkov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. DevCraft banner
  4. Anwar Arakkal
    Anwar Arakkal avatar
    21 posts
    Member since:
    Nov 2007

    Posted 03 Aug 2009 Link to this post

    Hi,
    I am building aplication on Silverlight 2. I am getting problem on version 2009.1.526.1020 . But my application works perfectly on version 2009.1.312.1020 which is trial version

    Anwar

  5. Ivan
    Admin
    Ivan avatar
    519 posts

    Posted 05 Aug 2009 Link to this post

    Hello Anwar Arakkal,

    Thank you for the clarification.

    Actually the System.Windows.Browser assembly is a part of the Microsoft Silverlight framework. Could you please try to re-reference it and if the problem persists try to locate the assembly manually - note the Reference Assemblies' location depends on the Silverlight version - for example if you setup your computer with SL2 the folder is:
        \Program Files\Microsoft SDKs\Silverlight\v2.0\Reference Assemblies\
    and for SL3 it is:
        \Program Files\Reference Assemblies\Microsoft\Framework\Silverlight\v3.0\

    Once again we advise you do download and use our latest release.

    PS: Please note after the upcoming SP1 release we will probably stop support for the Silverlight 2. Regarding this information we highly advise you to move ahead with the RadControls for Silverlight 3.

    Kind regards,
    Ivan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top