Could not create Database when configure Scheduling server

6 posts, 0 answers
  1. Jutichai
    Jutichai avatar
    3 posts
    Member since:
    Jul 2013

    Posted 25 Jul 2013 Link to this post

    Hello,

    I try to create the database for Scheduling server but I got this error:
  2. Herb
    Herb avatar
    18 posts
    Member since:
    Jul 2013

    Posted 26 Jul 2013 Link to this post

    Jutichai,

    I ran into this problem as well.  Check your eventlog for which user is trying to create the database and give that user permissions to create DB's.

    Herb
  3. Jutichai
    Jutichai avatar
    3 posts
    Member since:
    Jul 2013

    Posted 28 Jul 2013 Link to this post

    Got this error although I assign the permission to be dbcreator and db_owner

    Error
  4. Velin Koychev
    Admin
    Velin Koychev avatar
    88 posts

    Posted 29 Jul 2013 Link to this post

    Hello,

    @Herb - Thank you for sharing with us your experience! 

    @Jutichai -  The error you are receiving means that your database administrator has not given you  the sufficient permission. Speak to your DBA to give you the appropriate permission. Please refer to the attached screenshots for Server Roles and User Mapping for your user and make sure you have the same settings applied. Then give a try with configuring your Scheduling Server following the steps from this article. 

    If the scheduling service on a different machine than the SQL database server, you may need to enable the dbcreator role (see attached screen shot) on the SQL server for the user under which the scheduling service runs. Please find attached a screenshot of this setting in the SQL Server Management Studio.

    Looking forward to hearing from you.

    Regards,
    Velin Koychev
    Telerik
    We've released our first-ever public Test Studio BETA! Download the BETA, install it,
    and send us your feedback! Expires mid-August!
  5. Jutichai
    Jutichai avatar
    3 posts
    Member since:
    Jul 2013

    Posted 29 Jul 2013 Link to this post

    I enabled but it's still not work
  6. Velin Koychev
    Admin
    Velin Koychev avatar
    88 posts

    Posted 31 Jul 2013 Link to this post

    Hello Jutichai,

    I am sorry to hear that you are still experiencing this issue.

    Once you've verified that the role is set, you should try to reconfigure your scheduling server. If you are still having issues, please reply with a screenshot of the Server Roles for the affected user and error in the scheduling server application. In SQL Management Studio you can access the server roles by right-clicking on the affected user, choosing properties and then Server Roles. 

    Looking forward to hearing from you. 

    Regards,
    Velin Koychev
    Telerik
    We've released our first-ever public Test Studio BETA! Download the BETA, install it,
    and send us your feedback! Expires mid-August!
Back to Top