Cordova Vulnerability

2 posts, 0 answers
  1. Ethan
    Ethan avatar
    6 posts
    Member since:
    Sep 2012

    Posted 28 Aug 2014 Link to this post

    There is a new Cordova vulnerability that was published earlier this month. The mitigation includes updating to Cordova 3.5.1. However, the latest version that is available from AppBuilder is 3.5.0, which is still vulnerable. I know Telerik only integrates every other major version into AppBuilder, but considering the vulnerability, is it possible to integrate Cordova 3.5.1 into AppBuilder?
  2. Martin
    Martin avatar
    29 posts

    Posted 28 Aug 2014 Link to this post

    Hi Ethan,

    We integrated and tested Cordova 3.5.1 immediately after its official release. However, we discovered some breaking changes due to the tightened security of the WebView. Most notably, jsHybugger plugin stopped working  and even crashed on some devices.

    The crashes have been resolved and we reported an issue in jsHybugger and despite the fact that it still isn't fixed, we intend to upgrade to Cordova 3.5.1 for Android with our v2.5 release which is scheduled for Sept 9th.

    Best regards,

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top