Color Identifiers Black Background

7 posts, 0 answers
  1. GUTIERREZ Nicolas
    GUTIERREZ Nicolas avatar
    13 posts
    Member since:
    Feb 2008

    Posted 12 Jun 2012 Link to this post

    Hi,

    I use Visual Studio Professional 2012 RC (French) with JustCode Q2 2012.
    When I use the Color Identifiers option, The background is black, so it's unreadable.
    Look at the joined screenshot.

    Is this normal ? How can I change it ?
  2. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 12 Jun 2012 Link to this post

    Whilst I have no access to VS2012, I assume that there is an equivalent option to the VS2010 Tools | Options | Fonts and colors one.

    If you scroll through the list of "Display Items" you should find a bunch of options beginning "JustCode". change the ones you wwant there.

    Does that help?

    --
    Stuart
  3. DevCraft banner
  4. GUTIERREZ Nicolas
    GUTIERREZ Nicolas avatar
    13 posts
    Member since:
    Feb 2008

    Posted 12 Jun 2012 Link to this post

    Yes it works but...

    You have to select "White" for the background color.
    "Auto" and "Default" don't work.

    The same behaviour happens in 3 differents computers, so it's justcode default options that cause this problem.
    It should be "white" by default or auto...
    Because if I use the dark theme, then the background is white. So I can't switch from one to another easily...

    Thanks anyway for your answer !
  5. Stuart Hemming
    Stuart Hemming avatar
    1622 posts
    Member since:
    Jul 2004

    Posted 12 Jun 2012 Link to this post

    In VS2010 selecting "Default" for the background colour seems to work just fine (where changing the background is an available option, for example for (JustCode Method Identifier Marker).

    If it doesn't work in VS2012, you prolly need to raise a bug.

    --
    Stuart
  6. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 14 Jun 2012 Link to this post

    Hi,

     Thanks for the feedback.
    We are aware of this issue which happens in VS2012. As a temporary workaround I will suggest you to manually change the background colors from VS Tools menu -> Options -> Environment -> Fonts and Colors.
    We will do our best to fix it as soon as possible.
    Thank you.

    Please, do not hesitate to contact us if you have any questions.

    Kind regards,
    Zdravko
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  7. Jason Parrish
    Jason Parrish avatar
    87 posts
    Member since:
    Sep 2009

    Posted 18 Jul 2012 Link to this post

    Has this been addressed yet in any internal builds?
  8. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 19 Jul 2012 Link to this post

    Hello Jason,

     Thanks for contacting us.
    Yes, actually it is already fixed, but we could not manage to include in the SP . Most probably we will release it after that.
    So please, stay tuned for the upcoming fixes and features.
    Thanks.

    All the best,
    Zdravko
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top
DevCraft banner