Clarify the binary target frameworks

2 posts, 0 answers
  1. Travis
    Travis avatar
    49 posts
    Member since:
    Dec 2012

    Posted 21 Apr 2013 Link to this post


    Question concerning the binaries included in the install:

    There is a Bin\ and a Bin40\ directory. Is that for .NET 4.0? And what other version(?). Current through .NET 3.5? .NET 4.5?

    I can't imagine we would start any projects with anything less than .NET 4.0, but just wanted to clarify that detail.

    Thank you...


    Michael Powell
  2. Stefan
    Stefan avatar
    2891 posts

    Posted 24 Apr 2013 Link to this post

    Hello Michael,

    Thank you for writing.

    We do provide two builds of our assemblies - one for .NET2.0 and one for .NET4.0. The first is in the Bin\ folder while the latter is in the Bin40\ folder. Most of our controls are built using 2.0, except the RadRichTextBox and RadSpellChecker components which require 4.0, which are only available with the 4.0 version of the assemblies.

    Feel free to use either version of the suite your projects.

    I hope that the provided information addresses your questions.

    Kind regards,
    the Telerik team
    WinForms Q1 2013 boasts PivotGrid, PDF Viewer, Chart enhancements and more. Check out all of the latest highlights.
  3. DevCraft banner
Back to Top