Changing Theme breaks DocumentHost in RadDocking

2 posts, 0 answers
  1. Matthias Bibo
    Matthias Bibo avatar
    72 posts
    Member since:
    Mar 2010

    Posted 07 May 2015 Link to this post

     

    Hello,

     he are having an issue with changing the Theme at runtime. We are using the current release with implicit Theme an noXaml dlls.

    After changing the Theme at runtime while displaying a RadDocking-Container in a Tab the DocumentHost part of the docking is no longer being displayed.

    This only habens if the RadDocking is already open, if a Tab with RadDocking-Control is openend after the Theme has already been switched, everything works fine. It dosent seem to matter witch Theme is used or in witch direction we switch (but tested from Windows7 to DarkTheme and back).

    Its only the DocumentHost part of the Docking that dosent get displayed, the rest (RadSplitContainer etc.) work fine.

    Is there a workaround for this problem?

    Beste regards

    Matthias

  2. Sia
    Admin
    Sia avatar
    667 posts

    Posted 11 May 2015 Link to this post

    Hello Matthias,

    It is hard to understand the issue that causes your problem by the provided information. However there are some known specifics when changing implicit styles at runtime and that is why I would ask you to send us a sample application showing your layout. This way, we will be able to answer you in a quick and satisfactory manner.

    Thank you in advance,
    Sia
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  3. DevCraft banner
Back to Top