CertEnroll not working in release

3 posts, 0 answers
  1. Jasper
    Jasper avatar
    1 posts
    Member since:
    Nov 2015

    Posted 16 Nov 2015 Link to this post

    Hi Eric,

    Not sure this is the right medium for a bug report, but I could not find a bug tracker for your Fiddler project. After update I got certificate errors in browsers that said the certificate had an invalid digital key. After fiddling around I found that your HTTPS options tab changed. After switching to MakeCert things worked again. The issue can be reproduced by clearing the certificates from the stores and switching back to CertEnroll. Let me know if you need additional information or are unable to reproduce the issue. I am currently working on windows 8.1 and .NET framework 4.5.51650.



  2. Eric Lawrence
    Eric Lawrence avatar
    833 posts

    Posted 16 Nov 2015 Link to this post

    Hi, Jasper--

    Please see http://textslashplain.com/2015/10/30/reset-fiddlers-https-certificates/ for simple instructions on how to reset your certificates after you switch to CertEnroll. You'll need to use CertEnroll to remain compatible with upcoming changes in browsers.

    Eric Lawrence
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Michael Freidgeim
    Michael Freidgeim avatar
    1 posts
    Member since:
    May 2010

    Posted 19 Nov 2015 Link to this post

    After installing Https decryption stopped working with the error "The remote certificate is invalid according to the validation procedure" . It wasn't easy to find this post and link to http://textslashplain.com/2015/10/30/reset-fiddlers-https-certificates/.

    It will be good to include reference to reset certificates procedure in release notes for

Back to Top