Cant connect VS2012/OpenAccess to SQL Azure DB

6 posts, 0 answers
  1. Chris
    Chris avatar
    1 posts
    Member since:
    Dec 2012

    Posted 26 Dec 2012 Link to this post

    I can connect VS2012/openaccess to SQL Azure DB...
    But a Dev we're working with can't connect VS2012/OpenAccess to SQL Azure DB.
    His ip is whitelisted in Azure Console.

    Any ideas?
    Thanks
  2. Ady
    Admin
    Ady avatar
    589 posts

    Posted 27 Dec 2012 Link to this post

    Hello Chris,

     Can you provide some more information as to the exact error he experiences? Can he not connect to SQL Azure even via SqlServer Management Studio? What is the error message there?

    Greetings,
    Ady
    the Telerik team
    Q3'12 SP1 of OpenAccess ORM packs Multi-Table Entities mapping support. Check it out.
  3. DevCraft banner
  4. vinkesh
    vinkesh avatar
    10 posts
    Member since:
    Jul 2011

    Posted 27 Dec 2012 Link to this post

    Hello Ady,
    thanks for reply :)

    the connection through SQL server management studio is working fine (can connect to the SQL Azure database through SSMS) but when trying to connect OpenAccess to the SQL Azure and having an error with prompt as below:

    Unable to retrieve the database schema Information.
    Reason :  A connection was successfully established with the sever but then an error occurred during the pre-login handshake provider SSL provider, error : 0 the wait operation timed out.

    Added a OpenAccess Domain model --> Populate from database --> Backend (Microsoft SQL Azure) --> Add Connection string --> Next and then this error comes all the time.

    i am not able to figure it out what is the main problem.

    thanks

  5. Ady
    Admin
    Ady avatar
    589 posts

    Posted 28 Dec 2012 Link to this post

    Hi Vinkesh,

     This seems to be an error while initiating the connection to SQL Azure. Can you increase the default connection timeout value (15 seconds) by specifying a higher value in the connection string? Something like, 'Connect Timeout=30' in the connection string.

    Do let me know if that helps

    All the best,
    Ady
    the Telerik team
    Q3'12 SP1 of OpenAccess ORM packs Multi-Table Entities mapping support. Check it out.
  6. Yordan
    Admin
    Yordan avatar
    39 posts

    Posted 21 Mar 2013 Link to this post

    Hi Bill,

    Please find the answer in this forum thread.

    If that doesn't help you or if you have any other issues connecting to MS Azure using OpenAccess ORM, don't hesitate to get back to us for assistance.

     

    Regards,
    Yordan
    the Telerik team
    Free Webinar: OpenAccess Integration in Sitefinity. SIGN UP NOW.
Back to Top
DevCraft banner