cannot get exclusions to work

5 posts, 0 answers
  1. James
    James avatar
    70 posts
    Member since:
    Jun 2009

    Posted 31 Jan 2011 Link to this post

    Hi.

    I am using radcompression on a .net 2 app which is also compressing viewstate into a session.

    I want to exclude a page from being compressed (specifially the viewstate as it is 300k - it's a very big and silly page with 100''s of controls on).

    whatever i do i cannot achieve this - the page size does nto change.

    after adding

    <

     

    telerik.web.ui>

     

    <

     

    radCompression>

     

    <

     

    excludeHandlers>

     

    <

     

    add handlerPath="rptcurrentactivity.aspx" matchExact="false"/>

     

    </

     

    excludeHandlers>

     

    </

     

    radCompression>

     

    </

     

    telerik.web.ui>

     



    into the web.config for the site, the size does not increase as i would expect. if i remove teh appbrowser file to stop copression, the page size is inclreaed by about 300k as i expect. any ideas?
  2. Martin
    Admin
    Martin avatar
    811 posts

    Posted 03 Feb 2011 Link to this post

    Hello James,

    Could you please try stopping the state compression for the relevant page by adding the following attribute to it:

    [RadCompressionSettings(StateCompression = CompressionType.None)]
    partial class _Default : System.Web.UI.Page
    {
       ...
    }

    I hope this helps.

    Best wishes,
    Martin
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. James
    James avatar
    70 posts
    Member since:
    Jun 2009

    Posted 07 Feb 2011 Link to this post

    <RadCompressionSettings(HttpCompression := CompressionType.None)> _  
    Public Partial Class Default  
        Inherits System.Web.UI.Page  
        ...   
    End Class  

    ... in VB.net.

    Thanks Martin.
  5. Martin
    Admin
    Martin avatar
    811 posts

    Posted 10 Feb 2011 Link to this post

    Hello James,

    Note that setting <RadCompressionSettings(HttpCompression := CompressionType.None)> should stop the request compression. Instead I would suggest that you use <RadCompressionSettings(StateCompression := CompressionType.None)> to stop the viewstate compression.

    I hope this helps.

    All the best,
    Martin
    the Telerik team
    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.
  6. James
    James avatar
    70 posts
    Member since:
    Jun 2009

    Posted 10 Feb 2011 Link to this post

    Good spot! thanks!
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017