Cannot find resource rlinq

5 posts, 0 answers
  1. Rodney
    Rodney avatar
    2 posts
    Member since:
    Nov 2015

    Posted 17 Dec 2015 Link to this post

    I am getting this error and I have tried the fix below, but it did not seem to make any difference.

     

           Message=Cannot find resource EntitiesModel.rlinq embedded in assembly DSDB.DataAccess, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
           Source=Telerik.OpenAccess

     

    Tried this:

    SOLUTION
    You need to manually integrate the OpenAccess Enhancer in the project containing your .rlinq file:
        1.In Solution Explorer right-click the project containing the rlinq and select Unload Project.
        2.Right-click on the unloaded project and select Edit ProjectName.csproj (vbproj).
        3.In your project file, find a line like this one:
    <Import Project="$(MSBuildToolsPath)\Microsoft.CSharp.targets" />
    or if you have VB.NET project, then look for:
    <Import Project="$(MSBuildToolsPath)\Microsoft.VisualBasic.targets" />
    And import the following code after it:
    <ImportCondition="Exists('$(MSBuildExtensionsPath)\OpenAccess.targets')"Project="$(MSBuildExtensionsPath)\OpenAccess.targets"/>
        4.Save your changes. Right-click on your project in the Solution Explorer and select Reload Project.
        5.In Solution Explorer, select your rlinq file and press F4 to open the Properties pane. Ensure that the Build Action is set toOpenAccessDeploy.
        6.Build your solution.

  2. John
    John avatar
    4 posts
    Member since:
    Aug 2015

    Posted 03 Aug 2016 Link to this post

    Rodney, did you ever find a solution to this?
  3. Boyan
    Admin
    Boyan avatar
    100 posts

    Posted 08 Aug 2016 Link to this post

    Hi John,

    To provide its functionalities, Telerik Data Access does some post built enhancements over the model assembly. From the provided information, it seems that this step has failed on your side.

    Here are some known scenarios in which the exception you are experiencing may occur:

    - The last version of Telerik Data Access that has Visual Studio integration and support .rlinq files is 2015 Q1. Please check if you have that (or a prior one) installed - you could download it from this page.
    If you do an upgrade you could use the Upgrade References functionality of Telerik Data Access

    - In case of manual move of a .linq file to another project. In that case the .csproj has to be updated.

    Could I kindly ask you to describe your scenario in detail. It will allow us to help you more quickly.

    I am looking forward to hearing from you.

    Regards,
    Boyan
    Telerik by Progress
     
    Check out the latest announcement about Telerik Data Access vNext as a powerful framework able to solve core development problems.
  4. Sahir
    Sahir avatar
    2 posts
    Member since:
    Feb 2013

    Posted 07 Apr in reply to Boyan Link to this post

    Where i can download Telerik.OpenAccess.2015.1.225.1 ? I didnt found any installer from site now.
  5. Viktor Zhivkov
    Admin
    Viktor Zhivkov avatar
    314 posts

    Posted 11 Apr Link to this post

    Hi Sahir,

    You can download Telerik Data Access 2015 Q1 (version 2015.1.225.1) by logging into your account at www.telerik.com, going to Downloads and selecting the correct version from the Version drop-down.
    Install the .MSI and you will be able to edit your .RLINQ models in Visual Studio 2012 or 2013.

    Regards,
    Viktor Zhivkov
    Telerik by Progress
     
    Check out the latest announcement about Telerik Data Access vNext as a powerful framework able to solve core development problems.
Back to Top