Cannot Find RadMediaPlayer

17 posts, 0 answers
  1. Adam Macaulay
    Adam Macaulay avatar
    5 posts
    Member since:
    Feb 2005

    Posted 17 Aug 2009 Link to this post

    I may be missing it but, when I add the Telerk MediaPlayer dll I only have the abillity to add the PlayListPresenter and RadMediaChapter to the control box. The RadMediaPlayer is not there.

    Am I loading the wrong dll? This is for the latest build released on August 12th

    Thank you
  2. Tihomir Petkov
    Admin
    Tihomir Petkov avatar
    576 posts

    Posted 18 Aug 2009 Link to this post

    Hi Adam,

    Please take a look at the sample project that I prepared for you and let me know if you experience any difficulties.

    Kind regards,
    Tihomir Petkov
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. DevCraft banner
  4. Ruhi TAS
    Ruhi TAS avatar
    8 posts
    Member since:
    Jul 2009

    Posted 28 Aug 2009 Link to this post

    i have the same problem i add all silverligth dll but i couldnt't find media player on the tool box ? 
  5. Miroslav
    Admin
    Miroslav avatar
    922 posts

    Posted 02 Sep 2009 Link to this post

    Hello Ruhi TAS,

    Is this a problem in Visual Studio or Blend 2/3?

    If it is in VS, could you try resetting your toolbox like it is shown here:

    http://www.telerik.com/ClientsFiles/121549_resettoolbox.png

    Best wishes,
    Miroslav
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Tony Freeburg
    Tony Freeburg avatar
    1 posts
    Member since:
    Sep 2009

    Posted 21 Sep 2009 Link to this post

    I have the same problem. I have added Telerik.Windows.Controls, System.Windows.Controls and Telerik.Windows.Controls.MediaPlayer to the references in VS2008. When I browse the the MediaPlayer dll and try to add it to the toolbox, only PlayListPresenter and RadMediaChapter show up. I can see RadMediaPlayer in the dll using the object browser, but I cannot get it to go in the toolbox. Help would be appreciated so that I can go ahead and buy the controls.

    Thank you.
  7. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 22 Sep 2009 Link to this post

    Hello Tony,

    I was not able to reproduce the issue you are describing.
    This is what I did:

    1. From the Toolbox, I selected "Choose Items":



    2. From the "Silverlight Components" tab, I selected to browse for Telerik.Windows.Controls.MediaPlayer.dll.





    3. This is how the "Silverlight Components" tab looked like after selecting the desired binary.



    4. Finally, when I hit OK, the controls were in the Toolbox.



    Give this approach a try and let me know whether I doing something differently.

    Regards,
    Kiril Stanoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  8. Robert Smallwood
    Robert Smallwood avatar
    12 posts
    Member since:
    Jul 2009

    Posted 30 Sep 2009 Link to this post

    I'm having the same issue as Adam and Ruhi. I have gone so far as to completely remove and reinstall everything to verify it is properly installed/configured and it still only shows PlayListPresenter and RadMediaChapter.

    Please see the attached jpg showing the "choose toolbox items" dialog box with only the 2 items available.

    If anyone has any ideas some help would be much appreciated.

    Robert
  9. Ruhi TAS
    Ruhi TAS avatar
    8 posts
    Member since:
    Jul 2009

    Posted 01 Oct 2009 Link to this post

    dear 
    Kiril Stanoev  i have still same problem. I have tried to reinstall all components but i couldn't resolved! i am wainting for new realeas :-(
    bets regards

    ruhi
  10. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 05 Oct 2009 Link to this post

    Hi Ruhi and Robert,

    Could you please try following the steps I previously described, but this time with our latest internal build and let me know if you still encounter the same problem.


    Sincerely yours,
    Kiril Stanoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  11. Robert Smallwood
    Robert Smallwood avatar
    12 posts
    Member since:
    Jul 2009

    Posted 05 Oct 2009 Link to this post

    Kiril,

    I downloaded the latest internal build, reset my toolbar, added the new updated DLLs and everything is working correctly now.

    Thank you for the prompt help!

    Patrick
  12. Ruhi TAS
    Ruhi TAS avatar
    8 posts
    Member since:
    Jul 2009

    Posted 05 Oct 2009 Link to this post

    thanx for new updates .. its ok!!!
  13. Albert Anglin
    Albert Anglin avatar
    7 posts
    Member since:
    Mar 2007

    Posted 06 Dec 2009 Link to this post

    I having the same issue.  I'm using the Q3 version of the Silverlight tools.  It appears to be the most recent version of the tools.  Is there any other advice?  I'm using VS 2008 SP 1 (version 9.0.30729.1) and version 2009.3.1103.1030 of the MediaPlayer DLL.  Is there any sort of work around for these issues.  I have a client asking for the impossible and they wanted it done yesterday. 

    Thanks for your help.  I know this is the problem that keeps on giving...
  14. Albert Anglin
    Albert Anglin avatar
    7 posts
    Member since:
    Mar 2007

    Posted 06 Dec 2009 Link to this post

    FYI, I've tried this on two computers now with the same results one with XP the other running on Vista.
  15. Terry
    Terry avatar
    157 posts
    Member since:
    Jul 2009

    Posted 08 Dec 2009 Link to this post

    i too am having the same problem with Q3.  I really don't want to use the latest internal build for my customer.

    It's not a show-stopper.  I'll just enter the XAML manually.
  16. Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 09 Dec 2009 Link to this post

    Hello Terry,

    This issue has been fixed with our Service Pack 1 release. Give it a try and let me know if you experience some problems.


    Greetings,
    Kiril Stanoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  17. Lee Sauer
    Lee Sauer avatar
    6 posts
    Member since:
    Dec 2009

    Posted 24 May 2010 Link to this post

    Greetings,

    I, too am experiencing the same problem as the others in this thread.  However, I'm using the Q1 2010 version of the control (the specific version is 2010.1.422.1040).

    I have tried the other "tricks" you suggested without any luck.  The Media Player controls all show up in Expression Blend 4, but not in Visual Studio 2010.  Like the others I get only Playlist Presenter and RadMediaChapter.

    Your help will be appreciated.

    Thanks,

    Lee Sauer
  18. Vladislav
    Admin
    Vladislav avatar
    275 posts

    Posted 27 May 2010 Link to this post

    Hello Lee Sauer,

    We are not aware of this problem with our latest official release.
    All of our controls should be available in the VisualStudio 2010 toolbox, just after installing them with our installer.
    You don't have to perform any additional "tricks" in order to add them in the toolbox.
    Can you please try to re-install the controls and let us know the result?

    Attached is a screen shot of VS2010 with RadMediaPlayer just added from the toolbox. The RadMediaPlayer components are in the upper left corner of the picture.

    Sincerely yours,
    Vladislav
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
DevCraft banner