Can't get rid of padding

6 posts, 0 answers
  1. Keith Heilveil
    Keith Heilveil avatar
    29 posts
    Member since:
    May 2005

    Posted 22 Apr 2008 Link to this post

    I noticed I can't seem to use "None" for a skin anymore. this is causing issues because I keep getting padding around an image only menu, which makes the image have breaks in it.

    Note, it's only doing this in IE7. In Firefox, it displays correctly.

    Here's the css I'm using (and yes I named it None), where I tried to set everything to zero.

    Thanks,
    Jason

    .RadMenu_None

    {

    border-right: 0px solid;

    border-top: 0px solid;

    border-left: 0px solid;

    border-bottom: 0px solid;

    padding: 0px 0px 0px 0px;

    margin: 0px;

    }

    .RadMenu_None

    .rmItem

    {

    padding: 0px 0px 0px 0px;

    text-align: left;

    border-right: 0px solid;

    border-top: 0px solid;

    border-left: 0px solid;

    border-bottom: 0px solid;

    }

    .RadMenu_None

    .rmGroup .rmText

    {

    border-right: 0px solid;

    border-top: 0px solid;

    border-left: 0px solid;

    border-bottom: 0px solid;

    padding: 0px 0px 0px 0px;

    text-align:left;

    }

     

    .RadMenu_None

    .rmSeparator

    {

    line-height: 0px;

    border-right: 0px solid;

    border-top: 0px solid;

    border-left: 0px solid;

    border-bottom: 0px solid;

    padding: 0px 0px 0px 0px;

    text-align:left;

    }

    .RadMenu_None

    .rmExpandLeft,

    .RadMenu_None

    .rmExpandRight

    {

    border-right: 0px solid;

    border-top: 0px solid;

    border-left: 0px solid;

    border-bottom: 0px solid;

    padding: 0px 0px 0px 0px;

    }

    .RadMenu_None

    .rmTopArrow,

    .RadMenu_None

    .rmTopArrowDisabled,

    .RadMenu_None

    .rmRightArrow,

    .RadMenu_None

    .rmRightArrowDisabled,

    .RadMenu_None

    .rmLeftArrow,

    .RadMenu_None

    .rmLeftArrowDisabled,

    .RadMenu_None

    .rmBottomArrow,

    .RadMenu_None

    .rmBottomArrowDisabled

    {

    height:16px;

    text-decoration:none;

    color:#E3EFFF;

    text-indent:-9000px;

    }

    .RadMenu_None_rtl

    .rmTopArrow,

    .RadMenu_None_rtl

    .rmTopArrowDisabled,

    .RadMenu_None_rtl

    .rmRightArrow,

    .RadMenu_None_rtl

    .rmRightArrowDisabled,

    .RadMenu_None_rtl

    .rmLeftArrow,

    .RadMenu_None_rtl

    .rmLeftArrowDisabled,

    .RadMenu_None_rtl

    .rmBottomArrow,

    .RadMenu_None_rtl

    .rmBottomArrowDisabled

    {

    text-indent:9000px;

    }

    .RadMenu_None

    .rmRightArrow,

    .RadMenu_None

    .rmRightArrowDisabled

    {

    background: #F6F6F6 url(Menu/right.gif) center center no-repeat;

    width:25px;

    height:100%;

    }

    .RadMenu_None

    .rmLeftArrow,

    .RadMenu_None

    .lefttArrowDisabled

    {

    background: #F6F6F6 url(Menu/left.gif) center center no-repeat;

    width:25px;

    height:100%;

    }

    .RadMenu_None

    .rmTopArrow,

    .RadMenu_None

    .rmTopArrowDisabled

    {

    background: #e3efff url(Menu/top.gif) center center no-repeat;

    width: 100%;

    }

    .RadMenu_None

    .rmBottomArrow,

    .RadMenu_None

    .rmBottomArrowDisabled

    {

    background: #e3efff url(Menu/bottom.gif) center center no-repeat;

    width: 100%;

    }

    .RadMenu_None

    .rmScrollWrap

    {

    position: relative;

    }

    .RadMenu_None_rtl

    ,

    .RadMenu_None_rtl

    *

    {

    text-align:right !important;

    }

    .RadMenu_None_rtl

    .rmGroup .rmText

    {

    padding: 0px 0px 0px 0px !important;

    }

    .RadMenu_None_rtl

    .rmGroup

    {

    background-position: right;

    }

    .RadMenu_None_rtl

    .rmExpandLeft,

    .RadMenu_None_rtl

    .rmExpandRight

    {

    background:transparent url(Menu/groupImageRTL.gif) left center no-repeat;

    }

  2. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 23 Apr 2008 Link to this post

    Hello Keith,

    You can easily turn off skinning by setting the EnableEmbeddedSkins property of the control to false.

    Greetings,
    Paul
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Keith Heilveil
    Keith Heilveil avatar
    29 posts
    Member since:
    May 2005

    Posted 23 Apr 2008 Link to this post

    Thanks for the suggestion,
    I should have mentioned I was already using that setting (that's how I was using a custom skin). Using just that setting, with no skin set, still gives me left and right padding around images.

    Any other suggestions on how to resolve that?

    Thanks,
    Jason
  5. Paul
    Admin
    Paul avatar
    4281 posts

    Posted 23 Apr 2008 Link to this post

    Hi Keith,

    Unfortunately, the provided information does not help us much in reproducing the error. I'm afraid we could not be of much help unless we reproduce the issue on our side. It will be best if you can open a support ticket and send us a simple running project (incl. your custom skin, CSS, images, DB backup if needed and so on) demonstrating the problem (and step-by-step instructions on doing so). In that way we can reproduce and pinpoint the problems you're facing on our side, understand the logic of your application and provide a solution.

    Best wishes,
    Paul
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Keith Heilveil
    Keith Heilveil avatar
    29 posts
    Member since:
    May 2005

    Posted 23 Apr 2008 Link to this post

    Ok,
     I determined the issue. Since I am running under DNN, it was applying the wrong doctype (html versus xhtml transitional) which causes the Radmenu to add the padding since the page then renders in quriks mode in IE 7.

    Once I set the doctype in the DNN skin, it solved the issue.

    Thanks,
    Jason
  7. Tab Alleman
    Tab Alleman avatar
    18 posts
    Member since:
    Apr 2010

    Posted 07 Jun 2010 Link to this post

    Could you explain your solution a little better for someone who is having the same issue in IE7 and doesn't know what DNN is or where/how to set the doctype?

    Sure would be appreciated,
    Tab
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017