Can't Figure Out Vertical Scrolling.

3 posts, 0 answers
  1. TheLostLeaf
    TheLostLeaf avatar
    34 posts
    Member since:
    Feb 2007

    Posted 25 Jun 2010 Link to this post

    Hello, 

    I can't ever seem to get the vertical scroll to appear. The regular MS Windows grid scrolls always appears. This control is being added to another grid inside a RadTabItem. I would like the scroll to kick in when ever the screen size requires it without having to set hard Heights and Widths. Thanks.

    <UserControl x:Class="XXXXXXXXXX_Controls.ServerControlLog"    
                 xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"    
                 xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"    
                 xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"      
                 xmlns:d="http://schemas.microsoft.com/expression/blend/2008"      
                     
                 mc:Ignorable="d"      
                  xmlns:telerik="http://schemas.telerik.com/2008/xaml/presentation">     
        <Grid>    
            <Grid.RowDefinitions>    
                <RowDefinition Height="Auto" />    
                <RowDefinition Height="Auto" />    
            </Grid.RowDefinitions>    
            <WrapPanel Grid.Row="0" Margin="10">     
                <telerik:RadButton Content="Start Server" Margin="5"  Height="23" HorizontalAlignment="Left"  Name="btnStartServer" Click="btnStartServer_Click" VerticalAlignment="Top" Width="75" />    
                <Label Name="lblMessage" Margin="5"></Label>    
            </WrapPanel>    
            <telerik:RadGridView HorizontalAlignment="Left"  Name="radGridServerLog" VerticalAlignment="Top" Grid.Row="1" ScrollViewer.VerticalScrollBarVisibility="Visible" />    
        
        </Grid>    
    </UserControl>    
     
  2. TheLostLeaf
    TheLostLeaf avatar
    34 posts
    Member since:
    Feb 2007

    Posted 26 Jun 2010 Link to this post

    Ok, I figured it out. You can't use auto in the row of the grid you have to apply a min value for height with an astrks *
     <Grid.RowDefinitions> 
                <RowDefinition Height="Auto" /> 
                 <RowDefinition Height="200*"  /> 
    </Grid.RowDefinitions> 
  3. UI for WPF is Visual Studio 2017 Ready
  4. Pavel Pavlov
    Admin
    Pavel Pavlov avatar
    2039 posts

    Posted 28 Jun 2010 Link to this post

    Hi ,
    Just a small clarification - RadGridView will not show any scrollbars  in case it is placed in a panel which measures it with Infinity. In this context - setting the height as you have done is a descent solution.

    Sincerely yours,
    Pavel Pavlov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top