Can't Connect to TFS2010

9 posts, 1 answers
  1. Nasir Ahmed
    Nasir Ahmed avatar
    3 posts
    Member since:
    Oct 2012

    Posted 07 Sep 2011 Link to this post

    Hi,

    Am assessing Team Pulse's suitability - but am getting the following error when establishing a sync server.

    Exception Type: TeamPulse.Client.TeamPulseException

    Exception Message: A connection could not be established to the server with the information you provided. No server entry has been added to TeamPulse.

    Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

       at TeamPulse.Client.Presentation.Sync.SyncServersPresenterModel.ThrowTestServerConnectionException(TestConnectionToRemoteServerCompletedEventArgs e, Boolean resultExceptionEcountered)

       at TeamPulse.Client.Presentation.Sync.SyncServersPresenterModel.service_TestConnectionToRemoteServerCompleted(Object sender, TestConnectionToRemoteServerCompletedEventArgs e)

       at TeamPulse.Client.SynchronizationService.TeamPulseSynchronizationServiceClient.OnTestConnectionToRemoteServerCompleted(Object state)

    (Inner Exception)

    Exception Type: System.Exception

    Exception Message: Could not load file or assembly 'Microsoft.TeamFoundation.Client, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.




    Thanks
    Nas
  2. Kamen Ivanov
    Admin
    Kamen Ivanov avatar
    55 posts

    Posted 07 Sep 2011 Link to this post

    Hi Nasir Ahmed,

    Thanks for contacting us. You need to install TFS client tools to be able to sync with TFS. For more information look here.

    Greetings,
    Kamen Ivanov
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  3. Nasir Ahmed
    Nasir Ahmed avatar
    3 posts
    Member since:
    Oct 2012

    Posted 14 Sep 2011 Link to this post

    Hi,

    I did the install and still the same messaage. I connected from the Team Pusle Server to the TFS server using the Visual studio explorer just to check that they work..

    Please advise?

    Nas
  4. Answer
    Jordan
    Admin
    Jordan avatar
    123 posts

    Posted 14 Sep 2011 Link to this post

    Hi Nasir,

     You need to restart the TeamPulse Integration Service. You can do that from the windows Administrative Tools\services.
    If you need further assistance do not hesitate to contact us again.

    Kind regards,
    Jordan
    the Telerik team
    TeamPulse R2 Officially Released!
    Do you want to know what's new and be able to directly talk to our professionals?
    Reserve a seat for the Weekly Live Demo !
  5. Nasir Ahmed
    Nasir Ahmed avatar
    3 posts
    Member since:
    Oct 2012

    Posted 15 Sep 2011 Link to this post

    That fixed it!

    Thanks
  6. Terry
    Terry avatar
    1 posts
    Member since:
    Aug 2012

    Posted 16 Aug 2012 Link to this post

    I installed the Team Explorer tools on the TFS server..not the TeamPulse server...<roll eyes>...
  7. Ryan
    Admin
    Ryan avatar
    164 posts

    Posted 17 Aug 2012 Link to this post

    Hello,

    Glad you got it sorted out. :) 

    Kind regards,
    Ryan
    the Telerik team
  8. Alex
    Alex avatar
    4 posts
    Member since:
    Mar 2012

    Posted 14 Dec 2012 Link to this post

    FYI: Link is invalid.
  9. Petar
    Admin
    Petar avatar
    3 posts

    Posted 15 Dec 2012 Link to this post

    Hi Alex,

    Thank you for pointing that out. We are doing our best at the moment to correct it.
    Let me know if you need any additional assistance by our side.

    Kind regards,
    Petar Grigorov
    the Telerik team
Back to Top