Button gets disabled after postback

6 posts, 0 answers
  1. JP
    JP avatar
    120 posts
    Member since:
    Aug 2011

    Posted 08 May 2012 Link to this post

    Hi,

    I found an obscure bug in the RibbonBar. I have 8 buttons in the first group of the ribbon bar. Normally, they are all visible. But there is one mode of the page where 7 of them are set to invisible in CreateChildControls after they were added to the RibbonBar. If buttons 2-8 are set to invisible but not the first one, everything works fine after a postback and button 1 is still enabled. But when the visible button is at e.g. the 6th position while all others are invisble, the button gets disabled after the postback. I'm using Q3 2011.

    My workaround for this is to check the mode and insert the button at the first position when I'm in this specific mode. 
    But it would be nice if this strange bug would get fixed.
  2. Bozhidar
    Admin
    Bozhidar avatar
    1101 posts

    Posted 11 May 2012 Link to this post

    Hello,

    Thank you for reporting this issue to us. I've logged it in our system and we will fix it as soon as we can. I've also updated your telerik points.
     
    All the best,
    Bozhidar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. JP
    JP avatar
    120 posts
    Member since:
    Aug 2011

    Posted 19 Jun 2012 Link to this post

    Hi,

    I just wanted to know if this bug is fixed in Q2 2012? I couldn't find anything about that in the release notes.
  5. Bozhidar
    Admin
    Bozhidar avatar
    1101 posts

    Posted 21 Jun 2012 Link to this post

    Hello,

    The bug hasn't been fixed yet, but we'll do our best to fix it in time for the service pack, which comes out next month. 

    Please excuse us for any inconvenience caused.
     
    All the best,
    Bozhidar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. JP
    JP avatar
    120 posts
    Member since:
    Aug 2011

    Posted 10 Sep 2012 Link to this post

    Hi!

    I'm sorry to bring this topic back to top, but I just want to know when there will be a fix for this bug. The last release notes are from July and this bug wasn't mentioned.

    Thanks!
  7. Bozhidar
    Admin
    Bozhidar avatar
    1101 posts

    Posted 13 Sep 2012 Link to this post

    Hi,

    We cannot say with certainty when a fix will be available, but we'll try to address the issue as soon as we can.
     
    Kind regards,
    Bozhidar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017