Built-in content filter - global setting

3 posts, 1 answers
  1. fudoki22
    fudoki22 avatar
    8 posts
    Member since:
    Jun 2009

    Posted 03 Mar 2014 Link to this post

    I would like to disable the RadEditor built-in content filter "ConvertTags" globally rather than in code or markup.
    Is this possible? (In the ConfigFile.xml perhaps?).

    thanks in advance

  2. Answer
    Ianko avatar
    1510 posts

    Posted 06 Mar 2014 Link to this post

    Hello Michael,

    Unfortunately the config files does not provide possibility to control the built-in filters of all RadEditor controls. I recommend using the ASP.NET theme and skins feature to globally configure the desired controls.

    Another possibility would be implementing a custom Client-side method, attached to the Page_Load event, the logic of which is to find all editors on the page and disable the desired filter. You can examine the following customization as example:
    <telerik:RadEditor runat="server" ID="RadEditor1" OnClientLoad="OnClientLoad">
        Sys.Application.add_load(function () {
            var radControls = $telerik.radControls;
            var editors = [];
            for (var i = 0; i < radControls.length; i++) {
                var control = radControls[i];
                if (control instanceof Telerik.Web.UI.RadEditor) {
            disableFilter(editors, "ConvertTagsFilter");
        function disableFilter(editors, filterName) {
            for (var i = 0; i < editors.length; i++) {
                var editor = editors[i];
                var filtersManager = editor.get_filtersManager();


    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

  3. DevCraft R3 2016 release webinar banner
  4. fudoki22
    fudoki22 avatar
    8 posts
    Member since:
    Jun 2009

    Posted 13 Mar 2014 in reply to Ianko Link to this post

    Hi Ianko,

    Thanks for the response - adding the custom client side method seems the simplest option for me and worked well.

Back to Top