Build Failed on android device.

9 posts, 0 answers
  1. John
    John avatar
    16 posts
    Member since:
    Oct 2012

    Posted 12 Apr 2013 Link to this post

    App works fine in emulator and previously worked ok on Android device.

    Not sure if relevant, but since that time, all I have done isI added an IOS device to test on (and the childbrowser plugin) , then ran through the Publish to the Appstore.

    Now, when I try and run it on the Android device I get:

    Error: unable to process assets while packaging '\\419161-FS2\ClientProjects\jcblessing_gmail.com\yourApp\yourApp\bin\Android\Release\app.apk'
     Error: packaging of '\\419161-FS2\ClientProjects\jcblessing_gmail.com\yourApp\yourApp\bin\Android\Release\app.apk' failed
     Error: The command ""C:\Program Files\Java\jdk1.6.0_31\bin\java" -jar apktool.jar build -f "\\419161-FS2\ClientProjects\jcblessing_gmail.com\yourApp\yourApp\bin\Android\Release\app" "\\419161-FS2\ClientProjects\jcblessing_gmail.com\yourApp\yourApp\bin\Android\Release\app.apk"" exited with code 1.
    Done building project "yourApp.proj" -- FAILED.

    Now getting:

    Warning: Access to the path 'classes.dex' is denied.
  2. Paul
    Paul avatar
    56 posts
    Member since:
    Jan 2006

    Posted 12 Apr 2013 Link to this post

    I am experiencing the same issue. I have been evaluating Icenium Graphite for a few weeks now and have had no issue creating apps for both iOS and Android. However, today I am unable to build already existing/non-changed applications. I did however get it to build once this afternoon, but when the apk was transferred to our usual test droid (Galaxy S3), during install it said installation failed....Please elevate this.
  3. John
    John avatar
    16 posts
    Member since:
    Oct 2012

    Posted 12 Apr 2013 Link to this post

    Further info. Just created a new test jquery app and that won't run on an Android device, so I know it is not my code.
  4. Paul
    Paul avatar
    56 posts
    Member since:
    Jan 2006

    Posted 12 Apr 2013 Link to this post

    Same here John. Basic shell template will not build for Android
  5. Dylan
    Dylan avatar
    1 posts
    Member since:
    Apr 2013

    Posted 12 Apr 2013 Link to this post

    Yep, I am getting the same error... damn I just spent a few good hours trying to look into this.
  6. John
    John avatar
    16 posts
    Member since:
    Oct 2012

    Posted 13 Apr 2013 Link to this post

    This morning it seems to be working Ok, fingers crossed...
  7. Deyan Varchev
    Admin
    Deyan Varchev avatar
    150 posts

    Posted 13 Apr 2013 Link to this post

    Hello,

     Thanks guys for reporting this and accept our deepest apologies for any inconvenience you have experienced. We are already investigating what could have caused these errors. Unfortunately, we are not able to reproduce it on our end.
    It could have been some temporary glitch so it will be great if you could try build again.
    We'll continue to investigate this problem to ensure it does not happen in the future.

    Greetings,
    Deyan Varchev
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
  8. John
    John avatar
    16 posts
    Member since:
    Oct 2012

    Posted 13 Apr 2013 Link to this post

    I don't know if it is related or not, but I now find that the app running on my Android device won't update to show changes unless I uninstall the app first
  9. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 15 Apr 2013 Link to this post

    Hello guys,

    We've verified that build, deploy and sync all work as expected now.

    Please excuse us for the temporary inconvenience once again.

    All the best,
    Steve
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Kendo UI Dojo.
Back to Top