Build error

3 posts, 0 answers
  1. Thomas Weidman
    Thomas Weidman avatar
    12 posts
    Member since:
    Apr 2004

    Posted 01 Mar 2012 Link to this post

    I just installed the latest nuget package for a new VS project and am getting the following build error:

    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : System.IO.FileNotFoundException: Could not load file or assembly 'Telerik.OpenAccess, Version=2012.1.214.1, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. The system cannot find the file specified.
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : File name: 'Telerik.OpenAccess, Version=2012.1.214.1, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342'
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at Telerik.OpenAccess.Sdk.Enhancer.EnhancerBase.CrossDomainRun()
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at System.AppDomain.DoCallBack(CrossAppDomainDelegate callBackDelegate)
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at Telerik.OpenAccess.Sdk.Enhancer.EnhancerBase.DomainRun(Boolean createDomain)
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at Telerik.OpenAccess.Sdk.Enhancer.Enhancer.Start(EnhancerSettings _settings)
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at Telerik.OpenAccess.Sdk.Enhancer.Enhancer.Run(EnhancerSettings settings)
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :    at Telerik.OpenAccess.Tools.OpenAccessEnhancer.Execute()
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : WRN: Assembly binding logging is turned OFF.
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : Note: There is some performance penalty associated with assembly bind failure logging.
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error : To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    \packages\OpenAccess.CodeFirst.2012.1.214.1\tools\enhancer\OpenAccess.targets(100,3): error :

    I checked my project with a different version using an older version of OA and I don't see a difference in my csproj or OpenAccess.targets file other than the new version numbers.

    Any input would be appreciated.

    Thanks,
    Thomas

  2. Serge
    Admin
    Serge avatar
    367 posts
    Member since:
    Sep 2012

    Posted 01 Mar 2012 Link to this post

    Hello Thomas,

     We found out there that is an issue with the latest NuGet package, that it seems you have stumbled upon. Fortunately it is pretty easy to workaround it. Just open the OpenAccess package directory, find the lib folder and copy the Telerik.OpenAccess.dll assembly to the package's tools\enhancer folder. (A visual studio restart might be required).

    Either that or download a previous version of the package. Rest assured that we will be uploading the updated one either today or tomorrow. 

    All the best,
    Serge
    the Telerik team
    Want to use Telerik OpenAccess with SQL Azure? Download the trial version today. 

  3. Thomas Weidman
    Thomas Weidman avatar
    12 posts
    Member since:
    Apr 2004

    Posted 01 Mar 2012 Link to this post

    Hi Serge,

    That fixed the issue.

    Thanks,
    Thomas

Back to Top