Bug when using ticktemplate without Height set on root element

3 posts, 1 answers
  1. hwsoderlund
    hwsoderlund avatar
    419 posts
    Member since:
    Aug 2006

    Posted 02 Feb 2011 Link to this post

    I found some sort of layout measuring bug where the entire Silverlight plugin freezes. It happens when using a TickTemplate and the root Grid of that TickTemplate does not have a Height set. I am guessing that it goes into an infinite loop when measuring the ticks. This did not happen before SP1. I have posted a sample project with comments. It references the latest internal build.

    Best regards,
    /Henrik

  2. Answer
    Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 03 Feb 2011 Link to this post

    Hi hwsoderlund,

    We are aware of this issue and the good news is that this is fixed and you will be able to use the fixed slider in the next internal build version of telerik controls. It will be available next week. I tested your application with our daily build (that has the fix included) and it worked fine (whether or not the height of the grid is set)  Please accept us for the inconvenience caused.

    All the best,
    Petar Mladenov
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  3. DevCraft banner
  4. hwsoderlund
    hwsoderlund avatar
    419 posts
    Member since:
    Aug 2006

    Posted 03 Feb 2011 Link to this post

    Great! Thank you.

    /Henrik
Back to Top