Bug when dealing with RadListBox components in the 2010Q1 VSB

2 posts, 1 answers
  1. Gabriele Svelto
    Gabriele Svelto avatar
    6 posts
    Member since:
    Sep 2009

    Posted 19 Mar 2010 Link to this post

    I have tried to create a new style for various components in the new Visual Style Builder and got stuck when dealing with the RadListBox component. In the RadListBoxElement > RadListBoxItem sub-component both the ListBoxItemSelectionFIll and ListBoxItemSelectionBorder seem to ignore their settings, no changes are visible in the preview even if new styles are assigned to this components. The ListBoxItemText sub-component works however. If I save the resulting theme and import it in an application the same problem applies, all the settings for other sub-components work correctly (like the RadListBox border and background) but the list box items' fill and border styles seem to be ignored.


    I looked deeper into the problem and realized that this is not a bug. Apparently the ListBoxItemSelectionFill and ListBoxItemSelectionBorder have by default their Visibility property set to Hidden. Changing it into Visible fixes the problem.
  2. Answer
    Victor avatar
    1349 posts

    Posted 23 Mar 2010 Link to this post

    Hi Gabriele Svelto,

    I am glad that you have found the reason for the experienced behavior. For additional information about this case, you can refer to the following article: Precedence Example: Visibility Property.

    Write again if you have other feedback or if you have questions about our products.

    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. DevCraft R3 2016 release webinar banner
Back to Top