Bug in designer - Q2 2007 SP1

8 posts, 0 answers
  1. Lorenzo
    Lorenzo avatar
    17 posts
    Member since:
    Aug 2007

    Posted 17 Oct 2007 Link to this post

    Hi, there is a bug in RadTabStrip in release Q2 2007 SP1.

    Try this:

    1. Drag RadTabStrip in the form
    2. Write name in tab ("Type here") and press enter
    3. Tha tab just created doesn't appear until RadTabStrip is resized

    Regards,
    Lorenzo
  2. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 18 Oct 2007 Link to this post

    Hi Lorenzo,

    We couldn't replicate the specific behavior you are describing. I have prepared a movie demonstrating that I'm following the steps you've given us.

    Could you please give us more details on how to reproduce this?

    I'm looking forward to your reply.

    Regards,
    Boyko Markov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 22 Oct 2007 Link to this post

    Are you developing under VMWare?
  5. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 22 Oct 2007 Link to this post

    Hi,

    Visual Studio 2003/2005/2008 can do very strange things if you have a graphics card that does not have full direct-x support; Along with your apps if you use direct-x.  I first came across this when developing in a VM-Ware environment, but it also holds true for other environments.

    What I found was that certain graphics were not being rendered “on screen” until I resized my form.  This is a really bad problem because as far as the applications are concerned it did render, which means that you can click on and alter things on page that you can’t even see!

    If this is your problem there is a solution…

    Plan A: Update your video drivers.  It may be that your graphics card does have full direct-x support but your current driver is not utilising it.

    Plan B: Make sure that you have direct-x installed.

    Plan C: Disable direct-x so that everything get’s calculated in the CPU rather than the GPU.

    Windows XP Instructions…

    <!--1.  Go to “Display Properties” (Right Click on blank section of screen and click Properties)

    <!--2.  Go to “Settings” Tab

    <!--3.  Click Advanced Button

    <!--4.  Go to  “Troubleshoot” Tab

    <!--5.  Drag “Hardware Acceleration” slider to the third node from the LHS. (“Disable all DirectDraw and Direct3d accelerations,” …)

    6. Click "Apply"

    I hope this helps…

    Regards,

    Brad

    P.S. If you are using VM-Ware 6 and don’t use 2 or more screens then you could turn on the experimental direct-x support…

  6. Mike
    Admin
    Mike avatar
    640 posts

    Posted 24 Oct 2007 Link to this post

    Hello Brad,

    Thank you for introducing this info on the possible problem under VMware. We will keep this in mind if other customers experience similar problems. The Telerik points in your account have been updated.


    All the best,
    Mike
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Lorenzo
    Lorenzo avatar
    17 posts
    Member since:
    Aug 2007

    Posted 24 Oct 2007 Link to this post

    Hi,

    Sorry for late reply. I'm very busy in these days. I think Brad is right, now I'm trying to fix my problem.

    Thanks for support
    Best regards,
    Lorenzo
  8. Lorenzo
    Lorenzo avatar
    17 posts
    Member since:
    Aug 2007

    Posted 24 Oct 2007 Link to this post

    Fixed!

    I used "plan C" suggested by Brad:

    Right click on desktop / Properties / Settings / Advanced / Troubleshoot and I have disabled all hardware acceleration and "write combining" option too.

    Thank you very much for great support.
    Lorenzo
  9. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 24 Oct 2007 Link to this post

    Glad to be of service!

    Out of curiosity, were you using VMWare or was it a problem with your graphics card?

    Most AGP/PCI-Express graphics cards implement direct-x well.  The same can't be said for a number of on-board video implementations.
Back to Top
UI for WinForms is Visual Studio 2017 Ready