BUG: ContentTemplate added twice

3 posts, 0 answers
  1. Patrik Johansson
    Patrik Johansson avatar
    270 posts
    Member since:
    May 2010

    Posted 26 Mar 2012 Link to this post

    We've noticed what must be a bug in the RadPanelBar, sometimes it seems like the Designer does not update the ContentTemplate, but instead simply adds another ContentTemplate to the markup code, after the previous one. We noticed this bug when we could never see any of the changes we made to a RadPanelBar (it contained just text which was edited), and when we examined the HTML markup, we noticed that there were 2 ContentTemplates, one with the new text and one with the old. Removing the one with the old solved the problem. 
  2. Patrik Johansson
    Patrik Johansson avatar
    270 posts
    Member since:
    May 2010

    Posted 26 Mar 2012 Link to this post

    This actually seem to be a bug that concerns more than just the PanelBar, we've noticed the same problem with other designer components as well, like the RadAjaxManagerProxy which adds new <telerik:AjaxSetting> for any changes made, instead of updating the once already in place. 
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Peter
    Admin
    Peter avatar
    6637 posts

    Posted 27 Mar 2012 Link to this post

    Hello,

    How exactly do you replicate this problem. Here is a video capture of my local test which shows that everything works as expected - http://screencast.com/t/YF2hbTUahG. Can you let me know if I am doing the right steps to observe the issue?


    Regards,
    Peter
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top