Both loading panels show up

6 posts, 1 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 22 Apr 2009 Link to this post

    Hi,

    I have a Masterpage with the following settings for Ajax
            <telerik:RadAjaxManager ID="ramManager" runat="server" DefaultLoadingPanelID="alpPan1" UpdatePanelsRenderMode="Inline" onajaxrequest="ramManager_AjaxRequest" RequestQueueSize="6">  
            <AjaxSettings> 
                <telerik:AjaxSetting AjaxControlID="ramManager">  
                    <UpdatedControls> 
                          
                    </UpdatedControls> 
                </telerik:AjaxSetting> 
            </AjaxSettings> 
        </telerik:RadAjaxManager> 
        <telerik:RadAjaxLoadingPanel ID="alpPan1" Width="200" Height="200" runat="server" Transparency="0" MinDisplayTime="2000">  
            <img alt="Loading..." src='<%= RadAjaxLoadingPanel.GetWebResourceUrl(Page, "Telerik.Web.UI.Skins.Default.Ajax.loading6.gif") %>' style="border: 0;" /> 
        </telerik:RadAjaxLoadingPanel> 
     
    About the "missing" updated controls - my ajax function does only set a session variable.

    On a page I have a radgrid and an ajax proxy like this.

        <telerik:RadAjaxManagerProxy ID="raProxy" runat="server">  
            <AjaxSettings> 
                <telerik:AjaxSetting AjaxControlID="rgCartLines">  
                    <UpdatedControls> 
                        <telerik:AjaxUpdatedControl ControlID="rgCartLines"/>  
                    </UpdatedControls> 
                </telerik:AjaxSetting> 
            </AjaxSettings> 
        </telerik:RadAjaxManagerProxy> 
     
    My problem - the grid shows the loading panel I choose - plus the "new auto panel" from the skin.

    I already started a thread in grid about the "new panels" - I'm not really happy that I can't provide my own panel (with the next version it should be like this).
    The reason - a "spinning wheel" say's almost nothing - especially when it does no longer spin because there is lengthy client rendering going on.

    Anyhow - at the moment the "old panels" are still supported -- BUT I get the panel I choose PLUS the other one.
    This does not look good.
    How can I turn of this "Autopanel feature" so that only my panels (set via manager) get's displayed?

    Regards

    Manfred
  2. Dimo
    Admin
    Dimo avatar
    8330 posts

    Posted 23 Apr 2009 Link to this post

    Hello Manfred,

    You can simply set ShowStatusBar="false" to RadGrid and use only the RadAjaxLoadingPanel.

    Kind regards,
    Dimo
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 23 Apr 2009 Link to this post

    Hi,

    I guess i was misunderstood (maybe this comes from lacks in my english).

    The problem I'm talking about is the "duplication of loading panels".
    Here a screenshot of my problem: http://wow.puzzle101.net/images/loadingpan.png
    As told above I already made a post which includes (some aspects) of this problem.
    http://www.telerik.com/community/forums/aspnet-ajax/general-discussions/first-impressions-q1-2009.aspx#769018
    And what Dimo told here is true on the one hand - and wrong on the other.
    >>the control's Skin property value is set to "" by default, so one will not receive two animated images with the Q1 2009 version
    That sounds true - but the fact is that default isn't looking that good so I have to set a Skin - which results in double animations.
    The other problem - if you don't set a loading panel (keep the things as they are) - the complete controls is grayed out (especially with skin black) and somewhere is that spinner. (In the middle of the control). With big grids where you have to scroll - this is really nasty looking (the users sees only a dark gird - nothing more).

    Anyhow I have to set my panel - and the result is what you see in the screenshot.
    And this is not even a telerik control - it is an image - no chance to set a Skin.
    I found the source of the problem - there is a skin set - I do it in web.config since my customer should be able to change the general look of the telerik controls.

    But the post of Dimo brought me to a solution. I set this CSS rule:
    div.RadAjax_Office2007 .raDiv  
    {  
        background-image:none;  
    }  
     
    And I have to do this for every available skin since my customer can change skins.
    But finally this makes the nasty extra spinner disappear.

    Thank you

    Manfred
  5. Answer
    Dimo
    Admin
    Dimo avatar
    8330 posts

    Posted 24 Apr 2009 Link to this post

    Hello ManniAT,

    I am glad that you have resolved your problem. Actually, if you set Skin="" to the RadAjaxLoadingPanel, this will override the web.config setting.

    Here is some more information about the RadAjaxLoadingPanel skinning feature, in case someone needs it:

    http://www.telerik.com/help/aspnet-ajax/skins.html

    Sincerely yours,
    Dimo
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 24 Apr 2009 Link to this post

    Thank you for this information - it saves me from including all possible Skins in my CSS override.
  7. TonyG
    TonyG avatar
    239 posts
    Member since:
    Feb 2006

    Posted 05 May 2009 Link to this post

    This was very helpful to me. I removed the default Telerik image from my loading panel and then added another asp:Image within the RadAjaxLoadingPanel tags. (An HTML <img> tag doesn't work.)  But then I was always getting two images, mine plus the default spinner.  I did searches for text like "two images", "extra image", "additional images", etc and didn't find anything useful until I got to this thread.  Setting Skin="" on the loadingpanel did the trick!  And I've used the keywords that I was searching for in this posting to help any other poor idiot who's trying to solve the same problem.  ;)
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017