avoid vertical scrollbars

3 posts, 1 answers
  1. HDC
    HDC avatar
    214 posts
    Member since:
    Dec 2010

    Posted 20 Jun 2012 Link to this post

    Hi

    I have following scheduleview
    <telerikDocking:RadPane x:Name="SchedulerRadPane"                                                                 CanUserClose="False"
                            CanFloat="False"
                            CanUserPin="False"
                            CanDockInDocumentHost="False"
    >
     
      <Grid>
     
        <telerik:RadScheduleView x:Name="DesignerSchedulerView"
                                 NavigationHeaderVisibility="Collapsed"
                                 GroupHeaderContentTemplateSelector="{StaticResource GroupHeaderContentTemplateSelector}"
                                 AppointmentsSource="{Binding DesignerAppointments}"             
                                 CategoriesSource="{Binding Categories}"                                                                   
                                 FirstVisibleTime="{Binding FirstVisibleTime}"                              
                                 CurrentDate="{Binding DesignerScheduleViewBaseDateTime, Mode=TwoWay}"                                      
                                 SelectedSlot="{Binding SelectedSlot, Mode=TwoWay}"
                                 ActiveViewDefinitionIndex="{Binding ActiveDesignerViewDefinitionIndex, Mode=TwoWay}"
                                 SelectedAppointment="{Binding SelectedAppointment, Mode=TwoWay}"
                                 ShowDialog="ScheduleviewShowDialog"                                      
                                 AppointmentEditing="ScheduleViewAppointmentEditing"
                                 AppointmentDeleting="ScheduleViewAppointmentDeleting"
                                  
                                 >
     
          <telerik:RadScheduleView.ViewDefinitions>
            <telerik:DayViewDefinition  />
            <telerik:WeekViewDefinition DayStartTime="08:00:00" DayEndTime="10:00:00" MinorTickLength="1h" MajorTickLength="2h"/>
          </telerik:RadScheduleView.ViewDefinitions>
     
        </telerik:RadScheduleView>
     
         
      </Grid>
     
    </telerikDocking:RadPane>

    I would like to display the scheduleview without scrollbars. I have tried setting Day -StartTime and -EndTime, Minor and Major- TickLength, but no matter what i do, it keeps on showing scrollbars.

    How do I prevent the control from using scrollbars and make the content "fit to page"?

    Best Regards,

    Peter
  2. Answer
    Vladi
    Admin
    Vladi avatar
    744 posts

    Posted 22 Jun 2012 Link to this post

    Hello Peter,

    To remove the vertical scrollbar in the ScheduleView control all you need to do is set the MinTimeRulerExtent property to lower value. In this article you can read more details about TimeRuler configuration.

    Kind regards,
    Vladi
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. HDC
    HDC avatar
    214 posts
    Member since:
    Dec 2010

    Posted 22 Jun 2012 Link to this post

    Hi Vladi,

    Thanks for the advice, it solves my problem.

    Best Regards,

    Peter
Back to Top