Aviod vertical RadGrid

4 posts, 0 answers
  1. satya
    satya avatar
    87 posts
    Member since:
    Apr 2009

    Posted 04 Jul 2009 Link to this post


    Hi,

    How to avoid only vertical scroll bar in the rad grid. 
    My rad grid  has 10 columns in the grid and i set AllowScroll=false 
    in the ClientSettings. When radgrid has loaded with the data, i could not see the veritical scroll bar. This is ok for me. But now i could not see the horizontal scroll bar also. Because of this i could see only 5 columns of the grid. Remaining 5 columns are missing. 

    I need to avoid only vertical scroll bar of the grid not horizontal scroll bar.


    Please sugguest.

    Thanks 
    Satya.
     
  2. Kenneth
    Kenneth avatar
    70 posts
    Member since:
    Feb 2008

    Posted 04 Jul 2009 Link to this post

    You can put the grid into a div and let the div handle the horizontal scrolling. Just set the div with styles:

    overflow: auto;
    overflow-y: hidden;

    Regards,
    Ken
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 06 Jul 2009 Link to this post

    Hi Satya,

    Try setting the AllowScroll property of the Grid to true. In order to display horizontal scroll for navigation, you need to make sure that the total width of the columns (either auto-generated or declaratively set) exceeds the width of the grid (as demonstrated in the online demo itself).  Moreover, to render merely the horizontal scroll and avoid the appearance of the vertical scroll, make sure that the height of the records in the grid does not exceed the ClientSettings -> Scrolling -> ScrollHeight scroll setting.  Refer the following online demo for getting more details about the Scrolling feature in Grid.
    Scrolling

    Thanks
    Shinu





  5. satya
    satya avatar
    87 posts
    Member since:
    Apr 2009

    Posted 06 Jul 2009 Link to this post

    Hi Ken,

    Thank you very much for your reponse. It got resolved in IE 7.0, but still problem in IE 6.0 . I hope overflow property will not support in IE 6.0

    Can you please suggest me how can i resolve this in IE 6.0 also?


    Regards,
    Satya.
Back to Top