AutoResponder's Match only once

4 posts, 1 answers
  1. Hideki
    Hideki avatar
    3 posts
    Member since:
    Feb 2014

    Posted 14 Sep 2015 Link to this post

    For "AutoResponder" of "Match only once".

    When multiple simultaneous access to the same URL, it seems to match more than once.

    My client has access to the same URL in 12 threads, rarely, I have received the same response.

    Is it a problem of setting?
  2. Hideki
    Hideki avatar
    3 posts
    Member since:
    Feb 2014

    Posted 14 Sep 2015 Link to this post

    Fiddler: 4.6.0.2
    OS: Windows 7(x64)

    I'm sorry in a sentence of machine translation.
  3. Answer
    Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 15 Sep 2015 Link to this post

    Cool bug! 

    Do you have the Enable Latency option enabled by any chance? If so, then yes, a race condition here is pretty likely because while waiting for the latency in returning the first match, one or more additional matches will not see the rule as disabled because the first match hasn't completed.

    I will fix this for the next version such that the likelihood of a race condition is much lower.

    Thanks for reporting this!!

    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Hideki
    Hideki avatar
    3 posts
    Member since:
    Feb 2014

    Posted 15 Sep 2015 in reply to Eric Lawrence Link to this post

    Thank you for your answer.

    I am looking forward to the next version.

    Fiddeler is really a great tool.
Back to Top