AutoCompleteBox nested in MultiPage

5 posts, 0 answers
  1. Morten
    Morten avatar
    267 posts
    Member since:
    Jul 2012

    Posted 09 Dec 2012 Link to this post

    When I nest an AutoCompleteBox on a page other than the first page in a MultiPage the
    text entered in the AutoCompletBox is hidden to the left of the cursor. Please see code
    and screen shots.

    <
    div>
     
        <telerik:RadTabStrip ID="RadTabStrip1" runat="server" MultiPageID="RadMultiPage1">
            <Tabs>
                <telerik:RadTab Text="TAB 1" PageViewID="RadPageView1" />
                <telerik:RadTab Text="TAB 2" PageViewID="RadPageView2" />
            </Tabs>
        </telerik:RadTabStrip>
     
        <telerik:RadMultiPage ID="RadMultiPage1" runat="server" SelectedIndex="0">
             
            <telerik:RadPageView ID="RadPageView1" runat="server">
                <telerik:RadAutoCompleteBox ID="RadAutoCompleteBox1" runat="server" DataSourceID="ds" DataTextField="Name" DataValueField="Id" />
            </telerik:RadPageView>
             
            <telerik:RadPageView ID="RadPageView2" runat="server">
                ABC
            </telerik:RadPageView>
     
        </telerik:RadMultiPage>
     
    </div>
     
    <div>
     
        <telerik:RadTabStrip ID="RadTabStrip2" runat="server" MultiPageID="RadMultiPage2">
            <Tabs>
                <telerik:RadTab Text="TAB 3" PageViewID="RadPageView3" />
                <telerik:RadTab Text="TAB 4" PageViewID="RadPageView4" />
            </Tabs>
        </telerik:RadTabStrip>
     
        <telerik:RadMultiPage ID="RadMultiPage2" runat="server" SelectedIndex="0">
             
            <telerik:RadPageView ID="RadPageView3" runat="server">
                ABC
            </telerik:RadPageView>
     
            <telerik:RadPageView ID="RadPageView4" runat="server">
                <telerik:RadAutoCompleteBox ID="RadAutoCompleteBox2" runat="server" DataSourceID="ds" DataTextField="Name" DataValueField="Id" />
            </telerik:RadPageView>
             
        </telerik:RadMultiPage>
     
        <asp:SqlDataSource ID="ds" runat="server" ConnectionString="<%$ ConnectionStrings:ConnectionStringDB %>" DataSourceMode="DataSet" SelectCommand="SELECT Id, Name FROM Table;" />
     
    </div>
  2. Kalina
    Admin
    Kalina avatar
    918 posts

    Posted 13 Dec 2012 Link to this post

    Hello Morten,

    We have recently fixed a bug that caused similar issue.
    Could you please download our latest internal build and test the RadAutoCompleteBox appearance with it?

    All the best,
    Kalina
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Morten
    Morten avatar
    267 posts
    Member since:
    Jul 2012

    Posted 13 Dec 2012 Link to this post

    sorry the problem persists in dll 2012.3.1205.40

    <div>
     
        <telerik:RadTabStrip ID="RadTabStrip1" runat="server" MultiPageID="RadMultiPage1">
            <Tabs>
                <telerik:RadTab Text="TAB 1" PageViewID="RadPageView1" />
                <telerik:RadTab Text="TAB 2" PageViewID="RadPageView2" />
            </Tabs>
        </telerik:RadTabStrip>
     
        <telerik:RadMultiPage ID="RadMultiPage1" runat="server" SelectedIndex="0">
             
            <telerik:RadPageView ID="RadPageView1" runat="server">
                <telerik:RadAutoCompleteBox ID="RadAutoCompleteBox1" runat="server" DataSourceID="ds" DataTextField="Name" DataValueField="Id" />
            </telerik:RadPageView>
             
            <telerik:RadPageView ID="RadPageView2" runat="server">
                <telerik:RadAutoCompleteBox ID="RadAutoCompleteBox5" runat="server" DataSourceID="ds" DataTextField="Name" DataValueField="Id" />
            </telerik:RadPageView>
     
        </telerik:RadMultiPage>
     
    </div>
  5. Kalina
    Admin
    Kalina avatar
    918 posts

    Posted 14 Dec 2012 Link to this post

    Hello Morten,

    I tested your code with our latest internal build ( version 2012, 3, 1212, 40 ) - and the text typed in RadAutoCompleteBox input looks properly.
    Please take a look at this demonstration video - maybe I miss something?
    I am attaching here the sample page that I have used - can you test it on your side?

    Regards,
    Kalina
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Morten
    Morten avatar
    267 posts
    Member since:
    Jul 2012

    Posted 14 Dec 2012 Link to this post

    2012.3.1212.40 works for me too
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017