Auto-update in VS2010 doesn't download

12 posts, 0 answers
  1. Larry Brindise
    Larry Brindise  avatar
    5 posts
    Member since:
    Jun 2010

    Posted 17 Dec 2010 Link to this post

    I occasionally received the "New JustCode version available!" popup when I open Visual Studio 2010.  Cool.
    I type in my Telerik account Email and Password.  (I have verified that they are correct by logging into my Telerik account separately.)
    I have tried to click the "Download" button with this information entered and not entered.  I have tried it with the "Use my Telerik account" checkbox checked-and-unchecked.  (In other words, I believe I have tried all permutations of data entry)  I have tried this several times over the past few weeks with the same bad result.
    No matter what I do, I received the error (after less than a second):
    "You have entered wrong Telerik credentials or the service is currently not available."
    Wondering whether I should just ignore this whole VS auto-update process and get my downloads from the Telerik web site.
    Thanks,
    Larry
  2. Svetlozar
    Admin
    Svetlozar avatar
    269 posts

    Posted 21 Dec 2010 Link to this post

    Hello Larry Brindise @ The Phil,

    Sorry for the inconvenience. We had a bug in our update process that is fixed in the service pack. You shouldn't have problems downloading future JustCode versions once you have Q3 2010 Service Pack 1 installed. For those of you, who have older versions with this problem, please download the Service Pack from www.telerik.com.

    Greetings,
    Svetlozar Angelov
    the Telerik team
    Browse the videos here>> to help you get started with JustCode
  3. DevCraft banner
  4. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 28 Feb 2011 Link to this post

    I have always had trouble with JustCode downloading new versions.
    I am using 2010.3.1215.0 and I still get wrong credentials error messages.
  5. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 28 Feb 2011 Link to this post

    I just uninstalled JustCode then Reinstalled the same version.
    I re-entered my credentials and the download works fine now.
  6. John
    John avatar
    4 posts
    Member since:
    Mar 2011

    Posted 04 Apr 2011 Link to this post

    I'm experiencing the same error.  However, when checking for updates I am not presented with an option to enter a password; only an email address.  I have changed my Telerik password, but I tried changing it back; but that did not lead to success.  I also tried uninstalling and reinstalling.  I was never prompted for my credentials; I assume they are built into my download.
  7. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 04 Apr 2011 Link to this post

    I am having the same problem again (Same as John).
    Silverlight controls updates itself just fine
    JustCode usually says I have the wrong credentials.
  8. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 05 Apr 2011 Link to this post

    I just tried to download the latest Justcode and had the same problem.
    No where to enter a password.

    So on a hunch I erased my username and poof a password box appeared.
    I re-entered my username and password and all was OK.

    I dont know how the wrong password was entered because it worked before.

    It would be nice to be able to save and close VS from the downloader then automatically start the install of JustCode.
  9. John
    John avatar
    4 posts
    Member since:
    Mar 2011

    Posted 05 Apr 2011 Link to this post

    MiddleTommy, you are a genius.  That worked like a champ!  It never even occured to me that the password box might just be hidden.

    Thanks for the help!
  10. Svetlozar
    Admin
    Svetlozar avatar
    269 posts

    Posted 07 Apr 2011 Link to this post

    Hello John,

    I just want to mention a few things about the problem you might experience with our auto updates process.

    When you send feedback with valid username and password we save an authentication token and next time we use that instead of username/password. We do that, because we don't want to compromise your password security (safe the password on your machine). If you have that token we don't show the password textbox and we try to authenticate you with the token. The problem is that after a while the token expires and becomes invalid for the service that downloads the file. The solution for that is already mentioned by Tommy Tucker (thank you for that).

    What we will do is to improve JustCode to check first if the token is valid before trying to use it (hiding the password textbox).  

    Regards,
    Svetlozar Angelov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  11. Ron
    Ron  avatar
    16 posts
    Member since:
    Aug 2008

    Posted 22 Mar 2012 Link to this post

    Hi,

    This feature never worked for me either! It's 2012 now and I'm using the latest version of Telerik.

    What happened?
    Ron
  12. MiddleTommy
    MiddleTommy avatar
    163 posts
    Member since:
    Nov 2009

    Posted 22 Mar 2012 Link to this post

    I would uninstall justcode restart then install the latest.
  13. Svetlozar
    Admin
    Svetlozar avatar
    269 posts

    Posted 23 Mar 2012 Link to this post

    Hello,

    Which version of JustCode did you have when you tried to download the file? Recently we did some improvements to the telerik login view and one of the improvements was to show you the password textbox in case of wrong credentials.

    Regards,
    Svetlozar
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top
DevCraft banner