Expression Blend and Themes support in RadControls for Silverlight
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1. Operating Systems:  Windows Server 2008; Windows Vista; Windows XP
2. .Net Framework 3.5 SP1
3. Silverlight 2.0 SDK
4. Expression Blend 2 SP1
5. Microsoft Visual Studio 2008 SP1 with the Visual Web Developer Features or Microsoft Visual Web Developer 2008 Express with SP1
6. RadControls for Silverlight
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RadControls for Silverlight can be extensively customized using several important techniques. Our controls support extensive design time customization such as editing style and control templates as well as setting visual properties for easily modify the look of RadControls for Silverlight. We also provide you with several high quality built-in themes. Built-in themes can be used in application-wide and instance-specific scope. RadControls for Silverlight allow you to use our theme mechanism to create your own custom themes and apply them similarly as the default ones.  
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This article briefly explains how to create new Silverlight application in Blend and easy integrate RadControls for Silverlight 2 for extensive make over in Blend. There are several techniques that are used to edit a control in Blend. First of all you can change Background, Foreground and literally all visual properties that a control exposes without tackling control templates. In more advanced scenario that requires complete change of a control you can edit a control template and introduce new structure. We will briefly explain how to edit a control template in Blend and make most of our controls to achieve rich and unique experience 
Note that every control template consists of control specific parts that are essential for achieving consistence between code and template. That is why it’s of great importance to check all required parts and their specific naming convention prior to editing a control template..
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Prior to editing a control in Blend you are required to have an existing Silverlight application or create one as follow:
1. Open Microsoft Expression Blend 
2. Click on File > New Project
3. Select Silverlight 2 Application
4. Name your project as shown below, e.g. SilverlightApplication1
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5. Click OK
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In order to use RadControls for Silverlight in Silverlight application, you first need to add a reference to assembly that hosts the control you need. More information about the distribution of controls in assemblies can be found in our Install Guide. To add a reference to an existing application using Blend follows the instructions below:
1. Click Project > Add Reference…
2. Navigate to the location you have installed RadControls for Silverlight.
3. Select the appropriate assembly that hosts controls you need as shown below:
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4. Click Open
Note: Make sure you also have a reference to Telerik.Windows.Controls which is the core assembly you need to use our controls.
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Now that you have referenced assemblies you need, you can open Asset Library part of Expression Blend and drag and drop a control in your Page. For instructions how to achieve this follow these instructions:
1. Open Page.xaml
2. Open Asset Library part of your Expression Blend toolbox. 
3. Navigate to the Custom Controls tab as shown below:
[image: ]

4. Drag and drop a control over Page.xaml in design view.
After correctly performing these steps your xaml view of Page.xaml should look similar to this, depending on the control you have dragged. In this case we used RadSlider.
<UserControl
	xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
	xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
	x:Class="SilverlightApplication1.Page"
	Width="640" Height="480" xmlns:telerik="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls">
	<Grid x:Name="LayoutRoot" Background="White">
		<telerik:RadSlider />
	</Grid>
</UserControl>
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If you want to change the visual appearance of RadControl you can simply customize any brushes or visual properties that are exposed from the controls themselves. To check all appearance and brushes following these instructions:
1. In Expression Blend navigate to the Objects and Timeline explorer.
2. Select the control you want to visually change.
3. Navigate to the Properties explorer.
4. In order to change brushes part of the control expand Brushes category.
5. In order to change other parts affecting the overall appearance expand Appearance category.
6. Brushes and Appearance category part of Properties explorer as shown below:
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1. In Expression Blend navigate to the Objects and Timeline explorer.
2. Select a control.
3. Right click over the control and choose Edit Control Parts (Template) > Edit a Copy… as shown below:
[image: ]
4. Enter style name of your new style copy as shown below:
[image: ]
5. Click OK
Blend automatically creates a copy of the default style. Now you just have to go to the Template opening tag in xaml and start editing the control template. Also note that the controls’ style is now explicitly bound to your new style. You can edit any parts of the control template to comply with your design idea.
Note that while editing the control template you don’t have to remove any parts that are explicitly named, because these parts are required and are used by the code behind logic. In case you delete any of the required parts, you won’t be able to use its functionality. 
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If you do not want to bother yourself by editing the control templates of our controls you can choose to use some of our professionally built-in themes. You have option to choose between changing the theme of a single control and changing the application theme that will affect all controls in the application scope. Here we briefly explain how to set a predefined theme both in xaml and c#.  Currently we support the following themes:
	Summer
	Telerik.Windows.Themes.Summer

	Vista
	Telerik.Windows.Themes.Vista

	 Office Black (default)
	No assembly required



1. Create new Silverlight project or open an existing one.
2. Click the menu item Project > Add Reference…
3. Navigate to the place you’ve installed RadControls for Silverlight.
4. Browse Binaries/Silverlight
5. Select the assembly that references your theme as shown above.
Now you are ready to use the themes either for a single control or all controls in your application scope.
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In order to change the theme of a single control in xaml you have to declare a resource of type Theme and set an appropriate key. To complete this procedure follow the instructions below.
1. Open the user control that hosts your control.
2. Declare one of the RadControls for Silverlight and set the attached proprety StyleManager.Theme value to “Summer. Note that in this example we use the Summer theme.
3.  After executing all steps your code should look similar to this;
<UserControl
    x:Class="SilverlightApplication1.Page"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" 
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:telerik="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls">
    <Grid Background="White" x:Name="LayoutRoot">
        <telerik:RadSlider telerik:StyleManager.Theme=”Summer” />
    </Grid>
</UserControl>
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You can also choose to change the theme of our controls in code behind. To achieve these follow the brief steps described below.
1. Open your user control.
2. Make sure you have explicitly named the target control in xaml.
3. In the constructor of your user control place the following code:
      StyleManager.SetTheme(radSlider1, new SummerTheme());
Note that we have explicitly named an instance of RadSlider in xaml to radSlider1.
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Changing the application theme is much similar to changing the theme of single controls in Silverlight. However, changing the application theme is in much bigger scale as it affects all controls in the scope of your application. You should use the constructor of your application to set the desired theme. Here is a quick glimpse at how to change the application theme:
To change the application theme in code behind you should follow the instructions below:
1. Open your existing application or create new.
2. Open Page.xaml.cs
3. Declare the following code before the InitializeComponent() call depending on the name of your theme as follows:
Telerik.Windows.Controls.StyleManager.ApplicationTheme = new SummerTheme();
4. After properly executing the following steps your App class should look similar to this:
public partial class App : Application
{

      public App()
      {
Telerik.Windows.Controls.StyleManager.ApplicationTheme = new SummerTheme();

            InitializeComponent();
      }
}
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You can open and edit one of the provided theme project which contains all the xaml of the built-in theme assembly you can reference the theme project or the compiled assembly in your project.
Please note that the generic.xaml includes the control templates and resources for all the controls and they are around 20000 lines. It is therefore advisable to first delete the templates and styles for the control that you do not need to modify.
To create your custom theme by modifying a built-in theme:
1. In your application, add a reference to the theme project file.
2. Open the generic.xaml in the theme project  and go to the resources pane in Blend
3.  Locate the resource of the style or template of the control you want to edit and double click it.
4. Change the template, save and build the project.
5. Go to your project file and apply the custom theme. 
Tips: If you need to change just a color for the control, you can search through the generic.xaml resources, find the particular color by name and change it. All colors are separate resources and 
Tips: You can also copy the style of a control to your application and use it locally, instead of relying on the theming mechanism. 
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In order to change the theme of a single control in xaml you have to declare a resource of type Theme and set an appropriate key. To complete this procedure follow the instructions below.
4. Open the user control that hosts your control.
5. Open the Resource tag like this:
    <UserControl.Resources>
    </UserControl.Resources>
6. Declare the following Theme resource similar to this:
<telerik:Theme x:Key="theme"                        Source="/Telerik.Windows.Themes.CustomTheme;component/Themes/generic.xaml"/>
7. Note that in this example we use custom theme, thus you have to change the Source path to the generic file of your new theme assembly.
8. Declare one of the RadControls for Silverlight and set the attached property StyleManager.Theme to use the static resource we just declared. After executing all steps your code should look similar to this;
<UserControl
    x:Class="SilverlightApplication1.Page"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation" 
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:telerik="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls">
    <UserControl.Resources>
<telerik:Theme x:Key="theme"                        Source="/Telerik.Windows.Themes.CustomTheme;component/Themes/generic.xaml"/>

    </UserControl.Resources>

    <Grid Background="White" x:Name="LayoutRoot">
        <telerik:RadSlider telerik:StyleManager.Theme="{StaticResource theme}" />
    </Grid>
</UserControl>
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You can also choose to change the theme of our controls in code behind. To achieve these follow the brief steps described below.
4. Open your user control.
5. Make sure you have explicitly named the target control.
6. In the constructor of your user control place the following code:
      Theme customTheme = new Theme(
            new Uri("/Telerik.Windows.Themes.CustomTheme;component/Themes/generic.xaml",
            UriKind.Relative));

      StyleManager.SetTheme(radSlider1, customTheme);

Note that we have explicitly named an instance of RadSlider in xaml to radSlider1.
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Changing the application theme is much similar to changing the theme of single controls in Silverlight. However, changing the application theme is in much bigger scale as it affects all controls in the scope of your application. You should use the constructor of your application to set the desired theme. Here is a quick glimpse at how to change the application theme:
To change the application theme in code behind you should follow the instructions below:
5. Open your existing application or create new.
6. Open Page.xaml.cs
7. Declare the following code before the InitializeComponent() call depending on the name of your theme as follows:
Telerik.Windows.Controls.StyleManager.ApplicationTheme =
                  new Theme(Uri("/Telerik.Windows.Themes.CustomTheme;component/Themes/generic.xaml",
                              UriKind.Relative));
8. After properly executing the following steps your App class should look similar to this:
public partial class App : Application
{

      public App()
      {
Telerik.Windows.Controls.StyleManager.ApplicationTheme =
                  new Theme(Uri("/Telerik.Windows.Themes.CustomTheme;component/Themes/generic.xaml",
                              UriKind.Relative));

            InitializeComponent();
      }
}
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