Association and Inheritance Tools

3 posts, 0 answers
  1. rasteler
    rasteler avatar
    5 posts
    Member since:
    Jun 2006

    Posted 09 Jun 2013 Link to this post

    Hi,

    I am seasoned developer of ORM type projects and I am testing OpenAccess ORM.
    I can't get the visual designer to apply associations or inheritance on my entities.
    When I drag the association or inheritance tool to the entity diagram a  circle is displayed indicating that the function is not available.
    All other tools work when I drag them on to the entity diagram.

    I have tried to modify  your sample projects and I can't get it to work there either.

    Thank you for your collaboration.

    Richard
  2. rasteler
    rasteler avatar
    5 posts
    Member since:
    Jun 2006

    Posted 10 Jun 2013 Link to this post

    Never mind.. I figured it out....

    I was dragging the tool while leaving the mouse button clicked.... I didn't realize that I had to release the mouse button and then click on the enitities.
  3. DevCraft banner
  4. PetarP
    Admin
    PetarP avatar
    754 posts

    Posted 12 Jun 2013 Link to this post

    Hi rasteler,

     Indeed the association and inheritance tool require you to click on them and then specify which 2 classes should be involved in the link. 
    If you face any further difficulties please do not hesitate to contact us again.

    Regards,
    Petar
    Telerik
    OpenAccess Samples Kit boasts 50+ sample applications providing diverse real-life business solutions. Click to read more and see OpenAccess ORM in action.
Back to Top