asp.net ajax error deleting file 'Telerik.Web.UI.dll' Access is denied

4 posts, 0 answers
  1. Ricardo
    Ricardo avatar
    22 posts
    Member since:
    Aug 2012

    Posted 26 Sep 2012 Link to this post

    I updated from Version:

     2012.1.411
    to
     2012.2 912

    I used the msi file: Telerik.Web.UI_2012_2_912_Dev.msi


    The error is:
    ==============================================================================
    Microsoft Visual Studio
    x
    Error executing custom action Telerik.Web.UI.VSX.Actions.MultiprojectUpdateReferencesAction: Error deleting file 'Telerik.Web.UI.dll'. Unable to delete 'Bin/Telerik.Web.UI.dll'. Access is denied.
    ==============================================================================
    Regards,
  2. Petar
    Admin
    Petar avatar
    219 posts

    Posted 29 Sep 2012 Link to this post

    Hello Rico,

    Did you try deleting Telerik assemblies from the project's bin and then running the Upgrade Wizard again?

    If the problem remains I will be glad to provide further help.

    Regards,
    Petar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Ricardo
    Ricardo avatar
    22 posts
    Member since:
    Aug 2012

    Posted 01 Oct 2012 Link to this post

    No I have no idea was is going wrong.
    The only thing make it work was to reboot the computer each time I try to upgrade a site.
    I'm sure it is an issue on the upgrade wizard.

    I have three sites so I have to restart my PC three times after trying to upgrade using the Telerik wizard.
    What I noticed that the Web.UI was deleted but not the Skins one.

    I'm sure you can reproduce this issue on your side.
  5. Petar
    Admin
    Petar avatar
    219 posts

    Posted 05 Oct 2012 Link to this post

    Hello Rico,

    I am sorry for the late reply.

    I reproduced the issue in our test environment. I have logged a bug in our Public Issue Tracker - http://www.telerik.com/support/pits.aspx#/public/aspnet-ajax/12854. You and all other clients can check its state. We will try to have it fixed and released as soon as possible.

    Should you have any future inquires don't hesitate to contact us again.

    Regards,
    Petar
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top