AjaxSpellChecker in RadEditor not working

8 posts, 0 answers
  1. Rekha
    Rekha avatar
    9 posts
    Member since:
    Jul 2012

    Posted 22 Sep 2012 Link to this post

    Hi

    I am using Telerik2012 Radeditor in my page. I have given the following statement in the editor control.

     <telerik:EditorTool Name="AjaxSpellCheck" ShowIcon="true" Enabled="true" />

    I have added corresponding changes in web.config file also. But once I click the icon on RadEditor, it shows a drop down as 
    "Spell checking in progress..." and two buttons as "Finish Spellchecking" and "Cancel". This two buttons are always disabled. This state remains the same as long as the page exists. Also the spell checker is not indicating any errors in the editor.

    Can anyone please tell me what would be the issue here?

    Any help will be highly appreciated.

    Regards
    Rekha.
  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 25 Sep 2012 Link to this post

    Hello,

    Do you get a JavaScript error and what when the problem happens? Please, provide the whole error information so that we can help you.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Rekha
    Rekha avatar
    9 posts
    Member since:
    Jul 2012

    Posted 25 Sep 2012 Link to this post

    Hello Admin

    I don't get any error in the page. Please see my modification in web.config file for AjaxSpellChecker.

    <httpHandlers>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2012.1.215.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" verb="*" validate="false" />
     <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>
     <add path="Telerik.Web.UI.DialogHandler.axd" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Version=2012.1.215.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />
        </httpHandlers>

     <handlers>
    <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2012.1.215.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />
     <add name="Telerik.Web.UI.WebResource"  path="Telerik.Web.UI.WebResource.axd" verb="*"    type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2012.1.215.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />
     <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler"/>
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler"/>
    </handlers>

    Please see the attached image of my Editor and how it looks after clicking the icon of  AjaxSpellChecker on RadEditor.


    Regards
    Rekha.


  5. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 25 Sep 2012 Link to this post

    Hello,

    Under which browser are you testing? You should enable the JS error notification which is by default disabled in IE - > go to Tools -> Internet Options -> Advanced -> and check Display a notification about every script error.

    Please, also provide a live url to the problematic page.

    Greetings,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Rekha
    Rekha avatar
    9 posts
    Member since:
    Jul 2012

    Posted 25 Sep 2012 Link to this post

    Hello Admin

    Please see the following error details in IE9.

    Webpage error details

    Message: Sys.ArgumentException: Cannot deserialize. The data does not correspond to valid JSON.
    Parameter name: data
    Line: 5
    Char: 86281
    Code: 0
    URI: http://url/ScriptResource.axd?d=i9_DM5dYQy3FAqrulUP0nsDNyQxUpTE0u0zAOgWSLc-jcddQrADalw4DTR-RlbSXpySJgu6Zqw5Jo_EwRKLNZ7mzQoAHQGZd-oKjMujBdDQJdMzU4-84Qq_3KYLfjBeRWRsIXSXDGOsFMOOphkWyyXhcJRg1&t=ffffffffb868b5f4

    Regards
    Rekha.
  7. Adam
    Adam avatar
    13 posts
    Member since:
    Nov 2011

    Posted 25 Sep 2012 Link to this post

    I had the same problem when using RadEditor for sharepoint, with Polish translation in place. Try to check if in case of non default languages - there is the right dictionary in the correct format, in the right place. In my case it was:
    _wpresources/RadEditorSharePoint/6.4.0.0__1f131a624888eeed\Resources/App_Data/RadSpell

    For standard web app you should copy your dictionaries to App_Data  directory in your project or set proper DictionaryPath property.

  8. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 25 Sep 2012 Link to this post

    Hello,

    You can also see in this forum post how another user has fixed this error: JSON Error with Spell Control.

    Greetings,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  9. Sunil P
    Sunil P avatar
    7 posts
    Member since:
    Nov 2009

    Posted 26 Jun 2014 Link to this post

    I was also facing same JSON issue on Spell check. But this issue was found only on pages which are under a sub-folder, pages under home directory were working fine.

    I tried below code and its worked for me.


    <telerik:RadEditor id="radE1" runat="server" DialogHandlerUrl = "~/Telerik.Web.UI.DialogHandler.axd">
                <SpellCheckSettings DictionaryPath="~/App_Data/RadSpell"   AjaxUrl="~/Telerik.Web.UI.SpellCheckHandler.axd" />
            </telerik:RadEditor>

    For me removing "DictionaryPath" also working...

    --Sunil S P
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017