Adding FileExplorer to page breaks CSS

3 posts, 0 answers
  1. Shaw
    Shaw avatar
    13 posts
    Member since:
    Sep 2011

    Posted 22 Jul 2013 Link to this post


    I have a site using Telerik controls and the pages all look fine.

    I added a new page and it looked fine. However, I just added the FileExplorer and now my menu style has changed. If I remove the FileExplorer control the menu goes back to normal. 

    Any ideas? I have attached a before/after screenshot. 

    Update: the issue goes away if I stop using a custom skin on my menu and instead use a built in skin. I have switched to using a built in skin (Silk) for now.

    Thank you
  2. Vessy
    Vessy avatar
    1350 posts

    Posted 25 Jul 2013 Link to this post

    Hello Shaw,

    We are not aware of such a behavior and, unfortunately, the provided information was not enough for me  to determine what is causing it. Could you provide more detailed information regarding the specific scenario?
    • Which version of RadControls for ASP.NET AJAX and .NET Framework are used in the application?
    • Are you able to reproduce this behavior under different browsers?
    • Are there any custom CSS styles registered on the page? Could you try to remove them and see if the problem still occurs?
    • Are there any JavaScript errors risen when the problem occurs?
    • The paths of the FileExplorer in the provided screenshots seems not to be configured - could you set them and see if the problem still occurs?

    If none of the above helps in solving the case - could you try to isolate the issue into a sample fully runnable project  and send it for a further investigation? More information on how this could be done is available here: Isolating a problem in a sample project

    Looking forward to hearing from you,
    Veselina Raykova
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. DevCraft R3 2016 release webinar banner
  4. Shaw
    Shaw avatar
    13 posts
    Member since:
    Sep 2011

    Posted 27 Jul 2013 Link to this post

    Hi Veselina,

    You are correct - the custom CSS is the issue. The styles are okay when only Telerik skins are used but the File Explorer seems to conflict with custom skins.

    We are using the most recent version of RadControls. There are no JavaScript errors. I did configure the paths and that did not fix the issue.

    We have now fixed the issue by removing our custom skins. It is not a high priority for us. 

Back to Top