Add OpenAccess Service Wizard Error

2 posts, 1 answers
  1. Richard Weeks
    Richard Weeks avatar
    95 posts
    Member since:
    Oct 2009

    Posted 26 Jun 2012 Link to this post

    At the "Select Service Type" step of the Add OpenAccess Service Wizard, I select "WCF Data Service - OData v3" and receive the following error message:

    "You have not configured ADO.NET Data Services to use V2 of the OData protocol.
    You can do that by setting the dscodegen_version environment variable to 2.0 and dscodegen_usedsc to 1

    I understand this message is known.

    However, I am targetting OData v3, so why would I care about this?

    I am using VS 2010 SP1 with WCF Data Services 5.0 installed and I would expect this installation to fully prepare my environment.

    Is this message inappropriate and if so, when will it be addressed?

    If it is appropriate, does the workaround apply for v3?

    I should add this was meant to be my first experience of the Q2 2012 OpenAccess ORM and it's not exactly making me feel warm.

  2. Answer
    Serge avatar
    375 posts

    Posted 27 Jun 2012 Link to this post

    Hello Richard,

     As it turns out this is an unnecessary check, that we have already removed and will be part of the service pack that we are preparing. As a workaround you can just add the enviroment variables and this warning will cease to pop up. 

    I would like to apologize for inconvenience caused by this and to thank you for letting us know about this problem. Do find your Telerik points updated.

    All the best,
    the Telerik team
    Follow @OpenAccessORM Twitter channel to be the first one to get the latest updates on new releases, tips and tricks and sneak peeks at our product labs!
  3. DevCraft banner
Back to Top