Activate RadEditor feature error

2 posts, 0 answers
  1. lee
    lee avatar
    20 posts
    Member since:
    Aug 2007

    Posted 18 Mar 2008 Link to this post


    I found an error returned with the event from server when I was creating a Personal Site. The error ids were 5187 and 6151. We activated the RadEditor feature when the personal site is created. In our test case, if we create a few sites at the same time, it will be sucessful. But if we create many sites at the same time (12 sites/min), it always return an error.

    The error message :

    Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.IO.IOException: The process cannot access the file 'C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\CONTROLTEMPLATES\RadEditorList.ascx' because it is being used by another process.

    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

    at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite)

    at Telerik.SharePoint.RadEditorFeature.RadFeatureReceiver.FeatureActivated(SPFeatureReceiverProperties properties)

    at Microsoft.SharePoint.SPFeature.DoActivationCallout(Boolean fActivate, Boolean fForce)

    at Microsoft.SharePoint.SPFeature.Activate(SPSite siteParent, SPWeb webParent, SPFeaturePropertyCollection props, Boolean fForce)

    Best Regards,

  2. George
    George avatar
    859 posts

    Posted 19 Mar 2008 Link to this post

    Hi lee,

    Thank you for the detailed information.

    I logged this problem in our bug tracking system and we will do our best to fix it for the next release.

    Your points were updated.

    Best regards,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

Back to Top