A maximized RibbonForm on Win7 and XP

15 posts, 0 answers
  1. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 09 Feb 2011 Link to this post

    My Ribbon form is slightly cropped on my Windows 7 dev machine. But on a windows XP machine, the borders are beautifully visible. See attached files.
  2. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 10 Feb 2011 Link to this post

    Any help please.
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 10 Feb 2011 Link to this post

    Hi Hassan,

    I've got both a Win7 and XP machine here. I'll try it out with just a RadRibbonForm. What theme is that you're using?
    Richard
  5. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 10 Feb 2011 Link to this post

    Main theme is Desert. So far, all themes are behaving the same way.
  6. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 10 Feb 2011 Link to this post

    Hi Hassan,

    Attached are 2 images. One from my Win7 64 bit laptop, and the other from my XP Desktop. To be honest, I can't really see much difference.
    Richard
  7. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 10 Feb 2011 Link to this post

    I have this in my form's constructor:

    public AppMDIRibbon() {
      InitializeComponent();
      AllowTransparency = true;
      AllowAero = true;
    }

    I have AllowAero as true as I think it looks more beautiful. having AllowAero as false will produce the correct result but very ugly.
  8. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 10 Feb 2011 Link to this post

    Here you are, the same settings as you have. To be honest, I still can't notice a particular issue.
    Let me know if you spot something in it though
    Richard
  9. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 10 Feb 2011 Link to this post

    Sorry, I meant AllowAero = false is what I require...

    So,

    public AppMDIRibbon() {
      InitializeComponent();
      AllowTransparency = true;
      AllowAero = false;
    }
  10. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 10 Feb 2011 Link to this post

    Hi Hassan,

    See attached. Still not seeing much difference.
    Richard
  11. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 10 Feb 2011 Link to this post

    Well, the cut-offs are clearly seen as the round application button and the whle Left and right borders are gone. see my original winxp screen.
  12. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 10 Feb 2011 Link to this post

    Just a thought, but your AutoScaleMode property on the form is probably set to Font. Could you try setting it to none and see if that makes any difference.
    otherwise, I admit I am unable to think of anything else on this one at the moment.
    Richard
  13. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 11 Feb 2011 Link to this post

    Sadly, nothing happened. It's not an issue for me but it means a lot to the designers and the QA guys. They make my life very difficult ans as the Telerik demos work properly, they blame me for this. I can set AllowAero = true fom now and loose the cool Form buttons (Minimize, Maximize, and Close) but you Telerik guys gotta check this one out.
  14. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 11 Feb 2011 Link to this post

    Sorry I couldn't help further on this one Hassan. If I can think of anyhting else, I'll be sure to let you know
    Richard
  15. DoomerDGR8
    DoomerDGR8 avatar
    133 posts
    Member since:
    Aug 2010

    Posted 11 Feb 2011 Link to this post

    Okay. No Problem. You helped me out a lot on different things. This one is weird. I'll wait.
  16. Ivan Petrov
    Admin
    Ivan Petrov avatar
    701 posts

    Posted 11 Feb 2011 Link to this post

    Hello Hassan,

    I cannot reproduce the behavior you have described, but what you can do is increase the margin of the main panel hosting the groups of the RadRibbonBar which will allow you to see more of the white background. I have attached a screen shot to ease your way to the margin property you need to set.

    I hope this will help you. If you need further assistance I would be happy to provide it.

    Greetings,
    Ivan Petrov
    the Telerik team
    Q3’10 SP1 of RadControls for WinForms is available for download; also available is the Q1'11 Roadmap for Telerik Windows Forms controls.
Back to Top
UI for WinForms is Visual Studio 2017 Ready