a lot of performance issues and bugs

4 posts, 0 answers
  1. Maor
    Maor avatar
    50 posts
    Member since:
    Dec 2012

    Posted 05 Feb 2014 Link to this post

    hi guys.
    i want to report about a lot of major bugs i found in appbuilder since the last change from icenium to app builder. since the change the ide crashes all time time. in task manager i can see high consuming of memory for nothing. also the work with the cloud is worst then before because each create or open project task take a lot of time.
    i use appbuilder graphite.
    hope that next build will be less buggy.
    regards maor.
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 07 Feb 2014 Link to this post

    Hello Maor,

    Thank you for voicing your problems and concerns. It has been two weeks now since the new Telerik Platform release and we're stabilizing the environment and polishing small bugs as we go. With that said, we are working on improving the performance to at least the previous levels, so expected development on that matter.

    As for the AppBuilder Windows Client crashing - you are the first person to report such problems. What is the OS you're running it on and is it a physical or virtual machine?

    You can try to wipe clean the Telerik AppBuilder installation:
    1. Close all AppBuilder instances. Open the Task Manager and make sure that there are no running processes with the name Icenium.Graphite.exe. If there is - kill it.
    2. Uninstall Telerik AppBuilder.
    3. Delete all contents in the %localappdata%\Temp\IceDeviceSimulator folder.
    4. Delete all contents in the  %localappdata%\Telerik\BlackDragon\ folder.
    5. Delete all contents in the  %localappdata%\Apps\2.0 folder.
    6. Re-install Telerik AppBuilder.

    If the problem persists, in order to help you further, we would need the following information:
    • Session logs from FiddlerCap (with the Decrypt HTTPS Traffic option enabled). Start it prior
      Telerik AppBuilder and save the HTTP requests to disk. Zip the sessions and upload it to this ticket.
    • Windows event logs: are there any Telerik AppBuilder related errors once the problem occurs? You can save the relevant event log entries, zip and upload those as well.

    Regards,
    Steve
    Telerik
    Icenium is now Telerik AppBuilder, and is part of the Telerik Platform. For more information on the new name, and to learn more about the Platform, register for the free online keynote and webinar on Wednesday, February 12, 2014 at 11:00 a.m. ET (8:00 a.m. PT)
  3. Maor
    Maor avatar
    50 posts
    Member since:
    Dec 2012

    Posted 11 Feb 2014 in reply to Steve Link to this post

    hi Steve.
    i try to uninstall and install appbuilder' following the steps you have suggest and currently is less buggy.
    so,thanks for the help.
    regards maor.
    p.s: i posted thread in the past about loading animation issues in app builder and since i found this (https://github.com/Initsogar/cordova-activityindicator) cordova plugin which is native loader and it work great. very recommended.
  4. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 13 Feb 2014 Link to this post

    Hello Maor,

    I'm glad that a clean reinstall has resolved your performance issues. About the "loading animation", as per my understanding of the problem from your explanations in the ticket, we were talking about the splashscreen. The plugin you have found is not a replacement for splashscreen, which is a must in Apple App Store and recommended for Google Play store.

    Regards,
    Steve
    Telerik
    Icenium is now Telerik AppBuilder, and is part of the Telerik Platform. For more information on the new name, and to learn more about the Platform, register for the free online keynote and webinar on Wednesday, February 12, 2014 at 11:00 a.m. ET (8:00 a.m. PT)
Back to Top