unrecognized tag prefix or device filter 'telerik'.

8 posts, 1 answers
  1. Jaymie
    Jaymie avatar
    57 posts
    Member since:
    Jan 2009

    Posted 20 Oct 2009 Link to this post

    I realise that there are few topics concerning this issue, but mine seems to be different.

    Here is some information.
    I recently uninstalled all previous versions of RadControls for ASP.Net because I was getting conflicts between different versions and having some issues when trying to modify the site from my home machine. So, once I uninstalled everything, I installed the latest build of the rad controls hoping that that would fix any issues I was having.
    My home machine works fine, but my work machine will not work. The rad controls are displayed on a page but with no styling and they do not actually work, but no errors are thrown when building the site.
    The only thing is the unrecognized tag prefix green underline.

    I have read that putting the Telerik.Charting.dll into the bin folder fixes this issue, but the only version of this DLL I have is from a cached version which resides here:

    C:\Program Files\Telerik\Telerik Trainer\CachedAssemblies\RadControls for ASP.NET AJAX\Q1 2008\Bin

    Using this dll causes my website to break. A 'ASP.NET Ajax client-side framework failed to load.' error is thrown.

    There is no other version to this dll anywhere. Is there something I am missing or is there a new solution to this problem?



  2. Answer
    Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 20 Oct 2009 Link to this post

    Hi Jaymie,

    This error could be generated when you have not granted permissions for the Telerik.Web.UI.WebResource.axd http handler to all users (through the web.config file). Review the relevant section of this help topic for more details.

    Kind regards,
    Pavlina
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Martin
    Martin avatar
    199 posts
    Member since:
    Oct 2005

    Posted 09 Dec 2010 Link to this post

    (I know it's quite an old thread, but anyway, here's another possible solution for the problem)

    In my case, the problem was caused by an old version of Telerik.Web.Design.dll in the bin folder of my web app. Once I deleted this dll the problem went away.

    I'm only referencing Telerik.Web.UI.dll from my web app (via a .refresh file), but somehow/somewhen the old version of Telerik.Web.Design.dll was also added to the bin folder.

    Hope this helps.

  5. hkdave95
    hkdave95 avatar
    245 posts
    Member since:
    Nov 2006

    Posted 24 Dec 2010 Link to this post

    Hi

    Just to say that Martin's solution solved my problem.

    David
  6. Prateek
    Prateek avatar
    13 posts
    Member since:
    Feb 2014

    Posted 03 Apr 2014 Link to this post

    I have opened two different projects on different windows... problem is one is working correctly and another one is not working..... the problem is still same. So is there any issue of web.config or any thing else.
  7. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 07 Apr 2014 Link to this post

    Hi Prateek,

    You can try replacing your web config file with the one I have attached and see if you will still receive the unrecognized tag prefix error.

    Regards,
    Pavlina
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. Prateek
    Prateek avatar
    13 posts
    Member since:
    Feb 2014

    Posted 08 Apr 2014 in reply to Pavlina Link to this post

    Hi Pavlina,

    I have Replaced my web.config to yours sample web.config file. but the problem is still same.
  9. Pavlina
    Admin
    Pavlina avatar
    6084 posts

    Posted 09 Apr 2014 Link to this post

    Hello Prateek,

    At this point I would recommend you to isolate the problem in a simple runnable project and send it to us via support ticket. Otherwise it would be hard to determine the cause of the issue you are facing.

    Regards,
    Pavlina
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017