2013R1 Authenication & redirect issue

6 posts, 0 answers
  1. Thomas
    Thomas avatar
    1 posts
    Member since:
    Dec 2012

    Posted 20 Jun 2013 Link to this post

    I have a ticket submitted for this but I thought I would try the forums as well.
    -------------
    In our previous installation 2012 R6, we setup an external redirect (through our DMZ) for our remote workers (https://teampulse.doelegal.com). This friendly URL redirected to our internal server (http://devteamserver:9898).

    After installing 2013 R1, the internal direct URL still works (http://devteamserver:9898), but the friendly URL is now broken. Instead of getting the login page, users get this:
    -------------
    Unable to connect
       Firefox can't establish a connection to the server at teampulse.doelegal.com:9898.
      The site could be temporarily unavailable or too busy. Try again in a few moments.
      If you are unable to load any pages, check your computer's network connection.
      If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.
    ------------

    When this error displays, the URL in the address bar shows:
    http://teampulse.doelegal.com:9898/Authentication/Restrict?ReturnUrl=https%3A%2F%2Fteampulse.doelegal.com%2F

    So, it appears the browser is being appropriately redirected but there is some authentication issue, which I have not been able to resolve.  Also, in our previous version (2012R6), the URL didn't have the port number. In other words, a working URL looked something like this: https://teampulse.doelegal.com/#/Project/1/Stories

    Any help is appreciated!
  2. Diana
    Admin
    Diana avatar
    24 posts

    Posted 27 Jun 2013 Link to this post

    Hi,

     In cases when url redirecting is used we have a kb article and a custom TeamPulse Uri Changer application that should be used to update the default TeamPulse configuration. When using the application you should check Use Proxy option, fill in the external url in TeamPulse url textbox and the internal url in the Rewrite Url textbox. 

    If the information was not helpful or you still have issues, we will figure out them via the support ticket.

    Regards,
    Diana
    Telerik
  3. Keith Heilveil
    Keith Heilveil avatar
    29 posts
    Member since:
    May 2005

    Posted 01 Jul 2013 Link to this post

    Thomas,

    We had the same issue and had to revert back to the prior version.  Did the changes that the Uri Changer application made to the config files solve the issue?


    Regards,
    Keith
  4. Diana
    Admin
    Diana avatar
    24 posts

    Posted 08 Jul 2013 Link to this post

    Hi Keith,

    We have recommended uri changer application to several other clients and so far this resolved their issues. You could try it and send us a support ticket if you still encounter any problems.
     
    Regards,
    Diana
    Telerik
  5. Keith Heilveil
    Keith Heilveil avatar
    29 posts
    Member since:
    May 2005

    Posted 09 Jul 2013 Link to this post

    Hi Diana,

    We used the uri changer and we were successful.

    Thanks,
    Keith
  6. Diana
    Admin
    Diana avatar
    24 posts

    Posted 10 Jul 2013 Link to this post

    Hi Keith,

     I am glad to hear that everything worked fine.

    Regards,
    Diana
    Telerik
Back to Top