Language

2 posts, 0 answers
  1. Falk
    Falk avatar
    30 posts
    Member since:
    Mar 2008

    Posted 13 Jun 2008 Link to this post

    Hi,

    I wanted to set the Language to german and I also wanted to hide the preview button in version 5.0.1. Therefor I added to the ConfigFile.xml and the ListConfigFile the following statements.

    <

    property name="ShowPreviewMode">False</property> <property name="Language">de-DE</property>

    This had no effects! Am I doing something wrong?

    Another point is copy and paste from a different source: As you can see in this post. I copied the sourcecode and the Editor is adding some styletags, that do formatting I have not made. In this exampel the break after the "<" sign.

    Thanks for helping

    Falk

  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 17 Jun 2008 Link to this post

    Hello Falk,

    To fix the language problem, try copying all the files from the \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\5.0.1.0__1f131a624888eeed\Resources\App_GlobalResources\ folder to the SharePoint web application's App_GlobalResources folder (e.g. \Inetpub\wwwroot\wss\VirtualDirectories\80\App_GlobalResources\).

    The preview mode should be set like this:
      <property name="EditModes">Design,Html</property>

    However, when I tried to set this in the configuration file, I got an error. It seems there is a problem with setting the EditModes property from the config file. I have logged this and I expect that it will be fixed in the next editor release.

    We are aware of the copy/paste problem from Visual Studio. The problem is that when you paste from VS, it automatically converts the clipboard content to HTML (to preserve the coloring/fonts) and this resulting HTML contains some overlapping tags. When these overlapping tags parsed, the editor automatically changes them so they are semantically correct. Unfortunately, this changes the layout of the pasted content (new lines are added). For now we have not been able to find a workaround for this problem. You will need to either use the "Paste as Plain text" editor tool to insert plain text or the "Format Code Block" dialog to paste the text and keep the coloring/format.


    Regards,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

Back to Top