0.3 not running on my iOS 8.1

10 posts, 0 answers
  1. Volker
    Volker avatar
    17 posts
    Member since:
    Feb 2007

    Posted 03 Nov 2014 Link to this post

    Hi,

    I have build a completely new 0.3 app with Appbuilder
    The NativeScript iOS app is immediately closing after deploying code with RedLaser. I've tried reinstalling the NativeScript app a few times and restarted my iPhone 5 with no success.

    I've got no errors with the same code (from the "Tap"-template) on Samsung Note II Android at the moment.

    Best Regards,
    Volker
  2. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 03 Nov 2014 in reply to Volker Link to this post

    Thanks Volker! The companion app for iOS is still under pending review from Apple. Hopefully it will be published soon and iOS8.1 support in AppBuilder will be available.

    You can still build the app using AppBuilder if you have an ad-hoc provisioning profile. Just choose the "App package" option in the build configuration screens and you should be able to download the generated .ipa file. Then simply deploy to the device.

    Sorry for the inconvenience, I will let you know when the companion iOS app is being published in the AppStore.

    Greetings,
    Valio Stoychev
    Telerik team
  3. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 20 Nov 2014 Link to this post

    Hey Volker,

    this issue is fixed now with our 0.4 release. You can give it a try, but please update the companion app from the AppStore before that :)

    BTW: We are almost finishing with the branding, logo, etc. so I will sent them once they are available.

    Greetings,
    Valio

  4. Volker
    Volker avatar
    17 posts
    Member since:
    Feb 2007

    Posted 21 Nov 2014 in reply to Valio Link to this post

    Hi Valio,

    I'm getting Errors.
    Please see attached screenshots.

    Thank you for the good News about the logos!
    Greetings,
    Volker
  5. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 21 Nov 2014 in reply to Volker Link to this post

    Hey Volker,

    do you get the same errors when trying to build on http://platform.telerik.com? Have you updated the VisualStudio extensions for NativeScript after the 0.4 release?

    Thanks!
  6. Volker
    Volker avatar
    17 posts
    Member since:
    Feb 2007

    Posted 21 Nov 2014 in reply to Valio Link to this post

    Hi Valio,

    Yes updating VS was my first step. See attached version-info and update-info.
    On the platform I don't see any NativeScript Project possibilities (attached also).

    Greetings
    Volker
  7. Valio
    Valio avatar
    102 posts
    Member since:
    Jun 2006

    Posted 22 Nov 2014 in reply to Volker Link to this post

    Volker, there was a problem with your account. I fixed it and it should be OK now. Please give it a try.

    Have you made any changes to your account recently? Any new purchases, anything? I wonder how this happened, so please let me know if you have done something that I can start from there.

    Thanks!
  8. Volker
    Volker avatar
    17 posts
    Member since:
    Feb 2007

    Posted 22 Nov 2014 in reply to Valio Link to this post

    Hi Valio,

    AppBuilder lets me create all types of projects and create QR-codes for Android now. Tomorrow I'll try iOS. 

    Your Github-code is a great inspiration and I've got it to build and deploy with AppBuilder, also. I've zipped your Github Tasks code and then added it to a blank solution in AppBuilder so that the files were overwritten.

    In VS still no success.

    Regarding my account: I have two accounts with Telerik. One is years old and bound to a developer suite I bought then. The new account is bound to the platform and NativeScript. Maybe you can merge both to one account to avoid further problems.

    Greetings
    Volker 
  9. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 27 Nov 2014 Link to this post

    Hi Volker,

    We are glad to hear that the issue is resolved for Android. Please, let us know if the same goes for iOS.

    Further, we will require some more time in order to address the other matters you have came across. Thank you for the understanding in advance. We will get back to you as soon as possible.

    Regards,
    Kaloyan
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  10. Volker
    Volker avatar
    17 posts
    Member since:
    Feb 2007

    Posted 27 Nov 2014 in reply to Kaloyan Link to this post

    Hi Kaloyan,

    Sorry no. Same behavior as before on iOS: App starts and Closes immediately.
    I have the newest NativeScript app and reinstalled iOS a few days before.

    Greetings
    Volker
Back to Top