(Another) Page loads faster with Fiddler enabled

7 posts, 0 answers
  1. Izaak
    Izaak avatar
    5 posts
    Member since:
    Nov 2015

    Posted 28 Nov 2015 Link to this post

    Hello,

     first of all, thanks a lot for this great advantage piece of software :-)

     I am a little bit stucked with my problem, so maybe I've missed something.

    A project, i am currently working on - running "locally" in a VirtualBox, bridged network. (PHP / Yii Framework) When I load a page, there are access times around 550ms - 2,5s. This does not really depends on a keep alive or a new connection. Page generation time is mostly around 200ms.

    Now when I start Fiddler, the first page load after that is around 20-40ms more than page generation time and all next loads as fast as the first - not much more than 300ms. I can wait 2 minutes and load a new page, and I get the same results.

    That is really awesome, but I don't think, I can convince my customers to install Fiddler :-))

    I have read a lot about that problem - the keep alive problem is excluded (I also disabled the options in Fiddler) Firebug marks it as "waiting time" without more info, when Fiddler is unactive.

    Any advices?

    Kind regards!
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 28 Nov 2015 Link to this post

    Hello, Izaak--

    The most likely cause of a problem like this is described in the "Slow Proxy Determination" section of this post. You should check to see what proxy settings the client is configured to use when Fiddler isn't running-- most likely, it should be explicitly configured for "No proxy" to avoid losing any time to proxy determination.

    Short of that, you might try getting a WireShark or NetMon capture of the "slow" scenario; you can email me the .PCAP or .CAP file (via Help > Send Feedback) and I'll have a look to see if there are any clues.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Izaak
    Izaak avatar
    5 posts
    Member since:
    Nov 2015

    Posted 30 Nov 2015 Link to this post

    Hello Eric,

     Thanks for your answer.

    I forgot to say, that I've also read and worked through your complete blogpost without a result. Proxy settings are explicit disabled.
    Also I tried to locate the problem using wireshark on clientside or strace on serverside without finding anything. But I would be very happy, when you take a closer look at it, so I will send you a filtered NetMon .cap.

    The strange thing is, that between request and answer in the capture is only a delay of circa 0.05s (page generation 0.047, firebug measures 2.13s)

     Kind regards,

    Izaak

  4. Izaak
    Izaak avatar
    5 posts
    Member since:
    Nov 2015

    Posted 30 Nov 2015 in reply to Izaak Link to this post

    When looking at netmon till sending the request it seems like (most of) the wait time is on client side _after_ completing the request-response-communication. This is an ajax request, so some may think, this is the time, javascript needs to unzip or parse the answer, but that does not explain, why its faster with fiddler... mmh
  5. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 30 Nov 2015 Link to this post

    Do you see this in all browsers, or just Firefox?

    In Firebug's Network Panel, what does the bar chart for this request look like?

    One possibility is that you have many parallel connections and you're hitting the "Connections-per-server" limit that the browser maintains; that limit could be impacted when a proxy is in play because a different limit (a "connections-per-proxy" limit) is used instead.

    In Firefox, you can examine your network.http.max-persistent-connections-per-server value by navigating to about:config.

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Izaak
    Izaak avatar
    5 posts
    Member since:
    Nov 2015

    Posted 01 Dec 2015 in reply to Eric Lawrence Link to this post

    I've also tested it so far with IE 10 - it's the same. And also in production with "normal" clients having only "normal" network scenario.

    The Firebug's network panel or HttpWatch bar at Internet Explorer shows 98% waiting time - e.g.
    DNS: 0ms
    Connect: 0ms
    Send: 0ms
    Wait: 3.15s
    Receive: 1ms
    Page generation: 0.83s

    Raised max-persistent-connections to 32 (like proxy is) without any change.

     Kind regards,

    Izaak

  7. Izaak
    Izaak avatar
    5 posts
    Member since:
    Nov 2015

    Posted 01 Dec 2015 Link to this post

    Ok I finally found the solution. It was Bitdefenders phishing-filter and the big size of the response. Either it was the loopback proxy ip, or the unnormal port, that BD ignores it with Fiddler running.

    Thanks a lot for your help!

Back to Top