割 character in a listview

6 posts, 1 answers
  1. Chris @ Willows Consulting Ltd.
    Chris @ Willows Consulting Ltd. avatar
    15 posts
    Member since:
    Sep 2013

    Posted 09 Dec 2013 Link to this post

    Hello Guys,

    I have the 割 character for a multiple select. This view is populated by ajax. See screenshot attached.
    It does this only on Apple devices.

    Regards.
  2. Kiril Nikolov
    Admin
    Kiril Nikolov avatar
    2565 posts

    Posted 11 Dec 2013 Link to this post

    Hello Sean,

    This problem is caused by the font icon not being loaded correctly. I guess an arrow should be displayed there instead of the Japanese sign and this is due to missing font file. So please make sure all files are loaded when you deploy your application.

    Regards,
    Kiril Nikolov
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Kendo UI is VS 2017 Ready
  4. Chris @ Willows Consulting Ltd.
    Chris @ Willows Consulting Ltd. avatar
    15 posts
    Member since:
    Sep 2013

    Posted 11 Dec 2013 Link to this post

    Hello Kiril,

    May I have your guidance for the missing fonts?... Again: this is only affecting iOS, not Android. It should be noted that this character should be radios similar to those here:
    http://demos.kendoui.com/mobile/forms/checkboxes.html#radios

    Regards.
  5. Kiril Nikolov
    Admin
    Kiril Nikolov avatar
    2565 posts

    Posted 11 Dec 2013 Link to this post

    Hello Sean,

    The icons used in Kendo UI Mobile are part of the kendoui.ttf and kendoui.woff files that you can find in the  styles/images folder of the package that you have downloaded. If the icon files are not loaded the icons are replaced with default symbols - like the one you see.

    Regards,
    Kiril Nikolov
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  6. Answer
    Chris @ Willows Consulting Ltd.
    Chris @ Willows Consulting Ltd. avatar
    15 posts
    Member since:
    Sep 2013

    Posted 11 Dec 2013 Link to this post

    For some reasons, when I extracted kendoui.mobile.2013.3.1127.commercial.zip, files had those names:
    \styles\images\KendoUI.ttf
    \styles\images\KendoUI.woff
    instead of:
    \styles\images\kendoui.ttf
    \styles\images\kendoui.woff

    I don't know why, it's the second time this happens to me :(.

    Regards.
  7. Kiril Nikolov
    Admin
    Kiril Nikolov avatar
    2565 posts

    Posted 11 Dec 2013 Link to this post

    Hi Sean,

    I have checked again the build that you are mentioning and the files inside are correctly cased. I am glad to hear that you found this issue and your application is now working as expected.

    Regards,
    Kiril Nikolov
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Back to Top
Kendo UI is VS 2017 Ready