Special Character

2 posts, 0 answers
  1. Susan
    Susan avatar
    137 posts
    Member since:
    Jul 2007

    Posted 14 Oct 2008 Link to this post

    I typed text for an email into the editor. I did not copy from word. the text looks fine, the html looks fine, but when the email is sent, a special character is inserted in different places. below is a partial copy of the email:

     
    The 2008 Winter Basketball Season registration is now open! Go to the PYSA

    How do I remove this?

    Thanks,
    Susan
  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 15 Oct 2008 Link to this post

    Hi Susan,

    Having Â's around means that you probably do not save the file with the correct encoding - or, alternatively, you save it in one encoding, but display on a page with a different encoding. Our suggestion is to check and make sure all is saved with the same encoding.

    Please, try the suggestions provided in the following help article:
    Appearance of odd characters after saving RadEditor's content in Database.

    You can save the ascx file with Unicode encoding using Visual Studio -> File -> Save <PageName> As -> Click on the bottom arrow dropdown button next to the Save button -> choose Save with Encoding -> choose Unicode (UTF-8 with signature).

    You have to also set <globalization fileEncoding="UTF-8"/> in your web.config file.

    Here are some links that discuss [file] encoding.

    http://support.microsoft.com/kb/893663
    http://msdn.microsoft.com/en-us/library/39d1w2xf.aspx
    http://weblogs.asp.net/ssadasivuni/archive/2005/01/19/355935.aspx

    Best regards,
    Rumen
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top