Overview

[image]

Telerik Reporting Q2 2012
Overview
Send Feedback

Telerik Reporting is a unified Windows Forms and ASP.NET reporting tool that offers an easy Visual Studio based design-time experience and royalty-free run time redistribution for all of your .NET reporting needs.

New features in Telerik Reporting streamline the creation of production level reporting. Design time features such as the Report Wizard, Data Explorer and Conditional Formatting provide a true RAD report development experience.

Report Wizard

The Report Wizard steps you through building a report, from data binding to layout and styling. Wizard highlights include:

  • Automatically group and sub total on any column.
  • Convert existing Crystal, ActiveReports and XtraReports.
  • Choose from predefined layout formats and styles.

Powerful Data Processing Model

Flexible expressions allow you to group, sort and filter data without writing queries or event handlers. Use built-in functions, aggregates, database fields, report parameters and user defined functions to build your expressions. Expressions can be used directly as output to the report or as criteria for grouping, sorting and filtering report data. Report Parameters allow user input to be used directly in grouping, sorting and filtering expressions.

Fine Grain CSS-Like Styling

Telerik Reporting uses a built-in styling model similar to CSS. The model provides for fine-grained visual customization of all elements of a report directly in the Visual Studio designer. This CSS-like mechanism offers full control over background, colors, borders, images for every item on your report. Styles can be copied between report items directly in the Report Designer for easy, rapid report development.

Conditional Formatting

Conditional Formatting formatting lets you change the report display dynamically based on rules that you define using simple comparisons or by building more complex expressions with the Integrated Expression Builder. Highlighting text based on data values, conditionally displaying images and alternating row appearance are now codeless operations accomplished entirely in the Report Designer. Conditional formatting works together with Telerik Report Styles to achieve complex visual output with minimal effort.

Design-time Support for Visual Studio 2008 or later

Telerik Reporting is closely integrated with Visual Studio, including:

  • Report Designer
  • Preview mode for reports
  • Report Explorer with a hierarchical view of the structure of your report
  • Data Explorer with a view of the data sources of your report
  • Group Explorer that allows you to see the structure of groups, to select them and change the Grouping, Sorting and Filtering
  • Report Wizard guides you through designing, data binding and styling a report
  • Table and CrossTab Wizards that guide you through designing, data binding and styling a Table or CrossTab
  • Expression Builder to help build expressions using data fields, aggregates, user functions and more
  • Report Parameter Collection Editor
  • Style Builder dialog for visually modifying styles and previewing the results
  • Conditional Formatting Rules dialog for building rules and styles
  • HtmlTextBox design editor
  • Format Builder to build and preview string formats
  • Dialogs for editing groups, filters and sorting

Rich Set of Measurement Units

Telerik Reporting supports a variety of measurement units that are used to achieve precise report layout. Measurement units can be used for any reporting element including borders, padding and font size. Available measurement units are Pixel, Point, Pica, Inch, Mm and Cm. Differing measurement units can be used, even for properties of a single report element. For example Height could be expressed in pixels and Width in inches. A default measurement unit allows you to quickly enter dimensions and positions without specifying the unit.

Send comments on this topic to documentation@telerik.com

© 2002-2012 Telerik, All Rights Reserved.


Release History

[image]

Telerik Reporting Q2 2012
Release History
Send Feedback


What's New in This Version

[image]

Telerik Reporting Q2 2012
What's New in This Version
Send Feedback


Installation

[image]

Telerik Reporting Q2 2012
Installation
Send Feedback

This section discusses the installation consideration for Telerik Reporting:

  • System Requirements
  • Trial License Limitations
  • Installing Telerik Reporting
  • Deploying Applications using Telerik Reporting
  • Upgrading to a Newer Version of Telerik Reporting
  • Upgrading Telerik Reporting Trial to Telerik Reporting Developer license
  • Protecting Telerik Reporting binaries when redistributed as part of a packaged product


System Requirements

[image]

Telerik Reporting Q2 2012
System Requirements
Send Feedback


Trial License Limitations

[image]

Telerik Reporting Q2 2012
Trial License Limitations
Send Feedback

Developer Licenses

Developer licenses come with modified DLLs, which work without license keys. If you have a Developer license for one or more of the Telerik products, you only need to ensure that you are using the developer build when downloading the control(s). These builds have the Dev abbreviation in their file names.

If your reports are displaying a copyright message, this means that you are using a trial version of the product. Log in to your Client.net account and download the developer build. To update your project, please take a look at the Upgrading Telerik Reporting Trial to Telerik Reporting Developer license section for step-by-step instructions.

Trial Licenses

The free trial licenses of all Telerik products are fully functional and will work for an unlimited time but with a copyright message displayed on each report page.


Installing Telerik Reporting

[image]

Telerik Reporting Q2 2012
Installing Telerik Reporting
Send Feedback

The MSI files are intended for easy and automatic installation of the product on your computer to a folder named Telerik in your Program Files, automatically creating the necessary virtual folders and projects. Additionally, it installs the help file(s) in the VS.NET IDE and in your local copy of MSDN, if you have such installed.

To install Telerik Reporting on your machine follow the instructions below:

  1. Log into your Telerik account and click on Manage products from the top menu.
  2. In the dropdown that appears choose from your purchased products or trial downloads Telerik Reporting, and click on it. If you have purchased a collection you would need to click on it and the trial downloads page will show all trial downlads directly.
  3. Click on Download Installer and other resources (the Download link next to the suite if you are a trial user). You need to choose Telerik Reporting suite if you have purchased the collection and click its Browse all product files button.
  4. Download the Automatic installation (MSI) file.
  5. Once the download completes, run the Telerik Reporting Q2 2012.msi and follow the instructions.

How to install Telerik Reporting

  1. After executing the msi file you should see the following window prompting the user to click next:
  2. Next you are provided with a customization window giving you ability to choose among several features, which are self explanatory. What you should note here is the Examples feature - it would be marked as deselected if we do not find a local SQL Server instance on your machine or if your SQL Browser service is stopped. Supported SQL Server instances are SQL Server 2005 Standard/Express editions or later. In such case, the Reporting product would be installed without the demo reports, which can also be found online on our demos page.
    If we detect supported SQL Server instance, the Examples feature would be enabled by default and you should proceed with Next button.
    Note

    The Examples use the AdventureWorks database which is installed on your machine unless it already exists. Should you need to recover it, you can download it from codeplex.

  3. If Examples feature is selected in previous step, next step would let you choose your Database Server and the authentication used to connect. The Wizard should detect all running instances and list them in the input field.

Telerik Reporting will be added to the Visual Studio toolbox automatically.

The Wizard will install Telerik Reporting in the following folder unless you specify otherwise: C:\Program Files\Telerik\Reporting Q2 2012. on 32 bit machines

C:\Program Files (x86)\Telerik\Reporting Q2 2012 on 64 bit machines

All Reporting assemblies are available in the product installation Bin folder:

  • Telerik.Reporting.dll
  • Telerik.ReportViewer.WebForms.dll
  • Telerik.ReportViewer.WinForms.dll
  • Telerik.Reporting.Adomd.dll

Assemblies targeting .NET 3.5 framework:

  • Telerik.Reporting.Service.dll
  • Telerik.Reporting.XpsRendering.dll
  • Telerik.ReportViewer.Silverlight.dll
  • Telerik.ReportViewer.Wpf.dll
  • Telerik.Reporting.OpenXmlRendering.dll

To view the Reporting examples, you can launch the Demos by opening Start Menu -> Programs -> Telerik -> Reporting Q2 2012 --> Visual Studio Examples --> C#/VB NET Solutions.


Upgrading to a Newer Version of Telerik Reporting

[image]

Telerik Reporting Q2 2012
Upgrading to a Newer Version of Telerik Reporting
Send Feedback

There are two kinds of Telerik Reporting versions -- major and minor. Major versions such as Q3 2007, Q1 2008, etc. can coexist simultaneously on the same machine. Minor versions are also known as Service Packs. There can be only one Service Pack installed per major version, i.e. if you had v Q1 2008 and a Service Pack is released (let's say Q1 2008 SP1) you will need to un-install version Q1 2008 and then install Q1 2008 SP1.

Upgrading to a Newer Version
  1. Uninstall the old version if you are installing a Service Pack, for example from Q1 2008 to Q1 2008 SP1. Even if you forget to remove the old version, when you start the installer of the Service Pack you will be prompted to do so.
  2. Install the new version of Telerik Reporting.

Auto Upgrade

Since Q2 2008, Telerik Reporting offers automatic upgrade for your report projects by using Telerik Upgrade Wizard. It is introduced as guide for the process of upgrading the projects and files of the current open solution to a newer version of Telerik Reporting. Make sure that before proceeding with the upgrade, you have the necessary access permissions to the solution folder and files. If the solution or some of its projects are under source control, make sure that the correct source control plug-in is active in Visual Studio and no files are exclusively checked-out by another user. Once you open a solution, the Upgrade Wizard would check what version of Telerik Reporting is used and if you have a newer one installed, it would offer to upgrade your application. Visual Studio would automatically popup the Upgrade Wizard on opening a solution and you can also manually start it from the Telerik Reporting Menu.

Manual Upgrade

For all projects that need to use the new version of Telerik Reporting:

Web Site project:

  1. In Solution Explorer, click the "Show All Files" button.
  2. Delete all Telerik Reporting assemblies from the Bin folder.
  3. From the References tab on the Web Site’s Property Pages remove all references to Telerik Reporting assemblies. Remember the names of assemblies that you delete.
  4. Add all needed references to the new version of Telerik Reporting assemblies. They should be the same as the ones that you deleted in the previous step.
  5. Open your web.config file and make sure that you change all versions to the new one in the following instances:
    • <configSections> - this is where you can alter the rendering extensions attributes
    • <httpHandlers> - this is where the ReportViewer registers its handler
    • <assemblies> - the Reporting assemblies that are references in the web site
  6. Open your .aspx/.master pages and change the version of the ReportViewer in the Register directive
  7. Open all report resource files (each .resx file appears under the respective report file) as XML. Locate all occurrences of a Telerik Reporting Assembly and update the version number to the new one. Unlike the version name (Q1 2008) a version number is a more technical identifier such as 2.5.8.414, for example.
  8. Restart Visual Studio.
  9. Rebuild all updated projects.
Class Library/Windows Forms/Web application project
  1. In Solution Explorer, click the "Show All Files" button.
  2. Open the "References" node and locate the references to the old Telerik Reporting assemblies. In case you are installing a Service Pack you will notice that the Telerik Reporting assemblies have an yellow exclamation mark next to them, meaning that they cannot be located. That is because you have uninstalled the version that they belong to and is normal.
  3. Select the old assemblies that you located in Step 3 and hit delete to remove them. Remember the names of assemblies that you delete.
  4. Right-click on the "References" node and select "Add Reference".
  5. Add all needed references to the new version of Telerik Reporting assemblies. They should be the same as the ones that you deleted earlier.
  6. Now they should appear in the "References" node without yellow exclamation marks, meaning that they are valid.
  7. Open your web.config/app.config file and make sure that you change all versions to the new one in the following instances:
    • <configSections> - this is where you can alter the rendering extensions attributes
    • <httpHandlers> - this is where the ReportViewer registers its handler
    • <assemblies> - the Reporting assemblies that are references in the web site
  8. Open your .aspx/.master pages (for web apps only) and change the version of the ReportViewer in the Register directive
  9. Open all report resource files (each .resx file appears under the respective report file) as XML. Locate all occurrences of a Telerik Reporting Assembly and update the version number to the new one. Unlike the version name (Q1 2008) a version number is a more technical identifier such as 2.5.8.414, for example.
  10. Restart Visual Studio.
  11. Rebuild all updated projects.


Upgrading Telerik Reporting Trial to Telerik Reporting Developer license

[image]

Telerik Reporting Q2 2012
Upgrading Telerik Reporting Trial to Telerik Reporting Developer license
Send Feedback

Follow the steps below to upgrade installed TRIAL version of Telerik Reporting with a Developer (production) license.

1. Back-up Your Old Files

We strongly suggest that you back-up your old Telerik Reporting files and folders, especially if you would like to use your old settings.

2. Obtain the Necessary File

  1. Log in your account.
  2. Click Downloads under "Your Products" section.
  3. Locate Telerik Reporting product, and click on it. Since you have purchased the product, make sure you are downloading the proper file - the Developer version has Dev abbreviation in it.

3. Removing the Trial Version

Uninstall the Trial version either from the Start Menu shortcut or from Add/Remove programs dialog.

4. Installing the developer version

  1. Close Visual Studio or any other IDE, which may lock the assemblies.
  2. Install the Dev version of Telerik Reporting.
  3. Rebuild your solution.


Quickstart

[image]

Telerik Reporting Q2 2012
Quickstart
Send Feedback

This section discusses basic steps for creating a report and showing it in a viewer:

  • Creating a Simple Report
  • Extending the Simple Report Design
  • Displaying Reports in the Windows Viewer


Creating a Simple Report

[image]

Telerik Reporting Q2 2012
Creating a Simple Report
Send Feedback

Create the Class Library for the Reports

To create even simple reports you start by creating a class library to contain your report and a web, windows or Silverlight application to display the report.

Caution

It is possible to put the report definition and viewer in the same application but this route is not recommended. See this topic on best practices for more information.

  1. Select File | New | Project from the Visual Studio File menu. Select the Class Library project, give it a name and location. Click the OK button to close the dialog.

    Creating the Class Library

  2. Right-click the project context menu and select Add | New Item | Telerik Report. Enter a name for the report class and click the Add button to close the dialog. In this example we name the report class file "ProductList.cs".

  3. The Telerik Report Wizard will appear automatically to help you select data and design your report quickly. Once you have the basic report layout you can go back to edit the report, add data columns and tweak the format. Click the Next button.

  4. On the Report Choice Page of the Report Wizard, select New Report and click the Next button.

  5. On the Choose Data Source page of the Report Wizard, select Add New Data Source.

  6. The DataSource Wizard is started. Select the SqlDataSource component icon and click the OK button.

  7. On the Choose Your Data Connection page select a connection for the AdventureWorks database from the drop down list. If you do not have it in the dropdown list, click New Connection and create a connection to it. When done click the Next button.

  8. The Save the Connection String step appears, where you can save the connection string in the application configuration file if you want with the name you want. Click Next.

  9. The Configure Data Source Command step will display next.
    • Click the Query Builder button.
    • In the Add Table dialog select "Product", "ProductInventory", "ProductPhoto" and "ProductProductPhoto" from the list of tables. Note: You can hold down the control key and click each of the tables to select them all at one time.
    • Click the Add button to close the dialog.

    • On the Query Builder select the fields shown in the figure below. In the Product table select "Name", "ProductNumber" and "ReorderPoint". In ProductPhoto select the "ThumbNailPhoto" column. In the ProductInventory table select the "Quantity" column.
    • Click the OK button to close the dialog.

    • The Configure Data Source Command step would show the generated statement. Clicking the Next button would lead you to the Preview Data Source Results step, where you can preview the data. Click finish to return to the Choose Data Source page of the Report Wizard. On the next page choose Standard Report Type and click the Next button.

  10. The Design Data Layout page of the Report Wizard allows you to assign database fields to sections of the report. The Report Wizard automatically places and formats the database fields in the appropriate report sections.
    • Select from the Available Fields list on the left side of the page.
    • Select "Name", "ProductNumber", "ReorderPoint" and "Quantity".
    • After selecting each field, click the Detail button to add those columns to the detail listing of the report.
    • Click the Next button.

  11. On the Choose Report Layout page of the Report Wizard unselect the Adjust report items to fit available space checkbox. Click the Next button.

  12. On the Choose Report Style page of the Report Wizard select "Civic" from the Style Sheets list on the left side of the page. Notice the style changes in the Preview portion on the right side of the page.

  13. On the Completing the Wizard page of the Report Wizard you can review the settings for the report and click the Finish button

    The initial report layout appears in the design view in Visual Studio.

    Note

    Notice that the wizard has automatically provided:

    • Data bound fields in the detail section of the report.
    • Styled page and column titles.
    • A page footer with standard date and page number output.

  14. Rebuild the project.
  15. Click the Preview tab of the designer to view your report.

From here you can:

  • Extend the Simple Report Design to include conditional formatting, Shape and PictureBox report items. This topic also introduces in-place editing, copying and pasting styles, using the Data Explorer and Report Explorer.
  • Create a Windows application to display the reports.

To learn more about displaying your report in a viewer see the Displaying Reports in the Windows Viewer Quickstart.


Extending the Simple Report Design

[image]

Telerik Reporting Q2 2012
Extending the Simple Report Design
Send Feedback

This topic will extend the example Creating a Simple Report to show several unique Telerik Reporting features including:

  • In Place Editing.
  • Copying and pasting styles.
  • Conditional formatting.
  • Navigating and sizing report items.
  • Resizing report sections.
  • Adding Text, Shape and PictureBox report items to the report designer.
  • Using the Data Explorer.
  • Using the Report Explorer.

Use the report design created in Creating a Simple Report as a starting point.

  1. Double click the "ProductList" TextBox report item in the report header. This will activate the "in place" editor, allowing you to enter text right in the designer without having to find the appropriate property in the Property Window. Add a space so the TextBox reads "Product List".

  2. Zoom to 150% from the Zoom Combo Box in the lower left corner of the design surface. From the ToolBox window drag a TextBox item to the report header just to the right of the "Quantity" column. While dragging the TextBox, the Snap Lines will aid you in positioning it so it aligns nicely with its neighbours. Double-click the TextBox and enter "Reorder".

  3. Right-click the "Quantity" TextBox and select Copy Style from the context menu. Right-click the "Reorder" field and select Paste Style from the context menu.

  4. In these next steps you define a circle Shape item that reacts to changes in the data so that when inventory falls below 50% of the "reorder point" quantity the circle will be filled in red.

    From the ToolBox window drag a Shape item to the detail section just below the "Reorder" column. In the Properties window set the Size.Width property to ".1" and the Size.Height property to ".1". Right click the Shape item and select Conditional Formatting from the context menu.

  5. The Conditional Formatting Rules dialog will display.
    • Click the New Rule button.
    • The Edit Formatting Rule dialog will display.
    • Click the New button to create a rule. Use the drop down lists to set Expression to Fields.Quantity, Operator to "<" and Value to "<Expression>". When you select "<Expression>" the Edit Expression dialog displays. This dialog allows you to select from predefined data (i.e. constants, database fields, report parameters, etc.) and create an expression with them.
    • Select Fields from the list on the bottom right of the dialog.
    • Double-click "ReorderPoint" from the bottom middle list to add it to the expression.
    • Add to the expression at the top of the dialog so the complete expression reads "= Fields.ReorderPoint * .5". This rule will fire when the quantity of a product falls below half of the ReorderPoint value. Click OK to close the Edit Expression dialog.

    • On the Edit Formatting Rule dialog click the Style button to display the Style Builder dialog.
    • Click Background from the list on the left and select "Red" from the Background Color drop down list.
    • Click OK to close the dialog.Click OK twice more to close the remaining rule dialogs.

  6. Press F6 to build the report.
  7. Click the Preview button to display the report. Scroll through the data and notice that the "Quantity" values that are below 50% of the "Reorder point" are displayed in red.

  8. The last set of steps to building this report design add an image item to the report and format the page footer. These last steps also use the Data Explorer and the Report Explorer.

    From the Telerik Reporting menu select the Data Explorer.

  9. Select the "ThumbNailPhoto" column from the Data Explorer list and drag it to the detail section of the report designer, just to the right of the "Reorder" column. Notice that this step automatically creates a PictureBox report item.
  10. After dropping the ThumbNailPhoto the DetailSection will be automatically resized to accommodate the entire PictureBox item:

  11. The Report Explorer provides a hierarchical view of all the report sections and items in the report design. This allows you to easily locate items that might otherwise be difficult to find in a visually complex report.

    From the Telerik Reporting menu select the Report Explorer.

  12. Click "pageFooterSection1" to select the report page footer.
  13. In the Properties window set the Style.BackgroundColor property to "LightGray".

  14. Rebuild the project.
  15. Click the Preview button to view the report. Scroll through the report pages to find records that have images.


Displaying Reports in the Windows Viewer

[image]

Telerik Reporting Q2 2012
Displaying Reports in the Windows Viewer
Send Feedback
  1. Select File | New | Project from the Visual Studio File menu. Select the Windows Application project, give it a name and location. Click the OK button to close the dialog.

  2. Right-click the project References and select Add Reference from the context menu. Select the reference for the class library containing your report from the list on the Projects tab. Note: If the class library resides in another solution you will need to use the Browse tab and navigate to the assembly containing the report.

  3. From the ToolBox drag a Telerik ReportViewer control to the Windows form.
  4. Rebuild the Windows Forms project.
  5. In the Properties Window for the report viewer, open the ReportSource dialog, select Instance Report Source and select the report we created in the class library.
    Note

    Once an instance report is selected, notice that a component representing the report appears in the tray below Windows form designer. The component allows you to access the properties of the report in your report viewing application, providing access to report parameters, styles and page settings.

  6. Add a call to the RefreshReport() method of the viewer in the form Load event:
    CopyC#
    private void MainForm_Load(object sender, System.EventArgs e)
{
    this.reportViewer1.RefreshReport();
}

    CopyVB.NET
    Private Sub MainForm_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
     Me.reportViewer1.RefreshReport()
End Sub
  7. Copy the connection string which you saved in the application configuration file (app.config) of the report class library, to the configuration file of your windows forms project. By default there is no app.config so you can create a new one from Add -> New Item.
  8. Right-click the Windows report viewing application and select Set as Startup Project from the context menu.
  9. Press F5 to run the report.


Designing Reports

[image]

Telerik Reporting Q2 2012
Designing Reports
See Also Send Feedback

The Telerik Reporting package provides a complete graphical report designer that runs inside of Visual Studio. Using the designer, you can perform all the tasks necessary to construct a report:

  • Report life cycle
  • Understanding report sections
  • Understanding report items
  • Connecting Data to a Report
  • Data Source Components
  • Creating page headers and footers
  • Creating report headers and footers
  • Placing and sizing report items
  • Filtering Data
  • Ordering Data
  • Grouping Data
  • Report Parameters
  • Using Expressions
  • Adding Interactivity to Reports
  • Styling Reports
  • Previewing the report
  • Creating Master-Detail Reports Using SubReports
  • Document Map
  • Report Book
  • Data Items
  • Design Considerations for Report Rendering
  • Expressions
  • Report Globalization

See Also

Other Resources

Dynamic Layout (Dock and Anchor)
Performance Considerations
Page Setup
Dev's Expression reference
Extending Expressions


Report Life Cycle

[image]

Telerik Reporting Q2 2012
Report Life Cycle
Send Feedback

Understanding the report life cycle, what happens and when it happens is crucial to effectively using Telerik Reporting.

  • The diagram shown below describes the sequence of stages from designer to completed document.

  • The section "Report Lifecycle Overview" below provides further detail on the activities that occur at each stage of the report lifecycle.

  • The section "Why Report Lifecycle is Important" explains what report sections may contain - data bound fields, aggregates and global objects.

Report Lifecycle Overview

  1. The report is designed in the Visual Studio Report Designer. The act of designing the report produces a report class that embodies the Report Definition.

  2. The report is processed:

    • Binds the Report Definition with data from the report data source.

    • Performs all grouping, sorting and filtering calculations.

    • Evaluates all Expressions except page header and footer section items.

    • Fires item Binding and Bound events.

    • Produces a Report Instance. Report instances may be stored and rendered at a later time.

  3. The report is rendered:

    • The Report Instance is passed to a specific rendering extension (e.g. MHTML or PDF output formats).

    • The report instance is paged if the output format supports paging.

    • Item expressions are evaluated in the page header and footer sections for every page.

    • The report is rendered to the Output Document.

Why Report Lifecycle is Important

There are many ramifications of the report lifecycle including when you can use bound data fields, aggregates and page information functions.

  • Page Headers and Footers: Item binding expressions cannot use data fields or aggregate functions. Paging is specific to rendering format and must occur during rendering, well after early report processing where data binding occurs. PageNumber and PageCount global objects are available only in this section.

  • Report Headers and Footers: Item binding expressions should use only aggregate functions. If an expression specifies a data field without an aggregate, the First() aggregate function is used by default. The First() function returns the first record of the data source for the specified field.

  • Detail Section: The detail section item binding expressions can contain data bound fields, Expression Functions and Global Objects except PageCount and PageNumber.

  • Grouping: Item binding expressions should only use Aggregate Functions. If an expression specifies a data field without an aggregate, the First() aggregate function is used by default. The First() function returns the first record of the data source for the specified field.


Report Designer User Interface

[image]

Telerik Reporting Q2 2012
Report Designer User Interface
Send Feedback

This section discusses the Telerik Report designer user interface:

  • Report Designer
  • Telerik Reporting Menu
  • Report Explorer
  • Data Explorer
  • Group Explorer
  • Report Wizard
  • Upgrade Wizard
  • DataSource Wizard
  • Table and CrossTab Wizards
  • Context Menu
  • Edit Expression Dialog
  • Conditional Formatting Rules Dialog
  • Format Builder Dialog
  • Edit Filter Dialog
  • Edit Sorting Dialog
  • Edit Grouping Dialog
  • Edit Bindings Dialog
  • Edit Action Dialog
  • ReportParameter Collection Editor
  • Edit Calculated Fields Dialog
  • Style Builder Dialog
  • SqlDataSource Wizard
  • ObjectDataSource Wizard
  • EntityDataSource Wizard
  • OpenAccessDataSource Wizard


Report Designer

[image]

Telerik Reporting Q2 2012
Report Designer
Send Feedback

To start/open the designer, double click on the Report.cs file or right click on it and select "View Designer".

The Telerik Report Designer has the following elements:

  • Telerik Reporting Menu: The menu lets you run the Report Explorer, Data Explorer, Group Explorer Report Wizard and Upgrade Wizard. It is accessible through the Telerik Menu --> Reporting.
  • Report selector button: Located in the upper left hand of the report designer. Clicking this button makes the report active in the Properties window.
  • Rulers: on the top and left side of the designer provide a point of reference to the report layout.
  • Report Sections: The high level report design consists of report sections for the report header, report footer, page header, page footer, detail, group header and group footer. Each section can be resized by dragging the sizing grips at the bottom/right of each section. Most sections except the detail can be deleted by selecting the section and hitting the delete key. To delete a group section, you have to delete the whole group from the Group Explorer
  • Component Tray: shows the DataSource components that are used in this report.
  • Context Menu: This menu will conditionally display contents depending on the area that was right-clicked. In the figure below the menu is invoked in the area next to the report design surface.

  • View Mode Buttons: Use these buttons to switch between Design, Preview and HTML views of the report.

All of the elements below are especially designed to ease you in your Report Designing experience. They toggle various different options that help in aligning, snapping, stretching the report items and make sure they have margins and padding in mind.

  • Zoom Combobox - this enables you to easily specify the zoom percentage in which you see the design surface. You can do that by holding the Ctrl key and use the mouse wheel to zoom as well.
  • Snap Grid: Snapping and the snap grid provide you with a set of horizontal and vertical gridlines that—when you drag an object on the design surface—will snap or pull towards the closest vertical or horizontal gridlines. Objects can also snap to column and row dividers within a grid panel. Here is a workspace showing the snap grid turned on:
    Additionally, snaplines allow you to drag objects on the design surface and have them snap to the margins or alignment (red dashed line) of other objects within the same container element such as a layout panel, column and row dividers in a grid panel, as well as the padding of the container element.
    Show/hide the snap grid by using the button in the lower-left corner of the design surface, click Show snap grid . To hide the snap grid, click the button again to see the off icon.Turn on snapping to gridlines: In the lower-left corner of the design surface, click Turn on snapping to gridlines . To turn off snapping to gridlines, click the button again to see the off icon.Turn on snapping to snaplines: In the lower-left corner of the design surface, click Turn on snapping to snaplines . To turn off snapping to snaplines, click the button again to see the off icon.
    Show/Hide Dimensions: In the lower-left corner of the design surface, click Show Dimensions . To hide the dimensions, click the button again to see the off icon.
    Turn On/Off Pan: In the lower-left corner of the design surface, click Turn On Pan . To hide the "hand" and disable dragging, click the button again to see the off icon.Show/Hide the report MiniMap: In the lower-right corner of the design surface, click Show MiniMap. This element is especially useful when you have zoomed the report and want to focus on a specific element. To hide the map, click on the design surface to have it closed.

  • Change the alignment of an element

    Alignment determines how an element resizes. For example, a left aligned element stretches to the right as the parent layout container gets resized.

    To change the alignment of an element use the Layout toolbar and do one of the following:

    • Select two report items and change their HorizontalAlignment by clicking Left , Center , Right , or Stretch .
    • Select two report items and change their VerticalAlignment by clicking Top , Center , Bottom , or Stretch .

    You can also change alignment by moving an element on the design surface.


Telerik Reporting Menu

[image]

Telerik Reporting Q2 2012
Telerik Reporting Menu
Send Feedback

The Telerik Reporting menu can be accessed whenever an area of the report designer is selected. From here you can call:

  • Report Explorer - allows you to see the structure of the report and to select any item in the report. This menu item is available only when you're in the context of the report designer.
  • Data Explorer - provides an overview of the database fields that are available to your report. This menu item is available only when you're in the context of the report designer.
  • Report Wizard - helps you quickly create the structure of your report. This menu item is available only when you're in the context of the report designer.
  • Upgrade Wizard - guides you through the process of upgrading the projects and files of the current open solution to a newer version of Telerik Reporting. This menu item is always available in the Telerik Reporting Menu.
  • Group Explorer - the Group Explorer is an aid to navigating report/table groups. The Group Explorer allows you to see the structure of the groups, to select them and change the respective Grouping, Sorting and Filtering. This menu item is available only when you're in the context of the report designer.

As seen there are four options. The "Upgrade Wizard" option is always available, while the other three options are available only when you are editing a Telerik Report in the Report Designer.

Caution

If the report designer is opened, but still only the "Upgrade Wizard" is visible, make sure the Report Designer is the active window i.e. it has focus.


Report Explorer

[image]

Telerik Reporting Q2 2012
Report Explorer
Send Feedback

The Report Explorer is an aid to navigating report elements. The Report Explorer allows you to see the structure of the report and to select any item in the report. The Report Explorer can be especially handy for complex reports where components may be nested and where it would be difficult to select an item with the mouse.

In the screenshot below you can see that the report is represented by the root node of the tree. Underneath that you see the styles, report parameters and the sections of the report and for each section/item the report items in the section/item.

The Report Explorer can also be accessed from the context menu View | Report Explorer when right-clicking the area next to the report design surface.


Data Explorer

[image]

Telerik Reporting Q2 2012
Data Explorer
Send Feedback

The Data Explorer provides an overview of the database fields that are available to your report and the calculated fields you have created. It is available whenever you have a report open in design view.

To display the Data Explorer, select Data Explorer from the Telerik Reporting menu.

The Data Explorer window lists the data source columns and calculated fields defined for your report. Drag column names from the Data Explorer to the report design surface to create new data bound report items. The report designer automatically creates appropriate report items for data source columns based on the column data type, e.g. if the column has character data a TextBox report item will be created, if the column has image data then a PictureBox report item will be created.

Note

The Data Explorer would be populated only when there is DataSource set in design time through the report's DataSource property.

The Data Explorer Toolbar contains two buttons - Edit Calculated Fields and Refresh. Clicking on the Edit Calculated Fields button would show the Edit Calculated Fields dialog which allows you to Add or Delete new Calculated Fields. Please see Calculated Fields topic for more information


Group Explorer

[image]

Telerik Reporting Q2 2012
Group Explorer
Send Feedback

This topic provides a brief overview of the Group Explorer window, and its main features.

The Group Explorer is an aid to navigating report/table groups. The Group Explorer allows you to see the structure of the groups, to select them and change the Grouping, Sorting and Filtering. The Group Explorer can be especially handy for complex reports where there might be a lot of groups and it would be difficult to select a group and distinguish group hierarchy.

The Group Explorer allows you to easily apply grouping, sorting and filtering to your report. With this dialog, you don't need to manually invoke the Grouping dialog, Sorting dialog and Filtering dialog and define the group, sort and filter properties. Instead, you can use the Grouping, Sorting and Filter fields to do this with several intuitive mouse clicks.

You can get to the Group Explorer dialog by opening the Telerik menu in Visual Studio IDE (while you edit a report at design time) --> Reporting and choose Group Explorer. It can be moved, sized or docked in the same manner as other IDE windows, and usually has the following look:

The Group Explorer can also be accessed from the context menu View | Group Explorer when right-clicking the area next to the report design surface.

When a table/crosstab item is selected, the Group Explorer dialog changes a bit to show you the Row/Column Groups:

It does not show the Static groups by default, but you can enable them from the "Display Mode" button:

You can also change the Layout of the Groups pane by switching between Horizontal and Vertical mode.


Report Wizard

[image]

Telerik Reporting Q2 2012
Report Wizard
Send Feedback

The Telerik Report Wizard helps you quickly create the structure of your report. Using the wizard you can:

  • Select a data source.
  • Design a query to execute against the data source.
  • Choose the type of report to create.
  • Specify the basic layout of the report.
  • Specify the formatting for the report.

The Report Wizard runs automatically when you add a Telerik Report item to the project, but can also be run using the Telerik Reporting Menu. Each run of the Report Wizard overwrites previous definitions of the report. The Report Wizard consists of the following pages:

Page Image Description
Welcome Page
This page lists the tasks that can be performed with this wizard.
Report Choice Page
From here you can choose to create a new report or convert from an existing report. Select New Report to start from scratch or select Convert from existing Report to select from a list of available converters. Use the Browse button to locate the report to convert.
Choose Data Source

This page lets you use an existing data source from a list of data sources or add new Data Source. If you choose to create new data source, click the Add New Data Source button to start the Data Source Wizard. It will walk you through an additional set of steps and when finished will return you to the Report Wizard so you can continue.

Select Report Type

This page lets you choose the report type. Choose Standard to create a general type of report or Label if you would like to create a special purpose report such as one for printing labels for mailing envelopes.

Design Data Layout

Lets you select data columns from the data source and have them placed in the report heading and the detail sections of the report. You can also choose columns to group data by.

Select from a list located on the left in the dialog titled Available Fields. Use the Report, Group and Detail buttons to add the selected column from the Available Fields to the respective list of Displayed Fields. Use the Remove button to move fields from the Displayed Fields list back to the Available Fields list. Use the up and down arrow buttons to reorder the columns in the report.

Choose Report Layout

Choose from a list of predefined layouts to quickly structure the reports visual representation. See the Description and Preview window to get a rough idea of how the report will be layed out.

Select the Adjust report items to fit available space checkbox to have columns take all the horizontal area available. Unselect this checkbox if you want to add other columns by hand later and need the columns to take less horizontal space.

Check the Generate sub-totals to have subtotals created at group footers. Appropriate functions are used based on the data type of the column, i.e. Sum() for numeric Count() for other types.

Choose Report Style
Select from a predefined list of report styles to give your report a polished look. The preview widow provides a general idea of what a finished report will look like.
Completing the Wizard
This page provides a summary of the choices made in the wizard including the connection string and SQL statement. Click the Finish button to see the completed report or Cancel to ignore all changes.


Upgrade Wizard

[image]

Telerik Reporting Q2 2012
Upgrade Wizard
Send Feedback

The Upgrade Wizard is introduced as guide through the process of upgrading the projects and files of the current open solution to a newer version of Telerik Reporting. Make sure that before proceeding with the upgrade, you have the necessary access permissions to the solution folder and files. If the solution or some of its projects are under source control, make sure that the correct source control plug-in is active in Visual Studio and no files are exclusively checked-out by another user. Once you open a solution, the Upgrade Wizard would check what version of Telerik Reporting is used and if you have a newer one installed, it would offer to upgrade your application. Visual Studio would automatically popup the Upgrade Wizard as shown below:

If you do not want it to popup automatically, simply check the "Do not start this wizard" checkbox at the bottom. If at later stage you decide that you want to upgrade your solution, simply use the Telerik Reporting Menu and select "Upgrade Wizard" from it.

Next step is to specify which project from the solution you want to upgrade and if you have multiple versions of Telerik Reporting installed - select the one you would like to upgrade/downgrade to:

You would be then asked whether you would like to backup your solution before proceeding with the upgrade and specify where it should be backed up. Once you make your choice, you would be presented with confirmation step where you can review the files that are going to be changed during the upgrade. Choosing Next from the wizard would proceed with the upgrade and you'll finish with screen where all successfully upgraded projects/files would be shown with green tick right next to them:

You can also review a detailed log of the upgrade once the solution is loaded into Visual Studio - to cancel this, you have to uncheck the "Show the upgrade log" checkbox at the bottom.

Once your solution is opened in the IDE, it would notify you with "File Modification Detected" prompt that your project (s) have been modified outside of the environment and you should press "Reload" in order to reload the updated project:


Data Source Wizards

[image]

Telerik Reporting Q2 2012
Data Source Wizards
Send Feedback

This section contains information on the available data source wizards:

  • SqlDataSource Wizard
  • ObjectDataSource Wizard
  • OpenAccessDataSource Wizard
  • EntityDataSource Wizard
  • CubeDataSource Wizard


DataSource Wizard

[image]

Telerik Reporting Q2 2012
DataSource Wizard
Send Feedback

The Data Source Wizard allows you to select from one of the available data source components:

  • SqlDataSource - represents an SQL Database to data items
  • ObjectDataSource - represents a business object that provides data to data items
  • EntityDataSource - represents an Entity data model to data items
  • OpenAccessDataSource - represents an Open Access data model to data items
  • CubeDataSource - represents OLAP cube data model to data items

and selecting one of those choices, starts the respective wizard:

  • SqlDataSource Wizard
  • ObjectDataSource Wizard
  • EntityDataSource Wizard
  • OpenAccessDataSource Wizard
  • CubeDataSource Wizard

There are two ways to start the Data Source wizard:

  1. From the DataSource property of a data report item
    • Select the DataSource property of a data report item (Report, Table/Crosstab/List, Chart)
    • Click on the Add New Data Source link.
    • The Data Source Wizard is started

  2. From the Report Wizard
    • Navigate to Choose Data Source page of the Wizard
    • click the Add New Data Source button
    • The Data Source Wizard is started


SqlDataSource Wizard

[image]

Telerik Reporting Q2 2012
SqlDataSource Wizard
Send Feedback

The SQL Data Source Wizard allows you to create a new or edit an existing SqlDataSource component based on a SQL select statement or a database stored procedure. After the wizard appears you have to perform the following steps:

  1. Choose Your Data Connection

    Choose an existing connection from the list of connections or click "New Connection" to create a new connection to your database. The "Connection String" text area displays read-only information about the selected connection string.

  2. Save the Connection String

    Choose "Yes, save the connection with the following name" to store the connection string in the application configuration file under a specific name. Type a name for the connection or use the provided default name if applicable.

    Note

    Saving connection strings in the application configuration file simplifies the process of maintaining your application if the database connection changes. In the event of a change in the database connection you can edit the connection string in the application configuration file as opposed to editing the source code and having to recompile your application.

  3. Configure Data Source Command

    Choose whether you want to base your SqlDataSource on a SQL select statement or a stored procedure:

    • Choosing the "Select Statement" option allows you to enter a SQL query statement directly in the text box below. Alternatively you can click "Query Builder" to invoke the Query Builder dialog which offers a user-friendly interface for building SQL queries.
    • Choosing the "Stored Procedure" option allows you to select the name of an existing database stored procedure from the drop-down list below which is responsible for the data retrieval.

  4. Configure Data Source Parameters

    Specify the parameters for the SQL query or stored procedure. Click "New" to add a new parameter to the SqlDataSource component or "Delete" to remove an existing parameter. Use the arrow buttons to change the order of the parameters when necessary.

    • Specify a valid name for each data source parameter in the "Name" column. You can also choose that name from the list of existing parameter names which are derived directly from the SQL query statement or stored procedure.
    • Choose the appropriate database type for the parameter in the "DbType" column. This type should match exactly the type of the expression in the SQL query statement or the type of the parameter from the stored procedure.
    • Specify a default value for the parameter in the "Value" column or bind it via an expression.

    Note

    You can bind a data source parameter directly to a report parameter. This way you can use the standard report parameter user interface to provide values for your data source parameters. The drop-down list of the "Value" column displays all existing report parameters. You can create a new report parameter by choosing <New Report Parameter> from the list. Alternatively you can invoke the Edit Expression dialog by choosing <Expression> from the list. This allows you to specify an arbitrary expression to evaluate for the parameter value.

  5. Configure Design Time Parameters

    This step allows you to specify a value for each data source parameter that can be used at design time to retrieve the schema of the SqlDataSource component.

    Note

    Specifying design time values for the parameters is necessary because the designer might need to execute the SQL query or stored procedure of the data source in order to populate the schema displayed in the Data Explorer tool window and the Edit Expression dialog. These values do not affect the execution of the SQL query at runtime however.

  6. Preview Data Source Results

    You can preview the result set returned by the SqlDataSource before completing the wizard. Click Execute Query to execute the SQL query or stored procedure and display the retrieved data.

    If the data source has parameters, the wizard displays a popup dialog before each preview, which allows you to enter the parameter values.

    This is the last step of the wizard. After pressing "Finish" the wizard will configure the SqlDataSource component with the specified settings and close.


ObjectDataSource Wizard

[image]

Telerik Reporting Q2 2012
ObjectDataSource Wizard
Send Feedback

After the ObjectDataSource wizard appears you have to perform the following steps:

  1. Select a Business Object.

    In this step you have to specify the business object to use for your data source. The available business objects are organized in two tabs for easier navigation:

    • Available data source types

      This tab lists all available types that can be used with the ObjectDataSource component. That includes all public, non-abstract, non-generic classes and structures from the current project and from all other referenced projects. The types are organized in a hierarchical manner grouped by namespace, as shown in the following screenshot:

      Note

      If the desired type does not appear in the list, make sure the current project is built and all necessary project references are added. Have in mind that Visual Studio is a 32-bit application, so the designer is restricted to x86 mode even on x64 platforms, which prevents the ObjectDataSource Wizard from discovering any types from x64 assemblies. The solution is to use different platform configurations: for "Debug" builds it is best to use "Any CPU", while for "Release" builds you can use "x64" instead.

      Note

      When the "Show data components only" check box is checked, only the types marked with the DataObjectAttribute are listed. This is useful for distinguishing the types appropriate for data binding from the regular ones.

      Note

      The Cars class from the screenshot above is shown in the list of business object types because it is marked with the DataObjectAttribute in this example:

      CopyC#
      [System.ComponentModel.DataObject()]
public class Cars : List<Car>
{
   ....
}
      CopyVB.NET
      <System.ComponentModel.DataObject> _
Public Class Cars
    Inherits List(Of Car)
    ....
End Class

    • Existing data source components

      This tab lists all existing components in the current report that can be used with the ObjectDataSource component. That includes all components from the component tray in the designer that are not data source components themselves.

      Note

      When the "Show data components only" check box is checked, only the components marked with the DataObjectAttribute are listed. This is useful for distinguishing the components appropriate for data binding from the regular ones.

  2. Choose a data member

    In this step you have to specify a member from the chosen business object that is responsible for data retrieval.

    • No data source member – selecting this option specifies that there is no specific member responsible for retrieving data. In this case the chosen business object itself serves as a data source for the report. If you have specified a type in the previous step, the default constructor of the chosen type is used to create a new instance of the business object.

    • Choose a data source member – selecting this option allows you to specify a member of the business object that is responsible for data retrieval. The list of displayed members is contextual and depends on the selection from the previous step:
      • When a business object type is chosen, the list of available members is the following:
        • All public instance constructors
        • All public instance properties
        • All public static (shared in VB.NET) properties
        • All public instance methods
        • All public static (shared in VB.NET) methods
      • When a business object component is chosen, the list of available members is the following:
        • All public instance properties
        • All public instance methods
      • When the "Show data components only" check box is checked, only the methods that are marked with the DataObjectMethodAttribute attribute are listed, and only if the specified type of the data method is DataObjectMethodType.Select.

      Here are some sample Cars class methods:

      CopyC#
      [System.ComponentModel.DataObject]
public class Cars : System.Collections.Generic.List<Car>
{
    [System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)]
    public System.Collections.Generic.List<Car> GetCarsByYear(int year)
    {
        // TODO: Implement your specific business logic here.
        return new System.Collections.Generic.List<Car>();
    }

    [System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)]
    public System.Collections.Generic.List<Car> GetCarsByColor(string color)
    {
        // TODO: Implement your specific business logic here.
        return new System.Collections.Generic.List<Car>();
    }

    [System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)]
    public System.Collections.Generic.List<Car> GetCars(int year, string color)
    {
        // TODO: Implement your specific business logic here.
        return new System.Collections.Generic.List<Car>();
    }
}
      CopyVB.NET
      <System.ComponentModel.DataObject()>
Public Class Cars
    Inherits System.Collections.Generic.List(Of Car)

    <System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)>
    Public Function GetCarsByYear(ByVal year As Integer) As System.Collections.Generic.List(Of Car)
        ' TODO: Implement your specific business logic here.
        Return New System.Collections.Generic.List(Of Car)
    End Function

    <System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)>
    Public Function GetCarsByColor(ByVal color As String) As System.Collections.Generic.List(Of Car)
        ' TODO: Implement your specific business logic here.
        Return New System.Collections.Generic.List(Of Car)
    End Function

    <System.ComponentModel.DataObjectMethod(System.ComponentModel.DataObjectMethodType.Select)>
    Public Function GetCars(ByVal year As Integer, ByVal color As String) As System.Collections.Generic.List(Of Car)
        ' TODO: Implement your specific business logic here.
        Return New System.Collections.Generic.List(Of Car)
    End Function
End Class

      When the "Show data components only" check box from the previous step is not checked, all public members of the Cars business object type are listed, as shown in the screenshot above. When the check box is checked, only the methods with the DataObjectMethodAttribute attribute appear in the list. This is especially useful for filtering only the methods that are appropriate for data binding.

      Note

      If the chosen member does not have any parameters, this is the last step of the wizard. However, if the specified member has parameters, the next step allows you to configure those parameters.

  3. Configure Data Source Parameters:

    Each argument of the selected method corresponds to a data source parameter. This step allows you to specify for each parameter a constant value, an expression, or create a new ReportParameter and the expression will be set automatically to it.

    Note

    The names and types of the defined parameters should match exactly the arguments of the selected method. In case this requirement is not fulfilled the ObjectDataSource component will not be able to resolve or call correctly the method and will raise an exception at runtime.

    This is the last step of the wizard. After pressing the Finish button the wizard will create the ObjectDataSource component with the specified settings and close.


OpenAccessDataSource Wizard

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Wizard
Send Feedback

After the OpenAccessDataSource wizard appears you have to perform the following steps:

  1. Choose your data connection

    In this step you have to specify a data connection for the OpenAccessDataSource component. Choose an existing connection from the list or click "New Connection" to create a new connection to your database. The "Connection String" text area displays a read-only information about the selected connection string.

  2. Save the connection string

    This step appears only if you have specified a new connection string in the previous one. Choose "Yes, save the connection with the following name" to store the connection string in the application configuration file under a specific name. Type a name for the connection or use the provided default name if applicable.

    Note

    Saving the connection string in the application configuration file simplifies the process of maintaining your application if the database connection changes. In the event of a change in the database connection you can edit the connection string in the application configuration file as opposed to editing the source code and having to recompile your application.

  3. Choose an object context

    In this step you have to specify an existing OpenAccessContext that is responsible for accessing your entity data model. The available OpenAccessContext types are organized in a hierarchical manner grouped by namespace, as shown in the following screenshot:

    Note

    If the desired OpenAccessContext type does not appear in the list make sure the current project is built and all necessary project references are added.

  4. Choose an object context member

    In this step you have to specify a member of the chosen OpenAccessContext that is responsible for data retrieval. You can choose either a property that returns the desired entities directly or a method that executes some business logic against the Open Access model to obtain the required data for the report.

    Note

    If the chosen member does not have any parameters, this is the last step of the wizard. However, if the specified member is a method with parameters, the next step allows you to configure those parameters.

  5. Configure data source parameters

    Each argument of the selected method corresponds to a data source parameter. This step allows you to specify for each parameter a constant value, an expression, or create a new ReportParameter and the expression will be set automatically to it.

    Note

    The names and types of the defined parameters should match exactly the arguments of the selected method. In case this requirement is not fulfilled the OpenAccessDataSource component will not be able to resolve or call correctly the method and will raise an exception at runtime.

This is the last step of the wizard. After pressing the Finish button the wizard will configure the OpenAccessDataSource component with the specified settings and close.


EntityDataSource Wizard

[image]

Telerik Reporting Q2 2012
EntityDataSource Wizard
Send Feedback

After the EntityDataSource wizard appears you have to perform the following steps:

  1. Choose your data connection

    In this step you have to specify a data connection for the EntityDataSource component. There are two possible options for specifying the data connection:

    • Choose an existing data connection – selecting this option allows you to specify an existing data connection stored in the configuration file of the current project from the drop-down list.

      Note

      The drop-down list displays only data connections that are stored in the configuration file of the current project. If your entity data model is located in a different project from the report class library, you have to copy the appropriate connection string to the configuration file of the report library to make it appear in the wizard.

      The connection string stored in the configuration file of the report class library is used only during design time. When running the report in production it is necessary to copy that connection string to the corresponding configuration file of your application or web site as well.

    • Specify a new connection string – selecting this option allows you to enter a new connection string directly in the text area below.

      Note

      This option is useful for testing purposes only. Embedding the connection string directly in the reports is not recommended, because it might prove difficult to maintain all your reports later, when that connection string changes. The recommended approach is to store your connection string in the configuration file of the report class library and then choose it by name from the drop-down list.

  2. Save the connection string

    This step appears only if you have specified a new connection string in the previous one. Choose "Yes, save the connection with the following name" to store the connection string in the application configuration file under a specific name. Type a name for the connection or use the provided default name if applicable.

    Note

    Saving the connection string in the application configuration file simplifies the process of maintaining your application if the database connection changes. In the event of a change in the database connection you can edit the connection string in the application configuration file as opposed to editing the source code and having to recompile your application.

  3. Choose an object context

    In this step you have to specify an existing ObjectContext that is responsible for accessing your entity data model. The available ObjectContext types are organized in a hierarchical manner grouped by namespace, as shown in the following screenshot:

    Note

    If the desired ObjectContext type does not appear in the list make sure the current project is built and all necessary project references are added.

  4. Choose an object context member

    In this step you have to specify a member of the chosen ObjectContext that is responsible for data retrieval. You can choose either a property that returns the desired entities directly or a method that executes some business logic against the entity data model to obtain the required data for the report.

    Note

    If the chosen member does not have any parameters, this is the last step of the wizard. However, if the specified member is a method with parameters, the next step allows you to configure those parameters.

  5. Configure data source parameters

    Each argument of the selected method corresponds to a data source parameter. This step allows you to specify for each parameter a constant value, an expression, or create a new ReportParameter and the expression will be set automatically to it.

    Note

    The names and types of the defined parameters should match exactly the arguments of the selected method. In case this requirement is not fulfilled the EntityDataSource component will not be able to resolve or call correctly the method and will raise an exception at runtime.

  6. Configure Design Time Parameters

    This step allows you to specify a value for each data source parameter that can be used at design time to retrieve the schema of the EntityDataSource component.

    Note

    Specifying design time values for the parameters is necessary because the designer might need to execute the methods in order to populate the schema displayed in the Data Explorer tool window and the Edit Expression dialog. These values do not affect the execution of the methods at runtime however.

This is the last step of the wizard. After pressing the Finish button the wizard will configure the EntityDataSource component with the specified settings and close.


CubeDataSource Wizard

[image]

Telerik Reporting Q2 2012
CubeDataSource Wizard
Send Feedback

After the CubeDataSource wizard appears you have to perform the following steps:

  1. Choose your data connection

    In this step you have to specify a data connection for the CubeDataSource component. There are two possible options for specifying the data connection:

    • Choose an existing data connection - selecting this option allows you to specify an existing data connection stored in the configuration file of the current project from the drop-down list.

      Note

      The connection string stored in the configuration file of the report class library is used only during design time. When running the report in production it is necessary to copy that connection string to the corresponding configuration file of your application or web site as well.

    • Specify a new connection string – selecting this option allows you to enter a new connection string directly in the text area below.

      Instead of typing the connection string manually you can click "Build" to open the Connection Properties dialog and configure a new database connection there.

      Enter the name of the database server in the "Server name" field and choose your cube database from the "Database name" list. Click "Test connection" to verify that the connection is valid and the chosen database is available. When done with the dialog click "OK" to close it and accept the new connection.

  2. Save the connection string

    This step appears only if you have specified a new connection string in the previous one. Choose "Yes, save the connection with the following name" to store the connection string in the application configuration file under a specific name. Type a name for the connection or use the provided default name if applicable.

    Note

    Saving the connection string in the application configuration file simplifies the process of maintaining your application if the database connection changes. In the event of a change in the database connection you can edit the connection string in the application configuration file as opposed to editing the source code and having to recompile your application.

  3. Configure data source command

    In this step you have to specify an MDX select statement to retrieve data for the data source.

    Note

    The CubeDataSource component does not impose any restrictions over the format of the MDX query. However, to ensure that the retrieved data is in a proper format for visualization you should follow the next rule: specify the measures you want to aggregate in the column axis and the dimensions to group by in the row axis of the query; also avoid using more than two axes in a single query.

  4. Configure data source parameters

    In this step you have to specify the parameters for the MDX query. Click "New" to add a new parameter to the CubeDataSource or "Delete" to remove an existing parameter. Use the arrow buttons to change the order of the parameters when necessary.

    • Specify a valid name for each data source parameter in the "Name" column. You can also choose that name from the list of existing parameter names which are derived directly from the MDX select statement.

    • Specify a default value for the parameter in the "Value" column or bind it via an expression.

    You can bind a data source parameter directly to a report parameter. This way you can use the standard report parameter user interface to provide values for your data source parameters. The drop-down list of the "Value" column displays all existing report parameters. You can create a new report parameter by choosing "<New Report Parameter>" from the list. Alternatively you can invoke the Edit Expression dialog by choosing "<Expression>" from the list. This allows you to specify an arbitrary expression to evaluate for the parameter.

  5. Configure design time parameters

    This step allows you to specify a value for each data source parameter that can be used at design time to retrieve the schema of the CubeDataSource component.

    Note

    Specifying design time values for the parameters is necessary because the designer might need to execute the MDX query of the data source to refresh the schema displayed in the Data Explorer tool window and the Edit Expression dialog. These values do not affect the execution of the MDX query at runtime however.

  6. Configure data source fields

    This step allows you to specify short aliases for the data source fields that can be used for data binding in expressions. Enter an appropriate alias for each data source field in the "Alias" column of the grid or leave the default suggestion if applicable.

    Note

    The default fields returned by an MDX query often are too long and might need to be escaped when used in expressions. To overcome this it is advised to always specify shorter and more descriptive aliases for them.

  7. Preview data source results

    You can preview the result set returned by the CubeDataSource before completing the wizard. Click "Execute Query" to execute the MDX query and display the retrieved data.

    If the data source has parameters the wizard displays a popup dialog before each preview which allows you to enter the parameter values.

    This is the last step of the wizard. After pressing "Finish" the wizard will configure the CubeDataSource component with the specified settings and close.


Table and CrossTab Wizards

[image]

Telerik Reporting Q2 2012
Table and CrossTab Wizards
Send Feedback

The Table and CrossTab Wizards are introduced as guide through the process of creating a Table or CrossTab for your reports. Their intuitive step by step instructions would get you going in no time as no previous experience is needed when using the wizards:

Step 1: This is the welcome screen which appears once you drop a crosstab or table wizard item on the reporting design surface.

Step 2: Choose DataSource

This page lets you use an existing data source from a list of data sources or add new Data Source. If you choose to create new data source, click the Add New Data Source button to start the Data Source Wizard. It will walk you through an additional set of steps and when finished will return you to the Table/CrossTab Wizard so you can continue.

Step 3: Arrange Fields (Table Wizard is on the right. It allows for adding columns only).

Step 4: Choose Layout:

Step 5: Choose Style and Finish the wizard:

Here is how the wizard generated crosstab looks like:


Context Menu

[image]

Telerik Reporting Q2 2012
Context Menu
Send Feedback

The context menu will conditionally display items depending on the area of the report that was right-clicked. Some of the significant context menu items are:

  • View:The sub menu of View allows you to select Data Explorer, Report Explorer and Group Explorer.
  • Style: Invokes the Edit Style dialog for the right-clicked item. From here you can set the Text, Background, Edges and Line style for the report items, sections or the report as a whole.
  • Copy, Paste, Reset Style: To copy the style from one item in the report, right-click a report item and select Copy Style, then right-click another report item and select Paste Style. Right-click and select Reset Style to restore an items previous style before the paste.
  • Page Header, Page Footer, Report Header: and Report Footer: These menu items can be toggled on and off to create and remove respective sections in the report.
  • Add New Group:This menu item adds a new group to the report and new group component to the tray below the report designer.
  • Groups:This menu item opens the Group Collection Editor dialog and allows you to add or remove groups to the report
  • Report Parameters:This menu item opens the ReportParameter Collection Editor dialog and allows you to add or remove report parameters to the report
  • Sorting:This menu item opens the Edit Sorting dialog and allows you to add or remove sort expressions to sort the data in the report
  • Filters:This menu item opens the Edit Filters dialog and allows you to add or remove filter expressions to restrict the data that is being shown in the report

In the figure below the menu is invoked in the area next to the report design surface.

In the example below, a TextBox was right-clicked to display its context menu. It includes the following menu items:

  • Bring To Front/Send To Back:Allow you to change the order of the items in the items collection of a section.
  • Select:Variations of this menu item allow you to select the report, sections in the report or items in sections of the report. The menu choices allow you to select elements of the report that are underneath the right-clicked item.
  • Expressions: This menu item invokes the Edit Expression dialog. The dialog supplies a list of elements that can be used in your expression including Aggregates, Constants, Fields, Functions, Global Objects, Operators and Report Parameters.
  • Format Selecting this item displays the Format Builder dialog.
  • Conditional Formatting: This menu item invokes the Conditional Formatting Rules Dialog. This dialog lets you define rules that when fired change the style formatting of the selected item.


Conditional Formatting Rules Dialog

[image]

Telerik Reporting Q2 2012
Conditional Formatting Rules Dialog
Send Feedback

The Conditional Formatting Rules dialog lets you define rules that when fired change the style formatting of the selected item. You can define multiple rules that will format the same report item. Each rule is made up of a set of conditions and a style to use when the conditions of the rule are met. Rules are executed in the order they appear in the ConditionalFormatting collection. You can choose whether to continue evaluating all rules in the collection or interrupt execution when a rule is satisfied.

Use the New Rule, Edit Rule and Delete Rule buttons to add, edit and delete formatting rules. Use the arrow buttons to change the order of precedence where rules higher in the list are evaluated before rules occuring later in the list. Select the Stop if true checkbox to interrupt rule processing if the rule conditions are satisfied.

The New Rule and Edit Rule buttons display the Edit Formatting Rule dialog. The top portion of the dialog contains a list of rules. Each rule consists of an Expression an Operator and a Value. Expression can be a database field defined in the Report DataSource or "<Expression>". "<Expression>" invokes the Edit Expression Dialog. Operator lists comparison operators (i.e. <, >, >=, etc.), Like, Top N, Top %, Bottom N and Bottom %. Value can be a hard coded value, "<Blank>" or "<Expression>". Rules expressions are "and-ed" together and must all be true for the rule condition to be satisfied.

The bottom portion of the Edit Formatting Rule dialog has a button to invoke the Edit Style dialog and a preview of the style. The Style button displays the Style Builder dialog that sets the formatting to be used if the rule conditions are satisfied. Here you can define the style for Text, Background, Edges, Line styles as well as whether an item/section would be visible or not.


Edit Expression Dialog

[image]

Telerik Reporting Q2 2012
Edit Expression Dialog
Send Feedback

The Edit Expression dialog allows you to dynamically produce a value for a report item in place of a hard coded value. The Edit Expression dialog provides a list of predefined and dynamic elements that can be used in your expression. A list of expression element categories is located in the lower left hand list of the dialog, the elements for each category are located in the lower middle of the dialog, and descriptions are displayed in the lower right hand of the dialog.

To use the Edit Expression dialog either type an expression in directly or double click the list of elements in the bottom middle list to add them to the expression. In the figure below an expression with two database Fields multiplied provide an extended price value. For a list of the supported expression elements see Using Item Binding Expressions.


Edit Filter Dialog

[image]

Telerik Reporting Q2 2012
Edit Filter Dialog
Send Feedback

The Edit Filters dialog allows you to specify which records will be displayed. The dialog populates the Report.Filters collection. See the example below that displays only records where the first four characters of the "Name" field must be "Tour" and the "FinishedGoodsFlag" field must be True.

Using the Edit Filters Dialog

For more information on adding filters to Data Items, please refer to the Filtering Data help topic.


Edit Sorting Dialog

[image]

Telerik Reporting Q2 2012
Edit Sorting Dialog
Send Feedback

The Edit Sorting dialog controls the order that records are displayed in. The dialog populates the Report.Sorting property. In the example below products are sorted first by Shelf, then Bin (in descending order) and finally by product Name.

Using the Edit Sorting Dialog

For more information on sorting Data Items, please refer to the Ordering Data help topic.


Edit Grouping Dialog

[image]

Telerik Reporting Q2 2012
Edit Grouping Dialog
Send Feedback

The Edit Grouping dialog controls how sets of records are broken out and displayed with headings and subtotals. The dialog populates the Report.Grouping collection. In the example below products are grouped first by Shelf then by Bin. Headings and subtotals appear for each Shelf/Bin combination.

You can arrive at the Edit Grouping dialog by clicking on the ellipsis in the Report.Groups property.

Using the Edit Grouping Dialog

For more information on adding groups to Data Items, please refer to the Grouping Data help topic.


Edit Bindings Dialog

[image]

Telerik Reporting Q2 2012
Edit Bindings Dialog
Send Feedback

Generally only some properties of certain report items can handle expression values. Other properties of a report item can take advantage of expression values by adding Binding objects to its Bindings collection. Only write-enabled properties can be set through binding expressions, so read-only properties are not suitable for "data-binding".

The Edit Bindings dialog is available in the property grid by clicking on the ellipsis of the Bindings property.

Add a Binding object

The dialog accepts Property Path and Expression for that property. The property can have a period-delimited navigation path in order to reference a property down the object hierarchy. The Expression can be constant, expression value, user defined function or even a report parameter. The evaluated expression should return an object of appropriate type for the bound property

For example, you can bind the Style.Font.Bold property of a TextBox item to an expression such as =Fields.MyBoolField that would return true or false. In certain cases using user-defined functions to perform appropriate type conversions should be considered e.g. for System.Drawing.Color as seen on the image.

For example the following navigation paths are valid:

  • DataSource
  • Style.BackgroundColor
  • Style.Font.Name

Edit a Binding object

To edit a Binding object, click in the inline editors directly.

Delete a Binding object

To delete a Binding object, use the Delete Button.

Note

Not all item properties support expression bindings. Please refer to the API reference to check if a property supports binding.


Edit Calculated Fields Dialog

[image]

Telerik Reporting Q2 2012
Edit Calculated Fields Dialog
Send Feedback

Calculated fields can be used to create new values that do not exist in the data source. For example, a calculated field can represent a new value, a constant, an expression value, user defined function or even a report parameter, or an existing field that is converted to a different datatype.

Add a Calculated Field

You specify a calculated field manually by creating an expression. The Edit Calculated Fields dialog is available in the property grid of our DataSource components:

  • SqlDataSource
  • ObjectDataSource
  • EntityDataSource
  • OpenAccessDataSource
by clicking on the ellipsis of the CalculatedFields property.

The dialog accepts Name, DataType and Expression.

Edit a Calculated Field

To edit a Calculated Field, click in the inline editors directly

Delete a Calculated Field

To delete a Calculated Field, use the Delete Button

Note

Names must be unique in the datasource and the expression for a calculated field cannot contain aggregates, RowNumber or ColumnNumber global functions.


Edit Action Dialog

[image]

Telerik Reporting Q2 2012
Edit Action Dialog
Send Feedback

The Action dialog box can be used to enable interactive actions for all items that support interactivity. Define an action so that a user can click on the report and link to a URL, to a different report, to a different location in the same report or toggle the visibility of items.

The Edit Action offers the following choices:

  • None
  • Navigate to Report
  • Navigate to Bookmark
  • Navigate to Url
  • Toggle Visibility

Depending on the purpose of the interactive actions you can choose the appropriate option which would open an additional pane below. For more information review the following articles:

  • Document Map
  • Drillthrough Report Action
  • BookMark Action
  • Hyperlink Action
  • Drilldown Report Action
  • How to: Add a Document Map
  • How to: Add a Bookmark Action
  • How to: Add a Hyperlink Action
  • How to: Add a Drillthrough Report Action
  • How to: Add a Drilldown Action


Format Builder Dialog

[image]

Telerik Reporting Q2 2012
Format Builder Dialog
Send Feedback

The Format Builder dialog allows you to apply formating to the TextBox and CheckBox items. You can open that dialog either from the property grid of those items or from their context menu, by selecting the Format menu item.

The expression values are handled differently depending on what type of formatting you have assigned.For example, if you choose Currency formatting, Telerik Reporting will automatically convert 3 into $3.00; if you choose Date formatting it would convert 3/1 to March 1; if you choose Percent formatting, it would change 0.3 to 30% etc.

If you want a format that is not included in the pre-made formats, you can make your own custom format, using the Custom category. For example if you have a numeric field that holds social security numbers, you can format it to look correct in the report by specifying a custom format: ###-##-####. Look through the list of Custom formats and try making some of your own.


Load Report Dialog

[image]

Telerik Reporting Q2 2012
Load Report Dialog
See Also Send Feedback

The Choose Report Source dialog is used to select the source for a report that would be displayed in a report viewer, SubReport item or drill-through action.

The dialog offers the available report sources, which are:

  • URL or file
  • Type name
  • XML markup
  • Object instance

For examples that demonstrate how to programmatically create a report source, check the API reference examples below.

Reports can be stored in different locations and in different formats so use the uniform way to access them via the appropriate option. It would open an additional pane below allowing you to select the report source and set report source parameters as well.

See Also

Reference

UriReportSource
TypeReportSource
InstanceReportSource
XmlReportSource

Other Resources

Report Sources


ReportParameter Collection Editor

[image]

Telerik Reporting Q2 2012
ReportParameter Collection Editor
Send Feedback

The ReportParameter Collection Editor dialog allows you to add/remove entries from the Report.ReportParameters collection.

Access the Report Parameter Collection Editor

There are several ways to open the ReportParameter Collection Editor:

  • Click the ellipses on the Report.ReportParameters property.
  • Select the Report Parameters .. option from the Context Menu of the Report Designer.
  • Right click on the Parameters node of the Report Explorer dialog.
  • From the Configure Data Source Parameters step of the DataSource Components

More information on adding and working with Report Parameters is available in the Adding Parameters to Report article.


Style Builder Dialog

[image]

Telerik Reporting Q2 2012
Style Builder Dialog
Send Feedback

The Style Builder dialog lets you set Text, Background, Edges and Line Style for any given report item including sections and the report as a whole. The dialog is accessed through the Style property ellipses button and is also used in conditional formatting. The dialog lets you change several style elements at one time and see the result in the Preview pane at the bottom of the dialog.

To use the Style Builder dialog choose a style element from the list on the left of the dialog. Change style characteristics in the area to the right of the list. Click the OK button to apply the style changes or the Cancel to leave the previous style untouched.


Understanding Report Structure

[image]

Telerik Reporting Q2 2012
Understanding Report Structure
See Also Send Feedback

This article describes the structure of a Telerik Report. To learn more about the report building blocks used in Telerik Report, refer to Understanding Report Sections and Understanding Report Items.

Report Structure

Telerik Reporting is an embedded engine, thus available and accessible directly within your application. Telerik Reports are standard .NET classes and you can add a report to a project and handle it in the Visual Studio IDE in a similar manner to what you're already used to.

A Telerik Report is represented by an instance of the Report class and each report serves as a container for sections. In the same way every section serves as a container for report items.

The design of a report is divided into sections and you can open your report in Report Designer to see its sections. To create useful reports, you need to understand how each section works. For example, the section in which you choose to place a data bound items determines how Telerik Reporting calculates the results.

Report sections divide the report vertically. Depending on their type they appear on specific places in the report document and the report items they contain are processed and rendered differently. For more information see Understanding Report Sections

A report can be either data bound or unbound. To create a bound report you should first bind the report or a nested Data Items to a data source, and then specify Expressions for report items within the report or data item. To learn more about creating a bound report, see the Connecting to Data and Using Expressions sections.

After a report is constructed, it is possible to save it to XML file and re-use it later (for more information, see Serializing Report Definition in XML). Also, if a report uses stylesheets, they can be saved to xml file and shared between multiple reports in your application (for more information, see Exporting and Reusing Style Sheets ).

Report Sections

Telerik Report consists of a number of sections, each of a different type. Every section may contain report items. A report section represents a specific area on a report page, used to define how to render report items that belong to it. Every section is an instance of the ReportSectionBase class. The Height property defines the space that a section occupies on a page. Other specific properties such as PrintOnFirstPage and PrintOnLastPage define a section's behavior.

When a new Telerik Report is added to a project, it is initially divided into three sections - PageHeader, Detail and PageFooter. A section type specifies how the items located on this section are rendered, their rendering order and how many times they are rendered if report is data bound.

Report Items

Report items are inserted into a report depending on what you need e.g. TextBox item for static or data bound text, PictureBox for displaying images, Barcode for showing barcode in your label report etc. Every report item is an instance of the ReportItemBase class. Report items can reside either inside report sections or inside other report items that may serve as item containers (e.g. Panel or Table/Crosstab/List items).

The appearance and behavior of a report item is defined by its type. See Understanding Report Items section for more info about different report item types available in the current version of Telerik Reporting.

Controlling Height

To remove blank vertical space in a container (report section or panel item), whenever you control the visibility of report items in runtime, set its respective height to a very small value (e.g. 1mm). Section/Panel item can grow to accommodate their children but cannot shrink/take space that is no longer occupied. If you want a section/panel to shrink only at runtime you can set its Height property in the report constructor. Place the Height property assignment code just after the IntializeComponent() method call.

See Also

Other Resources

Understanding Report Sections
Understanding Report Items
Placing and Sizing Report Items


Understanding Report Sections

[image]

Telerik Reporting Q2 2012
Understanding Report Sections
See Also Send Feedback

The following table presents a summary of the section types and their usage:

Section Type | Description
Page Header | This section is printed at the top of every page. For example, use the page header to repeat the report title on every page. Since the paging of a report strongly depends on the format it is rendered to, this section and its items are processed by the corresponding rendering extension after the report data has been processed. At this moment the report data source is not available anymore and due to this you can use the built-in PageNumber and PageCount objects (which contain the current page number and the total report pages count) only in this section. It is possible to suppress the printing of the Page Header section on the first and last page of a report, but the space taken up would always be reserved no matter whether it is visible.
Report Header | This section is printed just once, at the beginning of the report. Use the report header for information that might normally appear on a cover page, such as a logo, a title, or a date. In the Report Header section all data fields must be aggregated, even if the data source returns only one row. Typically you should use the FIRST() function for character and date data and the SUM() function for numeric data. When you place a databound report item that uses an aggregate function in the report header, it is calculated for the entire report data.
Group Header | This section is printed at the beginning of each new group of records. Use the group header to print the group name. For example, in a report that is grouped by product, use the group header to print the product name. In the Group Header section all data fields must be aggregated, even if the data source returns only one row. Typically you should use the FIRST() function for character and date data and SUM() function for numeric data. When you place a databound report item that uses an aggregate function in the Group Header, it is calculated for the entire group data.
Detail | This section is printed once for every row in the data source. This is where you place the report items that make up the main body of the report.
Group Footer | This section is printed at the end of each group of records. Use a group footer to print summary information for a group. Similar to the Group Header section, you should always use aggregate functions for the databound items that are calculated for the group data.
Report Footer | This section is printed just once, at the end of the report. Use the report footer to print report totals or other summary information for the entire report. Similar to the Report Header section, you should always use aggregate functions for the databound items that are calculated for the entire report data.
Page Footer | This section is printed at the end of every page. Use a page footer to print page numbers or per-page information. Similar to the Page Header Section you cannot use databound items, but can access the PageNumber and PageCount objects. It is possible to suppress the printing of the Page Footer section on the first and last page of a report, but the space taken up would always be reserved no matter whether it is visible.

See Also

Other Resources

How to: Create Report Headers and Footers
How to: Create Page Headers and Footers
How to: Create Group Headers and Footers


How to: Create Report Headers and Footers

[image]

Telerik Reporting Q2 2012
How to: Create Report Headers and Footers
See Also Send Feedback

Reports can contain report headers and footers. By default, new reports are created without these sections.

  • Any control you place in the report header section is rendered once at the top of the entire report's output, but after the first page header section (if any).
  • Any control you place in the report footer section is rendered once at the bottom of the entire report's output, but before the last page footer section (if any).

To Add or Remove Report Header/Footer Section

  1. Right-click on any section header in the report, or in the empty space around the sections.
  2. Select Report Header or Report Footer.

See Also

Reference

ReportHeaderSection
ReportFooterSection


How to: Create Page Headers and Footers

[image]

Telerik Reporting Q2 2012
How to: Create Page Headers and Footers
See Also Send Feedback

By default, every new report is created with a page header section and a page footer section.

  • Any control you place in the page header section is rendered at the top of each page of the report's output.
  • Any control you place in the page footer section is rendered at the bottom of each page of the report's output.

To Add or Remove the Page Header/Footer Section

  1. Right-click in the empty space around the sections.
  2. Select Page Header or Page Footer.

Page Header/Footer Specifics

Size of page sections is constant for the whole report document. If a report item inside a page section grows beyond its parent size, the page section would not grow to accommodate it and the part that does not fit would be cut off. Listed below are page section specific properties:
  • PrintOnFirstPage: Set to False to suppress the page section on the first page of the report.
  • PrintOnLastPage: Set to False to suppress the page section on the last page of the report.
Caution

Page sections are not related to the report itself, but are relative to the paper or screen. Thus page sections of nested/detail reports are ignored and only the page sections of the main report are visible.

Caution

Data Items cannot be used in page sections, because the latter are processed after the report data has been processed. At this moment the report data source is not available anymore.

Adding Calculated Page Totals to a Header or Footer

For some reports, it is useful to include a page-scoped aggregate in the page header or page footer of the report. For example, a per-page sum total may be rendered if the page includes numeric values.

For more information, please refer to the PageExec description in the Functions article.

See Also

Reference

PageHeaderSection
PageFooterSection

Other Resources

Functions
Aggregate Functions


How to: Create Group Headers and Footers

[image]

Telerik Reporting Q2 2012
How to: Create Group Headers and Footers
See Also Send Feedback

Each Report Group has a Group Header and Group Footer sections associated with it. How to create a Report Group is explained in How-To: Add groups to Report article.

Group Header/Footer Specific Properties

  • PrintOnEveryPage: Set to True to repeat the group header at the top of each page if the details of the group extend across multiple pages.

Report Group Properties

To set the following group properties you have to select a group from the Group Explorer

  • Filters: This property determines which groups will display. This level of filtering occurs before filtering for the report as a whole occurs. The filters for the group are applied to the grouping data, not the report data itself. Filter data for the group using the Filters property ellipses to invoke the Edit Filter Dialog. See Filtering Report Data for more information.
  • GroupKeepTogether: Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
  • Grouping: The grouping property controls how groups of data are broken out in the report. Click the ellipsis for this property to invoke the Edit Grouping Dialog. This dialog allows you to specify grouping criteria that determine where the grouping level breaks occur. Note: It is also possible to have groups with no grouping criteria.
  • Sorting: This property controls the sorting order for the grouping data, not the report data. This level of sorting occurs before the sorting for the report as a whole. For example, Click the ellipsis button for this property to open the Edit Sorting dialog. Click Add to add a new sort expression. For each SortExpression, set the FieldName property to the name of the field by which this group should sort records, and select either Ascending or a Descending sort order.

See Also

Reference

GroupHeaderSection
GroupFooterSection
Group


Understanding Report Items

[image]

Telerik Reporting Q2 2012
Understanding Report Items
Send Feedback

Telerik Reporting supplies report item components that are placed in the report designer to build report content:

Report item | Description
TextBox | The TextBox displays text in the report, can be styled to a specific visual appearance, can be configured to grow/shrink, formatted for specific data types (e.g. date time) and can be multi-line.
HtmlTextBox | The HtmlTextBox item allows developers to insert HTML-formatted text into a report. You can specify the HTML value at design time (either through a WYSIWYG editor or through an expression editor), or retrieve it from a data source using expression that evaluates to correctly formatted HTML.
PictureBox | The PictureBox allows you to place images in the report. It supports only image formats supported by GDI+ (BMP, GIF, JPEG, EXIF, PNG and TIFF).
Panel | The Panel report item is used as a container for other items, usually to group/separate multiple report items by some criteria.
SubReport | The SubReport report item lets you display one report within another report. This allows you to compose complex reports from disparate report sources.
Table | The Table items is used to display fields from a dataset either as detail data or as grouped data in a grid or free-form layout. Telerik Reporting provides three items that can be used as templates and you can add them directly from the Toolbox: Table, Crosstab, and List.
CheckBox | This report item displays a check mark (small picture) and a Text field (same as the text in TextBox). It can be styled to a specific visual appearance, can be configured to grow/shrink, the text can be formatted for specific data types (e.g. date time) and can be multi-line. The Check mark and Text can be aligned vertically and horizontally. There are three predefined check mark images, but they can be replaced with others.
Chart | The chart lets you display data in a visually compelling way. The chart can bind to live data and display in many popular chart types, e.g. Bar, Pie, Gantt, Line, Area, Bubble, etc.
BarCode | The Barcode report item is used for automatic barcode generation directly from a numeric or character data without need of any barcode font being installed in the end user's PC.
Shape | The Shape item displays visual primitives in the report including ellipse, vertical/horizontal/slanting lines, and triangles.

Definition item versus Processing item

Report Definition

The Report Definition item is created during the first stage of the Report Life Cycle. This is the actual .NET class that represents the report. It is always a subclass Telerik.Reporting.Report and contains information about report items and their properties. Report items are represented by the private fields of the report class.

Let’s illustrate this with an example. While in design-time, if you add a TextBox to the Detail Section of the report that you are designing, a private field of type TextBox will be added to the code-behind file and some basic initialization code will be generated within the InitalizeComponent method of the report class.

Note

The InitializeComponent method initializes (creates) a Report and its child items.It is a special method recognized and parsed by the Report Designer in order to display the report in design-time.

This object will later serve as the definition for creating a concrete instance of the TextBox for each row form the data source. These definition objects are of the types that reside in the Telerik.Reporting namespace, for example Telerik.Reporting.TextBox.

Report Processing

The second stage of the Report Life Cycle involves combining the report definition with the data source. The processing engine performs all grouping, sorting and filtering calculations and iterates over all rows from the data source and creates the appropriate processing items based on the item definitions created earlier and the actual data. Based on the original item definition (Telerik.Reporting.TextBox for example) and the actual data in the current data row a new item is created. This item is known as a processing item (Telerik.Reporting.Processing.TextBox for example) and bears all characteristics of its definition item, but it is bound to the respective data field from the current data row. While the definition TextBox’s Value property may contain something like “=Fields.FirstName”, the processing item’s Value property will be equal to “John”.

The Processing Engine provides the developer with a way to intervene in this process. Just before the processing item is bound to data, the ItemDataBinding event of its definition item is raised. After the processing item has been data bound the ItemDataBound event is raised. By subscribing a listener for those events, the developer can modify the default behavior at run-time. The sender parameter of the event handler methods is in fact the processing report item.


Barcode

[image]

Telerik Reporting Q2 2012
Barcode
See Also Send Feedback

The BarCode report item is used for automatic BarCode generation directly from a numeric or character data without need of any BarCode font being installed in the end user’s PC. The screenshot below shows a BarCode report item on a report at design-time:

The following figure illustrates how the value of the BarAlign property affects the appearance of the BarCode report item when Stretch is set to false:

When the ShowText property is set to true, the placement of the text around the BarCode can be controlled by the TextAlign and VerticalAlign properties of the Style property. The figure below shows different combinations of values for the TextAlign and VerticalAlign properties and how they affect the final appearance of the BarCode report item.

Symbology Specifications

BarCode | Description
Codabar | (aka Ames Code/USD-4/NW-7/2 of 7 Code): Used in libraries and blood banks
Code 11 | (USD-8): Used to identify telecommunications equipment
Code 25 Standard | Used in airline ticket marking, photofinishing
Code 25 Interleaved | Used in warehouse, industrial applications
Code 39 | (aka USD-3, 3 of 9): U.S. Government and military use, required for DoD applications
Code 39 Extended | (aka USD-3, 3 of 9): U.S. Government and military use, required for DoD applications, supports full ASCII
Code 93 | (aka USS-93): Compressed form of Code 39
Code 93 Extended | (aka USS-93): Compressed form of Code 39, supports full ASCII
Code 128 | Very dense code, used extensively worldwide
Code 128 A | Subset of Code 128 *(more info below)
Code 128 B | Subset of Code 128 *(more info below)
Code 128 C | Subset of Code 128 *(more info below)
MSI | Variation of Plessey code, with similar applications
EAN 8 | Short version of EAN-13, 8 characters
EAN 13 | Used with consumer products internationally, 13 characters
EAN 128 | Used to encode shipping/product information *(more info below)
Postnet | Printed by U.S. Post Office on envelopes
UPC A | Used with consumer products in U.S., 12 characters
UPC E | Short version of UPC symbol, 6 characters
UPC Supplement 2 | Used to indicate magazines and newspaper issue numbers
UPC Supplement 5 | Used to mark suggested retail price of books

Additional information on Code128

  1. Code128A, Code128B and Code128C represent the A, B and C subsets of the Code128 symbology. Code128 uses an intelligent algorithm that picks automatically the appropriate subset according to the input value, and might switch between these subsets in the middle of a BarCode in order to produce a shorter generated sequence. For example, if you have the input string “ABCD1234”, the “ABCD” part of the string will be encoded using the A subset, while the “1234” part will be encoded with the C subset, because Code128C uses a double-density code for numerical values, thus producing a shorter BarCode as a result. If you want to disable this behavior you can specify explicitly one of the subsets: Code128A, Code128B or Code128C to the Symbology property of the BarCode report item.
  2. Code128 can represent both ASCII characters and non-ASCII control characters. Normally the BarCode report item inserts automatically the appropriate control characters in order to conform to the Code128 specification. However certain applications might require manual insertion of certain control characters, such as the functional characters: FNC1-FNC4. For this purpose the BarCode report item assigns special Unicode values to these control characters outside the normal 0-127 ASCII code range. The following table lists all Code128 control characters and their corresponding Unicode values:
Code 128 Control Characters
Control Character | Hexadecimal | Decimal
Code A | F4 | 244
Code B | F5 | 245
Code C | F6 | 246
FNC1 | F7 | 247
FNC2 | F8 | 248
FNC3 | F9 | 249
FNC4 | FA | 250
Shift | FB | 251
Start A | FC | 252
Start B | FD | 253
Start C | FE | 254
Stop | FF | 255

For example, the following code inserts the FNC4 control character in the middle of a BarCode:

CopyC#
BarCode1.Value = "ABCD" + "\u00FA" + "1234";
CopyVB.NET
BarCode1.Value = "ABCD" & ChrW(&HFA) & "1234"

Additional information on EAN128

EAN128 is a special case of Code128. The only difference between EAN128 and Code 128 is that EAN128 inserts the FNC1 control character at the beginning of the BarCode in order to conform to the EAN128 specification. If you have a multi-part EAN128 BarCode which requires the FNC1 control character as a delimiter between the different parts, you should insert it manually:

CopyC#
BarCode1.Value = "1234" + "\u00F7" + "5678";
CopyVB.NET
BarCode1.Value = "1234" & ChrW(&HF7) & "5678"

See Also

Reference

BarCode
BarAlign
Checksum
Module
ShowText
Stretch
Symbology


Checkbox

[image]

Telerik Reporting Q2 2012
Checkbox
See Also Send Feedback

The CheckBox report item is used to display both text and a check mark on a report. This screenshot shows a CheckBox report item with CheckAlign property set to TopCenter and text aligned to Top and left.

Growing and Shrinking

By default, CheckBoxes are a set size. If you want to allow a CheckBox to expand vertically based on its contents, set the CanGrow property to True (default value). If you want to allow a CheckBox to shrink based on its contents set the CanShrink property to True (default value is False). The CheckBox would always grow to accomodate the first line of text even when CanGrow is False.

Embedded expressions

The text part of the Checkbox report item supports embedded expressions for mail merge functionality. Embedded expressions give you the freedom to get and insert data-driven information directly into the CheckBox.Text property to produce customized reports and mail merging.

A view where each CheckBox is initialized with CheckAlign varying from TopLeft to BottomRight:

The check mark image depends on the value set in the Value property. By default it would accept =true or =false. At design time the Value property can be initialized with an expression which later at runtime is evaluated to one of the System.Windows.Forms.CheckState values e.g.:

=IsNull(Fields.Quantity, 0) > 100 which would return true or false and would check and uncheck the check mark respectively.

Also if your data fields return two/three distinctive values, which are not true/false you can change the TrueValue/FalseValue/UndeterminateValue properties to match your field values directly.

Example:

You have a Status field that has three values:

  • Approved
  • DisApproved
  • NotSet

In such case it is more convenient to use those values directly instead of trying to evaluate them as true/false. You can do that easily by using the TrueValue/FalseValue/UndeterminateValue properties:

And here is the final result:

See Also

Reference

Telerik.Reporting..::.CheckBox
CheckAlign
CheckedImage
UncheckedImage
FalseValue
IndeterminateImage
IndeterminateValue
Text
TrueValue


Panel

[image]

Telerik Reporting Q2 2012
Panel
See Also Send Feedback

The Panel report item is not associated with data and is used as a container for other items, usually to group/separate multiple report items by some criteria. You can set properties such as Visible on the Panel to affect all of the report items hosted in that Panel. When you move the Panel, the items that are contained within it move along with it. The screenshot shows a Panel containing two TextBox report items.

Note

A Panel acts as a container for items that you either create in it or drag into it. If you draw a Panel around an item that already exists in the Report Designer, the Panel will not act as its container.

See Also

Reference

Panel

Other Resources

Using Styles to Customize Reports


PictureBox

[image]

Telerik Reporting Q2 2012
PictureBox
See Also Send Feedback

The PictureBox report item is used to display images on a report and it supports only image formats supported by GDI+ (BMP, GIF, JPEG, EXIF, PNG and TIFF).

Its value can be an expression that contains binary image data or it can be a URI (local path or Url). When a Value property is assigned a string that is not an expression (doesn't start with "=") the value is assumed to be an URI. Click the ellipsis for this property to browse for an image file on your hard drive.

This screenshot shows a PictureBox report item on a report at design-time (note the image thumbnail in the upper left corner).

Data Binding

Binding image data to a PictureBox report item is straight-forward. If you’re using the designer in Visual Studio and have connected to a data source, you can simply drag the image field from the Data Explorer window onto your report. The designer is smart enough to know what kind of report item to associate with each field based on its data type.

Alternatively, one can drag a PictureBox item onto the design surface and use an expression to set its Value property to an existing field from the data source.

While the methods above are quickest to get an image onto your report, one doesn’t have to bind directly to a database field with an image column. The type of the PictureBox.Value property is Object which allows for versatile data binding. The Value property accepts objects of type Image and strings.

Binding to a Binary Image

You can directly assign a reference to an Image to the Value property of a PictureBox:

CopyC#
using System.Drawing;

Image image1 = Image.FromFile(@"C:\MyPictures\MyPicture.jpg");
this.pictureBox1.Value = image1;

Image image2 = Image.FromStream(imageStream);
this.pictureBox2.Value = image2;
CopyVB.NET
Imports System.Drawing

Dim image1 As Image = Image.FromFile("C:\MyPictures\MyPicture.jpg")
Me.PictureBox1.Value = image1

Dim image2 As Image = Image.FromStream(imageStream)
Me.PictureBox2.Value = image2

While in design-time, if you click the ellipsis of the Value property of a selected PictureBox, you will be presented with a dialog to choose the desired image. After you have selected the image, the Designer will automatically store it in the resources file for the report (.resx) and add a line of code to the InitializeComponent method that obtains a reference to the image stored in the resources and assigns it to the Value property of the PictureBox:

CopyC#
this.pictureBox1.Value = ((object)(resources.GetObject("pictureBox1.Value")));

When the database field contains relative path (be it file path or uri) you can use User Functions to specify the correct path to the image:

CopyC#
public static Image LoadImage(string imageLocation)
{
     string absoluteLocation = "C:\\" + imageLocation;
     return Image.FromFile(absoluteLocation);
}
CopyVB.NET
Public Shared Function LoadImage(imageLocation As String) As Image
    Dim absoluteLocation As String = "C:\" + imageLocation
    Return Image.FromFile(absoluteLocation)
End Function
 and set the Value of the PictureBox item to the correct expression: =LoadImage(Fields.YourImagePathColumn).

Binding to Expression/URI

Alternatively you can assign a string value to the Value property of a PictureBox. This string value can be either an item binding expression or an URI. Both absolute and relative URIs are supported. When binding to a data field with an expression, the Value property will accept both binary and string data fields. In other words, your data source column may store the image directly or store an URI pointing to the image:

CopyC#
this.pictureBox1.Value = "=Fields.MyImageBinary";//a binary data column
this.pictureBox2.Value = "=Fields.MyImageURI";//a data column containing an URI
this.pictureBox3.Value = @"C:\MyPictures\MyPicture.png";//absolute file path
this.pictureBox4.Value = @".\images\MyPicture.png";//relative file path
this.pictureBox5.Value = "http://www.mysite.com/images/img1.gif";//absolute URL
this.pictureBox6.Value = "/images/img1.gif";//relative URL
CopyVB.NET
Me.PictureBox1.Value = "=Fields.MyImageBinary" 'a binary data column
Me.PictureBox2.Value = "=Fields.MyImageURI" 'a data column containing an URI
Me.PictureBox3.Value = "C:\MyPictures\MyPicture.png" 'absolute file path
Me.PictureBox4.Value = ".\images\MyPicture.png" 'relative file path
Me.PictureBox5.Value = "http://www.mysite.com/images/img1.gif" 'absolute URL
Me.PictureBox6.Value = "/images/img1.gif" 'relative URL

Clipping and positioning

The clipping and positioning of an image in the display area of a PictureBox item is controlled by its Sizing property.

Sizing Property modes:

Name | Description
AutoSize | The PictureBox item size is adjusted to that of the image it contains.
Center | The image is displayed in the center of the PictureBox item. If the image is larger than the PictureBox item, the outside edges are clipped.
Normal | The image is placed in the upper-left corner of the PictureBox item. The image is clipped if it's larger than the PictureBox item which contains it.
Stretch | The image within the PictureBox item is stretched or shrunk as appropriate to fit the size of the PictureBox item.
ScaleProportional | The image is sized proportionally (without clipping), so that it's best fitted to the PictureBox item. If the height and width ratio of the PictureBox item is the same as the image's ratio it will be resized to exactly fit into the PictureBox item. Otherwise the closest fitting side (height or width) of the image will be sized to the item and the other side (height or width) of the image sized proportionally (leaving empty space).

See Also

Reference

PictureBox
Sizing

Other Resources

Using Styles to Customize Reports
Using Expressions
Types of Bitmaps
Images, Bitmaps, and Metafiles


Shape

[image]

Telerik Reporting Q2 2012
Shape
See Also Send Feedback

The Shape report item is used to display one of a selection of predefined shapes on a report. The screenshot below shows a Shape report item with ShapeType="Right Arrow" on the report design surface.

You can use shapes to create visual effects within a report. You can set display and other properties to this item by using the Properties pane.

ShapeType Property modes:

  • Ellipse
  • Vertical Line
  • Horizontal Line
  • Slant Line
  • BackSlant Line
  • Triangle
  • Square
  • Pentagon
  • Hexagon
  • Octagon
  • 3-ray star
  • 4-ray star
  • 5-ray star
  • 6-ray star
  • 8-ray star
  • Top Arrow
  • Bottom Arrow
  • Left Arrow
  • Right Arrow
  • Cross

See Also

Reference

Shape
ShapeType
Stretch

Other Resources

Using Styles to Customize Reports


SubReport

[image]

Telerik Reporting Q2 2012
SubReport
See Also Send Feedback

The SubReport report item lets you display one report within another report. It is a container item just like the report sections and grows depending on its children. The screenshot shows a SubReport report item at design-time. This allows you to compose complex reports from disparate report sources. The data for each SubReport can be completely different. For example you could combine a product listing, a sales summary and a list of sales people each in their own sub reports, with each sub report getting data from a different source. You can also pass parameters to SubReports using the Edit Parameters collection editor.

Caution

Data Items cannot be used in page sections, because the latter are processed after the report data has been processed. At this moment the report data source is not available anymore.

Caution

Page sections are not related to the report itself, but are relative to the paper or screen. Thus page sections of nested/detail reports are ignored and only the page sections of the main report are visible.

In order to have sections that repeat on every page similar to page sections, consider using an unbound group (no grouping criteria specified) and set the PrintOnEveryPage property of its sections to True. Be aware that you cannot use PageCount and PageNumber global objects in group sections.

Passing Parameters to a SubReport

To setup parameters for a SubReport click the ellipses of the Parameters property. Each parameter consists of a Parameter Name and Parameter Value.

Click the New button to add a parameter. Assuming you have assigned the ReportSource property the Parameter Name drop down list will contain the names of parameters defined in the report. Select a Parameter Name from the combobox to set the target for this parameter. Parameter Value combobox allows you to enter value directly, create an "<Expression>" or a "<New Report Parameter>".

SubReport Height Issues

To remove blank vertical space in the detail section of a SubReport, set the Height of the SubReport.ReportSource DetailSection to the height of the tallest item. Sections can grow to accommodate their children but cannot shrink to hide empty space. If you want the detail section to shrink only at runtime you can set the Height property of the DetailSection in the report constructor. Place the Height property assignment code just after the IntializeComponent() method call.

See Also

Reference

SubReport
ReportSource


How-To: Creating Master-Detail Reports Using SubReports

[image]

Telerik Reporting Q2 2012
How-To: Creating Master-Detail Reports Using SubReports
Send Feedback

The following walk through demonstrates how to create a Master-Detail report using a SubReport report item to contain detail data. The master report data in this example consists of product categories from the AdventureWorks database. The detail report displays product names and numbers. A Report Parameter is used to filter the detail report on product category.

Create the Detail Report

  1. Create a new class library named "MasterDetail" to contain the reports.

  2. Add a new Telerik Report item to the project and name it DetailReport.

  3. The Report Wizard will display automatically, cancel it. Click on the report selector (upper left corner of design surface) to select the report.

  4. Navigate to its DataSource property, open it, select "Add New Data Source" and select SqlDataSource Component.
  5. Setup the data connection to the AdventureWorks database, save it so it can be used later when creating the master report and click Next. Enter the following SQL statement and Finish the DataSource wizard.
    CopySQL
    SELECT
    P.Name,ProductID,ProductNumber,PC.ProductCategoryID
FROM
    Production.Product P,
    Production.ProductSubcategory PS,
    Production.ProductCategory PC
WHERE
    P.ProductSubcategoryID=PS.ProductSubcategoryID
    AND PS.ProductCategoryID=PC.ProductCategoryID
  6. Remove the page header and page footer sections. Open the Data Explorer and add the ProductNumber and Name fields to the detail section of the report.

The detail report should now look something like this in the designer.

Configure the Report Parameter and Filter

This next set of steps creates a report parameter and a filter that uses the report parameter. The master report passes in the current ProductCategoryID for each record and the detail report prints all products that have that ProductCategoryID.

  1. In the Property Window navigate to the ReportParameters property and click the ellipses.
  2. In the ReportParameter Collection Editor click the Add button. In the Name property for the parameter enter ProductCategoryID. Enter zero for the Value property.

  3. In the Property Window navigate to the Filters property and click the ellipses.
  4. Click the New button to create a new filter. In the Expression drop down for the filter select =Fields.ProductCategoryID. Leave the operator at the default equals ("=") sign. In the Value property drop down select the report parameter we created in earlier step: =Parameters.ProductCategoryID.Value.

  5. Click the OK button to close the dialog.

Create the Master Report

The master report will contain only a simple listing of product categories.

  1. Add a new report item to the project and name it MasterReport.
  2. The Report Wizard will display automatically, select New Report.
  3. On Choose Data Source page of the wizard, click Add New Data Source button and select SqlDataSource Component. On the Choose Your Data Connection page of the wizard, select the saved database connection you created for the detail report. Click the Next button.
  4. Enter the SQL statement below and click the Next button.
    CopySQL
    SELECT ProductCategoryID,Name FROM Production.ProductCategory
  5. In the Design Data Layout page of the wizard add the Name column to the detail section and click the Next button. Continue taking the defaults until you finish the Wizard.

Configure the SubReport

This next set of steps ties both reports together using a SubReport to display the detail and passing the current ProductCategoryID from each record of the master report to the detail. The detail report uses the parameter to filter the data to only products for the specified product category.

  1. Resize the detail section to create some vertical room for a SubReport item.
  2. Drag a SubReport from the Toolbox to the detail section of the report.
  3. In the Properties Window for the SubReport, open the ReportSource dialog, select Instance Report Source and set it to the DetailReport.
  4. Click the Edit Parameters button that would display the Edit Parameters dialog.
  5. Click the New button to define a parameter.
  6. Set the Parameter Name to ProductCategoryID and the parameter value to =Fields.ProductCategoryID.
  7. Click the OK button to close the parameters dialog and click OK once again to close the Report Source dialog.

    Click the Preview button to preview the MasterReport. Notice that product numbers and names from the detail report display under each product category from the master report.


TextBox

[image]

Telerik Reporting Q2 2012
TextBox
See Also Send Feedback

The TextBox report item is used to display text on a report. This screenshot shows two TextBox report items.

TextBox can display literal text for titles, descriptions, and labels, or dynamic text based on expressions. Every cell in a Table, List or CrossTab also contains a TextBox, which can be formatted in the same way as stand-alone TextBoxes in your report. The expressions in a TextBox can contain literal text, point to a database field or calculate data.

Use a Panel item when you want to control the TextBox layout and dependency with other report items. For more information, see Panel.

In order to format separate chunks of text (i.e. different words) or insert HTML-formatted text into a report, use the HtmlTextBox report item.

Growing and Shrinking

By default, TextBoxes are a set size. If you want to allow a TextBox to expand vertically based on its contents, set the CanGrow property to True (default value). If you want to allow a TextBox to shrink based on its contents set the CanShrink property to True (default value is False). The TextBox would always grow to accomodate the first line of text even when CanGrow is False.

TextBox Orientation

You can use the Angle property to change the text orientation in a TextBox. Orienting TextBoxes can help you create more readable reports, support locale-specific text orientation, fit more columns on a printed report that has fixed page size, and create reports with more graphical appeal.

Formatting Considerations

Before you apply a format, you should consider the following:

  • By default, numbers are formatted to reflect the cultural settings on the client computer. Use formatting strings to specify how numbers are displayed so that formatting is consistent regardless of where the person who is viewing the report is located.
  • The formats provided on the Number page are a subset of the .NET Framework standard numeric format strings. To format a number or date using a custom format that is not shown in the dialog box, you can use any .NET Framework format strings for numbers or dates. For more information about custom format strings, see the Formatting Types topic on MSDN.
  • If a custom format string has been specified, it has a higher priority over default settings that are culture-specific. For example, suppose you set a custom format string of "#,###" to show the number 1234 as 1,234. This may have different meaning to users in different parts of the world. Before specifying a custom format, consider how the chosen format will affect users of different cultures viewing the report.
  • If you specify an invalid format string, it will override the actual Value.

See also Format Builder Dialog.

Using In-place editing

The in-place editor for TextBox report items allows you to quickly enter text directly into the designer where the report item is rather than having to go look for a property in the Property Window. To activate the in-place editor, double-click the TextBox report item or select the report item and press F2. Once the in-place editor is activated:

  • CTRL-Enter creates a new line.
  • Enter accepts all changes.
  • Esc discards all changes.
  • Moving focus away from the TextBox also accepts all changes.

The screenshot below shows a TextBox with the in-place editor active.

In Place Editor

Using Expression editor

Information on using the expression editor is available in the Edit Expression Dialog article.

Note

Pressing the Enter key inserts a new paragraph or new list item depending on the current context. Note that it does NOT insert <br /> (new line). To insert new line, use the button on the toolbar)

Embedded expressions

The item supports embedded expressions for mail merge functionality. Embedded expressions give you the freedom to get and insert data-driven information directly into the text box report item to produce customized reports and mail merging.

See Also

Reference

TextBox
Angle
Format
HtmlTextBox

Other Resources

Using Styles to Customize Reports


HtmlTextBox

[image]

Telerik Reporting Q2 2012
HtmlTextBox
Send Feedback

The HtmlTextBox report item allows developers to insert HTML-formatted text into a report. You can specify the HTML value at design time (either through a WYSIWYG editor or through an expression editor), or retrieve it from a data source using any simple or complex expression that evaluates to correctly formatted HTML.

You can define colors, fonts, and other behavior on any subset of text within a single HtmlTextBox to create a mail merge or template for text in your report. You can also use multiple paragraphs inside a single text box. You can also set an alignment value for any individual string of text.

Note

Known Limitations:

  • The HtmlTextBox works with the text formatting options only.
  • The HtmlTextbox is rendered as plain text with no formatting in Excel.
  • RTL (Right to Left) is not supported.
  • HyperLink (<A> tag) is interactive (acts as actual hyperlink) under HTML rendering extension only.
  • Any limitations of the HtmlTextBox in specific export formats are reflected in the respective topic in the Design considerations for Report Rendering help section.

Supported HTML tags

Various formatting options are available to control the text presentation:

  • Font, size (relative size against the font size of the item, default is 3 (1-7)), color (<FONT>)
  • Bold, Italic, Underline (<STRONG>,<B>, <EM>, <I>, <U>)
  • HyperLink (<A href target>)
  • Lists (<OL>, <UL>, <LI>)
  • Organize the text in paragraphs (<DIV>, <SPAN>,<P>, <BR>, <CENTER>)

Supported css attributes

  • background-color
  • border-color, border-width, border-style
  • text-align (center, left and right only), text-indent
  • font-family, font-size, font-weight
  • padding, padding-bottom, padding-top, padding-right, padding-left
  • color
Note

When you import text that contains HTML markup, the data is always parsed by the HtmlTextBox first. Because only a subset of HTML tags is supported, the HTML that is shown in the rendered report may differ from your original HTML.

Also according to the HTML specification (and the general XML specification as well) the "&", "<" and ">" characters are considered special (markup delimiters), so they need to be encoded in order to be treated as regular text. For example the "&" character can be escaped with the "&amp;" entity. More information on the subject you can find in this w3.org article.

Any other HTML markup tags will be ignored during report processing. If the HTML represented by the expression in the HtmlTextBox is not well formed, the HtmlTextBox would throw an exception. All HTML tags are case-insensitive.

Growing and Shrinking

By default, HtmlTextBoxes are a set size. If you want to allow an HtmlTextBox to expand vertically based on its contents, set the CanGrow property to True (default value). If you want to allow a TextBox to shrink based on its contents set the CanShrink property to True (default value is False). The HtmlTextBox would always grow to accomodate the first line of text even when CanGrow is False.

Embedded expressions

The item supports embedded expressions for mail merge functionality. Embedded expressions give you the freedom to get and insert data-driven information directly into the text box report item to produce customized reports and mail merging.

After the expression evaluation/replacement, the value of the HtmlTextBox must be valid XHTML.

Editing

The HtmlTextBox supports data-driven in-line fields, which are editable either in-place or through design time editor, available directly in Visual Studio.

The in-place editor for the HTML text box report item (as with the TextBox item) allows you to quickly enter text directly into the designer where the report item is rather than having to go look for a property in the property grid. To activate the in-place editor, double-click the HtmlTextBox or select it and press F2. Once the in-place editor is activated:

  • Enter accepts all changes.
  • Esc discards all changes.
  • Moving focus away from the HtmlTextBox also accepts all changes.

The screenshot below shows an HtmlTextBox with the in-place editor active.

The design time editor supports two modes:

  1. Interactive (word-like editor) - you can select portion of the text and make it bold, change the font, etc. using appropriate controls like comboboxes and buttons (WYSIWYG editor). Internally the designer generates valid HTML source and stores it in the Value property of the item. Adding embedded expressions is possible, however the whole html value cannot be an expression. You can switch to source mode at any time if needed.
    Note

    Pressing the Enter key inserts a new paragraph or new list item depending on the current context. Note that it does NOT insert <br /> (new line). To insert new line, use the button on the toolbar)

  2. Expression (source editor) - the user enters raw HTML tags and text. The value can be expression or text containing embedded expressions. The user can switch to Interactive mode unless the value is an expression.
Note

MultiLine and TextWrap concepts are always true for HtmlTextBox.


XHTML Validation

[image]

Telerik Reporting Q2 2012
XHTML Validation
Send Feedback

The HtmlTextBox requires valid XHTML and you should make sure you provide such otherwise the HtmlTextBox would throw exception. To handle this exception or just check whether the HtmlTextBox would be able to handle the content you set as value, you should use the IsValidXHTML method of the HtmlTextBox processing instance. Three possible approaches are listed below:

Validate Xhtml Using Event And IsValidXhtml

Use the IsValidXhtml inside the HtmlTextBox ItemDataBinding handler:

CopyC#
const string validXhtml = "<b>valid xhtml</b>.";
const string systemXhtml = "Provided html is not acceptable.";

Telerik.Reporting.HtmlTextBox txt = new Telerik.Reporting.HtmlTextBox();
txt.ItemDataBinding += delegate(object sender, EventArgs args)
    {
        Telerik.Reporting.Processing.HtmlTextBox procTxt = (Telerik.Reporting.Processing.HtmlTextBox)sender;
        if (procTxt.IsValidXhtml(validXhtml))
        {
            procTxt.Value = validXhtml;
        }
        else
        {
            procTxt.Value = systemXhtml;
        }
    };
CopyVB.NET
    Dim txt As New Telerik.Reporting.HtmlTextBox()
    AddHandler txt.ItemDataBinding, AddressOf MyEventHandler

Const validXhtml As String = "<b>valid xhtml</b>."
Const systemXhtml As String = "Provided html is not acceptable."

Private Sub MyEventHandler(ByVal sender As Object, ByVal e As EventArgs)
    Dim procTxt As Telerik.Reporting.Processing.HtmlTextBox = DirectCast(sender, Telerik.Reporting.Processing.HtmlTextBox)
    If procTxt.IsValidXhtml(validXhtml) Then
        procTxt.Value = validXhtml
    Else
        procTxt.Value = systemXhtml
    End If
End Sub

Validate Xhtml Using IsValidXhtml in Expression

Use the IsValidXhtml inside the HtmlTextBox Expression:

CopyC#
const string validXhtml = "<b>valid xhtml</b>.";
const string systemXhtml = "Provided html is not acceptable.";

Telerik.Reporting.HtmlTextBox txt = new Telerik.Reporting.HtmlTextBox();
txt.Value = string.Format("=Iif(ReportItem.IsValidXhtml('{0}'), '{0}', '{1}')", validXhtml, systemXhtml);
CopyVB.NET
Const validXhtml As String = "<b>valid xhtml</b>."
Const systemXhtml As String = "Provided html is not acceptable."

Dim txt As New Telerik.Reporting.HtmlTextBox()
txt.Value = String.Format("=Iif(ReportItem.IsValidXhtml('{0}'), '{0}', '{1}')", validXhtml, systemXhtml)

Validate Xhtml Using Event And ValueError

Use a try-catch block to handle the exception:

CopyC#
const string invalidXhtml = "<b>invalid xhtml.";
const string systemXhtml = "Provided html is not acceptable.";

Telerik.Reporting.HtmlTextBox txt = new Telerik.Reporting.HtmlTextBox();
txt.ItemDataBinding += delegate(object sender, EventArgs args)
    {
        Telerik.Reporting.Processing.HtmlTextBox procTxt = (Telerik.Reporting.Processing.HtmlTextBox)sender;
        try
        {
            procTxt.Value = invalidXhtml;
            // html that will not be accepted
        }
        catch (Exception)
        {
            procTxt.Value = systemXhtml;
        }
    };
CopyVB.NET
    Dim txt As New Telerik.Reporting.HtmlTextBox()
    AddHandler txt.ItemDataBinding, AddressOf ValueErrorHandler

Const invalidXhtml As String = "<b>invalid xhtml."
Const defaultXhtml As String = "Provided html is not acceptable."

Private Sub ValueErrorHandler(ByVal sender As Object, ByVal e As EventArgs)
    Dim procTxt As Telerik.Reporting.Processing.HtmlTextBox = DirectCast(sender, Telerik.Reporting.Processing.HtmlTextBox)
    Try
        ' html that will not be accepted
        procTxt.Value = invalidXhtml
    Catch generatedExceptionName As Exception
        procTxt.Value = defaultXhtml
    End Try
End Sub


Using HTML from Telerik RadEditor

[image]

Telerik Reporting Q2 2012
Using HTML from Telerik RadEditor
Send Feedback

The HtmlTextBox works with text formatting options only (a subset of HTML tags and CSS attributes), which are available for the sole purpose of styling labels and headers. The unsupported tags/css attributes have to be filtered in order to avoid exceptions. The purpose of this article is to outline how to accomplish this when the HTML data entry tool is RadEditor for ASP.NET AJAX.

Two things should be considered:

  • limit the options in the RadEditor's toolbar
  • Allowing plain text only. RadEditor can automatically do this for you by stripping all HTML tags), because even if you limit the toolbar to certain actions only, pasting rich-text will still be available by default.
Here are the exact steps taken:
  1. Use the markup below for your ToolsFile.xml file
    CopyXML
    <?xml version="1.0" encoding="utf-8" ?>
<root>
  <modules>
    <module name="RadEditorStatistics" dockingZone="Bottom"/>
    <module name="RadEditorDomInspector" visible="false" />
    <module name="RadEditorNodeInspector" visible="false" />
    <module name="RadEditorHtmlInspector"  visible="false" />
  </modules>
  <tools name="MainToolbar">
    <tool name="Print" shortcut="CTRL+P"/>
    <tool name="AjaxSpellCheck"/>
    <tool name="FindAndReplace" shortcut="CTRL+F"/>
    <tool name="Cut" />
    <tool name="Copy" shortcut="CTRL+C"/>
    <tool name="Paste" shortcut="CTRL+V"/>
    <tool separator="true"/>
    <tool name="Undo" shortcut="CTRL+Z"/>
    <tool name="Redo" shortcut="CTRL+Y"/>
  </tools>
  <tools name="InsertToolbar" >
    <tool name="DocumentManager" />
    <tool separator="true"/>
    <tool name="LinkManager" shortcut="CTRL+K"/>
    <tool name="Unlink" shortcut="CTRL+SHIFT+K"/>
  </tools>

  <tools>
    <tool name="ForeColor"/>
    <tool name="BackColor"/>
    <tool name="FormatStripper"/>
  </tools>

  <tools>
    <tool name="FontName" shortcut="CTRL+SHIFT+F"/>
    <tool name="FontSize" shortcut="CTRL+SHIFT+P"/>
    <tool separator="true"/>
    <tool name="Bold" shortcut="CTRL+B"/>
    <tool name="Italic" shortcut="CTRL+I"/>
    <tool name="Underline" shortcut="CTRL+U"/>
    <tool separator="true"/>
    <tool name="JustifyLeft" />
    <tool name="JustifyCenter" />
    <tool name="JustifyRight" />
    <tool separator="true"/>
    <tool name="InsertOrderedList" />
    <tool name="InsertUnorderedList" />
    <tool name="SelectAll" shortcut="CTRL+A"/>
  </tools>
</root>
  2. Since the inline text-decoration css property is not supported, disable the FixUlBoldItalic filter:
    CopyC#
    RadEditor1.DisableFilter(Telerik.Web.UI.EditorFilters.FixUlBoldItalic);
    CopyVB.NET
    RadEditor1.DisableFilter(Telerik.Web.UI.EditorFilters.FixUlBoldItalic)
  3. Since HtmlTextBox works with font tags, disable the ConvertFontToSpan filter, which converts the non XHTML compliant Font tags with Span tags
    CopyC#
    RadEditor1.DisableFilter(Telerik.Web.UI.EditorFilters.ConvertFontToSpan);
    CopyVB.NET
    RadEditor1.DisableFilter(Telerik.Web.UI.EditorFilters.ConvertFontToSpan)
  4. Strip the HTML formatting from pasted content, because the user could paste non well formed content which could break the HtmlTextBox and the export to PDF feature. To do that set the StripFormattingOptions property to "All" or "AllExceptNewLines".
  5. Use the following custom content filter, which will remove unsupported HTML tags. Supported tags are: FONT, STRONG, B, EM, I, U, A, OL, UL, LI, DIV, SPAN, P, BR, CENTER.
    CopyXML
    <telerik:RadEditor ID="RadEditor1" StripFormattingOptions="AllExceptNewLines" ToolsFile="~/HtmlTextBoxToolsFile.xml" OnClientLoad="editorLoaded" runat="server">
</telerik:RadEditor>
    CopyJavaScript
    <script type="text/javascript">
      ReportingFilter = function()
{
    ReportingFilter.initializeBase(this);
    this.set_isDom(false);
    this.set_enabled(true);
    this.set_name("ReportingFilter");
    this.set_description("Telerik Reporting HTML filter for RadEditor");
}
ReportingFilter.prototype =
{
    getHtmlContent: function (content) {
        return this._removeHtmlTags(content);
    },

    getDesignContent: function (content) {
        return this._removeHtmlTags(content);
    },

    _removeHtmlTags: function (initContent) {
        var cleanContent;

        //Perform necessary REGEX replacement to remove unsupported HTML tags
        //Supported Reporting HTML tags: FONT, STRONG, B, EM, I, U, A, OL, UL, LI, DIV, SPAN, P, BR, CENTER
        //HTML must be XHTML valid, too, but Editor already provides that filter

        //Following REGEX will remove all HTML tags EXCEPT those expliclitly listed
        cleanContent = initContent.replace(new RegExp("<(?!\/?(font|strong|b|em|(i(?!mg))|u|a|ol|ul|li|div|span|p|br|center)(?=>|\s?.*>))\/?.*?>", "ig"), "");

        return cleanContent;
    }
}
ReportingFilter.registerClass('ReportingFilter', Telerik.Web.UI.Editor.Filter);

 function editorLoaded(editor, args)
        {
           editor.get_filtersManager().add(new ReportingFilter());
        }
</script>
  6. The ConvertToXhtml filter should be enabled (default state).


Table/Crosstab/List

[image]

Telerik Reporting Q2 2012
Table/Crosstab/List
Send Feedback

The Table report item is a separate data region and does not make use of the report's data source. It has its own Table..::.DataSource property which you have to set in order to populate the item with data.

Use the table to display fields from a dataset either as detail data or as grouped data in a grid or free-form layout. Telerik Reporting provides three items that can be used as templates and you can add them directly from the Toolbox: table, crosstab, and list.

OverView

  • Table: Use a table item to display detail data, organize the data in row groups, or both. The Table contains three columns with a table header row and a details row for data. The following figure shows the initial table template, selected on the design surface:
  • CrossTab: Use a CrossTab template to display aggregated data summaries, grouped in rows and columns. The number of rows and columns for groups is determined by the number of unique values for each row and column groups. The following figure shows the initial crossTab template, selected on the design surface:
  • List: Use a list item to create a free-form layout. You are not limited to a grid layout, but can place fields freely inside the list. You can use a list to design a form for displaying many dataset fields or as a container to display multiple data regions side by side for grouped data. For example, you can define a group for a list; add a table, chart, and image; and display values in table and graphic form for each group value.

Of course, you are not limited to your initial template choice. As you add groups, totals, and labels, you may find you want to modify your table design. For example, you might start with a table and then delete the details row and add column groups.

You can continue to develop a Table, crossTab, or List by adding any table feature. Table features include displaying detail data or aggregates for grouped data on rows and columns. You can create nested groups, independent adjacent groups, or recursive groups. You can filter and sort grouped data, and easily combine groups by including multiple group expressions in a group definition.

Caution

Data Items cannot be used in page sections, because the latter are processed after the report data has been processed. At this moment the report data source is not available anymore.

Context Menu

When you have clicked on a table/crosstab/list cell, you've selected a textbox item. Although this is standard textbox report item, when it is in the context of a table/crosstab/list item, its context menu would show settings for the table item besides the usual attributes it shows. To see an option you need to click either on an item or on the row/column handlers (the gray rectangles appearing when the whole table item is selected). The context menu is functionally dependent on where exactly you've clicked and offers possible actions that are allowed and you can take (see image below).

The Groups can be Parent, Child and Adjacent according to the hierarchy level. However when it comes to row/column operations they're referred to as inside and outside group i.e. a static row/column is added inside or outside of the current group.

When you select several cells which belong to a single dynamic (or static) group, then the context menu would show Merge Cells option. Once cells from a single group are merged they can be later split by selecting the merged cell and choosing Split Cells from the menu.

Table Group Editor

Choosing a dynamic group from the Group Explorer, shows a context menu which allows you to alter the properties of the selected group. Choosing Group properties option, would open a "Edit Table Group" dialog from which you can control Filters, Grouping and Sorting along with specifying GroupKeepTogether.

In This Section

Basic concepts

Understanding CrossTab areas

Understanding table cells, rows and columns


Basic concepts

[image]

Telerik Reporting Q2 2012
Basic concepts
Send Feedback

The Table is a generalized layout report item that displays report data in cells that are organized into rows and columns. Report data can be detail data as it is retrieved from the data source, or aggregated detail data organized into groups that you specify. Each table cell can contain any report item, including a TextBox, a PictureBox, Chart or another table item. To add multiple report items to a cell, first add a panel item, which acts as a container, and then add the report items to the panel.

The Table, CrossTab, and List report items are actually variations of the same thing optimized for a specific data layout. By default, a table item displays detail data in a grid layout, a CrossTab displays group data in a grid layout, and a list displays detail data in a free-form layout.

By default, each cell in a table or CrossTab contains a text box. The cell in a list contains a panel. You can replace a default report item with a different report item, for example, an image.

As you define groups for a table, CrossTab, or list, the report designer adds rows and columns to the Table on which to display grouped data.

In order to understand these report items, you should first understand the following:

  1. What is the difference between detail and grouped data.
  2. Groups organized as members of group hierarchies on the horizontal axis are row groups and on the vertical axis are column groups.
  3. What is the purpose of table cells in the four areas of a CrossTab data region: the body, the row group headers, the column group headers, and the corner.
  4. Static and dynamic rows and columns and how they relate to groups.

Once you understand these concepts, you can recognize the structure that the report designer adds for you and modify the structure to suit your own needs.

Understanding Detail and Grouped Data

Detail data is all the data from a report data source as it comes back from the data source. Detail data is essentially what you see in the query designer results pane when you run a database query. The actual detail data includes, and is restricted by filters set on the data source, data region, and details group. You display detail data on a detail row by using a simple expression such as =Fields.ProductCategory. When the report runs, the detail row repeats once for each row in the query results at run time.

Grouped data is detail data that is organized by a value that you specify in the group definition, for example, =Fields.ProductCategory. You display grouped data on group rows and columns by using simple expressions that aggregate the grouped data, for example, =Sum(Fields.Quantity).

Understanding Group Hierarchies

Groups are organized as members of group hierarchies. Row group and column group hierarchies are identical structures on different axes. Think of row groups as expanding down the page and column groups as expanding across the page.

A tree structure represents nested row and column groups that have a parent/child relationship, for example, a category with sub categories. The parent group is the root of the tree and child groups are its branches. Groups can also have an independent, adjacent relationship, for example, sales by territory and sales by year. Multiple unrelated tree hierarchies are called a forest. In a Table, row groups and columns groups are each represented as an independent forest.

Understanding the Table item

A table has four areas for cells: corner, row group hierarchy, column group hierarchy, and table body, which always exists. The other areas are optional. Cells in table body area display detail and group data.

Cells in the Row Groups area are created automatically when you create a row group. These are row group header cells and display row group instance values by default. For example, when you group by =Fields.ProductCategory, group instance values are the individual sales orders that you are grouping by.

Cells in the Column Groups area are created automatically when you create a column group. These are column group header cells and display column group instance values by default. For example, when you group by =Fields.Year, group instance values are the individual years that you are grouping by.

Cells in the table corner area are created automatically when you have both row groups and column groups defined. For more info see Understanding Table areas.

Understanding Static and Dynamic Rows and Columns

A table item organizes cells in rows and columns that are associated with groups. Because group structures for row groups and columns are identical, we would talk about row groups. You can apply the same concepts to column groups.

A row is either static or dynamic. A static row is not associated to a group. When the report runs, a static row renders once. Table headers and footers are static rows. Static rows display labels and totals.

A dynamic row is associated to one or more groups. A dynamic row renders once for every unique group value for the innermost group. Cells in a dynamic row are scoped to the innermost row group and column group to which the cell belongs.

Dynamic detail rows are associated with the details group that is automatically created when you add a table or list to the design surface. By definition, the details group is the innermost group for a table. Cells in detail rows display detail data.


Understanding CrossTab areas

[image]

Telerik Reporting Q2 2012
Understanding CrossTab areas
Send Feedback

A CrossTab item has four areas that contain table cells: corner, row group, column group and body. Cells in each area have a distinct function. You add cells to the body area to display detail and grouped data. The report designer adds cells to the row group or column group area when you create a group in order to display group instance values. The corner cells are created when both row groups and column groups exist.

The following figure shows the areas for a CrossTab with nested row groups based on ProductCategory and ProductSubCategory, nested column groups based on OrderDate.Year.

The following list describes each area:

  • Corner area. (Optional) A CrossTab corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a CrossTab. In this area, you can merge cells and add a label or embed another report item. In the figure, the corner display the AdventureWorks logo.
  • Column groups area. (Optional) CrossTab column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values. In the figure, the cell that displays OrderDate.Year is column group. The columns Total and Grant Total displays the aggregated totals across each row. It can be repeated on every page that the table spans vertically on by setting the ColumnHeadersPrintOnEveryPage to true.
  • Row groups area. (Optional) CrossTab row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values. In the figure, the cells that display ProductCategory and ProductSubCategory are nested row groups. The Total row below ProductSubCategory repeats with each category group to show the aggregated subtotals for each column. The grand total row shows the totals for all categories. It can be repeated on every page that the table spans horizontally on by setting RowHeadersPrintOnEveryPage to true.
  • Body area. The CrossTab body is located in the lower right corner and it displays detail and grouped data. In this example, only aggregated data is used. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the CrossTab body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group. In the figure, the cells display the aggregate totals and grand totals for line totals for all sales order.

When the report runs, column groups expand to the right for as many columns as there are unique values for a group expression. Row groups expand down the page. For more information see Understanding table cells, rows and columns.

The following figure shows the CrossTab in Preview.

The row group area displays group instances for ProductCategory (Accessories from the screenshot). The column group displays four year group instances for 2001, 2002, 2003 and 2004. The Total column row displays the row totals; the totals row that repeats with the category group shows productSubCategory totals, and the grand total row displays the category totals once for the crosstab.


Understanding table cells, rows and columns

[image]

Telerik Reporting Q2 2012
Understanding table cells, rows and columns
Send Feedback

To control how the rows and columns of a Table display data in a report, you must understand how to specify rows and columns for detail data, for group data, and for labels and totals. In many cases, you can use the default structures for a Table, CrossTab or List to display your data.

A Table displays detail data on detail rows and detail columns and grouped data on group rows and group columns. When you add row groups and column groups to a Table, rows and columns on which to display the data are automatically added. You can manually add and remove rows and columns to customize a Table and control the way your data displays in the report.

Displaying Data on Rows and Columns

Rows and row groups and columns and column groups have identical relationships. This discussion describes how to add rows to display detail and group data on rows in a Table, however the same principles apply to adding columns to display detail and grouped data.

For each row in a Table, a row is either inside or outside each row group. If the row is inside a row group, it repeats once for every unique value of the group, known as a group instance. If the row is outside a row group, it repeats only once in relation to that group. Rows outside all row groups are static and repeat only once for the data region. For example, a table header or footer row is a static row. Rows that repeat with at least one group are dynamic.

When you have nested groups, a row can be inside a parent group but outside a child group. The row repeats for every group value in the parent group, but displays only once in relation to the child group. To display labels or totals for a group, add a row outside the group. To display data that changes for every group instance, add a row inside the group.

When you have detail groups, each detail row is inside the detail group. The row repeats for every value in the data source.

When detail data is displayed, the details group is the innermost child group. Rows that you add to a details group repeat once per row in the result set for the query.

For each column in a Table, the same principles apply i.e. a column is either inside or outside each column group; to display totals, add a column outside the group.

To remove rows and columns associated to a group - delete the group. Doing that you have the choice between deleting the group definition only or deleting the group and all its associated rows and columns. By deleting just the group, you preserve the row and column layout. When you delete the group and its related rows and columns, you are deleting all static rows and columns (including group headers and footers) and dynamic rows and columns (including group instances) that are associated with that group.

Understanding Table cells

Table cells belong to one of four Table areas: body, row or column group areas and corner. Although each cell can potentially display any value from the data source, the default function for each cell is determined by its location. For detailed information about Table areas, see Understanding CrossTab areas.

By default, cells in a Table row and column group areas represent group members. Group members are organized into multiple tree structures in the report definition. The row group hierarchy expands horizontally and the column group hierarchy expands vertically. These cells are added automatically when you create a group, and display the unique values for a group at run time.

Cells in the Table corner are created when there are both row and column group areas. You can merge cells in this area to create a label or embed another report item.

Cells in the Table body area can display detail data when the cell is in a detail row or column and aggregated group data when the cell is in a group row or column. The scope for the data in a cell is the intersection of the innermost row group and innermost column group to which the cell belongs.


Chart

[image]

Telerik Reporting Q2 2012
Chart
See Also Send Feedback

The Chart report item is used to display a chart on a report. It is business-oriented item with a focus on development productivity and ease-of-use. It allows you to rapidly build appealing charts that represent data in a people-friendly manner.

You can bind the Chart item:

  • From the Report Designer by setting its DataSource property
  • By using its NeedDataSource event
When you are in the event, you should work with the processing chart item i.e.:

CopyC#
private void chart1_NeedDataSource(object sender, System.EventArgs e)
{
    Telerik.Reporting.Processing.Chart procChart = (Telerik.Reporting.Processing.Chart)sender;
    procChart.DataSource = your_datasource;
}
CopyVB.NET
Private Sub chart1_NeedDataSource(sender As Object, e As System.EventArgs)
    Dim procChart As Telerik.Reporting.Processing.Chart = DirectCast(sender, Telerik.Reporting.Processing.Chart)
    procChart.DataSource = your_datasource
End Sub

The formatting of the Chart report item is managed by a large number of properties. To customize the Chart report item, right-click the chart and select Properties from the context menu to use the Chart Wizard.

The Chart item offers numerous features including:

  • 17 customizable chart types, available in both horizontal and vertical direction .
  • Automatic Text-wrapping- text elements in the chart can be wrapped automatically.
  • Databinding - Chart can be databound to various datasources
  • Chart wizard for quick and easy configuration.
  • Second Y axis - Chart provides a second scale of measurements.
  • Empty Values - allow approximating missing values between data points.
  • Scale Breaks make graphs with large amplitude easier to read.
  • Marked zones - Chart allows adding ranges to highlight certain areas of the chart.
  • Styling - Chart provides fine-grained control over its elements appearance.

See Also

Reference

Chart

Other Resources

Telerik Charting Documentation


Spline Areas

[image]

Telerik Reporting Q2 2012
Spline Areas
Send Feedback

The new Spline Area Charts take the Spline chart a step further. Like the Spline, the Spline Area takes a limited set of known data points and interpolates the intervening values. Then the area defined by the spline curve is filled in. You define one or more series of chart items, set the chart type to SplineArea, SplineStackedArea or StackedSplineArea100 and Chart does the rest.

You can see how the same data is presented using the new chart types. SplineArea displays from the back to the front, starting with the first series. StackedSplineArea adds each area to the next without covering previous areas. StackedSplineArea100 shows each area as a percentage contributing to the whole of a category.

Spline Area Charts


Empty Values

[image]

Telerik Reporting Q2 2012
Empty Values
Send Feedback

The Chart automatically approximates missing values between known data points, simply by setting the Empty property true on any chart series item. This works for bar, line and area based chart types. You also have complete control over the visual style of empty values. The empty value style can be articulated separately from the style for the main values.

Empty Values Approximation


Scale Breaks

[image]

Telerik Reporting Q2 2012
Scale Breaks
Send Feedback

The ScaleBreaks feature allows you to "break off" large chunks of the axis so that graphs with large amplitude are easier to read. ScaleBreaks are available for both YAxis and YAxis2 of the plot area. You can tailor the maximum number of breaks, the minimum interval between data points before a break can occur, the visual size of the breaks and the visual style of the breaks.

Scale Breaks


Multi-Line Labels

[image]

Telerik Reporting Q2 2012
Multi-Line Labels
Send Feedback

Labels in Chart can appear on multiple lines. The property editor for TextBlock.Text properties allows you to hit the enter key to start a new line. Press control-enter to accept the text and close the property editor.

Multi-Line Labels


Intelligent Labels

[image]

Telerik Reporting Q2 2012
Intelligent Labels
Send Feedback

For charts that have many data points or data points with values close to one another, labels tend to collide making readability a problem. The Intelligent Labels feature of Chart automatically re-aligns labels making each labeled value stand out clearly.


Strict Mode

[image]

Telerik Reporting Q2 2012
Strict Mode
Send Feedback

Strict Mode

The Chart bar series now features "strict mode". This is not a property or setting, but a behavior of bar chart series where X values are respected and bars are positioned according to their XValues. If there are no series items with XValues then Chart resumes standard sequential ordering of each item. The screen shot above was produced using the following X and Y values:

Series 1

YValue | XValue
3 | 0
3 | 1
4 | 3
3 | 3
5 | 4

Series 2

YValue | XValue
1 | 5
2 | 4


Marked Zones

[image]

Telerik Reporting Q2 2012
Marked Zones
Send Feedback

PlotArea MarkedZones are ranges that can be labeled and filled to highlight areas of the chart or to visually group data. The MarkedZones property by default display behind the chart series. You can create any number of members for the MarkedZones collection and each marked zone is defined by a starting and ending X and Y value pairs. You can also control the labeling and appearance for each zone independently.

Chart with MarkedZones


Populate Chart Data
Send Feedback

Populate Chart Data

  1. Click the ellipses for the Chart Series Collection.
  2. Click "Series 1" in the members list on the left, then locate the Name property in the property window.
  3. Change the Name property to "Sales" and the DefaultLabelValue to "#ITEM". Name will be the series name that shows up in the legend. DefaultLabelValue will display the name of each item in the series instead of the item value.
  4. Locate the Items property in the property window.
  5. Click the ellipses button of the Items property to open the ChartSeriesItem Collection Editor.
  6. Click the Add button to add a new Item.
  7. In the property window for the new item, change the Name property to "Beverages".
  8. Change the YValue property to "10000".

    Adding Chart Series Item Values and Labels

  9. Repeat the Add Item steps to add 3 new items.
  10. Replace the properties for the three new items as follows
    • Label=Produce, YValue =7500
    • Label=Poultry, YValue =9000
    • Label=Grains, YValue =11200
  11. Click OK to close the ChartSeriesItem Collection Editor.
  12. Click "Series 2" in the ChartSeries Collection Editor.
  13. Click the Remove button to remove Series 2.
  14. Click the OK button to close the ChartSeries Collection Editor.
  15. The chart will display the new data using the default formatting.


Format the Chart
Send Feedback

Format the Chart

  1. Invoke the Chart Wizard by selecting the Chart properties menu.
  2. Click the Axis Tab.
  3. Locate the Visual Properties section of the Axis tab.
  4. On the Select Axis drop down list select the X Axis. In the Axis Title entry enter "Product Categories". Un-check Show Ticks to remove the tick marks from the bottom of the chart.

  5. On the Select Axis drop down list select the Y Axis. Un-check Show Ticks to remove the tick marks on the left hand side of the chart.

    Setting Axis Properties

  6. Click the Labels, Legend & Title tab
  7. Locate the Legend section.
  8. Uncheck the Visible check box. This will remove the Sales legend from the right side of the graph.

    Setting Legend Properties

  9. On the Skins tab select the Deep Blue skin.

  10. Click the OK button to close the wizard.
  11. In the properties window, locate PlotArea.XAxis.AxisLabel.TextBlock.Visible and set it to "True".

Run the application to view the finished chart. It should look like the screen shot shown below.


Chart Types Overview

[image]

Telerik Reporting Q2 2012
Chart Types Overview
Send Feedback

There are 17 chart types:

Chart Type | Description | When to use
Bar | Bar charts graphically display values in vertical and horizontal bars across categories. | Bar charts are useful for comparing multiple series of data (i.e. providing snapshots of data at particular points in time).
Stacked Bar | Stacked Bar charts are used to compare contributions of values to a total across categories | Use the Stacked Bar chart when you need visibility to the combined values for each category.
Stacked Bar 100% | Stacked Bar 100% shows the combined contribution of values as percentages where the combined total for each category is 100 percent. | Use when the relationship between values in a category is more significant than the amounts.
Pie | The Pie chart shows slices representing fractional parts of a whole. | When you need to display the contribution of fractional parts to a whole.
Gantt | Gantt charts, also known as Time charts, display separate events as bars along a time scale. | These charts are often used for project/time planning, where data can be plotted using a date-time scale or other numeric scale.
Bezier | The Bezier chart displays a series of points on a curved line. Two "control points" determine the position and amount of curvature in the line between end points | The Bezier chart is often used for data modelling by taking a limited number of data points and interpolating or estimating the intervening values.
Spline | Spline charts allow you to take a limited set of known data points and approximate intervening values. | The Spline chart, like the Bezier, is often used for data modelling by taking a limited number of data points and interpolating or estimating the intervening values.
Spline Area | The Spline Area chart type defines one or more spline curves and fills in the area defined by the spline. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type also emphasizes the area between the spline curve and a mid-point of the spline.
Stacked Spline Area | The Stacked Spline Area chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type allows the entire surface area for all sequences to be displayed at one time.
Stacked Spline Area 100% | The Stacked Spline Area 100% chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series and where the combined total for each category is 100 percent. | Also can be used for data modelling in that it takes a limited number of data points and interpolates the intervening values. This chart type allows the entire surface area for all sequences to be displayed at one time. Use this chart type when the relationship between values in a category is more significant than the amounts.
Point | Point or "Scatter" charts are used to show correlations between two sets of values. | The Point chart is often used for scientific data modeling or financial data. Typically not used used with time dependent data where a Line chart is more suited.
Bubble | The Bubble chart is an extension of the Point chart but each point can be a circle or oval of any size or dimension. The bubble size may be used to convey larger values. | The Bubble chart is often used for scientific data modeling or financial data.
Line | This chart type displays a set of data points connected by a line. | A common use for the line chart is to show trends over a period of time.
Area | The Area chart consists of a series of data points joined by a line and where the area below the line is filled | Area charts are appropriate for visualizing data that fluctuates over a period of time and can be useful for emphasizing trends.
Stacked Area | The Stacked Area chart is a variation of the Area chart that display trends of the contribution of each value over time (or across categories). The areas are stacked so that each series adjoins but does not overlap the preceding series. | Area charts are appropriate for visualizing data that fluctuates over a period of time and where the entire area for all series data must be visible at one time.
Stacked Area 100% | Stacked Areas 100% charts are a variation of Stacked Area charts that present values for trends as percentages, totaling to 100% for each category. | Use this chart type to visualize data that fluctuates over a period of time and where the relationship between values in a category is more significant than the amounts.
CandleStick | The CandleStick chart combines bar and line chart styles to show a range of value movement over time. Dark colored bars show downward trends, light colored bars show upward trends and the line through the center (the "wick") shows the extreme high and low values. | Use this chart type to visualize price or currency fluctuations. Typically this chart is used to analyze stock prices or currency changes.


Bar Charts

[image]

Telerik Reporting Q2 2012
Bar Charts
Send Feedback

Bar charts graphically summarize and display categories of data and let the user easily compare amounts or values between different categories. Bar charts are useful for comparing multiple series of data (i.e. providing snapshots of data at particular points in time). In the examples below the categories are various sources for sales (Internet, Wholesale, Retail) that combine to make the total sales for each quarter. Chart automatically displays each series in a different color to make them easier to distinguish.

To create a Vertical Bar Chart set the Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart Telerik.Reporting.Charting..::.ChartSeriesType to Bar.

Vertical Bar Chart

To create a Horizontal Bar Chart set the Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart Telerik.Reporting.Charting..::.ChartSeriesType to Bar.

Horizontal Bar Chart


Stacked Bar Charts

[image]

Telerik Reporting Q2 2012
Stacked Bar Charts
Send Feedback

Stacked bar charts are used to compare contributions of values to a total across categories. In the examples below the categories are various sources for sales (Internet, Wholesale, Retail) that combine to make the total sales for each quarter. Use the Stacked Bar chart when you need visibility to the combined values for each category.

To create a Vertical Stacked Bar Chart set the Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart Telerik.Reporting.Charting..::.ChartSeriesType to StackedBar.

Vertical Stacked Bar Chart

To create a Horizontal Stacked Bar Chart set the Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart Telerik.Reporting.Charting..::.ChartSeriesType to StackedBar.

Horizontal Stacked Bar Chart

Note

To display custom labeling on the X-Axis "Qtr 1", "Qtr 2", etc., set the Chart Telerik.Reporting.Charting..::.ChartAxis ChartAxis..::.AutoScale property to False. Use the Telerik.Reporting.Charting..::.ChartAxisItemsCollectionproperty and for each item set the Telerik.Reporting.Charting..::.TextBlock Text propertyto the desired label.


Stacked Bar 100% Charts

[image]

Telerik Reporting Q2 2012
Stacked Bar 100% Charts
Send Feedback

Stacked Bar 100 charts are used when you have three or more data series and want to compare distributions within categories, and at the same time display the differences between categories. Each bar represents 100% of the amounts for that category.

To create a Vertical Stacked Bar 100 Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Telerik.Reporting.Charting..::.ChartSeriesType to StackedBar100.

Vertical Stacked Bar 100 Chart

To create a Horizontal Stacked Bar Chart set the Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or Telerik.Reporting.Charting..::.ChartSeriesType to StackedBar100.

Horizontal Stacked 100 Chart

To display the label values as percentages, change the ChartSeries..::.DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


Pie Charts

[image]

Telerik Reporting Q2 2012
Pie Charts
Send Feedback

Pie charts are used to display the contribution of fractional parts to a whole. A Pie chart uses a single series of data. Multiple series of data can be defined and are each displayed in a separate pie chart.

You can tailor the look of each pie slice individually by working with the pie chart series Appearance ChartSeries..::.Appearance property:

  • You can "explode" (i.e. offset) a single slice of the pie to emphasize a portion of the data by setting the pie chart series item Appearance.Exploded StyleSeriesItem..::.Exploded property to true.
  • The Appearance.FillStyle StyleSeriesItem..::.FillStyle FillSettings Telerik.Reporting.Charting.Styles..::.FillSettings property allows you to set the fill for each slice to Solid, Gradient, ComplexGradient, Hatch or Image. You also have control over gradients (colors, direction and angle), images (alignment, orientation), colors and shadows.
  • Control the label format and appearance for each slice using the pie chart series item Label Telerik.Reporting.Charting..::.SeriesItemLabel property. The Label. TextBlock Telerik.Reporting.Charting..::.TextBlock .Text can make use of built-in formats, such as "#Y" to show the values for the Y axis or "#%" to show the percentage value of a slice. The figure below uses a format similar to "Qtr 1 - #%".

To create a Pie chart set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType Pie.

Pie chart with a single series

Pie Chart with two series


Gantt Charts

[image]

Telerik Reporting Q2 2012
Gantt Charts
Send Feedback

Gantt charts help visualize time based information. Gantt charts, also known as Time charts, display separate events, with a beginning and an end. These charts are often used for project/time planning, where data can be plotted using a date-time scale or a numerical scale.

To create a vertical Gantt Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Gantt.

Gantt chart

To create a horizontal Gantt Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Gantt.

Horizontal Gantt Chart

Other Gantt chart issues:

  • To add dates to an axis or chart item, values must be converted to OleAutomation types. Use the DateTime ToOADate() function for this purpose.
  • When setting a range for an axis that involves dates, set the axis IsZeroBased ChartAxis..::.IsZeroBased property to zero. This avoids having the range calculated from the minimum date value forward, instead of a range you define.
  • Use the ValueFormat Telerik.Reporting.Charting.Styles..::.ChartValueFormat property to display values as dates.
CopyC#
    RadChart1.PlotArea.YAxis.Appearance.ValueFormat =
Telerik.Reporting.Charting.Styles.ChartValueFormat.ShortDate;
CopyVB.NET
RadChart1.PlotArea.YAxis.Appearance.ValueFormat = Telerik.Reporting.Charting.Styles.ChartValueFormat.ShortDate
CopyC#
    radChart1.PlotArea.YAxis.Appearance.ValueFormat =
Telerik.Reporting.Charting.Styles.ChartValueFormat.ShortDate;
CopyVB.NET
RadChart1.PlotArea.YAxis.Appearance.ValueFormat = Telerik.Reporting.Charting.Styles.ChartValueFormat.ShortDate


Bezier Charts

[image]

Telerik Reporting Q2 2012
Bezier Charts
Send Feedback

The Bezier chart is often used for modelling data by interpolating data points, through which curved lines pass.

To draw a Bezier chart series you add (1 + 3 x N) items to a series. So you can have 4 data points or 7, 10, 13, etc. The simplest set of data would be 4 data points: two end points and two "control points" that control the position and amount of curvature in the line between the two end points. See the figures below for examples. Each of the data points must have a X and Y value.

To create a simple vertical Bezier Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Bezier. Create a series and add four chart items with X and Y values.

Note

The second chart series labeled "Data Points" is included to emphasize the location of the end and control points in the Bezier series.

Horizontal Bezier Chart

To create a simple horizontal Bezier Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Bezier. Create a series and add four chart items with X and Y values.

YValue | XValue
20 | 50
20 | 100
80 | 100
80 | 50

Another Bezier chart with control points placed evenly

YValue | XValue
20 | 50
50 | 100
80 | 100
80 | 50

Bezier chart with control points placed asymetrically


Spline Charts

[image]

Telerik Reporting Q2 2012
Spline Charts
Send Feedback

Spline charts allow you to take a limited set of known data points and approximate intervening values. In practice you define a series of chart items with X/Y values and Chart does the rest.

To create a simple vertical Spline Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Spline. Create a series and add chart items with Y or X and Y values.

Vertical Spline Chart

To create a simple horizontal Spline Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Spline. Create a series and add 3 or more chart items with X and Y values.

YValue | XValue
20 | 50
50 | -10
70 | 100
80 | 50

Horizontal Spline Chart

Another example showing the same Y data points as above, but with no X values defined displays an automatic even progression over the X axis.

YValue
20
50
70
80

Spline chart with only Y values defined


Bubble Charts

[image]

Telerik Reporting Q2 2012
Bubble Charts
Send Feedback

The Bubble chart is an extension of the Point chart but each point can be a circle or oval of any size or dimension. Instead of using just the XValue and YValue, the Bubble chart uses XValue/XValue2, and YValue/YValue2 pairs to define the dimensions of each bubble. Bubble charts are commonly used to display financial information where the size of the bubble can be proportionate to the data values.

Tip

To change the size of all bubbles in a series, but to not distort the dimensions of the bubble, assign the Series.Appearance.BubbleSize StyleSeries..::.BubbleSize property.

To create a vertical Bubble Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType Bubble. Add one or more chart series to the Series Telerik.Reporting.Charting..::.ChartSeries collection. Add one or more chart items to the series Items collection. Populate numeric values for XValue ChartSeriesItem..::.XValue, ChartSeriesItem..::.XValue2, ChartSeriesItem..::.YValue and ChartSeriesItem..::.YValue2 properties of each chart series item.

Vertical Bubble Chart

To create a horizontal Bubble Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType Bubble. Add one or more chart series to the Series Telerik.Reporting.Charting..::.ChartSeries collection. Add one or more chart items to the series Items Telerik.Reporting.Charting..::.ChartSeriesItemsCollection collection. Populate numeric values for XValue ChartSeriesItem..::.XValue, ChartSeriesItem..::.XValue2, ChartSeriesItem..::.YValue and ChartSeriesItem..::.YValue2 properties of each chart series item.

Horizontal Bubble Chart


Point Charts

[image]

Telerik Reporting Q2 2012
Point Charts
Send Feedback

Point or "Scatter" charts are used to show correlations between two sets of values. The point chart lets you observe the dependence of one value to another and is often used for scientific data modeling. The Point chart is typically not used used with time dependent data where a Line chart is more suited.

To change the display of any given point use the chart item's PointAppearance ChartSeriesItem..::.PointAppearance property. Here you can change the Dimensions Telerik.Reporting.Charting.Styles..::.Dimensions property to control Height Dimensions..::.Height , Width Dimensions..::.Width , Margins Dimensions..::.Margins and Paddings Dimensions..::.Paddings . The Figure property lets you choose from a set of predefined shapes other than the default Ellipse shape (e.g. Cross, Diamond, Circle, Rectangle, Triangle and several different Star marker shapes).

To create a Vertical Point Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Point. Add one or more chart series to the Series Telerik.Reporting.Charting..::.ChartSeries collection. Add one or more chart items to the series Items Telerik.Reporting.Charting..::.ChartSeriesItemsCollection collection. Populate numeric values for XValue ChartSeriesItem..::.XValue and YValue ChartSeriesItem..::.YValue properties of each chart series item.

Vertical Point Chart

To create a Horizontal Point Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Point. Add one or more chart series to the Series Telerik.Reporting.Charting..::.ChartSeries collection. Add one or more chart items to the series Items Telerik.Reporting.Charting..::.ChartSeriesItemsCollection collection. Populate numeric values for XValue ChartSeriesItem..::.XValue and YValue ChartSeriesItem..::.YValue properties of each chart series item.

Horizontal Point Chart


Spline Area Charts

[image]

Telerik Reporting Q2 2012
Spline Area Charts
Send Feedback

Spline charts allow you to take a limited set of known data points and approximate intervening values. In the Spline Area Chart the area defined by the spline curve is filled. In practice you define a series of chart items and Chart does the rest. Each series overlays the preceding, from back to front.

To create a simple vertical Spline Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to SplineArea. Create one or more series and add chart items with Y or X and Y values.

Veritical Spline Area Chart

To create a simple horizontal Spline Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to SplineArea. Create a series and add chart items with Y or X and Y values.

Horizontal Spline Area Chart


Stacked Spline Area Charts

[image]

Telerik Reporting Q2 2012
Stacked Spline Area Charts
Send Feedback

The Stacked Spline Area chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. This contrasts with the Stacked Area chart where each series overlays the preceding series.

To create a simple vertical Stacked Spline Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedSplineArea. Create multiple chart series and add chart items with Y or X and Y values

To create a simple horizontal Stacked Spline Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedSplineArea. Create multiple chart series and add chart items with Y or X and Y values

Horizontal Stacked Spline Area Chart


Stacked Spline Area 100% Charts

[image]

Telerik Reporting Q2 2012
Stacked Spline Area 100% Charts
Send Feedback

The Stacked Spline Area 100% chart is a variation of the Spline Area chart. The areas are stacked so that each series adjoins but does not overlap the preceding series. This chart displays contributions for each data point to the category as a percentage.

To create a vertical Stacked Spline Area Chart 100% chart, set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedSplineArea100.

To create a horizontal Stacked Spline Area Chart 100% chart, set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedSplineArea100.

Vertical Stacked Spline Area 100% Chart
Tip

To display the label values as percentages, change the DefaultLabelValue ChartSeries..::.DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


Line Charts

[image]

Telerik Reporting Q2 2012
Line Charts
Send Feedback

Line charts are used to display a series of data points, typically to show trends over a period of time. One or more series of data can be used and the appearance for each series can be tailored to emphasize the data using unique colors, line thicknesses, shadow, pen style, and point marks.

To create a Vertical Line Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Line.

Vertical Line Chart

To create a Horizontal Line Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Line.

Horizontal Line Chart


Area Charts

[image]

Telerik Reporting Q2 2012
Area Charts
Send Feedback

The Area chart consists of a series of data points joined by a line and where the area below the line is filled. Area charts are appropriate for visualizing data that fluctuates over a period of time and can be useful for emphasizing trends. Note: Values that don't vary too wildly work best for area charts.

Area charts display series in the order they are added, back-to-front. Depending on the Skin Chart..::.Skin used, the chart can automatically differentiate each series by displaying it in a different color. The appearance for each series Telerik.Reporting.Charting..::.ChartSeries can also be modified directly.

To create a Vertical Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Area.

Vertical Area Chart

To create a Horizontal Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Area.

Horizontal Area Chart


Stacked Area Charts

[image]

Telerik Reporting Q2 2012
Stacked Area Charts
Send Feedback

The Stacked Area chart is a variation of the Area chart that display trends of the contribution of each value over time (or across categories). The areas are stacked so that each series adjoins but does not overlap the preceding series. This contrasts with the Area chart where each series overlays the preceding series.

Depending on the Skin Chart..::.Skin used, the chart can automatically differentiate each series by displaying it in a different color. The appearance for each series Telerik.Reporting.Charting..::.ChartSeries can also be modified directly.

To create a Vertical Stacked Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedArea.

Vertical Stacked Area Chart

To create a Horizontal Stacked Area Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to Area.

Horizontal Stacked Area Chart


Stacked Area 100% Charts

[image]

Telerik Reporting Q2 2012
Stacked Area 100% Charts
Send Feedback

Stacked Areas 100% charts are a variation of Stacked Area charts that present values for trends as percentages, totaling to 100% for each category

To create a Vertical Stacked Area 100% Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedArea100.

Vertical Stacked Area 100% Chart

To create a Horizontal Stacked Area 100% Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to StackedArea100.

Horizontal Stacked Area 100% Chart
Tip

To display the label values as percentages, change the DefaultLabelValue ChartSeries..::.DefaultLabelValue for each chart series from "#Y" (the numeric value for each data point) to "#%" (the percentage of each data point to the category).


CandleStick Charts

[image]

Telerik Reporting Q2 2012
CandleStick Charts
Send Feedback

The CandleStick chart combines bar and line chart styles to show a range of value movement over time. A filled bar indicates the opening value was greater than the closing value. An empty bar indicates that the closing value was greater than the opening value. The line through the center (the "wick") shows the extreme high and low values. The meaning of the Y values in a CandleStick chart are:

  • YValue = Open
  • YValue2 = Close
  • YValue 3 = Max
  • YValue 4 = Min

The "bar" portion of each chart item is formed between the YValue ChartSeriesItem..::.YValue and YValue2 ChartSeriesItem..::.YValue2 properties. The "wick" portion of the chart is defined with the YValue3 and YValue4 chart item properties.

To create a Vertical CandleStick Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Vertical. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to CandleStick.

CandleStick Chart Type

To create a Horizontal CandleStick Chart set the SeriesOrientation Telerik.Reporting.Charting..::.ChartSeriesOrientation property to Horizontal. Set the Chart DefaultType property or ChartSeries.Type Telerik.Reporting.Charting..::.ChartSeriesType to CandleStick.

Horizontal CandleStick Chart

The screenshots above use the following data points:

YValue | YValue2 | YValue3 | YValue4
6 | 7.1 | 4.5 | 8
5.5 | 7.7 | 3 | 6
21 | 9 | 8 | 23
5.5 | 6.5 | 4 | 6.5
6 | 4.5 | 3 | 7


Chart Basics

[image]

Telerik Reporting Q2 2012
Chart Basics
Send Feedback

Charts are composed of a hierarchy of elements. Most of the elements are common across all chart types (unless otherwise noted). The illustration below shows some of the significant chart elements.

Chart elements

Chart Element Descriptions

Title | The heading for the chart as a whole. The position and appearance of the title is completely customizable. Read More | Legend | The legend contains a symbol and name for each series in the chart. The legend may also display a series of items. The position and appearance of the legend can also be customized. Read more
Axis Item | Axis Items are the individual points along each axis that help indicate the axis measurement and scale. Read more | Grid Lines | Vertical and horizontal lines parrallel to the X and Y axes. These grid lines form the grid, making the chart easier to read. Read more
Point Mark | The point mark is a visual cue to enhance visibility of data points on line and area charts. Read more Series Items | Chart Series | Series contains a set of data points to be drawn on the chart. This set of points contains related data. Each series can be represented by a chart type. Pie charts use only a single series. For other chart types there is no limitation to the number of series or items within each series. Read more
Item Label | The label next to each data point displaying a value or custom text. Read more | Margins | The distance between the outer edge of an item to the outer edge of the item containing it. For example, the margin for the plot area is the distance from the plot area border to the outermost border of the chart. Plot area, legend and title all have margins. Read more
Axis Label | The label next to each axis identifying the nature of data points found along that axis. Read more ChartAxis..::.AxisLabel | Plot Area | The area enclosed between the X and Y axes. Read more
Ticks | Axis ticks are small marks that identify the position of items on the axes and the starting points of gridlines. Read more | Plot Area Border | The line that encloses the area between the X and Y axes. Read more
Axis (X and Y) | These axes form the coordinates in which the data points are placed. Chart series items are displayed along the X and Y axes. Note: Pie charts do not use axes. Read more | Background Border | The outermost line that encloses the whole chart area. Read more
Exploded Pie | A piece of the a Pie chart that is visually separated from the rest of the pie for easier distinction. Read more StyleSeriesItem..::.Exploded |  |


Background and Plot Areas

[image]

Telerik Reporting Q2 2012
Background and Plot Areas
Send Feedback

Chart Background

The background of the chart is the outermost rectangle that encloses all other elements of the chart. It stretches for the whole width and length of the output image of the chart. Using the Appearance Chart..::.Appearance property of the chart you can fully customize the chart background look and feel including:

  • Telerik.Reporting.Charting.Styles..::.StyleChartBorder visibility,color, pen style and width.
  • The StyleChart..::.Corners property lets you square or round each corner individually. The degree of rounding can be tailored.
  • StyleChart..::.FillStyle controls the fill color and type (solid, hatched, image, gradient).
  • StyleChart..::.ImageQuality and TextQuality StyleChart..::.TextQuality properties can also be fine tuned.

Plot Area

The plot area is the working rectangular area between X and Y axes where data is displayed. The size of the plot depends on the chart background size and the chart margins Telerik.Reporting.Charting.Styles..::.ChartMargins, which define the distance between the border of the plot area and the border of the chart background. This area is represented by the Chart PlotArea Telerik.Reporting.Charting..::.ChartPlotArea property. Some unique Telerik.Reporting.Charting..::.ChartPlotArea properties are:

  • Chart..::.SeriesOrientation is an enumeration that orients the entire Telerik.Reporting.Charting..::.ChartPlotArea either Vertical or Horizontal.
  • ChartPlotArea..::.XAxis, ChartPlotArea..::.YAxis, and ChartPlotArea..::.YAxis2 properties. These axis properties control the scale and appearance of both axes. See the Axes topic for more information.
  • DataTable: Displays a spreadsheet style table of the data in the chart, typically just below the chart itself. See the DataTable topic for more information.
  • EmptySeriesMessage: The predefined message that displays in the PlotArea Telerik.Reporting.Charting..::.ChartPlotArea when there is no series data defined for the chart.

  • MarkedZones: Areas in the background of the chart that can be defined, labeled and filled. MarkedZones are used to highlight or group areas on the chart.

Chart Background and Plot Area

Like the chart as a whole, Telerik.Reporting.Charting..::.ChartPlotArea has an Appearance Telerik.Reporting.Charting.Styles..::.StylePlotArea property allowing customization:

  • Telerik.Reporting.Charting.Styles..::.StyleBorder visibility,color, pen style and width.
  • The Telerik.Reporting.Charting.Styles..::.Corners property lets you square or round each corner individually. The degree of rounding can be tailored.
  • Telerik.Reporting.Charting.Styles..::.FillStylePlotArea controls the fill color and type (solid, hatched, image, gradient).
  • The
Telerik.Reporting.Charting.Styles..::.DimensionsPlotArea
property provides control of  Width
Dimensions..::.Width,
Dimensions..::.Height,
DimensionsPlotArea..::.Margins,
Dimensions..::.Paddings
and if you want the dimensions to  Autosize
Dimensions..::.AutoSize
.
  • Chart..::.SeriesPalette is a property of the chart that lets you to choose a predefined skin color palette for each series. This can help provide a distinct look to differentiate each series.
  • The Style..::.Shadow property lets you control shadow Blur ShadowStyle..::.Blur, shadow ShadowStyle..::.Color, shadow ShadowStyle..::.Distance and ShadowStyle..::.Position relative to the plot area.


Axes

[image]

Telerik Reporting Q2 2012
Axes
Send Feedback

X and Y axes are included in all chart types but the Pie chart. Typically the YAxis ChartPlotArea..::.YAxis displays values and the XAxis ChartPlotArea..::.XAxis displays categories. For example, the YAxis ChartPlotArea..::.YAxis might show "items sold" or "revenue", while the XAxis ChartPlotArea..::.XAxis might show "Months" or "Products". The X axis can also display values. A second "Y" axis property YAxis2 ChartPlotArea..::.YAxis2 is provided for displaying a second scale of measurements.

XAxis, YAxis and YAxis2

Axis Elements

Each axis has:

  • Grid lines display perpendicular to the axis covering the plot area.
  • Axis line
  • Axis label
  • Axis marks along the axis line
  • Item labels below the axis line

The example below shows a sample X-axis with several appearance related properties customized.

Axis Elements

The Chart PlotArea Telerik.Reporting.Charting..::.ChartPlotArea property has sub properties XAxis ChartPlotArea..::.XAxis, YAxis ChartPlotArea..::.YAxis and YAxis2 ChartPlotArea..::.YAxis2. Each axis object has an Appearance Telerik.Reporting.Charting.Styles..::.StyleAxis property used to make the customizations shown above. Some significant axis appearance related properties are:

  • The
StyleAxis..::.LabelAppearance
property includes sub properties that control the axis label
Style..::.Visible,
Style..::.Border,
StyleLabel..::.Corners,
LayoutStyle..::.Dimensions,
StyleLabel..::.FillStyle,
LayoutStyle..::.Position
and
Style..::.Shadow.
  • StyleAxis..::.MajorGridLines
controls the appearance of grid lines displaying over the plot area including
StyleBorder..::.Visible,
StyleBorderEndCap()()(),
StyleGridLine..::.Color,
StyleGridLine..::.PenStyle
and
StyleGridLine..::.Width.
  • StyleAxis..::.TextAppearance handles the axis item label text, most notably Telerik.Reporting.Charting.Styles..::.TextProperties controls font properties and color.
Note

Axis properties can be set from the Properties Window of Visual Studio, in the XML configuration file, or through the API. Properties for the X and Y axis are identical except where noted.

Formatting Axis

You can modify the overall appearance of an axes by changing the ChartAxis..::.AutoScale and ChartXAxis..::.AutoShrink properties. These properties when set to true cause the axis to expand and shrink to accommodate dynamically added and removed items. This is useful when the number of items changes on-the-fly.

Turn ChartAxis..::.AutoScale off if you want complete control over labeling of an axis.

Formatting Axis Labels

Axis Positioning

To display a range of values along an axis, specify for the Telerik.Reporting.Charting..::.ChartAxis a starting ChartAxis..::.MinValue, an ending ChartAxis..::.MaxValue, and a Step ChartAxis..::.Step. In the example above, the YAxis has a ChartAxis..::.MinValue of "0", a ChartAxis..::.MaxValue of "250" and a ChartAxis..::.Step of "50". The X axis is labeled explicitly by setting ChartPlotArea..::.XAxis properties:

  • ChartAxis..::.AutoScale = False
  • ChartAxis..::.MaxValue = 3
  • ChartAxis..::.MinValue = 1
  • ChartAxis..::.Step = 1
  • ChartAxis..::.Visible = True
  • ChartAxis..::.Items is populated with with 3 Telerik.Reporting.Charting..::.ChartAxisItem objects where the Appearance.Text property contains "Non-Smokers", "Social Smokers" and "Heavy Smokers".

You can control the size and position of the labels using the axis StyleAxis..::.LabelAppearance, LayoutStyle..::.Dimensions and LayoutStyle..::.Position properties.

X-Axis Properties Used in Data Binding

ChartXAxis..::.DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each X Axis item.

Unique YAxis and YAxis2 Properties

ChartYAxis..::.AxisMode: AxisMode can be Normal (the default) or Extended. Extended mode provides buffer space above the largest value for best visual formatting.

ChartYAxis..::.ScaleBreaks: The ScaleBreaks feature allows you to "break off" large chunks of the axis so that graphs with large amplitude are easier to read. ScaleBreaks are available for both YAxis and YAxis2 of the plot area. By default ScaleBreak..::.Enabled is false so scale breaks do not display. Set the maximum number of breaks using ScaleBreak..::.MaxCount to set the minimum interval between data points before a break will occur. For the lines ScaleBreak..::.Line controls the shape of the line (i.e. Sinusoid, Straight, JaggedCurve and Curve).


Axis Labels

[image]

Telerik Reporting Q2 2012
Axis Labels
Send Feedback

Labels are displayed for each:

  • Chart axis to describe the category of values along the axis. For example "Products", "Risk Factors", time periods or geographic areas.
  • Chart axis item to describe the specific value or category for that item.

Formatting Axis Labels

  • To format the chart axis label use the Telerik.Reporting.Charting..::.AxisLabel to access Telerik.Reporting.Charting.Styles..::.StyleLabel and ChartBaseLabel..::.TextBlock properties

  • To set the formatting for all labels on an axis use the Telerik.Reporting.Charting.Styles..::.StyleAxis LabelAppearance Telerik.Reporting.Charting.Styles..::.StyleLabel and TextAppearance Telerik.Reporting.Charting.Styles..::.StyleAxisItemText properties.

  • To format a label for a specific chart axis item use the Telerik.Reporting.Charting.Styles..::.StyleLabel property.

Use the ChartAxis..::.MinValue and ChartAxis..::.MaxValue properties to specify the minimum and maximum values for the data to display. The MinValue ChartAxis..::.MinValue property allows you to specify either negative or positive number as the minimum value. In the example below the MinValue ChartAxis..::.MinValue = -50, ChartAxis..::.MaxValue = 50 and ChartAxis..::.Step = 10.

Formatted Y-Axis Labels

The Telerik.Reporting.Charting.Styles..::.ChartValueFormat property automatically formats axis label values as Currency, Scientific, General, Number, Percent, ShortDate, ShortTime, LongDate, LongTime or None.

Positioning Axis Labels

You can specify the horizontal and vertical alignment of axis labels and axis item labels using the
LayoutStyle..::.Position
property of the axis label or chart axis item respectively.
LayoutStyle..::.Position
has sub properties for
Telerik.Reporting.Charting.Styles..::.AlignedPositions,
Position..::.Auto,
Position..::.X
and
Position..::.Y.

Use Telerik.Reporting.Charting.Styles..::.AlignedPositions to automatically place the label Right, Left, Top, Center, TopRight, TopLeft, BottomRight or BottomLeft.

Aligned Labels

Use the RotationAngle property to spin axis and axis item labels to any angle. In the example below the StyleLabel..::.RotationAngle is set to 45.

RotationAngle

By turning off the Position.Auto Position..::.Auto property and setting Position.AlignedPosition Telerik.Reporting.Charting.Styles..::.AlignedPositions to None you can place the axis label any where in the plot area. In the example below the PlotArea.YAxis.AxisLabel.Appearance.Position LayoutStyle..::.Position property is configured such that:

  • Telerik.Reporting.Charting.Styles..::.AlignedPositions = None
  • Position..::.Auto = False
  • Position..::.X = 120
  • Position..::.Y = 200

The YAxis.AxisLabel.Appearance.RotationAngle StyleLabel..::.RotationAngle = 325.

Note

This isn't a recommended or usual approach but serves to illustrate the flexibility of the object model.

Also in the example below, the PlotArea.XAxis.AutoScale ChartAxis..::.AutoScale is turned off so the PlotArea.XAxis.Items ChartAxis..::.Items collection could be populated manually. Each ChartAxisItem Telerik.Reporting.Charting..::.ChartAxisItem has its ChartBaseLabel..::.TextBlock.Text property populated with the strings "Non-Smokers", "Social Smokers" and "Heavy Smokers".

Axis Positioning


Gridlines

[image]

Telerik Reporting Q2 2012
Gridlines
Send Feedback

Gridlines are auxiliary lines that form a grid for easier reading of the chart. Gridlines can be vertical or horizontal. Vertical gridlines are controlled by the XAxis ChartPlotArea..::.XAxis and horizontal gridlines are controlled by ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2. Gridlines can be "major", e.g. falling on the labeled axis ChartAxis..::.Step values. "Minor" gridlines appear for ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2 that fall between ChartAxis..::.Step values. See the figure below where major gridlines fall on 20 and 40 of the YAxis and minor gridlines fall between the major gridlines.

To control the visibility and general appearance of gridlines use the the Telerik.Reporting.Charting.Styles..::.StyleAxis property to reach StyleAxis..::.MajorGridLines and StyleAxis..::.MinorGridLines properties. ChartPlotArea..::.XAxis has only StyleAxis..::.MajorGridLines while ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2 have both StyleAxis..::.MajorGridLines and StyleAxis..::.MinorGridLines properties. Both major and minor gridline objects include the following properties:

  • StyleBorder..::.Visible
  • StyleGridLine..::.Color
  • StyleGridLine..::.PenStyle (Solid, Dash, Dot, DashDot, DashDotDot and Custom)
  • StyleGridLine..::.Width

In the example below both X axis and Y axis are visible. ChartPlotArea..::.XAxis StyleAxis..::.MajorGridLines are red solid lines 3 pixels wide. ChartPlotArea..::.YAxis StyleAxis..::.MinorGridLines are shown as blue dotted lines 2 pixels wide and ChartPlotArea..::.YAxis StyleAxis..::.MajorGridLines are shown as blue solid lines 3 pixels wide.


Legends

[image]

Telerik Reporting Q2 2012
Legends
Send Feedback

Legends are symbols and text used to provide additional information about the chart. In a multiple series chart the legend typically describes each series to improve readability. By default Chart includes the color and name of each chart series in the legend. You can also define your own legend and control the style for the legend or each item in the legend using the Chart Legend Telerik.Reporting.Charting..::.ChartLegend property. Telerik.Reporting.Charting..::.ChartLegend holds properties for:

  • ChartBaseLabel..::.Visible : If a legend is not relevant to your chart you can set this false to hide the legend.
  • ExtendedLabel..::.Appearance
: This property controls the visual style of the legend as a whole including  Dimensions
LayoutStyle..::.Dimensions,
LayoutStyle..::.Position,
StyleLabel..::.FillStyle,
StyleExtendedLabel..::.ItemAppearance,
StyleExtendedLabel..::.ItemMarkerAppearance,
StyleExtendedLabel..::.ItemTextAppearance,
StyleLabel..::.RotationAngle
and
Style..::.Shadow.
  • ExtendedLabel..::.Items: A collection containing the individual legend text and symbols for each series. Add to this collection to create your own custom legends.
  • ChartBaseLabel..::.Marker: A visual marker for the legend as a whole. Use the marker ChartMarker..::.Appearance property to control properties like StyleMarker..::.FillStyle, LayoutStyle..::.Dimensions and LayoutStyle..::.Position. To assign an image to the marker use the marker StyleMarker..::.FillStyle property to set FillStyle..::.FillType to Image and FillStyle..::.FillSettings.BackgroundImage to the path of the image.
  • ChartBaseLabel..::.TextBlock: Use TextBlock to control the default text and appearance.

Formatting Legends

Use the legend Appearance StyleExtendedLabel..::.ItemTextAppearance property to tailor the look of all legend item text at one time and the ItemMarkerAppearance StyleExtendedLabel..::.ItemMarkerAppearance to format all of the legend markers. Particularly note the CompositionType Telerik.Reporting.Charting.Styles..::.LabelItemsCompositionTypes property that handles the display order of text vs. images where valid values are ColumnImageText, ColumnTextImage, RowImageText (the default) and RowTextImage. "Column" values show the text and image one above the other. "Row" shows text and image side-by-side.

Use the StyleExtendedLabel..::.ItemMarkerAppearance property to select from a set of predefined marker shapes.

Marker Figures

Use the LayoutStyle..::.Position property to control where the legend should appear on the chart surface. The Telerik.Reporting.Charting.Styles..::.AlignedPositions sub property automatically places the legend in a predefined position. Or set the Position..::.Auto property false and manually set the Position..::.X and Position..::.Y properties to place the legend in any exact position.

AlignedPosition

Use the LayoutStyle..::.Dimensions property to control the legend height and width. By default the Dimensions..::.AutoSize sub property is true and dimensioning is handled for you. Set Dimensions..::.AutoSize off to manually handle Dimensions..::.Width, Dimensions..::.Height, Dimensions..::.Margins and Dimensions..::.Paddings.

Adding Custom Legends

In the collection editor for the ExtendedLabel..::.Items property add one or more items. Use the ChartBaseLabel..::.Marker property to add images or colored shapes next to the text. Use the ChartBaseLabel..::.TextBlock property to add the text description for the legend item. You can also define image maps using the ChartBaseLabel..::.ActiveRegion property of the legend or legend items.

To add images to the legend you can set the Telerik.Reporting.Charting.Styles..::.FillType to Image and the FillSettings..::.BackgroundImage to the path of an image to display. In the example below two legend items are added to the collection where the FillSettings..::.BackgroundImage contains image paths for two flags and where the ChartBaseLabel..::.TextBlock properties contain corresponding descriptions. In addition the Telerik.Reporting.Charting.Styles..::.ShadowStyle property has ShadowStyle..::.Blur = 5 and ShadowStyle..::.Distance = 2.


Margins

[image]

Telerik Reporting Q2 2012
Margins
Send Feedback

Chart margins are the distances from the outermost chart borders to the borders of the plot area.

Chart Margins

Margins are expressed in the Chart PlotArea.Dimensions.Margins Dimensions..::.Margins property and are specified in pixels or percentages. Percentages refer to a percentage of the Chart width. In the figure below the dimensions are populated with some values in percentages, some in fixed pixels.

PlotArea Dimensions
Tip

To provide extra space for positioning legends, labels and title, use greater margin values for the PlotArea to provide room.


Titles

[image]

Telerik Reporting Q2 2012
Titles
Send Feedback

The title for the chart as a whole is controlled by the Chart..::.ChartTitle object. The following sub properties of ChartTitle allow you to format the text, marker and overall appearance of the title:

  • ChartBaseLabel..::.ActiveRegion: ActiveRegion contains properties for HTML Attributes, Tooltip and URL.
  • ChartLabel..::.Appearance
controls visibility,
Style..::.Border,
StyleLabel..::.Corners,
LayoutStyle..::.Dimensions,
StyleLabel..::.FillStyle,
LayoutStyle..::.Position,
StyleLabel..::.RotationAngle
and
Style..::.Shadow
for the title. Use the
Telerik.Reporting.Charting.Styles..::.AlignedPositions
to place the title area in a predefined position (e.g. Left, Right, Center, Top, Bottom, BottomRight, BottomLeft, TopRight, TopLeft), or set the  Auto
Position..::.Auto
property off and use the
Position..::.X
and
Position..::.Y
properties to place the chart title anywhere on the chart including the plot area.
  • ChartBaseLabel..::.Marker controls a small graphic for the title area. By default the marker is not visible.
  • The ChartBaseLabel..::.TextBlock properties provides fine tune control over the text and text background.

In the example below the title is customized so that the position is aligned to the top left, corners are rounded, the fill is a gradient fill radiating from the center and a shadow makes it stand out from the background.

RadChart Title


Series Overview

[image]

Telerik Reporting Q2 2012
Series Overview
Send Feedback

Series refers to a series of data points displayed in the chart. The Chart Series object is a collection of ChartSeriesItem objects. The number of series used depends on the type of chart. A Pie chart type only uses a single series. "Stacked" charts like the Stacked Area chart use several series.

Each ChartSeries object contains a collection of ChartSeriesItem Telerik.Reporting.Charting..::.ChartSeriesItem objects that contain the actual data points displayed on the chart. You can add data to a series programmatically at run time, at design time in the Properties Window of Visual Studio, declaratively in the ASP.NET HTML markup Telerik.Reporting.Charting..::.ChartSeries are:

  • Appearance ChartSeries..::.Appearance: This property contains the common appearance related properties such as Border StyleSeries..::.Border, Corners StyleSeries..::.Corners, FillStyle StyleSeries..::.FillStyle and TextAppearance StyleSeries..::.TextAppearance.

    In addition there are series specific properties including LabelAppearance StyleSeries..::.LabelAppearance, LineSeriesAppearance StyleSeries..::.LineSeriesAppearance, LegendDisplayMode StyleSeries..::.LegendDisplayMode, BubbleSize StyleSeries..::.BubbleSize and PointMark StyleSeries..::.PointMark.

  • DefaultLabelValue: Specifies a format for label values. This allows you to display data points as numeric amounts, percentages, totals or any format described in this MSDN article Standard Numeric Format Strings

  • Items: The collection of ChartSeriesItem objects that contain data points.

  • Name ChartSeries..::.Name: By default this name is displayed in the legend for the series.

  • Types: Use this property to select the chart type. Valid values are Bar, StackedBar, StackedBar100, Line, Area, StackedArea, StackedArea100, Pie, Gantt, Bezier, Spline, Bubble, Point, SplineArea, StackedSplineArea and StackedSplineArea100.

  • Visible ChartSeries..::.Visible: Turn this property off to hide the series.

ChartSeries Properties

ChartSeries Properties Used in Data Binding

ChartSeries..::.DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each data point in the chart.

ChartSeries..::.DataXColumn,
ChartSeries..::.DataXColumn2,
ChartSeries..::.DataYColumn,
ChartSeries..::.DataYColumn2:
These are the names of the columns that will contain data used for the series item
ChartSeriesItem..::.XValue,
ChartSeriesItem..::.XValue2,
ChartSeriesItem..::.YValue
and
ChartSeriesItem..::.YValue2
columns respectively.


Series Items

[image]

Telerik Reporting Q2 2012
Series Items
Send Feedback

Each chart series item encapsulates a single data point.

The key properties are shown in the figure below in the property category "Basic value set". For simple charts along a single axis populate the YValue ChartSeriesItem..::.YValue property. Use the ChartSeriesItem..::.XValue property to add a second data dimension. For example, the Y values might be "Sales Volume" and the X values might be time periods or geographic regions. XValue2 ChartSeriesItem..::.XValue2 and ChartSeriesItem..::.YValue2 are used by Gantt type to indicate a period of time and the Bubble chart type to show amplitude of data.

Set the Empty property to true to have Chart approximate the value. The example below has a third item with the Empty ChartSeriesItem..::.Empty property set to True, causing the item to display by default as a unfilled dotted line with a label of 30.5 (the average of the values that come before and after, 5 and 56, respectively). The look of the empty value is controlled by the EmptyValue Telerik.Reporting.Charting.Styles..::.EmptyValue property for the series Appearance ChartSeries..::.Appearance.

Empty Property

Other significant properties for the ChartSeriesItem Telerik.Reporting.Charting..::.ChartSeriesItem are:

  • ChartSeriesItem..::.ActiveRegion: Contains HTML ActiveRegion..::.Attributes, ActiveRegion..::.Tooltip and URL ActiveRegion..::.Url. These properties support making image maps.
  • ChartSeriesItem..::.Appearance: This contains common visual properties Style..::.Border, StyleSeriesItem..::.Corners, StyleSeriesItem..::.FillStyle and Style..::.Visible. In addition the property StyleSeriesItem..::.Exploded is specific to the Pie chart property type. When true, StyleSeriesItem..::.Exploded displays a chart series item (a pie slice in this context) as slightly separated from the rest of the pie.
  • ChartSeriesItem..::.Label: Use this property to override the default item label. By default the numeric values of each data point are displayed on the chart. Here you can use the TextBlock..::.Text to add a more specific description of the data point. You have full control over each label HTML characteristics with the ChartBaseLabel..::.ActiveRegion. Control visual display and layout using the Telerik.Reporting.Charting.Styles..::.StyleSeriesItemLabel property.
ChartSeriesItem Collection


Series-Specific Properties

[image]

Telerik Reporting Q2 2012
Series-Specific Properties
Send Feedback

The following are properties specific to the series appearance Telerik.Reporting.Charting.Styles..::.StyleSeries of specific chart types.

Bubble

The StyleSeries..::.BubbleSize property is specific to the Bubble chart type and allows you to increase or decrease bubble size without distorting the shape.

Lines and Splines

The StyleSeries..::.LineSeriesAppearance property is specific to the Line and Spline chart types. LineSeriesAppearance StyleSeries..::.LineSeriesAppearance has a LineStyle..::.EndCap property that governs the appearance of a line terminating shape that occurs where at each data point (except the first). Valid Cap LineStyle..::.EndCap values are Flat, Square, Round, Triangle, NoAnchor, SquareAnchor, RoundAnchor, DiamondAnchor, ArrowAnchor, AnchorMask and Custom. LineSeriesAppearance StyleSeries..::.LineSeriesAppearance also has sub properties for StyleLineSeries..::.Color, StyleLineSeries..::.PenStyle, StyleLineSeries..::.Visible and StyleLineSeries..::.Width.

The
StyleSeries..::.PointMark
is a shape that occurs at every data point, including the first.  PointMarks are off by default but can be enabled using the  Pointmark.Visible
StyleMarkerSeriesPoint..::.Visible
property. Use the
StyleMarkerSeriesPoint..::.Figure
property to choose one of the predefined shapes. Other  PointMark
StyleSeries..::.PointMark
 properties include
Style..::.Border,
StyleMarker..::.Corners,
LayoutStyle..::.Dimensions,
StyleMarker..::.FillStyle,
StyleMarker..::.RotationAngle
and
Style..::.Shadow.

LineSeriesAppearance

The example above shows Series 1 in red where LineSeriesAppearance StyleSeries..::.LineSeriesAppearance properties are:

  • LineStyle..::.EndCap = ArrowAnchor
  • StyleLineSeries..::.Color = Red
  • StyleLineSeries..::.PenStyle = Dash
  • StyleLineSeries..::.Width = 5

Series 2 show in blue has StyleSeries..::.PointMark properties set as:

  • StyleBorder..::.Color = 50, 0, 245, 100
  • StyleBorder..::.Width = 1
  • StyleMarkerSeriesPoint..::.Figure = Star5
  • StyleMarkerSeriesPoint..::.Visible = True
  • Dimensions..::.Height = 25px
  • Dimensions..::.Width = 25px
  • FillStyle..::.FillType = Solid
  • FillStyle..::.MainColor = 90, 100, 254, 100
  • ShadowStyle..::.Blur = 1
  • ShadowStyle..::.Color = DimGray
  • ShadowStyle..::.Distance = 2

Pie

The StyleSeries..::.StartAngle property specifies degrees for the rotation of a pie. The default value and the starting position is 0°. Positive values of the StyleSeries..::.StartAngle property will rotate the pie clockwise and negative - counterclockwise.

StartAngle Example

The StyleSeries..::.DiameterScale property controls the ratio between the size of the plot area and the diameter of the chart. It effectively sets the size of the pie. In the example below, StyleSeries..::.DiameterScale is set to 1, .75 (the default) and .5.

DiameterScale Example

When true, the StyleSeries..::.ShowLabelConnectors property visually ties the label with the corresponding pie slice.

ShowLabelConnectors

The StyleSeries..::.ExplodePercent property defines the percentage of explosion of pie pieces. By default this is 20 percent. In the example below it is set to 50 percent:

ExplodePercent Example

The StyleSeries..::.CenterXOffset and StyleSeries..::.CenterYOffset properties specify the distance from the center of the plot area to the center of the pie in pixels. Use these two properties to position pie charts within the plot area.


Ticks

[image]

Telerik Reporting Q2 2012
Ticks
Send Feedback

Axis ticks are the small marks that identify the position of items on the axes and the starting points of gridlines.

Vertical ticks are controlled by the ChartPlotArea..::.XAxis and horizontal ticks are controlled by ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2. Ticks can be "major", e.g. falling on the labeled axis ChartAxis..::.Step values. "Minor" ticks fall between ChartAxis..::.Step values for ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2. See the figure below where major ticks fall on 50, 100, 150, 200, 250 of the ChartPlotArea..::.YAxis and minor ticks fall between the major ticks.

X and Y Axis Ticks

To control the visibility and general appearance of gridlines use the the ChartAxis..::.Appearance property to reach StyleAxis..::.MajorTick and StyleAxis..::.MinorTick properties. ChartPlotArea..::.XAxis has only a StyleAxis..::.MajorTick property while ChartPlotArea..::.YAxis and ChartPlotArea..::.YAxis2 have both StyleAxis..::.MajorTick and StyleAxis..::.MinorTick properties. Both major and minor tick objects include the following properties:

  • StyleBorder..::.Visible: Set this property false to hide the ticks.
  • LineStyle..::.EndCap : The terminator for each tick can be Flat, Square, Round, Triangle, NoAnchor, SquareAnchor, DiamondAnchor, ArrowAnchor, AnchorMask or Custom. In the example above the Y Axis major ticks have a Square cap, minor ticks have a RoundCap and X Axis major ticks have an ArrowAnchor cap.
  • StyleTick..::.Color of the line and cap.
  • StyleTick..::.Length: The length of the tick in pixels. To reverse the direction of the ticks and have them appear above the axis line use a negative value for StyleTick..::.Length.
  • StyleBorder..::.PenStyle : values can be Solid, Dash, Dot, DashDot, DashDotDot and Custom.
  • StyleTick..::.Width in pixels.

Layout

The ChartXAxis..::.LayoutMode property of each the X axis object specifies how axis marks are positioned with regard to series items. Layout modes change the chart appearance while the underlying data remains the same. The available ChartXAxis..::.LayoutMode values are Normal, Inside and Between.

Layout Modes


DefaultLabelValue

[image]

Telerik Reporting Q2 2012
DefaultLabelValue
Send Feedback

DefaultLabelValue ChartSeries..::.DefaultLabelValue specifies a format for label values that will be displayed automatically if you do not specifically assign text to a chart series item.

  • Use "#Y" or "#X" to display numbers from the X or Y axis respectively
  • Use "#%" for a percentage of the total sum (of all items).
  • Use "#SUM" to display the total of all items.
  • "#STSUM" displays the sum of a stacked series.
  • "#SERIES" displays the series name.
  • "#ITEM" displays the item name.
  • You can also use the formatting described in this MSDN article Standard Numeric Format Strings. Use curly brackets to contain the standard numeric formats. For example, you can display Y values as currency by setting DefaultLabelValue ChartSeries..::.DefaultLabelValue to "#Y{C}". See examples in the figure below.

DefaultLabelValue Examples


BarOverLapPercent and BarWidthPercent

[image]

Telerik Reporting Q2 2012
BarOverLapPercent and BarWidthPercent
Send Feedback

In bar charts with multiple series BarOverLapPercent StyleChart..::.BarOverlapPercent governs to what degree the bars will overlap the preceding bar series. If you enter a negative value for BarOverLapPercent StyleChart..::.BarOverlapPercent , a gap appears between the bars of different series. Overlapping is especially useful when a long series of items needs to fit in a small-size chart.

BarWidthPercent StyleChart..::.BarWidthPercent controls how much space each bar takes up so that a BarWidthPercent StyleChart..::.BarWidthPercent of 100 will have all the bars in the chart taking exactly all the available width.

Note

The maximum bar width is calculated as follows: bar width = axislength / bars count.

See the examples below to see how these two properties work together.


Chart Wizard

[image]

Telerik Reporting Q2 2012
Chart Wizard
Send Feedback

The Chart Wizard helps you traverse the many properties of Chart by providing the most commonly used properties in an intuitive way. The wizard can help you quickly set up the basic structure of your chart. You can invoke the chart wizard from the context menu that appears when you right-click the chart item and select Properties.

The Chart Interface consists of tabs:

  • Type
  • Data
  • Skin
  • Labels, Legend & Title
  • Axis
  • Values Data Table

The Chart Wizard


The Wizard Type Tab

[image]

Telerik Reporting Q2 2012
The Wizard Type Tab
Send Feedback

The Type tab lets you quickly choose the chart type by providing visual cues to what each type looks like. Here you can also choose the chart orientation.

Chart Wizard Type Tab


The Wizard Data Tab

[image]

Telerik Reporting Q2 2012
The Wizard Data Tab
Send Feedback

The Data tab brings together the Series, Series Item, Axis labels and data binding to a single screen. Here you can add data points to your chart manually or by binding to data sources.

Chart Wizard Data Tab

The Data tab is composed of areas:

Series

Use the Series area of the tab to add, delete and reorder chart series elements using the list box provided. Use the plus and minus buttons to add or delete a series element. Use the up and down arrows to move a series element up or down in the list. For each selected series element in the list box you can provide a name and select from the list of chart types.

If you bind to a data source the Databind Series Elements portion will be enabled and allow you to choose column names for your labels and values from the drop down lists provided. When you bind to a data source the Series list box will be populated automatically with a series for each numeric column in the data source. If you need to fine tune the behavior or appearance of a series in more depth than the Data tab provides, use the Chart Telerik.Reporting.Charting..::.Chart Series property in the property window. In the example below the Labels for the series have been bound to a column "TenMostExpensiveProducts", which contains product descriptions. These descriptions display to the right next to each bar in the chart. Note that SeriesOrientation is Horizontal, so the X-Axis is on the left.

Labeling Series Elements

Series Items

For each series you select in the Series area list, you can add, edit, delete and reorder entries in the Series Items list. Use the plus and minus buttons to add and delete series items. Use the up and down arrows to move series items up or down in the list. For each item you can set the Name, Label and X and Y Values. X2 and Y2 values are enabled for Gantt and Bubble chart types. If you need to refine the behavior or appearance in more detail than provided by this Wizard page, use the Items collection Telerik.Reporting.Charting..::.ChartSeriesItemsCollection of the Chart Telerik.Reporting.Charting..::.Chart Series from the Property window.

Axis Labels

This section lets you choose between binding to a column in the data source and using the column data to populate the labels along an Axis. Click the Add Labels Manually link to navigate to the Axis tab. The screen shot below shows the X-Axis labels set data bound to a column "TenMostExpensiveProducts" that contains product descriptions. Note that SeriesOrientation is Horizontal, so the X-Axis items show on the left.

Axis Labels

Send comments on this topic to documentation@telerik.com

© 2002-2012 Telerik, All Rights Reserved.


The Wizard Skin Tab

[image]

Telerik Reporting Q2 2012
The Wizard Skin Tab
Send Feedback

The Chart Telerik.Reporting.Charting..::.Chart Skin Chart..::.Skin property lets you apply a coordinated set of style changes to all the chart visual details at one time. The Skin tab of the wizard lets you visually inspect how a chart might look with a given skin. The skins displayed reflect the current chart type. In the screen shot below the chart type is Bubble.

The Chart Wizard Skin Tab


The Wizard Labels, Legend and Titles Tab

[image]

Telerik Reporting Q2 2012
The Wizard Labels, Legend and Titles Tab
Send Feedback

On the Labels, Legend and Titles Tab:

  • Title: From this portion of the tab set the Text for the title, toggle visibility of the title using the checkbox provided and set text direction from the drop down list. Use the Alignment drop down to move the title position between None, Left, Top, Bottom, Center, TopRight, TopLeft, BottomRight and BottomLeft.

  • Legend: Unselect the Visible checkbox to hide the legend. Use the Marker drop down to select from a predefined list of shapes. In the example below the Rectangle shape is selected. Use the Alignment drop down to move the legend position between None, Left, Top, Bottom, Center, TopRight, TopLeft, BottomRight and BottomLeft. In the example below the legend is moved to the upper right corner.

    Tip

    If you hide the legend, the extra space at the right of the screen remains. Use the PlotArea.Appearance.Dimensions.Margins to add or remove buffer space around the plot area.

  • Series Labels: This section lets you set label properties for a series name selected in the Series drop down list. Uncheck the Visible box to hide the series labels. Enter a value between 0 and 360 to the Rotation entry to rotate all series labels at one time. In the example below the labels are rotated 330 degrees. Positive Rotation values rotate the labels clockwise, negative values rotate the labels counter-clockwise. Positive Distance values move the labels away from the chart series items. The example below has a distance of 60.

    Using the Wizard Labels, Legend and Titles Tab


The Wizard Axis Tab

[image]

Telerik Reporting Q2 2012
The Wizard Axis Tab
Send Feedback

The Axis tab lets you select an axis from the drop down list at the top of the page. You can then modify the properties below and they will be retained for the selected axis. Use the Copy Settings From button to replicate settings from another axis.

Visual Properties

The Visual Properties section of the page controls properties for the axis as a whole.

  • Uncheck the Visible checkbox to hide the entire axis (including labels and tick marks).
  • Axis Title text populates a single label that appears for the axis as a whole.
  • Use the Alignment property to place the axis label in a predefined position, e.g. Left, Right, Top, Bottom, Center, TopRight, TopLeft, BottomRight, BottomLeft.
  • Uncheck Show Ticks to hide the axis tick marks.
  • Uncheck Show Labels to hide the axis labels (but not the Axis Title).
  • The Value Format drop down list automatically formats axis labels as various kinds of dates, times, percentages, numbers and currency.
  • Visible Values can be All, Positive or Negative values.
  • Rotation is used to rotate the axis label text. Positive numbers spin the labels clockwise, negative numbers counter-clockwise.

Axis Labels

  • Turn off Auto Scale if you want to provide custom axis labels instead of the default numeric values. Turning off Auto Scale also lets you use the Min, Max and Step values.
  • Enter Min and Max values to control the number of series items to be displayed along that axis. Enter a Step value to control the interval between axis labels.
  • If Auto Scale is off you can use the provided list box to add, delete and reorder axis label items manually. By selecting any one of the axis label values in the listbox you can assign a text label.
  • Click the Bind Axis Labels to Database link to navigate back to the Data tab.

The Chart Wizard Axis Tab

The settings in the Axis Tab shown above result in the following X Axis labeling example:

Resulting Axis Labels


Understanding Wizard Values Data Table Tab

[image]

Telerik Reporting Q2 2012
Understanding Wizard Values Data Table Tab
Send Feedback

The Values Data Table tab of the Wizard controls the general look and positioning of the chart data table.

Data Table Drawn PlotAreaRelative

Visual Properties

  • Check Visible to display the chart data table. By default this is unchecked.
  • Select Draw Type from the drop down list to control the general size and positioning of the chart. Select AutoSize to have each cell size to the data inside of it. PlotAreaRelative places each cell just below the chart series item it represents. CellFixedSize and TableFixedSize fix the size of the cells or table irrespective of the data it contains.

Alignment

Use the Align drop down list to place the chart data table in a predefined position (e.g. Top, Bottom, BottomRight, etc.) To place the data table at exact coordinates, uncheck Auto and enter values for X and Y.

RadChart Wizard Values Data Table Tab


Building Charts

[image]

Telerik Reporting Q2 2012
Building Charts
See Also Send Feedback

To provide flexibility and best ease-of-use, Telerik provides multiple avenues to populate chart. There are three main techniques for building the chart: interactively at design-time, programmatically at runtime and by data binding.

In simple scenarios or to test out a design you can use the design-time interface to build the entire chart. Collection editors provide a consistent interface and easy navigation over all your chart series and series items. You can also use the Chart Wizard to display a subset of the data.

Most business applications display some sort of database data so Chart fully supports binding data source data to labels and data elements via the Data Source Components. The chart item also supports data binding to the X-Axis.

To create Telerik.Reporting.Charting..::.Chart and populate the ChartSeries and ChartSeriesItem collections:

  • At design time by using the editors for ChartSeries and ChartSeriesItem collections.
  • Binding to a datasource at run time or design time.

  • Bind to a datasource programmatically to populate the ChartSeries and ChartSeriesItem collections. See this minimal example of creating and populating a Chart programmatically or this more complex example.

See Also

Other Resources

Populate Chart at Design-Time
Creating Chart Programmatically
Creating Chart Programmatically - more complex example
Data Binding Chart
How-To: Programmatically Data Binding Chart to a Generic List of Objects


Populate Chart at Design-Time

[image]

Telerik Reporting Q2 2012
Populate Chart at Design-Time
See Also Send Feedback

The chart provides two collection editors: ChartSeries Collection Editor and ChartSeriesItem Collection Editor. They allow you to easily create series and items, and set the relevant properties without writing any code.

There are two basic steps to populate the Chart with data:

  1. Click on the Telerik.Reporting.Charting..::.ChartSeriesCollection property ellipses to display the ChartSeries Collection Editor. Here you can add or remove series in the Members list box on the left side of the editor. You can set the series level properties by selecting a series member and editing properties in the properties window located on the right hand side of the editor. See topics Series Overview, Series Items and Series-Specific Properties \ for more information. Note the Telerik.Reporting.Charting..::.ChartSeriesItemsCollection property under the Telerik.Reporting.Charting..::.ChartSeriesCollection property category.

    ChartSeries Collection Editor

  2. Click the Telerik.Reporting.Charting..::.ChartSeriesItemsCollection property ellipses of a series to display the ChartSeriesItem Collection Editor. Here you can add or remove items in the Members list box on the left side of the editor. Select Telerik.Reporting.Charting..::.ChartSeriesItem objects in the Members list box on the left side of the editor. You can set item properties by selecting an item member and editing properties in the properties window located on the right hand side of the editor. Set the values for each item using the properties under the "Basic value set" property category. See Series Items for more information.

    ChartSeriesItem Collection Editor

The running application shows Telerik.Reporting.Charting..::.ChartSeries members in the Legend and Telerik.Reporting.Charting..::.ChartSeriesItem as bars in the plot area.

Note

This chart example also displays customization in the legend and axis labels. See Legends and Axis Labels for more information.

Completed Chart populated at Design Time

See Also

Other Resources

Building Charts
Creating Chart Programmatically


Creating Chart Programmatically

[image]

Telerik Reporting Q2 2012
Creating Chart Programmatically
See Also Send Feedback

The steps below show how to create a minimal chart definition (i.e. Telerik.Reporting.Charting..::.Chart) programmatically. See Creating Chart Programmatically - more complex example topic for more info how to create multiple series and how appearance can be tailored at run-time.

Once the chart definition is created, you need to create ChartSeries and ChartSeriesItem collections.

Note

The example below is an alternative to using the Report Designer for creating a chart. The approach of hardcoding data in the series is for the sake of the example and would produce a static chart. This code should not be used for programmatic creation of dynamic charts based on data, for such scenario, see How-To: Programmatically Data Binding Chart to a Generic List of Objects.

  1. First add the namespaces that support the objects to be referenced. The Telerik.Reporting.Charting namespace supports the Telerik.Reporting.Charting..::.Chart declaration.
    CopyC#
    using Telerik.Reporting.Charting;
    CopyVB.NET
    Imports Telerik.Reporting.Charting
  2. Next construct the Telerik.Reporting.Charting..::.Chart item itself.
    CopyC#
    Telerik.Reporting.Chart progchart = new Telerik.Reporting.Chart();
progchart.BitmapResolution = 96F;
progchart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf;
progchart.Location = new Telerik.Reporting.Drawing.PointU(Telerik.Reporting.Drawing.Unit.Cm(0.3), Telerik.Reporting.Drawing.Unit.Cm(1.8));
progchart.Name = "progchart1";
progchart.PlotArea.EmptySeriesMessage.Appearance.Visible = true;
progchart.PlotArea.EmptySeriesMessage.Visible = true;
progchart.Size = new Telerik.Reporting.Drawing.SizeU(Telerik.Reporting.Drawing.Unit.Cm(9.6), Telerik.Reporting.Drawing.Unit.Cm(6.1));
    CopyVB.NET
    Dim progchart As New Telerik.Reporting.Chart()
progchart.BitmapResolution = 96.0F
progchart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf
progchart.Location = New Telerik.Reporting.Drawing.PointU(Telerik.Reporting.Drawing.Unit.Cm(0.3), Telerik.Reporting.Drawing.Unit.Cm(1.8))
progchart.Name = "progchart1"
progchart.PlotArea.EmptySeriesMessage.Appearance.Visible = True
progchart.PlotArea.EmptySeriesMessage.Visible = True
progchart.Size = New Telerik.Reporting.Drawing.SizeU(Telerik.Reporting.Drawing.Unit.Cm(9.6), Telerik.Reporting.Drawing.Unit.Cm(6.1))

  3. Construct a new ChartSeries object and assign a name to it. Set the Telerik.Reporting.Charting..::.ChartSeriesType to be Bar. Using the ChartSeries..::.AddItem method, add a series of ChartSeriesItem objects to the series Items Telerik.Reporting.Charting..::.ChartSeriesItemsCollection collection. The latter method takes as parameters a double "Value" and a string "Label".

    CopyC#
    // Create a ChartSeries and assign its name and chart type
ChartSeries chartSeries = new ChartSeries();
chartSeries.Name = "Sales";
chartSeries.Type = ChartSeriesType.Bar;
// add new items to the series,
// passing a value and a label string
chartSeries.AddItem(120, "Internet");
chartSeries.AddItem(140, "Retail");
chartSeries.AddItem(35, "Wholesale");
    CopyVB.NET
    ' Create a ChartSeries and assign its name and chart type
Dim chartSeries As New ChartSeries()
chartSeries.Name = "Sales"
chartSeries.Type = ChartSeriesType.Bar
' add new items to the series,
' passing a value and a label string
chartSeries.AddItem(120, "Internet")
chartSeries.AddItem(140, "Retail")
chartSeries.AddItem(35, "Wholesale")

  4. Finally, add the ChartSeries to the chart series collection and add the chart to a report section (detail section in the example).

    CopyC#
    // add the series to the Chart Series collection
progchart.Series.Add(chartSeries);
// add the Chart to the page.
this.detail.Items.Add(progchart);
    CopyVB.NET
    ' add the series to the Chart Series collection
progchart.Series.Add(chartSeries)
' add the Chart to the page.
Me.detail.Items.Add(progchart)
  5. The finished chart should look like this example:
    Programmatically Created Chart at Runtime

See Also

Other Resources

Building Charts
Populate Chart at Design-Time
Creating Chart Programmatically - more complex example
How-To: Programmatically Data Binding Chart to a Generic List of Objects
Multiple Chart Types in a Single Chart


Creating Chart Programmatically - more complex example

[image]

Telerik Reporting Q2 2012
Creating Chart Programmatically - more complex example
See Also Send Feedback

Programmatically Created Chart

The figure above shows a more complex chart than the minimal example of programmatically created Chart. This example demonstrates how to:

  • Create the chart, define the chart title and the title's appearance.
  • Define two different chart series, how to hide the series labels and tailor the series appearance.
  • Add multiple chart series items with data.
  • How to display point marks to highlight the data points.
  • Fill the plot area background with a gradient color.
  • Set axis line and label appearance.
Note

The example below is an alternative to using the Report Designer for creating a chart. The approach of hardcoding data in the series is for the sake of the example and would produce a static chart. This code should not be used for programmatic creation of dynamic charts based on data, for such scenario, see How-To: Programmatically Data Binding Chart to a Generic List of Objects.

CopyC#
// Define chart and title
Telerik.Reporting.Chart Chart = new Telerik.Reporting.Chart();
Chart.BitmapResolution = 96F;
Chart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf;
Chart.Location = new Telerik.Reporting.Drawing.PointU(new Telerik.Reporting.Drawing.Unit(0.32, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))), new Telerik.Reporting.Drawing.Unit(1.8, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))));
Chart.Name = "progchart1";
Chart.PlotArea.EmptySeriesMessage.Appearance.Visible = true;
Chart.PlotArea.EmptySeriesMessage.Visible = true;
Chart.PlotArea.XAxis.AxisLabel.Visible = true;
Chart.PlotArea.YAxis.AxisLabel.Visible = true;
Chart.Size = new Telerik.Reporting.Drawing.SizeU(new Telerik.Reporting.Drawing.Unit(9.6, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))), new Telerik.Reporting.Drawing.Unit(6.1, ((Telerik.Reporting.Drawing.UnitType)(Telerik.Reporting.Drawing.UnitType.Cm))));
Chart.ChartTitle.TextBlock.Text = "My Chart";
Chart.ChartTitle.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Blue;
// Define chart series
ChartSeries chartSeries = new ChartSeries();
chartSeries.Appearance.LabelAppearance.Visible = false;
chartSeries.Name = "GDP";
chartSeries.Type = ChartSeriesType.Line;
chartSeries.Appearance.LineSeriesAppearance.Color =
System.Drawing.Color.BlueViolet;
// Define the items in the series
chartSeries.AddItem(1);
chartSeries.AddItem(1.5);
chartSeries.AddItem(2.0);
chartSeries.AddItem(2.5);
chartSeries.AddItem(3.5);
// visually enhance the data points
chartSeries.Appearance.PointMark.Dimensions.Width = 5;
chartSeries.Appearance.PointMark.Dimensions.Height = 5;
chartSeries.Appearance.PointMark.FillStyle.MainColor =
System.Drawing.Color.Black;
chartSeries.Appearance.PointMark.Visible = true;
// Define chart series
ChartSeries chartSeries2 = new ChartSeries();
chartSeries2.Appearance.LabelAppearance.Visible = false;
chartSeries2.Name = "GNP";
chartSeries2.Type = ChartSeriesType.Line;
chartSeries2.Appearance.LineSeriesAppearance.Color =
System.Drawing.Color.Green;
// Define the items in the series
chartSeries2.AddItem(2);
chartSeries2.AddItem(3);
chartSeries2.AddItem(3.5);
chartSeries2.AddItem(4);
chartSeries2.AddItem(4.5);
// visually enhance the data points
chartSeries2.Appearance.PointMark.Dimensions.Width = 5;
chartSeries2.Appearance.PointMark.Dimensions.Height = 5;
chartSeries2.Appearance.PointMark.FillStyle.MainColor =
System.Drawing.Color.Black;
chartSeries2.Appearance.PointMark.Visible = true;
// set the plot area gradient background fill
Chart.PlotArea.Appearance.FillStyle.FillType =
Telerik.Reporting.Charting.Styles.FillType.Gradient;
Chart.PlotArea.Appearance.FillStyle.MainColor =
System.Drawing.Color.FromArgb(65, 201, 254);
Chart.PlotArea.Appearance.FillStyle.SecondColor =
System.Drawing.Color.FromArgb(0, 107, 186);
// Set text and line for X axis
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Text = "Years";
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Red;
Chart.PlotArea.XAxis.Appearance.Width = 3;
Chart.PlotArea.XAxis.Appearance.Color = System.Drawing.Color.Red;
// Set text and line for Y axis
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Text = "%";
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color =
System.Drawing.Color.Red;
Chart.PlotArea.YAxis.Appearance.Width = 3;
Chart.PlotArea.YAxis.Appearance.Color = System.Drawing.Color.Red;
// Add the series to the chart, chart to page.
Chart.Series.Add(chartSeries);
Chart.Series.Add(chartSeries2);

this.detail.Items.AddRange(new Telerik.Reporting.ReportItemBase[] { Chart });
CopyVB.NET
' Define chart and title
Dim Chart As New Telerik.Reporting.Chart()
Chart.BitmapResolution = 96.0F
Chart.ImageFormat = System.Drawing.Imaging.ImageFormat.Emf
Chart.Location = New Telerik.Reporting.Drawing.PointU(New Telerik.Reporting.Drawing.Unit(0.32, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(1.8, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))
Chart.Name = "progchart1"
Chart.PlotArea.EmptySeriesMessage.Appearance.Visible = True
Chart.PlotArea.EmptySeriesMessage.Visible = True
Chart.PlotArea.XAxis.AxisLabel.Visible = True
Chart.PlotArea.YAxis.AxisLabel.Visible = True
Chart.Size = New Telerik.Reporting.Drawing.SizeU(New Telerik.Reporting.Drawing.Unit(9.6, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))), New Telerik.Reporting.Drawing.Unit(6.1, (DirectCast((Telerik.Reporting.Drawing.UnitType.Cm), Telerik.Reporting.Drawing.UnitType))))
Chart.ChartTitle.TextBlock.Text = "My Chart"
Chart.ChartTitle.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Blue
' Define chart series
Dim chartSeries As New ChartSeries()
chartSeries.Appearance.LabelAppearance.Visible = False
chartSeries.Name = "GDP"
chartSeries.Type = ChartSeriesType.Line
chartSeries.Appearance.LineSeriesAppearance.Color = System.Drawing.Color.BlueViolet
' Define the items in the series
chartSeries.AddItem(1)
chartSeries.AddItem(1.5)
chartSeries.AddItem(2)
chartSeries.AddItem(2.5)
chartSeries.AddItem(3.5)
' visually enhance the data points
chartSeries.Appearance.PointMark.Dimensions.Width = 5
chartSeries.Appearance.PointMark.Dimensions.Height = 5
chartSeries.Appearance.PointMark.FillStyle.MainColor = System.Drawing.Color.Black
chartSeries.Appearance.PointMark.Visible = True
' Define chart series
Dim chartSeries2 As New ChartSeries()
chartSeries2.Appearance.LabelAppearance.Visible = False
chartSeries2.Name = "GNP"
chartSeries2.Type = ChartSeriesType.Line
chartSeries2.Appearance.LineSeriesAppearance.Color = System.Drawing.Color.Green
' Define the items in the series
chartSeries2.AddItem(2)
chartSeries2.AddItem(3)
chartSeries2.AddItem(3.5)
chartSeries2.AddItem(4)
chartSeries2.AddItem(4.5)
' visually enhance the data points
chartSeries2.Appearance.PointMark.Dimensions.Width = 5
chartSeries2.Appearance.PointMark.Dimensions.Height = 5
chartSeries2.Appearance.PointMark.FillStyle.MainColor = System.Drawing.Color.Black
chartSeries2.Appearance.PointMark.Visible = True
' set the plot area gradient background fill
Chart.PlotArea.Appearance.FillStyle.FillType = Telerik.Reporting.Charting.Styles.FillType.Gradient
Chart.PlotArea.Appearance.FillStyle.MainColor = System.Drawing.Color.FromArgb(65, 201, 254)
Chart.PlotArea.Appearance.FillStyle.SecondColor = System.Drawing.Color.FromArgb(0, 107, 186)
' Set text and line for X axis
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Text = "Years"
Chart.PlotArea.XAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Red
Chart.PlotArea.XAxis.Appearance.Width = 3
Chart.PlotArea.XAxis.Appearance.Color = System.Drawing.Color.Red
' Set text and line for Y axis
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Text = "%"
Chart.PlotArea.YAxis.AxisLabel.TextBlock.Appearance.TextProperties.Color = System.Drawing.Color.Red
Chart.PlotArea.YAxis.Appearance.Width = 3
Chart.PlotArea.YAxis.Appearance.Color = System.Drawing.Color.Red
' Add the series to the chart, chart to page.
Chart.Series.Add(chartSeries)
Chart.Series.Add(chartSeries2)

Me.detail.Items.AddRange(New Telerik.Reporting.ReportItemBase() {Chart})

See Also

Other Resources

Building Charts
Populate Chart at Design-Time
Creating Chart Programmatically
How-To: Programmatically Data Binding Chart to a Generic List of Objects
Multiple Chart Types in a Single Chart


Data Binding Chart

[image]

Telerik Reporting Q2 2012
Data Binding Chart
See Also Send Feedback

As the Chart item is a Data item, it takes advantage of the Data Source Components for binding to data.

Once you have the data source defined you can use the Property Editor or code for selecting which data columns will be used to populate the chart. The key properties for binding to a data source are:

  • ChartSeries Properties Used in Data Binding:

    DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each data point in the chart.

    DataXColumn, DataXColumn2, DataYColumn, DataYColumn2: These are the names of the columns that will contain data used for the series item XValue, XValue2, YValue and YValue2 columns respectively.

  • X-Axis Properties Used in Data Binding

    DataLabelsColumn: This is the name of a data source column that will supply the text that displays next to each X Axis item.

  • Chart Properties Used in Data Binding

    DataSource: You can assign a compatible data source to the DataSource property of the chart.

    DataGroupColumn: This is the name of the column in the data source that data will be grouped by. This is similar to defining a "group by" SQL expression in the underlying query.

See Also

Other Resources

How-To: Programmatically Data Binding Chart to a Generic List of Objects
Series Overview


How-To: Programmatically Data Binding Chart to a Generic List of Objects

[image]

Telerik Reporting Q2 2012
How-To: Programmatically Data Binding Chart to a Generic List of Objects
See Also Send Feedback

You can bind to a generic lists of objects that have multiple properties. The example below binds to a list of "Product" objects that contain two properties, one property for "Name" and a second for "QuantityInStock".

Binding to Generic List of Complex Objects

The Product object is defined with a constructor that passes both Name and QuantityInStock:

CopyC#
public class Product
        {
            public Product(string name, int quantityInStock)
            {
                _name = name;
                _quantityInStock = quantityInStock;
            }
    private string _name;
            public string Name
            {
                get { return _name; }
                set { _name = value; }
            }
    private int _quantityInStock;
            public int QuantityInStock
            {
                get { return _quantityInStock; }
                set { _quantityInStock = value; }
            }
}
CopyVB.NET
Public Class Product
         Public Sub New(ByVal name As String, ByVal quantityInStock As Integer)
          _name = name
          _quantityInStock = quantityInStock
         End Sub
 Private _name As String
         Public Property Name() As String
          Get
           Return _name
          End Get
          Set
           _name = value
          End Set
         End Property
 Private _quantityInStock As Integer
         Public Property QuantityInStock() As Integer
          Get
           Return _quantityInStock
          End Get
          Set
           _quantityInStock = value
          End Set
         End Property
        End Class

After the Product object is defined the chart NeedDataSource event is used to bind to the generic List:

CopyC#
  private void chart1_NeedDataSource(object sender, EventArgs e)
                {
                    List&lt;Product&gt; products = new List&lt;Product&gt;();
                    products.Add(new Product("Parka L", 120));
                    products.Add(new Product("Parka M", 100));
                    products.Add(new Product("Parka S", 132));
                    products.Add(new Product("Wool Cap", 45));
                    products.Add(new Product("Mittens", 67));
                    Telerik.Reporting.Processing.Chart procChart = (Telerik.Reporting.Processing.Chart)sender;
                    Telerik.Reporting.Chart defChart = (Telerik.Reporting.Chart)procChart.ItemDefinition;
                    defChart.IntelligentLabelsEnabled = false;
                    ChartSeries serie = new ChartSeries();
                    serie.Type = ChartSeriesType.Pie;
                    serie.Clear();
                    serie.Appearance.LegendDisplayMode = Telerik.Reporting.Charting.ChartSeriesLegendDisplayMode.ItemLabels;
            foreach (Product lst in products)
                    {
                        ChartSeriesItem item = new ChartSeriesItem();
                        item.YValue = (double)lst.QuantityInStock;
                        item.Name = (string)lst.Name;
                        item.Appearance.Exploded = true;
                        item.Label.TextBlock.Text = (string)lst.Name + " - #%";
                        serie.Items.Add(item);
                    }
            defChart.Series.Add(serie);
                }
CopyVB.NET
Private Sub chart1_NeedDataSource(sender As Object, e As EventArgs)
         Dim products As New List(Of Product)()
         products.Add(New Product("Parka L", 120))
         products.Add(New Product("Parka M", 100))
         products.Add(New Product("Parka S", 132))
         products.Add(New Product("Wool Cap", 45))
         products.Add(New Product("Mittens", 67))
         Dim procChart As Telerik.Reporting.Processing.Chart = DirectCast(sender, Telerik.Reporting.Processing.Chart)
         Dim defChart As Telerik.Reporting.Chart = DirectCast(procChart.ItemDefinition, Telerik.Reporting.Chart)
         defChart.IntelligentLabelsEnabled = False
         Dim serie As New ChartSeries()
         serie.Type = ChartSeriesType.Pie
         serie.Clear()
         serie.Appearance.LegendDisplayMode = Telerik.Reporting.Charting.ChartSeriesLegendDisplayMode.ItemLabels
 For Each lst As Product In products
          Dim item As New ChartSeriesItem()
          item.YValue = DirectCast(lst.QuantityInStock, Double)
          item.Name = DirectCast(lst.Name, String)
          item.Appearance.Exploded = True
          item.Label.TextBlock.Text = DirectCast(lst.Name, String) + " - #%"
          serie.Items.Add(item)
         Next
 defChart.Series.Add(serie)
        End Sub

See Also

Other Resources

Data Binding Chart to a Generic List
Data Binding Chart to a Generic List of Simple Types


Styling Chart Elements

[image]

Telerik Reporting Q2 2012
Styling Chart Elements
Send Feedback

The Chart offers a set of properties to modify the look and feel of its elements. See those elements marked on the image below consider the table showing where their customization properties are located in the chart properties grid.

Rad Chart Elements

Element

Properties

  • Elements -> Legend -> Appearance
  • Elements -> Legend -> TextBlock
  • PlotArea -> YAxis -> AxisLabel
  • PlotArea -> YAxis -> Appearance -> MajorTick
  • PlotArea -> YAxis -> Appearance -> MajorGridLines
  • PlotArea -> YAxis -> Appearance -> LabelAppearance
  • PlotArea -> XAxis -> AxisLabel
  • PlotArea -> XAxis -> Appearance -> LabelAppearance
  • Data -> Series -> [series name] -> Appearance -> Appearance
  • Elements -> PlotArea -> Appearance

    • a. Chart Title
    • Elements -> ChartTitle -> Appearance
    • Elements -> ChartTitle -> TextBlock

    b. Legend

    c. Legend TextBlock (Legend Title)
    d. Y Axis
    • PlotArea -> YAxis -> Appearance

    e. Y Axis Label (Axis Title)

    f. Y Axis Major Tick

    g. Y Axis Major GridLine

    h. Y Axis Minor Tick
    • PlotArea -> YAxis -> Appearance -> MinorTicк

    i. Y Axis Minor GridLine
    • PlotArea -> YAxis -> Appearance -> MinorGridLines

    j. Y Axis Label (Digit)

    k. X Axis
    • PlotArea -> XAxis -> Appearance

    l. X Axis Label (Axis Title)

    m. X Axis Major Tick
    • PlotArea -> XAxis -> Appearance -> MajorTick

    n. X Axis Major GridLine
    • PlotArea -> XAxis -> Appearance -> MajorGridLines

    o. X Axis Label (Digit)

    p. Series 1
    • Data -> Series -> [series name] -> Appearance -> Appearance

    q. Series 2

    r. Series Item Label
    • Data -> Series -> [series name] -> Appearance -> Appearance -> TextAppearance

    s. PlotArea

    Common Appearance Properties

    All chart elements have common appearance settings, which are:

    • Border – border width, color and style
    • Corners – corner style and size
    • Dimensions – width, height, margin, padding
    • FillStyle – background color, image and gradients
    • Position
    • Shadow – color, distance and position
    • Visible – true or false


Setting The Background

[image]

Telerik Reporting Q2 2012
Setting The Background
Send Feedback

The Chart offers a variety of ways to define backgrounds. Here are the main scenarios:

1. Solid color

… -> FillStyle -> FillType -> Solid

… -> FillStyle -> MainColor ->

2. Simple 2-color gradient

… -> FillStyle -> FillType : Gradient

… -> FillStyle -> MainColor ->

… -> FillStyle -> SecondColor ->

… -> FillStyle -> FillSettings -> GradientMode ->

3. Complex Gradient

… -> FillStyle -> FillType -> ComplexGradient

… -> FillStyle -> FillSettings -> ComplexGradient -> Collection ->

… -> FillStyle -> FillSettings -> GradientAngle ->

4. Hatch (2-color pattern)

… -> FillStyle -> FillType -> Hatch

… -> FillStyle -> MainColor ->

… -> FillStyle -> SecondColor ->

… -> FillStyle -> FillSettings -> HatchStyle ->

5. Custom Image

… -> FillStyle -> FillType -> Image

… -> FillStyle -> FillSettings -> BackgroundImage ->

… -> FillStyle -> FillSettings -> ImageAlign ->

… -> FillStyle -> FillSettings -> ImageDrawMode ->

… -> FillStyle -> FillSettings -> ImageFlip ->

6. Opacity

You can achieve opacity by specifying an alpha transparency to the color, in addition to the red-green-blue values. The alpha value should come first, like this:

[transparency level0 - 255]; [red 0 - 255]; [green 0 - 255]; [blue 0 - 255]

The greater the opacity value, the less transparent the background is.


Custom Appearance Properties

[image]

Telerik Reporting Q2 2012
Custom Appearance Properties
Send Feedback

Apart from the common properties, every chart element may have unique appearance properties, e.g. “Figure”, “Rotation Angle”, “Text Properties”, etc. Here is a quick reference of the unique appearance properties of the chart and its elements.

Chart

  • Layout -> Width
  • Layout -> Height
    • Set dimensions
    Set the chart type
    • Appearance -> DefaultType
    Set series orientation
    • Appearance -> Series Orientation
    Set a series palette
    • Appearance -> SeriesPalette
    • Appearance -> CustomPalettes
    Set a predefined chart skin
    • Appearance -> Skin
    Set a bar overlap ratio How much two adjacent bars overlap each other
    • Appearance -> Appearance -> BarOverlapPercent
    Set bar width Define how much space will occupy all bars located on the same spot on the X Axis. The value represents percent of the total available space for that X Axis value.
    • Appearance -> Appearance -> BarWidthPercent
    Set text quality
    • Appearance -> Appearance -> TextQuality
    Set alternative text (accessibility feature)
    • Appearance -> AlternativeText
    Set the image MIME type (file type)
    • Settings -> ChartImageFormat

    Chart title

    Set the form
    • Elements -> ChartTitle -> Appearance -> Figure
    Set a rotation angle
    • Elements -> ChartTitle -> Appearance -> RotationAngle
    Style the chart title marker
    • Elements -> ChartTitle -> Marker -> Appearance

    Legend

    Style the legend title
    • Elements -> Legend -> TextBlock
    Style the legend marker
    • Elements -> Legend -> Marker -> Appearance
    Style the legend items’ appearance
    • Elements -> Legend -> Appearance -> ItemAppearance
    • Elements -> Legend -> Appearance -> ItemMarkerAppearance
    • Elements -> Legend -> Appearance -> ItemTextAppearance
    Set legend items’ orientation
    • Elements -> Legend -> Appearance -> Overflow
    Set a rotation angle
    • Elements -> Legend -> Appearance -> RotationAngle

    PlotArea and Axes

    Style the empty series (no data) message
    • Elements -> PlotArea -> EmptySeriesMessage
    Set intelligent series’ label positioning
    • Elements -> PlotArea -> IntelligentLabelsEnabled
    Set the axis’ layout mode Determine whether the axis values’ positions match the gridlines or the values are places between the gridlines
    • Elements -> PlotArea -> [axis] -> LayoutMode
    Style the axis’ maximum value end
    • Elements -> PlotArea -> axis [axis] -> Appearance -> Cap


Step-By-Step Skinning Example

[image]

Telerik Reporting Q2 2012
Step-By-Step Skinning Example
Send Feedback

Here is a list of the steps one has to make in order to style Chart to look like the image we used when describing the Chart elements. We start with a plain chart with no visual properties defined.

  1. Styling the chart’s borders and background
    1. Appearance -> Appearance -> Border -> Color : 0; 66; 110
    2. Appearance -> Appearance -> Border -> Width : 5
    3. Appearance -> Appearance -> FillStyle -> FillType : Gradient
    4. Appearance -> Appearance -> FillStyle -> FillSettings -> GradientMode : Center
    5. Appearance -> Appearance -> FillStyle -> MainColor : 35; 189; 254
    6. Appearance -> Appearance -> FillStyle -> SecondColor : 26; 120; 179
  2. Styling the title
    1. Elements -> ChartTitle -> Appearance -> Border -> Visible : False
    2. Elements -> ChartTitle -> Appearance -> FillStyle -> MainColor : None / Transparent
    3. Elements -> ChartTitle -> TextBlock -> Appearance -> TextProperties -> Color : White
    4. Elements -> ChartTitle -> TextBlock -> Appearance -> TextProperties -> Font : Verdana; 14pt
    5. Elements -> ChartTitle -> Appearance ->Position -> AlignedPosition : TopLeft
    6. Elements -> ChartTitle -> Appearance -> Dimensions -> Margins : 4%; 10px; 14px; 8%
  3. Styling the legend
    1. Elements -> Legend -> Appearance -> FillStyle -> MainColor : None / Transparent
    2. Elements -> Legend -> Appearance -> Border -> Visible : False
    3. Elements -> Legend -> Appearance -> ItemTextAppearance -> TextProperties -> Color : White
    4. Elements -> Legend -> TextBlock -> Text : Legend
    5. Elements -> Legend -> TextBlock -> Visible : True
    6. Elements -> Legend -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
    7. Elements -> Legend -> TextBlock -> Appearance -> Position -> AlignedPosition : Top
    8. Elements -> Legend -> Appearance -> Position -> AlignedPosition -> BottomRight
    9. Elements -> Legend -> Appearance -> Dimensions -> Margins : 1px; 3%; 12%; 1px
  4. Styling the plotarea
    1. Elements -> PlotArea -> Appearance -> Border -> Color : 97; 180; 223
    2. Elements -> PlotArea -> Appearance -> FillStyle -> MainColor : 50; 255; 255; 255
    3. Elements -> PlotArea -> Appearance -> Dimensions -> Margins : 18%; 90px; 15%; 10%
  5. Styling the X Axis
    1. Elements -> PlotArea -> XAxis -> Appearance -> Color : 96; 164; 205
    2. Elements -> PlotArea -> XAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    3. Elements -> PlotArea -> XAxis -> Appearance -> MajorTick -> Color : 96; 164; 205
    4. Elements -> PlotArea -> XAxis -> Appearance -> TextAppearance -> TextProperties -> Color : White
    5. Elements -> PlotArea -> XAxis -> AxisLabel -> TextBlock -> Text -> X Axis
    6. Elements -> PlotArea -> XAxis -> AxisLabel -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
    7. Elements -> PlotArea -> XAxis -> AxisLabel -> Appearance -> Dimensions -> Paddings : 1px; 1px; 10%; 1px
  6. Styling the Y Axis
    1. Elements -> PlotArea -> YAxis -> Appearance -> Color : 95; 165; 208
    2. Elements -> PlotArea -> YAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    3. Elements -> PlotArea -> YAxis -> Appearance -> MajorTick -> Color : 95; 165; 208
    4. Elements -> PlotArea -> YAxis -> Appearance -> MajorGridLines -> Color : 120; 209; 248
    5. Elements -> PlotArea -> YAxis -> Appearance -> MinorTick -> Color : 95; 165; 208
    6. Elements -> PlotArea -> YAxis -> Appearance -> TextAppearance -> TextProperties -> Color : White
    7. Elements -> PlotArea -> YAxis -> AxisLabel -> TextBlock -> Text -> Y Axis
    8. Elements -> PlotArea -> YAxis -> AxisLabel -> TextBlock -> Appearance -> TextProperties -> Color : LightSkyBlue
  7. Styling the data series
    1. Data -> Series -> Series 1 -> Appearance -> Appearance -> Border -> Color : 153; 209; 248
    2. Data -> Series -> Series 1 -> Appearance -> Appearance -> FillStyle -> MainColor : 213; 247; 255
    3. Data -> Series -> Series 1 -> Appearance -> Appearance -> FillStyle -> SecondColor : 157; 217; 238
    4. Data -> Series -> Series 1 -> Appearance -> Appearance -> TextAppearance -> TextProperties -> Color : White
    5. Data -> Series -> Series 2 -> Appearance -> Appearance -> Border -> Color : 67; 181; 229
    6. Data -> Series -> Series 2 -> Appearance -> Appearance -> FillStyle -> MainColor : 136; 221; 246
    7. Data -> Series -> Series 2 -> Appearance -> Appearance -> FillStyle -> SecondColor : 59; 161; 197
    8. Data -> Series -> Series 2 -> Appearance -> Appearance -> TextAppearance -> TextProperties -> Color : White


How Do I add Axis Labels Programmatically?

[image]

Telerik Reporting Q2 2012
How Do I add Axis Labels Programmatically?
Send Feedback

To add labels along an Axis programmatically:

  • Set AutoScale to false.
  • Add a range of items to the axis.
  • Populate the Items.

XAxis Labels

CopyC#
Chart.PlotArea.XAxis.AutoScale = false;
Chart.PlotArea.XAxis.AddRange(1, 7, 1);
Chart.PlotArea.XAxis[0].TextBlock.Text = "Mon";
Chart.PlotArea.XAxis[1].TextBlock.Text = "Tue";
Chart.PlotArea.XAxis[2].TextBlock.Text = "Wed";
Chart.PlotArea.XAxis[3].TextBlock.Text = "Thu";
Chart.PlotArea.XAxis[4].TextBlock.Text = "Fri";
Chart.PlotArea.XAxis[5].TextBlock.Text = "Sat";
Chart.PlotArea.XAxis[6].TextBlock.Text = "Sun";
CopyVB.NET
    Chart.PlotArea.XAxis.AutoScale = False
Chart.PlotArea.XAxis.AddRange(1, 7, 1)
Chart.PlotArea.XAxis(0).TextBlock.Text = "Mon"
Chart.PlotArea.XAxis(1).TextBlock.Text = "Tue"
Chart.PlotArea.XAxis(2).TextBlock.Text = "Wed"
Chart.PlotArea.XAxis(3).TextBlock.Text = "Thu"
Chart.PlotArea.XAxis(4).TextBlock.Text = "Fri"
Chart.PlotArea.XAxis(5).TextBlock.Text = "Sat"
Chart.PlotArea.XAxis(6).TextBlock.Text = "Sun"


How Do I Assign Individual Colors to Bars?

[image]

Telerik Reporting Q2 2012
How Do I Assign Individual Colors to Bars?
Send Feedback

"I need each bar in a bar chart to be a different color. How do I do this?"

By default the chart is designed so that all bars from a series have the same colors. If you need each to have a different color, loop through each chart series item and assign them a color from an array. This should be done after binding the chart, so the chart series items are available.

Colors Assigned to Individual Items

CopyC#
public ChartReport()
{
/// &lt;summary&gt;
/// Required for telerik Reporting designer support
/// &lt;/summary&gt;
InitializeComponent();
//
// TODO: Add any constructor code after InitializeComponent call
//
            Color[] barColors = new Color[8]{
                Color.Purple,
                Color.SteelBlue,
                Color.Aqua,
                Color.Yellow,
                Color.Navy,
                Color.Green,
                Color.Blue,
                Color.Red
            };
                int i = 0;
                foreach (ChartSeriesItem item in chart1.Series[0].Items)
                {
                    item.Appearance.FillStyle.MainColor = barColors[i++];
                }
            }
        }
CopyVB.NET
Public Sub New()
         ''' &lt;summary&gt;
         ''' Required for telerik Reporting designer support
         ''' &lt;/summary&gt;
 InitializeComponent()
          '
          ' TODO: Add any constructor code after InitializeComponent call
          '
         Dim barColors As Color() = New Color(8) {Color.Purple, Color.SteelBlue, Color.Aqua, Color.Yellow, Color.Navy, Color.Green, _
          Color.Blue, Color.Red}

          For Each item As ChartSeriesItem In chart1.Series(0).Items
           item.Appearance.FillStyle.MainColor = barColors(System.Math.Max(System.Threading.Interlocked.Increment(i),i - 1))
          Next
         End If
        End Sub


How do I make colors display with partial transparency?

[image]

Telerik Reporting Q2 2012
How do I make colors display with partial transparency?
Send Feedback

"If I have several series that overlap and I want partial transparency so I can see all series at one time (without it being a stacked chart), how do I set a color to be transparent?"

When defining the color, add an "alpha" channel, i.e. a percentage of transparency to the beginning of the array that defines the color. For example:

255, 0, 0 = Red

80, 255, 0, 0 = Red that is 80% transparent.

In the example below both series have a main color with a transparency of 90%.

Transparent Colors


Multiple Chart Types in a Single Chart

[image]

Telerik Reporting Q2 2012
Multiple Chart Types in a Single Chart
Send Feedback

The Chart allows you to combine several chart types in a single chart. You can use the ChartSeries Telerik.Reporting.Charting..::.ChartSeries Collection Editor at design-time to create the ChartSeries Telerik.Reporting.Charting..::.ChartSeries and set the respective ChartSeriesType Telerik.Reporting.Charting..::.ChartSeriesType . You can also add chart series and set chart type programmatically.

To designate dissimilar chart types in a single chart at design time, click on a series, then select the Type property from the drop down list.

Setting the Series Chart Type

To assign chart types to a series at run-time programmatically you can pass the ChartSeriesType Telerik.Reporting.Charting..::.ChartSeriesType in the constructor or assign the ChartSeriesType Telerik.Reporting.Charting..::.ChartSeriesType after the series is constructed. The example below passes three chart series types to the constructor.

CopyC#
ChartSeries chartSeries =
          new ChartSeries("Average Temperatures", ChartSeriesType.Bar);
        ChartSeries chartSeries2 =
          new ChartSeries("Maximum Temperatures", ChartSeriesType.Line);
        ChartSeries chartSeries3 =
          new ChartSeries("Minimum Temperatures", ChartSeriesType.Bubble);
CopyVB.NET
Dim chartSeries As New ChartSeries("Average Temperatures", ChartSeriesType.Bar)
        Dim chartSeries2 As New ChartSeries("Maximum Temperatures", ChartSeriesType.Line)
        Dim chartSeries3 As New ChartSeries("Minimum Temperatures", ChartSeriesType.Bubble)

Use the Axis.Range property to set minimum values, maximum values and step amount for each axis. The screen shot below shows three chart series types in the same chart. See below for the full source.

Multiple Chart Types in a Single Chart


How Do I extend the Displayable Area for YAxis Data?

[image]

Telerik Reporting Q2 2012
How Do I extend the Displayable Area for YAxis Data?
Send Feedback

"My data touches the upper boundary of the plot area but that makes the data harder to see. How do I extend the viewable area along the YAxis?"

Assign the YAxis Telerik.Reporting.Charting..::.ChartYAxisMode property. By default the ChartYAxisMode property value is Normal and the YAxis data fills the available space.

myChart.PlotArea.YAxis.AxisMode = ChartYAxisMode.Normal;

ChartYAxisMode is Normal

If you set the ChartYAxisMode Telerik.Reporting.Charting..::.ChartYAxisMode to Extended, additional area is placed above the highest data point to make the chart easier to read.

myChart.PlotArea.YAxis.AxisMode = ChartYAxisMode.Extended;

ChartYAxisMode is Extended


Report Book

[image]

Telerik Reporting Q2 2012
Report Book
Send Feedback

The main goal of a report book is combining different reports into one for the purposes of printing them at once or exporting them to a single file. Reports are displayed in the order they were added to the report book, each report starting on a new page.

In This Section

  • Report Book Parameters
  • Report Book Paging
  • Page Settings, Sizes and Naming
  • Walk-Through for the Web report viewer
  • Walk-Through for the Windows forms viewer


Report Book Parameters
Send Feedback

Report Book Parameters

Often one or more reports that are part of a report book will contain report parameters. The report book is shown as a single document in the report viewer and the parameters area is constructed based on the report parameters defined in all child reports.

Telerik Reporting provides a mechanism known as parameter merging. The rule for merging parameters is straightforward. If the Name and Type of two (or more) parameters from different reports are the same, then they are considered equivalent and are displayed as a single parameter in the parameters area.

Note

When one or more parameters are merged the UI settings of the first one are used for displaying it in the parameters area

You can control parameter merging via the Mergeable boolean property of the ReportParameter class. The default value of the Mergeable property is true. Set the Mergeable property to false if you want to prevent a parameter from being merged with its equivalent ones.

The parameter values for non mergeable report parameters are set in the following format:

  • TelerikReportingRepeatingParameter1_MyParam
  • TelerikReportingRepeatingParameter2_MyParam
  • .....

MyParam is the actual name of the report parameter and TelerikReportingRepeatingParameter is a prefix with a number depending on how many times a non mergeable parameter is present in a ReportBook.


Report Book Paging
See Also Send Feedback

Report Book Paging

Reports are displayed in the order they were added to the report book, each report starting on a new page. The way pages are counted (the evaluation of the 'PageNumber' global object) may be different in the context of a report book compared to counting pages in a single report. The Report class has a property of type PageNumberingStyle that will let you control the behavior of page counting in the context of a report book.

Note

The PageNumberingStyle property has meaning and effect only when the report is part of a report book.

The PageNumberingStyle enumeration has three values with self-explanatory names. "ResetNumbering" resets page numbering while page count aggregation continues, ResetNumberingAndCount resets both page numbering and page count and "Continue" indicates that both page numbering and page count aggregations continue from where the previous report in the book has left off. The default value of this property is "Continue". Below is a small example of how to use the PageNumberingStyle assuming that each of the three reports has a total of two pages:

The value of the TextBox in the PageHeader is equal to = "Page: " + PageNumber + " of " + PageCount

PageNumberingStyle.Continue

CopyC#
ReportBook reportBook = new ReportBook();
reportBook.Reports.Add(new ReportA());
reportBook.Reports.Add(new ReportB());
reportBook.Reports.Add(new ReportC());
// "Continue" is the default value so there is no need to set up anything
CopyVB.NET
Dim reportBook As New ReportBook()
reportBook.Reports.Add(New ReportA())
reportBook.Reports.Add(New ReportB())
reportBook.Reports.Add(New ReportC())
' "Continue" is the default value so there is no need to set up anything

PageNumberingStyle.ResetNumbering

CopyC#
ReportBook reportBook = new ReportBook();
reportBook.Reports.Add(new ReportA());
reportBook.Reports.Add(new ReportB());
reportBook.Reports.Add(new ReportC());
reportBook.Reports[0].PageNumberingStyle = PageNumberingStyle.ResetNumbering;
reportBook.Reports[1].PageNumberingStyle = PageNumberingStyle.ResetNumbering;
reportBook.Reports[2].PageNumberingStyle = PageNumberingStyle.ResetNumbering;
CopyVB.NET
Dim reportBook As New ReportBook()
reportBook.Reports.Add(New ReportA())
reportBook.Reports.Add(New ReportB())
reportBook.Reports.Add(New ReportC())
reportBook.Reports(0).PageNumberingStyle = PageNumberingStyle.ResetNumbering
reportBook.Reports(1).PageNumberingStyle = PageNumberingStyle.ResetNumbering
reportBook.Reports(2).PageNumberingStyle = PageNumberingStyle.ResetNumbering

PageNumberingStyle.ResetNumberingAndCount

CopyC#
ReportBook reportBook = new ReportBook();
reportBook.Reports.Add(new ReportA());
reportBook.Reports.Add(new ReportB());
reportBook.Reports.Add(new ReportC());
reportBook.Reports[0].PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount;
reportBook.Reports[1].PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount;
reportBook.Reports[2].PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount;
CopyVB.NET
Dim reportBook As New ReportBook()
reportBook.Reports.Add(New ReportA())
reportBook.Reports.Add(New ReportB())
reportBook.Reports.Add(New ReportC())
reportBook.Reports(0).PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount
reportBook.Reports(1).PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount
reportBook.Reports(2).PageNumberingStyle = PageNumberingStyle.ResetNumberingAndCount

See Also

Other Resources

Report Book Parameters
Page Settings, Sizes and Naming


Page Settings, Sizes and Naming

[image]

Telerik Reporting Q2 2012
Page Settings, Sizes and Naming
See Also Send Feedback

Page Settings and Sizes

Physical page formats such as Image, PDF and RTF support combining reports with different page sizes into one report book. When rendering to one of those formats, each page will preserve the size from the page settings of the report it belongs to.

The HTML rendering extension also supports different page sizes for a report book. The only difference from the physical page formats is that HTML works with logical pages whose sizes are determined based on report item definitions before the actual rendering starts.

When exporting to XLS, each report will occupy a separate worksheet in the Excel workbook.

The CSV rendering extension simply combines all reports one after the other in the CSV file it produces.

Caution

When viewing a Report Book in the Viewer the Page Settings button is disabled by design

Document Name

You can use the DocumentName property of a Report Book to suggest a file name when exporting in exactly the same manner as you would do with a single report.

See Also

Other Resources

Report Book Parameters
Report Book Paging


Walk-Through for the Web report viewer

[image]

Telerik Reporting Q2 2012
Walk-Through for the Web report viewer
Send Feedback

Creating a Report Book at Design-time

Report Books can be created either at design-time or on the fly at run-time. Follow these steps to create a Report Book at design-time:

  1. Add a ReportViewer to your form by following the help topic: Embedding the Web Report Viewer on a Form
  2. Add a ReportBookControl control from the "Telerik Reporting" tab of the Visual Studio Toolbox to the design surface.
  3. Use the smart tag of the ReportBookControl to open a dialog which lets you choose the reports you want to add. Select the reports and adjust the order in which you would like them to appear in the report book.
    Caution

    Make sure you have built the project(s) containing the report(s) that you want to add

  4. Select the ReportViewer control and click on the ellipsis of its "Report" property in the Properties Window. You will see an editor allowing you to choose what to display in the ReportViewer. The ReportBookControl control that you just added in step 2 should be listed under the "ReportBooks" node of the treeview.
Note

You can omit step 3 altogether and choose "Add New Report Book" from the editor. This will automatically add a new report book to the design surface, let you choose the reports and assign the new instance to the "Report" property

These are all the steps needed to create and set-up your report book at design-time.

Due to the specifics of the web apps/sites, the ReportBookControl web control is created simply for the purpose of design time. When you need to add report book programmatically, you should use the ReportBook() class as shown below.

Creating a Report Book at run-time

Depending on the business logic of your application there might be cases in which you will not be able to determine the reports you need in advance. If that is the case you can programmatically create a report book at run time by using the Telerik Reporting API. Simply create an instance of the ReportBook class and add the necessary reports to its "Reports" collection. Alternatively, you can derive from the ReportBook class and initialize the book in the constructor if you want to separate the report book implementation details from the rest of your code. Below is an oversimplified sample that demonstrates those two techniques:

CopyC#
ReportBook reportBook = new ReportBook();
reportBook.Reports.Add(new TableOfContentsReport());
switch (DateTime.Now.DayOfWeek)
{
   case DayOfWeek.Saturday:
   case DayOfWeek.Sunday:
        reportBook.Reports.Add(new WeekendReport());
        break;
   default:
        reportBook.Reports.Add(new WeekdayReport());
        break;
}
reportBook.Reports.Add(new GlossaryReport());
reportBook.Reports.Add(new IndexReport());
CopyVB.NET
Dim reportBook As New ReportBook()
reportBook.Reports.Add(New TableOfContentsReport())
Select Case DateTime.Now.DayOfWeek
    Case DayOfWeek.Saturday, DayOfWeek.Sunday
        reportBook.Reports.Add(New WeekendReport())
        Exit Select
    Case Else
        reportBook.Reports.Add(New WeekdayReport())
        Exit Select
End Select
reportBook.Reports.Add(New GlossaryReport())
reportBook.Reports.Add(New IndexReport())


Walk-Through for the Windows forms viewer

[image]

Telerik Reporting Q2 2012
Walk-Through for the Windows forms viewer
Send Feedback

Creating a Report Book at Design-time

Report Books can be created either at design-time or on the fly at run-time. Follow these steps to create a Report Book at design-time:

  1. Add a ReportViewer to your form by following the help topic: Embedding the Windows Forms Report Viewer on a Form
  2. Add a ReportBook component from the "Telerik Reporting" tab of the Visual Studio Toolbox to the design surface.
  3. You will be presented with a dialog to choose the reports once you have added the report book component to the design surface. Select the reports and adjust the order in which you would like them to appear in the report book.
    Caution

    Make sure you have built the project(s) containing the report(s) that you want to add

  4. Select the ReportViewer control and click on the ellipsis of its "Report" property in the Properties Window. You will see an editor allowing you to choose what to display in the ReportViewer. The report book component that you just added in step 3 should be listed under the "Instances" node of the treeview.
Note

You can omit step 3 altogether and choose "Add New Report Book" from the editor. This will automatically add a new report book to the design surface, let you choose the reports and assign the new instance to the "Report" property

These are all the steps needed to create and set-up your report book at design-time.

Creating a Report Book at run-time

Depending on the business logic of your application there might be cases in which you will not be able to determine the reports you need in advance. If that is the case you can programmatically create a report book at run time by using the Telerik Reporting API. Simply create an instance of the ReportBook class and add the necessary reports to its "Reports" collection. Alternatively, you can derive from the ReportBook class and initialize the book in the constructor if you want to separate the report book implementation details from the rest of your code. Below is an oversimplified sample that demonstrates those two techniques:

CopyC#
ReportBook reportBook = new ReportBook();
reportBook.Reports.Add(new TableOfContentsReport());
switch (DateTime.Now.DayOfWeek)
{
   case DayOfWeek.Saturday:
   case DayOfWeek.Sunday:
        reportBook.Reports.Add(new WeekendReport());
        break;
   default:
        reportBook.Reports.Add(new WeekdayReport());
        break;
}
reportBook.Reports.Add(new GlossaryReport());
reportBook.Reports.Add(new IndexReport());
CopyVB.NET
Dim reportBook As New ReportBook()
reportBook.Reports.Add(New TableOfContentsReport())
Select Case DateTime.Now.DayOfWeek
    Case DayOfWeek.Saturday, DayOfWeek.Sunday
        reportBook.Reports.Add(New WeekendReport())
        Exit Select
    Case Else
        reportBook.Reports.Add(New WeekdayReport())
        Exit Select
End Select
reportBook.Reports.Add(New GlossaryReport())
reportBook.Reports.Add(New IndexReport())


Creating Multi-Column Reports

[image]

Telerik Reporting Q2 2012
Creating Multi-Column Reports
Send Feedback

You can create a multi-column report by modifying the DetailSection.ColumnCount property. Column width is determined by the width of the report in design view. The DetailSection.ColumnSpacing property is used to set the spacing in between the columns. The column width can be calculated as: Page width minus sum of left and right margins minus ColumnSpacing * (ColumnCount - 1). The result should be divided to the ColumnCount.

Column data is rendered down the page and then across.

Making a Report into a Multi-Column Report

Note

Multi-column report would be rendered as single-column when the report viewer is in Interactive view.

Multi-column report used in subreport item would be rendered as one-column report as well.

  1. Click the DetailSection of the report.
  2. In the Properties window, change the ColumnCount property to 4.
  3. Resize the report to match the desired width of the columns. You can do this visually or by setting the Width property of the report in the Properties window.
  4. Resize any report items so that they are not greater than the width of the report.
Note

If the report does not render the number of columns set in ColumnCount, it is likely the report width being too large. Check for report items that are greater than the width of the report and the column width itself.

A Sample Multi-Column Report

Below is a report in design and then run time mode which has the following properties:

Report.Width=1.5in

DetailSection.ColumnCount=4

DetailSection.ColumnSpacing=0in.

The report has a Group. The Group is displayed along with the detail section, and therefore, is incorporated into the columns.

The report title, A Very Long Contact List, is wider than the report width and does not fully display at design time. At run time, the Page Header and Footer sections span the actual width of the page, not the width of the column.

The run time report is displayed below the design time report.


Placing and Sizing Report Items

[image]

Telerik Reporting Q2 2012
Placing and Sizing Report Items
See Also Send Feedback

Content on reports is displayed in report items. To use report items, you select them from the Toolbox and place them on your report.

To Place a Report Item on a Report

  1. Open the report in design view.
  2. Expand the Telerik Reporting tab of the Toolbox.
  3. Select the report item that you want to place.
  4. Drag the report item from the Toolbox to the report's design surface. Alternatively, you may select the section of the report where you want the report item to appear by clicking the section header, and then double-click the report item in the Toolbox. Or you can select the report item in the toolbox and draw a bounding rectangle to indicate the area that the report item should occupy.

To Move a Report Item

Move the mouse over the report item until you see the cross hair cursor (see image above), then click and drag the report item.

To Change the Size of a Report Item

  1. Click on the report item to select it.
  2. Click and drag one of the size handles on the edge of the report item to the desired size.

See Also

Other Resources

Understanding Report Items
Design Considerations for Report Item Layout


Automatic Layout (Dock and Anchor)

[image]

Telerik Reporting Q2 2012
Automatic Layout (Dock and Anchor)
See Also Send Feedback

Anchoring

Anchoring is used to dynamically resize report items with their container (for example section or panel). Simply put, an anchor maintains the distance between the edge of the report item and the corresponding edge of the container in which it is anchored. An item can be anchored to any combination of the edges of its container. If the item is anchored to two opposite edges of its container, it is resized when the container is resized. For example, if you anchor an item both to the top and bottom edges of its parent section, and the section height increases because of its content (for example a text box with longer text grows vertically), the item tries to keep the distance of its top edge to the top edge of the section and at the same time it tries to keep the distance of its bottom edge to the bottom edge of the section. By default, report items are not anchored.

Docking

A report item can also be docked to its container (for example a section or a panel). Docking a report item causes its edges to adhere to the edges of its container. When a report item is docked to an edge of its container, it is always positioned to flush against that edge when the container is resized.

Like with anchoring, you specify an edge where the item is docked, but unlike anchoring, the item is always resized to cover the edge it is docked to. If you dock two items to the same edge, then they will be "stacked up" one next to the other and the item with the lowest z-order(the 1st item in the items collection is considered with the lowest z-order and the last item is with the highest z-order) will be positioned closest to the edge. You can also use docking to indicate that an item should occupy the remaining area of a container which is not occupied by other items (fill).

Note that anchoring and docking are really effective only when the container can be resized. With regard to Telerik Reporting report sections and panels usually contain all report items in a report and there are a couple of reasons for why they can grow:

  • A child TextBoxitem with CanGrowenabled can grow in height to accommodate the longer text that it should display;
  • A SubReportitem can grow in width and height according to the source report it contains;
  • A PictureBoxitem with auto sizing enabled (PictureBox.SizingMode= AutoSize) can grow to fit the bigger image when needed.
Note

Anchor and Dock both require parent item to have KeepTogether turned on (KeepTogether=true). They cannot work with KeepTogether=false, as they are bound to the container in some way.

Table Layout

Using Anchoring and Docking allows you to create table-like report layouts – all items inside a section can grow equally regardless of their content thus forming the “columns” of a table.

One way to achieve a table layout is by docking all of your report items to the left. In this way they will stick to the left leaving no empty space between them. They will also stick to the top and bottom edges of the section. You can then select all report items that will be part of the table and set a border in order to create a real table-like appearance.

Caution

Note that using this approach would not work for horizontally carried over pages i.e. report width is greater than page width. For such scenarios, please use our table item.

See Also

Reference

Anchor
Dock


Design Considerations for Report Item Layout

[image]

Telerik Reporting Q2 2012
Design Considerations for Report Item Layout
See Also Send Feedback

How Report Items are Layout in a Section

All report items grow from top to bottom and some (SubReport) can grow from left to right as well. When they grow, the items below/on the right are pushed down/right. Changing visibility of items at runtime would trigger the same effect i.e. items below or on the right side of the hidden item would move up or to the left to occupy the space of the hidden item.

If you have two report items positioned vertically with 1in space between them, hiding the first report item would result in the second item occupying the first item's height only. The 1in space between the report items is preserved at all times.

Section/Panel item can grow to accommodate their children but cannot shrink/take space that is no longer occupied. To remove such space in a container (report section or panel item), set its height to a very small value (e.g. 1mm). If you want a section/panel to shrink only at runtime you can set its Height property in the report constructor. Place the Height property assignment code just after the IntializeComponent() method call.

Visibility

Report items can be hidden or displayed by default, or hidden or displayed conditionally using Conditional Formatting or Bindings. Optionally, the visibility can be switched by clicking another report item (Drilldown Report Action).

In report with complex layout, changing the visibility of an item does not guarantee that the space it occupies would be filled in by the items below or to the right of it.

The following visibility rules apply when rendering report items (red lines define layout dependency):

  • If Item1 is hidden, all items below Item2 would remain in place.
  • If Item1 is hidden, all items right to Item3 would remain in place.
  • If Item1 and Item3 are hidden, Item2 will move to the left to fill in the space. Renderers maintain the space between report items that you define in the report layout.
  • If the visibility of a report item and its contents can be switched by clicking another report item, then pagination changes to accommodate the report item and its contents only when it is initially displayed.
  • If a report item is placed in a Panel, its visibility does not affect the original layout of items outside the Panel.

Keeping Report Items Together

Report items in a report can be kept together on a single page by setting the KeepTogether property. For keeping items in a report group or table group together, set GroupKeepTogether property. Report items are always rendered on the same page if the report item is smaller in size than the usable page area. If a report item does not completely fit on the page on which it starts, a page break is inserted before the report item, forcing it to the next page. For logical page renderers, the page grows to accommodate the report item.

When a report item is always hidden, the rules for keeping items together are ignored.

The following items are always kept together:

  • PictureBox.
  • Shape.
  • Chart.

See Also

Other Resources

Placing and Sizing Report Items
Understanding Report Items


Connecting to Data

[image]

Telerik Reporting Q2 2012
Connecting to Data
Send Feedback

The topics in this section describe how to connect Telerik Reports to data, filter, order, group data, and create expressions that when evaluated at runtime will customize the content and appearance of your reports.

In This Section

  • Data source components allows you to connect the report data items (Report, Table/Crosstab/List and Chart) to different types of data sources.
  • The data items display and manipulate data in Telerik Reports.
  • Expressions are widely used while designing reports, for example to retrieve, calculate, display, group, sort, filter, and parameterize the data in a report.


Data Source Components

[image]

Telerik Reporting Q2 2012
Data Source Components
Send Feedback

The Telerik Reporting Data Source Components allow you to connect report items (Report, Table/Crosstab/List and Chart) to different types of data sources such as database or middle-tier business objects, without requiring code.

They are intended to specify declaratively how to retrieve data for Data Items but do not contain any data at all. Their purpose is only to specify the means how to obtain it (e.g. in the case of SqlDataSource - by executing a SQL query against a database, in the case of ObjectDataSource - by invoking a method/property of a custom business object, etc.). You can view the Data Source Components as wrapper for your data that can only read the data and cannot modify it.

Note

Not to be confused with ASP.NET Data source controls!

The Telerik Reporting engine includes data source objects:

  • SqlDataSource – Enables you to work with Microsoft SQL Server, MySQL, Oracle, OLE DB or ODBC databases.
  • ObjectDataSource - Enables you to work with business objects or other classes and allows you to create reports that display data from the middle-tier.
  • EntityDataSource – Enables you to connect to the ADO.NET Entity Framework.
  • OpenAccessDataSource - Enables you to connect to Telerik OpenAccess ORM.
  • CubeDataSource – Enables you to retrieve data from an OLAP cube using Microsoft Analysis Services.

Note

For backwards compatibility reasons Telerik Reporting supports binding directly to IEnumberable/IListSource objects (incl. arrays, collections, DataSet, DataTable, DataView, DbDataAdapter). Instead consider using the ObjectDataSource that can handle this types of data sources.


SqlDataSource Component

[image]

Telerik Reporting Q2 2012
SqlDataSource Component
Send Feedback

The SqlDataDource component enables data items to display data located in a relational database, including Microsoft SQL Server and Oracle databases, as well as OLE DB and ODBC data sources, using little or no code. Using SqlDataSource allows you to access and display data in a report without using ADO.NET classes directly. You provide a connection string to connect to the database and define the SQL statement or the stored procedure to retrieve the data. At run time, SqlDataSource automatically opens the database connection, executes the SQL statement or stored procedure, returns the selected data, and then closes the connection.

Supported providers

The SqlDataDource component uses ADO.NET classes to interact with any database supported by ADO.NET. This includes, but is not limited to:
Provider Name | Invariant Name | Description
SqlClient Data Provider | System.Data.SqlClient | .Net Framework Data Provider for SqlServer
OracleClient Data Provider | System.Data.OracleClient | .Net Framework Data Provider for Oracle
OleDb Data Provider | System.Data.OleDb | .Net Framework Data Provider for OleDb
Odbc Data Provider | System.Data.Odbc | .Net Framework Data Provider for Odbc
MySQL Data Provider | MySql.Data.MySqlClient | .Net Framework Data Provider for MySQL
Oracle Data Provider for .NET | Oracle.DataAccess.Client | Oracle Data Provider for .NET

In This Section

  • Connecting the SqlDataSource component to a Data Source

  • Selecting Data with the SqlDataSource component

  • Using Parameters with the SqlDataSource component

  • How to: Connect to a SQL Server Database Using Text Query

  • How to: Connect to a SQL Server Database Using Stored Procedure

  • How to: Connect to an Access Database

  • How to: Connect to an ODBC Database

  • How to: Connect to an Oracle Database

  • How to: Connect to MySQL Database


Connecting the SqlDataSource component to a Data Source

[image]

Telerik Reporting Q2 2012
Connecting the SqlDataSource component to a Data Source
Send Feedback

When you configure the SqlDataSource component, you set the ProviderName property to the type of database (the default is System.Data.SqlClient) and the ConnectionString property to a connection string that includes information required to connect to the database. The contents of a connection string differ depending on what type of database the data source component is accessing. For example, the System.Data.SqlClient provider requires a server name, database (catalog) name, and information about how to authenticate the user when connecting to SQL Server. For information on valid connection strings, see the ConnectionString property topics for the SqlConnection, OracleConnection, OleDbConnection, and OdbcConnection classes.

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ProviderName = "System.Data.SqlClient";
sqlDataSource.ConnectionString = "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";
sqlDataSource.SelectCommand = "SELECT * FROM Production.Product";
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ProviderName = "System.Data.SqlClient"
sqlDataSource.ConnectionString = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"
sqlDataSource.SelectCommand = "SELECT * FROM Production.Product"

Instead of setting connection strings at design time as property settings in the SqlDataSource component, you can store them centrally as part of your application's configuration settings using the connectionStrings configuration element. This enables you to manage connection strings independently of your reports, including encrypting them using Protected Configuration.

The following example shows how to connect to the SQL Server AdventureWorks sample database using a connection string which stored in the connectionStrings configuration element named MyAdventureWorksDB:

CopyXML
<configuration xmlns="http://ddue.schemas.microsoft.com/authoring/2003/5">
  <connectionStrings>
    <add name="MyAdventureWorksDB" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True" providerName="System.Data.SqlClient" />
  </connectionStrings>
</configuration>

When the connection string is stored in the configuration file, you need to specify the name of the configuration element as a value for the ConnectionString property of SqlDataSource. Specifying a value for the ProviderName property is no longer necessary, since that information is already present in the configuration element itself.

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ConnectionString = "MyAdventureWorksDB";
sqlDataSource.SelectCommand = "SELECT * FROM Production.Product";
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ConnectionString = "MyAdventureWorksDB"
sqlDataSource.SelectCommand = "SELECT * FROM Production.Product"

The SqlDataSource component retrieves data using a SQL statement defined through the SelectCommand property. If the data source component connects to a database that supports stored procedures, you can specify the name of a stored procedure in place of the SQL statement. You can create parameterized commands that include placeholders for values to be supplied at run time. The following example shows a typical parameterized SQL select command:

CopySQL
SELECT CustomerID, CompanyName FROM Customers WHERE City = @City

You can create parameter objects that specify where the command should get parameter values from at run time. You can also use expressions which values will be evaluated when processing the report or pass specific values programmatically.


Selecting Data with the SqlDataSource component

[image]

Telerik Reporting Q2 2012
Selecting Data with the SqlDataSource component
Send Feedback

You can specify a SQL query for the SqlDataSource component to execute by setting its SelectCommand property. The following example demonstrates a SQL query that retrieves a result set consisting of the names of all the persons in the Contact table from the AdventureWorks sample database:

CopySQL
SELECT FirstName, LastName FROM Person.Contact

The following code example shows how to set the ConnectionString and SelectCommand properties of a SqlDataSource component to retrieve the data from the above SQL query:

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ConnectionString = "MyAdventureWorksDB";
sqlDataSource.SelectCommand = "SELECT FirstName, LastName FROM Person.Contact";
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ConnectionString = "MyAdventureWorksDB"
sqlDataSource.SelectCommand = "SELECT FirstName, LastName FROM Person.Contact"

If the database you are working with supports stored procedures, you can set the SelectCommand property to the name of an existing stored procedure and the SelectCommandType property to StoredProcedure to indicate that the SelectCommand property refers to a stored procedure. The following example demonstrates a simple stored procedure that you can create in SQL Server:

CopySQL
CREATE PROCEDURE GetAllContacts AS
    SELECT FirstName, LastName FROM Person.Contact;
GO

To configure the SqlDataSource component to use this stored procedure, set the SelectCommand text to "GetAllContacts" and the SelectCommandType property to StoredProcedure:

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ConnectionString = "MyAdventureWorksDB";
sqlDataSource.SelectCommand = "GetAllContacts";
sqlDataSource.SelectCommandType = SqlDataSourceCommandType.StoredProcedure;
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ConnectionString = "MyAdventureWorksDB"
sqlDataSource.SelectCommand = "GetAllContacts"
sqlDataSource.SelectCommandType = SqlDataSourceCommandType.StoredProcedure

At run time, the SqlDataSource component submits the text in the SelectCommand property to the database, and the database returns the result of the SQL query or stored procedure back to the SqlDataSource component. Any data items that are bound to the data source component display the result set on your report.


Using Parameters with the SqlDataSource component

[image]

Telerik Reporting Q2 2012
Using Parameters with the SqlDataSource component
Send Feedback

Users often request data based on parameters that can be resolved or evaluated only at run time. For example, the data displayed in a report might depend on a specific input value. If the user selects a different value, that data can also change. Whether the value is changed explicitly by the user or programmatically by the application, the SQL query that you submit to the database can be made more flexible and more maintainable if it is a parameterized SQL query, in which elements of the SQL statement are bound to parameters and evaluated at run time. Moreover using parameterized SQL queries to filter the data of the report might improve the performance and decrease the memory footprint of your application, because the filter is applied directly on the database server and only the necessary data is downloaded on the middle tier or client machine.

The SqlDataSource component supports parameterized SQL queries by associating the parameters you add to the Parameters collection with placeholders in the SelectCommand query. Parameter values can be evaluated with any expression which conforms to the common expression syntax supported by the reporting engine. This grants you a great deal of flexibility on how you can supply your SQL queries with parameters. For example, you can bind a SQL query parameter directly to a report parameter without any extra coding at all.

The syntax used for the placeholders varies, depending on the type of the database. If you are working with SQL Server, the parameter name begins with the '@' character, and its name corresponds to the name of the parameter object in the Parameters collection. For Oracle databases the parameters are prefixed with the ':' character instead, and are referenced by name in the Parameters collection as well. If you are working with an ODBC or OLE DB database, parameters in a parameterized statement are not named and instead are specified with the placeholder character '?'.

Using Parameters with the SqlClient Provider

The System.Data.SqlClient provider supports named parameters as placeholders, as shown in the following example:

CopySQL
SELECT * FROM Person.Contact WHERE FirstName = @FirstName AND LastName = @LastName

With named parameters, the order in which the parameters are specified in the command's parameters collection is not important. However, you must ensure that the parameter names that you use in your SQL command correspond to the names of the parameters in the associated collection. The following example shows how to use named parameters in an SQL command for a SqlDataSource component that uses the System.Data.SqlClient provider:

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ConnectionString = "MyAdventureWorksDB";
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = @FirstName AND LastName = @LastName";
sqlDataSource.Parameters.Add("@FirstName", System.Data.DbType.String, "John");
sqlDataSource.Parameters.Add("@LastName", System.Data.DbType.String, "Smith");
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ConnectionString = "MyAdventureWorksDB"
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = @FirstName AND LastName = @LastName"
sqlDataSource.Parameters.Add("@FirstName", System.Data.DbType.String, "John")
sqlDataSource.Parameters.Add("@LastName", System.Data.DbType.String, "Smith")

Using Parameters with the OLE DB and ODBC Providers

The System.Data.OleDb and System.Data.Odbc providers support only positional parameters identified by the '?' character, as shown in the following example:

CopySQL
SELECT * FROM Person.Contact WHERE FirstName = ? AND LastName = ?

When you use the System.Data.OleDb and System.Data.Odbc providers with parameterized SQL query statements, the order in which you specify the parameter placeholders must match exactly the order of the parameter objects in the Parameters collection of the SqlDataSource component. Specifying names for the parameters in this case is only for informative purposes, these names are not used when binding the parameter values to the SQL query statement.

The following example shows how to specify parameters for a SqlDataSource component that uses the System.Data.OleDb provider:

Example

CopyC#
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ProviderName = "System.Data.OleDb";
sqlDataSource.ConnectionString = "Provider=SQLOLEDB;Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=SSPI";
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = ? AND LastName = ?";
sqlDataSource.Parameters.Add("FirstName", System.Data.DbType.String, "John");
sqlDataSource.Parameters.Add("LastName", System.Data.DbType.String, "Smith");
CopyVB.NET
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ProviderName = "System.Data.OleDb"
sqlDataSource.ConnectionString = "Provider=SQLOLEDB;Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=SSPI"
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = ? AND LastName = ?"
sqlDataSource.Parameters.Add("FirstName", System.Data.DbType.String, "John")
sqlDataSource.Parameters.Add("LastName", System.Data.DbType.String, "Smith")

Binding SQL Query Parameters to Report Parameters

The following code example shows how to bind the parameters of an SQL query to the corresponding parameters of the report using expressions:

Example

CopyC#
Telerik.Reporting.Report report = new Telerik.Reporting.Report();
report.ReportParameters.Add("FirstName", ReportParameterType.String, "John");
report.ReportParameters.Add("LastName", ReportParameterType.String, "Smith");
Telerik.Reporting.SqlDataSource sqlDataSource = new Telerik.Reporting.SqlDataSource();
sqlDataSource.ConnectionString = "MyAdventureWorksDB";
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = @FirstName AND LastName = @LastName";
sqlDataSource.Parameters.Add("@FirstName", System.Data.DbType.String, "=Parameters.FirstName");
sqlDataSource.Parameters.Add("@LastName", System.Data.DbType.String, "=Parameters.LastName");
report.DataSource = sqlDataSource;
CopyVB.NET
Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()
report.ReportParameters.Add("FirstName", ReportParameterType.String, "John")
report.ReportParameters.Add("LastName", ReportParameterType.String, "Smith")
Dim sqlDataSource As Telerik.Reporting.SqlDataSource = New Telerik.Reporting.SqlDataSource()
sqlDataSource.ConnectionString = "MyAdventureWorksDB"
sqlDataSource.SelectCommand = "SELECT * FROM Person.Contact WHERE FirstName = @FirstName AND LastName = @LastName"
sqlDataSource.Parameters.Add("@FirstName", System.Data.DbType.String, "=Parameters.FirstName")
sqlDataSource.Parameters.Add("@LastName", System.Data.DbType.String, "=Parameters.LastName")
report.DataSource = sqlDataSource


SqlDataSource How-To

[image]

Telerik Reporting Q2 2012
SqlDataSource How-To
Send Feedback

The following procedures describe how to use the Telerik Reporting SqlDataSource component to connect to databases and make data available to report data items.

In this section

  • How to: Connect to a SQL Server Database Using the SqlDataSource Component with SelectCommandType Text
  • How to: Connect to a SQL Server Database Using the SqlDataSource Component with SelectCommandType StoredProcedure
  • How to: Connect to an Access Database Using the SqlDataSource Component
  • How to: Connect to an ODBC Database Using the SqlDataSource Component
  • How to: Connect to an Oracle Database Using the SqlDataSource Component
  • How to: Connect to MySQL Database Using the SqlDataSource Component


How to: Connect to a SQL Server Database Using Text Query

[image]

Telerik Reporting Q2 2012
How to: Connect to a SQL Server Database Using Text Query
Send Feedback

You can connect to a Microsoft SQL Server database using the Telerik SqlDataSource component. To do this, you need a connection string and access rights to a SQL Server database. Then, you can use the SqlDataSource component to provide data to data items (Report, Table, Chart).

To connect to a SQL Server database using the SqlDataSource component

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection

    • If the Change Data Source dialog box appears, click Microsoft SQL Server, and then click Continue.

  4. In the Add Connection dialog box, click Change.

  5. In the Change Data Source dialog box, click Microsoft SQL Server, and then click OK.

  6. In the Server name box, enter the name for your SQL Server database, and then under Logon to the server, enter the logon credentials.

    • For the logon credentials, select the option that is appropriate for accessing and running the SQL Server database (either by using Microsoft Windows integrated security or by providing a specific ID and password) and, if it is required, enter a user name and password.

  7. In the Select or enter a database name list, enter a valid database on the server e.g. AdventureWorks.

  8. Optionally, click Test connection to verify that your connection works.

  9. Click OK, Click Next to continue and select Yes, save this connection…. Enter a name for your connection for when it is stored in the application configuration file, and then click Next.

  10. Select the database table or view from which to retrieve results or specify your own SQL statement.

  11. To test your query, click Next, and then click Execute Query.

  12. Click Finish. The Wizard would close and the SqlDataSource component would be ready for use by the data items.


How to: Connect to a SQL Server Database Using Stored Procedure

[image]

Telerik Reporting Q2 2012
How to: Connect to a SQL Server Database Using Stored Procedure
Send Feedback

You can connect to a Microsoft SQL Server database using the Telerik SqlDataSource component. To do this, you need a connection string and access rights to a SQL Server database. Then, you can use the SqlDataSource component to provide data to data items (Report, Table, Chart).

To connect to a SQL Server database using the SqlDataSource component

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection

    • If the Change Data Source dialog box appears, click Microsoft SQL Server, and then click Continue.

  4. In the Add Connection dialog box, click Change.

  5. In the Change Data Source dialog box, click Microsoft SQL Server, and then click OK.

  6. In the Server name box, enter the name for your SQL Server database, and then under Logon to the server, enter the logon credentials.

    • For the logon credentials, select the option that is appropriate for accessing and running the SQL Server database (either by using Microsoft Windows integrated security or by providing a specific ID and password) and, if it is required, enter a user name and password.

  7. In the Select or enter a database name list, enter a valid database on the server e.g. AdventureWorks.

  8. Optionally, click Test connection to verify that your connection works.

  9. Click OK, Click Next to continue and select Yes, save this connection…. Enter a name for your connection for when it is stored in the application configuration file, and then click Next.

  10. Select the stored procedure from which to retrieve results e.g. uspGetEmployeeManagers and click Next.

    • If the stored procedure has a parameter, the Configure Data Source Parameters step shows. You can leave the sql parameter value blank and continue, create an expression or create a report parameter as values. Choosing the last option would give you ability to use the built-in report parameters to specify value at run time. The SqlDataSource component submits the text in the SelectCommand property to the database, and the database returns the result of the stored procedure back to the SqlDataSource component. Any data items that are bound to the data source component would display the result set on your report.

  11. To test your query, click Next, and then click Execute Query.

  12. Click Finish. The Wizard would close and the SqlDataSource component would be ready for use by the data items.


How to: Connect to an Access Database

[image]

Telerik Reporting Q2 2012
How to: Connect to an Access Database
Send Feedback

You can connect to a Microsoft Access database using the Telerik SqlDataSource component. To do this, you need a connection string and an Access data file. Then, you can use the SqlDataSource component to provide data to data items (Report, Table, Chart).

To connect to an Access database using the SqlDataSource control

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection

    • If the Change Data Source dialog box appears, click Microsoft Access Database File, and then click Continue.

  4. In the Add Connection dialog box, click Change, in the Change Data Source dialog box, click Microsoft Access Database File, and then click OK.

  5. In the Database file name box, enter a path to the Access database, and then under Log on to the database, enter your logon credentials, if they are required.

  6. Optionally, click Test connection to verify that the connection to the Access database succeeds.

  7. Click OK and notice that in the Data Connection - <Datasourcename> combobox, your new connection is selected.

  8. Click Next and Select the Yes, save this connection… check box, enter a name for your connection for when the connection is stored in the application configuration file, and then click Next.

  9. Select the database table from which to retrieve results or enter your own SQL statement.

  10. To test your query, click Next, and then click Execute Query

  11. Click Finish. The Wizard would close and the SqlDataSource component would be ready for usage by the data items.

Note

Parametrized Access Queries (stored procedures) are not supported, because the OLE DB provider cannot retrieve the procedures' parameter information.


How to: Connect to an ODBC Database

[image]

Telerik Reporting Q2 2012
How to: Connect to an ODBC Database
Send Feedback

You can use the Telerik SqlDataSource component to connect to any ODBC–compliant data source. You connect the component to an ODBC data source by specifying the appropriate ODBC driver in the connection string along with relevant server and authentication information.

To use the SqlDataSource control to connect to an ODBC database

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection.

  4. In the Add Connection dialog box, click Change to display the Change Data Source dialog box.

  5. In the Change Data Source dialog box, click Microsoft ODBC Data Source, and then click OK.

  6. The Add Connection dialog box is displayed. If you have an existing ODBC data source, click Use user or system data source name and select an existing ODBC data source from the list.

  7. If you do not have an existing ODBC data source, click Use connection string and then type the connection string or click Build to display the Select Data Source dialog box where you can build an ODBC data source name (DSN).

  8. If necessary, enter the user name and password required to connect to the database.

  9. Click Test connection to verify the connection to the ODBC data source, and then close the Add Connection dialog box to return to the Configure Data Source wizard.

  10. Click Next and Select the Yes, save this connection… check box. Enter a name for your connection for when the connection is stored in the application configuration file, and then click Next.

  11. Select the database table, view, or stored procedure from which to retrieve results or specify your own SQL statement.

  12. To test your query, click Next, and then click Execute Query.

  13. Click Finish. The Wizard would close and the SqlDataSource component would be ready for use by the data items


How to: Connect to an Oracle Database

[image]

Telerik Reporting Q2 2012
How to: Connect to an Oracle Database
Send Feedback

You can use the Telerik SqlDataSource component to connect to an Oracle database. You connect the component to an Oracle database by first establishing connection information in the config file, and then by referencing the connection information in a SqlDataSource control.

To use the SqlDataSource control to connect to an Oracle database

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection.

  4. In the Add Connection dialog box, click Change to display the Change Data Source dialog box.

  5. In the Data source list, click Oracle Database and then click Ok.

  6. The Add Connection dialog box is displayed. In the Server name box, type the name of the Oracle server.

  7. Type the user name and password to connect with the database.

  8. Select Save my password box to save authentication information as part of the connection string, and then click OK.

  9. You are returned to the Choose Your Data Connection dialog with the new connection string information displayed.

  10. Click Next and Select the Yes, save this connection… check box. Enter a name for your connection for when the connection is stored in the application configuration file, and then click Next.

  11. Select the database table, view, or stored procedure from which to retrieve results or specify your own SQL statement.

  12. To test your query, click Next, and then click Execute Query.

  13. Click Finish. The Wizard would close and the SqlDataSource component would be ready for use by the data items


How to: Connect to MySQL Database

[image]

Telerik Reporting Q2 2012
How to: Connect to MySQL Database
Send Feedback

You can use the SqlDataSource component to connect to MySQL database. Prior to this, you should install .NET connector. You need access rights to a MySQL Server database with relevant server and authentication information. Then, you can use the SqlDataSource component to provide data to data items (Report, Table, Chart).

To use the SqlDataSource control to connect to MySql database

  1. In Microsoft Visual Studio, open a Telerik Report. From the Telerik Reporting Q2 2012 group in the Toolbox, select the SqlDataSource component and click on the design surface to add it to the Report.

  2. Choose your Data Connection dialog box appears.

  3. Click New Connection.

  4. In the Add Connection dialog box, click Change to display the Change Data Source dialog box.

  5. In the Data source list, click MySQL Database and then click Ok

  6. The Add Connection dialog box is displayed. In the Server name box, type the name of the MySql server.

  7. Type the user name and password to connect with the database.

  8. Select the Save my password box to save authentication information as part of the connection string, select DataBase name and then click OK.

  9. You are returned to the Choose Your Data Connection dialog with the new connection string information displayed.

  10. Click Next and Select the Yes, save this connection… check box. Enter a name for your connection for when the connection is stored in the application configuration file, and then click Next.

  11. Select the database table, view, or stored procedure from which to retrieve results or specify your own SQL statement.

  12. To test your query, click Next, and then click Execute Query.

  13. Click Finish. The Wizard would close and the SqlDataSource component would be ready for use by the data items


ObjectDataSource Component

[image]

Telerik Reporting Q2 2012
ObjectDataSource Component
Send Feedback

A common application design practice is to separate the presentation layer from business logic and encapsulate the business logic in business objects. These business objects form a layer between the presentation layer and the data tier, resulting in a multi-tier application architecture. The ObjectDataSource component supports the multi-tier architecture by providing a way for you to bind the Data Report Items to a middle-tier business object without extensive code. The ObjectDataSource component represents the middle-tier object (business object or any other class) and provides data retrieval capabilities.

Supported object types

Any of the following data sources can be assigned to the DataSource property of the ObjectDataSource component:

  • Any component that implements IEnumerable , including System.Array , IList , ICollection , and BindingSource
  • Any component that implements IListSource, including DataTable, DataSet and DataView
  • Any component that implements IDbDataAdapter, including SqlDataAdapter and OleDbDataAdapter
  • System.Type which represents the type of the business object

If the DataSource reference contains more than one table, you must set the DataMember property to a string that specifies the table to bind to. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

If the DataSource references a strongly typed array of objects (business objects) these objects must contain public properties.

In case the DataSource is a business object, the DataMember property specifies the name of the method which should be invoked to retrieve the data. If the DataMember property is not specified, the constructor of the type will be invoked. If the constructor or the method contains arguments they can be specified through the Parameters collection of the ObjectDataSource component.

You can also bind to an ArrayList. A feature of the ArrayList is that it can contain objects of multiple types. The ObjectDataSource component binds to such a list despite the types of items in it. The only requirement is that they provide public properties with the same names as they are used in the expressions.

Note

Visual Studio is a 32-bit application, so the designer is restricted to x86 mode even on x64 platforms, which prevents the ObjectDataSource Wizard from discovering any types from x64 assemblies. The solution is to use different platform configurations: for "Debug" builds it is best to use "Any CPU", while for "Release" builds you can use "x64" instead.


Using Parameters with the ObjectDataSource Component

[image]

Telerik Reporting Q2 2012
Using Parameters with the ObjectDataSource Component
Send Feedback

The ObjectDataSource component can call a business object method based on the name of the method specified in the DataMember property, and based additionally on the argument names that make up the business object method's signature. When you create methods in a business object, you must ensure that the parameter names and types accepted by the business object method match the parameter names and types that the ObjectDataSource component passes.

The ObjectDataSource component accepts input parameters at run time and manages them in a parameter collection. You can use the Parameters property to specify the parameters. For each parameter you can set a name and a default value or an expression. During the report processing the ObjectDataSource parameters’ values are used as argument values for the data method or the constructor of the business object. Because of this the order of the parameters is important and should exactly match the order of the arguments along with their types and names. Any discrepancy will result in a run-time exception.

Here is an example of programmatically setting the ObjectDataSource’s parameters:

CopyC#
public void HowToObjectDataSourceParameters()
{
    Telerik.Reporting.ObjectDataSource objectDataSource1 = new Telerik.Reporting.ObjectDataSource();
    objectDataSource1.DataMember = "GetCars";
    objectDataSource1.DataSource = typeof(Cars);
    objectDataSource1.Parameters.Add(new Telerik.Reporting.ObjectDataSourceParameter("year", typeof(int), 2010));
    objectDataSource1.Parameters.Add(new Telerik.Reporting.ObjectDataSourceParameter("color", typeof(string), "=Parameters.Color"));
}
CopyVB.NET
Public Sub HowToObjectDataSourceParameters()
    Dim objectDataSource1 As New Telerik.Reporting.ObjectDataSource()
    objectDataSource1.DataMember = "GetCars"
    objectDataSource1.DataSource = GetType(Cars)
    objectDataSource1.Parameters.Add(New Telerik.Reporting.ObjectDataSourceParameter("year", GetType(Integer), 2010))
    objectDataSource1.Parameters.Add(New Telerik.Reporting.ObjectDataSourceParameter("color", GetType(String), "=Parameters.Color"))
End Sub


ObjectDataSource How-To

[image]

Telerik Reporting Q2 2012
ObjectDataSource How-To
Send Feedback

The following procedures describe how to use the Telerik Reporting ObjectDataSource component to connect to databases and make data available to report data items.

In this section

  • How to: Bind to a BusinessObject
  • How to: Bind to a DataTable
  • How to: Bind to a DataView
  • How to: Bind to a DataAdapter
  • How to: Bind to a DataSet


How to: Bind to a BusinessObject

[image]

Telerik Reporting Q2 2012
How to: Bind to a BusinessObject
Example Send Feedback

The following code sample illustrates a custom middle-tier business object that can be used with an ObjectDataSource component that specifies a strongly typed source object.

Remarks

The business object exposes several methods which return different data types. They represent only part of the data types which are supported by Telerik Reporting and can be used to feed an item with data. Additionally methods with arguments are implemented which can be also invoked from the ObjectDataSource component. When the data method contains parameters the Parameters collection of the ObjectDataSource should be used to pass values to them at runtime. To successfully invoke the data method the parameters number should match as well as their names and types. The order of the parameters in the Parameters collection is not important. If there is a discrepancy between ObjectDataSource parameters and the method parameters you will receive a runtime exception that the method cannot be resolved.

The business object is marked with the DataObjectAttribute which indicates that the object is suitable for data binding. Objects marked with this attribute will be shown in the ObjectDataSource wizard when “Show only data components” checkbox is checked. Respectively the methods used for data retrieval are marked with the DataObjectMethod attribute.

Example

CopyC#
class Product
{
    public string Name { get; set; }
    public string ProductNumber { get; set; }
    public decimal ListPrice { get; set; }
    public int ProductModelID { get; set; }
    public string Color { get; set; }
}

[DataObject]
class Products
{
    const string SelectCommandText =
            "SELECT Name, ProductNumber, ListPrice, ProductModelID, Color" +
            "  FROM Production.Product" +
            "  WHERE ProductModelID is not NULL" +
            "    AND Color is not NULL";

    const string ConnectionString =
            "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";

    [DataObjectMethod(DataObjectMethodType.Select)]
    public DataTable GetDataTableSource()
    {
        DataTable dataTable = new DataTable();
        SqlDataAdapter dataAdapter;
        using (dataAdapter = new SqlDataAdapter(SelectCommandText, ConnectionString))
        {
            dataAdapter.Fill(dataTable);
        }
        return dataTable;
    }

    [DataObjectMethod(DataObjectMethodType.Select)]
    public IDataAdapter GetDataAdapterSource()
    {
        return new SqlDataAdapter(SelectCommandText, ConnectionString);
    }

    [DataObjectMethod(DataObjectMethodType.Select)]
    public DataView GetDataViewSource(string name)
    {
        SqlDataAdapter dataAdapter = new SqlDataAdapter(SelectCommandText, ConnectionString);
        DataTable dataTable = new DataTable();

        dataAdapter.Fill(dataTable);

        DataView dataView = dataTable.DefaultView;
        dataView.RowFilter = string.Format("Name like '%{0}%'", name);

        return dataView;
    }

    [DataObjectMethod(DataObjectMethodType.Select)]
    public Product[] GetArraySource()
    {
        return this.GetAllProducts().ToArray();
    }

    [DataObjectMethod(DataObjectMethodType.Select)]
    public ArrayList GetArrayListSource()
    {
        ArrayList arrayList = new ArrayList();
        foreach (var product in this.GetAllProducts())
        {
            arrayList.Add(product);
        }
        return arrayList;
    }

    [DataObjectMethod(DataObjectMethodType.Select)]
    public List<Product> GetAllProducts()
    {
        SqlConnection connection = new SqlConnection(ConnectionString);
        SqlCommand command = new SqlCommand(SelectCommandText, connection);
        SqlDataReader reader = null;
        List<Product> products = new List<Product>();

        try
        {
            connection.Open();

            reader = command.ExecuteReader();

            while (reader.Read())
            {
                products.Add(new Product()
                {
                    Name = reader.GetString(0),
                    ProductNumber = reader.GetString(1),
                    ListPrice = reader.GetDecimal(2),
                    ProductModelID = reader.GetInt32(3),
                    Color = reader.GetString(4)
                });
            }
        }
        catch
        {
            // Handle exception.
        }
        finally
        {
            if (reader != null)
            {
                reader.Close();
            }
            connection.Close();
        }
        return products;
    }

    // Gets products bellow a specified max price.
    [DataObjectMethod(DataObjectMethodType.Select)]
    public IList<Product> GetProducts(decimal maxPrice)
    {
        return this.GetAllProducts().FindAll(product => product.ListPrice <= maxPrice);
    }

    // Gets products of specific model and a color.
    [DataObjectMethod(DataObjectMethodType.Select)]
    public IList<Product> GetProducts(int productModelID, string color)
    {
        return this.GetAllProducts().FindAll(product => (product.ProductModelID == productModelID && product.Color == color));
    }
}

void Form1_Load(object sender, EventArgs e)
{
    // Creating and configuring the ObjectDataSource component:
    Telerik.Reporting.ObjectDataSource objectDataSource = new Telerik.Reporting.ObjectDataSource();
    objectDataSource.DataSource = typeof(Products); // Specifying the business object type
    objectDataSource.DataMember = "GetProducts"; // Specifying the name of the data object method
    objectDataSource.CalculatedFields.Add(new Telerik.Reporting.CalculatedField("FullName", typeof(string), "=Fields.Name + ' ' + Fields.ProductNumber")); // Adding a sample calculated field.

    // Specify the parameters, their types and values
    objectDataSource.Parameters.Add(new Telerik.Reporting.ObjectDataSourceParameter("color", typeof(string), "Silver"));
    objectDataSource.Parameters.Add(new Telerik.Reporting.ObjectDataSourceParameter("productModelID", typeof(int), 23));

    // Creating a new report
    Telerik.Reporting.Report report = new Telerik.Reporting.Report();

    // Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource;

    // Use the InstanceReportSource to pass the report to the viewer for displaying
    Telerik.Reporting.InstanceReportSource reportSource = new Telerik.Reporting.InstanceReportSource();
    reportSource.ReportDocument = report;

    // Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource;

    // Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport();
}
CopyVB.NET
Class Product
    Dim mName As String
    Dim mProductNumber As String
    Dim mListPrice As Decimal
    Dim mProductModelID As Integer
    Dim mColor As String

    Public Property Name() As String
        Get
            Return mName
        End Get
        Set(ByVal value As String)
            mName = value
        End Set
    End Property
    Public Property ProductNumber() As String
        Get
            Return mProductNumber
        End Get
        Set(ByVal value As String)
            mProductNumber = value
        End Set
    End Property
    Public Property ListPrice() As Decimal
        Get
            Return mListPrice
        End Get
        Set(ByVal value As Decimal)
            mListPrice = value
        End Set
    End Property
    Public Property ProductModelID() As Integer
        Get
            Return mProductModelID
        End Get
        Set(ByVal value As Integer)
            mProductModelID = value
        End Set
    End Property
    Public Property Color() As String
        Get
            Return mColor
        End Get
        Set(ByVal value As String)
            mColor = value
        End Set
    End Property
End Class

<DataObject()> _
Class Products
    Const SelectCommandText As String = "SELECT Name, ProductNumber, ListPrice, ProductModelID, Color" + "  FROM Production.Product" + "  WHERE ProductModelID is not NULL" + "    AND Color is not NULL"

    Const ConnectionString As String = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"

    <DataObjectMethod(DataObjectMethodType.Select)> _
    Public Function GetDataTableSource() As DataTable
        Dim dataTable = New DataTable()
        Using dataAdapter = New SqlDataAdapter(SelectCommandText, ConnectionString)
            dataAdapter.Fill(dataTable)
        End Using
        Return dataTable
    End Function

    <DataObjectMethod(DataObjectMethodType.Select)> _
    Public Function GetDataAdapterSource() As IDataAdapter
        Return New SqlDataAdapter(SelectCommandText, ConnectionString)
    End Function

    <DataObjectMethod(DataObjectMethodType.[Select])> _
    Public Function GetDataViewSource(ByVal name As String) As DataView
        Dim dataAdapter = New SqlDataAdapter(SelectCommandText, ConnectionString)
        Dim dataTable = New DataTable()

        dataAdapter.Fill(dataTable)

        Dim dataView = dataTable.DefaultView
        dataView.RowFilter = String.Format("Name like '%{0}%'", name)

        Return dataView
    End Function

    <DataObjectMethod(DataObjectMethodType.[Select])> _
    Public Function GetArraySource() As Product()
        Return Me.GetAllProducts().ToArray()
    End Function

    <DataObjectMethod(DataObjectMethodType.[Select])> _
    Public Function GetArrayListSource() As ArrayList
        Dim arrayList As New ArrayList()
        For Each product In Me.GetAllProducts()
            arrayList.Add(product)
        Next
        Return arrayList
    End Function

    <DataObjectMethod(DataObjectMethodType.[Select])> _
    Public Function GetAllProducts() As List(Of Product)
        Dim connection As New SqlConnection(ConnectionString)
        Dim command As New SqlCommand(SelectCommandText, connection)
        Dim reader As SqlDataReader = Nothing
        Dim products As New List(Of Product)()
        Try
            connection.Open()
            reader = command.ExecuteReader()
            While reader.Read()
                Dim product As New Product()
                product.Name = reader.GetString(0)
                product.ProductNumber = reader.GetString(1)
                product.ListPrice = reader.GetDecimal(2)
                product.ProductModelID = reader.GetInt32(3)
                product.Color = reader.GetString(4)
                products.Add(product)
            End While
            ' Handle exception.
        Catch ex As SqlException
        Finally
            If Not reader Is Nothing Then
                reader.Close()
            End If
            connection.Close()
        End Try
        Return products
    End Function

    ' Gets products bellow a specified max price.
    <DataObjectMethod(DataObjectMethodType.Select)> _
    Public Function GetProducts(ByVal maxPrice As Decimal) As IList(Of Product)
        Return Me.GetAllProducts().FindAll(Function(product) product.ListPrice <= maxPrice)
    End Function

    ' Gets products of specific model and a color.
    <DataObjectMethod(DataObjectMethodType.Select)> _
    Public Function GetProducts(ByVal productModelID As Integer, ByVal color As String) As IList(Of Product)
        Return Me.GetAllProducts().FindAll(Function(product) (product.ProductModelID = productModelID AndAlso product.Color = color))
    End Function
End Class

Private Sub Form2_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)

    ' Creating and configuring the ObjectDataSource component:
    Dim objectDataSource As New Telerik.Reporting.ObjectDataSource()
    objectDataSource.DataSource = GetType(Products) ' Specifying the business object type
    objectDataSource.DataMember = "GetProducts" ' Specifying the name of the method for retrieving the data
    objectDataSource.CalculatedFields.Add(New Telerik.Reporting.CalculatedField("FullName", GetType(String), "=Fields.Name + ' ' + Fields.ProductNumber")) ' Adding a sample calculated field.

    'Specifying the parameters, their types and values that should be passed to the method at runtime
    objectDataSource.Parameters.Add(New Telerik.Reporting.ObjectDataSourceParameter("color", GetType(String), "Silver"))
    objectDataSource.Parameters.Add(New Telerik.Reporting.ObjectDataSourceParameter("productModelID", GetType(Integer), 23))

    'Creating a new report
    Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

    ' Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource

    ' Use the InstanceReportSource to pass the report to the viewer for displaying.
    Dim reportSource As new InstanceReportSource
    reportSource.ReportDocument = report

    ' Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource

    ' Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport()

End Sub


How to: Bind to a DataTable

[image]

Telerik Reporting Q2 2012
How to: Bind to a DataTable
Send Feedback

The following example illustrates how to use a DataTable as the source for an ObjectDataSource component. The code bellow additionally creates a calculated field that can be used in the report definition in the same way as a regular field.

CopyC#
void Form2_Load(object sender, EventArgs e)
{
    // Creating and configuring the ObjectDataSource component:
    Telerik.Reporting.ObjectDataSource objectDataSource = new Telerik.Reporting.ObjectDataSource();
    objectDataSource.DataSource = GetData(); // GetData returns a DataTable
    objectDataSource.CalculatedFields.Add(new Telerik.Reporting.CalculatedField("FullName", typeof(string), "=Fields.Name + ' ' + Fields.ProductNumber")); // Adding a sample calculated field.

    // Creating a new report
    Telerik.Reporting.Report report = new Telerik.Reporting.Report();

    // Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource;

    // Use the InstanceReportSource to pass the report to the viewer for displaying
    Telerik.Reporting.InstanceReportSource reportSource = new Telerik.Reporting.InstanceReportSource();
    reportSource.ReportDocument = report;

    // Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource;

    // Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport();
}

static DataTable GetData()
{
    const string connectionString =
        "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";

    string selectCommandText =
        "SELECT Name, ProductNumber FROM Production.Product;";

    SqlDataAdapter dataAdapter = new SqlDataAdapter(selectCommandText, connectionString);
    DataTable dataTable = new DataTable();

    dataAdapter.Fill(dataTable);

    return dataTable;
}
CopyVB.NET
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)

    ' Creating and configuring the ObjectDataSource component:
    Dim objectDataSource As New Telerik.Reporting.ObjectDataSource()
    objectDataSource.DataSource = GetData() ' GetData returns a DataTable
    objectDataSource.CalculatedFields.Add(New Telerik.Reporting.CalculatedField("FullName", GetType(String), "=Fields.Name + ' ' + Fields.ProductNumber")) ' Adding a sample calculated field.

    'Creating a new report
    Dim report As New Telerik.Reporting.Report()

    ' Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource

    ' Use the InstanceReportSource to pass the report to the viewer for displaying.
    Dim reportSource As new InstanceReportSource
    reportSource.ReportDocument = report

    ' Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource

    ' Calling the RefreshReport method in case this is a WinForms application.
    Me.reportViewer1.RefreshReport()

End Sub

Shared Function GetData() As DataTable
    Const connectionString As String = _
        "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"

    Dim selectCommandText As String = _
        "SELECT Name, ProductNumber FROM Production.Product;"

    Dim dataAdapter = New SqlDataAdapter(selectCommandText, connectionString)
    Dim dataTable As New DataTable()
    dataAdapter.Fill(dataTable)

    Return dataTable
End Function


How to: Bind to a DataView

[image]

Telerik Reporting Q2 2012
How to: Bind to a DataView
Send Feedback

The following example illustrates how to use a DataView as the source for an ObjectDataSource component.

The sample code bellow shows how to pass a DataView object to the DataSource property of the ObjectDataSource component. DataView is usually used when we want to work only with a subset of data from the DataTable. Additionally a sample calculated field is added that can be used in the report definition in the same way as a regular field.

CopyC#
void Form3_Load(object sender, EventArgs e)
{
    // Creating and configuring the ObjectDataSource component:
    var objectDataSource = new Telerik.Reporting.ObjectDataSource();
    objectDataSource.DataSource = GetData("Name LIKE 'Mountain%'"); // GetData returns a DataView with the specified row filter.
    objectDataSource.CalculatedFields.Add(new Telerik.Reporting.CalculatedField("FullName", typeof(string), "=Fields.Name + ' ' + Fields.ProductNumber")); // Adding a sample calculated field.

    // Creating a new report
    Telerik.Reporting.Report report = new Telerik.Reporting.Report();

    // Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource;

    // Use the InstanceReportSource to pass the report to the viewer for displaying
    Telerik.Reporting.InstanceReportSource reportSource = new Telerik.Reporting.InstanceReportSource();
    reportSource.ReportDocument = report;

    // Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource;

    // Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport();
}

static DataView GetData(string rowFilter)
{
    const string connectionString =
        "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";

    string selectCommandText =
        "SELECT Name, ProductNumber FROM Production.Product;";

    SqlDataAdapter dataAdapter = new SqlDataAdapter(selectCommandText, connectionString);
    DataTable dataTable = new DataTable();

    dataAdapter.Fill(dataTable);

    DataView dataView = dataTable.DefaultView;
    dataView.RowFilter = rowFilter; // View only those records that match a certain criteria.

    return dataView;
}
CopyVB.NET
Private Sub Form3_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)

    ' Creating and configuring the ObjectDataSource component:
    Dim objectDataSource As New Telerik.Reporting.ObjectDataSource()
    objectDataSource.DataSource = GetData("Name LIKE 'Mountain%'") ' GetData returns a DataView with the specified row filter.
    objectDataSource.CalculatedFields.Add(New Telerik.Reporting.CalculatedField("FullName", GetType(String), "=Fields.Name + ' ' + Fields.ProductNumber")) ' Adding a sample calculated field.

    'Creating a new report
    Dim report As New Telerik.Reporting.Report()

    ' Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource

    ' Use the InstanceReportSource to pass the report to the viewer for displaying.
    Dim reportSource As new InstanceReportSource
    reportSource.ReportDocument = report

    ' Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource

    ' Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport()

End Sub

Shared Function GetData(ByVal rowFilter As String) As DataView
    Const connectionString As String = _
        "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"

    Dim selectCommandText As String = _
        "SELECT Name, ProductNumber FROM Production.Product;"

    Dim dataAdapter = New SqlDataAdapter(selectCommandText, connectionString)
    Dim dataTable As New DataTable()
    dataAdapter.Fill(dataTable)

    Dim dataView = dataTable.DefaultView
    dataView.RowFilter = rowFilter

    Return dataView
End Function


How to: Bind to a DataAdapter

[image]

Telerik Reporting Q2 2012
How to: Bind to a DataAdapter
Send Feedback

The following example illustrates how to use a DataAdapter as the source for an ObjectDataSource component.

The ObjectDataSource component allows you to use directly a class that implements the System.Data.IDataAdapter interface. In the sample code bellow an instance of the SqlDataAdapter class is created and passed to the DataSource property of the ObjectDataSource component. When the DataAdapter encounters multiple result sets, it creates multiple tables and each table is given an incremental default name of TableN, starting with "Table" for Table0. In this case you have to set the DataMember property of the ObjectDataSource component to indicate exactly which table to bind to. Additionally a sample calculated field is added that can be used in the report definition in the same way as a regular field.

CopyC#
void Form4_Load(object sender, EventArgs e)
{
    // Creating and configuring the ObjectDataSource component:
    var objectDataSource = new Telerik.Reporting.ObjectDataSource();
    objectDataSource.DataSource = GetMyData(); // GetData returns a SqlDataAdapter object which has a select command with three SELECT statements.
    objectDataSource.DataMember = "Table2"; /// Indicating the exact table to bind to. If the DataMember is not specified the first data table will be used.
    objectDataSource.CalculatedFields.Add(new Telerik.Reporting.CalculatedField("FullName", typeof(string), "=Fields.Name + ' ' + Fields.ProductNumber")); // Adding a sample calculated field.

    // Creating a new report
    Telerik.Reporting.Report report = new Telerik.Reporting.Report();

    // Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource;

    // Use the InstanceReportSource to pass the report to the viewer for displaying
    Telerik.Reporting.InstanceReportSource reportSource = new Telerik.Reporting.InstanceReportSource();
    reportSource.ReportDocument = report;

    // Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource;

    // Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport();
}

static IDataAdapter GetMyData()
{
    const string connectionString =
        "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";

    string selectCommandText = "SELECT Name, ProductCategoryID FROM Production.ProductCategory;" +
        "SELECT Name, ProductCategoryID FROM Production.ProductSubcategory;" +
        "SELECT Name, ProductNumber FROM Production.Product;";

    return new SqlDataAdapter(selectCommandText, connectionString);
}
CopyVB.NET
Private Sub Form4_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)
    ' Creating and configuring the ObjectDataSource component:
    Dim objectDataSource As New Telerik.Reporting.ObjectDataSource()
    objectDataSource.DataSource = GetMyData() ' GetData returns a SqlDataAdapter object which has a select command with three SELECT statements.
    objectDataSource.DataMember = "Table2" ' Indicating the exact table to bind to. If the DataMember is not specified the first data table will be used.
    objectDataSource.CalculatedFields.Add(New Telerik.Reporting.CalculatedField("FullName", GetType(String), "=Fields.Name + ' ' + Fields.ProductNumber")) ' Adding a sample calculated field.

    'Creating a new report
    Dim report As New Telerik.Reporting.Report()

    ' Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource

    ' Use the InstanceReportSource to pass the report to the viewer for displaying.
    Dim reportSource As new InstanceReportSource
    reportSource.ReportDocument = report

    ' Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource

    ' Calling the RefreshReport method in case this is a WinForms application.
    Me.reportViewer1.RefreshReport()
End Sub

Shared Function GetMyData() As IDataAdapter
    Const connectionString As String = _
        "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"

    Dim selectCommandText As String = _
        "SELECT Name, ProductCategoryID FROM Production.ProductCategory;" _
        + "SELECT Name, ProductCategoryID FROM Production.ProductSubcategory;" _
        + "SELECT Name, ProductNumber FROM Production.Product;"

    Return New SqlDataAdapter(selectCommandText, connectionString)
End Function


How to: Bind to a DataSet

[image]

Telerik Reporting Q2 2012
How to: Bind to a DataSet
Send Feedback

The following example illustrates how to use a DataSet as the source for an ObjectDataSource component.

In the code snippet bellow a DataSet object is filled with three tables and then used for the DataSource property of the ObjectDataSource component. The DataMemeber property of the ObjectDataSource component is set to indicate to which one of the three tables to bind to. Additionally a sample calculated field is added which can be used in the report definition in the same way as a regular field.

CopyC#
private void Form5_Load(object sender, EventArgs e)
{
    // Creating and configuring the ObjectDataSource component:
    var objectDataSource = new Telerik.Reporting.ObjectDataSource();
    objectDataSource.DataSource = GetAllData(); // GetData returns a DataSet with three tables
    objectDataSource.DataMember = "Product"; /// Indicating the exact table to bind to. If the DataMember is not specified the first data table will be used.
    objectDataSource.CalculatedFields.Add(new Telerik.Reporting.CalculatedField("FullName", typeof(string), "=Fields.Name + ' ' + Fields.ProductNumber")); // Adding a sample calculated field.

    // Creating a new report
    Telerik.Reporting.Report report = new Telerik.Reporting.Report();

    // Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource;

    // Use the InstanceReportSource to pass the report to the viewer for displaying
    Telerik.Reporting.InstanceReportSource reportSource = new Telerik.Reporting.InstanceReportSource();
    reportSource.ReportDocument = report;

    // Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource;

    // Calling the RefreshReport method (only in WinForms applications).
    reportViewer1.RefreshReport();
}

static DataSet GetAllData()
{
    const string connectionString =
        "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";

    string selectCommandText = "SELECT Name, ProductCategoryID FROM Production.ProductCategory;" +
        "SELECT Name, ProductCategoryID FROM Production.ProductSubcategory;" +
        "SELECT Name, ProductNumber FROM Production.Product;";

    SqlDataAdapter adapter = new SqlDataAdapter(selectCommandText, connectionString);
    DataSet dataSet = new DataSet();

    // The data set will be filled with three tables: ProductCategory, ProductSubcategory
    // and Product as the select command contains three SELECT statements.
    adapter.Fill(dataSet);

    // Giving meaningful names for the tables so that we can use them later.
    dataSet.Tables[0].TableName = "ProductCategory";
    dataSet.Tables[1].TableName = "ProductSubcategory";
    dataSet.Tables[2].TableName = "Product";
    return dataSet;
}
CopyVB.NET
Private Sub Form5_Load(ByVal sender As System.Object, ByVal e As System.EventArgs)

    ' Creating and configuring the ObjectDataSource component:
    Dim objectDataSource As New Telerik.Reporting.ObjectDataSource()
    objectDataSource.DataSource = GetAllData() ' GetData returns a DataSet with three tables
    objectDataSource.DataMember = "Product" ' Indicating the exact table to bind to. If the DataMember is not specified the first data table will be used.
    objectDataSource.CalculatedFields.Add(New Telerik.Reporting.CalculatedField("FullName", GetType(String), "=Fields.Name + ' ' + Fields.ProductNumber")) ' Adding a sample calculated field.

    'Creating a new report
    Dim report As New Telerik.Reporting.Report()

    ' Assigning the ObjectDataSource component to the DataSource property of the report.
    report.DataSource = objectDataSource

    ' Use the InstanceReportSource to pass the report to the viewer for displaying.
    Dim reportSource As new InstanceReportSource
    reportSource.ReportDocument = report

    ' Assigning the report to the report viewer.
    reportViewer1.ReportSource = reportSource

    ' Calling the RefreshReport method in case this is a WinForms application.
    reportViewer1.RefreshReport()

End Sub

Shared Function GetAllData() As DataSet
    Const connectionString As String = _
        "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"

    Dim selectCommandText As String = _
        "SELECT Name, ProductCategoryID FROM Production.ProductCategory;" _
        + "SELECT Name, ProductCategoryID FROM Production.ProductSubcategory;" _
        + "SELECT Name, ProductNumber FROM Production.Product;"

    Dim adapter As New SqlDataAdapter(selectCommandText, connectionString)
    Dim dataSet As New DataSet()

    'The data set will be filled with three tables: ProductCategory, ProductSubcategory
    'and Product as the select command contains three SELECT statements.
    adapter.Fill(dataSet)

    'Giving meaningful names for the tables so that we can use them later.
    dataSet.Tables(0).TableName = "ProductCategory"
    dataSet.Tables(1).TableName = "ProductSubcategory"
    dataSet.Tables(2).TableName = "Product"

    Return dataSet
End Function


EntityDataSource Component

[image]

Telerik Reporting Q2 2012
EntityDataSource Component
Send Feedback

The EntityDataSource component enables data items to connect to an ADO.NET Entity Data Model. This allows seamless integration of Telerik Reporting with applications or web sites that utilize the ADO.NET Entity Framework. There are several main benefits when using the EntityDataSource component for connecting to an Entity Data Model:

  • Dedicated design-time support: the EntityDataSource component has its own set of design-time editors, tool windows, and a configuration wizard. In addition to this, EntityDataSource adds support for entity schema in Data Explorer and live data preview of the report in Report Designer.
  • Configuring database connectivity: the EntityDataSource component offers an additional level of control over the database connectivity of the Entity Data Model. You can specify a connection string or a named connection from the configuration file of the main application or web site. That ensures EntityDataSource can establish a valid database connection both at design-time and when running the report in production.
  • Maintaining ObjectContext lifecycle: the EntityDataSource component allows the option to maintain the entire lifecycle of the ObjectContext automatically. It can create its own instance of the ObjectContext internally, keep it alive for the duration of the report generation process, and then destroy it automatically when it is no longer needed by the reporting engine.

In This Section

Note

In order to use the Report Designer and Report Wizard the Entity Data Model should be located in a separate class library. The connectionString to the database should be copied to the config file of the report class library for the Data Explorer and Preview to work.

In This Section

  • Connecting to an Entity Data Model with the EntityDataSource component

  • Using parameters with the EntityDataSource component

  • Configuring the database connectivity with the EntityDataSource component

  • Maintaining the lifecycle of the ObjectContext with the EntityDataSource component

  • Retrieving data from an Entity Data Model with the EntityDataSource component


Connecting to an Entity Data Model with the EntityDataSource component

[image]

Telerik Reporting Q2 2012
Connecting to an Entity Data Model with the EntityDataSource component
Send Feedback

This section discusses how to connect the EntityDataSource component to an Entity Data Model. The provided examples and code snippets assume an existing Entity Data Model of the Adventure Works sample database with the following structure:

The simplest way to configure EntityDataSource in Report Designer is to use the EntityDataSource Wizard. That wizard is started automatically when you create a new EntityDataSource, but you can invoke it manually at any time from the context menu associated with the data source by choosing "Configure":

To configure the EntityDataSource component programmatically you need to specify at least an ObjectContext and a property or a method from that ObjectContext which is responsible for data retrieval. Assign the type of the ObjectContext to the ObjectContext property of EntityDataSource and the name of the desired member to the ObjectContextMember property, as shown in the following example:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

The above code snippet connects the EntityDataSource component to the AdventureWorksEntities context and retrieves the information for all products from the Products auto-generated property. Instead of specifying a type you can assign a live instance of the ObjectContext. In this case however it is your responsibility to destroy that ObjectContext instance when done with the report:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();
AdventureWorksEntities objectContext = new AdventureWorksEntities();

entityDataSource.ObjectContext = objectContext;
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;

// You have to dispose the ObjectContext explicitly when done with the report.
objectContext.Dispose();
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()
Dim objectContext As AdventureWorksEntities = New AdventureWorksEntities()

entityDataSource.ObjectContext = objectContext
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

' You have to dispose the ObjectContext explicitly when done with the report.
objectContext.Dispose()

Binding to a method is more flexible than binding to a property, because it is possible to execute some custom business logic when retrieving data for the report. If the specified method has arguments, the EntityDataSource component allows you to pass parameters to those arguments via the Parameters collection. For example, let us extend the AdventureWorksEntities context using a partial class that defines the following method:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

You can bind the EntityDataSource component to that method with the following code snippet:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "GetProducts";
entityDataSource.Parameters.Add("color", typeof(string), "Black");
entityDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "GetProducts"
entityDataSource.Parameters.Add("color", GetType(String), "Black")
entityDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

Note

The names and types of the parameters in the Parameters collection should match exactly the names and types of the method arguments. In case this requirement is not fulfilled the EntityDataSource component will not be able to resolve or call correctly the method and will raise an exception at runtime.


Using parameters with the EntityDataSource component

[image]

Telerik Reporting Q2 2012
Using parameters with the EntityDataSource component
Send Feedback

This section discusses more in-depth how to pass parameters to a method of the ObjectContext with the EntityDataSource component. The provided examples and code snippets assume an existing Entity Data Model of the Adventure Works sample database with the following structure:

The EntityDataSource component can call a method of the ObjectContext based on the name of the method, and additionally based on the arguments which make the signature of that method. For example, let us extend the AdventureWorksEntities context using a partial class that defines the following method:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

To call the above method specify its name to the ObjectContextMember property and define a data source parameter in the Parameters collection for each method argument. The names and types of the data source parameters must match exactly the names and types of the corresponding method arguments otherwise the EntityDataSource component will raise an exception at runtime. The following code snippet illustrates how to pass parameters to the previous method programmatically:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "GetProducts";
entityDataSource.Parameters.Add("color", typeof(string), "Black");
entityDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "GetProducts"
entityDataSource.Parameters.Add("color", GetType(String), "Black")
entityDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

When declaring a data source parameter you can specify a default value for that parameter and the value will be passed automatically to the corresponding method argument. Instead of supplying the parameter value directly, you can specify an expression to be evaluated at runtime. For example, this way it is possible to link the data source parameter to an existing report parameter, as shown in the following code snippet:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "GetProducts";
entityDataSource.Parameters.Add("color", typeof(string), "=Parameters.Color.Value");
entityDataSource.Parameters.Add("price", typeof(decimal), "=Parameters.Price.Value");

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
report.ReportParameters.Add("Color", Telerik.Reporting.ReportParameterType.String, "Black");
report.ReportParameters.Add("Price", Telerik.Reporting.ReportParameterType.Float, 100);
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "GetProducts"
entityDataSource.Parameters.Add("color", GetType(String), "=Parameters.Color.Value")
entityDataSource.Parameters.Add("price", GetType(Decimal), "=Parameters.Price.Value")

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource
report.ReportParameters.Add("Color", Telerik.Reporting.ReportParameterType.String, "Black")
report.ReportParameters.Add("Price", Telerik.Reporting.ReportParameterType.Float, 100)


Configuring the database connectivity with the EntityDataSource component

[image]

Telerik Reporting Q2 2012
Configuring the database connectivity with the EntityDataSource component
Send Feedback

This section discusses how to specify a database connection to the EntityDataSource component that can be used both at design-time and when running the report in production. The provided examples and code snippets assume an existing Entity Data Model of the Adventure Works sample database with the following structure:

Strictly speaking, it is not necessary to specify a database connection when working with the EntityDataSource component. Simply specifying an ObjectContext and a member is enough to connect to the Entity Data Model, because the ObjectContext is already configured to access the database. The following code snippet shows the minimum code necessary to setup the EntityDataSource component:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

When running the report in production the above code should work just fine. However, this is not the case when generating a preview of the same report in the designer, for example. The problem is that the ObjectContext searches its connection string in the configuration file of the current executing application or web site. When it is your application that is currently running, all that is necessary is to make sure the connection string is present in the right configuration file. On the other side, when running the report in the designer, the current executing application is Microsoft Visual Studio, so the connection string is no longer available. To overcome this, you can specify your connection string to the ConnectionString property of the EntityDataSource component, as shown in the following example:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ConnectionString = "AdventureWorksConnection";
entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "Products";
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ConnectionString = "AdventureWorksConnection"
entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

The ConnectionString property can accept an inline connection string or the name of an existing connection string stored in the configuration file. When running the report EntityDataSource searches the configuration file for a connection string with the specified name. If such connection string exists EntityDataSource uses that connection string to connect to the database otherwise it is assumed that the value of the ConnectionString property represents an inline connection string.

Note

Specifying an inline connection string directly to the ConnectionString property of the EntityDataSource component is not recommended, because it might be difficult to maintain all your reports later, when that connection string changes. The recommended approach is to always specify the name of an existing connection string stored in the configuration file. When specifying a connection string form a configuration file it is important to understand which configuration file is used at design-time or when running the report in production. For example, let us consider the following simplified structure of a business application:

The above schema assumes that the different parts of the business application are represented as separate projects in the solution, each with its own configuration file. Initially, when you create the Entity Data Model in the Business Logic project, the connection string is stored automatically in the configuration file of that project. Later, when creating new reports in the Report Library project, you need to add the connection string to the configuration file of that project, because this is where Report Designer searches for existing connection strings. Finally, when deploying your application or web site in production, you need to add the connection string to the configuration file of your Main Application.


Maintaining the lifecycle of the ObjectContext with the EntityDataSource component

[image]

Telerik Reporting Q2 2012
Maintaining the lifecycle of the ObjectContext with the EntityDataSource component
Send Feedback

This section discusses how to maintain the lifecycle of the ObjectContext when using the EntityDataSource component. The provided examples and code snippets assume an existing Entity Data Model of the Adventure Works sample database with the following structure:

One possible approach to connect to an Entity Data Model without using the EntityDataSource component is to create a custom business object with a method that retrieves the necessary entities for the report. The sample code below defines a method that retrieves information about all products:

CopyC#
public class SampleBusinessObject
{
    public System.Collections.Generic.List<Product> GetProducts()
    {
        using (AdventureWorksEntities context = new AdventureWorksEntities())
        {
            return context.Products.ToList();
        }
    }
}
CopyVB.NET
Public Class SampleBusinessObject
    Public Function GetProducts() As System.Collections.Generic.List(Of Product)
        Using context As AdventureWorksEntities = New AdventureWorksEntities()
            Return context.Products.ToList()
        End Using
    End Function
End Class

Then you can use ObjectDataSource to connect to that business object, as shown in the following code snippet:

CopyC#
Telerik.Reporting.ObjectDataSource objectDataSource = new Telerik.Reporting.ObjectDataSource();

objectDataSource.DataSource = typeof(SampleBusinessObject);
objectDataSource.DataMember = "GetProducts";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = objectDataSource;
CopyVB.NET
Dim objectDataSource As Telerik.Reporting.ObjectDataSource = New Telerik.Reporting.ObjectDataSource()

objectDataSource.DataSource = GetType(SampleBusinessObject)
objectDataSource.DataMember = "GetProducts"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = objectDataSource

The problem with this approach is that it is not guaranteed to work in all possible scenarios. Simple expressions accessing primitive properties of the Product entity might work as expected:

=Fields.Name

However, let us consider the following expression that is intended to obtain the category of a given product:

=Fields.ProductSubcategory.ProductCategory.Name

The above expression relies upon the lazy loading mechanism of the ADO.NET Entity Framework to obtain the ProductSubcategory entity for the current Product entity via the corresponding relation property, and then the ProductCategory entity for the current ProductSubcategory entity. This is not guaranteed to work because the ObjectContext is already destroyed when evaluating the expression, so lazy loading is no longer possible. One of the greatest advantages of the EntityDataSource component is that it can maintain the lifecycle of the ObjectContext automatically, so scenarios like the previous one are guaranteed to work as expected. When specifying a Type for the ObjectContext property, EntityDataSource creates internally a new instance of the ObjectContext with the given type, keeps it alive for the duration of the report generation process, and then destroys it automatically when it is no longer needed by the reporting engine. The following code snippet accomplishes the previous task with the help of the EntityDataSource component:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

If you have already implemented your own mechanism for maintaining the lifecycle of the ObjectContext you can continue using the EntityDataSource component. In this case however you need to specify a live instance of your ObjectContext to the ObjectContext property as demonstrated here:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();
AdventureWorksEntities objectContext = new AdventureWorksEntities();

entityDataSource.ObjectContext = objectContext;
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;

// You have to dispose the ObjectContext explicitly when done with the report.
objectContext.Dispose();
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()
Dim objectContext As AdventureWorksEntities = New AdventureWorksEntities()

entityDataSource.ObjectContext = objectContext
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

' You have to dispose the ObjectContext explicitly when done with the report.
objectContext.Dispose()


Retrieving data from an Entity Data Model with the EntityDataSource component

[image]

Telerik Reporting Q2 2012
Retrieving data from an Entity Data Model with the EntityDataSource component
Send Feedback

This section discusses various techniques for retrieving data from an Entity Data Model with the help of the EntityDataSource component. The provided examples and code snippets assume an existing Entity Data Model of the Adventure Works sample database with the following structure:

The simplest approach to extract entities from an Entity Data Model is to bind the EntityDataSource component directly to an auto-generated property of the model, as shown in the sample code below:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

You can specify expressions to the data item to group, sort or filter the selected entities. The expressions are evaluated on the application level by the reporting engine after all entities are downloaded from the database. Sometimes it is preferable to offload certain tasks on the database level instead. To do this you need to define a custom method in the ObjectContext class that performs the required business logic. For example, the following method uses the Where extension method to filter the Product entities:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

Using a method instead of a property has the additional benefit that you can pass data source parameters to it, as illustrated in the following code snippet:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "GetProducts";
entityDataSource.Parameters.Add("color", typeof(string), "Black");
entityDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "GetProducts"
entityDataSource.Parameters.Add("color", GetType(String), "Black")
entityDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource

Another common problem is related to the lazy loading feature of the ADO.NET Entity Framework. For example, let us consider the following expression that obtains the category of a given product

=Fields.ProductSubcategory.ProductCategory.Name

The above expression relies upon the built-in lazy loading mechanism to obtain the ProductSubcategory entity for the current Product entity via the corresponding relation property, and then the ProductCategory entity for the current ProductSubcategory entity. While convenient, lazy loading requires additional round-trips to the database for the entities that are not present in memory. If this happens frequently it might significantly impact the performance of the report. To overcome this you can try performing eager loading of the entities instead. For example, the following statement uses the Include method to preload the ProductSubcategory and the ProductCategory entities while retrieving the Product entities:

CopyC#
this.Products.Include("ProductSubcategory").Include("ProductSubcategory.ProductCategory").ToList()
CopyVB.NET
Me.Products.Include("ProductSubcategory").Include("ProductSubcategory.ProductCategory").ToList()

However in certain scenarios eager loading might be costly too. Given the previous example, we materialize all ProductSubcategory and ProductCategory entities only to show the category name of each product. This means a lot of unnecessary data is downloaded from database just to be discarded later. The most flexible and efficient method for retrieving data from the Entity Data Model is to execute a custom query against the entities. The following sample method uses a LINQ query to obtain only the necessary data for the report and then packs it into a collection of POCOs:

CopyC#
public class ReportData
{
    public string CategoryName { get; set; }
    public string SubcategoryName { get; set; }
    public string ProductName { get; set; }
    public decimal ListPrice { get; set; }
}

partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<ReportData> GetProducts(string category, string subcategory)
    {
        var result = from productCategory in this.ProductCategories
                     where productCategory.Name.StartsWith(category)
                     from productSubcategory in productCategory.ProductSubcategories
                     where productSubcategory.Name.StartsWith(subcategory)
                     from product in productSubcategory.Products
                     select new ReportData
                     {
                         CategoryName = productCategory.Name,
                         SubcategoryName = productSubcategory.Name,
                         ProductName = product.Name,
                         ListPrice = product.ListPrice
                     };

        return result.ToList();
    }
}
CopyVB.NET
Public Class ReportData
    Public Property CategoryName As String
    Public Property SubcategoryName As String
    Public Property ProductName As String
    Public Property ListPrice As Decimal
End Class

Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal category As String, ByVal subcategory As String) As System.Collections.Generic.List(Of ReportData)
        Dim result = From productCategory In Me.ProductCategories
                     Where productCategory.Name.StartsWith(category)
                     From productSubcategory In productCategory.ProductSubcategories
                     Where productCategory.Name.StartsWith(subcategory)
                     From product In productSubcategory.Products
                     Select New ReportData With
                     {
                         .CategoryName = productCategory.Name,
                         .SubcategoryName = productSubcategory.Name,
                         .ProductName = product.Name,
                         .ListPrice = product.ListPrice
                     }

        Return result.ToList()
    End Function
End Class

The sample code that binds the EntityDataSource component to that method is shown here:

CopyC#
Telerik.Reporting.EntityDataSource entityDataSource = new Telerik.Reporting.EntityDataSource();

entityDataSource.ObjectContext = typeof(AdventureWorksEntities);
entityDataSource.ObjectContextMember = "GetProducts";
entityDataSource.Parameters.Add("category", typeof(string), "Bike");
entityDataSource.Parameters.Add("subcategory", typeof(string), "Road");

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = entityDataSource;
CopyVB.NET
Dim entityDataSource As Telerik.Reporting.EntityDataSource = New Telerik.Reporting.EntityDataSource()

entityDataSource.ObjectContext = GetType(AdventureWorksEntities)
entityDataSource.ObjectContextMember = "GetProducts"
entityDataSource.Parameters.Add("category", GetType(String), "Bike")
entityDataSource.Parameters.Add("subcategory", GetType(String), "Road")

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = entityDataSource


OpenAccessDataSource Component

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Component
Send Feedback

The OpenAccessDataSource component enables data items to connect to an OpenAccess Model. This allows seamless integration of Telerik Reporting with applications or web sites that utilize the OpenAccess ORM. There are several main benefits when using the OpenAccessDataSource component for connecting to an OpenAccess Model:

  • Dedicated design-time support: the OpenAccessDataSource component has its own set of design-time editors, tool windows, and a configuration wizard. In addition to this, OpenAccessDataSource adds support for entity schema in Data Explorer and live data preview of the report in Report Designer.
  • Configuring database connectivity: the OpenAccessDataSource component offers an additional level of control over the database connectivity of the OpenAccess Model. You can specify a connection string or a named connection from the configuration file of the main application or web site. That ensures OpenAccessDataSource can establish a valid database connection both at design-time and when running the report in production.
  • Maintaining OpenAccessContext lifecycle: the OpenAccessDataSource component allows the option to maintain the entire lifecycle of the OpenAccessContext automatically. It can create its own instance of the OpenAccessContext internally, keep it alive for the duration of the report generation process, and then destroy it automatically when it is no longer needed by the reporting engine.

In This Section

  • Connecting to an OpenAccess Model with the OpenAccessDataSource component

  • Using parameters with the OpenAccessDataSource component

  • Configuring the database connectivity with the OpenAccessDataSource component

  • Maintaining the lifecycle of the OpenAccessContext with the OpenAccessDataSource component

  • Retrieving data from an OpenAccess Model with the OpenAccessDataSource component


Connecting to an OpenAccess Model with the OpenAccessDataSource component

[image]

Telerik Reporting Q2 2012
Connecting to an OpenAccess Model with the OpenAccessDataSource component
Send Feedback

This section discusses how to connect the OpenAccessDataSource component to an OpenAccess Model. The provided examples and code snippets assume an existing OpenAccess Model of the Adventure Works sample database with the following structure:

The simplest way to configure OpenAccessDataSource in Report Designer is to use the OpenAccessDataSource Wizard. That wizard is started automatically when you create a new OpenAccessDataSource, but you can invoke it manually at any time from the context menu associated with the data source by choosing "Configure":

To configure the OpenAccessDataSource component programmatically you need to specify at least an ObjectContext and a property or a method from that ObjectContext which is responsible for data retrieval. Assign the type of the OpenAccessContext to the ObjectContext property of OpenAccessDataSource and the name of the desired member to the ObjectContextMember property, as shown in the following example:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

The above code snippet connects the OpenAccessDataSource component to the AdventureWorksEntities context and retrieves the information for all products from the Products auto-generated property. Instead of specifying a type you can assign a live instance of the OpenAccessContext. In this case however it is your responsibility to destroy that OpenAccessContext instance when done with the report:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();
AdventureWorksEntities openAccessContext = new AdventureWorksEntities();

openAccessDataSource.ObjectContext = openAccessContext;
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;

// You have to dispose the OpenAccessContext explicitly when done with the report.
openAccessContext.Dispose();
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()
Dim openAccessContext As AdventureWorksEntities = New AdventureWorksEntities()

openAccessDataSource.ObjectContext = openAccessContext
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

' You have to dispose the OpenAccessContext explicitly when done with the report.
openAccessContext.Dispose()

Binding to a method is more flexible than binding to a property, because it is possible to execute some custom business logic when retrieving data for the report. If the specified method has arguments, the OpenAccessDataSource component allows you to pass parameters to those arguments via the Parameters collection. For example, let us extend the AdventureWorksEntities context using a partial class that defines the following method:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

You can bind the OpenAccessDataSource component to that method with the following code snippet:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "GetProducts";
openAccessDataSource.Parameters.Add("color", typeof(string), "Black");
openAccessDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "GetProducts"
openAccessDataSource.Parameters.Add("color", GetType(String), "Black")
openAccessDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

Note

The names and types of the parameters in the Parameters collection should match exactly the names and types of the method arguments. In case this requirement is not fulfilled the OpenAccessDataSource component will not be able to resolve or call correctly the method and will raise an exception at runtime.


Using parameters with the OpenAccessDataSource component

[image]

Telerik Reporting Q2 2012
Using parameters with the OpenAccessDataSource component
Send Feedback

This section discusses more in-depth how to pass parameters to a method of the OpenAccessContext with the OpenAccessDataSource component. The provided examples and code snippets assume an existing OpenAccess Model of the Adventure Works sample database with the following structure:

The OpenAccessDataSource component can call a method of the OpenAccessContext based on the name of the method, and additionally based on the arguments which make the signature of that method. For example, let us extend the AdventureWorksEntities context using a partial class that defines the following method:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

To call the above method specify its name to the ObjectContextMember property and define a data source parameter in the Parameters collection for each method argument. The names and types of the data source parameters must match exactly the names and types of the corresponding method arguments otherwise the OpenAccessDataSource component will raise an exception at runtime. The following code snippet illustrates how to pass parameters to the previous method programmatically:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "GetProducts";
openAccessDataSource.Parameters.Add("color", typeof(string), "Black");
openAccessDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "GetProducts"
openAccessDataSource.Parameters.Add("color", GetType(String), "Black")
openAccessDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

When declaring a data source parameter you can specify a default value for that parameter and the value will be passed automatically to the corresponding method argument. Instead of supplying the parameter value directly, you can specify an expression to be evaluated at runtime. For example, this way it is possible to link the data source parameter to an existing report parameter, as shown in the following code snippet:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "GetProducts";
openAccessDataSource.Parameters.Add("color", typeof(string), "=Parameters.Color.Value");
openAccessDataSource.Parameters.Add("price", typeof(decimal), "=Parameters.Price.Value");

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
report.ReportParameters.Add("Color", Telerik.Reporting.ReportParameterType.String, "Black");
report.ReportParameters.Add("Price", Telerik.Reporting.ReportParameterType.Float, 100);
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "GetProducts"
openAccessDataSource.Parameters.Add("color", GetType(String), "=Parameters.Color.Value")
openAccessDataSource.Parameters.Add("price", GetType(Decimal), "=Parameters.Price.Value")

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource
report.ReportParameters.Add("Color", Telerik.Reporting.ReportParameterType.String, "Black")
report.ReportParameters.Add("Price", Telerik.Reporting.ReportParameterType.Float, 100)


Configuring the database connectivity with the OpenAccessDataSource component

[image]

Telerik Reporting Q2 2012
Configuring the database connectivity with the OpenAccessDataSource component
Send Feedback

This section discusses how to specify a database connection to the OpenAccessDataSource component that can be used both at design-time and when running the report in production. The provided examples and code snippets assume an existing OpenAccess Model of the Adventure Works sample database with the following structure:

Strictly speaking, it is not necessary to specify a database connection when working with the OpenAccessDataSource component. Simply specifying an OpenAccessContext and a member is enough to connect to the OpenAccess Model, because the OpenAccessContext is already configured to access the database. The following code snippet shows the minimum code necessary to setup the OpenAccessDataSource component:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

When running the report in production the above code should work just fine. However, this is not the case when generating a preview of the same report in the designer, for example. The problem is that the OpenAccessContext searches its connection string in the configuration file of the current executing application or web site. When it is your application that is currently running, all that is necessary is to make sure the connection string is present in the right configuration file. On the other side, when running the report in the designer, the current executing application is Microsoft Visual Studio, so the connection string is no longer available. To overcome this, you can specify your connection string to the OpenAccessDataSource component. Assign the connection string to the ConnectionString property and the ADO.NET provider to the ProviderName property, as shown in the following code snippet:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ProviderName = "System.Data.SqlClient";
openAccessDataSource.ConnectionString = "Data Source=.\\SqlExpress;Initial Catalog=AdventureWorks";
openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ProviderName = "System.Data.SqlClient"
openAccessDataSource.ConnectionString = "Data Source=.\SqlExpress;Initial Catalog=AdventureWorks"
openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Instead of specifying an inline connection string you can assign the name of an existing connection string stored in the configuration file to the ConnectionString property. In that case specifying an ADO.NET provider to the ProviderName property is no longer required, because that information is already present in the configuration. The following sample code demonstrates how to specify a named connection string from a configuration file:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ConnectionString = "AdventureWorksConnection";
openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ConnectionString = "AdventureWorksConnection"
openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Note

Specifying an inline connection string directly to the ConnectionString property of the OpenAccessDataSource component is not recommended, because it might be difficult to maintain all your reports later, when that connection string changes. The recommended approach is to always specify the name of an existing connection string stored in the configuration file. When specifying a connection string form a configuration file it is important to understand which configuration file is used at design-time or when running the report in production. For example, let us consider the following simplified structure of a business application:

The above schema assumes that the different parts of the business application are represented as separate projects in the solution, each with its own configuration file. Initially, when you create the OpenAccess Model in the Business Logic project, the connection string is stored automatically in the configuration file of that project. Later, when creating new reports in the Report Library project, you need to add the connection string to the configuration file of that project, because this is where Report Designer searches for existing connection strings. Finally, when deploying your application or web site in production, you need to add the connection string to the configuration file of your Main Application.


Maintaining the lifecycle of the OpenAccessContext with the OpenAccessDataSource component

[image]

Telerik Reporting Q2 2012
Maintaining the lifecycle of the OpenAccessContext with the OpenAccessDataSource component
Send Feedback

This section discusses how to maintain the lifecycle of the OpenAccessContext when using the OpenAccessDataSource component. The provided examples and code snippets assume an existing OpenAccess Model of the Adventure Works sample database with the following structure:

One possible approach to connect to an OpenAccess Model without using the OpenAccessDataSource component is to create a custom business object with a method that retrieves the necessary entities for the report. The sample code below defines a method that retrieves information about all products:

CopyC#
public class SampleBusinessObject
{
    public System.Collections.Generic.List<Product> GetProducts()
    {
        using (AdventureWorksEntities context = new AdventureWorksEntities())
        {
            return context.Products.ToList();
        }
    }
}
CopyVB.NET
Public Class SampleBusinessObject
    Public Function GetProducts() As System.Collections.Generic.List(Of Product)
        Using context As AdventureWorksEntities = New AdventureWorksEntities()
            Return context.Products.ToList()
        End Using
    End Function
End Class

Then you can use ObjectDataSource to connect to that business object, as shown in the following code snippet:

CopyC#
Telerik.Reporting.ObjectDataSource objectDataSource = new Telerik.Reporting.ObjectDataSource();

objectDataSource.DataSource = typeof(SampleBusinessObject);
objectDataSource.DataMember = "GetProducts";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = objectDataSource;
CopyVB.NET
Dim objectDataSource As Telerik.Reporting.ObjectDataSource = New Telerik.Reporting.ObjectDataSource()

objectDataSource.DataSource = GetType(SampleBusinessObject)
objectDataSource.DataMember = "GetProducts"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = objectDataSource

The problem with this approach is that it is not guaranteed to work in all possible scenarios. Simple expressions accessing primitive properties of the Product entity might work as expected:

=Fields.Name

However, let us consider the following expression that is intended to obtain the category of a given product:

=Fields.ProductSubcategory.ProductCategory.Name

The above expression relies upon the lazy loading mechanism of the OpenAccess ORM to obtain the ProductSubcategory entity for the current Product entity via the corresponding relation property, and then the ProductCategory entity for the current ProductSubcategory entity. This is not guaranteed to work because the OpenAccessContext is already destroyed when evaluating the expression, so lazy loading is no longer possible. One of the greatest advantages of the OpenAccessDataSource component is that it can maintain the lifecycle of the OpenAccessContext automatically, so scenarios like the previous one are guaranteed to work as expected. When specifying a Type for the OpenAccessContext property, OpenAccessDataSource creates internally a new instance of the OpenAccessContext with the given type, keeps it alive for the duration of the report generation process, and then destroys it automatically when it is no longer needed by the reporting engine. The following code snippet accomplishes the previous task with the help of the OpenAccessDataSource component:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

If you have already implemented your own mechanism for maintaining the lifecycle of the OpenAccessContext you can continue using the OpenAccessDataSource component. In this case however you need to specify a live instance of your OpenAccessContext to the ObjectContext property as demonstrated here:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();
AdventureWorksEntities openAccessContext = new AdventureWorksEntities();

openAccessDataSource.ObjectContext = openAccessContext;
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;

// You have to dispose the OpenAccessContext explicitly when done with the report.
openAccessContext.Dispose();
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()
Dim openAccessContext As AdventureWorksEntities = New AdventureWorksEntities()

openAccessDataSource.ObjectContext = openAccessContext
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

' You have to dispose the OpenAccessContext explicitly when done with the report.
openAccessContext.Dispose()


Retrieving data from an OpenAccess Model with the OpenAccessDataSource component

[image]

Telerik Reporting Q2 2012
Retrieving data from an OpenAccess Model with the OpenAccessDataSource component
Send Feedback

This section discusses various techniques for retrieving data from an OpenAccess Model with the help of the OpenAccessDataSource component. The provided examples and code snippets assume an existing OpenAccess Model of the Adventure Works sample database with the following structure:

The simplest approach to extract entities from an OpenAccess Model is to bind the OpenAccessDataSource component directly to an auto-generated property of the model, as shown in the sample code below:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "Products";

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "Products"

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

You can specify expressions to the data item to group, sort or filter the selected entities. The expressions are evaluated on the application level by the reporting engine after all entities are downloaded from the database. Sometimes it is preferable to offload certain tasks on the database level instead. To do this you need to define a custom method in the OpenAccessContext class that performs the required business logic. For example, the following method uses the Where extension method to filter the Product entities:

CopyC#
partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<Product> GetProducts(string color, decimal price)
    {
        return this.Products.Where(product => product.Color == color && product.ListPrice <= price).ToList();
    }
}
CopyVB.NET
Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal color As String, ByVal price As Decimal) As System.Collections.Generic.List(Of Product)
        Return Me.Products.Where(Function(product) product.Color = color And product.ListPrice <= price).ToList()
    End Function
End Class

Using a method instead of a property has the additional benefit that you can pass data source parameters to it, as illustrated in the following code snippet:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "GetProducts";
openAccessDataSource.Parameters.Add("color", typeof(string), "Black");
openAccessDataSource.Parameters.Add("price", typeof(decimal), 100);

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "GetProducts"
openAccessDataSource.Parameters.Add("color", GetType(String), "Black")
openAccessDataSource.Parameters.Add("price", GetType(Decimal), 100)

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource

Another common problem is related to the lazy loading feature of the OpenAccess ORM. For example, let us consider the following expression that obtains the category of a given product

=Fields.ProductSubcategory.ProductCategory.Name

The above expression relies upon the built-in lazy loading mechanism to obtain the ProductSubcategory entity for the current Product entity via the corresponding relation property, and then the ProductCategory entity for the current ProductSubcategory entity. While convenient, lazy loading requires additional round-trips to the database for the entities that are not present in memory. If this happens frequently it might significantly impact the performance of the report. To overcome this you need to query all entities needed for the report at once. This way lazy loading is avoided completely and all data is retrieved in a single round-trip from the database. The most flexible and efficient method for retrieving data from the OpenAccess Model is to execute a custom query against the entities. The following sample method uses a LINQ query to obtain only the necessary data for the report and then packs it into a collection of POCOs:

CopyC#
public class ReportData
{
    public string CategoryName { get; set; }
    public string SubcategoryName { get; set; }
    public string ProductName { get; set; }
    public decimal ListPrice { get; set; }
}

partial class AdventureWorksEntities
{
    public System.Collections.Generic.List<ReportData> GetProducts(string category, string subcategory)
    {
        var result = from productCategory in this.ProductCategories
                     where productCategory.Name.StartsWith(category)
                     from productSubcategory in productCategory.ProductSubcategories
                     where productSubcategory.Name.StartsWith(subcategory)
                     from product in productSubcategory.Products
                     select new ReportData
                     {
                         CategoryName = productCategory.Name,
                         SubcategoryName = productSubcategory.Name,
                         ProductName = product.Name,
                         ListPrice = product.ListPrice
                     };

        return result.ToList();
    }
}
CopyVB.NET
Public Class ReportData
    Public Property CategoryName As String
    Public Property SubcategoryName As String
    Public Property ProductName As String
    Public Property ListPrice As Decimal
End Class

Partial Class AdventureWorksEntities
    Public Function GetProducts(ByVal category As String, ByVal subcategory As String) As System.Collections.Generic.List(Of ReportData)
        Dim result = From productCategory In Me.ProductCategories
                     Where productCategory.Name.StartsWith(category)
                     From productSubcategory In productCategory.ProductSubcategories
                     Where productCategory.Name.StartsWith(subcategory)
                     From product In productSubcategory.Products
                     Select New ReportData With
                     {
                         .CategoryName = productCategory.Name,
                         .SubcategoryName = productSubcategory.Name,
                         .ProductName = product.Name,
                         .ListPrice = product.ListPrice
                     }

        Return result.ToList()
    End Function
End Class

The sample code that binds the OpenAccessDataSource component to that method is shown here:

CopyC#
Telerik.Reporting.OpenAccessDataSource openAccessDataSource = new Telerik.Reporting.OpenAccessDataSource();

openAccessDataSource.ObjectContext = typeof(AdventureWorksEntities);
openAccessDataSource.ObjectContextMember = "GetProducts";
openAccessDataSource.Parameters.Add("category", typeof(string), "Bike");
openAccessDataSource.Parameters.Add("subcategory", typeof(string), "Road");

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = openAccessDataSource;
CopyVB.NET
Dim openAccessDataSource As Telerik.Reporting.OpenAccessDataSource = New Telerik.Reporting.OpenAccessDataSource()

openAccessDataSource.ObjectContext = GetType(AdventureWorksEntities)
openAccessDataSource.ObjectContextMember = "GetProducts"
openAccessDataSource.Parameters.Add("category", GetType(String), "Bike")
openAccessDataSource.Parameters.Add("subcategory", GetType(String), "Road")

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = openAccessDataSource


CubeDataSource Component

[image]

Telerik Reporting Q2 2012
CubeDataSource Component
Send Feedback

The CubeDataSource component enables data items to retrieve data from an OLAP cube using Microsoft Analysis Services with little or no extra code. CubeDataSource uses the ADOMD.NET client data provider internally to connect to Microsoft Analysis Services and execute an MDX query against the desired OLAP cube. The returned result set can be visualized directly by the Report itself or using a Table/Crosstab report item.

In this section

  • Configuring your project for using Microsoft Analysis Services
  • Connecting the CubeDataSource component to an OLAP database
  • Selecting data from an OLAP cube with the CubeDataSource component
  • Specifying query parameters with the CubeDataSource component


Configuring your project for using Microsoft Analysis Services

[image]

Telerik Reporting Q2 2012
Configuring your project for using Microsoft Analysis Services
Send Feedback

Before utilizing the CubeDataSource component in your reports you need to configure your report class library for using Microsoft Analysis Services first:

  1. Install the Microsoft ADOMD.NET client data provider: The CubeDataSource component requires the Microsoft ADOMD.NET client data provider to be installed on your machine. The present version of Telerik Reporting is compiled against the ADOMD.NET provider for SQL Server 2008 R2.

  2. Add the required assembly references to your project: You need to add the following assembly references to your report class library:

    • Microsoft.AnalysisServices.AdomdClient - this is the ADOMD.NET client data provider assembly which is normally located in the following directory after installation:

      "<Program Files>\Microsoft.NET\ADOMD.NET\<Product Version>".

      Here "<Program Files>" is the directory with your program files, and "<Product Version>" is the version of the installed product (this should be 100 for ADOMD.NET for SQL Server 2008 R2).

    • Telerik.Reporting.Adomd - this is the Telerik Reporting provider assembly for ADOMD.NET which is located in the "Bin" subdirectory of your Telerik Reporting installation.

  3. Add an assembly binding redirect if necessary: The current version of Telerik Reporting uses ADOMD.NET for SQL Server 2008 R2. Please, verify that the version of the Microsoft.AnalysisServices.AdomdClient assembly is "10.0.0.0". If you have a different version of that assembly you need to add an appropriate assembly binding redirect in the configuration file of your report class library as illustrated below:

    CopyXML
    <configuration>
    <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="Microsoft.AnalysisServices.AdomdClient"
                                  publicKeyToken="89845dcd8080cc91"
                                  culture="neutral" />
                <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535"
                                 newVersion="<Your Version>" />
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
</configuration>

    Here "<Your Version>" is the actual version of your Microsoft.AnalysisServices.AdomdClient assembly.


Connecting the CubeDataSource component to an OLAP database

[image]

Telerik Reporting Q2 2012
Connecting the CubeDataSource component to an OLAP database
Send Feedback

When you configure a CubeDataSource you set the ConnectionString property to a connection string that includes information required to connect to the database. Specifying an appropriate connection string requires at least a server name and database (catalog) name. For information on valid connection strings see the ConnectionString property topic for the AdomdConnection class.

The sample code below illustrates how to connect a CubeDataSource component to the Adventure Works DW 2008R2 sample database:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "Data Source=localhost;Initial Catalog=Adventure Works DW 2008R2";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] } on rows " +
                               "from [Adventure Works]";
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "Data Source=localhost;Initial Catalog=Adventure Works DW 2008R2"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] } on rows " & _
                               "from [Adventure Works]"

Instead of setting connection strings as property settings in the CubeDataSource object, you can store them centrally as part of your application's configuration settings using the connectionStrings configuration element. This enables you to manage connection strings independently of your reports, including encrypting them using Protected Configuration . The following example shows how to connect to the Adventure Works DW 2008R2 sample database using a connection string which stored in the connectionStrings configuration element named MyAdventureWorksDW:

CopyXML
<configuration>
    <connectionStrings>
        <add name="MyAdventureWorksDW"
             connectionString="Data Source=localhost;Initial Catalog=Adventure Works DW 2008R2"
             providerName="Microsoft.AnalysisServices.AdomdClient" />
    </connectionStrings>
</configuration>

When the connection string is stored in the configuration file you need to specify the name of the configuration element as a value for the ConnectionString property of the CubeDataSource component:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] } on rows " +
                               "from [Adventure Works]";
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] } on rows " & _
                               "from [Adventure Works]"


Selecting data from an OLAP cube with the CubeDataSource component

[image]

Telerik Reporting Q2 2012
Selecting data from an OLAP cube with the CubeDataSource component
Send Feedback

You can specify an MDX query for the CubeDataSource component to execute by setting its SelectCommand property.

The following example demonstrates an MDX query that retrieves a result set consisting of product sales grouped by category and subcategory:

CopySQL
select non empty { [Measures].[Sales Amount] } on columns,
       non empty { [Product].[Category].[Category] *
                   [Product].[Subcategory].[Subcategory] } on rows
from [Adventure Works]

The next code sample illustrates how to set the ConnectionString and SelectCommand properties of a CubeDataSource component to retrieve the data from the above MDX query:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] * " +
                               "                   [Product].[Subcategory].[Subcategory] } on rows " +
                               "from [Adventure Works]";
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] * " & _
                               "                   [Product].[Subcategory].[Subcategory] } on rows " & _
                               "from [Adventure Works]"

The CubeDataSource component does not impose any restrictions over the format of the MDX query. However, to ensure that the retrieved data is in a proper format for visualization you should follow the next rule: specify the measures you want to aggregate in the column axis and the dimensions to group by in the row axis of the query; also avoid using more than two axes in a single query.

If you need to visualize the data grouped by rows and columns you can use the Crosstab report item. Specify all the measures you want aggregated inside the Crosstab body in the column axis and all the grouping dimensions in the row axis of your MDX query. You can distribute the groups by rows and columns in the Crosstab later, when configuring the Crosstab layout from Crosstab Wizard or in Report Designer.

The default fields returned by an MDX query often are too long and might need to be escaped when used in expressions. To overcome this it is advised to assign shorter and more descriptive aliases for them. Use the Mappings collection of the CubeDataSource component to specify mappings between the fields of the data source and their corresponding aliases for use in expressions as illustrated in the following code sample:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] * " +
                               "                   [Product].[Subcategory].[Subcategory] } on rows " +
                               "from [Adventure Works]";
cubeDataSource.Mappings.Add("[Measures].[Sales Amount]", "Sales");
cubeDataSource.Mappings.Add("[Product].[Category].[Category].[MEMBER_CAPTION]", "Category");
cubeDataSource.Mappings.Add("[Product].[Subcategory].[Subcategory].[MEMBER_CAPTION]", "Subcategory");
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] * " & _
                               "                   [Product].[Subcategory].[Subcategory] } on rows " & _
                               "from [Adventure Works]"
cubeDataSource.Mappings.Add("[Measures].[Sales Amount]", "Sales")
cubeDataSource.Mappings.Add("[Product].[Category].[Category].[MEMBER_CAPTION]", "Category")
cubeDataSource.Mappings.Add("[Product].[Subcategory].[Subcategory].[MEMBER_CAPTION]", "Subcategory")


Specifying query parameters with the CubeDataSource component

[image]

Telerik Reporting Q2 2012
Specifying query parameters with the CubeDataSource component
Send Feedback

The CubeDataSource component supports parameterized MDX queries by associating the parameters you add to the Parameters collection with placeholders in the query. Parameter values can be evaluated with any expression which conforms to the common expression syntax supported by the reporting engine. This grants you a great deal of flexibility on how you can supply your MDX queries with parameters. For example, you can bind an MDX query parameter directly to a report parameter.

When creating a parameterized query, you identify the parameter name by prefixing the name with the "@" character. For example, "@Year" would be a valid parameter name. MDX supports only parameters for literal or scalar values. To create a parameter that references a member, set, or tuple, you would have to use a function such as StrToMember or StrToSet. To illustrate this, let us define a simple MDX query that selects product sales grouped by category and subcategory, and define a slicing axis by year, where the chosen year is specified as a parameter. Since the "@Year" parameter is passed as a string literal value, we need to use the StrToMember function to convert that value to a valid member of the cube as shown below:

CopySQL
select non empty { [Measures].[Sales Amount] } on columns,
       non empty { [Product].[Category].[Category] *
                   [Product].[Subcategory].[Subcategory] } on rows
from [Adventure Works]
where StrToMember(@Year)

The following code sample illustrates how to pass a value to the "@Year" parameter of the query using the Parameters collection of the CubeDataSource component:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] * " +
                               "                   [Product].[Subcategory].[Subcategory] } on rows " +
                               "from [Adventure Works] " +
                               "where StrToMember(@Year)";
cubeDataSource.Parameters.Add("Year", "[CY 2001]");
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] * " & _
                               "                   [Product].[Subcategory].[Subcategory] } on rows " & _
                               "from [Adventure Works] " & _
                               "where StrToMember(@Year)"
cubeDataSource.Parameters.Add("Year", "[CY 2001]")

When you need to pass multiple values as a single parameter to the query, use the StrToSet function instead. For example, to pass several years for the slicing axis at once, we can modify the previous query as shown below:

CopySQL
select non empty { [Measures].[Sales Amount] } on columns,
       non empty { [Product].[Category].[Category] *
                   [Product].[Subcategory].[Subcategory] } on rows
from [Adventure Works]
where StrToSet(@Year)

Now it is possible to assign an array of years to the data source parameter:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] * " +
                               "                   [Product].[Subcategory].[Subcategory] } on rows " +
                               "from [Adventure Works] " +
                               "where StrToSet(@Year)";
cubeDataSource.Parameters.Add("Year", new string[] { "[CY 2001]", "[CY 2002]" });
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] * " & _
                               "                   [Product].[Subcategory].[Subcategory] } on rows " & _
                               "from [Adventure Works] " & _
                               "where StrToSet(@Year)"
cubeDataSource.Parameters.Add("Year", New String() {"[CY 2001]", "[CY 2002]"})

Instead of specifying the parameter values directly, you can use expressions to evaluate them at runtime. For instance, you can bind the CubeDataSourceParameter from the previous example to a ReportParameter with an expression, so that the default parameter user interface of Report Viewer can be used for choosing the slicing year:

CopyC#
Telerik.Reporting.CubeDataSource cubeDataSource = new Telerik.Reporting.CubeDataSource();

cubeDataSource.ConnectionString = "MyAdventureWorksDW";
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " +
                               "       non empty { [Product].[Category].[Category] * " +
                               "                   [Product].[Subcategory].[Subcategory] } on rows " +
                               "from [Adventure Works] " +
                               "where StrToMember(@Year)";
cubeDataSource.Parameters.Add("Year", "=Parameters.Year.Value");

Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.DataSource = cubeDataSource;
report.ReportParameters.Add("Year", ReportParameterType.String, "[CY 2001]");
CopyVB.NET
Dim cubeDataSource As Telerik.Reporting.CubeDataSource = New Telerik.Reporting.CubeDataSource()

cubeDataSource.ConnectionString = "MyAdventureWorksDW"
cubeDataSource.SelectCommand = "select non empty { [Measures].[Sales Amount] } on columns, " & _
                               "       non empty { [Product].[Category].[Category] * " & _
                               "                   [Product].[Subcategory].[Subcategory] } on rows " & _
                               "from [Adventure Works] " & _
                               "where StrToMember(@Year)"
cubeDataSource.Parameters.Add("Year", "=Parameters.Year.Value")

Dim report As Telerik.Reporting.Report = New Telerik.Reporting.Report()

report.DataSource = cubeDataSource
report.ReportParameters.Add("Year", ReportParameterType.String, "[CY 2001]")


Working With Data at Design Time

[image]

Telerik Reporting Q2 2012
Working With Data at Design Time
See Also Send Feedback

The Report Designer would show data source related information (incl. data source schema) when a valid data source is available at design time. As the Report Designer works inside Visual Studio, a valid data source means:

  • A data source object that is instantiated and initialized in the InitializeComponent() method of the designed object class - this is the only part of the class that Visual Studio designer respects.
  • The data source object should be operational at design time. This means that Visual Studio (through the Report Designer) should be able to use this object and instantiate it correctly. Be aware that these objects become part of the Visual Studio application (devenv.exe) and not your application.

With the above in mind, there are two cases:

Data source available at design time

The Data Source Components designed and developed specifically for Telerik Reports, overcome most of the design time issues while providing the freedom to connect Data Items to a wide variety of data sources incl. databases, OR/mappers, Analysis Services' Cubes, etc. without requiring code. Data source components can only read the data and cannot modify it. Every data source component is an instance of the DataSource class. Having valid data source attached to Data Source Components at design time allows you to take advantage of all design time goodness and work with the Data Explorer. For more information please see Data Source Components and DataSource Wizard.

Data source available only at runtime

This approach is useful when you cannot get the report's data source at design time or want to avoid loading real data into Visual Studio at design time. In this case you would have to mock your data just to enable the Report Designer to show any data schema. This will enable you to adjust the layout of the report and bind report items to the available data fields, while the real data will be loaded only at runtime either in NeedDataSource event or in the actual application.

See Also

Other Resources

DataSource Wizard
SqlDataSource Wizard
ObjectDataSource Wizard
OpenAccessDataSource Wizard
EntityDataSource Wizard
CubeDataSource Wizard


Calculated Fields

[image]

Telerik Reporting Q2 2012
Calculated Fields
Send Feedback

Calculated fields can be used to create new values that do not exist in the data source. For example, a calculated field can represent a new value, a constant, an expression value, user defined function or even a report parameter, or an existing field that is converted to a different datatype.

You specify a calculated field manually by creating an expression. The Edit Calculated Fields dialog is available in the property grid of our DataSource components:

  • SqlDataSource
  • ObjectDataSource
  • EntityDataSource
  • OpenAccessDataSource
by clicking on the ellipsis of the CalculatedFields property.

The dialog accepts Name, DataType and Expression.

Note

Names must be unique in the datasource and the expression for a calculated field cannot contain aggregates.

Examples:

For example, you can combine text found in two fields. You can create a calculated field that combines the text found in the columns First Name and Last Name, as in the following example (see image above):

Family Name | First Name | Full Name (Calculated Field)
Harrington | Mark | Mark Harrington
Pak | Jae | Jae Pak
Reinhart | Marie | Marie Reinhart

You can combine the text in the first two columns by entering the following formula for the calculated column:

=Fields.CustFirstName + " " + Fields.CustLastName

You can also create Calculated fields that work with calendar dates. In the following example, the calculated field automatically fills in the date when a business process will be completed. The expression assumes that the process takes seven days to complete.

Date Submitted | Work Complete (Calculated Field)
12/05 | 12/12
12/06 | 12/13
12/07 | 12/14
The expression for this calculated field is: =Fields.SubmittedDate.AddDays(CDbl(7))


Using Parameters with Data Source objects

[image]

Telerik Reporting Q2 2012
Using Parameters with Data Source objects
See Also Send Feedback

Data source objects can accept input parameters so that you can pass values to them at runtime. You can use parameters to supply search criteria for data retrieval and to supply values for sorting and filtering. Using parameters enables you to filter data and create hierarchical reports with little or no custom code.

See Also

Other Resources

SqlDataSource
ObjectDataSource
EntityDataSource
OpenAccessDataSource


How to: Create Project Data Source

[image]

Telerik Reporting Q2 2012
How to: Create Project Data Source
Send Feedback

In order to reuse a Data Source component across multiple reports follow the steps to create a Project Data Source component:

  1. From the Project menu select Add -> New Item

  2. In the Add New Item dialog box, choose a Component Class and click Add.

    The new file is added to the project and automatically opened in Visual Studio.

  3. Change the base class from Component to the appropriate Telerik Reporting Data Source component (Telerik.Reporting.SqlDataSource, Telerik.Reporting.ObjectDataSource, Telerik.Reporting.EntityDataSource, Telerik.Reporting.OpenAccessDataSource) as shown in the following code snippet:

    CopyC#
    public partial class Component1 : Telerik.Reporting.SqlDataSource
    CopyVB.NET
    Partial Class Component1
   Inherits Telerik.Reporting.SqlDataSource

  4. Save and rebuild the project.

  5. Right click the component class -> View Designer

  6. Click Configure data source

  7. Follow the wizard

  8. Save and rebuild

  9. The Project Data Source is now listed under the Project Data Sources node.


Data Items

[image]

Telerik Reporting Q2 2012
Data Items
Send Feedback

The data items display and manipulate data in Telerik Reports. With a data item, you can group, sort, filter, and aggregate data from a single data source. Telerik Reporting provides several types of data items: Report, Table, Crosstab, List, and Chart. The Table, Crosstab and List data items are templates based on the Table data item, and they can be combined in unique ways to customize the data presentation. Charts provide a graphical view of data and aggregates. The type of data item you choose depends on your data: the amount of data, the range in data values, and what you want to convey in your report.

To make the best choice of data item to use for displaying report data, it helps to understand the characteristics of your data and the purpose of the report. The following list describes the features of each data region:

  • Report. The Report item consists of multiple horizontal sections (bands), one for each part of the report. For example, data and text in the report header section renders at the beginning of the report, data and text in the page header section renders at the beginning of each page, and data and text in the page footer sections renders at the end of each page. In the middle of the report are the report groups and the detail section. The report groups are always nested and display data for each value in the group, which is determined at runtime. The detail section displays at run-time one row for each detail item in the report data source.
  • Table. The Table item has a fixed number of columns and displays detail or grouped data by rows. The Table expands down the page as needed. You can display all the detail data, row by row, or group the data by creating row groups. Row groups can be nested or adjacent. Each row group displays a dynamic row down the page for each value in the group, which is determined at run-time. You can also add static rows for labels or totals. You can add totals to the table or to a specific group.
  • Crosstab. The Crosstab item is derived from the Table item and displays data grouped by rows and columns. A Crosstab has at least one row group and one column group. The Crosstab expands across the page for column groups and down the page for row groups. The Crosstab cells display summary and aggregate values scoped to the intersections of the row and column groups. You can create additional nested groups and adjacent groups. The number of rows and columns in a Crosstab depend on the values for each group, determined at run-time. You can also add static rows for labels or totals. You can add totals to the table or to a specific group.
  • List. The List item is derived from the Table item and contains one row that repeats for each value in the data source and displays data in a free-form format. For example, you might use a list to design a form or display both a table and a chart. Arrange text boxes anywhere in the list to create your layout.
  • Chart. The Chart item displays data graphically and helps visualizing data summary and aggregation.

In This Section

Binding a Data item to Data

Filtering Data

Ordering Data

Grouping Data

Report Parameters

Using the NeedDataSource event to connect data


Binding a Data item to Data

[image]

Telerik Reporting Q2 2012
Binding a Data item to Data
Send Feedback

You can work with a data item by binding it to a data source component such as an ObjectDataSource or a SqlDataSource. The data source component connects to a data source such as a database or middle-tier object to retrieve the data. The data-bound item can then use this data. To perform the binding, you set the data item's DataSource property to point to a data source component. When a data-bound item is bound to a data source component, little or no additional code is required for data operations, because the data-bound item can automatically take advantage of the data services provided by the data source component.

Note

For backwards compatibility reasons Telerik Reporting supports binding directly to IEnumberable/IListSource objects (incl. arrays, collections, DataSet, DataTable, DataView, and DbDataAdapter). Instead consider using the ObjectDataSource that can handle these types of data sources.


Filtering Data

[image]

Telerik Reporting Q2 2012
Filtering Data
Send Feedback

In Telerik Reporting, you can filter report data before or after it is retrieved for a report.

To filter data before it is retrieved, change the query for each data source. When you filter data in the query, you filter data at the data source, which reduces the amount data that needs to be retrieved and processed in a report.

To filter data after it is retrieved, create filter expressions in the report. You can set filter expressions for a data item, or a group, including detail groups.

Filters can contain report parameters in filter expressions, providing a way to filter data for specific values or for specific users, for example, filtering on a value that identifies the user viewing the report. Filters are defined using the the Edit Filter Dialog.

Filtering conditions are defined by adding Filter objects to the Filters collection of the data items or groups. Each Filter object is made up of an expression, an operator and a value:

  • Expression – can be either a single data field or a combination of multiple expressions. See Expressions.
  • Operator
    Operator | Description
    > Expression is greater than Value
    < Expression is less than Value
    >= Expression is greater than or equal to Value
    <= Expression is less than or equal to Value
    = Expression is equal to Value
    <> Expression is not equal to Value
    Like | Expression is like Value. Use the "%" wildcard to represent any number of other characters. Example: Fields.ProductName Like "%Bike%" will allow all records where the "ProductName" field contains "Bike".
    Not Like | Expression is Not like Value. Use the "%" wildcard to represent any number of other characters. Example: Fields.ProductName NotLike "%Bike%" will allow all records where the "ProductName" field does not contain "Bike".
    Top N

    Return the top N number of records.

    If Expression is blank the filter returns the exact number of records specified by Value. For example "Top N 5" returns exactly five records.

    If Expression contains a field or expression the filter returns the top number for that expression. This filter may return more than the exact count specified in Value. For example "ProductCategory Top N 2" might return twenty records containing ProductCategory "Accesories" and "Apparel".

    Bottom N

    Return the bottom N number of records.

    If Expression is blank the filter returns the exact number of records specified by Value. For example "Bottom N 5" returns exactly five records.

    If Expression contains a field or expression the filter returns the bottom records for that expression. This filter may return more than the exact count specified in Value. For example "CountryRegion Bottom N 2" might return twenty records containing "Zambia" and "Zimbabwe".

    Top %

    Returns the top N percentage of records.

    If Expression is blank the filter returns the percentage of total records specified in Value. If the report has an initial 1000 records and the filter is "Top % 5", 50 records are returned.

    If Expression contains a field or expression the filter returns the bottom percentage records that satisfy the expression. For example if the top two percent country codes in a StateProvince table are "AS", "AU" and "CA" might return twenty records containing only those country codes.

    Bottom %

    Returns the bottom N percentage of records.

    If Expression is blank the filter returns the percentage of total records specified in Value. If the report has an initial 1000 records and the filter is "Bottom % 5", 50 records are returned.

    If Expression contains a field or expression the filter returns the bottom percentage records that satisfy the expression. For example if the bottom two percent country codes in a StateProvince table are "VI", "US" and "PW" might return twenty records containing only those country codes.

  • Value – a literal value, an expression or an empty (<blank>) value, which will be compared to the Expression when evaluated at runtime.

Data items and groups may have one or more Filters defined, that at runtime are combined and applied together to the data.

Depending on where the Filter is applied - to a data item or group – it can produce different result:

  • A filter defined on the data item level limits the data from the data source and all subsequent operations will be performed of this subset of data. These filters operate over the entire set of data and should not use the aggregate functions for the Expression and Value members. Data item filters work similar to the WHERE clause in a SQL statement;
  • A filter defined on a report/table group limits the group members to a certain values. These filters operate over the group members after the groups are calculated and can contain aggregate functions. Group filters are similar to the HAVING clause in a SQL statement.

In This Section

How-To: Add filtering to Report

How-To: Add filtering to Table item and Crosstab item

How-To: Add filtering to Chart item


How-To: Add filtering to Report

[image]

Telerik Reporting Q2 2012
How-To: Add filtering to Report
See Also Send Feedback

This topic illustrates how to add filters to the Report using the Report Designer or Report API.

Adding filters to Report using Report Designer

To add filters to the Report use the following steps:

  1. Open a report in Design view.
  2. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window.
  3. Click Filters ellipsis in the property grid. This displays the current list of filters. By default, the list is empty.
  4. Click New. A new blank filter equation appears.
  5. In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
  6. In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
  7. In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  8. Click OK.

Adding filters to Report programatically

CopyC#
Telerik.Reporting.Filter filter1 = new Telerik.Reporting.Filter();
filter1.Expression = "=Fields.ProductID";
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan;
filter1.Value = "=10";

report1.Filters.Add(filter1);
CopyVB.NET
Dim filter1 As New Telerik.Reporting.Filter()
filter1.Expression = "=Fields.ProductID"
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan
filter1.Value = "=10"

report1.Filters.Add(filter1)

See Also

Reference

Report
Filter
FilterCollection

Other Resources

Using Expressions


How-To: Add filtering to Table item and Crosstab item

[image]

Telerik Reporting Q2 2012
How-To: Add filtering to Table item and Crosstab item
See Also Send Feedback

This topic illustrates how to add filters to a Table or Crosstab item using the Report Designer or Report API.

Adding filters to Table or Crosstab item using Report Designer

  1. Open a report in Design view.
  2. Left-click a Table or a Crosstab item on the design surface to select it.
  3. Click Filters ellipsis in the property grid. This displays the current list of filters. By default, the list is empty.
  4. Click New. A new blank filter equation appears.
  5. In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
  6. In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
  7. In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  8. Click OK.

Adding filters to Table or Crosstab item programatically

CopyC#
Telerik.Reporting.Filter filter1 = new Telerik.Reporting.Filter();
filter1.Expression = "=Fields.ProductID";
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan;
filter1.Value = "=10";

table1.Filters.Add(filter1);
CopyVB.NET
Dim filter1 As New Telerik.Reporting.Filter()
filter1.Expression = "=Fields.ProductID"
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan
filter1.Value = "=10"

table1.Filters.Add(filter1)

See Also

Reference

Table
Filter
FilterCollection

Other Resources

Using Expressions


How-To: Add filtering to Chart item

[image]

Telerik Reporting Q2 2012
How-To: Add filtering to Chart item
See Also Send Feedback

This topic illustrates how to add filters to a Chart item using the Report Designer or Report API.

Adding filters to Chart using Report Designer

  1. Open a report in Design view.
  2. Left-click a Chart item to select it.
  3. Click Filters ellipsis in the property grid. This displays the current list of filters. By default, the list is empty.
  4. Click New. A new blank filter equation appears.
  5. In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
  6. In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
  7. In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  8. Click OK.

Adding filters to Chart programatically

CopyC#
Telerik.Reporting.Filter filter1 = new Telerik.Reporting.Filter();
filter1.Expression = "=Fields.ProductID";
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan;
filter1.Value = "=10";

chart1.Filters.Add(filter1);
CopyVB.NET
Dim filter1 As New Telerik.Reporting.Filter()
filter1.Expression = "=Fields.ProductID"
filter1.Operator = Telerik.Reporting.FilterOperator.GreaterThan
filter1.Value = "=10"

chart1.Filters.Add(filter1)

See Also

Reference

Chart
Filter
FilterCollection

Other Resources

Using Expressions


Ordering Data

[image]

Telerik Reporting Q2 2012
Ordering Data
Send Feedback

In Telerik Reporting data items can order the data that are bound to by taking advantage of the sorting capabilities of the Telerik Reporting engine.

Sorting can be performed at the data item and group level through the Sorting collections. Sorting for groups controls the order of grouping data, not the detail data. Group level sorting occurs before the sorting for the report as a whole.

You specify the sorting criteria by adding Telerik.Reporting.Data..::.Sorting objects to the data items’ or groups’ Sorting collections. Each sorting is made up of an Expression and a Direction:

  • Expression can be a single data field or a combination of multiple expressions. See Expressions.
  • Direction can be either "Asc" (ascending) or "Desc" (descending).

Data items and groups may contain one or more Sortings that are combined at runtime and applied together to the data.

Sorting criteria is defined through the Edit Sorting Dialog.

Depending on where the Sorting is applied – to a data item or a group – it may produce different results:

  • A sorting applied to a data item sets the order of the detail data thus resulting on the order of appearance of the detail rows (including the DetailSection and detail groups). As the First and Last aggregate functions depend on the order of the data they operate with, they may return different values depending on the data items’ sorting.
  • A sorting applied to a group sets the order of the members of this group thus resulting on the order of appearance of the rows/columns depending on if this is a row or column group.

In This Section

How-To: Add sorting to Report

How-To: Add sorting to Table item and Crosstab item

How-To: Add sorting to Chart item


How-To: Add sorting to Report

[image]

Telerik Reporting Q2 2012
How-To: Add sorting to Report
See Also Send Feedback

In the Report item the sorting is performed at data item level and sets the order of appearance of the detail sections.

To define a sorting for the Report item use the following steps:

Adding sorting to Report using Report Designer

  1. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window.
  2. Click the Sorting ellipsis.

  3. For each sort expression, follow these steps:

    1. Click New.
    2. Type or select an expression by which to sort the data.
    3. From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.

  4. Click OK.

Adding sorting to Report programatically

CopyC#
Telerik.Reporting.Sorting sorting1 = new Telerik.Reporting.Sorting();
sorting1.Expression = "=Fields.ProductID";
sorting1.Direction = Telerik.Reporting.SortDirection.Asc;

report1.Sortings.Add(sorting1);

CopyVB.NET
Dim sorting1 As New Telerik.Reporting.Sorting()
sorting1.Expression = "=Fields.ProductID"
sorting1.Direction = Telerik.Reporting.SortDirection.Asc

report1.Sortings.Add(sorting1)

See Also

Reference

Report
Sorting
SortingCollection

Other Resources

How-To: Add groups to Report


How-To: Add sorting to Table item and Crosstab item

[image]

Telerik Reporting Q2 2012
How-To: Add sorting to Table item and Crosstab item
See Also Send Feedback

In the Table or Crosstab items the sorting is performed at data item level and sets the order of appearance of the detail groups.

To define a sorting for the Table or Crosstab items use the following steps:

Adding sorting to Table/Crosstab data item using Report Designer

  1. In the Report Designer, right click on a Table/Crosstab and then select Properties.
  2. Click the Sorting ellipsis.

  3. For each sort expression, follow these steps:

    1. Click New.
    2. Type or select an expression by which to sort the data.
    3. From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.

  4. Click OK.

Adding sorting to Table/Crosstab data item programatically

CopyC#
Telerik.Reporting.Sorting sorting1 = new Telerik.Reporting.Sorting();
sorting1.Expression = "=Fields.ProductID";
sorting1.Direction = Telerik.Reporting.SortDirection.Asc;

table1.Sortings.Add(sorting1);
CopyVB.NET
Dim sorting1 As New Telerik.Reporting.Sorting()
sorting1.Expression = "=Fields.ProductID"
sorting1.Direction = Telerik.Reporting.SortDirection.Asc

table1.Sortings.Add(sorting1)

See Also

Reference

Table
Sorting
SortingCollection

Other Resources

How-To: Add groups to Table item and Crosstab item


How-To: Add sorting to Chart item

[image]

Telerik Reporting Q2 2012
How-To: Add sorting to Chart item
See Also Send Feedback

In the Chart item the sorting is performed at data item level and sets the order of appearance of the detail rows.

Adding sorting to Table/Crosstab data item using Report Designer

  1. In the Report Designer, select the Chart item and open its Properties grid.
  2. Click the Sorting ellipsis.

  3. For each sort expression, follow these steps:

    1. Click New.
    2. Type or select an expression by which to sort the data.
    3. From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.

  4. Click OK.

Adding sorting to Chart data item programatically

CopyC#
Telerik.Reporting.Sorting sorting1 = new Telerik.Reporting.Sorting();
sorting1.Expression = "=Fields.ProductID";
sorting1.Direction = Telerik.Reporting.SortDirection.Asc;

chart1.Sortings.Add(sorting1);
CopyVB.NET
Dim sorting1 As New Telerik.Reporting.Sorting()
sorting1.Expression = "=Fields.ProductID"
sorting1.Direction = Telerik.Reporting.SortDirection.Asc

chart1.Sortings.Add(sorting1)

See Also

Reference

Chart
Sorting
SortingCollection


Grouping Data

[image]

Telerik Reporting Q2 2012
Grouping Data
See Also Send Feedback

In Telerik Reporting, data items can aggregate and summarize data, display it in visual hierarchies or create different views, thus helping the user/ decision maker understand and analyze data in a more efficient manner.

In Telerik Reporting, groups are named sets of data that are bound to a data item. You specify groups by defining their names and grouping criteria (expression).

To create a grouping expression you add Grouping objects to the Grouping collection. The set of group expressions can be a single data field reference or a combination of multiple expressions. At runtime, group expressions are combined and applied together to the data.

Depending on the grouping expressions, groups may be static, dynamic or detail:

  • Static groups are defined by empty (no) expression or expression that evaluates to the same value, disregarding the data (ex.: =1 + 2). Static groups always produce a single member that contains all the data.

  • Dynamic groups are defined by expressions that produce different results according to the current data (ex.: =Fields.County). This way the items of the data source are partitioned into groups according to the values of the grouping expressions.

  • Details groups are defined by a single Grouping object that has no expression (empty Grouping) and produce one member for each item of the data source. Detail groups can be applied to Table, Crosstab or List items; for backwards compatibility reasons, the Report item treats the detail groups as static groups.

Groups support filtering and sorting that allows you to limit and order the members of the group according to your needs. For more information see Filtering Data and Ordering Data.

Groups are internally organized as members of one or more hierarchies for each data item. A group hierarchy has parent/child groups that are nested and can have adjacent groups. As groups have names, the group hierarchy defines the named scope hierarchy for the report items and expressions.

Data items support groups in different manner according to their structure and application. The following list summarizes how the data items work with groups:

  • Report – Report groups are defined by adding Group objects to the report’s Groups collection. Report groups are always nested according to the order in the Groups collection. To display group data one should use the GroupHeaderSection and GroupFooterSection that appear once for each group member, respectively at start and end. The DetailSection displays detail data in a report and always appears inside the innermost group (if any).

  • Table item – If you think of the parent/ child groups as a tree structure, each group hierarchy is a forest of tree structures. The Table data item includes row and column group hierarchies. Data associated with row group members expand horizontally across the page and data associated with column group members expand vertically down the page. The Group Explorer tool window displays row group and column group members for the currently selected Table data item on the design surface. To create a group one should create a TableGroup object and add it to the corresponding group hierarchy. According to their different specialization the three derivatives of the Table item works with groups in different manner:

    • Table – define nested row groups and adjacent row groups. By default, a table includes a details group.

    • Crosstab – define nested row and column groups, and adjacent row and column groups.

    • List – by default, supports the details group. Typical use is to support one level of grouping.

  • Chart – use the DataGroupColumn to define the name of the field to group the data by. At runtime the Chart item will create new series for each member of the group. Currently this property does not support expressions.

In This Section

How-To: Add groups to Report

How-To: Add groups to Table item and Crosstab item

See Also

Other Resources

Filtering Data
Ordering Data


How-To: Add filtering to Group

[image]

Telerik Reporting Q2 2012
How-To: Add filtering to Group
Send Feedback

A filter defined on a report/table group limits the group members to a certain values. These filters operate over the group members after the groups are calculated. Group filters are similar to the HAVING clause in a SQL statement.

We will use the filter to hide/show the dynamic groups members. Additionally we add the possibility for dynamic filtering by using report parameters. The example shown is based on the ProductSales demo report

Using dynamic filter to show/hide crosstab group members

  1. Open the report in the designer and show the Group explorer

  2. Define new Report Parameter DetailsForYear as shown on picture. Use the same DataSource as for the report. The parameter should be MultiValue parameter.

    Define Report Parameter

  3. Select the Crosstab (or any cell in it) and invoke the Edit Filters dialog for the Qtr Column group. Enter the filter expression as shown on next picture

  4. Preview the report - see the Preview.png. Now it is possible to select for which year to show Quarter columns and hide for the rest.


How-To: Add groups to Report

[image]

Telerik Reporting Q2 2012
How-To: Add groups to Report
See Also Send Feedback

Report groups are defined by adding Group objects to the report’s Groups collection. Report groups are always nested according to the order in the Groups collection. To display group data one should use the GroupHeaderSection and GroupFooterSection that appear once for each group member, respectively at start and end. The DetailSection displays detail data in a report and always appears inside the innermost group (if any). To add a group, follow these steps:

Adding a group to a Report using Report Designer

  1. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window.
  2. Click the Groups ellipsis.
  3. Follow these steps for each group:
    1. Click Add button - a new unbound group will be added to the Groups collection.
    2. Click the Grouping property ellipsis.
    3. From the Edit Grouping dialog, type or select an expression by which to group the data.
    4. To apply sorting to the group, follow these steps:
      • Click the Sorting ellipsis.
      • Click New
      • Type or select an expression by which to sort the data.
      • From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.
    5. To apply filtering to the group, follow these steps:
      • Click the Filters ellipsis
      • Click New.
      • In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
      • In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
      • In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
    6. In Name, type the name of the group.
    7. Click GroupKeepTogether to specify the keep together options.
    8. Click BookMarkID to set a BookMark for this group.
  4. Click Ok twice to close the Edit Grouping and Group Collection dialogs.
Note

You can add a group to the Report item by using the grouping pane in the Group Explorer as well. To do so right click on the detail and select Add Parent Group. If there are existing groups, you can create Parent or Child groups by right clicking on any of the existing groups.

Edit a group in a Report using Report Designer

  1. In the Report Designer, click the Report selector button located in the upper left hand of the Report Designer to make the report active in the Properties window. The Grouping pane in the Group Explorer displays the available groups (if any).
  2. Right-click the group, and then click Group Properties.
  3. In Name, type the name of the group.
  4. In Grouping property, type or select a simple expression, or click the <Expression> option to create a new group expression.
  5. Click New to create additional expressions. All expressions you specify are combined using a logical AND to specify data for this group.
  6. To allow sorting for the group, follow these steps:
    • Click the Sorting ellipsis.
    • Click New.
    • Type or select an expression by which to sort the data.
    • From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.
  7. To allow filtering for the group, follow these steps:
    • Click the Filters ellipsis
    • Click New.
    • In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
    • In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
    • In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  8. Click GroupKeepTogether to specify the keep together options.
  9. Click BookMarkID to set a BookMark for this group.

Delete a group from a Report using Report Designer

  1. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window. The grouping pane in the Group Explorer displays the available groups (if any).
  2. Right click on the group and select Delete Group.
  3. When prompted to delete it, Select Yes.

Adding a group to a Report programatically

CopyC#
Telerik.Reporting.Group group1 = new Telerik.Reporting.Group();
group1.Name = "group1";
group1.Groupings.Add(new Telerik.Reporting.Grouping("=Fields.ProductID"));
Telerik.Reporting.GroupFooterSection groupFooterSection1 = new Telerik.Reporting.GroupFooterSection();
Telerik.Reporting.GroupHeaderSection groupHeaderSection1 =  new Telerik.Reporting.GroupHeaderSection();
group1.GroupFooter = groupFooterSection1;
group1.GroupHeader = groupHeaderSection1;
//if you need to filter the data, apply filtering
group1.Filters.Add(new Telerik.Reporting.Filter("=Fields.ProductID", Telerik.Reporting.FilterOperator.Equal, "=10"));
//if you need to sort the data, apply sorting
group1.Sortings.Add(new Telerik.Reporting.Sorting("=Fields.ProductID", Telerik.Reporting.SortDirection.Asc));

report1.Groups.Add(group1);
CopyVB.NET
Dim group1 As New Telerik.Reporting.Group()
group1.Name = "group1"
group1.Groupings.Add(New Telerik.Reporting.Grouping("=Fields.ProductID"))
Dim groupFooterSection1 As New Telerik.Reporting.GroupFooterSection()
Dim groupHeaderSection1 As New Telerik.Reporting.GroupHeaderSection()
group1.GroupFooter = groupFooterSection1
group1.GroupHeader = groupHeaderSection1
'if you need to filter the data, apply filtering
group1.Filters.Add(New Telerik.Reporting.Filter("=Fields.ProductID", Telerik.Reporting.FilterOperator.Equal, "=10"))
'if you need to sort the data, apply sorting
group1.Sortings.Add(New Telerik.Reporting.Sorting("=Fields.ProductID", Telerik.Reporting.SortDirection.Asc))

report1.Groups.Add(group1)

See Also

Reference

Report
Groups


How-To: Add groups to Table item and Crosstab item

[image]

Telerik Reporting Q2 2012
How-To: Add groups to Table item and Crosstab item
See Also Send Feedback

Add groups to a data item when you want to display your data in a visual hierarchy, align multiple data items to show different views of the same data, or to calculate totals.

You can create both nested groups and adjacent groups. Within a data item, you can create multiple row groups and column groups.

Typically, you define groups automatically as you work with data regions. However, you can add your own groups. The process of adding groups varies based on the type of data region. In a Table, Crosstab or List items, drag data source fields to the Row/Column Fields area. Right-click an existing group to add parent, child or adjacent groups. By definition, the details group is the innermost group and can only be added as a child group. Right-click an existing group to delete it. Rows and columns on which to display group values are automatically added for you. For more information, see Working with Table article.

Add a parent or child row/column group to a Table data item using Report Designer

  1. Drag a data source field from the Data Explorer to the Row/Column Fields area of the Table or CrossTab items.
  2. Drop the field above or below the group hierarchy using the guide bar to place the group as a parent group or a child group to an existing group.

The group is added with a default name, group expression, and sort expression that is based on the field name.

Add an adjacent row/column group to a Table data item

  1. In the Group Explorer group pane, right-click a group that is a peer to the group that you want to add. Click Add Group, and then click Adjacent Before or Adjacent After to specify where to add the group. The Table Group dialog box opens.

  2. Click New button.

  3. In the group expression, type an expression, select a data source field or create a new expression. The group is added with a default name RowGroup or ColumnGroup respectively.

  4. Click OK.
  5. Right-click the group, and then click Group Properties.
  6. In Name, type the name of the group.
  7. In Grouping property, type or select a simple expression, or click the <Expression> option to create a new group expression.
  8. Click New to create additional expressions. All expressions you specify are combined using a logical AND to specify data for this group.
  9. To apply sorting to the group, follow these steps:
    • Click the Sorting ellipsis
    • Click New.
    • Type or select an expression by which to sort the data.
    • From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.
  10. To apply filtering to the group, follow these steps:
    • Click the Filters ellipsis
    • Click New.
    • In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
    • In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
    • In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  11. Click GroupKeepTogether to specify the keep together options.
  12. Click BookMarkID to set a BookMark for this group.
  13. Click OK.

A new group is added to the grouping pane in the Group Explorer and a row or column on which to display group values is added to the Table data item on the design surface.

Add a details group to a Table data item using Report Designer

  1. In the Group Explorer group pane, right-click a group that is the innermost child group. Click Add Group, and then click Child Group. The Table Group dialog box opens.

  2. Leave the expression blank - a details group has no expression.

  3. Select Show detail data.

  4. Click OK.
  5. Right-click the group, and then click Group Properties.
  6. In Name, type the name of the group.
  7. In Grouping property, type or select a simple expression, or click the <Expression> option to create a new group expression.
  8. Click New to create additional expressions. All expressions you specify are combined using a logical AND to specify data for this group.
  9. To apply sorting to the group, follow these steps:
    • Click the Sorting ellipsis
    • Click New.
    • Type or select an expression by which to sort the data.
    • From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.
  10. To apply filtering to the group, follow these steps:
    • Click the Filters ellipsis
    • Click New.
    • In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
    • In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
    • In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  11. Click GroupKeepTogether to specify the keep together options.
  12. Click BookMarkID to set a BookMark for this group.
  13. Click OK.

A new details group is added as a child group in the Grouping pane in the Group Explorer, and the new group displays the details group icon.

Edit a row or column group in a Table data item using Report Designer

  1. In the Report Designer, select the Table data item. The Grouping pane in the Group Explorer displays the row and column groups.
  2. Right-click the group, and then click Group Properties.
  3. In Name, type the name of the group.
  4. In Grouping property, type or select a simple expression, or click the <Expression> option to create a new group expression.
  5. Click New to create additional expressions. All expressions you specify are combined using a logical AND to specify data for this group.
  6. To apply sorting to the group, follow these steps:
    • Click the Sorting ellipsis
    • Click New.
    • Type or select an expression by which to sort the data.
    • From the Direction column drop-down list, choose the sort direction for each expression. ASC sorts the expression in ascending order. DESC sorts the expression in descending order.
  7. To apply filtering to the group, follow these steps:
    • Click the Filters ellipsis
    • Click New.
    • In Expression, type or select the expression for the field to filter. To open the Edit Expression Dialog, select the <Expression> option.
    • In the Operator box, select the operator that you want the filter to use to compare the values in the Expression box and the Value box.
    • In the Value box, type the expression or value against which you want the filter to evaluate the value in Expression.
  8. Click GroupKeepTogether to specify the keep together options.
  9. Click BookMarkID to set a BookMark for this group.
  10. Click OK.

Delete a group from a Table data item using Report Designer

  1. In the Group Explorer group pane, right-click the group, and then click Delete Group.
  2. In the Delete Group dialog box, select one of the following options:
    • Delete group and related rows and columns Choose this option to delete the group definition and all related rows that display group data. For the details group, if the same row belongs to both detail and group data, only the detail data rows are deleted.
    • Delete group only Choose this option to keep the structure of the Table data item the same and delete only the group definition.
  3. Click OK.

Adding a group to Table data item programatically

CopyC#
Telerik.Reporting.TableGroup group1 = new Telerik.Reporting.TableGroup();
group1.Name = "ProductID1";
group1.Groupings.Add(new Telerik.Reporting.Grouping("=Fields.ProductID"));

// If you need to filter the members of the group, apply filtering
group1.Filters.Add(new Telerik.Reporting.Filter("=Fields.ProductID", Telerik.Reporting.FilterOperator.Equal, "=10"));

// If you need to order the members of the group, apply sorting
group1.Sortings.Add(new Telerik.Reporting.Sorting("=Fields.ProductID", Telerik.Reporting.SortDirection.Asc));

Telerik.Reporting.TextBox textBox1 = new Telerik.Reporting.TextBox();
table1.Items.Add(textBox1);
group1.ReportItem = textBox1;

table1.RowGroups.Add(group1);
CopyVB.NET
Dim group1 As New Telerik.Reporting.TableGroup()
group1.Name = "RowGroup1"
group1.Groupings.Add(New Telerik.Reporting.Grouping("=Fields.ProductID"))

' If you need to filter the members of the group, apply filtering
group1.Filters.Add(New Telerik.Reporting.Filter("=Fields.ProductID", Telerik.Reporting.FilterOperator.Equal, "=10"))

' If you need to order the members of the group, apply sorting
group1.Sortings.Add(New Telerik.Reporting.Sorting("=Fields.ProductID", Telerik.Reporting.SortDirection.Asc))

Dim textBox1 As New Telerik.Reporting.TextBox()
table1.Items.Add(textBox1)
group1.ReportItem = textBox1

table1.RowGroups.Add(group1)

See Also

Reference

Table
ColumnGroups
RowGroups


Using the NeedDataSource event to connect data

[image]

Telerik Reporting Q2 2012
Using the NeedDataSource event to connect data
See Also Send Feedback

In certain scenarios you may find it impossible to connect to your data at design time. Data Items provide suitable event to notify you that they are about to process so you may provide data for them to render, otherwise they will be processed as unbound items.

The NeedDataSource event is raised by the reporting engine to inform you that the data item is about to be processed and still has no data source attached. The sender of the event is always the processing counterpart of the data item and it is the receiver of the data source.

This event is meant to be used only for providing data source to the report. Once the report is bound, the data source is cached and NeedDataSource event is no longer fired, unless it depends on report or data source parameter. Every time the report is previewed, exported or printed through the viewer it is processed and rendered from scratch, and the data caching improves the performance for these operations. Any other code irrelevant to providing data to the report should be moved to ItemDataBinding event which is fired regardless of whether the report is bound or not.

Below is an example that illustrates how to provide data source to the Report item using the Report.NeedDataSource event.

CopyC#
private void Report1_NeedDataSource(object  sender, System.EventArgs e)
{
    string sql =
    @"SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product";
    string connectionString =
    "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";
    SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
    DataSet dataSet = new DataSet();
    adapter.Fill(dataSet);
    (sender as Telerik.Reporting.Processing.Report).DataSource = dataSet;
}
CopyVB.NET
Private Sub Report1_NeedDataSource(ByVal  sender As Object, ByVal e As System.EventArgs)
    Dim sql As String = "SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product"
    Dim connectionString As String = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"
    Dim adapter As New SqlDataAdapter(sql, connectionString)
    Dim dataSet As New DataSet()
    adapter.Fill(dataSet)
    TryCast(sender, Telerik.Reporting.Processing.Report).DataSource = dataSet
End Sub

See Also

Other Resources

Connecting to Data
SqlDataSource Component
ObjectDataSource Component
EntityDataSource Component
OpenAccessDataSource Component
CubeDataSource Component


Expressions

[image]

Telerik Reporting Q2 2012
Expressions
Send Feedback

Expressions are widely used while designing reports, for example to retrieve, calculate, display, group, sort, filter, and parameterize the data in a report. Expressions provide great flexibility to control the content, style, and behavior of your reports. Expressions use the Telerik Reporting's built-in scripting language and are saved in the report definition. When the report runs, the report processor evaluates the expressions and substitutes the expression results for the property values.

To see evaluated expression values in a report, preview the report.

Parameters can be used with expressions to provide additional flexibility for changing the content and appearance of a report.

Expressions begin with an equal (=) and can include a combination of constants, operators, and references to built-in values (fields, parameters, and functions), and to external or custom code.

During the evaluation, all defined operations and functions are executed and all built-in objects are replaced with the real data according to the current scope and a single value is returned. The type of the result depends on the expression and should always conform to the property it is applied to.

For example, if you create an expression for the Style.BackgroundColor property, the value must evaluate to a System.Drawing.Color object.

In This Section

  • Expression Scope
  • Using Expressions
  • Developer's Reference
  • Extending Expressions


Expression scope

[image]

Telerik Reporting Q2 2012
Expression scope
Send Feedback

Expressions are evaluated against the data scopes. Data scopes are determined from the data items and groups in the report definition including: Report with Report groups and the Detail section, Table and Crosstab items with Table group and the Chart item. That said one expression is evaluated against the data set defined by its scope.

Data scopes are defined by the data items and groups. Data items contain all data from their data source and define the outermost scope. For example the report item Report1 defines the scope named Report1 and contains all data filtered and ordered by the Filtering and Sorting criteria defined for the Report (if any). Data items can contain groups that partition the data by its grouping criteria into smaller sets and define the hierarchy of inner scopes. The detail groups or DetailSection define the innermost scope.

The report processor evaluates the expressions in a named scope or the default scope. The default scope depends on the report item property that the report processor is evaluating.

The rule used for resolving the default data scope is the following: Each expression is used in some property of a report item. The processor finds the nearest ancestor item defining a data scope. This scope is used for the expression evaluation.

A named scope can be the name of a data item, or a group. You must specify the current scope or a containing scope; you cannot specify a scope that is lower or at the same level in containment order than the current scope.

By default all non-aggregating functions are usually evaluated in the default scope and operate over a single/detail item of the data source. If the current scope is a data item or a group then functions will be evaluated against the first item in the current set of data.

Aggregate functions always operate over the entire set of data defined by their scope. If the current scope is a detail section or a detail group the calculations are performed over a single item of the data source.

You can set the scope of the expression evaluation by using the built-in Exec function.


Using Expressions

[image]

Telerik Reporting Q2 2012
Using Expressions
Send Feedback

In Telerik Reporting, expressions are used throughout the report definition to specify or calculate values for parameters, filters, report item properties, group and sort definitions, text box properties, bookmarks, document maps, dynamic page header and footer content, images, and dynamic data source definitions. In the next topics provides examples of the many places you can use expressions to vary the content or appearance of a report. This list is not comprehensive.

In This Section

  • Expressions as Values of Item Properties

  • Embedded expressions

  • Bindings

  • Conditional formatting

  • Grouping, Filtering and Sorting

  • Report parameters


Expressions as Values of Item Properties

[image]

Telerik Reporting Q2 2012
Expressions as Values of Item Properties
Send Feedback

By default the report items’ properties are strongly typed. Anyway you can use expressions as value for some of them. To specify that the value of a property is an expression, the value should be a string starting with equal (=) sign. If the equal sign is not present the value will be interpreted as a string literal.

This expression:

='Hi Mr.' + Fields.LastName + ', ' + Fields.FirstName + '!'

when evaluated will result in:

Hi Mr. Smith, John!

On the design surface expressions are usually displayed surrounded by square brackets ([]). For example, the expression =Fields.PersonID when used in TextBox.Value property would appear as [=Fields.PersonID].

The following objects and properties support expressions as property values:

Object | Property
Barcode | Value
CheckBox | Value TrueValue FalseValue IndeterminateValue Text
PictureBox | Value
Report | DocumentName
ReportBook | DocumentName
ReportParameter | Value
TextBox | Value
ReportItemBase (all items) | BookmarkID DocumentMapText
Group | BookmarkID DocumentMapText
TableGroup | BookmarkID DocumentMapText
CalculateField | Expression
Filter | Expression Value
Sorting | Expression
Grouping | Expression
ReportParameter | Value
ReportParameter.AvailableValues | ValueMember, DisplayMember
Parameter | Value


Embedded Expressions

[image]

Telerik Reporting Q2 2012
Embedded Expressions
Send Feedback

Some properties that accept String values allow mixing text with expressions. When evaluated, expressions will be replaced by their result thus forming the runtime value of the property.

Expressions are embedded in a string literal by surrounding them with curly brackets {}:

Hi Mr. {Fields.LastName}, {Fields.FirstName}!

In the example above the expressions Fields.FirstName and Fields.LastName are embedded in a string constant and when evaluated will produce a result like this:

Hi Mr. Smith, John!

If used in a string literal, curly brackets - { } should be escaped with double brackets like this: {{ or }}.

The following properties support embedded expressions:

  • TextBox.Value
  • HtmlTextBox.Value
  • CheckBox.Text
  • ReportParameter.AvailableValues.DisplayMember
  • ReportParameter.AvailableValues.ValueMember


Bindings

[image]

Telerik Reporting Q2 2012
Bindings
See Also Send Feedback

By default only a certain number of report items and properties can handle expression values. The simple binding between the other properties of a report item and an expression is accomplished by adding Binding objects to the Bindings collection.

For example, you can bind the Style.BackgroundColor property of a TextBox item to an expression (=Fields.CarColor) that when evaluated returns an object of type appropriate for the property, System.Drawing.Color in this case. In certain cases using user-defined functions to perform appropriate type conversions should be considered.

When constructing a Binding instance with Binding constructor, you must specify:

  • the name of the property to bind; alternatively a period-delimited navigation path can be used to reference a property down the object hierarchy. For example the following navigation paths define valid properties:

    • "DataSource"
    • "Style.BackgroundColor"
    • "Style.Font.Name"

    Only write-enabled properties can be set through binding expressions, so read-only properties are not suitable for data-binding.

    Note: Not all item properties support expression bindings. Please refer to the API reference to check if a property supports binding.

  • an expression that will return the value for the property when evaluated at runtime.

See Also

Reference

Telerik.Reporting..::.Binding
Telerik.Reporting..::.BindingCollection


Conditional Formatting

[image]

Telerik Reporting Q2 2012
Conditional Formatting
See Also Send Feedback

You can design a report so that different styles are applied to items based on the data in the report. For example, you can display negative numbers in red or change the background colors on a table cell.

To make styles conditional, use an expression instead of a static value for the style properties of the report item. For example, to make a text box render negative values in red for a field called Profit:

Using Conditional Formatting Editor

  1. open the Edit Formatting Rule dialog
  2. enter the conditional expression
    =Fields.Profit
  3. enter the operator
    <
  4. enter the value expression
    =0
  5. in the Edit Style dialog select Red color for the Background

Using Bindings

  1. To use Bindings we need to implement a helper User Function:

    CopyC#
    public static Color ColorFromName(string colorName)
{
    if (!string.IsNullOrEmpty(colorName))
    {
        return Color.FromName(colorName);
    }
    return Color.Transparent;
}
    CopyVB.NET
    Public Shared Function ColorFromName(ByVal colorName As String) As Color
    If Not String.IsNullOrEmpty(colorName) Then
        Return Color.FromName(colorName)
    End If
    Return Color.Transparent
End Function

  2. In the Bindings Editor select the Style.BackGroundColor property

  3. enter the next expression:
    =Iif(Fields.Profit < 0, ColorFromName("Red"), ColorFromName("White"))

See Also

Other Resources

Conditional Formatting


Grouping, Filtering and Sorting

[image]

Telerik Reporting Q2 2012
Grouping, Filtering and Sorting
See Also Send Feedback

Another usage of expressions is the Grouping, Filtering, and Sorting criteria.

It is important to understand that these operations perform comparison/combination between the results of the evaluation of the used expression. These are valid only between items of the same data type. If the data types do not match, you must explicitly convert the data type that the expression evaluates to by using conversion functions Here are the cases when you need to use conversion:

  • Writing filter expressions that compare values of different data types.
  • Writing sort expressions that combine fields of different data types.
  • Writing group expressions that combine fields of different data types.
  • Converting a value retrieved from the data source from one data type to a different data type.

See Also

Other Resources

Grouping Data
Ordering Data
Filtering Data


Report Parameters

[image]

Telerik Reporting Q2 2012
Report Parameters
See Also Send Feedback

Report parameters expose AvailableValues, which represents the valid set of value/label pairs that the end user can choose from.

The AvailableValues.ValueMember and AvailableValues.DisplayMember are usually names of columns from the AvailableValues.DataSource, but sometimes you may need to use an expression to combine values from more columns as values/labels of the parameters. Expressions are also valid ValueMember/DisplayMembers, for example:

='Mr. ' + Fields.LastName + ', ' + Fields.FirstName

You may also use embedded expressions:

Mr. {Fields.LastName}, {Fields.FirstName}

See Also

Other Resources

Report Parameters
Using Report Parameters in Expressions


Developer's reference

[image]

Telerik Reporting Q2 2012
Developer's reference
Send Feedback

Expressions are written in Telerik Reporting scripting language. The language is based on mathematical expressions, and is case insensitive.

When you write an expression, you have access to many built-in fields, collections, and functions that you can use alone or combine with other terms. You can add function calls, operators, constants, fields, parameters, items from the built-in collections to an expression. Built-in function calls include aggregation, commonly used utility functions, and conversion methods. You can also add references to functions defined in your code (see user functions).

The following list outlines what you can include in an expression:

In This Section

  • Constants

  • Operators

  • Global objects

  • Functions

  • Aggregate functions


Constants

[image]

Telerik Reporting Q2 2012
Constants
Send Feedback

Built-in constants

False, True, null.

Literal text

In an expression, literal text is text that is enclosed in single or double quotation marks.

Example:

="Product name: " + Fields.ProductName

or

='Product name: ' + Fields.ProductName

Note

Because quotation marks are special characters inside the literal text, you need to double the quotation mark to escape it. For example, a literal It's my birthday is used as

= 'It''s my birthday' + Fields.SomeField

Other option is to use the other quotation marks as literal delimiters (then our quotation mark will not be a special symbol):

="It's my birthday" + Fields.SomeField.

Some report item properties allow the usage of Embedded Expressions, which provide easy concatenation of string literals with expression terms.

Numeric constants

They are resolved to:

  • Integer if decimal point is not used - for example 1, 256, 65000
  • Decimal if decimal point is used - for example 1.0, 25.6

Example:

= Fields.LineTotal < 100

Date-time constants

Date values should be enclosed within pound signs (#).

Example:

=Fields.Birthdate < #1/31/82#


Operators

[image]

Telerik Reporting Q2 2012
Operators
Send Feedback

Arithmetic operators

Operator | Description
+ | addition
- | subtraction
* | multiplication
/ | division
% | the remainder after division
Mod | modulus

String Concatenation

Operator | Description
+ | Concatenation, joining strings Example: Fields.FirstName + " " + Fields.LastName.

Comparison operators

Operator | Description
< | less than
<= | less than or equal to
<> | not equal to
= | equal
> | greater than
>= | greater than or equal to
Between | selects a range of data between two values
In | Compare to a list of items. The list can be a any collection of objects
Like | pattern matching
IS [NOT] NULL | If the value of expression is NULL, IS NULL returns TRUE; otherwise, it returns FALSE. If the value of expression is NULL, IS NOT NULL returns FALSE; otherwise, it returns TRUE.

Logical/Bitwise operators

Operator | Description
And | Combines two Boolean expressions and returns TRUE when both expressions are TRUE
Not | Using NOT negates an expression
Or | Combines two Boolean expressions and returns TRUE when either of the conditions is TRUE

Using wildcards for operators

Both the * and % can be used interchangeably for wildcard characters in a LIKE comparison. If the string in a LIKE clause contains a * or %, those characters should be escaped in brackets ([]). If a bracket is in the clause, the bracket characters should be escaped in brackets (for example [[] or [&cd;). A wildcard is allowed at the start and end of a pattern, or at the end of a pattern, or at the start of a pattern. For example:

  • "ItemName LIKE '*product*'"
  • "ItemName LIKE '*product'"
  • "ItemName LIKE 'product*'"

Wildcard characters are not allowed in the middle of a string. For example, 'te*xt' is not allowed.


Global Objects

[image]

Telerik Reporting Q2 2012
Global Objects
Send Feedback

Telerik script language provides five intrinsic (or "built-in") objects. They are the Fields, Parameters, PageNumber, PageCount, and ReportItem objects.

Fields

The Fields collection represents the set of fields specified by the report data source plus any additional calculated fields that you create. After you create a data source for a data item (Report, Table, Crosstab, List, Chart), the field collection appears in the Data Explorer toolbox (link).

Example:Fields.ProductID - returns the value of the field ProductID in the current data scope instance. If the data source does not contain the referenced column, error is thrown. If the report has no data source set, the expression result is null (Nothing)

Note

If the data source field name is not a valid name in terms of programming languages (contains spaces, punctuation marks, etc.) enclose its name in square brackets, for example =Fields.[My Column]; Because brackets are special characters, you must use a back slash ('\') to escape the bracket, if it is part of a data field name. For example, a data field named Field[1] would be referenced as Fields.[Field\[1\]].

Another option of accessing the values in the fields collection is the global function Fields(fieldName).

Parameters

represents the collection of report parameters, each of which can be single-value or multi-value. See Adding Parameters to Report.

Example: =Parameters.Product.Value - returns the value of the report parameter with name Product; =Parameters.Product.Label - returns the label of the report parameter with name Product.

Another option for accessing the report parameters' collection is the global function Parameters(parameterName).

PageNumber

The current page number that can be used only in page header and footer.

PageCount

The total number of pages in the report that can be used only in page header and footer.

Note

The page numbering behavior in a report contained in a report book may be controlled through the Report.PageNumberingStyle(link) property.

ReportItem

The current item in which context the expression is evaluated.


Functions

[image]

Telerik Reporting Q2 2012
Functions
Send Feedback

Conversion functions:

Function | Description
CBool(expression) | Converts an expression to Boolean value.
CDbl(expression) | Converts an expression to Double value.
CInt(expression) | Converts an expression to Integer value.
CDate(expression) | Converts an expression to Date value.
CStr(expression) | Converts an expression to string value.

Expression evaluation flow functions:

Function | Description
IIf(expression, ReturnedIfTrue, ReturnedIfFalse)

Returns one of two objects, depending on the evaluation of an expression. The first parameter is the expression. If the expression evaluates to True the second parameter is returned, if false the third parameter is returned. Both parameters are evaluated prior to the function execution.

Example: prints sum only when vendor is not null: IIf(IsNull(Fields.VendorID, 0)=0,'', Sum(Fields.ContractAmount)).
IsNull(expression, ReplacementValue) | Checks an expression and either returns the checked expression or a replacement value. Example where zero is returned if "Price" is null: IsNull(Fields.Price, 0).
Caution

The reporting engine first evaluates the function parameters and then passes the result values to the function. This means that you need to make sure the parameters of the function are valid statements prior to executing the function.

String manipulation:

Function | Description
StripHtmlTags(string) | Strips the HTML tags from the input text.
Len(string) | Gets the number of characters in a string.
SubStr(string, Start, Length) | Retrieves a substring from a string. The substring starts at a specified character position and has a specified length. Example: SubStr("Telerik", 0, 3) returns "Tel".
Trim(string) | Removes all leading and trailing whitespace from the passed in string.
Format(format, value) | Formats the value using the specified format string. Example: =Format(' LineTotal: {0} ', Fields.LineTotal)

Scope related functions

Data scope related functions

  • Exec(scope, expression) - executes the specified expression in the given data scope. Used mostly with aggregate expressions as a second parameter; this function allows changing of the data scope in which the expression is evaluated. Scope parameter is the name of the data scope we need to evaluate the expression against. For example the expression

    =Fields.LineTotal / Exec(' Report1 ', Sum(Fields.LineTotal))

    used in detail section will return the LineTotal amount as percentage from the whole report.

  • RunningValue(scope, aggregateFunction) - the value for RunningValue resets to 0 for each new instance of the specified scope. If a group is specified, the running value is reset when the group expression changes. If a data item is specified, the running value is reset for each new instance of the data item.

    Restrictions for RunningValue are determined by the aggregate function specified in the function parameter. RunningValue cannot be used in a filter or sort expression.

The set of data specified in the expression must have the same data type. To convert data that has multiple numeric data types to the same data type, use conversion functions like CInt , CDbl, etc.

Page scope related function

  • PageExec(itemName, aggregateFunction) - executes the specified aggregate function in the given scope. As the name suggests, it can be used in page header or page footer of the report. In order to specify the scope in which the aggregate would be evaluated, you need to specify a report item as a parameter of the function.

    It takes two parameters:

    • itemName – determines which data objects are included in the page exec accumulation. For each instance of the report item with the specified name that occurs on the current page, its data object is accumulated.
    • aggregateFunction – the aggregate that is accumulated for each page. The expression used as argument of the aggregate function is evaluated against the collected data objects.

    For example the expression

    =PageExec("lineTotalTextBox",Sum(Fields.LineTotal))

    used in a page section (page header or footer) will return the LineTotal summary for every single page of the report.

Note

Page aggregates are supported in page oriented formats only: IMAGE (TIFF, EMF, BMP, JPEG, GIF, Print), PDF, PPTX, DOCX, RTF, XPS.

Report sections / table rows(columns) running count

Function | Description
RowNumber(scope) | Returns a running count of all rows in the specified scope.
ColumnNumber(scope) | Returns a running count of all columns in the specified scope.
Note

Data scope functions cannot be nested.

Access built-in collection functions

Function | Description
Fields(fieldName) | Returns the value of the field with the specified name in the current data scope. Use this function when you want to dynamically change the referred field. For example you may define string parameter SortField and use =Fields(Parameters.SortField) expression as Sorting of a report.
Parameters(parameterName) | Returns the report parameter with the specified name.

Other functions

Function | Description
Now() | Returns the current date and time on the computer processing the report, expressed as the local time.
Abs(object) | Returns the absolute value of a specified number.


Aggregate Functions

[image]

Telerik Reporting Q2 2012
Aggregate Functions
Send Feedback

Aggregate functions perform a calculation on a set of values and return a single value. All aggregate functions ignore null values. To include aggregated values in your report, use the Aggregates node in Edit Expression editor. You can specify a scope to identify which set of data to use for the calculation by using data scope functions.

Function | Description | Return Type | Example
Avg(Expression) | Returns the average of all non-null values from the specified expression. | The return type is determined by the type of the evaluated result of expression. | Avg(Fields.ListPrice * Fields.Quantity)
Count(Expression) | Returns a count of the non-null values from the specified expression. | Returns an Integer. | Count(Fields.EmployeeID)
CountDistinct(Expression) | Returns a count of the distinct values from the specified expression. | Returns an Integer. | CountDistinct(Fields.EmployeeID)
First(Expression) | Returns the first value from the specified expression. | Determined by the type of expression. | First(Fields.Phone)
Last(Expression) | Returns the last value from the specified expression. | Determined by the type of expression. | Last(Fields.CustomerID)
Max(Expression) | Returns the maximum value from all non-null values of the specified expression. | Determined by the type of the expression. | Max(Fields.ListPrice)
Min(Expression) | Returns the minimum value from all non-null values of the specified expression. | Determined by the type of the expression. | Min(Fields.Quantity)
Sum(Expression) | Returns a sum of the values of the specified expression. | Returns the summation of all expression values in the most precise expression data type. | Sum(Fields.ListPrice * Fields.Quantity)


Member Access

[image]

Telerik Reporting Q2 2012
Member Access
See Also Send Feedback

When you write an expression, you have access not only to Global Objects, Functions and Aggregate Functions but you can also access a member of an object, using the . (dot) character. You can call all public members of an object directly in the Expression Editor. Here are a few examples:

  • = Now().ToShortDateString(): Returns a string that contains the current date in short format.
  • = 'abc'.ToUpper(): Returns "ABC" string.
  • = 'abc'.Length: Returns the length of the current string, 3.
  • = Price.ToString('$0.'): Returns the value of Price formatted according to the specified format, i.e. $123

See Also

Other Resources

Constants
Operators
Global Objects
Functions
Aggregate Functions


Extending Expressions

[image]

Telerik Reporting Q2 2012
Extending Expressions
Send Feedback

You can extend the expression reference using .NET code. You can add complex functions or functions that are used multiple times in a single report. Also you can add custom aggregate functions to apply custom logic while accumulating values.

In This Section

  • User functions

  • User Aggregate functions


User Functions

[image]

Telerik Reporting Q2 2012
User Functions
Send Feedback

User functions allow you to extend the default behavior of the Telerik Reporting engine. User functions are public static (Public Shared in VB.NET) methods that should always return a value and can take an arbitrary number of input parameters. See the code example below:

CopyC#
public class Report1 : Telerik.Reporting.Report
{
    //...
    public static Image ResolveUrl(string relativeUrl)
    {
        string path = HttpContext.Current.Server.MapPath(relativeUrl);
        return Image.FromFile(path);
    }
    //...
}
CopyVB.NET
Public Class Report1 Inherits Telerik.Reporting.Report
    '...
    Public Shared Function ResolveUrl(ByVal relativeUrl As String) As Image
        Dim path As String = HttpContext.Current.Server.MapPath(relativeUrl)
        Return Image.FromFile(path)
    End Function
    '...
End Class

According to their scope, there are two different types of user functions:

  1. Report scoped user functions: such functions are any public static (Public Shared in VB.NET) methods of the current report class. The report scoped user functions can be invoked from an expression by their name, specifying the necessary parameters in the braces:

    Invoking a Report Scoped User Function

    = ResolveUrl("~/Images/Logo.jpg")

  2. Assembly scoped user functions: such functions are any public static (Public Shared in VB.NET) methods that reside in the same assembly as the current report class. The report scoped user functions can be invoked from an expression by their fully qualified name, including the full namespace and the name of the type they belong to, and specifying the necessary parameters in the braces:

    Invoking an Assembly Scoped User Function

    = Telerik.Reporting.Report.Report1.ResolveUrl("~/Images/Logo.jpg")

If the current assembly contains many public static (Public Shared in VB.NET) methods, this might produce some clutter in the Edit Expression dialog, when browsing for existing user functions. In order to overcome this problem, you can use the Browsable attribute to hide any methods, which are not intended to be used as user functions. See the code example below:

CopyC#
public class Report1 : Telerik.Reporting.Report
{
    //...
    [Browsable(false)]
    public static Image ResolveUrl(stringrelativeUrl)
    {
        string path = HttpContext.Current.Server.MapPath(relativeUrl);
        return Image.FromFile(path);
    }
    //...
}
CopyVB.NET
Public Class Report1 InheritsTelerik.Reporting.Report
    '...
    <Browsable(False)>;
    Public Shared FunctionResolveUrl(ByValrelativeUrl AsString) AsImage
        Dim path As String= HttpContext.Current.Server.MapPath(relativeUrl)
        Return Image.FromFile(path)
    End Function
    '...
End Class


User Aggregate Functions

[image]

Telerik Reporting Q2 2012
User Aggregate Functions
Send Feedback

User aggregate functions allow you to apply custom logic when accumulating values over a set of rows from the data source. They are used by the Telerik Reporting engine as all built-in aggregate functions.

Implementing a custom aggregate function

User aggregates are public or internal (Public or Friend in VB.NET) classes that implement the IAggregateFunction interface.

Aggregate function implementation accumulates values from each row using the Accumulate method. The aggregate can take an arbitrary number of input parameters and will receive them as items in the object array parameter passed in this method.

The function merges its value with other instances of the aggregate using the Merge method. For example if you implement SUM aggregate and merge an instance of the aggregate with current accumulated value of 4+5=9 within the current aggregate instance with accumulated value of 1+2+3=6 the result should be 15.

The function returns value using the GetValue method.

Apply AggregateFunctionAttribute to the custom aggregate class implementation to define an interface for the users of the aggregate function. The Name parameter of the attribute defines how to refer to the function in expressions.

Example

CopyC#
[AggregateFunction(Description = "Concatenation aggregate. Output: (value1, value2, ...)", Name = "Concatenate")]
class ConcatenateAggregate : IAggregateFunction
{
    string result;

    public void Accumulate(object[] values)
    {
        // The aggregate function expects one parameter
        object value = values[0];

        // null values are not aggregated
        if (null == value)
        {
            return;
        }

        // The actual accumulation
        if (this.result.Length > 0)
        {
            result += ", ";
        }
        this.result += value.ToString();
    }

    public object GetValue()
    {
        return string.Format("({0})", this.result);
    }

    public void Init()
    {
        // Add aggregate function initialization code here if needed
        this.result = string.Empty;
    }

    public void Merge(IAggregateFunction aggregateFunction)
    {
        ConcatenateAggregate aggregate = (ConcatenateAggregate)aggregateFunction;

        if (aggregate.result.Length > 0)
        {
            if (this.result.Length > 0)
            {
                result += ", ";
            }
            this.result += aggregate.result;
        }
    }
}
CopyVB.NET
<AggregateFunction(Description:="Concatenation aggregate. Output: (value1, value2, ...)", Name:="Concatenate")> _
Class ConcatenateAggregate
    Implements IAggregateFunction
    Private result As String

    Public Sub Accumulate(ByVal values As Object()) Implements IAggregateFunction.Accumulate
        ' The aggregate function expects one parameter
        Dim value As Object = values(0)

        ' null values are not aggregated
        If value Is Nothing Then
            Return
        End If

        ' The actual accumulation
        If Me.result.Length > 0 Then
            result += ", "
        End If
        Me.result += value.ToString()
    End Sub

    Public Function GetValue() As Object Implements IAggregateFunction.GetValue
        Return String.Format("({0})", Me.result)
    End Function

    Public Sub Init() Implements IAggregateFunction.Init
        ' Add aggregate function initialization code here if needed
        Me.result = String.Empty
    End Sub

    Public Sub Merge(ByVal aggregateFunction As IAggregateFunction) Implements IAggregateFunction.Merge
        Dim aggregate As ConcatenateAggregate = DirectCast(aggregateFunction, ConcatenateAggregate)

        If aggregate.result.Length > 0 Then
            If Me.result.Length > 0 Then
                result += ", "
            End If
            Me.result += aggregate.result
        End If
    End Sub
End Class

Invoking a Custom Aggregate Function

You can use a custom aggregate within expressions the same way you invoke an built-in aggregate function:

=Concatenate(Fields.ProductName)

Note

Custom aggregates are not supported when you preview the report in Visual Studio. To see the aggregate output, use a ReportViewer control.


Report Parameters

[image]

Telerik Reporting Q2 2012
Report Parameters
See Also Send Feedback

In Telerik Reporting, parameters are used to specify the data to use in a report, connect related reports together, and vary report presentation. To design a report that uses parameters effectively, you must understand how parameters and Data Source components work together, how parameters and expressions work together and how parameters can be managed. What you choose to parameterize can influence the report design and layout.

After a report parameter is created, you can modify the default values and other parameter properties, such as visibility. For example, you might want to create a report with a hidden parameter that selects data specific to the user running the report. Parameters can contain single values or multiple values, use a static or query-based valid values list, and accept null or blank values. Multivalue parameters enable users to select more than one value at run time.

The major usages of the report parameters are:

  • to vary report data retrieved from a Data Source component

  • in expressions to directly provide a value

  • in data item filtering, sorting or grouping criteria

Report Parameter Properties

  • Type

    Determines the type of the values that are acceptable. The allowed types are Boolean, DateTime, Integer, Float, String. Acceptable values for each type are listed here: ReportParameterType The default parameter type is String.

  • Name

    Specifies the parameter name and used to access the parameter. The name must be a valid identifier - may contain only digits (0-9), letters (a-z, A-Z), and underscore sign (_). Must begin with a letter or underscore.

  • Value

    Used to specify value for the parameter. You can leave the Value property blank, enter a literal value or click the ellipses to invoke the Expression Edit Dialog.

  • Text

    The Text property specifies the text for the parameter to be displayed in the report viewer as prompt to the end user. If not set, the Name of the parameter will be used instead.

  • Visible

    Specifies whether the editor will have UI in the parameters area. When at least one report parameter has the Visible property turned on, a parameter area is shown as part of the report viewer.

  • AllowNull

    Determines if null (Nothing in VB.Net) value is acceptable.

  • AllowBlank

    Applied only when the parameter is of type String. Determines if an empty string is acceptable.

  • MultiValue

    Determines if a collection of values (of the specified Type) is acceptable as value of the parameter. Parameters with MultiValue turned on are mainly used with the IN logical operator.

  • AvailableValues

    The available values, or valid values, are a set of predefined values which are acceptable as value of the parameter. Each available value may have label that will be displayed if the parameter is visible. To define available values for a parameter you need to setup the following nested properties:

    DataSource – a data source for the value/label pairs. Same data sources are supported as for the Data Items, including the Telerik Reporting Data Source Components.

    ValueMember – a column name, expression, or embedded expression based on the DataSource schema. It is used as value in the value/label pair.

    DisplayMember – a column name, expression, or embedded expression based on the DataSource schema. It is used as label in the value/label pair. If omitted the ValueMember will be used as DisplayMember as well. Optional.

    At design time, you can use the Data Source Wizard to select an existing or to create a new data source.

  • Mergeable

    Controls parameter merging in ReportBook. The default value of the Mergeable property is true. Set the Mergeable property to false if you want to prevent a parameter from being merged with its equivalent ones.

  • AutoRefresh

    Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters. Default value is False.

Report Parameter Validation

When a report enters in the processing stage, its value is validated against its validation properties. If one or more parameters do not have valid values, processing is aborted. The following properties are used to validate the supplied parameter’s value:

  • Type

  • AllowNull

  • AllowBlank

  • MultiValue

  • AvailableValues

Passing a value to Report Parameter

A Parameter is populated by setting its Value property. You may set this property to a valid value or an expression that evaluates to a valid value. The expression evaluation and validation are performed while the report is processed. An expression used as parameter value may not contain reference to the built-in Fields collection, as fields are still not populated when the parameters are processed.

Report Parameters' value can be populated in one of the following ways:

  • At design time through the ReportParameter Collection editor.
  • Using the automatic user interface that each Report Viewer provides.
  • Programmatically by using the ReportParameters collection.
  • Using a SubReports Parameters collection.

Cascading (dependent) parameters

Cascading parameters provide a way of creating dependencies between parameters to handle large amounts of input data. You can define a set of parameters where the list of available values for one parameter depends on the values chosen in other parameters.

For example, the first parameter could present a list of product categories. When the user selects a category, the second parameter is updated with a list of subcategories within the category. A third parameter could then display a list of products within the selected subcategory. The value for the product parameter is used to filter the report to a particular product. The parameters which values depend on other parameters values are known as cascading, dependent or hierarchical parameters.

Parameter area

When at least one report parameter has its Visible property turned on, a parameter area is shown as part of the report viewer. This helps the report developer to easily provide input method for the end users. Based on the settings of the parameters, a suitable editor UI is created. Parameter layout on the parameter area is formatted automatically. The order is determined by the order that parameters appear in the ReportParameters collection. The end user can enter or select values in the editors. When at least one visible report parameter has AutoRefresh property turned off, a Preview button is available. In this case to preview the report, the end user should click the Preview button. If all parameters have default values, the report runs automatically on first view. You can show or hide the parameters area from the Parameters button in the report viewer’s toolbar.

See Also

Other Resources

How-To: Add Report Parameters
Using Report Parameters in Expressions
Using Report Parameters programmatically
How-To: Cascading Parameters with applied filtering on Report level
How-To: Cascading Parameters with applied filtering on data source level
Using Multivalue Parameters


How-To: Add Report Parameters

[image]

Telerik Reporting Q2 2012
How-To: Add Report Parameters
Send Feedback

Report parameters typically filter report data that is retrieved from a data source. Filtering data at the data source can improve performance for processing and viewing a report. For the times when you cannot filter data at the source, you can use parameters to filter report data after it is retrieved. You can also sort and group data in a report based on report parameters.

There are several ways to add a Report Parameter:

  • Using the Report.ReportParameters property in the property grid.
  • Select the Report Parameters .. option from the Context Menu of the Report Designer.
  • Right click on the Parameters node of the Report Explorer dialog.
  • From the Configure Data Source Parameters step of the DataSource Components

Add a Report Parameter using Report Designer

  1. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.

  2. Click the Add button to create a new parameter.
  3. In Name, type the name of the parameter.
  4. In Text type the text for the parameter to be displayed in the report viewer as prompt to the end user. If not set, the Name of the parameter will be used instead.
  5. In Type, select the data type for the parameter value. By default String type is selected.

  6. You can leave the Value property blank, enter a literal value or click the ellipses to invoke the Expression Edit Dialog.

  7. If the parameter can contain a blank value, set AllowBlank accordingly.
  8. If the parameter can contain a null value, set AllowNull accordingly.
  9. To allow a user to select more than one value for the parameter, set MultiValue accordingly.
  10. To allow a user to select or change a parameter value, set Visible to True.

Add a Report Parameter programmatically

CopyC#
Telerik.Reporting.ReportParameter reportParameter1 = new Telerik.Reporting.ReportParameter();
reportParameter1.Name = "Parameter1";
reportParameter1.Text = "Enter Value for Parameter1";
reportParameter1.Type = Telerik.Reporting.ReportParameterType.Integer;
reportParameter1.AllowBlank = false;
reportParameter1.AllowNull = false;
reportParameter1.Value = "=10";
reportParameter1.Visible = true;
report1.ReportParameters.Add(reportParameter1);
CopyVB.NET
Dim reportParameter1 As New Telerik.Reporting.ReportParameter()
reportParameter1.Name = "Parameter1"
reportParameter1.Text = "Enter Value for Parameter1"
reportParameter1.Type = Telerik.Reporting.ReportParameterType.Integer
reportParameter1.AllowBlank = False
reportParameter1.AllowNull = False
reportParameter1.Value = "=10"
reportParameter1.Visible = True
report1.ReportParameters.Add(reportParameter1)

Defining AvailableValues for ReportParameter’s UI using Report Designer

  1. Expand the AvailableValues property of the report parameter and fill the following settings to determine the values the end user can choose from.
    • Set the DataSource property to specify data source from which the available values of the editor will be loaded. The same object types used as data source for the report can be used as data source for the report parameters. If no DataSource is specified, available values are not loaded.
    • In the ValueMember property choose a column from the data source from which the editor to load the values.
    • In the DisplayMember property choose a column from the data source from which the editor to draw the value labels.
    • In the Filters you can limit the number of records in the available values based on specified filter rules. If the conditions of the rules are met the record is included. Filters are defined using the Edit Filter Dialog.
    • Sorting can be performed on the available values through the Sorting property. Sorting controls the order of the items provided to the user to choose from. Sorting is defined using the Edit Sorting Dialog.

Defining AvailableValues for ReportParameter’s UI programmatically

CopyC#
reportParameter1.AvailableValues.DataSource = objectDataSource1;
reportParameter1.AvailableValues.ValueMember = "= Fields.EmployeeID";
reportParameter1.AvailableValues.DisplayMember = "= Fields.FirstName";
Telerik.Reporting.Filter filter1 = new Telerik.Reporting.Filter();
filter1.Expression = "=Fields.ProductCategory";
filter1.Operator = Telerik.Reporting.FilterOperator.Equal;
filter1.Value = "=Parameters.ProductCategory";
reportParameter1.AvailableValues.Filters.AddRange(new Telerik.Reporting.Filter[] { filter1 });
Telerik.Reporting.Sorting sorting1 = new Telerik.Reporting.Sorting();
sorting1.Expression = "=Fields.ProductSubcategory";
sorting1.Direction = Telerik.Reporting.SortDirection.Asc;
reportParameter1.AvailableValues.Sortings.AddRange(new Telerik.Reporting.Sorting[] { sorting1 });
CopyVB.NET
reportParameter1.AvailableValues.DataSource = objectDataSource1
reportParameter1.AvailableValues.ValueMember = "= Fields.EmployeeID"
reportParameter1.AvailableValues.DisplayMember = "= Fields.FirstName"
Dim filter1 As New Telerik.Reporting.Filter()
filter1.Expression = "=Fields.ProductCategory"
filter1.Operator = Telerik.Reporting.FilterOperator.Equal
filter1.Value = "=Parameters.ProductCategory"
reportParameter1.AvailableValues.Filters.AddRange(New Telerik.Reporting.Filter() {filter1})
Dim sorting1 As New Telerik.Reporting.Sorting()
sorting1.Expression = "=Fields.ProductSubcategory"
sorting1.Direction = Telerik.Reporting.SortDirection.Asc
reportParameter1.AvailableValues.Sortings.AddRange(New Telerik.Reporting.Sorting() {sorting1})


Using Report Parameters in Expressions

[image]

Telerik Reporting Q2 2012
Using Report Parameters in Expressions
Send Feedback

Report Parameters can be used in expressions that you display directly and can also be used with other elements in an expression. These expressions in turn can be used as criteria for filters, sorting and grouping.

Report Parameters in Expressions

For example if you have a "Vendor List" report you can define a "VendorSelect" parameter. To display this value directly in the report you can assign an expression to a TextBox as in the example below:

You can show the Label value in the same manner by using similar expression e.g. =Parameters.VendorSelect.Label. This same parameter can be used to filter the vendor listing. In the example below we set up an expression where the VendorName from the database is compared, using a Like operator to the VendorSelect parameter. The expression is appended with the "%" wildcard so that any VendorName that starts with the characters passed in the parameter will be included in the report.

To extend this example to handle sorting choices a second column "VendorID" is added to the report and a second parameter called "SortColumn" is added. In the Report Sorting property an expression is added that checks the value of SortColumn. If SortColumn is zero then the sort is by the VendorID column, otherwise the sort column is VendorName.


Using Report Parameters programmatically

[image]

Telerik Reporting Q2 2012
Using Report Parameters programmatically
Send Feedback

In the report viewing application you can populate the values of ReportParameters collection members prior to displaying the report.

CopyC#
Report1 report = new Report1();
report.ReportParameters["ManagerID"].Value = "123";
CopyVB.NET
Dim report As New Report1()
report.ReportParameters("ManagerID").Value = "123"

At runtime you can access the report parameters through the Report..::.Parameters dictionary. Each Parameter object contains resolved available values, current value and label. The label returns the currently selected DisplayMember from the available values (if available values are defined).

Note

Prior to version 2010 Q1 the processing report exposes a dictionary containing only the current values of the report parameters.

Example:

  1. Create a Telerik Report
  2. Use the instructions from the How to: Connect to a SQL Server Database Using Stored Procedure article to bind to the uspGetManagerEmployees stored procedure from the AdventureWorks table.
  3. Leave the Value for the @ManagerID data source parameter empty and finish the wizard.
  4. Create the following layout for the report

  5. Add a report parameter and name it ManagerID.
  6. Change its Type to Integer.
  7. Set its Visible property to True.
  8. Expand the AvailableValues and bind it to SqlDataSource component with the following query:
    CopySQL
    SELECT        M.ManagerID, C.FirstName + ' ' + C.LastName AS Name
FROM          (SELECT DISTINCT ManagerID
               FROM      HumanResources.Employee) AS M INNER JOIN
                         HumanResources.Employee AS E ON M.ManagerID = E.EmployeeID INNER JOIN
                         Person.Contact AS C ON E.ContactID = C.ContactID
  9. Set the ValueMember to = Fields.ManagerID.
  10. Set the DisplayMember to = Fields.Name.
  11. Add grouping for the report with = Fields.ManagerID as grouping expression.
  12. Wire the NeedDataSource event of the report.
  13. In the report.cs file set the DataSource property to null (Nothing in VB.NET) so that NeedDataSource event is fired.
  14. Add the following code to the NeedDataSource event handler:
    CopyC#
    private void Report1_NeedDataSource(object sender, System.EventArgs e)
{
    //Take the Telerik.Reporting.Processing.Report instance
    Telerik.Reporting.Processing.Report report = (Telerik.Reporting.Processing.Report)sender;

    // Transfer the value of the processing instance of ReportParameter
    // to the parameter value of the sqlDataSource component
    this.sqlDataSource1.Parameters[0].Value = report.Parameters["ManagerID"].Value;

    // Set the SqlDataSource component as it's DataSource
    report.DataSource = this.sqlDataSource1;
}
    CopyVB.NET
    Private Sub Report1_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.NeedDataSource
    'Take the Telerik.Reporting.Processing.Report instance
    Dim report As Telerik.Reporting.Processing.Report = DirectCast(sender, Telerik.Reporting.Processing.Report)

    ' Transfer the value of the processing instance of ReportParameter
    ' to the parameter value of the sqlDataSource component
    Me.sqlDataSource1.Parameters(0).Value = report.Parameters("ManagerID").Value

    ' Set the SqlDataSource component as it's DataSource
    report.DataSource = Me.sqlDataSource1
End Sub
  15. Display the Report in a report viewer.
  16. Select a parameter from the available values in the parameter editor and click Preview.


Using Multivalue Parameters

[image]

Telerik Reporting Q2 2012
Using Multivalue Parameters
See Also Send Feedback

A multivalue parameter can be set to more than one value. When you define list of available values for a multivalue parameter, a <select all> option is automatically added to the list of values in the report parameter editor. You can use this option to select and clear all values in the list. The expression for a multivalue parameter does not differ than the expression for a single value parameter i.e. the expression begins with Parameters keyword. For example, a parameter named VendorSelect appears as Parameters.VendorSelect.Value. For more information, see Using Report Parameters in Expressions.

To specify that a report parameter would accept multiple values, set the Multivalue property for a parameter to True. You can set any parameter type to multivalue except Boolean. The primary use of multivalue parameters is to allow for a query restriction clause, to test for inclusion in a set of values instead to a single value.

Writing Queries for Multivalue Report Parameters

If you want to pass multiple parameter values back to a data source by using query, the following requirements must be satisfied:

  • The data source must be supported. For a list see SqlDataSource Component
  • The data source cannot be a stored procedure. Telerik Reporting does not support passing a multivalue parameter array to a stored procedure.
  • Use an IN clause in the query to specify the parameter.

The Data Source Components are based on ADO.NET and ADO.NET does not allow a collection of values to be passed. The SqlDataSource Component however supports parametrized SQL queries by associating the report parameters with placeholders in the SelectCommand query. Parameter values can be evaluated with any expression which conforms to the common expression syntax supported by the reporting engine. This grants a great deal of flexibility on how to supply SQL queries with parameters.

The example below shows the use of an IN keyword in the WHERE clause of a T-SQL statement. More information about the IN keyword or the results returned by this query, see IN (Transact-SQL) .

CopySQL
SELECT        ProductID, Name, Color
FROM            Production.Product
WHERE        ProductID IN (@ProductID)

To experiment with this in a report, add SqlDataSource Component using this query. Create a new report parameter as Value for the @ProductID data source parameter. Set its Multivalue and Visible properties to true, set the Type property to Integer. In AvailableValues, set the DataSource for the parameter to a new SqlDataSource Component with the following query:

CopySQL
SELECT        ProductID, Name
FROM            Production.Product
Set the ValueMember property to = Fields.ProductID and the DisplayMember property to = Fields.Name. Run preview, select different values for the report parameter and verify that you get the expected results.

Note

The report engine rewrites queries for data sources that cannot process parameters as an array. The rewrite logic is triggered when a parameter is defined as multivalue and the database query uses an IN statement to specify the parameter.

Specifying Default Value for a MultiValue Parameter

In order to have multiple values selected, you should set the Value property of the parameter to an IEnumerable instance containing the desired values. This can be done using the code behind or an expression.

The data source which the Value property expression is evaluated against is the data source of the available values. For example if the AvailableValues data source has a field Name, as a Value you may use an expression like =First(Fields.Name). The same approach may be used to have all available values returned. This is achieved with the help of a simple User Aggregate Functions:

Example

CopyC#
[AggregateFunction(Description = "Collects all values", Name = "AllValues")]
public class AllValuesAggregateFunction : IAggregateFunction
{
    ArrayList values;

    public void Accumulate(object[] values)
    {
        var value = values[0];
        this.values.Add(value);
    }

    public object GetValue()
    {
        return this.values;
    }

    public void Init()
    {
        this.values = new ArrayList();
    }

    public void Merge(IAggregateFunction aggregateFunction)
    {
        var otherFunction = (AllValuesAggregateFunction)aggregateFunction;
        this.values.AddRange(otherFunction.values);
    }
}
CopyVB.NET
<AggregateFunction(Description:="Collects all values", Name:="AllValues")> _
Public Class AllValuesAggregateFunction
    Implements IAggregateFunction
    Private values As ArrayList

    Public Sub Accumulate(values As Object()) Implements IAggregateFunction.Accumulate
        Dim value = values(0)
        Me.values.Add(value)
    End Sub

    Public Function GetValue() As Object Implements IAggregateFunction.GetValue
        Return Me.values
    End Function

    Public Sub Init() Implements IAggregateFunction.Init
        Me.values = New ArrayList()
    End Sub

    Public Sub Merge(aggregateFunction As IAggregateFunction) Implements IAggregateFunction.Merge
        Dim otherFunction = DirectCast(aggregateFunction, AllValuesAggregateFunction)
        Me.values.AddRange(otherFunction.values)
    End Sub
End Class
Then set the following expression for the Value property = AllValues(Fields.Name).

See Also

Other Resources

User Aggregate Functions


How-To: Cascading Parameters with applied filtering on Report level

[image]

Telerik Reporting Q2 2012
How-To: Cascading Parameters with applied filtering on Report level
Send Feedback

To create cascading report parameters with applied filtering on report level follow the steps bellow:

  1. Using the DataSource Wizard bind the report to SqlDataSource with query:
    CopySQL
    SELECT
    Production.Product.ProductNumber,
    Production.Product.Name AS ProductName,
    Production.Product.ProductSubcategoryID,
    Production.ProductSubcategory.Name AS SubcategoryName
FROM
    Production.Product
    INNER JOIN Production.ProductSubcategory
        ON Production.Product.ProductSubcategoryID = Production.ProductSubcategory.ProductSubcategoryID
  2. Click the ellipses on the Report.ReportParameters property. This invokes the ReportParameter Collection editor.
  3. Add new Report Parameter
  4. Name it ProductCategoryID.
  5. Set the Type of the parameter to Integer.
  6. Expand the AvailableValues.
  7. Set the DataSource using the Data Source Wizard to SqlDataSource with query:
    CopySQL
    SELECT
    ProductCategoryID,
    Name AS CategoryName
FROM
    Production.ProductCategory
  8. It is not compulsory to set the DataMember property when the data source contains only one table.
  9. Set the DisplayMember to = Fields.CategoryName column.
  10. Set the ValueMember to = Fields.ProductCategoryID.
  11. Set the Text to Product Category.
  12. Set the Visible property to True if needed.
  13. Add new Report Parameter
  14. Name it ProductSubcategoryID.
  15. Set the Type of the parameter to Integer.
  16. Expand the AvailableValues.
  17. Set the DataSource using the Data Source Wizard to SqlDataSource with query:
    CopySQL
    SELECT
    ProductCategoryID,
    ProductSubcategoryID,
    Name AS SubcategoryName
FROM
    Production.ProductSubcategory
  18. It is not compulsory to set the DataMember property when the data source contains only one table.
  19. Set the DisplayMember to = Fields.SubcategoryName column.
  20. Set the ValueMember to = Fields.ProductSubcategoryID.
  21. Click on the ellipsis on the Filters property.
  22. Add new filter.
  23. As Expression choose =Fields.ProductCategoryID.
  24. As Operator choose equals(=).
  25. As Value choose =Parameters.ProductCategoryID.Value.
  26. Click OK.
  27. Set the Multivalue to false (or to true if you want to be able to select more than one subcategory at a time).
  28. Set the Text to Product Subcategory.
  29. Set the Visible property to True if needed.
  30. Close the ReportParameter Collection Editor.
  31. Click on the ellipsis on the Filters property of the report to open the Edit Filters dialog.
  32. Add new filter.
  33. As Expression choose =Fields.ProductSubcategoryID.
  34. As Operator choose equals(=) (or to IN operator if you have set ProductSubcategoryID parameter as multivalue parameter).
  35. As Value choose =Parameters.ProductSubcategoryID.Value.
  36. Click OK.
  37. Preview the report. Use the Product Category and Product Subcategory parameters to filter the list of products shown in the report.


How-To: Cascading Parameters with applied filtering on data source level

[image]

Telerik Reporting Q2 2012
How-To: Cascading Parameters with applied filtering on data source level
Send Feedback

To create cascading report parameters with applied filtering on data source level follow the steps bellow:

Cascading Parameters with applied filtering on Datasource level

  1. Using the Data Source Wizard bind the report to SqlDataSource with query:
    CopySQL
    SELECT        Production.Product.ProductNumber, Production.Product.Name AS ProductName,
              Production.ProductSubcategory.Name AS SubcategoryName
FROM          Production.Product
              INNER JOIN Production.ProductSubcategory
                   ON Production.Product.ProductSubcategoryID = Production.ProductSubcategory.ProductSubcategoryID
WHERE        (Production.Product.ProductSubcategoryID = @ProductSubcategoryID)
     Note that there is a WHERE clause that filters the datasource based on the ProductSubcategoryID parameter.
  2. Click the Next button and the "Configure Data Source Parameters" step of the SqlDataSource appears. Set the DbType of the ProductSubcategoryID parameter to Int32 and select "New Report Parameter" for the Value.
  3. This invokes the Report Parameter Editor.
  4. Name the new parameter ProductSubcategoryID.
  5. Set the Text to Product SubCategory.
  6. Set the Type of the parameter to Integer.
  7. Set the Visible property to True.
  8. Expand the AvailableValues.
  9. Start the Data Source Wizard and set the DataSource for the parameter to the following query:
    CopySQL
    SELECT        ProductSubcategoryID,
              Name AS SubcategoryName
FROM          Production.ProductSubcategory
WHERE        (ProductCategoryID = @ProductCategoryID)
     Note that there is a WHERE clause that filters the data source based on the ProductCategoryID parameter.
  10. Click the Next button and the "Configure Data Source Parameters" step of the SqlDataSource appears. Set the DbType of the ProductCategoryID parameter to Int32 and select "New Report Parameter" for the Value.
  11. This invokes the Report Parameter Editor.
  12. Name the new parameter ProductCategoryID.
  13. Set the Text to Product Category.
  14. Set the Type of the parameter to Integer.
  15. Set the Visible property to True.
  16. Expand the AvailableValues.
  17. Start the Data Source Wizard and set the DataSource for the parameter to the following query:
    CopySQL
    SELECT
              ProductCategoryID,
              Name AS CategoryName
FROM
              Production.ProductCategory
  18. Click Next and Finish the Data Source Wizard.
  19. Set the DisplayMember to = Fields.CategoryName column.
  20. Set the ValueMember to = Fields.ProductCategoryID.
  21. It is not compulsory to set the DataMember property when the data source contains only one table.
  22. Click OK to close the Report Parameter Editor.
  23. Click Next and Finish the Data Source Wizard for the ProductCategoryID parameter.
  24. Select the Report Parameter Editor for the ProductSubcategoryID parameter.
  25. Set the DisplayMember to = Fields.SubcategoryName column
  26. Set the ValueMember to = Fields.ProductSubcategoryID.
  27. It is not compulsory to set the DataMember property when the data source contains only one table.
  28. Click OK to close the Report Parameter Editor.
  29. Click Next and Finish the Data Source Wizard for the ProductSubcategoryID parameter.
  30. Preview the report. Use the Product Category and Product Subcategory parameters to filter the list of products shown in the report.


Adding Interactivity to Reports

[image]

Telerik Reporting Q2 2012
Adding Interactivity to Reports
Send Feedback
In Telerik Reporting, you can add a number of features that let your users interact with reports.

In This Section

  • Bookmarks
  • How to: Add Bookmarks to a Report Item
  • How to: Add Bookmarks to a Report group
  • How to: Add Bookmarks to a Table group
  • Actions
  • Drillthrough Report Action
  • BookMark Action
  • Hyperlink Action
  • Drilldown Report Action
  • How to: Add a Drillthrough Report Action
  • How to: Add a Bookmark Action
  • How to: Add a Hyperlink Action
  • How to: Add a Drilldown Action
  • Document Map
  • How to: Add a Report Item to Document Map
  • How to: Add a Report group to Document Map
  • How to: Add a Table group to Document Map


Bookmarks

[image]

Telerik Reporting Q2 2012
Bookmarks
See Also Send Feedback

Add bookmarks to a report when you want to provide a customized table of contents or to provide customized internal navigation in the report. Typically, you add bookmarks to locations in the report to which you want to direct users. You can create your own strings to use as bookmarks, or, for groups, you can set the bookmark to the group expression. After you create bookmarks, you can add report items that the user can click to go to each bookmark. These items are typically text boxes or images. For example, if your report displays a table grouped by color, you would add a bookmark based on the group expression to the group header. Then you would add a table with a single text box at the beginning of the report that displayed the color values, and set the bookmark link on that text box. When you click the color, the report jumps to the page that displays the group header row for that color. You can add a bookmark to any report item/group and add a bookmark link to any report item.

To define a bookmark on item/group use the BookmarkId property. To define a bookmark action add a NavigateToBookmarkAction on another item.

In This Section

  • How to: Add Bookmarks to a Report item
  • How to: Add Bookmarks to a Report group
  • How to: Add Bookmarks to a Table group

See Also

Other Resources

How to: Add a Bookmark Action


How to: Add Bookmarks to a Report item

[image]

Telerik Reporting Q2 2012
How to: Add Bookmarks to a Report item
See Also Send Feedback

Add bookmarks to a report when you want to provide a customized table of contents or to provide customized internal navigation in the report. Typically, you add bookmarks to locations in the report to which you want to direct users. You can create your own strings to use as bookmarks, or, for groups, you can set the bookmark to the group expression. After you create bookmarks, you can add report items that the user can click to go to each bookmark. These items are typically text boxes or images.

Adding a bookmark to a report item

  1. In Design view, select a report item to which you want to add a bookmark. The properties for the selected item appear in the Properties pane.
  2. In the BookmarkId property, type a string that is the label for this bookmark. Alternatively, click the ellipsis to open the Expression dialog box to specify an expression that evaluates to a label.
Note

The BookmarkId can be any string, but it must be unique in the report. If the BookmarkID is not unique, an action to the bookmark finds the first matching bookmark.

See Also

Other Resources

Bookmarks
How to: Add Bookmarks to a Report group
How to: Add Bookmarks to a Table group


How to: Add Bookmarks to a Report group

[image]

Telerik Reporting Q2 2012
How to: Add Bookmarks to a Report group
See Also Send Feedback

Add bookmarks to a report when you want to provide a customized table of contents or to provide customized internal navigation in the report. Typically, you add bookmarks to locations in the report to which you want to direct users. You can create your own strings to use as bookmarks, or, for groups, you can set the bookmark to the group expression. After you create bookmarks, you can add report items that the user can click to go to each bookmark. These items are typically text boxes or images.

Adding a bookmark to a Report group

  1. In Design view, right click outside the report sections, select View and open up the Group Explorer. Select a report group to which you want to add a bookmark. The properties for the selected group appear in the Properties pane.
  2. In the BookmarkId property, type a string that is the label for this bookmark. Alternatively, click the ellipsis to open the Expression dialog box to specify an expression that evaluates to text. Typically for a group, the expression you type should be the group expression.
Note

The BookmarkId can be any string, but it must be unique in the report. If the BookmarkID is not unique, an action to the bookmark finds the first matching bookmark.

See Also

Other Resources

Bookmarks
How to: Add Bookmarks to a Report item
How to: Add Bookmarks to a Table group


How to: Add Bookmarks to a Table group

[image]

Telerik Reporting Q2 2012
How to: Add Bookmarks to a Table group
See Also Send Feedback

Add bookmarks to a report when you want to provide a customized table of contents or to provide customized internal navigation in the report. Typically, you add bookmarks to locations in the report to which you want to direct users. You can create your own strings to use as bookmarks, or, for groups, you can set the bookmark to the group expression. After you create bookmarks, you can add report items that the user can click to go to each bookmark. These items are typically text boxes or images.

Adding a bookmark to a Table group

  1. In Design view, right click outside the report sections, select View and open up the Group Explorer. Select a Table, Crosstab or List report item, so the Group Explorer shows the respective groups. Select a group to which you want to add a bookmark, right click on it and select Group Properties. The properties for the selected group appear in the Edit Table Group dialog.
  2. In the BookmarkId property, type a string that is the label for this bookmark. Alternatively, click the ellipsis to open the Expression dialog box to specify an expression that evaluates to text. Typically for a group, the expression you type should be the group expression.
Note

The BookmarkId can be any string, but it must be unique in the report. If the BookmarkID is not unique, an action to the bookmark finds the first matching bookmark.

See Also

Other Resources

Bookmarks
How to: Add Bookmarks to a Report item
How to: Add Bookmarks to a Report group


Actions

[image]

Telerik Reporting Q2 2012
Actions
Send Feedback

You can add interactive actions that allow users to open Web pages or other reports, jump to another location within the same report or drilldown to detail data. To add an interactive action, you define an Action on a report item. Use the Edit Action dialog to set the type of interactive action. When the user clicks that report item, the action that you define takes place. The report engine supports four types of actions:

  • Navigate to Report: Jump to other reports from the main report (Drillthrough report).
  • Navigate to Bookmark: Jump to areas within a report.
  • Navigate to Url: Jump to external web URLs that specify the address of web pages.
  • Toggle Visibility: Show or hide report items within the same report.
Note

The actions are feature of the report viewers and not of the rendering extension. You can find more info about the supported interactive features in each format by checking the Interactivity section of the respective articles in Design Considerations for Report Rendering help section.

In This Section

  • Drillthrough Report Action
  • Bookmark Action
  • Hyperlink Action
  • Drilldown Report Action


Drillthrough Report Action

[image]

Telerik Reporting Q2 2012
Drillthrough Report Action
See Also Send Feedback

A drillthrough report is a report that a user opens by clicking a link within another report. Drillthrough reports commonly contain details about an item that is contained in an original summary report. For example, you might have a sales summary report with a list of orders and sales totals. When a user clicks an order number in the summary list, another report opens that contains details about the order.

A drillthrough report serves a different purpose than a subreport. A subreport is processed as part of the main report. For example, if a subreport that displays order detail information is added to a table cell in the detail row, the subreport is processed once per row of the table and rendered as part of the main report. A drillthrough report is only processed and rendered when the user clicks the drillthrough link in the summary main report.

A drillthrough report typically contains parameters that are passed to it by the summary report. When you set a drillthrough report link on a report item, set a value for the parameter of the target report as well. When the user clicks the link in the summary report, the target detail report opens and displays the information for that specific value.

To define a drill-through action add a NavigateToReportAction on an item.

Note

The Target report of a drill-through action should always have a default constructor, so it can be instantiated.

See Also

Other Resources

How to: Add a Drillthrough Report Action


Bookmark Action

[image]

Telerik Reporting Q2 2012
Bookmark Action
See Also Send Feedback

A bookmark action is a link that a user clicks to move to another area or report item in a report. To create a bookmark, set a bookmark on the destination report item and add bookmark action on report items that users should click to jump to the bookmarked report item. You can set bookmarks on any report item, including text boxes, images, charts, and gauges. You can add multiple bookmark actions to the same bookmark. To define a bookmark action add a NavigateToBookmarkAction on another report item/section.

See Also

Other Resources

How to: Add a Bookmark Action


Hyperlink Action

[image]

Telerik Reporting Q2 2012
Hyperlink Action
See Also Send Feedback

You can add a hyperlink to a report item so that a user can access a Web page by clicking the item. A hyperlink can be a static URL or an expression that evaluates to a URL. If you have a field in a database that contains URLs, the expression can contain that field, resulting in a dynamic list of hyperlinks in the report. You can define a hyperlink on any report item.

To define a hyperlink add a NavigateToUrlAction on an item.

You can also specify whether the URL is opened in the same or new browser window using the Target property.

Caution

Opening URL in the same window is only applicable for the Web Report Viewer and Silverlight Report Viewer. For the others, the NavigateToUrlAction would be opened in a new window.

See Also

Other Resources

How to: Add a Hyperlink Action


Drilldown Report Action

[image]

Telerik Reporting Q2 2012
Drilldown Report Action
See Also Send Feedback

You can control whether a report item initially displays or is hidden when a user views a report. By providing a toggle on a text box, you can enable users to hide and display items interactively. For a Table or CrossTab, you can show or hide dynamic (associated with groups), static and detail row and column groups. The main reason for hiding items is usually for clarity - a report that initially shows summary but enables users to drilldown into detail data.

For example, you can initially hide all the row groups except the outer parent group for a table. For each inner group (including the details group), add a drilldown action to the grouping cell of the containing group. When the report is rendered, the user can click the text box to expand and collapse the detail data.

To define a drilldown action add a ToggleVisibilityAction on an item. To define if the item exposing the action will be rendered initially with expanded or with collapsed mark, use the DisplayExpandedMark property.

Note

The report item that you use for the toggle visibility action must be in a containing scope that controls the item that you want to show or hide. Example: to hide a row group, the report item must be in a row group associated with the parent group or higher in the containment hierarchy.

See Also

Other Resources

How to: Add a Drilldown Action
Drillthrough Report Action
How to: Add a Drillthrough Report Action


Actions How-To

[image]

Telerik Reporting Q2 2012
Actions How-To
Send Feedback

The following tutorials describe how to create and use drill-through reports, bookmarks, hyperlink navigation and drilldown to detail data in Telerik Reports.

In This Section

  • How to: Add a Drillthrough Report Action
  • How to: Add a Bookmark Action
  • How to: Add a Hyperlink Action
  • How to: Add a Drilldown Action


How to: Add a Drillthrough Report Action

[image]

Telerik Reporting Q2 2012
How to: Add a Drillthrough Report Action
See Also Send Feedback

A report can contain links to other reports. The report that opens when you click the link in the main report is known as a drillthrough report. Drillthrough reports must be published to the same report server as the main report, but they can be in different folders. You can add a drillthrough link to any item that has an Action property.

Adding a drillthrough action using the Report Designer

  1. In Design view, right-click a report item to which you want to add a link and then click Properties.
  2. In the item's Properties dialog box, click Action.
  3. Select Navigate to Report. Additional section appears which allows you to select a ReportSource.
  4. In the Choose a Report Source dialog, select how you would navigate to the report, For this example we would use Type Report Source, click that option and select the report that you would like to navigate to.

    If you have to specify parameters for the drillthrough report, follow the next step.

  5. Click Edit Parameters button - Edit Parameters dialog appears. Click New. In the Parameter Name column select the name of the report parameter in the drillthrough report. In the Parameter Value, type or select the value to pass to the parameter in the drillthrough report.
  6. To test the link, run the report and click the report item with the applied Action. For TextBoxes, it is helpful to change the color and effect of the text to indicate that the text is a link. For example, change the color to blue and the effect to underline by setting the corresponding Font properties of the TextBox.

Adding a drillthrough action programatically

CopyC#
Telerik.Reporting.TypeReportSource reportSource = new Telerik.Reporting.TypeReportSource();
reportSource.TypeName = "ReportLibrary1.Report1, ReportLibrary1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null";
reportSource.Parameters.Add(new Telerik.Reporting.Parameter("OrderNumber", "SO43659"));

Telerik.Reporting.NavigateToReportAction reportAction1 = new Telerik.Reporting.NavigateToReportAction();
reportAction1.ReportSource = reportSource;
textBox1.Action = reportAction1;
CopyVB.NET
Dim reportSource As New TypeReportSource()
reportSource.TypeName = "ReportLibrary1.Report1, ReportLibrary1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"
reportSource.Parameters.Add(New Telerik.Reporting.Parameter("OrderNumber", "SO43659"))

Dim reportAction1 As New Telerik.Reporting.NavigateToReportAction()
textBox1.Action = reportAction1

See Also

Other Resources

How to: Add a Bookmark Action
How to: Add a Hyperlink Action
Add Interactivity
Expressions
Data Items


How to: Add a Bookmark Action

[image]

Telerik Reporting Q2 2012
How to: Add a Bookmark Action
See Also Send Feedback

Adding a bookmark action using the Report Designer

  1. In Design view, right-click the report item to which you want to add a link and then click Properties.
  2. In The Properties dialog box for that report item, click Action.
  3. Select Navigate to bookmark. An additional section appears in the dialog box for this option.
  4. In the Target bookmark by Value textbox, type a bookmark or an expression that evaluates to a bookmark.
  5. Click OK
  6. To test the link, run the report and click the report item with the applied Action. For TextBox items, it is helpful to change the style of the text to indicate to the user that the text is a link. For example, change the color to blue and the effect to underline by setting the corresponding Font properties of the TextBox.

Adding a bookmark action programatically

CopyC#
Telerik.Reporting.NavigateToBookmarkAction bookmarkAction1 = new Telerik.Reporting.NavigateToBookmarkAction();
textBox2.DocumentMapText = "MyBookMark";
bookmarkAction1.TargetBookmarkId = "MyBookMark";
textBox1.Action = bookmarkAction1;
CopyVB.NET
Dim bookmarkAction1 As New Telerik.Reporting.NavigateToBookmarkAction()
textBox2.DocumentMapText = "MyBookMark"
bookmarkAction1.TargetBookmarkId = "MyBookMark"
textBox1.Action = bookmarkAction1

See Also

Other Resources

How to: Add a Drillthrough Report Action
How to: Add a Hyperlink Action
Add Interactivity
Expressions
Data Items


How to: Add a Hyperlink Action

[image]

Telerik Reporting Q2 2012
How to: Add a Hyperlink Action
See Also Send Feedback

Add a hyperlink to a URL when you want users to be able to click a link in a report and open a browser to the URL you specify. You must ensure that the user has access to the URL that you provide i.e. it allows anonymous access or does not require credentials. You can add a hyperlink to a URL to any item that has an Action property.

Adding a Hyperlink action using Report Designer

  1. In Design view, right-click a report item to which you want to add a link and then click Properties.
  2. In the Properties dialog box, click Action.
  3. Select Navigate to URL. An additional section appears in the dialog box for this option.
  4. In Target URL TextBox, type a URL or an expression that evaluates to a URL.
  5. Click OK.
  6. To test the link, run the report and click the report item with the applied Action. For TextBoxes, it is helpful to change the color and effect of the text to indicate that the text is a link. For example, change the color to blue and the effect to underline by setting the corresponding Font properties of the TextBox.

Adding a Hyperlink action programatically

CopyC#
Telerik.Reporting.NavigateToUrlAction UrlAction1 = new Telerik.Reporting.NavigateToUrlAction();
UrlAction1.Url = "http://demos.telerik.com/reporting";
textBox1.Action = UrlAction1;
CopyVB.NET
Dim UrlAction1 As New Telerik.Reporting.NavigateToUrlAction()
UrlAction1.Url = "http://demos.telerik.com/reporting"
textBox1.Action = UrlAction1

See Also

Other Resources

How to: Add a Drillthrough Report Action
How to: Add a Bookmark Action
Add Interactivity
Expressions
Data Items


How to: Add a Drilldown Action

[image]

Telerik Reporting Q2 2012
How to: Add a Drilldown Action
See Also Send Feedback

A report item can initially display or be hidden when a user views a report. The toggle action applied on the report item that allows you to hide and display items interactively is known as drilldown action.

Adding a drilldown action to a report item using the Report Designer

  1. In Design view, right-click a report item to which you want to add a toggle visibility action and then click Properties.
  2. In the item's Properties dialog box, click Action.
  3. Select Toggle Visibility. Additional sections appear in the dialog box for this option.
  4. Click Edit toggle targets button, which opens Edit toggle Visibility targets dialog.
  5. Click New button to add a new toggle action. Select a report item from the combobox to set it as toggle target, which visibility will be toggled when the action is triggered.
  6. To add more toggle targets, repeat steps 4 and 5.
  7. The Toggle mark initially expanded checkbox determines if the item exposing the action will be rendered initially with expanded or with collapsed mark.
  8. To test the toggle, run the report and click the text box with the toggle mark. The report display refreshes to show report items with their toggled visibility.
Note

The report item must be in the same container hierarchy or higher (up to the report itself).

Adding a drilldown action to a Table, CrossTab or ListBox group using the Report Designer

  1. In Design view, click the Table, CrossTab or ListBox to select it. The Group Explorer displays the row and column groups.
  2. Locate the Display Mode combo in the title bar of the Group Explorer and select Extended Mode. This toggles to show the underlying display structure for rows and columns.
  3. Right-click the name of the row group or column group for which you want to hide the associated rows or columns and select Group Properties.
  4. Alter the Visible property to indicate whether the group is displayed initially expanded or collapsed (default is expanded). Click OK.
  5. In Design view, right-click the report item representing the row group or column group to which you want to add a toggle visibility action and then click Properties.
  6. In the item's Properties dialog box, click Action.
  7. Select Toggle Visibility. Additional sections appear in the dialog box for this option.
  8. Click Edit toggle targets button, which opens Edit toggle Visibility targets dialog.
  9. Click New button to add a new toggle action. Select a row group or column group from the combobox to set it as toggle target, which visibility will be toggled when the action is triggered.
  10. To add more toggle targets, repeat steps 8 and 9.
  11. The Toggle mark initially expanded checkbox determines if the item exposing the action will be rendered initially with expanded or with collapsed mark.
  12. To test the toggle, run the report and click the text box with the toggle mark. The report display refreshes to show report items with their toggled visibility.
Note

The report item must either be in the same group as the item that is being hidden or in an ancestor group.

Adding a drilldown action programatically

CopyC#
Telerik.Reporting.ToggleVisibilityAction toggleVisibilityAction1 = new Telerik.Reporting.ToggleVisibilityAction();
textBox1.Action = toggleVisibilityAction1;
toggleVisibilityAction1.DisplayExpandedMark = false;
toggleVisibilityAction1.Targets.AddRange(new Telerik.Reporting.IToggleVisibilityTarget[] { textBox2 });
CopyVB.NET
Dim toggleVisibilityAction1 As New Telerik.Reporting.ToggleVisibilityAction()
textBox1.Action = toggleVisibilityAction1
toggleVisibilityAction1.DisplayExpandedMark = False
toggleVisibilityAction1.Targets.AddRange(New Telerik.Reporting.IToggleVisibilityTarget() {textBox2})

See Also

Reference

ToggleVisibilityAction

Other Resources

Adding Interactivity to Reports
Drilldown Report Action
Drillthrough Report Action
How to: Add a Drillthrough Report Action


Document Map

[image]

Telerik Reporting Q2 2012
Document Map
Send Feedback

A document map provides a set of navigational links to report items in the rendered report. A user can click links in the document map to jump to the report page that displays that item.

The Document map is defined by setting the DocumentMapText and BookmarkId properties of any report item/group. The BookmarkID property should be unique for the whole IReportDocument. If BookmarkID is not set, then the Value of DocumentMapText is taken into account. Valid values are static text, expression, or text with embedded expressions. The resulting text will be displayed in the document map tree.

To form hierarchical structure of the document map, you may set the DocumentMapText property of the report groups, the CrossTab/Table groups, the Detail section and the Report (useful for SubReports). For example nested groups will create nested nodes in the tree. Each of the produced nodes will navigate to the most appropriate page and location in the rendered report. For example bookmark of a report group will navigate to the group header (or first detail inside the group if header is not visible).

To add a node in the document map pointing to a report item, you may use the DocumentMapText property of that item. Note that all report items (except the Detail section and the Report itself) produce leaf nodes in the document map tree. For example if you have a Panel item with TextBox item inside, and set the DocumentMapText property of both, the resulting nodes will be added as leaf siblings in the document map.

The order of items in the document map is according to the order of the report items in the report items' collection, and not by the order in which you have added DocumentMapText to items.

Note

The document map is intended for use in the Designer Preview and in all ReportViewers. From the supported rendering extensions, only the PDF renders a document map as Bookmarks pane. All other rendering extensions ignore document maps.

In This Section

  • How to: Add a Report Item to Document Map
  • How to: Add a Report group to Document Map
  • How to: Add a Table group to Document Map


How to: Add a Report Item to Document Map

[image]

Telerik Reporting Q2 2012
How to: Add a Report Item to Document Map
See Also Send Feedback

You can add a document map, which acts like a table of contents. A user can click items in the document map to jump to areas within a report.

Adding a report item to document map

  1. In Design view, make sure the Properties pane is visible. Select the report item that you want to add to the document map. In the Properties pane, type the text that you want to appear in the document map in the DocumentMapText property, or enter an expression that evaluates to a text. For example, type Product Catalog. If the DocumentMapText does not evaluate to unique value, then a unique value should be set to the BookmarkId property.

  2. Repeat step 1 for every report item that you want to appear in the document map.

  3. Click Preview. The report runs and the document map displays the text you created. Click any link to jump to the report page and the exact location of that item.

Hiding the document map when you view a report

You can run the report without initially displaying the document map by setting the ReportViewer.DocumentMapVisible property to false (true by default), and then click the Show/Hide button on the report viewer toolbar to toggle its display whenever needed.

If you want to restrict the user from showing/hiding the document map, you can hide the corresponding button by altering the viewer's ShowDocumentMapButton (true by default) property.

Note

The order of items in the document map is according to the order of the report items in the report items' collection, and not by the order in which you have added DocumentMapText to items.

See Also

Other Resources

Document Map
How to: Add a Report group to Document Map
How to: Add a Table group to Document Map


How to: Add a Report group to Document Map

[image]

Telerik Reporting Q2 2012
How to: Add a Report group to Document Map
See Also Send Feedback

You can add a document map, which acts like a table of contents. A user can click items in the document map to jump to areas within a report.

Adding a Report group to document map

  1. In Design view, right click outside the report sections, select View and open up the Group Explorer.
  2. Select a report group to which you want to add a document map. The properties for the selected group appear in the Properties pane.
  3. In the DocumentMapText property, type the text that you want to appear in the document map. Alternatively, click the ellipsis to open the Expression dialog box to specify an expression that evaluates to a text. Typically for a group, the expression you type should match the group expression.
  4. Click OK.
  5. Repeat steps 1-4 for every group that you want to appear in the document map.
  6. Run the report - the document map displays the group values. Click any document map node to jump to the report page with that item.

See Also

Other Resources

Document Map
How to: Add a Report Item to Document Map
How to: Add a Table group to Document Map


How to: Add a Table group to Document Map

[image]

Telerik Reporting Q2 2012
How to: Add a Table group to Document Map
See Also Send Feedback

You can add a document map, which acts like a table of contents. A user can click items in the document map to jump to areas within a report.

Adding a Table group to document map

  1. In Design view, right click outside the report sections, select View and open up the Group Explorer.
  2. Select a Table, Crosstab or List report item, so the Group Explorer shows the respective groups.
  3. Select a group to which you want to add a document map, right click on it and select Group Properties. The properties for the selected group appear in the Edit Table Group dialog.
  4. In the DocumentMapText property, type the text that you want to appear in the document map. Alternatively, click the ellipsis to open the Expression dialog box to specify an expression that evaluates to a text. Typically for a group, the expression you type should match the group expression.
  5. Click OK.
  6. Repeat steps 1-4 for every group that you want to appear in the document map.
  7. Run the report - the document map displays the group values. Click any document map node to jump to the report page with that item.

See Also

Other Resources

Document Map
How to: Add a Report Item to Document Map
How to: Add a Report group to Document Map


Styling Reports

[image]

Telerik Reporting Q2 2012
Styling Reports
Send Feedback

This section discusses all the aspects of a report styling:

  • Style Inheritance and Overriding
  • Using Styles to Customize Reports
  • Exporting and Reusing Style Sheets
  • Understanding Style Selectors
  • Creating Style Rules
  • Styling Using the Context Menu
  • Conditional Formatting


Using Styles to Customize Reports

[image]

Telerik Reporting Q2 2012
Using Styles to Customize Reports
See Also Send Feedback

Telerik Reporting uses a built-in styling model that is similar to CSS. The model provides for very fine-grained visual customization of all elements of a report directly in the Visual Studio designer. This CSS-like mechanism offers full control over such things as the background, colors, borders, and images for every item on your report. You can assign styles by using CSS selectors such as Type, Attribute, Style, and Descendent.

Creating a Style Sheet for a Report

To create a style sheet for a report, follow these steps:

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, click the ellipsis button to open the StyleRule Collection Editor.
  4. Click Add to add a new StyleRule.
  5. Expand the Style property and customize your new StyleRule. For example, the screenshot below shows a StyleRule that specifies a yellow background, blue text, and bold Times New Roman font.

  6. Click in the Selectors property, click the ellipsis button to open the TypeSelector Collection Editor.
  7. Click the drop-down arrow on the Add button and select the type of selector to add. See the type of selectors in Understanding Style Selectors.
  8. Use the properties area of the TypeSelector Collection Editor to customize the new selector. For example, the screenshot below shows a StyleSelector named DataField which applies to TextBox report items only.

  9. Click OK when you are done adding selectors for the current StyleRule.
  10. Click OK when you are done adding StyleRules for the report's StyleSheet.

Assigning Styles to Report Items

Telerik Reporting will automatically apply styles that use TypeSelectors, AttributeSelectors, or DescendantSelectors to the appropriate report items. For example, if you add a style to the report's StyleSheet with a TypeSelector of Telerik.Reporting.TextBox, that style will be inherited by all text box report items on the report.

To apply a style that uses a StyleSelector to a report item, select the report item and set its StyleName property to the StyleName property of the StyleSelector.

See Also

Other Resources

Understanding Style Selectors
Creating Style Rules
Exporting and Reusing Style Sheets


Understanding Style Selectors
See Also Send Feedback

Style Selectors are used to define how a style will be applied globally to items in a report. Each Style Rule that you create (either in code or using the StyleRule Collection Editor) must be created as one of the following four selectors:

  • TypeSelector
  • AttributeSelector
  • StyleSelector
  • DescendantSelector

Understanding Style Selectors

TypeSelector

A TypeSelector applies to all report items of a particular type, for example a Telerik.Reporting.TextBox or a Telerik.Reporting.PageFooterSection.

When a style is defined as a TypeSelector, the formatting for that style is automatically applied to all items on the report that match the type.

AttributeSelector

An AttributeSelector applies to all report items with a particular attribute (such as Color=Red).

Using an AttributeSelector Style Rule, you could specify that any report item on the report that has children (for example. where the value of the HasChildren property is equal to True) should be Bold.

StyleSelector

A StyleSelector applies to all report items with a particular style name. When defining a StyleSelector style, use the Name property to create a name for the style. Each report item has a StyleName property. By setting the value of StyleName to the name of the StyleSelector Style Rule, that report item will display the attributes of the named style.

DescendantSelector

A DescendantSelector applies to all parent/child report item combinations. The actual Style Rule for the child can be specified by any type of Selector.

For example, you can specify that any TextBox that exists inside of a ReportHeaderSection should have a particular style using a TypeSelector within the DescendantSelector.

Alternatively, you can create multiple StyleSelector Style Rules with the same Name and that descend from different report item types, such as DetailSection or GroupSection. Report items with this Name value in their StyleName property will apply the correct style based on where they are placed in the report , even if they are moved.

See Also

Other Resources

Using Styles to Customize Reports
Creating Style Rules


Creating Style Rules

[image]

Telerik Reporting Q2 2012
Creating Style Rules
Send Feedback

Style definitions can be stored in a Style Rule. Style Rules can be created in the designer or in code.

Style Rules are defined as one of the following four types:

  • A TypeSelector applies to all report items of a particular type.
  • An AttributeSelector applies to all report items with a particular attribute (such as Color=Red).
  • A StyleSelector applies to all report items with a particular style name.
  • A DescendantSelector applies to all report items descended from another report item, which in turn can be specified by any type of selector.

See Understanding Style Selectors for more information about the types of Style Rules.

Creating Rules Using the StyleRule Collection Editor

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, and then click the ellipsis button to open the StyleRule Collection Editor.

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.

  2. Click the Selectors property, then click the ellipsis button that appears to the right of (Collection). This action will open TypeSelector Collection Editor.
  3. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  4. Click TypeSelector from the list. Note: TypeSelector is the default type created when you click the Add button.

  5. Click the Type property of the new TypeSelector, and then click the ellipsis button.

  6. Select the Telerik.Reporting.TextBox and click OK. The StyleRule will now apply to all TextBox report items on the report.
  7. Click the plus sign next to Style to expand the Style properties.
  8. Modify any properties you wish to define formatting to be applied to the TextBox report item.
  9. Click OK to save the rules and close the editor window.

Creating a TypeSelector StyleRule in Code

The following code demonstrates the four steps required to create a TypeSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Add a TypeSelector to the StyleRule and define the type as Telerik.Reporting.TextBox.
  3. Apply some formatting rules to the StyleRule.
  4. Add the StyleRule to the Style Sheet.
CopyC#
//Create a StyleRule
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
//Add a TypeSelector
myStyleRule.Selectors.AddRange(new Telerik.Reporting.Drawing.ISelector[]
    {new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.TextBox))});
//Add formatting
myStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen;
myStyleRule.Style.Color = System.Drawing.Color.DodgerBlue;
myStyleRule.Style.Font.Name = "Courier New";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});
CopyVB.NET
'Create a StyleRule
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
'Add a TypeSelector
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.TextBox))})
'Add formatting
MyStyleRule.Style.BackgroundColor = System.Drawing.Color.LinenMyStyleRule.Style.Color = System.Drawing.Color.DodgerBlue
MyStyleRule.Style.Font.Name = "Courier New"
'Add rule to Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.
  2. Click the Selectors property, and then click the ellipsis button to open the TypeSelector Collection Editor window.
  3. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  4. Click StyleSelector from the list.
  5. Type a name for the Style into the StyleName property.

  6. Click OK to return to the StyleRule Collection Editor.
  7. Expand the Style property and modify the formatting properties as desired.
  8. When finished, click OK to close the StyleRule Collection Editor.

Creating a StyleSelector StyleRule in Code

The following code demonstrates the four steps required to create a StyleSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Add a TypeSelector to the StyleRule and give it a StyleName, such as CaptionStyle.
  3. Apply some formatting rules to the StyleRule.
  4. Add the StyleRule to the Style Sheet.
CopyC#
//Create a StyleRule
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
//Add a StyleSelector
myStyleRule.Selectors.AddRange(new Telerik.Reporting.Drawing.ISelector[] {new Telerik.Reporting.Drawing.StyleSelector("CaptionStyle")});
//Add formatting
myStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen;
myStyleRule.Style.Color = System.Drawing.Color.DodgerBlue;
myStyleRule.Style.Font.Name = "Courier New";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});
CopyVB.NET
'Create a StyleRule
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
'Add a StyleSelector
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.StyleSelector("CaptionStyle")})
'Add(formatting)
MyStyleRule.Style.BackgroundColor = System.Drawing.Color.Linen
MyStyleRule.Style.Color = System.Drawing.Color.DodgerBlue
MyStyleRule.Style.Font.Name = "Courier New"

'Add rule to Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})

Applying StyleSelector StyleRules

Each report item has a StyleName property.

Type the StyleName of the desired StyleRule into the report item's StyleName property to apply the formatting of the StyleRule.

Using the StyleRule Collection Editor

  1. In the StyleRule Collection Editor, click Add. A new rule will be added to the Members list and you will see the Selectors and Style properties for the rule.
  2. Click the Selectors property, and then click the ellipsis button to open the TypeSelector Collection Editor window.
  3. Click the drop-down arrow on the Add button to choose the type of Selector to create.
  4. Click DescendantSelector from the list.

    The DescendantSelector is made up of additional Selectors.

  5. Click the Selectors property, and then click the ellipsis button to open up a new TypeSelector Collection Editor window.

    In this new TypeSelector Collection Editor window, you will define the Selectors that make up the DescendantSelector.

  6. Click Add to add a new TypeSelector.
  7. Click Type, and then click the ellipsis button to open up the Select Type dialog.
  8. Select the Telerik.Reporting.DetailSection type.
  9. Add another new TypeSelector and set its type to Telerik.Reporting.TextBox.

  10. Click OK to close the window and return to the TypeSelector Collection Editor window for the DescendantSelector.
  11. Click OK to close this window and return to the StyleRule Collection Editor window.

  12. Expand the Style property to define the formatting for the DetailSection TextBox StyleRule.
  13. Click OK when complete.

Creating a DescendantSelector StyleRule in Code

The following code demonstrates the four steps required to create a DescendantSelector StyleRule programmatically:

  1. Create a new StyleRule called MyStyleRule.
  2. Create a new DescendantSelector.
  3. Add Selectors to the DescendantSelectors. If you are using TypeSelectors, define the types too.
  4. Add a TypeSelector to the StyleRule and give it a StyleName, such as CaptionStyle.
  5. Apply some formatting rules to the StyleRule.
  6. Add the StyleRule to the Style Sheet.
CopyC#
//Create StyleRule and DescendantSelector
Telerik.Reporting.Drawing.StyleRule myStyleRule = new Telerik.Reporting.Drawing.StyleRule();
Telerik.Reporting.Drawing.DescendantSelector myDescendantSelector = new Telerik.Reporting.Drawing.DescendantSelector();
//Define the Selectors and Types of the DescendantSelector
myDescendantSelector.Selectors.AddRange(
    new Telerik.Reporting.Drawing.ISelector[]
    { new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.ReportHeaderSection)),
        new Telerik.Reporting.Drawing.TypeSelector(typeof(Telerik.Reporting.TextBox))
    });
//Add the DescendantSelector to the StyleRule
myStyleRule.Selectors.AddRange(
    new Telerik.Reporting.Drawing.ISelector[]
    {
    myDescendantSelector
    });
//Apply Formatting
myStyleRule.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Ridge;
myStyleRule.Style.Color = System.Drawing.Color.Navy;
myStyleRule.Style.Font.Name = "Arial";
//Add rule to Style Sheet
this.StyleSheet.AddRange(new Telerik.Reporting.Drawing.StyleRule[] {myStyleRule});
CopyVB.NET
'Create StyleRule and DescendantSelector
Dim MyStyleRule As Telerik.Reporting.Drawing.StyleRule = New Telerik.Reporting.Drawing.StyleRule
Dim MyDescendantSelector As Telerik.Reporting.Drawing.DescendantSelector = _
New Telerik.Reporting.Drawing.DescendantSelector
'Define the Selectors and Types of the DescendantSelector
MyDescendantSelector.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() _
{New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.ReportHeaderSection)), _
New Telerik.Reporting.Drawing.TypeSelector(GetType(Telerik.Reporting.TextBox))})
'Add the DescendantSelector to the StyleRule
MyStyleRule.Selectors.AddRange(New Telerik.Reporting.Drawing.ISelector() {DescendantSelector1})
'Apply formatting
MyStyleRule.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Ridge
MyStyleRule.Style.Color = System.Drawing.Color.Navy
MyStyleRule.Style.Font.Name = "Arial"
'Add the StyleRule to the Style Sheet
Me.StyleSheet.AddRange(New Telerik.Reporting.Drawing.StyleRule() {MyStyleRule})


Style Inheritance and Overriding

[image]

Telerik Reporting Q2 2012
Style Inheritance and Overriding
Send Feedback

Telerik Reporting Styling is similar to CSS (Cascading Style Sheets), of which many web developers are familiar.

Styles can be defined globally using the StyleRules. They can be inherited from parent report items. They can also be explicitly defined in a report item's Style properties.

General Inheritance Rules

Child report items placed within another report item always derive their styling based on the following precedence:

Lowest Priority - Parent: If the parent control has a Style applied, then the child will inherit the parent's styling. This will be over-ruled by the higher priorities.

Second Priority - Global: If any of the global styles apply to the child (eg. the child is a TextBox and there is a TypeSelector rule for TextBox report items) then the control will use this styling. Parent styling will be ignored in this case.

Highest Priority - Inline: If the child control's Style properties have been changed from their defaults, then these properties will be honored with the highest priority. In this case, the the Global styling and the style of the parent will be ignored.

Global Styles and Precedence

Styles defined with Style Rules will be applied globally in a report based on the definition of the Style Rule. A Style Rule can be defined by using one of the Style Selectors.

The Style Sectors have the following precedence:

  • DescendantSelector
  • TypeSelector
  • AttributeSelector
  • StyleSelector
where the order is from bottom to top. This means that a StyleSelector has precedence over the other Selectors.

By default the order of the Style Rules in the collection determines how styles are applied and the order is from bottom (last) to top (first). Exception from this rule is the TypeSelector where the more specific the rule is, the higher precedence it has. For example a Style Rule for a TextBox will have precedence over a style rule for ReportItemBase despite their order in the style sheet.

If several rules match the same Selectors, the last Style Rule has precedence.

Inheriting from Global Styles

Report items placed within a report item that is styled using one of the Global Styles will inherit the Font, Vertical Alignment, and Horizontal alignment of the parent.

Overriding Global Styles

You can override a GlobalStyle by modifying the Style properties of an individual report item. Select the report item and either click the ellipsis of the Style property or right click and select the Style... option. These open the Edit Style dialog box, which allows you to edit the various properties that can be set through the style sheet. Any changes you make through the Edit Style dialog box override settings made through the report's StyleSheet property.

Resetting Global Styles

If you have overridden a style using a report item's Style properties, it is possible to reset the report item to its Global Style.

  1. Right-click the report item to open its context menu.
  2. Click Reset Style.


Exporting and Reusing Style Sheets

[image]

Telerik Reporting Q2 2012
Exporting and Reusing Style Sheets
Send Feedback

Styles created in a report can be exported and then used in other reports. You can store one or more Styles in an exported file. The exported information is stored in an XML file.

Export a Style Sheet

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the StyleSheet property, and then click the ellipsis button to open the StyleRule Collection Editor.
  4. Select one or more of the styles in the Members box on the left. Use Windows keyboard combinations to select more than one style.

  5. Click the Export button. This will open the Save As dialog box.
  6. Enter a name for the exported file and click Save to complete the task.

Use an Exported Style Sheet in Another Report

  1. Open the report in design view.
  2. Select the Report object.
  3. Click in the External Styles property, and then click the ellipsis button to open the Collection Editor.
  4. Click the Add icon in the upper left corner of the Collection Editor window. This will open a File Open dialog. You will be located in the current project's root directory.
  5. Browse to, and then select, the exported Style Sheet. Click Open. This action will return you to the Collection Editor window.
  6. When you are finished adding Style Sheets, click OK.

Styles that are defined by TypeSelectors or AttributeSelectors will be automatically formatted. To use styles defined by StyleSelectors, change the StyleName property of the desired report item to the appropriate style names that exist in the Style Sheets that you added.

External Style Sheet Location Kinds

There are three ways in which an external style sheet can be located:

  • Absolute Path/URL such as C:\Application1\StyleSheets\StyleSheet1.xml or
  • Relative Path/URL such as .\StyleSheets\StyleSheet1.xml or ~/StyleSheets/StyleSheet1.xml
  • Resource Name such as Application1.Resources.StyleSheet1.xml

When you add a new external style sheet to the collection it will be recorded via Relative or Absolute path depending on the file's location. If the file that you chose is located inside the current project root directory the style sheet will be recorded via relative path, otherwise it will be recorded via absolute path. Later you can change the way it is serialized by changing its location kind from the combo box next to its name.

Absolute Path/URL

The external style sheet file does not have to be a part of the project since it is referenced absolutely.

Relative Path/URL

When an external style sheet is referenced relatively the path is relative to the hosting application root folder. The project item representing the style sheet file should have its "Copy to Output Directory"="Copy Always". When you use the Collection Editor, a project item for the style sheet file will be created automatically, if it does not exists, and it will be moved to a folder named "StyleSheets" under the project root and its "Copy to Output Directory" property will be adjusted automatically as well.

Note

For Windows Forms projects, the root folder is the location of the executable file (by default bin folder). In Web applications the root folder is the root of the application. In this case the stylesheets should be copied to the root of the Web application as well.

Resource Name

You can reference an external style sheet as an embedded resource by its name. The name should be the case-sensitive name of the manifest resource being requested. The project item representing the style sheet file should have its "Build Action"="Embedded Resource". When you use the Collection Editor, a project item for the style sheet file will be created automatically, if it does not exists, it will be moved to a folder named "Resources" under the project root and its "Build Action" property will be adjusted automatically as well. In the end the generated name will look something like MyApplication1.Resources.StyleSheet1.xml, where MyApplication1 is the default project namespace and the file is located in the folder Resources.

Note

Specifying an URL for the external style sheet can be done only programmatically. It is not supported directly from the Collection Editor.


Styling Using the Context Menu

[image]

Telerik Reporting Q2 2012
Styling Using the Context Menu
See Also Send Feedback

The context menu for a report's report item allows you to modify styles easily.

Right-clicking on a report item opens the following context menu:

Style...

The Style... option will open the Edit style dialog so that you can make changes to the formatting of the report item.

Copy Style

Copy Style will place the details of the report item's style into the clipboard.

Paste Style

Paste Style will apply the style that was copied using Copy Style. Note that the style will be applied as an Inline style, regardless of the source. This means that the report item's style properties will be modified to match the source control.

Reset Style

If a report item's style properties were modified, clicking Reset Style will remove Inline styling and reset the report item to use either the parent report item's style or any Global styling that was applied with StyleSelectors. See Style Inheritance and Overriding for more information.

See Also

Other Resources

Style Inheritance and Overriding
Understanding Style Selectors


Conditional Formatting

[image]

Telerik Reporting Q2 2012
Conditional Formatting
Send Feedback

Conditional formatting lets you dynamically style report items based on rules that you define in the Conditional Formatting Rules Dialog. This lets you change the visual appearance of the report based on changing conditions in the report without the need for coding events. Conditional formatting applies to any report item including sections and the report itself, all using the same Conditional Formatting Rules Dialog user interface. See also the Extending the Simple Report Design Quickstart Quickstart for a walkthrough demonstration of the conditional formatting feature.

The ConditionalFormatting property contains a collection of formatting rules that are evaluated in the order they are defined. Each rule has an associated style that lets you change styling characteristics when the rule is satisfied. You can choose to stop evaluating rules if a particular rule condition is met.

Each filter condition is made up of an Expression, Operator and Value. The Expression can be a data field from the Fields collection or defined using the Edit Expression Dialog. Operator can be simple comparison operators but can also include Like and additional operators to include the top and bottom number of records and the top and bottom percentage of records. See the table of operators below. Value can a literal value, "<blank>" or an expression defined in the Edit Expression Dialog. When all the filter conditions are met, the rule is fired and the style is applied.

You can change the Text, Background, Edges and Line Style for the given item using the Style Builder dialog.


Rendering and Paging

[image]

Telerik Reporting Q2 2012
Rendering and Paging
See Also Send Feedback

Telerik Reporting includes a set of rendering extensions (also referred to as renderers) for exporting reports to different formats. Each renderer applies set of rules when rendering reports. When exporting a report to file formats such as PDF which uses pagination based on physical page size, you might need to alter the layout of the report, so the exported report looks and prints correctly after the rules for the specific rendering extension are applied.

Getting satisfactory results for exported reports is often a continuous and repetative process; you create and preview the report in Report Designer, export the report to the preferred format, review the exported report, and then make changes to the report back in the Report Designer.

Rendering extensions

Telerik Reporting includes a set of renderers that you can use to export reports to different formats. There are three types of renderers:

  • Data layout: CSV.
  • Logical page layout: MHTML and Excel (XLS(X)) formats and report viewer in Interactive view.
  • Physical page layout: IMAGE, PDF, RTF, XPS, PPTX, DOCX formats and report viewer in Print Preview.

The HTML, XAML and IMAGE/EMF rendering extensions are intended for internal use by the respective report viewers.

Rendering Behaviors

Depending on the renderer you select, certain rules are applied when rendering the report. How report items fit together on a page is determined by the combination of these factors:

  • Rendering rules.
  • The width and height of report items.
  • The size of the report.
  • The width and height of the page.
  • Renderer-specific support for paging.

For example, reports rendered to HTML and MHTML formats are optimized for a computer screen-based experience where pages can be various lengths. For more information, see Understanding Rendering Behaviors.

Pagination

Pagination refers to the number of pages within a report and how report items are arranged on these pages. Pagination varies depending on the used renderer, page break and keep-together options you configure the report to use.

A successfully designed report that is optimized for the renderer that you plan to use to deliver your report, requires understanding of the rules used to control pagination. Reports exported by using the data and logical rendering extensions are typically not affected by pagination. When you use a logical rendering extension such as the HTML rendering extension, you might want to know how the report looks printed and also how well it renders using a physical page renderer such as PDF. You can use the Preview in the Report Designer and export the report to easily get an idea how the report looks in the different layouts.

The physical page renderers impact the report layout and physical page size most. To learn more, see Understanding Pagination.

See Also

Other Resources

Understanding Rendering Behaviors
Understanding Pagination
Design Considerations for Report Rendering


Understanding Rendering Behaviors

[image]

Telerik Reporting Q2 2012
Understanding Rendering Behaviors
See Also Send Feedback

Depending on the renderer you select, certain rules are applied when rendering the report. How report items fit together on a page is determined by the combination of these factors:

  • Rendering rules.
  • The width and height of report items.
  • The size of the report.
  • The width and height of the page.
  • Renderer-specific support for paging.

This topic discusses the general rules that are applied by Telerik Reporting. For more information, see Design Considerations for Report Item Layout.

This topic contains the following sections.

  • General Behaviors for MHTML, and Excel (Logical Page Renderers)
  • General Behaviors for PDF, Image, HTML and Print (Physical Page Renderers)
  • Page Header and Footer sections
  • See Also

General Behaviors for MHTML, and Excel (Logical Page Renderers)

Reports exported using HTML, MHTML and Excel formats are optimized for a computer screen-based experience where pages can be various lengths. To determine how a report will appear in a logical page renderer, use Interactive View or any of the report viewers. The report will appear as it would in a HTML, MHTML, or Excel format.

When exporting a report to HTML, MHTML, or Excel, the following rules are followed:

  • The page breaks that you explicitly insert, are applied to report items. For example, if you insert a page break between each group, they are applied when the report is rendered.
  • Report pages can grow to accommodate any report items that need to be kept together. This means that the report can extend beyond the screen width and can be viewed by using slider bars.
  • Pagination is applied to reports vertically only.
  • Page margins are not applied.

General Behaviors for PDF, Image, HTML and Print (Physical Page Renderers)

Reports exported using PDF and Image are optimized for a book-like or printed experience where pages are a consistent size. Page breaks are inserted vertically and horizontally at specific locations within the report. These specific locations are determined by the page width and page height settings.

Note

To determine how a report will appear in a physical page renderer, switch to Print Preview in any of the report viewers. The report appears as it would in PDF or Image formats.

When exporting a report to Image, PDF, RTF, XPS, Powerpoint, and Word, the following general rules are followed:

  • Pages are rendered sequentially from left to right, then top to bottom. (when horizontal paging occurs)
  • Explicitly set page breaks can cause report items to push other items to the next page.
  • If a page break occurs through report items that must be kept together (e.g. placed in a Panel), the items that must be kept together are moved to the next page.
  • If an item cannot be kept together, for example a text box that grows too large to fit within the vertical usable page area, then the item will be clipped at the physical page boundary and will continue on the next page.
  • Pagination is applied to reports vertically and horizontally.

Page Header and Footer sections

The following rules apply to page headers and footers when rendered in Logical page rendering format:

  • The header and footer is rendered at the top and bottom of every page within the usable page area (when present).
  • When the page header or footer section is hidden on certain pages, its height is still reserved within the usable page area, even though the page section is not rendered.
  • If the contents of the page header or footer sections grows beyond their boundaries, they increase in size to accommodate the contents.

The following rules apply to page headers and footers when rendered in Physical page rendering format:

  • The header or footer is rendered at the top and bottom of every page within the usable page area.
  • When the page header or footer section is hidden on certain pages, its height is still reserved within the usable page area, even though the page section is not rendered.
  • The header and footer do not grow or shrink. They are rendered on every page at the height specified when you created the respective page section.
  • If the contents of the header or footer grow beyond the boundaries of the header or footer, the contents are clipped.
  • Page sections of report used as SubReport are not rendered. Only page sections of the main report are rendered.
  • In multi-column reports, there is only one page header and footer per page, regardless of the number of columns.

See Also

Other Resources

Rendering and Paging
Design Considerations for Report Rendering
Understanding Pagination


Understanding Pagination

[image]

Telerik Reporting Q2 2012
Understanding Pagination
See Also Send Feedback

Pagination refers to the number of pages within a report and how report items are arranged on these pages. Pagination varies depending on the used renderer, page break and keep-together options you configure the report to use.

A successfully designed report that is optimized for the renderer that you plan to use to deliver your report, requires understanding of the rules used to control pagination.

This topic discusses the impact of the physical page size and the report layout on how page break renderers render the report.

Page Setup

When you render a report you can specify page setup options at run-time or design-time. Some of these options can be changed by the user using the Page Setup dialog. Page setup options apply to all report output types.

Page Settings

The PageSettings property of the Report object allows you to customize the following properties:

Property | Description
Landscape | True to print in landscape orientation, False to print in portrait orientation.
Margins | A Telerik.Reporting.Drawing.MarginsU object, which lets you individually specify the margins at the four sides of the report.
PaperKind | The type of paper to print the report on, such as Letter, Legal, A3, or A4. Setting this automatically sets the correct dimensions in the PaperSize property.
PaperSize | If the Paper Kind is "Custom" you can specify a non-standard set of paper dimensions.
Watermarks | Typically used to designate a document's status e.g. draft or for internal distribution only. They are commingled with the report content, making them next to impossible to ignore.

Physical Page

The physical page size is the paper size. The paper size that you specify for the report controls how the report is rendered. Reports rendered in physical page formats insert page breaks horizontally and vertically based on the physical page size to provide an optimized reading experience when printed or viewed in a physical page format. Reports rendered in logical page formats insert page breaks horizontally based on the physical size to provide an optimized reading experience when viewed in a Web browser.

You can change page size by changing the PaperSize.Height and PaperSize.Width properties in the Properties pane. The page size does not grow or shrink to accommodate the contents of the report. If you want the report to appear on a single page, the whole report content must fit on the physical page. If it does not fit and you use physical page format, the report will occupy additional pages. If the report grows past the right edge of the physical page, then a page break is inserted horizontally. If the report body grows past the bottom edge of the physical page, then a page break is inserted vertically.

Margins

Margins are specified by changing the Top, Bottom, Left and Right properties in the Properties pane. The area of the physical page that remains after space is allocated for margins, column spacing (multi-column), and the page header and footer, is referred to as usable page area. Margins are only applied when you render and print reports in physical page formats.

Paging and Keep Together

Based on report content and page settings the report is divided into one or more pages. The actual report content is rendered on a page after margins are subtracted from the page size.

If the report body cannot fit in the available page width, a new page will be added in order to accommodate all content. At design-time, a vertical red line will appear to indicate the available width. Make sure report sections and items do not cross this boundary if you do not want them to be split across different pages.

Caution

If every other page in a report seems to be blank, the most probable reason is that a report item is stretching over the right page margin (appears over the vertical red line in report designer) and in case it has no background or border, you will not be able to detect it, but it is still there and is causing a new page to be created.

In the vertical direction, by default sections are not split across different pages, unless their KeepTogether property is set to false. If you want to force a page break before or after a section, use the section’s PageBreak property.

Simple report items (i.e. non-container items) are always kept together on a page if possible. If not, they are rendered at the beginning of the next page. If they still cannot fit, because they are longer than a whole page, they are split. The PictureBox, Shape and Chart items are always kept together.

By default groups are not kept together on a single page. You can instruct the rendering engine to try to keep the entire group or the group header with the first detail on a single page if possible by setting the GroupKeepTogether property of the Group component.

Note

If the content that should be kept together is too large to fit on a single page, it is not moved and is left on the current page, forcing the rest of the content to move to next page, as if KeepTogether is false.

Example: Report group has GroupKeepTogether=FirstDetail, this means that the summary height of the group header, height of all child group headers (if any) and height of the first detail should be able to fit on a single page in order for the KeepTogether algorithm to work and move the whole Group on a new page.

If the report spans over several pages in width then its sections are stretched from the left edge of the left-most page’s printable area to the right edge of the right-most page’s printable area, as displayed in the following diagram:

Report sections

Report sections can grow or shrink to accommodate the report items contained within. They do not reflect the physical page size and can grow beyond the boundaries of the physical page size to span multiple report pages. Some renderers, such as HTML and MHTML render reports that grow or shrink depending on the contents of the page. Reports rendered in these formats are optimized for screen-based viewing in a Web browser. These renderers add vertical page breaks when required.

See Also

Other Resources

Rendering and Paging
Design Considerations for Report Rendering
Understanding Rendering Behaviors


Watermarks

[image]

Telerik Reporting Q2 2012
Watermarks
Send Feedback

Watermarks are text or pictures that appear commingled with the report content. They often add interest or identify status, such as marking a generated report as a Draft. You can see watermarks in Print Preview Layout of the report viewers and when printing or exporting. You have the ability to set the Opacity of the text or image, specify its Position and whether it is displayed on first (PrintOnFirstPage) and last page (PrintOnLastPage).

Add Text Watermark

Add Text Watermark using Report Designer

To add Text Watermarks to the Report use the following steps:

  1. Open a report in Design view.
  2. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window.
  3. Expand PageSettings and click Watermarks ellipsis in the property grid. This displays the Watermarks collection. By default, the collection is empty.
  4. Click Add button and select TextWatermark.
  5. In Text, type or click the ellipsis to enter text or an Expressions that represents the Text Watermark.
  6. Format the text by setting Color and Font attributes.
  7. Set Opacity.
  8. Set Position. Available options are Behind and Front. Default is Behind.
  9. Set Orientation. Available options are Horizontal, Vertical and Diagonal. Default is Horizontal.
  10. Specify whether it will be displayed on first (PrintOnFirstPage) and last page (PrintOnLastPage).
  11. Click OK.

Add Text Watermark programatically

CopyC#
Telerik.Reporting.Drawing.TextWatermark textWatermark1 = new Telerik.Reporting.Drawing.TextWatermark();
textWatermark1.Color = System.Drawing.Color.Red;
textWatermark1.Font.Bold = true;
textWatermark1.Font.Italic = false;
textWatermark1.Font.Name = "Arial";
textWatermark1.Font.Size = Telerik.Reporting.Drawing.Unit.Point(10D);
textWatermark1.Font.Strikeout = false;
textWatermark1.Font.Underline = false;
textWatermark1.Orientation = Telerik.Reporting.Drawing.WatermarkOrientation.Diagonal;
textWatermark1.Position = Telerik.Reporting.Drawing.WatermarkPosition.Behind;
textWatermark1.PrintOnFirstPage = true;
textWatermark1.PrintOnLastPage = true;
textWatermark1.Text = "My Test Watermark";
textWatermark1.Opacity = 0.3D;
report1.PageSettings.Watermarks.Add(textWatermark1);
CopyVB.NET
Dim textWatermark1 As New Telerik.Reporting.Drawing.TextWatermark()
textWatermark1.Color = System.Drawing.Color.Red
textWatermark1.Font.Bold = True
textWatermark1.Font.Italic = False
textWatermark1.Font.Name = "Arial"
textWatermark1.Font.Size = Telerik.Reporting.Drawing.Unit.Point(10.0)
textWatermark1.Font.Strikeout = False
textWatermark1.Font.Underline = False
textWatermark1.Orientation = Telerik.Reporting.Drawing.WatermarkOrientation.Diagonal
textWatermark1.Position = Telerik.Reporting.Drawing.WatermarkPosition.Behind
textWatermark1.PrintOnFirstPage = True
textWatermark1.PrintOnLastPage = True
textWatermark1.Text = "My Test Watermark"
textWatermark1.Opacity = 0.3
report1.PageSettings.Watermarks.Add(textWatermark1)

Add Picture Watermark

Add Picture Watermark using Report Designer

To add Picture Watermarks to the Report use the following steps:

  1. Open a report in Design view.
  2. Click the Report selector button located in the upper left hand of the Report Designer. This makes the report active in the Properties window.
  3. Expand PageSettings and click Watermarks ellipsis in the property grid. This displays the Watermarks collection. By default, the collection is empty.
  4. Click Add button and select PictureWatermark.
  5. In Image, browse for an image file on your hard drive, input an URI (local path or Url) or an Expressions that evaluates to an image.
  6. Set Sizing mode. Available options are Normal, Stretch and ScaleProportional. See PictureBox article for more information on the modes.
  7. Set Opacity.
  8. Set Position. Available options are Behind and Front. Default is Behind.
  9. Specify whether it will be displayed on first (PrintOnFirstPage) and last page (PrintOnLastPage).
  10. Click OK.

Add Picture Watermark programatically

CopyC#
Telerik.Reporting.Drawing.PictureWatermark pictureWatermark1 = new Telerik.Reporting.Drawing.PictureWatermark();
pictureWatermark1.Image = "http://www.telerik.com/images/reporting/cars/NSXGT_7.jpg";
pictureWatermark1.Position = Telerik.Reporting.Drawing.WatermarkPosition.Behind;
pictureWatermark1.PrintOnFirstPage = true;
pictureWatermark1.PrintOnLastPage = true;
pictureWatermark1.Sizing = Telerik.Reporting.Drawing.WatermarkSizeMode.ScaleProportional;
pictureWatermark1.Opacity = 0.5D;
report1.PageSettings.Watermarks.Add(pictureWatermark1);
CopyVB.NET
Dim pictureWatermark1 As New Telerik.Reporting.Drawing.PictureWatermark()
pictureWatermark1.Image = "http://www.telerik.com/images/reporting/cars/NSXGT_7.jpg"
pictureWatermark1.Position = Telerik.Reporting.Drawing.WatermarkPosition.Behind
pictureWatermark1.PrintOnFirstPage = True
pictureWatermark1.PrintOnLastPage = True
pictureWatermark1.Sizing = Telerik.Reporting.Drawing.WatermarkSizeMode.ScaleProportional
pictureWatermark1.Opacity = 0.5
report1.PageSettings.Watermarks.Add(pictureWatermark1)

Add Watermark conditionally

Add Watermarks to the Report on even pages only:

  • For Text Watermark, in Text property, use the following expression: =IIF(PageNumber %2 = 0, "My Text Watermark", null)
  • For Picture Watermark, in Image property, use the following expression: =IIF(PageNumber %2 = 0, "C:\MyImageWatermark.png", null)

Add Watermarks to the Report via defined page range:

  • For Text Watermark, in Text property, use the following expression: =IIF(PageNumber > 2 and PageNumber < 10, "My Text Watermark", null)
  • For Picture Watermark, in Image property, use the following expression: =IIF(PageNumber > 2 and PageNumber < 10, "C:\MyImageWatermark.png", null)
Caution

Some formats do not support Watermarks. For more information refer to Design Considerations for Report Rendering


Design Considerations for Report Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for Report Rendering
Send Feedback

All Telerik Reporting output formats have specific characteristics that determine their usage and impose ceratin limitations, which need to be taken into consideration when designing reports. For example, the CSV rendering extension is useful for creating reports that can be used as a data source by another application or process, layout rendering extensions produce reports in a format suitable for viewing by users, while physical rendering extensions are intended for precise printing.

For more information on the page layout and rendering extensions, refer to Rendering and Paging

  • Design Considerations for HTML Rendering
  • Design Considerations for Image Rendering
  • Design Considerations for PDF Rendering
  • Design Considerations for Excel Rendering
  • Design Considerations for CSV Rendering
  • Design Considerations for RTF Rendering
  • Design Considerations for XPS Rendering
  • Design Considerations for Word Rendering
  • Design Considerations for PowerPoint Rendering

Page Setup options can also alter the appearance of the report at design-time, run-time or when the user changes the options prior to printing a report.


Design Considerations for HTML Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for HTML Rendering
See Also Send Feedback

The HTML rendering extension renders a report into HTML or MHTML format.

HTML Output

The HTML rendering extension is based on the Image rendering extension, with some differences. For information common to both output formats, see Design Considerations for Image Rendering. This topic describes features that are specific to the HTML output format.

Rendering

  • Styles specified in report item properties are injected to the HEAD tag for use in the corresponding HTML elements.
  • All report items are rendered as separate div elements.
  • All output is generated with UTF8 encoding.

Pagination

Page size is calculated based on whether the report is rendered for Interactive view or Print Preview.

Interactivity

All Actions are supported.

MHTML Output

Rendering

Reports can be output as MHTML (Web archive or "MIME Encapsulation of Aggregate HTML Documents") standard. MHTML is used for including resources in the same file as the HTML code. This is particularly useful when sending email because all resources, such as image and sound files, are included in a single file.

The following rendering specifics apply to MHTML:

  • Styles specified in report item properties are injected to the HEAD tag for use in the corresponding HTML elements.
  • Each report section is rendered as a separate HTML table.
  • Columns and ColumnSpacing properties are ignored during HTML rendering.
  • The size of report items is the same as in design-time and the browser is responsible for sizing them.

Report Items render as the following HTML elements:

Report Item | HTML Element
TextBox

If CanGrow is set to true: the text value is contained in <TABLE>, <ROW> and <CELL> elements. If CanShrink is also true, the text is further wrapped in a <DIV> element.

If CanGrow is set to false the text value is contained in a <DIV> element. If CanShrink is set to true, outer and inner <DIV> elements wrap the text value to handle shrinking and growing size conditions.

If the MultiLine property is set to true, carriage return and line feed characters are replaced with <BR> tags.

Chart | <IMG>. A Portable Network Graphic (PNG) of the chart is created as the image source.
Panel | <TABLE>
PictureBox

A <DIV> surrounding an <IMG> tag. The DIV tag acts as a container that has a style to specify border, dimensions, padding, etc.

The position and scaling of the image is also affected by the Sizing property.

Normal and AutoSize: No scaling occurs and the image is rendered in the upper left corner of the PictureBox client area.

Center: Centers the area within the PictureBox client area.

Stretch: Expands the image to fill the client area.

ScaleProportional: Expands the image to fill as much of the client area as possible without distorting the image.

Checkbox

A <TABLE> with two cell elements placed in one or two rows is generated. If the CheckAlign property is set to one of TopCenter or BottomCenter, then the two rows model is used, CheckAlign=MiddleCenter has no meaning for html rendering as the checkbox image cannot be centered in single row model due to the text. If the Angle differs from zero than the Text is rendered as an image. CanShrink and CanGrow properties are respected. If the MultiLine property is set to true, carriage return and line feed characters are replaced with <BR> tags.

Shape | <IMG>
SubReport | <DIV>
Barcode | <IMG>. A Graphics Interchange Format (GIF) of the Barcode is created as the image source.
HtmlTextBox | All HTML tags and CSS attributes it supports are rendered as is, unsupported ones are omitted.
Table | A TABLE with cells containing other report items. It uses border-collapse:collapse css attribute, so that borders of neighbouring cells can be merged. For more information, refer to the W3 specification .

Interactivity

URL actions on report items are rendered as hyperlinks in HTML. When you click the hyperlink, the default Web browser opens and navigates to the specified URL.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for Image Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for Image Rendering
See Also Send Feedback

The Image rendering extension renders a report to a bitmap or metafile. By default, the Image rendering extension produces a TIFF file of the report, which can be viewed in multiple pages. When the client receives the image, it can be displayed in an image viewer and printed.

The Image rendering extension can generate files in any of the formats supported by GDI+: BMP, EMF, GIF, JPEG, PNG, and TIFF.

The Image rendering extension processes the report by assembling all elements of the report and creates an image for each page. With extensions like the HTML rendering extension, you rely on the client browser to display the final report to the user. This can lead to varying user experiences, based on browser versions, settings and fonts. With an image, you are assured that each user is viewing the same style and layout.

Rendering

Rendering takes into consideration the rules defines in General Behaviors for PDF, Image, HTML and Print topic.

Pagination

Paging takes into consideration the rules defines in Understanding Pagination topic.

Interactivity

This rendering extension does not support any interactive features.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for PDF Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for PDF Rendering
See Also Send Feedback

The PDF Rendering Extension of Telerik Reporting produces a version 1.6 PDF file. The file can be opened with Adobe Acrobat 7.0 or later. The file is compressed using the FlateDecode filter. The PDF rendering extension is a physical page renderer, thus has pagination behavior that differs from other rendering extensions such as HTML and Excel, which are not page oriented. PDF and Image Export Formats share the same high-level layout engine. Therefore all rules and design considerations that apply for the Image Rendering Extension apply for PDF as well.

The PDF rendering extension is based on the Image rendering extension, with some differences. For information common to the Image rendering extension and the PDF rendering extension, see Design Considerations for Image Rendering. This topic describes features that are specific to the PDF rendering extension.

Font Requirements

The PDF rendering extension embeds fonts by default. This functionality is controlled by the FontEmbedding device informattion setting. Fonts that are used in a report must be installed on the machine where the application is running, so the PDF rendering can embed them. If you disable font embedding, the fonts used in the report must be installed on the client computers used to view the report. When the report engine generates a report in PDF format, it uses the information stored in the font to measure and create character mappings within the PDF file. If the referenced font is not installed on the machine where the application is running, the resulting PDF file might not contain the correct mappings and might not display correctly when viewed. Before deploying the report on a production server, you should test the PDF output on client computers to verify that the report renders correctly. Do not rely on the Designer Preview or rendering to HTML, because GDI font substitution in those formats behaves differently than PDF. If there are Unicode Glyphs missing on the server, you may see characters replaced with a question mark and if there is a font missing on the client, you may see characters replaced with boxes.

Caution

When designing a report that would be exported to PDF, you should make sure that the font you use in the report supports the characters that would be displayed. For example when you use a font that does not support non-Latin characters, but then non-Latin characters are added to the report and it is exported to PDF, they would be replaced by question mark character (?) as PDF doesn’t automatically substitute fonts.

To view the list of fonts that are embedded in a PDF file, open the file in Adobe Acrobat and from the File menu, view Properties. The Fonts tab displays the list of fonts that are embedded in the file.

Metadata

The PDF rendering extension writes the following information to the PDF file:

PDF property | Value
Creator | Telerik Reporting product name and version.
Producer | Telerik Reporting product name and version.
CreationDate | Report execution time.

Limitations

The PDF Rendering extension has the following limitations:

  • Only Unicode fonts are supported.
  • PDF Security features such as password and encryption are not supported.

Interactivity

Bookmarks

The PDF rendering extension supports Document Map interactive feature which is rendered as PDF Bookmarks. You can use the Bookmarks by opening the Bookmarks pane in Acrobat Reader to navigate inside the report.

Hyperlinks

URL actions on report items are rendered as hyperlinks in the PDF file. Hyperlinks are rendered as clickable links and when you click the hyperlink, the default Web browser opens and navigates to the specified URL.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for Excel Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for Excel Rendering
See Also Send Feedback

Telerik Reporting produces Excel files in:

  • Microsoft Excel 2007 and above (OpenXML 2.0)
  • Microsoft Excel 97-2003 (BIFF, v.8)
Telerik Reporting does not rely on Microsoft Office being installed in order to export to both formats.

Microsoft Excel 97-2003 files can be opened by Microsoft Excel 97 for Windows and later.

Microsoft Excel 2007 files can be opened by Microsoft Excel 2007 for Windows and later and has the following advantages over Microsoft Excel 97-2003:

  • Works in Medium Trust.
  • Supports up to 16 million colors.
  • Hyperlinks support.
  • Charts are rendered as Metafiles. This guarantees best quality in any scale factor and when printing.

The Excel Rendering Extensions tries to reproduce as much of the original report as possible regarding layout and styling, but there are certain limitations that are imposed by the physical and logical structure of an Excel Document.

Report Item Layout

  • The entire report is rendered into a single Excel worksheet. There is no paging when exporting to Excel.

  • Overlapping items are not supported and will be moved down/right by the Excel renderer so that they do not overlap.

  • When you use the CanGrow and CanShrink properties, the Rendering Engine will utilize the AutoFit functionality of Excel. That means that cell content will resize according to Excel behavior which might not produce the expected result. Furthermore, AutoFit is applied by Excel only for horizontal text, so if you have rotated text (at an angle different than zero), the CanGrow and CanShrink properties might not behave as expected. Rotated text is realized via Excel's built-in cell rotation settings.

  • Multi-column reports are not supported.

Page Headers and Footers

The page header and footer render differently depending on the Excel Device Information Settings. The page header can be rendered in two ways: as a sequence of frozen rows at the top of the worksheet, or in the native Excel page header. The page footer can also be rendered in two ways: as sequence of excel cells at the bottom of the worksheet or in the native Excel page footer. The native Excel page sections are divided in three – left, middle and right. Report items will enter the respective page footer section according to their original location in design-time.

Note

Because of Excel limitations, TextBoxes are the only type of report item that can be rendered in the native Excel header/footer section.

With default configuration (DefaultPageHeader is False and DefaultPageFooter is True), the page header is rendered as frozen rows at the top of the worksheet and the page footer is rendered in the native Excel page footer.

When configuration is changed (DefaultPageHeader is True or DefaultPageFooter is False), the behavior is reverted: the page header is rendered in the native Excel page header and the page footer is rendered as sequence of excel cells at the bottom of the worksheet.

Caution

The PageNumber and PageCount global objects are not to be used when rendering to Excel, since it is not a page-oriented format.

ReportBook

Each report in a ReportBook will occupy a separate worksheet in the Excel workbook. Each worksheet of the Excel workbook will have the name of the respective report.

Styling

Background images are not supported.

Report Items

Report Item | Rendering Notes
TextBox | TextBox values are converted to string or number cells in Excel depending on the actual value. If a supported .NET string format is supplied through the Format property of the TextBox, the resulting cell is accordingly formatted respecting the Culture of the TextBox. Item binding expressions are not converted to Excel formulas.
Chart | Chart report items are rendered as an Excel Picture object and not Excel Chart object. In Microsoft Excel 97-2003 it is a Bitmap image; in Microsoft Excel 2007 and above it is a Metafile.
Barcode | Barcode is rendered as an Excel Picture object with a Bitmap image.
Table | Table is rendered as a range of Excel cells.
HtmlTextBox | HtmlTextBox is rendered as plain text with no formatting.
Shape | Shape report items are rendered as Excel Picture objects with Bitmap images, not Microsoft Office Drawings.
CheckBox | CheckBox report items are rendered as Excel Picture objects with Bitmap images – including check marks and text.
PictureBox | PictureBox is rendered as an Excel Picture object.
Panel | Panel is rendered as a range of Excel cells.
SubReport | SubReport is rendered as a range of Excel cells.

Merging Cells

The Excel renderer is mainly a layout renderer. Its purpose is to replicate the layout of the report being rendered as closely as possibly in an Excel worksheet and consequently cells might be merged in the worksheet to keep the WYSIWYG report layout. Merged cells are possible source for problems, since the sort functionality in Excel requires cells to be merged in a very specific way for sort to work properly e.g. Excel requires that the ranges of merged cells have the same size in order to be sorted.

If sorting is important for your exported to Excel reports, the guidelines below can help you reduce the number of merged cells in your Excel worksheets, which is the common cause for difficulties with Excel sort functionality:

  • The most common cause of merged cells is improper or missing left/right alignment of report items. Make sure the left and right edges of all report items line up with one another. The alignment and applying the same width to report items will usually solve the problem.
  • Aligning items precisely might not be enough, and in some rare cases columns might continue to be merged. This is likely caused by internal unit conversion and rounding when the Excel worksheet is rendered. In the report definition, you can specify location and size in different measurement units such as inches, pixels, centimeters, and points, but internally Excel uses points. So in order to minimize conversion and the potential inaccuracy of rounding when converting inches and centimeters to points, consider specifying all measurements in points (one inch is 72 points).

Page Settings

The following standard paper kinds are supported:

  • A3 (297mm x 420mm)
  • A4 (210mm x 297mm)
  • A5 (148mm x 210mm)
  • B4 (250mm x 353mm)
  • Quarto (215mm x 275mm)
  • DLEnvelope (110mm x 220mm)
  • C5Envelope (162mm x 229mm)
  • PrcEnvelopeNumber10 (324mm x 458mm)
  • PrcEnvelopeNumber9 (229mm x 324mm)
  • C6Envelope (114mm x 162mm)
  • C65Envelope (114mm x 229mm)
  • B4Envelope (250mm x 353mm)
  • B5 (176mm x 250mm)
  • B6Envelope (176mm x 125mm)
  • ItalyEnvelope (110mm x 230mm)
  • Letter (8.5” x 11”)
  • Tabloid (11” x 17”)
  • Ledger (17” x 11”)
  • Legal (8.5” x 14”)
  • Statement (5.5” x 8.5”)
  • Folio (8.5” x 13”)
  • Standard10x14 (10” x 14”)
  • Number9Envelope (3.875” x 8.875”)
  • Number10Envelope (4.125” x 9.5”)
  • Number11Envelope (4.5” x 10.375”)
  • Number12Envelope (4.75” x 11”)
  • Number14Envelope (5” x 11.5”)
  • DSheet (22” x 34”)
  • ESheet (34” x 44”)
  • MonarchEnvelope (3.875” x 7.5”)
  • PersonalEnvelope (3.625” x 6.5”)
  • USStandardFanfold (14.875” x 11”)

If any other paper size is specified, the default printer settings will be used. In this manner you can use custom paper sizes.

Formatting Strings

Standard Numeric Format Strings

A subset of the .NET string formats (set through the TextBox.Format property) is supported by the rendering extension. Those include:

  • C or c (Currency)
  • N or n (Number)
  • G or g (General)
  • P or p (Percent)
  • and others ..

Standard DateTime Format Strings

  • d (Short date pattern)
  • D (Long date pattern)
  • t (Short time pattern)
  • T (Long time pattern)
  • f (Full date/time pattern with short time)
  • F (Full date/time pattern with long time)
  • g (General date/time pattern with short time)
  • G (General date/time pattern with long time)
  • M or m (Month day pattern)
  • R or r (RFC1123 pattern)
  • s (Sortable date/time pattern; conforms to ISO 8601)
  • u (Universal sortable date/time pattern)
  • U (Universal sortable date/time pattern)
  • Y or y (Year month pattern)

Currency Format Strings

Currency format strings are always hard-coded with "Custom Format". This way the currency formatting from the report definition is preserved and does not depend on the client machine locale.

If a valid format string is detected by the rendering extension, the raw value will be stored in the cell as a Number and an Excel Number Format will be applied. Otherwise the value will just be stored in the cell, again as a Number, but without formatting. Even unformatted, it would be possible to use the resulting cell in Excel functions.

Excel Limitations

Common for both formats

Excel places limitations on exported reports due to the format capabilities. The most significant are the following:

  • TextBoxes are rendered within one Excel cell. Font size, font face, decoration, and font style are the only formatting that is supported on individual text within an Excel cell.
  • Telerik Reporting expressions are not converted to Excel formulas. TextBox values that are expressions are evaluated during report processing and the result is exported as content of Excel cell.
  • Excel does not support background images for individual cells, so Background images for report items (including Report) are ignored.
  • Excel headers and footers support a maximum of 256 characters including markup. The rendering extension truncates the string at 256 characters.
  • Excel does not support Watermarks.

Excel 97-2003

  • Excel supports a palette of up to 56 colors. The first 56 unique colors used in the report are defined in a custom palette. If more than 56 colors are used in the report, the rendering extension matches the required color to one of the 56 colors already available in the palette. Excel’s color matching algorithm is used to match colors to ones already existing in the palette.
  • The maximum number of rows in a worksheet is limited to 65,536. If this is exceeded, the renderer displays an error message.
  • The maximum number of columns in a worksheet is limited to 256. If this is exceeded, the renderer displays an error message.
  • The maximum column width is limited to 255 characters or 1726.5 points. The renderer does not verify that the column width is less than the limit.
  • The maximum row height is 409 points. If the contents of the row cause the row height to increase beyond 409 points, the contents are split and added to the next row instead.
  • The maximum number of characters in a cell is limited to 32,767. If this is exceeded, the renderer displays an error message.

Excel 2007 and above

  • Excel 2007 supports up to 1 million rows.
  • Excel 2007 supports up to 16 thousand columns per worksheet. Specifically, the Office Excel 2007 grid is 1,048,576 rows by 16,384 columns
  • Excel 2007 supports up to 16 million colors.

Interactivity

Microsoft Excel 2007 and above format supports hyperlinks, which are rendered as Excel hyperlinks in the cell in which the text is rendered. When you click the hyperlink, the default Web browser opens and navigates to the specified URL.

Microsoft Excel 97-2003 format does not support any interactive features.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for CSV Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for CSV Rendering
See Also Send Feedback

The Comma-Separated Value (CSV) rendering extension renders reports in comma-delimited plain text files, without any formatting. It uses a string character delimiter to separate fields (, - comma) and rows (<cr><lf>). The resulting file can be opened in a spreadsheet program like Microsoft Excel or used as an import format for other programs. The exported report becomes a .csv file and returns a MIME type of text/plain.

When rendered using the default settings, a CSV report has the following characteristics:

  • The first record contains headers for all the columns in the report (the items' name, not value).
  • All rows have the same number of columns.
  • The default field delimiter string is a comma (,).
  • The record delimiter string is the carriage return and line feed (<cr><lf>).
  • The text qualifier string is a quotation mark (").
  • If the text contains an embedded delimiter string or qualifier string, the text qualifier is placed around the text, and the embedded qualifier strings are doubled.
  • Formatting and layout are ignored.

The following items are ignored during processing:

  • Page Header Section
  • Page Footer Section
  • Shape
  • PictureBox
  • Chart

The remaining report items appear as ordered in the parent’s item collection. Each item is then rendered to a column. If the report has nested report, the parent items are repeated in each record.

The following table lists the considerations applied to items when rendering to CSV:

Report Item | Rendering Behavior
TextBox | Renders the contents of the text box. The data is formatted according to the item's Format property
CheckBox | Renders the contents of the CheckBox. The Text is formatted according to the item's Format property. The first character of resulting string represents the CheckMark state: 0 is Unchecked, 1 is Checked and 2 is Indeterminate.
Detail section | Renders a record for each detail row.
Report Header Section | Renders its content at the beginning of each detail row.
Group Header Section | Renders its content at the beginning of each detail row after the Report Header content if any.
Group Footer Section | Renders its content at the end of each detail row.
Report Footer Section | Renders its content at the end of each detail row after the Group Footer content if any.
Crosstab | Due to the required data denormalization (flattening) some Crosstab configurations will not be exported correctly.

Interactivity

This rendering extension does not support any interactive features.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for RTF Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for RTF Rendering
See Also Send Feedback

The RTF Rendering Extension of Telerik Reporting produces RTF v1.6 files. It is reccommended that the exported file is viewed with Microsoft Word 97 or later.

Design Consideration for RTF Rendering (Frames Mode)

Telerik Reporting relies on Frames to a achieve a WYSIWYG layout and preserve the original report outlook as much as possible. Consumer applications that do not support Frames might produce unexpected results and are not recommended.

Limitations

  • Vertical Alignment is not supported.
  • Report Background Color is not supported.
  • TextWrap = false is not supported.
  • Inset and Outset Borders are not supported.
  • Rotated Text is rendered by an image.
  • RTL Text Handling is left to the consumer application.
  • Maximum Page Width and Height is 22 inches.
  • Simple Report Items (such as TextBoxes, PictureBoxes, etc.) cannot span on multiple pages. They should fit on a single page.

HtmlTextBox Limitations

Due to the media limitations, the following CSS style properties set on the HTML tags are NOT respected:

  • borders
  • padding
  • background-color on Block elements is rendered as background-color of the text
  • text-align (center tag)

Design Consideration for RTF Rendering (Tables Mode)

When a report contains a Table or a CrossTab item, the RTF Rendering Extension switches to an alternative rendering mode and uses tables since they are natural for those two items.

When a report is exported to RTF in the Table mode it is represented by a series of tables nested in one another representing the hierarchical structure of the report. Each container (for example a ReportSection or Panel) is rendered as a table and its child elements are positioned in the respective row and column of this table. The rows and columns of the table are calculated and sized depending on the locations and sizes of the child elements. Non-container items (for example a TextBox or PictureBox) are rendered as the contents of the cell they fall in. If a child element is a container itself, then a new table is nested in the respective cell.

Paging

  • The report is paged by the consumer application (MS Word most often) based on the table generated and the page size. The exact number of pages might not be the same as in the Image Rendering Extensions.
  • Since the paging is left to the consumer application the page breaks might not be at exactly the same spots as in the Image Rendering Extensions.
  • The GroupSection.PrintOnEveryPage is not respected
  • KeepTogether properties might produce slightly different results from the ImageRendering Extensions in certain circumstances, since the decision of whether a certain table row can be kept together on the current page is taken by the consumer application.
  • Page widths that are up to 22 inches wide are supported.
  • If the report grows more than the page width, the page will be automatically expanded to accommodate the report if possible.
  • If an item’s bounds (location and size) are exactly or close to the page bounds (i.e. the item occupies exactly one page entirely), an additional page might be added after it.

Page Headers / Footers

  • Page Headers/Footers are rendered by using the real page header/footer of the document.
  • If the report is part of a ReportBook, then it does not render its Page Header/Footer.
  • Contents inside the Page Header/Footer are rendered with tables as well.
  • The global objects PageNumber and PageCount are inserted as calculated fields.

Limitations

  • BackgroundImages are usually not rendered. Only if the container has no children or the simple item has no content its BackgroundImage will appear. So, for example, if you have a Panel with TextBoxes inside it, then it will not render its BackgroundImage.
  • Item borders are rendered as cell borders on the cell that the item occupies.
  • Mixing a lot of items that are not aligned to each other in the same container increases the complexity of the generated table, thus increasing document rendering and opening times and file size.
  • Text boxes grow when they contain non-breaking spaces.
  • When text is exported, text with font decoration in certain fonts may generate unexpected or missing glyphs in the rendered report.
  • Some older readers do not support nested tables and other crucial features so export results may be unexpected. The recommended application for opening RTF files generated by Telerik Reporting is Microsoft Office Word 2007.
  • Watermarks are not supported (Tables mode).

Interactivity

This rendering extension does not support any interactive features.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for XPS Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for XPS Rendering
See Also Send Feedback

The XPS Rendering Extension of Telerik Reporting produces XPS files that comply with version 1.0 of the XML Paper Specification.

An XPS document is a paginated set of related pages. The pages have a fixed layout, are organized into one or more fixed documents, and stored according to the Open Packaging Conventions. The file can be opened with the built-in XPS viewer in Windows Vista or later.

XPS and Image rendering extensions share the same high-level layout engine. Therefore all rules and design considerations that apply for the Image Rendering Extension apply for XPS as well.

For information common to the Image rendering extension and the XPS rendering extension, see Design Considerations for Image Rendering. This topic describes features that are specific to the XPS rendering extension.

Interactivity

This rendering extension does not support any interactive features.

Note

XPS glyphs do not work with TrueType Collection Fonts. When you use such fonts in report, only the first font in the collection is used for the creation of the XPS document. Hotfixes are available in MS KB 981429 and 2328677.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for Word Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for Word Rendering
See Also Send Feedback

The Word Rendering Extension of Telerik Reporting produces Open XML Word documents. The generated documents are compatible with Microsoft Word 2007 or later. Earlier versions of Microsoft Word are not supported. The file name extension generated by this renderer is DOCX. After the report is exported, you can edit the contents of the generated document or print it as usual.

The Word rendering extension is based on the Image rendering extension, with some differences. For information common to both formats, see Design Considerations for Image Rendering. This topic describes features that are specific to the Word rendering extension.

Rendering

Report exported to Word appears as a nested table that represents both the report layout and content. Nested data region items, such as SubReport, Table, Crosstab or List items are rendered as nested tables that reflect the layout and structure of that data region in the report. Other items are rendered as separate cells within the same table. The item’s value is rendered as content in the table cell. PictureBox, Chart, Barcode and Shape items are rendered as static images in the cell. URL actions of TextBox items are rendered as hyperlinks in Word.

Note

Word tables support a maximum of 63 columns. Reports with very complex layout or many misaligned items might sometimes produce documents exceeding that limit. To avoid this, align your items carefully in the designer, using the "snap to lines" and "snap to grid" modes whenever possible. To organize many items together in columns and rows consider using the Table, Crosstab or List report item instead.

Caution

Since report items are rendered as individual table cells they cannot overlap. If you have overlapping items in the report definition, the resulting document is undefined, i.e. this would break the report layout. If there are no overlapping items the original layout is preserved. In general, avoid having overlapping items at design-time if you are planning to export the report to Word.

Pagination

Microsoft Word does not support the concept of hard pages. Instead, when the exported document is opened in Word, Word repaginates it again based on the page size. The rendering extension tries to preserve closely the original pages of the report, inserting additional page breaks when necessary. However in some rare cases the repagination performed by Word might interfere with this behavior, resulting in a document with page breaks on unexpected places or blank pages. To correct this, you can try changing the Word’s pagination by adjusting the page margins.

Page Sizing

When the report is rendered, the page size, orientation and margins are configured in the document according to the corresponding properties in the report definition. For ReportBook the page settings of each individual report in the book are respected. This can produce a document with varying page sizes and orientation per report.

Note

Word supports a maximum page size of 22 inches wide and 22 inches high. If your page is wider than 22 inches, some data may not be displayed in Print Layout view.

Page Headers and Footers

Report’s PageHeaderSection and PageFooterSection are rendered as header and footer regions in the document. For ReportBook the page sections of each individual report in the book are respected. This can produce a document with varying page headers and footers per report.

Word does not support configuring explicitly the height of headers and footers. Instead they are sized automatically according to their content.

Page Columns

Newsletter-style multi-column reports are rendered as multiple columns in Word.

Since Word repaginates the entire document when opening it, the same behavior is applied to multi-column documents as well. The rendering extension tries to preserve the original organization of the report in columns by inserting column breaks when necessary. However in some rare occasions the repagination performed by Word might interfere with this behavior resulting in column breaks on unexpected places or empty columns. To correct this, you can try changing the Word’s pagination by adjusting the column spacing or page margins.

Styling

The following is a brief description of how styles are rendered in Word.

  • Colors - Colors are rendered as exact RGB values. Transparent colors with alpha channel are not supported.
  • Borders - Borders of report items are rendered as table cell borders. Borders of adjacent report items are collapsed automatically, following the Word’s own border collapse rules.
  • Background - Background colors are rendered as background shading of table cells. Background images are not supported.
  • Fonts - Fonts and their settings are rendered exactly as they are specified in the report definition. In order to display correctly a document that uses a specific font, that font must be installed on the client machine. The rendering extension does not provide a fallback mechanism in case of missing fonts.
  • Text - Text justification and alignment is preserved when exporting to Word. Text orientation is supported only for the angles of 0, 90 and 270 degrees. Rotated text on other angles is not supported and is approximated to the closest match.
  • HTML - HTML text is rendered using Word’s own HTML rendering engine. This might produce a result that is slightly different from the output generated in Web browsers.

Interactivity

URL actions on TextBox items are rendered as hyperlinks in the Word document. When you click the hyperlink, the default Web browser opens and navigates to the specified URL. Other types of actions are not supported.

Limitations

Text Watermarks do not support strikethrough and underline text decorations.

See Also

Other Resources

Understanding Report Sections
Understanding Report Items
Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Design Considerations for PowerPoint Rendering

[image]

Telerik Reporting Q2 2012
Design Considerations for PowerPoint Rendering
See Also Send Feedback

The PowerPoint rendering extension produces Presentation document without relying on Microsoft Office being installed. The content type of files generated by this renderer is: application/vnd.openxmlformats-officedocument.presentationml.presentation. The rendering extension requires Open Xml SDK 2.0 (DocumentFormat.OpenXml.dll). The file name extension of generated files is .PPTX and it can be viewed with MS Office PowerPoint 2007 or later.

The PowerPoint rendering extension is based on the Image rendering extension, with some differences. For information common to both formats, see Design Considerations for Image Rendering. This topic describes features that are specific to the PowerPoint rendering extension.

Report items

The following rules apply to rendered report items:

  • All report items (except the Table) are exported as PowerPoint shape. If Border is set, the report item is exported as PowerPoint table.

  • Table/Crosstab/List report item is exported as PowerPoint table. If the table table cell content is a container (Panel, Table) its children are exported separately on top of the table cell.

  • The Chart report item is exported as picture object and not powerpoint chart object.

  • In TextBox item with rotated text, each text line is exported as a separate rotated shape.

Styling

  • Color property is applied as color of the PowerPoint shape/table cell.
  • The BackgroundImage is applied as image in the PowerPoint shape/table cell.
  • When both Color and BackgroundImage are set – the Color is exported as separate PowerPoint shape. The BackgroundImage is applied as picture on top of the Color shape.
  • A PictureBox report item with Color and BackgoundImage applied, will be exported as a separate PowerPoint shape for the Color, a separate PowerPoint shape for the BackgroundImage on top of the Color shape and picture for the actual image, which would be on top of both.

Page Header and Footer

Page header and Footer are rendered as PowerPoint shape/table cell as all report sections.

Interactivity

URL actions on report items are rendered as hyperlinks in the Presentation. Hyperlinks are rendered as clickable links and when you click the hyperlink, the default Web browser opens and navigates to the specified URL. They should be applied to the top most element.

Limitations

  • Page margins are ignored.
  • All slides in a single Presentation document have the same size. In case of ReportBook, the largest width and height from all reports is determined and applied to the Presentation document.
  • (HtmlTextBox only) Paragraph margins are not supported.

See Also

Other Resources

Rendering Extensions
Telerik Reporting Configuration Section
Device Information Settings


Previewing Reports

[image]

Telerik Reporting Q2 2012
Previewing Reports
See Also Send Feedback

In the Report Designer, you are not working with the actual data but a representation of the data indicated by the field name or expression. When you want to see the actual data displayed in the context of the report you design, you can preview the data from the underlying database displayed in the report layout. Switching between designing and running your report allows you to adjust its design and see the results immediately. To view the report you have designed:

  • Switch to Preview or Html Preview mode.
  • Use any of the report viewers in a standalone application.

See Also

Other Resources

Interactive vs. Print Layout


Report Globalization

[image]

Telerik Reporting Q2 2012
Report Globalization
Send Feedback

Telerik Reporting offers the possibility to control the way numbers, dates and currencies are displayed and to layout text in different directions.

A report is globalized with the help of a System.Globalization.CultureInfo object. You can specify a Culture for the entire Telerik.Reporting..::.Report by setting its Report..::.Culture property. This will force all Telerik.Reporting..::.TextBox items to respect the assigned Culture. But you are not limited by one culture per report. You can mix an unlimited number of cultures, by setting the TextItemBase..::.Culture property of a specific Telerik.Reporting..::.TextBox. This will override the Report's Culture.

Culture Inheritance

When determining what Culture to use for formatting strings and text direction, the rendering engine will inspect the those objects in the following order:

  1. The Culture of the TextBox.
  2. If the TextBox has no Culture defined, the Culture of the Report is used.
  3. If the Report has no Culture defined, the Culture of the CurrentThread is used.
Tip
The Culture of the CurrentThread is determined by the Regional Settings of the machine the application is running on. (Control Panel->Regional Settings->Regional Options->Standards And Formats)

Culture Dependant Properties

  • String Formatting

Culture affects the way strings are formatted in Telerik Reporting. For example, if you set the British Culture (en-GB) for a TextBox and set its TextItemBase..::.Format to Currency ({0:C2}) you will see values like: £43.21. Same applies for dates, times and numbers.

  • Text Direction (LTR/RTL)

Middle Eastern languages such as Hebrew and Arabic are generally written from right to left. If your TextBox will contain text written using a RTL script, then you simply need to specify the appropriate Culture, for example "he" for Hebrew and "ar" for Arabic.


Localizing Reports

[image]

Telerik Reporting Q2 2012
Localizing Reports
Send Feedback

You can localize your reports to display in the language of a specific culture. For example, your report may display in both English and Spanish (see figure below).

Telerik Reporting uses a similar methodology for localization as Visual Studio uses for Windows Forms. The designer lets you define static text for the report (e.g. column headings, titles) in each language that you specify. A resource file (resx) is automatically created for each language to store translated text. For more background information on localizing applications see the MSDN article Globalizing and Localizing Applications.

Localized Reports

To localize a report:

  1. In the designer set the Report Localizable property to true.
  2. Select a Language property value from the drop down list in the properties window.
  3. Translate the static text into the desired language indicated by the Language property.

To run a localized report:

  1. Add Threading and Globalization namespaces to your application.
  2. Set the current thread CurrentUICulture to a new instance of CultureInfo. The CultureInfo constructor takes the culture code of the language you want to display. For example "en-US" for United States English or "es-MX" for Mexican Spanish.
  3. Optionally you can set the CurrentCulture for the current thread to the culture code of the language you wish to display. CurrentCulture affects dynamic data such as date, time and money formats. The "Birth Date" column date format in the figure above shows Month/Day/Year in English, but in Day/Month/Year format in the Spanish example.
  4. Create an instance of the report and assign it to the ReportViewer Report property.If you are using a ReportViewer in a Windows application, call the RefreshReport() method of the ReportViewer.
Copy[C#] Setting the language at runtime
using System.Threading;
using System.Globalization;
// . . .
// Set the language for static text (i.e. column headings, titles)
Thread.CurrentThread.CurrentUICulture = new CultureInfo("es-MX");
// Set the language for dynamic text (i.e. date, time, money)
Thread.CurrentThread.CurrentCulture = new CultureInfo("es-MX");
reportViewer1.Report = new Report1();
// If this is a Windows application, refresh the report
reportViewer1.RefreshReport();
Copy[VB.NET] Setting the language at runtime
Imports System.Threading
Imports System.Globalization
'. . .

' Set the language for static text (i.e. column headings, titles)
Thread.CurrentThread.CurrentUICulture = New CultureInfo("es-MX")
' Set the language for dynamic text (i.e. date, time, money)
Thread.CurrentThread.CurrentCulture = New CultureInfo("es-MX")
reportViewer1.Report = New Report1()
' If this is a Windows application, refresh the report
reportViewer1.RefreshReport()


Performance Considerations

[image]

Telerik Reporting Q2 2012
Performance Considerations
Send Feedback

The performance of Telerik Reporting can be viewed as the time the reporting engine takes to produce a report, i.e. the rendering engine has to perform some calculations, expression evaluations, filtering, HTML generation, and/or other tasks to produce a report.

The processing time (as well as consumed memory) depends heavily on the following:

  • Large amount of data retrieved from the database and size of the generated document (in pages)
  • Data calculations (aggregates, conditional formatting, expressions, filtering, etc.)
  • Complexity of the report layout
  • Using PageCount - this triggers an extra paging pass that depending on the report complexity may significantly increase the time for the rendering operation to complete.
  • Rendering media (HTML, PDF, Excel, etc.)
  • Number of items (excl. charts)
  • Number of Chart items
  • Machine/network resources
  • Other ways to improve performance
  • For additional assistance

Basically, the more complex the report, the more time it will take to get it rendered. Let’s look at each of the above and how to improve performance:

Large amount of data retrieved from the database and size of the generated document (in pages)

Description: If your report(s) display large amounts of data, it may take a long time for the data to be retrieved from the database.

Optimization: With large amounts of database server data you need to retrieve the smallest usable set of data to reduce network traffic, use resources effectively and to render reports quickly. This can be achieved by using selections applied to data at the report level vs. user selections applied at the database. Selections applied at the database level are effective when the data does not need to be re-queried. This can be effective when only a narrow range of data is required. Additional trips to the database for different views of the same data increase the network traffic cost and the time needed to render the report. When user selections are applied at the report level the data is cached in-memory. This can be effective when different views of the same data are required and the data is not too large. A combination of these techniques may be the most appropriate solution. To filter data on database level and fetch only a subset of the data, review the Design Time Support for Parameterized Queries video.

Data calculations (aggregates, conditional formatting, expressions, filtering, etc.)

Description: complicated binding expressions (especially with many report items) require time to be evaluated and they can also lead to slowness.

Optimization: It is a good idea to replace these expressions with a user function. User functions are compiled code and would not be evaluated numerous times by our processing engine, like an expression would.

Complexity of the report layout

Description: You should avoid lots of nested reports and tables. SubReports require additional data filtering on the application side, and so do tables.

Optimization: The SubReport/table items are separate data regions. In the case when they are bound to the same data they will produce multiple unnecessary queries to the database. In this case, try simplifying the report by using textbox items directly in the master report (if applicable), rather than using SubReports and tables. You should also avoid using nested tables.

Rendering media (HTML, PDF, Excel, etc.)

Description: The HTML and Excel rendering engines create a complex matrix taking into account every item's coordinates and size, and then create an HTML table with many table cells and rows, some of which are used merely as "spacers". This way an item's exact location and size are preserved, but at the cost of many calculations. When a report has tons of items that are not vertically and horizontally aligned, the resulting HTML table is gigantic.

Optimization: Align your items horizontally and vertically relative to each other and make sure that you have NO warning signs in design-time. While in TIFF and PDF formats the rendering locations and sizes do not relate to performance, in HTML and Excel this is critical. The more items are aligned horizontally and vertically, the less dummy spacer rows and cells will be created by the HTML and Excel rendering engine;

Number of items (excl. charts)

Description: Report items are first bound to data and then are rendered. If there are many report items on the report, its generation may take a while.

Optimization: Move the separate logical parts of your report into SubReports, and then combine them in one main report. Each SubReport will be rendered separately, which in turn will decrease the matrix complexity. Try not to put many report items into a single DetailSection, rather logically divide the report into parts and place them in separate SubReports. In this manner you will also be able to "assemble" many different kinds of reports later on, once you have created the "building blocks", i.e. the SubReports.

Number of Chart items

Description: The Chart item does not use the reporting data engine, but its own. As a result showing many charts involves extra data processing. Telerik is working on optimizing this behavior.

Optimization: Avoid using the IntelligentLabels property. If possible, minimize the amount of charts that you have to display. Usually charts are used for summary and group information, so natural place for its use is in the Group section, i.e. escape using the charts in the Detail section. If you are trying to mimic an existing application/page layout in a report, the chances are that the chart image has already been generated by the application. If so, simply reuse the already created chart image and display it through the PictureBox report item. To do this, save the chart image to a stream, and feed this stream to the PictureBox Image property. For more information, review this article: Use asp:chart in Telerik Reports.

Machine/network resources

The CPU power and amount of memory have direct impact on the rendering performance. Obviously, the faster the hardware, the better. For data- and layout-intensive reports, we would suggest a minimum of a dual core processor with at least 2 GB of RAM. Network traffic bandwidth also impacts performance.

Other ways to improve performance

Avoid using the ChildElements.Find method to loop through the report hierarchy – this method is time and memory consuming, and should be avoided in data- and layout-intensive reports. Telerik Reporting offers a reference to the items in the report, so using ChildElements.Find to locate items is not necessary. For example, instead of using: TelItem = Report.ChildElements.Find("txtQuotefor", True) you can directly refer to the appropriate field and save all the time taken in searching: TelItem = Me.txtQuotefor

For additional assistance

If your case is not listed above, or you have tried all suggestions, but experience slow rendering, please open a new support ticket and send us the following so that we can investigate your case and check what is causing your troubles:

  1. Detailed information about your report(s) and environment, i.e.
  2. Your archived report files
  3. The data source you're binding to


Using Telerik Reporting in Applications

[image]

Telerik Reporting Q2 2012
Using Telerik Reporting in Applications
See Also Send Feedback

As an embedded engine, Telerik Reporting engine can be accessed directly in your application. For convenience we provide report viewers for all supported platforms (Silverlight, WPF, ASP.NET and Windows Forms). Should you need to interact with the reporting engine manually, you can use the ReportProcessor. A common usage would be to export or print the report, which can be accomplished with the help of RenderReport and PrintReport methods.

In This Section

  • Web Report Viewer
  • Windows Forms Report Viewer
  • Silverlight Report Viewer
  • WPF Report Viewer
  • Accessing Report Engine

See Also

Other Resources

Exporting Report Programmatically


Web Report Viewer

[image]

Telerik Reporting Q2 2012
Web Report Viewer
Send Feedback
  • Web Viewer Introduction
  • Assign Telerik Report to the viewer
  • Report Viewer Localization
  • Deploying Web ReportViewer in MOSS
  • Medium Trust Support
  • AJAX support
  • Client-Side API
  • Design Considerations for Out-proc Session State


Overview

[image]

Telerik Reporting Q2 2012
Overview
See Also Send Feedback

The Web Report Viewer is designed to render Telerik Reports within ASP.NET projects.

Caution

The Web Report Viewer uses ASP.NET Session in order to preserve the report instance assigned to its Report property during page postbacks and for some design reasons as well, so Session should be enabled at all times!

  • Navigate back in history
  • Navigate forward in history
  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Zoom level (Internet Explorer feature only)
  • Export: see Rendering Extensions for available export formats.
  • Refresh
  • Print Preview: switches between Logical and Physical page renderer. See Rendering and Paging for more info.
  • Print: see True Print for more info.
  • Show/Hide parameters area
  • Show/Hide document map

See Also

Other Resources

How to: Add report viewer to a web page
Report Viewer Localization
Deploying Web ReportViewer in SharePoint
Medium Trust Support
AJAX support
Client-Side API


How to: Add report viewer to a web page

[image]

Telerik Reporting Q2 2012
How to: Add report viewer to a web page
See Also Send Feedback

Assign report to the viewer in design time

To use Telerik Reports in web application, you need the Web report viewer:

  1. Drag the ReportViewer control from the Toolbox to the design surface of a web form.

    By doing so, the ReportViewer control would register automatically the http handler it needs to function properly in the web.config file of the web application/site.

    Note

    The http handler is automatically registered in the web.config only when the report viewer control is dropped from the Toolbox to the design surface of a web form. If you drop the report viewer in the text editor (source view) or add it to the web form programatically, you should manually register the http handler using the xml markup below.

    In the <system.web>\<httpHandlers> section:

    CopyXML
    <system.web>
....
    <httpHandlers>
          <add path="Telerik.ReportViewer.axd" verb="*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"/>
    </httpHandlers>
....
</system.web>

    In the <system.webServer>\<handlers> section:

    CopyXML
    <system.webServer>
        <handlers>
            <add name="Telerik.ReportViewer.axd_*" path="Telerik.ReportViewer.axd" verb="*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" preCondition="integratedMode"/>
        </handlers>
        <validation validateIntegratedModeConfiguration="false"/>
</system.webServer>

  2. Add reference to the class library that contains your reports in the web application/site.
  3. Build the application
  4. Set the ReportSource of the viewer using the combobox in the Properties Window.

Assign report to the viewer programatically

In the Page_Load event handler you create an instance report source and set its ReportDocument property to a report instance. Next assign the instance report source to the ReportSource property of the viewer.

Example

CopyC#
protected void Page_Load(object sender, EventArgs e)
{
    if (!IsPostBack)
    {
        Telerik.Reporting.InstanceReportSource instanceReportSource = new Telerik.Reporting.InstanceReportSource();
        instanceReportSource.ReportDocument = new Telerik.Reporting.Examples.CSharp.ListBoundReport();
        this.ReportViewer1.ReportSource = instanceReportSource;
    }
}
CopyVB.NET
Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
    If Not IsPostBack Then
        Dim instanceReportSource As New Telerik.Reporting.InstanceReportSource()
        instanceReportSource.ReportDocument = New ListBoundReport()
        ReportViewer1.ReportSource = instanceReportSource
        ReportViewer1.RefreshReport()
    End If
End Sub

See Also

Other Resources

Solution Structure
How do I set 100% height to the Web Report Viewer
Overview
Report Viewer Localization
Deploying Web ReportViewer in SharePoint
Medium Trust Support


Report Viewer Localization

[image]

Telerik Reporting Q2 2012
Report Viewer Localization
See Also Send Feedback

In the Web Report Viewer, localized resources are stored in separate RESX resource files and loaded according to the current UI culture settings. To understand how localized resources are loaded, it is useful to think of them as being organized in a hierarchical manner.

Types of Resources in the Hierarchy

  • At the top of the hierarchy sit the fallback resources for the default UI culture, which is English (“en”) by default. These are the only resources that do not have their own file. They are stored directly in the assembly of the Report Viewer.
  • Below the fallback resources are the resources for any neutral cultures. A neutral culture is associated with a language but not a region. For example, French ("fr") is a neutral culture. Note that the fallback resources are also for a neutral culture, but a special one.
  • Below those are the resources for any specific cultures. A specific culture is associated with a language and a region. For example, French Canadian ("fr-CA") is a specific culture.

When the Report Viewer tries to load any localized resource and does not find it it will travel up the hierarchy until it finds a resource file containing the requested resource.

The best way to store your resources is to generalize them as much as possible. That means to store localized strings in resource files for neutral cultures rather than specific cultures whenever possible. For instance, if you have resources for the French Belgian ("fr-BE") culture and the resources immediately above are the fallback resources in English, a problem may result when someone uses your application on a system configured for the French Canadian culture. The Report Viewer will look for a RESX file named "fr-CA", it will not find it and will load the fallback resource, which is English, instead of loading the French resources. The following picture shows this undesirable scenario.

If you follow the recommended practice of placing as many resources as possible in a neutral resource file for the "fr" culture, the French Canadian user would not see resources marked for the "fr-BE" culture, but he or she would still see strings in French. The following situation demonstrates this preferred scenario.

Naming Conventions for the Localization Resources

The Report Viewer uses the following naming convention when searching for localized RESX resource files in the main application folder:

  • The names of the RESX localization resource files should have the following format:

    Telerik.ReportViewer.WebForms.Resources.[culture].resx

    Here “[culture]” is the name of the culture for the specified localization resource. For example, to provide a localization resource for the French Belgian culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WebForms.Resources.fr-BE.resx

  • Respectively, to provide a localization resource for the French neutral culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WebForms.Resources.fr.resx

  • It is possible to override the default resources for the language neutral culture, which are stored in the assembly of the Report Viewer. In that case the resource file should be named as follows:

    Telerik.ReportViewer.WebForms.Resources.resx

As described above, if for example the current UI culture is set to French Belgian, the Report Viewer will search for localized RESX resource files inside the main application folder in the following order:

  1. Telerik.ReportViewer.WebForms.Resources.fr-BE.resx
  2. Telerik.ReportViewer.WebForms.Resources.fr.resx
  3. Telerik.ReportViewer.WebForms.Resources.resx

The above diagram illustrates a simple view of the resource fallback for a UI culture set to “fr-BE”. The Report Viewer handles the case probing the “fr-BE” RESX resource file for the requested key first, and subsequently falls back to the neutral French culture “fr”, ultimately looking in the default assembly resources for a value if a value has still not been found.

Adding Localization Resources for the Report Viewer

  1. Add an ASP.NET folder "App_GlobalResources" to the main project of the web application or web site, if such a folder does not already exist.
  2. Add a new RESX resource file to the "App_GlobalResources" folder. Name the newly-created RESX file according to the naming convention described above.
  3. (not applicable for web site projects) In the Property Inspector specify the following properties for the resource file:
    1. Build Action: "None"
    2. Copy to Output Directory: "Copy if newer" or "Copy always"
  4. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  5. Repeat steps from 2 to 4 for each desired translation of the Report Viewer.
  6. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.

Distributing an Application with a Localized Report Viewer

In order to distribute an application that uses Telerik Reporting with a localized Report Viewer, one should distribute all of the required localization RESX resource files, in addition to the main application assemblies. For Web Sites and Web Applications the localization RESX resource files should be placed in the "App_GlobalResources" folder. In case of Precompiled website, place the RESX file in the bin folder.

See Also

Other Resources

Hierarchical Organization of Resources for Localization
Setting the Culture and UI Culture for Web Forms Globalization
Security and Localized Satellite Assemblies


Deploying Web ReportViewer in SharePoint

[image]

Telerik Reporting Q2 2012
Deploying Web ReportViewer in SharePoint
See Also Send Feedback

This topic outlines the required steps that need to be taken to deploy the web ReportViewer prior to implementing it within an existing MOSS web site.

  1. First you need to install Telerik.Reporting.dll and Telerik.ReportViewer.WebForms.dll in the GAC (Global Assembly Cache) of your SharePoint server. For more information please refer to How to: Install an Assembly into the Global Assembly Cache article.
  2. Next you should tell SharePoint that the Reporting assemblies are safe to use. To do so you should add a few <SafeControl> entries within the <SafeControls> section of your web.config:
    CopyXML
    <SafeControl Assembly="Telerik.Reporting, Version=x.x.x.xxxx, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" Namespace="Telerik.Reporting" TypeName="*" Safe="True" />
<SafeControl Assembly="Telerik.ReportViewer.WebForms, Version=x.x.x.xxxx, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" Namespace="Telerik.ReportViewer" TypeName="*" Safe="True" />
  3. In order for the report viewer to function properly, you need to register its handler in the <system.web>\<httpHandlers> section in the web.config:
    CopyXML
    <add path="Telerik.ReportViewer.axd" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" verb="*" validate="true" />

    When the application is hosted on IIS 7+, the handler of the report viewer should be registered in the <system.webServer>\<handlers> section as well:

    CopyXML
    <add name="Telerik.ReportViewer.axd_*" path="Telerik.ReportViewer.axd" verb="*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" preCondition="integratedMode" />

  4. Open the page where you want to add the ReportViewer control (e.g. e.g. default.master) and if prompted to check out the file select “Yes”. Now you need to register the Telerik.ReportViewer.WebForms assembly in the master page. Do so by adding the following directive:
    CopyXML
    <%@ Register TagPrefix="telerik" Namespace="Telerik.ReportViewer.WebForms"
        Assembly="Telerik.ReportViewer.WebForms, Version=x.x.x.xxxx, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" %>
    Note
    Note that the version of an assembly is specified in each <SafeControl> tag. Make sure that you input the correct version you use before proceeding.
    Note
    The ReportViewer uses the session state to preserve the report instance assigned to its Report property during page postbacks and for some other design reasons as well. Thus have in mind that you should enable session state on your SharePoint server.

See Also

Other Resources

Overview
How to: Add report viewer to a web page
Medium Trust Support
AJAX support


AJAX support

[image]

Telerik Reporting Q2 2012
AJAX support
See Also Send Feedback

The main idea of Ajax requests is the elimination of full-page postbacks. In contrast, only the relevant parts of the page are updated, without a disturbing refresh. The markup that is transferred between the client machine and the server is reduced dramatically, which results in a significant performance improvement.

The Web ReportViewer can work both Telerik RadAjax and the native ASP.NET AJAX frameworks. Generally you do not have to apply ajax for the Web ReportViewer itself as all its commands are issued through an http handler and update only the report/report parameters areas and not the entire page.

So when might you need to use ajax in conjunction with the web report viewer? A valid case is when you want to change the Report on another control action e.g. button click.

Issue Ajax Request through Telerik RadAjaxManager

Add the instance of the ReportViewer to a RadAjaxManager control. You can optionally provide it with a loading panel, as shown below:

CopyXML
<asp:Button ID="Button1" runat="server" Text="Button" onclick="Button1_Click" />
<telerik:ReportViewer ID="ReportViewer1" runat="server"></telerik:ReportViewer>
<telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">
            <AjaxSettings>
                <telerik:AjaxSetting AjaxControlID="Button1">
                    <UpdatedControls>
                        <telerik:AjaxUpdatedControl ControlID="ReportViewer1"/>
                    </UpdatedControls>
                </telerik:AjaxSetting>
            </AjaxSettings>
</telerik:RadAjaxManager>
CopyC#
protected void Button1_Click(object sender, EventArgs e)
{
   ReportViewer1.Report = new BarcodesReport();
}
CopyVB.NET
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ReportViewer1.Report = New BarcodesReport()
End Sub

Issue Ajax Request through ASP.NET AJAX UpdatePanel

Wrap the instance of the ReportViewer into UpdatePanel ContentTemplate:

CopyXML
<asp:ScriptManager ID="ScriptManager1" runat="server" />
<asp:Button ID="Button1" runat="server" Text="Button" onclick="Button1_Click" />
<asp:UpdatePanel ID="UpdatePanel1" runat="server">
<Triggers>
    <asp:AsyncPostBackTrigger ControlID="Button1" />
</Triggers>
    <ContentTemplate>
       <telerik:ReportViewer ID="ReportViewer1" runat="server">
        </telerik:ReportViewer>
    </ContentTemplate>
</asp:UpdatePanel>
CopyC#
protected void Button1_Click(object sender, EventArgs e)
{
   ReportViewer1.Report = new BarcodesReport();
}
CopyVB.NET
Protected Sub Button1_Click(sender As Object, e As EventArgs)
    ReportViewer1.Report = New BarcodesReport()
End Sub

See Also

Other Resources

Overview
How to: Add report viewer to a web page
Report Viewer Localization
Deploying Web ReportViewer in SharePoint
Medium Trust Support


Client-Side API

[image]

Telerik Reporting Q2 2012
Client-Side API
Send Feedback

Accessing the client-side report viewer object

The ReportViewer control creates a client-side object with the ClientID of the viewer. You can obtain reference to it by using the following javascript code:

var viewer = <%=ReportViewer1.ClientID%>

Client API

Member

Parameters

Description

PrintReport()

N/A

Starts printing of the document. Uses the Adobe PDF Reader browser add-on if available. Otherwise uses the default print functionality of the browser.

set_CurrentPage(pageNumber)

pageNumber: number of the page(starts from 1).

Specifies the number of the page which has to be displayed in the viewer.

get_CurrentPage()

Returns the number of the page currently shown in the viewer.

get_TotalPages()

Returns the total count of document pages.

CanMoveToPage(pageNumber)

pageNumber: the number of the page to which you want to navigate.

Checks whether is possible to navigate to a specific page.

RefreshReport()

N/A

Refreshes the report.

ExportReport(format)

The available formats are listed in the Rendering Extensions article.

Exports the document to one of the specified formats.

PrintAs(format)

format:

  • "PDF": uses the Adobe PDF Reader add-on.
  • "Default": uses the default printing capabilities of the browser.

Forces the viewer to print the document according to the specified print format.

ShowDocumentMap()

Shows the DocumentMap
HideDocumentMap() Hides the DocumentMap


Design Considerations for Out-proc Session State

[image]

Telerik Reporting Q2 2012
Design Considerations for Out-proc Session State
See Also Send Feedback

The ReportViewer control uses the ASP.NET session state to preserve the report instance assigned to its Report property during page postbacks and for some other design reasons as well. Sometimes because of different requirements the web application has to be configured to use an out-proc session state such as SQLServer or StateServer. When this is the case, the report instance has to be serialized and deserialized in contrast to the InProc session state mode where the report just stays in memory and is available at any time as it is. However, during the deserialization of the session object, the report is instantiated again through its default constructor which leads to the following limitations:

  • The report should have a default constructor (constructor without parameters i.e. parameterless constructor).
  • All modifications made to the report instance, after the default constructor has been called are ignored.

Additionally the values of the report’s DataSource and DataMemeber properties and the current values of the report parameters are also preserved in ASP.NET session state. The latter is especially important and can be used to pass values from the page with the ReportViewer control to the report definition. This is achieved by using the parameters in expressions where they are supported (e.g. Value properties; Filter, Sorting and Grouping expressions; etc.).

As the value of the DataSource property is kept in the ASP.NET session state, it is also recommended to use the NeedDataSource event to populate the report with data that when in an out-proc session mode. Otherwise the Session will either become very large, especially when using large datasets or the data for the report will not be serialized at all if it cannot be binary serialized/deserialized (e.g. business objects, anonymous types, data adapters, etc.). Again you can use the parameters' values to pass specific information needed to retrieve the relevant data in the NeedDataSource event.

Example 1: Modifying the Value of a TextBox item using an expression and a report parameter.

The goal is to change the value of a TextBox item in the report, according to the selected value in a drop down list:

  1. The SelectedIndexChanged event handler of the DropDownList:
    CopyC#
    protected void DropDownList1_SelectedIndexChanged(object sender, EventArgs e)
{
    Report report = (Report)this.ReportViewer1.Report;
    report.ReportParameters["Year"].Value = ((DropDownList)sender).SelectedItem.Value;
}
    CopyVB.NET
    Protected Sub DropDownList1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DropDownList1.SelectedIndexChanged
    Dim report As Telerik.Reporting.Report = CType(Me.ReportViewer1.Report, Telerik.Reporting.Report)
    report.ReportParameters("Year").Value = CType(sender, DropDownList).SelectedItem.ToString()
End Sub
  2. The expression for the Value property of the TextBox item:
  3. Setting the report parameter:

Example 2: Using report parameters to retrieve specific data.

The goal is to retrieve a name depending on the selected year from a drop down list:

  1. The SelectedIndexChanged event handler implementation of the DropDownList:
    CopyC#
    protected void DropDownList1_SelectedIndexChanged(object sender, EventArgs e)
{
    Report report = (Report)this.ReportViewer1.Report;
    report.ReportParameters["Year"].Value = ((DropDownList)sender).SelectedItem.Value;
}
    CopyVB.NET
    Protected Sub DropDownList1_SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) Handles DropDownList1.SelectedIndexChanged
    Dim report As Telerik.Reporting.Report = CType(Me.ReportViewer1.Report, Telerik.Reporting.Report)
    report.ReportParameters("Year").Value = CType(sender, DropDownList).SelectedItem.Value
End Sub

  2. Expressions for the TextBox items:

  3. Setting the report parameter:

  4. The NeedDataSource event of the report:

    CopyC#
    private void Report2_NeedDataSource(object sender, EventArgs e)
{
    Telerik.Reporting.Processing.Report report = (Telerik.Reporting.Processing.Report)sender;
    report.DataSource = GetData((string)report.Parameters["Year"]);
}
    CopyVB.NET
    Private Sub Report2_NeedDataSource(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.NeedDataSource
    Dim report As Telerik.Reporting.Processing.Report = CType(sender, dTelerik.Reporting.Processing.Report)
    report.DataSource = GetData(report.Parameters("Year"))
End Sub

  5. A sample method with a parameter to retrieve the relevant data. You should implemented your way for getting the data here:

    CopyC#
    static DataTable GetData(string year)
{
    DataTable table = new DataTable();
    table.Columns.Add("Name", typeof(string));
    if ("2007" == year)
    {
        table.Rows.Add("Peter");
    }
    else if ("2008" == year)
    {
        table.Rows.Add("Scott");
    }
    return table;
}
    CopyVB.NET
    Private Shared Function GetData(ByVal year) As DataTable
    Dim table As DataTable
    table = New DataTable()
    table.Columns.Add("Name", GetType(String))
    If (year = "2007") Then
        table.Rows.Add("Peter")
    ElseIf (year = "2008") Then
        table.Rows.Add("Scott")
    End If
    Return table
End Function

See Also

Other Resources

Overview
How to: Add report viewer to a web page
Report Viewer Localization
Medium Trust Support
AJAX support


Windows Forms Report Viewer

[image]

Telerik Reporting Q2 2012
Windows Forms Report Viewer
Send Feedback

This section discusses the usage of the Windows Forms Report Viewer:

  • Viewer Introduction
  • Assign report to the Windows Forms viewer
  • Report Viewer Localization
  • ReportViewer events


Overview

[image]

Telerik Reporting Q2 2012
Overview
See Also Send Feedback

The Windows Forms Report Viewer is designed to render Telerik Reports within Windows Forms projects.

The toolbar on the Windows Forms Report Viewer provides basic functionality for interacting with the currently-loaded report:

  • Navigate back in history
  • Navigate forward in history
  • Stop loading (useful when a large report is taking a long time to load)
  • Refresh
  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Page Setup (set paper kind, orientation, margins)
  • Print Preview: switches between Logical and Physical page renderer. See Rendering and Paging for more info.
  • Print
  • Export: see Rendering Extensions for available export formats.
  • Zoom level
  • Show/Hide parameters area
  • Show/Hide document map
Note

.NET Framework Client Profiles (3.5 SP1, 4.0) are not supported.

See Also

Other Resources

How to: Add report viewer to a Windows Forms' Form
Report Viewer Localization
ReportViewer events
Windows Forms Report Viewer


How to: Add report viewer to a Windows Forms' Form

[image]

Telerik Reporting Q2 2012
How to: Add report viewer to a Windows Forms' Form
See Also Send Feedback

Assign report to the viewer in design time

To use Telerik Reports in Windows Forms application, you need the Windows Forms report viewer:

  1. Drag the ReportViewer control from the Toolbox to the form design surface.

  2. Add reference to the class library that contains your reports in the windows form application.
  3. Build the application
  4. Set the ReportSource of the viewer using the combobox in the Properties Window.
  5. To run the report in the viewer, call ReportViewer.RefreshReport() from your application code.

Assign report to the viewer programatically

In the Form_Load event handler you create an instance report source and set its ReportDocument property to a report instance. Next assign the instance report source to the ReportSource property of the viewer. Finally call ReportViewer.RefreshReport().

Example

CopyC#
private void Form1_Load(object sender, EventArgs e)
{
    Telerik.Reporting.InstanceReportSource instanceReportSource = new Telerik.Reporting.InstanceReportSource();
    instanceReportSource.ReportDocument = new Telerik.Reporting.Examples.CSharp.ListBoundReport();
    reportViewer1.ReportSource = instanceReportSource;
    reportViewer1.RefreshReport();
}
CopyVB.NET
Private Sub Form1_Load(sender As System.Object, e As System.EventArgs) Handles MyBase.Load
    Dim instanceReportSource As New Telerik.Reporting.InstanceReportSource()
    instanceReportSource.ReportDocument = New ListBoundReport()
    ReportViewer1.ReportSource = instanceReportSource
    ReportViewer1.RefreshReport()
End Sub

See Also

Other Resources

Solution Structure
Overview
Report Viewer Localization
ReportViewer events


Report Viewer Localization

[image]

Telerik Reporting Q2 2012
Report Viewer Localization
See Also Send Feedback

In the Windows Report Viewer, localized resources are stored in separate RESX resource files and loaded according to the current UI culture settings. To understand how localized resources are loaded, it is useful to think of them as being organized in a hierarchical manner.

Types of Resources in the Hierarchy

  • At the top of the hierarchy sit the fallback resources for the default UI culture, which is English ("en") by default. These are the only resources that do not have their own file. They are stored directly in the assembly of the Report Viewer.
  • Below the fallback resources are the resources for any neutral cultures. A neutral culture is associated with a language but not a region. For example, French ("fr") is a neutral culture. Note that the fallback resources are also for a neutral culture, but a special one.
  • Below those are the resources for any specific cultures. A specific culture is associated with a language and a region. For example, French Canadian ("fr-CA") is a specific culture.

When the Report Viewer tries to load any localized resource and does not find it it will travel up the hierarchy until it finds a resource file containing the requested resource.

The best way to store your resources is to generalize them as much as possible. That means to store localized strings in resource files for neutral cultures rather than specific cultures whenever possible. For instance, if you have resources for the French Belgian ("fr-BE") culture and the resources immediately above are the fallback resources in English, a problem may result when someone uses your application on a system configured for the French Canadian culture. The Report Viewer will look for a RESX file named "fr-CA", it will not find it and will load the fallback resource, which is English, instead of loading the French resources. The following picture shows this undesirable scenario.

If you follow the recommended practice of placing as many resources as possible in a neutral resource file for the "fr" culture, the French Canadian user would not see resources marked for the "fr-BE" culture, but he or she would still see strings in French. The following situation demonstrates this preferred scenario.

Naming Conventions for the Localization Resources

The Report Viewer uses the following naming convention when searching for localized RESX resource files in the main application folder:

  • The names of the RESX localization resource files should have the following format:

    Telerik.ReportViewer.WinForms.Resources.[culture].resx

    Here “[culture]” is the name of the culture for the specified localization resource. For example, to provide a localization resource for the French Belgian culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WinForms.Resources.fr-BE.resx

  • Respectively, to provide a localization resource for the French neutral culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WinForms.Resources.fr.resx

  • It is possible to override the default resources for the language neutral culture, which are stored in the assembly of the Report Viewer. In that case the resource file should be named as follows:

    Telerik.ReportViewer.WinForms.Resources.resx

As described above, if for example the current UI culture is set to French Belgian, the Report Viewer will search for localized RESX resource files inside the main application folder in the following order:

  1. Telerik.ReportViewer.WinForms.Resources.fr-BE.resx
  2. Telerik.ReportViewer.WinForms.Resources.fr.resx
  3. Telerik.ReportViewer.WinForms.Resources.resx

The above diagram illustrates a simple view of the resource fallback for a UI culture set to "fr-BE". The Report Viewer handles the case probing the "fr-BE" RESX resource file for the requested key first, and subsequently falls back to the neutral French culture "fr", ultimately looking in the default assembly resources for a value if a value has still not been found.

Adding Localization Resources for the Report Viewer

  1. Add a new RESX resource file to the main project of the application. Name the newly-created RESX file according to the naming convention described above.
  2. In the Property Inspector specify the following properties for the resource file:
    1. Build Action: "None"
    2. Copy to Output Directory: "Copy if newer" or "Copy always"
  3. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  4. Repeat steps from 1 to 3 for each desired translation of the Report Viewer.
  5. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.

Distributing an Application with a Localized Report Viewer

In order to distribute an application that uses Telerik Reporting with a localized Report Viewer, one should distribute all of the required localization RESX resource files, in addition to the main application assemblies. For Windows Forms Applications the RESX files should be placed in the same directory, where the application is installed.

Related articles

Windows Forms Report Viewer

Overview

How to: Add report viewer to a Windows Forms' Form

ReportViewer events

See Also

Other Resources

Hierarchical Organization of Resources for Localization
Setting the Culture and UI Culture for Windows Forms Globalization
Security and Localized Satellite Assemblies


ReportViewer events

[image]

Telerik Reporting Q2 2012
ReportViewer events
See Also Send Feedback

Our WinForms ReportViewer exposes four events: Export, Print, RenderingBegin and UpdateUI

Export event

The Export event occurs when the report shown in the ReportViewer control is exported. The Export event handler receives two arguments:

  1. The ReportViewer control that owns the report that is being exported. This argument is of type object, but can be cast to the ReportViewer type.
  2. Telerik.ReportViewer.WinForms.ExportEventArgs with the following properties:
  • Cancel: This boolean property can be set true to abandon exporting
  • DeviceInfo: This property can be used to pass rendering parameters to a rendering extension (more info here).
  • RenderingExtension: This property is read only and shows export extention info for the exported report. More info is available in the Rendering extensions help article.

Example

CopyC#
private void reportViewer1_Export(object sender, Telerik.ReportViewer.WinForms.ExportEventArgs args)
{
    switch (args.RenderingExtension.Name)
    {
        case "Excel":
            //do something
            break;
        case "PDF":
            //do something
            break;
    }
CopyVB.NET
Private Sub reportViewer1_Export(sender As Object, args As Telerik.ReportViewer.WinForms.ExportEventArgs)
    Select Case args.RenderingExtension.Name
        Case "Excel"
            'do something
            Exit Select
        Case "PDF"
            'do something
            Exit Select
    End Select
End Sub

Print event

The Print event occurs when the report shown in the ReportViewer control is printed. The Print event handler receives two arguments:

  1. The ReportViewer control that owns the report that is being exported. This argument is of type object, but can be cast to the ReportViewer type.
  2. System.ComponentModel.CancelEventArgs with a single property:Cancel: This boolean property can be set true to abandon printing

Example

CopyC#
private void reportViewer1_Print(object sender, System.ComponentModel.CancelEventArgs e)
{
    e.Cancel = true;
}
CopyVB.NET
Private Sub reportViewer1_Print(sender As Object, e As System.ComponentModel.CancelEventArgs)
    e.Cancel = True
End Sub

RenderingBegin event

The RenderingBegin event occurs when the report in the viewer control is rendered. The RenderingBegin event handler receives two arguments:

  1. The ReportViewer control that owns the report that is being exported. This argument is of type object, but can be cast to the ReportViewer type.
  2. System.ComponentModel.CancelEventArgs with a single property:Cancel: This boolean property can be set true to abandon rendering
CopyC#
private void reportViewer1_RenderingBegin(object sender, System.ComponentModel.CancelEventArgs e)
{
    e.Cancel = true;
}
CopyVB.NET
Private Sub reportViewer1_RenderingBegin(sender As Object, e As System.ComponentModel.CancelEventArgs)
    e.Cancel = True
End Sub

UpdateUI event

The UpdateUI event occurs when the UI of the report viewer control is updated. The UpdateUI event handler receives two arguments:

  1. The ReportViewer control that owns the report that is being exported. This argument is of type object, but can be cast to the ReportViewer type.
  2. System.EventArgs

See Also

Other Resources

Overview
How to: Add report viewer to a Windows Forms' Form
Report Viewer Localization


Silverlight Report Viewer

[image]

Telerik Reporting Q2 2012
Silverlight Report Viewer
Send Feedback

In order to use our Silverlight Report Viewer, you need a Silverlight application. In order to create such, you need the following tools installed:

System Requirements

  • Telerik Reporting Q3 2009+. Download the latest version here.
  • The corresponding RadControls for Silverlight version , available at the time of the Telerik Reporting release to use the Telerik Reporting Silverlight Report Viewer.
  • Visual Studio 2010
  • The latest version of Microsoft Silverlight (Silverlight 4 supported only)
  • The latest version of Silverlight Tools/SDK for VS2010 is needed for development
  • .NET Framework 3.5 Service Pack 1
  • (optional) Expression Blend
Note

The Silverlight report viewer requires the Telerik Reporting WCF Service. For more information: Telerik Reporting WCF Service.

In This Section

  • Overview
  • How to: Add report viewer to a Silverlight application
  • Using Custom Bindings
  • Creating Style in Expression Blend


Overview

[image]

Telerik Reporting Q2 2012
Overview
See Also Send Feedback

The Silverlight Report Viewer allows developers to deliver reports produced by Telerik Reporting to any rich application developed with Silverlight. The most significant difference between the Silverlight viewer and the other viewers is that it lives entirely on the client side, while the reports and the rendering engine are on the server side (accessible through the Telerik Reporting WCF Service).

The toolbar on the Silverlight Report Viewer provides basic functionality for interacting with the currently-loaded report:

  • Navigate back in history
  • Navigate forward in history
  • Refresh
  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Print Preview: switches between Logical and Physical page renderer. See Rendering and Paging for more info.
  • Print: use ReportViewer..::.UseNativePrinting to switch between Silverlight native print and True Print.
  • Export: see Rendering Extensions for available export formats.
  • Show/Hide document map
  • Show/Hide parameters area
  • Zooming

Silverlight report viewer specific properties

  • ReportViewer..::.ReportServiceUri - the location of the report service - absolute or relative Uri. If the uri is absolute, the same instance is returned. If the uri is relative, a new absolute Uri based on the combination of Source of the current application and the given relative uri is created. The Source usually points to the application package (XAP).
  • ReportViewer..::.Report - the assembly qualified name of the Report type for the viewer to display;
  • ReportViewer..::.UseNativePrinting - Specifies whether to use native Silverlight printing or True Print. Default value is true. Currently the Silverlight document print has very limited API which does not allow to set the page orientation. This has to be done manually from the printer settings.

See Also

Other Resources

How to: Add report viewer to a Silverlight application
Using Custom Bindings
Creating Style in Expression Blend


How to: Add report viewer to a Silverlight application

[image]

Telerik Reporting Q2 2012
How to: Add report viewer to a Silverlight application
See Also Send Feedback

This article explains the steps needed to create an application which uses the Silverlight report viewer.

  1. First you need to create a Silverlight project. Once you do, add references to the following assemblies in your Silverlight project:
    • Telerik.ReportViewer.Silverlight.dll (located in C:\Program Files\Telerik\Reporting Q2 2012\Bin)
    • System.Windows.Controls.dll
    • Telerik.Windows.Controls.dll
    • Telerik.Windows.Controls.Input.dll
    • Telerik.Windows.Controls.Navigation.dll

    The RadControls for Silverlight assemblies are located in C:\Program Files\Telerik\Reporting Q2 2012\Examples\CSharp\SilverlightDemo\bin)

  2. Add the ReportViewer to the MainPage.xaml from the ToolBox either through Visual Studio 2010 or from Expression Blend. You should skip points #3, #4 and #5 if you have done that, as they describe how to register the report viewer manually.
  3. Open MainPage.xaml
  4. Register the namespace in the following way: xmlns:<Name of namespace>= "<Name of assembly>" in our case xmlns:telerik="clr-namespace:Telerik.ReportViewer.Silverlight;assembly=Telerik.ReportViewer.Silverlight"
  5. Now you would be able to declare the ReportViewer control:
    CopyXML
    <telerik:ReportViewer></telerik:ReportViewer>
  6. Next we need to set the ReportServiceUri and Report properties of the viewer. The ReportViewer..::.ReportServiceUri should point to the Telerik Reporting WCF service:(ReportServiceUri="../ReportService.svc") and the ReportViewer..::.Report should be set to the assembly qualified name of the report you want to show i.e.:(Report="Telerik.Reporting.Examples.CSharp.BarcodesReport, CSharp.ReportLibrary, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"). Review Creating a Simple Report topic for information on creating a Telerik Report. The MainPage.xaml should look similar:

    Example

    CopyXML
    <UserControl x:Class="MainPage"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
    xmlns:telerik="clr-namespace:Telerik.ReportViewer.Silverlight;assembly=Telerik.ReportViewer.Silverlight">

    <Grid x:Name="LayoutRoot">
            <telerik:ReportViewer  x:Name="ReportViewer1" Width="1000"
              ReportServiceUri="../ReportService.svc"
              Report="Telerik.Reporting.Examples.CSharp.BarcodesReport, CSharp.ReportLibrary, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null">
            </telerik:ReportViewer>
  </Grid>
</UserControl>

See Also

Other Resources

Overview
Using Custom Bindings
Creating Style in Expression Blend
Silverlight Report Viewer


Report Viewer Localization

[image]

Telerik Reporting Q2 2012
Report Viewer Localization
See Also Send Feedback

In the Silverlight Report Viewer, localized resources are stored in separate RESX resource files and loaded according to the current UI culture settings. To understand how localized resources are loaded, it is useful to think of them as being organized in a hierarchical manner.

Types of Resources in the Hierarchy

  • At the top of the hierarchy sit the fallback resources for the default UI culture, which is English ("en") by default. These are the only resources that do not have their own file. They are stored directly in the assembly of the Report Viewer.
  • Below the fallback resources are the resources for any neutral cultures. A neutral culture is associated with a language but not a region. For example, French ("fr") is a neutral culture. Note that the fallback resources are also for a neutral culture, but a special one.
  • Below those are the resources for any specific cultures. A specific culture is associated with a language and a region. For example, French Canadian ("fr-CA") is a specific culture.

When the Report Viewer tries to load any localized resource and does not find it it will travel up the hierarchy until it finds a resource file containing the requested resource.

The best way to store your resources is to generalize them as much as possible. That means to store localized strings in resource files for neutral cultures rather than specific cultures whenever possible. For instance, if you have resources for the French Belgian ("fr-BE") culture and the resources immediately above are the fallback resources in English, a problem may result when someone uses your application on a system configured for the French Canadian culture. The Report Viewer will look for a RESX file named "fr-CA", it will not find it and will load the fallback resource, which is English, instead of loading the French resources. The following picture shows this undesirable scenario.

If you follow the recommended practice of placing as many resources as possible in a neutral resource file for the "fr" culture, the French Canadian user would not see resources marked for the "fr-BE" culture, but he or she would still see strings in French. The following situation demonstrates this preferred scenario.

Naming Conventions for the Localization Resources

The Report Viewer uses the following naming convention when searching for localized RESX resource files in the main application folder:

  • The names of the RESX localization resource files should have the following format:

    Telerik.ReportViewer.Silverlight.TextResources.[culture].resx

    Here “[culture]” is the name of the culture for the specified localization resource. For example, to provide a localization resource for the French Belgian culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.Silverlight.TextResources.fr-BE.resx

  • Respectively, to provide a localization resource for the French neutral culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.Silverlight.TextResources.fr.resx

  • It is possible to override the default resources for the language neutral culture, which are stored in the assembly of the Report Viewer. In that case the resource file should be named as follows:

    Telerik.ReportViewer.Silverlight.TextResources.resx

As described above, if for example the current UI culture is set to French Belgian, the Report Viewer will search for localized RESX resource files inside the main application folder in the following order:

  1. Telerik.ReportViewer.Silverlight.TextResources.fr-BE.resx
  2. Telerik.ReportViewer.Silverlight.TextResources.fr.resx
  3. Telerik.ReportViewer.Silverlight.TextResources.resx

The above diagram illustrates a simple view of the resource fallback for a UI culture set to "fr-BE". The Report Viewer handles the case probing the "fr-BE" RESX resource file for the requested key first, and subsequently falls back to the neutral French culture "fr", ultimately looking in the default assembly resources for a value if a value has still not been found.

Adding Localization Resources for the Report Viewer

  1. Add a new RESX resource file to the main project of the application. Name the newly-created RESX file according to the naming convention described above.
  2. In the Property Inspector specify the following properties for the resource file:
    1. Build Action: "Embedded Resource"
    2. Copy to Output Directory: "Copy if newer" or "Copy always"
  3. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  4. Unload the project by right clicking on it and selecting "Unload Project"
  5. Right click on the project again and select "Edit MyProject.csproj"
  6. Locate the SupportedCultures tag and add the supported cultures (there is no need to specify the neutral culture):
    CopyXML
    <SupportedCultures>
    fr;fr-BE
</SupportedCultures>
  7. Reload and build the project
  8. Repeat steps from 1 to 3 for each desired translation of the Report Viewer. Steps 4 to 7 can be performed at the end only once.
  9. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.

Distributing an Application with a Localized Report Viewer

In order to distribute an application that uses Telerik Reporting with a localized Report Viewer, one should distribute all of the required localization RESX resource files, in addition to the main application assemblies. For Silverlight Applications the RESX files should be placed in the "Localization" folder.

Localization Using the ITextResources interface

The other way to localize the Silverlight Report Viewer in a more flexible manner is to create a class that implements the ITextResources interface and to implement all its properties, which represent all tooltips and messages in the Report Viewer. After you implement ITextResources you have to pass an instance of your custom class to the TextResources property ot the report viewer. The logic is pretty simple, the property just has to return the correct translation for each resource key, as it is shown below:

CopyC#
public class CustomResources : Telerik.ReportViewer.Silverlight.ITextResources
{
    public string AllFiles
    {
        get
        {
            return "Todos Archivos";
        }
    }
    public string BackToolTip
    {
        get
        {
            return "Navega hacia atrás";
        }
    }
    public string CurrentPageToolTip
    {
        get
        {
            return "Página corriente";
        }
    }

    //...... Implement the rest of the properties ......

}
CopyVB.NET
Public Class CustomResources
    Implements Telerik.ReportViewer.Silverlight.ITextResources

    Public ReadOnly Property AllFiles() As String Implements ReportViewer.Silverlight.ITextResources.AllFiles
        Get
            Return "Todos Archivos"
        End Get
    End Property

    Public ReadOnly Property BackToolTip() As String Implements ReportViewer.Silverlight.ITextResources.BackToolTip
        Get
            Return "Navega hacia atrás"
        End Get
    End Property

    Public ReadOnly Property CurrentPageToolTip() As String Implements ReportViewer.Silverlight.ITextResources.CurrentPageToolTip
        Get
            Return "Página corriente"
        End Get
    End Property

    '...... Implement the rest of the properties ......

End Class

Instead of a hard-coded string the property can be set in a method/contructor or to be created a method that returns string and implements a cutsom logic, for example retreives the resource key from a database.

CopyC#
public class CustomTextResources : Telerik.ReportViewer.Silverlight.ITextResources
{

    public string AllFiles
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.AllFiles);
        }
    }

    public string BackToolTip
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.BackToolTip);
        }
    }

    public string CurrentPageToolTip
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.CurrentPageToolTip);
        }
    }

    //...... Implement the rest of the properties ......

}
CopyVB.NET
Public Class CustomTextResources
    Implements Telerik.ReportViewer.Silverlight.ITextResources

    Public ReadOnly Property AllFiles() As String Implements ReportViewer.Silverlight.ITextResources.AllFiles
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.AllFiles)
        End Get
    End Property

    Public ReadOnly Property BackToolTip() As String Implements ReportViewer.Silverlight.ITextResources.BackToolTip
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.BackToolTip)
        End Get
    End Property

    Public ReadOnly Property CurrentPageToolTip() As String Implements ReportViewer.Silverlight.ITextResources.CurrentPageToolTip
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.CurrentPageToolTip)
        End Get
    End Property

    '...... Implement the rest of the properties ......

End Class

Related articles

Silverlight Report Viewer

Overview

How to: Add report viewer to a Silverlight application

Creating Style in Expression Blend

See Also

Other Resources

Hierarchical Organization of Resources for Localization
Silverlight Globalization and Localization Overview
Security and Localized Satellite Assemblies


Using Custom Bindings

[image]

Telerik Reporting Q2 2012
Using Custom Bindings
Send Feedback

You might encounter a need to use custom Bindings for the ReportServiceClient in certain scenarios. To do that create your own ReportServiceClient object instance and initialize it according to your needs.

You need to implement the IReportServiceClientFactory interface and its only method should create and return a new instance of the ReportServiceClient class using any of its constructors. This way you attach your custom Binding to be used for connecting to the Report Service.

Once you have implemented IReportServiceClientFactory, you should provide an instance to the report viewer so it will use it the next time it creates a new instance of the ReportServiceClient - that is when the report or report service Uri have changed or the RefreshReportCommand is executed through the ReportViewerModel.

The ReportViewer usually passes absolute Uri to the IReportServiceClientFactory.Create() method. For more information on how the ReportServiceUri is resolved to absolute please review ReportViewer..::.EnsureAbsoluteUri

The example bellow illustrates how to implement and use a custom IReportServiceClientFactory:

Example

CopyC#
using System;
using System.ServiceModel;
using System.Windows.Controls;
using Telerik.Reporting.Service.SilverlightClient;
using Telerik.ReportViewer.Silverlight;

public partial class MainPage : UserControl, IReportServiceClientFactory
{
    public MainPage()
    {
        InitializeComponent();

        this.ReportViewer1.ReportServiceClientFactory = this;
    }

    ReportServiceClient IReportServiceClientFactory.Create(System.Uri remoteAddress)
    {
        var binding = new BasicHttpBinding() // or BasicHttpBinding(BasicHttpSecurityMode.Transport) overload if SSL is used
        {
            MaxBufferSize = int.MaxValue,
            MaxReceivedMessageSize = int.MaxValue,
            ReceiveTimeout = new TimeSpan(0, 15, 0),
            SendTimeout = new TimeSpan(0, 15, 0)
        };

        var endpointAddress = new EndpointAddress(remoteAddress);

        return new ReportServiceClient(binding, endpointAddress);

    }
}
CopyVB.NET
Imports System
Imports System.ServiceModel
Imports System.Windows.Controls
Imports Telerik.Reporting.Service.SilverlightClient
Imports Telerik.ReportViewer.Silverlight

Partial Public Class MainPage
    Inherits UserControl
    Implements IReportServiceClientFactory

    Public Sub New()
        InitializeComponent()

        Me.ReportViewer1.ReportServiceClientFactory = Me

    End Sub

    Function Create(ByVal remoteAddress As Uri) As ReportServiceClient Implements IReportServiceClientFactory.Create

        Dim binding = New BasicHttpBinding()
        binding.MaxBufferSize = Integer.MaxValue
        binding.MaxReceivedMessageSize = Integer.MaxValue
        binding.ReceiveTimeout = New TimeSpan(0, 15, 0)
        binding.SendTimeout = New TimeSpan(0, 15, 0)

        Dim endpointAddress As New EndpointAddress(remoteAddress)

        Return New ReportServiceClient(binding, endpointAddress)

    End Function
End Class


Setting a Theme

[image]

Telerik Reporting Q2 2012
Setting a Theme
See Also Send Feedback

The purpose of this tutorial is to show you how to set a built-in theme to the Silverlight report viewer. This topic contains the following sections:

  • Setting instance-specific built-in theme in XAML
  • Setting instance-specific built-in theme in the code-behind
  • Setting application-wide built-in theme in the code-behind
Note

The Silverlight themes are located in separate assemblies to optimize the size of the control assembly. The WPF themes are embedded in the control assemblies. Currently the Silverlight report viewer offers the following themes:

  • Office Black - this is the default theme. No assembly is required for it.
  • Office Blue - requires Telerik.Windows.Themes.Office_Blue.dll.
  • Office Silver - requires Telerik.Windows.Themes.Office_Silver.dll.
  • Expression Dark - requires Telerik.Windows.Themes.Expression_Dark.dll.
  • Summer - requires Telerik.Windows.Themes.Summer.dll.
  • Vista - requires Telerik.Windows.Themes.Vista.dll.
  • Windows 7 - requires Telerik.Windows.Themes.Windows7.dll.
  • Transparent - requires Telerik.Windows.Themes.Transparent.dll
  • Metro - requires Telerik.Windows.Themes.Metro.dll

Note

We will use the Vista theme for the examples below.

Setting Instance-Specific Built-In Theme in XAML

In order to change the theme in XAML you have to declare a resource of type Theme and set an appropriate key. To complete this procedure follow the instructions below.

  • Open the user control that hosts the report viewer.
  • Set the attached property StyleManager.Theme value to Vista.
CopyXAML
<UserControl x:Class="MainPage"
     xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
     xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
     xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
     xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
     xmlns:telerikControls="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls"
     xmlns:telerik="clr-namespace:Telerik.ReportViewer.Silverlight;assembly=Telerik.ReportViewer.Silverlight">

     <Grid x:Name="LayoutRoot">
            <telerik:ReportViewer telerikControls:StyleManager.Theme="Vista"/>
     </Grid>
</UserControl>

Setting Instance-Specific Built-In Theme in the Code-Behind

To change the theme for the Silverlight viewer in code-behind:

  • Open your user control.
  • Make sure you have explicitly named the target control in XAML.
  • In the constructor of your user control place the following code:
CopyC#
StyleManager.SetTheme(ReportViewer1, new VistaTheme());
CopyVB.NET
StyleManager.SetTheme(ReportViewer1, new VistaTheme())

Setting Application-Wide Built-In Theme in the Code-Behind

Changing the application theme is in much bigger scale as it affects all Telerik Silverlight controls in your application. You should use the constructor of your application to set the desired theme. To change the application theme in code-behind you should declare the theme before the InitializeComponent() call, depending on the name of your theme as follows:

CopyC#
public partial class MainPage : UserControl
{
    public MainPage()
    {
        StyleManager.ApplicationTheme = new VistaTheme();
        InitializeComponent();
    }
}
CopyVB.NET
Public Partial Class MainPage
    Inherits UserControl
    Public Sub New()
        StyleManager.ApplicationTheme = New VistaTheme()
        InitializeComponent()
    End Sub
End Class
Tip

Setting an application-wide theme can be done in the constructor of your Application class as well (App.xaml.cs):

See Also

Other Resources

Creating Style in Expression Blend


Creating Style in Expression Blend

[image]

Telerik Reporting Q2 2012
Creating Style in Expression Blend
See Also Send Feedback

The purpose of this tutorial is to show you how to create/edit a Style in Expression Blend.

In order to create a style in Expression Blend you need to perform the following instructions:

  1. Open your application in Expression Blend.
    Note

    You can open your application in Expression Blend directly from your Visual Studio. For that purpose do the following things:

    1. Open your Solution Explorer (View->Solution Explorer or use the Ctrl+Alt+L shortcut)
    2. Select your user controls
    3. Right mouse button click and select "Open in Expression Blend...".

  2. In the "Objects and Timeline" pane (Window->Objects and Timeline) select the ReportViewer Control for which you want to create (modify) a style.

  3. Expand the Object -> Edit Style menu.

    You have three options here:

    • Edit Current - if you choose it, this will open the currently applied style for edit.
      Note
      If you don't have an applied style to the control, this option will be disabled.
    • Edit a Copy... - edit a copy of the default style. When you select this option a new dialog will be opened.

      The "Create Style Resource" dialog will prompt you to select a name for your style, as well as to choose the location where your style will be defined in.

    • Create Empty... - create an empty style for the selected control. When you select this option, the same "Create Style Resource" dialog will be opened. You should select a name for the style, as well as to choose the location where your style will be defined in.
Caution

Telerik Silverlight viewer uses controls from the Telerik XAML suites. If needed, you can replace them with any other controls.

See Also

Other Resources

Overview
How to: Add report viewer to a Silverlight application
Using Custom Bindings
Silverlight Report Viewer


WPF Report Viewer

[image]

Telerik Reporting Q2 2012
WPF Report Viewer
Send Feedback

In order to use the WPF Report Viewer, you need a WPF application. In order to create such, you need the following tools installed:

System Requirements

  • Telerik Reporting Q1 2010 SP1 or above. Download the latest version here.
  • The corresponding RadControls for WPF version , available at the time of the Telerik Reporting release to use the Telerik Reporting WPF Report Viewer.
  • Visual Studio 2008 SP1 or Visual Studio 2010

  • .NET Framework 3.5 Service Pack 1 or above.

    Note

    .NET Framework Client Profiles (3.5 SP1, 4.0) are not supported

  • (optional) Expression Blend

In This Section

  • Overview
  • How to: Add report viewer to a WPF application
  • Creating Style in Expression Blend


Overview

[image]

Telerik Reporting Q2 2012
Overview
See Also Send Feedback

The WPF Report Viewer allows developers to deliver reports produced by Telerik Reporting to any rich application developed with WPF.

The toolbar of the WPF Report Viewer provides basic functionality for interacting with the currently-loaded report:

  • Navigate back in history
  • Navigate forward in history
  • Refresh
  • Go to first page
  • Go to previous page
  • Go to a specific page
  • Total number of pages
  • Go to next page
  • Go to last page
  • Print Preview: switches between Logical and Physical page renderer. See Rendering and Paging for more info.
  • Print
  • Export: see Rendering Extensions for available export formats.
  • Show/Hide document map
  • Show/Hide parameters area
  • Zooming
Note

.NET Framework Client Profiles (3.5 SP1, 4.0) are not supported.

See Also

Other Resources

How to: Add report viewer to a WPF application
Creating Style in Expression Blend
WPF Report Viewer


How to: Add report viewer to a WPF application

[image]

Telerik Reporting Q2 2012
How to: Add report viewer to a WPF application
See Also Send Feedback

This article explains the steps needed to create an application which uses the WPF report viewer.

  1. Install Telerik RadControls for WPF.

  2. Create a new WPF Application project in Visual Studio. .NET Framework 4 Client Profile is not supported, so change the target framework to .NET 4 Framework.

  3. Add references to the following Telerik RadControls for WPF assemblies:

    • Telerik.Windows.Controls.dll
    • Telerik.Windows.Controls.Input.dll
    • Telerik.Windows.Controls.Navigation.dll
    • Telerik.Windows.Data.dll
    It is possible that the RadControls for WPF assemblies have a greater version than the one against which the WPF report viewer control is build. In this case you have to add appropriate assembly binding redirects (see Binding Redirects topic bellow).

  4. Drag and drop the ReportViewer control from the toolbox in a WPF window. If the ReportViewer is not available in the toolbox, you can add it using the instructions from the How to add the WPF ReportViewer to the toolbox topic bellow.

  5. Add reference to Telerik.Reporting.dll in your project.

  6. Assign a report to the Report property of the report viewer control. This can be done either declaratively or programmatically:

    • Specifying a report declaratively using its full assembly qualified name:

      Example

      CopyXML
      <Window x:Class="WpfApplication1.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    Title="Window1" Height="451" Width="683"
    xmlns:telerik="clr-namespace:Telerik.ReportViewer.Wpf;assembly=Telerik.ReportViewer.Wpf" >
    <Grid>
        <telerik:ReportViewer Name="reportViewer1" Report="Telerik.Reporting.Examples.CSharp.BarcodesReport, CSharp.ReportLibrary" />
    </Grid>
</Window>
    • Setting the Report property at run time. The following code snippet illustrates how to assign a report to the WPF ReportViewer in the Window.Loaded event handler:

      Example

      CopyC#
      <Window x:Class="WpfApplication1.Window2"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    Title="Window2" Height="328" Width="618" xmlns:my="clr-namespace:Telerik.ReportViewer.Wpf;assembly=Telerik.ReportViewer.Wpf" Loaded="Window_Loaded">
    <Grid>
        <my:ReportViewer Name="reportViewer1" />
    </Grid>
</Window>
      CopyC#
      namespace WpfApplication1
{
    using System.Windows;
    using Telerik.Reporting;

    /// <summary>
    /// Interaction logic for Window2.xaml
    /// </summary>
    public partial class Window2 : Window
    {
        public Window2()
        {
            InitializeComponent();
        }

        private void Window_Loaded(object sender, RoutedEventArgs e)
        {
            Telerik.Reporting.InstanceReportSource instanceReportSource = new Telerik.Reporting.InstanceReportSource();
            instanceReportSource.ReportDocument = new Telerik.Reporting.Examples.CSharp.ListBoundReport();

            this.reportViewer1.ReportSource = instanceReportSource;
        }
    }
}
      CopyVB.NET
      <Window x:Class="Window2"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    Title="Window2" Height="489" Width="687" xmlns:my="clr-namespace:Telerik.ReportViewer.Wpf;assembly=Telerik.ReportViewer.Wpf" Name="Window1">
    <Grid>
        <my:ReportViewer Name="ReportViewer1" />
    </Grid>
</Window>
      CopyVB.NET
      Partial Public Class Window2

    Private Sub Window1_Loaded(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs) Handles MyBase.Loaded
        Me.ReportViewer1.ReportSource = New InstanceReportSource With { .ReportDocument = New ListBoundReport() }
    End Sub
End Class

How to add the WPF ReportViewer to the toolbox

  1. Select a WPF window file (e.g. Window1.xaml).

  2. Open the toolbox and add your own tab or click on the General tab.

  3. Right click in the selected tab area and select Choose Items… from the context menu.

  4. The previous step will open Choose Toolbox Items dialog. Select the WPF Components tab and find the ReportViewer component from the Telerik.ReportViewer.Wpf assembly.

  5. Click OK

Binding Redirects

In case you use Telerik RadControls for WPF version greater than 2010.1.421.35 you have to redirect all assemblies required by the Telerik WPF ReportViewer to their latest versions. To do this, add the following bindingRedirects to your app.config and replace the "2010.1.421.35" with the exact version of Telerik RadControls for WPF assemblies:

Example

CopyXML
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Telerik.Windows.Controls" culture="neutral" publicKeyToken="5803cfa389c90ce7"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2010.1.421.35"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Telerik.Windows.Controls.Input" culture="neutral" publicKeyToken="5803cfa389c90ce7"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2010.1.421.35"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Telerik.Windows.Controls.Navigation" culture="neutral" publicKeyToken="5803cfa389c90ce7"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2010.1.421.35"/>
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>

See Also

Other Resources

Overview
Creating Style in Expression Blend
WPF Report Viewer


Report Viewer Localization

[image]

Telerik Reporting Q2 2012
Report Viewer Localization
See Also Send Feedback

In the WPF Report Viewer, localized resources are stored in separate RESX resource files and loaded according to the current UI culture settings. To understand how localized resources are loaded, it is useful to think of them as being organized in a hierarchical manner.

Types of Resources in the Hierarchy

  • At the top of the hierarchy sit the fallback resources for the default UI culture, which is English ("en") by default. These are the only resources that do not have their own file. They are stored directly in the assembly of the Report Viewer.
  • Below the fallback resources are the resources for any neutral cultures. A neutral culture is associated with a language but not a region. For example, French ("fr") is a neutral culture. Note that the fallback resources are also for a neutral culture, but a special one.
  • Below those are the resources for any specific cultures. A specific culture is associated with a language and a region. For example, French Canadian ("fr-CA") is a specific culture.

When the Report Viewer tries to load any localized resource and does not find it it will travel up the hierarchy until it finds a resource file containing the requested resource.

The best way to store your resources is to generalize them as much as possible. That means to store localized strings in resource files for neutral cultures rather than specific cultures whenever possible. For instance, if you have resources for the French Belgian ("fr-BE") culture and the resources immediately above are the fallback resources in English, a problem may result when someone uses your application on a system configured for the French Canadian culture. The Report Viewer will look for a RESX file named "fr-CA", it will not find it and will load the fallback resource, which is English, instead of loading the French resources. The following picture shows this undesirable scenario.

If you follow the recommended practice of placing as many resources as possible in a neutral resource file for the "fr" culture, the French Canadian user would not see resources marked for the "fr-BE" culture, but he or she would still see strings in French. The following situation demonstrates this preferred scenario.

Naming Conventions for the Localization Resources

The Report Viewer uses the following naming convention when searching for localized RESX resource files in the main application folder:

  • The names of the RESX localization resource files should have the following format:

    Telerik.ReportViewer.WPF.TextResources.[culture].resx

    Here “[culture]” is the name of the culture for the specified localization resource. For example, to provide a localization resource for the French Belgian culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WPF.TextResources.fr-BE.resx

  • Respectively, to provide a localization resource for the French neutral culture, the corresponding resource file should be named as follows:

    Telerik.ReportViewer.WPF.TextResources.fr.resx

  • It is possible to override the default resources for the language neutral culture, which are stored in the assembly of the Report Viewer. In that case the resource file should be named as follows:

    Telerik.ReportViewer.WPF.TextResources.resx

As described above, if for example the current UI culture is set to French Belgian, the Report Viewer will search for localized RESX resource files inside the main application folder in the following order:

  1. Telerik.ReportViewer.WPF.TextResources.fr-BE.resx
  2. Telerik.ReportViewer.WPF.TextResources.fr.resx
  3. Telerik.ReportViewer.WPF.TextResources.resx

The above diagram illustrates a simple view of the resource fallback for a UI culture set to "fr-BE". The Report Viewer handles the case probing the "fr-BE" RESX resource file for the requested key first, and subsequently falls back to the neutral French culture "fr", ultimately looking in the default assembly resources for a value if a value has still not been found.

Adding Localization Resources for the Report Viewer

  1. Add a new RESX resource file to the main project of the application. Name the newly-created RESX file according to the naming convention described above.
  2. In the Property Inspector specify the following properties for the resource file:
    1. Build Action: "None"
    2. Copy to Output Directory: "Copy if newer" or "Copy always"
  3. Open the RESX resource file in the Visual Studio Resource Editor. Enter the required resource strings to translate the Report Viewer to the desired language.
  4. Repeat steps from 1 to 3 for each desired translation of the Report Viewer.
  5. Compile and run the project. When viewing a Telerik Report, the Report Viewer should be translated according to the current UI culture.

Distributing an Application with a Localized Report Viewer

In order to distribute an application that uses Telerik Reporting with a localized Report Viewer, one should distribute all of the required localization RESX resource files, in addition to the main application assemblies. For WPF Applications the RESX files should be placed in the same directory, where the application is installed.

Localization Using the ITextResources interface

The other way to localize the WPF Report Viewer in a more flexible manner is to create a class that implements the ITextResources interface and to implement all its properties, which represent all tooltips and messages in the Report Viewer. After you implement ITextResources you have to pass an instance of your custom class to the TextResources property ot the report viewer. The logic is pretty simple, the property just has to return the correct translation for each resource key, as it is shown below:

CopyC#
class CustomResources : Telerik.ReportViewer.Wpf.ITextResources
{
    public string AllFiles
    {
        get
        {
            return "Todos Archivos";
        }
    }
    public string BackToolTip
    {
        get
        {
            return "Navega hacia atrás";
        }
    }
    public string CurrentPageToolTip
    {
        get
        {
            return "Página corriente";
        }
    }

    //...... Implement the rest of the properties ......

}
CopyVB.NET
Class CustomResources
    Implements Telerik.ReportViewer.Wpf.ITextResources

    Public ReadOnly Property AllFiles() As String Implements ReportViewer.Wpf.ITextResources.AllFiles
        Get
            Return "Todos Archivos"
        End Get
    End Property

    Public ReadOnly Property BackToolTip() As String Implements ReportViewer.Wpf.ITextResources.BackToolTip
        Get
            Return "Navega hacia atrás"
        End Get
    End Property

    Public ReadOnly Property CurrentPageToolTip() As String Implements ReportViewer.Wpf.ITextResources.CurrentPageToolTip
        Get
            Return "Página corriente"
        End Get
    End Property

    '...... Implement the rest of the properties ......

End Class

Instead of a hard-coded string the property can be set in a method/contructor or to be created a method that returns string and implements a cutsom logic, for example retreives the resource key from a database.

CopyC#
class CustomTextResources : Telerik.ReportViewer.Wpf.ITextResources
{

    public string AllFiles
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.AllFiles);
        }
    }

    public string BackToolTip
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.BackToolTip);
        }
    }

    public string CurrentPageToolTip
    {
        get
        {
            return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.CurrentPageToolTip);
        }
    }

    //...... Implement the rest of the properties ......

}
CopyVB.NET
Class CustomTextResources
    Implements Telerik.ReportViewer.Wpf.ITextResources

    Public ReadOnly Property AllFiles() As String Implements ReportViewer.Wpf.ITextResources.AllFiles
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.AllFiles)
        End Get
    End Property

    Public ReadOnly Property BackToolTip() As String Implements ReportViewer.Wpf.ITextResources.BackToolTip
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.BackToolTip)
        End Get
    End Property

    Public ReadOnly Property CurrentPageToolTip() As String Implements ReportViewer.Wpf.ITextResources.CurrentPageToolTip
        Get
            Return SqlHelper.GetViewerKeyFromDb(TextResourcesEnum.CurrentPageToolTip)
        End Get
    End Property

    '...... Implement the rest of the properties ......

End Class

Related articles

WPF Report Viewer

Overview

How to: Add report viewer to a WPF application

Creating Style in Expression Blend

See Also

Other Resources

Hierarchical Organization of Resources for Localization
WPF Globalization and Localization Overview
Security and Localized Satellite Assemblies


Setting a Theme

[image]

Telerik Reporting Q2 2012
Setting a Theme
See Also Send Feedback

The purpose of this tutorial is to show you how to set a built-in theme to the WPF report viewer. This topic contains the following sections:

  • Setting instance-specific built-in theme in XAML
  • Setting instance-specific built-in theme in the code-behind
  • Setting application-wide built-in theme in the code-behind
Note

The WPF themes are embedded in the control assemblies. Currently the WPF report viewer offers the following themes:

  • Office Black - this is the default theme.
  • Office Blue
  • Office Silver
  • Expression Dark
  • Summer
  • Vista
  • Windows 7
  • Transparent
  • Metro

Note

We will use the Vista theme for the examples below.

Setting Instance-Specific Built-In Theme in XAML

In order to change the theme in XAML you have to declare a resource of type Theme and set an appropriate key. To complete this procedure follow the instructions below.

  • Open the user control that hosts the report viewer.
  • Set the attached property StyleManager.Theme value to Vista.
CopyXAML
<UserControl x:Class="MainPage"
     xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
     xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
     xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
     xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
     xmlns:telerikControls="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls"
     xmlns:telerik="clr-namespace:Telerik.ReportViewer.Wpf;assembly=Telerik.ReportViewer.Wpf">

     <Grid x:Name="LayoutRoot">
            <telerik:ReportViewer telerikControls:StyleManager.Theme="Vista"/>
     </Grid>
</UserControl>

Setting Instance-Specific Built-In Theme in the Code-Behind

To change the theme for the WPF viewer in code-behind:

  • Open your user control.
  • Make sure you have explicitly named the target control in XAML.
  • In the constructor of your user control place the following code:
CopyC#
StyleManager.SetTheme(ReportViewer1, new VistaTheme());
CopyVB.NET
StyleManager.SetTheme(ReportViewer1, new VistaTheme())

Setting Application-Wide Built-In Theme in the Code-Behind

Changing the application theme is in much bigger scale as it affects all Telerik WPF controls in your application. You should use the constructor of your application to set the desired theme. To change the application theme in code-behind you should declare the theme before the InitializeComponent() call, depending on the name of your theme as follows:

CopyC#
public partial class MainPage : UserControl
{
    public MainPage()
    {
        StyleManager.ApplicationTheme = new VistaTheme();
        InitializeComponent();
    }
}
CopyVB.NET
Public Partial Class MainPage
    Inherits UserControl
    Public Sub New()
        StyleManager.ApplicationTheme = New VistaTheme()
        InitializeComponent()
    End Sub
End Class
Tip

Setting an application-wide theme can be done in the constructor of your Application class as well (App.xaml.cs):

See Also

Other Resources

Creating Style in Expression Blend


Creating Style in Expression Blend

[image]

Telerik Reporting Q2 2012
Creating Style in Expression Blend
See Also Send Feedback

The purpose of this tutorial is to show you how to create/edit a Style in Expression Blend.

In order to create a style in Expression Blend you need to perform the following instructions:

  1. Open your application in Expression Blend.
    Note

    You can open your application in Expression Blend directly from your Visual Studio. For that purpose do the following things:

    1. Open your Solution Explorer (View->Solution Explorer or use the Ctrl+Alt+L shortcut)
    2. Select your user controls
    3. Right mouse button click and select "Open in Expression Blend...".

  2. In the "Objects and Timeline" pane (Window->Objects and Timeline) select the ReportViewer Control for which you want to create (modify) a style.

  3. Expand the Object -> Edit Style menu.

    You have three options here:

    • Edit Current - if you choose it, this will open the currently applied style for edit.
      Note
      If you don't have an applied style to the control, this option will be disabled.
    • Edit a Copy... - edit a copy of the default style. When you select this option a new dialog will be opened.

      The "Create Style Resource" dialog will prompt you to select a name for your style, as well as to choose the location where your style will be defined in.

    • Create Empty... - create an empty style for the selected control. When you select this option, the same "Create Style Resource" dialog will be opened. You should select a name for the style, as well as to choose the location where your style will be defined in.
Caution

Telerik WPF viewer uses controls from the Telerik XAML suites. If needed, you can replace them with any other controls.

See Also

Other Resources

WPF Report Viewer
Overview
How to: Add report viewer to a WPF application


Accessing Report Engine

[image]

Telerik Reporting Q2 2012
Accessing Report Engine
Send Feedback

You can use the report engine without the Report Viewers. Telerik Reporting API has methods for direct exporting and printing without a Report Viewer.

In This Section

  • Exporting Report Programmatically
  • Exporting Report in Silverlight


Exporting Report Programmatically

[image]

Telerik Reporting Q2 2012
Exporting Report Programmatically
See Also Send Feedback

Requirements

To export a report, you can use the RenderReport method of the ReportProcessor class. This method converts the contents of the report to a byte array in the specified format, which you can then use with other classes such as MemoryStream or FileStream .

The RenderReport method has two overloads, the first is used when rendering a single stream, the second when rendering multiple streams. The available extensions used as first argument of the RenderReport method are listed in the Rendering Extensions article.

Exporting a report to a single document format:

Some formats (MHTML, PDF, XLS(X), RTF, DOCX, PPTX, CSV) produce a single document which is handled by the first overload of the RenderReport:

Example

CopyC#
Telerik.Reporting.Processing.ReportProcessor reportProcessor =
    new Telerik.Reporting.Processing.ReportProcessor();

//set any deviceInfo settings if necessary
System.Collections.Hashtable deviceInfo =
    new System.Collections.Hashtable();

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

instanceReportSource.ReportDocument = report1;

Telerik.Reporting.Processing.RenderingResult result =
    reportProcessor.RenderReport("PDF", instanceReportSource, deviceInfo);

string fileName = result.DocumentName + "." + result.Extension;
const string path = @"C:\";
string filePath = System.IO.Path.Combine(path, fileName);

using (System.IO.FileStream fs = new System.IO.FileStream(filePath, System.IO.FileMode.Create))
{
    fs.Write(result.DocumentBytes, 0, result.DocumentBytes.Length);
}
CopyVB.NET
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor()

'set any deviceInfo settings if necessary
Dim deviceInfo As New System.Collections.Hashtable()

Dim instanceReportSource as new Telerik.Reporting.InstanceReportSource()
instanceReportSource.ReportDocument = report1

Dim result As Telerik.Reporting.Processing.RenderingResult = reportProcessor.RenderReport("PDF", instanceReportSource, deviceInfo)
Dim fileName As String = result.DocumentName + "." + result.Extension
Const path As String = "C:\"
Dim filePath As String = System.IO.Path.Combine(path, fileName)

Using fs As New System.IO.FileStream(filePath, System.IO.FileMode.Create)
    fs.Write(result.DocumentBytes, 0, result.DocumentBytes.Length)
End Using
Note

When you export programmatically to XPS, you should use a separate STA thread which is required by the underlying WPF UI elements that we use to create the XAML representation of the report.

Exporting a report to a multi document format:

Some formats produce multiple files, for example HTML outputs all pages and related resources (images) in separate streams. In order to render a report in a non-single document format (HTML and IMAGE except TIFF) one should use the second RenderReport overload that accepts a CreateStream callback. For this example we're going to render to JPEG, but you can render a report in all graphic formats that GDI+ supports natively - this includes BMP, GIF, JPEG, PNG, TIFF and metafile (EMF). The Windows Forms Report Viewer uses internally metafile for rendering the reports for viewing, and TIFF for exporting. The rest of the formats are available only through code using the ReportProcessor.Render method where you should specify "IMAGE" as export format and the additional output format that is the actual graphic format - BMP, GIF, JPEG. Here is an example that renders a report as a JPEG image:

Example

CopyC#
System.Collections.Generic.List<System.IO.Stream> streams =
    new System.Collections.Generic.List<System.IO.Stream>();

public bool RenderReport(IReportDocument report)
{
    Telerik.Reporting.Processing.ReportProcessor reportProcessor =
        new Telerik.Reporting.Processing.ReportProcessor();

    string documentName = "";

    //specify the output format of the produced image.
    System.Collections.Hashtable deviceInfo =
        new System.Collections.Hashtable();

    deviceInfo["OutputFormat"] = "JPEG";

    Telerik.Reporting.InstanceReportSource instanceReportSource =
        new Telerik.Reporting.InstanceReportSource();

    instanceReportSource.ReportDocument = report;

    bool result = reportProcessor.RenderReport("IMAGE", instanceReportSource, deviceInfo, this.CreateStream, out documentName);
    this.CloseStreams();

    return result;
}

void CloseStreams()
{
    foreach (System.IO.Stream stream in this.streams)
    {
        stream.Close();
    }
    this.streams.Clear();
}

System.IO.Stream CreateStream(string name, string extension, System.Text.Encoding encoding, string mimeType)
{
    const string path = @"C:\";
    string filePath = System.IO.Path.Combine(path, name + "." + extension);

    System.IO.FileStream fs = new System.IO.FileStream(filePath, System.IO.FileMode.Create);
    this.streams.Add(fs);
    return fs;
}
CopyVB.NET
Dim streams As New System.Collections.Generic.List(Of System.IO.Stream)()

Public Function RenderReport(report As IReportDocument) As Boolean
    Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor()
    Dim documentName As String = ""

    'specify the output format of the produced image.
    Dim deviceInfo As New System.Collections.Hashtable()
    deviceInfo("OutputFormat") = "JPEG"

    Dim result As Boolean = reportProcessor.RenderReport("IMAGE", report, deviceInfo, AddressOf Me.CreateStream, documentName)
    Me.CloseStreams()

    Return result
End Function

Private Sub CloseStreams()
    For Each stream As System.IO.Stream In Me.streams
        stream.Close()
    Next
    Me.streams.Clear()
End Sub

Private Function CreateStream(name As String, extension As String, encoding As System.Text.Encoding, mimeType As String) As System.IO.Stream
    Const path As String = "C:\"
    Dim filePath As String = System.IO.Path.Combine(path, name + "." + extension)

    Dim fs As New System.IO.FileStream(filePath, System.IO.FileMode.Create)
    Me.streams.Add(fs)
    Return fs
End Function

See Also

Reference

RenderReport


Exporting Report in Silverlight

[image]

Telerik Reporting Q2 2012
Exporting Report in Silverlight
See Also Send Feedback

To export a Telerik report from a Silverlight application without a Silverligh Report Viewer you have to instantiate the Telerik.Reporting.Service.SilverlightClient..::.ReportServiceClient class, which plays the role of proxy to the Telerik Reporting WCF Service.

To specify that you want to render the report we use the RenderAsync method of the ReportServiceClient, which invokes the respective method on the server (remember that it serves as proxy) that would return the rendered report.

Since we’ve used an asynchronous method and we do not know when the render would finish, we need to handle the RenderCompleted event. In the RenderCompleted event we get the result from the rendering and decide what to do with it - in this case write down the report.

Note

We invoke the ShowDialog method prior to having the rendered report, because the dialog box, can only be called from user-initiated code, such as a button Click event. If ShowDialog is called from code that is not user-initiated, a SecurityException is thrown.

CopyC#
public partial class MainPage : UserControl
    {
        public MainPage()
        {
            InitializeComponent();
        }

        Stream file;

        private void Button_Click(object sender, RoutedEventArgs e)
        {
            var fileDlg = new SaveFileDialog();
            fileDlg.Filter = "PDF files|*.pdf|All files|*.*";

            if (fileDlg.ShowDialog() == true)
            {
                //set any deviceInfo settings if necessary
                var deviceInfo = new NameValueDictionary();
                //set any report parameter value if necessary
                var parameters = new NameValueDictionary();

                this.file = fileDlg.OpenFile();
                var serviceClient = new ReportServiceClient(new Uri(App.Current.Host.Source, "../ReportService.svc"));
                serviceClient.RenderAsync("PDF",
                    "ClassLibrary1.Report1, ClassLibrary1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null",
                    deviceInfo,
                    parameters);
                serviceClient.RenderCompleted += new EventHandler<RenderEventArgs>(serviceClient_RenderCompleted);
            }
        }

        void serviceClient_RenderCompleted(object sender, RenderEventArgs e)
        {
            var result = e.RenderingResult;
            if (this.file != null)
            {
                this.file.Write(result.DocumentBytes, 0, result.DocumentBytes.Length);
                this.file.Close();
                this.file.Dispose();
                this.file = null;
            }
        }
    }
CopyVB.NET
    Public Sub New()
        InitializeComponent()
    End Sub

    Private file As Stream

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.Windows.RoutedEventArgs) Handles Button1.Click
        Dim fileDlg = New SaveFileDialog()
        fileDlg.Filter = "PDF files|*.pdf|All files|*.*"

        If fileDlg.ShowDialog() = True Then

            'set any deviceInfo settings if necessary
            Dim deviceInfo As New NameValueDictionary()
            'set any report parameter value if necessary
            Dim parameters As New NameValueDictionary()

            Me.file = fileDlg.OpenFile()
            Dim serviceClient = New ReportServiceClient(New Uri(App.Current.Host.Source, "../ReportService.svc"))
            serviceClient.RenderAsync("PDF", "ClassLibrary1.Report1, ClassLibrary1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null", deviceInfo, parameters)
            AddHandler serviceClient.RenderCompleted, AddressOf Me.serviceClient_RenderCompleted
        End If
    End Sub

    Private Sub serviceClient_RenderCompleted(ByVal sender As Object, ByVal e As RenderEventArgs)
        Dim result = e.RenderingResult
        If Me.file IsNot Nothing Then
            Me.file.Write(result.DocumentBytes, 0, result.DocumentBytes.Length)
            Me.file.Close()
            Me.file.Dispose()
            Me.file = Nothing
        End If
    End Sub

End Class

See Also

Reference

Telerik.Reporting.Service.SilverlightClient..::.ReportServiceClient


Programmatic Control of Reports

[image]

Telerik Reporting Q2 2012
Programmatic Control of Reports
See Also Send Feedback

Telerik Reporting offers a full API for programmatic control of reports. You can create, modify, and work with reports in code, just as you can from the Visual Studio IDE. In this section, you will see how to perform the following fundamental operations in code:

  • Creating a Report Programmatically
  • Creating Sections Programmatically
  • Creating Report Items Programmatically
  • Serializing Report Definition in XML

See Also

Reference

Telerik.Reporting


Creating a Report Programmatically

[image]

Telerik Reporting Q2 2012
Creating a Report Programmatically
See Also Send Feedback

To create a Telerik report in code, you need to instantiate a Telerik.Reporting.Report object and set its properties. For example, this code will create a report and set up its data source:

CopyC#
MyReport report = new MyReport();
string sql = @"SELECT * FROM Sales.Store";
string connectionString = "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";
SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
report.DataSource = adapter;
CopyVB.NET
Dim report As New MyReport()
Dim sql As String = "SELECT * FROM Sales.Store"
Dim connectionString As String = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"
Dim adapter As New SqlDataAdapter(sql, connectionString)
report.DataSource = adapter

See Also

Reference

Report


Creating Sections Programmatically

[image]

Telerik Reporting Q2 2012
Creating Sections Programmatically
See Also Send Feedback

To create sections in code, instantiate the appropriate object, set its properties, and add it to the Report object's Items collection. The objects you will need to work with are:

  • DetailSection - for a detail section
  • GroupHeaderSection - for a group header
  • GroupFooterSection - for a group footer
  • PageHeaderSection - for a page header
  • PageFooterSection - for a page footer
  • ReportHeaderSection - for a report header
  • ReportFooterSection - for a report footer

For example, this code creates a detail section and adds it to the report:

CopyC#
DetailSection detail = new DetailSection();
this.detail.Height = new Telerik.Reporting.Drawing.Unit(3.0, Telerik.Reporting.Drawing.UnitType.Inch);
this.detail.Name = "detail";
report.Items.Add((ReportItemBase)detail);
CopyVB.NET
Dim detail As New DetailSection()
Me.detail.Height = New Telerik.Reporting.Drawing.Unit(3, Telerik.Reporting.Drawing.UnitType.Inch)
Me.detail.Name = "detail";
report.Items.Add(DirectCast(detail, ReportItemBase)

See Also

Reference

ReportHeaderSection
ReportFooterSection
DetailSection
GroupHeaderSection
GroupFooterSection
PageHeaderSection
PageFooterSection


Creating Report Items Programmatically

[image]

Telerik Reporting Q2 2012
Creating Report Items Programmatically
See Also Send Feedback

To create a report item in code, instantiate a report item object, set its properties, and add it to the Items collection of the section where you wish the control to appear. For example, this code will add two TextBox report items to a report:

CopyC#
Telerik.Reporting.Panel panel1 = new Telerik.Reporting.Panel();
Telerik.Reporting.TextBox textBox1 = new Telerik.Reporting.TextBox();

// panel1

panel1.Location = new Telerik.Reporting.Drawing.PointU(new Telerik.Reporting.Drawing.Unit(1.0, Telerik.Reporting.Drawing.UnitType.Cm), new Telerik.Reporting.Drawing.Unit(1.0, Telerik.Reporting.Drawing.UnitType.Cm));
panel1.Size = new Telerik.Reporting.Drawing.SizeU(new Telerik.Reporting.Drawing.Unit(8.5, Telerik.Reporting.Drawing.UnitType.Cm), new Telerik.Reporting.Drawing.Unit(3.5, Telerik.Reporting.Drawing.UnitType.Cm));
panel1.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Solid;

// textBox1

textBox1.Location = new Telerik.Reporting.Drawing.PointU(new Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Cm), new Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Cm));
textBox1.Name = "NameDataTextBox";
textBox1.Size = new Telerik.Reporting.Drawing.SizeU(new Telerik.Reporting.Drawing.Unit(5.0, Telerik.Reporting.Drawing.UnitType.Cm), new Telerik.Reporting.Drawing.Unit(0.6, Telerik.Reporting.Drawing.UnitType.Cm));
textBox1.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Solid;
textBox1.StyleName = "Data";
textBox1.Value = "=Fields.CustomerID";

panel1.Items.AddRange(new Telerik.Reporting.ReportItemBase[] {textBox1});
detail.Items.AddRange(new Telerik.Reporting.ReportItemBase[] {panel1});
CopyVB.NET
Dim panel1 As New Telerik.Reporting.Panel()
Dim textBox1 As New Telerik.Reporting.TextBox()

'panel1

panel1.Location = New Telerik.Reporting.Drawing.PointU(New Telerik.Reporting.Drawing.Unit(1, Telerik.Reporting.Drawing.UnitType.Cm), New Telerik.Reporting.Drawing.Unit(1, Telerik.Reporting.Drawing.UnitType.Cm))
panel1.Size = New Telerik.Reporting.Drawing.SizeU(New Telerik.Reporting.Drawing.Unit(8.5, Telerik.Reporting.Drawing.UnitType.Cm), New Telerik.Reporting.Drawing.Unit(3.5, Telerik.Reporting.Drawing.UnitType.Cm))
panel1.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Solid

'textBox1

textBox1.Location = New Telerik.Reporting.Drawing.PointU(New Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Cm), New Telerik.Reporting.Drawing.Unit(0, Telerik.Reporting.Drawing.UnitType.Cm))
textBox1.Name = "NameDataTextBox"
textBox1.Size = New Telerik.Reporting.Drawing.SizeU(New Telerik.Reporting.Drawing.Unit(5, Telerik.Reporting.Drawing.UnitType.Cm), New Telerik.Reporting.Drawing.Unit(0.6, Telerik.Reporting.Drawing.UnitType.Cm))
textBox1.Style.BorderStyle.Default = Telerik.Reporting.Drawing.BorderType.Solid
textBox1.StyleName = "Data"
textBox1.Value = "=Fields.CustomerID"

panel1.Items.AddRange(New Telerik.Reporting.ReportItemBase() {textBox1})
detail.Items.AddRange(New Telerik.Reporting.ReportItemBase() {panel1})

See Also

Reference

TextBox
PictureBox
Panel
SubReport
Shape
Table
CheckBox


Report Events

[image]

Telerik Reporting Q2 2012
Report Events
Send Feedback

Understanding the provided events is essential when working with Telerik Reporting. Expressions, Conditional Formatting and user defined functions provide flexibility to handle most tasks. These tools are typically the most productive way to build reports and should be favored over using events. There are a few cases where additional power and flexibility is required. The Telerik Reporting event model includes events for report, section, and report item.


Understanding Events

[image]

Telerik Reporting Q2 2012
Understanding Events
See Also Send Feedback

Report Definition

The Report Definition is created during the first stage of the life cycle. This is the actual .NET class that represents the report. It is always a subclass Telerik.Reporting.Report and contains information about report items and their properties. Report items are represented by the private fields of the report class.

Let's illustrate this with an example. While in design-time, if you add a TextBox to the Detail Section of the report that you are designing, a private field of type TextBox will be added to the code-behind file and some basic initialization code will be generated within the InitalizeComponent method of the report class.

Note

The InitializeComponent method initializes (creates) a Report and its child items. It is a special method recognized and parsed by the Report Designer in order to display the report in design-time.

This object will later serve as the definition for creating a concrete instance of the TextBox for each row form the data source. These definition objects are of the types that reside in the Telerik.Reporting namespace, for example Telerik.Reporting.TextBox.

Report Processing

The second stage of the report life cycle involves combining the report definition with the data source. The processing engine performs all grouping, sorting and filtering calculations and iterates over all records from the data source and creates the appropriate processing items based on the item definitions created earlier and the actual data. Based on the original item definition (e.g. Telerik.Reporting.TextBox) and the actual data in the current record a new item is created. This item is known as a processing item (e.g. Telerik.Reporting.Processing.TextBox) and bears all characteristics of its definition item, but it is bound to the respective data field from the current record. While the definition TextBox's Value property may contain something like "=Fields.FirstName", the processing item's Value property will be equal to "John".

The Processing Engine provides the developer with a way to intervene in this process. Just before the processing item is bound to data, the ItemDataBinding event of its definition item is raised. By subscribing a listener for this event, the developer can modify the default behavior at run-time. The sender parameter of the event handler methods is in fact the processing report item. After the processing item has been data bound the ItemDataBound event is raised.

Note

Be very careful when working inside event handlers. If by mistake you modify the report item (the private field of the report class, i.e. this.textBox1) instead of its processing counterpart (the sender argument), all subsequent processing items will be modeled after the modified reporting item.

Report Rendering

After processing is over, the processed report is ready for rendering in one of the available formats, see Rendering Extensions.

See Also

Other Resources

Report Life Cycle


Using Report Events

[image]

Telerik Reporting Q2 2012
Using Report Events
Send Feedback

The Report object exposes these events:

Property | Description
ItemDataBinding | Fires just before the report is bound to data.
NeedDataSource | Fires when the report does not have data source set.
ItemDataBound | Fires just after the report is bound to data.

The example below shows the NeedDataSource event assigning the report DataSource at runtime. This event only fires when the DataSource is null.

CopyC#
private void Report1_NeedDataSource(object sender, System.EventArgs e)
{
    string sql = @"SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product";
    string connectionString = "Data Source=(local)\\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True";
    SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
    DataSet dataSet = new DataSet();
    adapter.Fill(dataSet);
    (sender as Telerik.Reporting.Processing.Report).DataSource = dataSet;
}
CopyVB.NET
Private Sub Report1_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs)
    Dim sql As String = "SELECT Production.Product.Name, Production.Product.ProductNumber FROM Production.Product"
    Dim connectionString As String = "Data Source=(local)\SQLEXPRESS;Initial Catalog=AdventureWorks;Integrated Security=True"
    Dim adapter As New SqlDataAdapter(sql, connectionString)
    Dim dataSet As New DataSet()
    adapter.Fill(dataSet)
    (TryCast(sender, Telerik.Reporting.Processing.Report)).DataSource = dataSet
End Sub


Using Section Events

[image]

Telerik Reporting Q2 2012
Using Section Events
See Also Send Feedback

The various report Section objects expose these events:

Property | Description
ItemDataBinding | Fires just before the section is bound to data.
ItemDataBound | Fires just after the section is bound to data.

In ItemDataBinding and ItemDataBound events use the "sender" argument of the event handler to get a reference to the section object. From the section object you can reference any of the items the section contains, i.e. TextBoxes, PictureBoxes, etc. You can also use the section DataObject property to access the data fields for the section.

Tip

Be aware that the "sender" section object is of type Telerik.Reporting.Processing.ReportItemBase, not the definition item Telerik.Reporting.ReportItemBase.

The example below demonstrates getting a reference to the detail section of the report and finding a specific TextBox within the section. The example also shows retrieving data source column values for the section and using it to alter the TextBox.

The second example demonstrates getting a reference to the detail section of the report, finding all its children and setting a BackgroundColor to them:

Example

CopyC#
private void detail_ItemDataBinding(object sender, EventArgs e)
{
    Telerik.Reporting.Processing.DetailSection section = (sender as Telerik.Reporting.Processing.DetailSection);
    Telerik.Reporting.Processing.TextBox txt = (Telerik.Reporting.Processing.TextBox)Telerik.Reporting.Processing.ElementTreeHelper.GetChildByName(section, "textBox1");
    object title = section.DataObject["Title"];
    if ((string)title == "Developer")
    {
        txt.Style.BackgroundColor = System.Drawing.Color.Blue;
    }
}
CopyVB.NET
Private Sub detail_ItemDataBinding(sender As Object, e As EventArgs)
    Dim section As Telerik.Reporting.Processing.DetailSection = TryCast(sender, Telerik.Reporting.Processing.DetailSection)
    Dim txt As Telerik.Reporting.Processing.TextBox = DirectCast(Telerik.Reporting.Processing.ElementTreeHelper.GetChildByName(section, "textBox1"), Telerik.Reporting.Processing.TextBox)
    Dim title As Object = section.DataObject("Title")
    If DirectCast(title, String) = "Developer" Then
        txt.Style.BackgroundColor = System.Drawing.Color.Blue
    End If
End Sub
CopyC#
void DetailSection_ItemDataBinding_Using_ILayoutElementContainer_Children(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    Processing.ILayoutElementContainer processingContainer = processingInstance as Processing.ILayoutElementContainer;
    if (null != processingContainer)
    {
        foreach (Processing.LayoutElement processingChild in processingContainer.Children)
        {
            Processing.VisualElement visualChild = processingChild as Processing.VisualElement;
            if (null != visualChild)
            {
                visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
            }
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_ILayoutElementContainer_Children(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim processingContainer As Processing.ILayoutElementContainer = TryCast(processingInstance, Processing.ILayoutElementContainer)
    If processingContainer IsNot Nothing Then
        For Each processingChild As Processing.LayoutElement In processingContainer.Children
            Dim visualChild As Processing.VisualElement = TryCast(processingChild, Processing.VisualElement)
            If visualChild IsNot Nothing Then
                visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
            End If
        Next
    End If
End Sub

See Also

Other Resources

Display Reports with alternating style rows


Using Report Item Events

[image]

Telerik Reporting Q2 2012
Using Report Item Events
See Also Send Feedback

Each report item on a report exposes these events:

Property | Description
ItemDataBinding | Fires just before the item is bound to data.
ItemDataBound | Fires just after the item is bound to data.
Note

The SubReport report item exposes one additional event: NeedDataSource. This event fires when the SubReport.ReportSource does not have data source bound to it.

Let us demonstrate this with a simple example. Suppose that we have a TextBox containing the job position of an employee. Assume that the TextBox's Value property equals "=Fields.JobPosition", where JobPosition is a column from the data source containing values like "Team Leader", "Senior Developer", "Junior Developer", "Quality Assurance", etc. For the sake of our example, suppose that we would like to color all developers in Blue.

First we need to attach to the TextBox's ItemDataBinding event. Double-click the event in the property grid and an event handler method will be automatically generated for you.

As explained in Understanding Events topic, the sender argument is in fact the processing TextBox that has already been data bound. The method will be called for each data row, i.e. for each employee we have in the data source. So the only thing we have left to do is cast the sender, check the position, and do the coloring if needed:

Example

CopyC#
private void textBox1_ItemDataBinding(object sender, EventArgs e)
{
    Telerik.Reporting.Processing.TextBox txt = (Telerik.Reporting.Processing.TextBox)sender;
    Telerik.Reporting.Processing.IDataObject dataObject = (Telerik.Reporting.Processing.IDataObject)txt.DataObject;
    if ((string)dataObject["Title"] == "Developer")
    {
        txt.Style.BackgroundColor = System.Drawing.Color.Blue;
    }
}
CopyVB.NET
Private Sub textBox1_ItemDataBinding(sender As Object, e As EventArgs) Handles textBox1.ItemDataBinding
    Dim txt As Telerik.Reporting.Processing.TextBox = DirectCast(sender, Telerik.Reporting.Processing.TextBox)
    Dim dataObject As Telerik.Reporting.Processing.IDataObject = DirectCast(txt.DataObject, Telerik.Reporting.Processing.IDataObject)
    If DirectCast(dataObject("Title"), String) = "Developer" Then
        txt.Style.BackgroundColor = System.Drawing.Color.Blue
    End If
End Sub
Note

The provided example can be easily implemented using ConditionalFormatting, see Change row color based on a value in the row or Bindings, see Bindings.

See Also

Other Resources

Access items from report, calling application and Table
Change row color based on a value in the row


Serializing Report Definition in XML

[image]

Telerik Reporting Q2 2012
Serializing Report Definition in XML
Send Feedback

Telerik Reporting supports serialization/deserialization of the report definition as XML. This is useful in various different scenarios and opens many possibilities that are not easily accomplished otherwise. For example, this allows adding or modifying reports in your application without recompiling or redeploying it. Another typical scenario is saving/loading of dynamically generated report definitions or transferring them over the network.

Report Definition

The XML serialization/deserialization of report definitions is achieved through the dedicated ReportXmlSerializer class. To illustrate how a report is serialized and deserialized, let us start with a simple dynamically generated report definition:

CopyC#
Telerik.Reporting.Report report = new Telerik.Reporting.Report();

report.Width = Telerik.Reporting.Drawing.Unit.Inch(4);

Telerik.Reporting.DetailSection detailSection = new Telerik.Reporting.DetailSection();

detailSection.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2);
report.Items.Add(detailSection);

Telerik.Reporting.TextBox numberTextBox = new Telerik.Reporting.TextBox();

numberTextBox.Value = "=Fields.ProductNumber";
numberTextBox.Left = Telerik.Reporting.Drawing.Unit.Inch(0);
numberTextBox.Top = Telerik.Reporting.Drawing.Unit.Inch(0);
numberTextBox.Width = Telerik.Reporting.Drawing.Unit.Inch(2);
numberTextBox.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2);
detailSection.Items.Add(numberTextBox);

Telerik.Reporting.TextBox nameTextBox = new Telerik.Reporting.TextBox();

nameTextBox.Value = "=Fields.Name";
nameTextBox.Left = Telerik.Reporting.Drawing.Unit.Inch(2);
nameTextBox.Top = Telerik.Reporting.Drawing.Unit.Inch(0);
nameTextBox.Width = Telerik.Reporting.Drawing.Unit.Inch(2);
nameTextBox.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2);
detailSection.Items.Add(nameTextBox);

Telerik.Reporting.SqlDataSource dataSource = new Telerik.Reporting.SqlDataSource();

dataSource.ConnectionString = "Data Source=.\\SqlExpress;Initial Catalog=AdventureWorks;Integrated Security=True";
dataSource.SelectCommand = "select ProductNumber, Name from Production.Product";
report.DataSource = dataSource;
CopyVB.NET
Dim report As New Telerik.Reporting.Report()

report.Width = Telerik.Reporting.Drawing.Unit.Inch(4)

Dim detailSection As New Telerik.Reporting.DetailSection()

detailSection.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2)
report.Items.Add(detailSection)

Dim numberTextBox As New Telerik.Reporting.TextBox()

numberTextBox.Value = "=Fields.ProductNumber"
numberTextBox.Left = Telerik.Reporting.Drawing.Unit.Inch(0)
numberTextBox.Top = Telerik.Reporting.Drawing.Unit.Inch(0)
numberTextBox.Width = Telerik.Reporting.Drawing.Unit.Inch(2)
numberTextBox.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2)
detailSection.Items.Add(numberTextBox)

Dim nameTextBox As New Telerik.Reporting.TextBox()

nameTextBox.Value = "=Fields.Name"
nameTextBox.Left = Telerik.Reporting.Drawing.Unit.Inch(2)
nameTextBox.Top = Telerik.Reporting.Drawing.Unit.Inch(0)
nameTextBox.Width = Telerik.Reporting.Drawing.Unit.Inch(2)
nameTextBox.Height = Telerik.Reporting.Drawing.Unit.Inch(0.2)
detailSection.Items.Add(nameTextBox)

Dim dataSource As New Telerik.Reporting.SqlDataSource()

dataSource.ConnectionString = "Data Source=.\SqlExpress;Initial Catalog=AdventureWorks;Integrated Security=True"
dataSource.SelectCommand = "select ProductNumber, Name from Production.Product"
report.DataSource = dataSource

Serialize Report Definition to an XML file

The following sample code snipped demonstrates how to serialize the above report definition to an XML file:

CopyC#
using (System.Xml.XmlWriter xmlWriter = System.Xml.XmlWriter.Create("report.xml"))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    xmlSerializer.Serialize(xmlWriter, report);
}
CopyVB.NET
Using xmlWriter As System.Xml.XmlWriter = System.Xml.XmlWriter.Create("report.xml")
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    xmlSerializer.Serialize(xmlWriter, report)
End Using

Deserialize Report Definition from XML file

The corresponding code that can be used to deserialize the report definition from the file is shown below:

CopyC#
System.Xml.XmlReaderSettings settings = new System.Xml.XmlReaderSettings();
settings.IgnoreWhitespace = true;

using (System.Xml.XmlReader xmlReader = System.Xml.XmlReader.Create("SampleReport1.trdx", settings))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    Telerik.Reporting.Report report = (Telerik.Reporting.Report)
        xmlSerializer.Deserialize(xmlReader);
}
CopyVB.NET
Dim settings As New XmlReaderSettings()
settings.IgnoreWhitespace = True

Using xmlReader As System.Xml.XmlReader = System.Xml.XmlReader.Create("SampleReport1.trdx", settings)
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    Dim report As Telerik.Reporting.Report = DirectCast(xmlSerializer.Deserialize(xmlReader), Telerik.Reporting.Report)
End Using

Serialized Report Definition in XML

and the resulting XML file would look like this:

CopyXML
<Report DataSourceName="sqlDataSource1" Width="4in" Name="userReport1" xmlns="http://schemas.telerik.com/reporting/2012/2">
  <DataSources>
    <SqlDataSource ConnectionString="Data Source=.\SqlExpress;Initial Catalog=AdventureWorks;Integrated Security=True" SelectCommand="select ProductNumber, Name from Production.Product" Name="sqlDataSource1" />
  </DataSources>
  <Items>
    <DetailSection Height="0.2in" Name="detailSection1">
      <Items>
        <TextBox Value="=Fields.ProductNumber" Size="2in, 0.2in" Location="0in, 0cm" Name="textBox1" />
        <TextBox Value="=Fields.Name" Size="2in, 0.2in" Location="2in, 0cm" Name="textBox2" />
      </Items>
    </DetailSection>
  </Items>
  <PageSettings>
    <PageSettings PaperKind="Letter" Landscape="False">
      <Margins>
        <MarginsU Left="1in" Right="1in" Top="1in" Bottom="1in" />
      </Margins>
    </PageSettings>
  </PageSettings>
</Report>


Report Sources

[image]

Telerik Reporting Q2 2012
Report Sources
See Also Send Feedback

Reports can be stored in different locations and in different formats so there should be a uniform way to access them. This is achieved through the various report sources that the Reporting engine provides.

The report sources are utilized by:

  • The SubReport item and for any report item that would use drill-through action (NavigateToReport action).

  • The report viewers when specifying the source for a report to view:

    • Web Report Viewer
    • Windows Forms Report Viewer
    • WPF Report Viewer

  • When you render or print reports programmatically, via the corresponding methods:

    • RenderReport
    • PrintReport

Available Report Sources

The available report sources are:

  • Instance report source

    This report source is used when you have a reference to an already instantiated report and you want to pass it to the reporting engine. Typical scenarios include when you create the reports and assign them programmatically.

  • URI report source

    The URI report source allows you to load a report document either from a file path or from an Url.

  • Type report source

    The reports created with Visual Studio are usually stored as .NET classes. To access a .net class declaratively you can use the assembly qualified name of the type.

  • Xml report source

    The primary intent for this report source is to be used with database fields where the report is stored as pure XML. In order to access it set the Xml property of the report source to the field that contains the report xml. For example: xmlReportSource.Xml = "=Fields.ReportXml".

For examples that demonstrate how to programmatically create a report source, check the API reference examples below.

Report Source Parameters

Each report source has a collection of parameters which determine the parameter values that are passed to the report when it is initialized. Please, note that the name of the parameter should match the names of the Report Parameters.

See Also

Reference

ReportSource
UriReportSource
TypeReportSource
InstanceReportSource
XmlReportSource
ReportProcessor


Interactive vs. Print Layout

[image]

Telerik Reporting Q2 2012
Interactive vs. Print Layout
Send Feedback

All report viewers can show a report in two distinctive report layouts:

  • Interactive View
  • Print Preview

Interactive View

The Interactive View is a logical layout that removes the strict restrictions for report pagination on the client by utilizing a simpler paging algorithm, which allows it to render reports faster. For example, if you use the crosstab's drill-down feature, the crosstab will expand its subcategories faster, because it will not recalculate the report's page size. Rather, this action will simply stretch the report.

The paging mechanism of the Interactive View is based on soft page breaks, where the report is optimized for screen-based viewing and delivery. In other words, you could have a two-page long table which to appear in a single continuous form on the client with a vertical scroll bar (logical layout); when printed, the table will print on two separate sheets of paper (print layout).

Note

The Interactive layout is the default report layout which users see. You can control the default layout via the ViewMode property of the respective report viewer.

Print Preview

The paging in Print Preview layout is calculated based on the page settings. During the preparation of the report for printing, the latest state of the report will be printed, such as expanded/collapsed Crosstab categories. The Print Preview is not interactive, it is dedicated only for printing.


Medium Trust Support

[image]

Telerik Reporting Q2 2012
Medium Trust Support
See Also Send Feedback

This article describes the limitations and requirements for deploying an ASP.NET application containing Telerik Reporting on a web host that requires Medium Trust permission level.

If you plan on deploying web application under Medium Trust level, first get acquainted with what Medium Trust is and how to use it - more info in "ASP.NET Trust Levels and Policy Files" and "Use Medium Trust in ASP.NET 2.0" documents in MSDN.

Telerik Reporting works in Medium Trust environment with the following exceptions:

  • The PDF and Excel 97- 2003 rendering extensions require UnmanagedCode permission to operate at all times. If the permission is not present, PDF and Excel 97- 2003 extensions are disabled and removed as options from the export dropdown. The Excel rendering extension (i.e. Excel 2007) works correctly under medium trust.
  • The XPS rendering extension requires Full Trust and is removed as option from the export dropdown.
  • Creating TIFF images with CCITT Group 3/Group 4 or RLE compressions, require UnmanagedCode permission.
  • Picturebox item shows images from Web (Value is an URL) - requires WebPermission.
  • Localization of Telerik Web ReportViewer through RESX resource files, requires Full Trust.
  • Shapes and barcodes with transparent colors are rendered in PNG format, which is not supported by Internet Explorer 6 browser.
Note

When running Telerik Reports in Medium Trust, one should always set the ReportViewer.Report property in code behind. Otherwise the ReportConverter class is used, which requires more permissions than are granted in Medium Trust level.

See Also

Other Resources

Overview
How to: Add report viewer to a web page
Report Viewer Localization
Deploying Web ReportViewer in SharePoint
AJAX support


True Print

[image]

Telerik Reporting Q2 2012
True Print
Send Feedback

The true printing functionality of the Web Report Viewer and Silverlight Report Viewer depends on the Adobe PDF (or Chrome PDF plug-in for Chrome browser). If Adobe or Chrome PDF plug-in is not detected, clicking the print button would export the report to PDF and depending on the browser would either open it directly or ask you to save the PDF file.

If you want to use the true print, the following requirements must be satisfied:

  • Javascript should be enabled in your browser.
  • The Adobe PDF or Chrome PDF plug-in should be enabled in your browser. Disable any other print related plug-ins such as Foxit.
  • (Silverlight viewer only) UseNativePrinting property should be false. Telerik Reporting WCF Service should be properly configured e.g. resource endpoint should be present. See Hosting WCF Service in IIS
  • (Internet Explorer only) Print menu in IE group policy should be enabled.
  • (Internet Explorer only) ActiveX Filtering should be disabled.


Session State Management
See Also Send Feedback

Telerik Reporting uses a dedicated session state management system to store and cache rendered pages and some large resources such as images on an external storage. This session state management system is utilized by all report viewers automatically as shown in the following illustration:

Note

The Telerik Reporting session state should not be confused with the ASP.NET session state. Telerik Reporting session state is used by all report viewers, regardless of the underlying application technology. In case of an ASP.NET web application, the Telerik Reporting session state is used to offload some large objects from the ASP.NET session state, such as rendered report pages and images, which often leads to an improved performance and a significantly reduced memory footprint for the application.

Session State Management

Such session state management implementation offers the following key benefits:

  • Reduced memory footprint – since the rendered pages and resources are cached on an external storage rather than being kept in memory, the viewers can handle very large reports with thousands of pages and images without increasing the memory consumed by the application too much.
  • Improved performance – the caching mechanism implemented by the session state management system can lead to improved performance of the viewers in certain scenarios.
  • Improved scalability – web farms can be configured to cache rendered reports on a dedicated database server. This allows subsequent requests to the same report to be served by different machines in the web farm leading to better load balancing. Only the database storage is shared between all machines in the farm, as shown in the following illustration:

See Also

Other Resources

Configuring Session State
Configuring the File Session State Provider
Configuring the Database Session State Provider


Protecting Telerik Reporting binaries when redistributed as part of a packaged product

[image]

Telerik Reporting Q2 2012
Protecting Telerik Reporting binaries when redistributed as part of a packaged product
Send Feedback

Technical guidelines for protecting Telerik Reporting binaries when redistributed with other applications

We are providing the following suggestions to protect our IP (Intellectual Property) when redistribute our assemblies as a part of shrink-wrapped software (packaged products):

The simplest way is to ILMerge them to any of your own assemblies laying in the bin folder. You can download ILMerge utility from this location. If your reports are in the assembly Reports.dll and your assembly that uses it (have reference to it) is named Application.dll you can merge them in this way:

Web Forms

ILMerge.exe /target:library /out:<your_application>.dll /keyfile:<your_key>.snk <your_application>.dll <your_report_library>.dll Telerik.Reporting.dll Telerik.ReportViewer.WebForms.dll

Windows Forms

ILMerge.exe /target:library /out:<your_application>.exe /keyfile:<your_key>.snk <your_application>.exe <your_report_library>.dll Telerik.Reporting.dll Telerik.ReportViewer.WinForms.dll

Also anywhere in your pages references to the Telerik.ReportViewer.WebForms.dll or Telerik.ReportViewer.WinForms.dll assemblies should be changed to point to <your_application>.dll/exe instead.


Deploying Applications using Telerik Reporting

[image]

Telerik Reporting Q2 2012
Deploying Applications using Telerik Reporting
Send Feedback

This section discusses the deployment considerations for Telerik Reporting:

  • Deploying Web Applications
  • Deploying Web Site
  • Deploying Windows Forms Applications
  • Deploying WPF Applications
  • Deploying Silverlight Application


Deploying Web Applications

[image]

Telerik Reporting Q2 2012
Deploying Web Applications
Send Feedback

This article describes how to deploy Web Applications that use Telerik Reporting on a production server.

During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Web Application project the assemblies from the GAC are not copied automatically so you need to make sure the assemblies physically exist in the bin folder of your application.

Required assemblies:

  • Telerik.Reporting.dll
  • Telerik.ReportViewer.WebForms.dll

Optional assemblies:

These assemblies add up to the core reporting functionality and should be used only if you need the specific feature. They are responsible for additional support formats, database session, retrieving data from an OLAP cube or using the Silverlight report viewer.

  • (.NET 3.5 or above) XPS rendering extension requires Telerik.Reporting.XpsRendering assembly (Telerik.Reporting.XpsRendering.dll)
  • (.NET 3.5 or above) DOCX/PPTX/XLSX rendering extensions require Telerik.Reporting.OpenXmlRendering.dll and Open XML SDK 2.0 for Microsoft Office (DocumentFormat.OpenXml.dll v.2.0.5022.0 or above).
  • (.NET 3.5 or above) The Telerik Reporting WCF Service (if needed) requires Telerik.Reporting.Service assembly (Telerik.Reporting.Service.dll)
  • (.NET 3.5 or above) Database Session State Provider requires Telerik.Reporting.DatabaseSession.dll and Open Access ORM.
  • CubeDataSource requires Telerik.Reporting.Adomd.dll and ADOMD.NET (Microsoft.AnalysisServices.AdomdClient.dll v.10.0.0.0 or above).


Deploying Web Site

[image]

Telerik Reporting Q2 2012
Deploying Web Site
Send Feedback

This article describes how to deploy Web Sites that use Telerik Reporting on a production server.

During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Web Site project the assemblies from the GAC are not copied automatically so you need to make sure the assemblies physically exist in the bin folder of your application.

Required assemblies:

  • Telerik.Reporting.dll
  • Telerik.ReportViewer.WebForms.dll

Optional assemblies:

These assemblies add up to the core reporting functionality and should be used only if you need the specific feature. They are responsible for additional support formats, database session, retrieving data from an OLAP cube or using the Silverlight report viewer.

  • (.NET 3.5 or above) XPS rendering extension requires Telerik.Reporting.XpsRendering assembly (Telerik.Reporting.XpsRendering.dll)
  • (.NET 3.5 or above) DOCX/PPTX/XLSX rendering extensions require Telerik.Reporting.OpenXmlRendering.dll and Open XML SDK 2.0 for Microsoft Office (DocumentFormat.OpenXml.dll v.2.0.5022.0 or above).
  • (.NET 3.5 or above) The Telerik Reporting WCF Service (if needed) requires Telerik.Reporting.Service assembly (Telerik.Reporting.Service.dll)
  • (.NET 3.5 or above) Database Session State Provider requires Telerik.Reporting.DatabaseSession.dll and Open Access ORM.
  • CubeDataSource requires Telerik.Reporting.Adomd.dll and ADOMD.NET (Microsoft.AnalysisServices.AdomdClient.dll v.10.0.0.0 or above).


Deploying Silverlight Application

[image]

Telerik Reporting Q2 2012
Deploying Silverlight Application
Send Feedback

All referenced assemblies are embedded into the XAP file at compile time and no extra steps are required for the Silverlight Application. You still need to include required assemblies based on the project you host the Silverlight application in e.g. if you're hosting it in Web Application, you should review the Deploying Web Applications help article.


Deploying Windows Forms Applications

[image]

Telerik Reporting Q2 2012
Deploying Windows Forms Applications
Send Feedback

This article describes how to deploy Windows Forms Application that use Telerik Reporting.

During the installation of Telerik Reporting on your machine, the Telerik assemblies were added to GAC. When deploying a Windows Forms Application project the assemblies from the GAC are not copied automatically so you need to make sure the assemblies physically exist in the bin folder of your application:

Required assemblies:

  • Telerik.Reporting.dll
  • Telerik.ReportViewer.WinForms.dll

Optional assemblies:

These assemblies add up to the core reporting functionality and should be used only if you need the specific feature. They are responsible for additional support formats, database session or retrieving data from an OLAP cube.

  • (.NET 3.5 or above) XPS rendering extension requires Telerik.Reporting.XpsRendering assembly (Telerik.Reporting.XpsRendering.dll)
  • (.NET 3.5 or above) DOCX/PPTX/XLSX rendering extensions require Telerik.Reporting.OpenXmlRendering.dll and Open XML SDK 2.0 for Microsoft Office (DocumentFormat.OpenXml.dll v.2.0.5022.0 or above).
  • (.NET 3.5 or above) Database Session State Provider requires Telerik.Reporting.DatabaseSession.dll and Open Access ORM.
  • CubeDataSource requires Telerik.Reporting.Adomd.dll and ADOMD.NET (Microsoft.AnalysisServices.AdomdClient.dll v.10.0.0.0 or above).


Deploying WPF Applications

[image]

Telerik Reporting Q2 2012
Deploying WPF Applications
Send Feedback

This article describes how to deploy WPF Application that use Telerik Reporting.

To deploy a WPF Application project containing WPF report viewer used to deliver reports produced by Telerik Reporting you need to make sure the assemblies physically exist in the bin folder of your application:

Required assemblies:

  • Telerik.Reporting.dll
  • Telerik.ReportViewer.Wpf.dll
  • Telerik.Reporting.XpsRendering.dll

Optional assemblies:

These assemblies add up to the core reporting functionality and should be used only if you need the specific feature. They are responsible for additional support formats, database session or retrieving data from an OLAP cube.

  • (.NET 3.5 or above) DOCX/PPTX/XLSX rendering extensions require Telerik.Reporting.OpenXmlRendering.dll and Open XML SDK 2.0 for Microsoft Office (DocumentFormat.OpenXml.dll v.2.0.5022.0 or above).
  • (.NET 3.5 or above) Database Session State Provider requires Telerik.Reporting.DatabaseSession.dll and Open Access ORM.
  • CubeDataSource requires Telerik.Reporting.Adomd.dll and ADOMD.NET (Microsoft.AnalysisServices.AdomdClient.dll v.10.0.0.0 or above).
The WPF report viewer requires the corresponding RadControls for WPF assemblies, available at the time of the Telerik Reporting release.
  • Telerik.Windows.Data.dll
  • Telerik.Windows.Controls.dll
  • Telerik.Windows.Controls.Input.dll
  • Telerik.Windows.Controls.Navigation.dll


ADOMD.NET

[image]

Telerik Reporting Q2 2012
ADOMD.NET
Send Feedback

ADOMD.NET is a .NET object model, used for building client applications that access an XML for Analysis 1.1 compliant data provider, such as that provided by the XML for Analysis 1.1 SDK.

Download

ADOMD.NET Download link


Open XML SDK 2.0 for Microsoft Office

[image]

Telerik Reporting Q2 2012
Open XML SDK 2.0 for Microsoft Office
Send Feedback

Open XML is an open ECMA 376 standard and is also approved as the ISO/IEC 29500 standard that defines a set of XML schemas for representing spreadsheets, charts, presentations, and word processing documents. Microsoft Office Word 2007, Excel 2007, and PowerPoint 2007 all use Open XML as the default file format.

The Open XML file formats are useful for developers because they use an open standard and are based on well-known technologies: ZIP and XML.

Download

Open XML SDK 2.0 for Microsoft Office Download link


Telerik Reporting WCF Service

[image]

Telerik Reporting Q2 2012
Telerik Reporting WCF Service
Send Feedback

The Telerik Reporting Service is a WCF service that enables the remote access to the Telerik Reporting Engine. The Reporting Service acts as a communication interface between the client programs and the report server.

The Telerik Reporting WCF Service is usually exposed to the clients through a .NET 3.5 application.

Telerik Reporting WCF Service exposes two contracts:

  • The Telerik.Reporting.Service..::.IReportService - meant for basic report operations, which can be used by client viewer applications: render, page navigation, parameters etc.
  • The Telerik.Reporting.Service..::.IResourceService - all its exposed operations should be accessed through HTTP GET request only
Caution

The Telerik Reporting WCF Service uses session state and it should be enabled at all times. Make sure that you do not have EnableSessionState=false in your page directive or <sessionState mode="Off"> in your web.config or machine.config files.

The WCF Report Service's main purpose is to provide access for the Silverlight Report Viewer to the reporting engine. There are 3 methods of Telerik.Reporting.Service.IReportService that may be of interest to you:

  • IList<ReportInfo> IReportService..::.ListAvailableReports - returns a list of all available for the report service hosting application Report types. That is all types implementing the The Telerik.Reporting..::.IReportDocument interface that are available for the application hosting the report service.
  • IList<ExtensionInfo> IReportService..::.ListRenderingExtensions - returns all rendering extensions available for the report service.
  • IReportService..::.Render (string format, string report, NameValueDictionary deviceInfo, NameValueDictionary parameters) - renders the specified report (assembly qualified type name) in the specified format (see ListRenderingExtensions operation above), with the given deviceInfo settings and parameter values.


Hosting WCF Service in IIS

[image]

Telerik Reporting Q2 2012
Hosting WCF Service in IIS
Send Feedback

This topic describes how to host the Telerik Reporting WCF Service in IIS. For this purpose you should follow the steps below to configure your web application:

  1. In order to take advantage of the Silverlight viewer and WCF service, your application should target .NET 3.5 or above framework.
  2. Required assembly references:
    • System.ServiceModel.dll assembly
    • Telerik.Reporting.Service.dll assembly
    • Assemblies with Telerik Reports to be exposed through the Reporting Service
  3. Add .svc file (e.g. ReportService.svc) to reference the Telerik.Reporting.Service..::.ReportService. The file would contain the following line only:
    CopyXML
    <%@ServiceHost Service="Telerik.Reporting.Service.ReportService, Telerik.Reporting.Service, Version=x.x.x.x, Culture=neutral, PublicKeyToken=A9D7983DFCC261BE" %>
    Caution

    The code sample have the version listed as Version=x.x.x.x, and you should change that with the exact assembly version you use before proceeding.

  4. Register the Reporting Service endpoints in the web.config:
    CopyXML
    <configuration>
    ...
    <system.serviceModel>
        <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
        <services>
            <service
                    name="Telerik.Reporting.Service.ReportService"
                    behaviorConfiguration="ReportServiceBehavior">
             <endpoint
                    address=""
                    binding="basicHttpBinding"
                    contract="Telerik.Reporting.Service.IReportService">
                    <identity>
                        <dns value="localhost" />
                    </identity>
                </endpoint>
                <endpoint
                        address="resources"
                        binding="webHttpBinding"
                        behaviorConfiguration="WebBehavior"
                        contract="Telerik.Reporting.Service.IResourceService"/>
                <endpoint
                        address="mex"
                        binding="mexHttpBinding"
                        contract="IMetadataExchange" />
            </service>
        </services>
        <behaviors>
            <serviceBehaviors>
                <behavior name="ReportServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" />
                    <serviceDebug includeExceptionDetailInFaults="false" />
                </behavior>
            </serviceBehaviors>
            <endpointBehaviors>
                <behavior name="WebBehavior">
                    <webHttp />
                </behavior>
            </endpointBehaviors>
        </behaviors>
    </system.serviceModel>
    ...
</configuration>
Caution

For troubleshooting and configuring IIS hosted WCF services, please refer to IIS Hosted Service Fails article in MSDN.

Related Articles:

  • Hosting Windows Communication Foundation Services
  • How to: Host a WCF Service in IIS


Enable SSL for Telerik Reporting WCF service

[image]

Telerik Reporting Q2 2012
Enable SSL for Telerik Reporting WCF service
Send Feedback

When using HTTP as the transport, security is provided by a Secure Sockets Layer (SSL) implementation. SSL is widely used on the Internet to authenticate a service to a client, and then to provide confidentiality (encryption) to the channel. This topic explains how to enable SSL for the Telerik Reporting WCF service.

The solution is to configure corresponding bindings to use Transport security mode. Use the bindingConfiguration property inside your endpoint definition to point to your custom bindings.

The entire HTTPS-enabled system.serviceModel section of web.config is below:

CopyXML
<system.serviceModel>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />

        <bindings>
            <basicHttpBinding>
                <binding name="BasicHttpBindingConfig">
                    <security mode="Transport"/>
                </binding>
            </basicHttpBinding>
            <webHttpBinding>
                <binding name="WebHttpBindingConfig">
                    <security mode="Transport"/>
                </binding>
            </webHttpBinding>
        </bindings>

        <services>
            <service name="Telerik.Reporting.Service.ReportService"
                        behaviorConfiguration="ReportServiceBehavior">

                <endpoint address=""
                            binding="basicHttpBinding"
                            bindingConfiguration="BasicHttpBindingConfig"
                            contract="Telerik.Reporting.Service.IReportService">
                    <identity>
                        <dns value="localhost" />
                    </identity>
                </endpoint>

                <endpoint address="resources"
                            binding="webHttpBinding"
                            bindingConfiguration="WebHttpBindingConfig"
                            behaviorConfiguration="WebBehavior"
                            contract="Telerik.Reporting.Service.IResourceService"/>

                <endpoint address="mex"
                            binding="mexHttpBinding"
                            contract="IMetadataExchange" />
            </service>
        </services>

        <behaviors>
            <serviceBehaviors>
                <behavior name="ReportServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" />
                    <serviceDebug includeExceptionDetailInFaults="false" />
                </behavior>
            </serviceBehaviors>

            <endpointBehaviors>
                <behavior name="WebBehavior">
                    <webHttp />
                </behavior>
            </endpointBehaviors>

        </behaviors>
    </system.serviceModel>

Related topics:

  • How to Setup SSL on IIS 7
  • Transport Security Overview
  • HTTP Transport Security
  • BasicHttpSecurityMode Enumeration


How to: Create Self-Hosted Telerik Reporting WCF Service

[image]

Telerik Reporting Q2 2012
How to: Create Self-Hosted Telerik Reporting WCF Service
Send Feedback

The advantages of a Self-Hosted service:

  • Easy to use: With only a few lines of code you have your service running.
  • Easy to debug: Debugging WCF services that are hosted in a self-hosted environment provides a familiar way of debugging, without having to attach to separate applications that activate your service.
  • Easy to deploy.
  • Flexible: You can easily control the lifetime of your services.
  • Supports all bindings and transport.

To create a Telerik self-hosted reporting service follow the steps below:

  1. Create a new Windows console application and make sure it uses .NET Framework 3.5

  2. Add references to the following System assemblies:

    • System.ServiceModel
    • System.Runtime.Serialization
    • System.Drawing
    • System.Windows.Forms

  3. Add references to the following Telerik Reporting assemblies:

    • Telerik.Reporting
    • Telerik.Reporting.Service
    • Telerik.Reporting.XpsRendering (in case you plan to render reports in XPS format)

  4. The Telerik Reporting WCF Service is represented by the Telerik.Reporting.Service.ReportServiceBase - abstract class that requires a base URI to be used for proper resource resolution. This base URI is usually the well-known address of the report service endpoint:

    CopyC#
    [System.Runtime.Serialization.KnownType(typeof(object[]))]
class ReportService : Telerik.Reporting.Service.ReportServiceBase
{
    static readonly Uri baseUri = new Uri("http://localhost:54321/reportservice");

    protected override Uri BaseAddress
    {
        get { return baseUri; }
    }
}
    CopyVB.NET
    <System.Runtime.Serialization.KnownType(GetType(Object()))> _
Class ReportService
    Inherits Telerik.Reporting.Service.ReportServiceBase
    Shared ReadOnly baseUri As New Uri("http://localhost:54321/reportservice")

    Protected Overrides ReadOnly Property BaseAddress() As Uri
        Get
            Return baseUri
        End Get
    End Property
End Class

  5. Create a ServiceHost for our ReportService and call its Open method:

    CopyC#
    public class ReportServiceBaseSnippets
{

    public static void Main(string[] args)
    {
        System.ServiceModel.ServiceHost host = new System.ServiceModel.ServiceHost(typeof(ReportService));
        host.Open();

        // Block the Main() method until the user presses a key; then close the host and exit the program
        Console.WriteLine("Ready...");
        Console.ReadLine();

        host.Close();
    }

}
    CopyVB.NET
    Public Class ReportServiceBaseSnippets

    Public Shared Sub Main(ByVal args As String())
        Dim host As New System.ServiceModel.ServiceHost(GetType(ReportService))
        host.Open()

        ' Block the Main() method until the user presses a key; then close the host and exit the program
        Console.WriteLine("Ready...")
        Console.ReadLine()

        host.Close()
    End Sub

End Class

  6. To configure the service and its endpoints add the next code to the application’s configuration file:

    CopyC#
    <?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <system.serviceModel>
    <services>
      <service name="ConsoleApplication1.ReportService"
               behaviorConfiguration="ReportServiceBehavior">

        <host>
          <baseAddresses>
            <add baseAddress="http://localhost:54321"/>
          </baseAddresses>
        </host>

        <endpoint address="ReportService"
                  binding="basicHttpBinding"
                  contract="Telerik.Reporting.Service.IReportService">
          <identity>
            <dns value="localhost" />
          </identity>
        </endpoint>

        <endpoint address="ReportService/resources"
                  binding="webHttpBinding"
                  behaviorConfiguration="WebBehavior"
                  contract="Telerik.Reporting.Service.IResourceService"/>

        <endpoint address=""
                  binding="webHttpBinding"
                  behaviorConfiguration="WebBehavior"
                  contract="Telerik.Reporting.Service.IClientAccessPolicy"/>

        <endpoint address="mex"
                  binding="mexHttpBinding"
                  contract="IMetadataExchange" />
      </service>
    </services>

    <behaviors>
      <serviceBehaviors>
        <behavior name="ReportServiceBehavior">
          <serviceMetadata httpGetEnabled="true" />
          <serviceDebug includeExceptionDetailInFaults="false" />
        </behavior>
      </serviceBehaviors>

      <endpointBehaviors>
        <behavior name="WebBehavior">
          <webHttp />
        </behavior>
      </endpointBehaviors>
    </behaviors>
  </system.serviceModel>
</configuration>

  7. Add a new report Report1 to the project to test the self-hosted report service.

  8. Run the application – the Windows console will appear and when the "Ready…" message appears the service is ready to operate.

  9. To test the self-hosted Telerik Reporting WCF Service we use the Export operation for the Resource Service (Telerik.Reporting.Service.IResourceService). As it is dedicated to be used by HTTP GET request we will use a web browser application as a client. Open any web browser and type the next address:

    http://localhost:54321/reportservice/resources/export?format=PDF&report=YourNameSpace.Report1,YourNameSpace&deviceInfo={}&parameterValues={}

    This will call the IResourceService. Export operation that will render the report in PDF with no deviceInfo or parameterValues. When completed, a PDF document will be sent back to the browser.


How to: Implement and use custom IReportResolver

[image]

Telerik Reporting Q2 2012
How to: Implement and use custom IReportResolver
Send Feedback

The client programs invoke the report rendering from the service using a string report description. Based on the report description the service’s report resolvers try to create an IReportDocument instance needed by the ReportProcessor.

The IReportDocument interface represents a report document. This includes a single Report or ReportBook. The IReportDocument returned by the report resolver will be further handled by the ReportProcessor.

The service includes default report resolvers that are capable to resolve IReportDocument from relative and physical path that points to trdx file (report definition serialized in XML) or from assembly qualified name. This way we cover most of the scenarios. However if you have requirements that are not covered by the default report resolvers, such as retrieving report definitions stored in database or building a report book based on the report description, you can plug into the Telerik Reporting Service report resolving workflow.

The report resolvers implement the IReportResolver interface. This interface has only one method Resolve with a string argument - the report description. In custom resolver implementations you should use that description as you like in order to map it to IReportDocument instance.

If you use the Silverlight report viewer the report description is provided by the ReportViewer.Report property.

Extending Telerik Reporting WCF service with custom IReportResolver implementation:

  1. Prerequisites:

    • Web application that targets .NET 3.5+
    • Reference to System.ServiceModel.dll assembly
    • Reference to Telerik.Reporting.Service.dll assembly
    • Telerik Reports definitions to be exposed through the Reporting Service

  2. Steps to implement and use custom IReportResolver:

    1. Implement the Telerik.Reporting.Service.IReportResolver

      CopyC#
      class ReportResolver : IReportResolver
{
    public ReportSource Resolve(string report)
    {
        //TODO implement custom report resolving mechanism
        throw new NotImplementedException();
    }
}
      CopyVB.NET
      Class ReportResolver
    Implements IReportResolver
    Public Function Resolve(report As String) As ReportSource Implements IReportResolver.Resolve
        'TODO implement custom report resolving mechanism
        Throw New NotImplementedException()
    End Function
End Class

    2. In order to utilize your IReportResolver implementation, create a Telerik.Reporting.Service subclass and in your subclass constructor pass your IReportResolver implementation to the Telerik.Reporting.ServiceBase.ReportResolver property:

      CopyC#
      class CustomReportService : ReportService
{
    static readonly IReportResolver resolver = new ReportResolver();

    public CustomReportService()
    {
        this.ReportResolver = resolver;
    }
}
      CopyVB.NET
      Class CustomReportService
    Inherits ReportService
    Shared ReadOnly resolver As IReportResolver = New ReportResolver()

    Public Sub New()
        Me.ReportResolver = resolver
    End Sub
End Class

  3. Steps to implement and use custom IReportResolver with fallback mechanism:

    1. Add to your IReportResolver implementation a constructor with parameter IReportDocument parentResolver. Then use the parentResolver if the custom report resolving mechanism fails.

      CopyC#
      class ReportResolverWithFallBack : IReportResolver
{
    readonly IReportResolver parentResolver;

    public ReportResolverWithFallBack(IReportResolver parentResolver)
    {
        this.parentResolver = parentResolver;
    }

    public ReportSource Resolve(string report)
    {
        ReportSource reportDocument = null;
        reportDocument = this.CustomReportResolver(report);

        if (null == reportDocument && null != this.parentResolver)
        {
            reportDocument = this.parentResolver.Resolve(report);
        }

        return reportDocument;
    }

    public ReportSource CustomReportResolver(string report)
    {
        //TODO implement custom report resolving mechanism
        return null;
    }
}
      CopyVB.NET
      Class ReportResolverWithFallBack
    Implements IReportResolver
    ReadOnly parentResolver As IReportResolver

    Public Sub New(parentResolver As IReportResolver)
        Me.parentResolver = parentResolver
    End Sub

    Public Function Resolve(report As String) As ReportSource Implements IReportResolver.Resolve
        Dim reportDocument As IReportDocument = Nothing
        reportDocument = Me.CustomReportResolver(report)

        If reportDocument Is Nothing AndAlso Me.parentResolver IsNot Nothing Then
            reportDocument = Me.parentResolver.Resolve(report)
        End If

        Return reportDocument
    End Function

    Public Function CustomReportResolver(report As String) As ReportSource
        'TODO implement custom report resolving mechanism
        Return Nothing
    End Function
End Class

    2. Add to Telerik.Reporting.Service subclass the IReportResolver implementations in a chain. Thus the custom one will be executed first, if it fails the second one and so on.

      CopyC#
      class ReportServiceWithResolverFallback : ReportService
{
    static readonly IReportResolver resolvers = new ReportResolverWithFallBack(
                                                  new ReportTypeResolver(
                                                   new ReportFileResolverWeb(null)));
    public ReportServiceWithResolverFallback()
    {
        this.ReportResolver = resolvers;
    }
}
      CopyVB.NET
      Class ReportServiceWithResolverFallback
    Inherits ReportService
    Shared ReadOnly resolvers As IReportResolver = New ReportResolverWithFallBack(New ReportTypeResolver(New ReportFileResolverWeb(Nothing)))
    Public Sub New()
        Me.ReportResolver = resolvers
    End Sub
End Class

      You can use for fallback the default IReportResolver implementations:

      • ReportTypeResolver - Resolves IReportDocument from assembly qualified name
      • ReportFileResolver - Resolves IReportDocument from physical path to trdx file
      • ReportFileResolverWeb - Resolves IReportDocument from a relative path to trdx file

  4. Hosting Telerik.Reporting.Service.ReportService subclass in IIS.

    1. Add .svc file (e.g. ReportService.svc) to reference your Telerik.Reporting.Service.ReportService subclass. The file would contain the following line only:

      CopyXML
      <%@ServiceHost Service="CSharp.SilverlightDemo.Web.CustomReportService , CSharp.SilverlightDemo.Web" %>

    2. Register the Reporting Service endpoints with service name your Telerik.Reporting.Service.ReportService subclass in the web.config:

      CopyC#
      <?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <system.serviceModel>
        <services>
            <service name="CSharp.SilverlightDemo.Web.CustomReportService"
                     behaviorConfiguration="ReportServiceBehavior">
                <endpoint
                       address=""
                       binding="basicHttpBinding"
                       contract="Telerik.Reporting.Service.IReportService">
                    <identity>
                        <dns value="localhost" />
                    </identity>
                </endpoint>
                <endpoint
                        address="resources"
                        binding="webHttpBinding"
                        behaviorConfiguration="WebBehavior"
                        contract="Telerik.Reporting.Service.IResourceService"/>
                <endpoint
                        address="mex"
                        binding="mexHttpBinding"
                        contract="IMetadataExchange" />
            </service>
        </services>
        <behaviors>
            <serviceBehaviors>
                <behavior name="ReportServiceBehavior">
                    <serviceMetadata httpGetEnabled="true" />
                    <serviceDebug includeExceptionDetailInFaults="false" />
                </behavior>
            </serviceBehaviors>
            <endpointBehaviors>
                <behavior name="WebBehavior">
                    <webHttp />
                </behavior>
            </endpointBehaviors>
        </behaviors>
    </system.serviceModel>
</configuration>


Configuring Telerik Reporting

[image]

Telerik Reporting Q2 2012
Configuring Telerik Reporting
Send Feedback

This section discuss the configuration of Telerik Reporting:

  • Telerik Reporting Configuration Section
  • Device Information Settings
  • Configuring Session State
  • Configuring the File Session State Provider
  • Configuring the Database Session State Provider


Rendering Extensions

[image]

Telerik Reporting Q2 2012
Rendering Extensions
Send Feedback

A rendering extension is a component of the Telerik Reporting engine that transforms report data and layout into a device-specific format. By default Telerik Reporting outputs reports in the following formats: Image, PDF, HTML, MHTML, Excel 97-2003, XLSX, PPTX, DOCX, RTF and CSV. You can specify rendering extension parameters in your application’s configuration file to override the default report rendering behavior. The rendering extension parameters are specified as device information settings.

Adding device information settings to an application configuration file is useful when you want to override the default values that are provided by the reporting engine. Specifying device information settings in the configuration files affects rendering extensions globally. The settings in the configuration files are used in place of default values whenever a particular rendering extension is used. If you want to set rendering extension parameters for a specific report or rendering operation, you must specify device information programmatically using the RenderReport method. For more information about specifying device information settings for a rendering operation, and to view the complete list of device information settings, see Telerik Reporting Device Information Settings.

Caution

For Windows applications the configuration file is called app.config and for ASP.NET applications – web.config. For more information about configuring a .NET application, see Configuring Applications( http://msdn2.microsoft.com/en-us/library/kza1yk3a(VS.80).aspx).

Caution

All configuration settings on Telerik Reporting engine are applied only at runtime, not in design-time.

The following table describes the rendering extensions that are included with Telerik Reporting:

Extension Name | Description | Type
IMAGE | Renders a report in a page-oriented format. The format is shown as TIFF in the Export drop-down of the report toolbar. | Telerik.Reporting.ImageRendering.ImageReport, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
PDF | Renders a report in the Adobe Acrobat Reader. The format is shown as Acrobat (PDF) File in the Export drop-down of the report toolbar. | Telerik.Reporting.ImageRendering.PdfReport, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
HTML | Renders a report in XHTML 1.1 compliant HTML. | Telerik.Reporting.HtmlRendering.HtmlRenderingExtension, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
MHTML | Renders a report in MHTML. The report opens in Internet Explorer. The format is shown as Web Archive in the Export drop-down of the report toolbar. | Telerik.Reporting.HtmlRendering.MHtmlRenderingExtension, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
XLS | Renders a report in Microsoft Excel. The report opens in Microsoft Excel 97 or later. | Telerik.Reporting.ExcelRendering.Excel97.ExcelReport, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
CSV | Renders a report in comma-delimited format. The report opens in a viewing tool associated with CSV file formats. | Telerik.Reporting.CsvRendering.CsvRenderingExtension, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
RTF | Renders a report in Rich Text Format. The report opens in Microsoft Word 97 or later. | Telerik.Reporting.RtfRendering.RtfReport, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
XPS | Renders a report in XML Paper Specification (XPS) format - electronic representation of digital documents based on XML.The report opens in Microsoft XPS Viewer. | Telerik.Reporting.XpsRendering.XpsReport, Telerik.Reporting.XpsRendering, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
DOCX | Renders a report in Microsoft Word 2007 format (also known as OpenXML) - it is a zipped, XML-based file format developed by Microsoft for representing word processing documents. | Telerik.Reporting.OpenXmlRendering.Wordprocessing.WordprocessingReport, Telerik.Reporting.OpenXmlRendering, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
XLSX | Renders a report in Microsoft Excel 2007 format (also known as OpenXML) - it is a zipped, XML-based file format developed by Microsoft for representing spreadsheets. | Telerik.Reporting.OpenXmlRendering.Spreadsheet.SpreadsheetReport, Telerik.Reporting.OpenXmlRendering, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
PPTX | Renders a report in Microsoft PowerPoint 2007 format (also known as OpenXML) - it is a zipped, XML-based file format developed by Microsoft for presentations. | Telerik.Reporting.OpenXmlRendering.Presentation.PresentationReport, Telerik.Reporting.OpenXmlRendering, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
Note

Replace the version number above with the version of Telerik Reporting assembly that you are using.


Telerik Reporting Configuration Section

[image]

Telerik Reporting Q2 2012
Telerik Reporting Configuration Section
See Also Send Feedback

Telerik Reporting settings are defined in a custom configuration section called Telerik.Reporting. In order to process the configuration file correctly the .NET Framework requires this section to be the first child element in the <configuration> element, like this:

CopyXML
<configuration>
    <configSections>
        <section
                name="Telerik.Reporting"
                type="Telerik.Reporting.Processing.Config.ReportingConfigurationSection, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"
                allowLocation="true"
                allowDefinition="Everywhere"/>
    </configSections>
    …
</configuration>

<Telerik.Reporting> Configuration Section

CopyXML
<Telerik.Reporting>
    <Extensions>
        <Render>
            <Extension>
                <Parameters>
                    <Parameter/>
                </Parameters>
            </Extension>
        </Render>
    </Extensions>
    <SessionState>
        <Providers>
            <Provider>
                <Parameters>
                    <Parameter/>
                </Parameters>
          </Provider>
        </Providers>
    </SessionState>
</Telerik.Reporting>
Caution

For Windows applications the configuration file is called app.config and for ASP.NET applications – web.config. For more information about configuring a .NET application, see Configuring Applications( http://msdn2.microsoft.com/en-us/library/kza1yk3a(VS.80).aspx).

<Telerik.Reporting> element

Telerik.Reporting XML element is the root element of the Telerik Reporting engine settings. All the settings of the Reporting engine are nested in it.

Attributes | No attributes are defined for this element
Child elements | Extensions – Specifies a collection of extensions, for which the configuration is applied
Parent element | Configuration - Specifies the required root element in every configuration file that is used by the common language runtime and the .NET Framework applications. Only one Telerik.Reporting element can be used in the Configuration element.

<Extensions> element

Extensions XML element specifies a collection of extension types, for which configuration is applied.

Attributes | No attributes are defined for this element
Child elements | Render – specifies a collection of render extensions, for which the configuration settings are applied.
Parent element | Telerik.Reporting - specifies the root element of the Telerik Reporting configuration settings. Only one Extensions element can be used in the Telerik.Reporting element.

<Render> element

Render XML element specifies a collection of extensions, for which configuration is applied.

Attributes | No attributes are defined for this element
Child elements | Extension – specifies an extension, for which the configuration settings are applied. Multiple Extension elements can be applied in the Render element
Parent element | Extensions - specifies a collection of extension types, for which configuration is applied. Only one Render element can be used in the Extensions element.

<Extension> element

Extension XML element specifies an extension, for which the configuration settings are applied.

Attributes

name – required string attribute. Name is the key attribute that determines on which extension the configuration is to be applied. The name for every extension is defined in the class definition of the extension, in the ExtensionNameAttribute attribute.

  • type – optional string attribute. It is used when new extension is added or a core extension is overridden with a new one. Specifies the name of the extension class to be used when an extension with the name specified in the name attribute is needed. Use the following format:

    type="Fully qualified class name, assembly file name, version, culture, public key token"

    For example : type="MyAssembly.MyExtension, MyAssembly, Version=1.0.0.0, Culture=neutral,PublicKeyToken=null"

  • description - optional string attribute. Defines a description for the extension.It is used to override the default description of the extension. The reporting engine uses the description in places where the extensions are listed. For example in the Win and Web ReportViewer controls descriptions are used as labels in the dropdownwith available export formats. The default value of the description of every extension is defined in the class definition of the extension, by the ExtansionDescriptionAttribute attribute.
  • visible – Optional boolean attribute(the valid values are visible=”true” or visible=”false”). The value is used to determine if the extension must be populated in the lists of available extensions. The default value is true. You can use it to hide the export format from the list of the available render extensions.
Child elements | Parameters – specifies a collection of parameters for the extension in the Extension element. Only one Parameters element can be used in the Extension element.
Parent element | Render - specifies a collection of extensions, for which the configuration is applied. Multiple Extension elements can be applied in the Render element.

<Parameters> element

Parameters XML element specifies a collection of parameters for the extension defined in the parent Extension element.

Attributes | No attributes are defined for this element
Child elements | Parameter – specifies a parameter for the extension in the Extension element. Multiple Parameter elements can be used in the Parameters element.
Parent element
  • Extension - specifies an extension, for which the configuration is applied. Only one Parameters element can be applied in the Extension element. The default value is true. You can use it to hide the export format from the list of the available render extensions.
  • Provider - specifies a session state provider to register for use in the application.

<Parameter> element

Parameter XML element specifies a parameter for the extension defined in the ancestor Extension element. The parameter is supplied as name/value pairs.

Attributes
  • name – the name of the parameter that is supplied. Required attribute.
  • value – the value of the parameter with the name specified. As the value can be only a string, the parameter Type must have an associatedTypeConverter that handles conversions from string. Built-in .NET value types and enums have type converters defined.
Child elements | No child elements are defined for this element.
Parent element | Parameters - specifies a collection of parameters for the extension defined in the parent Extension element. Multiple Parameter elements can be used in the Parameters element.
CopyXML
<configuration>
    …
    <Telerik.Reporting>
        <Extensions>
            <Render>
                <Extension name="IMAGE" description="JPEG image">
                    <Parameters>
                        <Parameter name="OutputFormat" value="JPEG"/>
                    </Parameters>
                </Extension>
            </Render>
        </Extensions>
        <SessionState provider="File">
            <Providers>
                <Provider name="File" type="Telerik.Reporting.Processing.Session.FileSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be">
                    <Parameters>
                        <Parameter name="BasePath" value="C:\MyDataCache" />
                    </Parameters>
                </Provider>
            </Providers>
        </SessionState>
    </Telerik.Reporting>
    …
</configuration>

<SessionState> element

The SessionState element specifies the configuration settings for the session state management system which is utilized by the viewers to store and cache rendered pages and resources.

Attributes provider – required string attribute. Specifies the name of the current active session state provider used by the viewers. There are several preconfigured providers, although additional ones can be registered in this part of the configuration section. The following session state providers are available by default:
  • Auto - the actual provider is chosen automatically according to the characteristics of the stored resource and the permissions granted to the application;
  • Memory – specifies that the rendered pages and resources are stored in memory;
  • File – specifies that the rendered pages and resources are stored as temporary files in the file system;
  • IsolatedStorage– specifies that the rendered pages and resources are stored as temporary files in the isolated storage.
Child elements | Providers – specifies a collection of session state providers to register for use in the application. Only one Provider child element can be used inside the SessionState parent element.
Parent element | Telerik.Reporting – specifies the root element of the Telerik Reporting configuration settings. Only one SessionState child element can be used inside the Telerik.Reporting root element.

<Providers> element

The Providers element specifies a collection of session state providers to register for use in the application.

Attributes | No attributes are defined for this element.
Child elements | Provider – specifies a session state provider to register for use in the application. Multiple Provider child elements can be used inside a single Providers parent element.
Parent element | SessionState – specifies the configuration settings for the session state used by the viewers. Only one Provider child element can be used inside the SessionState parent element.

<Provider> element

The Provider element specifies a session state provider to register for use in the application.

Attributes
  • name – required string attribute. Specifies a unique name to identify the session state provider in the configuration section. The active session state provider specified by the provider attribute of the SessionState element should match one of the names specified by this attribute.
  • type – required string attribute. Specifies the assembly qualified type name of the session state provider to register. Use the following format: type="Fully qualified class name, assembly file name, version, culture, public key token". For example: type="MyAssembly.MyProvider, MyAssembly, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null".
Child elements | Parameters – specifies a collection of parameters for the current session state provider. Only one Parameters child element can be used in the Provider parent element.
Parent element | Providers – specifies a collection of session state providers to register for use in the application. Multiple Provider child elements can be used inside a single Providers parent element.

Configuring Multiple Entries for a Rendering Extension

You can specify multiple instances of a single rendering extension to vary rendering behavior. If you configure multiple instances, make sure that each extension name is unique. Then you can use the rendering extension programmatically by using the extension name to identify which particular instance to use for a particular rendering operation.

You should also specify the description attribute of the Extension element. The string you specify for description will be visible to users in the list of export options for the report. If you are configuring multiple versions of the same extension, be sure to provide a value for the description. Otherwise, all versions of the extension will have the same export option name.

The following example illustrates how to use the default Image rendering extension (which produces TIFF output) alongside a second instance that outputs reports in EMF. Notice that the extension name distinguishes one instance from the other:

CopyXML
<Telerik.Reporting>
    <Extensions>
        <Render>
            <Extension name="TIFF_CCITT4"
                                 type="Telerik.Reporting.ImageRendering.ImageReport, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"
                                 description="TIFF file (CCITT Group 4)">
                <Parameters>
                    <Parameter name="TiffCompression" value="ccitt4" />
                </Parameters>
            </Extension>
        </Render>
    </Extensions>
</Telerik.Reporting>
Caution

The code samples have the version listed as Version=x.x.x.x, and you should change that with the exact assembly version you use before proceeding.

Set rendering parameters programmatically

To define device rendering parameters programmatically, we need a key/value pair, and what better than a HashTable which represents collection of key/value pairs. If the collection contains rendering parameters that are not supported by the specified rendering extension, they would be ignored.

CopyC#
Telerik.Reporting.Processing.ReportProcessor reportProcessor =
    new Telerik.Reporting.Processing.ReportProcessor();

System.Collections.Hashtable deviceInfo =
    new System.Collections.Hashtable();

deviceInfo.Add("DocumentAuthor", "John Doe");
deviceInfo.Add("DocumentTitle", "My Doc title");

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

instanceReportSource.ReportDocument = report1;

Telerik.Reporting.Processing.RenderingResult result =
    reportProcessor.RenderReport("PDF", instanceReportSource, deviceInfo);
CopyVB.NET
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor()
Dim deviceInfo As New System.Collections.Hashtable()
deviceInfo.Add("DocumentAuthor", "John Doe")
deviceInfo.Add("DocumentTitle", "My Doc title")

Dim instanceReportSource as New Telerik.Reporting.InstanceReportSource()
instanceReportSource.ReportDocument = report1

Dim result As Telerik.Reporting.Processing.RenderingResult = reportProcessor.RenderReport("PDF", instanceReportSource, deviceInfo)

See Also

Other Resources

Device Information Settings
Configuring Session State


Device Information Settings

[image]

Telerik Reporting Q2 2012
Device Information Settings
Send Feedback

In Telerik Reporting, device information settings are used to pass rendering parameters to a rendering extension.

You can specify device information settings in a variety of ways. Programmatically, you can use the RenderReport method. You can also use the <Telerik.Reporting> configuration section to specify rendering parameters globally. For more information about specifying rendering parameters globally, see Configuring Telerik Reporting.

This section discusses the device information settings that are associated with the Telerik Reporting rendering extensions:

  • Image Device Information Settings
  • PDF Device Information Settings
  • Excel Device Information Settings
  • CSV Device Information Settings
  • RTF Device Information Settings
  • XPS Device Information Settings
  • MHTML Device Information Settings
  • HTML Device Information Settings
  • Word Device Information Settings
  • PowerPoint Device Information Settings


Image Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in IMAGE format.

Image Device Information Settings

Name | Type | Description
OutputFormat | String | Defines the output format of the produced image. Supported formats are: BMP, EMF, EMFPLUS, GIF, JPEG, PNG, or TIFF. The default value is TIFF
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.
DpiX | Integer | The resolution of the output image in x-direction. The default value is 96.
DpiY | Integer | The resolution of the output image in y-direction. The default value is 96.
TiffCompression | String | Specifies the compression scheme of the output TIFF file. Supported compression kinds are: LZW, CCITT3, CCITT4, RLE, or NONE. The default value is LZW.

See Also

Other Resources

Device Information Settings
Rendering Extensions


PDF Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in PDF format.

PDF Device Information Settings

Name

Type

Description

FontEmbedding

String

Specifies if the fonts used in the report should be embedded in the output PDF document. Valid values are: Full, Subset, None. Specifying the Subset option will embed only font glyphs that are used, thus reducing output file size while maintaining portability. Default value: Subset.

JavaScript

String

A JavaScript to be compiled and executed by the JavaScript interpreter. Netscape Communications Corporation’s Client-Side JavaScript Reference and the Adobe JavaScript for Acrobat API Reference give details on the contents and effects of JavaScript scripts.

StartPage

Integer

The first page of the report to render. A value of 0 indicates that all pages are rendered.

EndPage

Integer

The last page of the report to render.

DpiX

Integer

The resolution of the output device in x-direction.

DpiY

Integer

The resolution of the output device in y-direction.

DocumentTitle

String

The document’s title.

DocumentAuthor

String

The name of the person who created the document.

DocumentSubject

String

The subject of the document.

DocumentKeywords

String

Keywords associated with the document.

ViewerHideToolbar

Boolean

A flag specifying whether to hide the viewer application’s tool bars when the document is active. Default value: false.

ViewerHideMenubar

Boolean

A flag specifying whether to hide the viewer application’s menu bar when the document is active. Default value: false.

ViewerHideWindowUI

Boolean

A flag specifying whether to hide user interface elements in the document’s window (such as scroll bars and navigation controls), leaving only the document’s contents displayed. Default value: false.

ViewerFitWindow

Boolean

A flag specifying whether to resize the document’s window to fit the size of the first displayed page. Default value: false.

ViewerCenterWindow

Boolean

A flag specifying whether to position the document’s window in the center of the screen. Default value: false.

ViewerDisplayDocTitle

Boolean

A flag specifying whether the window’s title bar should display the document title taken from the DocumentTitle parameter. If false, the title bar should instead display the name of the PDF file containing the document. Default value: false.

ViewerDirection

String

The predominant reading order for text:

  • L2R: Left to right
  • R2L: Right to left (including vertical writing systems, such as Chinese, Japanese, and Korean)

This entry has no direct effect on the document’s contents or page numbering but can be used to determine the relative positioning of pages when displayed side by side or printed n-up. Default value: L2R.

ViewerPrintScaling

String

The page scaling option to be selected when a print dialog is displayed for this document. Valid values are None, which indicates that the print dialog should reflect no page scaling, and AppDefault, which indicates that applications should use the current print scaling. Default value: None.

See Also

Other Resources

Device Information Settings
Rendering Extensions


Excel Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in Excel format.

Excel Device Information Settings

Name | Type | Description
DefaultPageHeader | Boolean | Specifies whether to render the report’s page header in the native Excel page header section. When false (default value) the page header is rendered as a sequence of frozen rows at the top of the worksheet.
DefaultPageFooter | Boolean | Specifies whether to render the report’s page footer in the native Excel page footer section. When false, the footer is rendered as sequence of excel cells. Default value is true.
ShowGridlines | Boolean | Specifies whether Excel Gridlines are visible. Default value is false.

See Also

Other Resources

Device Information Settings
Rendering Extensions


CSV Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in CSV format.

CSV Device Information Settings

Name | Type | Description
FieldDelimiter | String | The delimiter string to put in the result. The default value is a comma (,).
NoHeader | Boolean | Indicates whether the header row is excluded from the output. The default value is false.
NoStaticText | Boolean | Indicates whether static text is excluded from the output. From Telerik Reporting point of view a TextBox item which value is a string that does not start with = is considered static; otherwise it is evaluated as an expression. The default value is false.
Qualifier | String | The qualifier string to put around results that contain the field delimiter. If the results contain the qualifier, the qualifier is repeated. The Qualifier setting must be different from the FieldDelimiter setting. The default value is a quotation mark (").

See Also

Other Resources

Device Information Settings
Rendering Extensions


RTF Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in RTF format.

RTF Device Information Settings

Name | Type | Description
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.
RenderingMode | String | Specifies whether to use Tables or Frames to render the rtf file. Available modes are: Auto, Tables and Frames. The default mode is Auto. If Table/List/Crosstab report items are used in the report, the mode automatically changes to Tables, if not it uses Frames. Setting it explicitly to different value than Auto would force the RTF rendering extension to use the selected mode.

See Also

Other Resources

Device Information Settings
Rendering Extensions


XPS Device Information Settings

[image]

Telerik Reporting Q2 2012
XPS Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in XPS format.

XAML/XPS Device Information Settings

Name | Type | Description
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.

See Also

Other Resources

Device Information Settings
Rendering Extensions


MHTML Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in MHTML format.

MHTML Device Information Settings

Name

Type

Description

EmailCompatible

Boolean

Specifies whether the rendered report is compatible with MS Outlook. This is required as the Word rendering engine does not support some HTML and CSS attributes. For more information about HMTL and CSS standards, visit the following Microsoft websites:

  • http://msdn2.microsoft.com/en-us/library/aa338200.aspx
  • http://msdn2.microsoft.com/en-us/library/aa338201.aspx
The default mode is False.

See Also

Other Resources

Device Information Settings
Rendering Extensions


HTML Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in HTML format.

HTML Device Information Settings

No parameters can be specified for the HTML rendering extension.

See Also

Other Resources

Device Information Settings
Rendering Extensions


Word Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in Word format.

Word Device Information Settings

Name | Type | Description
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.

See Also

Other Resources

Device Information Settings
Rendering Extensions


PowerPoint Device Information Settings
See Also Send Feedback

The following table lists the device information settings for rendering in PowerPoint format.

PowerPoint Device Information Settings

Name | Type | Description
StartPage | Integer | The first page of the report to render. A value of 0 indicates that all pages are rendered.
EndPage | Integer | The last page of the report to render.

See Also

Other Resources

Device Information Settings
Rendering Extensions


Configuring Session State

[image]

Telerik Reporting Q2 2012
Configuring Session State
See Also Send Feedback

The session state management system can be configured by specifying one or more session state providers in the Telerik Reporting Configuration Section of the application’s configuration file. For example, the following XML snippet configures the session state to store the rendered pages and resources in the file system:

CopyXML
<Telerik.Reporting>
  <SessionState provider="File" />
</Telerik.Reporting>

The "provider" attribute of the "SessionState" element specifies the name of the current session state provider used by the viewers. There are several preconfigured providers that can be used by applications without any additional setup:

Provider | Description
Auto | The actual provider is chosen automatically according to the characteristics of the stored resource and the permissions granted to the application. This is the default setting if the "SessionState" element is omitted from the configuration section.
Memory | All rendered pages and resources are stored in memory. Use this setting to improve the performance when rendering relatively small reports in desktop applications. However this could also increase the memory footprint of the application significantly for large reports.
File | All rendered pages and resources are stored as temporary files in the file system.
IsolatedStorage | All rendered pages and resources are stored as temporary files in the isolated storage.

Except the preconfigured session state providers, additional providers can be registered under the "Providers" child element of the "SessionState" element. For example, Telerik Reporting is distributed with a session state provider that utilizes the Open Access ORM to store session state in a database. The following code snippet demonstrates how to configure this provider:

CopyXML
<Telerik.Reporting>
  <SessionState provider="Database">
    <Providers>
      <Provider name="Database" type="Telerik.Reporting.DatabaseSession.DatabaseSessionProvider, Telerik.Reporting.DatabaseSession, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be">
        <Parameters>
          <Parameter name="BackendName" value="mssql" />
          <Parameter name="ConnectionString" value="MyConnectionString" />
        </Parameters>
      </Provider>
    </Providers>
  </SessionState>
</Telerik.Reporting>

The individual providers are registered by adding one or more "Provider" elements. Here the "name" attribute specifies the friendly name of the provider and the "type" attribute specifies the assembly-qualified type name of that provider. If the provider requires additional parameters, these can be specified under the "Parameters" child element of the "Provider" element. The individual parameters are specified by adding one or more "Parameter" elements. Here the "name" attribute specifies the name of the parameter and the "value" attribute specifies the value of that parameter.

The following table lists all session state providers distributed with Telerik Reporting:

Provider | Description | Type
Auto | Chooses the storage automatically according to the characteristics of the stored resources and granted permissions to the application. | Telerik.Reporting.Processing.Session.SmartSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
Memory | Stores all resources in memory. | Telerik.Reporting.Processing.Session.MemorySessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
File | Stores all resources as temporary files in the file system. | Telerik.Reporting.Processing.Session.FileSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
IsolatedStorage | Stores all resources as temporary files in the isolated storage. | Telerik.Reporting.Processing.Session.IsolatedStorageSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
Database | Stores all resources in database. Uses Open Access ORM to access the database. | Telerik.Reporting.DatabaseSession.DatabaseSessionProvider, Telerik.Reporting.DatabaseSession, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be
ADO.NET | Stores all resources in database. Uses ADO.NET provider to access the database. | Telerik.Reporting.Processing.Session.AdoNetSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be

See Also

Other Resources

Configuring the File Session State Provider
Configuring the Database Session State Provider
Telerik Reporting Configuration Section


Configuring the File Session State Provider

[image]

Telerik Reporting Q2 2012
Configuring the File Session State Provider
See Also Send Feedback

The file session state provider is used to cache rendered pages and resources as temporary files on disk. This can help reducing the memory footprint of the application without sacrificing the performance significantly. It is necessary to configure the Telerik Reporting Configuration Section first and then use the following XML snippet that configures the viewers in the application to use the file session state provider:

CopyXML
<Telerik.Reporting>
  <SessionState provider="File" />
</Telerik.Reporting>

By default, this provider stores the files in the temporary folder of the current user. However it can be configured to store the files in another location by specifying the "BasePath" parameter, as illustrated below:

CopyXML
<Telerik.Reporting>
  <SessionState provider="File">
    <Providers>
      <Provider name="File" type="Telerik.Reporting.Processing.Session.FileSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be">
        <Parameters>
          <Parameter name="BasePath" value="C:\MyDataCache" />
        </Parameters>
      </Provider>
    </Providers>
  </SessionState>
</Telerik.Reporting>

The "BasePath" can represent either an absolute path on disk or a relative path. In the latter case the path is mapped to the application’s working directory.

See Also

Other Resources

Configuring Session State
Configuring the Database Session State Provider
Telerik Reporting Configuration Section


Configuring the Database Session State Provider

[image]

Telerik Reporting Q2 2012
Configuring the Database Session State Provider
See Also Send Feedback

The database session state provider stores the rendered pages and resources in database. This is useful in web farm applications where different computers can serve different requests to the same report, so a common storage is necessary to hold the shared resources.

Before using the database session state provider it is necessary to install the shared database. Start the Database Session Configuration Tool that can be found in the following location:

-InstallDir-\Tools\DatabaseSessionConfigurator.exe

where InstallDir is the installation directory of Telerik Reporting.

Choose the desired target backend from the drop-down list and specify the connection string to the database being created in the text block below. It is recommended that the database specified in the connection string is different from your production database. Click the "Configure" button to configure the database. The Database Session Configuration Tool can be used to create a new database or reconfigure an existing one, if the database schema has changed from the previous release of Telerik Reporting.

The database session state provider is distributed as a separate assembly and requires .NET Framework 3.5 and above. It utilizes the Open Access ORM internally to access the database (requires reference to Telerik.OpenAccess.35.Extensions.dll). It is necessary to configure the Telerik Reporting Configuration Section first and then use the following XML snippet to configure this provider in application’s configuration file:

CopyXML
<Telerik.Reporting>
  <SessionState provider="Database">
    <Providers>
      <Provider name="Database" type="Telerik.Reporting.DatabaseSession.DatabaseSessionProvider, Telerik.Reporting.DatabaseSession, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be">
        <Parameters>
          <Parameter name="BackendName" value="mssql" />
          <Parameter name="ConnectionString" value="MyConnectionString" />
        </Parameters>
      </Provider>
    </Providers>
  </SessionState>
</Telerik.Reporting>

Here the "BackendName" parameter specifies the name of the chosen backend, and the "ConnectionString" specifies the connection string to the database. The connection string can be specified either as a named connection, configured in the "connectionStrings" section of the configuration file, or directly as an inline connection string.

For applications that use the .NET Framework 2.0 the ADO.NET session state provider can be used instead. The following XML snippet demonstrates how to configure this provider:

CopyXML
<Telerik.Reporting>
  <SessionState provider="ADO.NET">
    <Providers>
      <Provider name="ADO.NET" type="Telerik.Reporting.Processing.Session.AdoNetSessionProvider, Telerik.Reporting, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be">
        <Parameters>
          <Parameter name="ProviderName" value="System.Data.SqlClient" />
          <Parameter name="ConnectionString" value="MyConnectionString" />
        </Parameters>
      </Provider>
    </Providers>
  </SessionState>
</Telerik.Reporting>

Here the "ProviderName" parameter specifies the ADO.NET provider, and the "ConnectionString" specifies the connection string to the database.

Binding Redirects

In case you use Telerik Open Access ORM version greater than the version available at the time of the Telerik Reporting release, you have to redirect all assemblies required by the Database Session Provider to their latest versions. To do this, add the following bindingRedirects to your app.config and replace the 2011.3.1129.2 with the exact version of Open Access ORM assemblies:

CopyXML
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="Telerik.OpenAccess" culture="neutral" publicKeyToken="7ce17eeaf1d59342"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2011.3.1129.2"/>
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Telerik.OpenAccess.35.Extensions" culture="neutral" publicKeyToken="7ce17eeaf1d59342"/>
        <bindingRedirect oldVersion="0.0.0.0-65535.65535.65535.65535" newVersion="2011.3.1129.2"/>
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
</configuration>

See Also

Other Resources

Configuring Session State
Configuring the File Session State Provider
Telerik Reporting Configuration Section


Solution Structure

[image]

Telerik Reporting Q2 2012
Solution Structure
Send Feedback

The most efficient way to structure your reporting solution is to first create a class library that contains your reports and then reference that class library in applications that view the reports. You can have any number of Windows or Web viewing applications that get re-use out of the same class library. This solution structure decouples your program logic from the report and its data.

In the example solution below "MyReportSolution" there are three projects.

  • "MyReportLib" is the class library that contains Telerik Reporting items. In this case the project contains only a single item "Report1.cs".
  • "MyWebApplication" is an ASP.NET application that displays the report. Notice the "MyReportLib" entry in the References for the project.
  • "MyWindowsApplication" is a Windows forms application that also references "MyReportLib".

Example solution


How do I display a PDF directly in the browser without exporting first?

[image]

Telerik Reporting Q2 2012
How do I display a PDF directly in the browser without exporting first?
Send Feedback

To create a PDF and open it directly within a webform, use the ReportProcessor object to create a stream of bytes and write those bytes to the ASP.NET Response object.

  1. In your web application, verify you have the following assemblies referenced and add them if you do not:
    • Telerik.Reporting
    • Telerik.Reporting.Processing
  2. Add the ExportToPDF() method (see code example below) to your application.
  3. Call the ExportToPDF() method. For example you might call this within a button click event handler for a "Run" button:
CopyC#
void ExportToPDF(Telerik.Reporting.Report reportToExport)
{
    ReportProcessor reportProcessor = new ReportProcessor();
    RenderingResult result = reportProcessor.RenderReport("PDF", reportToExport, null);

    string fileName = result.DocumentName + ".pdf";

    Response.Clear();
    Response.ContentType = result.MimeType;
    Response.Cache.SetCacheability(HttpCacheability.Private);
    Response.Expires = -1;
    Response.Buffer = true;

    Response.AddHeader("Content-Disposition",
                       string.Format("{0};FileName=\"{1}\"",
                                     "attachment",
                                     fileName));

    Response.BinaryWrite(result.DocumentBytes);
    Response.End();
}
//. . .
// Sample call to ExportToPDF()
ExportToPDF(new Report1());
CopyVB.NET
Sub ExportToPDF(ByVal reportToExport As Telerik.Reporting.Report)
    Dim reportProcessor As New ReportProcessor()
    Dim result As RenderingResult = reportProcessor.RenderReport("PDF", reportToExport, Nothing)

    Dim fileName As String = result.DocumentName + ".pdf"
    Response.Clear()
    Response.ContentType = result.MimeType
    Response.Cache.SetCacheability(HttpCacheability.Private)
    Response.Expires = -1
    Response.Buffer = True
    Response.AddHeader("Content-Disposition", String.Format("{0};FileName=""{1}""", "attachment", fileName))
    Response.BinaryWrite(result.DocumentBytes)
    Response.End()
End Sub
'. . .
' Sample call to ExportToPDF()
ExportToPDF(New Report1())


How do I display groups with different datasources and details sections?

[image]

Telerik Reporting Q2 2012
How do I display groups with different datasources and details sections?
Send Feedback

Usually grouping is used to group the data together by criteria. Instead, use SubReports to allow different sets of data within a single report. Using the SubReport ToolBox item you can embed several different reports in one report. Each report can use a different data source and you can arrange your “master” report to look exactly the same way as a report with groups. To use SubReport components:

  1. Create a "master" report that will act as a container for the other reports.
  2. Create reports that will be contained within the master report. Each report can have a different datasource and layout defined.
  3. Add SubReport items from the ToolBox to the "master" report detail section for each Report item created in step 2.
  4. Select the Report property from the drop down list for each SubReport.
  5. Rebuild the project.


How do I set 100% height to the Web Report Viewer

[image]

Telerik Reporting Q2 2012
How do I set 100% height to the Web Report Viewer
See Also Send Feedback

In order to have the Web ReportViewer display with 100% height, you need to specify height to the whole DOM tree:

CopyXML
<html xmlns="http://www.w3.org/1999/xhtml" id="html">
<head runat="server">
    <title>telerik Report Viewer</title>
    <style type="text/css">
    form#form1, div#content
    {
        height: 100%;
    }
    </style>
</head>
<body>
    <form id="form1" runat="server">
    <div id="content"><telerik:ReportViewer ID="ReportViewer1" runat="server" height="100%"/></div>
    </form>
</body>
</html>

In some cases you would need to remove the default doctype (or use a less restrictive one) in order to get this working (e.g. IE 6).

See Also

Other Resources

Web Report Viewer
Overview
How to: Add report viewer to a web page


What is the preferred report rendering extension for producing labels?

[image]

Telerik Reporting Q2 2012
What is the preferred report rendering extension for producing labels?
Send Feedback

To achieve the best results when producing labels, use the WinForms viewer. You can directly print the report from the viewer or, if you want to store the report for later use, you can export it to PDF or TIFF and print it later. The PDF and TIFF image formats are page-oriented formats. As a result, you can set properties to precisely control how pages will look when viewed in PDF or TIFF formats. That makes this formats more suitable for printing on paper.


How do I 'shrink' TextBoxes that have no data?

[image]

Telerik Reporting Q2 2012
How do I 'shrink' TextBoxes that have no data?
Send Feedback

Question: "I have three textboxes (a textbox on each "row" below each other) and have been testing the CanShrink property. Let's say the first textbox is empty but the other two are not, is it possible that the other two textboxes 'move up', the second textbox takes the first textbox place etc?"

Answer: Yes. The following shows how CanShrink and CanGrow properties change the display of a report.

The figure below shows TextBox items for Name and Summary fields, the detail section is surrounded by a dotted line. The Name and Summary TextBox items are surrounded by a solid line. This topic will show the report display when setting and unsetting the CanShrink and CanGrow properties.

CanShrink and CanGrow properties for both Name and Summary are set to false. Both TextBox items stay at the same dimensions as designed even though the Name TextBox has less data than needed and Summary has more text than needed to fill the area.

CanShrink and CanGrow set to false

The CanShrink property for the Name TextBox is set to true and the CanGrow property for the Summary TextBox is set to true. Here you can see that the Name and Summary TextBoxes are sized to fit the data exactly.

CanGrow and CanShrink set true

In this last example the TextBoxes are arranged vertically into a single column, with the Name TextBox appearing twice. The layout is roughly:

Name

Name

Summary

The data for the first row Name field is blanked out. The output with CanShrink true for Name and CanGrow true for Summary shows the the Name property TextBox has shrunk and the Summary information takes its place:

CanShrink and CanGrow true with fields arranged vertically


Does Telerik Reporting support XML as a datasource?

[image]

Telerik Reporting Q2 2012
Does Telerik Reporting support XML as a datasource?
Send Feedback

You have a couple of options:

  1. (recommended) Create a typed DataSet from your XML. Once you have the DataSet ready, use the ObjectDataSource Component and it will appear in the list of the available data sources; select it and follow the instructions of the wizard. For more information on typed DataSets please see here. For more information on binding to DataSet, see How to: Bind to a DataSet.
  2. Load the XML into a DataSet programmatically. Use the DataSet.ReadXml method to load the XML data into a DataSet and then pass it to the Report.DataSource property. The disadvantage of this approach is that the schema of the report's data source won't be available at the design time. This means that the Report Wizard won't be of any help. Anyway you still can create a report without it. You can use the Visual Studio Toolbox to select from the available items. For more information please see Designing Reports.


Change row color based on a value in the row

[image]

Telerik Reporting Q2 2012
Change row color based on a value in the row
Send Feedback

You can change row color, or any other styling characteristic, using conditional formatting.

  1. Select the detail section of your report.
  2. Select the ConditionalFormatting property of the detail section.
  3. Click the New Rule button.
  4. Enter a condition that should be true for the row to change color. In the example below the Expression is "=Fields.FinishedGoodsFlag", Operator is equal "=" and Value is "True".
  5. Click the Style button.
  6. Click the Background style item.
  7. Choose a background color from the drop down list or ellipses color selector. Change any other style characteristics you choose.
  8. Click OK to close each of the open dialogs.


Display Reports with alternating style rows

[image]

Telerik Reporting Q2 2012
Display Reports with alternating style rows
Send Feedback

Many production level reports use an alternating row style as an aid to readability. This technique is used in the ProductCatalog sample report.

This look can be achieved with conditional formatting by setting up a rule that fires on every other line.

  1. Select the detail section of your report.
  2. Select the ConditionalFormatting property of the detail section.
  3. Click the New Rule button.
  4. Enter the expression "= RowNumber()%2"
  5. Select the equal "=" operator from the drop down list.
  6. Enter the value as "=1".
  7. Click the Style button.
  8. Click the Background style item.
  9. Enter the color as "#F0F0F0".
  10. Click OK to close each of the open dialogs.


Access items from report, calling application and Table

[image]

Telerik Reporting Q2 2012
Access items from report, calling application and Table
Send Feedback

In the examples below we show how to access a report item from within the report and from the invoking application. In the first example let's access a TextBox item from the detail section ItemDataBinding eventhandler.

Access Report Items from within events

  1. Select the detail section in the designer, and in the Properties Window, Events tab, find the ItemDataBinding entry and double-click.

  2. The event handler passes in "sender" which is a Telerik.Reporting.Processing.DetailSection that represents the section during processing. Thus you can derive:

    • A DataObject that represents the underlying data for a record being processed.
    • All processing report items.
  3. Use the ElementTreeHelper.GetChildByName method to locate an item on the report. In the code example below GetChildByName is used to retrieve "textBox1" TextBox.
Note

In the code example below we are referring to a Processing.TextBox, not Report1.TextBox. The Processing.TextBox represents the TextBox during processing and has a different set of properties than the Report1.TextBox used when defining the report.

Example

CopyC#
private void detail_ItemDataBinding(object sender, EventArgs e)
{
    Telerik.Reporting.Processing.DetailSection section = (sender as Telerik.Reporting.Processing.DetailSection);
    Telerik.Reporting.Processing.TextBox txt = (Telerik.Reporting.Processing.TextBox)Telerik.Reporting.Processing.ElementTreeHelper.GetChildByName(section, "textBox1");
    object title = section.DataObject["Title"];
    if ((string)title == "Developer")
    {
        txt.Style.BackgroundColor = System.Drawing.Color.Blue;
    }
}
CopyVB.NET
Private Sub detail_ItemDataBinding(sender As Object, e As EventArgs)
    Dim section As Telerik.Reporting.Processing.DetailSection = TryCast(sender, Telerik.Reporting.Processing.DetailSection)
    Dim txt As Telerik.Reporting.Processing.TextBox = DirectCast(Telerik.Reporting.Processing.ElementTreeHelper.GetChildByName(section, "textBox1"), Telerik.Reporting.Processing.TextBox)
    Dim title As Object = section.DataObject("Title")
    If DirectCast(title, String) = "Developer" Then
        txt.Style.BackgroundColor = System.Drawing.Color.Blue
    End If
End Sub

Access items from calling application

If we are in the context of a web/win form and we need to access an item from the Report that is shown in a ReportViewer control, we can proceed directly following the report hierarchy e.g.:

CopyC#
protected void Button1_Click(object sender, EventArgs e)
{
    Telerik.Reporting.Report report = (Telerik.Reporting.Report)this.ReportViewer1.Report;
    Telerik.Reporting.TextBox txt = report.Items.Find("productNameDataTextBox", true)[0] as Telerik.Reporting.TextBox;
}
CopyVB.NET
Protected Sub Button1_Click(sender As Object, e As EventArgs)
     Dim report As Telerik.Reporting.Report = DirectCast(Me.ReportViewer1.Report, Telerik.Reporting.Report)
     Dim txt As Telerik.Reporting.TextBox = TryCast(report.Items.Find("productNameDataTextBox", True)(0), Telerik.Reporting.TextBox)
End Sub

Access report fields from a Table item

You can reference the report fields from a table item easily using the Report API hierarchy. Consider the following code:

CopyC#
private void tableTextBox_ItemDataBinding(object sender, EventArgs eventArgs)
{
    //get the textbox from the sender object
    Telerik.Reporting.Processing.TextBox textBox = (Telerik.Reporting.Processing.TextBox)sender;
    //get the table object
    Telerik.Reporting.Processing.Table table = (Telerik.Reporting.Processing.Table)textBox.Parent;
    //get the detail section
    Telerik.Reporting.Processing.DetailSection detail = (Telerik.Reporting.Processing.DetailSection)table.Parent;
    //get the raw value from the Report datasource directly
    textBox.Value = detail.DataObject["Data"];
}
CopyVB.NET
Private Sub tableTextBox_ItemDataBinding(sender As Object, eventArgs As EventArgs)
    'get the textbox from the sender object
    Dim textBox As Telerik.Reporting.Processing.TextBox = DirectCast(sender, Telerik.Reporting.Processing.TextBox)
    'get the table object
    Dim table As Telerik.Reporting.Processing.Table = DirectCast(textBox.Parent, Telerik.Reporting.Processing.Table)
    'get the detail section
    Dim detail As Telerik.Reporting.Processing.DetailSection = DirectCast(table.Parent, Telerik.Reporting.Processing.DetailSection)
    'get the raw value from the Report datasource directly
    textBox.Value = detail.DataObject("Data")
End Sub


Why does the page header appear before the report header?

[image]

Telerik Reporting Q2 2012
Why does the page header appear before the report header?
Send Feedback

A report can be viewed as "document content", consisting of detail, report header and footer sections. Similar to Word, document content is centered on the screen with page header and footer sections above and below the content. Page headers and footers are not related to the report itself, but are relative to the margins of the report's media, i.e. to the paper or screen and contain page numbers, document dates, etc.


How to print report on client machine without showing the report

[image]

Telerik Reporting Q2 2012
How to print report on client machine without showing the report
Send Feedback

By default the Adobe Plugin is used when printing (if available) and the user has the option to select the printer he would like to use when print is initiated. However there is no way to know the default or in fact any of the available client printers as this would be a major security vulnerability. That is why the print dialog would be always shown, so that the user can select the desired printer and then click the Print button.

On the client side you can invoke the print through the ReportViewer client object's PrintReport() method like in the code snipped below:

CopyXML
<asp:Button ID="PrintButton" runat="server" Text="Print Report" OnClientClick="MyPrint(); return false;" />
<telerik:ReportViewer ID="ReportViewer1" runat="server" style="display:none" />
<script type="text/javascript">
    ReportViewer.OnReportLoadedOld = ReportViewer.OnReportLoaded;
    ReportViewer.prototype.OnReportLoaded = function()
    {
        this.OnReportLoadedOld();
        var printButton = document.getElementById("PrintButton");
        printButton.disabled = false;
    }
    function MyPrint()
    {
        <%=ReportViewer1.ClientID %>.PrintReport();
    }
</script>

Note that we disable the print button until the report has not loaded in the viewer. Once it is loaded we can print it from our Print Report button.

In order to perform other actions on click of the print button (e.g. print using the browser printing capabilities), you'll have to override the default PrintReport() function:

CopyXML
<script type="text/javascript">
    ReportViewer.prototype.PrintReport = function()
    {
        this.PrintAs("Default");
    }
</script>


Hide the print progress dialog when printing a report programmatically

[image]

Telerik Reporting Q2 2012
Hide the print progress dialog when printing a report programmatically
See Also Send Feedback

To prevent the print UI from appearing, you should specify valid printer settings and a standard print controller to this method. This example illustrates how to prevent the print UI from appearing in a batch print operation or when printing from a service.

CopyC#
Telerik.Reporting.IReportDocument myReport = new MyReport();

// Obtain the settings of the default printer
System.Drawing.Printing.PrinterSettings printerSettings
    = new System.Drawing.Printing.PrinterSettings();

// The standard print controller comes with no UI
System.Drawing.Printing.PrintController standardPrintController =
    new System.Drawing.Printing.StandardPrintController();

// Print the report using the custom print controller
Telerik.Reporting.Processing.ReportProcessor reportProcessor
    = new Telerik.Reporting.Processing.ReportProcessor();

reportProcessor.PrintController = standardPrintController;

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

instanceReportSource.ReportDocument = myReport;

reportProcessor.PrintReport(instanceReportSource, printerSettings);
CopyVB.NET
Dim report1 As New MyReport

' Obtain the settings of the default printer
Dim printerSettings As New System.Drawing.Printing.PrinterSettings

' The standard print controller comes with no UI
Dim standardPrintController As New System.Drawing.Printing.StandardPrintController

' Create an instance report source to pass the report to the report processor
Dim instanceReportSource as new Telerik.Reporting.InstanceReportSource()
instanceReportSource.ReportDocument = report1

' Print the report using the custom print controller
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor
reportProcessor.PrintController = standardPrintController
reportProcessor.PrintReport(instanceReportSource, printerSettings)

See Also

Reference

ReportProcessor..::.PrintController
ReportProcessorPrintReport(IReportDocument, PrinterSettings)
System.Drawing.Printing..::.PrintController
System.Drawing.Printing..::.StandardPrintController


Converting reports from other reporting solutions
Send Feedback

Converting reports from other reporting solutions

Telerik Reporting is currently able to convert reports from:

  • Crystal Reports - requires build 10.2.3600.0 or later
  • Active Reports - requires build 5.2.1013.2 or later
  • XtraReports - requires build 8.1.6.0
Caution

The converters are just a helper utility we did out of good will to save some time. They do not guarantee a one-to-one complete conversion and are provided as is. Please have in mind that there are some parts (items/sections) that have no analog on our end and vice versa, thus you would need to review and fix the converted reports manually.

The conversion depends on the 3rd party products' object model to create Telerik Reports and often there are additional adjustments that need to be carried out by the developer. Parsing the code is far more complicated since you may use any .NET programming language which makes the task almost impossible, and that is why only the report definition is inspected and all events and custom logic is skipped i.e. it should be added manually by the developer. The same goes for parts that have no counterpart on our end.

The converters are compiled against the 3rd party product version specified above. If you have upgraded to a newer version of Crystal or Active Reports, you will need to add an assembly binding redirect statement to your Visual Studio configuration file. More info on this process is available in the following articles:

  • Converting reports from various versions of CrystalReports
  • Converting reports from various versions of ActiveReports

Converting from XtraReports does not require any additional steps. It is built against the version described in the right-hand panel of the information panel of the "Report Choice Page" of the "Report Wizard".


Troubleshooting

[image]

Telerik Reporting Q2 2012
Troubleshooting
Send Feedback

This section lists Troubleshooting tips for Telerik Reporting:

  • Installation Problems
  • Design Time Problems
  • Run Time Problems


Installation Problems

[image]

Telerik Reporting Q2 2012
Installation Problems
Send Feedback

Make sure to run the installer as administrator (or from admin account) to avoid rights elevation problems. When the Telerik Reporting installer fails for some reason, the way to determine what has caused problem is to generate an installer log. Here are the steps to generate this log file:

  1. Bring up a command prompt window: Click Start, in the prompt type cmd and press Enter.

  2. Navigate to the folder where the Telerik Reporting installer is saved.

  3. Input the following command: msiexec /i Telerik_Reporting.msi -l*xv install.log and press Enter.

    Note

    In the above example, replace install.log with the directory path and filename you want the log saved to/as.

  4. After you generate the file, archive it and attach it to a support ticket with information about the problem.


Design Time Problems

[image]

Telerik Reporting Q2 2012
Design Time Problems
Send Feedback

I want to show my report in a ReportViewer control, but when I click on the arrow in the Report property from the property grid, it does not show available reports - what is wrong?

Make sure that to follow our best practices and have the report in a separate code library that is referenced in the web app/site. Check if the class library containing the report is referenced in your app/site and that you have rebuilt your app/site.

The most reliable way to specify a report for the ReportViewer is to do this programmatically on the Page_Load event of the page. For example:

CopyC#
Page_Load(object sender, System.EventArgs e)
{
    if (!Page.IsPostBack)
    {
        this.ReportViewer1.Report = new ReportLibrary.Report1();
    }
}
CopyVB.NET
    Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
        If Not Page.IsPostBack Then
            Me.ReportViewer1.Report = New ReportLibrary.Report1()
        End If
    End Sub

A multi-column report shows fine when using Preview, but when used as a subreport, it shows as a one-column report only

The multi-column functionality is intended to be used only in the main report because all report sections (excluding Page sections) are rendered in a column-wise layout, thus the report can be wide only one column.


Run Time Problems

[image]

Telerik Reporting Q2 2012
Run Time Problems
Send Feedback

Cannot create an object of type 'Telerik.Reporting.Report' from its string representation 'MyNameSpace.MyClass, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' for the 'Report' property.

This error might occur if you are using website and you have the report class in the website directly. This is due to the fact that when using website, after rebuild the following would always be different and it does not match with the originally assigned report: App_Code.unch8s_n. That is why we recommend following our best practices and have the report in a separate class library that is referenced in the web app/site.

Unable to serialize the session state. In 'StateServer' and 'SQLServer' mode, ASP.NET will serialize the session state objects, and as a result non-serializable objects or MarshalByRef objects are not permitted. The same restriction applies if similar serialization is done by the custom session state store in 'Custom' mode.

This exception might surface if you try to use objects which do not implement ISerializable for Report Datasource. For example if this is IList, you can try using List instead as we show in our cars example. You can also use the NeedDataSource event of the report and assign the datasource to the "processing report", thus avoiding any need for serialization/deserialization. Another approach is to move on to DataSet or DataTable:

CopyC#
DataTable dt = new DataTable();
DataColumn col = new DataColumn("ColumnName", typeof(string));
//....
dt.Columns.Add(col);
foreach (object Item in MyIList)
{
    DataRow row = dt.NewRow();
    row["ColumnName"] = Item;
    //.....
    dt.Rows.Add(row);
}

When deploying a project with Telerik Reporting on a server, you get the following error: Could not load file or assembly 'Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be' or one of its dependencies. The system cannot find the file specified.

During the installation of Telerik Reporting on dev machine, Telerik assemblies are added to GAC. When deploying a project using Visual Studio's built-in functionality, the assemblies from the GAC are not copied automatically, so you need to make sure the assemblies physically exist in the bin folder of your applicatio. Full details are available in the Deploying Applications using Telerik Reporting section.

The expression contains undefined function call MyUserFunction()

There are three cases in which this error message occurs:

  • The function is typed in manually without rebuilding the class library, thus it does not yet exist.
  • Using the function with wrong number/type of parameters. The passed fields must match the function signature you've defined originally.
  • The field specified in the function is null. Make sure such cases are handled in the user function.

My Web ReportViewer looks messed up - its styles and images are missing

  1. Check if runat="server" is present in your web page's head tag.

  2. Check if the web report viewer's http handler is registered in the web.config file. If the app is deployed on IIS7 and setup to work in integrated mode, make sure preCondition attribute is present at the end of Telerik.ReportViewer handler:

    CopyXML
    <add
    name="Telerik.ReportViewer.axd_*"
    type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=x.x.x.x, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"
    path="Telerik.ReportViewer.axd" verb="*"
    preCondition="integratedMode"
/>
  3. Check if the web report viewer's styles are registered on the page. This can be accomplished with http debugging proxy like Fiddler.
  4. If above steps are correct and problem persists, check for defined global styles on page that might mess up the viewer's styles. Remove any style declarations from page to make sure this is the culprit. If proves so, make sure global styles do not affect html elements directly, but are applied through the CssClass property.


For More Help

[image]

Telerik Reporting Q2 2012
For More Help
Send Feedback

This section discusses how to optimize your support resource searches:

  • Support inquiry
  • Knowledge Base Article
  • Forums
  • Blogs


Knowledge Base

[image]

Telerik Reporting Q2 2012
Knowledge Base
Send Feedback

The Telerik Knowledge Base, lets you browse and search articles for a solution to your problem.


Forums

[image]

Telerik Reporting Q2 2012
Forums
Send Feedback

The Telerik Product Forums, http://www.telerik.com/community/forums.aspx, provide a place where you can communicate and consult with other people who use Telerik products.


Blogs

[image]

Telerik Reporting Q2 2012
Blogs
Send Feedback

The Telerik Reporting product Blogs, http://blogs.telerik.com/telerikreportingteam/posts.aspx provide a place where you can find tips and tricks straight out from the guys developing the product:


About the Samples

[image]

Telerik Reporting Q2 2012
About the Samples
Send Feedback

Telerik Reporting Demos provide a set of pre-built samples designed to demonstrate the breadth of capabilities of the Telerik Reporting package.

To launch the demos, select from the Start menu Telerik | Reporting | Run Demos. This would load the online examples in your browser. Use the tree on the left to navigate between the sample reports. The live demos use the ASP.NET and Silverlight report viewers and come with short video showing how they are created.

You can also open the sample projects (C# or Visual Basic) in Visual Studio to see the full design and source code for each of the sample reports. To open up the sample solutions go to the Start menu and select Telerik | Reporting | Visual Studio Examples | C#/VB.NET Solution. The Visual Studio examples contain applications for all supported platforms (ASP.NET, Windows Forms, WPF and Silverlight).


Redistributing

[image]

Telerik Reporting Q2 2012
Redistributing
Send Feedback

Your purchase of Telerik Reporting includes a run time royalty-free license to redistribute the reports in your own solutions. You can freely use and redistribute any reports that you build in your own solutions, and your end users are not required to purchase their own licenses for the reports. Some potential uses of the reports require further discussion with our sales team.

Examples of Permitted Uses

  • Applications for internal company use.
  • Commercial applications deployed for end users by Telerik customers.
  • Shrink-wrapped software in which the Telerik reports are integrated.

Examples of Uses that Require Discussion

  • Products that expose the design-time functionality of the Telerik reports.
  • Products that do not add significant functionality to the Telerik reports.
  • Open source products.

For further details, please refer to the license agreement or send e-mail to sales@Telerik.com to discuss your planned use of the controls.


Licensing

[image]

Telerik Reporting Q2 2012
Licensing
Send Feedback


Copyrights and Trademarks

[image]

Telerik Reporting Q2 2012
Copyrights and Trademarks
Send Feedback

Telerik Reporting is a trademark of Telerik Corp.

.NET, Visual Basic, and Visual C# are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

Adobe and Adobe Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.


Reporting API Reference

[image]

Telerik Reporting Q2 2012
Reporting API Reference
Send Feedback

Namespaces

Namespace | Description
Telerik.Reporting |
Telerik.Reporting.Charting |
Telerik.Reporting.Charting.Styles |
Telerik.Reporting.Data |
Telerik.Reporting.Drawing |
Telerik.Reporting.Drawing.Shapes |
Telerik.Reporting.Expressions |
Telerik.Reporting.Interfaces |
Telerik.Reporting.Interfaces.Attributes |
Telerik.Reporting.Paging.InteractiveLayout |
Telerik.Reporting.Processing |
Telerik.Reporting.Processing.Config |
Telerik.Reporting.Processing.Session |
Telerik.Reporting.Service |
Telerik.Reporting.Service.SilverlightClient |
Telerik.Reporting.XmlSerialization |
Telerik.ReportViewer.Common |
Telerik.ReportViewer.Silverlight |
Telerik.ReportViewer.WebForms |
Telerik.ReportViewer.WinForms |
Telerik.ReportViewer.Wpf |


Telerik.Reporting Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting Namespace
Send Feedback

Classes

Class | Description
Barcode | Represents a barcode report item.
Binding | Represents the simple binding between the target property of a report item and an expression.
BindingCollection | Represents a collection of Bindings.
CalculatedField | Represents an user-defined field in a DataSource.
CalculatedFieldCollection | Represents a collection of CalculatedFields.
Chart | Represents a chart report item
CheckBox | Represents a check box report item.
Crosstab | The Crosstab report item displays aggregated data summaries, grouped in rows and columns.
CubeDataSource | Represents an OLAP cube to data items.
CubeDataSourceParameter | Represents a parameter in a CubeDataSource component.
CubeDataSourceParameterCollection | Represents a collection of CubeDataSourceParameter objects.
DataFieldMapping | Represents a mapping between a field from a data source and its corresponding short alias used for data binding in expressions.
DataFieldMappingCollection | Represents a collection of DataFieldMapping objects.
DataSource |
DataSourceParameter | Represents a parameter in a DataSource component.
DetailSection | Represents the main section of a Report. It is printed once for every record in the data source of the report.
EntityDataSource | Represents an Entity data model to data items.
ErrorEventArgs | Provides a data for the Error event of a Report.
Filter |
FilterCollection |
Group | Represents a class that defines a report group.
GroupCollection |
GroupFooterSection | Represents a group footer section. Group footers are displayed at the end of a group. Group headers and footers are unified by the Group class.
GroupHeaderSection | Represents a group header section. Group headers are displayed at the beginning of a group. Group headers and footers are unified by the Group class.
Grouping |
GroupingCollection |
GroupSection | Base abstract class for group sections. GroupHeaderSection and GroupFooterSection inherit from this class.
HtmlTextBox | Represents a html text box report item.
InstanceReportSource | Represents a report source that contains a reference to an instance of IReportDocument.
ItemEventArgs | Provides data for the ItemAdded()()() and ItemRemoved()()() events.
List | The list report item represents a free-form layout.
NavigateToBookmarkAction | Represent an interactive action that navigates the report viewer to a predefined bookmark in the same report.
NavigateToReportAction | Represent an interactive action that navigates the report viewer to another report.
NavigateToUrlAction | Represent an interactive action that opens an Url.
ObjectDataSource | Represents a business object to data items.
ObjectDataSourceBase |
ObjectDataSourceParameter | Represents a parameter in an ObjectDataSource component.
ObjectDataSourceParameterCollection | Represents a collection of ObjectDataSourceParameter objects.
OpenAccessDataSource | Represents an Open Access data model to data items.
PageEventArgs | Provides data for the [!:Telerik.Reporting.Report.BeginRenderPage] and [!:Telerik.Reporting.Report.EndRenderPage] events.
PageFooterSection | Represents a page footer section. Page footers are displayed at the end of a page.
PageHeaderSection | Represents a page header section. Page headers are displayed at the beginning of a page.
PageSection | Base abstract class for group sections. PageHeaderSection and PageFooterSection inherit from this class.
Panel | Provides a grouping mechanism for organizing report items.
Parameter | Represents a parameter of nested report (subreport)
ParameterCollection | Represents a collection of Parameter objects.
PictureBox | Represents a picture box report item for displaying an image.
Report | Represents the base class for any report in the Telerik Reporting.
ReportBook | Represents a collection of reports logically unified as a single document.
ReportCollection | Represents a collection of Report objects.
ReportFooterSection | Represents a report footer section. Report footer is displayed at the end of a report, but before the last PageFooterSection if any.
ReportHeaderSection | Represents a report header section. Report header is displayed at the beginning of a report, but after the first PageHeaderSection if any.
ReportItem | Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.
ReportItemBase | Defines the base class for visual report items used for creating reports.
ReportItemBase..::.ItemCollection | Represents a collection of ReportItemBase objects.
ReportObject | Represents a base class for all Telerik Reporting objects
ReportParameter | Represents a report parameter.
ReportParameterAvailableValues | Represents the available values for a ReportParameter
ReportParameterCollection | Represents a collection of ReportParameter objects.
ReportParameterCollectionBase<(Of <(TReportParameter>)>) | Represents a base class for collection of IReportParameter objects.
ReportParameterUISettings | Obsolete.
ReportSection | Base abstract class for all report sections contained in the report body. Inherited by DetailSection, GroupSection, ReportHeaderSection, ReportFooterSection,
ReportSectionBase | Defines the base class for report sections.
ReportSource | Provides the base class for a report source. This is an abstract class that contains only a collection of parameter values that are passed to the IReportDocument object when its instance is initialized.
Shape | Represents a shape report item.
Sorting |
SortingCollection |
SqlDataSource | Represents an SQL database to data items.
SqlDataSourceParameter | Represents a parameter in a SqlDataSource component.
SqlDataSourceParameterCollection | Represents a collection of SqlDataSourceParameter objects.
SubReport | Represents a report item used to embed another report into the current report.
Table | The table report item displays detail data, data organized in row groups, or both.
TableBody | Represents the Body of the Table item
TableBody..::.ColumnCollection | Represents a collection of TableBodyColumn
TableBody..::.RowCollection | Represents a collection of TableBodyRows
TableBodyColumn | Represents a column in the Table's Body
TableBodyRow | Represents a row in the Table's Body
TableCell |
TableCellContainer |
TableGroup |
TextBox | Represents a text box report item.
TextItemBase | Represents a Text Item - a base class for report items like TextBox and CheckBox.
ToggleVisibilityAction | Represents an interactive action that toggles the visibility of one or more items / groups.
ToggleVisivilityTargetCollection | Represents a collection of IToggleVisibilityTarget objects.
TypeReportSource | Represents a report source that allows a report document to be instantiated from an AssemblyQualifiedName.
UriReportSource | Represents a report source that loads a report document from a URI.
XmlReportSource | Represents a report source that contains the XML markup of a report document.

Interfaces

Interface | Description
IAction | Represents an interactive action associated with a report item.
IExtension | Telerik Reporting extension
IReportDocument | Represents a report document.
IReportParameter | Represents a report parameter.
IToggleVisibilityTarget | Represents a report object which may be used as target of a ToggleVisibilityAction.

Delegates

Delegate | Description
ErrorEventHandler |
ItemEventHandler | Handles the events that occur when items are being added to or removed from an items collection.
PageEventHandler | Handles the events that occur when a page rendering begins or ends.

Enumerations

Enumeration | Description
AnchoringStyles | Specifies how a ReportItem anchors to the edges of its container.
Barcode..::.SymbologyType |
DockingStyle | Specifies how a ReportItem docks to the edges of its container.
FilterOperator |
GroupKeepTogether | GroupKeepTogether applies to a group and has similar to the KeepTogether meaning, but for the whole group. It indicates whether the rendering engine should try to render the whole group on a single page, the group header plus the first detail on a single page, or leave the group flow as it is. If GroupKeepTogether is set to FirstDetail -- the group header and at least one detail in this group should be on the same page; if set to All -- the whole group should be on a single page. The following rule applies: the rendering engine will try to render the group as specified, but if there is not enough space on the current page, the group is moved to the next page and it continues as long as it needs.
PageBreak | Specifies where to make a page break, with respect to a ReportSection.
PageNumberingStyle | Specifies the page numbering style of a report. Has meaning and effect only when the report is part of a report book.
ReportParameterType |
SortDirection |
SqlDataSourceCommandType | Specifies how a command string is interpreted.
UrlTarget | Represents NavigateToUrlAction target types.


AnchoringStyles Enumeration

[image]

Telerik Reporting Q2 2012
AnchoringStyles Enumeration
See Also Send Feedback
Specifies how a ReportItem anchors to the edges of its container.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[FlagsAttribute]
public enum AnchoringStyles
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration AnchoringStyles

Members

Member name | Description
None | The ReportItem is not anchored to any edge of its container.
Top | The ReportItem is anchored to the top edge of its container.
Bottom | The ReportItem is anchored to the bottom edge of its container.
Left | The ReportItem is anchored to the left edge of its container.
Right | The ReportItem is anchored to the right edge of its container.

See Also

Telerik.Reporting Namespace


Barcode Class

[image]

Telerik Reporting Q2 2012
Barcode Class
Members See Also Send Feedback
Represents a barcode report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Barcode : ReportItem
Visual Basic (Declaration)
Public Class Barcode _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Barcode

See Also

Barcode Members
Telerik.Reporting Namespace


Barcode Members

[image] [image]

Telerik Reporting Q2 2012
Barcode Members
Barcode Class Constructors Methods Properties Events See Also Send Feedback

The Barcode type exposes the following members.

Constructors

Name | Description
Barcode | Initializes a new instance of the Barcode class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.
BarAlign | Gets or sets the horizontal alignment of the barcode in the report item.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
Checksum | Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Module | Gets or sets a Unit representing the width of of the narrowest bar of the barcode.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
ShowText | Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Stretch | Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Symbology | Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current value to be encoded in the barcode.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Barcode Class
Telerik.Reporting Namespace


Barcode Constructor

[image]

Telerik Reporting Q2 2012
Barcode Constructor
Barcode Class See Also Send Feedback
Initializes a new instance of the Barcode class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Barcode()
Visual Basic (Declaration)
Public Sub New

See Also

Barcode Class
Telerik.Reporting Namespace


Barcode Methods

[image] [image]

Telerik Reporting Q2 2012
Barcode Methods
Barcode Class See Also Send Feedback

The Barcode type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

Barcode Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Barcode..::.Dispose Method
Barcode Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Barcode Class
Barcode Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Barcode..::.ToString Method
Barcode Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Barcode Class
Barcode Members
Telerik.Reporting Namespace


Barcode Properties

[image] [image]

Telerik Reporting Q2 2012
Barcode Properties
Barcode Class See Also Send Feedback

The Barcode type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.
BarAlign | Gets or sets the horizontal alignment of the barcode in the report item.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
Checksum | Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Module | Gets or sets a Unit representing the width of of the narrowest bar of the barcode.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
ShowText | Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Stretch | Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Symbology | Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current value to be encoded in the barcode.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Barcode Class
Telerik.Reporting Namespace


Angle Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Angle Property
Barcode Class See Also Send Feedback
Gets or sets a value indicating the angle of rotation of the bar code inside the report item, specified in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double

Field Value

A double value indicating the angle of rotation in degrees.

See Also

Barcode Class
Telerik.Reporting Namespace


BarAlign Property

[image]

Telerik Reporting Q2 2012
Barcode..::.BarAlign Property
Barcode Class See Also Send Feedback
Gets or sets the horizontal alignment of the barcode in the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public HorizontalAlign BarAlign { get; set; }
Visual Basic (Declaration)
Public Property BarAlign As HorizontalAlign

Field Value

One of the HorizontalAlign values. The default value is HorizontalAlign.Center.

See Also

Barcode Class
Telerik.Reporting Namespace


Checksum Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Checksum Property
Barcode Class See Also Send Feedback
Gets or sets a value indicating whether the barcode should contain a checksum for validation purposes during the scanning process or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Checksum { get; set; }
Visual Basic (Declaration)
Public Property Checksum As Boolean

Field Value

true if the barcode should contain a checksum for validation purposes during the scanning process, otherwise false.

See Also

Barcode Class
Telerik.Reporting Namespace


Module Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Module Property
Barcode Class See Also Send Feedback
Gets or sets a Unit representing the width of of the narrowest bar of the barcode.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Module { get; set; }
Visual Basic (Declaration)
Public Property Module As Unit

Field Value

A Unit value representing the width of the narrowest bar of the barcode.

See Also

Barcode Class
Telerik.Reporting Namespace


ShowText Property

[image]

Telerik Reporting Q2 2012
Barcode..::.ShowText Property
Barcode Class See Also Send Feedback
Gets or sets a value indicating whether the barcode should display a human-readable text representation of the encoded value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ShowText { get; set; }
Visual Basic (Declaration)
Public Property ShowText As Boolean

Field Value

true if the barcode should display text, otherwise false.

See Also

Barcode Class
Telerik.Reporting Namespace


Stretch Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Stretch Property
Barcode Class See Also Send Feedback
Gets or sets a value indicating whether to stretch the barcode to fill the entire area of the report item item or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Stretch { get; set; }
Visual Basic (Declaration)
Public Property Stretch As Boolean

Field Value

true if the barcode should be stretched, otherwise false.

See Also

Barcode Class
Telerik.Reporting Namespace


Symbology Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Symbology Property
Barcode Class See Also Send Feedback
Gets or sets a value indicating the current symbology used to encode the Value property as series of bars and spaces.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Barcode..::.SymbologyType Symbology { get; set; }
Visual Basic (Declaration)
Public Property Symbology As Barcode..::.SymbologyType

Field Value

A Barcode..::.SymbologyType enumerated value indicating the symbology associated with the current barcode.

See Also

Barcode Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Value Property
Barcode Class See Also Send Feedback
Gets or sets the current value to be encoded in the barcode.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String

Field Value

A String that starts with the symbol "=" is interpreted as an expression to calculate the value of the current barcode, otherwise the value is interpreted as a literal string.

See Also

Barcode Class
Telerik.Reporting Namespace


Barcode Events

[image] [image]

Telerik Reporting Q2 2012
Barcode Events
Barcode Class See Also Send Feedback

The Barcode type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Barcode Class
Telerik.Reporting Namespace


Barcode.SymbologyType Enumeration

[image]

Telerik Reporting Q2 2012
Barcode..::..SymbologyType Enumeration
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum SymbologyType
Visual Basic (Declaration)
Public Enumeration SymbologyType

Members

Member name | Description
Codabar |
Code11 |
Code25Standard |
Code25Interleaved |
Code39 |
Code39Extended |
Code93 |
Code93Extended |
Code128 |
Code128A |
Code128B |
Code128C |
CodeMSI |
EAN8 |
EAN13 |
EAN128 |
EAN128A |
EAN128B |
EAN128C |
Postnet |
UPCA |
UPCE |
UPCSupplement2 |
UPCSupplement5 |

See Also

Telerik.Reporting Namespace


Binding Class

[image]

Telerik Reporting Q2 2012
Binding Class
Members See Also Send Feedback
Represents the simple binding between the target property of a report item and an expression.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class Binding : INotifyPropertyChanged
Visual Basic (Declaration)
Public NotInheritable Class Binding _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Binding

See Also

Binding Members
Telerik.Reporting Namespace


Binding Members

[image] [image]

Telerik Reporting Q2 2012
Binding Members
Binding Class Constructors Properties Events See Also Send Feedback

The Binding type exposes the following members.

Constructors

Name | Description
Binding | Overloaded.

Properties

Name | Description
Expression | Gets or sets the expression used to evaluate the value of the specified in Path target property.
Path | Gets or sets the property path determining the item's bound simple/nested property.

Events

Name | Description
PropertyChanged |

See Also

Binding Class
Telerik.Reporting Namespace


Binding Constructor

[image] [image]

Telerik Reporting Q2 2012
Binding Constructor
Binding Class See Also Send Feedback

Overload List

Name | Description
Binding()()() | Initializes a new instance of the Binding class
Binding(String, String) | Initializes a new instance of the Binding class

See Also

Binding Class
Binding Members
Telerik.Reporting Namespace


Binding Constructor

[image]

Telerik Reporting Q2 2012
Binding Constructor
Binding Class See Also Send Feedback
Initializes a new instance of the Binding class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Binding()
Visual Basic (Declaration)
Public Sub New

See Also

Binding Class
Binding Overload
Telerik.Reporting Namespace


Binding Constructor (String, String)

[image]

Telerik Reporting Q2 2012
Binding Constructor (String, String)
Binding Class See Also Send Feedback
Initializes a new instance of the Binding class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Binding(
    string path,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    path As String, _
    expression As String _
)

Parameters

path
Type: System..::.String
expression
Type: System..::.String

See Also

Binding Class
Binding Overload
Telerik.Reporting Namespace


Binding Properties

[image] [image]

Telerik Reporting Q2 2012
Binding Properties
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Properties

Name | Description
Expression | Gets or sets the expression used to evaluate the value of the specified in Path target property.
Path | Gets or sets the property path determining the item's bound simple/nested property.

See Also

Binding Class
Telerik.Reporting Namespace


Expression Property

[image]

Telerik Reporting Q2 2012
Binding..::.Expression Property
Binding Class See Also Send Feedback
Gets or sets the expression used to evaluate the value of the specified in Path target property.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

Binding Class
Telerik.Reporting Namespace


Path Property

[image]

Telerik Reporting Q2 2012
Binding..::.Path Property
Binding Class See Also Send Feedback
Gets or sets the property path determining the item's bound simple/nested property.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Path { get; set; }
Visual Basic (Declaration)
Public Property Path As String

See Also

Binding Class
Telerik.Reporting Namespace


Binding Events

[image] [image]

Telerik Reporting Q2 2012
Binding Events
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Binding Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Binding..::.PropertyChanged Event
Binding Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Binding Class
Telerik.Reporting Namespace


BindingCollection Class

[image]

Telerik Reporting Q2 2012
BindingCollection Class
Members See Also Send Feedback
Represents a collection of Bindings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BindingCollection : Collection<Binding>
Visual Basic (Declaration)
Public Class BindingCollection _
    Inherits Collection(Of Binding)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Binding >)>)>
Telerik.Reporting..::.BindingCollection

See Also

BindingCollection Members
Telerik.Reporting Namespace


BindingCollection Members

[image] [image]

Telerik Reporting Q2 2012
BindingCollection Members
BindingCollection Class Constructors Methods See Also Send Feedback

The BindingCollection type exposes the following members.

Constructors

Name | Description
BindingCollection | Initializes a new instance of the BindingCollection class

Methods

Name | Description
AddRange |

See Also

BindingCollection Class
Telerik.Reporting Namespace


BindingCollection Constructor

[image]

Telerik Reporting Q2 2012
BindingCollection Constructor
BindingCollection Class See Also Send Feedback
Initializes a new instance of the BindingCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BindingCollection()
Visual Basic (Declaration)
Public Sub New

See Also

BindingCollection Class
Telerik.Reporting Namespace


BindingCollection Methods

[image] [image]

Telerik Reporting Q2 2012
BindingCollection Methods
BindingCollection Class See Also Send Feedback

The BindingCollection type exposes the following members.

Methods

Name | Description
AddRange |

See Also

BindingCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
BindingCollection..::.AddRange Method
BindingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<Binding> bindings
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    bindings As IEnumerable(Of Binding) _
)

Parameters

bindings
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Binding >)>)>

See Also

BindingCollection Class
Telerik.Reporting Namespace


CalculatedField Class

[image]

Telerik Reporting Q2 2012
CalculatedField Class
Members See Also Send Feedback
Represents an user-defined field in a DataSource.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CalculatedField : INotifyPropertyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CalculatedField _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.CalculatedField

See Also

CalculatedField Members
Telerik.Reporting Namespace


CalculatedField Members

[image] [image]

Telerik Reporting Q2 2012
CalculatedField Members
CalculatedField Class Constructors Properties Events See Also Send Feedback

The CalculatedField type exposes the following members.

Constructors

Name | Description
CalculatedField | Overloaded.

Properties

Name | Description
DataType | Gets or sets the data type of the CalculatedField
Expression | Gets or sets the expression of the CalculatedField
Name | Gets or sets the name of the CalculatedField

Events

Name | Description
PropertyChanged |

See Also

CalculatedField Class
Telerik.Reporting Namespace


CalculatedField Constructor

[image] [image]

Telerik Reporting Q2 2012
CalculatedField Constructor
CalculatedField Class See Also Send Feedback

Overload List

Name | Description
CalculatedField()()() | Initializes a new instance of the CalculatedField class
CalculatedField(String) | Initializes a new instance of the CalculatedField class
CalculatedField(String, Type) | Initializes a new instance of the CalculatedField class
CalculatedField(String, Type, String) | Initializes a new instance of the CalculatedField class

See Also

CalculatedField Class
CalculatedField Members
Telerik.Reporting Namespace


CalculatedField Constructor

[image]

Telerik Reporting Q2 2012
CalculatedField Constructor
CalculatedField Class See Also Send Feedback
Initializes a new instance of the CalculatedField class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedField()
Visual Basic (Declaration)
Public Sub New

See Also

CalculatedField Class
CalculatedField Overload
Telerik.Reporting Namespace


CalculatedField Constructor (String)

[image]

Telerik Reporting Q2 2012
CalculatedField Constructor (String)
CalculatedField Class See Also Send Feedback
Initializes a new instance of the CalculatedField class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedField(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String

See Also

CalculatedField Class
CalculatedField Overload
Telerik.Reporting Namespace


CalculatedField Constructor (String, Type)

[image]

Telerik Reporting Q2 2012
CalculatedField Constructor (String, Type)
CalculatedField Class See Also Send Feedback
Initializes a new instance of the CalculatedField class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedField(
    string name,
    Type dataType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As Type _
)

Parameters

name
Type: System..::.String
dataType
Type: System..::.Type

See Also

CalculatedField Class
CalculatedField Overload
Telerik.Reporting Namespace


CalculatedField Constructor (String, Type, String)

[image]

Telerik Reporting Q2 2012
CalculatedField Constructor (String, Type, String)
CalculatedField Class See Also Send Feedback
Initializes a new instance of the CalculatedField class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedField(
    string name,
    Type dataType,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As Type, _
    expression As String _
)

Parameters

name
Type: System..::.String
dataType
Type: System..::.Type
expression
Type: System..::.String

See Also

CalculatedField Class
CalculatedField Overload
Telerik.Reporting Namespace


CalculatedField Properties

[image] [image]

Telerik Reporting Q2 2012
CalculatedField Properties
CalculatedField Class See Also Send Feedback

The CalculatedField type exposes the following members.

Properties

Name | Description
DataType | Gets or sets the data type of the CalculatedField
Expression | Gets or sets the expression of the CalculatedField
Name | Gets or sets the name of the CalculatedField

See Also

CalculatedField Class
Telerik.Reporting Namespace


DataType Property

[image]

Telerik Reporting Q2 2012
CalculatedField..::.DataType Property
CalculatedField Class See Also Send Feedback
Gets or sets the data type of the CalculatedField

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

CalculatedField Class
Telerik.Reporting Namespace


Expression Property

[image]

Telerik Reporting Q2 2012
CalculatedField..::.Expression Property
CalculatedField Class See Also Send Feedback
Gets or sets the expression of the CalculatedField

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

CalculatedField Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
CalculatedField..::.Name Property
CalculatedField Class See Also Send Feedback
Gets or sets the name of the CalculatedField

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

CalculatedField Class
Telerik.Reporting Namespace


CalculatedField Events

[image] [image]

Telerik Reporting Q2 2012
CalculatedField Events
CalculatedField Class See Also Send Feedback

The CalculatedField type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

CalculatedField Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
CalculatedField..::.PropertyChanged Event
CalculatedField Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

CalculatedField Class
Telerik.Reporting Namespace


CalculatedFieldCollection Class

[image]

Telerik Reporting Q2 2012
CalculatedFieldCollection Class
Members See Also Send Feedback
Represents a collection of CalculatedFields.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CalculatedFieldCollection : Collection<CalculatedField>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CalculatedFieldCollection _
    Inherits Collection(Of CalculatedField)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' CalculatedField >)>)>
Telerik.Reporting..::.CalculatedFieldCollection

See Also

CalculatedFieldCollection Members
Telerik.Reporting Namespace


CalculatedFieldCollection Members

[image] [image]

Telerik Reporting Q2 2012
CalculatedFieldCollection Members
CalculatedFieldCollection Class Constructors Methods See Also Send Feedback

The CalculatedFieldCollection type exposes the following members.

Constructors

Name | Description
CalculatedFieldCollection | Initializes a new instance of the CalculatedFieldCollection class

Methods

Name | Description
AddRange |

See Also

CalculatedFieldCollection Class
Telerik.Reporting Namespace


CalculatedFieldCollection Constructor

[image]

Telerik Reporting Q2 2012
CalculatedFieldCollection Constructor
CalculatedFieldCollection Class See Also Send Feedback
Initializes a new instance of the CalculatedFieldCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedFieldCollection()
Visual Basic (Declaration)
Public Sub New

See Also

CalculatedFieldCollection Class
Telerik.Reporting Namespace


CalculatedFieldCollection Methods

[image] [image]

Telerik Reporting Q2 2012
CalculatedFieldCollection Methods
CalculatedFieldCollection Class See Also Send Feedback

The CalculatedFieldCollection type exposes the following members.

Methods

Name | Description
AddRange |

See Also

CalculatedFieldCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
CalculatedFieldCollection..::.AddRange Method
CalculatedFieldCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    CalculatedField[] fields
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    fields As CalculatedField() _
)

Parameters

fields
Type: array< Telerik.Reporting..::.CalculatedField >[]()[][]

See Also

CalculatedFieldCollection Class
Telerik.Reporting Namespace


Chart Class

[image]

Telerik Reporting Q2 2012
Chart Class
Members See Also Send Feedback
Represents a chart report item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Chart : ReportItem, IComponent,
    IDisposable
Visual Basic (Declaration)
Public Class Chart _
    Inherits ReportItem _
    Implements IComponent, IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Chart

See Also

Chart Members
Telerik.Reporting Namespace


Chart Members

[image] [image]

Telerik Reporting Q2 2012
Chart Members
Chart Class Constructors Methods Properties Events See Also Send Feedback

The Chart type exposes the following members.

Constructors

Name | Description
Chart | Initializes a new instance of the Chart class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
ClearSkin | Resets current chart skin to the default one.
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | Raise event.
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Appearance | Link to visualization and design properties
AutoLayout | Specifies AutoLayout mode to all items on the chart control.
AutoTextWrap | Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
BitmapResolution | Specifies the resolution of the chart image when rendered as Bitmap.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ChartTitle | Collection of titles for chart
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
CustomPalettes | Specifies the custom palettes for chart.
DataGroupColumn | Defines a data source column name for grouping data
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Chart will render.
DataSource | Gets or sets the data source that the Chart is displaying data for.
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DefaultType | Default chart type
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Chart
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
ImageFormat | Specifies the image format in which the image is streamed.
IntelligentLabelsEnabled | Toggles the use of the IntelligentLabels feature.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Legend | Chart legend
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PlotArea | Chart plot area
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Series | Gets or sets the chart's series collection object.
SeriesOrientation | Specifies the orientation of the chart series on the plot area.
SeriesPalette | Specifies the series palette
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Skin | Gets or sets the name of the chart's skin.
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Chart
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the chart has no data source set.

See Also

Chart Class
Telerik.Reporting Namespace


Chart Constructor

[image]

Telerik Reporting Q2 2012
Chart Constructor
Chart Class See Also Send Feedback
Initializes a new instance of the Chart class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Chart()
Visual Basic (Declaration)
Public Sub New

See Also

Chart Class
Telerik.Reporting Namespace


Chart Methods

[image] [image]

Telerik Reporting Q2 2012
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
ClearSkin | Resets current chart skin to the default one.
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | Raise event.
ToString | Overloaded.

See Also

Chart Class
Telerik.Reporting Namespace


ClearSkin Method

[image]

Telerik Reporting Q2 2012
Chart..::.ClearSkin Method
Chart Class See Also Send Feedback
Resets current chart skin to the default one.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearSkin()
Visual Basic (Declaration)
Public Sub ClearSkin

See Also

Chart Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.Dispose Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Chart Class
Chart Members
Telerik.Reporting Namespace


OnNeedDataSource Method

[image]

Telerik Reporting Q2 2012
Chart..::.OnNeedDataSource Method
Chart Class See Also Send Feedback
Raise event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnNeedDataSource(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnNeedDataSource ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Chart Class
Telerik.Reporting Namespace
Chart..::.NeedDataSource


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.ToString Method
Chart Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Chart Class
Chart Members
Telerik.Reporting Namespace


Chart Properties

[image] [image]

Telerik Reporting Q2 2012
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Appearance | Link to visualization and design properties
AutoLayout | Specifies AutoLayout mode to all items on the chart control.
AutoTextWrap | Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
BitmapResolution | Specifies the resolution of the chart image when rendered as Bitmap.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ChartTitle | Collection of titles for chart
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
CustomPalettes | Specifies the custom palettes for chart.
DataGroupColumn | Defines a data source column name for grouping data
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Chart will render.
DataSource | Gets or sets the data source that the Chart is displaying data for.
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DefaultType | Default chart type
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Chart
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
ImageFormat | Specifies the image format in which the image is streamed.
IntelligentLabelsEnabled | Toggles the use of the IntelligentLabels feature.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Legend | Chart legend
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PlotArea | Chart plot area
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Series | Gets or sets the chart's series collection object.
SeriesOrientation | Specifies the orientation of the chart series on the plot area.
SeriesPalette | Specifies the series palette
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Skin | Gets or sets the name of the chart's skin.
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Chart
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Chart Class
Telerik.Reporting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
Chart..::.Appearance Property
Chart Class See Also Send Feedback
Link to visualization and design properties

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChart Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChart

See Also

Chart Class
Telerik.Reporting Namespace


AutoLayout Property

[image]

Telerik Reporting Q2 2012
Chart..::.AutoLayout Property
Chart Class See Also Send Feedback
Specifies AutoLayout mode to all items on the chart control.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AutoLayout { get; set; }
Visual Basic (Declaration)
Public Property AutoLayout As Boolean

See Also

Chart Class
Telerik.Reporting Namespace


AutoTextWrap Property

[image]

Telerik Reporting Q2 2012
Chart..::.AutoTextWrap Property
Chart Class See Also Send Feedback
Specifies AutoTextWrap mode for all wrappable text blocks of the chart control.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AutoTextWrap { get; set; }
Visual Basic (Declaration)
Public Property AutoTextWrap As Boolean

See Also

Chart Class
Telerik.Reporting Namespace


BitmapResolution Property

[image]

Telerik Reporting Q2 2012
Chart..::.BitmapResolution Property
Chart Class See Also Send Feedback
Specifies the resolution of the chart image when rendered as Bitmap.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float BitmapResolution { get; set; }
Visual Basic (Declaration)
Public Property BitmapResolution As Single

See Also

Chart Class
Telerik.Reporting Namespace


ChartTitle Property

[image]

Telerik Reporting Q2 2012
Chart..::.ChartTitle Property
Chart Class See Also Send Feedback
Collection of titles for chart

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartTitle ChartTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChartTitle As ChartTitle

See Also

Chart Class
Telerik.Reporting Namespace


CustomPalettes Property

[image]

Telerik Reporting Q2 2012
Chart..::.CustomPalettes Property
Chart Class See Also Send Feedback
Specifies the custom palettes for chart.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomPalettesCollection CustomPalettes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomPalettes As CustomPalettesCollection

See Also

Chart Class
Telerik.Reporting Namespace


DataGroupColumn Property

[image]

Telerik Reporting Q2 2012
Chart..::.DataGroupColumn Property
Chart Class See Also Send Feedback
Defines a data source column name for grouping data

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataGroupColumn { get; set; }
Visual Basic (Declaration)
Public Property DataGroupColumn As String

See Also

Chart Class
Telerik.Reporting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Chart..::.DataMember Property
Chart Class See Also Send Feedback
Gets or sets the specific list in a DataSource which the Chart will render.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

Field Value

A list in a DataSource. The default is an empty string ("").

Remarks

If a DataSource contains multiple sources of data, you should set the DataMember to one of the sources. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

If the DataSource is a DataTable, DataView, collection, or array, there is no need to set the DataMember property of the Chart

See Also

Chart Class
Telerik.Reporting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Chart..::.DataSource Property
Chart Class See Also Send Feedback
Gets or sets the data source that the Chart is displaying data for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

Field Value

An object that functions as a data source.

Remarks

The following data sources are valid:

  • A DataTable
  • A DataView
  • A DataSet
  • A DataViewManager
  • Any component that implements the IListSource interface
  • Any component that implements the IEnumerable interface
  • Any component that implements the IDataAdapter interface

If the DataSource reference contains more than one table, you must set the DataMember property a string that specifies the table to bind to. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

Setting the DataSource to an object that does not implement the IListSource, IEnumerable, or IDataAdapter will cause an exception.

See Also

Chart Class
Telerik.Reporting Namespace


DefaultSize Property

[image]

Telerik Reporting Q2 2012
Chart..::.DefaultSize Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override SizeU DefaultSize { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As SizeU

See Also

Chart Class
Telerik.Reporting Namespace


DefaultType Property

[image]

Telerik Reporting Q2 2012
Chart..::.DefaultType Property
Chart Class See Also Send Feedback
Default chart type

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesType DefaultType { get; set; }
Visual Basic (Declaration)
Public Property DefaultType As ChartSeriesType

See Also

Chart Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
Chart..::.Filters Property
Chart Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Chart

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

Field Value

A [!:Telerik.Reporting.Data.FilterCollection] that contains the Filter objects for the Chart

Remarks

Filter expressions limit the data that is displayed to the user after the data is retrieved from the data source.

See Also

Chart Class
Telerik.Reporting Namespace


ImageFormat Property

[image]

Telerik Reporting Q2 2012
Chart..::.ImageFormat Property
Chart Class See Also Send Feedback
Specifies the image format in which the image is streamed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageFormat

See Also

Chart Class
Telerik.Reporting Namespace


IntelligentLabelsEnabled Property

[image]

Telerik Reporting Q2 2012
Chart..::.IntelligentLabelsEnabled Property
Chart Class See Also Send Feedback
Toggles the use of the IntelligentLabels feature.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IntelligentLabelsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IntelligentLabelsEnabled As Boolean

See Also

Chart Class
Telerik.Reporting Namespace


Legend Property

[image]

Telerik Reporting Q2 2012
Chart..::.Legend Property
Chart Class See Also Send Feedback
Chart legend

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLegend Legend { get; }
Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend

See Also

Chart Class
Telerik.Reporting Namespace


PlotArea Property

[image]

Telerik Reporting Q2 2012
Chart..::.PlotArea Property
Chart Class See Also Send Feedback
Chart plot area

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea PlotArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlotArea As ChartPlotArea

See Also

Chart Class
Telerik.Reporting Namespace


Series Property

[image]

Telerik Reporting Q2 2012
Chart..::.Series Property
Chart Class See Also Send Feedback
Gets or sets the chart's series collection object.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As ChartSeriesCollection

See Also

Chart Class
Telerik.Reporting Namespace


SeriesOrientation Property

[image]

Telerik Reporting Q2 2012
Chart..::.SeriesOrientation Property
Chart Class See Also Send Feedback
Specifies the orientation of the chart series on the plot area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesOrientation SeriesOrientation { get; set; }
Visual Basic (Declaration)
Public Property SeriesOrientation As ChartSeriesOrientation

See Also

Chart Class
Telerik.Reporting Namespace


SeriesPalette Property

[image]

Telerik Reporting Q2 2012
Chart..::.SeriesPalette Property
Chart Class See Also Send Feedback
Specifies the series palette

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string SeriesPalette { get; set; }
Visual Basic (Declaration)
Public Property SeriesPalette As String

See Also

Chart Class
Telerik.Reporting Namespace


Skin Property

[image]

Telerik Reporting Q2 2012
Chart..::.Skin Property
Chart Class See Also Send Feedback
Gets or sets the name of the chart's skin.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Skin { get; set; }
Visual Basic (Declaration)
Public Property Skin As String

See Also

Chart Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
Chart..::.Sorting Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

Chart Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
Chart..::.Sortings Property
Chart Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Chart

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

Field Value

A [!:Telerik.Reporting.Data.SortingCollection] that contains the Sorting objects for the Chart

Remarks

Sort expressions sort the data that is displayed to the user after the data is retrieved from the data source.

See Also

Chart Class
Telerik.Reporting Namespace


Chart Events

[image] [image]

Telerik Reporting Q2 2012
Chart Events
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the chart has no data source set.

See Also

Chart Class
Telerik.Reporting Namespace


NeedDataSource Event

[image]

Telerik Reporting Q2 2012
Chart..::.NeedDataSource Event
Chart Class See Also Send Feedback
Occurs at the start of report processing if the chart has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler NeedDataSource
Visual Basic (Declaration)
Public Event NeedDataSource As EventHandler

See Also

Chart Class
Telerik.Reporting Namespace


CheckBox Class

[image]

Telerik Reporting Q2 2012
CheckBox Class
Members See Also Send Feedback
Represents a check box report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CheckBox : TextItemBase
Visual Basic (Declaration)
Public Class CheckBox _
    Inherits TextItemBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.TextItemBase
Telerik.Reporting..::.CheckBox

See Also

CheckBox Members
Telerik.Reporting Namespace


CheckBox Members

[image] [image]

Telerik Reporting Q2 2012
CheckBox Members
CheckBox Class Constructors Methods Properties Events See Also Send Feedback

The CheckBox type exposes the following members.

Constructors

Name | Description
CheckBox | Initializes a new instance of the CheckBox class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase.)
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase.)
CheckAlign | Gets or sets the alignment of the check mark on a CheckBox.
CheckedImage | Gets or sets the image corresponding to an Selected CheckBox
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
FalseValue | Gets or sets the value template corresponding to an Unchecked CheckBox
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
IndeterminateImage | Gets or sets the image corresponding to an Indeterminate CheckBox
IndeterminateValue | Gets or sets the value template corresponding to an Indeterminate CheckBox
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Text | Gets or sets the current text (aka label) in the check box.
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
TrueValue | Gets or sets the value template corresponding to an Selected CheckBox
UncheckedImage | Gets or sets the image corresponding to an Unchecked CheckBox
Value | Gets or sets the value of the check box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

CheckBox Class
Telerik.Reporting Namespace


CheckBox Constructor

[image]

Telerik Reporting Q2 2012
CheckBox Constructor
CheckBox Class See Also Send Feedback
Initializes a new instance of the CheckBox class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CheckBox()
Visual Basic (Declaration)
Public Sub New

See Also

CheckBox Class
Telerik.Reporting Namespace


CheckBox Methods

[image] [image]

Telerik Reporting Q2 2012
CheckBox Methods
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

CheckBox Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
CheckBox..::.Dispose Method
CheckBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

CheckBox Class
CheckBox Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
CheckBox..::.ToString Method
CheckBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

CheckBox Class
CheckBox Members
Telerik.Reporting Namespace


CheckBox Properties

[image] [image]

Telerik Reporting Q2 2012
CheckBox Properties
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase.)
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase.)
CheckAlign | Gets or sets the alignment of the check mark on a CheckBox.
CheckedImage | Gets or sets the image corresponding to an Selected CheckBox
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
FalseValue | Gets or sets the value template corresponding to an Unchecked CheckBox
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
IndeterminateImage | Gets or sets the image corresponding to an Indeterminate CheckBox
IndeterminateValue | Gets or sets the value template corresponding to an Indeterminate CheckBox
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Text | Gets or sets the current text (aka label) in the check box.
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
TrueValue | Gets or sets the value template corresponding to an Selected CheckBox
UncheckedImage | Gets or sets the image corresponding to an Unchecked CheckBox
Value | Gets or sets the value of the check box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

CheckBox Class
Telerik.Reporting Namespace


CheckAlign Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.CheckAlign Property
CheckBox Class See Also Send Feedback
Gets or sets the alignment of the check mark on a CheckBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ContentAlignment CheckAlign { get; set; }
Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment

Field Value

One of the ContentAlignment values. The default is MiddleLeft.

See Also

CheckBox Class
Telerik.Reporting Namespace


CheckedImage Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.CheckedImage Property
CheckBox Class See Also Send Feedback
Gets or sets the image corresponding to an Selected CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object CheckedImage { get; set; }
Visual Basic (Declaration)
Public Property CheckedImage As Object

Field Value

A String started with "=" is interpreted as an expression,

See Also

CheckBox Class
Telerik.Reporting Namespace


FalseValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.FalseValue Property
CheckBox Class See Also Send Feedback
Gets or sets the value template corresponding to an Unchecked CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object FalseValue { get; set; }
Visual Basic (Declaration)
Public Property FalseValue As Object

Field Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

See Also

CheckBox Class
Telerik.Reporting Namespace


IndeterminateImage Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.IndeterminateImage Property
CheckBox Class See Also Send Feedback
Gets or sets the image corresponding to an Indeterminate CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object IndeterminateImage { get; set; }
Visual Basic (Declaration)
Public Property IndeterminateImage As Object

Field Value

A String started with "=" is interpreted as an expression,

See Also

CheckBox Class
Telerik.Reporting Namespace


IndeterminateValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.IndeterminateValue Property
CheckBox Class See Also Send Feedback
Gets or sets the value template corresponding to an Indeterminate CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object IndeterminateValue { get; set; }
Visual Basic (Declaration)
Public Property IndeterminateValue As Object

Field Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

See Also

CheckBox Class
Telerik.Reporting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.Text Property
CheckBox Class See Also Send Feedback
Gets or sets the current text (aka label) in the check box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

Field Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

See Also

CheckBox Class
Telerik.Reporting Namespace


TrueValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.TrueValue Property
CheckBox Class See Also Send Feedback
Gets or sets the value template corresponding to an Selected CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object TrueValue { get; set; }
Visual Basic (Declaration)
Public Property TrueValue As Object

Field Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

See Also

CheckBox Class
Telerik.Reporting Namespace


UncheckedImage Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.UncheckedImage Property
CheckBox Class See Also Send Feedback
Gets or sets the image corresponding to an Unchecked CheckBox

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object UncheckedImage { get; set; }
Visual Basic (Declaration)
Public Property UncheckedImage As Object

Field Value

A String started with "=" is interpreted as an expression,

See Also

CheckBox Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.Value Property
CheckBox Class See Also Send Feedback
Gets or sets the value of the check box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

Field Value

A String started with "=" is interpreted as an expression to calculate the real data, otherwise - literal string.

See Also

CheckBox Class
Telerik.Reporting Namespace


CheckBox Events

[image] [image]

Telerik Reporting Q2 2012
CheckBox Events
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

CheckBox Class
Telerik.Reporting Namespace


Crosstab Class

[image]

Telerik Reporting Q2 2012
Crosstab Class
Members See Also Send Feedback
The Crosstab report item displays aggregated data summaries, grouped in rows and columns.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Crosstab : Table
Visual Basic (Declaration)
Public Class Crosstab _
    Inherits Table

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Table
Telerik.Reporting..::.Crosstab

See Also

Crosstab Members
Telerik.Reporting Namespace


Crosstab Members

[image] [image]

Telerik Reporting Q2 2012
Crosstab Members
Crosstab Class Constructors Methods Properties Events See Also Send Feedback

The Crosstab type exposes the following members.

Constructors

Name | Description
Crosstab | Initializes a new instance of the Crosstab class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | (Inherited from Table.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group. (Inherited from Table.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values. (Inherited from Table.)
ColumnHeadersPrintOnEveryPage | (Inherited from Table.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item. (Inherited from Table.)
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render. (Inherited from Table.)
DataSource | Gets or sets the data source that the Table is displaying data for. (Inherited from Table.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table (Inherited from Table.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible. (Inherited from Table.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values. (Inherited from Table.)
RowHeadersPrintOnEveryPage | (Inherited from Table.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete. (Inherited from Table.)
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table (Inherited from Table.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set. (Inherited from Table.)

See Also

Crosstab Class
Telerik.Reporting Namespace


Crosstab Constructor

[image]

Telerik Reporting Q2 2012
Crosstab Constructor
Crosstab Class See Also Send Feedback
Initializes a new instance of the Crosstab class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Crosstab()
Visual Basic (Declaration)
Public Sub New

See Also

Crosstab Class
Telerik.Reporting Namespace


Crosstab Methods

[image] [image]

Telerik Reporting Q2 2012
Crosstab Methods
Crosstab Class See Also Send Feedback

The Crosstab type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | (Inherited from Table.)
ToString | Overloaded.

See Also

Crosstab Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Crosstab..::.Dispose Method
Crosstab Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Crosstab Class
Crosstab Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Crosstab..::.ToString Method
Crosstab Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Crosstab Class
Crosstab Members
Telerik.Reporting Namespace


Crosstab Properties

[image] [image]

Telerik Reporting Q2 2012
Crosstab Properties
Crosstab Class See Also Send Feedback

The Crosstab type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group. (Inherited from Table.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values. (Inherited from Table.)
ColumnHeadersPrintOnEveryPage | (Inherited from Table.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item. (Inherited from Table.)
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render. (Inherited from Table.)
DataSource | Gets or sets the data source that the Table is displaying data for. (Inherited from Table.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table (Inherited from Table.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible. (Inherited from Table.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values. (Inherited from Table.)
RowHeadersPrintOnEveryPage | (Inherited from Table.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete. (Inherited from Table.)
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table (Inherited from Table.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Crosstab Class
Telerik.Reporting Namespace


Crosstab Events

[image] [image]

Telerik Reporting Q2 2012
Crosstab Events
Crosstab Class See Also Send Feedback

The Crosstab type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set. (Inherited from Table.)

See Also

Crosstab Class
Telerik.Reporting Namespace


CubeDataSource Class

[image]

Telerik Reporting Q2 2012
CubeDataSource Class
Members See Also Send Feedback
Represents an OLAP cube to data items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CubeDataSource : DataSource
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CubeDataSource _
    Inherits DataSource

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.CubeDataSource

See Also

CubeDataSource Members
Telerik.Reporting Namespace


CubeDataSource Members

[image] [image]

Telerik Reporting Q2 2012
CubeDataSource Members
CubeDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CubeDataSource type exposes the following members.

Constructors

Name | Description
CubeDataSource | Overloaded.

Methods

Name | Description
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to the OLAP database.
Mappings | Gets a collection with DataFieldMapping objects.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with CubeDataSourceParameter objects.
SelectCommand | Gets or sets the MDX select statement to execute against the OLAP cube.

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

CubeDataSource Class
Telerik.Reporting Namespace


CubeDataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
CubeDataSource Constructor
CubeDataSource Class See Also Send Feedback

Overload List

Name | Description
CubeDataSource()()() | Initializes a new instance of the CubeDataSource class.
CubeDataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the CubeDataSource class
CubeDataSource(String, String) | Initializes a new instance of the CubeDataSource class.

See Also

CubeDataSource Class
CubeDataSource Members
Telerik.Reporting Namespace


CubeDataSource Constructor

[image]

Telerik Reporting Q2 2012
CubeDataSource Constructor
CubeDataSource Class See Also Send Feedback
Initializes a new instance of the CubeDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSource()
Visual Basic (Declaration)
Public Sub New

See Also

CubeDataSource Class
CubeDataSource Overload
Telerik.Reporting Namespace


CubeDataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
CubeDataSource Constructor (SerializationInfo, StreamingContext)
CubeDataSource Class See Also Send Feedback
Initializes a new instance of the CubeDataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected CubeDataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

CubeDataSource Class
CubeDataSource Overload
Telerik.Reporting Namespace


CubeDataSource Constructor (String, String)

[image]

Telerik Reporting Q2 2012
CubeDataSource Constructor (String, String)
CubeDataSource Class See Also Send Feedback
Initializes a new instance of the CubeDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSource(
    string connectionString,
    string selectCommand
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String, _
    selectCommand As String _
)

Parameters

connectionString
Type: System..::.String
Specifies the connection string used to connect to the OLAP database.
selectCommand
Type: System..::.String
Specifies the MDX select statement to execute against the OLAP cube.

See Also

CubeDataSource Class
CubeDataSource Overload
Telerik.Reporting Namespace


CubeDataSource Methods

[image] [image]

Telerik Reporting Q2 2012
CubeDataSource Methods
CubeDataSource Class See Also Send Feedback

The CubeDataSource type exposes the following members.

Methods

Name | Description
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

CubeDataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
CubeDataSource..::.GetObjectData Method
CubeDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

CubeDataSource Class
Telerik.Reporting Namespace


CubeDataSource Properties

[image] [image]

Telerik Reporting Q2 2012
CubeDataSource Properties
CubeDataSource Class See Also Send Feedback

The CubeDataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to the OLAP database.
Mappings | Gets a collection with DataFieldMapping objects.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with CubeDataSourceParameter objects.
SelectCommand | Gets or sets the MDX select statement to execute against the OLAP cube.

See Also

CubeDataSource Class
Telerik.Reporting Namespace


ConnectionString Property

[image]

Telerik Reporting Q2 2012
CubeDataSource..::.ConnectionString Property
CubeDataSource Class See Also Send Feedback
Gets or sets the connection string used to connect to the OLAP database.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String

Remarks

The ConnectionString property contains a valid connection string or a name of a [!:ConnectionStringSettings] in the application's configuration file.

See Also

CubeDataSource Class
Telerik.Reporting Namespace


Mappings Property

[image]

Telerik Reporting Q2 2012
CubeDataSource..::.Mappings Property
CubeDataSource Class See Also Send Feedback
Gets a collection with DataFieldMapping objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMappingCollection Mappings { get; private set; }
Visual Basic (Declaration)
Public Property Mappings As DataFieldMappingCollection

Remarks

The Mappings collection is used to map the names of the data source fields to the actual fields returned when executing the MDX select statement.

See Also

CubeDataSource Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
CubeDataSource..::.Parameters Property
CubeDataSource Class See Also Send Feedback
Gets a collection with CubeDataSourceParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameterCollection Parameters { get; private set; }
Visual Basic (Declaration)
Public Property Parameters As CubeDataSourceParameterCollection

Remarks

The Parameters collection is used to pass named parameters when executing a parameterized MDX select statement against the OLAP cube.

See Also

CubeDataSource Class
Telerik.Reporting Namespace


SelectCommand Property

[image]

Telerik Reporting Q2 2012
CubeDataSource..::.SelectCommand Property
CubeDataSource Class See Also Send Feedback
Gets or sets the MDX select statement to execute against the OLAP cube.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string SelectCommand { get; set; }
Visual Basic (Declaration)
Public Property SelectCommand As String

See Also

CubeDataSource Class
Telerik.Reporting Namespace


CubeDataSourceParameter Class

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Class
Members See Also Send Feedback
Represents a parameter in a CubeDataSource component.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CubeDataSourceParameter : DataSourceParameter
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CubeDataSourceParameter _
    Inherits DataSourceParameter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.DataSourceParameter
Telerik.Reporting..::.CubeDataSourceParameter

See Also

CubeDataSourceParameter Members
Telerik.Reporting Namespace


CubeDataSourceParameter Members

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Members
CubeDataSourceParameter Class Constructors Methods Properties Events See Also Send Feedback

The CubeDataSourceParameter type exposes the following members.

Constructors

Name | Description
CubeDataSourceParameter | Overloaded.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

Properties

Name | Description
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

CubeDataSourceParameter Class
Telerik.Reporting Namespace


CubeDataSourceParameter Constructor

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Constructor
CubeDataSourceParameter Class See Also Send Feedback

Overload List

Name | Description
CubeDataSourceParameter()()() | Initializes a new instance of the CubeDataSourceParameter class.
CubeDataSourceParameter(String) | Initializes a new instance of the CubeDataSourceParameter class.
CubeDataSourceParameter(String, Object) | Initializes a new instance of the CubeDataSourceParameter class.

See Also

CubeDataSourceParameter Class
CubeDataSourceParameter Members
Telerik.Reporting Namespace


CubeDataSourceParameter Constructor

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Constructor
CubeDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameter()
Visual Basic (Declaration)
Public Sub New

See Also

CubeDataSourceParameter Class
CubeDataSourceParameter Overload
Telerik.Reporting Namespace


CubeDataSourceParameter Constructor (String)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Constructor (String)
CubeDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameter(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.

See Also

CubeDataSourceParameter Class
CubeDataSourceParameter Overload
Telerik.Reporting Namespace


CubeDataSourceParameter Constructor (String, Object)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Constructor (String, Object)
CubeDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameter(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
value
Type: System..::.Object
Specifies the value of the parameter.

See Also

CubeDataSourceParameter Class
CubeDataSourceParameter Overload
Telerik.Reporting Namespace


CubeDataSourceParameter Methods

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Methods
CubeDataSourceParameter Class See Also Send Feedback

The CubeDataSourceParameter type exposes the following members.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

See Also

CubeDataSourceParameter Class
Telerik.Reporting Namespace


CubeDataSourceParameter Properties

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Properties
CubeDataSourceParameter Class See Also Send Feedback

The CubeDataSourceParameter type exposes the following members.

Properties

Name | Description
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

See Also

CubeDataSourceParameter Class
Telerik.Reporting Namespace


CubeDataSourceParameter Events

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameter Events
CubeDataSourceParameter Class See Also Send Feedback

The CubeDataSourceParameter type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

CubeDataSourceParameter Class
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Class

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Class
Members See Also Send Feedback
Represents a collection of CubeDataSourceParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CubeDataSourceParameterCollection : Collection<CubeDataSourceParameter>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CubeDataSourceParameterCollection _
    Inherits Collection(Of CubeDataSourceParameter)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' CubeDataSourceParameter >)>)>
Telerik.Reporting..::.CubeDataSourceParameterCollection

See Also

CubeDataSourceParameterCollection Members
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Members
CubeDataSourceParameterCollection Class Constructors Methods Properties See Also Send Feedback

The CubeDataSourceParameterCollection type exposes the following members.

Constructors

Name | Description
CubeDataSourceParameterCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Constructor
CubeDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
CubeDataSourceParameterCollection()()() | Initializes a new instance of the CubeDataSourceParameterCollection class.
CubeDataSourceParameterCollection(array<CubeDataSourceParameter>[]()[]) | Initializes a new instance of the CubeDataSourceParameterCollection class.
CubeDataSourceParameterCollection(CubeDataSourceParameterCollection) | Initializes a new instance of the CubeDataSourceParameterCollection class.

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Members
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Constructor
CubeDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Overload
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Constructor (CubeDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Constructor (array<CubeDataSourceParameter>[]()[][])
CubeDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameterCollection(
    CubeDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As CubeDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.CubeDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Overload
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Constructor (CubeDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Constructor (CubeDataSourceParameterCollection)
CubeDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the CubeDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameterCollection(
    CubeDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As CubeDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.CubeDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Overload
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Methods
CubeDataSourceParameterCollection Class See Also Send Feedback

The CubeDataSourceParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


Add Method

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.Add Method
CubeDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(String) | Adds a new parameter with the specified name to the collection.
Add(String, Object) | Adds a new parameter with the specified name and value to the collection.

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Members
Telerik.Reporting Namespace


Add Method (String)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.Add Method (String)
CubeDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.

See Also

CubeDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


Add Method (String, Object)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.Add Method (String, Object)
CubeDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name and value to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.
value
Type: System..::.Object
Specifies the value of the new parameter to add to the collection.

See Also

CubeDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.AddRange Method
CubeDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<CubeDataSourceParameter>[]()[]) | Adds a range of parameters to the collection.
AddRange(CubeDataSourceParameterCollection) | Adds a range of parameters to the collection.

See Also

CubeDataSourceParameterCollection Class
CubeDataSourceParameterCollection Members
Telerik.Reporting Namespace


AddRange Method (CubeDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.AddRange Method (array<CubeDataSourceParameter>[]()[][])
CubeDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    CubeDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As CubeDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.CubeDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

CubeDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


AddRange Method (CubeDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.AddRange Method (CubeDataSourceParameterCollection)
CubeDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    CubeDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As CubeDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.CubeDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

CubeDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.Contains Method
CubeDataSourceParameterCollection Class See Also Send Feedback
Determines if the collection contains a parameter with the specified name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

True if a parameter with the specified name exists, False otherwise.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


ToArray Method

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.ToArray Method
CubeDataSourceParameterCollection Class See Also Send Feedback
Converts the collection to an array of parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameter[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As CubeDataSourceParameter()

Return Value

Array of parameters contained in the collection.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


CubeDataSourceParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection Properties
CubeDataSourceParameterCollection Class See Also Send Feedback

The CubeDataSourceParameterCollection type exposes the following members.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
CubeDataSourceParameterCollection..::.Item Property
CubeDataSourceParameterCollection Class See Also Send Feedback
Gets the parameter with the specified name from the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CubeDataSourceParameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As CubeDataSourceParameter

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

The parameter with the specified name from the collection.

See Also

CubeDataSourceParameterCollection Class
Telerik.Reporting Namespace


DataFieldMapping Class

[image]

Telerik Reporting Q2 2012
DataFieldMapping Class
Members See Also Send Feedback
Represents a mapping between a field from a data source and its corresponding short alias used for data binding in expressions.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class DataFieldMapping : INotifyPropertyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DataFieldMapping _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.DataFieldMapping

See Also

DataFieldMapping Members
Telerik.Reporting Namespace


DataFieldMapping Members

[image] [image]

Telerik Reporting Q2 2012
DataFieldMapping Members
DataFieldMapping Class Constructors Methods Properties Events See Also Send Feedback

The DataFieldMapping type exposes the following members.

Constructors

Name | Description
DataFieldMapping | Overloaded.

Methods

Name | Description
NotifyPropertyChanged |

Properties

Name | Description
Alias | Gets or sets the alias of the field from the mapping.
Name | Gets or sets the name of the field from the mapping.

Events

Name | Description
PropertyChanged |

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


DataFieldMapping Constructor

[image] [image]

Telerik Reporting Q2 2012
DataFieldMapping Constructor
DataFieldMapping Class See Also Send Feedback

Overload List

Name | Description
DataFieldMapping()()() | Initializes a new instance of the DataFieldMapping class.
DataFieldMapping(String, String) | Initializes a new instance of the DataFieldMapping class.

See Also

DataFieldMapping Class
DataFieldMapping Members
Telerik.Reporting Namespace


DataFieldMapping Constructor

[image]

Telerik Reporting Q2 2012
DataFieldMapping Constructor
DataFieldMapping Class See Also Send Feedback
Initializes a new instance of the DataFieldMapping class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMapping()
Visual Basic (Declaration)
Public Sub New

See Also

DataFieldMapping Class
DataFieldMapping Overload
Telerik.Reporting Namespace


DataFieldMapping Constructor (String, String)

[image]

Telerik Reporting Q2 2012
DataFieldMapping Constructor (String, String)
DataFieldMapping Class See Also Send Feedback
Initializes a new instance of the DataFieldMapping class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMapping(
    string name,
    string alias
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    alias As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the field for the mapping.
alias
Type: System..::.String
Specifies the alias of the field for the mapping.

See Also

DataFieldMapping Class
DataFieldMapping Overload
Telerik.Reporting Namespace


DataFieldMapping Methods

[image] [image]

Telerik Reporting Q2 2012
DataFieldMapping Methods
DataFieldMapping Class See Also Send Feedback

The DataFieldMapping type exposes the following members.

Methods

Name | Description
NotifyPropertyChanged |

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


NotifyPropertyChanged Method

[image]

Telerik Reporting Q2 2012
DataFieldMapping..::.NotifyPropertyChanged Method
DataFieldMapping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void NotifyPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub NotifyPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::.String

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


DataFieldMapping Properties

[image] [image]

Telerik Reporting Q2 2012
DataFieldMapping Properties
DataFieldMapping Class See Also Send Feedback

The DataFieldMapping type exposes the following members.

Properties

Name | Description
Alias | Gets or sets the alias of the field from the mapping.
Name | Gets or sets the name of the field from the mapping.

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


Alias Property

[image]

Telerik Reporting Q2 2012
DataFieldMapping..::.Alias Property
DataFieldMapping Class See Also Send Feedback
Gets or sets the alias of the field from the mapping.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Alias { get; set; }
Visual Basic (Declaration)
Public Property Alias As String

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
DataFieldMapping..::.Name Property
DataFieldMapping Class See Also Send Feedback
Gets or sets the name of the field from the mapping.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


DataFieldMapping Events

[image] [image]

Telerik Reporting Q2 2012
DataFieldMapping Events
DataFieldMapping Class See Also Send Feedback

The DataFieldMapping type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
DataFieldMapping..::.PropertyChanged Event
DataFieldMapping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DataFieldMapping Class
Telerik.Reporting Namespace


DataFieldMappingCollection Class

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Class
Members See Also Send Feedback
Represents a collection of DataFieldMapping objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class DataFieldMappingCollection : Collection<DataFieldMapping>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DataFieldMappingCollection _
    Inherits Collection(Of DataFieldMapping)

Remarks

Represents a collection of mappings for the fields of a data source and their corresponding short aliases used for data binding in expressions.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' DataFieldMapping >)>)>
Telerik.Reporting..::.DataFieldMappingCollection

See Also

DataFieldMappingCollection Members
Telerik.Reporting Namespace


DataFieldMappingCollection Members

[image] [image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Members
DataFieldMappingCollection Class Constructors Methods Properties See Also Send Feedback

The DataFieldMappingCollection type exposes the following members.

Constructors

Name | Description
DataFieldMappingCollection | Overloaded.

Methods

Name | Description
Add | Adds a new mapping for the specified field to the collection.
AddRange | Overloaded.
Contains | Determines if the collection contains a mapping for the specified field.
ToArray | Converts the collection to an array of mappings.

Properties

Name | Description
Item | Gets the mapping of the specified field from the collection.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


DataFieldMappingCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Constructor
DataFieldMappingCollection Class See Also Send Feedback

Overload List

Name | Description
DataFieldMappingCollection()()() | Initializes a new instance of the DataFieldMappingCollection class.
DataFieldMappingCollection(array<DataFieldMapping>[]()[]) | Initializes a new instance of the DataFieldMappingCollection class.
DataFieldMappingCollection(DataFieldMappingCollection) | Initializes a new instance of the DataFieldMappingCollection class.

See Also

DataFieldMappingCollection Class
DataFieldMappingCollection Members
Telerik.Reporting Namespace


DataFieldMappingCollection Constructor

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Constructor
DataFieldMappingCollection Class See Also Send Feedback
Initializes a new instance of the DataFieldMappingCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMappingCollection()
Visual Basic (Declaration)
Public Sub New

See Also

DataFieldMappingCollection Class
DataFieldMappingCollection Overload
Telerik.Reporting Namespace


DataFieldMappingCollection Constructor (DataFieldMapping[])

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Constructor (array<DataFieldMapping>[]()[][])
DataFieldMappingCollection Class See Also Send Feedback
Initializes a new instance of the DataFieldMappingCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMappingCollection(
    DataFieldMapping[] mappings
)
Visual Basic (Declaration)
Public Sub New ( _
    mappings As DataFieldMapping() _
)

Parameters

mappings
Type: array< Telerik.Reporting..::.DataFieldMapping >[]()[][]
Specifies a range of mappings to add to the collection.

See Also

DataFieldMappingCollection Class
DataFieldMappingCollection Overload
Telerik.Reporting Namespace


DataFieldMappingCollection Constructor (DataFieldMappingCollection)

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Constructor (DataFieldMappingCollection)
DataFieldMappingCollection Class See Also Send Feedback
Initializes a new instance of the DataFieldMappingCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMappingCollection(
    DataFieldMappingCollection mappings
)
Visual Basic (Declaration)
Public Sub New ( _
    mappings As DataFieldMappingCollection _
)

Parameters

mappings
Type: Telerik.Reporting..::.DataFieldMappingCollection
Specifies a range of mappings to add to the collection.

See Also

DataFieldMappingCollection Class
DataFieldMappingCollection Overload
Telerik.Reporting Namespace


DataFieldMappingCollection Methods

[image] [image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Methods
DataFieldMappingCollection Class See Also Send Feedback

The DataFieldMappingCollection type exposes the following members.

Methods

Name | Description
Add | Adds a new mapping for the specified field to the collection.
AddRange | Overloaded.
Contains | Determines if the collection contains a mapping for the specified field.
ToArray | Converts the collection to an array of mappings.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.Add Method
DataFieldMappingCollection Class See Also Send Feedback
Adds a new mapping for the specified field to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    string alias
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    alias As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the field for the new mapping.
alias
Type: System..::.String
Specifies the alias of the field for the new mapping.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.AddRange Method
DataFieldMappingCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<DataFieldMapping>[]()[]) | Adds a range of mappings to the collection.
AddRange(DataFieldMappingCollection) | Adds a range of mappings to the collection.

See Also

DataFieldMappingCollection Class
DataFieldMappingCollection Members
Telerik.Reporting Namespace


AddRange Method (DataFieldMapping[])

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.AddRange Method (array<DataFieldMapping>[]()[][])
DataFieldMappingCollection Class See Also Send Feedback
Adds a range of mappings to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    DataFieldMapping[] mappings
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    mappings As DataFieldMapping() _
)

Parameters

mappings
Type: array< Telerik.Reporting..::.DataFieldMapping >[]()[][]
Specifies a range of mappings to add to the collection.

See Also

DataFieldMappingCollection Class
AddRange Overload
Telerik.Reporting Namespace


AddRange Method (DataFieldMappingCollection)

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.AddRange Method (DataFieldMappingCollection)
DataFieldMappingCollection Class See Also Send Feedback
Adds a range of mappings to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    DataFieldMappingCollection mappings
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    mappings As DataFieldMappingCollection _
)

Parameters

mappings
Type: Telerik.Reporting..::.DataFieldMappingCollection
Specifies a range of mappings to add to the collection.

See Also

DataFieldMappingCollection Class
AddRange Overload
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.Contains Method
DataFieldMappingCollection Class See Also Send Feedback
Determines if the collection contains a mapping for the specified field.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Specifies the name of a field from the collection.

Return Value

True if a mapping for the specified field exists, False otherwise.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


ToArray Method

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.ToArray Method
DataFieldMappingCollection Class See Also Send Feedback
Converts the collection to an array of mappings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMapping[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As DataFieldMapping()

Return Value

Array of mappings contained in the collection.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


DataFieldMappingCollection Properties

[image] [image]

Telerik Reporting Q2 2012
DataFieldMappingCollection Properties
DataFieldMappingCollection Class See Also Send Feedback

The DataFieldMappingCollection type exposes the following members.

Properties

Name | Description
Item | Gets the mapping of the specified field from the collection.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
DataFieldMappingCollection..::.Item Property
DataFieldMappingCollection Class See Also Send Feedback
Gets the mapping of the specified field from the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataFieldMapping this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As DataFieldMapping

Parameters

name
Type: System..::.String
Specifies the name of a field from the collection.

Return Value

The mapping of the specified field from the collection.

See Also

DataFieldMappingCollection Class
Telerik.Reporting Namespace


DataSource Class

[image]

Telerik Reporting Q2 2012
DataSource Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public abstract class DataSource : Component,
    ISerializable
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class DataSource _
    Inherits Component _
    Implements ISerializable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.CubeDataSource
Telerik.Reporting..::.ObjectDataSourceBase
Telerik.Reporting..::.SqlDataSource

See Also

DataSource Members
Telerik.Reporting Namespace


DataSource Members

[image] [image]

Telerik Reporting Q2 2012
DataSource Members
DataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The DataSource type exposes the following members.

Constructors

Name | Description
DataSource | Overloaded.

Methods

Name | Description
GetObjectData |

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection.
Name | Gets or sets the name of the DataSource component.

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData |

See Also

DataSource Class
Telerik.Reporting Namespace


DataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
DataSource Constructor
DataSource Class See Also Send Feedback

Overload List

Name | Description
DataSource()()() | Initializes a new instance of the DataSource class
DataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the DataSource class

See Also

DataSource Class
DataSource Members
Telerik.Reporting Namespace


DataSource Constructor

[image]

Telerik Reporting Q2 2012
DataSource Constructor
DataSource Class See Also Send Feedback
Initializes a new instance of the DataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected DataSource()
Visual Basic (Declaration)
Protected Sub New

See Also

DataSource Class
DataSource Overload
Telerik.Reporting Namespace


DataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
DataSource Constructor (SerializationInfo, StreamingContext)
DataSource Class See Also Send Feedback
Initializes a new instance of the DataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected DataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

DataSource Class
DataSource Overload
Telerik.Reporting Namespace


DataSource Methods

[image] [image]

Telerik Reporting Q2 2012
DataSource Methods
DataSource Class See Also Send Feedback

The DataSource type exposes the following members.

Methods

Name | Description
GetObjectData |

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData |

See Also

DataSource Class
Telerik.Reporting Namespace


ISerializable.GetObjectData Method

[image]

Telerik Reporting Q2 2012
DataSource..::.ISerializable..::.GetObjectData Method
DataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ISerializable.GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Private Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
) Implements ISerializable.GetObjectData

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

Implements

ISerializable..::.GetObjectData(SerializationInfo, StreamingContext)

See Also

DataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
DataSource..::.GetObjectData Method
DataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overridable Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

DataSource Class
Telerik.Reporting Namespace


DataSource Properties

[image] [image]

Telerik Reporting Q2 2012
DataSource Properties
DataSource Class See Also Send Feedback

The DataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection.
Name | Gets or sets the name of the DataSource component.

See Also

DataSource Class
Telerik.Reporting Namespace


CalculatedFields Property

[image]

Telerik Reporting Q2 2012
DataSource..::.CalculatedFields Property
DataSource Class See Also Send Feedback
Gets the calculated fields collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CalculatedFieldCollection CalculatedFields { get; }
Visual Basic (Declaration)
Public ReadOnly Property CalculatedFields As CalculatedFieldCollection

See Also

DataSource Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
DataSource..::.Name Property
DataSource Class See Also Send Feedback
Gets or sets the name of the DataSource component.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

The name of the DataSource component.

See Also

DataSource Class
Telerik.Reporting Namespace


DataSourceParameter Class

[image]

Telerik Reporting Q2 2012
DataSourceParameter Class
Members See Also Send Feedback
Represents a parameter in a DataSource component.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class DataSourceParameter : INotifyPropertyChanged
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class DataSourceParameter _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.DataSourceParameter
Telerik.Reporting..::.CubeDataSourceParameter
Telerik.Reporting..::.ObjectDataSourceParameter
Telerik.Reporting..::.SqlDataSourceParameter

See Also

DataSourceParameter Members
Telerik.Reporting Namespace


DataSourceParameter Members

[image] [image]

Telerik Reporting Q2 2012
DataSourceParameter Members
DataSourceParameter Class Constructors Methods Properties Events See Also Send Feedback

The DataSourceParameter type exposes the following members.

Constructors

Name | Description
DataSourceParameter | Overloaded.

Methods

Name | Description
NotifyPropertyChanged |

Properties

Name | Description
Name | Gets or sets the name of the parameter.
Value | Gets or sets the value of the parameter.

Events

Name | Description
PropertyChanged |

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


DataSourceParameter Constructor

[image] [image]

Telerik Reporting Q2 2012
DataSourceParameter Constructor
DataSourceParameter Class See Also Send Feedback

Overload List

Name | Description
DataSourceParameter()()() | Initializes a new instance of the DataSourceParameter class.
DataSourceParameter(String) | Initializes a new instance of the DataSourceParameter class.
DataSourceParameter(String, Object) | Initializes a new instance of the DataSourceParameter class.

See Also

DataSourceParameter Class
DataSourceParameter Members
Telerik.Reporting Namespace


DataSourceParameter Constructor

[image]

Telerik Reporting Q2 2012
DataSourceParameter Constructor
DataSourceParameter Class See Also Send Feedback
Initializes a new instance of the DataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSourceParameter()
Visual Basic (Declaration)
Public Sub New

See Also

DataSourceParameter Class
DataSourceParameter Overload
Telerik.Reporting Namespace


DataSourceParameter Constructor (String)

[image]

Telerik Reporting Q2 2012
DataSourceParameter Constructor (String)
DataSourceParameter Class See Also Send Feedback
Initializes a new instance of the DataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSourceParameter(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.

See Also

DataSourceParameter Class
DataSourceParameter Overload
Telerik.Reporting Namespace


DataSourceParameter Constructor (String, Object)

[image]

Telerik Reporting Q2 2012
DataSourceParameter Constructor (String, Object)
DataSourceParameter Class See Also Send Feedback
Initializes a new instance of the DataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSourceParameter(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
value
Type: System..::.Object
Specifies the value of the parameter.

See Also

DataSourceParameter Class
DataSourceParameter Overload
Telerik.Reporting Namespace


DataSourceParameter Methods

[image] [image]

Telerik Reporting Q2 2012
DataSourceParameter Methods
DataSourceParameter Class See Also Send Feedback

The DataSourceParameter type exposes the following members.

Methods

Name | Description
NotifyPropertyChanged |

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


NotifyPropertyChanged Method

[image]

Telerik Reporting Q2 2012
DataSourceParameter..::.NotifyPropertyChanged Method
DataSourceParameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void NotifyPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Sub NotifyPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::.String

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


DataSourceParameter Properties

[image] [image]

Telerik Reporting Q2 2012
DataSourceParameter Properties
DataSourceParameter Class See Also Send Feedback

The DataSourceParameter type exposes the following members.

Properties

Name | Description
Name | Gets or sets the name of the parameter.
Value | Gets or sets the value of the parameter.

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
DataSourceParameter..::.Name Property
DataSourceParameter Class See Also Send Feedback
Gets or sets the name of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
DataSourceParameter..::.Value Property
DataSourceParameter Class See Also Send Feedback
Gets or sets the value of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


DataSourceParameter Events

[image] [image]

Telerik Reporting Q2 2012
DataSourceParameter Events
DataSourceParameter Class See Also Send Feedback

The DataSourceParameter type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
DataSourceParameter..::.PropertyChanged Event
DataSourceParameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DataSourceParameter Class
Telerik.Reporting Namespace


DetailSection Class

[image]

Telerik Reporting Q2 2012
DetailSection Class
Members See Also Send Feedback
Represents the main section of a Report. It is printed once for every record in the data source of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DetailSection : ReportSection
Visual Basic (Declaration)
Public Class DetailSection _
    Inherits ReportSection

Remarks

The Detail section appears below PageHeaderSection and ReportHeaderSection sections and above PageFooterSection and ReportFooterSection sections.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.DetailSection

See Also

DetailSection Members
Telerik.Reporting Namespace


DetailSection Members

[image] [image]

Telerik Reporting Q2 2012
DetailSection Members
DetailSection Class Constructors Methods Properties Events See Also Send Feedback

The DetailSection type exposes the following members.

Constructors

Name | Description
DetailSection | Initializes a new instance of the DetailSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ColumnCount | Gets or sets a value that specifies how many columns are present in the DetailSection of the report.
ColumnSpacing | Gets or sets a value indicating the space in Units between two adjacent columns.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

DetailSection Class
Telerik.Reporting Namespace


DetailSection Constructor

[image]

Telerik Reporting Q2 2012
DetailSection Constructor
DetailSection Class See Also Send Feedback
Initializes a new instance of the DetailSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DetailSection()
Visual Basic (Declaration)
Public Sub New

See Also

DetailSection Class
Telerik.Reporting Namespace


DetailSection Methods

[image] [image]

Telerik Reporting Q2 2012
DetailSection Methods
DetailSection Class See Also Send Feedback

The DetailSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

DetailSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DetailSection..::.Dispose Method
DetailSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

DetailSection Class
DetailSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
DetailSection..::.ToString Method
DetailSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

DetailSection Class
DetailSection Members
Telerik.Reporting Namespace


DetailSection Properties

[image] [image]

Telerik Reporting Q2 2012
DetailSection Properties
DetailSection Class See Also Send Feedback

The DetailSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ColumnCount | Gets or sets a value that specifies how many columns are present in the DetailSection of the report.
ColumnSpacing | Gets or sets a value indicating the space in Units between two adjacent columns.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

DetailSection Class
Telerik.Reporting Namespace


ColumnCount Property

[image]

Telerik Reporting Q2 2012
DetailSection..::.ColumnCount Property
DetailSection Class See Also Send Feedback
Gets or sets a value that specifies how many columns are present in the DetailSection of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ColumnCount { get; set; }
Visual Basic (Declaration)
Public Property ColumnCount As Integer

Field Value

An integer value specifying the number of columns. The value should be equal to or greater than 1. The default is 1.

Remarks

Column widths are calculated based on the following rule: DetailWidth = ColumnWidth * ColumnCount + ColumSpacing * (ColumnCount - 1)

Multi-column reports are primarily used for printing labels.

See Also

DetailSection Class
Telerik.Reporting Namespace


ColumnSpacing Property

[image]

Telerik Reporting Q2 2012
DetailSection..::.ColumnSpacing Property
DetailSection Class See Also Send Feedback
Gets or sets a value indicating the space in Units between two adjacent columns.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit ColumnSpacing { get; set; }
Visual Basic (Declaration)
Public Property ColumnSpacing As Unit

Field Value

A Unit value specifying the space between two adjacent columns. The value should be a non-negative Unit. The default is Zero

Remarks

This property should be used when there should be some blank space left between adjacent columns.

See Also

DetailSection Class
Telerik.Reporting Namespace


DetailSection Events

[image] [image]

Telerik Reporting Q2 2012
DetailSection Events
DetailSection Class See Also Send Feedback

The DetailSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

DetailSection Class
Telerik.Reporting Namespace


DockingStyle Enumeration

[image]

Telerik Reporting Q2 2012
DockingStyle Enumeration
See Also Send Feedback
Specifies how a ReportItem docks to the edges of its container.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum DockingStyle
Visual Basic (Declaration)
Public Enumeration DockingStyle

Members

Member name | Description
None | The ReportItem is not docked to any edge of its container.
Top | The ReportItem is docked to the top edge of its container.
Bottom | The ReportItem is docked to the bottom edge of its container.
Left | The ReportItem is docked to the left edge of its container.
Right | The ReportItem is docked to the right edge of its container.
Fill | The ReportItem is docked to the all edges of its container.

See Also

Telerik.Reporting Namespace


EntityDataSource Class

[image]

Telerik Reporting Q2 2012
EntityDataSource Class
Members See Also Send Feedback
Represents an Entity data model to data items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class EntityDataSource : ObjectDataSourceBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EntityDataSource _
    Inherits ObjectDataSourceBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.ObjectDataSourceBase
Telerik.Reporting..::.EntityDataSource

See Also

EntityDataSource Members
Telerik.Reporting Namespace


EntityDataSource Members

[image] [image]

Telerik Reporting Q2 2012
EntityDataSource Members
EntityDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The EntityDataSource type exposes the following members.

Constructors

Name | Description
EntityDataSource | Overloaded.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
ObjectContext | Gets or sets the object context used to connect to data.
ObjectContextMember | Gets or sets the object context member used to connect to data.
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

EntityDataSource Class
Telerik.Reporting Namespace


EntityDataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
EntityDataSource Constructor
EntityDataSource Class See Also Send Feedback

Overload List

Name | Description
EntityDataSource()()() | Initializes a new instance of the EntityDataSource class.
EntityDataSource(Object, String) | Initializes a new instance of the EntityDataSource class.
EntityDataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the EntityDataSource class
EntityDataSource(String, Object, String) | Initializes a new instance of the EntityDataSource class.

See Also

EntityDataSource Class
EntityDataSource Members
Telerik.Reporting Namespace


EntityDataSource Constructor

[image]

Telerik Reporting Q2 2012
EntityDataSource Constructor
EntityDataSource Class See Also Send Feedback
Initializes a new instance of the EntityDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EntityDataSource()
Visual Basic (Declaration)
Public Sub New

See Also

EntityDataSource Class
EntityDataSource Overload
Telerik.Reporting Namespace


EntityDataSource Constructor (Object, String)

[image]

Telerik Reporting Q2 2012
EntityDataSource Constructor (Object, String)
EntityDataSource Class See Also Send Feedback
Initializes a new instance of the EntityDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EntityDataSource(
    Object objectContext,
    string objectContextMember
)
Visual Basic (Declaration)
Public Sub New ( _
    objectContext As Object, _
    objectContextMember As String _
)

Parameters

objectContext
Type: System..::.Object
Specifies the object context used to connect to data.
objectContextMember
Type: System..::.String
Specifies the object context member used to connect to data.

See Also

EntityDataSource Class
EntityDataSource Overload
Telerik.Reporting Namespace


EntityDataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
EntityDataSource Constructor (SerializationInfo, StreamingContext)
EntityDataSource Class See Also Send Feedback
Initializes a new instance of the EntityDataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected EntityDataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

EntityDataSource Class
EntityDataSource Overload
Telerik.Reporting Namespace


EntityDataSource Constructor (String, Object, String)

[image]

Telerik Reporting Q2 2012
EntityDataSource Constructor (String, Object, String)
EntityDataSource Class See Also Send Feedback
Initializes a new instance of the EntityDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EntityDataSource(
    string connectionString,
    Object objectContext,
    string objectContextMember
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String, _
    objectContext As Object, _
    objectContextMember As String _
)

Parameters

connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
objectContext
Type: System..::.Object
Specifies the object context used to connect to data.
objectContextMember
Type: System..::.String
Specifies the object context member used to connect to data.

See Also

EntityDataSource Class
EntityDataSource Overload
Telerik.Reporting Namespace


EntityDataSource Methods

[image] [image]

Telerik Reporting Q2 2012
EntityDataSource Methods
EntityDataSource Class See Also Send Feedback

The EntityDataSource type exposes the following members.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

EntityDataSource Class
Telerik.Reporting Namespace


GetDataMember Method

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.GetDataMember Method
EntityDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override string GetDataMember()
Visual Basic (Declaration)
Protected Overrides Function GetDataMember As String

See Also

EntityDataSource Class
Telerik.Reporting Namespace


GetDataSource Method

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.GetDataSource Method
EntityDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object GetDataSource()
Visual Basic (Declaration)
Protected Overrides Function GetDataSource As Object

See Also

EntityDataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.GetObjectData Method
EntityDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

EntityDataSource Class
Telerik.Reporting Namespace


EntityDataSource Properties

[image] [image]

Telerik Reporting Q2 2012
EntityDataSource Properties
EntityDataSource Class See Also Send Feedback

The EntityDataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
ObjectContext | Gets or sets the object context used to connect to data.
ObjectContextMember | Gets or sets the object context member used to connect to data.
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)

See Also

EntityDataSource Class
Telerik.Reporting Namespace


ConnectionString Property

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.ConnectionString Property
EntityDataSource Class See Also Send Feedback
Gets or sets the connection string used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String

Remarks

The ConnectionString property contains either a valid connection string or the name of a [!:ConnectionStringSettings] in the application configuration file.

See Also

EntityDataSource Class
Telerik.Reporting Namespace


ObjectContext Property

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.ObjectContext Property
EntityDataSource Class See Also Send Feedback
Gets or sets the object context used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object ObjectContext { get; set; }
Visual Basic (Declaration)
Public Property ObjectContext As Object

Remarks

The ObjectContext property can contain either an instance of an object context or the Type of such a context to be created at run time.

See Also

EntityDataSource Class
Telerik.Reporting Namespace


ObjectContextMember Property

[image]

Telerik Reporting Q2 2012
EntityDataSource..::.ObjectContextMember Property
EntityDataSource Class See Also Send Feedback
Gets or sets the object context member used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ObjectContextMember { get; set; }
Visual Basic (Declaration)
Public Property ObjectContextMember As String

Remarks

The ObjectContextMember property contains the name of a property or a method of the object context to be invoked during data retrieval.

See Also

EntityDataSource Class
Telerik.Reporting Namespace


ErrorEventArgs Class

[image]

Telerik Reporting Q2 2012
ErrorEventArgs Class
Members See Also Send Feedback
Provides a data for the Error event of a Report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ErrorEventArgs : CancelEventArgs
Visual Basic (Declaration)
Public Class ErrorEventArgs _
    Inherits CancelEventArgs

Remarks

A ErrorEventArgs object is passed to the event handler, which allows you to determine the current exception that has occurred during the report processing and to indicate that the report operation should be canceled. To cancel the report operation, set the [!:ErrorEventArgs.Cancel] property to True.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
Telerik.Reporting..::.ErrorEventArgs

See Also

ErrorEventArgs Members
Telerik.Reporting Namespace


ErrorEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ErrorEventArgs Members
ErrorEventArgs Class Properties See Also Send Feedback

The ErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets the current exception.

See Also

ErrorEventArgs Class
Telerik.Reporting Namespace


ErrorEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ErrorEventArgs Properties
ErrorEventArgs Class See Also Send Feedback

The ErrorEventArgs type exposes the following members.

Properties

Name | Description
Exception | Gets the current exception.

See Also

ErrorEventArgs Class
Telerik.Reporting Namespace


Exception Property

[image]

Telerik Reporting Q2 2012
ErrorEventArgs..::.Exception Property
ErrorEventArgs Class See Also Send Feedback
Gets the current exception.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Exception Exception { get; }
Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception

See Also

ErrorEventArgs Class
Telerik.Reporting Namespace


ErrorEventHandler Delegate

[image]

Telerik Reporting Q2 2012
ErrorEventHandler Delegate
See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate void ErrorEventHandler(
    Object sender,
    ErrorEventArgs eventArgs
)
Visual Basic (Declaration)
Public Delegate Sub ErrorEventHandler ( _
    sender As Object, _
    eventArgs As ErrorEventArgs _
)

Parameters

sender
Type: System..::.Object
eventArgs
Type: Telerik.Reporting..::.ErrorEventArgs

See Also

Telerik.Reporting Namespace


Filter Class

[image]

Telerik Reporting Q2 2012
Filter Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Filter : ICloneable, INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Filter _
    Implements ICloneable, INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Filter
Telerik.Reporting.Data..::.Filter

See Also

Filter Members
Telerik.Reporting Namespace


Filter Members

[image] [image]

Telerik Reporting Q2 2012
Filter Members
Filter Class Constructors Methods Properties Events See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | Overloaded.

Methods

Name | Description
Clone |
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Expression |
Operator |
Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.

Events

Name | Description
PropertyChanged |

See Also

Filter Class
Telerik.Reporting Namespace


Filter Constructor

[image] [image]

Telerik Reporting Q2 2012
Filter Constructor
Filter Class See Also Send Feedback

Overload List

Name | Description
Filter()()() | Initializes a new instance of the Filter class
Filter(String, FilterOperator, String) | Initializes a new instance of the Filter class

See Also

Filter Class
Filter Members
Telerik.Reporting Namespace


Filter Constructor

[image]

Telerik Reporting Q2 2012
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New

See Also

Filter Class
Filter Overload
Telerik.Reporting Namespace


Filter Constructor (String, FilterOperator, String)

[image]

Telerik Reporting Q2 2012
Filter Constructor (String, FilterOperator, String)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Filter(
    string expression,
    FilterOperator operator,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    operator As FilterOperator, _
    value As String _
)

Parameters

expression
Type: System..::.String
operator
Type: Telerik.Reporting..::.FilterOperator
value
Type: System..::.String

See Also

Filter Class
Filter Overload
Telerik.Reporting Namespace


Filter Methods

[image] [image]

Telerik Reporting Q2 2012
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
Clone |
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

See Also

Filter Class
Telerik.Reporting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Filter..::.Clone Method
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

Filter Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Filter..::.GetHashCode Method
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

Filter Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Filter..::.ToString Method
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Filter Class
Telerik.Reporting Namespace


Filter Properties

[image] [image]

Telerik Reporting Q2 2012
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

Name | Description
Expression |
Operator |
Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.

See Also

Filter Class
Telerik.Reporting Namespace


Expression Property

[image]

Telerik Reporting Q2 2012
Filter..::.Expression Property
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

Filter Class
Telerik.Reporting Namespace


Operator Property

[image]

Telerik Reporting Q2 2012
Filter..::.Operator Property
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterOperator Operator { get; set; }
Visual Basic (Declaration)
Public Property Operator As FilterOperator

See Also

Filter Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Filter..::.Value Property
Filter Class See Also Send Feedback
If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String

See Also

Filter Class
Telerik.Reporting Namespace


Filter Events

[image] [image]

Telerik Reporting Q2 2012
Filter Events
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Filter Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Filter..::.PropertyChanged Event
Filter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Filter Class
Telerik.Reporting Namespace


FilterCollection Class

[image]

Telerik Reporting Q2 2012
FilterCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FilterCollection : Collection<Filter>
Visual Basic (Declaration)
Public Class FilterCollection _
    Inherits Collection(Of Filter)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Filter >)>)>
Telerik.Reporting..::.FilterCollection

See Also

FilterCollection Members
Telerik.Reporting Namespace


FilterCollection Members

[image] [image]

Telerik Reporting Q2 2012
FilterCollection Members
FilterCollection Class Constructors Methods See Also Send Feedback

The FilterCollection type exposes the following members.

Constructors

Name | Description
FilterCollection | Initializes a new instance of the FilterCollection class

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

FilterCollection Class
Telerik.Reporting Namespace


FilterCollection Constructor

[image]

Telerik Reporting Q2 2012
FilterCollection Constructor
FilterCollection Class See Also Send Feedback
Initializes a new instance of the FilterCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

FilterCollection Class
Telerik.Reporting Namespace


FilterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
FilterCollection Methods
FilterCollection Class See Also Send Feedback

The FilterCollection type exposes the following members.

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

FilterCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
FilterCollection..::.Add Method
FilterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string expression,
    FilterOperator op,
    string value
)
Visual Basic (Declaration)
Public Sub Add ( _
    expression As String, _
    op As FilterOperator, _
    value As String _
)

Parameters

expression
Type: System..::.String
op
Type: Telerik.Reporting..::.FilterOperator
value
Type: System..::.String

See Also

FilterCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
FilterCollection..::.AddRange Method
FilterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    Filter[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As Filter() _
)

Parameters

items
Type: array< Telerik.Reporting..::.Filter >[]()[][]

See Also

FilterCollection Class
Telerik.Reporting Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
FilterCollection..::.InsertItem Method
FilterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Filter item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Filter _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting..::.Filter

See Also

FilterCollection Class
Telerik.Reporting Namespace


FilterOperator Enumeration

[image]

Telerik Reporting Q2 2012
FilterOperator Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum FilterOperator
Visual Basic (Declaration)
Public Enumeration FilterOperator

Members

Member name | Description
Equal |
NotEqual |
GreaterThan |
GreaterOrEqual |
LessThan |
LessOrEqual |
TopN |
BottomN |
TopPercent |
BottomPercent |
In |
Like |
NotLike |

See Also

Telerik.Reporting Namespace


Group Class

[image]

Telerik Reporting Q2 2012
Group Class
Members See Also Send Feedback
Represents a class that defines a report group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Group : Component, IToggleVisibilityTarget
Visual Basic (Declaration)
Public Class Group _
    Inherits Component _
    Implements IToggleVisibilityTarget

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.Group

See Also

Group Members
Telerik.Reporting Namespace


Group Members

[image] [image]

Telerik Reporting Q2 2012
Group Members
Group Class Constructors Properties See Also Send Feedback

The Group type exposes the following members.

Constructors

Name | Description
Group | Overloaded.

Properties

Name | Description
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this group.
BookmarkId | Gets or sets a bookmark id for this group.
DocumentMapText | Gets or sets a text to be displayed for this group in the document map.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Group
GroupFooter | Gets a GroupFooterSection representing the group's footer section.
GroupHeader | Gets a GroupHeaderSection representing the group's header section.
Grouping | Obsolete.
Groupings | Gets a [!:Telerik.Reporting.Data.GroupingCollection] object that holds all Grouping objects for the group.
GroupKeepTogether | Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
Name | Gets or sets the name of the report group.
Report | Gets a Report representing the group's owner report.
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Group
Visible | Gets or sets a value indicating whether the group is displayed.

See Also

Group Class
Telerik.Reporting Namespace


Group Constructor

[image] [image]

Telerik Reporting Q2 2012
Group Constructor
Group Class See Also Send Feedback

Overload List

Name | Description
Group()()() | Initializes a new instance of the Group class with default settings.
Group(Boolean) | Initializes a new instance of the Group class with the specified group header/footer creation option.

See Also

Group Class
Group Members
Telerik.Reporting Namespace


Group Constructor

[image]

Telerik Reporting Q2 2012
Group Constructor
Group Class See Also Send Feedback
Initializes a new instance of the Group class with default settings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Group()
Visual Basic (Declaration)
Public Sub New

See Also

Group Class
Group Overload
Telerik.Reporting Namespace


Group Constructor (Boolean)

[image]

Telerik Reporting Q2 2012
Group Constructor (Boolean)
Group Class See Also Send Feedback
Initializes a new instance of the Group class with the specified group header/footer creation option.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Group(
    bool createHeaderFooter
)
Visual Basic (Declaration)
Public Sub New ( _
    createHeaderFooter As Boolean _
)

Parameters

createHeaderFooter
Type: System..::.Boolean
true to create a GroupHeaderSection and a GroupFooterSection; otherwise, false.

See Also

Group Class
Group Overload
Telerik.Reporting Namespace


Group Properties

[image] [image]

Telerik Reporting Q2 2012
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

Name | Description
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this group.
BookmarkId | Gets or sets a bookmark id for this group.
DocumentMapText | Gets or sets a text to be displayed for this group in the document map.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Group
GroupFooter | Gets a GroupFooterSection representing the group's footer section.
GroupHeader | Gets a GroupHeaderSection representing the group's header section.
Grouping | Obsolete.
Groupings | Gets a [!:Telerik.Reporting.Data.GroupingCollection] object that holds all Grouping objects for the group.
GroupKeepTogether | Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.
Name | Gets or sets the name of the report group.
Report | Gets a Report representing the group's owner report.
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Group
Visible | Gets or sets a value indicating whether the group is displayed.

See Also

Group Class
Telerik.Reporting Namespace


Bookmark Property

[image]

Telerik Reporting Q2 2012
Group..::.Bookmark Property
Group Class See Also Send Feedback
Gets or sets a bookmark label to be displayed for this group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")]
public string Bookmark { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")> _
Public Property Bookmark As String

Field Value

A string / expression value specifying the bookmark label.

See Also

Group Class
Telerik.Reporting Namespace


BookmarkId Property

[image]

Telerik Reporting Q2 2012
Group..::.BookmarkId Property
Group Class See Also Send Feedback
Gets or sets a bookmark id for this group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string BookmarkId { get; set; }
Visual Basic (Declaration)
Public Property BookmarkId As String

Field Value

A string / expression value specifying the bookmark id. When processed should evaluate to an unique value for each processing instance of the group.

See Also

Group Class
Telerik.Reporting Namespace


DocumentMapText Property

[image]

Telerik Reporting Q2 2012
Group..::.DocumentMapText Property
Group Class See Also Send Feedback
Gets or sets a text to be displayed for this group in the document map.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentMapText { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapText As String

Field Value

A string / expression value specifying the document map text.

Remarks

When defined the document map displays nodes that navigate to the instances of the group.

See Also

Group Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
Group..::.Filters Property
Group Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Group

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

Field Value

A [!:Telerik.Reporting.Data.FilterCollection] that contains the Filter objects for the Group

Remarks

Filter expressions limit the data that is displayed in the Group

See Also

Group Class
Telerik.Reporting Namespace


GroupFooter Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupFooter Property
Group Class See Also Send Feedback
Gets a GroupFooterSection representing the group's footer section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupFooterSection GroupFooter { get; set; }
Visual Basic (Declaration)
Public Property GroupFooter As GroupFooterSection

Field Value

A GroupFooterSection value that represents the group footer section of the Group.

Remarks

The Group footer section is rendered after the detail sections of the Group.

See Also

Group Class
Telerik.Reporting Namespace


GroupHeader Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupHeader Property
Group Class See Also Send Feedback
Gets a GroupHeaderSection representing the group's header section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupHeaderSection GroupHeader { get; set; }
Visual Basic (Declaration)
Public Property GroupHeader As GroupHeaderSection

Field Value

A GroupHeaderSection value that reporesents the group header section of the Group.

Remarks

The Group header section is rendered before the detail sections of the Group. Typically, this section will contain report items that are bound to the data fields of the Group's grouping expressions.

See Also

Group Class
Telerik.Reporting Namespace


Grouping Property

[image]

Telerik Reporting Q2 2012
Group..::.Grouping Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Groupings property instead.")]
public GroupingCollection Grouping { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Groupings property instead.")> _
Public ReadOnly Property Grouping As GroupingCollection

See Also

Group Class
Telerik.Reporting Namespace


Groupings Property

[image]

Telerik Reporting Q2 2012
Group..::.Groupings Property
Group Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.GroupingCollection] object that holds all Grouping objects for the group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupingCollection Groupings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groupings As GroupingCollection

Field Value

A [!:Telerik.Reporting.Data.GroupingCollection] value containing the group expressions of the group.

Remarks

Groups are defined by adding one or more group expressions to the collection. Grouping can be done by one or more data fields. Each data field is represented by a group expression in the collection.

See Also

Group Class
Telerik.Reporting Namespace


GroupKeepTogether Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupKeepTogether Property
Group Class See Also Send Feedback
Set to FirstDetail to ensure that the group header and the first detail record are printed on the same page of output, or All to ensure that the entire group is printed on the same page of output. If there is not enough space on the current page, then rendering will skip to the top of the next page.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupKeepTogether GroupKeepTogether { get; set; }
Visual Basic (Declaration)
Public Property GroupKeepTogether As GroupKeepTogether

See Also

Group Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Group..::.Name Property
Group Class See Also Send Feedback
Gets or sets the name of the report group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

The name of the report group.

Implements

IToggleVisibilityTarget..::.Name

Remarks

The Name property can be used at run time to set the scope of aggregate functions.

See Also

Group Class
Telerik.Reporting Namespace


Report Property

[image]

Telerik Reporting Q2 2012
Group..::.Report Property
Group Class See Also Send Feedback
Gets a Report representing the group's owner report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Report Report { get; internal set; }
Visual Basic (Declaration)
Public Property Report As Report

Field Value

A Report value that reporesents the owner report of the Group.

See Also

Group Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
Group..::.Sorting Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

Group Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
Group..::.Sortings Property
Group Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Group

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

Field Value

A [!:Telerik.Reporting.Data.SortingCollection] that contains the Sorting objects for the Group

Remarks

Sort expressions sort the data that is displayed in the Group

See Also

Group Class
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
Group..::.Visible Property
Group Class See Also Send Feedback
Gets or sets a value indicating whether the group is displayed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Field Value

true if the group is displayed; otherwise, false. The default is true.

See Also

Group Class
Telerik.Reporting Namespace


GroupCollection Class

[image]

Telerik Reporting Q2 2012
GroupCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GroupCollection : Collection<Group>
Visual Basic (Declaration)
Public Class GroupCollection _
    Inherits Collection(Of Group)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Group >)>)>
Telerik.Reporting..::.GroupCollection

See Also

GroupCollection Members
Telerik.Reporting Namespace


GroupCollection Members

[image] [image]

Telerik Reporting Q2 2012
GroupCollection Members
GroupCollection Class Constructors Methods See Also Send Feedback

The GroupCollection type exposes the following members.

Constructors

Name | Description
GroupCollection | Initializes a new instance of the GroupCollection class

Methods

Name | Description
AddRange |

See Also

GroupCollection Class
Telerik.Reporting Namespace


GroupCollection Constructor

[image]

Telerik Reporting Q2 2012
GroupCollection Constructor
GroupCollection Class See Also Send Feedback
Initializes a new instance of the GroupCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupCollection()
Visual Basic (Declaration)
Public Sub New

See Also

GroupCollection Class
Telerik.Reporting Namespace


GroupCollection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupCollection Methods
GroupCollection Class See Also Send Feedback

The GroupCollection type exposes the following members.

Methods

Name | Description
AddRange |

See Also

GroupCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
GroupCollection..::.AddRange Method
GroupCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    Group[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As Group() _
)

Parameters

items
Type: array< Telerik.Reporting..::.Group >[]()[][]

See Also

GroupCollection Class
Telerik.Reporting Namespace


GroupFooterSection Class

[image]

Telerik Reporting Q2 2012
GroupFooterSection Class
Members See Also Send Feedback
Represents a group footer section. Group footers are displayed at the end of a group. Group headers and footers are unified by the Group class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GroupFooterSection : GroupSection
Visual Basic (Declaration)
Public Class GroupFooterSection _
    Inherits GroupSection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.GroupSection
Telerik.Reporting..::.GroupFooterSection

See Also

GroupFooterSection Members
Telerik.Reporting Namespace


GroupFooterSection Members

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection Members
GroupFooterSection Class Constructors Methods Properties Events See Also Send Feedback

The GroupFooterSection type exposes the following members.

Constructors

Name | Description
GroupFooterSection | Initializes a new instance of the GroupFooterSection class.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section. (Inherited from GroupSection.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Constructor

[image]

Telerik Reporting Q2 2012
GroupFooterSection Constructor
GroupFooterSection Class See Also Send Feedback
Initializes a new instance of the GroupFooterSection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupFooterSection()
Visual Basic (Declaration)
Public Sub New

See Also

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection Methods
GroupFooterSection Class See Also Send Feedback

The GroupFooterSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

GroupFooterSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection..::.Dispose Method
GroupFooterSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

GroupFooterSection Class
GroupFooterSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection..::.ToString Method
GroupFooterSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

GroupFooterSection Class
GroupFooterSection Members
Telerik.Reporting Namespace


GroupFooterSection Properties

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection Properties
GroupFooterSection Class See Also Send Feedback

The GroupFooterSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section. (Inherited from GroupSection.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

GroupFooterSection Class
Telerik.Reporting Namespace


GroupFooterSection Events

[image] [image]

Telerik Reporting Q2 2012
GroupFooterSection Events
GroupFooterSection Class See Also Send Feedback

The GroupFooterSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupFooterSection Class
Telerik.Reporting Namespace


GroupHeaderSection Class

[image]

Telerik Reporting Q2 2012
GroupHeaderSection Class
Members See Also Send Feedback
Represents a group header section. Group headers are displayed at the beginning of a group. Group headers and footers are unified by the Group class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GroupHeaderSection : GroupSection
Visual Basic (Declaration)
Public Class GroupHeaderSection _
    Inherits GroupSection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.GroupSection
Telerik.Reporting..::.GroupHeaderSection

See Also

GroupHeaderSection Members
Telerik.Reporting Namespace


GroupHeaderSection Members

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection Members
GroupHeaderSection Class Constructors Methods Properties Events See Also Send Feedback

The GroupHeaderSection type exposes the following members.

Constructors

Name | Description
GroupHeaderSection | Initializes a new instance of the GroupHeaderSection class.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section. (Inherited from GroupSection.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Constructor

[image]

Telerik Reporting Q2 2012
GroupHeaderSection Constructor
GroupHeaderSection Class See Also Send Feedback
Initializes a new instance of the GroupHeaderSection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupHeaderSection()
Visual Basic (Declaration)
Public Sub New

See Also

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection Methods
GroupHeaderSection Class See Also Send Feedback

The GroupHeaderSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

GroupHeaderSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection..::.Dispose Method
GroupHeaderSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

GroupHeaderSection Class
GroupHeaderSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection..::.ToString Method
GroupHeaderSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

GroupHeaderSection Class
GroupHeaderSection Members
Telerik.Reporting Namespace


GroupHeaderSection Properties

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection Properties
GroupHeaderSection Class See Also Send Feedback

The GroupHeaderSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section. (Inherited from GroupSection.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies. (Inherited from GroupSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

GroupHeaderSection Class
Telerik.Reporting Namespace


GroupHeaderSection Events

[image] [image]

Telerik Reporting Q2 2012
GroupHeaderSection Events
GroupHeaderSection Class See Also Send Feedback

The GroupHeaderSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupHeaderSection Class
Telerik.Reporting Namespace


Grouping Class

[image]

Telerik Reporting Q2 2012
Grouping Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Grouping : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Grouping _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Grouping
Telerik.Reporting.Data..::.Grouping

See Also

Grouping Members
Telerik.Reporting Namespace


Grouping Members

[image] [image]

Telerik Reporting Q2 2012
Grouping Members
Grouping Class Constructors Methods Properties Events See Also Send Feedback

The Grouping type exposes the following members.

Constructors

Name | Description
Grouping | Overloaded.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Expression |
IsEmpty |

Events

Name | Description
PropertyChanged |

See Also

Grouping Class
Telerik.Reporting Namespace


Grouping Constructor

[image] [image]

Telerik Reporting Q2 2012
Grouping Constructor
Grouping Class See Also Send Feedback

Overload List

Name | Description
Grouping()()() | Initializes a new instance of the Grouping class
Grouping(String) | Initializes a new instance of the Grouping class

See Also

Grouping Class
Grouping Members
Telerik.Reporting Namespace


Grouping Constructor

[image]

Telerik Reporting Q2 2012
Grouping Constructor
Grouping Class See Also Send Feedback
Initializes a new instance of the Grouping class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Grouping()
Visual Basic (Declaration)
Public Sub New

See Also

Grouping Class
Grouping Overload
Telerik.Reporting Namespace


Grouping Constructor (String)

[image]

Telerik Reporting Q2 2012
Grouping Constructor (String)
Grouping Class See Also Send Feedback
Initializes a new instance of the Grouping class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Grouping(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)

Parameters

expression
Type: System..::.String

See Also

Grouping Class
Grouping Overload
Telerik.Reporting Namespace


Grouping Methods

[image] [image]

Telerik Reporting Q2 2012
Grouping Methods
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

Grouping Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Grouping..::.ToString Method
Grouping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Grouping Class
Telerik.Reporting Namespace


Grouping Properties

[image] [image]

Telerik Reporting Q2 2012
Grouping Properties
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Properties

Name | Description
Expression |
IsEmpty |

See Also

Grouping Class
Telerik.Reporting Namespace


Expression Property

[image]

Telerik Reporting Q2 2012
Grouping..::.Expression Property
Grouping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

Grouping Class
Telerik.Reporting Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
Grouping..::.IsEmpty Property
Grouping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

See Also

Grouping Class
Telerik.Reporting Namespace


Grouping Events

[image] [image]

Telerik Reporting Q2 2012
Grouping Events
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Grouping Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Grouping..::.PropertyChanged Event
Grouping Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Grouping Class
Telerik.Reporting Namespace


GroupingCollection Class

[image]

Telerik Reporting Q2 2012
GroupingCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GroupingCollection : Collection<Grouping>
Visual Basic (Declaration)
Public Class GroupingCollection _
    Inherits Collection(Of Grouping)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Grouping >)>)>
Telerik.Reporting..::.GroupingCollection

See Also

GroupingCollection Members
Telerik.Reporting Namespace


GroupingCollection Members

[image] [image]

Telerik Reporting Q2 2012
GroupingCollection Members
GroupingCollection Class Constructors Methods See Also Send Feedback

The GroupingCollection type exposes the following members.

Constructors

Name | Description
GroupingCollection | Initializes a new instance of the GroupingCollection class

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

GroupingCollection Class
Telerik.Reporting Namespace


GroupingCollection Constructor

[image]

Telerik Reporting Q2 2012
GroupingCollection Constructor
GroupingCollection Class See Also Send Feedback
Initializes a new instance of the GroupingCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupingCollection()
Visual Basic (Declaration)
Public Sub New

See Also

GroupingCollection Class
Telerik.Reporting Namespace


GroupingCollection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupingCollection Methods
GroupingCollection Class See Also Send Feedback

The GroupingCollection type exposes the following members.

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

GroupingCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
GroupingCollection..::.Add Method
GroupingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string expression
)
Visual Basic (Declaration)
Public Sub Add ( _
    expression As String _
)

Parameters

expression
Type: System..::.String

See Also

GroupingCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
GroupingCollection..::.AddRange Method
GroupingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    Grouping[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As Grouping() _
)

Parameters

items
Type: array< Telerik.Reporting..::.Grouping >[]()[][]

See Also

GroupingCollection Class
Telerik.Reporting Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
GroupingCollection..::.InsertItem Method
GroupingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Grouping item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Grouping _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting..::.Grouping

See Also

GroupingCollection Class
Telerik.Reporting Namespace


GroupKeepTogether Enumeration

[image]

Telerik Reporting Q2 2012
GroupKeepTogether Enumeration
See Also Send Feedback
GroupKeepTogether applies to a group and has similar to the KeepTogether meaning, but for the whole group. It indicates whether the rendering engine should try to render the whole group on a single page, the group header plus the first detail on a single page, or leave the group flow as it is. If GroupKeepTogether is set to FirstDetail -- the group header and at least one detail in this group should be on the same page; if set to All -- the whole group should be on a single page. The following rule applies: the rendering engine will try to render the group as specified, but if there is not enough space on the current page, the group is moved to the next page and it continues as long as it needs.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum GroupKeepTogether
Visual Basic (Declaration)
Public Enumeration GroupKeepTogether

Members

Member name | Description
None | The rendering engine will leave the group flow as it is.
FirstDetail | The rendering engine should try to keep the group header and at least 1 detail on the same page.
All | The rendering engine should try to keep the whole group on the same page.

See Also

Telerik.Reporting Namespace


GroupSection Class

[image]

Telerik Reporting Q2 2012
GroupSection Class
Members See Also Send Feedback
Base abstract class for group sections. GroupHeaderSection and GroupFooterSection inherit from this class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class GroupSection : ReportSection
Visual Basic (Declaration)
Public MustInherit Class GroupSection _
    Inherits ReportSection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.GroupSection
Telerik.Reporting..::.GroupFooterSection
Telerik.Reporting..::.GroupHeaderSection

See Also

GroupSection Members
Telerik.Reporting Namespace


GroupSection Members

[image] [image]

Telerik Reporting Q2 2012
GroupSection Members
GroupSection Class Methods Properties Events See Also Send Feedback

The GroupSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section.
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies.
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupSection Class
Telerik.Reporting Namespace


GroupSection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupSection Methods
GroupSection Class See Also Send Feedback

The GroupSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

GroupSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
GroupSection..::.Dispose Method
GroupSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

GroupSection Class
GroupSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
GroupSection..::.ToString Method
GroupSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

GroupSection Class
GroupSection Members
Telerik.Reporting Namespace


GroupSection Properties

[image] [image]

Telerik Reporting Q2 2012
GroupSection Properties
GroupSection Class See Also Send Feedback

The GroupSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Group | Gets the Group object associated with this section.
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnEveryPage | Indicates whether the section should be printed on every page that the group occupies.
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

GroupSection Class
Telerik.Reporting Namespace


Group Property

[image]

Telerik Reporting Q2 2012
GroupSection..::.Group Property
GroupSection Class See Also Send Feedback
Gets the Group object associated with this section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Group Group { get; internal set; }
Visual Basic (Declaration)
Public Property Group As Group

Field Value

A Group object that this section belong to.

See Also

GroupSection Class
Telerik.Reporting Namespace


PrintOnEveryPage Property

[image]

Telerik Reporting Q2 2012
GroupSection..::.PrintOnEveryPage Property
GroupSection Class See Also Send Feedback
Indicates whether the section should be printed on every page that the group occupies.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnEveryPage As Boolean

Field Value

A boolean value indicating whether the section should be printed on every page that the group occupies.

See Also

GroupSection Class
Telerik.Reporting Namespace


GroupSection Events

[image] [image]

Telerik Reporting Q2 2012
GroupSection Events
GroupSection Class See Also Send Feedback

The GroupSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

GroupSection Class
Telerik.Reporting Namespace


HtmlTextBox Class

[image]

Telerik Reporting Q2 2012
HtmlTextBox Class
Members See Also Send Feedback
Represents a html text box report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class HtmlTextBox : ReportItem
Visual Basic (Declaration)
Public Class HtmlTextBox _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.HtmlTextBox

See Also

HtmlTextBox Members
Telerik.Reporting Namespace


HtmlTextBox Members

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Members
HtmlTextBox Class Constructors Methods Properties Events See Also Send Feedback

The HtmlTextBox type exposes the following members.

Constructors

Name | Description
HtmlTextBox | Initializes a new instance of the HtmlTextBox class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the HtmlTextBox on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current text in the text box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


HtmlTextBox Constructor

[image]

Telerik Reporting Q2 2012
HtmlTextBox Constructor
HtmlTextBox Class See Also Send Feedback
Initializes a new instance of the HtmlTextBox class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public HtmlTextBox()
Visual Basic (Declaration)
Public Sub New

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


HtmlTextBox Methods

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Methods
HtmlTextBox Class See Also Send Feedback

The HtmlTextBox type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox..::.Dispose Method
HtmlTextBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

HtmlTextBox Class
HtmlTextBox Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox..::.ToString Method
HtmlTextBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

HtmlTextBox Class
HtmlTextBox Members
Telerik.Reporting Namespace


HtmlTextBox Properties

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Properties
HtmlTextBox Class See Also Send Feedback

The HtmlTextBox type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the HtmlTextBox on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current text in the text box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


CanGrow Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.CanGrow Property
HtmlTextBox Class See Also Send Feedback
Gets or sets a value indicating whether the Text Item can grow vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean

Field Value

true if the Text Item can grow vertically; otherwise false.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


CanShrink Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.CanShrink Property
HtmlTextBox Class See Also Send Feedback
Gets or sets a value indicating whether the Text Item can shrink vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean

Field Value

true if the Text Item can shrink vertically; otherwise false.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


Culture Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.Culture Property
HtmlTextBox Class See Also Send Feedback
Gets or sets the culture information associated with the Text Item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As CultureInfo

Field Value

A CultureInfo representing the culture supported by the TextItemBase.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.KeepTogether Property
HtmlTextBox Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the HtmlTextBox on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the HtmlTextBox on one page if possible.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.Value Property
HtmlTextBox Class See Also Send Feedback
Gets or sets the current text in the text box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String

Field Value

A String that starts with "=" is interpreted as expression to calculate the value of the current TextBox; otherwise - literal string.

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


HtmlTextBox Events

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Events
HtmlTextBox Class See Also Send Feedback

The HtmlTextBox type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

HtmlTextBox Class
Telerik.Reporting Namespace


IAction Interface

[image]

Telerik Reporting Q2 2012
IAction Interface
See Also Send Feedback
Represents an interactive action associated with a report item.

Namespace: Telerik.Reporting
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public interface IAction
Visual Basic (Declaration)
Public Interface IAction

See Also

Telerik.Reporting Namespace


IExtension Interface

[image]

Telerik Reporting Q2 2012
IExtension Interface
Members See Also Send Feedback
Telerik Reporting extension

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IExtension : IDisposable
Visual Basic (Declaration)
Public Interface IExtension _
    Implements IDisposable

See Also

IExtension Members
Telerik.Reporting Namespace


IExtension Members

[image] [image]

Telerik Reporting Q2 2012
IExtension Members
IExtension Interface Methods See Also Send Feedback

The IExtension type exposes the following members.

Methods

Name | Description
Initialize | Initializes the current extension with default settings

See Also

IExtension Interface
Telerik.Reporting Namespace


IExtension Methods

[image] [image]

Telerik Reporting Q2 2012
IExtension Methods
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Methods

Name | Description
Initialize | Initializes the current extension with default settings

See Also

IExtension Interface
Telerik.Reporting Namespace


Initialize Method

[image]

Telerik Reporting Q2 2012
IExtension..::.Initialize Method
IExtension Interface See Also Send Feedback
Initializes the current extension with default settings

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Initialize(
    Hashtable deviceInfo
)
Visual Basic (Declaration)
Sub Initialize ( _
    deviceInfo As Hashtable _
)

Parameters

deviceInfo
Type: System.Collections..::.Hashtable

See Also

IExtension Interface
Telerik.Reporting Namespace


InstanceReportSource Class

[image]

Telerik Reporting Q2 2012
InstanceReportSource Class
Members Example See Also Send Feedback
Represents a report source that contains a reference to an instance of IReportDocument.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class InstanceReportSource : ReportSource
Visual Basic (Declaration)
Public Class InstanceReportSource _
    Inherits ReportSource

Examples

The following example shows how to create an InstanceReportSource:
CopyC#
Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

// Assigning the Report object to the InstanceReportSource
instanceReportSource.ReportDocument = new Telerik.Reporting.Examples.CSharp.Invoice();

// Adding the initial parameter values
instanceReportSource.Parameters.Add(new Telerik.Reporting.Parameter("OrderNumber", "SO43659"));
CopyVB.NET
Dim instanceReportSource As New Telerik.Reporting.InstanceReportSource()

' Assigning the Report object to the InstanceReportSource
instanceReportSource.ReportDocument = New Invoice()

' Adding the initial parameter values
instanceReportSource.Parameters.Add(New Telerik.Reporting.Parameter("OrderNumber", "SO43659"))

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.InstanceReportSource

See Also

InstanceReportSource Members
Telerik.Reporting Namespace


InstanceReportSource Members

[image] [image]

Telerik Reporting Q2 2012
InstanceReportSource Members
InstanceReportSource Class Constructors Methods Properties See Also Send Feedback

The InstanceReportSource type exposes the following members.

Constructors

Name | Description
InstanceReportSource | Initializes a new instance of the InstanceReportSource class.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
ReportDocument | Gets or sets the IReportDocument instance for the report source.

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


InstanceReportSource Constructor

[image]

Telerik Reporting Q2 2012
InstanceReportSource Constructor
InstanceReportSource Class See Also Send Feedback
Initializes a new instance of the InstanceReportSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public InstanceReportSource()
Visual Basic (Declaration)
Public Sub New

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


InstanceReportSource Methods

[image] [image]

Telerik Reporting Q2 2012
InstanceReportSource Methods
InstanceReportSource Class See Also Send Feedback

The InstanceReportSource type exposes the following members.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
InstanceReportSource..::.Equals Method
InstanceReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
InstanceReportSource..::.GetHashCode Method
InstanceReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
InstanceReportSource..::.ToString Method
InstanceReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


InstanceReportSource Properties

[image] [image]

Telerik Reporting Q2 2012
InstanceReportSource Properties
InstanceReportSource Class See Also Send Feedback

The InstanceReportSource type exposes the following members.

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
ReportDocument | Gets or sets the IReportDocument instance for the report source.

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


ReportDocument Property

[image]

Telerik Reporting Q2 2012
InstanceReportSource..::.ReportDocument Property
InstanceReportSource Class See Also Send Feedback
Gets or sets the IReportDocument instance for the report source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IReportDocument ReportDocument { get; set; }
Visual Basic (Declaration)
Public Property ReportDocument As IReportDocument

See Also

InstanceReportSource Class
Telerik.Reporting Namespace


IReportDocument Interface

[image]

Telerik Reporting Q2 2012
IReportDocument Interface
Members See Also Send Feedback
Represents a report document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IReportDocument : IComponent,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportDocument _
    Implements IComponent, IDisposable

See Also

IReportDocument Members
Telerik.Reporting Namespace


IReportDocument Members

[image] [image]

Telerik Reporting Q2 2012
IReportDocument Members
IReportDocument Interface Properties See Also Send Feedback

The IReportDocument type exposes the following members.

Properties

Name | Description
DocumentName | Gets or sets the name of the document.
PageSettings | Gets or sets the page setting for the document.
ReportParameters | Gets the parameters for the document.
Reports | Gets the reports contained in the document.

See Also

IReportDocument Interface
Telerik.Reporting Namespace


IReportDocument Properties

[image] [image]

Telerik Reporting Q2 2012
IReportDocument Properties
IReportDocument Interface See Also Send Feedback

The IReportDocument type exposes the following members.

Properties

Name | Description
DocumentName | Gets or sets the name of the document.
PageSettings | Gets or sets the page setting for the document.
ReportParameters | Gets the parameters for the document.
Reports | Gets the reports contained in the document.

See Also

IReportDocument Interface
Telerik.Reporting Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
IReportDocument..::.DocumentName Property
IReportDocument Interface See Also Send Feedback
Gets or sets the name of the document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string DocumentName { get; set; }
Visual Basic (Declaration)
Property DocumentName As String

See Also

IReportDocument Interface
Telerik.Reporting Namespace


PageSettings Property

[image]

Telerik Reporting Q2 2012
IReportDocument..::.PageSettings Property
IReportDocument Interface See Also Send Feedback
Gets or sets the page setting for the document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PageSettings PageSettings { get; set; }
Visual Basic (Declaration)
Property PageSettings As PageSettings

See Also

IReportDocument Interface
Telerik.Reporting Namespace


ReportParameters Property

[image]

Telerik Reporting Q2 2012
IReportDocument..::.ReportParameters Property
IReportDocument Interface See Also Send Feedback
Gets the parameters for the document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<IReportParameter> ReportParameters { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParameters As IEnumerable(Of IReportParameter)

See Also

IReportDocument Interface
Telerik.Reporting Namespace


Reports Property

[image]

Telerik Reporting Q2 2012
IReportDocument..::.Reports Property
IReportDocument Interface See Also Send Feedback
Gets the reports contained in the document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<Report> Reports { get; }
Visual Basic (Declaration)
ReadOnly Property Reports As IEnumerable(Of Report)

See Also

IReportDocument Interface
Telerik.Reporting Namespace


IReportParameter Interface

[image]

Telerik Reporting Q2 2012
IReportParameter Interface
Members See Also Send Feedback
Represents a report parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IReportParameter
Visual Basic (Declaration)
Public Interface IReportParameter

See Also

IReportParameter Members
Telerik.Reporting Namespace


IReportParameter Members

[image] [image]

Telerik Reporting Q2 2012
IReportParameter Members
IReportParameter Interface Properties See Also Send Feedback

The IReportParameter type exposes the following members.

Properties

Name | Description
AllowBlank | Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.
AvailableValues | Gets an object that defines a set of valid values the parameter can accept from.
Mergeable | Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.
MultiValue | Determines if the parameter can hold more then one value.
Name | Gets or sets the name of the parameter. Used to access the parameter.
Text | Gets or sets the text for the parameter's automatic UI displayed in the report viewer.
Type | Gets or sets the data type of the parameter.
Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.
Visible | Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


IReportParameter Properties

[image] [image]

Telerik Reporting Q2 2012
IReportParameter Properties
IReportParameter Interface See Also Send Feedback

The IReportParameter type exposes the following members.

Properties

Name | Description
AllowBlank | Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.
AvailableValues | Gets an object that defines a set of valid values the parameter can accept from.
Mergeable | Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.
MultiValue | Determines if the parameter can hold more then one value.
Name | Gets or sets the name of the parameter. Used to access the parameter.
Text | Gets or sets the text for the parameter's automatic UI displayed in the report viewer.
Type | Gets or sets the data type of the parameter.
Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.
Visible | Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


AllowBlank Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.AllowBlank Property
IReportParameter Interface See Also Send Feedback
Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool AllowBlank { get; set; }
Visual Basic (Declaration)
Property AllowBlank As Boolean

See Also

IReportParameter Interface
Telerik.Reporting Namespace


AllowNull Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.AllowNull Property
IReportParameter Interface See Also Send Feedback
Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool AllowNull { get; set; }
Visual Basic (Declaration)
Property AllowNull As Boolean

Remarks

Only if this property is set to false null ( Nothing in VB) are considered as valid values of the parameter.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


AutoRefresh Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.AutoRefresh Property
IReportParameter Interface See Also Send Feedback
Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool AutoRefresh { get; set; }
Visual Basic (Declaration)
Property AutoRefresh As Boolean

Remarks

If this property is set to true, the report viewer will trigger the report preview automatically when the parameter value is changed. The parameter should be visible in order to auto preview the report.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.AvailableValues Property
IReportParameter Interface See Also Send Feedback
Gets an object that defines a set of valid values the parameter can accept from.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ReportParameterAvailableValues AvailableValues { get; }
Visual Basic (Declaration)
ReadOnly Property AvailableValues As ReportParameterAvailableValues

Remarks

The available values, or valid values, are a set of predefined values which are acceptable as value of the parameter. Each available value may have label that will be displayed if the parameter is visible.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Mergeable Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Mergeable Property
IReportParameter Interface See Also Send Feedback
Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool Mergeable { get; set; }
Visual Basic (Declaration)
Property Mergeable As Boolean

Remarks

Controls parameter merging in ReportBook. The default value of the Mergeable property is true. Set the Mergeable property to false if you want to prevent a parameter from being merged with its equivalent ones.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


MultiValue Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.MultiValue Property
IReportParameter Interface See Also Send Feedback
Determines if the parameter can hold more then one value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool MultiValue { get; set; }
Visual Basic (Declaration)
Property MultiValue As Boolean

Remarks

If the value is set to true as a valid value of the parameter is accepted an [!:IEnumerable] of values of the specified Type of the parameter. Parameters with MultiValue turned on are mainly used with the IN logical operator.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Name Property
IReportParameter Interface See Also Send Feedback
Gets or sets the name of the parameter. Used to access the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String

Remarks

Parameter names must be unique in the context of a single report. The name must be a valid identifier - may contain only digits (0-9), letters (a-z, A-Z), and underscore sign (_). Must begin with a letter or underscore.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Text Property
IReportParameter Interface See Also Send Feedback
Gets or sets the text for the parameter's automatic UI displayed in the report viewer.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string Text { get; set; }
Visual Basic (Declaration)
Property Text As String

Remarks

The Text property specifies the text for the parameter to be displayed in the report viewer as prompt to the end user. If value for the property is not provided the Name of the parameter is used.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Type Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Type Property
IReportParameter Interface See Also Send Feedback
Gets or sets the data type of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ReportParameterType Type { get; set; }
Visual Basic (Declaration)
Property Type As ReportParameterType

Remarks

Determines the type of the values. Acceptable values for each type are listed in ReportParameterType. The default parameter type is String.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Value Property
IReportParameter Interface See Also Send Feedback
Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object Value { get; set; }
Visual Basic (Declaration)
Property Value As Object

See Also

IReportParameter Interface
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
IReportParameter..::.Visible Property
IReportParameter Interface See Also Send Feedback
Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool Visible { get; set; }
Visual Basic (Declaration)
Property Visible As Boolean

Remarks

Specifies whether the parameter will have UI in the parameters area. When at least one report parameter has the Visible property turned on, a parameter area is shown as part of the report viewer. If this property is set to false, the parameter must be populated programmatically or at design time.

See Also

IReportParameter Interface
Telerik.Reporting Namespace


ItemEventArgs Class

[image]

Telerik Reporting Q2 2012
ItemEventArgs Class
Members See Also Send Feedback
Provides data for the ItemAdded()()() and ItemRemoved()()() events.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ItemEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ItemEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting..::.ItemEventArgs

See Also

ItemEventArgs Members
Telerik.Reporting Namespace


ItemEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ItemEventArgs Members
ItemEventArgs Class Constructors Properties See Also Send Feedback

The ItemEventArgs type exposes the following members.

Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class with the specified item that is added or removed.

Properties

Name | Description
Item | Gets the report item that is added/removed.

See Also

ItemEventArgs Class
Telerik.Reporting Namespace


ItemEventArgs Constructor

[image]

Telerik Reporting Q2 2012
ItemEventArgs Constructor
ItemEventArgs Class See Also Send Feedback
Initializes a new instance of the ItemEventArgs class with the specified item that is added or removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ItemEventArgs(
    ReportItemBase item
)
Visual Basic (Declaration)
Public Sub New ( _
    item As ReportItemBase _
)

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
A ReportItemBase that is the item being added or removed.

See Also

ItemEventArgs Class
Telerik.Reporting Namespace


ItemEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ItemEventArgs Properties
ItemEventArgs Class See Also Send Feedback

The ItemEventArgs type exposes the following members.

Properties

Name | Description
Item | Gets the report item that is added/removed.

See Also

ItemEventArgs Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ItemEventArgs..::.Item Property
ItemEventArgs Class See Also Send Feedback
Gets the report item that is added/removed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItemBase Item { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item As ReportItemBase

Field Value

A ReportItemBase that is the item being added or removed.

See Also

ItemEventArgs Class
Telerik.Reporting Namespace


ItemEventHandler Delegate

[image]

Telerik Reporting Q2 2012
ItemEventHandler Delegate
See Also Send Feedback
Handles the events that occur when items are being added to or removed from an items collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate void ItemEventHandler(
    Object sender,
    ItemEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ItemEventHandler ( _
    sender As Object, _
    e As ItemEventArgs _
)

Parameters

sender
Type: System..::.Object
The item whose collection is being modified.
e
Type: Telerik.Reporting..::.ItemEventArgs
An object of the ItemEventArgs class that contains the item that is being added or removed.

See Also

Telerik.Reporting Namespace


IToggleVisibilityTarget Interface

[image]

Telerik Reporting Q2 2012
IToggleVisibilityTarget Interface
Members See Also Send Feedback
Represents a report object which may be used as target of a ToggleVisibilityAction.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IToggleVisibilityTarget
Visual Basic (Declaration)
Public Interface IToggleVisibilityTarget

See Also

IToggleVisibilityTarget Members
Telerik.Reporting Namespace


IToggleVisibilityTarget Members

[image] [image]

Telerik Reporting Q2 2012
IToggleVisibilityTarget Members
IToggleVisibilityTarget Interface Properties See Also Send Feedback

The IToggleVisibilityTarget type exposes the following members.

Properties

Name | Description
Name | Gets the name of the report object used as toggle visibility target.

See Also

IToggleVisibilityTarget Interface
Telerik.Reporting Namespace


IToggleVisibilityTarget Properties

[image] [image]

Telerik Reporting Q2 2012
IToggleVisibilityTarget Properties
IToggleVisibilityTarget Interface See Also Send Feedback

The IToggleVisibilityTarget type exposes the following members.

Properties

Name | Description
Name | Gets the name of the report object used as toggle visibility target.

See Also

IToggleVisibilityTarget Interface
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
IToggleVisibilityTarget..::.Name Property
IToggleVisibilityTarget Interface See Also Send Feedback
Gets the name of the report object used as toggle visibility target.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String

Field Value

The name of the report object.

Remarks

The Name of the toggle visibility target should be unique in the report scope so that triggering the toggle visibility action does not interfere with other report objects.

See Also

IToggleVisibilityTarget Interface
Telerik.Reporting Namespace


List Class

[image]

Telerik Reporting Q2 2012
List Class
Members See Also Send Feedback
The list report item represents a free-form layout.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class List : Table
Visual Basic (Declaration)
Public Class List _
    Inherits Table

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Table
Telerik.Reporting..::.List

See Also

List Members
Telerik.Reporting Namespace


List Members

[image] [image]

Telerik Reporting Q2 2012
List Members
List Class Constructors Methods Properties Events See Also Send Feedback

The List type exposes the following members.

Constructors

Name | Description
List | Initializes a new instance of the List class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | (Inherited from Table.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group. (Inherited from Table.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values. (Inherited from Table.)
ColumnHeadersPrintOnEveryPage | (Inherited from Table.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item. (Inherited from Table.)
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render. (Inherited from Table.)
DataSource | Gets or sets the data source that the Table is displaying data for. (Inherited from Table.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table (Inherited from Table.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible. (Inherited from Table.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values. (Inherited from Table.)
RowHeadersPrintOnEveryPage | (Inherited from Table.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete. (Inherited from Table.)
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table (Inherited from Table.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set. (Inherited from Table.)

See Also

List Class
Telerik.Reporting Namespace


List Constructor

[image]

Telerik Reporting Q2 2012
List Constructor
List Class See Also Send Feedback
Initializes a new instance of the List class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List()
Visual Basic (Declaration)
Public Sub New

See Also

List Class
Telerik.Reporting Namespace


List Methods

[image] [image]

Telerik Reporting Q2 2012
List Methods
List Class See Also Send Feedback

The List type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource | (Inherited from Table.)
ToString | Overloaded.

See Also

List Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
List..::.Dispose Method
List Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

List Class
List Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
List..::.ToString Method
List Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

List Class
List Members
Telerik.Reporting Namespace


List Properties

[image] [image]

Telerik Reporting Q2 2012
List Properties
List Class See Also Send Feedback

The List type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group. (Inherited from Table.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values. (Inherited from Table.)
ColumnHeadersPrintOnEveryPage | (Inherited from Table.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item. (Inherited from Table.)
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render. (Inherited from Table.)
DataSource | Gets or sets the data source that the Table is displaying data for. (Inherited from Table.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table (Inherited from Table.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible. (Inherited from Table.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values. (Inherited from Table.)
RowHeadersPrintOnEveryPage | (Inherited from Table.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete. (Inherited from Table.)
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table (Inherited from Table.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

List Class
Telerik.Reporting Namespace


List Events

[image] [image]

Telerik Reporting Q2 2012
List Events
List Class See Also Send Feedback

The List type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set. (Inherited from Table.)

See Also

List Class
Telerik.Reporting Namespace


NavigateToBookmarkAction Class

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction Class
Members See Also Send Feedback
Represent an interactive action that navigates the report viewer to a predefined bookmark in the same report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class NavigateToBookmarkAction : IAction,
    IEquatable<NavigateToBookmarkAction>
Visual Basic (Declaration)
Public Class NavigateToBookmarkAction _
    Implements IAction, IEquatable(Of NavigateToBookmarkAction)

Remarks

Use this action to specify an interactive action on a report item that navigates the report viewer to an item with defined BookmarkId in the same report.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.NavigateToBookmarkAction

See Also

NavigateToBookmarkAction Members
Telerik.Reporting Namespace


NavigateToBookmarkAction Members

[image] [image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction Members
NavigateToBookmarkAction Class Constructors Methods Properties See Also Send Feedback

The NavigateToBookmarkAction type exposes the following members.

Constructors

Name | Description
NavigateToBookmarkAction | Initializes a new instance of the NavigateToBookmarkAction class

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

Properties

Name | Description
TargetBookmarkId | Gets or sets the target bookmark of the action.

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


NavigateToBookmarkAction Constructor

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction Constructor
NavigateToBookmarkAction Class See Also Send Feedback
Initializes a new instance of the NavigateToBookmarkAction class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public NavigateToBookmarkAction()
Visual Basic (Declaration)
Public Sub New

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


NavigateToBookmarkAction Methods

[image] [image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction Methods
NavigateToBookmarkAction Class See Also Send Feedback

The NavigateToBookmarkAction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction..::.Equals Method
NavigateToBookmarkAction Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(NavigateToBookmarkAction) |

See Also

NavigateToBookmarkAction Class
NavigateToBookmarkAction Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction..::.Equals Method (Object)
NavigateToBookmarkAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

NavigateToBookmarkAction Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (NavigateToBookmarkAction)

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction..::.Equals Method (NavigateToBookmarkAction)
NavigateToBookmarkAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    NavigateToBookmarkAction other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As NavigateToBookmarkAction _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.NavigateToBookmarkAction

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

NavigateToBookmarkAction Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction..::.GetHashCode Method
NavigateToBookmarkAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


NavigateToBookmarkAction Properties

[image] [image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction Properties
NavigateToBookmarkAction Class See Also Send Feedback

The NavigateToBookmarkAction type exposes the following members.

Properties

Name | Description
TargetBookmarkId | Gets or sets the target bookmark of the action.

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


TargetBookmarkId Property

[image]

Telerik Reporting Q2 2012
NavigateToBookmarkAction..::.TargetBookmarkId Property
NavigateToBookmarkAction Class See Also Send Feedback
Gets or sets the target bookmark of the action.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string TargetBookmarkId { get; set; }
Visual Basic (Declaration)
Public Property TargetBookmarkId As String

Remarks

Use this property to specify the value of the target bookmark. This property accepts expressions.

See Also

NavigateToBookmarkAction Class
Telerik.Reporting Namespace


NavigateToReportAction Class

[image]

Telerik Reporting Q2 2012
NavigateToReportAction Class
Members See Also Send Feedback
Represent an interactive action that navigates the report viewer to another report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class NavigateToReportAction : IAction,
    IEquatable<NavigateToReportAction>
Visual Basic (Declaration)
Public Class NavigateToReportAction _
    Implements IAction, IEquatable(Of NavigateToReportAction)

Remarks

Use this action to specify an interactive action on a report item that navigates the report viewer to another report (drillthrough). Report parameter values may be passed to the target report.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.NavigateToReportAction

See Also

NavigateToReportAction Members
Telerik.Reporting Namespace


NavigateToReportAction Members

[image] [image]

Telerik Reporting Q2 2012
NavigateToReportAction Members
NavigateToReportAction Class Constructors Methods Properties See Also Send Feedback

The NavigateToReportAction type exposes the following members.

Constructors

Name | Description
NavigateToReportAction | Initializes a new instance of the NavigateToReportAction class

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Parameters | Obsolete. Determines the report parameters that are passed to the target report when the action is triggered.
ReportDocumentType | Obsolete. Gets or sets the type name of the target report.
ReportSource | Specifies the ReportSource for the action.

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


NavigateToReportAction Constructor

[image]

Telerik Reporting Q2 2012
NavigateToReportAction Constructor
NavigateToReportAction Class See Also Send Feedback
Initializes a new instance of the NavigateToReportAction class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public NavigateToReportAction()
Visual Basic (Declaration)
Public Sub New

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


NavigateToReportAction Methods

[image] [image]

Telerik Reporting Q2 2012
NavigateToReportAction Methods
NavigateToReportAction Class See Also Send Feedback

The NavigateToReportAction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.Equals Method
NavigateToReportAction Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(NavigateToReportAction) |

See Also

NavigateToReportAction Class
NavigateToReportAction Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.Equals Method (Object)
NavigateToReportAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

NavigateToReportAction Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (NavigateToReportAction)

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.Equals Method (NavigateToReportAction)
NavigateToReportAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    NavigateToReportAction other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As NavigateToReportAction _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.NavigateToReportAction

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

NavigateToReportAction Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.GetHashCode Method
NavigateToReportAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.ToString Method
NavigateToReportAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


NavigateToReportAction Properties

[image] [image]

Telerik Reporting Q2 2012
NavigateToReportAction Properties
NavigateToReportAction Class See Also Send Feedback

The NavigateToReportAction type exposes the following members.

Properties

Name | Description
Parameters | Obsolete. Determines the report parameters that are passed to the target report when the action is triggered.
ReportDocumentType | Obsolete. Gets or sets the type name of the target report.
ReportSource | Specifies the ReportSource for the action.

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.Parameters Property
NavigateToReportAction Class See Also Send Feedback
Determines the report parameters that are passed to the target report when the action is triggered.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The Parameters property is now obsolete. Please use the ReportSource property instead.")]
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Parameters property is now obsolete. Please use the ReportSource property instead.")> _
Public ReadOnly Property Parameters As ParameterCollection

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


ReportDocumentType Property

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.ReportDocumentType Property
NavigateToReportAction Class See Also Send Feedback
Gets or sets the type name of the target report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The ReportDocumentType property is now obsolete. Please use the ReportSource property instead.")]
public string ReportDocumentType { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("The ReportDocumentType property is now obsolete. Please use the ReportSource property instead.")> _
Public Property ReportDocumentType As String

Remarks

Use this property to specify the type name of the target report of the action. Must be the assembly qualified name of the Type of the report.

The target type should implement the IReportDocument interface and should have default (parameterless) constructor. The default constructor is used from the reporting engine to create a report instance when the action is triggered.

This property accepts expressions.

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
NavigateToReportAction..::.ReportSource Property
NavigateToReportAction Class See Also Send Feedback
Specifies the ReportSource for the action.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

NavigateToReportAction Class
Telerik.Reporting Namespace
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.XmlReportSource


NavigateToUrlAction Class

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction Class
Members See Also Send Feedback
Represent an interactive action that opens an Url.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class NavigateToUrlAction : IAction,
    IEquatable<NavigateToUrlAction>
Visual Basic (Declaration)
Public Class NavigateToUrlAction _
    Implements IAction, IEquatable(Of NavigateToUrlAction)

Remarks

Use this action to specify an interactive action on a report item that opens an Url.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.NavigateToUrlAction

See Also

NavigateToUrlAction Members
Telerik.Reporting Namespace


NavigateToUrlAction Members

[image] [image]

Telerik Reporting Q2 2012
NavigateToUrlAction Members
NavigateToUrlAction Class Constructors Methods Properties See Also Send Feedback

The NavigateToUrlAction type exposes the following members.

Constructors

Name | Description
NavigateToUrlAction | Creates a new instance of NavigateToUrlAction class

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

Properties

Name | Description
Target |
Url |

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


NavigateToUrlAction Constructor

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction Constructor
NavigateToUrlAction Class See Also Send Feedback
Creates a new instance of NavigateToUrlAction class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public NavigateToUrlAction()
Visual Basic (Declaration)
Public Sub New

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


NavigateToUrlAction Methods

[image] [image]

Telerik Reporting Q2 2012
NavigateToUrlAction Methods
NavigateToUrlAction Class See Also Send Feedback

The NavigateToUrlAction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.Equals Method
NavigateToUrlAction Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(NavigateToUrlAction) |

See Also

NavigateToUrlAction Class
NavigateToUrlAction Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.Equals Method (Object)
NavigateToUrlAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

NavigateToUrlAction Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (NavigateToUrlAction)

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.Equals Method (NavigateToUrlAction)
NavigateToUrlAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    NavigateToUrlAction other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As NavigateToUrlAction _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.NavigateToUrlAction

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

NavigateToUrlAction Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.GetHashCode Method
NavigateToUrlAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


NavigateToUrlAction Properties

[image] [image]

Telerik Reporting Q2 2012
NavigateToUrlAction Properties
NavigateToUrlAction Class See Also Send Feedback

The NavigateToUrlAction type exposes the following members.

Properties

Name | Description
Target |
Url |

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


Target Property

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.Target Property
NavigateToUrlAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public UrlTarget Target { get; set; }
Visual Basic (Declaration)
Public Property Target As UrlTarget

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


Url Property

[image]

Telerik Reporting Q2 2012
NavigateToUrlAction..::.Url Property
NavigateToUrlAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String

See Also

NavigateToUrlAction Class
Telerik.Reporting Namespace


ObjectDataSource Class

[image]

Telerik Reporting Q2 2012
ObjectDataSource Class
Members See Also Send Feedback
Represents a business object to data items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class ObjectDataSource : ObjectDataSourceBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ObjectDataSource _
    Inherits ObjectDataSourceBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.ObjectDataSourceBase
Telerik.Reporting..::.ObjectDataSource

See Also

ObjectDataSource Members
Telerik.Reporting Namespace


ObjectDataSource Members

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSource Members
ObjectDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ObjectDataSource type exposes the following members.

Constructors

Name | Description
ObjectDataSource | Overloaded.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
DataMember | Gets or sets the data source member that is used to connect to data.
DataSource | Gets or sets the data source object that is used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


ObjectDataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSource Constructor
ObjectDataSource Class See Also Send Feedback

Overload List

Name | Description
ObjectDataSource()()() | Creates a new instance of the ObjectDataSource class.
ObjectDataSource(Object, String) | Creates a new instance of the ObjectDataSource class.
ObjectDataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectDataSource class

See Also

ObjectDataSource Class
ObjectDataSource Members
Telerik.Reporting Namespace


ObjectDataSource Constructor

[image]

Telerik Reporting Q2 2012
ObjectDataSource Constructor
ObjectDataSource Class See Also Send Feedback
Creates a new instance of the ObjectDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSource()
Visual Basic (Declaration)
Public Sub New

See Also

ObjectDataSource Class
ObjectDataSource Overload
Telerik.Reporting Namespace


ObjectDataSource Constructor (Object, String)

[image]

Telerik Reporting Q2 2012
ObjectDataSource Constructor (Object, String)
ObjectDataSource Class See Also Send Feedback
Creates a new instance of the ObjectDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSource(
    Object dataSource,
    string dataMember
)
Visual Basic (Declaration)
Public Sub New ( _
    dataSource As Object, _
    dataMember As String _
)

Parameters

dataSource
Type: System..::.Object
Specifies the data source object that is used to connect to data.
dataMember
Type: System..::.String
Specifies the data source member that is used to connect to data.

See Also

ObjectDataSource Class
ObjectDataSource Overload
Telerik.Reporting Namespace


ObjectDataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
ObjectDataSource Constructor (SerializationInfo, StreamingContext)
ObjectDataSource Class See Also Send Feedback
Initializes a new instance of the ObjectDataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ObjectDataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

ObjectDataSource Class
ObjectDataSource Overload
Telerik.Reporting Namespace


ObjectDataSource Methods

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSource Methods
ObjectDataSource Class See Also Send Feedback

The ObjectDataSource type exposes the following members.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


GetDataMember Method

[image]

Telerik Reporting Q2 2012
ObjectDataSource..::.GetDataMember Method
ObjectDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override string GetDataMember()
Visual Basic (Declaration)
Protected Overrides Function GetDataMember As String

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


GetDataSource Method

[image]

Telerik Reporting Q2 2012
ObjectDataSource..::.GetDataSource Method
ObjectDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object GetDataSource()
Visual Basic (Declaration)
Protected Overrides Function GetDataSource As Object

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
ObjectDataSource..::.GetObjectData Method
ObjectDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


ObjectDataSource Properties

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSource Properties
ObjectDataSource Class See Also Send Feedback

The ObjectDataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
DataMember | Gets or sets the data source member that is used to connect to data.
DataSource | Gets or sets the data source object that is used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
ObjectDataSource..::.DataMember Property
ObjectDataSource Class See Also Send Feedback
Gets or sets the data source member that is used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String

Remarks

The DataMember property can contain the name of a property or a method of the business object to be invoked during data retrieval. If the DataSource property contains the Type of a business object, and the DataMember property is set to null (Nothing in Visual Basic) or an empty string, the constructor with the specified parameters is invoked to create a new instance of the business object.

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
ObjectDataSource..::.DataSource Property
ObjectDataSource Class See Also Send Feedback
Gets or sets the data source object that is used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

Remarks

The DataSource property can contain either an instance of a business object or the Type of such a business object to be created at run time.

See Also

ObjectDataSource Class
Telerik.Reporting Namespace


ObjectDataSourceBase Class

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ObjectDataSourceBase : DataSource
Visual Basic (Declaration)
Public MustInherit Class ObjectDataSourceBase _
    Inherits DataSource

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.ObjectDataSourceBase
Telerik.Reporting..::.EntityDataSource
Telerik.Reporting..::.ObjectDataSource
Telerik.Reporting..::.OpenAccessDataSource

See Also

ObjectDataSourceBase Members
Telerik.Reporting Namespace


ObjectDataSourceBase Members

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Members
ObjectDataSourceBase Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ObjectDataSourceBase type exposes the following members.

Constructors

Name | Description
ObjectDataSourceBase | Overloaded.

Methods

Name | Description
GetDataMember |
GetDataSource |
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with ObjectDataSourceParameters.

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


ObjectDataSourceBase Constructor

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Constructor
ObjectDataSourceBase Class See Also Send Feedback

Overload List

Name | Description
ObjectDataSourceBase()()() | Initializes a new instance of the ObjectDataSourceBase class
ObjectDataSourceBase(SerializationInfo, StreamingContext) | Initializes a new instance of the ObjectDataSourceBase class

See Also

ObjectDataSourceBase Class
ObjectDataSourceBase Members
Telerik.Reporting Namespace


ObjectDataSourceBase Constructor

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Constructor
ObjectDataSourceBase Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceBase class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ObjectDataSourceBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ObjectDataSourceBase Class
ObjectDataSourceBase Overload
Telerik.Reporting Namespace


ObjectDataSourceBase Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Constructor (SerializationInfo, StreamingContext)
ObjectDataSourceBase Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceBase class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ObjectDataSourceBase(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

ObjectDataSourceBase Class
ObjectDataSourceBase Overload
Telerik.Reporting Namespace


ObjectDataSourceBase Methods

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Methods
ObjectDataSourceBase Class See Also Send Feedback

The ObjectDataSourceBase type exposes the following members.

Methods

Name | Description
GetDataMember |
GetDataSource |
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


GetDataMember Method

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase..::.GetDataMember Method
ObjectDataSourceBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected abstract string GetDataMember()
Visual Basic (Declaration)
Protected MustOverride Function GetDataMember As String

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


GetDataSource Method

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase..::.GetDataSource Method
ObjectDataSourceBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected abstract Object GetDataSource()
Visual Basic (Declaration)
Protected MustOverride Function GetDataSource As Object

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase..::.GetObjectData Method
ObjectDataSourceBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


ObjectDataSourceBase Properties

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceBase Properties
ObjectDataSourceBase Class See Also Send Feedback

The ObjectDataSourceBase type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with ObjectDataSourceParameters.

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
ObjectDataSourceBase..::.Parameters Property
ObjectDataSourceBase Class See Also Send Feedback
Gets a collection with ObjectDataSourceParameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ObjectDataSourceParameterCollection

Remarks

The Parameters property specifies a collection of parameters to be passed to the constructor or the method of the business object during data retrieval. If the DataSource property contains the Type of a business object, and the DataMember property is set to null (Nothing in Visual Basic) or an empty string, the constructor with the specified parameters is invoked to create a new instance of the business object. If the DataMember property is set to a non-empty string that represents a valid method name, the parameters are passed to the method with the matching signature.

See Also

ObjectDataSourceBase Class
Telerik.Reporting Namespace


ObjectDataSourceParameter Class

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Class
Members See Also Send Feedback
Represents a parameter in an ObjectDataSource component.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class ObjectDataSourceParameter : DataSourceParameter
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ObjectDataSourceParameter _
    Inherits DataSourceParameter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.DataSourceParameter
Telerik.Reporting..::.ObjectDataSourceParameter

See Also

ObjectDataSourceParameter Members
Telerik.Reporting Namespace


ObjectDataSourceParameter Members

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Members
ObjectDataSourceParameter Class Constructors Methods Properties Events See Also Send Feedback

The ObjectDataSourceParameter type exposes the following members.

Constructors

Name | Description
ObjectDataSourceParameter | Overloaded.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

Properties

Name | Description
DataType | Gets or sets the data type of the parameter.
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

ObjectDataSourceParameter Class
Telerik.Reporting Namespace


ObjectDataSourceParameter Constructor

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Constructor
ObjectDataSourceParameter Class See Also Send Feedback

Overload List

Name | Description
ObjectDataSourceParameter()()() | Initializes a new instance of the ObjectDataSourceParameter class.
ObjectDataSourceParameter(String) | Initializes a new instance of the ObjectDataSourceParameter class.
ObjectDataSourceParameter(String, Type) | Initializes a new instance of the ObjectDataSourceParameter class.
ObjectDataSourceParameter(String, Type, Object) | Initializes a new instance of the ObjectDataSourceParameter class.

See Also

ObjectDataSourceParameter Class
ObjectDataSourceParameter Members
Telerik.Reporting Namespace


ObjectDataSourceParameter Constructor

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Constructor
ObjectDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter()
Visual Basic (Declaration)
Public Sub New

See Also

ObjectDataSourceParameter Class
ObjectDataSourceParameter Overload
Telerik.Reporting Namespace


ObjectDataSourceParameter Constructor (String)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Constructor (String)
ObjectDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.

See Also

ObjectDataSourceParameter Class
ObjectDataSourceParameter Overload
Telerik.Reporting Namespace


ObjectDataSourceParameter Constructor (String, Type)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Constructor (String, Type)
ObjectDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter(
    string name,
    Type dataType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As Type _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
dataType
Type: System..::.Type
Specifies the data type of the parameter.

See Also

ObjectDataSourceParameter Class
ObjectDataSourceParameter Overload
Telerik.Reporting Namespace


ObjectDataSourceParameter Constructor (String, Type, Object)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Constructor (String, Type, Object)
ObjectDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter(
    string name,
    Type dataType,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As Type, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
dataType
Type: System..::.Type
Specifies the data type of the parameter.
value
Type: System..::.Object
Specifies the value of the parameter.

See Also

ObjectDataSourceParameter Class
ObjectDataSourceParameter Overload
Telerik.Reporting Namespace


ObjectDataSourceParameter Methods

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Methods
ObjectDataSourceParameter Class See Also Send Feedback

The ObjectDataSourceParameter type exposes the following members.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

See Also

ObjectDataSourceParameter Class
Telerik.Reporting Namespace


ObjectDataSourceParameter Properties

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Properties
ObjectDataSourceParameter Class See Also Send Feedback

The ObjectDataSourceParameter type exposes the following members.

Properties

Name | Description
DataType | Gets or sets the data type of the parameter.
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

See Also

ObjectDataSourceParameter Class
Telerik.Reporting Namespace


DataType Property

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter..::.DataType Property
ObjectDataSourceParameter Class See Also Send Feedback
Gets or sets the data type of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

ObjectDataSourceParameter Class
Telerik.Reporting Namespace


ObjectDataSourceParameter Events

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameter Events
ObjectDataSourceParameter Class See Also Send Feedback

The ObjectDataSourceParameter type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

ObjectDataSourceParameter Class
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Class

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Class
Members See Also Send Feedback
Represents a collection of ObjectDataSourceParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class ObjectDataSourceParameterCollection : Collection<ObjectDataSourceParameter>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ObjectDataSourceParameterCollection _
    Inherits Collection(Of ObjectDataSourceParameter)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ObjectDataSourceParameter >)>)>
Telerik.Reporting..::.ObjectDataSourceParameterCollection

See Also

ObjectDataSourceParameterCollection Members
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Members
ObjectDataSourceParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ObjectDataSourceParameterCollection type exposes the following members.

Constructors

Name | Description
ObjectDataSourceParameterCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Constructor
ObjectDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
ObjectDataSourceParameterCollection()()() | Initializes a new instance of the ObjectDataSourceParameterCollection class.
ObjectDataSourceParameterCollection(array<ObjectDataSourceParameter>[]()[]) | Initializes a new instance of the ObjectDataSourceParameterCollection class.
ObjectDataSourceParameterCollection(ObjectDataSourceParameterCollection) | Initializes a new instance of the ObjectDataSourceParameterCollection class.

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Members
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Constructor
ObjectDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Overload
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Constructor (ObjectDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Constructor (array<ObjectDataSourceParameter>[]()[][])
ObjectDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameterCollection(
    ObjectDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As ObjectDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.ObjectDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Overload
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Constructor (ObjectDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Constructor (ObjectDataSourceParameterCollection)
ObjectDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the ObjectDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameterCollection(
    ObjectDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As ObjectDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.ObjectDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Overload
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Methods
ObjectDataSourceParameterCollection Class See Also Send Feedback

The ObjectDataSourceParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


Add Method

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Add Method
ObjectDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(String) | Adds a new parameter with the specified name to the collection.
Add(String, Type) | Adds a new parameter with the specified name and data type to the collection.
Add(String, Type, Object) | Adds a new parameter with the specified name, data type and value to the collection.

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Members
Telerik.Reporting Namespace


Add Method (String)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Add Method (String)
ObjectDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


Add Method (String, Type)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Add Method (String, Type)
ObjectDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name and data type to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    Type dataType
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    dataType As Type _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.
dataType
Type: System..::.Type
Specifies the data type of the new parameter to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


Add Method (String, Type, Object)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Add Method (String, Type, Object)
ObjectDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name, data type and value to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    Type dataType,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    dataType As Type, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.
dataType
Type: System..::.Type
Specifies the data type of the new parameter to add to the collection.
value
Type: System..::.Object
Specifies the value of the new parameter to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.AddRange Method
ObjectDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<ObjectDataSourceParameter>[]()[]) | Adds a range of parameters to the collection.
AddRange(ObjectDataSourceParameterCollection) | Adds a range of parameters to the collection.

See Also

ObjectDataSourceParameterCollection Class
ObjectDataSourceParameterCollection Members
Telerik.Reporting Namespace


AddRange Method (ObjectDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.AddRange Method (array<ObjectDataSourceParameter>[]()[][])
ObjectDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    ObjectDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As ObjectDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.ObjectDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


AddRange Method (ObjectDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.AddRange Method (ObjectDataSourceParameterCollection)
ObjectDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    ObjectDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As ObjectDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.ObjectDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

ObjectDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Contains Method
ObjectDataSourceParameterCollection Class See Also Send Feedback
Determines if the collection contains a parameter with the specified name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

True if a parameter with the specified name exists, False otherwise.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


ToArray Method

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.ToArray Method
ObjectDataSourceParameterCollection Class See Also Send Feedback
Converts the collection to an array of parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As ObjectDataSourceParameter()

Return Value

Array of parameters contained in the collection.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


ObjectDataSourceParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection Properties
ObjectDataSourceParameterCollection Class See Also Send Feedback

The ObjectDataSourceParameterCollection type exposes the following members.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ObjectDataSourceParameterCollection..::.Item Property
ObjectDataSourceParameterCollection Class See Also Send Feedback
Gets the parameter with the specified name from the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ObjectDataSourceParameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ObjectDataSourceParameter

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

The parameter with the specified name from the collection.

See Also

ObjectDataSourceParameterCollection Class
Telerik.Reporting Namespace


OpenAccessDataSource Class

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Class
Members See Also Send Feedback
Represents an Open Access data model to data items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class OpenAccessDataSource : ObjectDataSourceBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class OpenAccessDataSource _
    Inherits ObjectDataSourceBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.ObjectDataSourceBase
Telerik.Reporting..::.OpenAccessDataSource

See Also

OpenAccessDataSource Members
Telerik.Reporting Namespace


OpenAccessDataSource Members

[image] [image]

Telerik Reporting Q2 2012
OpenAccessDataSource Members
OpenAccessDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The OpenAccessDataSource type exposes the following members.

Constructors

Name | Description
OpenAccessDataSource | Overloaded.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
ObjectContext | Gets or sets the object context used to connect to data.
ObjectContextMember | Gets or sets the object context member used to connect to data.
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)
ProviderName | Gets or sets the managed provider name used to connect to data.

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


OpenAccessDataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor
OpenAccessDataSource Class See Also Send Feedback

Overload List

Name | Description
OpenAccessDataSource()()() | Initializes a new instance of the OpenAccessDataSource class.
OpenAccessDataSource(Object, String) | Initializes a new instance of the OpenAccessDataSource class.
OpenAccessDataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the OpenAccessDataSource class
OpenAccessDataSource(String, Object, String) | Initializes a new instance of the OpenAccessDataSource class.
OpenAccessDataSource(String, String, Object, String) | Initializes a new instance of the OpenAccessDataSource class.

See Also

OpenAccessDataSource Class
OpenAccessDataSource Members
Telerik.Reporting Namespace


OpenAccessDataSource Constructor

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor
OpenAccessDataSource Class See Also Send Feedback
Initializes a new instance of the OpenAccessDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public OpenAccessDataSource()
Visual Basic (Declaration)
Public Sub New

See Also

OpenAccessDataSource Class
OpenAccessDataSource Overload
Telerik.Reporting Namespace


OpenAccessDataSource Constructor (Object, String)

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor (Object, String)
OpenAccessDataSource Class See Also Send Feedback
Initializes a new instance of the OpenAccessDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public OpenAccessDataSource(
    Object objectContext,
    string objectContextMember
)
Visual Basic (Declaration)
Public Sub New ( _
    objectContext As Object, _
    objectContextMember As String _
)

Parameters

objectContext
Type: System..::.Object
Specifies the object context used to connect to data.
objectContextMember
Type: System..::.String
Specifies the object context member used to connect to data.

See Also

OpenAccessDataSource Class
OpenAccessDataSource Overload
Telerik.Reporting Namespace


OpenAccessDataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor (SerializationInfo, StreamingContext)
OpenAccessDataSource Class See Also Send Feedback
Initializes a new instance of the OpenAccessDataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected OpenAccessDataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

OpenAccessDataSource Class
OpenAccessDataSource Overload
Telerik.Reporting Namespace


OpenAccessDataSource Constructor (String, Object, String)

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor (String, Object, String)
OpenAccessDataSource Class See Also Send Feedback
Initializes a new instance of the OpenAccessDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public OpenAccessDataSource(
    string connectionString,
    Object objectContext,
    string objectContextMember
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String, _
    objectContext As Object, _
    objectContextMember As String _
)

Parameters

connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
objectContext
Type: System..::.Object
Specifies the object context used to connect to data.
objectContextMember
Type: System..::.String
Specifies the object context member used to connect to data.

See Also

OpenAccessDataSource Class
OpenAccessDataSource Overload
Telerik.Reporting Namespace


OpenAccessDataSource Constructor (String, String, Object, String)

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource Constructor (String, String, Object, String)
OpenAccessDataSource Class See Also Send Feedback
Initializes a new instance of the OpenAccessDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public OpenAccessDataSource(
    string providerName,
    string connectionString,
    Object objectContext,
    string objectContextMember
)
Visual Basic (Declaration)
Public Sub New ( _
    providerName As String, _
    connectionString As String, _
    objectContext As Object, _
    objectContextMember As String _
)

Parameters

providerName
Type: System..::.String
Specifies the managed provider name used to connect to data.
connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
objectContext
Type: System..::.Object
Specifies the object context used to connect to data.
objectContextMember
Type: System..::.String
Specifies the object context member used to connect to data.

See Also

OpenAccessDataSource Class
OpenAccessDataSource Overload
Telerik.Reporting Namespace


OpenAccessDataSource Methods

[image] [image]

Telerik Reporting Q2 2012
OpenAccessDataSource Methods
OpenAccessDataSource Class See Also Send Feedback

The OpenAccessDataSource type exposes the following members.

Methods

Name | Description
GetDataMember | (Overrides ObjectDataSourceBase..::.GetDataMember()()().)
GetDataSource | (Overrides ObjectDataSourceBase..::.GetDataSource()()().)
GetObjectData | (Overrides ObjectDataSourceBase..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


GetDataMember Method

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.GetDataMember Method
OpenAccessDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override string GetDataMember()
Visual Basic (Declaration)
Protected Overrides Function GetDataMember As String

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


GetDataSource Method

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.GetDataSource Method
OpenAccessDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object GetDataSource()
Visual Basic (Declaration)
Protected Overrides Function GetDataSource As Object

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.GetObjectData Method
OpenAccessDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


OpenAccessDataSource Properties

[image] [image]

Telerik Reporting Q2 2012
OpenAccessDataSource Properties
OpenAccessDataSource Class See Also Send Feedback

The OpenAccessDataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
ObjectContext | Gets or sets the object context used to connect to data.
ObjectContextMember | Gets or sets the object context member used to connect to data.
Parameters | Gets a collection with ObjectDataSourceParameters. (Inherited from ObjectDataSourceBase.)
ProviderName | Gets or sets the managed provider name used to connect to data.

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


ConnectionString Property

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.ConnectionString Property
OpenAccessDataSource Class See Also Send Feedback
Gets or sets the connection string used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String

Remarks

The ConnectionString property contains either a valid connection string or the name of a [!:ConnectionStringSettings] in the application configuration file.

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


ObjectContext Property

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.ObjectContext Property
OpenAccessDataSource Class See Also Send Feedback
Gets or sets the object context used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object ObjectContext { get; set; }
Visual Basic (Declaration)
Public Property ObjectContext As Object

Remarks

The ObjectContext property can contain either an instance of an object context or the Type of such a context to be created at run time.

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


ObjectContextMember Property

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.ObjectContextMember Property
OpenAccessDataSource Class See Also Send Feedback
Gets or sets the object context member used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ObjectContextMember { get; set; }
Visual Basic (Declaration)
Public Property ObjectContextMember As String

Remarks

The ObjectContextMember property contains the name of a property or a method of the object context to be invoked during data retrieval.

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


ProviderName Property

[image]

Telerik Reporting Q2 2012
OpenAccessDataSource..::.ProviderName Property
OpenAccessDataSource Class See Also Send Feedback
Gets or sets the managed provider name used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ProviderName { get; set; }
Visual Basic (Declaration)
Public Property ProviderName As String

Remarks

If the ProviderName property is set to null (Nothing in Visual Basic) or an empty string, the default provider is System.Data.SqlClient.

See Also

OpenAccessDataSource Class
Telerik.Reporting Namespace


PageBreak Enumeration

[image]

Telerik Reporting Q2 2012
PageBreak Enumeration
See Also Send Feedback
Specifies where to make a page break, with respect to a ReportSection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[FlagsAttribute]
public enum PageBreak
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration PageBreak

Members

Member name | Description
None | No page break will occur.
Before | A page break will occur before the ReportSection
After | A page break will occur after the ReportSection
BeforeAndAfter | A page break will occur before and after the ReportSection

See Also

Telerik.Reporting Namespace


PageEventArgs Class

[image]

Telerik Reporting Q2 2012
PageEventArgs Class
Members See Also Send Feedback
Provides data for the [!:Telerik.Reporting.Report.BeginRenderPage] and [!:Telerik.Reporting.Report.EndRenderPage] events.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PageEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PageEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting..::.PageEventArgs

See Also

PageEventArgs Members
Telerik.Reporting Namespace


PageEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
PageEventArgs Members
PageEventArgs Class Constructors Properties See Also Send Feedback

The PageEventArgs type exposes the following members.

Constructors

Name | Description
PageEventArgs | Initializes a new instance of the PageEventArgs class with the specified page number and page count.

Properties

Name | Description
PageCount | Gets the total number of pages of the report.
PageNumber | Gets the number of the page that the event is beign raised for.

See Also

PageEventArgs Class
Telerik.Reporting Namespace


PageEventArgs Constructor

[image]

Telerik Reporting Q2 2012
PageEventArgs Constructor
PageEventArgs Class See Also Send Feedback
Initializes a new instance of the PageEventArgs class with the specified page number and page count.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageEventArgs(
    int pageNumber,
    int pageCount
)
Visual Basic (Declaration)
Public Sub New ( _
    pageNumber As Integer, _
    pageCount As Integer _
)

Parameters

pageNumber
Type: System..::.Int32
The number of the page.
pageCount
Type: System..::.Int32
The total number of pages.

See Also

PageEventArgs Class
Telerik.Reporting Namespace


PageEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
PageEventArgs Properties
PageEventArgs Class See Also Send Feedback

The PageEventArgs type exposes the following members.

Properties

Name | Description
PageCount | Gets the total number of pages of the report.
PageNumber | Gets the number of the page that the event is beign raised for.

See Also

PageEventArgs Class
Telerik.Reporting Namespace


PageCount Property

[image]

Telerik Reporting Q2 2012
PageEventArgs..::.PageCount Property
PageEventArgs Class See Also Send Feedback
Gets the total number of pages of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int PageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer

Field Value

A int value specifying the total number of pages of the report.

See Also

PageEventArgs Class
Telerik.Reporting Namespace


PageNumber Property

[image]

Telerik Reporting Q2 2012
PageEventArgs..::.PageNumber Property
PageEventArgs Class See Also Send Feedback
Gets the number of the page that the event is beign raised for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int PageNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer

Field Value

A int value specifying the number of the page that the event is beign raised for.

See Also

PageEventArgs Class
Telerik.Reporting Namespace


PageEventHandler Delegate

[image]

Telerik Reporting Q2 2012
PageEventHandler Delegate
See Also Send Feedback
Handles the events that occur when a page rendering begins or ends.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate void PageEventHandler(
    Object sender,
    PageEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub PageEventHandler ( _
    sender As Object, _
    e As PageEventArgs _
)

Parameters

sender
Type: System..::.Object
The report that owns the page.
e
Type: Telerik.Reporting..::.PageEventArgs
An object of the PageEventArgs class that contains data for the page being rendered.

See Also

Telerik.Reporting Namespace


PageFooterSection Class

[image]

Telerik Reporting Q2 2012
PageFooterSection Class
Members See Also Send Feedback
Represents a page footer section. Page footers are displayed at the end of a page.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PageFooterSection : PageSection
Visual Basic (Declaration)
Public Class PageFooterSection _
    Inherits PageSection

Remarks

Note:Page header/footer section of nested reports are ignored by the reporting engine (only the master report respects page sections). In order to have a header/footer that repeats on every page, you may consider using an unbound group (a group without any grouping criteria specified) and set its GroupHeader/FooterSection.PrintOnEveryPage = True

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.PageSection
Telerik.Reporting..::.PageFooterSection

See Also

PageFooterSection Members
Telerik.Reporting Namespace


PageFooterSection Members

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection Members
PageFooterSection Class Constructors Methods Properties Events See Also Send Feedback

The PageFooterSection type exposes the following members.

Constructors

Name | Description
PageFooterSection | Initializes a new instance of the PageFooterSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection.)
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Constructor

[image]

Telerik Reporting Q2 2012
PageFooterSection Constructor
PageFooterSection Class See Also Send Feedback
Initializes a new instance of the PageFooterSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageFooterSection()
Visual Basic (Declaration)
Public Sub New

See Also

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Methods

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection Methods
PageFooterSection Class See Also Send Feedback

The PageFooterSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

PageFooterSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection..::.Dispose Method
PageFooterSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

PageFooterSection Class
PageFooterSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection..::.ToString Method
PageFooterSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PageFooterSection Class
PageFooterSection Members
Telerik.Reporting Namespace


PageFooterSection Properties

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection Properties
PageFooterSection Class See Also Send Feedback

The PageFooterSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection.)
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

PageFooterSection Class
Telerik.Reporting Namespace


PageFooterSection Events

[image] [image]

Telerik Reporting Q2 2012
PageFooterSection Events
PageFooterSection Class See Also Send Feedback

The PageFooterSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageFooterSection Class
Telerik.Reporting Namespace


PageHeaderSection Class

[image]

Telerik Reporting Q2 2012
PageHeaderSection Class
Members See Also Send Feedback
Represents a page header section. Page headers are displayed at the beginning of a page.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PageHeaderSection : PageSection
Visual Basic (Declaration)
Public Class PageHeaderSection _
    Inherits PageSection

Remarks

Note:Page header/footer section of nested reports are ignored by the reporting engine (only the master report respects page sections). In order to have a header/footer that repeats on every page, you may consider using an unbound group (a group without any grouping criteria specified) and set its GroupHeader/FooterSection.PrintOnEveryPage = True

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.PageSection
Telerik.Reporting..::.PageHeaderSection

See Also

PageHeaderSection Members
Telerik.Reporting Namespace


PageHeaderSection Members

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection Members
PageHeaderSection Class Constructors Methods Properties Events See Also Send Feedback

The PageHeaderSection type exposes the following members.

Constructors

Name | Description
PageHeaderSection | Initializes a new instance of the PageHeaderSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection.)
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Constructor

[image]

Telerik Reporting Q2 2012
PageHeaderSection Constructor
PageHeaderSection Class See Also Send Feedback
Initializes a new instance of the PageHeaderSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageHeaderSection()
Visual Basic (Declaration)
Public Sub New

See Also

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Methods

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection Methods
PageHeaderSection Class See Also Send Feedback

The PageHeaderSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

PageHeaderSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection..::.Dispose Method
PageHeaderSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

PageHeaderSection Class
PageHeaderSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection..::.ToString Method
PageHeaderSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PageHeaderSection Class
PageHeaderSection Members
Telerik.Reporting Namespace


PageHeaderSection Properties

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection Properties
PageHeaderSection Class See Also Send Feedback

The PageHeaderSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report. (Inherited from PageSection.)
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report. (Inherited from PageSection.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

PageHeaderSection Class
Telerik.Reporting Namespace


PageHeaderSection Events

[image] [image]

Telerik Reporting Q2 2012
PageHeaderSection Events
PageHeaderSection Class See Also Send Feedback

The PageHeaderSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageHeaderSection Class
Telerik.Reporting Namespace


PageNumberingStyle Enumeration

[image]

Telerik Reporting Q2 2012
PageNumberingStyle Enumeration
See Also Send Feedback
Specifies the page numbering style of a report. Has meaning and effect only when the report is part of a report book.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum PageNumberingStyle
Visual Basic (Declaration)
Public Enumeration PageNumberingStyle

Members

Member name | Description
Restart | Obsolete. Page numbering starts from 1.
ResetNumbering | Resets page numbering while page count aggregation continues.
ResetNumberingAndCount | Resets both page numbering and page count.
Continue | Page numbering and page count aggregations continue.

See Also

Telerik.Reporting Namespace


PageSection Class

[image]

Telerik Reporting Q2 2012
PageSection Class
Members See Also Send Feedback
Base abstract class for group sections. PageHeaderSection and PageFooterSection inherit from this class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class PageSection : ReportSectionBase
Visual Basic (Declaration)
Public MustInherit Class PageSection _
    Inherits ReportSectionBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.PageSection
Telerik.Reporting..::.PageFooterSection
Telerik.Reporting..::.PageHeaderSection

See Also

PageSection Members
Telerik.Reporting Namespace


PageSection Members

[image] [image]

Telerik Reporting Q2 2012
PageSection Members
PageSection Class Constructors Methods Properties Events See Also Send Feedback

The PageSection type exposes the following members.

Constructors

Name | Description
PageSection | Initializes a new instance of the PageSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report.
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report.
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageSection Class
Telerik.Reporting Namespace


PageSection Constructor

[image]

Telerik Reporting Q2 2012
PageSection Constructor
PageSection Class See Also Send Feedback
Initializes a new instance of the PageSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PageSection()
Visual Basic (Declaration)
Protected Sub New

See Also

PageSection Class
Telerik.Reporting Namespace


PageSection Methods

[image] [image]

Telerik Reporting Q2 2012
PageSection Methods
PageSection Class See Also Send Feedback

The PageSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

PageSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PageSection..::.Dispose Method
PageSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

PageSection Class
PageSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PageSection..::.ToString Method
PageSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PageSection Class
PageSection Members
Telerik.Reporting Namespace


PageSection Properties

[image] [image]

Telerik Reporting Q2 2012
PageSection Properties
PageSection Class See Also Send Feedback

The PageSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
PrintOnFirstPage | Gets or sets a value indicating whether the section should print on the first page of the report.
PrintOnLastPage | Gets or sets a value indicating whether the section should print on the last page of the report.
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

PageSection Class
Telerik.Reporting Namespace


PrintOnFirstPage Property

[image]

Telerik Reporting Q2 2012
PageSection..::.PrintOnFirstPage Property
PageSection Class See Also Send Feedback
Gets or sets a value indicating whether the section should print on the first page of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnFirstPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean

Field Value

A boolean value indicating whether the section should print on the first page of the report.

See Also

PageSection Class
Telerik.Reporting Namespace


PrintOnLastPage Property

[image]

Telerik Reporting Q2 2012
PageSection..::.PrintOnLastPage Property
PageSection Class See Also Send Feedback
Gets or sets a value indicating whether the section should print on the last page of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnLastPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean

Field Value

A boolean value indicating whether the section should print on the last page of the report.

See Also

PageSection Class
Telerik.Reporting Namespace


PageSection Events

[image] [image]

Telerik Reporting Q2 2012
PageSection Events
PageSection Class See Also Send Feedback

The PageSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PageSection Class
Telerik.Reporting Namespace


Panel Class

[image]

Telerik Reporting Q2 2012
Panel Class
Members See Also Send Feedback
Provides a grouping mechanism for organizing report items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Panel : ReportItem
Visual Basic (Declaration)
Public Class Panel _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Panel

See Also

Panel Members
Telerik.Reporting Namespace


Panel Members

[image] [image]

Telerik Reporting Q2 2012
Panel Members
Panel Class Constructors Methods Properties Events See Also Send Feedback

The Panel type exposes the following members.

Constructors

Name | Description
Panel | Initializes a new instance of the Panel class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Panel on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Panel Class
Telerik.Reporting Namespace


Panel Constructor

[image]

Telerik Reporting Q2 2012
Panel Constructor
Panel Class See Also Send Feedback
Initializes a new instance of the Panel class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Panel()
Visual Basic (Declaration)
Public Sub New

See Also

Panel Class
Telerik.Reporting Namespace


Panel Methods

[image] [image]

Telerik Reporting Q2 2012
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

Panel Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Panel..::.Dispose Method
Panel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Panel Class
Panel Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Panel..::.ToString Method
Panel Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Panel Class
Panel Members
Telerik.Reporting Namespace


Panel Properties

[image] [image]

Telerik Reporting Q2 2012
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Panel on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Panel Class
Telerik.Reporting Namespace


DefaultSize Property

[image]

Telerik Reporting Q2 2012
Panel..::.DefaultSize Property
Panel Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override SizeU DefaultSize { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As SizeU

See Also

Panel Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
Panel..::.KeepTogether Property
Panel Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the Panel on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the Panel on one page if possible.

See Also

Panel Class
Telerik.Reporting Namespace


Panel Events

[image] [image]

Telerik Reporting Q2 2012
Panel Events
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Panel Class
Telerik.Reporting Namespace


Parameter Class

[image]

Telerik Reporting Q2 2012
Parameter Class
Members See Also Send Feedback
Represents a parameter of nested report (subreport)

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class Parameter : INotifyPropertyChanged,
    IEquatable<Parameter>
Visual Basic (Declaration)
Public NotInheritable Class Parameter _
    Implements INotifyPropertyChanged, IEquatable(Of Parameter)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Parameter

See Also

Parameter Members
Telerik.Reporting Namespace


Parameter Members

[image] [image]

Telerik Reporting Q2 2012
Parameter Members
Parameter Class Constructors Methods Properties Events See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Overloaded.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Name |
Value |

Events

Name | Description
PropertyChanged |

See Also

Parameter Class
Telerik.Reporting Namespace


Parameter Constructor

[image] [image]

Telerik Reporting Q2 2012
Parameter Constructor
Parameter Class See Also Send Feedback

Overload List

Name | Description
Parameter()()() | Initializes a new instance of the Parameter class
Parameter(Parameter) | Initializes a new instance of the Parameter class
Parameter(String, Object) | Initializes a new instance of the Parameter class

See Also

Parameter Class
Parameter Members
Telerik.Reporting Namespace


Parameter Constructor

[image]

Telerik Reporting Q2 2012
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New

See Also

Parameter Class
Parameter Overload
Telerik.Reporting Namespace


Parameter Constructor (Parameter)

[image]

Telerik Reporting Q2 2012
Parameter Constructor (Parameter)
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Parameter(
    Parameter p
)
Visual Basic (Declaration)
Public Sub New ( _
    p As Parameter _
)

Parameters

p
Type: Telerik.Reporting..::.Parameter

See Also

Parameter Class
Parameter Overload
Telerik.Reporting Namespace


Parameter Constructor (String, Object)

[image]

Telerik Reporting Q2 2012
Parameter Constructor (String, Object)
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Parameter(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
value
Type: System..::.Object

See Also

Parameter Class
Parameter Overload
Telerik.Reporting Namespace


Parameter Methods

[image] [image]

Telerik Reporting Q2 2012
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

See Also

Parameter Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
Parameter..::.Equals Method
Parameter Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(Parameter) |

See Also

Parameter Class
Parameter Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
Parameter..::.Equals Method (Object)
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

Parameter Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (Parameter)

[image]

Telerik Reporting Q2 2012
Parameter..::.Equals Method (Parameter)
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    Parameter p
)
Visual Basic (Declaration)
Public Function Equals ( _
    p As Parameter _
) As Boolean

Parameters

p
Type: Telerik.Reporting..::.Parameter

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

Parameter Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Parameter..::.GetHashCode Method
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

Parameter Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Parameter..::.ToString Method
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Parameter Class
Telerik.Reporting Namespace


Parameter Properties

[image] [image]

Telerik Reporting Q2 2012
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
Name |
Value |

See Also

Parameter Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Name Property
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

Parameter Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Value Property
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

Parameter Class
Telerik.Reporting Namespace


Parameter Events

[image] [image]

Telerik Reporting Q2 2012
Parameter Events
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Parameter Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Parameter..::.PropertyChanged Event
Parameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Parameter Class
Telerik.Reporting Namespace


ParameterCollection Class

[image]

Telerik Reporting Q2 2012
ParameterCollection Class
Members See Also Send Feedback
Represents a collection of Parameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ParameterCollection : Collection<Parameter>,
    IEquatable<ParameterCollection>
Visual Basic (Declaration)
Public Class ParameterCollection _
    Inherits Collection(Of Parameter) _
    Implements IEquatable(Of ParameterCollection)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Parameter >)>)>
Telerik.Reporting..::.ParameterCollection

See Also

ParameterCollection Members
Telerik.Reporting Namespace


ParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Members
ParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ParameterCollection type exposes the following members.

Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class

Methods

Name | Description
Add | Creates a Parameter with specific settings and adds it to the ParameterCollection.
AddRange | Adds an enumerable of Parameter objects to the ParameterCollection.
Contains | Determines whether the ParameterCollection contains a parameter with a specific name.
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
IndexOf | Determines the index of a specific parameter in the ParameterCollection.
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Item | Gets a Parameter by name.

See Also

ParameterCollection Class
Telerik.Reporting Namespace


ParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
ParameterCollection Constructor
ParameterCollection Class See Also Send Feedback
Initializes a new instance of the ParameterCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ParameterCollection Class
Telerik.Reporting Namespace


ParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Methods
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Methods

Name | Description
Add | Creates a Parameter with specific settings and adds it to the ParameterCollection.
AddRange | Adds an enumerable of Parameter objects to the ParameterCollection.
Contains | Determines whether the ParameterCollection contains a parameter with a specific name.
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)
IndexOf | Determines the index of a specific parameter in the ParameterCollection.
ToString | (Overrides Object..::.ToString()()().)

See Also

ParameterCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Add Method
ParameterCollection Class See Also Send Feedback
Creates a Parameter with specific settings and adds it to the ParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
A String value that will be used as Name for the newly created Parameter.
value
Type: System..::.Object
A Object value that will be used as Value for the newly created Parameter. May be expression.

Return Value

The newly created and added Parameter

See Also

ParameterCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.AddRange Method
ParameterCollection Class See Also Send Feedback
Adds an enumerable of Parameter objects to the ParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<Parameter> collection
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    collection As IEnumerable(Of Parameter) _
)

Parameters

collection
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Parameter >)>)>

Remarks

The Parameter objects returned from the enumerable are appended to the end of the ParameterCollection.

See Also

ParameterCollection Class
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Contains Method
ParameterCollection Class See Also Send Feedback
Determines whether the ParameterCollection contains a parameter with a specific name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
A String that specifies the parameter name for which to search the elements of the ParameterCollection.

Return Value

Returns a Boolean value indicating whether the ParameterCollection object contains a parameter with the specified name.

See Also

ParameterCollection Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection..::.Equals Method
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ParameterCollection) |

See Also

ParameterCollection Class
ParameterCollection Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Equals Method (Object)
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

ParameterCollection Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (ParameterCollection)

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Equals Method (ParameterCollection)
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    ParameterCollection other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As ParameterCollection _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.ParameterCollection

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

ParameterCollection Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.GetHashCode Method
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

ParameterCollection Class
Telerik.Reporting Namespace


IndexOf Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.IndexOf Method
ParameterCollection Class See Also Send Feedback
Determines the index of a specific parameter in the ParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    string name
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    name As String _
) As Integer

Parameters

name
Type: System..::.String
The parameter name used to locate the parameter in the ParameterCollection.

Return Value

The index of parameter if found in the ParameterCollection; otherwise, -1.

See Also

ParameterCollection Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.ToString Method
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ParameterCollection Class
Telerik.Reporting Namespace


ParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Properties
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Properties

Name | Description
Item | Gets a Parameter by name.

See Also

ParameterCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Item Property
ParameterCollection Class See Also Send Feedback
Gets a Parameter by name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Parameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Parameter

Parameters

name
Type: System..::.String
The name of the parameter.

Return Value

A parameter if found; otherwise null (Nothing)

See Also

ParameterCollection Class
Telerik.Reporting Namespace


PictureBox Class

[image]

Telerik Reporting Q2 2012
PictureBox Class
Members See Also Send Feedback
Represents a picture box report item for displaying an image.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PictureBox : ReportItem
Visual Basic (Declaration)
Public Class PictureBox _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.PictureBox

See Also

PictureBox Members
Telerik.Reporting Namespace


PictureBox Members

[image] [image]

Telerik Reporting Q2 2012
PictureBox Members
PictureBox Class Constructors Methods Properties Events See Also Send Feedback

The PictureBox type exposes the following members.

Constructors

Name | Description
PictureBox | Initializes a new instance of the PictureBox class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | This member overrides DefaultSize. (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
MimeType | Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sizing | Gets or sets the sizing mode of the PictureBox.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the value associated with this PictureBox.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PictureBox Class
Telerik.Reporting Namespace


PictureBox Constructor

[image]

Telerik Reporting Q2 2012
PictureBox Constructor
PictureBox Class See Also Send Feedback
Initializes a new instance of the PictureBox class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PictureBox()
Visual Basic (Declaration)
Public Sub New

See Also

PictureBox Class
Telerik.Reporting Namespace


PictureBox Methods

[image] [image]

Telerik Reporting Q2 2012
PictureBox Methods
PictureBox Class See Also Send Feedback

The PictureBox type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

PictureBox Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PictureBox..::.Dispose Method
PictureBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | Releases the unmanaged resources used by the PictureBox and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)

See Also

PictureBox Class
PictureBox Members
Telerik.Reporting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
PictureBox..::.Dispose Method (Boolean)
PictureBox Class See Also Send Feedback
Releases the unmanaged resources used by the PictureBox and optionally releases the managed resources

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

PictureBox Class
Dispose Overload
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PictureBox..::.ToString Method
PictureBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PictureBox Class
PictureBox Members
Telerik.Reporting Namespace


PictureBox Properties

[image] [image]

Telerik Reporting Q2 2012
PictureBox Properties
PictureBox Class See Also Send Feedback

The PictureBox type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | This member overrides DefaultSize. (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
MimeType | Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sizing | Gets or sets the sizing mode of the PictureBox.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the value associated with this PictureBox.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

PictureBox Class
Telerik.Reporting Namespace


DefaultSize Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.DefaultSize Property
PictureBox Class See Also Send Feedback
This member overrides DefaultSize.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override SizeU DefaultSize { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As SizeU

Field Value

A SizeU object that defines the default size of the PictureBox. It is 100 pixels wide by 100 pixels high by default.

See Also

PictureBox Class
Telerik.Reporting Namespace


MimeType Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.MimeType Property
PictureBox Class See Also Send Feedback
Gets or sets a string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string MimeType { get; set; }
Visual Basic (Declaration)
Public Property MimeType As String

Field Value

A string that contains the picture box's Multipurpose Internet Mail Extensions (MIME) type.

See Also

PictureBox Class
Telerik.Reporting Namespace


Sizing Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.Sizing Property
PictureBox Class See Also Send Feedback
Gets or sets the sizing mode of the PictureBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageSizeMode Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As ImageSizeMode

Field Value

A ImageSizeMode object that specifies the sizing mode of the PictureBox.

See Also

PictureBox Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.Value Property
PictureBox Class See Also Send Feedback
Gets or sets the value associated with this PictureBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

Field Value

A String that starts with "=" is interpreted as data expression; Image that holds an image data.

See Also

PictureBox Class
Telerik.Reporting Namespace


PictureBox Events

[image] [image]

Telerik Reporting Q2 2012
PictureBox Events
PictureBox Class See Also Send Feedback

The PictureBox type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

PictureBox Class
Telerik.Reporting Namespace


Report Class

[image]

Telerik Reporting Q2 2012
Report Class
Members See Also Send Feedback
Represents the base class for any report in the Telerik Reporting.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Report : ReportItemBase, ISupportInitialize,
    IReportDocument, IComponent, IDisposable
Visual Basic (Declaration)
Public Class Report _
    Inherits ReportItemBase _
    Implements ISupportInitialize, IReportDocument, IComponent, IDisposable

Remarks

All reports created with Telerik Reporting inherit from the Report class. The Report comprises of one or more report sections which contain report items.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.Report

See Also

Report Members
Telerik.Reporting Namespace


Report Members

[image] [image]

Telerik Reporting Q2 2012
Report Members
Report Class Constructors Methods Operators Properties Events Explicit Interface Implementations See Also Send Feedback

The Report type exposes the following members.

Constructors

Name | Description
Report | Initializes a new instance of the Report class with default settings.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnError |
OnItemAdded | (Overrides ReportItemBase..::.OnItemAdded(ReportItemBase).)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource |
ToString | Overloaded.

Operators

Name | Description
Implicit | Obsolete.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the report.
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Report will render.
DataSource | Gets or sets the data source that the Report is displaying data for.
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
DocumentName | Gets or sets a String representing the name of the report document.
ExternalStyles | Obsolete.
ExternalStyleSheets | Gets the collection of ExternalStyleSheets for the report.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Report
Groups | Gets a GroupCollection that defines the groups for the Report
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageNumberingStyle | Gets or sets a PageNumberingStyle for the Report.
PageSettings | Gets or sets the page settings for the Report .
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
ReportParameters |
Site | (Inherited from ReportItemBase.)
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Report
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
StyleSheet | Gets the StyleSheet associated with the report.
UnitOfMeasure | Gets or sets the default unit of measure for the report.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
Error |
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the report has no data source set.

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit |
ISupportInitialize..::.EndInit |
IReportDocument..::.ReportParameters |
IReportDocument..::.Reports |

See Also

Report Class
Telerik.Reporting Namespace


Report Constructor

[image]

Telerik Reporting Q2 2012
Report Constructor
Report Class See Also Send Feedback
Initializes a new instance of the Report class with default settings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Report()
Visual Basic (Declaration)
Public Sub New

See Also

Report Class
Telerik.Reporting Namespace


Report Methods

[image] [image]

Telerik Reporting Q2 2012
Report Methods
Report Class See Also Send Feedback

The Report type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnError |
OnItemAdded | (Overrides ReportItemBase..::.OnItemAdded(ReportItemBase).)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource |
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit |
ISupportInitialize..::.EndInit |

See Also

Report Class
Telerik.Reporting Namespace


ISupportInitialize.BeginInit Method

[image]

Telerik Reporting Q2 2012
Report..::.ISupportInitialize..::.BeginInit Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ISupportInitialize.BeginInit()
Visual Basic (Declaration)
Private Sub BeginInit Implements ISupportInitialize.BeginInit

Implements

ISupportInitialize..::.BeginInit()()()

See Also

Report Class
Telerik.Reporting Namespace


ISupportInitialize.EndInit Method

[image]

Telerik Reporting Q2 2012
Report..::.ISupportInitialize..::.EndInit Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ISupportInitialize.EndInit()
Visual Basic (Declaration)
Private Sub EndInit Implements ISupportInitialize.EndInit

Implements

ISupportInitialize..::.EndInit()()()

See Also

Report Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Report..::.Dispose Method
Report Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Report Class
Report Members
Telerik.Reporting Namespace


OnError Method

[image]

Telerik Reporting Q2 2012
Report..::.OnError Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnError(
    Object sender,
    ErrorEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnError ( _
    sender As Object, _
    e As ErrorEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: Telerik.Reporting..::.ErrorEventArgs

See Also

Report Class
Telerik.Reporting Namespace


OnItemAdded Method

[image]

Telerik Reporting Q2 2012
Report..::.OnItemAdded Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnItemAdded(
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemAdded ( _
    item As ReportItemBase _
)

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase

See Also

Report Class
Telerik.Reporting Namespace


OnNeedDataSource Method

[image]

Telerik Reporting Q2 2012
Report..::.OnNeedDataSource Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnNeedDataSource(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnNeedDataSource ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Report Class
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Report..::.ToString Method
Report Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Report Class
Report Members
Telerik.Reporting Namespace


Report Operators

[image] [image]

Telerik Reporting Q2 2012
Report Operators
Report Class See Also Send Feedback

The Report type exposes the following members.

Operators

Name | Description
Implicit | Obsolete.

See Also

Report Class
Telerik.Reporting Namespace


Implicit Operator

[image]

Telerik Reporting Q2 2012
Report..::.Implicit Operator
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static implicit operator ReportSource (
    Report report
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    report As Report _
) As ReportSource

Parameters

report
Type: Telerik.Reporting..::.Report

See Also

Report Class
Telerik.Reporting Namespace


Report Properties

[image] [image]

Telerik Reporting Q2 2012
Report Properties
Report Class See Also Send Feedback

The Report type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the report.
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Report will render.
DataSource | Gets or sets the data source that the Report is displaying data for.
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
DocumentName | Gets or sets a String representing the name of the report document.
ExternalStyles | Obsolete.
ExternalStyleSheets | Gets the collection of ExternalStyleSheets for the report.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Report
Groups | Gets a GroupCollection that defines the groups for the Report
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageNumberingStyle | Gets or sets a PageNumberingStyle for the Report.
PageSettings | Gets or sets the page settings for the Report .
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
ReportParameters |
Site | (Inherited from ReportItemBase.)
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Report
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
StyleSheet | Gets the StyleSheet associated with the report.
UnitOfMeasure | Gets or sets the default unit of measure for the report.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report.

Explicit Interface Implementations

Name | Description
IReportDocument..::.ReportParameters |
IReportDocument..::.Reports |

See Also

Report Class
Telerik.Reporting Namespace


Culture Property

[image]

Telerik Reporting Q2 2012
Report..::.Culture Property
Report Class See Also Send Feedback
Gets or sets the culture information associated with the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As CultureInfo

Field Value

A CultureInfo representing the culture supported by the Report.

See Also

Report Class
Telerik.Reporting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Report..::.DataMember Property
Report Class See Also Send Feedback
Gets or sets the specific list in a DataSource which the Report will render.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

Field Value

A list in a DataSource. The default is an empty string ("").

Remarks

If a DataSource contains multiple sources of data, you should set the DataMember to one of the sources. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

If the DataSource is a DataTable, DataView, collection, or array, there is no need to set the DataMember property of the Report

See Also

Report Class
Telerik.Reporting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Report..::.DataSource Property
Report Class See Also Send Feedback
Gets or sets the data source that the Report is displaying data for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

Field Value

An object that functions as a data source.

Remarks

The following data sources are valid:

  • A DataTable
  • A DataView
  • A DataSet
  • A DataViewManager
  • Any component that implements the IListSource interface
  • Any component that implements the IEnumerable interface
  • Any component that implements the IDataAdapter interface

If the DataSource reference contains more than one table, you must set the DataMember property a string that specifies the table to bind to. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

Setting the DataSource to an object that does not implement the IListSource, IEnumerable, or IDataAdapter will cause an exception.

See Also

Report Class
Telerik.Reporting Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
Report..::.DocumentName Property
Report Class See Also Send Feedback
Gets or sets a String representing the name of the report document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

Field Value

A String representing the document name. The default value is the name of the Report this property belongs to.

Implements

IReportDocument..::.DocumentName

Remarks

The value of this property is used to suggest a file name when exporting a report to one of the available export formats.

A String that starts with "=" is interpreted as an expression to evaluate the document name; otherwise it is interpreted as a literal string.

See Also

Report Class
Telerik.Reporting Namespace


ExternalStyles Property

[image]

Telerik Reporting Q2 2012
Report..::.ExternalStyles Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ExternalStyleSheets property instead.")]
public ICollection<string> ExternalStyles { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ExternalStyleSheets property instead.")> _
Public ReadOnly Property ExternalStyles As ICollection(Of String)

See Also

Report Class
Telerik.Reporting Namespace


ExternalStyleSheets Property

[image]

Telerik Reporting Q2 2012
Report..::.ExternalStyleSheets Property
Report Class See Also Send Feedback
Gets the collection of ExternalStyleSheets for the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ICollection<ExternalStyleSheet> ExternalStyleSheets { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExternalStyleSheets As ICollection(Of ExternalStyleSheet)

See Also

Report Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
Report..::.Filters Property
Report Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

Field Value

A [!:Telerik.Reporting.Data.FilterCollection] that contains the Filter objects for the Report

Remarks

Filter expressions limit the data that is displayed to the user after the data is retrieved from the data source.

See Also

Report Class
Telerik.Reporting Namespace


Groups Property

[image]

Telerik Reporting Q2 2012
Report..::.Groups Property
Report Class See Also Send Feedback
Gets a GroupCollection that defines the groups for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupCollection Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As GroupCollection

Field Value

A GroupCollection that contains the Group objects for the Report

Remarks

Grouping is used to gather all rows that match certain grouping criteria together. Grouping criteria is defined by adding one or more Grouping objects to a Group.

See Also

Report Class
Telerik.Reporting Namespace


IReportDocument.ReportParameters Property

[image]

Telerik Reporting Q2 2012
Report..::.IReportDocument..::.ReportParameters Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<IReportParameter> IReportDocument.ReportParameters { get; }
Visual Basic (Declaration)
Private ReadOnly Property ReportParameters As IEnumerable(Of IReportParameter)
    Implements IReportDocument.ReportParameters

Implements

IReportDocument..::.ReportParameters

See Also

Report Class
Telerik.Reporting Namespace


IReportDocument.Reports Property

[image]

Telerik Reporting Q2 2012
Report..::.IReportDocument..::.Reports Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<Report> IReportDocument.Reports { get; }
Visual Basic (Declaration)
Private ReadOnly Property Reports As IEnumerable(Of Report)
    Implements IReportDocument.Reports

Implements

IReportDocument..::.Reports

See Also

Report Class
Telerik.Reporting Namespace


PageNumberingStyle Property

[image]

Telerik Reporting Q2 2012
Report..::.PageNumberingStyle Property
Report Class See Also Send Feedback
Gets or sets a PageNumberingStyle for the Report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageNumberingStyle PageNumberingStyle { get; set; }
Visual Basic (Declaration)
Public Property PageNumberingStyle As PageNumberingStyle

Field Value

A PageNumberingStyle representing the page numbering style. The default value is Continue

Remarks

When the report is part of a ReportBook, use this property to indicate whether the page numbering / count should start from 1 or continue from the last page number / count of the previous report.

See Also

Report Class
Telerik.Reporting Namespace


PageSettings Property

[image]

Telerik Reporting Q2 2012
Report..::.PageSettings Property
Report Class See Also Send Feedback
Gets or sets the page settings for the Report .

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSettings PageSettings { get; set; }
Visual Basic (Declaration)
Public Property PageSettings As PageSettings

Field Value

The page settings for the Report.

Implements

IReportDocument..::.PageSettings

See Also

Report Class
Telerik.Reporting Namespace


ReportParameters Property

[image]

Telerik Reporting Q2 2012
Report..::.ReportParameters Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterCollection ReportParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportParameters As ReportParameterCollection

See Also

Report Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
Report..::.Sorting Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

Report Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
Report..::.Sortings Property
Report Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

Field Value

A [!:Telerik.Reporting.Data.SortingCollection] that contains the Sorting objects for the Report

Remarks

Sort expressions sort the data that is displayed to the user after the data is retrieved from the data source.

See Also

Report Class
Telerik.Reporting Namespace


StyleSheet Property

[image]

Telerik Reporting Q2 2012
Report..::.StyleSheet Property
Report Class See Also Send Feedback
Gets the StyleSheet associated with the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSheet StyleSheet { get; }
Visual Basic (Declaration)
Public ReadOnly Property StyleSheet As StyleSheet

Field Value

A StyleSheet object representing a collection of style rules.

Remarks

The StyleSheet property of a report can be used to define various types of styles for use by the report items.

See Also

Report Class
Telerik.Reporting Namespace


UnitOfMeasure Property

[image]

Telerik Reporting Q2 2012
Report..::.UnitOfMeasure Property
Report Class See Also Send Feedback
Gets or sets the default unit of measure for the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public UnitType UnitOfMeasure { get; set; }
Visual Basic (Declaration)
Public Property UnitOfMeasure As UnitType

Field Value

An UnitType representing the default unit of measure for the report.

Remarks

All newly created report items will have their locations, sizes, etc. in this UnitType.

See Also

Report Class
Telerik.Reporting Namespace


Width Property

[image]

Telerik Reporting Q2 2012
Report..::.Width Property
Report Class See Also Send Feedback
Gets or sets the width of the report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

Field Value

The width of the report in Units.

See Also

Report Class
Telerik.Reporting Namespace


Report Events

[image] [image]

Telerik Reporting Q2 2012
Report Events
Report Class See Also Send Feedback

The Report type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
Error |
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the report has no data source set.

See Also

Report Class
Telerik.Reporting Namespace


Error Event

[image]

Telerik Reporting Q2 2012
Report..::.Error Event
Report Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event ErrorEventHandler Error
Visual Basic (Declaration)
Public Event Error As ErrorEventHandler

See Also

Report Class
Telerik.Reporting Namespace


NeedDataSource Event

[image]

Telerik Reporting Q2 2012
Report..::.NeedDataSource Event
Report Class See Also Send Feedback
Occurs at the start of report processing if the report has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler NeedDataSource
Visual Basic (Declaration)
Public Event NeedDataSource As EventHandler

See Also

Report Class
Telerik.Reporting Namespace


ReportBook Class

[image]

Telerik Reporting Q2 2012
ReportBook Class
Members See Also Send Feedback
Represents a collection of reports logically unified as a single document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportBook : Component, IReportDocument,
    IComponent, IDisposable
Visual Basic (Declaration)
Public Class ReportBook _
    Inherits Component _
    Implements IReportDocument, IComponent, IDisposable

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.ReportBook

See Also

ReportBook Members
Telerik.Reporting Namespace


ReportBook Members

[image] [image]

Telerik Reporting Q2 2012
ReportBook Members
ReportBook Class Constructors Properties Explicit Interface Implementations See Also Send Feedback

The ReportBook type exposes the following members.

Constructors

Name | Description
ReportBook | Overloaded.

Properties

Name | Description
DocumentName | Gets or sets a String representing the name of the document.
Reports | Gets the collection of reports that are parts of this ReportBook.

Explicit Interface Implementations

Name | Description
IReportDocument..::.PageSettings | For internal use only.
IReportDocument..::.ReportParameters | Gets the ReportParameters of the ReportBook. Parameters are obtained by merging the parameters of individual reports that have their Mergeable property set to true plus adding all non-mergable parameters.
IReportDocument..::.Reports | Gets the reports contained in the ReportBook.

See Also

ReportBook Class
Telerik.Reporting Namespace


ReportBook Constructor

[image] [image]

Telerik Reporting Q2 2012
ReportBook Constructor
ReportBook Class See Also Send Feedback

Overload List

Name | Description
ReportBook()()() | Initializes a new instance of the ReportBook class with default settings.
ReportBook(IEnumerable<(Of <(Report>)>)) | Initializes a new instance of the ReportBook class from the provided reports.
ReportBook(IEnumerable<(Of <(Report>)>), String) | Initializes a new instance of the ReportBook class from the provided reports and document name.

See Also

ReportBook Class
ReportBook Members
Telerik.Reporting Namespace


ReportBook Constructor

[image]

Telerik Reporting Q2 2012
ReportBook Constructor
ReportBook Class See Also Send Feedback
Initializes a new instance of the ReportBook class with default settings.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportBook()
Visual Basic (Declaration)
Public Sub New

See Also

ReportBook Class
ReportBook Overload
Telerik.Reporting Namespace


ReportBook Constructor (IEnumerable(Report))

[image]

Telerik Reporting Q2 2012
ReportBook Constructor (IEnumerable<(Of <(<'Report>)>)>)
ReportBook Class See Also Send Feedback
Initializes a new instance of the ReportBook class from the provided reports.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportBook(
    IEnumerable<Report> reports
)
Visual Basic (Declaration)
Public Sub New ( _
    reports As IEnumerable(Of Report) _
)

Parameters

reports
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Report >)>)>

See Also

ReportBook Class
ReportBook Overload
Telerik.Reporting Namespace


ReportBook Constructor (IEnumerable(Report), String)

[image]

Telerik Reporting Q2 2012
ReportBook Constructor (IEnumerable<(Of <(<'Report>)>)>, String)
ReportBook Class See Also Send Feedback
Initializes a new instance of the ReportBook class from the provided reports and document name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportBook(
    IEnumerable<Report> reports,
    string documentName
)
Visual Basic (Declaration)
Public Sub New ( _
    reports As IEnumerable(Of Report), _
    documentName As String _
)

Parameters

reports
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Report >)>)>
documentName
Type: System..::.String

See Also

ReportBook Class
ReportBook Overload
Telerik.Reporting Namespace


ReportBook Properties

[image] [image]

Telerik Reporting Q2 2012
ReportBook Properties
ReportBook Class See Also Send Feedback

The ReportBook type exposes the following members.

Properties

Name | Description
DocumentName | Gets or sets a String representing the name of the document.
Reports | Gets the collection of reports that are parts of this ReportBook.

Explicit Interface Implementations

Name | Description
IReportDocument..::.PageSettings | For internal use only.
IReportDocument..::.ReportParameters | Gets the ReportParameters of the ReportBook. Parameters are obtained by merging the parameters of individual reports that have their Mergeable property set to true plus adding all non-mergable parameters.
IReportDocument..::.Reports | Gets the reports contained in the ReportBook.

See Also

ReportBook Class
Telerik.Reporting Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
ReportBook..::.DocumentName Property
ReportBook Class See Also Send Feedback
Gets or sets a String representing the name of the document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

Field Value

A String representing the document name. The default value is the Type name of the ReportBook this property belongs to.

Implements

IReportDocument..::.DocumentName

Remarks

The value of this property is used to suggest a file name when exporting to one of the available export formats.

A String that starts with "=" is interpreted as an expression to evaluate the document name; otherwise it is interpreted as a literal string.

See Also

ReportBook Class
Telerik.Reporting Namespace


IReportDocument.PageSettings Property

[image]

Telerik Reporting Q2 2012
ReportBook..::.IReportDocument..::.PageSettings Property
ReportBook Class See Also Send Feedback
For internal use only.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PageSettings IReportDocument.PageSettings { get; set; }
Visual Basic (Declaration)
Private Property PageSettings As PageSettings
    Implements IReportDocument.PageSettings

Implements

IReportDocument..::.PageSettings

See Also

ReportBook Class
Telerik.Reporting Namespace


IReportDocument.ReportParameters Property

[image]

Telerik Reporting Q2 2012
ReportBook..::.IReportDocument..::.ReportParameters Property
ReportBook Class See Also Send Feedback
Gets the ReportParameters of the ReportBook. Parameters are obtained by merging the parameters of individual reports that have their Mergeable property set to true plus adding all non-mergable parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<IReportParameter> IReportDocument.ReportParameters { get; }
Visual Basic (Declaration)
Private ReadOnly Property ReportParameters As IEnumerable(Of IReportParameter)
    Implements IReportDocument.ReportParameters

Implements

IReportDocument..::.ReportParameters

See Also

ReportBook Class
Telerik.Reporting Namespace


IReportDocument.Reports Property

[image]

Telerik Reporting Q2 2012
ReportBook..::.IReportDocument..::.Reports Property
ReportBook Class See Also Send Feedback
Gets the reports contained in the ReportBook.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<Report> IReportDocument.Reports { get; }
Visual Basic (Declaration)
Private ReadOnly Property Reports As IEnumerable(Of Report)
    Implements IReportDocument.Reports

Implements

IReportDocument..::.Reports

See Also

ReportBook Class
Telerik.Reporting Namespace


Reports Property

[image]

Telerik Reporting Q2 2012
ReportBook..::.Reports Property
ReportBook Class See Also Send Feedback
Gets the collection of reports that are parts of this ReportBook.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportCollection Reports { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reports As ReportCollection

See Also

ReportBook Class
Telerik.Reporting Namespace


ReportCollection Class

[image]

Telerik Reporting Q2 2012
ReportCollection Class
Members See Also Send Feedback
Represents a collection of Report objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportCollection : Collection<Report>
Visual Basic (Declaration)
Public Class ReportCollection _
    Inherits Collection(Of Report)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Report >)>)>
Telerik.Reporting..::.ReportCollection

See Also

ReportCollection Members
Telerik.Reporting Namespace


ReportCollection Members

[image] [image]

Telerik Reporting Q2 2012
ReportCollection Members
ReportCollection Class Constructors Methods See Also Send Feedback

The ReportCollection type exposes the following members.

Constructors

Name | Description
ReportCollection | Initializes a new instance of the ReportCollection class

Methods

Name | Description
AddRange | Adds an array of report objects to the collection.

See Also

ReportCollection Class
Telerik.Reporting Namespace


ReportCollection Constructor

[image]

Telerik Reporting Q2 2012
ReportCollection Constructor
ReportCollection Class See Also Send Feedback
Initializes a new instance of the ReportCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ReportCollection Class
Telerik.Reporting Namespace


ReportCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportCollection Methods
ReportCollection Class See Also Send Feedback

The ReportCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds an array of report objects to the collection.

See Also

ReportCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ReportCollection..::.AddRange Method
ReportCollection Class See Also Send Feedback
Adds an array of report objects to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    Report[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As Report() _
)

Parameters

items
Type: array< Telerik.Reporting..::.Report >[]()[][]
An array of Report objects to add to the collection.

Remarks

The Report objects contained in the items array are appended to the end of the collection.

See Also

ReportCollection Class
Telerik.Reporting Namespace


ReportFooterSection Class

[image]

Telerik Reporting Q2 2012
ReportFooterSection Class
Members See Also Send Feedback
Represents a report footer section. Report footer is displayed at the end of a report, but before the last PageFooterSection if any.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportFooterSection : ReportSection
Visual Basic (Declaration)
Public Class ReportFooterSection _
    Inherits ReportSection

Remarks

If you do not want a PageFooterSection displayed on the last page set the PrintOnLastPage property to false.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.ReportFooterSection

See Also

ReportFooterSection Members
Telerik.Reporting Namespace


ReportFooterSection Members

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection Members
ReportFooterSection Class Constructors Methods Properties Events See Also Send Feedback

The ReportFooterSection type exposes the following members.

Constructors

Name | Description
ReportFooterSection | Initializes a new instance of the ReportFooterSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Constructor

[image]

Telerik Reporting Q2 2012
ReportFooterSection Constructor
ReportFooterSection Class See Also Send Feedback
Initializes a new instance of the ReportFooterSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportFooterSection()
Visual Basic (Declaration)
Public Sub New

See Also

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection Methods
ReportFooterSection Class See Also Send Feedback

The ReportFooterSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

ReportFooterSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection..::.Dispose Method
ReportFooterSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

ReportFooterSection Class
ReportFooterSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection..::.ToString Method
ReportFooterSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportFooterSection Class
ReportFooterSection Members
Telerik.Reporting Namespace


ReportFooterSection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection Properties
ReportFooterSection Class See Also Send Feedback

The ReportFooterSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

ReportFooterSection Class
Telerik.Reporting Namespace


ReportFooterSection Events

[image] [image]

Telerik Reporting Q2 2012
ReportFooterSection Events
ReportFooterSection Class See Also Send Feedback

The ReportFooterSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportFooterSection Class
Telerik.Reporting Namespace


ReportHeaderSection Class

[image]

Telerik Reporting Q2 2012
ReportHeaderSection Class
Members See Also Send Feedback
Represents a report header section. Report header is displayed at the beginning of a report, but after the first PageHeaderSection if any.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportHeaderSection : ReportSection
Visual Basic (Declaration)
Public Class ReportHeaderSection _
    Inherits ReportSection

Remarks

If you do not want a PageHeaderSection displayed on the first page set the PrintOnFirstPage property to false.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.ReportHeaderSection

See Also

ReportHeaderSection Members
Telerik.Reporting Namespace


ReportHeaderSection Members

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection Members
ReportHeaderSection Class Constructors Methods Properties Events See Also Send Feedback

The ReportHeaderSection type exposes the following members.

Constructors

Name | Description
ReportHeaderSection | Initializes a new instance of the ReportHeaderSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Constructor

[image]

Telerik Reporting Q2 2012
ReportHeaderSection Constructor
ReportHeaderSection Class See Also Send Feedback
Initializes a new instance of the ReportHeaderSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportHeaderSection()
Visual Basic (Declaration)
Public Sub New

See Also

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection Methods
ReportHeaderSection Class See Also Send Feedback

The ReportHeaderSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

ReportHeaderSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection..::.Dispose Method
ReportHeaderSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

ReportHeaderSection Class
ReportHeaderSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection..::.ToString Method
ReportHeaderSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportHeaderSection Class
ReportHeaderSection Members
Telerik.Reporting Namespace


ReportHeaderSection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection Properties
ReportHeaderSection Class See Also Send Feedback

The ReportHeaderSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible. (Inherited from ReportSection.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection. (Inherited from ReportSection.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportHeaderSection Events

[image] [image]

Telerik Reporting Q2 2012
ReportHeaderSection Events
ReportHeaderSection Class See Also Send Feedback

The ReportHeaderSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportHeaderSection Class
Telerik.Reporting Namespace


ReportItem Class

[image]

Telerik Reporting Q2 2012
ReportItem Class
Members See Also Send Feedback
Defines the base class for all report items that can be placed in a ReportSectionBase. Items of this type have a location and a size.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportItem : ReportItemBase
Visual Basic (Declaration)
Public MustInherit Class ReportItem _
    Inherits ReportItemBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Barcode
Telerik.Reporting..::.Chart
Telerik.Reporting..::.HtmlTextBox
Telerik.Reporting..::.Panel
Telerik.Reporting..::.PictureBox
Telerik.Reporting..::.Shape
Telerik.Reporting..::.SubReport
Telerik.Reporting..::.Table
Telerik.Reporting..::.TextItemBase

See Also

ReportItem Members
Telerik.Reporting Namespace


ReportItem Members

[image] [image]

Telerik Reporting Q2 2012
ReportItem Members
ReportItem Class Constructors Methods Properties Events See Also Send Feedback

The ReportItem type exposes the following members.

Constructors

Name | Description
ReportItem | Initializes a new instance of the ReportItem class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete.
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item.
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete.
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportItem Class
Telerik.Reporting Namespace


ReportItem Constructor

[image]

Telerik Reporting Q2 2012
ReportItem Constructor
ReportItem Class See Also Send Feedback
Initializes a new instance of the ReportItem class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportItem()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportItem Class
Telerik.Reporting Namespace


ReportItem Methods

[image] [image]

Telerik Reporting Q2 2012
ReportItem Methods
ReportItem Class See Also Send Feedback

The ReportItem type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

ReportItem Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportItem..::.Dispose Method
ReportItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

ReportItem Class
ReportItem Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportItem..::.ToString Method
ReportItem Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportItem Class
ReportItem Members
Telerik.Reporting Namespace


ReportItem Properties

[image] [image]

Telerik Reporting Q2 2012
ReportItem Properties
ReportItem Class See Also Send Feedback

The ReportItem type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete.
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item.
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete.
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item.

See Also

ReportItem Class
Telerik.Reporting Namespace


Anchor Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Anchor Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Use the Anchoring property instead.")]
public AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use the Anchoring property instead.")> _
Public Property Anchor As AnchorStyles

See Also

ReportItem Class
Telerik.Reporting Namespace


Anchoring Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Anchoring Property
ReportItem Class See Also Send Feedback
Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AnchoringStyles Anchoring { get; set; }
Visual Basic (Declaration)
Public Property Anchoring As AnchoringStyles

Field Value

A bitwise combination of the AnchoringStyles values. The default is None.

Remarks

Use the Anchoring property to define how a report is automatically resized as its parent item is resized. Anchoring a report to its parent ensures that the anchored edges remain in the same position relative to the edges of the parent when the parent control is resized.

You can anchor a report item to one or more edges of its container. For example, if you have a DetailSection with a TextBox whose Anchoring property value is set to Top and Bottom, the TextBox is stretched to maintain the anchored distance to the top and bottom edges of the DetailSection as the Height of the DetailSection is increased.

Note:The Anchoring and Docking properties are mutually exclusive. Only one can be set at a time, and the last one set takes precedence.

See Also

ReportItem Class
Telerik.Reporting Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Bottom Property
ReportItem Class See Also Send Feedback
Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Unit

Field Value

An Unit representing the distance between the bottom edge of the report item and the top edge of its container's client area.

Remarks

The value of the Bottom property is equal to the sum of the Top property value and the Height property value.

See Also

ReportItem Class
Telerik.Reporting Namespace


Bounds Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Bounds Property
ReportItem Class See Also Send Feedback
Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As RectangleU

Field Value

A RectangleU relative to the parent report item that represents the size and location of the report item including its nonclient elements.

Remarks

The bounds of the report item include the nonclient elements such as borders and padding.

See Also

ReportItem Class
Telerik.Reporting Namespace


DefaultSize Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.DefaultSize Property
ReportItem Class See Also Send Feedback
Gets the default size of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual SizeU DefaultSize { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultSize As SizeU

Field Value

The default SizeU of the report item.

Remarks

The DefaultSize property represents the SizeU of the report item when it is initially created. You can adjust the size of the report item by setting its Size property value.

See Also

ReportItem Class
Telerik.Reporting Namespace


Dock Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Dock Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Use the Docking property instead.")]
public DockStyle Dock { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use the Docking property instead.")> _
Public Property Dock As DockStyle

See Also

ReportItem Class
Telerik.Reporting Namespace


Docking Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Docking Property
ReportItem Class See Also Send Feedback
Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DockingStyle Docking { get; set; }
Visual Basic (Declaration)
Public Property Docking As DockingStyle

Field Value

One of the DockStyle values. The default is None.

Remarks

Use the Docking property to define how a report is automatically resized as its parent is resized. For example, setting Docking to Bottom causes the report item to align itself with the bottom edges of its parent and to resize as the parent is resized.

A report item can be docked to one edge of its parent container or can be docked to all edges and fill the parent container.

Note:The Anchoring and Docking properties are mutually exclusive. Only one can be set at a time, and the last one set takes precedence.

See Also

ReportItem Class
Telerik.Reporting Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Height Property
ReportItem Class See Also Send Feedback
Gets or sets the height of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

Field Value

The height of the report item in Units.

Remarks

Changes made to the Height and Top property values cause the Bottom property value of the report item to change.

See Also

ReportItem Class
Telerik.Reporting Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Left Property
ReportItem Class See Also Send Feedback
Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Unit

Field Value

An Unit representing the distance between the left edge of the report item and the left edge of its container's client area.

Remarks

The Left property value is equivalent to the X property of the Location property value of the report item.

Changes made to the Width and Left property values cause the Right property value of the report item to change.

See Also

ReportItem Class
Telerik.Reporting Namespace


Location Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Location Property
ReportItem Class See Also Send Feedback
Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU Location { get; set; }
Visual Basic (Declaration)
Public Property Location As PointU

Field Value

The PointU that represents the upper-left corner of the report item relative to the upper-left corner of its container.

Remarks

Because the PointU class is a value type (Structure in Visual Basic, struct in Visual C#), it is returned by value, meaning accessing the property returns a copy of the upper-left point of the report item. So, adjusting the X or Y properties of the PointU returned from this property will not affect the Left, Right, Top, or Bottom property values of the report item. To adjust these properties set each property value individually, or set the Location property with a new PointU.

See Also

ReportItem Class
Telerik.Reporting Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Right Property
ReportItem Class See Also Send Feedback
Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Unit

Field Value

An Unit representing the distance between the right edge of the report item and the left edge of its container's client area.

Remarks

The value of the Right property is equal to the sum of the Left property value and the Width property value.

See Also

ReportItem Class
Telerik.Reporting Namespace


Size Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Size Property
ReportItem Class See Also Send Feedback
Gets or sets the height and width of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU Size { get; set; }
Visual Basic (Declaration)
Public Property Size As SizeU

Field Value

The SizeU that represents the height and width of the report item in Units.

Remarks

Because the SizeU class is a value type (Structure in Visual Basic, struct in Visual C#), it is returned by value, meaning accessing the property returns a copy of the size of the report item. So, adjusting the Width or Height properties of the SizeU returned from this property will not affect the Width or Height of the report item. To adjust the Width or Height of the report item, you must set the item's Width or Height property, or set the Size property with a new SizeU.

See Also

ReportItem Class
Telerik.Reporting Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Top Property
ReportItem Class See Also Send Feedback
Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Unit

Field Value

An Unit representing the distance between the top edge of the report item and the top edge of its container's client area.

Remarks

The Top property value is equivalent to the Y property of the Location property value of the report item.

Changes made to the Height and Top property values cause the Bottom property value of the report item to change.

See Also

ReportItem Class
Telerik.Reporting Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Width Property
ReportItem Class See Also Send Feedback
Gets or sets the width of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

Field Value

The width of the report item in Units.

Remarks

Changes made to the Width and Left property values cause the Right property value of the report item to change.

See Also

ReportItem Class
Telerik.Reporting Namespace


ReportItem Events

[image] [image]

Telerik Reporting Q2 2012
ReportItem Events
ReportItem Class See Also Send Feedback

The ReportItem type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportItem Class
Telerik.Reporting Namespace


ReportItemBase Class

[image]

Telerik Reporting Q2 2012
ReportItemBase Class
Members See Also Send Feedback
Defines the base class for visual report items used for creating reports.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportItemBase : ReportObject,
    IComponent, IDisposable, IToggleVisibilityTarget
Visual Basic (Declaration)
Public MustInherit Class ReportItemBase _
    Inherits ReportObject _
    Implements IComponent, IDisposable, IToggleVisibilityTarget

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.Report
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.ReportSectionBase

See Also

ReportItemBase Members
Telerik.Reporting Namespace


ReportItemBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Members
ReportItemBase Class Constructors Methods Properties Events See Also Send Feedback

The ReportItemBase type exposes the following members.

Constructors

Name | Description
ReportItemBase | Initializes a new instance of the ReportItemBase class

Methods

Name | Description
ClearGlobalDependencies |
Contains | Retrieves a value indicating whether the specified report item is a child of the report item.
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event.
OnItemRemoved | Raises the ItemRemoved()()() event.
OnItemValidate |
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item.
Bindings | Gets the collection of binding rules contained within the report item.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item.
BookmarkId | Gets or sets a bookmark id for this item.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item.
Container |
DesignMode |
DocumentMapText | Gets or sets a text to be displayed for this item in the document map.
Items | Gets the collection of report items contained within the report item.
Name | Gets or sets the name of the report item.
Parent | Gets or sets the parent container of the report item.
Report | Gets the report this item belongs to.
Site |
Style | Gets a Style object specifying the appearance of the report item.
StyleName | Gets or sets the name of the report item's global style.
Visible | Gets or sets a value indicating whether the report item is displayed.

Events

Name | Description
Disposed | Occurs when the report item is disposed.
ItemDataBinding | Occurs when the report item binds to a data source.
ItemDataBound | Occurs after the report item binds to a data source.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ReportItemBase Constructor

[image]

Telerik Reporting Q2 2012
ReportItemBase Constructor
ReportItemBase Class See Also Send Feedback
Initializes a new instance of the ReportItemBase class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportItemBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ReportItemBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Methods
ReportItemBase Class See Also Send Feedback

The ReportItemBase type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies |
Contains | Retrieves a value indicating whether the specified report item is a child of the report item.
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event.
OnItemRemoved | Raises the ItemRemoved()()() event.
OnItemValidate |
ToString | Overloaded.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ClearGlobalDependencies Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ClearGlobalDependencies Method
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void ClearGlobalDependencies()
Visual Basic (Declaration)
Protected Sub ClearGlobalDependencies

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Contains Method
ReportItemBase Class See Also Send Feedback
Retrieves a value indicating whether the specified report item is a child of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    ReportItemBase item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As ReportItemBase _
) As Boolean

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to evaluate.

Return Value

true if the specified report item is a child of the report item; otherwise, false.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::.Dispose Method
ReportItemBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the ReportItemBase
Dispose(Boolean) | Releases the unmanaged resources used by the ReportItemBase and optionally releases the managed resources

See Also

ReportItemBase Class
ReportItemBase Members
Telerik.Reporting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Dispose Method
ReportItemBase Class See Also Send Feedback
Releases all resources used by the ReportItemBase

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

ReportItemBase Class
Dispose Overload
Telerik.Reporting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Dispose Method (Boolean)
ReportItemBase Class See Also Send Feedback
Releases the unmanaged resources used by the ReportItemBase and optionally releases the managed resources

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ReportItemBase Class
Dispose Overload
Telerik.Reporting Namespace


OnItemAdded Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.OnItemAdded Method
ReportItemBase Class See Also Send Feedback
Raises the ItemAdded()()() event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnItemAdded(
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemAdded ( _
    item As ReportItemBase _
)

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase being added.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


OnItemRemoved Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.OnItemRemoved Method
ReportItemBase Class See Also Send Feedback
Raises the ItemRemoved()()() event.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnItemRemoved(
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemRemoved ( _
    item As ReportItemBase _
)

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase being removed.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


OnItemValidate Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.OnItemValidate Method
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnItemValidate(
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overridable Sub OnItemValidate ( _
    item As ReportItemBase _
)

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::.ToString Method
ReportItemBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Overrides Object..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportItemBase Class
ReportItemBase Members
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ToString Method
ReportItemBase Class See Also Send Feedback
Returns a String that represents the current ReportItemBase.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A String that contains the Name and the Type's FullName of the current ReportItemBase.

See Also

ReportItemBase Class
ToString Overload
Telerik.Reporting Namespace


ReportItemBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Properties
ReportItemBase Class See Also Send Feedback

The ReportItemBase type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item.
Bindings | Gets the collection of binding rules contained within the report item.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item.
BookmarkId | Gets or sets a bookmark id for this item.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item.
Container |
DesignMode |
DocumentMapText | Gets or sets a text to be displayed for this item in the document map.
Items | Gets the collection of report items contained within the report item.
Name | Gets or sets the name of the report item.
Parent | Gets or sets the parent container of the report item.
Report | Gets the report this item belongs to.
Site |
Style | Gets a Style object specifying the appearance of the report item.
StyleName | Gets or sets the name of the report item's global style.
Visible | Gets or sets a value indicating whether the report item is displayed.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Action Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Action Property
ReportItemBase Class See Also Send Feedback
Gets or sets an interactive action associated with this report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IAction Action { get; set; }
Visual Basic (Declaration)
Public Property Action As IAction

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Bindings Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Bindings Property
ReportItemBase Class See Also Send Feedback
Gets the collection of binding rules contained within the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BindingCollection Bindings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bindings As BindingCollection

Field Value

An collection of Binding instances representing the list of property bindings defined within the item.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Bookmark Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Bookmark Property
ReportItemBase Class See Also Send Feedback
Gets or sets a bookmark label to be displayed for this report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")]
public string Bookmark { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")> _
Public Property Bookmark As String

Field Value

A string / expression value specifying the bookmark label.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


BookmarkId Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.BookmarkId Property
ReportItemBase Class See Also Send Feedback
Gets or sets a bookmark id for this item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string BookmarkId { get; set; }
Visual Basic (Declaration)
Public Property BookmarkId As String

Field Value

A string / expression value specifying the bookmark id. When processed should evaluate to an unique value for each processing instance of the item.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ConditionalFormatting Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ConditionalFormatting Property
ReportItemBase Class See Also Send Feedback
Gets the collection of the conditional formatting rules, associated with this item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ConditionalFormatting ConditionalFormatting { get; }
Visual Basic (Declaration)
Public ReadOnly Property ConditionalFormatting As ConditionalFormatting

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Container Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Container Property
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual IContainer Container { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Container As IContainer

See Also

ReportItemBase Class
Telerik.Reporting Namespace


DesignMode Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.DesignMode Property
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool DesignMode { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property DesignMode As Boolean

See Also

ReportItemBase Class
Telerik.Reporting Namespace


DocumentMapText Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.DocumentMapText Property
ReportItemBase Class See Also Send Feedback
Gets or sets a text to be displayed for this item in the document map.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentMapText { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapText As String

Field Value

A string / expression value specifying the document map text.

Remarks

When defined the document map displays nodes that navigate to the instances of the item.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Items Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Items Property
ReportItemBase Class See Also Send Feedback
Gets the collection of report items contained within the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItemBase..::.ItemCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ReportItemBase..::.ItemCollection

Field Value

An ReportItemBase..::.ItemCollection representing the collection of items contained within the item.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Name Property
ReportItemBase Class See Also Send Feedback
Gets or sets the name of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

The name of the report item.

Implements

IToggleVisibilityTarget..::.Name

Remarks

The Name property can be used at run time to evaluate the object by name rather than type and programmatic name.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Parent Property
ReportItemBase Class See Also Send Feedback
Gets or sets the parent container of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItemBase Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ReportItemBase

Field Value

A ReportItemBase that represents the parent item of the report item.

Remarks

Setting the Parent property value to a null reference (Nothing in Visual Basic) removes the item from the ReportItemBase..::.ItemCollection of its current parent item.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Report Property
ReportItemBase Class See Also Send Feedback
Gets the report this item belongs to.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Report Report { get; }
Visual Basic (Declaration)
Public ReadOnly Property Report As Report

Field Value

A Report object which the item belongs to.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Site Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Site Property
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ISite Site { get; set; }
Visual Basic (Declaration)
Public Overridable Property Site As ISite

Implements

IComponent..::.Site

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Style Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Style Property
ReportItemBase Class See Also Send Feedback
Gets a Style object specifying the appearance of the report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As Style

Field Value

A Style object specifying the items's style.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


StyleName Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.StyleName Property
ReportItemBase Class See Also Send Feedback
Gets or sets the name of the report item's global style.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string StyleName { get; set; }
Visual Basic (Declaration)
Public Property StyleName As String

Field Value

A string value specifying the style name.

Remarks

Global styles are defined through the Report's StyleSheet property.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Visible Property
ReportItemBase Class See Also Send Feedback
Gets or sets a value indicating whether the report item is displayed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Field Value

true if the report item is displayed; otherwise, false. The default is true.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ReportItemBase Events

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Events
ReportItemBase Class See Also Send Feedback

The ReportItemBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed.
ItemDataBinding | Occurs when the report item binds to a data source.
ItemDataBound | Occurs after the report item binds to a data source.

See Also

ReportItemBase Class
Telerik.Reporting Namespace


Disposed Event

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Disposed Event
ReportItemBase Class See Also Send Feedback
Occurs when the report item is disposed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler Disposed
Visual Basic (Declaration)
Public Event Disposed As EventHandler

Implements

IComponent..::.Disposed

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ItemDataBinding Event

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ItemDataBinding Event
ReportItemBase Class See Also Send Feedback
Occurs when the report item binds to a data source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler ItemDataBinding
Visual Basic (Declaration)
Public Event ItemDataBinding As EventHandler

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ItemDataBound Event

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ItemDataBound Event
ReportItemBase Class See Also Send Feedback
Occurs after the report item binds to a data source.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler ItemDataBound
Visual Basic (Declaration)
Public Event ItemDataBound As EventHandler

See Also

ReportItemBase Class
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Class

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection Class
ReportItemBase Class Members See Also Send Feedback
Represents a collection of ReportItemBase objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ItemCollection : Collection<ReportItemBase>
Visual Basic (Declaration)
Public Class ItemCollection _
    Inherits Collection(Of ReportItemBase)

Remarks

The [!:Telerik.Reporting.ReportItemBase.ItemCollection.Add(Telerik.Reporting.ReportItemBase)], [!:Telerik.Reporting.ReportItemBase.ItemCollection.Remove(Telerik.Reporting.ReportItemBase)], and RemoveAt(Int32) methods enable you to add and remove individual items from the collection. You can also use the AddRange(array<ReportItemBase>[]()[]) or Clear()()() methods to add or remove all the items from the collection. You can determine if a ReportItemBase is a member of the collection by passing the item into the [!:Telerik.Reporting.ReportItemBase.ItemCollection.Contains(Telerik.Reporting.ReportItemBase)] method. To get the index value of the location of a ReportItemBase in the collection, pass the item into the [!:Telerik.Reporting.ReportItemBase.ItemCollection.IndexOf(Telerik.Reporting.ReportItemBase)] method. The collection can be copied into an array by calling the [!:Telerik.Reporting.ReportItemBase.ItemCollection.CopyTo(System.Array, int)] method.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ReportItemBase >)>)>
Telerik.Reporting..::.ReportItemBase..::.ItemCollection

See Also

ReportItemBase..::.ItemCollection Members
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Members

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection Members
ReportItemBase..::.ItemCollection Class Constructors Methods Properties See Also Send Feedback

Defines the base class for visual report items used for creating reports.

The ReportItemBase..::.ItemCollection type exposes the following members.

Constructors

Name | Description
ReportItemBase..::.ItemCollection | Initializes a new instance of the ReportItemBase..::.ItemCollection class.

Methods

Name | Description
AddRange | Adds an array of report item objects to the collection.
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
ContainsKey | Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.
Find | Overloaded.
FindItem | Searches the collection for a report item of the specified type.
GetChildIndex | Overloaded.
IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
InsertItem | Overrides the InsertItem(Int32, T) method. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveByKey | Removes the child report item with the specified key.
RemoveItem | Overrides the RemoveItem(Int32) method. (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

Properties

Name | Description
Item | Returns the ReportItemBase with the specified key in the collection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Constructor

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection Constructor
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Initializes a new instance of the ReportItemBase..::.ItemCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ItemCollection(
    ReportItemBase owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As ReportItemBase _
)

Parameters

owner
Type: Telerik.Reporting..::.ReportItemBase
A ReportItemBase representing the report item that owns the report item collection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection Methods
ReportItemBase..::.ItemCollection Class See Also Send Feedback

The ReportItemBase..::.ItemCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds an array of report item objects to the collection.
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
ContainsKey | Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.
Find | Overloaded.
FindItem | Searches the collection for a report item of the specified type.
GetChildIndex | Overloaded.
IndexOfKey | Retrieves the index of the first occurrence of the specified item within the collection.
InsertItem | Overrides the InsertItem(Int32, T) method. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveByKey | Removes the child report item with the specified key.
RemoveItem | Overrides the RemoveItem(Int32) method. (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.AddRange Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Adds an array of report item objects to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void AddRange(
    ReportItemBase[] items
)
Visual Basic (Declaration)
Public Overridable Sub AddRange ( _
    items As ReportItemBase() _
)

Parameters

items
Type: array< Telerik.Reporting..::.ReportItemBase >[]()[][]
An array of ReportItemBase objects to add to the collection.

Remarks

The ReportItemBase objects contained in the items array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of ReportItemBase objects to the collection instead of manually adding each ReportItemBase to the collection using the [!:Telerik.Reporting.ReportItemBase.ItemCollection.Add(Telerik.Reporting.ReportItemBase)] method.

To remove a ReportItemBase that you previously added, use the [!:Telerik.Reporting.ReportItemBase.ItemCollection.Remove(Telerik.Reporting.ReportItemBase)], RemoveAt(Int32), or Clear()()() methods.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.ClearItems Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ContainsKey Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.ContainsKey Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Determines whether the ReportItemBase.ItemCollection contains an item with the specified key.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Overridable Function ContainsKey ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String
The key to locate in the ReportItemBase..::.ItemCollection.

Return Value

true if the ReportItemBase.ItemCollection contains an item with the specified key; otherwise, false.

Remarks

The Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase..::.ItemCollection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


Find Method

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.Find Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback

Overload List

Name | Description
Find(Type) | Searches for report items by their Type and builds an array of all the items that match.
Find(String, Boolean) | Searches for report items by their Name property and builds an array of all the report items that match.
Find(Type, Boolean) | Searches for report items by their Type and builds an array of all the items that match.

See Also

ReportItemBase..::.ItemCollection Class
ReportItemBase..::.ItemCollection Members
Telerik.Reporting Namespace


Find Method (Type)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.Find Method (Type)
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Searches for report items by their Type and builds an array of all the items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ReportItemBase[] Find(
    Type type
)
Visual Basic (Declaration)
Public Overridable Function Find ( _
    type As Type _
) As ReportItemBase()

Parameters

type
Type: System..::.Type
The Type to search for.

Return Value

An array of type ReportItemBase containing the matching report items.

See Also

ReportItemBase..::.ItemCollection Class
Find Overload
Telerik.Reporting Namespace


Find Method (String, Boolean)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.Find Method (String, Boolean)
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Searches for report items by their Name property and builds an array of all the report items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ReportItemBase[] Find(
    string key,
    bool recursive
)
Visual Basic (Declaration)
Public Overridable Function Find ( _
    key As String, _
    recursive As Boolean _
) As ReportItemBase()

Parameters

key
Type: System..::.String
The key to locate in the ReportItemBase..::.ItemCollection.
recursive
Type: System..::.Boolean
true to search all child report items; otherwise, false.

Return Value

An array of type ReportItemBase containing the matching report items.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The key parameter is null or empty.

See Also

ReportItemBase..::.ItemCollection Class
Find Overload
Telerik.Reporting Namespace


Find Method (Type, Boolean)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.Find Method (Type, Boolean)
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Searches for report items by their Type and builds an array of all the items that match.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ReportItemBase[] Find(
    Type type,
    bool recursive
)
Visual Basic (Declaration)
Public Overridable Function Find ( _
    type As Type, _
    recursive As Boolean _
) As ReportItemBase()

Parameters

type
Type: System..::.Type
The Type to search for.
recursive
Type: System..::.Boolean
A value indicating whether to search all children recursively.

Return Value

An array of type ReportItemBase containing the matching report items.

See Also

ReportItemBase..::.ItemCollection Class
Find Overload
Telerik.Reporting Namespace


FindItem Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.FindItem Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Searches the collection for a report item of the specified type.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ReportItemBase FindItem(
    Type type
)
Visual Basic (Declaration)
Public Overridable Function FindItem ( _
    type As Type _
) As ReportItemBase

Parameters

type
Type: System..::.Type
The Type to search for.

Return Value

The first ReportItemBase in the collection that matches the given Type. If no item in the collection matches the given Type the method returns null.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


GetChildIndex Method

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.GetChildIndex Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback

Overload List

Name | Description
GetChildIndex(ReportItemBase) | Retrieves the index of a report item within the item collection.
GetChildIndex(ReportItemBase, Boolean) | Retrieves the index of the specified child report item within the item collection, and optionally raises an exception if the specified report item is not within the item collection.

See Also

ReportItemBase..::.ItemCollection Class
ReportItemBase..::.ItemCollection Members
Telerik.Reporting Namespace


GetChildIndex Method (ReportItemBase)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.GetChildIndex Method (ReportItemBase)
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Retrieves the index of a report item within the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetChildIndex(
    ReportItemBase child
)
Visual Basic (Declaration)
Public Function GetChildIndex ( _
    child As ReportItemBase _
) As Integer

Parameters

child
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to search for in the item collection.

Return Value

A zero-based index value that represents the location of the specified child report item within the item collection.

See Also

ReportItemBase..::.ItemCollection Class
GetChildIndex Overload
Telerik.Reporting Namespace


GetChildIndex Method (ReportItemBase, Boolean)

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.GetChildIndex Method (ReportItemBase, Boolean)
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Retrieves the index of the specified child report item within the item collection, and optionally raises an exception if the specified report item is not within the item collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual int GetChildIndex(
    ReportItemBase child,
    bool throwException
)
Visual Basic (Declaration)
Public Overridable Function GetChildIndex ( _
    child As ReportItemBase, _
    throwException As Boolean _
) As Integer

Parameters

child
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to search for in the item collection.
throwException
Type: System..::.Boolean
true to throw an exception if the ReportItemBase specified in the child parameter is not an item in the ReportItemBase..::.ItemCollection; otherwise, false.

Return Value

A zero-based index value that represents the location of the specified child report item within the item collection; otherwise -1 if the specified ReportItemBase is not found in the ReportItemBase..::.ItemCollection.

Exceptions

Exception | Condition
System..::.ArgumentException | The child is not contained in the collection and the throwException parameter is true.

See Also

ReportItemBase..::.ItemCollection Class
GetChildIndex Overload
Telerik.Reporting Namespace


IndexOfKey Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.IndexOfKey Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Retrieves the index of the first occurrence of the specified item within the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual int IndexOfKey(
    string key
)
Visual Basic (Declaration)
Public Overridable Function IndexOfKey ( _
    key As String _
) As Integer

Parameters

key
Type: System..::.String
The name of the report item to search for.

Return Value

The zero-based index of the first occurrence of the report item with the specified name in the collection.

Remarks

The key comparison is not case-sensitive. If the key parameter is a null reference (Nothing in Visual Basic) or an empty string, or an item with the specified key is not found, IndexOfKey returns -1.

The Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase..::.ItemCollection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.InsertItem Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Overrides the InsertItem(Int32, T) method.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As ReportItemBase _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which to insert value.
item
Type: Telerik.Reporting..::.ReportItemBase

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


RemoveByKey Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.RemoveByKey Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Removes the child report item with the specified key.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void RemoveByKey(
    string key
)
Visual Basic (Declaration)
Public Overridable Sub RemoveByKey ( _
    key As String _
)

Parameters

key
Type: System..::.String
The name of the child report item to remove.

Remarks

The Name property of a ReportItemBase corresponds to the key for a ReportItemBase in the ReportItemBase..::.ItemCollection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


RemoveItem Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.RemoveItem Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Overrides the RemoveItem(Int32) method.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which value can be found.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


SetItem Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.SetItem Method
ReportItemBase..::.ItemCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void SetItem(
    int index,
    ReportItemBase item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As ReportItemBase _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting..::.ReportItemBase

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ReportItemBase.ItemCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection Properties
ReportItemBase..::.ItemCollection Class See Also Send Feedback

The ReportItemBase..::.ItemCollection type exposes the following members.

Properties

Name | Description
Item | Returns the ReportItemBase with the specified key in the collection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::..ItemCollection..::.Item Property
ReportItemBase..::.ItemCollection Class See Also Send Feedback
Returns the ReportItemBase with the specified key in the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ReportItemBase this[
    string key
] { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Default Property Item ( _
    key As String _
) As ReportItemBase

Parameters

key
Type: System..::.String
The name of the report item to retrieve from the report item collection.

Field Value

The ReportItemBase with the specified key in the collection.

See Also

ReportItemBase..::.ItemCollection Class
Telerik.Reporting Namespace


ReportObject Class

[image]

Telerik Reporting Q2 2012
ReportObject Class
Members See Also Send Feedback
Represents a base class for all Telerik Reporting objects

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportObject
Visual Basic (Declaration)
Public Class ReportObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.FormattingRule
Telerik.Reporting.Drawing..::.PageSettings
Telerik.Reporting.Drawing..::.StyleRule
Telerik.Reporting.Drawing..::.Watermark
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.Watermark
Telerik.Reporting..::.ReportItemBase

See Also

ReportObject Members
Telerik.Reporting Namespace


ReportObject Members

[image] [image]

Telerik Reporting Q2 2012
ReportObject Members
ReportObject Class Methods See Also Send Feedback

The ReportObject type exposes the following members.

Methods

Name | Description
ToString |

See Also

ReportObject Class
Telerik.Reporting Namespace


ReportObject Methods

[image] [image]

Telerik Reporting Q2 2012
ReportObject Methods
ReportObject Class See Also Send Feedback

The ReportObject type exposes the following members.

Methods

Name | Description
ToString |

See Also

ReportObject Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportObject..::.ToString Method
ReportObject Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual string ToString(
    string[] members
)
Visual Basic (Declaration)
Protected Overridable Function ToString ( _
    members As String() _
) As String

Parameters

members
Type: array< System..::.String >[]()[][]

See Also

ReportObject Class
Telerik.Reporting Namespace


ReportParameter Class

[image]

Telerik Reporting Q2 2012
ReportParameter Class
Members See Also Send Feedback
Represents a report parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportParameter : IReportParameter,
    INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ReportParameter _
    Implements IReportParameter, INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportParameter

See Also

ReportParameter Members
Telerik.Reporting Namespace


ReportParameter Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameter Members
ReportParameter Class Constructors Properties Events See Also Send Feedback

The ReportParameter type exposes the following members.

Constructors

Name | Description
ReportParameter | Overloaded.

Properties

Name | Description
AllowBlank | Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.
AvailableValues | Gets an object that defines a set of valid values the parameter can accept from.
Mergeable | Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.
MultiValue | Determines if the parameter can hold more then one value.
Name | Gets or sets the name of the parameter. Used to access the parameter.
Text | Gets or sets the text for the parameter's automatic UI displayed in the report viewer.
Type | Gets or sets the data type of the parameter.
Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.
Visible | Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

Events

Name | Description
PropertyChanged |

See Also

ReportParameter Class
Telerik.Reporting Namespace


ReportParameter Constructor

[image] [image]

Telerik Reporting Q2 2012
ReportParameter Constructor
ReportParameter Class See Also Send Feedback

Overload List

Name | Description
ReportParameter()()() | Initializes a new instance of the ReportParameter class.
ReportParameter(String, ReportParameterType, Object) | Initializes a new instance of the ReportParameter class.

See Also

ReportParameter Class
ReportParameter Members
Telerik.Reporting Namespace


ReportParameter Constructor

[image]

Telerik Reporting Q2 2012
ReportParameter Constructor
ReportParameter Class See Also Send Feedback
Initializes a new instance of the ReportParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameter()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameter Class
ReportParameter Overload
Telerik.Reporting Namespace


ReportParameter Constructor (String, ReportParameterType, Object)

[image]

Telerik Reporting Q2 2012
ReportParameter Constructor (String, ReportParameterType, Object)
ReportParameter Class See Also Send Feedback
Initializes a new instance of the ReportParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameter(
    string name,
    ReportParameterType type,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As ReportParameterType, _
    value As Object _
)

Parameters

name
Type: System..::.String
type
Type: Telerik.Reporting..::.ReportParameterType
value
Type: System..::.Object

See Also

ReportParameter Class
ReportParameter Overload
Telerik.Reporting Namespace


ReportParameter Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameter Properties
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Properties

Name | Description
AllowBlank | Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.
AvailableValues | Gets an object that defines a set of valid values the parameter can accept from.
Mergeable | Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.
MultiValue | Determines if the parameter can hold more then one value.
Name | Gets or sets the name of the parameter. Used to access the parameter.
Text | Gets or sets the text for the parameter's automatic UI displayed in the report viewer.
Type | Gets or sets the data type of the parameter.
Value | Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.
Visible | Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

See Also

ReportParameter Class
Telerik.Reporting Namespace


AllowBlank Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.AllowBlank Property
ReportParameter Class See Also Send Feedback
Gets or sets a value that indicates whether an empty string is a valid value for the parameter. Only for parameters of Type String.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AllowBlank { get; set; }
Visual Basic (Declaration)
Public Property AllowBlank As Boolean

Implements

IReportParameter..::.AllowBlank

See Also

ReportParameter Class
Telerik.Reporting Namespace


AllowNull Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.AllowNull Property
ReportParameter Class See Also Send Feedback
Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AllowNull { get; set; }
Visual Basic (Declaration)
Public Property AllowNull As Boolean

Implements

IReportParameter..::.AllowNull

Remarks

Only if this property is set to false null ( Nothing in VB) are considered as valid values of the parameter.

See Also

ReportParameter Class
Telerik.Reporting Namespace


AutoRefresh Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.AutoRefresh Property
ReportParameter Class See Also Send Feedback
Determines whether to trigger the report preview after changing the value for a parameter. Applies only for visible parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AutoRefresh { get; set; }
Visual Basic (Declaration)
Public Property AutoRefresh As Boolean

Implements

IReportParameter..::.AutoRefresh

Remarks

If this property is set to true, the report viewer will trigger the report preview automatically when the parameter value is changed. The parameter should be visible in order to auto preview the report.

See Also

ReportParameter Class
Telerik.Reporting Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.AvailableValues Property
ReportParameter Class See Also Send Feedback
Gets an object that defines a set of valid values the parameter can accept from.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterAvailableValues AvailableValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableValues As ReportParameterAvailableValues

Implements

IReportParameter..::.AvailableValues

Remarks

The available values, or valid values, are a set of predefined values which are acceptable as value of the parameter. Each available value may have label that will be displayed if the parameter is visible.

See Also

ReportParameter Class
Telerik.Reporting Namespace


Mergeable Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Mergeable Property
ReportParameter Class See Also Send Feedback
Gets or sets a value indicating whether this parameter should be merged with identical parameters from other reports when this report is part of a ReportBook.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Mergeable { get; set; }
Visual Basic (Declaration)
Public Property Mergeable As Boolean

Implements

IReportParameter..::.Mergeable

Remarks

Controls parameter merging in ReportBook. The default value of the Mergeable property is true. Set the Mergeable property to false if you want to prevent a parameter from being merged with its equivalent ones.

See Also

ReportParameter Class
Telerik.Reporting Namespace


MultiValue Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.MultiValue Property
ReportParameter Class See Also Send Feedback
Determines if the parameter can hold more then one value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool MultiValue { get; set; }
Visual Basic (Declaration)
Public Property MultiValue As Boolean

Implements

IReportParameter..::.MultiValue

Remarks

If the value is set to true as a valid value of the parameter is accepted an [!:IEnumerable] of values of the specified Type of the parameter. Parameters with MultiValue turned on are mainly used with the IN logical operator.

See Also

ReportParameter Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Name Property
ReportParameter Class See Also Send Feedback
Gets or sets the name of the parameter. Used to access the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Implements

IReportParameter..::.Name

Remarks

Parameter names must be unique in the context of a single report. The name must be a valid identifier - may contain only digits (0-9), letters (a-z, A-Z), and underscore sign (_). Must begin with a letter or underscore.

See Also

ReportParameter Class
Telerik.Reporting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Text Property
ReportParameter Class See Also Send Feedback
Gets or sets the text for the parameter's automatic UI displayed in the report viewer.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

Implements

IReportParameter..::.Text

Remarks

The Text property specifies the text for the parameter to be displayed in the report viewer as prompt to the end user. If value for the property is not provided the Name of the parameter is used.

See Also

ReportParameter Class
Telerik.Reporting Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Type Property
ReportParameter Class See Also Send Feedback
Gets or sets the data type of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As ReportParameterType

Implements

IReportParameter..::.Type

Remarks

Determines the type of the values. Acceptable values for each type are listed in ReportParameterType. The default parameter type is String.

See Also

ReportParameter Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Value Property
ReportParameter Class See Also Send Feedback
Gets or sets the value of the parameter. Can be an Expression that evaluates to an object, value of the allowed types, or [!:IEnumerable] containing values of the allowed types.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

Implements

IReportParameter..::.Value

See Also

ReportParameter Class
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ReportParameter..::.Visible Property
ReportParameter Class See Also Send Feedback
Determines whether automatic user interface (UI) prompting for values to be generated for the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Implements

IReportParameter..::.Visible

Remarks

Specifies whether the parameter will have UI in the parameters area. When at least one report parameter has the Visible property turned on, a parameter area is shown as part of the report viewer. If this property is set to false, the parameter must be populated programmatically or at design time.

See Also

ReportParameter Class
Telerik.Reporting Namespace


ReportParameter Events

[image] [image]

Telerik Reporting Q2 2012
ReportParameter Events
ReportParameter Class See Also Send Feedback

The ReportParameter type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ReportParameter Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
ReportParameter..::.PropertyChanged Event
ReportParameter Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ReportParameter Class
Telerik.Reporting Namespace


ReportParameterAvailableValues Class

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues Class
Members See Also Send Feedback
Represents the available values for a ReportParameter

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ReportParameterAvailableValues
Visual Basic (Declaration)
Public NotInheritable Class ReportParameterAvailableValues

Remarks

The available values, or valid values, are a set of predefined values which are acceptable as value of the parameter. Each available value may have label that will be displayed if the parameter is visible.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportParameterAvailableValues

See Also

ReportParameterAvailableValues Members
Telerik.Reporting Namespace


ReportParameterAvailableValues Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues Members
ReportParameterAvailableValues Class Constructors Methods Properties See Also Send Feedback

The ReportParameterAvailableValues type exposes the following members.

Constructors

Name | Description
ReportParameterAvailableValues | Initializes a new instance of the ReportParameterAvailableValues class

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
DataMember | Obsolete. Gets or sets the specific list in a DataSource.
DataSource | Gets or sets the data source used for retrieving the value / label pairs of the available values.
DisplayMember | Gets or sets a string that specifies the property of the data source from which to draw the value labels.
Filters | Gets a FilterCollection that defines the filter expression(s).
Sorting | Obsolete.
Sortings | Gets a SortingCollection that defines the sort column(s), and their type and order.
ValueMember | Gets or sets a string that specifies the field of the data source from which to draw the values.

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ReportParameterAvailableValues Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues Constructor
ReportParameterAvailableValues Class See Also Send Feedback
Initializes a new instance of the ReportParameterAvailableValues class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterAvailableValues()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ReportParameterAvailableValues Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues Methods
ReportParameterAvailableValues Class See Also Send Feedback

The ReportParameterAvailableValues type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.ToString Method
ReportParameterAvailableValues Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ReportParameterAvailableValues Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues Properties
ReportParameterAvailableValues Class See Also Send Feedback

The ReportParameterAvailableValues type exposes the following members.

Properties

Name | Description
DataMember | Obsolete. Gets or sets the specific list in a DataSource.
DataSource | Gets or sets the data source used for retrieving the value / label pairs of the available values.
DisplayMember | Gets or sets a string that specifies the property of the data source from which to draw the value labels.
Filters | Gets a FilterCollection that defines the filter expression(s).
Sorting | Obsolete.
Sortings | Gets a SortingCollection that defines the sort column(s), and their type and order.
ValueMember | Gets or sets a string that specifies the field of the data source from which to draw the values.

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.DataMember Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets or sets the specific list in a DataSource.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.DataSource Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets or sets the data source used for retrieving the value / label pairs of the available values.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

Remarks

For backwards compatibility reasons Telerik Reporting supports binding directly to IEnumberable/IListSource objects (incl. arrays, collections, DataSet, DataTable, DataView, and DbDataAdapter). Instead consider using the ObjectDataSource component that can handle these types of data sources.

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


DisplayMember Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.DisplayMember Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets or sets a string that specifies the property of the data source from which to draw the value labels.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DisplayMember { get; set; }
Visual Basic (Declaration)
Public Property DisplayMember As String

Remarks

Specifies a column name, expression, or embedded expression based on the DataSource schema. It is used as label in the value/label pair. If omitted the ValueMember will be used as DisplayMember as well. Optional.

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.Filters Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets a FilterCollection that defines the filter expression(s).

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.Sorting Property
ReportParameterAvailableValues Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.Sortings Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets a SortingCollection that defines the sort column(s), and their type and order.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ValueMember Property

[image]

Telerik Reporting Q2 2012
ReportParameterAvailableValues..::.ValueMember Property
ReportParameterAvailableValues Class See Also Send Feedback
Gets or sets a string that specifies the field of the data source from which to draw the values.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ValueMember { get; set; }
Visual Basic (Declaration)
Public Property ValueMember As String

Remarks

Specifies a column name, expression, or embedded expression based on the DataSource schema. It is used as value in the value / label pair.

See Also

ReportParameterAvailableValues Class
Telerik.Reporting Namespace


ReportParameterCollection Class

[image]

Telerik Reporting Q2 2012
ReportParameterCollection Class
Members See Also Send Feedback
Represents a collection of ReportParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportParameterCollection : ReportParameterCollectionBase<ReportParameter>
Visual Basic (Declaration)
Public Class ReportParameterCollection _
    Inherits ReportParameterCollectionBase(Of ReportParameter)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ReportParameter >)>)>
Telerik.Reporting..::.ReportParameterCollectionBase <(Of <(<' ReportParameter >)>)>
Telerik.Reporting..::.ReportParameterCollection

See Also

ReportParameterCollection Members
Telerik.Reporting Namespace


ReportParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollection Members
ReportParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ReportParameterCollection type exposes the following members.

Constructors

Name | Description
ReportParameterCollection | Initializes a new instance of the ReportParameterCollection class

Methods

Name | Description
Add | Creates a ReportParameter with specific settings and adds it to the ReportParameterCollection.
AddRange | Adds an enumerable of ReportParameter objects to the ReportParameterCollection. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether the ReportParameterCollection contains a report parameter with a specific name. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
IndexOf | Determines the index of a specific report parameter in the ReportParameterCollection. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
InsertItem | Inserts an item to the ReportParameterCollection at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)

Properties

Name | Description
Item | Gets a report parameter by name. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


ReportParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterCollection Constructor
ReportParameterCollection Class See Also Send Feedback
Initializes a new instance of the ReportParameterCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


ReportParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollection Methods
ReportParameterCollection Class See Also Send Feedback

The ReportParameterCollection type exposes the following members.

Methods

Name | Description
Add | Creates a ReportParameter with specific settings and adds it to the ReportParameterCollection.
AddRange | Adds an enumerable of ReportParameter objects to the ReportParameterCollection. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether the ReportParameterCollection contains a report parameter with a specific name. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
IndexOf | Determines the index of a specific report parameter in the ReportParameterCollection. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)
InsertItem | Inserts an item to the ReportParameterCollection at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollection..::.Add Method
ReportParameterCollection Class See Also Send Feedback
Creates a ReportParameter with specific settings and adds it to the ReportParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IReportParameter Add(
    string name,
    ReportParameterType parameterType,
    Object value
)
Visual Basic (Declaration)
Public Function Add ( _
    name As String, _
    parameterType As ReportParameterType, _
    value As Object _
) As IReportParameter

Parameters

name
Type: System..::.String
A String value that will be used as Name for the newly created ReportParameter.
parameterType
Type: Telerik.Reporting..::.ReportParameterType
A ReportParameterType value that will be used as Type for the newly created ReportParameter.
value
Type: System..::.Object
A Object value that will be used as Value for the newly created ReportParameter. May be expression.

Return Value

The newly created and added ReportParameter

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollection..::.ClearItems Method
ReportParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollection..::.InsertItem Method
ReportParameterCollection Class See Also Send Feedback
Inserts an item to the ReportParameterCollection at the specified index.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    ReportParameter item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As ReportParameter _
)

Parameters

index
Type: System..::.Int32
The zero-based index at which item should be inserted.
item
Type: Telerik.Reporting..::.ReportParameter
The ReportParameter to insert into the ReportParameterCollection.

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


RemoveItem Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollection..::.RemoveItem Method
ReportParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


ReportParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollection Properties
ReportParameterCollection Class See Also Send Feedback

The ReportParameterCollection type exposes the following members.

Properties

Name | Description
Item | Gets a report parameter by name. (Inherited from ReportParameterCollectionBase<(Of <(TReportParameter>)>).)

See Also

ReportParameterCollection Class
Telerik.Reporting Namespace


ReportParameterCollectionBase(TReportParameter) Class

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)> Class
Members See Also Send Feedback
Represents a base class for collection of IReportParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportParameterCollectionBase<TReportParameter> : Collection<TReportParameter>
where TReportParameter : IReportParameter
Visual Basic (Declaration)
Public MustInherit Class ReportParameterCollectionBase(Of TReportParameter As IReportParameter) _
    Inherits Collection(Of TReportParameter)

Type Parameters

TReportParameter

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<'TReportParameter>)>)>
Telerik.Reporting..::.ReportParameterCollectionBase<(Of <(TReportParameter>)>)
Telerik.Reporting..::.ReportParameterCollection

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Members
Telerik.Reporting Namespace


ReportParameterCollectionBase(TReportParameter) Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)> Members
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class Constructors Methods Properties See Also Send Feedback

The ReportParameterCollectionBase<(Of <(TReportParameter>)>) type exposes the following members.

Constructors

Name | Description
ReportParameterCollectionBase<(Of <(TReportParameter>)>) | Initializes a new instance of the ReportParameterCollectionBase<(Of <(TReportParameter>)>) class

Methods

Name | Description
AddRange | Adds an enumerable of ReportParameter objects to the ReportParameterCollection.
Contains | Determines whether the ReportParameterCollection contains a report parameter with a specific name.
IndexOf | Determines the index of a specific report parameter in the ReportParameterCollection.

Properties

Name | Description
Item | Gets a report parameter by name.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


ReportParameterCollectionBase(TReportParameter) Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)> Constructor
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback
Initializes a new instance of the ReportParameterCollectionBase<(Of <(TReportParameter>)>) class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportParameterCollectionBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


ReportParameterCollectionBase(TReportParameter) Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)> Methods
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback

The ReportParameterCollectionBase<(Of <(TReportParameter>)>) type exposes the following members.

Methods

Name | Description
AddRange | Adds an enumerable of ReportParameter objects to the ReportParameterCollection.
Contains | Determines whether the ReportParameterCollection contains a report parameter with a specific name.
IndexOf | Determines the index of a specific report parameter in the ReportParameterCollection.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)>..::.AddRange Method
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback
Adds an enumerable of ReportParameter objects to the ReportParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<TReportParameter> enumerable
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    enumerable As IEnumerable(Of TReportParameter) _
)

Parameters

enumerable
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' TReportParameter >)>)>
An enumerable of ReportParameter objects to add to the ReportParameterCollection.

Remarks

The ReportParameter objects returned from the enumerable are appended to the end of the ReportParameterCollection.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)>..::.Contains Method
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback
Determines whether the ReportParameterCollection contains a report parameter with a specific name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
A String that specifies the parameter name for which to search the elements of the ReportParameterCollection.

Return Value

Returns a Boolean value indicating whether the ReportParameterCollection object contains a report parameter with the specified name.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


IndexOf Method

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)>..::.IndexOf Method
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback
Determines the index of a specific report parameter in the ReportParameterCollection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    string name
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    name As String _
) As Integer

Parameters

name
Type: System..::.String
The parameter name used to locate the report parameter in the ReportParameterCollection.

Return Value

The index of report parameter if found in the ReportParameterCollection; otherwise, -1.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


ReportParameterCollectionBase(TReportParameter) Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)> Properties
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback

The ReportParameterCollectionBase<(Of <(TReportParameter>)>) type exposes the following members.

Properties

Name | Description
Item | Gets a report parameter by name.

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ReportParameterCollectionBase<(Of <(<'TReportParameter>)>)>..::.Item Property
ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class See Also Send Feedback
Gets a report parameter by name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TReportParameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As TReportParameter

Parameters

name
Type: System..::.String
The name of the report parameter.

Return Value

A report parameter if found; otherwise null (Nothing)

See Also

ReportParameterCollectionBase<(Of <(TReportParameter>)>) Class
Telerik.Reporting Namespace


ReportParameterType Enumeration

[image]

Telerik Reporting Q2 2012
ReportParameterType Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ReportParameterType
Visual Basic (Declaration)
Public Enumeration ReportParameterType

Members

Member name | Description
Boolean | Values of type Boolean are accepted.
DateTime | Values of type DateTime are accepted.
Integer | Values of type Int16, Int32, or Int64 are accepted. Internally the values are converted to Int64.
Float | Values of type Single or Double are accepted. Internally the values are converted to Double.
String | Values of type String are accepted.

See Also

Telerik.Reporting Namespace


ReportParameterUISettings Class

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ReportParameter instead.")]
public class ReportParameterUISettings
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ReportParameter instead.")> _
Public Class ReportParameterUISettings

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportParameterUISettings

See Also

ReportParameterUISettings Members
Telerik.Reporting Namespace


ReportParameterUISettings Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterUISettings Members
ReportParameterUISettings Class Constructors Methods Properties See Also Send Feedback

The ReportParameterUISettings type exposes the following members.

Constructors

Name | Description
ReportParameterUISettings | Initializes a new instance of the ReportParameterUISettings class

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
AllowBlank | Obsolete. Determines if the parameter allows an empty string to be passed. Only for parameters of type string.
AllowNull | Obsolete. Determines if the parameter allows no value to be passed from it's editor.
AvailableValues | Obsolete. Gets an object that defines a set of values the parameter can accept from.
MultiValue | Obsolete. Determines if the parameter can hold more then one value.
Text | Obsolete. Gets or sets the text for the parameter to be displayed in the report viewer.
Visible | Obsolete. Determines whether the parameter user interface is visible.

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


ReportParameterUISettings Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings Constructor
ReportParameterUISettings Class See Also Send Feedback
Initializes a new instance of the ReportParameterUISettings class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportParameterUISettings(
    ReportParameter owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As ReportParameter _
)

Parameters

owner
Type: Telerik.Reporting..::.ReportParameter

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


ReportParameterUISettings Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterUISettings Methods
ReportParameterUISettings Class See Also Send Feedback

The ReportParameterUISettings type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.ToString Method
ReportParameterUISettings Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


ReportParameterUISettings Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterUISettings Properties
ReportParameterUISettings Class See Also Send Feedback

The ReportParameterUISettings type exposes the following members.

Properties

Name | Description
AllowBlank | Obsolete. Determines if the parameter allows an empty string to be passed. Only for parameters of type string.
AllowNull | Obsolete. Determines if the parameter allows no value to be passed from it's editor.
AvailableValues | Obsolete. Gets an object that defines a set of values the parameter can accept from.
MultiValue | Obsolete. Determines if the parameter can hold more then one value.
Text | Obsolete. Gets or sets the text for the parameter to be displayed in the report viewer.
Visible | Obsolete. Determines whether the parameter user interface is visible.

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


AllowBlank Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.AllowBlank Property
ReportParameterUISettings Class See Also Send Feedback
Determines if the parameter allows an empty string to be passed. Only for parameters of type string.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.AllowBlank property instead.")]
public bool AllowBlank { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.AllowBlank property instead.")> _
Public Property AllowBlank As Boolean

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


AllowNull Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.AllowNull Property
ReportParameterUISettings Class See Also Send Feedback
Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.AllowNull property instead.")]
public bool AllowNull { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.AllowNull property instead.")> _
Public Property AllowNull As Boolean

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.AvailableValues Property
ReportParameterUISettings Class See Also Send Feedback
Gets an object that defines a set of values the parameter can accept from.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.AvailableValues property instead.")]
public ReportParameterAvailableValues AvailableValues { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.AvailableValues property instead.")> _
Public ReadOnly Property AvailableValues As ReportParameterAvailableValues

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


MultiValue Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.MultiValue Property
ReportParameterUISettings Class See Also Send Feedback
Determines if the parameter can hold more then one value.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.MultiValue property instead.")]
public bool MultiValue { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.MultiValue property instead.")> _
Public Property MultiValue As Boolean

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.Text Property
ReportParameterUISettings Class See Also Send Feedback
Gets or sets the text for the parameter to be displayed in the report viewer.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.Text property instead.")]
public string Text { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.Text property instead.")> _
Public Property Text As String

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ReportParameterUISettings..::.Visible Property
ReportParameterUISettings Class See Also Send Feedback
Determines whether the parameter user interface is visible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the ReportParameter.Visible property instead.")]
public bool Visible { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the ReportParameter.Visible property instead.")> _
Public Property Visible As Boolean

See Also

ReportParameterUISettings Class
Telerik.Reporting Namespace


ReportSection Class

[image]

Telerik Reporting Q2 2012
ReportSection Class
Members See Also Send Feedback
Base abstract class for all report sections contained in the report body. Inherited by DetailSection, GroupSection, ReportHeaderSection, ReportFooterSection,

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportSection : ReportSectionBase
Visual Basic (Declaration)
Public MustInherit Class ReportSection _
    Inherits ReportSectionBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.ReportSection
Telerik.Reporting..::.DetailSection
Telerik.Reporting..::.GroupSection
Telerik.Reporting..::.ReportFooterSection
Telerik.Reporting..::.ReportHeaderSection

See Also

ReportSection Members
Telerik.Reporting Namespace


ReportSection Members

[image] [image]

Telerik Reporting Q2 2012
ReportSection Members
ReportSection Class Constructors Methods Properties Events See Also Send Feedback

The ReportSection type exposes the following members.

Constructors

Name | Description
ReportSection | Initializes a new instance of the ReportSection class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection.
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportSection Class
Telerik.Reporting Namespace


ReportSection Constructor

[image]

Telerik Reporting Q2 2012
ReportSection Constructor
ReportSection Class See Also Send Feedback
Initializes a new instance of the ReportSection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportSection()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportSection Class
Telerik.Reporting Namespace


ReportSection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportSection Methods
ReportSection Class See Also Send Feedback

The ReportSection type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

ReportSection Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportSection..::.Dispose Method
ReportSection Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

ReportSection Class
ReportSection Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportSection..::.ToString Method
ReportSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportSection Class
ReportSection Members
Telerik.Reporting Namespace


ReportSection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportSection Properties
ReportSection Class See Also Send Feedback

The ReportSection type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section. (Inherited from ReportSectionBase.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
PageBreak | Gets or sets the page braking rule for this ReportSection.
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

ReportSection Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
ReportSection..::.KeepTogether Property
ReportSection Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the ReportSection on one page if possible.

See Also

ReportSection Class
Telerik.Reporting Namespace


PageBreak Property

[image]

Telerik Reporting Q2 2012
ReportSection..::.PageBreak Property
ReportSection Class See Also Send Feedback
Gets or sets the page braking rule for this ReportSection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageBreak PageBreak { get; set; }
Visual Basic (Declaration)
Public Property PageBreak As PageBreak

Field Value

A PageBreak object specifying the page braking rule for this ReportSection.

See Also

ReportSection Class
Telerik.Reporting Namespace


ReportSection Events

[image] [image]

Telerik Reporting Q2 2012
ReportSection Events
ReportSection Class See Also Send Feedback

The ReportSection type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportSection Class
Telerik.Reporting Namespace


ReportSectionBase Class

[image]

Telerik Reporting Q2 2012
ReportSectionBase Class
Members See Also Send Feedback
Defines the base class for report sections.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportSectionBase : ReportItemBase
Visual Basic (Declaration)
Public MustInherit Class ReportSectionBase _
    Inherits ReportItemBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportSectionBase
Telerik.Reporting..::.PageSection
Telerik.Reporting..::.ReportSection

See Also

ReportSectionBase Members
Telerik.Reporting Namespace


ReportSectionBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Members
ReportSectionBase Class Constructors Methods Properties Events See Also Send Feedback

The ReportSectionBase type exposes the following members.

Constructors

Name | Description
ReportSectionBase | Initializes a new instance of the ReportSectionBase class.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


ReportSectionBase Constructor

[image]

Telerik Reporting Q2 2012
ReportSectionBase Constructor
ReportSectionBase Class See Also Send Feedback
Initializes a new instance of the ReportSectionBase class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportSectionBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


ReportSectionBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Methods
ReportSectionBase Class See Also Send Feedback

The ReportSectionBase type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase..::.Dispose Method
ReportSectionBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

ReportSectionBase Class
ReportSectionBase Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase..::.ToString Method
ReportSectionBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportSectionBase Class
ReportSectionBase Members
Telerik.Reporting Namespace


ReportSectionBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Properties
ReportSectionBase Class See Also Send Feedback

The ReportSectionBase type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DesignMode | (Inherited from ReportItemBase.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the current section.
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Site | (Inherited from ReportItemBase.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ReportSectionBase..::.Height Property
ReportSectionBase Class See Also Send Feedback
Gets or sets the height of the current section.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

Field Value

The height of the current section in Units.

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


ReportSectionBase Events

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Events
ReportSectionBase Class See Also Send Feedback

The ReportSectionBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

ReportSectionBase Class
Telerik.Reporting Namespace


ReportSource Class

[image]

Telerik Reporting Q2 2012
ReportSource Class
Members See Also Send Feedback
Provides the base class for a report source. This is an abstract class that contains only a collection of parameter values that are passed to the IReportDocument object when its instance is initialized.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportSource
Visual Basic (Declaration)
Public MustInherit Class ReportSource

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.XmlReportSource

See Also

ReportSource Members
Telerik.Reporting Namespace


ReportSource Members

[image] [image]

Telerik Reporting Q2 2012
ReportSource Members
ReportSource Class Constructors Methods Properties See Also Send Feedback

The ReportSource type exposes the following members.

Constructors

Name | Description
ReportSource | Initializes a new instance of the ReportSource class

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized.

See Also

ReportSource Class
Telerik.Reporting Namespace


ReportSource Constructor

[image]

Telerik Reporting Q2 2012
ReportSource Constructor
ReportSource Class See Also Send Feedback
Initializes a new instance of the ReportSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ReportSource()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportSource Class
Telerik.Reporting Namespace


ReportSource Methods

[image] [image]

Telerik Reporting Q2 2012
ReportSource Methods
ReportSource Class See Also Send Feedback

The ReportSource type exposes the following members.

Methods

Name | Description
Equals | (Overrides Object..::.Equals(Object).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
ToString | (Overrides Object..::.ToString()()().)

See Also

ReportSource Class
Telerik.Reporting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
ReportSource..::.Equals Method
ReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

ReportSource Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ReportSource..::.GetHashCode Method
ReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

ReportSource Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportSource..::.ToString Method
ReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ReportSource Class
Telerik.Reporting Namespace


ReportSource Properties

[image] [image]

Telerik Reporting Q2 2012
ReportSource Properties
ReportSource Class See Also Send Feedback

The ReportSource type exposes the following members.

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized.

See Also

ReportSource Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
ReportSource..::.Parameters Property
ReportSource Class See Also Send Feedback
Determines the parameter values that are passed to the IReportDocument object when its instance is initialized.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection

Remarks

The parameter name must match the name of the ReportParameter of the IReportDocument in order the value to be passed correctly.

See Also

ReportSource Class
Telerik.Reporting Namespace


Shape Class

[image]

Telerik Reporting Q2 2012
Shape Class
Members See Also Send Feedback
Represents a shape report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Shape : ReportItem
Visual Basic (Declaration)
Public Class Shape _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Shape

See Also

Shape Members
Telerik.Reporting Namespace


Shape Members

[image] [image]

Telerik Reporting Q2 2012
Shape Members
Shape Class Constructors Methods Properties Events See Also Send Feedback

The Shape type exposes the following members.

Constructors

Name | Description
Shape | Initializes a new instance of the Shape class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the shape in degrees.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
ShapeType | Gets or sets the type of the shape displayed in the item.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Stretch | Gets or sets a value indicating whether to stretch the shape in the item or not.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Shape Class
Telerik.Reporting Namespace


Shape Constructor

[image]

Telerik Reporting Q2 2012
Shape Constructor
Shape Class See Also Send Feedback
Initializes a new instance of the Shape class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Shape()
Visual Basic (Declaration)
Public Sub New

See Also

Shape Class
Telerik.Reporting Namespace


Shape Methods

[image] [image]

Telerik Reporting Q2 2012
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

Shape Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Shape..::.Dispose Method
Shape Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Shape Class
Shape Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Shape..::.ToString Method
Shape Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Shape Class
Shape Members
Telerik.Reporting Namespace


Shape Properties

[image] [image]

Telerik Reporting Q2 2012
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the shape in degrees.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | (Overrides ReportItem..::.DefaultSize.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
ShapeType | Gets or sets the type of the shape displayed in the item.
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Stretch | Gets or sets a value indicating whether to stretch the shape in the item or not.
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Shape Class
Telerik.Reporting Namespace


Angle Property

[image]

Telerik Reporting Q2 2012
Shape..::.Angle Property
Shape Class See Also Send Feedback
Gets or sets the angle of rotation of the shape in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double

Field Value

A double value indicating the angle of rotation in degrees.

See Also

Shape Class
Telerik.Reporting Namespace


DefaultSize Property

[image]

Telerik Reporting Q2 2012
Shape..::.DefaultSize Property
Shape Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override SizeU DefaultSize { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultSize As SizeU

See Also

Shape Class
Telerik.Reporting Namespace


ShapeType Property

[image]

Telerik Reporting Q2 2012
Shape..::.ShapeType Property
Shape Class See Also Send Feedback
Gets or sets the type of the shape displayed in the item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ShapeBase ShapeType { get; set; }
Visual Basic (Declaration)
Public Property ShapeType As ShapeBase

Field Value

A ShapeBase object representing the type of the shape displayed in the item.

See Also

Shape Class
Telerik.Reporting Namespace


Stretch Property

[image]

Telerik Reporting Q2 2012
Shape..::.Stretch Property
Shape Class See Also Send Feedback
Gets or sets a value indicating whether to stretch the shape in the item or not.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Stretch { get; set; }
Visual Basic (Declaration)
Public Property Stretch As Boolean

Field Value

true if the shape should be stretched; otherwise false.

See Also

Shape Class
Telerik.Reporting Namespace


Shape Events

[image] [image]

Telerik Reporting Q2 2012
Shape Events
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

Shape Class
Telerik.Reporting Namespace


SortDirection Enumeration

[image]

Telerik Reporting Q2 2012
SortDirection Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum SortDirection
Visual Basic (Declaration)
Public Enumeration SortDirection

Members

Member name | Description
Asc |
Desc |

See Also

Telerik.Reporting Namespace


Sorting Class

[image]

Telerik Reporting Q2 2012
Sorting Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Sorting : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Sorting _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Sorting
Telerik.Reporting.Data..::.Sorting

See Also

Sorting Members
Telerik.Reporting Namespace


Sorting Members

[image] [image]

Telerik Reporting Q2 2012
Sorting Members
Sorting Class Constructors Methods Properties Events See Also Send Feedback

The Sorting type exposes the following members.

Constructors

Name | Description
Sorting | Overloaded.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Direction |
Expression |
IsEmpty |

Events

Name | Description
PropertyChanged |

See Also

Sorting Class
Telerik.Reporting Namespace


Sorting Constructor

[image] [image]

Telerik Reporting Q2 2012
Sorting Constructor
Sorting Class See Also Send Feedback

Overload List

Name | Description
Sorting()()() | Initializes a new instance of the Sorting class
Sorting(String) | Initializes a new instance of the Sorting class
Sorting(String, SortDirection) | Initializes a new instance of the Sorting class

See Also

Sorting Class
Sorting Members
Telerik.Reporting Namespace


Sorting Constructor

[image]

Telerik Reporting Q2 2012
Sorting Constructor
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting()
Visual Basic (Declaration)
Public Sub New

See Also

Sorting Class
Sorting Overload
Telerik.Reporting Namespace


Sorting Constructor (String)

[image]

Telerik Reporting Q2 2012
Sorting Constructor (String)
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)

Parameters

expression
Type: System..::.String

See Also

Sorting Class
Sorting Overload
Telerik.Reporting Namespace


Sorting Constructor (String, SortDirection)

[image]

Telerik Reporting Q2 2012
Sorting Constructor (String, SortDirection)
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting(
    string expression,
    SortDirection direction
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    direction As SortDirection _
)

Parameters

expression
Type: System..::.String
direction
Type: Telerik.Reporting..::.SortDirection

See Also

Sorting Class
Sorting Overload
Telerik.Reporting Namespace


Sorting Methods

[image] [image]

Telerik Reporting Q2 2012
Sorting Methods
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

Sorting Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Sorting..::.ToString Method
Sorting Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Sorting Class
Telerik.Reporting Namespace


Sorting Properties

[image] [image]

Telerik Reporting Q2 2012
Sorting Properties
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Properties

Name | Description
Direction |
Expression |
IsEmpty |

See Also

Sorting Class
Telerik.Reporting Namespace


Direction Property

[image]

Telerik Reporting Q2 2012
Sorting..::.Direction Property
Sorting Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As SortDirection

See Also

Sorting Class
Telerik.Reporting Namespace


Expression Property

[image]

Telerik Reporting Q2 2012
Sorting..::.Expression Property
Sorting Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

Sorting Class
Telerik.Reporting Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
Sorting..::.IsEmpty Property
Sorting Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

See Also

Sorting Class
Telerik.Reporting Namespace


Sorting Events

[image] [image]

Telerik Reporting Q2 2012
Sorting Events
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Sorting Class
Telerik.Reporting Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Sorting..::.PropertyChanged Event
Sorting Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Sorting Class
Telerik.Reporting Namespace


SortingCollection Class

[image]

Telerik Reporting Q2 2012
SortingCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class SortingCollection : Collection<Sorting>
Visual Basic (Declaration)
Public Class SortingCollection _
    Inherits Collection(Of Sorting)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Sorting >)>)>
Telerik.Reporting..::.SortingCollection

See Also

SortingCollection Members
Telerik.Reporting Namespace


SortingCollection Members

[image] [image]

Telerik Reporting Q2 2012
SortingCollection Members
SortingCollection Class Constructors Methods See Also Send Feedback

The SortingCollection type exposes the following members.

Constructors

Name | Description
SortingCollection | Initializes a new instance of the SortingCollection class

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

SortingCollection Class
Telerik.Reporting Namespace


SortingCollection Constructor

[image]

Telerik Reporting Q2 2012
SortingCollection Constructor
SortingCollection Class See Also Send Feedback
Initializes a new instance of the SortingCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection()
Visual Basic (Declaration)
Public Sub New

See Also

SortingCollection Class
Telerik.Reporting Namespace


SortingCollection Methods

[image] [image]

Telerik Reporting Q2 2012
SortingCollection Methods
SortingCollection Class See Also Send Feedback

The SortingCollection type exposes the following members.

Methods

Name | Description
Add |
AddRange |
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

SortingCollection Class
Telerik.Reporting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
SortingCollection..::.Add Method
SortingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string expression,
    SortDirection dir
)
Visual Basic (Declaration)
Public Sub Add ( _
    expression As String, _
    dir As SortDirection _
)

Parameters

expression
Type: System..::.String
dir
Type: Telerik.Reporting..::.SortDirection

See Also

SortingCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
SortingCollection..::.AddRange Method
SortingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    Sorting[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As Sorting() _
)

Parameters

items
Type: array< Telerik.Reporting..::.Sorting >[]()[][]

See Also

SortingCollection Class
Telerik.Reporting Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
SortingCollection..::.InsertItem Method
SortingCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Sorting item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Sorting _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting..::.Sorting

See Also

SortingCollection Class
Telerik.Reporting Namespace


SqlDataSource Class

[image]

Telerik Reporting Q2 2012
SqlDataSource Class
Members See Also Send Feedback
Represents an SQL database to data items.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class SqlDataSource : DataSource
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlDataSource _
    Inherits DataSource

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
Telerik.Reporting..::.DataSource
Telerik.Reporting..::.SqlDataSource

See Also

SqlDataSource Members
Telerik.Reporting Namespace


SqlDataSource Members

[image] [image]

Telerik Reporting Q2 2012
SqlDataSource Members
SqlDataSource Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The SqlDataSource type exposes the following members.

Constructors

Name | Description
SqlDataSource | Overloaded.

Methods

Name | Description
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
CommandTimeout | Gets or sets the wait time in seconds before terminating the attempt to retrieve data.
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with data source parameters.
ProviderName | Gets or sets the managed provider name used to connect to data.
SelectCommand | Gets or sets the SQL select statement or stored procedure to execute.
SelectCommandType | Gets or sets a value indicating how the select command to be interpreted.

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

SqlDataSource Class
Telerik.Reporting Namespace


SqlDataSource Constructor

[image] [image]

Telerik Reporting Q2 2012
SqlDataSource Constructor
SqlDataSource Class See Also Send Feedback

Overload List

Name | Description
SqlDataSource()()() | Initializes a new instance of the SqlDataSource class.
SqlDataSource(SerializationInfo, StreamingContext) | Initializes a new instance of the SqlDataSource class
SqlDataSource(String, String) | Initializes a new instance of the SqlDataSource class.
SqlDataSource(String, String, String) | Initializes a new instance of the SqlDataSource class.
SqlDataSource(String, String, String, SqlDataSourceCommandType) | Initializes a new instance of the SqlDataSource class.

See Also

SqlDataSource Class
SqlDataSource Members
Telerik.Reporting Namespace


SqlDataSource Constructor

[image]

Telerik Reporting Q2 2012
SqlDataSource Constructor
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSource()
Visual Basic (Declaration)
Public Sub New

See Also

SqlDataSource Class
SqlDataSource Overload
Telerik.Reporting Namespace


SqlDataSource Constructor (SerializationInfo, StreamingContext)

[image]

Telerik Reporting Q2 2012
SqlDataSource Constructor (SerializationInfo, StreamingContext)
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected SqlDataSource(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Sub New ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

SqlDataSource Class
SqlDataSource Overload
Telerik.Reporting Namespace


SqlDataSource Constructor (String, String)

[image]

Telerik Reporting Q2 2012
SqlDataSource Constructor (String, String)
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSource(
    string connectionString,
    string selectCommand
)
Visual Basic (Declaration)
Public Sub New ( _
    connectionString As String, _
    selectCommand As String _
)

Parameters

connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
selectCommand
Type: System..::.String
Specifies the SQL select statement or stored procedure to execute.

See Also

SqlDataSource Class
SqlDataSource Overload
Telerik.Reporting Namespace


SqlDataSource Constructor (String, String, String)

[image]

Telerik Reporting Q2 2012
SqlDataSource Constructor (String, String, String)
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSource(
    string providerName,
    string connectionString,
    string selectCommand
)
Visual Basic (Declaration)
Public Sub New ( _
    providerName As String, _
    connectionString As String, _
    selectCommand As String _
)

Parameters

providerName
Type: System..::.String
Specifies the managed provider name used to connect to data.
connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
selectCommand
Type: System..::.String
Specifies the SQL select statement or stored procedure to execute.

See Also

SqlDataSource Class
SqlDataSource Overload
Telerik.Reporting Namespace


SqlDataSource Constructor (String, String, String, SqlDataSourceCommandType)

[image]

Telerik Reporting Q2 2012
SqlDataSource Constructor (String, String, String, SqlDataSourceCommandType)
SqlDataSource Class See Also Send Feedback
Initializes a new instance of the SqlDataSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSource(
    string providerName,
    string connectionString,
    string selectCommand,
    SqlDataSourceCommandType selectCommandType
)
Visual Basic (Declaration)
Public Sub New ( _
    providerName As String, _
    connectionString As String, _
    selectCommand As String, _
    selectCommandType As SqlDataSourceCommandType _
)

Parameters

providerName
Type: System..::.String
Specifies the managed provider name used to connect to data.
connectionString
Type: System..::.String
Specifies the connection string used to connect to data.
selectCommand
Type: System..::.String
Specifies the SQL select statement or stored procedure to execute.
selectCommandType
Type: Telerik.Reporting..::.SqlDataSourceCommandType
Specifies how the select command string to be interpreted.

See Also

SqlDataSource Class
SqlDataSource Overload
Telerik.Reporting Namespace


SqlDataSource Methods

[image] [image]

Telerik Reporting Q2 2012
SqlDataSource Methods
SqlDataSource Class See Also Send Feedback

The SqlDataSource type exposes the following members.

Methods

Name | Description
GetObjectData | (Overrides DataSource..::.GetObjectData(SerializationInfo, StreamingContext).)

Explicit Interface Implementations

Name | Description
ISerializable..::.GetObjectData | (Inherited from DataSource.)

See Also

SqlDataSource Class
Telerik.Reporting Namespace


GetObjectData Method

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.GetObjectData Method
SqlDataSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void GetObjectData(
    SerializationInfo serializationInfo,
    StreamingContext streamingContext
)
Visual Basic (Declaration)
Protected Overrides Sub GetObjectData ( _
    serializationInfo As SerializationInfo, _
    streamingContext As StreamingContext _
)

Parameters

serializationInfo
Type: System.Runtime.Serialization..::.SerializationInfo
streamingContext
Type: System.Runtime.Serialization..::.StreamingContext

See Also

SqlDataSource Class
Telerik.Reporting Namespace


SqlDataSource Properties

[image] [image]

Telerik Reporting Q2 2012
SqlDataSource Properties
SqlDataSource Class See Also Send Feedback

The SqlDataSource type exposes the following members.

Properties

Name | Description
CalculatedFields | Gets the calculated fields collection. (Inherited from DataSource.)
CommandTimeout | Gets or sets the wait time in seconds before terminating the attempt to retrieve data.
ConnectionString | Gets or sets the connection string used to connect to data.
Name | Gets or sets the name of the DataSource component. (Inherited from DataSource.)
Parameters | Gets a collection with data source parameters.
ProviderName | Gets or sets the managed provider name used to connect to data.
SelectCommand | Gets or sets the SQL select statement or stored procedure to execute.
SelectCommandType | Gets or sets a value indicating how the select command to be interpreted.

See Also

SqlDataSource Class
Telerik.Reporting Namespace


CommandTimeout Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.CommandTimeout Property
SqlDataSource Class See Also Send Feedback
Gets or sets the wait time in seconds before terminating the attempt to retrieve data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CommandTimeout { get; set; }
Visual Basic (Declaration)
Public Property CommandTimeout As Integer

Field Value

The time in seconds to wait before terminating the attempt to retrieve data. The default value of the CommandTimeout property is 30 seconds.

Remarks

The provided value should be valid for the currently used data provider.

See Also

SqlDataSource Class
Telerik.Reporting Namespace


ConnectionString Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.ConnectionString Property
SqlDataSource Class See Also Send Feedback
Gets or sets the connection string used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String

Remarks

The ConnectionString property contains either a valid connection string or the name of a [!:ConnectionStringSettings] in the application configuration file.

See Also

SqlDataSource Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.Parameters Property
SqlDataSource Class See Also Send Feedback
Gets a collection with data source parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameterCollection Parameters { get; private set; }
Visual Basic (Declaration)
Public Property Parameters As SqlDataSourceParameterCollection

See Also

SqlDataSource Class
Telerik.Reporting Namespace


ProviderName Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.ProviderName Property
SqlDataSource Class See Also Send Feedback
Gets or sets the managed provider name used to connect to data.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ProviderName { get; set; }
Visual Basic (Declaration)
Public Property ProviderName As String

Remarks

If the ProviderName property is set to null (Nothing in Visual Basic) or an empty string, the default provider is System.Data.SqlClient.

See Also

SqlDataSource Class
Telerik.Reporting Namespace


SelectCommand Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.SelectCommand Property
SqlDataSource Class See Also Send Feedback
Gets or sets the SQL select statement or stored procedure to execute.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string SelectCommand { get; set; }
Visual Basic (Declaration)
Public Property SelectCommand As String

See Also

SqlDataSource Class
Telerik.Reporting Namespace


SelectCommandType Property

[image]

Telerik Reporting Q2 2012
SqlDataSource..::.SelectCommandType Property
SqlDataSource Class See Also Send Feedback
Gets or sets a value indicating how the select command to be interpreted.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceCommandType SelectCommandType { get; set; }
Visual Basic (Declaration)
Public Property SelectCommandType As SqlDataSourceCommandType

Remarks

One of the SqlDataSourceCommandType enumeration values. The default value of the SelectCommandType property is Text.

See Also

SqlDataSource Class
Telerik.Reporting Namespace


SqlDataSourceCommandType Enumeration

[image]

Telerik Reporting Q2 2012
SqlDataSourceCommandType Enumeration
See Also Send Feedback
Specifies how a command string is interpreted.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum SqlDataSourceCommandType
Visual Basic (Declaration)
Public Enumeration SqlDataSourceCommandType

Members

Member name | Description
Text | An SQL text command. (Default)
StoredProcedure | The name of a stored procedure.

See Also

Telerik.Reporting Namespace


SqlDataSourceParameter Class

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Class
Members See Also Send Feedback
Represents a parameter in a SqlDataSource component.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class SqlDataSourceParameter : DataSourceParameter
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlDataSourceParameter _
    Inherits DataSourceParameter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.DataSourceParameter
Telerik.Reporting..::.SqlDataSourceParameter

See Also

SqlDataSourceParameter Members
Telerik.Reporting Namespace


SqlDataSourceParameter Members

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Members
SqlDataSourceParameter Class Constructors Methods Properties Events See Also Send Feedback

The SqlDataSourceParameter type exposes the following members.

Constructors

Name | Description
SqlDataSourceParameter | Overloaded.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

Properties

Name | Description
DbType | Gets or sets the data type of the parameter.
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

SqlDataSourceParameter Class
Telerik.Reporting Namespace


SqlDataSourceParameter Constructor

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Constructor
SqlDataSourceParameter Class See Also Send Feedback

Overload List

Name | Description
SqlDataSourceParameter()()() | Initializes a new instance of the SqlDataSourceParameter class.
SqlDataSourceParameter(String) | Initializes a new instance of the SqlDataSourceParameter class.
SqlDataSourceParameter(String, DbType) | Initializes a new instance of the SqlDataSourceParameter class.
SqlDataSourceParameter(String, DbType, Object) | Initializes a new instance of the SqlDataSourceParameter class.

See Also

SqlDataSourceParameter Class
SqlDataSourceParameter Members
Telerik.Reporting Namespace


SqlDataSourceParameter Constructor

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Constructor
SqlDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter()
Visual Basic (Declaration)
Public Sub New

See Also

SqlDataSourceParameter Class
SqlDataSourceParameter Overload
Telerik.Reporting Namespace


SqlDataSourceParameter Constructor (String)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Constructor (String)
SqlDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.

See Also

SqlDataSourceParameter Class
SqlDataSourceParameter Overload
Telerik.Reporting Namespace


SqlDataSourceParameter Constructor (String, DbType)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Constructor (String, DbType)
SqlDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter(
    string name,
    DbType dataType
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As DbType _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
dataType
Type: System.Data..::.DbType
Specifies the data type of the parameter.

See Also

SqlDataSourceParameter Class
SqlDataSourceParameter Overload
Telerik.Reporting Namespace


SqlDataSourceParameter Constructor (String, DbType, Object)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Constructor (String, DbType, Object)
SqlDataSourceParameter Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameter class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter(
    string name,
    DbType dataType,
    Object value
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    dataType As DbType, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the parameter.
dataType
Type: System.Data..::.DbType
Specifies the data type of the parameter.
value
Type: System..::.Object
Specifies the value of the parameter.

See Also

SqlDataSourceParameter Class
SqlDataSourceParameter Overload
Telerik.Reporting Namespace


SqlDataSourceParameter Methods

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Methods
SqlDataSourceParameter Class See Also Send Feedback

The SqlDataSourceParameter type exposes the following members.

Methods

Name | Description
NotifyPropertyChanged | (Inherited from DataSourceParameter.)

See Also

SqlDataSourceParameter Class
Telerik.Reporting Namespace


SqlDataSourceParameter Properties

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Properties
SqlDataSourceParameter Class See Also Send Feedback

The SqlDataSourceParameter type exposes the following members.

Properties

Name | Description
DbType | Gets or sets the data type of the parameter.
Name | Gets or sets the name of the parameter. (Inherited from DataSourceParameter.)
Value | Gets or sets the value of the parameter. (Inherited from DataSourceParameter.)

See Also

SqlDataSourceParameter Class
Telerik.Reporting Namespace


DbType Property

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameter..::.DbType Property
SqlDataSourceParameter Class See Also Send Feedback
Gets or sets the data type of the parameter.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DbType DbType { get; set; }
Visual Basic (Declaration)
Public Property DbType As DbType

See Also

SqlDataSourceParameter Class
Telerik.Reporting Namespace


SqlDataSourceParameter Events

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameter Events
SqlDataSourceParameter Class See Also Send Feedback

The SqlDataSourceParameter type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from DataSourceParameter.)

See Also

SqlDataSourceParameter Class
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Class

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Class
Members See Also Send Feedback
Represents a collection of SqlDataSourceParameter objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class SqlDataSourceParameterCollection : Collection<SqlDataSourceParameter>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class SqlDataSourceParameterCollection _
    Inherits Collection(Of SqlDataSourceParameter)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' SqlDataSourceParameter >)>)>
Telerik.Reporting..::.SqlDataSourceParameterCollection

See Also

SqlDataSourceParameterCollection Members
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Members
SqlDataSourceParameterCollection Class Constructors Methods Properties See Also Send Feedback

The SqlDataSourceParameterCollection type exposes the following members.

Constructors

Name | Description
SqlDataSourceParameterCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Constructor
SqlDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
SqlDataSourceParameterCollection()()() | Initializes a new instance of the SqlDataSourceParameterCollection class.
SqlDataSourceParameterCollection(array<SqlDataSourceParameter>[]()[]) | Initializes a new instance of the SqlDataSourceParameterCollection class.
SqlDataSourceParameterCollection(SqlDataSourceParameterCollection) | Initializes a new instance of the SqlDataSourceParameterCollection class.

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Members
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Constructor
SqlDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Overload
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Constructor (SqlDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Constructor (array<SqlDataSourceParameter>[]()[][])
SqlDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameterCollection(
    SqlDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As SqlDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.SqlDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Overload
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Constructor (SqlDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Constructor (SqlDataSourceParameterCollection)
SqlDataSourceParameterCollection Class See Also Send Feedback
Initializes a new instance of the SqlDataSourceParameterCollection class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameterCollection(
    SqlDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As SqlDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.SqlDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Overload
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Methods
SqlDataSourceParameterCollection Class See Also Send Feedback

The SqlDataSourceParameterCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddRange | Overloaded.
Contains | Determines if the collection contains a parameter with the specified name.
ToArray | Converts the collection to an array of parameters.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


Add Method

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Add Method
SqlDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Add(String) | Adds a new parameter with the specified name to the collection.
Add(String, DbType) | Adds a new parameter with the specified name and data type to the collection.
Add(String, DbType, Object) | Adds a new parameter with the specified name, data type and value to the collection.

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Members
Telerik.Reporting Namespace


Add Method (String)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Add Method (String)
SqlDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.

See Also

SqlDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


Add Method (String, DbType)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Add Method (String, DbType)
SqlDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name and data type to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    DbType dataType
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    dataType As DbType _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.
dataType
Type: System.Data..::.DbType
Specifies the data type of the new parameter to add to the collection.

See Also

SqlDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


Add Method (String, DbType, Object)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Add Method (String, DbType, Object)
SqlDataSourceParameterCollection Class See Also Send Feedback
Adds a new parameter with the specified name, data type and value to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name,
    DbType dataType,
    Object value
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String, _
    dataType As DbType, _
    value As Object _
)

Parameters

name
Type: System..::.String
Specifies the name of the new parameter to add to the collection.
dataType
Type: System.Data..::.DbType
Specifies the data type of the new parameter to add to the collection.
value
Type: System..::.Object
Specifies the value of the new parameter to add to the collection.

See Also

SqlDataSourceParameterCollection Class
Add Overload
Telerik.Reporting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.AddRange Method
SqlDataSourceParameterCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<SqlDataSourceParameter>[]()[]) | Adds a range of parameters to the collection.
AddRange(SqlDataSourceParameterCollection) | Adds a range of parameters to the collection.

See Also

SqlDataSourceParameterCollection Class
SqlDataSourceParameterCollection Members
Telerik.Reporting Namespace


AddRange Method (SqlDataSourceParameter[])

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.AddRange Method (array<SqlDataSourceParameter>[]()[][])
SqlDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    SqlDataSourceParameter[] parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As SqlDataSourceParameter() _
)

Parameters

parameters
Type: array< Telerik.Reporting..::.SqlDataSourceParameter >[]()[][]
Specifies a range of parameters to add to the collection.

See Also

SqlDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


AddRange Method (SqlDataSourceParameterCollection)

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.AddRange Method (SqlDataSourceParameterCollection)
SqlDataSourceParameterCollection Class See Also Send Feedback
Adds a range of parameters to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    SqlDataSourceParameterCollection parameters
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    parameters As SqlDataSourceParameterCollection _
)

Parameters

parameters
Type: Telerik.Reporting..::.SqlDataSourceParameterCollection
Specifies a range of parameters to add to the collection.

See Also

SqlDataSourceParameterCollection Class
AddRange Overload
Telerik.Reporting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Contains Method
SqlDataSourceParameterCollection Class See Also Send Feedback
Determines if the collection contains a parameter with the specified name.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

True if a parameter with the specified name exists, False otherwise.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


ToArray Method

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.ToArray Method
SqlDataSourceParameterCollection Class See Also Send Feedback
Converts the collection to an array of parameters.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter[] ToArray()
Visual Basic (Declaration)
Public Function ToArray As SqlDataSourceParameter()

Return Value

Array of parameters contained in the collection.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


SqlDataSourceParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection Properties
SqlDataSourceParameterCollection Class See Also Send Feedback

The SqlDataSourceParameterCollection type exposes the following members.

Properties

Name | Description
Item | Gets the parameter with the specified name from the collection.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
SqlDataSourceParameterCollection..::.Item Property
SqlDataSourceParameterCollection Class See Also Send Feedback
Gets the parameter with the specified name from the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SqlDataSourceParameter this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As SqlDataSourceParameter

Parameters

name
Type: System..::.String
Specifies the name of a parameter from the collection.

Return Value

The parameter with the specified name from the collection.

See Also

SqlDataSourceParameterCollection Class
Telerik.Reporting Namespace


SubReport Class

[image]

Telerik Reporting Q2 2012
SubReport Class
Members See Also Send Feedback
Represents a report item used to embed another report into the current report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class SubReport : ReportItem
Visual Basic (Declaration)
Public Class SubReport _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.SubReport

See Also

SubReport Members
Telerik.Reporting Namespace


SubReport Members

[image] [image]

Telerik Reporting Q2 2012
SubReport Members
SubReport Class Constructors Methods Properties Events See Also Send Feedback

The SubReport type exposes the following members.

Constructors

Name | Description
SubReport | Initializes a new instance of the SubReport class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the SubReport on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parameters | Obsolete.
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
ReportSource | Specifies the ReportSource for the sub-report.
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the inner report has no data source set.

See Also

SubReport Class
Telerik.Reporting Namespace


SubReport Constructor

[image]

Telerik Reporting Q2 2012
SubReport Constructor
SubReport Class See Also Send Feedback
Initializes a new instance of the SubReport class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SubReport()
Visual Basic (Declaration)
Public Sub New

See Also

SubReport Class
Telerik.Reporting Namespace


SubReport Methods

[image] [image]

Telerik Reporting Q2 2012
SubReport Methods
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

SubReport Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
SubReport..::.Dispose Method
SubReport Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

SubReport Class
SubReport Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
SubReport..::.ToString Method
SubReport Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

SubReport Class
SubReport Members
Telerik.Reporting Namespace


SubReport Properties

[image] [image]

Telerik Reporting Q2 2012
SubReport Properties
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the SubReport on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parameters | Obsolete.
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
ReportSource | Specifies the ReportSource for the sub-report.
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

SubReport Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
SubReport..::.KeepTogether Property
SubReport Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the SubReport on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the SubReport on one page if possible.

See Also

SubReport Class
Telerik.Reporting Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
SubReport..::.Parameters Property
SubReport Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The Parameters property is now obsolete. Please use the ReportSource.Parameters property instead.")]
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Parameters property is now obsolete. Please use the ReportSource.Parameters property instead.")> _
Public ReadOnly Property Parameters As ParameterCollection

See Also

SubReport Class
Telerik.Reporting Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
SubReport..::.ReportSource Property
SubReport Class See Also Send Feedback
Specifies the ReportSource for the sub-report.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

SubReport Class
Telerik.Reporting Namespace
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.XmlReportSource


SubReport Events

[image] [image]

Telerik Reporting Q2 2012
SubReport Events
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of report processing if the inner report has no data source set.

See Also

SubReport Class
Telerik.Reporting Namespace


NeedDataSource Event

[image]

Telerik Reporting Q2 2012
SubReport..::.NeedDataSource Event
SubReport Class See Also Send Feedback
Occurs at the start of report processing if the inner report has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler NeedDataSource
Visual Basic (Declaration)
Public Event NeedDataSource As EventHandler

See Also

SubReport Class
Telerik.Reporting Namespace


Table Class

[image]

Telerik Reporting Q2 2012
Table Class
Members See Also Send Feedback
The table report item displays detail data, data organized in row groups, or both.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Table : ReportItem
Visual Basic (Declaration)
Public Class Table _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.Table
Telerik.Reporting..::.Crosstab
Telerik.Reporting..::.List

See Also

Table Members
Telerik.Reporting Namespace


Table Members

[image] [image]

Telerik Reporting Q2 2012
Table Members
Table Class Constructors Methods Properties Events See Also Send Feedback

The Table type exposes the following members.

Constructors

Name | Description
Table | Initializes a new instance of the Table class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource |
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values.
ColumnHeadersPrintOnEveryPage |
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item.
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render.
DataSource | Gets or sets the data source that the Table is displaying data for.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values.
RowHeadersPrintOnEveryPage |
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set.

See Also

Table Class
Telerik.Reporting Namespace


Table Constructor

[image]

Telerik Reporting Q2 2012
Table Constructor
Table Class See Also Send Feedback
Initializes a new instance of the Table class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Table()
Visual Basic (Declaration)
Public Sub New

See Also

Table Class
Telerik.Reporting Namespace


Table Methods

[image] [image]

Telerik Reporting Q2 2012
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
OnNeedDataSource |
ToString | Overloaded.

See Also

Table Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Table..::.Dispose Method
Table Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

Table Class
Table Members
Telerik.Reporting Namespace


OnNeedDataSource Method

[image]

Telerik Reporting Q2 2012
Table..::.OnNeedDataSource Method
Table Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnNeedDataSource(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnNeedDataSource ( _
    sender As Object, _
    e As EventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

Table Class
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Table..::.ToString Method
Table Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Table Class
Table Members
Telerik.Reporting Namespace


Table Properties

[image] [image]

Telerik Reporting Q2 2012
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Body | Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group.
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
ColumnGroups | Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values.
ColumnHeadersPrintOnEveryPage |
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Corner | Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item.
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Table will render.
DataSource | Gets or sets the data source that the Table is displaying data for.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
RowGroups | Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values.
RowHeadersPrintOnEveryPage |
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

Table Class
Telerik.Reporting Namespace


Body Property

[image]

Telerik Reporting Q2 2012
Table..::.Body Property
Table Class See Also Send Feedback
Table body area. (Optional) The Table body is located in the lower right corner. The Table body displays detail and grouped data. The scope for the expression is determined by the innermost groups to which the text box belongs. Cells in the Table body display detail data when they are members of a detail row and they represent aggregate data when they are members of a row or column associated with a group. By default, cells in a group row or column that contain simple expressions that do not include an aggregate function, evaluate to the first value in the group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBody Body { get; }
Visual Basic (Declaration)
Public ReadOnly Property Body As TableBody

See Also

Table Class
Telerik.Reporting Namespace


ColumnGroups Property

[image]

Telerik Reporting Q2 2012
Table..::.ColumnGroups Property
Table Class See Also Send Feedback
Table column group hierarchy. (Optional) Table column groups are located in the upper-right corner. This area is automatically created when you add a column group. Cells in this area represent members of the column groups hierarchy, and display the column group instance values.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IList<TableGroup> ColumnGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnGroups As IList(Of TableGroup)

See Also

Table Class
Telerik.Reporting Namespace


ColumnHeadersPrintOnEveryPage Property

[image]

Telerik Reporting Q2 2012
Table..::.ColumnHeadersPrintOnEveryPage Property
Table Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ColumnHeadersPrintOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeadersPrintOnEveryPage As Boolean

See Also

Table Class
Telerik.Reporting Namespace


Corner Property

[image]

Telerik Reporting Q2 2012
Table..::.Corner Property
Table Class See Also Send Feedback
Table corner area. (Optional) A Table corner is located in the upper-left corner. This area is automatically created when you add both row groups and column groups to a Table item. In this area, you can merge cells and add a label or embed another report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableCellContainer Corner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Corner As TableCellContainer

See Also

Table Class
Telerik.Reporting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Table..::.DataMember Property
Table Class See Also Send Feedback
Gets or sets the specific list in a DataSource which the Table will render.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

Field Value

A list in a DataSource. The default is an empty string ("").

Remarks

If a DataSource contains multiple sources of data, you should set the DataMember to one of the sources. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

If the DataSource is a DataTable, DataView, collection, or array, there is no need to set the DataMember property of the Table

See Also

Table Class
Telerik.Reporting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Table..::.DataSource Property
Table Class See Also Send Feedback
Gets or sets the data source that the Table is displaying data for.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

Field Value

An object that functions as a data source.

Remarks

The following data sources are valid:

  • A DataTable
  • A DataView
  • A DataSet
  • A DataViewManager
  • Any component that implements the IListSource interface
  • Any component that implements the IEnumerable interface
  • Any component that implements the IDataAdapter interface

If the DataSource reference contains more than one table, you must set the DataMember property a string that specifies the table to bind to. For example, if the DataSource is a DataSet or DataViewManager that contains three tables named Customers, Orders, and OrderDetails, you must specify the table to bind to.

Setting the DataSource to an object that does not implement the IListSource, IEnumerable, or IDataAdapter will cause an exception.

See Also

Table Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
Table..::.Filters Property
Table Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

Field Value

A [!:Telerik.Reporting.Data.FilterCollection] that contains the Filter objects for the Table

Remarks

Filter expressions limit the data that is displayed to the user after the data is retrieved from the data source.

See Also

Table Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
Table..::.KeepTogether Property
Table Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the Table on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the Table on one page if possible.

See Also

Table Class
Telerik.Reporting Namespace


RowGroups Property

[image]

Telerik Reporting Q2 2012
Table..::.RowGroups Property
Table Class See Also Send Feedback
Table row groups hierarchy. (Optional) Table row groups are located on the lower-left corner. This area is automatically created when you add a row group. Cells in this area represent members of the row groups hierarchy, and display row group instance values.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IList<TableGroup> RowGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowGroups As IList(Of TableGroup)

See Also

Table Class
Telerik.Reporting Namespace


RowHeadersPrintOnEveryPage Property

[image]

Telerik Reporting Q2 2012
Table..::.RowHeadersPrintOnEveryPage Property
Table Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool RowHeadersPrintOnEveryPage { get; set; }
Visual Basic (Declaration)
Public Property RowHeadersPrintOnEveryPage As Boolean

See Also

Table Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
Table..::.Sorting Property
Table Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

Table Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
Table..::.Sortings Property
Table Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

Field Value

A [!:Telerik.Reporting.Data.SortingCollection] that contains the Sorting objects for the Table

Remarks

Sort expressions sort the data that is displayed to the user after the data is retrieved from the data source.

See Also

Table Class
Telerik.Reporting Namespace


Table Events

[image] [image]

Telerik Reporting Q2 2012
Table Events
Table Class See Also Send Feedback

The Table type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)
NeedDataSource | Occurs at the start of table processing if the table has no data source set.

See Also

Table Class
Telerik.Reporting Namespace


NeedDataSource Event

[image]

Telerik Reporting Q2 2012
Table..::.NeedDataSource Event
Table Class See Also Send Feedback
Occurs at the start of table processing if the table has no data source set.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler NeedDataSource
Visual Basic (Declaration)
Public Event NeedDataSource As EventHandler

See Also

Table Class
Telerik.Reporting Namespace


TableBody Class

[image]

Telerik Reporting Q2 2012
TableBody Class
Members See Also Send Feedback
Represents the Body of the Table item

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableBody : TableCellContainer
Visual Basic (Declaration)
Public Class TableBody _
    Inherits TableCellContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableCellContainer
Telerik.Reporting..::.TableBody

See Also

TableBody Members
Telerik.Reporting Namespace


TableBody Members

[image] [image]

Telerik Reporting Q2 2012
TableBody Members
TableBody Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TableBody type exposes the following members.

Methods

Name | Description
ClearCellContent | (Inherited from TableCellContainer.)
Dispose | (Inherited from TableCellContainer.)
GetEnumerator | (Inherited from TableCellContainer.)
SetCellContent | Overloaded.

Properties

Name | Description
Columns | Gets the collection of the columns for the Table's Body.
Item | (Inherited from TableCellContainer.)
Rows | Gets the collection of the rows for the Table's Body

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from TableCellContainer.)

See Also

TableBody Class
Telerik.Reporting Namespace


TableBody Methods

[image] [image]

Telerik Reporting Q2 2012
TableBody Methods
TableBody Class See Also Send Feedback

The TableBody type exposes the following members.

Methods

Name | Description
ClearCellContent | (Inherited from TableCellContainer.)
Dispose | (Inherited from TableCellContainer.)
GetEnumerator | (Inherited from TableCellContainer.)
SetCellContent | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator | (Inherited from TableCellContainer.)

See Also

TableBody Class
Telerik.Reporting Namespace


SetCellContent Method

[image] [image]

Telerik Reporting Q2 2012
TableBody..::.SetCellContent Method
TableBody Class See Also Send Feedback

Overload List

Name | Description
SetCellContent(Int32, Int32, ReportItem) | (Inherited from TableCellContainer.)
SetCellContent(Int32, Int32, ReportItem, Int32, Int32) | (Inherited from TableCellContainer.)

See Also

TableBody Class
TableBody Members
Telerik.Reporting Namespace


TableBody Properties

[image] [image]

Telerik Reporting Q2 2012
TableBody Properties
TableBody Class See Also Send Feedback

The TableBody type exposes the following members.

Properties

Name | Description
Columns | Gets the collection of the columns for the Table's Body.
Item | (Inherited from TableCellContainer.)
Rows | Gets the collection of the rows for the Table's Body

See Also

TableBody Class
Telerik.Reporting Namespace


Columns Property

[image]

Telerik Reporting Q2 2012
TableBody..::.Columns Property
TableBody Class See Also Send Feedback
Gets the collection of the columns for the Table's Body.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBody..::.ColumnCollection Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As TableBody..::.ColumnCollection

Remarks

Use this collection to define the columns for the TableBody. If specified, the number of the columns should be equal to the number of the leaf groups in the Table.ColumnGroups hierarchy.

See Also

TableBody Class
Telerik.Reporting Namespace


Rows Property

[image]

Telerik Reporting Q2 2012
TableBody..::.Rows Property
TableBody Class See Also Send Feedback
Gets the collection of the rows for the Table's Body

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBody..::.RowCollection Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As TableBody..::.RowCollection

Remarks

Use this collection to define the rows for the TableBody. If specified, the number of the rows should be equal to the number of the leaf groups in the Table.RowGroups hierarchy.

See Also

TableBody Class
Telerik.Reporting Namespace


TableBody.ColumnCollection Class

[image]

Telerik Reporting Q2 2012
TableBody..::..ColumnCollection Class
TableBody Class Members See Also Send Feedback
Represents a collection of TableBodyColumn

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ColumnCollection : Collection<TableBodyColumn>
Visual Basic (Declaration)
Public Class ColumnCollection _
    Inherits Collection(Of TableBodyColumn)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' TableBodyColumn >)>)>
Telerik.Reporting..::.TableBody..::.ColumnCollection

See Also

TableBody..::.ColumnCollection Members
Telerik.Reporting Namespace


TableBody.ColumnCollection Members

[image] [image]

Telerik Reporting Q2 2012
TableBody..::..ColumnCollection Members
TableBody..::.ColumnCollection Class Constructors Methods See Also Send Feedback

Represents the Body of the Table item

The TableBody..::.ColumnCollection type exposes the following members.

Constructors

Name | Description
TableBody..::.ColumnCollection | Initializes a new instance of the TableBody..::.ColumnCollection class

Methods

Name | Description
AddRange |

See Also

TableBody..::.ColumnCollection Class
Telerik.Reporting Namespace


TableBody.ColumnCollection Constructor

[image]

Telerik Reporting Q2 2012
TableBody..::..ColumnCollection Constructor
TableBody..::.ColumnCollection Class See Also Send Feedback
Initializes a new instance of the TableBody..::.ColumnCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColumnCollection()
Visual Basic (Declaration)
Public Sub New

See Also

TableBody..::.ColumnCollection Class
Telerik.Reporting Namespace


TableBody.ColumnCollection Methods

[image] [image]

Telerik Reporting Q2 2012
TableBody..::..ColumnCollection Methods
TableBody..::.ColumnCollection Class See Also Send Feedback

The TableBody..::.ColumnCollection type exposes the following members.

Methods

Name | Description
AddRange |

See Also

TableBody..::.ColumnCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
TableBody..::..ColumnCollection..::.AddRange Method
TableBody..::.ColumnCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<TableBodyColumn> items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As IEnumerable(Of TableBodyColumn) _
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' TableBodyColumn >)>)>

See Also

TableBody..::.ColumnCollection Class
Telerik.Reporting Namespace


TableBody.RowCollection Class

[image]

Telerik Reporting Q2 2012
TableBody..::..RowCollection Class
TableBody Class Members See Also Send Feedback
Represents a collection of TableBodyRows

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class RowCollection : Collection<TableBodyRow>
Visual Basic (Declaration)
Public Class RowCollection _
    Inherits Collection(Of TableBodyRow)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' TableBodyRow >)>)>
Telerik.Reporting..::.TableBody..::.RowCollection

See Also

TableBody..::.RowCollection Members
Telerik.Reporting Namespace


TableBody.RowCollection Members

[image] [image]

Telerik Reporting Q2 2012
TableBody..::..RowCollection Members
TableBody..::.RowCollection Class Constructors Methods See Also Send Feedback

Represents the Body of the Table item

The TableBody..::.RowCollection type exposes the following members.

Constructors

Name | Description
TableBody..::.RowCollection | Initializes a new instance of the TableBody..::.RowCollection class

Methods

Name | Description
AddRange |

See Also

TableBody..::.RowCollection Class
Telerik.Reporting Namespace


TableBody.RowCollection Constructor

[image]

Telerik Reporting Q2 2012
TableBody..::..RowCollection Constructor
TableBody..::.RowCollection Class See Also Send Feedback
Initializes a new instance of the TableBody..::.RowCollection class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RowCollection()
Visual Basic (Declaration)
Public Sub New

See Also

TableBody..::.RowCollection Class
Telerik.Reporting Namespace


TableBody.RowCollection Methods

[image] [image]

Telerik Reporting Q2 2012
TableBody..::..RowCollection Methods
TableBody..::.RowCollection Class See Also Send Feedback

The TableBody..::.RowCollection type exposes the following members.

Methods

Name | Description
AddRange |

See Also

TableBody..::.RowCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
TableBody..::..RowCollection..::.AddRange Method
TableBody..::.RowCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<TableBodyRow> items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As IEnumerable(Of TableBodyRow) _
)

Parameters

items
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' TableBodyRow >)>)>

See Also

TableBody..::.RowCollection Class
Telerik.Reporting Namespace


TableBodyColumn Class

[image]

Telerik Reporting Q2 2012
TableBodyColumn Class
Members See Also Send Feedback
Represents a column in the Table's Body

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableBodyColumn
Visual Basic (Declaration)
Public Class TableBodyColumn

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableBodyColumn

See Also

TableBodyColumn Members
Telerik.Reporting Namespace


TableBodyColumn Members

[image] [image]

Telerik Reporting Q2 2012
TableBodyColumn Members
TableBodyColumn Class Constructors Properties See Also Send Feedback

The TableBodyColumn type exposes the following members.

Constructors

Name | Description
TableBodyColumn | Overloaded.

Properties

Name | Description
Width | The width of the TableBodyColumn

See Also

TableBodyColumn Class
Telerik.Reporting Namespace


TableBodyColumn Constructor

[image] [image]

Telerik Reporting Q2 2012
TableBodyColumn Constructor
TableBodyColumn Class See Also Send Feedback

Overload List

Name | Description
TableBodyColumn()()() | Initializes a new instance of the TableBodyColumn class
TableBodyColumn(Unit) | Initializes a new instance of the TableBodyColumn class

See Also

TableBodyColumn Class
TableBodyColumn Members
Telerik.Reporting Namespace


TableBodyColumn Constructor

[image]

Telerik Reporting Q2 2012
TableBodyColumn Constructor
TableBodyColumn Class See Also Send Feedback
Initializes a new instance of the TableBodyColumn class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBodyColumn()
Visual Basic (Declaration)
Public Sub New

See Also

TableBodyColumn Class
TableBodyColumn Overload
Telerik.Reporting Namespace


TableBodyColumn Constructor (Unit)

[image]

Telerik Reporting Q2 2012
TableBodyColumn Constructor (Unit)
TableBodyColumn Class See Also Send Feedback
Initializes a new instance of the TableBodyColumn class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBodyColumn(
    Unit width
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Unit _
)

Parameters

width
Type: Telerik.Reporting.Drawing..::.Unit

See Also

TableBodyColumn Class
TableBodyColumn Overload
Telerik.Reporting Namespace


TableBodyColumn Properties

[image] [image]

Telerik Reporting Q2 2012
TableBodyColumn Properties
TableBodyColumn Class See Also Send Feedback

The TableBodyColumn type exposes the following members.

Properties

Name | Description
Width | The width of the TableBodyColumn

See Also

TableBodyColumn Class
Telerik.Reporting Namespace


Width Property

[image]

Telerik Reporting Q2 2012
TableBodyColumn..::.Width Property
TableBodyColumn Class See Also Send Feedback
The width of the TableBodyColumn

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

See Also

TableBodyColumn Class
Telerik.Reporting Namespace


TableBodyRow Class

[image]

Telerik Reporting Q2 2012
TableBodyRow Class
Members See Also Send Feedback
Represents a row in the Table's Body

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableBodyRow
Visual Basic (Declaration)
Public Class TableBodyRow

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableBodyRow

See Also

TableBodyRow Members
Telerik.Reporting Namespace


TableBodyRow Members

[image] [image]

Telerik Reporting Q2 2012
TableBodyRow Members
TableBodyRow Class Constructors Properties See Also Send Feedback

The TableBodyRow type exposes the following members.

Constructors

Name | Description
TableBodyRow | Overloaded.

Properties

Name | Description
Height | The height of the TableBodyRow

See Also

TableBodyRow Class
Telerik.Reporting Namespace


TableBodyRow Constructor

[image] [image]

Telerik Reporting Q2 2012
TableBodyRow Constructor
TableBodyRow Class See Also Send Feedback

Overload List

Name | Description
TableBodyRow()()() | Initializes a new instance of the TableBodyRow class
TableBodyRow(Unit) | Initializes a new instance of the TableBodyRow class

See Also

TableBodyRow Class
TableBodyRow Members
Telerik.Reporting Namespace


TableBodyRow Constructor

[image]

Telerik Reporting Q2 2012
TableBodyRow Constructor
TableBodyRow Class See Also Send Feedback
Initializes a new instance of the TableBodyRow class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBodyRow()
Visual Basic (Declaration)
Public Sub New

See Also

TableBodyRow Class
TableBodyRow Overload
Telerik.Reporting Namespace


TableBodyRow Constructor (Unit)

[image]

Telerik Reporting Q2 2012
TableBodyRow Constructor (Unit)
TableBodyRow Class See Also Send Feedback
Initializes a new instance of the TableBodyRow class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableBodyRow(
    Unit height
)
Visual Basic (Declaration)
Public Sub New ( _
    height As Unit _
)

Parameters

height
Type: Telerik.Reporting.Drawing..::.Unit

See Also

TableBodyRow Class
TableBodyRow Overload
Telerik.Reporting Namespace


TableBodyRow Properties

[image] [image]

Telerik Reporting Q2 2012
TableBodyRow Properties
TableBodyRow Class See Also Send Feedback

The TableBodyRow type exposes the following members.

Properties

Name | Description
Height | The height of the TableBodyRow

See Also

TableBodyRow Class
Telerik.Reporting Namespace


Height Property

[image]

Telerik Reporting Q2 2012
TableBodyRow..::.Height Property
TableBodyRow Class See Also Send Feedback
The height of the TableBodyRow

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

See Also

TableBodyRow Class
Telerik.Reporting Namespace


TableCell Class

[image]

Telerik Reporting Q2 2012
TableCell Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableCell : IDisposable
Visual Basic (Declaration)
Public Class TableCell _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableCell

See Also

TableCell Members
Telerik.Reporting Namespace


TableCell Members

[image] [image]

Telerik Reporting Q2 2012
TableCell Members
TableCell Class Methods Properties See Also Send Feedback

The TableCell type exposes the following members.

Methods

Name | Description
Dispose | Releases all resources used by the TableCell
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
ColumnIndex |
ColumnSpan |
ReportItem |
RowIndex |
RowSpan |

See Also

TableCell Class
Telerik.Reporting Namespace


TableCell Methods

[image] [image]

Telerik Reporting Q2 2012
TableCell Methods
TableCell Class See Also Send Feedback

The TableCell type exposes the following members.

Methods

Name | Description
Dispose |
ToString | (Overrides Object..::.ToString()()().)

See Also

TableCell Class
Telerik.Reporting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
TableCell..::.Dispose Method
TableCell Class See Also Send Feedback
Releases all resources used by the TableCell

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

TableCell Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TableCell..::.ToString Method
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TableCell Class
Telerik.Reporting Namespace


TableCell Properties

[image] [image]

Telerik Reporting Q2 2012
TableCell Properties
TableCell Class See Also Send Feedback

The TableCell type exposes the following members.

Properties

Name | Description
ColumnIndex |
ColumnSpan |
ReportItem |
RowIndex |
RowSpan |

See Also

TableCell Class
Telerik.Reporting Namespace


ColumnIndex Property

[image]

Telerik Reporting Q2 2012
TableCell..::.ColumnIndex Property
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ColumnIndex { get; internal set; }
Visual Basic (Declaration)
Public Property ColumnIndex As Integer

See Also

TableCell Class
Telerik.Reporting Namespace


ColumnSpan Property

[image]

Telerik Reporting Q2 2012
TableCell..::.ColumnSpan Property
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ColumnSpan { get; internal set; }
Visual Basic (Declaration)
Public Property ColumnSpan As Integer

See Also

TableCell Class
Telerik.Reporting Namespace


ReportItem Property

[image]

Telerik Reporting Q2 2012
TableCell..::.ReportItem Property
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItem ReportItem { get; internal set; }
Visual Basic (Declaration)
Public Property ReportItem As ReportItem

See Also

TableCell Class
Telerik.Reporting Namespace


RowIndex Property

[image]

Telerik Reporting Q2 2012
TableCell..::.RowIndex Property
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int RowIndex { get; internal set; }
Visual Basic (Declaration)
Public Property RowIndex As Integer

See Also

TableCell Class
Telerik.Reporting Namespace


RowSpan Property

[image]

Telerik Reporting Q2 2012
TableCell..::.RowSpan Property
TableCell Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int RowSpan { get; internal set; }
Visual Basic (Declaration)
Public Property RowSpan As Integer

See Also

TableCell Class
Telerik.Reporting Namespace


TableCellContainer Class

[image]

Telerik Reporting Q2 2012
TableCellContainer Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableCellContainer : IDisposable,
    IEnumerable<TableCell>, IEnumerable
Visual Basic (Declaration)
Public Class TableCellContainer _
    Implements IDisposable, IEnumerable(Of TableCell),  _
    IEnumerable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableCellContainer
Telerik.Reporting..::.TableBody

See Also

TableCellContainer Members
Telerik.Reporting Namespace


TableCellContainer Members

[image] [image]

Telerik Reporting Q2 2012
TableCellContainer Members
TableCellContainer Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TableCellContainer type exposes the following members.

Methods

Name | Description
ClearCellContent |
Dispose | Releases all resources used by the TableCellContainer
GetEnumerator |
SetCellContent | Overloaded.

Properties

Name | Description
Item |

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

TableCellContainer Class
Telerik.Reporting Namespace


TableCellContainer Methods

[image] [image]

Telerik Reporting Q2 2012
TableCellContainer Methods
TableCellContainer Class See Also Send Feedback

The TableCellContainer type exposes the following members.

Methods

Name | Description
ClearCellContent |
Dispose |
GetEnumerator |
SetCellContent | Overloaded.

Explicit Interface Implementations

Name | Description
IEnumerable..::.GetEnumerator |

See Also

TableCellContainer Class
Telerik.Reporting Namespace


IEnumerable.GetEnumerator Method

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.IEnumerable..::.GetEnumerator Method
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

TableCellContainer Class
Telerik.Reporting Namespace


ClearCellContent Method

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.ClearCellContent Method
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearCellContent()
Visual Basic (Declaration)
Public Sub ClearCellContent

See Also

TableCellContainer Class
Telerik.Reporting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.Dispose Method
TableCellContainer Class See Also Send Feedback
Releases all resources used by the TableCellContainer

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

TableCellContainer Class
Telerik.Reporting Namespace


GetEnumerator Method

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.GetEnumerator Method
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IEnumerator<TableCell> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of TableCell)

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

TableCellContainer Class
Telerik.Reporting Namespace


SetCellContent Method

[image] [image]

Telerik Reporting Q2 2012
TableCellContainer..::.SetCellContent Method
TableCellContainer Class See Also Send Feedback

Overload List

Name | Description
SetCellContent(Int32, Int32, ReportItem) |
SetCellContent(Int32, Int32, ReportItem, Int32, Int32) |

See Also

TableCellContainer Class
TableCellContainer Members
Telerik.Reporting Namespace


SetCellContent Method (Int32, Int32, ReportItem)

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.SetCellContent Method (Int32, Int32, ReportItem)
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetCellContent(
    int rowIndex,
    int columnIndex,
    ReportItem item
)
Visual Basic (Declaration)
Public Sub SetCellContent ( _
    rowIndex As Integer, _
    columnIndex As Integer, _
    item As ReportItem _
)

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32
item
Type: Telerik.Reporting..::.ReportItem

See Also

TableCellContainer Class
SetCellContent Overload
Telerik.Reporting Namespace


SetCellContent Method (Int32, Int32, ReportItem, Int32, Int32)

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.SetCellContent Method (Int32, Int32, ReportItem, Int32, Int32)
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetCellContent(
    int rowIndex,
    int columnIndex,
    ReportItem item,
    int rowSpan,
    int columnSpan
)
Visual Basic (Declaration)
Public Sub SetCellContent ( _
    rowIndex As Integer, _
    columnIndex As Integer, _
    item As ReportItem, _
    rowSpan As Integer, _
    columnSpan As Integer _
)

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32
item
Type: Telerik.Reporting..::.ReportItem
rowSpan
Type: System..::.Int32
columnSpan
Type: System..::.Int32

See Also

TableCellContainer Class
SetCellContent Overload
Telerik.Reporting Namespace


TableCellContainer Properties

[image] [image]

Telerik Reporting Q2 2012
TableCellContainer Properties
TableCellContainer Class See Also Send Feedback

The TableCellContainer type exposes the following members.

Properties

Name | Description
Item |

See Also

TableCellContainer Class
Telerik.Reporting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
TableCellContainer..::.Item Property
TableCellContainer Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableCell this[
    int rowIndex,
    int columnIndex
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    rowIndex As Integer, _
    columnIndex As Integer _
) As TableCell

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32

See Also

TableCellContainer Class
Telerik.Reporting Namespace


TableGroup Class

[image]

Telerik Reporting Q2 2012
TableGroup Class
Members See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TableGroup : IToggleVisibilityTarget
Visual Basic (Declaration)
Public Class TableGroup _
    Implements IToggleVisibilityTarget

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.TableGroup

See Also

TableGroup Members
Telerik.Reporting Namespace


TableGroup Members

[image] [image]

Telerik Reporting Q2 2012
TableGroup Members
TableGroup Class Constructors Properties See Also Send Feedback

The TableGroup type exposes the following members.

Constructors

Name | Description
TableGroup | Initializes a new instance of the TableGroup class

Properties

Name | Description
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this group.
BookmarkId | Gets or sets a bookmark id for this group.
ChildGroups |
DocumentMapText | Gets or sets a text to be displayed for this group in the document map.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table
Grouping | Obsolete.
Groupings | Gets a GroupCollection that defines the groups for the Report
GroupKeepTogether | Indicates whether to keep all rows or columns that belong to the current group on one page.
Name | Gets or sets the name of the table group.
ReportItem |
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table
Visible | Gets or sets a value indicating whether the table group is displayed.

See Also

TableGroup Class
Telerik.Reporting Namespace


TableGroup Constructor

[image]

Telerik Reporting Q2 2012
TableGroup Constructor
TableGroup Class See Also Send Feedback
Initializes a new instance of the TableGroup class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableGroup()
Visual Basic (Declaration)
Public Sub New

See Also

TableGroup Class
Telerik.Reporting Namespace


TableGroup Properties

[image] [image]

Telerik Reporting Q2 2012
TableGroup Properties
TableGroup Class See Also Send Feedback

The TableGroup type exposes the following members.

Properties

Name | Description
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this group.
BookmarkId | Gets or sets a bookmark id for this group.
ChildGroups |
DocumentMapText | Gets or sets a text to be displayed for this group in the document map.
Filters | Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table
Grouping | Obsolete.
Groupings | Gets a GroupCollection that defines the groups for the Report
GroupKeepTogether | Indicates whether to keep all rows or columns that belong to the current group on one page.
Name | Gets or sets the name of the table group.
ReportItem |
Sorting | Obsolete.
Sortings | Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table
Visible | Gets or sets a value indicating whether the table group is displayed.

See Also

TableGroup Class
Telerik.Reporting Namespace


Bookmark Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Bookmark Property
TableGroup Class See Also Send Feedback
Gets or sets a bookmark label to be displayed for this group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")]
public string Bookmark { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use BookmarkId and DocumentMapText instead.")> _
Public Property Bookmark As String

Field Value

A string / expression value specifying the bookmark label.

See Also

TableGroup Class
Telerik.Reporting Namespace


BookmarkId Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.BookmarkId Property
TableGroup Class See Also Send Feedback
Gets or sets a bookmark id for this group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string BookmarkId { get; set; }
Visual Basic (Declaration)
Public Property BookmarkId As String

Field Value

A string / expression value specifying the bookmark id. When processed should evaluate to an unique value for each processing instance of the group.

See Also

TableGroup Class
Telerik.Reporting Namespace


ChildGroups Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.ChildGroups Property
TableGroup Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IList<TableGroup> ChildGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildGroups As IList(Of TableGroup)

See Also

TableGroup Class
Telerik.Reporting Namespace


DocumentMapText Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.DocumentMapText Property
TableGroup Class See Also Send Feedback
Gets or sets a text to be displayed for this group in the document map.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentMapText { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapText As String

Field Value

A string / expression value specifying the document map text.

Remarks

When defined the document map displays nodes that navigate to the instances of the group.

See Also

TableGroup Class
Telerik.Reporting Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Filters Property
TableGroup Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.FilterCollection] that defines the filter expression(s) for the Table

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

Field Value

A [!:Telerik.Reporting.Data.FilterCollection] that contains the Filter objects for the Table

Remarks

Filter expressions limit the data that is displayed to the user after the data is retrieved from the data source.

See Also

TableGroup Class
Telerik.Reporting Namespace


Grouping Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Grouping Property
TableGroup Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Groupings property instead.")]
public GroupingCollection Grouping { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Groupings property instead.")> _
Public ReadOnly Property Grouping As GroupingCollection

See Also

TableGroup Class
Telerik.Reporting Namespace


Groupings Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Groupings Property
TableGroup Class See Also Send Feedback
Gets a GroupCollection that defines the groups for the Report

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupingCollection Groupings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groupings As GroupingCollection

Field Value

A GroupCollection that contains the Group objects for the Report

Remarks

Grouping is used to gather all rows that match certain grouping criteria together. Grouping criteria is defined by adding one or more Grouping objects to a Group.

See Also

TableGroup Class
Telerik.Reporting Namespace


GroupKeepTogether Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.GroupKeepTogether Property
TableGroup Class See Also Send Feedback
Indicates whether to keep all rows or columns that belong to the current group on one page.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool GroupKeepTogether { get; set; }
Visual Basic (Declaration)
Public Property GroupKeepTogether As Boolean

Field Value

True to keep all rows or columns that belong to the current group on one page; otherwise False.

Remarks

When the GroupKeepTogether is set to True and there is not enough space on the current page, the entire group is moved the the top/left of the next page.

See Also

TableGroup Class
Telerik.Reporting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Name Property
TableGroup Class See Also Send Feedback
Gets or sets the name of the table group.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

The name of the table group.

Implements

IToggleVisibilityTarget..::.Name

Remarks

The Name property can be used at run time to evaluate the object by name rather than type and programmatic name.

See Also

TableGroup Class
Telerik.Reporting Namespace


ReportItem Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.ReportItem Property
TableGroup Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItem ReportItem { get; set; }
Visual Basic (Declaration)
Public Property ReportItem As ReportItem

See Also

TableGroup Class
Telerik.Reporting Namespace


Sorting Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Sorting Property
TableGroup Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use Sortings property instead.")]
public SortingCollection Sorting { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use Sortings property instead.")> _
Public ReadOnly Property Sorting As SortingCollection

See Also

TableGroup Class
Telerik.Reporting Namespace


Sortings Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Sortings Property
TableGroup Class See Also Send Feedback
Gets a [!:Telerik.Reporting.Data.SortingCollection] that defines the sort column(s), and their type and order for the Table

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SortingCollection Sortings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sortings As SortingCollection

Field Value

A [!:Telerik.Reporting.Data.SortingCollection] that contains the Sorting objects for the Table

Remarks

Sort expressions sort the data that is displayed to the user after the data is retrieved from the data source.

See Also

TableGroup Class
Telerik.Reporting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
TableGroup..::.Visible Property
TableGroup Class See Also Send Feedback
Gets or sets a value indicating whether the table group is displayed.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Field Value

true if the table group is displayed; otherwise, false. The default is true.

See Also

TableGroup Class
Telerik.Reporting Namespace


TextBox Class

[image]

Telerik Reporting Q2 2012
TextBox Class
Members See Also Send Feedback
Represents a text box report item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBox : TextItemBase
Visual Basic (Declaration)
Public Class TextBox _
    Inherits TextItemBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.TextItemBase
Telerik.Reporting..::.TextBox

See Also

TextBox Members
Telerik.Reporting Namespace


TextBox Members

[image] [image]

Telerik Reporting Q2 2012
TextBox Members
TextBox Class Constructors Methods Properties Events See Also Send Feedback

The TextBox type exposes the following members.

Constructors

Name | Description
TextBox | Initializes a new instance of the TextBox class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase.)
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the TextBox on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current text in the text box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

TextBox Class
Telerik.Reporting Namespace


TextBox Constructor

[image]

Telerik Reporting Q2 2012
TextBox Constructor
TextBox Class See Also Send Feedback
Initializes a new instance of the TextBox class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBox()
Visual Basic (Declaration)
Public Sub New

See Also

TextBox Class
Telerik.Reporting Namespace


TextBox Methods

[image] [image]

Telerik Reporting Q2 2012
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

TextBox Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBox..::.Dispose Method
TextBox Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

TextBox Class
TextBox Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
TextBox..::.ToString Method
TextBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

TextBox Class
TextBox Members
Telerik.Reporting Namespace


TextBox Properties

[image] [image]

Telerik Reporting Q2 2012
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees. (Inherited from TextItemBase.)
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically. (Inherited from TextItemBase.)
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically. (Inherited from TextItemBase.)
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item. (Inherited from TextItemBase.)
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
KeepTogether | Gets or sets a value indicating whether the rendering engine should try to keep the TextBox on one page if possible.
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item. (Inherited from TextItemBase.)
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary. (Inherited from TextItemBase.)
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Value | Gets or sets the current text in the text box.
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

TextBox Class
Telerik.Reporting Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
TextBox..::.KeepTogether Property
TextBox Class See Also Send Feedback
Gets or sets a value indicating whether the rendering engine should try to keep the TextBox on one page if possible.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

Field Value

A boolean value indicating whether the rendering engine should try to keep the TextBox on one page if possible.

See Also

TextBox Class
Telerik.Reporting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
TextBox..::.Value Property
TextBox Class See Also Send Feedback
Gets or sets the current text in the text box.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String

Field Value

A String that starts with "=" is interpreted as expression to calculate the value of the current TextBox; otherwise - literal string.

See Also

TextBox Class
Telerik.Reporting Namespace


TextBox Events

[image] [image]

Telerik Reporting Q2 2012
TextBox Events
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

TextBox Class
Telerik.Reporting Namespace


TextItemBase Class

[image]

Telerik Reporting Q2 2012
TextItemBase Class
Members See Also Send Feedback
Represents a Text Item - a base class for report items like TextBox and CheckBox.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class TextItemBase : ReportItem
Visual Basic (Declaration)
Public MustInherit Class TextItemBase _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting..::.ReportItemBase
Telerik.Reporting..::.ReportItem
Telerik.Reporting..::.TextItemBase
Telerik.Reporting..::.CheckBox
Telerik.Reporting..::.TextBox

See Also

TextItemBase Members
Telerik.Reporting Namespace


TextItemBase Members

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Members
TextItemBase Class Constructors Methods Properties Events See Also Send Feedback

The TextItemBase type exposes the following members.

Constructors

Name | Description
TextItemBase | Initializes a new instance of the TextItemBase class

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Format | Gets or sets the character(s) that specify how text is formatted.
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

TextItemBase Class
Telerik.Reporting Namespace


TextItemBase Constructor

[image]

Telerik Reporting Q2 2012
TextItemBase Constructor
TextItemBase Class See Also Send Feedback
Initializes a new instance of the TextItemBase class

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected TextItemBase()
Visual Basic (Declaration)
Protected Sub New

See Also

TextItemBase Class
Telerik.Reporting Namespace


TextItemBase Methods

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Methods
TextItemBase Class See Also Send Feedback

The TextItemBase type exposes the following members.

Methods

Name | Description
ClearGlobalDependencies | (Inherited from ReportItemBase.)
Contains | Retrieves a value indicating whether the specified report item is a child of the report item. (Inherited from ReportItemBase.)
Dispose | Overloaded.
OnItemAdded | Raises the ItemAdded()()() event. (Inherited from ReportItemBase.)
OnItemRemoved | Raises the ItemRemoved()()() event. (Inherited from ReportItemBase.)
OnItemValidate | (Inherited from ReportItemBase.)
ToString | Overloaded.

See Also

TextItemBase Class
Telerik.Reporting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextItemBase..::.Dispose Method
TextItemBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from ReportItemBase.)
Dispose(Boolean) | (Inherited from ReportItemBase.)

See Also

TextItemBase Class
TextItemBase Members
Telerik.Reporting Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
TextItemBase..::.ToString Method
TextItemBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a String that represents the current ReportItemBase. (Inherited from ReportItemBase.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

TextItemBase Class
TextItemBase Members
Telerik.Reporting Namespace


TextItemBase Properties

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Properties
TextItemBase Class See Also Send Feedback

The TextItemBase type exposes the following members.

Properties

Name | Description
Action | Gets or sets an interactive action associated with this report item. (Inherited from ReportItemBase.)
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | Gets or sets the edges of the container to which a report is bound and determines how a report items is resized with its parent. (Inherited from ReportItem.)
Angle | Gets or sets the angle of rotation of the text in degrees.
Bindings | Gets the collection of binding rules contained within the report item. (Inherited from ReportItemBase.)
Bookmark | Obsolete. Gets or sets a bookmark label to be displayed for this report item. (Inherited from ReportItemBase.)
BookmarkId | Gets or sets a bookmark id for this item. (Inherited from ReportItemBase.)
Bottom | Gets the distance, in Units, between the bottom edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Bounds | Gets or sets the size and location of the report item including its nonclient elements, in Units, relative to the parent report item. (Inherited from ReportItem.)
CanGrow | Gets or sets a value indicating whether the Text Item can grow vertically.
CanShrink | Gets or sets a value indicating whether the Text Item can shrink vertically.
ConditionalFormatting | Gets the collection of the conditional formatting rules, associated with this item. (Inherited from ReportItemBase.)
Container | (Inherited from ReportItemBase.)
Culture | Gets or sets the culture information associated with the Text Item.
DefaultSize | Gets the default size of the report item. (Inherited from ReportItem.)
DesignMode | (Inherited from ReportItemBase.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | Gets or sets which report item borders are docked to its parent and determines how a report item is resized with its parent. (Inherited from ReportItem.)
DocumentMapText | Gets or sets a text to be displayed for this item in the document map. (Inherited from ReportItemBase.)
Format | Gets or sets the character(s) that specify how text is formatted.
Height | Gets or sets the height of the report item. (Inherited from ReportItem.)
Items | Gets the collection of report items contained within the report item. (Inherited from ReportItemBase.)
Left | Gets or sets the distance, in Units, between the left edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Location | Gets or sets the coordinates of the upper-left corner of the report item relative to the upper-left corner of its container. (Inherited from ReportItem.)
Multiline | Gets or sets a value indicating whether this is a multiline Text Item.
Name | Gets or sets the name of the report item. (Inherited from ReportItemBase.)
Parent | Gets or sets the parent container of the report item. (Inherited from ReportItemBase.)
Report | Gets the report this item belongs to. (Inherited from ReportItemBase.)
Right | Gets the distance, in Units, between the right edge of the report item and the left edge of its container's client area. (Inherited from ReportItem.)
Site | (Inherited from ReportItemBase.)
Size | Gets or sets the height and width of the report item. (Inherited from ReportItem.)
Style | Gets a Style object specifying the appearance of the report item. (Inherited from ReportItemBase.)
StyleName | Gets or sets the name of the report item's global style. (Inherited from ReportItemBase.)
TextWrap | Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.
Top | Gets or sets the distance, in Units, between the top edge of the report item and the top edge of its container's client area. (Inherited from ReportItem.)
Visible | Gets or sets a value indicating whether the report item is displayed. (Inherited from ReportItemBase.)
Width | Gets or sets the width of the report item. (Inherited from ReportItem.)

See Also

TextItemBase Class
Telerik.Reporting Namespace


Angle Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.Angle Property
TextItemBase Class See Also Send Feedback
Gets or sets the angle of rotation of the text in degrees.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double

Field Value

A double value indicating the angle of rotation in degrees.

See Also

TextItemBase Class
Telerik.Reporting Namespace


CanGrow Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.CanGrow Property
TextItemBase Class See Also Send Feedback
Gets or sets a value indicating whether the Text Item can grow vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CanGrow { get; set; }
Visual Basic (Declaration)
Public Property CanGrow As Boolean

Field Value

true if the Text Item can grow vertically; otherwise false.

See Also

TextItemBase Class
Telerik.Reporting Namespace


CanShrink Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.CanShrink Property
TextItemBase Class See Also Send Feedback
Gets or sets a value indicating whether the Text Item can shrink vertically.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CanShrink { get; set; }
Visual Basic (Declaration)
Public Property CanShrink As Boolean

Field Value

true if the Text Item can shrink vertically; otherwise false.

See Also

TextItemBase Class
Telerik.Reporting Namespace


Culture Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.Culture Property
TextItemBase Class See Also Send Feedback
Gets or sets the culture information associated with the Text Item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As CultureInfo

Field Value

A CultureInfo representing the culture supported by the TextItemBase.

See Also

TextItemBase Class
Telerik.Reporting Namespace


Format Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.Format Property
TextItemBase Class See Also Send Feedback
Gets or sets the character(s) that specify how text is formatted.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String

Field Value

The character or characters that specify how text is formatted.

See Also

TextItemBase Class
Telerik.Reporting Namespace


Multiline Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.Multiline Property
TextItemBase Class See Also Send Feedback
Gets or sets a value indicating whether this is a multiline Text Item.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic (Declaration)
Public Property Multiline As Boolean

Field Value

true if the Text Item supports multiple lines; otherwise false.

See Also

TextItemBase Class
Telerik.Reporting Namespace


TextWrap Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.TextWrap Property
TextItemBase Class See Also Send Feedback
Gets or sets a value indicating whether a Text Item automatically wraps words to the beginning of the next line when necessary.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool TextWrap { get; set; }
Visual Basic (Declaration)
Public Property TextWrap As Boolean

Field Value

true if the Text Item wraps words; otherwise false.

See Also

TextItemBase Class
Telerik.Reporting Namespace


TextItemBase Events

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Events
TextItemBase Class See Also Send Feedback

The TextItemBase type exposes the following members.

Events

Name | Description
Disposed | Occurs when the report item is disposed. (Inherited from ReportItemBase.)
ItemDataBinding | Occurs when the report item binds to a data source. (Inherited from ReportItemBase.)
ItemDataBound | Occurs after the report item binds to a data source. (Inherited from ReportItemBase.)

See Also

TextItemBase Class
Telerik.Reporting Namespace


ToggleVisibilityAction Class

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Class
Members See Also Send Feedback
Represents an interactive action that toggles the visibility of one or more items / groups.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ToggleVisibilityAction : IAction,
    IEquatable<ToggleVisibilityAction>
Visual Basic (Declaration)
Public Class ToggleVisibilityAction _
    Implements IAction, IEquatable(Of ToggleVisibilityAction)

Remarks

Use this action to specify an interactive action on a report item that toggles the visibility of one or more items / groups (drilldown).

When this action is set on an item, the item is rendered with an expand / collapse mark in all report viewers. Clicking on that mark triggers the action.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ToggleVisibilityAction

See Also

ToggleVisibilityAction Members
Telerik.Reporting Namespace


ToggleVisibilityAction Members

[image] [image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Members
ToggleVisibilityAction Class Constructors Methods Properties See Also Send Feedback

The ToggleVisibilityAction type exposes the following members.

Constructors

Name | Description
ToggleVisibilityAction | Overloaded.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

Properties

Name | Description
DisplayExpandedMark | Determines if the item exposing the action will be rendered initially with expanded or with collapsed mark.
Targets | Gets the list of toggle targets which visibility will be toggled when the action is triggered.

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


ToggleVisibilityAction Constructor

[image] [image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Constructor
ToggleVisibilityAction Class See Also Send Feedback

Overload List

Name | Description
ToggleVisibilityAction()()() | Creates a new instance of the ToggleVisibilityAction class.
ToggleVisibilityAction(IToggleVisibilityTarget, Boolean) | Creates a new instance of the ToggleVisibilityAction class with the specified toggle visibility target and initial toggle mark state.
ToggleVisibilityAction(array<IToggleVisibilityTarget>[]()[], Boolean) | Creates a new instance of the ToggleVisibilityAction class with specified toggle visibility targets and initial toggle mark state.

See Also

ToggleVisibilityAction Class
ToggleVisibilityAction Members
Telerik.Reporting Namespace


ToggleVisibilityAction Constructor

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Constructor
ToggleVisibilityAction Class See Also Send Feedback
Creates a new instance of the ToggleVisibilityAction class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ToggleVisibilityAction()
Visual Basic (Declaration)
Public Sub New

See Also

ToggleVisibilityAction Class
ToggleVisibilityAction Overload
Telerik.Reporting Namespace


ToggleVisibilityAction Constructor (IToggleVisibilityTarget, Boolean)

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Constructor (IToggleVisibilityTarget, Boolean)
ToggleVisibilityAction Class See Also Send Feedback
Creates a new instance of the ToggleVisibilityAction class with the specified toggle visibility target and initial toggle mark state.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ToggleVisibilityAction(
    IToggleVisibilityTarget target,
    bool displayExpandedMark
)
Visual Basic (Declaration)
Public Sub New ( _
    target As IToggleVisibilityTarget, _
    displayExpandedMark As Boolean _
)

Parameters

target
Type: Telerik.Reporting..::.IToggleVisibilityTarget
The Name / Name / Name of the toggle visibility target.
displayExpandedMark
Type: System..::.Boolean
The initial toggle visibility mark of the item.

See Also

ToggleVisibilityAction Class
ToggleVisibilityAction Overload
Telerik.Reporting Namespace


ToggleVisibilityAction Constructor (IToggleVisibilityTarget[], Boolean)

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Constructor (array<IToggleVisibilityTarget>[]()[][], Boolean)
ToggleVisibilityAction Class See Also Send Feedback
Creates a new instance of the ToggleVisibilityAction class with specified toggle visibility targets and initial toggle mark state.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ToggleVisibilityAction(
    IToggleVisibilityTarget[] targets,
    bool displayExpandedMark
)
Visual Basic (Declaration)
Public Sub New ( _
    targets As IToggleVisibilityTarget(), _
    displayExpandedMark As Boolean _
)

Parameters

targets
Type: array< Telerik.Reporting..::.IToggleVisibilityTarget >[]()[][]
An enumerable of Name / Name / Name of the toggle visibility targets.
displayExpandedMark
Type: System..::.Boolean
The initial toggle visibility mark of the item.

See Also

ToggleVisibilityAction Class
ToggleVisibilityAction Overload
Telerik.Reporting Namespace


ToggleVisibilityAction Methods

[image] [image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Methods
ToggleVisibilityAction Class See Also Send Feedback

The ToggleVisibilityAction type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.Equals Method
ToggleVisibilityAction Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ToggleVisibilityAction) |

See Also

ToggleVisibilityAction Class
ToggleVisibilityAction Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.Equals Method (Object)
ToggleVisibilityAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

ToggleVisibilityAction Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (ToggleVisibilityAction)

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.Equals Method (ToggleVisibilityAction)
ToggleVisibilityAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    ToggleVisibilityAction other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As ToggleVisibilityAction _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.ToggleVisibilityAction

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

ToggleVisibilityAction Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.GetHashCode Method
ToggleVisibilityAction Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


ToggleVisibilityAction Properties

[image] [image]

Telerik Reporting Q2 2012
ToggleVisibilityAction Properties
ToggleVisibilityAction Class See Also Send Feedback

The ToggleVisibilityAction type exposes the following members.

Properties

Name | Description
DisplayExpandedMark | Determines if the item exposing the action will be rendered initially with expanded or with collapsed mark.
Targets | Gets the list of toggle targets which visibility will be toggled when the action is triggered.

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


DisplayExpandedMark Property

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.DisplayExpandedMark Property
ToggleVisibilityAction Class See Also Send Feedback
Determines if the item exposing the action will be rendered initially with expanded or with collapsed mark.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool DisplayExpandedMark { get; set; }
Visual Basic (Declaration)
Public Property DisplayExpandedMark As Boolean

Remarks

A true value will determine an expanded mark to be rendered (minus sign). A false value will determine an collapsed mark to be rendered (plus sign).

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


Targets Property

[image]

Telerik Reporting Q2 2012
ToggleVisibilityAction..::.Targets Property
ToggleVisibilityAction Class See Also Send Feedback
Gets the list of toggle targets which visibility will be toggled when the action is triggered.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ToggleVisivilityTargetCollection Targets { get; private set; }
Visual Basic (Declaration)
Public Property Targets As ToggleVisivilityTargetCollection

Remarks

Use this property to add / remove toggle targets of the action. To add an item / report group / table group as toggle target you need to add / remove the value of the Name / Name / Name of the target respectively. The used names must be unique in the report scope.

The items in this list do not accept expressions.

See Also

ToggleVisibilityAction Class
Telerik.Reporting Namespace


ToggleVisivilityTargetCollection Class

[image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection Class
Members See Also Send Feedback
Represents a collection of IToggleVisibilityTarget objects.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ToggleVisivilityTargetCollection : Collection<IToggleVisibilityTarget>,
    IEquatable<ToggleVisivilityTargetCollection>
Visual Basic (Declaration)
Public Class ToggleVisivilityTargetCollection _
    Inherits Collection(Of IToggleVisibilityTarget) _
    Implements IEquatable(Of ToggleVisivilityTargetCollection)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' IToggleVisibilityTarget >)>)>
Telerik.Reporting..::.ToggleVisivilityTargetCollection

See Also

ToggleVisivilityTargetCollection Members
Telerik.Reporting Namespace


ToggleVisivilityTargetCollection Members

[image] [image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection Members
ToggleVisivilityTargetCollection Class Methods See Also Send Feedback

The ToggleVisivilityTargetCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds multiple IToggleVisibilityTarget objects to the collection.
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

See Also

ToggleVisivilityTargetCollection Class
Telerik.Reporting Namespace


ToggleVisivilityTargetCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection Methods
ToggleVisivilityTargetCollection Class See Also Send Feedback

The ToggleVisivilityTargetCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds multiple IToggleVisibilityTarget objects to the collection.
Equals | Overloaded.
GetHashCode | (Overrides Object..::.GetHashCode()()().)

See Also

ToggleVisivilityTargetCollection Class
Telerik.Reporting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection..::.AddRange Method
ToggleVisivilityTargetCollection Class See Also Send Feedback
Adds multiple IToggleVisibilityTarget objects to the collection.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IToggleVisibilityTarget[] targets
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    targets As IToggleVisibilityTarget() _
)

Parameters

targets
Type: array< Telerik.Reporting..::.IToggleVisibilityTarget >[]()[][]
An array of IToggleVisibilityTarget objects to add to the list.

See Also

ToggleVisivilityTargetCollection Class
Telerik.Reporting Namespace


Equals Method

[image] [image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection..::.Equals Method
ToggleVisivilityTargetCollection Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | (Overrides Object..::.Equals(Object).)
Equals(ToggleVisivilityTargetCollection) |

See Also

ToggleVisivilityTargetCollection Class
ToggleVisivilityTargetCollection Members
Telerik.Reporting Namespace


Equals Method (Object)

[image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection..::.Equals Method (Object)
ToggleVisivilityTargetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

ToggleVisivilityTargetCollection Class
Equals Overload
Telerik.Reporting Namespace


Equals Method (ToggleVisivilityTargetCollection)

[image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection..::.Equals Method (ToggleVisivilityTargetCollection)
ToggleVisivilityTargetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Equals(
    ToggleVisivilityTargetCollection other
)
Visual Basic (Declaration)
Public Function Equals ( _
    other As ToggleVisivilityTargetCollection _
) As Boolean

Parameters

other
Type: Telerik.Reporting..::.ToggleVisivilityTargetCollection

Implements

IEquatable<(Of <(T>)>)..::.Equals(T)

See Also

ToggleVisivilityTargetCollection Class
Equals Overload
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ToggleVisivilityTargetCollection..::.GetHashCode Method
ToggleVisivilityTargetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

ToggleVisivilityTargetCollection Class
Telerik.Reporting Namespace


TypeReportSource Class

[image]

Telerik Reporting Q2 2012
TypeReportSource Class
Members Example See Also Send Feedback
Represents a report source that allows a report document to be instantiated from an AssemblyQualifiedName.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TypeReportSource : ReportSource
Visual Basic (Declaration)
Public Class TypeReportSource _
    Inherits ReportSource

Examples

The following example shows how to create a TypeReportSource:
CopyC#
Telerik.Reporting.TypeReportSource typeReportSource =
    new Telerik.Reporting.TypeReportSource();

// Specifying the assembly qualified name of the Report class for the TypeName of the report source
typeReportSource.TypeName = "Telerik.Reporting.Examples.CSharp.Invoice, CSharp.ReportLibrary";

// Adding the initial parameter values
typeReportSource.Parameters.Add(new Telerik.Reporting.Parameter("OrderNumber", "SO43659"));
CopyVB.NET
Dim typeReportSource As New Telerik.Reporting.TypeReportSource()

' Specifying the assembly qualified name of the Report class for the TypeName of the report source
typeReportSource.TypeName = "Telerik.Reporting.Examples.VB.Invoice, VB.ReportLibrary"

' Adding the initial parameter values
typeReportSource.Parameters.Add(New Telerik.Reporting.Parameter("OrderNumber", "SO43659"))

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.TypeReportSource

See Also

TypeReportSource Members
Telerik.Reporting Namespace


TypeReportSource Members

[image] [image]

Telerik Reporting Q2 2012
TypeReportSource Members
TypeReportSource Class Constructors Methods Properties See Also Send Feedback

The TypeReportSource type exposes the following members.

Constructors

Name | Description
TypeReportSource | Initializes a new instance of the TypeReportSource class.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
TypeName | Gets or sets the assembly qualified type name of the report document.

See Also

TypeReportSource Class
Telerik.Reporting Namespace


TypeReportSource Constructor

[image]

Telerik Reporting Q2 2012
TypeReportSource Constructor
TypeReportSource Class See Also Send Feedback
Initializes a new instance of the TypeReportSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TypeReportSource()
Visual Basic (Declaration)
Public Sub New

See Also

TypeReportSource Class
Telerik.Reporting Namespace


TypeReportSource Methods

[image] [image]

Telerik Reporting Q2 2012
TypeReportSource Methods
TypeReportSource Class See Also Send Feedback

The TypeReportSource type exposes the following members.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

See Also

TypeReportSource Class
Telerik.Reporting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
TypeReportSource..::.Equals Method
TypeReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

TypeReportSource Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
TypeReportSource..::.GetHashCode Method
TypeReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

TypeReportSource Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TypeReportSource..::.ToString Method
TypeReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TypeReportSource Class
Telerik.Reporting Namespace


TypeReportSource Properties

[image] [image]

Telerik Reporting Q2 2012
TypeReportSource Properties
TypeReportSource Class See Also Send Feedback

The TypeReportSource type exposes the following members.

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
TypeName | Gets or sets the assembly qualified type name of the report document.

See Also

TypeReportSource Class
Telerik.Reporting Namespace


TypeName Property

[image]

Telerik Reporting Q2 2012
TypeReportSource..::.TypeName Property
TypeReportSource Class See Also Send Feedback
Gets or sets the assembly qualified type name of the report document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string TypeName { get; set; }
Visual Basic (Declaration)
Public Property TypeName As String

Remarks

Use this property to specify the type name of the report document. Must be the assembly qualified name of the Type of the report.

The target type should implement the IReportDocument interface and should have a default (parameterless) constructor. The default constructor is used from the reporting engine to create the report instance.

This property can accept an expression when the report source is used in a SubReport item or a NavigateToReportAction action.

See Also

TypeReportSource Class
Telerik.Reporting Namespace


UriReportSource Class

[image]

Telerik Reporting Q2 2012
UriReportSource Class
Members Example See Also Send Feedback
Represents a report source that loads a report document from a URI.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class UriReportSource : ReportSource
Visual Basic (Declaration)
Public Class UriReportSource _
    Inherits ReportSource

Examples

The following example demonstrates how to create a UriReportSource:
CopyC#
Telerik.Reporting.UriReportSource uriReportSource =
    new Telerik.Reporting.UriReportSource();

// Specifying an URL or a file path
uriReportSource.Uri = "SampleReport.trdx";

// Adding the initial parameter values
uriReportSource.Parameters.Add(new Telerik.Reporting.Parameter("OrderNumber", "SO43659"));
CopyVB.NET
Dim uriReportSource As New Telerik.Reporting.UriReportSource()

' Specifying an URL or a file path
uriReportSource.Uri = "SampleReport.trdx"

' Adding the initial parameter values
uriReportSource.Parameters.Add(New Telerik.Reporting.Parameter("OrderNumber", "SO43659"))

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource

See Also

UriReportSource Members
Telerik.Reporting Namespace


UriReportSource Members

[image] [image]

Telerik Reporting Q2 2012
UriReportSource Members
UriReportSource Class Constructors Methods Properties See Also Send Feedback

The UriReportSource type exposes the following members.

Constructors

Name | Description
UriReportSource | Initializes a new instance of the UriReportSource class.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
Uri | Specifies the URI to load the report document from.

See Also

UriReportSource Class
Telerik.Reporting Namespace


UriReportSource Constructor

[image]

Telerik Reporting Q2 2012
UriReportSource Constructor
UriReportSource Class See Also Send Feedback
Initializes a new instance of the UriReportSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public UriReportSource()
Visual Basic (Declaration)
Public Sub New

See Also

UriReportSource Class
Telerik.Reporting Namespace


UriReportSource Methods

[image] [image]

Telerik Reporting Q2 2012
UriReportSource Methods
UriReportSource Class See Also Send Feedback

The UriReportSource type exposes the following members.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

See Also

UriReportSource Class
Telerik.Reporting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
UriReportSource..::.Equals Method
UriReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

UriReportSource Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
UriReportSource..::.GetHashCode Method
UriReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

UriReportSource Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
UriReportSource..::.ToString Method
UriReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

UriReportSource Class
Telerik.Reporting Namespace


UriReportSource Properties

[image] [image]

Telerik Reporting Q2 2012
UriReportSource Properties
UriReportSource Class See Also Send Feedback

The UriReportSource type exposes the following members.

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
Uri | Specifies the URI to load the report document from.

See Also

UriReportSource Class
Telerik.Reporting Namespace


Uri Property

[image]

Telerik Reporting Q2 2012
UriReportSource..::.Uri Property
UriReportSource Class See Also Send Feedback
Specifies the URI to load the report document from.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Uri { get; set; }
Visual Basic (Declaration)
Public Property Uri As String

Remarks

A URI.

This property can accept an expression when the report source is used in a SubReport item or a NavigateToReportAction action.

See Also

UriReportSource Class
Telerik.Reporting Namespace


UrlTarget Enumeration

[image]

Telerik Reporting Q2 2012
UrlTarget Enumeration
See Also Send Feedback
Represents NavigateToUrlAction target types.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum UrlTarget
Visual Basic (Declaration)
Public Enumeration UrlTarget

Members

Member name | Description
NewWindow | Open in new window
SameWindow | Open in the same window

See Also

Telerik.Reporting Namespace


XmlReportSource Class

[image]

Telerik Reporting Q2 2012
XmlReportSource Class
Members Example See Also Send Feedback
Represents a report source that contains the XML markup of a report document.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class XmlReportSource : ReportSource
Visual Basic (Declaration)
Public Class XmlReportSource _
    Inherits ReportSource

Examples

The following example shows how to create a XmlReportSource:
CopyC#
Telerik.Reporting.XmlReportSource xmlReportSource =
    new Telerik.Reporting.XmlReportSource();

// Specifying the XML markup of the report
xmlReportSource.Xml = @"<?xml version='1.0' encoding='utf-8'?>
                        <Report Width='3in' Name='userReport1' xmlns='http://schemas.telerik.com/reporting/2012/2'>
                          <Items>
                            <DetailSection Height='1in' Name='detailSection1'>
                              <Items>
                                <TextBox Value='=Parameters.OrderNumber.Value' Size='2in, 0.4in' Location='0.5in, 0.3in' Name='textBox1' />
                              </Items>
                            </DetailSection>
                          </Items>
                          <PageSettings>
                            <PageSettings PaperKind='Letter' Landscape='False'>
                              <Margins>
                                <MarginsU Left='1in' Right='1in' Top='1in' Bottom='1in' />
                              </Margins>
                            </PageSettings>
                          </PageSettings>
                          <ReportParameters>
                            <ReportParameter Name='OrderNumber'>
                              <AvailableValues />
                            </ReportParameter>
                          </ReportParameters>
                        </Report>";

// Adding the initial parameter values
xmlReportSource.Parameters.Add(new Telerik.Reporting.Parameter("OrderNumber", "SO43659"));
CopyVB.NET
Dim xmlReportSource As New Telerik.Reporting.XmlReportSource()

' Specifying the XML markup of the report
xmlReportSource.Xml = "<?xml version='1.0' encoding='utf-8'?>" & _
                            "<Report Width='3in' Name='userReport1' xmlns='http://schemas.telerik.com/reporting/2012/2'>" & _
                              "<Items>" & _
                                "<DetailSection Height='1in' Name='detailSection1'>" & _
                                  "<Items>" & _
                                    "<TextBox Value='=Parameters.OrderNumber.Value' Size='2in, 0.4in' Location='0.5in, 0.3in' Name='textBox1' />" & _
                                  "</Items>" & _
                                "</DetailSection>" & _
                              "</Items>" & _
                              "<PageSettings>" & _
                                "<PageSettings PaperKind='Letter' Landscape='False'>" & _
                                  "<Margins>" & _
                                    "<MarginsU Left='1in' Right='1in' Top='1in' Bottom='1in' />" & _
                                  "</Margins>" & _
                                "</PageSettings>" & _
                              "</PageSettings>" & _
                              "<ReportParameters>" & _
                                "<ReportParameter Name='OrderNumber'>" & _
                                  "<AvailableValues />" & _
                                "</ReportParameter>" & _
                              "</ReportParameters>" & _
                            "</Report>"

' Adding the initial parameter values
xmlReportSource.Parameters.Add(New Telerik.Reporting.Parameter("OrderNumber", "SO43659"))

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.XmlReportSource

See Also

XmlReportSource Members
Telerik.Reporting Namespace


XmlReportSource Members

[image] [image]

Telerik Reporting Q2 2012
XmlReportSource Members
XmlReportSource Class Constructors Methods Properties See Also Send Feedback

The XmlReportSource type exposes the following members.

Constructors

Name | Description
XmlReportSource | Creates a new instance of the XmlReportSource class.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
Xml | Gets or sets the XML markup of a IReportDocument.

See Also

XmlReportSource Class
Telerik.Reporting Namespace


XmlReportSource Constructor

[image]

Telerik Reporting Q2 2012
XmlReportSource Constructor
XmlReportSource Class See Also Send Feedback
Creates a new instance of the XmlReportSource class.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public XmlReportSource()
Visual Basic (Declaration)
Public Sub New

See Also

XmlReportSource Class
Telerik.Reporting Namespace


XmlReportSource Methods

[image] [image]

Telerik Reporting Q2 2012
XmlReportSource Methods
XmlReportSource Class See Also Send Feedback

The XmlReportSource type exposes the following members.

Methods

Name | Description
Equals | (Overrides ReportSource..::.Equals(Object).)
GetHashCode | (Overrides ReportSource..::.GetHashCode()()().)
ToString | (Overrides ReportSource..::.ToString()()().)

See Also

XmlReportSource Class
Telerik.Reporting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
XmlReportSource..::.Equals Method
XmlReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

XmlReportSource Class
Telerik.Reporting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
XmlReportSource..::.GetHashCode Method
XmlReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

XmlReportSource Class
Telerik.Reporting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
XmlReportSource..::.ToString Method
XmlReportSource Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

XmlReportSource Class
Telerik.Reporting Namespace


XmlReportSource Properties

[image] [image]

Telerik Reporting Q2 2012
XmlReportSource Properties
XmlReportSource Class See Also Send Feedback

The XmlReportSource type exposes the following members.

Properties

Name | Description
Parameters | Determines the parameter values that are passed to the IReportDocument object when its instance is initialized. (Inherited from ReportSource.)
Xml | Gets or sets the XML markup of a IReportDocument.

See Also

XmlReportSource Class
Telerik.Reporting Namespace


Xml Property

[image]

Telerik Reporting Q2 2012
XmlReportSource..::.Xml Property
XmlReportSource Class See Also Send Feedback
Gets or sets the XML markup of a IReportDocument.

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Xml { get; set; }
Visual Basic (Declaration)
Public Property Xml As String

Remarks

This property can accept an expression when the report source is used in a SubReport item or a [!:NavigateToReport] action.

See Also

XmlReportSource Class
Telerik.Reporting Namespace


Telerik.Reporting.Charting Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Charting Namespace
Send Feedback

Classes

Class Description
ActiveRegion
Represents the active region of the chart element/item.
AxisLabel
X Axis label
AxisLabelHidden
Axis label base
AxisSegment
Axis segment in case of ScaleBreaks enabled
AxisSegmentCollection
Segments collection
AxisYLabel
Y axis label
BindableLegendItem
Class for bindable legend items
Chart
This is an class which provides charting functionality for Telerik products.
ChartAxis
Base chart axis class
ChartAxisItem
Represents an axis item.
ChartAxisItemsCollection
A collection to store axis items.
ChartBaseLabel
Base class for all labels
ChartClickEventArgs
Event arguments when a chart element is clicked.
ChartDataTable
DataTable. Shows the series data in a tabular format.
ChartingStateManagedCollection<(Of <(T>)>)
Base class for all collections support view state tracking
ChartItemDataBoundEventArgs
Class containing event data for an ItemDataBound event
ChartLabel
Base class for labels with style
ChartLabelsCollection
Collection of labels
ChartLegend
Chart legend. Shows the series names or series labels listing. Can contains custom items.
ChartMarkedZone
Class describe a Marked zone functionality
ChartMarkedZonesCollection
Marked zones collection
ChartMarker
Base class for a different markers representation
ChartPlotArea
Plot area - series rendering canvas.
ChartSeries
Series
ChartSeriesCollection
Series collection
ChartSeriesItem
Represents the base element of RadChart's series.
ChartSeriesItemsCollection
Series items collection
ChartTitle
Chart Title
ChartXAxis
Represents the X Axis.
ChartYAxis
Represents a chart Y Axis.
ChartZoomEventArgs
Provides data for RadChart.Zoom event.
ColorBlend
Defines arrays of elements and positions used for interpolating GradientElement blending in a multicolor gradient.
ComplexDataSetClass
Sample class returns DataSet with several columns which could be used as Y values source. Used for a data binding demonstration only
CustomFigure
User-defined figure
CustomFiguresCollection
Custom figures collection
CustomPalettesCollection
User-defined palettes collection
DataManager
Acquires and manipulates data from databases or other sources. Populates the SeriesCollection of the chart control.
DataSetClass
Sample class returns DataSet for an ObjectDataSource data binding demo
DemoData
Simple data sources examples class. Used for a data binding demonstration only
DoubleCollection
Collection base object example. Used for a data binding demostration only
DummyWebControl
EmptySeriesMessage
Empty series message

Remarks

Visible if no or empty series present
ExtendedLabel
Base class for extended labels
GradientElement
Gradient element
LabelItem
Base class for labels in label collection
LayoutElement
Base class for all objects being calculated
MarkedZoneLabel
MarkedZone label class
Palette
Series color palette. Used for an automatic series items colors assignment
PaletteItem
Palette item
PaletteItemsCollection
Palette items collection
Product
Sample object. Used for a data binding demonstration only
ProductsBL
Sample business logic object. Used for a data binding demonstration only
ProductsList
IBindingList example. Used for a data binding demonstration only
RegionClickEventArgs
Event arguments when a chart element is clicked.
RenderedObject
Base class for all objects being rendered
ScaleBreak
Y Axis scale break
SeriesItemLabel
Series item label
StateManagedObject
Base class implements IStateManager
TextBlock
Label text properties
TextBlockAxisItem
Axis item text container properties
TextBlockEmptySeriesMessage
Empty Series message text container properties
TextBlockHidden
Chart title text container properties
TextBlockLabelItem
Legend item's text block
TextBlockLegend
Chart title text container properties
TextBlockMarkedZone
MarkedZone label's text container properties
TextBlockSeriesItem
Series label text container properties
TextBlockTitle
Chart title text container properties
TextBlockXAxisLabel
Chart X Axis text container properties
TextBlockYAxisLabel
Chart Y Axis text container properties

Structures

Structure | Description
PalettesCollection | Default palettes

Interfaces

Interface | Description
IChartingStateManagedItem | Common interface for a State managed collection items
IChartingStateManager | The common interface for all chart elements support View State tracking
IContainer | Common interface for a rendering container objects
IOrdering | Common interface for an order list element of rendering container

Delegates

Delegate | Description
RegionClickEventHandler |

Enumerations

Enumeration | Description
ChartElementLocation | Specifies the location of the RadChart's elements.
ChartSeriesLegendDisplayMode | Specifies legend items presentation.
ChartSeriesOrientation | Series orientation
ChartSeriesType | Supported series types.
ChartYAxisMode | Specifies the Y axis modes.
ChartYAxisType | Primary or Secondary
ContentHorizontalAlign | Horizontal Alignment of text in DataTable cells
ContentVerticalAlign | Vertical Alignment of text in DataTable cells
ScaleBreakLineType | Possible axis scale break's line types
TableRenderType | RenderType of DataTable


ActiveRegion Class

[image]

Telerik Reporting Q2 2012
ActiveRegion Class
Members See Also Send Feedback
Represents the active region of the chart element/item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ActiveRegion : StateManagedObject
Visual Basic (Declaration)
Public Class ActiveRegion _
    Inherits StateManagedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.ActiveRegion

See Also

ActiveRegion Members
Telerik.Reporting.Charting Namespace


ActiveRegion Members

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion Members
ActiveRegion Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The ActiveRegion type exposes the following members.

Constructors

Name | Description
ActiveRegion | Overloaded.

Methods

Name | Description
CheckPoint | Overloaded.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GoToUrl | Opens a web browser to the specified URL
IsEmpty | Returns true if ActiveRegion contains no data
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Attributes | Attributes
Parent | Reference to the parent.
Region | Define a graphic path
Tooltip | Tooltip
Url | URL
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Events

Name | Description
Click | Fires when the chart element to which the active region belongs is clicked.

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


ActiveRegion Constructor

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion Constructor
ActiveRegion Class See Also Send Feedback

Overload List

Name | Description
ActiveRegion()()() | Creates a new instance of the class.
ActiveRegion(Object) | Creates a new instance of the class.

See Also

ActiveRegion Class
ActiveRegion Members
Telerik.Reporting.Charting Namespace


ActiveRegion Constructor

[image]

Telerik Reporting Q2 2012
ActiveRegion Constructor
ActiveRegion Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ActiveRegion()
Visual Basic (Declaration)
Public Sub New

See Also

ActiveRegion Class
ActiveRegion Overload
Telerik.Reporting.Charting Namespace


ActiveRegion Constructor (Object)

[image]

Telerik Reporting Q2 2012
ActiveRegion Constructor (Object)
ActiveRegion Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ActiveRegion(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object

See Also

ActiveRegion Class
ActiveRegion Overload
Telerik.Reporting.Charting Namespace


ActiveRegion Methods

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion Methods
ActiveRegion Class See Also Send Feedback

The ActiveRegion type exposes the following members.

Methods

Name | Description
CheckPoint | Overloaded.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GoToUrl | Opens a web browser to the specified URL
IsEmpty | Returns true if ActiveRegion contains no data
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


CheckPoint Method

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion..::.CheckPoint Method
ActiveRegion Class See Also Send Feedback

Overload List

Name | Description
CheckPoint(PointF) | Checks whether point lies inside region
CheckPoint(PointF, Boolean) | Checks whether point lies inside region

See Also

ActiveRegion Class
ActiveRegion Members
Telerik.Reporting.Charting Namespace


CheckPoint Method (PointF)

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.CheckPoint Method (PointF)
ActiveRegion Class See Also Send Feedback
Checks whether point lies inside region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CheckPoint(
    PointF point
)
Visual Basic (Declaration)
Public Function CheckPoint ( _
    point As PointF _
) As Boolean

Parameters

point
Type: System.Drawing..::.PointF
The point.

Return Value

See Also

ActiveRegion Class
CheckPoint Overload
Telerik.Reporting.Charting Namespace


CheckPoint Method (PointF, Boolean)

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.CheckPoint Method (PointF, Boolean)
ActiveRegion Class See Also Send Feedback
Checks whether point lies inside region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool CheckPoint(
    PointF point,
    bool onclick
)
Visual Basic (Declaration)
Public Function CheckPoint ( _
    point As PointF, _
    onclick As Boolean _
) As Boolean

Parameters

point
Type: System.Drawing..::.PointF
The point.
onclick
Type: System..::.Boolean
if set to true [onclick].

Return Value

See Also

ActiveRegion Class
CheckPoint Overload
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion..::.Dispose Method
ActiveRegion Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ActiveRegion Class
ActiveRegion Members
Telerik.Reporting.Charting Namespace


GoToUrl Method

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.GoToUrl Method
ActiveRegion Class See Also Send Feedback
Opens a web browser to the specified URL

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void GoToUrl()
Visual Basic (Declaration)
Public Sub GoToUrl

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


IsEmpty Method

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.IsEmpty Method
ActiveRegion Class See Also Send Feedback
Returns true if ActiveRegion contains no data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty()
Visual Basic (Declaration)
Public Function IsEmpty As Boolean

Return Value

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


ActiveRegion Properties

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion Properties
ActiveRegion Class See Also Send Feedback

The ActiveRegion type exposes the following members.

Properties

Name | Description
Attributes | Attributes
Parent | Reference to the parent.
Region | Define a graphic path
Tooltip | Tooltip
Url | URL
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Attributes Property

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Attributes Property
ActiveRegion Class See Also Send Feedback
Attributes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Attributes { get; set; }
Visual Basic (Declaration)
Public Property Attributes As String

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Parent Property
ActiveRegion Class See Also Send Feedback
Reference to the parent.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Region Property

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Region Property
ActiveRegion Class See Also Send Feedback
Define a graphic path

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GraphicsPath Region { get; set; }
Visual Basic (Declaration)
Public Property Region As GraphicsPath

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Tooltip Property

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Tooltip Property
ActiveRegion Class See Also Send Feedback
Tooltip

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Tooltip { get; set; }
Visual Basic (Declaration)
Public Property Tooltip As String

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Url Property

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Url Property
ActiveRegion Class See Also Send Feedback
URL

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


ActiveRegion Events

[image] [image]

Telerik Reporting Q2 2012
ActiveRegion Events
ActiveRegion Class See Also Send Feedback

The ActiveRegion type exposes the following members.

Events

Name | Description
Click | Fires when the chart element to which the active region belongs is clicked.

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


Click Event

[image]

Telerik Reporting Q2 2012
ActiveRegion..::.Click Event
ActiveRegion Class See Also Send Feedback
Fires when the chart element to which the active region belongs is clicked.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event RegionClickEventHandler Click
Visual Basic (Declaration)
Public Event Click As RegionClickEventHandler

See Also

ActiveRegion Class
Telerik.Reporting.Charting Namespace


AxisLabel Class

[image]

Telerik Reporting Q2 2012
AxisLabel Class
Members See Also Send Feedback
X Axis label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AxisLabel : AxisLabelHidden
Visual Basic (Declaration)
Public Class AxisLabel _
    Inherits AxisLabelHidden

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.AxisLabelHidden
Telerik.Reporting.Charting..::.AxisLabel

See Also

AxisLabel Members
Telerik.Reporting.Charting Namespace


AxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
AxisLabel Members
AxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AxisLabel type exposes the following members.

Constructors

Name | Description
AxisLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Inherited from AxisLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
AxisLabel Constructor
AxisLabel Class See Also Send Feedback

Overload List

Name | Description
AxisLabel()()() | Create new instance of AxisLabel
AxisLabel(Object, IContainer) | Create new instance of AxisLabel

See Also

AxisLabel Class
AxisLabel Members
Telerik.Reporting.Charting Namespace


AxisLabel Constructor

[image]

Telerik Reporting Q2 2012
AxisLabel Constructor
AxisLabel Class See Also Send Feedback
Create new instance of AxisLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

AxisLabel Class
AxisLabel Overload
Telerik.Reporting.Charting Namespace


AxisLabel Constructor (Object, IContainer)

[image]

Telerik Reporting Q2 2012
AxisLabel Constructor (Object, IContainer)
AxisLabel Class See Also Send Feedback
Create new instance of AxisLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabel(
    Object parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

AxisLabel Class
AxisLabel Overload
Telerik.Reporting.Charting Namespace


AxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
AxisLabel Fields
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
AxisLabel Methods
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabel..::.Dispose Method
AxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

AxisLabel Class
AxisLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabel..::.GetOrder Method
AxisLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

AxisLabel Class
AxisLabel Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabel..::.Remove Method
AxisLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

AxisLabel Class
AxisLabel Members
Telerik.Reporting.Charting Namespace


AxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
AxisLabel Properties
AxisLabel Class See Also Send Feedback

The AxisLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Inherited from AxisLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

AxisLabel Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Class

[image]

Telerik Reporting Q2 2012
AxisLabelHidden Class
Members See Also Send Feedback
Axis label base

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AxisLabelHidden : ChartLabel
Visual Basic (Declaration)
Public Class AxisLabelHidden _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.AxisLabelHidden
Telerik.Reporting.Charting..::.AxisLabel
Telerik.Reporting.Charting..::.AxisYLabel

See Also

AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


AxisLabelHidden Members

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden Members
AxisLabelHidden Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AxisLabelHidden type exposes the following members.

Constructors

Name | Description
AxisLabelHidden | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden Constructor
AxisLabelHidden Class See Also Send Feedback

Overload List

Name | Description
AxisLabelHidden()()() | Create new instance of AxisLabelHidden
AxisLabelHidden(Object) | Create new instance of AxisLabelHidden
AxisLabelHidden(String) | Create new instance of AxisLabelHidden
AxisLabelHidden(Object, IContainer, StyleLabelHidden, TextBlock, String) | Create new instance of AxisLabelHidden

See Also

AxisLabelHidden Class
AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor

[image]

Telerik Reporting Q2 2012
AxisLabelHidden Constructor
AxisLabelHidden Class See Also Send Feedback
Create new instance of AxisLabelHidden

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabelHidden()
Visual Basic (Declaration)
Public Sub New

See Also

AxisLabelHidden Class
AxisLabelHidden Overload
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor (Object)

[image]

Telerik Reporting Q2 2012
AxisLabelHidden Constructor (Object)
AxisLabelHidden Class See Also Send Feedback
Create new instance of AxisLabelHidden

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabelHidden(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent element

See Also

AxisLabelHidden Class
AxisLabelHidden Overload
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor (String)

[image]

Telerik Reporting Q2 2012
AxisLabelHidden Constructor (String)
AxisLabelHidden Class See Also Send Feedback
Create new instance of AxisLabelHidden

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabelHidden(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text of label

See Also

AxisLabelHidden Class
AxisLabelHidden Overload
Telerik.Reporting.Charting Namespace


AxisLabelHidden Constructor (Object, IContainer, StyleLabelHidden, TextBlock, String)

[image]

Telerik Reporting Q2 2012
AxisLabelHidden Constructor (Object, IContainer, StyleLabelHidden, TextBlock, String)
AxisLabelHidden Class See Also Send Feedback
Create new instance of AxisLabelHidden

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisLabelHidden(
    Object parent,
    IContainer container,
    StyleLabelHidden appearance,
    TextBlock textBlock,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    appearance As StyleLabelHidden, _
    textBlock As TextBlock, _
    text As String _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabelHidden
Style of label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock
text
Type: System..::.String
Text of label

See Also

AxisLabelHidden Class
AxisLabelHidden Overload
Telerik.Reporting.Charting Namespace


AxisLabelHidden Fields

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden Fields
AxisLabelHidden Class See Also Send Feedback

The AxisLabelHidden type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisLabelHidden Methods

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden Methods
AxisLabelHidden Class See Also Send Feedback

The AxisLabelHidden type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden..::.Dispose Method
AxisLabelHidden Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

AxisLabelHidden Class
AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden..::.GetOrder Method
AxisLabelHidden Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

AxisLabelHidden Class
AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden..::.Remove Method
AxisLabelHidden Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

AxisLabelHidden Class
AxisLabelHidden Members
Telerik.Reporting.Charting Namespace


AxisLabelHidden Properties

[image] [image]

Telerik Reporting Q2 2012
AxisLabelHidden Properties
AxisLabelHidden Class See Also Send Feedback

The AxisLabelHidden type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
AxisLabelHidden..::.Visible Property
AxisLabelHidden Class See Also Send Feedback
Gets and sets Visibility of label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

Field Value

Visibility of label

See Also

AxisLabelHidden Class
Telerik.Reporting.Charting Namespace


AxisSegment Class

[image]

Telerik Reporting Q2 2012
AxisSegment Class
Members See Also Send Feedback
Axis segment in case of ScaleBreaks enabled

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AxisSegment : StateManagedObject
Visual Basic (Declaration)
Public Class AxisSegment _
    Inherits StateManagedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.AxisSegment

See Also

AxisSegment Members
Telerik.Reporting.Charting Namespace


AxisSegment Members

[image] [image]

Telerik Reporting Q2 2012
AxisSegment Members
AxisSegment Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AxisSegment type exposes the following members.

Constructors

Name | Description
AxisSegment | Overloaded.

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Fields

Name | Description
axisSegmentPointEnd | End point of segment
axisSegmentPointStart | Start point of segment
axisSegmentRectangle | Segments rectangle

Properties

Name | Description
MaxValue | Maximum segment's value at the axis
MinValue | Segment minimum value at the axis
Name | Segments name in collection
Step | Axis items step for a current Segment
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


AxisSegment Constructor

[image] [image]

Telerik Reporting Q2 2012
AxisSegment Constructor
AxisSegment Class See Also Send Feedback

Overload List

Name | Description
AxisSegment()()() | Creates a new class instance
AxisSegment(String) | Creates a new class instance Segment name

See Also

AxisSegment Class
AxisSegment Members
Telerik.Reporting.Charting Namespace


AxisSegment Constructor

[image]

Telerik Reporting Q2 2012
AxisSegment Constructor
AxisSegment Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisSegment()
Visual Basic (Declaration)
Public Sub New

See Also

AxisSegment Class
AxisSegment Overload
Telerik.Reporting.Charting Namespace


AxisSegment Constructor (String)

[image]

Telerik Reporting Q2 2012
AxisSegment Constructor (String)
AxisSegment Class See Also Send Feedback
Creates a new class instance Segment name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisSegment(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String

See Also

AxisSegment Class
AxisSegment Overload
Telerik.Reporting.Charting Namespace


AxisSegment Fields

[image] [image]

Telerik Reporting Q2 2012
AxisSegment Fields
AxisSegment Class See Also Send Feedback

The AxisSegment type exposes the following members.

Fields

Name | Description
axisSegmentPointEnd | End point of segment
axisSegmentPointStart | Start point of segment
axisSegmentRectangle | Segments rectangle

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


axisSegmentPointEnd Field

[image]

Telerik Reporting Q2 2012
AxisSegment..::.axisSegmentPointEnd Field
AxisSegment Class See Also Send Feedback
End point of segment

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PointF axisSegmentPointEnd
Visual Basic (Declaration)
Protected axisSegmentPointEnd As PointF

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


axisSegmentPointStart Field

[image]

Telerik Reporting Q2 2012
AxisSegment..::.axisSegmentPointStart Field
AxisSegment Class See Also Send Feedback
Start point of segment

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PointF axisSegmentPointStart
Visual Basic (Declaration)
Protected axisSegmentPointStart As PointF

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


axisSegmentRectangle Field

[image]

Telerik Reporting Q2 2012
AxisSegment..::.axisSegmentRectangle Field
AxisSegment Class See Also Send Feedback
Segments rectangle

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected RectangleF axisSegmentRectangle
Visual Basic (Declaration)
Protected axisSegmentRectangle As RectangleF

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


AxisSegment Methods

[image] [image]

Telerik Reporting Q2 2012
AxisSegment Methods
AxisSegment Class See Also Send Feedback

The AxisSegment type exposes the following members.

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
AxisSegment..::.Dispose Method
AxisSegment Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

AxisSegment Class
AxisSegment Members
Telerik.Reporting.Charting Namespace


AxisSegment Properties

[image] [image]

Telerik Reporting Q2 2012
AxisSegment Properties
AxisSegment Class See Also Send Feedback

The AxisSegment type exposes the following members.

Properties

Name | Description
MaxValue | Maximum segment's value at the axis
MinValue | Segment minimum value at the axis
Name | Segments name in collection
Step | Axis items step for a current Segment
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


MaxValue Property

[image]

Telerik Reporting Q2 2012
AxisSegment..::.MaxValue Property
AxisSegment Class See Also Send Feedback
Maximum segment's value at the axis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double MaxValue { get; set; }
Visual Basic (Declaration)
Public Property MaxValue As Double

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


MinValue Property

[image]

Telerik Reporting Q2 2012
AxisSegment..::.MinValue Property
AxisSegment Class See Also Send Feedback
Segment minimum value at the axis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double MinValue { get; set; }
Visual Basic (Declaration)
Public Property MinValue As Double

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
AxisSegment..::.Name Property
AxisSegment Class See Also Send Feedback
Segments name in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


Step Property

[image]

Telerik Reporting Q2 2012
AxisSegment..::.Step Property
AxisSegment Class See Also Send Feedback
Axis items step for a current Segment

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Step { get; set; }
Visual Basic (Declaration)
Public Property Step As Double

See Also

AxisSegment Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Class

[image]

Telerik Reporting Q2 2012
AxisSegmentCollection Class
Members See Also Send Feedback
Segments collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AxisSegmentCollection : ChartingStateManagedCollection<AxisSegment>
Visual Basic (Declaration)
Public Class AxisSegmentCollection _
    Inherits ChartingStateManagedCollection(Of AxisSegment)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' AxisSegment >)>)>
Telerik.Reporting.Charting..::.AxisSegmentCollection

See Also

AxisSegmentCollection Members
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Members

[image] [image]

Telerik Reporting Q2 2012
AxisSegmentCollection Members
AxisSegmentCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The AxisSegmentCollection type exposes the following members.

Constructors

Name | Description
AxisSegmentCollection | Initializes a new instance of the AxisSegmentCollection class

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Constructor

[image]

Telerik Reporting Q2 2012
AxisSegmentCollection Constructor
AxisSegmentCollection Class See Also Send Feedback
Initializes a new instance of the AxisSegmentCollection class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisSegmentCollection()
Visual Basic (Declaration)
Public Sub New

See Also

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Methods

[image] [image]

Telerik Reporting Q2 2012
AxisSegmentCollection Methods
AxisSegmentCollection Class See Also Send Feedback

The AxisSegmentCollection type exposes the following members.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisSegmentCollection Properties

[image] [image]

Telerik Reporting Q2 2012
AxisSegmentCollection Properties
AxisSegmentCollection Class See Also Send Feedback

The AxisSegmentCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

AxisSegmentCollection Class
Telerik.Reporting.Charting Namespace


AxisYLabel Class

[image]

Telerik Reporting Q2 2012
AxisYLabel Class
Members See Also Send Feedback
Y axis label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AxisYLabel : AxisLabelHidden
Visual Basic (Declaration)
Public Class AxisYLabel _
    Inherits AxisLabelHidden

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.AxisLabelHidden
Telerik.Reporting.Charting..::.AxisYLabel

See Also

AxisYLabel Members
Telerik.Reporting.Charting Namespace


AxisYLabel Members

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel Members
AxisYLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AxisYLabel type exposes the following members.

Constructors

Name | Description
AxisYLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Inherited from AxisLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisYLabel Class
Telerik.Reporting.Charting Namespace


AxisYLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel Constructor
AxisYLabel Class See Also Send Feedback

Overload List

Name | Description
AxisYLabel()()() | Create new instance of AxisYLabel
AxisYLabel(Object, IContainer) | Create new instance of AxisYLabel

See Also

AxisYLabel Class
AxisYLabel Members
Telerik.Reporting.Charting Namespace


AxisYLabel Constructor

[image]

Telerik Reporting Q2 2012
AxisYLabel Constructor
AxisYLabel Class See Also Send Feedback
Create new instance of AxisYLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisYLabel()
Visual Basic (Declaration)
Public Sub New

See Also

AxisYLabel Class
AxisYLabel Overload
Telerik.Reporting.Charting Namespace


AxisYLabel Constructor (Object, IContainer)

[image]

Telerik Reporting Q2 2012
AxisYLabel Constructor (Object, IContainer)
AxisYLabel Class See Also Send Feedback
Create new instance of AxisYLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisYLabel(
    Object parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

AxisYLabel Class
AxisYLabel Overload
Telerik.Reporting.Charting Namespace


AxisYLabel Fields

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel Fields
AxisYLabel Class See Also Send Feedback

The AxisYLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

AxisYLabel Class
Telerik.Reporting.Charting Namespace


AxisYLabel Methods

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel Methods
AxisYLabel Class See Also Send Feedback

The AxisYLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

AxisYLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel..::.Dispose Method
AxisYLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

AxisYLabel Class
AxisYLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel..::.GetOrder Method
AxisYLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

AxisYLabel Class
AxisYLabel Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel..::.Remove Method
AxisYLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

AxisYLabel Class
AxisYLabel Members
Telerik.Reporting.Charting Namespace


AxisYLabel Properties

[image] [image]

Telerik Reporting Q2 2012
AxisYLabel Properties
AxisYLabel Class See Also Send Feedback

The AxisYLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets Visibility of label (Inherited from AxisLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

AxisYLabel Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Class

[image]

Telerik Reporting Q2 2012
BindableLegendItem Class
Members See Also Send Feedback
Class for bindable legend items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BindableLegendItem : LabelItem
Visual Basic (Declaration)
Public Class BindableLegendItem _
    Inherits LabelItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.LabelItem
Telerik.Reporting.Charting..::.BindableLegendItem

See Also

BindableLegendItem Members
Telerik.Reporting.Charting Namespace


BindableLegendItem Members

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem Members
BindableLegendItem Class Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The BindableLegendItem type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
BindableLegendItemSource | Source object item bound to
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
Name | Gets and sets Label name in collection (Inherited from LabelItem.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Fields

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem Fields
BindableLegendItem Class See Also Send Feedback

The BindableLegendItem type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItem Methods

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem Methods
BindableLegendItem Class See Also Send Feedback

The BindableLegendItem type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem..::.Dispose Method
BindableLegendItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

BindableLegendItem Class
BindableLegendItem Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem..::.GetOrder Method
BindableLegendItem Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

BindableLegendItem Class
BindableLegendItem Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem..::.Remove Method
BindableLegendItem Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

BindableLegendItem Class
BindableLegendItem Members
Telerik.Reporting.Charting Namespace


BindableLegendItem Properties

[image] [image]

Telerik Reporting Q2 2012
BindableLegendItem Properties
BindableLegendItem Class See Also Send Feedback

The BindableLegendItem type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
BindableLegendItemSource | Source object item bound to
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
Name | Gets and sets Label name in collection (Inherited from LabelItem.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


BindableLegendItemSource Property

[image]

Telerik Reporting Q2 2012
BindableLegendItem..::.BindableLegendItemSource Property
BindableLegendItem Class See Also Send Feedback
Source object item bound to

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object BindableLegendItemSource { get; set; }
Visual Basic (Declaration)
Public Property BindableLegendItemSource As Object

See Also

BindableLegendItem Class
Telerik.Reporting.Charting Namespace


Chart Class

[image]

Telerik Reporting Q2 2012
Chart Class
Members See Also Send Feedback
This is an class which provides charting functionality for Telerik products.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Chart : LayoutElement, IContainer,
    IDisposable
Visual Basic (Declaration)
Public Class Chart _
    Inherits LayoutElement _
    Implements IContainer, IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.Chart

See Also

Chart Members
Telerik.Reporting.Charting Namespace


Chart Members

[image] [image]

Telerik Reporting Q2 2012
Chart Members
Chart Class Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Loading ViewState data (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Saving ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
Appearance | Contains appearance related settings.
ChartTitle | Provides access to the title element of the chart.
Container | Link to container element (Inherited from RenderedObject.)
CustomPalettes | Contains a collection of custom palettes
DefaultType | Specifies the default series type.
Legend | Provides access to the legend element of the chart.
Series | Gets or sets the RadChart's chart series collection object.
Skin | Specifies the skin to use.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Chart Fields

[image] [image]

Telerik Reporting Q2 2012
Chart Fields
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Chart Methods

[image] [image]

Telerik Reporting Q2 2012
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Loading ViewState data (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Saving ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
Chart..::.Add Method
Chart Class See Also Send Feedback
Add element at the end of list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Add ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Add(IOrdering)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.Dispose Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutElement..::.Dispose(Boolean).)

See Also

Chart Class
Chart Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
Chart..::.Dispose Method (Boolean)
Chart Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Chart Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.GetOrder Method
Chart Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Get elements order position

See Also

Chart Class
Chart Members
Telerik.Reporting.Charting Namespace


GetOrder Method (IOrdering)

[image]

Telerik Reporting Q2 2012
Chart..::.GetOrder Method (IOrdering)
Chart Class See Also Send Feedback
Get elements order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetOrder(
    IOrdering element
)
Visual Basic (Declaration)
Public Function GetOrder ( _
    element As IOrdering _
) As Integer

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.GetOrder(IOrdering)

See Also

Chart Class
GetOrder Overload
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
Chart..::.Insert Method
Chart Class See Also Send Feedback
Insert element at specific position in list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Insert(
    int order,
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Insert ( _
    order As Integer, _
    element As IOrdering _
)

Parameters

order
Type: System..::.Int32
Position
element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Insert(Int32, IOrdering)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
Chart..::.LoadViewState Method
Chart Class See Also Send Feedback
Loading ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object

See Also

Chart Class
Telerik.Reporting.Charting Namespace


ReIndex Method

[image]

Telerik Reporting Q2 2012
Chart..::.ReIndex Method
Chart Class See Also Send Feedback
Re-index order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ReIndex()
Visual Basic (Declaration)
Public Sub ReIndex

Implements

IContainer..::.ReIndex()()()

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.Remove Method
Chart Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list

See Also

Chart Class
Chart Members
Telerik.Reporting.Charting Namespace


Remove Method (IOrdering)

[image]

Telerik Reporting Q2 2012
Chart..::.Remove Method (IOrdering)
Chart Class See Also Send Feedback
Remove element from list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Remove ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Remove(IOrdering)

See Also

Chart Class
Remove Overload
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
Chart..::.RemoveAt Method
Chart Class See Also Send Feedback
Remove element from list by it's index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Position

Implements

IContainer..::.RemoveAt(Int32)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
Chart..::.SaveViewState Method
Chart Class See Also Send Feedback
Saving ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

See Also

Chart Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
Chart..::.TrackViewState Method
Chart Class See Also Send Feedback
Tracking ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Chart Properties

[image] [image]

Telerik Reporting Q2 2012
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

Name | Description
Appearance | Contains appearance related settings.
ChartTitle | Provides access to the title element of the chart.
Container | Link to container element (Inherited from RenderedObject.)
CustomPalettes | Contains a collection of custom palettes
DefaultType | Specifies the default series type.
Legend | Provides access to the legend element of the chart.
Series | Gets or sets the RadChart's chart series collection object.
Skin | Specifies the skin to use.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
Chart..::.Appearance Property
Chart Class See Also Send Feedback
Contains appearance related settings.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChart Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChart

See Also

Chart Class
Telerik.Reporting.Charting Namespace


ChartTitle Property

[image]

Telerik Reporting Q2 2012
Chart..::.ChartTitle Property
Chart Class See Also Send Feedback
Provides access to the title element of the chart.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartTitle ChartTitle { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChartTitle As ChartTitle

See Also

Chart Class
Telerik.Reporting.Charting Namespace


CustomPalettes Property

[image]

Telerik Reporting Q2 2012
Chart..::.CustomPalettes Property
Chart Class See Also Send Feedback
Contains a collection of custom palettes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomPalettesCollection CustomPalettes { get; }
Visual Basic (Declaration)
Public ReadOnly Property CustomPalettes As CustomPalettesCollection

See Also

Chart Class
Telerik.Reporting.Charting Namespace


DefaultType Property

[image]

Telerik Reporting Q2 2012
Chart..::.DefaultType Property
Chart Class See Also Send Feedback
Specifies the default series type.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesType DefaultType { get; set; }
Visual Basic (Declaration)
Public Property DefaultType As ChartSeriesType

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Legend Property

[image]

Telerik Reporting Q2 2012
Chart..::.Legend Property
Chart Class See Also Send Feedback
Provides access to the legend element of the chart.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLegend Legend { get; }
Visual Basic (Declaration)
Public ReadOnly Property Legend As ChartLegend

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Series Property

[image]

Telerik Reporting Q2 2012
Chart..::.Series Property
Chart Class See Also Send Feedback
Gets or sets the RadChart's chart series collection object.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As ChartSeriesCollection

See Also

Chart Class
Telerik.Reporting.Charting Namespace


Skin Property

[image]

Telerik Reporting Q2 2012
Chart..::.Skin Property
Chart Class See Also Send Feedback
Specifies the skin to use.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Skin { get; set; }
Visual Basic (Declaration)
Public Property Skin As String

See Also

Chart Class
Telerik.Reporting.Charting Namespace


ChartAxis Class

[image]

Telerik Reporting Q2 2012
ChartAxis Class
Members See Also Send Feedback
Base chart axis class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ChartAxis : RenderedObject
Visual Basic (Declaration)
Public MustInherit Class ChartAxis _
    Inherits RenderedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartAxis
Telerik.Reporting.Charting..::.ChartXAxis
Telerik.Reporting.Charting..::.ChartYAxis

See Also

ChartAxis Members
Telerik.Reporting.Charting Namespace


ChartAxis Members

[image] [image]

Telerik Reporting Q2 2012
ChartAxis Members
ChartAxis Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartAxis type exposes the following members.

Constructors

Name | Description
ChartAxis | Overloaded.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode.
AutoCalcAxisExtents | Auto determines the min and max value of the axis
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate
GetAxisStartCoord | Gets the start value coordinate
GetDistance | Gets distance between points
GetItem | Gets the item at the specified index.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis.
ResetMaxValue | Resets the MaxValue to default
ResetMinValue | Resets the MinValue to default
ResetStep | Resets the Step value to default
SaveViewState | Saves data to a State Bag (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position.
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value
SetMinValue | Sets the min axis range value
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason
ShouldSerializeMinValue | The axis MinValue design time serialization reason
ShouldSerializeStep | The axis Step design time serialization reason
TrackViewState | Tracking ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
chartAxisAppearance | ChartAxis style
chartAxisItems | ChartAxis items
chartAxisLabel | ChartAxis main label
chartAxisMaxAxisValue | Maximum series value
chartAxisMaxItemValue | Max axis item value
chartAxisMinAxisValue | Minimum series value
chartAxisMinItemValue | Min axis item value
chartAxisParent | Parent element
chartAxisPointEnd | Axis zero value end point
chartAxisPointStart | Axis start point
chartAxisRealIsZeroBased | Is axis zero based
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field.
zeroCoord | Cached zero coordinate value.

Properties

Name | Description
Appearance | ChartAxis style
AutoScale | Enables or disables automatic axis scaling.
AxisLabel | ChartAxis label
Container | Link to container element (Inherited from RenderedObject.)
IsZeroBased | Specifies whether the axis begins from 0.
Item | Returns the axis item at the specified position.
Items | Returns a collection of axis items.
LabelStep | Draw each 1,2,...,n item
MaxItemsCount | Gets or sets maximal count of the axis items when auto scaling.
MaxValue | Specifies the max value of the axis range.
MinValue | Specifies the min value of the axis range.
Parent | Parent element (PlotArea)
Step | Specifies the step at which axis values are calculated
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis should be rendered.
VisibleValues | Determines the type of shown values

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ChartAxis Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartAxis Constructor
ChartAxis Class See Also Send Feedback

Overload List

Name | Description
ChartAxis(ChartPlotArea) | Creates a new instance of the ChartAxis class.
ChartAxis(ChartPlotArea, IContainer) | Creates a new instance of the ChartAxis class.

See Also

ChartAxis Class
ChartAxis Members
Telerik.Reporting.Charting Namespace


ChartAxis Constructor (ChartPlotArea)

[image]

Telerik Reporting Q2 2012
ChartAxis Constructor (ChartPlotArea)
ChartAxis Class See Also Send Feedback
Creates a new instance of the ChartAxis class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxis(
    ChartPlotArea parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea

See Also

ChartAxis Class
ChartAxis Overload
Telerik.Reporting.Charting Namespace


ChartAxis Constructor (ChartPlotArea, IContainer)

[image]

Telerik Reporting Q2 2012
ChartAxis Constructor (ChartPlotArea, IContainer)
ChartAxis Class See Also Send Feedback
Creates a new instance of the ChartAxis class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxis(
    ChartPlotArea parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
container
Type: Telerik.Reporting.Charting..::.IContainer

See Also

ChartAxis Class
ChartAxis Overload
Telerik.Reporting.Charting Namespace


ChartAxis Fields

[image] [image]

Telerik Reporting Q2 2012
ChartAxis Fields
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Fields

Name | Description
chartAxisAppearance | ChartAxis style
chartAxisItems | ChartAxis items
chartAxisLabel | ChartAxis main label
chartAxisMaxAxisValue | Maximum series value
chartAxisMaxItemValue | Max axis item value
chartAxisMinAxisValue | Minimum series value
chartAxisMinItemValue | Min axis item value
chartAxisParent | Parent element
chartAxisPointEnd | Axis zero value end point
chartAxisPointStart | Axis start point
chartAxisRealIsZeroBased | Is axis zero based
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field.
zeroCoord | Cached zero coordinate value.

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisAppearance Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisAppearance Field
ChartAxis Class See Also Send Feedback
ChartAxis style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleAxis chartAxisAppearance
Visual Basic (Declaration)
Protected chartAxisAppearance As StyleAxis

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisItems Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisItems Field
ChartAxis Class See Also Send Feedback
ChartAxis items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartAxisItemsCollection chartAxisItems
Visual Basic (Declaration)
Protected chartAxisItems As ChartAxisItemsCollection

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisLabel Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisLabel Field
ChartAxis Class See Also Send Feedback
ChartAxis main label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartLabel chartAxisLabel
Visual Basic (Declaration)
Protected chartAxisLabel As ChartLabel

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisMaxAxisValue Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisMaxAxisValue Field
ChartAxis Class See Also Send Feedback
Maximum series value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected double chartAxisMaxAxisValue
Visual Basic (Declaration)
Protected chartAxisMaxAxisValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisMaxItemValue Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisMaxItemValue Field
ChartAxis Class See Also Send Feedback
Max axis item value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected double chartAxisMaxItemValue
Visual Basic (Declaration)
Protected chartAxisMaxItemValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisMinAxisValue Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisMinAxisValue Field
ChartAxis Class See Also Send Feedback
Minimum series value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected double chartAxisMinAxisValue
Visual Basic (Declaration)
Protected chartAxisMinAxisValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisMinItemValue Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisMinItemValue Field
ChartAxis Class See Also Send Feedback
Min axis item value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected double chartAxisMinItemValue
Visual Basic (Declaration)
Protected chartAxisMinItemValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisParent Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisParent Field
ChartAxis Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartPlotArea chartAxisParent
Visual Basic (Declaration)
Protected chartAxisParent As ChartPlotArea

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisPointEnd Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisPointEnd Field
ChartAxis Class See Also Send Feedback
Axis zero value end point

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PointF chartAxisPointEnd
Visual Basic (Declaration)
Protected chartAxisPointEnd As PointF

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisPointStart Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisPointStart Field
ChartAxis Class See Also Send Feedback
Axis start point

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PointF chartAxisPointStart
Visual Basic (Declaration)
Protected chartAxisPointStart As PointF

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


chartAxisRealIsZeroBased Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.chartAxisRealIsZeroBased Field
ChartAxis Class See Also Send Feedback
Is axis zero based

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool chartAxisRealIsZeroBased
Visual Basic (Declaration)
Protected chartAxisRealIsZeroBased As Boolean

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


pixelsPerValue Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.pixelsPerValue Field
ChartAxis Class See Also Send Feedback
Pixels per value field.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float pixelsPerValue
Visual Basic (Declaration)
Protected pixelsPerValue As Single

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


zeroCoord Field

[image]

Telerik Reporting Q2 2012
ChartAxis..::.zeroCoord Field
ChartAxis Class See Also Send Feedback
Cached zero coordinate value.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float zeroCoord
Visual Basic (Declaration)
Protected zeroCoord As Single

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ChartAxis Methods

[image] [image]

Telerik Reporting Q2 2012
ChartAxis Methods
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode.
AutoCalcAxisExtents | Auto determines the min and max value of the axis
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate
GetAxisStartCoord | Gets the start value coordinate
GetDistance | Gets distance between points
GetItem | Gets the item at the specified index.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis.
ResetMaxValue | Resets the MaxValue to default
ResetMinValue | Resets the MinValue to default
ResetStep | Resets the Step value to default
SaveViewState | Saves data to a State Bag (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position.
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value
SetMinValue | Sets the min axis range value
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason
ShouldSerializeMinValue | The axis MinValue design time serialization reason
ShouldSerializeStep | The axis Step design time serialization reason
TrackViewState | Tracking ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


AddItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method
ChartAxis Class See Also Send Feedback

Overload List

Name | Description
AddItem(List<(Of <(ChartAxisItem>)>)) | Adds ChartAxisItems to the axis.
AddItem(array<ChartAxisItem>[]()[]) | Adds ChartAxisItems to the axis.
AddItem(ChartAxisItemsCollection) | Adds a ChartAxisItemsCollection to the axis.
AddItem(String, Color) | Adds a new ChartAxisItem object to the axis with the specified label and color.
AddItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Adds a ChartAxisItem to the axis.
AddItem(String, Color, Boolean) | Adds a new ChartAxisItem object to the axis with the specified label and color.

See Also

ChartAxis Class
ChartAxis Members
Telerik.Reporting.Charting Namespace


AddItem Method (List(ChartAxisItem))

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (List<(Of <(<'ChartAxisItem>)>)>)
ChartAxis Class See Also Send Feedback
Adds ChartAxisItems to the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    List<ChartAxisItem> items
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    items As List(Of ChartAxisItem) _
)

Parameters

items
Type: System.Collections.Generic..::.List <(Of <(<' ChartAxisItem >)>)>

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartAxisItem[])

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (array<ChartAxisItem>[]()[][])
ChartAxis Class See Also Send Feedback
Adds ChartAxisItems to the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartAxisItem[] items
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    items As ChartAxisItem() _
)

Parameters

items
Type: array< Telerik.Reporting.Charting..::.ChartAxisItem >[]()[][]

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartAxisItemsCollection)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (ChartAxisItemsCollection)
ChartAxis Class See Also Send Feedback
Adds a ChartAxisItemsCollection to the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartAxisItemsCollection items
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    items As ChartAxisItemsCollection _
)

Parameters

items
Type: Telerik.Reporting.Charting..::.ChartAxisItemsCollection

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (String, Color)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (String, Color)
ChartAxis Class See Also Send Feedback
Adds a new ChartAxisItem object to the axis with the specified label and color.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartAxisItem AddItem(
    string label,
    Color color
)
Visual Basic (Declaration)
Protected Function AddItem ( _
    label As String, _
    color As Color _
) As ChartAxisItem

Parameters

label
Type: System..::.String
Axis label
color
Type: System.Drawing..::.Color
Item text color

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartAxisItem, ChartAxisItem[])

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (ChartAxisItem, array<ChartAxisItem>[]()[][])
ChartAxis Class See Also Send Feedback
Adds a ChartAxisItem to the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartAxisItem item,
    params ChartAxisItem[] items
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    item As ChartAxisItem, _
    ParamArray items As ChartAxisItem() _
)

Parameters

item
Type: Telerik.Reporting.Charting..::.ChartAxisItem
items
Type: array< Telerik.Reporting.Charting..::.ChartAxisItem >[]()[][]

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (String, Color, Boolean)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddItem Method (String, Color, Boolean)
ChartAxis Class See Also Send Feedback
Adds a new ChartAxisItem object to the axis with the specified label and color.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartAxisItem AddItem(
    string label,
    Color color,
    bool visible
)
Visual Basic (Declaration)
Protected Function AddItem ( _
    label As String, _
    color As Color, _
    visible As Boolean _
) As ChartAxisItem

Parameters

label
Type: System..::.String
Axis label
color
Type: System.Drawing..::.Color
Item text color
visible
Type: System..::.Boolean
Visibility

See Also

ChartAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AddRange Method
ChartAxis Class See Also Send Feedback
Automatically adds new axis items in AutoScale mode.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    double minValue,
    double maxValue,
    double step
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    minValue As Double, _
    maxValue As Double, _
    step As Double _
)

Parameters

minValue
Type: System..::.Double
Min range value
maxValue
Type: System..::.Double
Max range value
step
Type: System..::.Double
Axis step value

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


AutoCalcAxisExtents Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AutoCalcAxisExtents Method
ChartAxis Class See Also Send Feedback
Auto determines the min and max value of the axis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void AutoCalcAxisExtents()
Visual Basic (Declaration)
Protected Sub AutoCalcAxisExtents

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Clear Method
ChartAxis Class See Also Send Feedback
Clears data values of the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


DisableCachedValues Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.DisableCachedValues Method
ChartAxis Class See Also Send Feedback
Restores initial values of cached axis settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void DisableCachedValues()
Visual Basic (Declaration)
Protected Overridable Sub DisableCachedValues

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxis..::.Dispose Method
ChartAxis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

ChartAxis Class
ChartAxis Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Dispose Method (Boolean)
ChartAxis Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartAxis Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetAxisEndCoord Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.GetAxisEndCoord Method
ChartAxis Class See Also Send Feedback
Gets the end value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal abstract float GetAxisEndCoord()
Visual Basic (Declaration)
Protected Friend MustOverride Function GetAxisEndCoord As Single

Return Value

Coordinate

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


GetAxisStartCoord Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.GetAxisStartCoord Method
ChartAxis Class See Also Send Feedback
Gets the start value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal abstract float GetAxisStartCoord()
Visual Basic (Declaration)
Protected Friend MustOverride Function GetAxisStartCoord As Single

Return Value

Coordinate

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


GetDistance Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.GetDistance Method
ChartAxis Class See Also Send Feedback
Gets distance between points

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float GetDistance(
    PointF point1,
    PointF point2
)
Visual Basic (Declaration)
Protected Function GetDistance ( _
    point1 As PointF, _
    point2 As PointF _
) As Single

Parameters

point1
Type: System.Drawing..::.PointF
First point
point2
Type: System.Drawing..::.PointF
Second point

Return Value

Distance

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


GetItem Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.GetItem Method
ChartAxis Class See Also Send Feedback
Gets the item at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem GetItem(
    int index
)
Visual Basic (Declaration)
Public Function GetItem ( _
    index As Integer _
) As ChartAxisItem

Parameters

index
Type: System..::.Int32

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.LoadViewState Method
ChartAxis Class See Also Send Feedback
Loading ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
Saved state bag

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


RemoveAllItems Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveAllItems Method
ChartAxis Class See Also Send Feedback
Removes all items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveAllItems()
Visual Basic (Declaration)
Public Sub RemoveAllItems

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


RemoveItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveItem Method
ChartAxis Class See Also Send Feedback

Overload List

Name | Description
RemoveItem(Int32) | Removes the ChartAxisItem at the specified index.
RemoveItem(Int32, array<Int32>[]()[]) | Removes the ChartAxisItems at the specified indexes.
RemoveItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Removes the ChartAxisItem specified.

See Also

ChartAxis Class
ChartAxis Members
Telerik.Reporting.Charting Namespace


RemoveItem Method (Int32)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveItem Method (Int32)
ChartAxis Class See Also Send Feedback
Removes the ChartAxisItem at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    itemIndex As Integer _
)

Parameters

itemIndex
Type: System..::.Int32
item's index

See Also

ChartAxis Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


RemoveItem Method (Int32, Int32[])

[image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveItem Method (Int32, array<Int32>[]()[][])
ChartAxis Class See Also Send Feedback
Removes the ChartAxisItems at the specified indexes.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    int index,
    params int[] indexes
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    index As Integer, _
    ParamArray indexes As Integer() _
)

Parameters

index
Type: System..::.Int32
indexes
Type: array< System..::.Int32 >[]()[][]

See Also

ChartAxis Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


RemoveItem Method (ChartAxisItem, ChartAxisItem[])

[image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveItem Method (ChartAxisItem, array<ChartAxisItem>[]()[][])
ChartAxis Class See Also Send Feedback
Removes the ChartAxisItem specified.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    ChartAxisItem item,
    params ChartAxisItem[] items
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    item As ChartAxisItem, _
    ParamArray items As ChartAxisItem() _
)

Parameters

item
Type: Telerik.Reporting.Charting..::.ChartAxisItem
items
Type: array< Telerik.Reporting.Charting..::.ChartAxisItem >[]()[][]

See Also

ChartAxis Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


RemoveLastItem Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.RemoveLastItem Method
ChartAxis Class See Also Send Feedback
Removes the last item from the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveLastItem()
Visual Basic (Declaration)
Public Sub RemoveLastItem

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ResetMaxValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ResetMaxValue Method
ChartAxis Class See Also Send Feedback
Resets the MaxValue to default

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void ResetMaxValue()
Visual Basic (Declaration)
Protected Sub ResetMaxValue

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ResetMinValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ResetMinValue Method
ChartAxis Class See Also Send Feedback
Resets the MinValue to default

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void ResetMinValue()
Visual Basic (Declaration)
Protected Sub ResetMinValue

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ResetStep Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ResetStep Method
ChartAxis Class See Also Send Feedback
Resets the Step value to default

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void ResetStep()
Visual Basic (Declaration)
Protected Sub ResetStep

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SaveViewState Method
ChartAxis Class See Also Send Feedback
Saves data to a State Bag

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved axis data to a state bag

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


SetItemColor Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SetItemColor Method
ChartAxis Class See Also Send Feedback
Sets new color for the axis item text at the specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemColor(
    int itemIndex,
    Color newColor
)
Visual Basic (Declaration)
Public Sub SetItemColor ( _
    itemIndex As Integer, _
    newColor As Color _
)

Parameters

itemIndex
Type: System..::.Int32
Item index in collection
newColor
Type: System.Drawing..::.Color
Item text color

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


SetItemLabel Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxis..::.SetItemLabel Method
ChartAxis Class See Also Send Feedback

Overload List

Name | Description
SetItemLabel(Int32, String) | Sets new label text for the axis item at the specified position.
SetItemLabel(Int32, ChartAxisItem) | Sets new label for the axis item at the specified position.

See Also

ChartAxis Class
ChartAxis Members
Telerik.Reporting.Charting Namespace


SetItemLabel Method (Int32, String)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SetItemLabel Method (Int32, String)
ChartAxis Class See Also Send Feedback
Sets new label text for the axis item at the specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemLabel(
    int itemIndex,
    string newLabelText
)
Visual Basic (Declaration)
Public Sub SetItemLabel ( _
    itemIndex As Integer, _
    newLabelText As String _
)

Parameters

itemIndex
Type: System..::.Int32
Item index in collection
newLabelText
Type: System..::.String
Axis item label text

See Also

ChartAxis Class
SetItemLabel Overload
Telerik.Reporting.Charting Namespace


SetItemLabel Method (Int32, ChartAxisItem)

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SetItemLabel Method (Int32, ChartAxisItem)
ChartAxis Class See Also Send Feedback
Sets new label for the axis item at the specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemLabel(
    int itemIndex,
    ChartAxisItem newLabel
)
Visual Basic (Declaration)
Public Sub SetItemLabel ( _
    itemIndex As Integer, _
    newLabel As ChartAxisItem _
)

Parameters

itemIndex
Type: System..::.Int32
Item index in collection
newLabel
Type: Telerik.Reporting.Charting..::.ChartAxisItem

See Also

ChartAxis Class
SetItemLabel Overload
Telerik.Reporting.Charting Namespace


SetMaxValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SetMaxValue Method
ChartAxis Class See Also Send Feedback
Sets the maximum axis range value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void SetMaxValue(
    double maxValue
)
Visual Basic (Declaration)
Protected Sub SetMaxValue ( _
    maxValue As Double _
)

Parameters

maxValue
Type: System..::.Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


SetMinValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.SetMinValue Method
ChartAxis Class See Also Send Feedback
Sets the min axis range value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void SetMinValue(
    double minValue
)
Visual Basic (Declaration)
Protected Sub SetMinValue ( _
    minValue As Double _
)

Parameters

minValue
Type: System..::.Double
Value to set

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ShouldSerializeMaxValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ShouldSerializeMaxValue Method
ChartAxis Class See Also Send Feedback
The axis MaxValue design time serialization reason

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool ShouldSerializeMaxValue()
Visual Basic (Declaration)
Protected Function ShouldSerializeMaxValue As Boolean

Return Value

True is value have to be serialized

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ShouldSerializeMinValue Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ShouldSerializeMinValue Method
ChartAxis Class See Also Send Feedback
The axis MinValue design time serialization reason

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool ShouldSerializeMinValue()
Visual Basic (Declaration)
Protected Function ShouldSerializeMinValue As Boolean

Return Value

True is value have to be serialized

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ShouldSerializeStep Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.ShouldSerializeStep Method
ChartAxis Class See Also Send Feedback
The axis Step design time serialization reason

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool ShouldSerializeStep()
Visual Basic (Declaration)
Protected Function ShouldSerializeStep As Boolean

Return Value

True is value have to be serialized

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartAxis..::.TrackViewState Method
ChartAxis Class See Also Send Feedback
Tracking ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ChartAxis Properties

[image] [image]

Telerik Reporting Q2 2012
ChartAxis Properties
ChartAxis Class See Also Send Feedback

The ChartAxis type exposes the following members.

Properties

Name | Description
Appearance | ChartAxis style
AutoScale | Enables or disables automatic axis scaling.
AxisLabel | ChartAxis label
Container | Link to container element (Inherited from RenderedObject.)
IsZeroBased | Specifies whether the axis begins from 0.
Item | Returns the axis item at the specified position.
Items | Returns a collection of axis items.
LabelStep | Draw each 1,2,...,n item
MaxItemsCount | Gets or sets maximal count of the axis items when auto scaling.
MaxValue | Specifies the max value of the axis range.
MinValue | Specifies the min value of the axis range.
Parent | Parent element (PlotArea)
Step | Specifies the step at which axis values are calculated
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis should be rendered.
VisibleValues | Determines the type of shown values

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Appearance Property
ChartAxis Class See Also Send Feedback
ChartAxis style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleAxis

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


AutoScale Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AutoScale Property
ChartAxis Class See Also Send Feedback
Enables or disables automatic axis scaling.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AutoScale { get; set; }
Visual Basic (Declaration)
Public Property AutoScale As Boolean

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


AxisLabel Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.AxisLabel Property
ChartAxis Class See Also Send Feedback
ChartAxis label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel AxisLabel { get; }
Visual Basic (Declaration)
Public ReadOnly Property AxisLabel As ChartLabel

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


IsZeroBased Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.IsZeroBased Property
ChartAxis Class See Also Send Feedback
Specifies whether the axis begins from 0.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsZeroBased { get; set; }
Visual Basic (Declaration)
Public Property IsZeroBased As Boolean

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Item Property
ChartAxis Class See Also Send Feedback
Returns the axis item at the specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ChartAxisItem

Parameters

index
Type: System..::.Int32

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Items Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Items Property
ChartAxis Class See Also Send Feedback
Returns a collection of axis items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ChartAxisItemsCollection

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


LabelStep Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.LabelStep Property
ChartAxis Class See Also Send Feedback
Draw each 1,2,...,n item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int LabelStep { get; set; }
Visual Basic (Declaration)
Public Property LabelStep As Integer

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


MaxItemsCount Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.MaxItemsCount Property
ChartAxis Class See Also Send Feedback
Gets or sets maximal count of the axis items when auto scaling.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int MaxItemsCount { get; set; }
Visual Basic (Declaration)
Public Property MaxItemsCount As Integer

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


MaxValue Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.MaxValue Property
ChartAxis Class See Also Send Feedback
Specifies the max value of the axis range.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual double MaxValue { get; set; }
Visual Basic (Declaration)
Public Overridable Property MaxValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


MinValue Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.MinValue Property
ChartAxis Class See Also Send Feedback
Specifies the min value of the axis range.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual double MinValue { get; set; }
Visual Basic (Declaration)
Public Overridable Property MinValue As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Parent Property
ChartAxis Class See Also Send Feedback
Parent element (PlotArea)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartPlotArea

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Step Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Step Property
ChartAxis Class See Also Send Feedback
Specifies the step at which axis values are calculated

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual double Step { get; set; }
Visual Basic (Declaration)
Public Overridable Property Step As Double

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.Visible Property
ChartAxis Class See Also Send Feedback
Specifies whether the axis should be rendered.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisVisibility Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As ChartAxisVisibility

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


VisibleValues Property

[image]

Telerik Reporting Q2 2012
ChartAxis..::.VisibleValues Property
ChartAxis Class See Also Send Feedback
Determines the type of shown values

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisVisibleValues VisibleValues { get; set; }
Visual Basic (Declaration)
Public Property VisibleValues As ChartAxisVisibleValues

See Also

ChartAxis Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Class

[image]

Telerik Reporting Q2 2012
ChartAxisItem Class
Members See Also Send Feedback
Represents an axis item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartAxisItem : ChartLabel
Visual Basic (Declaration)
Public Class ChartAxisItem _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.ChartAxisItem

See Also

ChartAxisItem Members
Telerik.Reporting.Charting Namespace


ChartAxisItem Members

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem Members
ChartAxisItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartAxisItem type exposes the following members.

Constructors

Name | Description
ChartAxisItem | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
Value | Specifies the value of the axis.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis item should be rendered. (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor
ChartAxisItem Class See Also Send Feedback

Overload List

Name | Description
ChartAxisItem()()() | Creates a new instance of the class.
ChartAxisItem(String) | Creates a new instance of the class.
ChartAxisItem(IContainer) | Creates a new instance of the class.
ChartAxisItem(String, Color) | Creates a new instance of the class.
ChartAxisItem(String, Color, Boolean) | Creates a new instance of the class.
ChartAxisItem(String, Color, Boolean, IContainer) | Creates a new instance of the class.

See Also

ChartAxisItem Class
ChartAxisItem Members
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem()
Visual Basic (Declaration)
Public Sub New

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor (String)
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem(
    string labelText
)
Visual Basic (Declaration)
Public Sub New ( _
    labelText As String _
)

Parameters

labelText
Type: System..::.String

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor (IContainer)
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor (String, Color)

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor (String, Color)
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem(
    string labelText,
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    labelText As String, _
    color As Color _
)

Parameters

labelText
Type: System..::.String
Item text
color
Type: System.Drawing..::.Color
Item text color

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor (String, Color, Boolean)

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor (String, Color, Boolean)
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem(
    string label,
    Color color,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    label As String, _
    color As Color, _
    visible As Boolean _
)

Parameters

label
Type: System..::.String
Item text
color
Type: System.Drawing..::.Color
Item text color
visible
Type: System..::.Boolean
Visibility

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Constructor (String, Color, Boolean, IContainer)

[image]

Telerik Reporting Q2 2012
ChartAxisItem Constructor (String, Color, Boolean, IContainer)
ChartAxisItem Class See Also Send Feedback
Creates a new instance of the class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItem(
    string labelText,
    Color color,
    bool visible,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    labelText As String, _
    color As Color, _
    visible As Boolean, _
    container As IContainer _
)

Parameters

labelText
Type: System..::.String
color
Type: System.Drawing..::.Color
Item text color
visible
Type: System..::.Boolean
Visibility
container
Type: Telerik.Reporting.Charting..::.IContainer
Item container object

See Also

ChartAxisItem Class
ChartAxisItem Overload
Telerik.Reporting.Charting Namespace


ChartAxisItem Fields

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem Fields
ChartAxisItem Class See Also Send Feedback

The ChartAxisItem type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartAxisItem Methods

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem Methods
ChartAxisItem Class See Also Send Feedback

The ChartAxisItem type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem..::.Dispose Method
ChartAxisItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

ChartAxisItem Class
ChartAxisItem Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem..::.GetOrder Method
ChartAxisItem Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

ChartAxisItem Class
ChartAxisItem Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem..::.Remove Method
ChartAxisItem Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

ChartAxisItem Class
ChartAxisItem Members
Telerik.Reporting.Charting Namespace


ChartAxisItem Properties

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItem Properties
ChartAxisItem Class See Also Send Feedback

The ChartAxisItem type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
Value | Specifies the value of the axis.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis item should be rendered. (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ChartAxisItem..::.Value Property
ChartAxisItem Class See Also Send Feedback
Specifies the value of the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public decimal Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Decimal

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartAxisItem..::.Visible Property
ChartAxisItem Class See Also Send Feedback
Specifies whether the axis item should be rendered.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

ChartAxisItem Class
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Class

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Class
Members See Also Send Feedback
A collection to store axis items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartAxisItemsCollection : ChartingStateManagedCollection<ChartAxisItem>
Visual Basic (Declaration)
Public Class ChartAxisItemsCollection _
    Inherits ChartingStateManagedCollection(Of ChartAxisItem)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' ChartAxisItem >)>)>
Telerik.Reporting.Charting..::.ChartAxisItemsCollection

See Also

ChartAxisItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Members

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Members
ChartAxisItemsCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartAxisItemsCollection type exposes the following members.

Constructors

Name | Description
ChartAxisItemsCollection | Overloaded.

Methods

Name | Description
Add | Adds a chart axis item to the collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a ChartAxisItem element at the specified position. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor
ChartAxisItemsCollection Class See Also Send Feedback

Overload List

Name | Description
ChartAxisItemsCollection()()() | Creates a new instance of the ChartAxisItemsCollection class.
ChartAxisItemsCollection(Color) | Creates a new instance of the AxisItems class with the specified default item color.
ChartAxisItemsCollection(Font) | Creates a new instance of the AxisItems class with the specified default item font.
ChartAxisItemsCollection(ChartAxis) | Creates a new instance of the ChartAxisItemsCollection class.
ChartAxisItemsCollection(Font, Color) | Creates a new instance of the AxisItems class with the specified default item font and color.

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor
ChartAxisItemsCollection Class See Also Send Feedback
Creates a new instance of the ChartAxisItemsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor (Color)

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor (Color)
ChartAxisItemsCollection Class See Also Send Feedback
Creates a new instance of the AxisItems class with the specified default item color.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection(
    Color itemColor
)
Visual Basic (Declaration)
Public Sub New ( _
    itemColor As Color _
)

Parameters

itemColor
Type: System.Drawing..::.Color
Axis item text color settings

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor (Font)

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor (Font)
ChartAxisItemsCollection Class See Also Send Feedback
Creates a new instance of the AxisItems class with the specified default item font.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection(
    Font itemFont
)
Visual Basic (Declaration)
Public Sub New ( _
    itemFont As Font _
)

Parameters

itemFont
Type: System.Drawing..::.Font
Axis item's Font settings

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor (ChartAxis)

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor (ChartAxis)
ChartAxisItemsCollection Class See Also Send Feedback
Creates a new instance of the ChartAxisItemsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection(
    ChartAxis parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartAxis _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartAxis

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Constructor (Font, Color)

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Constructor (Font, Color)
ChartAxisItemsCollection Class See Also Send Feedback
Creates a new instance of the AxisItems class with the specified default item font and color.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisItemsCollection(
    Font itemFont,
    Color itemColor
)
Visual Basic (Declaration)
Public Sub New ( _
    itemFont As Font, _
    itemColor As Color _
)

Parameters

itemFont
Type: System.Drawing..::.Font
Axis item's Font settings
itemColor
Type: System.Drawing..::.Color
Axis item text color settings

See Also

ChartAxisItemsCollection Class
ChartAxisItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Methods
ChartAxisItemsCollection Class See Also Send Feedback

The ChartAxisItemsCollection type exposes the following members.

Methods

Name | Description
Add | Adds a chart axis item to the collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection..::.Add Method
ChartAxisItemsCollection Class See Also Send Feedback
Adds a chart axis item to the collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    ChartAxisItem chartAxisItem
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    chartAxisItem As ChartAxisItem _
)

Parameters

chartAxisItem
Type: Telerik.Reporting.Charting..::.ChartAxisItem
Axis item to add

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartAxisItemsCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection Properties
ChartAxisItemsCollection Class See Also Send Feedback

The ChartAxisItemsCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a ChartAxisItem element at the specified position. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection..::.Item Property
ChartAxisItemsCollection Class See Also Send Feedback
Gets or sets a ChartAxisItem element at the specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartAxisItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As ChartAxisItem

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartAxisItemsCollection..::.Parent Property
ChartAxisItemsCollection Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxis Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ChartAxis

See Also

ChartAxisItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartBaseLabel Class

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Class
Members See Also Send Feedback
Base class for all labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartBaseLabel : LayoutElement,
    IContainer, ICloneable
Visual Basic (Declaration)
Public Class ChartBaseLabel _
    Inherits LayoutElement _
    Implements IContainer, ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.ExtendedLabel
Telerik.Reporting.Charting..::.SeriesItemLabel

See Also

ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


ChartBaseLabel Members

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel Members
ChartBaseLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartBaseLabel type exposes the following members.

Constructors

Name | Description
ChartBaseLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Load ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Save to ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property)
chartBaseLabelParent | Parent element
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label
NextPosition | Gets a next free order position
OrderList | List, that represent the render order for taken up elements
Parent | Gets and sets Parent element
TextBlock | ChartLabel TextBlock
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor
ChartBaseLabel Class See Also Send Feedback

Overload List

Name | Description
ChartBaseLabel()()() | Create new instance of ChartBaseLabel class.
ChartBaseLabel(Object) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(String) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(IContainer) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(TextBlock) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(Object, IContainer) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(Object, IContainer, TextBlock) | Create new instance of ChartBaseLabel class.
ChartBaseLabel(Object, IContainer, TextBlock, LayoutStyle) | Create new instance of ChartBaseLabel class.

See Also

ChartBaseLabel Class
ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel()
Visual Basic (Declaration)
Public Sub New

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (Object)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (Object)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent element

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (String)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text of TextBlock

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (IContainer)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer
Container of the label

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (TextBlock)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (TextBlock)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    textBlock As TextBlock _
)

Parameters

textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (Object, IContainer)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (Object, IContainer)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    Object parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container of the label

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (Object, IContainer, TextBlock)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (Object, IContainer, TextBlock)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    Object parent,
    IContainer container,
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    textBlock As TextBlock _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container of the label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Constructor (Object, IContainer, TextBlock, LayoutStyle)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel Constructor (Object, IContainer, TextBlock, LayoutStyle)
ChartBaseLabel Class See Also Send Feedback
Create new instance of ChartBaseLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel(
    Object parent,
    IContainer container,
    TextBlock textBlock,
    LayoutStyle appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    textBlock As TextBlock, _
    appearance As LayoutStyle _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container of the label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock
appearance
Type: Telerik.Reporting.Charting.Styles..::.LayoutStyle
Style of label

See Also

ChartBaseLabel Class
ChartBaseLabel Overload
Telerik.Reporting.Charting Namespace


ChartBaseLabel Fields

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel Fields
ChartBaseLabel Class See Also Send Feedback

The ChartBaseLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property)
chartBaseLabelParent | Parent element
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


chartBaseLabelActiveRegion Field

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.chartBaseLabelActiveRegion Field
ChartBaseLabel Class See Also Send Feedback
Active region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ActiveRegion chartBaseLabelActiveRegion
Visual Basic (Declaration)
Protected chartBaseLabelActiveRegion As ActiveRegion

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


chartBaseLabelOrderList Field

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.chartBaseLabelOrderList Field
ChartBaseLabel Class See Also Send Feedback
List, that represent the render order for taken up elements (For IContainer.OrderList property)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected List<IOrdering> chartBaseLabelOrderList
Visual Basic (Declaration)
Protected chartBaseLabelOrderList As List(Of IOrdering)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


chartBaseLabelParent Field

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.chartBaseLabelParent Field
ChartBaseLabel Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Object chartBaseLabelParent
Visual Basic (Declaration)
Protected chartBaseLabelParent As Object

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ChartBaseLabel Methods

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel Methods
ChartBaseLabel Class See Also Send Feedback

The ChartBaseLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Load ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Save to ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Add Method
ChartBaseLabel Class See Also Send Feedback
Add element at the end of list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Add ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Add(IOrdering)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Clone Method
ChartBaseLabel Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

New instance of ChartBaseLabel class with the same fields as this object

Implements

ICloneable..::.Clone()()()

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Dispose Method
ChartBaseLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutElement..::.Dispose(Boolean).)

See Also

ChartBaseLabel Class
ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Dispose Method (Boolean)
ChartBaseLabel Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartBaseLabel Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.GetOrder Method
ChartBaseLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position

See Also

ChartBaseLabel Class
ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method (IOrdering)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.GetOrder Method (IOrdering)
ChartBaseLabel Class See Also Send Feedback
Gets elements order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetOrder(
    IOrdering element
)
Visual Basic (Declaration)
Public Function GetOrder ( _
    element As IOrdering _
) As Integer

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.GetOrder(IOrdering)

See Also

ChartBaseLabel Class
GetOrder Overload
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Insert Method
ChartBaseLabel Class See Also Send Feedback
Insert element at specific position in list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Insert(
    int order,
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Insert ( _
    order As Integer, _
    element As IOrdering _
)

Parameters

order
Type: System..::.Int32
Position
element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Insert(Int32, IOrdering)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.LoadViewState Method
ChartBaseLabel Class See Also Send Feedback
Load ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ReIndex Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.ReIndex Method
ChartBaseLabel Class See Also Send Feedback
Re-index order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ReIndex()
Visual Basic (Declaration)
Public Sub ReIndex

Implements

IContainer..::.ReIndex()()()

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Remove Method
ChartBaseLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list

See Also

ChartBaseLabel Class
ChartBaseLabel Members
Telerik.Reporting.Charting Namespace


Remove Method (IOrdering)

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Remove Method (IOrdering)
ChartBaseLabel Class See Also Send Feedback
Remove element from list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Remove ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Remove(IOrdering)

See Also

ChartBaseLabel Class
Remove Overload
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.RemoveAt Method
ChartBaseLabel Class See Also Send Feedback
Remove element from list by it's index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Position

Implements

IContainer..::.RemoveAt(Int32)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.SaveViewState Method
ChartBaseLabel Class See Also Send Feedback
Save to ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.TrackViewState Method
ChartBaseLabel Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ChartBaseLabel Properties

[image] [image]

Telerik Reporting Q2 2012
ChartBaseLabel Properties
ChartBaseLabel Class See Also Send Feedback

The ChartBaseLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label
NextPosition | Gets a next free order position
OrderList | List, that represent the render order for taken up elements
Parent | Gets and sets Parent element
TextBlock | ChartLabel TextBlock
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.ActiveRegion Property
ChartBaseLabel Class See Also Send Feedback
Gets and sets Active region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ActiveRegion ActiveRegion { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion

Field Value

Active region to set

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Marker Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Marker Property
ChartBaseLabel Class See Also Send Feedback
Graphic marker of label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarker Marker { get; }
Visual Basic (Declaration)
Public ReadOnly Property Marker As ChartMarker

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


NextPosition Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.NextPosition Property
ChartBaseLabel Class See Also Send Feedback
Gets a next free order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int NextPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextPosition As Integer

Implements

IContainer..::.NextPosition

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


OrderList Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.OrderList Property
ChartBaseLabel Class See Also Send Feedback
List, that represent the render order for taken up elements

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List<IOrdering> OrderList { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrderList As List(Of IOrdering)

Implements

IContainer..::.OrderList

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Parent Property
ChartBaseLabel Class See Also Send Feedback
Gets and sets Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object

Field Value

Element that should be Parent for this

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


TextBlock Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.TextBlock Property
ChartBaseLabel Class See Also Send Feedback
ChartLabel TextBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual TextBlock TextBlock { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property TextBlock As TextBlock

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartBaseLabel..::.Visible Property
ChartBaseLabel Class See Also Send Feedback
Gets and sets label's visibility

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean

Field Value

Visible label or not

See Also

ChartBaseLabel Class
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Class

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs Class
Members See Also Send Feedback
Event arguments when a chart element is clicked.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartClickEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ChartClickEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting.Charting..::.ChartClickEventArgs

See Also

ChartClickEventArgs Members
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ChartClickEventArgs Members
ChartClickEventArgs Class Constructors Properties See Also Send Feedback

The ChartClickEventArgs type exposes the following members.

Constructors

Name | Description
ChartClickEventArgs | Overloaded.

Properties

Name | Description
Element | Reverse link to a parent
Series | Chart series
SeriesItem | Chart Series Item

See Also

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartClickEventArgs Constructor
ChartClickEventArgs Class See Also Send Feedback

Overload List

Name | Description
ChartClickEventArgs(IActiveRegion) | Create instance of the class
ChartClickEventArgs(IActiveRegion, ChartSeries) | Create instance of the class
ChartClickEventArgs(IActiveRegion, ChartSeries, ChartSeriesItem) | Create instance of the class

See Also

ChartClickEventArgs Class
ChartClickEventArgs Members
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Constructor ()

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs Constructor ()
ChartClickEventArgs Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartClickEventArgs(
    IActiveRegion element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As IActiveRegion _
)

Parameters

element
Type: IActiveRegion
Parent object

See Also

ChartClickEventArgs Class
ChartClickEventArgs Overload
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Constructor (, ChartSeries)

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs Constructor (, ChartSeries)
ChartClickEventArgs Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartClickEventArgs(
    IActiveRegion element,
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    element As IActiveRegion, _
    series As ChartSeries _
)

Parameters

element
Type: IActiveRegion
Parent object
series
Type: Telerik.Reporting.Charting..::.ChartSeries
series

See Also

ChartClickEventArgs Class
ChartClickEventArgs Overload
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Constructor (, ChartSeries, ChartSeriesItem)

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs Constructor (, ChartSeries, ChartSeriesItem)
ChartClickEventArgs Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartClickEventArgs(
    IActiveRegion element,
    ChartSeries series,
    ChartSeriesItem seriesItem
)
Visual Basic (Declaration)
Public Sub New ( _
    element As IActiveRegion, _
    series As ChartSeries, _
    seriesItem As ChartSeriesItem _
)

Parameters

element
Type: IActiveRegion
Parent object
series
Type: Telerik.Reporting.Charting..::.ChartSeries
series
seriesItem
Type: Telerik.Reporting.Charting..::.ChartSeriesItem
series item

See Also

ChartClickEventArgs Class
ChartClickEventArgs Overload
Telerik.Reporting.Charting Namespace


ChartClickEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ChartClickEventArgs Properties
ChartClickEventArgs Class See Also Send Feedback

The ChartClickEventArgs type exposes the following members.

Properties

Name | Description
Element | Reverse link to a parent
Series | Chart series
SeriesItem | Chart Series Item

See Also

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


Element Property

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs..::.Element Property
ChartClickEventArgs Class See Also Send Feedback
Reverse link to a parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IActiveRegion Element { get; set; }
Visual Basic (Declaration)
Public Property Element As IActiveRegion

See Also

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


Series Property

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs..::.Series Property
ChartClickEventArgs Class See Also Send Feedback
Chart series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries Series { get; set; }
Visual Basic (Declaration)
Public Property Series As ChartSeries

See Also

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


SeriesItem Property

[image]

Telerik Reporting Q2 2012
ChartClickEventArgs..::.SeriesItem Property
ChartClickEventArgs Class See Also Send Feedback
Chart Series Item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem SeriesItem { get; set; }
Visual Basic (Declaration)
Public Property SeriesItem As ChartSeriesItem

See Also

ChartClickEventArgs Class
Telerik.Reporting.Charting Namespace


ChartDataTable Class

[image]

Telerik Reporting Q2 2012
ChartDataTable Class
Members See Also Send Feedback
DataTable. Shows the series data in a tabular format.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartDataTable : LayoutElement
Visual Basic (Declaration)
Public Class ChartDataTable _
    Inherits LayoutElement

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartDataTable

See Also

ChartDataTable Members
Telerik.Reporting.Charting Namespace


ChartDataTable Members

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable Members
ChartDataTable Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartDataTable type exposes the following members.

Constructors

Name | Description
ChartDataTable | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
Appearance | Appearance options
Container | Link to container element (Inherited from RenderedObject.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility of DataTable

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartDataTable Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable Constructor
ChartDataTable Class See Also Send Feedback

Overload List

Name | Description
ChartDataTable(ChartPlotArea) | Create new instance of ChartDataTable class
ChartDataTable(ChartPlotArea, IContainer) | Create new instance of ChartDataTable class

See Also

ChartDataTable Class
ChartDataTable Members
Telerik.Reporting.Charting Namespace


ChartDataTable Constructor (ChartPlotArea)

[image]

Telerik Reporting Q2 2012
ChartDataTable Constructor (ChartPlotArea)
ChartDataTable Class See Also Send Feedback
Create new instance of ChartDataTable class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartDataTable(
    ChartPlotArea plotArea
)
Visual Basic (Declaration)
Public Sub New ( _
    plotArea As ChartPlotArea _
)

Parameters

plotArea
Type: Telerik.Reporting.Charting..::.ChartPlotArea
PlotArea to which DataTable is related to

See Also

ChartDataTable Class
ChartDataTable Overload
Telerik.Reporting.Charting Namespace


ChartDataTable Constructor (ChartPlotArea, IContainer)

[image]

Telerik Reporting Q2 2012
ChartDataTable Constructor (ChartPlotArea, IContainer)
ChartDataTable Class See Also Send Feedback
Create new instance of ChartDataTable class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartDataTable(
    ChartPlotArea plotArea,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    plotArea As ChartPlotArea, _
    container As IContainer _
)

Parameters

plotArea
Type: Telerik.Reporting.Charting..::.ChartPlotArea
PlotArea to which DataTable is related to
container
Type: Telerik.Reporting.Charting..::.IContainer
Container of DataTable

See Also

ChartDataTable Class
ChartDataTable Overload
Telerik.Reporting.Charting Namespace


ChartDataTable Fields

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable Fields
ChartDataTable Class See Also Send Feedback

The ChartDataTable type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartDataTable Methods

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable Methods
ChartDataTable Class See Also Send Feedback

The ChartDataTable type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable..::.Dispose Method
ChartDataTable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

ChartDataTable Class
ChartDataTable Members
Telerik.Reporting.Charting Namespace


ChartDataTable Properties

[image] [image]

Telerik Reporting Q2 2012
ChartDataTable Properties
ChartDataTable Class See Also Send Feedback

The ChartDataTable type exposes the following members.

Properties

Name | Description
Appearance | Appearance options
Container | Link to container element (Inherited from RenderedObject.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility of DataTable

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartDataTable..::.Appearance Property
ChartDataTable Class See Also Send Feedback
Appearance options

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChartDataTable Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleChartDataTable

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartDataTable..::.Visible Property
ChartDataTable Class See Also Send Feedback
Visibility of DataTable

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ChartDataTable Class
Telerik.Reporting.Charting Namespace


ChartElementLocation Enumeration

[image]

Telerik Reporting Q2 2012
ChartElementLocation Enumeration
See Also Send Feedback
Specifies the location of the RadChart's elements.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartElementLocation
Visual Basic (Declaration)
Public Enumeration ChartElementLocation

Members

Member name | Description
InsidePlotArea | The chart element is placed inside plot area.
OutsidePlotArea | The chart element is placed outside plot area.

See Also

Telerik.Reporting.Charting Namespace


ChartingStateManagedCollection(T) Class

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Base class for all collections support view state tracking

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ChartingStateManagedCollection<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IChartingStateManager, IList, ICollection,
    IEnumerable
where T : class, new(), IChartingStateManagedItem
Visual Basic (Declaration)
Public MustInherit Class ChartingStateManagedCollection(Of T As {Class, New, IChartingStateManagedItem}) _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IChartingStateManager, IList, ICollection, IEnumerable

Type Parameters

T
Collection item type

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection<(Of <(T>)>)
Telerik.Reporting.Charting..::.AxisSegmentCollection
Telerik.Reporting.Charting..::.ChartAxisItemsCollection
Telerik.Reporting.Charting..::.ChartLabelsCollection
Telerik.Reporting.Charting..::.ChartMarkedZonesCollection
Telerik.Reporting.Charting..::.ChartSeriesCollection
Telerik.Reporting.Charting..::.ChartSeriesItemsCollection
Telerik.Reporting.Charting..::.ColorBlend
Telerik.Reporting.Charting..::.CustomFiguresCollection
Telerik.Reporting.Charting..::.CustomPalettesCollection
Telerik.Reporting.Charting..::.PaletteItemsCollection

See Also

ChartingStateManagedCollection<(Of <(T>)>) Members
Telerik.Reporting.Charting Namespace


ChartingStateManagedCollection(T) Members

[image] [image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)> Members
ChartingStateManagedCollection<(Of <(T>)>) Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartingStateManagedCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
ChartingStateManagedCollection<(Of <(T>)>) | Initializes a new instance of the ChartingStateManagedCollection<(Of <(T>)>) class

Methods

Name | Description
Add | Adds new item in collection
AddRange | Adds items range in collection
Clear | Clears collection
Contains | Checks does collection contain the given item
CopyTo |
GetEnumerator |
IndexOf | Item index in collection
Insert | Inserts item at the given index
LoadViewState | Loads collection from view state
OnClear | Before collection clearing event
OnClearComplete | Collection after clean event
OnInsert | Item before insert event
OnInsertComplete | Item after insert event
OnRemove | Item before remove event
OnRemoveComplete | Item after remove event
Remove | Removes item from collection
RemoveAt | Removes item from collection at given index
SaveViewState | Saves collection to a view state
SetItemDirty | Marks collection item dirty

Properties

Name | Description
Count | Gets items count in collection
IsReadOnly | Gets true if collection is read-only
Item | Gets the collection item at given index
List | Items list

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList
IList..::.Clear | Clears IList items
IList..::.Contains | Checks does IList contain the given value
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array.
ICollection..::.Count | Gets the collection items count
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection
IList..::.IndexOf | Gets the index of the object value in an IList
IList..::.Insert | Inserts new value in IList at given index
IList..::.IsFixedSize | Is IList fixed size. Returns False
IList..::.IsReadOnly | Is IList is read-only
ICollection..::.IsSynchronized | Checks is collection synchronized
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status
IList..::.Item | Gets or sets the value from/to IList at the give index
IChartingStateManager..::.LoadViewState | Loads collection from view state
IList..::.Remove | Removes value from IList
IList..::.RemoveAt | Removes value from IList at the given index
IChartingStateManager..::.SaveViewState | Saves collection to a view state
ICollection..::.SyncRoot | Gets the collection root
IChartingStateManager..::.TrackViewState | Tracks view state changes

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ChartingStateManagedCollection(T) Constructor

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)> Constructor
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Initializes a new instance of the ChartingStateManagedCollection<(Of <(T>)>) class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartingStateManagedCollection()
Visual Basic (Declaration)
Protected Sub New

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ChartingStateManagedCollection(T) Methods

[image] [image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)> Methods
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback

The ChartingStateManagedCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Adds new item in collection
AddRange | Adds items range in collection
Clear | Clears collection
Contains | Checks does collection contain the given item
CopyTo |
GetEnumerator |
IndexOf | Item index in collection
Insert | Inserts item at the given index
LoadViewState | Loads collection from view state
OnClear | Before collection clearing event
OnClearComplete | Collection after clean event
OnInsert | Item before insert event
OnInsertComplete | Item after insert event
OnRemove | Item before remove event
OnRemoveComplete | Item after remove event
Remove | Removes item from collection
RemoveAt | Removes item from collection at given index
SaveViewState | Saves collection to a view state
SetItemDirty | Marks collection item dirty

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList
IList..::.Clear | Clears IList items
IList..::.Contains | Checks does IList contain the given value
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array.
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection
IList..::.IndexOf | Gets the index of the object value in an IList
IList..::.Insert | Inserts new value in IList at given index
IChartingStateManager..::.LoadViewState | Loads collection from view state
IList..::.Remove | Removes value from IList
IList..::.RemoveAt | Removes value from IList at the given index
IChartingStateManager..::.SaveViewState | Saves collection to a view state
IChartingStateManager..::.TrackViewState | Tracks view state changes

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Add Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Add Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Adds new item in the IList

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int IList.Add(
    Object value
)
Visual Basic (Declaration)
Private Function Add ( _
    value As Object _
) As Integer Implements IList.Add

Parameters

value
Type: System..::.Object
Item to add

Return Value

Item index in IList

Implements

IList..::.Add(Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Clear Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Clear Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Clears IList items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IList.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements IList.Clear

Implements

IList..::.Clear()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Contains Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Contains Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Checks does IList contain the given value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IList.Contains(
    Object value
)
Visual Basic (Declaration)
Private Function Contains ( _
    value As Object _
) As Boolean Implements IList.Contains

Parameters

value
Type: System..::.Object
Value to check

Return Value

True if contains

Implements

IList..::.Contains(Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ICollection.CopyTo Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.ICollection..::.CopyTo Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ICollection.CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo

Parameters

array
Type: System..::.Array
The one-dimensional System.Array that is the destination of the elements
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IEnumerable.GetEnumerator Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IEnumerable..::.GetEnumerator Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Returns an enumerator that iterates through the collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Return Value

An System.Collections.IEnumerator object that can be used to iterate through the collection

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.IndexOf Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.IndexOf Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets the index of the object value in an IList

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int IList.IndexOf(
    Object value
)
Visual Basic (Declaration)
Private Function IndexOf ( _
    value As Object _
) As Integer Implements IList.IndexOf

Parameters

value
Type: System..::.Object
Value to check

Return Value

Index in IList or -1 if IList does not contain given value

Implements

IList..::.IndexOf(Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Insert Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Insert Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Inserts new value in IList at given index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IList.Insert(
    int index,
    Object value
)
Visual Basic (Declaration)
Private Sub Insert ( _
    index As Integer, _
    value As Object _
) Implements IList.Insert

Parameters

index
Type: System..::.Int32
Index to insert to
value
Type: System..::.Object
Value to insert

Implements

IList..::.Insert(Int32, Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Remove Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Remove Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Removes value from IList

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IList.Remove(
    Object value
)
Visual Basic (Declaration)
Private Sub Remove ( _
    value As Object _
) Implements IList.Remove

Parameters

value
Type: System..::.Object
Value to remove

Implements

IList..::.Remove(Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.RemoveAt Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Removes value from IList at the given index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IList.RemoveAt(
    int index
)
Visual Basic (Declaration)
Private Sub RemoveAt ( _
    index As Integer _
) Implements IList.RemoveAt

Parameters

index
Type: System..::.Int32
Index to remove value at

Implements

IList..::.RemoveAt(Int32)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Add Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Adds new item in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void Add(
    T item
)
Visual Basic (Declaration)
Public Overridable Sub Add ( _
    item As T _
)

Parameters

item
Type: T
Item to add

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.AddRange Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Adds items range in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void AddRange(
    T[] itemsToAdd
)
Visual Basic (Declaration)
Public Overridable Sub AddRange ( _
    itemsToAdd As T() _
)

Parameters

itemsToAdd
Type: array< T >[]()[][]
Items array to add

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Clear Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Clears collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Contains Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Checks does collection contain the given item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Contains(
    T item
)
Visual Basic (Declaration)
Public Overridable Function Contains ( _
    item As T _
) As Boolean

Parameters

item
Type: T
Item to check

Return Value

True if item is a collection member

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


CopyTo Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.CopyTo Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CopyTo(
    T[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    arrayIndex As Integer _
)

Parameters

array
Type: array< T >[]()[][]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


GetEnumerator Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.GetEnumerator Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of T)

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IChartingStateManager..::.LoadViewState Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Loads collection from view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IChartingStateManager.LoadViewState(
    Object state
)
Visual Basic (Declaration)
Private Sub LoadViewState ( _
    state As Object _
) Implements IChartingStateManager.LoadViewState

Parameters

state
Type: System..::.Object
View state to load from

Implements

IChartingStateManager..::.LoadViewState(Object)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IChartingStateManager..::.SaveViewState Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Saves collection to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object IChartingStateManager.SaveViewState()
Visual Basic (Declaration)
Private Function SaveViewState As Object
    Implements IChartingStateManager.SaveViewState

Return Value

Saved state bag object

Implements

IChartingStateManager..::.SaveViewState()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IChartingStateManager..::.TrackViewState Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IChartingStateManager.TrackViewState()
Visual Basic (Declaration)
Private Sub TrackViewState Implements IChartingStateManager.TrackViewState

Implements

IChartingStateManager..::.TrackViewState()()()

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IndexOf Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IndexOf Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Item index in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    T item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As T _
) As Integer

Parameters

item
Type: T
Item to get index of

Return Value

Index

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Insert Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Inserts item at the given index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void Insert(
    int index,
    T item
)
Visual Basic (Declaration)
Public Overridable Sub Insert ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::.Int32
Index
item
Type: T
Item to insert

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.LoadViewState Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Loads collection from view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Protected Overridable Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
View state to load from

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnClear Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnClear Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Before collection clearing event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnClear()
Visual Basic (Declaration)
Protected Overridable Sub OnClear

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnClearComplete Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnClearComplete Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Collection after clean event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnClearComplete()
Visual Basic (Declaration)
Protected Overridable Sub OnClearComplete

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnInsert Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnInsert Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Item before insert event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overridable Sub OnInsert ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index to insert at
value
Type: System..::.Object
Value to insert

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnInsertComplete Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnInsertComplete Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Item after insert event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overridable Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index to insert at
value
Type: System..::.Object
Value to insert

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnRemove Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnRemove Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Item before remove event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overridable Sub OnRemove ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index to insert at
value
Type: System..::.Object
Value to insert

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


OnRemoveComplete Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.OnRemoveComplete Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Item after remove event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overridable Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index to insert at
value
Type: System..::.Object
Value to insert

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Remove Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Removes item from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Remove(
    T item
)
Visual Basic (Declaration)
Public Overridable Function Remove ( _
    item As T _
) As Boolean

Parameters

item
Type: T
Item to remove

Return Value

True in case of success

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.RemoveAt Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Removes item from collection at given index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Overridable Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Index to remove at

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.SaveViewState Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Saves collection to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual Object SaveViewState()
Visual Basic (Declaration)
Protected Overridable Function SaveViewState As Object

Return Value

Saved state bag object

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


SetItemDirty Method

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.SetItemDirty Method
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Marks collection item dirty

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void SetItemDirty(
    T item
)
Visual Basic (Declaration)
Protected Overridable Sub SetItemDirty ( _
    item As T _
)

Parameters

item
Type: T
Item to mark

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ChartingStateManagedCollection(T) Properties

[image] [image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)> Properties
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback

The ChartingStateManagedCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection
IsReadOnly | Gets true if collection is read-only
Item | Gets the collection item at given index
List | Items list

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count
IList..::.IsFixedSize | Is IList fixed size. Returns False
IList..::.IsReadOnly | Is IList is read-only
ICollection..::.IsSynchronized | Checks is collection synchronized
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status
IList..::.Item | Gets or sets the value from/to IList at the give index
ICollection..::.SyncRoot | Gets the collection root

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ICollection.Count Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.ICollection..::.Count Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets the collection items count

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ICollection.Count { get; }
Visual Basic (Declaration)
Private ReadOnly Property Count As Integer
    Implements ICollection.Count

Implements

ICollection..::.Count

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.IsFixedSize Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.IsFixedSize Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Is IList fixed size. Returns False

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IList.IsFixedSize { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsFixedSize As Boolean
    Implements IList.IsFixedSize

Implements

IList..::.IsFixedSize

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.IsReadOnly Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.IsReadOnly Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Is IList is read-only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IList.IsReadOnly { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsReadOnly As Boolean
    Implements IList.IsReadOnly

Implements

IList..::.IsReadOnly

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ICollection.IsSynchronized Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.ICollection..::.IsSynchronized Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Checks is collection synchronized

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool ICollection.IsSynchronized { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized

Implements

ICollection..::.IsSynchronized

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IList.Item Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IList..::.Item Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets or sets the value from/to IList at the give index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object IList.Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    index As Integer _
) As Object Implements IList.Item

Parameters

index
Type: System..::.Int32
Index to give element at

Return Value

Value from IList

Implements

IList..::.Item[([(Int32])])

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ICollection.SyncRoot Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.ICollection..::.SyncRoot Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets the collection root

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICollection.SyncRoot { get; }
Visual Basic (Declaration)
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot

Implements

ICollection..::.SyncRoot

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Count Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Count Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets items count in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.IsTrackingViewState Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IChartingStateManager..::.IsTrackingViewState Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets the view state tracking status

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IChartingStateManager.IsTrackingViewState { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsTrackingViewState As Boolean
    Implements IChartingStateManager.IsTrackingViewState

Implements

IChartingStateManager..::.IsTrackingViewState

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


IsReadOnly Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.IsReadOnly Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets true if collection is read-only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.Item Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Gets the collection item at given index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual T this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overridable Default Property Item ( _
    index As Integer _
) As T

Parameters

index
Type: System..::.Int32
Index

Return Value

Item of type "T"

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


List Property

[image]

Telerik Reporting Q2 2012
ChartingStateManagedCollection<(Of <(<'T>)>)>..::.List Property
ChartingStateManagedCollection<(Of <(T>)>) Class See Also Send Feedback
Items list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected IList<T> List { get; }
Visual Basic (Declaration)
Protected ReadOnly Property List As IList(Of T)

See Also

ChartingStateManagedCollection<(Of <(T>)>) Class
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Class

[image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs Class
Members See Also Send Feedback
Class containing event data for an ItemDataBound event

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartItemDataBoundEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ChartItemDataBoundEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting.Charting..::.ChartItemDataBoundEventArgs

See Also

ChartItemDataBoundEventArgs Members
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs Members
ChartItemDataBoundEventArgs Class Constructors Properties See Also Send Feedback

The ChartItemDataBoundEventArgs type exposes the following members.

Constructors

Name | Description
ChartItemDataBoundEventArgs | Class constructor

Properties

Name | Description
ChartSeries | Chart series
DataItem | Real data source object for a chart.
SeriesItem | Series item

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Constructor

[image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs Constructor
ChartItemDataBoundEventArgs Class See Also Send Feedback
Class constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartItemDataBoundEventArgs(
    ChartSeriesItem seriesItem,
    ChartSeries chartSeries,
    Object dataItem
)
Visual Basic (Declaration)
Public Sub New ( _
    seriesItem As ChartSeriesItem, _
    chartSeries As ChartSeries, _
    dataItem As Object _
)

Parameters

seriesItem
Type: Telerik.Reporting.Charting..::.ChartSeriesItem
Data bound series item
chartSeries
Type: Telerik.Reporting.Charting..::.ChartSeries
Parent series
dataItem
Type: System..::.Object
Current data source object

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartItemDataBoundEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs Properties
ChartItemDataBoundEventArgs Class See Also Send Feedback

The ChartItemDataBoundEventArgs type exposes the following members.

Properties

Name | Description
ChartSeries | Chart series
DataItem | Real data source object for a chart.
SeriesItem | Series item

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartSeries Property

[image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs..::.ChartSeries Property
ChartItemDataBoundEventArgs Class See Also Send Feedback
Chart series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries ChartSeries { get; set; }
Visual Basic (Declaration)
Public Property ChartSeries As ChartSeries

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


DataItem Property

[image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs..::.DataItem Property
ChartItemDataBoundEventArgs Class See Also Send Feedback
Real data source object for a chart.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataItem { get; set; }
Visual Basic (Declaration)
Public Property DataItem As Object

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


SeriesItem Property

[image]

Telerik Reporting Q2 2012
ChartItemDataBoundEventArgs..::.SeriesItem Property
ChartItemDataBoundEventArgs Class See Also Send Feedback
Series item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem SeriesItem { get; set; }
Visual Basic (Declaration)
Public Property SeriesItem As ChartSeriesItem

See Also

ChartItemDataBoundEventArgs Class
Telerik.Reporting.Charting Namespace


ChartLabel Class

[image]

Telerik Reporting Q2 2012
ChartLabel Class
Members See Also Send Feedback
Base class for labels with style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartLabel : ChartBaseLabel
Visual Basic (Declaration)
Public Class ChartLabel _
    Inherits ChartBaseLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.AxisLabelHidden
Telerik.Reporting.Charting..::.ChartAxisItem
Telerik.Reporting.Charting..::.ChartTitle
Telerik.Reporting.Charting..::.EmptySeriesMessage
Telerik.Reporting.Charting..::.LabelItem
Telerik.Reporting.Charting..::.MarkedZoneLabel

See Also

ChartLabel Members
Telerik.Reporting.Charting Namespace


ChartLabel Members

[image] [image]

Telerik Reporting Q2 2012
ChartLabel Members
ChartLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartLabel type exposes the following members.

Constructors

Name | Description
ChartLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartLabel Constructor
ChartLabel Class See Also Send Feedback

Overload List

Name | Description
ChartLabel()()() | Create new instance of ChartLabel class
ChartLabel(Object) | Create new instance of ChartLabel class.
ChartLabel(String) | Create new instance of ChartLabel class.
ChartLabel(StyleLabel) | Create new instance of ChartLabel class.
ChartLabel(Chart, IContainer) | Create new instance of ChartLabel class.
ChartLabel(StyleLabel, Object) | Create new instance of ChartLabel class.
ChartLabel(StyleLabel, String) | Create new instance of ChartLabel class.
ChartLabel(StyleLabel, TextBlock) | Create new instance of ChartLabel class.
ChartLabel(StyleLabel, TextBlock, Object) | Create new instance of ChartLabel class.
ChartLabel(Object, IContainer, StyleLabel, TextBlock, String) | Create new instance of ChartLabel class.

See Also

ChartLabel Class
ChartLabel Members
Telerik.Reporting.Charting Namespace


ChartLabel Constructor

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel()
Visual Basic (Declaration)
Public Sub New

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (Object)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (Object)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent Element

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (String)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text of label

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (StyleLabel)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (StyleLabel)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    StyleLabel appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (Chart, IContainer)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (Chart, IContainer)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    Chart parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (StyleLabel, Object)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (StyleLabel, Object)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    StyleLabel appearance,
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    parent As Object _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
parent
Type: System..::.Object
Parent element

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (StyleLabel, String)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (StyleLabel, String)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    StyleLabel appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
text
Type: System..::.String
Text

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (StyleLabel, TextBlock)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (StyleLabel, TextBlock)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    StyleLabel appearance,
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    textBlock As TextBlock _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock of label

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (StyleLabel, TextBlock, Object)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (StyleLabel, TextBlock, Object)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    StyleLabel appearance,
    TextBlock textBlock,
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    textBlock As TextBlock, _
    parent As Object _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock of label
parent
Type: System..::.Object
Parent element

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Constructor (Object, IContainer, StyleLabel, TextBlock, String)

[image]

Telerik Reporting Q2 2012
ChartLabel Constructor (Object, IContainer, StyleLabel, TextBlock, String)
ChartLabel Class See Also Send Feedback
Create new instance of ChartLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel(
    Object parent,
    IContainer container,
    StyleLabel appearance,
    TextBlock textBlock,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    appearance As StyleLabel, _
    textBlock As TextBlock, _
    text As String _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of chart
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock of label
text
Type: System..::.String
Text of label

See Also

ChartLabel Class
ChartLabel Overload
Telerik.Reporting.Charting Namespace


ChartLabel Fields

[image] [image]

Telerik Reporting Q2 2012
ChartLabel Fields
ChartLabel Class See Also Send Feedback

The ChartLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLabel Methods

[image] [image]

Telerik Reporting Q2 2012
ChartLabel Methods
ChartLabel Class See Also Send Feedback

The ChartLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartLabel..::.Dispose Method
ChartLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

ChartLabel Class
ChartLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartLabel..::.GetOrder Method
ChartLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

ChartLabel Class
ChartLabel Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartLabel..::.Remove Method
ChartLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

ChartLabel Class
ChartLabel Members
Telerik.Reporting.Charting Namespace


ChartLabel Properties

[image] [image]

Telerik Reporting Q2 2012
ChartLabel Properties
ChartLabel Class See Also Send Feedback

The ChartLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartLabel..::.Appearance Property
ChartLabel Class See Also Send Feedback
Link to visualization and design properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleLabel Appearance { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Appearance As StyleLabel

See Also

ChartLabel Class
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Class

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection Class
Members See Also Send Feedback
Collection of labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartLabelsCollection : ChartingStateManagedCollection<LabelItem>
Visual Basic (Declaration)
Public Class ChartLabelsCollection _
    Inherits ChartingStateManagedCollection(Of LabelItem)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' LabelItem >)>)>
Telerik.Reporting.Charting..::.ChartLabelsCollection

See Also

ChartLabelsCollection Members
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Members

[image] [image]

Telerik Reporting Q2 2012
ChartLabelsCollection Members
ChartLabelsCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartLabelsCollection type exposes the following members.

Constructors

Name | Description
ChartLabelsCollection | Create new instance of ChartLabelsCollection class.

Methods

Name | Description
Add | Add LabelItem at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clear collection
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert LabelItem in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
LoadViewState | Load data from ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Clear items (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnClearComplete()()().)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Insert item in collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnInsertComplete(Int32, Object).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Remove item at specified index (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnRemoveComplete(Int32, Object).)
Remove | Remove LabelItem from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Remove(T).)
RemoveAt | Remove LabelItem in the specific position from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.RemoveAt(Int32).)
SaveViewState | Save data to ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.SaveViewState()()().)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a LabelItem at the specific position in Labels collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Constructor

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection Constructor
ChartLabelsCollection Class See Also Send Feedback
Create new instance of ChartLabelsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabelsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ChartLabelsCollection Methods
ChartLabelsCollection Class See Also Send Feedback

The ChartLabelsCollection type exposes the following members.

Methods

Name | Description
Add | Add LabelItem at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clear collection
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert LabelItem in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
LoadViewState | Load data from ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Clear items (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnClearComplete()()().)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Insert item in collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnInsertComplete(Int32, Object).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Remove item at specified index (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnRemoveComplete(Int32, Object).)
Remove | Remove LabelItem from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Remove(T).)
RemoveAt | Remove LabelItem in the specific position from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.RemoveAt(Int32).)
SaveViewState | Save data to ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.SaveViewState()()().)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Add Method
ChartLabelsCollection Class See Also Send Feedback
Add LabelItem at the collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    LabelItem item
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    item As LabelItem _
)

Parameters

item
Type: Telerik.Reporting.Charting..::.LabelItem
LabelItem for adding

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Clear Method
ChartLabelsCollection Class See Also Send Feedback
Clear collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Insert Method
ChartLabelsCollection Class See Also Send Feedback
Insert LabelItem in collection at the specific position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Insert(
    int index,
    LabelItem item
)
Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    item As LabelItem _
)

Parameters

index
Type: System..::.Int32
Position
item
Type: Telerik.Reporting.Charting..::.LabelItem
LabelItem

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.LoadViewState Method
ChartLabelsCollection Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
ViewState with data

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


OnClearComplete Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.OnClearComplete Method
ChartLabelsCollection Class See Also Send Feedback
Clear items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnClearComplete()
Visual Basic (Declaration)
Protected Overrides Sub OnClearComplete

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


OnInsertComplete Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.OnInsertComplete Method
ChartLabelsCollection Class See Also Send Feedback
Insert item in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index to insert in
value
Type: System..::.Object
Value to insert

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


OnRemoveComplete Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.OnRemoveComplete Method
ChartLabelsCollection Class See Also Send Feedback
Remove item at specified index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Remove Method
ChartLabelsCollection Class See Also Send Feedback
Remove LabelItem from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Remove(
    LabelItem item
)
Visual Basic (Declaration)
Public Overrides Function Remove ( _
    item As LabelItem _
) As Boolean

Parameters

item
Type: Telerik.Reporting.Charting..::.LabelItem
LabelItem

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.RemoveAt Method
ChartLabelsCollection Class See Also Send Feedback
Remove LabelItem in the specific position from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Overrides Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Position

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.SaveViewState Method
ChartLabelsCollection Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


ChartLabelsCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ChartLabelsCollection Properties
ChartLabelsCollection Class See Also Send Feedback

The ChartLabelsCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a LabelItem at the specific position in Labels collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Item Property
ChartLabelsCollection Class See Also Send Feedback
Gets or sets a LabelItem at the specific position in Labels collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override LabelItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As LabelItem

Parameters

index
Type: System..::.Int32
Position in the collection

Return Value

LabelItem at the specific position

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartLabelsCollection..::.Parent Property
ChartLabelsCollection Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object

See Also

ChartLabelsCollection Class
Telerik.Reporting.Charting Namespace


ChartLegend Class

[image]

Telerik Reporting Q2 2012
ChartLegend Class
Members See Also Send Feedback
Chart legend. Shows the series names or series labels listing. Can contains custom items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartLegend : ExtendedLabel
Visual Basic (Declaration)
Public Class ChartLegend _
    Inherits ExtendedLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ExtendedLabel
Telerik.Reporting.Charting..::.ChartLegend

See Also

ChartLegend Members
Telerik.Reporting.Charting Namespace


ChartLegend Members

[image] [image]

Telerik Reporting Q2 2012
ChartLegend Members
ChartLegend Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartLegend type exposes the following members.

Constructors

Name | Description
ChartLegend | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
AddCustomItemToLegend | Adds custom item to Legend
AddLabel | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clear LabelItems collection (Inherited from ExtendedLabel.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetLabel | Get inner label at specified position (Inherited from ExtendedLabel.)
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | load ViewState (Inherited from ExtendedLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAllLabels | Removes all inner labels (Inherited from ExtendedLabel.)
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
RemoveLabel | Overloaded.
SaveViewState | Save ViewState (Inherited from ExtendedLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ExtendedLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
extendedLabelItems | Inside labels collection (Inherited from ExtendedLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Gets style of label (Inherited from ExtendedLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Item | Reference to a label item by its index in items collection (Overrides ExtendedLabel..::.Item[([(Int32])]).)
Items | Items collection. (Inherited from ExtendedLabel.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


ChartLegend Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartLegend Constructor
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
ChartLegend()()() | Constructor
ChartLegend(Chart, IContainer) | Constructor

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


ChartLegend Constructor

[image]

Telerik Reporting Q2 2012
ChartLegend Constructor
ChartLegend Class See Also Send Feedback
Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLegend()
Visual Basic (Declaration)
Public Sub New

See Also

ChartLegend Class
ChartLegend Overload
Telerik.Reporting.Charting Namespace


ChartLegend Constructor (Chart, IContainer)

[image]

Telerik Reporting Q2 2012
ChartLegend Constructor (Chart, IContainer)
ChartLegend Class See Also Send Feedback
Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLegend(
    Chart parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Reference to a parent object (Current Chart instance)
container
Type: Telerik.Reporting.Charting..::.IContainer
Element container

See Also

ChartLegend Class
ChartLegend Overload
Telerik.Reporting.Charting Namespace


ChartLegend Fields

[image] [image]

Telerik Reporting Q2 2012
ChartLegend Fields
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
extendedLabelItems | Inside labels collection (Inherited from ExtendedLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


ChartLegend Methods

[image] [image]

Telerik Reporting Q2 2012
ChartLegend Methods
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
AddCustomItemToLegend | Adds custom item to Legend
AddLabel | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clear LabelItems collection (Inherited from ExtendedLabel.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetLabel | Get inner label at specified position (Inherited from ExtendedLabel.)
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | load ViewState (Inherited from ExtendedLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAllLabels | Removes all inner labels (Inherited from ExtendedLabel.)
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
RemoveLabel | Overloaded.
SaveViewState | Save ViewState (Inherited from ExtendedLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ExtendedLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


AddCustomItemToLegend Method

[image]

Telerik Reporting Q2 2012
ChartLegend..::.AddCustomItemToLegend Method
ChartLegend Class See Also Send Feedback
Adds custom item to Legend

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddCustomItemToLegend(
    string description,
    FillStyle fillStyle,
    string figure
)
Visual Basic (Declaration)
Public Sub AddCustomItemToLegend ( _
    description As String, _
    fillStyle As FillStyle, _
    figure As String _
)

Parameters

description
Type: System..::.String
Custom legend item text
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle
figure
Type: System..::.String
Figure for an item marker

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


AddLabel Method

[image] [image]

Telerik Reporting Q2 2012
ChartLegend..::.AddLabel Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
AddLabel(ChartLabelsCollection) | Add inside labels (Inherited from ExtendedLabel.)
AddLabel(List<(Of <(LabelItem>)>)) | Add inside labels (Inherited from ExtendedLabel.)
AddLabel(array<LabelItem>[]()[]) | Add inside labels (Inherited from ExtendedLabel.)
AddLabel(LabelItem, array<LabelItem>[]()[]) | Add inside labels (Inherited from ExtendedLabel.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartLegend..::.Dispose Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ExtendedLabel.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartLegend..::.GetOrder Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartLegend..::.Remove Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


RemoveLabel Method

[image] [image]

Telerik Reporting Q2 2012
ChartLegend..::.RemoveLabel Method
ChartLegend Class See Also Send Feedback

Overload List

Name | Description
RemoveLabel(Int32, array<Int32>[]()[]) | Removes inner labels (Inherited from ExtendedLabel.)
RemoveLabel(LabelItem, array<LabelItem>[]()[]) | Removes inner labels (Inherited from ExtendedLabel.)

See Also

ChartLegend Class
ChartLegend Members
Telerik.Reporting.Charting Namespace


ChartLegend Properties

[image] [image]

Telerik Reporting Q2 2012
ChartLegend Properties
ChartLegend Class See Also Send Feedback

The ChartLegend type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Gets style of label (Inherited from ExtendedLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Item | Reference to a label item by its index in items collection (Overrides ExtendedLabel..::.Item[([(Int32])]).)
Items | Items collection. (Inherited from ExtendedLabel.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartLegend..::.Item Property
ChartLegend Class See Also Send Feedback
Reference to a label item by its index in items collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override LabelItem this[
    int itemIndex
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    itemIndex As Integer _
) As LabelItem

Parameters

itemIndex
Type: System..::.Int32
Label item's index

Return Value

LabelItem at given index

See Also

ChartLegend Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Class

[image]

Telerik Reporting Q2 2012
ChartMarkedZone Class
Members See Also Send Feedback
Class describe a Marked zone functionality

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarkedZone : RenderedObject
Visual Basic (Declaration)
Public Class ChartMarkedZone _
    Inherits RenderedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartMarkedZone

See Also

ChartMarkedZone Members
Telerik.Reporting.Charting Namespace


ChartMarkedZone Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone Members
ChartMarkedZone Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarkedZone type exposes the following members.

Constructors

Name | Description
ChartMarkedZone | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data into Marked zone object (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saving Marked zone object into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ToString | Marked zone to String (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracking ViewState for Marked zone object (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
Appearance | Appearance properties
Container | Link to container element (Inherited from RenderedObject.)
Label | Marked zone label
Name | Marked zone name
ValueEndX | Marker end position X
ValueEndY | Marker end position Y
ValueStartX | Marker start position X
ValueStartY | Marker start position Y
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
YAxisType | Marked zone Y Axis type

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone Constructor
ChartMarkedZone Class See Also Send Feedback

Overload List

Name | Description
ChartMarkedZone()()() | Create a instance of object
ChartMarkedZone(String) | Create a instance of object
ChartMarkedZone(IContainer) | Create a instance of object

See Also

ChartMarkedZone Class
ChartMarkedZone Members
Telerik.Reporting.Charting Namespace


ChartMarkedZone Constructor

[image]

Telerik Reporting Q2 2012
ChartMarkedZone Constructor
ChartMarkedZone Class See Also Send Feedback
Create a instance of object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZone()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarkedZone Class
ChartMarkedZone Overload
Telerik.Reporting.Charting Namespace


ChartMarkedZone Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartMarkedZone Constructor (String)
ChartMarkedZone Class See Also Send Feedback
Create a instance of object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZone(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Name for marked zone

See Also

ChartMarkedZone Class
ChartMarkedZone Overload
Telerik.Reporting.Charting Namespace


ChartMarkedZone Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
ChartMarkedZone Constructor (IContainer)
ChartMarkedZone Class See Also Send Feedback
Create a instance of object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZone(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer
Container object

See Also

ChartMarkedZone Class
ChartMarkedZone Overload
Telerik.Reporting.Charting Namespace


ChartMarkedZone Fields

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone Fields
ChartMarkedZone Class See Also Send Feedback

The ChartMarkedZone type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone Methods
ChartMarkedZone Class See Also Send Feedback

The ChartMarkedZone type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data into Marked zone object (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saving Marked zone object into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ToString | Marked zone to String (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracking ViewState for Marked zone object (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Dispose Method
ChartMarkedZone Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

ChartMarkedZone Class
ChartMarkedZone Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Dispose Method (Boolean)
ChartMarkedZone Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartMarkedZone Class
Dispose Overload
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.LoadViewState Method
ChartMarkedZone Class See Also Send Feedback
Loading ViewState data into Marked zone object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.SaveViewState Method
ChartMarkedZone Class See Also Send Feedback
Saving Marked zone object into ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.ToString Method
ChartMarkedZone Class See Also Send Feedback
Marked zone to String

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Marked zone name

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.TrackViewState Method
ChartMarkedZone Class See Also Send Feedback
Tracking ViewState for Marked zone object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartMarkedZone Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZone Properties
ChartMarkedZone Class See Also Send Feedback

The ChartMarkedZone type exposes the following members.

Properties

Name | Description
Appearance | Appearance properties
Container | Link to container element (Inherited from RenderedObject.)
Label | Marked zone label
Name | Marked zone name
ValueEndX | Marker end position X
ValueEndY | Marker end position Y
ValueStartX | Marker start position X
ValueStartY | Marker start position Y
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
YAxisType | Marked zone Y Axis type

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Appearance Property
ChartMarkedZone Class See Also Send Feedback
Appearance properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkedZone Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleMarkedZone

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Label Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Label Property
ChartMarkedZone Class See Also Send Feedback
Marked zone label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabel Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As ChartLabel

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Name Property
ChartMarkedZone Class See Also Send Feedback
Marked zone name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ValueEndX Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.ValueEndX Property
ChartMarkedZone Class See Also Send Feedback
Marker end position X

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double ValueEndX { get; set; }
Visual Basic (Declaration)
Public Property ValueEndX As Double

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ValueEndY Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.ValueEndY Property
ChartMarkedZone Class See Also Send Feedback
Marker end position Y

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double ValueEndY { get; set; }
Visual Basic (Declaration)
Public Property ValueEndY As Double

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ValueStartX Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.ValueStartX Property
ChartMarkedZone Class See Also Send Feedback
Marker start position X

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double ValueStartX { get; set; }
Visual Basic (Declaration)
Public Property ValueStartX As Double

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ValueStartY Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.ValueStartY Property
ChartMarkedZone Class See Also Send Feedback
Marker start position Y

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double ValueStartY { get; set; }
Visual Basic (Declaration)
Public Property ValueStartY As Double

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.Visible Property
ChartMarkedZone Class See Also Send Feedback
Visibility

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


YAxisType Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZone..::.YAxisType Property
ChartMarkedZone Class See Also Send Feedback
Marked zone Y Axis type

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxisType YAxisType { get; set; }
Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType

See Also

ChartMarkedZone Class
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Class

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Class
Members See Also Send Feedback
Marked zones collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarkedZonesCollection : ChartingStateManagedCollection<ChartMarkedZone>
Visual Basic (Declaration)
Public Class ChartMarkedZonesCollection _
    Inherits ChartingStateManagedCollection(Of ChartMarkedZone)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' ChartMarkedZone >)>)>
Telerik.Reporting.Charting..::.ChartMarkedZonesCollection

See Also

ChartMarkedZonesCollection Members
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Members
ChartMarkedZonesCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarkedZonesCollection type exposes the following members.

Constructors

Name | Description
ChartMarkedZonesCollection | Overloaded.

Methods

Name | Description
Add | Add MarkerZone in the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clear collection
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert GridMarker in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Remove GridMarker from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Remove(T).)
RemoveAt | Remove GridMarker in the specific position from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.RemoveAt(Int32).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a GridMarker at the specific position in GridMarkers collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Constructor
ChartMarkedZonesCollection Class See Also Send Feedback

Overload List

Name | Description
ChartMarkedZonesCollection()()() | Create instance of class
ChartMarkedZonesCollection(ChartPlotArea) | Create instance of class

See Also

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Members
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Constructor

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Constructor
ChartMarkedZonesCollection Class See Also Send Feedback
Create instance of class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZonesCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Overload
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Constructor (ChartPlotArea)

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Constructor (ChartPlotArea)
ChartMarkedZonesCollection Class See Also Send Feedback
Create instance of class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZonesCollection(
    ChartPlotArea parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
ChartPlotArea object as parent

See Also

ChartMarkedZonesCollection Class
ChartMarkedZonesCollection Overload
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Methods
ChartMarkedZonesCollection Class See Also Send Feedback

The ChartMarkedZonesCollection type exposes the following members.

Methods

Name | Description
Add | Add MarkerZone in the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clear collection
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert GridMarker in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Remove GridMarker from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Remove(T).)
RemoveAt | Remove GridMarker in the specific position from collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.RemoveAt(Int32).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Add Method
ChartMarkedZonesCollection Class See Also Send Feedback
Add MarkerZone in the collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    ChartMarkedZone item
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    item As ChartMarkedZone _
)

Parameters

item
Type: Telerik.Reporting.Charting..::.ChartMarkedZone
GridMarker for adding

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Clear Method
ChartMarkedZonesCollection Class See Also Send Feedback
Clear collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Insert Method
ChartMarkedZonesCollection Class See Also Send Feedback
Insert GridMarker in collection at the specific position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Insert(
    int index,
    ChartMarkedZone item
)
Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    item As ChartMarkedZone _
)

Parameters

index
Type: System..::.Int32
Position
item
Type: Telerik.Reporting.Charting..::.ChartMarkedZone
GridMarker

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Remove Method
ChartMarkedZonesCollection Class See Also Send Feedback
Remove GridMarker from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Remove(
    ChartMarkedZone item
)
Visual Basic (Declaration)
Public Overrides Function Remove ( _
    item As ChartMarkedZone _
) As Boolean

Parameters

item
Type: Telerik.Reporting.Charting..::.ChartMarkedZone
GridMarker

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.RemoveAt Method
ChartMarkedZonesCollection Class See Also Send Feedback
Remove GridMarker in the specific position from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Overrides Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Position

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


ChartMarkedZonesCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection Properties
ChartMarkedZonesCollection Class See Also Send Feedback

The ChartMarkedZonesCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a GridMarker at the specific position in GridMarkers collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Item Property
ChartMarkedZonesCollection Class See Also Send Feedback
Gets or sets a GridMarker at the specific position in GridMarkers collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMarkedZone this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As ChartMarkedZone

Parameters

index
Type: System..::.Int32
Position in the collection

Return Value

GridMarker at the specific position

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartMarkedZonesCollection..::.Parent Property
ChartMarkedZonesCollection Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ChartPlotArea

See Also

ChartMarkedZonesCollection Class
Telerik.Reporting.Charting Namespace


ChartMarker Class

[image]

Telerik Reporting Q2 2012
ChartMarker Class
Members See Also Send Feedback
Base class for a different markers representation

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarker : LayoutElement
Visual Basic (Declaration)
Public Class ChartMarker _
    Inherits LayoutElement

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartMarker

See Also

ChartMarker Members
Telerik.Reporting.Charting Namespace


ChartMarker Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarker Members
ChartMarker Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarker type exposes the following members.

Constructors

Name | Description
ChartMarker | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from specified object
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Load data to ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Save data to ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Fields

Name | Description
chartMarkerActiveRegion | Active region
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Active region
Appearance | LabelAppearance properties
Container | Link to container element (Inherited from RenderedObject.)
Parent | Gets and sets Parent element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


ChartMarker Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartMarker Constructor
ChartMarker Class See Also Send Feedback

Overload List

Name | Description
ChartMarker()()() | Create new instance of ChartMarker class.
ChartMarker(Object) | Create new instance of ChartMarker class.
ChartMarker(IContainer) | Create new instance of ChartMarker class.
ChartMarker(Object, IContainer) | Create new instance of ChartMarker class.

See Also

ChartMarker Class
ChartMarker Members
Telerik.Reporting.Charting Namespace


ChartMarker Constructor

[image]

Telerik Reporting Q2 2012
ChartMarker Constructor
ChartMarker Class See Also Send Feedback
Create new instance of ChartMarker class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarker()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarker Class
ChartMarker Overload
Telerik.Reporting.Charting Namespace


ChartMarker Constructor (Object)

[image]

Telerik Reporting Q2 2012
ChartMarker Constructor (Object)
ChartMarker Class See Also Send Feedback
Create new instance of ChartMarker class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarker(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent lement

See Also

ChartMarker Class
ChartMarker Overload
Telerik.Reporting.Charting Namespace


ChartMarker Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
ChartMarker Constructor (IContainer)
ChartMarker Class See Also Send Feedback
Create new instance of ChartMarker class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarker(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

ChartMarker Class
ChartMarker Overload
Telerik.Reporting.Charting Namespace


ChartMarker Constructor (Object, IContainer)

[image]

Telerik Reporting Q2 2012
ChartMarker Constructor (Object, IContainer)
ChartMarker Class See Also Send Feedback
Create new instance of ChartMarker class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarker(
    Object parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

ChartMarker Class
ChartMarker Overload
Telerik.Reporting.Charting Namespace


ChartMarker Fields

[image] [image]

Telerik Reporting Q2 2012
ChartMarker Fields
ChartMarker Class See Also Send Feedback

The ChartMarker type exposes the following members.

Fields

Name | Description
chartMarkerActiveRegion | Active region
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


chartMarkerActiveRegion Field

[image]

Telerik Reporting Q2 2012
ChartMarker..::.chartMarkerActiveRegion Field
ChartMarker Class See Also Send Feedback
Active region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ActiveRegion chartMarkerActiveRegion
Visual Basic (Declaration)
Protected chartMarkerActiveRegion As ActiveRegion

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


ChartMarker Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarker Methods
ChartMarker Class See Also Send Feedback

The ChartMarker type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from specified object
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Load data to ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Save data to ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
ChartMarker..::.CopyFrom Method
ChartMarker Class See Also Send Feedback
Copy fields from specified object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CopyFrom(
    ChartMarker marker
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    marker As ChartMarker _
)

Parameters

marker
Type: Telerik.Reporting.Charting..::.ChartMarker
Marker to copy from

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMarker..::.Dispose Method
ChartMarker Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutElement..::.Dispose(Boolean).)

See Also

ChartMarker Class
ChartMarker Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartMarker..::.Dispose Method (Boolean)
ChartMarker Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartMarker Class
Dispose Overload
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarker..::.LoadViewState Method
ChartMarker Class See Also Send Feedback
Load data to ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarker..::.SaveViewState Method
ChartMarker Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartMarker..::.TrackViewState Method
ChartMarker Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


ChartMarker Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarker Properties
ChartMarker Class See Also Send Feedback

The ChartMarker type exposes the following members.

Properties

Name | Description
ActiveRegion | Active region
Appearance | LabelAppearance properties
Container | Link to container element (Inherited from RenderedObject.)
Parent | Gets and sets Parent element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

[image]

Telerik Reporting Q2 2012
ChartMarker..::.ActiveRegion Property
ChartMarker Class See Also Send Feedback
Active region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ActiveRegion ActiveRegion { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartMarker..::.Appearance Property
ChartMarker Class See Also Send Feedback
LabelAppearance properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleMarker

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartMarker..::.Parent Property
ChartMarker Class See Also Send Feedback
Gets and sets Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Object

Field Value

Parent element

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartMarker..::.Visible Property
ChartMarker Class See Also Send Feedback
Gets and sets visibility

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean

Field Value

Visibility of marker

See Also

ChartMarker Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Class

[image]

Telerik Reporting Q2 2012
ChartPlotArea Class
Members See Also Send Feedback
Plot area - series rendering canvas.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartPlotArea : LayoutElement,
    IContainer, IDisposable
Visual Basic (Declaration)
Public Class ChartPlotArea _
    Inherits LayoutElement _
    Implements IContainer, IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartPlotArea

See Also

ChartPlotArea Members
Telerik.Reporting.Charting Namespace


ChartPlotArea Members

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea Members
ChartPlotArea Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartPlotArea type exposes the following members.

Constructors

Name | Description
ChartPlotArea | Overloaded.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Load ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Save Track ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SeriesCollection | Series collection on current plot area
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
Appearance | Style
Chart | Link to chart object
Container | Link to container element (Inherited from RenderedObject.)
DataTable | Table that contain series data
EmptySeriesMessage | Specifies empty series message text
MarkedZones | Marked zones collection
NextPosition | Get a next free order position
OrderList | List, that is represent the render order for taken up elements
Parent | Parent element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
XAxis | Gets XAxis.
YAxis | Primary YAxis.
YAxis2 | Secondary YAxis

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea Constructor
ChartPlotArea Class See Also Send Feedback

Overload List

Name | Description
ChartPlotArea()()() | Create instance of the class
ChartPlotArea(Chart) | Create instance of the class

See Also

ChartPlotArea Class
ChartPlotArea Members
Telerik.Reporting.Charting Namespace


ChartPlotArea Constructor

[image]

Telerik Reporting Q2 2012
ChartPlotArea Constructor
ChartPlotArea Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea()
Visual Basic (Declaration)
Public Sub New

See Also

ChartPlotArea Class
ChartPlotArea Overload
Telerik.Reporting.Charting Namespace


ChartPlotArea Constructor (Chart)

[image]

Telerik Reporting Q2 2012
ChartPlotArea Constructor (Chart)
ChartPlotArea Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea(
    Chart parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Chart

See Also

ChartPlotArea Class
ChartPlotArea Overload
Telerik.Reporting.Charting Namespace


ChartPlotArea Fields

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea Fields
ChartPlotArea Class See Also Send Feedback

The ChartPlotArea type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Methods

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea Methods
ChartPlotArea Class See Also Send Feedback

The ChartPlotArea type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list
LoadViewState | Load ViewState (Overrides LayoutElement..::.LoadViewState(Object).)
ReIndex | Re-index order list
Remove | Overloaded.
RemoveAt | Remove element from list by it's index
SaveViewState | Save Track ViewState (Overrides LayoutElement..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SeriesCollection | Series collection on current plot area
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides LayoutElement..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Add Method
ChartPlotArea Class See Also Send Feedback
Add element at the end of list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Add ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Add(IOrdering)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Dispose Method
ChartPlotArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutElement..::.Dispose(Boolean).)

See Also

ChartPlotArea Class
ChartPlotArea Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Dispose Method (Boolean)
ChartPlotArea Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartPlotArea Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea..::.GetOrder Method
ChartPlotArea Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Get elements order position

See Also

ChartPlotArea Class
ChartPlotArea Members
Telerik.Reporting.Charting Namespace


GetOrder Method (IOrdering)

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.GetOrder Method (IOrdering)
ChartPlotArea Class See Also Send Feedback
Get elements order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetOrder(
    IOrdering element
)
Visual Basic (Declaration)
Public Function GetOrder ( _
    element As IOrdering _
) As Integer

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.GetOrder(IOrdering)

See Also

ChartPlotArea Class
GetOrder Overload
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Insert Method
ChartPlotArea Class See Also Send Feedback
Insert element at specific position in list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Insert(
    int order,
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Insert ( _
    order As Integer, _
    element As IOrdering _
)

Parameters

order
Type: System..::.Int32
Position
element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Insert(Int32, IOrdering)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.LoadViewState Method
ChartPlotArea Class See Also Send Feedback
Load ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ReIndex Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.ReIndex Method
ChartPlotArea Class See Also Send Feedback
Re-index order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ReIndex()
Visual Basic (Declaration)
Public Sub ReIndex

Implements

IContainer..::.ReIndex()()()

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Remove Method
ChartPlotArea Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list

See Also

ChartPlotArea Class
ChartPlotArea Members
Telerik.Reporting.Charting Namespace


Remove Method (IOrdering)

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Remove Method (IOrdering)
ChartPlotArea Class See Also Send Feedback
Remove element from list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    IOrdering element
)
Visual Basic (Declaration)
Public Sub Remove ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

Implements

IContainer..::.Remove(IOrdering)

See Also

ChartPlotArea Class
Remove Overload
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.RemoveAt Method
ChartPlotArea Class See Also Send Feedback
Remove element from list by it's index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Position

Implements

IContainer..::.RemoveAt(Int32)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.SaveViewState Method
ChartPlotArea Class See Also Send Feedback
Save Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Object data as array

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


SeriesCollection Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.SeriesCollection Method
ChartPlotArea Class See Also Send Feedback
Series collection on current plot area

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection SeriesCollection()
Visual Basic (Declaration)
Public Function SeriesCollection As ChartSeriesCollection

Return Value

Series collection

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.TrackViewState Method
ChartPlotArea Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartPlotArea Properties

[image] [image]

Telerik Reporting Q2 2012
ChartPlotArea Properties
ChartPlotArea Class See Also Send Feedback

The ChartPlotArea type exposes the following members.

Properties

Name | Description
Appearance | Style
Chart | Link to chart object
Container | Link to container element (Inherited from RenderedObject.)
DataTable | Table that contain series data
EmptySeriesMessage | Specifies empty series message text
MarkedZones | Marked zones collection
NextPosition | Get a next free order position
OrderList | List, that is represent the render order for taken up elements
Parent | Parent element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
XAxis | Gets XAxis.
YAxis | Primary YAxis.
YAxis2 | Secondary YAxis

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Appearance Property
ChartPlotArea Class See Also Send Feedback
Style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StylePlotArea Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StylePlotArea

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Chart Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Chart Property
ChartPlotArea Class See Also Send Feedback
Link to chart object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Chart Chart { get; }
Visual Basic (Declaration)
Public ReadOnly Property Chart As Chart

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


DataTable Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.DataTable Property
ChartPlotArea Class See Also Send Feedback
Table that contain series data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartDataTable DataTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataTable As ChartDataTable

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.EmptySeriesMessage Property
ChartPlotArea Class See Also Send Feedback
Specifies empty series message text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptySeriesMessage EmptySeriesMessage { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptySeriesMessage As EmptySeriesMessage

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


MarkedZones Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.MarkedZones Property
ChartPlotArea Class See Also Send Feedback
Marked zones collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarkedZonesCollection MarkedZones { get; }
Visual Basic (Declaration)
Public ReadOnly Property MarkedZones As ChartMarkedZonesCollection

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


NextPosition Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.NextPosition Property
ChartPlotArea Class See Also Send Feedback
Get a next free order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int NextPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextPosition As Integer

Implements

IContainer..::.NextPosition

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


OrderList Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.OrderList Property
ChartPlotArea Class See Also Send Feedback
List, that is represent the render order for taken up elements

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List<IOrdering> OrderList { get; }
Visual Basic (Declaration)
Public ReadOnly Property OrderList As List(Of IOrdering)

Implements

IContainer..::.OrderList

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Parent Property
ChartPlotArea Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Chart Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As Chart

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.Visible Property
ChartPlotArea Class See Also Send Feedback
Visibility

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


XAxis Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.XAxis Property
ChartPlotArea Class See Also Send Feedback
Gets XAxis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartXAxis XAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property XAxis As ChartXAxis

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


YAxis Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.YAxis Property
ChartPlotArea Class See Also Send Feedback
Primary YAxis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxis YAxis { get; }
Visual Basic (Declaration)
Public ReadOnly Property YAxis As ChartYAxis

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


YAxis2 Property

[image]

Telerik Reporting Q2 2012
ChartPlotArea..::.YAxis2 Property
ChartPlotArea Class See Also Send Feedback
Secondary YAxis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxis YAxis2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property YAxis2 As ChartYAxis

See Also

ChartPlotArea Class
Telerik.Reporting.Charting Namespace


ChartSeries Class

[image]

Telerik Reporting Q2 2012
ChartSeries Class
Members See Also Send Feedback
Series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartSeries : RenderedObject,
    ICloneable
Visual Basic (Declaration)
Public Class ChartSeries _
    Inherits RenderedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartSeries

See Also

ChartSeries Members
Telerik.Reporting.Charting Namespace


ChartSeries Members

[image] [image]

Telerik Reporting Q2 2012
ChartSeries Members
ChartSeries Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartSeries type exposes the following members.

Constructors

Name | Description
ChartSeries | Overloaded.

Methods

Name | Description
AddItem | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears all series items from the data series.
ClearDataBoundState | Removes data binding links from series
CloneSeries | Return new ChartSeries instance with copied all properties from source object and cloned Items collection
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copies settings from given series
CopyItems | Copies series items from given series
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Load ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveItem | Overloaded.
SaveViewState | Save Track ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetColors | Sets new colors to the items in the data series.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetExplodes | Sets exploded statuses to the items in the data series.
SetItemColor | Sets a new color to the series item at the specified index.
SetItemExplode | Sets a new explode status for the series item at the specified index.
SetItemLabel | Sets a new label for the series item at the specified index.
SetItems | Sets new SeriesItems objects to the data series.
SetItemValue | Sets a new value for the series item at the specified index.
SetLabels | Sets new labels to the items in the data series.
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
SetValues | Sets new values to the data series by passing an array of real values. Old values are cleared.
ToString | Overridden (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegionAttributes | Default attributes for series items' active regions
ActiveRegionToolTip | Default tooltip for series items' active regions
ActiveRegionUrl | Default url for series items' active regions
Appearance | Specifies the visual appearance of series items.
Container | Link to container element (Inherited from RenderedObject.)
DataLabelsColumn | Gets or sets the name of the DataSource column (member) that will be used as ChartSeries names source when Y-values are taken from one column for a several chart ChartSeries
DataXColumn | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X-value
DataXColumn2 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X2-value
DataYColumn | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y-value
DataYColumn2 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y2-value
DataYColumn3 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y3-value (High for CandleStick chart).
DataYColumn4 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y4-value (Low for CandleStick chart).
DefaultLabelValue | Specifies the default value for the series items labels.
Index | Current series index in the series collection
IsActiveRegionSet | Returns whether there is an active region associated with the series.
IsDataBound | Determines whether the series is configured as data bound or not.
Item | Gets or sets a ChartSeries SeriesItem object at the specified index.
Items | Gets a collection of series items.
Name | Gets or sets the name of the data series.
Parent | Parent element
PlotArea | Plot area element for series drawing
Type | Gets or sets the type of the series.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether to render the series or not.
YAxisType | Y Axis used by series

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeries Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartSeries Constructor
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
ChartSeries()()() | Creates a new instance of ChartSeries class.
ChartSeries(String) | Creates a new instance of ChartSeries class with given name
ChartSeries(ChartSeriesCollection) | Creates a new instance of ChartSeries class.
ChartSeries(String, ChartSeriesType) | Creates a new instance of ChartSeries class with given name and type.
ChartSeries(String, ChartSeriesType, ChartSeriesCollection) | Creates a new instance of ChartSeries class.
ChartSeries(String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries) | Creates a new instance of ChartSeries class.
ChartSeries(String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries, String, String, String, String, String, String, String) | Creates a new instance of ChartSeries class.

See Also

ChartSeries Class
ChartSeries Members
Telerik.Reporting.Charting Namespace


ChartSeries Constructor

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (String)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class with given name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Name of series

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (ChartSeriesCollection)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (ChartSeriesCollection)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    ChartSeriesCollection parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartSeriesCollection _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartSeriesCollection
Parent of series

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (String, ChartSeriesType)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (String, ChartSeriesType)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class with given name and type.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    string name,
    ChartSeriesType type
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As ChartSeriesType _
)

Parameters

name
Type: System..::.String
Name of series
type
Type: Telerik.Reporting.Charting..::.ChartSeriesType
Type of series

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    string name,
    ChartSeriesType type,
    ChartSeriesCollection parent
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    type As ChartSeriesType, _
    parent As ChartSeriesCollection _
)

Parameters

name
Type: System..::.String
Name of series
type
Type: Telerik.Reporting.Charting..::.ChartSeriesType
Type of series
parent
Type: Telerik.Reporting.Charting..::.ChartSeriesCollection
Parent of series

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    string seriesName,
    ChartSeriesType chartSeriesType,
    ChartSeriesCollection parent,
    ChartYAxisType yAxisType,
    StyleSeries style
)
Visual Basic (Declaration)
Public Sub New ( _
    seriesName As String, _
    chartSeriesType As ChartSeriesType, _
    parent As ChartSeriesCollection, _
    yAxisType As ChartYAxisType, _
    style As StyleSeries _
)

Parameters

seriesName
Type: System..::.String
Name of series
chartSeriesType
Type: Telerik.Reporting.Charting..::.ChartSeriesType
Type of series
parent
Type: Telerik.Reporting.Charting..::.ChartSeriesCollection
Parent of series
yAxisType
Type: Telerik.Reporting.Charting..::.ChartYAxisType
YAxisType(Primary or Secondary)
style
Type: Telerik.Reporting.Charting.Styles..::.StyleSeries
Style of series

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries, String, String, String, String, String, String, String)

[image]

Telerik Reporting Q2 2012
ChartSeries Constructor (String, ChartSeriesType, ChartSeriesCollection, ChartYAxisType, StyleSeries, String, String, String, String, String, String, String)
ChartSeries Class See Also Send Feedback
Creates a new instance of ChartSeries class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries(
    string seriesName,
    ChartSeriesType chartSeriesType,
    ChartSeriesCollection parent,
    ChartYAxisType yAxisType,
    StyleSeries style,
    string dataYColumn,
    string dataXColumn,
    string dataYColumn2,
    string dataXColumn2,
    string dataYColumn3,
    string dataYColumn4,
    string dataLabelsColumn
)
Visual Basic (Declaration)
Public Sub New ( _
    seriesName As String, _
    chartSeriesType As ChartSeriesType, _
    parent As ChartSeriesCollection, _
    yAxisType As ChartYAxisType, _
    style As StyleSeries, _
    dataYColumn As String, _
    dataXColumn As String, _
    dataYColumn2 As String, _
    dataXColumn2 As String, _
    dataYColumn3 As String, _
    dataYColumn4 As String, _
    dataLabelsColumn As String _
)

Parameters

seriesName
Type: System..::.String
Name of series
chartSeriesType
Type: Telerik.Reporting.Charting..::.ChartSeriesType
Type of series
parent
Type: Telerik.Reporting.Charting..::.ChartSeriesCollection
Parent of series
yAxisType
Type: Telerik.Reporting.Charting..::.ChartYAxisType
YAxisType(Primary or Secondary)
style
Type: Telerik.Reporting.Charting.Styles..::.StyleSeries
Style of series
dataYColumn
Type: System..::.String
DataSource column that is used to data-bind to the series YValue
dataXColumn
Type: System..::.String
DataSource column that is used to data-bind to the series XValue
dataYColumn2
Type: System..::.String
DataSource column that is used to data-bind to the series YValue2
dataXColumn2
Type: System..::.String
DataSource column that is used to data-bind to the series XValue2
dataYColumn3
Type: System..::.String
DataSource column that is used to data-bind to the series YValue3
dataYColumn4
Type: System..::.String
DataSource column that is used to data-bind to the series YValue4
dataLabelsColumn
Type: System..::.String
DataSource column (member) that will be used as ChartSeries names source when Y-values are taken from one column for a several chart ChartSeries

See Also

ChartSeries Class
ChartSeries Overload
Telerik.Reporting.Charting Namespace


ChartSeries Fields

[image] [image]

Telerik Reporting Q2 2012
ChartSeries Fields
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeries Methods

[image] [image]

Telerik Reporting Q2 2012
ChartSeries Methods
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Methods

Name | Description
AddItem | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears all series items from the data series.
ClearDataBoundState | Removes data binding links from series
CloneSeries | Return new ChartSeries instance with copied all properties from source object and cloned Items collection
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copies settings from given series
CopyItems | Copies series items from given series
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Load ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveItem | Overloaded.
SaveViewState | Save Track ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetColors | Sets new colors to the items in the data series.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetExplodes | Sets exploded statuses to the items in the data series.
SetItemColor | Sets a new color to the series item at the specified index.
SetItemExplode | Sets a new explode status for the series item at the specified index.
SetItemLabel | Sets a new label for the series item at the specified index.
SetItems | Sets new SeriesItems objects to the data series.
SetItemValue | Sets a new value for the series item at the specified index.
SetLabels | Sets new labels to the items in the data series.
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
SetValues | Sets new values to the data series by passing an array of real values. Old values are cleared.
ToString | Overridden (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


AddItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
AddItem(Double) | Adds a new series item to the data series by specifying its value.
AddItem(List<(Of <(ChartSeriesItem>)>)) | Adds a series item(s) to the series.
AddItem(array<ChartSeriesItem>[]()[]) | Adds a series item(s) to the series.
AddItem(ChartSeriesItemsCollection) | Adds a series item(s) to the series.
AddItem(Double, String) | Adds a new series item to the data series by specifying its value and label.
AddItem(ChartSeriesItem, array<ChartSeriesItem>[]()[]) | Adds a series item(s) to the series.
AddItem(Double, String, Color) | Adds a new series item to the data series by specifying its value, label and color.
AddItem(Double, String, Color, Boolean) | Adds a new series item to the data series by specifying its value, label, color and explosion.

See Also

ChartSeries Class
ChartSeries Members
Telerik.Reporting.Charting Namespace


AddItem Method (Double)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (Double)
ChartSeries Class See Also Send Feedback
Adds a new series item to the data series by specifying its value.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    double value
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    value As Double _
)

Parameters

value
Type: System..::.Double
YValue of new item

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (List(ChartSeriesItem))

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (List<(Of <(<'ChartSeriesItem>)>)>)
ChartSeries Class See Also Send Feedback
Adds a series item(s) to the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    List<ChartSeriesItem> seriesItems
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    seriesItems As List(Of ChartSeriesItem) _
)

Parameters

seriesItems
Type: System.Collections.Generic..::.List <(Of <(<' ChartSeriesItem >)>)>
Items to add

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartSeriesItem[])

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (array<ChartSeriesItem>[]()[][])
ChartSeries Class See Also Send Feedback
Adds a series item(s) to the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartSeriesItem[] seriesItems
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    seriesItems As ChartSeriesItem() _
)

Parameters

seriesItems
Type: array< Telerik.Reporting.Charting..::.ChartSeriesItem >[]()[][]
Items to add

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartSeriesItemsCollection)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (ChartSeriesItemsCollection)
ChartSeries Class See Also Send Feedback
Adds a series item(s) to the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartSeriesItemsCollection seriesItems
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    seriesItems As ChartSeriesItemsCollection _
)

Parameters

seriesItems
Type: Telerik.Reporting.Charting..::.ChartSeriesItemsCollection
Items to add

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (Double, String)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (Double, String)
ChartSeries Class See Also Send Feedback
Adds a new series item to the data series by specifying its value and label.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    double value,
    string label
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    value As Double, _
    label As String _
)

Parameters

value
Type: System..::.Double
YValue of new item
label
Type: System..::.String
Label of new item

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (ChartSeriesItem, ChartSeriesItem[])

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (ChartSeriesItem, array<ChartSeriesItem>[]()[][])
ChartSeries Class See Also Send Feedback
Adds a series item(s) to the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    ChartSeriesItem seriesItem,
    params ChartSeriesItem[] seriesItems
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    seriesItem As ChartSeriesItem, _
    ParamArray seriesItems As ChartSeriesItem() _
)

Parameters

seriesItem
Type: Telerik.Reporting.Charting..::.ChartSeriesItem
Item to add
seriesItems
Type: array< Telerik.Reporting.Charting..::.ChartSeriesItem >[]()[][]
Items to add

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (Double, String, Color)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (Double, String, Color)
ChartSeries Class See Also Send Feedback
Adds a new series item to the data series by specifying its value, label and color.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    double value,
    string label,
    Color color
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    value As Double, _
    label As String, _
    color As Color _
)

Parameters

value
Type: System..::.Double
YValue of new item
label
Type: System..::.String
Label of new item
color
Type: System.Drawing..::.Color
Color of new item

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (Double, String, Color, Boolean)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.AddItem Method (Double, String, Color, Boolean)
ChartSeries Class See Also Send Feedback
Adds a new series item to the data series by specifying its value, label, color and explosion.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    double value,
    string label,
    Color color,
    bool exploded
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    value As Double, _
    label As String, _
    color As Color, _
    exploded As Boolean _
)

Parameters

value
Type: System..::.Double
YValue of new item
label
Type: System..::.String
Label of new item
color
Type: System.Drawing..::.Color
Color of new item
exploded
Type: System..::.Boolean
If item is exploded

See Also

ChartSeries Class
AddItem Overload
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Clear Method
ChartSeries Class See Also Send Feedback
Clears all series items from the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ClearDataBoundState Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.ClearDataBoundState Method
ChartSeries Class See Also Send Feedback
Removes data binding links from series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearDataBoundState()
Visual Basic (Declaration)
Public Sub ClearDataBoundState

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


CloneSeries Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.CloneSeries Method
ChartSeries Class See Also Send Feedback
Return new ChartSeries instance with copied all properties from source object and cloned Items collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries CloneSeries()
Visual Basic (Declaration)
Public Function CloneSeries As ChartSeries

Return Value

New instance of ChartSeries with copied fields

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.CopyFrom Method
ChartSeries Class See Also Send Feedback
Copies settings from given series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal void CopyFrom(
    ChartSeries originalSeries
)
Visual Basic (Declaration)
Protected Friend Sub CopyFrom ( _
    originalSeries As ChartSeries _
)

Parameters

originalSeries
Type: Telerik.Reporting.Charting..::.ChartSeries
Series to copy from

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


CopyItems Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.CopyItems Method
ChartSeries Class See Also Send Feedback
Copies series items from given series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal void CopyItems(
    ChartSeries originalSeries
)
Visual Basic (Declaration)
Protected Friend Sub CopyItems ( _
    originalSeries As ChartSeries _
)

Parameters

originalSeries
Type: Telerik.Reporting.Charting..::.ChartSeries
Series that items should be copied

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartSeries..::.Dispose Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

ChartSeries Class
ChartSeries Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Dispose Method (Boolean)
ChartSeries Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartSeries Class
Dispose Overload
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.LoadViewState Method
ChartSeries Class See Also Send Feedback
Load ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


RemoveItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartSeries..::.RemoveItem Method
ChartSeries Class See Also Send Feedback

Overload List

Name | Description
RemoveItem(Int32) | Removes the SeriesItem object at the specified index.
RemoveItem(Int32, array<Int32>[]()[]) | Removes a series item(s) from the series.
RemoveItem(ChartSeriesItem, array<ChartSeriesItem>[]()[]) | Removes a series item(s) from the series.

See Also

ChartSeries Class
ChartSeries Members
Telerik.Reporting.Charting Namespace


RemoveItem Method (Int32)

[image]

Telerik Reporting Q2 2012
ChartSeries..::.RemoveItem Method (Int32)
ChartSeries Class See Also Send Feedback
Removes the SeriesItem object at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    int itemIndex
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    itemIndex As Integer _
)

Parameters

itemIndex
Type: System..::.Int32
Index to remove

See Also

ChartSeries Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


RemoveItem Method (Int32, Int32[])

[image]

Telerik Reporting Q2 2012
ChartSeries..::.RemoveItem Method (Int32, array<Int32>[]()[][])
ChartSeries Class See Also Send Feedback
Removes a series item(s) from the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    int index,
    params int[] indexes
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    index As Integer, _
    ParamArray indexes As Integer() _
)

Parameters

index
Type: System..::.Int32
Index of item should be removed
indexes
Type: array< System..::.Int32 >[]()[][]
Indexes of items should be removed

See Also

ChartSeries Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


RemoveItem Method (ChartSeriesItem, ChartSeriesItem[])

[image]

Telerik Reporting Q2 2012
ChartSeries..::.RemoveItem Method (ChartSeriesItem, array<ChartSeriesItem>[]()[][])
ChartSeries Class See Also Send Feedback
Removes a series item(s) from the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveItem(
    ChartSeriesItem seriesItem,
    params ChartSeriesItem[] seriesItems
)
Visual Basic (Declaration)
Public Sub RemoveItem ( _
    seriesItem As ChartSeriesItem, _
    ParamArray seriesItems As ChartSeriesItem() _
)

Parameters

seriesItem
Type: Telerik.Reporting.Charting..::.ChartSeriesItem
Item for removing
seriesItems
Type: array< Telerik.Reporting.Charting..::.ChartSeriesItem >[]()[][]
Items for removing

See Also

ChartSeries Class
RemoveItem Overload
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SaveViewState Method
ChartSeries Class See Also Send Feedback
Save Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Object data as array

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetColors Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetColors Method
ChartSeries Class See Also Send Feedback
Sets new colors to the items in the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetColors(
    params Color[] colors
)
Visual Basic (Declaration)
Public Sub SetColors ( _
    ParamArray colors As Color() _
)

Parameters

colors
Type: array< System.Drawing..::.Color >[]()[][]
New colors

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetExplodes Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetExplodes Method
ChartSeries Class See Also Send Feedback
Sets exploded statuses to the items in the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetExplodes(
    params bool[] explodes
)
Visual Basic (Declaration)
Public Sub SetExplodes ( _
    ParamArray explodes As Boolean() _
)

Parameters

explodes
Type: array< System..::.Boolean >[]()[][]
New exploded values

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetItemColor Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetItemColor Method
ChartSeries Class See Also Send Feedback
Sets a new color to the series item at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemColor(
    int itemIndex,
    Color newColor
)
Visual Basic (Declaration)
Public Sub SetItemColor ( _
    itemIndex As Integer, _
    newColor As Color _
)

Parameters

itemIndex
Type: System..::.Int32
Index of item to change color
newColor
Type: System.Drawing..::.Color
New color of item

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetItemExplode Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetItemExplode Method
ChartSeries Class See Also Send Feedback
Sets a new explode status for the series item at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemExplode(
    int itemIndex,
    bool exploded
)
Visual Basic (Declaration)
Public Sub SetItemExplode ( _
    itemIndex As Integer, _
    exploded As Boolean _
)

Parameters

itemIndex
Type: System..::.Int32
Index of item
exploded
Type: System..::.Boolean
Shoul be exploded or not

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetItemLabel Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetItemLabel Method
ChartSeries Class See Also Send Feedback
Sets a new label for the series item at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemLabel(
    int itemIndex,
    string newLabel
)
Visual Basic (Declaration)
Public Sub SetItemLabel ( _
    itemIndex As Integer, _
    newLabel As String _
)

Parameters

itemIndex
Type: System..::.Int32
Index of item to change label
newLabel
Type: System..::.String
New label

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetItems Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetItems Method
ChartSeries Class See Also Send Feedback
Sets new SeriesItems objects to the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItems(
    params ChartSeriesItem[] seriesItems
)
Visual Basic (Declaration)
Public Sub SetItems ( _
    ParamArray seriesItems As ChartSeriesItem() _
)

Parameters

seriesItems
Type: array< Telerik.Reporting.Charting..::.ChartSeriesItem >[]()[][]
New Items to replace old items in series

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetItemValue Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetItemValue Method
ChartSeries Class See Also Send Feedback
Sets a new value for the series item at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetItemValue(
    int itemIndex,
    double newValue
)
Visual Basic (Declaration)
Public Sub SetItemValue ( _
    itemIndex As Integer, _
    newValue As Double _
)

Parameters

itemIndex
Type: System..::.Int32
Index of item to change YValue
newValue
Type: System..::.Double
New YValue

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetLabels Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetLabels Method
ChartSeries Class See Also Send Feedback
Sets new labels to the items in the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetLabels(
    params string[] labels
)
Visual Basic (Declaration)
Public Sub SetLabels ( _
    ParamArray labels As String() _
)

Parameters

labels
Type: array< System..::.String >[]()[][]
New labels

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


SetValues Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.SetValues Method
ChartSeries Class See Also Send Feedback
Sets new values to the data series by passing an array of real values. Old values are cleared.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetValues(
    params double[] values
)
Visual Basic (Declaration)
Public Sub SetValues ( _
    ParamArray values As Double() _
)

Parameters

values
Type: array< System..::.Double >[]()[][]
New values

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.ToString Method
ChartSeries Class See Also Send Feedback
Overridden

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

Series name

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeries..::.TrackViewState Method
ChartSeries Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeries Properties

[image] [image]

Telerik Reporting Q2 2012
ChartSeries Properties
ChartSeries Class See Also Send Feedback

The ChartSeries type exposes the following members.

Properties

Name | Description
ActiveRegionAttributes | Default attributes for series items' active regions
ActiveRegionToolTip | Default tooltip for series items' active regions
ActiveRegionUrl | Default url for series items' active regions
Appearance | Specifies the visual appearance of series items.
Container | Link to container element (Inherited from RenderedObject.)
DataLabelsColumn | Gets or sets the name of the DataSource column (member) that will be used as ChartSeries names source when Y-values are taken from one column for a several chart ChartSeries
DataXColumn | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X-value
DataXColumn2 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X2-value
DataYColumn | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y-value
DataYColumn2 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y2-value
DataYColumn3 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y3-value (High for CandleStick chart).
DataYColumn4 | Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y4-value (Low for CandleStick chart).
DefaultLabelValue | Specifies the default value for the series items labels.
Index | Current series index in the series collection
IsActiveRegionSet | Returns whether there is an active region associated with the series.
IsDataBound | Determines whether the series is configured as data bound or not.
Item | Gets or sets a ChartSeries SeriesItem object at the specified index.
Items | Gets a collection of series items.
Name | Gets or sets the name of the data series.
Parent | Parent element
PlotArea | Plot area element for series drawing
Type | Gets or sets the type of the series.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether to render the series or not.
YAxisType | Y Axis used by series

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ActiveRegionAttributes Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.ActiveRegionAttributes Property
ChartSeries Class See Also Send Feedback
Default attributes for series items' active regions

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ActiveRegionAttributes { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegionAttributes As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ActiveRegionToolTip Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.ActiveRegionToolTip Property
ChartSeries Class See Also Send Feedback
Default tooltip for series items' active regions

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ActiveRegionToolTip { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegionToolTip As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ActiveRegionUrl Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.ActiveRegionUrl Property
ChartSeries Class See Also Send Feedback
Default url for series items' active regions

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ActiveRegionUrl { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegionUrl As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Appearance Property
ChartSeries Class See Also Send Feedback
Specifies the visual appearance of series items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeries Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeries

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataLabelsColumn Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataLabelsColumn Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that will be used as ChartSeries names source when Y-values are taken from one column for a several chart ChartSeries

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataLabelsColumn { get; set; }
Visual Basic (Declaration)
Public Property DataLabelsColumn As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataXColumn Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataXColumn Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X-value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataXColumn { get; set; }
Visual Basic (Declaration)
Public Property DataXColumn As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataXColumn2 Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataXColumn2 Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series X2-value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataXColumn2 { get; set; }
Visual Basic (Declaration)
Public Property DataXColumn2 As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataYColumn Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataYColumn Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y-value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataYColumn { get; set; }
Visual Basic (Declaration)
Public Property DataYColumn As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataYColumn2 Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataYColumn2 Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y2-value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataYColumn2 { get; set; }
Visual Basic (Declaration)
Public Property DataYColumn2 As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataYColumn3 Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataYColumn3 Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y3-value (High for CandleStick chart).

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataYColumn3 { get; set; }
Visual Basic (Declaration)
Public Property DataYColumn3 As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DataYColumn4 Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DataYColumn4 Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the DataSource column (member) that is used to data-bind to the series Y4-value (Low for CandleStick chart).

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataYColumn4 { get; set; }
Visual Basic (Declaration)
Public Property DataYColumn4 As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


DefaultLabelValue Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.DefaultLabelValue Property
ChartSeries Class See Also Send Feedback
Specifies the default value for the series items labels.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DefaultLabelValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultLabelValue As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Index Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Index Property
ChartSeries Class See Also Send Feedback
Current series index in the series collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


IsActiveRegionSet Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.IsActiveRegionSet Property
ChartSeries Class See Also Send Feedback
Returns whether there is an active region associated with the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsActiveRegionSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsActiveRegionSet As Boolean

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


IsDataBound Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.IsDataBound Property
ChartSeries Class See Also Send Feedback
Determines whether the series is configured as data bound or not.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsDataBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDataBound As Boolean

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Item Property
ChartSeries Class See Also Send Feedback
Gets or sets a ChartSeries SeriesItem object at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem this[
    int itemIndex
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    itemIndex As Integer _
) As ChartSeriesItem

Parameters

itemIndex
Type: System..::.Int32

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Items Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Items Property
ChartSeries Class See Also Send Feedback
Gets a collection of series items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItemsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ChartSeriesItemsCollection

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Name Property
ChartSeries Class See Also Send Feedback
Gets or sets the name of the data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Parent Property
ChartSeries Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartSeriesCollection

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


PlotArea Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.PlotArea Property
ChartSeries Class See Also Send Feedback
Plot area element for series drawing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPlotArea PlotArea { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlotArea As ChartPlotArea

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Type Property
ChartSeries Class See Also Send Feedback
Gets or sets the type of the series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As ChartSeriesType

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.Visible Property
ChartSeries Class See Also Send Feedback
Specifies whether to render the series or not.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


YAxisType Property

[image]

Telerik Reporting Q2 2012
ChartSeries..::.YAxisType Property
ChartSeries Class See Also Send Feedback
Y Axis used by series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxisType YAxisType { get; set; }
Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType

See Also

ChartSeries Class
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Class

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection Class
Members See Also Send Feedback
Series collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartSeriesCollection : ChartingStateManagedCollection<ChartSeries>
Visual Basic (Declaration)
Public Class ChartSeriesCollection _
    Inherits ChartingStateManagedCollection(Of ChartSeries)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' ChartSeries >)>)>
Telerik.Reporting.Charting..::.ChartSeriesCollection

See Also

ChartSeriesCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Members

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesCollection Members
ChartSeriesCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartSeriesCollection type exposes the following members.

Constructors

Name | Description
ChartSeriesCollection | Overloaded.

Methods

Name | Description
Add | Add ChartSeries at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ClearDataBoundState | Removes data binding links from series
ClearItems | Clears items in all series
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetByName | Find series by name
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetFilteredSeriesByYAxis | Gets all series related to the given Y ChartAxis
GetMaxItemsCount | Returns the number of items in the longest data series.
GetMaxYValue | Gets the maximal item value of all series.
GetMinYValue | Gets the minimal item value of all series.
GetSeries | Returns a reference to the ChartsSereis object at the specified index.
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert ChartSeries in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
InsertSeries | Insert ChartSeries in collection at the specific position
LoadViewState | Load ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Final code for series insertion (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnInsertComplete(Int32, Object).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveSeries | Removes the all data series from the series collection.
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a ChartSeries at the specific position in ChartSeries collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element (chart)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesCollection Constructor
ChartSeriesCollection Class See Also Send Feedback

Overload List

Name | Description
ChartSeriesCollection()()() | Creates a new instance of the ChartSeriesCollection class.
ChartSeriesCollection(Chart) | Creates a new instance of the ChartSeriesCollection class.

See Also

ChartSeriesCollection Class
ChartSeriesCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Constructor

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection Constructor
ChartSeriesCollection Class See Also Send Feedback
Creates a new instance of the ChartSeriesCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSeriesCollection Class
ChartSeriesCollection Overload
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Constructor (Chart)

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection Constructor (Chart)
ChartSeriesCollection Class See Also Send Feedback
Creates a new instance of the ChartSeriesCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection(
    Chart parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Parent for collection

See Also

ChartSeriesCollection Class
ChartSeriesCollection Overload
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesCollection Methods
ChartSeriesCollection Class See Also Send Feedback

The ChartSeriesCollection type exposes the following members.

Methods

Name | Description
Add | Add ChartSeries at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ClearDataBoundState | Removes data binding links from series
ClearItems | Clears items in all series
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetByName | Find series by name
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetFilteredSeriesByYAxis | Gets all series related to the given Y ChartAxis
GetMaxItemsCount | Returns the number of items in the longest data series.
GetMaxYValue | Gets the maximal item value of all series.
GetMinYValue | Gets the minimal item value of all series.
GetSeries | Returns a reference to the ChartsSereis object at the specified index.
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Insert ChartSeries in collection at the specific position (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Insert(Int32, T).)
InsertSeries | Insert ChartSeries in collection at the specific position
LoadViewState | Load ViewState (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Final code for series insertion (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.OnInsertComplete(Int32, Object).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveSeries | Removes the all data series from the series collection.
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.Add Method
ChartSeriesCollection Class See Also Send Feedback
Add ChartSeries at the collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    ChartSeries chartSeries
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    chartSeries As ChartSeries _
)

Parameters

chartSeries
Type: Telerik.Reporting.Charting..::.ChartSeries
ChartSeries to add

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ClearDataBoundState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.ClearDataBoundState Method
ChartSeriesCollection Class See Also Send Feedback
Removes data binding links from series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearDataBoundState()
Visual Basic (Declaration)
Public Sub ClearDataBoundState

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.ClearItems Method
ChartSeriesCollection Class See Also Send Feedback
Clears items in all series

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearItems()
Visual Basic (Declaration)
Public Sub ClearItems

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetByName Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetByName Method
ChartSeriesCollection Class See Also Send Feedback
Find series by name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries GetByName(
    string name
)
Visual Basic (Declaration)
Public Function GetByName ( _
    name As String _
) As ChartSeries

Parameters

name
Type: System..::.String
ChartSeries name

Return Value

ChartSeries

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetFilteredSeriesByYAxis Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetFilteredSeriesByYAxis Method
ChartSeriesCollection Class See Also Send Feedback
Gets all series related to the given Y ChartAxis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesCollection GetFilteredSeriesByYAxis(
    ChartYAxisType yAxisType
)
Visual Basic (Declaration)
Public Function GetFilteredSeriesByYAxis ( _
    yAxisType As ChartYAxisType _
) As ChartSeriesCollection

Parameters

yAxisType
Type: Telerik.Reporting.Charting..::.ChartYAxisType
YAxisType(Primary, Secondary)

Return Value

All series related to the given Y ChartAxis

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetMaxItemsCount Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetMaxItemsCount Method
ChartSeriesCollection Class See Also Send Feedback
Returns the number of items in the longest data series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetMaxItemsCount()
Visual Basic (Declaration)
Public Function GetMaxItemsCount As Integer

Return Value

Number of items in the longest data series

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetMaxYValue Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetMaxYValue Method
ChartSeriesCollection Class See Also Send Feedback
Gets the maximal item value of all series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double GetMaxYValue()
Visual Basic (Declaration)
Public Function GetMaxYValue As Double

Return Value

Maximal item value of all series

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetMinYValue Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetMinYValue Method
ChartSeriesCollection Class See Also Send Feedback
Gets the minimal item value of all series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double GetMinYValue()
Visual Basic (Declaration)
Public Function GetMinYValue As Double

Return Value

Minimal item value of all series

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


GetSeries Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.GetSeries Method
ChartSeriesCollection Class See Also Send Feedback
Returns a reference to the ChartsSereis object at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries GetSeries(
    int index
)
Visual Basic (Declaration)
Public Function GetSeries ( _
    index As Integer _
) As ChartSeries

Parameters

index
Type: System..::.Int32
Index of series

Return Value

Series with specified index

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.Insert Method
ChartSeriesCollection Class See Also Send Feedback
Insert ChartSeries in collection at the specific position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Insert(
    int index,
    ChartSeries item
)
Visual Basic (Declaration)
Public Overrides Sub Insert ( _
    index As Integer, _
    item As ChartSeries _
)

Parameters

index
Type: System..::.Int32
Position
item
Type: Telerik.Reporting.Charting..::.ChartSeries
ChartSeries

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


InsertSeries Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.InsertSeries Method
ChartSeriesCollection Class See Also Send Feedback
Insert ChartSeries in collection at the specific position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void InsertSeries(
    int index,
    ChartSeries item
)
Visual Basic (Declaration)
Public Sub InsertSeries ( _
    index As Integer, _
    item As ChartSeries _
)

Parameters

index
Type: System..::.Int32
Position
item
Type: Telerik.Reporting.Charting..::.ChartSeries
ChartSeries

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.LoadViewState Method
ChartSeriesCollection Class See Also Send Feedback
Load ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
ViewState with data

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


OnInsertComplete Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.OnInsertComplete Method
ChartSeriesCollection Class See Also Send Feedback
Final code for series insertion

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
Index where series should be insert
value
Type: System..::.Object
Value to insert

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


RemoveSeries Method

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.RemoveSeries Method
ChartSeriesCollection Class See Also Send Feedback
Removes the all data series from the series collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveSeries()
Visual Basic (Declaration)
Public Sub RemoveSeries

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesCollection Properties
ChartSeriesCollection Class See Also Send Feedback

The ChartSeriesCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a ChartSeries at the specific position in ChartSeries collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element (chart)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.Item Property
ChartSeriesCollection Class See Also Send Feedback
Gets or sets a ChartSeries at the specific position in ChartSeries collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartSeries this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As ChartSeries

Parameters

index
Type: System..::.Int32
Position in the collection

Return Value

ChartSeries at the specific position

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartSeriesCollection..::.Parent Property
ChartSeriesCollection Class See Also Send Feedback
Parent element (chart)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Chart Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As Chart

See Also

ChartSeriesCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Class

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Class
Members See Also Send Feedback
Represents the base element of RadChart's series.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartSeriesItem : RenderedObject,
    ICloneable
Visual Basic (Declaration)
Public Class ChartSeriesItem _
    Inherits RenderedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartSeriesItem

See Also

ChartSeriesItem Members
Telerik.Reporting.Charting Namespace


ChartSeriesItem Members

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem Members
ChartSeriesItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartSeriesItem type exposes the following members.

Constructors

Name | Description
ChartSeriesItem | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saving ViewState data (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking ViewState data (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Active region
Appearance | Link to visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Empty | Is series item contains empty value
Index | Index in items collection
Label | Item label
Name | ChartSeriesItem name
Parent | Parent element
PointAppearance | Point appearance settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the series item should be rendered.
XValue | Main X value
XValue2 | Second x value for item
YValue | Main Y value for item
YValue2 | Second y value for item
YValue3 | Third y value for item (could be used in CandleStick charts as High value)
YValue4 | Fourth y value for item (could be used in CandleStick charts as Low value)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor
ChartSeriesItem Class See Also Send Feedback

Overload List

Name | Description
ChartSeriesItem()()() | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Boolean) | Creates a new instance of the empty ChartSeriesItem class.
ChartSeriesItem(Double) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(ChartSeries) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, Double) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, String) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, Double, StyleSeriesItem) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, String, Color) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, Double, Double, Double) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, String, Color, Boolean) | Creates a new instance of the ChartSeriesItem class.
ChartSeriesItem(Double, Double, Double, Double, Double, Double) | Creates a new instance of the ChartSeriesItem class.

See Also

ChartSeriesItem Class
ChartSeriesItem Members
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Boolean)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Boolean)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the empty ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    bool isEmpty
)
Visual Basic (Declaration)
Public Sub New ( _
    isEmpty As Boolean _
)

Parameters

isEmpty
Type: System..::.Boolean

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double _
)

Parameters

value
Type: System..::.Double

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (ChartSeries)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    ChartSeries parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartSeries _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartSeries

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, Double)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, Double)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double x,
    double y
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double _
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, String)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, String)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double value,
    string labelText
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double, _
    labelText As String _
)

Parameters

value
Type: System..::.Double
labelText
Type: System..::.String

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, Double, StyleSeriesItem)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, Double, StyleSeriesItem)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double x,
    double y,
    StyleSeriesItem style
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    style As StyleSeriesItem _
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
style
Type: Telerik.Reporting.Charting.Styles..::.StyleSeriesItem

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, String, Color)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, String, Color)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double value,
    string label,
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double, _
    label As String, _
    color As Color _
)

Parameters

value
Type: System..::.Double
label
Type: System..::.String
color
Type: System.Drawing..::.Color

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, Double, Double, Double)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, Double, Double, Double)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double x,
    double y,
    double x2,
    double y2
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    x2 As Double, _
    y2 As Double _
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
x2
Type: System..::.Double
y2
Type: System..::.Double

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, String, Color, Boolean)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, String, Color, Boolean)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double value,
    string label,
    Color color,
    bool exploded
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double, _
    label As String, _
    color As Color, _
    exploded As Boolean _
)

Parameters

value
Type: System..::.Double
label
Type: System..::.String
color
Type: System.Drawing..::.Color
exploded
Type: System..::.Boolean

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Constructor (Double, Double, Double, Double, Double, Double)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem Constructor (Double, Double, Double, Double, Double, Double)
ChartSeriesItem Class See Also Send Feedback
Creates a new instance of the ChartSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItem(
    double x,
    double y,
    double x2,
    double y2,
    double y3,
    double y4
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Double, _
    y As Double, _
    x2 As Double, _
    y2 As Double, _
    y3 As Double, _
    y4 As Double _
)

Parameters

x
Type: System..::.Double
y
Type: System..::.Double
x2
Type: System..::.Double
y2
Type: System..::.Double
y3
Type: System..::.Double
y4
Type: System..::.Double

See Also

ChartSeriesItem Class
ChartSeriesItem Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItem Fields

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem Fields
ChartSeriesItem Class See Also Send Feedback

The ChartSeriesItem type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Methods

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem Methods
ChartSeriesItem Class See Also Send Feedback

The ChartSeriesItem type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loading ViewState data (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saving ViewState data (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking ViewState data (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Clone Method
ChartSeriesItem Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of ChartSeriesItem class that is copy of this object

Implements

ICloneable..::.Clone()()()

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Dispose Method
ChartSeriesItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

ChartSeriesItem Class
ChartSeriesItem Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Dispose Method (Boolean)
ChartSeriesItem Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ChartSeriesItem Class
Dispose Overload
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.LoadViewState Method
ChartSeriesItem Class See Also Send Feedback
Loading ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.SaveViewState Method
ChartSeriesItem Class See Also Send Feedback
Saving ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved in View state data

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.TrackViewState Method
ChartSeriesItem Class See Also Send Feedback
Tracking ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ChartSeriesItem Properties

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItem Properties
ChartSeriesItem Class See Also Send Feedback

The ChartSeriesItem type exposes the following members.

Properties

Name | Description
ActiveRegion | Active region
Appearance | Link to visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Empty | Is series item contains empty value
Index | Index in items collection
Label | Item label
Name | ChartSeriesItem name
Parent | Parent element
PointAppearance | Point appearance settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the series item should be rendered.
XValue | Main X value
XValue2 | Second x value for item
YValue | Main Y value for item
YValue2 | Second y value for item
YValue3 | Third y value for item (could be used in CandleStick charts as High value)
YValue4 | Fourth y value for item (could be used in CandleStick charts as Low value)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ActiveRegion Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.ActiveRegion Property
ChartSeriesItem Class See Also Send Feedback
Active region

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ActiveRegion ActiveRegion { get; set; }
Visual Basic (Declaration)
Public Property ActiveRegion As ActiveRegion

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Appearance Property
ChartSeriesItem Class See Also Send Feedback
Link to visualization and design properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItem Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeriesItem

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Empty Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Empty Property
ChartSeriesItem Class See Also Send Feedback
Is series item contains empty value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Empty { get; set; }
Visual Basic (Declaration)
Public Property Empty As Boolean

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Index Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Index Property
ChartSeriesItem Class See Also Send Feedback
Index in items collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Label Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Label Property
ChartSeriesItem Class See Also Send Feedback
Item label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SeriesItemLabel Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As SeriesItemLabel

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Name Property
ChartSeriesItem Class See Also Send Feedback
ChartSeriesItem name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Parent Property
ChartSeriesItem Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ChartSeries

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


PointAppearance Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.PointAppearance Property
ChartSeriesItem Class See Also Send Feedback
Point appearance settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerSeriesPoint PointAppearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointAppearance As StyleMarkerSeriesPoint

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.Visible Property
ChartSeriesItem Class See Also Send Feedback
Specifies whether the series item should be rendered.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


XValue Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.XValue Property
ChartSeriesItem Class See Also Send Feedback
Main X value

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double XValue { get; set; }
Visual Basic (Declaration)
Public Property XValue As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


XValue2 Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.XValue2 Property
ChartSeriesItem Class See Also Send Feedback
Second x value for item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double XValue2 { get; set; }
Visual Basic (Declaration)
Public Property XValue2 As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


YValue Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.YValue Property
ChartSeriesItem Class See Also Send Feedback
Main Y value for item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YValue { get; set; }
Visual Basic (Declaration)
Public Property YValue As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


YValue2 Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.YValue2 Property
ChartSeriesItem Class See Also Send Feedback
Second y value for item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YValue2 { get; set; }
Visual Basic (Declaration)
Public Property YValue2 As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


YValue3 Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.YValue3 Property
ChartSeriesItem Class See Also Send Feedback
Third y value for item (could be used in CandleStick charts as High value)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YValue3 { get; set; }
Visual Basic (Declaration)
Public Property YValue3 As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


YValue4 Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItem..::.YValue4 Property
ChartSeriesItem Class See Also Send Feedback
Fourth y value for item (could be used in CandleStick charts as Low value)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YValue4 { get; set; }
Visual Basic (Declaration)
Public Property YValue4 As Double

See Also

ChartSeriesItem Class
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Class

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Class
Members See Also Send Feedback
Series items collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartSeriesItemsCollection : ChartingStateManagedCollection<ChartSeriesItem>
Visual Basic (Declaration)
Public Class ChartSeriesItemsCollection _
    Inherits ChartingStateManagedCollection(Of ChartSeriesItem)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' ChartSeriesItem >)>)>
Telerik.Reporting.Charting..::.ChartSeriesItemsCollection

See Also

ChartSeriesItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Members

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Members
ChartSeriesItemsCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartSeriesItemsCollection type exposes the following members.

Constructors

Name | Description
ChartSeriesItemsCollection | Overloaded.

Methods

Name | Description
Add | Add Item at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Overloaded.
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Load ViewState data (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a Item at the specific position in Items collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Constructor
ChartSeriesItemsCollection Class See Also Send Feedback

Overload List

Name | Description
ChartSeriesItemsCollection()()() | Creates a new instance of the ChartSeriesItemsCollection class.
ChartSeriesItemsCollection(ChartSeries) | Creates a new instance of the ChartSeriesItemsCollection class.

See Also

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Constructor

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Constructor
ChartSeriesItemsCollection Class See Also Send Feedback
Creates a new instance of the ChartSeriesItemsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItemsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Constructor (ChartSeries)
ChartSeriesItemsCollection Class See Also Send Feedback
Creates a new instance of the ChartSeriesItemsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesItemsCollection(
    ChartSeries parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartSeries _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartSeries
Parent of the collection

See Also

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Overload
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Methods
ChartSeriesItemsCollection Class See Also Send Feedback

The ChartSeriesItemsCollection type exposes the following members.

Methods

Name | Description
Add | Add Item at the collection (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Overloaded.
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Load ViewState data (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.LoadViewState(Object).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.Add Method
ChartSeriesItemsCollection Class See Also Send Feedback
Add Item at the collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    ChartSeriesItem chartSeriesItem
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    chartSeriesItem As ChartSeriesItem _
)

Parameters

chartSeriesItem
Type: Telerik.Reporting.Charting..::.ChartSeriesItem
Item to add

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.AddRange Method
ChartSeriesItemsCollection Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<T>[]()[]) | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange(ChartSeriesItemsCollection) | Adds a collection of series items to the items collection.

See Also

ChartSeriesItemsCollection Class
ChartSeriesItemsCollection Members
Telerik.Reporting.Charting Namespace


AddRange Method (ChartSeriesItemsCollection)

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.AddRange Method (ChartSeriesItemsCollection)
ChartSeriesItemsCollection Class See Also Send Feedback
Adds a collection of series items to the items collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    ChartSeriesItemsCollection chartSeriesItems
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    chartSeriesItems As ChartSeriesItemsCollection _
)

Parameters

chartSeriesItems
Type: Telerik.Reporting.Charting..::.ChartSeriesItemsCollection
Items to add

See Also

ChartSeriesItemsCollection Class
AddRange Overload
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.LoadViewState Method
ChartSeriesItemsCollection Class See Also Send Feedback
Load ViewState data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
ViewState with data

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesItemsCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection Properties
ChartSeriesItemsCollection Class See Also Send Feedback

The ChartSeriesItemsCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets or sets a Item at the specific position in Items collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Item[([(Int32])]).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Parent | Parent element

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.Item Property
ChartSeriesItemsCollection Class See Also Send Feedback
Gets or sets a Item at the specific position in Items collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartSeriesItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Overrides Default Property Item ( _
    index As Integer _
) As ChartSeriesItem

Parameters

index
Type: System..::.Int32
Position in the collection

Return Value

Item at the specific position

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ChartSeriesItemsCollection..::.Parent Property
ChartSeriesItemsCollection Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeries Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ChartSeries

See Also

ChartSeriesItemsCollection Class
Telerik.Reporting.Charting Namespace


ChartSeriesLegendDisplayMode Enumeration

[image]

Telerik Reporting Q2 2012
ChartSeriesLegendDisplayMode Enumeration
See Also Send Feedback
Specifies legend items presentation.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartSeriesLegendDisplayMode
Visual Basic (Declaration)
Public Enumeration ChartSeriesLegendDisplayMode

Members

Member name | Description
Nothing | The legend does not show any information from the series.
SeriesName | The legend shows the series name.
ItemLabels | The legend shows the names of the series items.

See Also

Telerik.Reporting.Charting Namespace


ChartSeriesOrientation Enumeration

[image]

Telerik Reporting Q2 2012
ChartSeriesOrientation Enumeration
See Also Send Feedback
Series orientation

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartSeriesOrientation
Visual Basic (Declaration)
Public Enumeration ChartSeriesOrientation

Members

Member name | Description
Vertical | Specifies Vertical Orientation
Horizontal | Specifies Horizontal Orientation

See Also

Telerik.Reporting.Charting Namespace


ChartSeriesType Enumeration

[image]

Telerik Reporting Q2 2012
ChartSeriesType Enumeration
See Also Send Feedback
Supported series types.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartSeriesType
Visual Basic (Declaration)
Public Enumeration ChartSeriesType

Members

Member name | Description
Bar | Specifies a bar data series.
StackedBar | Specifies a stacked bar data series.
StackedBar100 | Specifies a stacked 100 bar data series.
Line | Specifies a line data series.
Area | Specifies an area data series.
StackedArea | Specifies a stacked area data series.
StackedArea100 | Specifies a stacked 100 area data series.
Pie | Specifies a pie data series.
Gantt | Specifies a gantt data series.
Bezier | Specifies a bezier data series.
Spline | Specifies a spline data series.
Bubble | Specifies a bubble data series.
Point | Specifies a point data series.
SplineArea | Specifies an spline area data series.
StackedSplineArea | Specifies a stacked spline area data series.
StackedSplineArea100 | Specifies a stacked 100 spline area data series.
CandleStick | Specifies a candlestick data series.
StackedLine | Specifies a stacked line data series.
StackedSpline | Specifies a stacked spline data series.

See Also

Telerik.Reporting.Charting Namespace


ChartTitle Class

[image]

Telerik Reporting Q2 2012
ChartTitle Class
Members See Also Send Feedback
Chart Title

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartTitle : ChartLabel
Visual Basic (Declaration)
Public Class ChartTitle _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.ChartTitle

See Also

ChartTitle Members
Telerik.Reporting.Charting Namespace


ChartTitle Members

[image] [image]

Telerik Reporting Q2 2012
ChartTitle Members
ChartTitle Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartTitle type exposes the following members.

Constructors

Name | Description
ChartTitle | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartTitle Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartTitle Constructor
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
ChartTitle()()() | Creates a new instance of the ChartTitle class.
ChartTitle(Chart) | Creates a new instance of the ChartTitle class.
ChartTitle(Chart, IContainer) | Creates a new instance of the ChartTitle class.

See Also

ChartTitle Class
ChartTitle Members
Telerik.Reporting.Charting Namespace


ChartTitle Constructor

[image]

Telerik Reporting Q2 2012
ChartTitle Constructor
ChartTitle Class See Also Send Feedback
Creates a new instance of the ChartTitle class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartTitle()
Visual Basic (Declaration)
Public Sub New

See Also

ChartTitle Class
ChartTitle Overload
Telerik.Reporting.Charting Namespace


ChartTitle Constructor (Chart)

[image]

Telerik Reporting Q2 2012
ChartTitle Constructor (Chart)
ChartTitle Class See Also Send Feedback
Creates a new instance of the ChartTitle class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartTitle(
    Chart parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Chart

See Also

ChartTitle Class
ChartTitle Overload
Telerik.Reporting.Charting Namespace


ChartTitle Constructor (Chart, IContainer)

[image]

Telerik Reporting Q2 2012
ChartTitle Constructor (Chart, IContainer)
ChartTitle Class See Also Send Feedback
Creates a new instance of the ChartTitle class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartTitle(
    Chart parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Chart
container
Type: Telerik.Reporting.Charting..::.IContainer
Elements container

See Also

ChartTitle Class
ChartTitle Overload
Telerik.Reporting.Charting Namespace


ChartTitle Fields

[image] [image]

Telerik Reporting Q2 2012
ChartTitle Fields
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartTitle Methods

[image] [image]

Telerik Reporting Q2 2012
ChartTitle Methods
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartTitle Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartTitle..::.Dispose Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ChartTitle..::.GetOrder Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ChartTitle..::.Remove Method
ChartTitle Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

ChartTitle Class
ChartTitle Members
Telerik.Reporting.Charting Namespace


ChartTitle Properties

[image] [image]

Telerik Reporting Q2 2012
ChartTitle Properties
ChartTitle Class See Also Send Feedback

The ChartTitle type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartTitle Class
Telerik.Reporting.Charting Namespace


ChartXAxis Class

[image]

Telerik Reporting Q2 2012
ChartXAxis Class
Members See Also Send Feedback
Represents the X Axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartXAxis : ChartAxis
Visual Basic (Declaration)
Public Class ChartXAxis _
    Inherits ChartAxis

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartAxis
Telerik.Reporting.Charting..::.ChartXAxis

See Also

ChartXAxis Members
Telerik.Reporting.Charting Namespace


ChartXAxis Members

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis Members
ChartXAxis Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartXAxis type exposes the following members.

Constructors

Name | Description
ChartXAxis | Overloaded.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode. (Inherited from ChartAxis.)
AutoCalcAxisExtents | Auto determines the min and max value of the axis (Inherited from ChartAxis.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis. (Inherited from ChartAxis.)
ClearDataBoundState | Clears all data bound settings for axis
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings (Overrides ChartAxis..::.DisableCachedValues()()().)
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate (Overrides ChartAxis..::.GetAxisEndCoord()()().)
GetAxisStartCoord | Gets the start value coordinate (Overrides ChartAxis..::.GetAxisStartCoord()()().)
GetDistance | Gets distance between points (Inherited from ChartAxis.)
GetItem | Gets the item at the specified index. (Inherited from ChartAxis.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
GetPixelStep | Returns axis step in pixels
LoadViewState | Loading ViewState data (Inherited from ChartAxis.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items (Inherited from ChartAxis.)
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis. (Inherited from ChartAxis.)
ResetMaxValue | Resets the MaxValue to default (Inherited from ChartAxis.)
ResetMinValue | Resets the MinValue to default (Inherited from ChartAxis.)
ResetStep | Resets the Step value to default (Inherited from ChartAxis.)
SaveViewState | Saves data to a State Bag (Inherited from ChartAxis.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position. (Inherited from ChartAxis.)
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value (Inherited from ChartAxis.)
SetMinValue | Sets the min axis range value (Inherited from ChartAxis.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeMinValue | The axis MinValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeStep | The axis Step design time serialization reason (Inherited from ChartAxis.)
TrackViewState | Tracking ViewState (Inherited from ChartAxis.)

Fields

Name | Description
chartAxisAppearance | ChartAxis style (Inherited from ChartAxis.)
chartAxisItems | ChartAxis items (Inherited from ChartAxis.)
chartAxisLabel | ChartAxis main label (Inherited from ChartAxis.)
chartAxisMaxAxisValue | Maximum series value (Inherited from ChartAxis.)
chartAxisMaxItemValue | Max axis item value (Inherited from ChartAxis.)
chartAxisMinAxisValue | Minimum series value (Inherited from ChartAxis.)
chartAxisMinItemValue | Min axis item value (Inherited from ChartAxis.)
chartAxisParent | Parent element (Inherited from ChartAxis.)
chartAxisPointEnd | Axis zero value end point (Inherited from ChartAxis.)
chartAxisPointStart | Axis start point (Inherited from ChartAxis.)
chartAxisRealIsZeroBased | Is axis zero based (Inherited from ChartAxis.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field. (Inherited from ChartAxis.)
pixelStep | Cached pixel step value.
zeroCoord | Cached zero coordinate value. (Inherited from ChartAxis.)

Properties

Name | Description
Appearance | ChartAxis style (Inherited from ChartAxis.)
AutoScale | Enables or disables automatic axis scaling. (Inherited from ChartAxis.)
AutoShrink | Specifies whether the axis is auto shrink or not.
AxisLabel | ChartAxis label (Inherited from ChartAxis.)
Container | Link to container element (Inherited from RenderedObject.)
DataLabelsColumn | The data source column used as axis items labels source
IsDataBound | Gets whether X ChartAxis data bound or not
IsZeroBased | Specifies whether the axis begins from 0. (Inherited from ChartAxis.)
Item | Returns the axis item at the specified position. (Inherited from ChartAxis.)
Items | Returns a collection of axis items. (Inherited from ChartAxis.)
LabelStep | Draw each 1,2,...,n item (Inherited from ChartAxis.)
LayoutMode | Specifies the layout style of the axis.
MaxItemsCount | Gets or sets maximal count of the axis items when auto scaling. (Inherited from ChartAxis.)
MaxValue | Specifies the max value of the axis range. (Inherited from ChartAxis.)
MinValue | Specifies the min value of the axis range. (Inherited from ChartAxis.)
Parent | Parent element (PlotArea) (Inherited from ChartAxis.)
Step | Specifies the step at which axis values are calculated (Inherited from ChartAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis should be rendered. (Inherited from ChartAxis.)
VisibleValues | Determines the type of shown values (Inherited from ChartAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


ChartXAxis Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis Constructor
ChartXAxis Class See Also Send Feedback

Overload List

Name | Description
ChartXAxis(ChartPlotArea) | Creates a new instance of the ChartXAxis class.
ChartXAxis(ChartPlotArea, IContainer) | Creates a new instance of the ChartXAxis class.

See Also

ChartXAxis Class
ChartXAxis Members
Telerik.Reporting.Charting Namespace


ChartXAxis Constructor (ChartPlotArea)

[image]

Telerik Reporting Q2 2012
ChartXAxis Constructor (ChartPlotArea)
ChartXAxis Class See Also Send Feedback
Creates a new instance of the ChartXAxis class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartXAxis(
    ChartPlotArea parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea

See Also

ChartXAxis Class
ChartXAxis Overload
Telerik.Reporting.Charting Namespace


ChartXAxis Constructor (ChartPlotArea, IContainer)

[image]

Telerik Reporting Q2 2012
ChartXAxis Constructor (ChartPlotArea, IContainer)
ChartXAxis Class See Also Send Feedback
Creates a new instance of the ChartXAxis class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartXAxis(
    ChartPlotArea parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
container
Type: Telerik.Reporting.Charting..::.IContainer

See Also

ChartXAxis Class
ChartXAxis Overload
Telerik.Reporting.Charting Namespace


ChartXAxis Fields

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis Fields
ChartXAxis Class See Also Send Feedback

The ChartXAxis type exposes the following members.

Fields

Name | Description
chartAxisAppearance | ChartAxis style (Inherited from ChartAxis.)
chartAxisItems | ChartAxis items (Inherited from ChartAxis.)
chartAxisLabel | ChartAxis main label (Inherited from ChartAxis.)
chartAxisMaxAxisValue | Maximum series value (Inherited from ChartAxis.)
chartAxisMaxItemValue | Max axis item value (Inherited from ChartAxis.)
chartAxisMinAxisValue | Minimum series value (Inherited from ChartAxis.)
chartAxisMinItemValue | Min axis item value (Inherited from ChartAxis.)
chartAxisParent | Parent element (Inherited from ChartAxis.)
chartAxisPointEnd | Axis zero value end point (Inherited from ChartAxis.)
chartAxisPointStart | Axis start point (Inherited from ChartAxis.)
chartAxisRealIsZeroBased | Is axis zero based (Inherited from ChartAxis.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field. (Inherited from ChartAxis.)
pixelStep | Cached pixel step value.
zeroCoord | Cached zero coordinate value. (Inherited from ChartAxis.)

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


pixelStep Field

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.pixelStep Field
ChartXAxis Class See Also Send Feedback
Cached pixel step value.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float pixelStep
Visual Basic (Declaration)
Protected pixelStep As Single

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


ChartXAxis Methods

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis Methods
ChartXAxis Class See Also Send Feedback

The ChartXAxis type exposes the following members.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode. (Inherited from ChartAxis.)
AutoCalcAxisExtents | Auto determines the min and max value of the axis (Inherited from ChartAxis.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis. (Inherited from ChartAxis.)
ClearDataBoundState | Clears all data bound settings for axis
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings (Overrides ChartAxis..::.DisableCachedValues()()().)
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate (Overrides ChartAxis..::.GetAxisEndCoord()()().)
GetAxisStartCoord | Gets the start value coordinate (Overrides ChartAxis..::.GetAxisStartCoord()()().)
GetDistance | Gets distance between points (Inherited from ChartAxis.)
GetItem | Gets the item at the specified index. (Inherited from ChartAxis.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
GetPixelStep | Returns axis step in pixels
LoadViewState | Loading ViewState data (Inherited from ChartAxis.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items (Inherited from ChartAxis.)
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis. (Inherited from ChartAxis.)
ResetMaxValue | Resets the MaxValue to default (Inherited from ChartAxis.)
ResetMinValue | Resets the MinValue to default (Inherited from ChartAxis.)
ResetStep | Resets the Step value to default (Inherited from ChartAxis.)
SaveViewState | Saves data to a State Bag (Inherited from ChartAxis.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position. (Inherited from ChartAxis.)
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value (Inherited from ChartAxis.)
SetMinValue | Sets the min axis range value (Inherited from ChartAxis.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeMinValue | The axis MinValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeStep | The axis Step design time serialization reason (Inherited from ChartAxis.)
TrackViewState | Tracking ViewState (Inherited from ChartAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


AddItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis..::.AddItem Method
ChartXAxis Class See Also Send Feedback

Overload List

Name | Description
AddItem(String) | Adds a new axis item.
AddItem(List<(Of <(ChartAxisItem>)>)) | Adds ChartAxisItems to the axis. (Inherited from ChartAxis.)
AddItem(array<ChartAxisItem>[]()[]) | Adds ChartAxisItems to the axis. (Inherited from ChartAxis.)
AddItem(ChartAxisItemsCollection) | Adds a ChartAxisItemsCollection to the axis. (Inherited from ChartAxis.)
AddItem(String, Color) | Adds a new axis item.
AddItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Adds a ChartAxisItem to the axis. (Inherited from ChartAxis.)
AddItem(String, Color, Boolean) | Adds a new ChartAxisItem object to the axis with the specified label and color. (Inherited from ChartAxis.)

See Also

ChartXAxis Class
ChartXAxis Members
Telerik.Reporting.Charting Namespace


AddItem Method (String)

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.AddItem Method (String)
ChartXAxis Class See Also Send Feedback
Adds a new axis item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    string label
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    label As String _
)

Parameters

label
Type: System..::.String
Item text

See Also

ChartXAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


AddItem Method (String, Color)

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.AddItem Method (String, Color)
ChartXAxis Class See Also Send Feedback
Adds a new axis item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddItem(
    string label,
    Color color
)
Visual Basic (Declaration)
Public Sub AddItem ( _
    label As String, _
    color As Color _
)

Parameters

label
Type: System..::.String
Item text
color
Type: System.Drawing..::.Color
Item text color

See Also

ChartXAxis Class
AddItem Overload
Telerik.Reporting.Charting Namespace


ClearDataBoundState Method

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.ClearDataBoundState Method
ChartXAxis Class See Also Send Feedback
Clears all data bound settings for axis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearDataBoundState()
Visual Basic (Declaration)
Public Sub ClearDataBoundState

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


DisableCachedValues Method

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.DisableCachedValues Method
ChartXAxis Class See Also Send Feedback
Restores initial values of cached axis settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void DisableCachedValues()
Visual Basic (Declaration)
Protected Overrides Sub DisableCachedValues

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis..::.Dispose Method
ChartXAxis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartAxis.)

See Also

ChartXAxis Class
ChartXAxis Members
Telerik.Reporting.Charting Namespace


GetAxisEndCoord Method

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.GetAxisEndCoord Method
ChartXAxis Class See Also Send Feedback
Gets the end value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal override float GetAxisEndCoord()
Visual Basic (Declaration)
Protected Friend Overrides Function GetAxisEndCoord As Single

Return Value

Coordinate

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


GetAxisStartCoord Method

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.GetAxisStartCoord Method
ChartXAxis Class See Also Send Feedback
Gets the start value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal override float GetAxisStartCoord()
Visual Basic (Declaration)
Protected Friend Overrides Function GetAxisStartCoord As Single

Return Value

Coordinate

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


GetPixelStep Method

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.GetPixelStep Method
ChartXAxis Class See Also Send Feedback
Returns axis step in pixels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal float GetPixelStep()
Visual Basic (Declaration)
Protected Friend Function GetPixelStep As Single

Return Value

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


RemoveItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis..::.RemoveItem Method
ChartXAxis Class See Also Send Feedback

Overload List

Name | Description
RemoveItem(Int32) | Removes the ChartAxisItem at the specified index. (Inherited from ChartAxis.)
RemoveItem(Int32, array<Int32>[]()[]) | Removes the ChartAxisItems at the specified indexes. (Inherited from ChartAxis.)
RemoveItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Removes the ChartAxisItem specified. (Inherited from ChartAxis.)

See Also

ChartXAxis Class
ChartXAxis Members
Telerik.Reporting.Charting Namespace


SetItemLabel Method

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis..::.SetItemLabel Method
ChartXAxis Class See Also Send Feedback

Overload List

Name | Description
SetItemLabel(Int32, String) | Sets new label text for the axis item at the specified position. (Inherited from ChartAxis.)
SetItemLabel(Int32, ChartAxisItem) | Sets new label for the axis item at the specified position. (Inherited from ChartAxis.)

See Also

ChartXAxis Class
ChartXAxis Members
Telerik.Reporting.Charting Namespace


ChartXAxis Properties

[image] [image]

Telerik Reporting Q2 2012
ChartXAxis Properties
ChartXAxis Class See Also Send Feedback

The ChartXAxis type exposes the following members.

Properties

Name | Description
Appearance | ChartAxis style (Inherited from ChartAxis.)
AutoScale | Enables or disables automatic axis scaling. (Inherited from ChartAxis.)
AutoShrink | Specifies whether the axis is auto shrink or not.
AxisLabel | ChartAxis label (Inherited from ChartAxis.)
Container | Link to container element (Inherited from RenderedObject.)
DataLabelsColumn | The data source column used as axis items labels source
IsDataBound | Gets whether X ChartAxis data bound or not
IsZeroBased | Specifies whether the axis begins from 0. (Inherited from ChartAxis.)
Item | Returns the axis item at the specified position. (Inherited from ChartAxis.)
Items | Returns a collection of axis items. (Inherited from ChartAxis.)
LabelStep | Draw each 1,2,...,n item (Inherited from ChartAxis.)
LayoutMode | Specifies the layout style of the axis.
MaxItemsCount | Gets or sets maximal count of the axis items when auto scaling. (Inherited from ChartAxis.)
MaxValue | Specifies the max value of the axis range. (Inherited from ChartAxis.)
MinValue | Specifies the min value of the axis range. (Inherited from ChartAxis.)
Parent | Parent element (PlotArea) (Inherited from ChartAxis.)
Step | Specifies the step at which axis values are calculated (Inherited from ChartAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies whether the axis should be rendered. (Inherited from ChartAxis.)
VisibleValues | Determines the type of shown values (Inherited from ChartAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


AutoShrink Property

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.AutoShrink Property
ChartXAxis Class See Also Send Feedback
Specifies whether the axis is auto shrink or not.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool AutoShrink { get; set; }
Visual Basic (Declaration)
Public Property AutoShrink As Boolean

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


DataLabelsColumn Property

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.DataLabelsColumn Property
ChartXAxis Class See Also Send Feedback
The data source column used as axis items labels source

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataLabelsColumn { get; set; }
Visual Basic (Declaration)
Public Property DataLabelsColumn As String

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


IsDataBound Property

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.IsDataBound Property
ChartXAxis Class See Also Send Feedback
Gets whether X ChartAxis data bound or not

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsDataBound { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsDataBound As Boolean

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


LayoutMode Property

[image]

Telerik Reporting Q2 2012
ChartXAxis..::.LayoutMode Property
ChartXAxis Class See Also Send Feedback
Specifies the layout style of the axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisLayoutMode LayoutMode { get; set; }
Visual Basic (Declaration)
Public Property LayoutMode As ChartAxisLayoutMode

See Also

ChartXAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Class

[image]

Telerik Reporting Q2 2012
ChartYAxis Class
Members See Also Send Feedback
Represents a chart Y Axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartYAxis : ChartAxis
Visual Basic (Declaration)
Public Class ChartYAxis _
    Inherits ChartAxis

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartAxis
Telerik.Reporting.Charting..::.ChartYAxis

See Also

ChartYAxis Members
Telerik.Reporting.Charting Namespace


ChartYAxis Members

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis Members
ChartYAxis Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ChartYAxis type exposes the following members.

Constructors

Name | Description
ChartYAxis | Creates a new instance of the ChartYAxis class.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode. (Inherited from ChartAxis.)
AutoCalcAxisExtents | Auto determines the min and max value of the axis (Inherited from ChartAxis.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis. (Inherited from ChartAxis.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings (Inherited from ChartAxis.)
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate (Overrides ChartAxis..::.GetAxisEndCoord()()().)
GetAxisStartCoord | Gets the start value coordinate (Overrides ChartAxis..::.GetAxisStartCoord()()().)
GetDistance | Gets distance between points (Inherited from ChartAxis.)
GetItem | Gets the item at the specified index. (Inherited from ChartAxis.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads Y axis settings from view state (Overrides ChartAxis..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items (Inherited from ChartAxis.)
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis. (Inherited from ChartAxis.)
ResetMaxValue | Resets the MaxValue to default (Inherited from ChartAxis.)
ResetMinValue | Resets the MinValue to default (Inherited from ChartAxis.)
ResetStep | Resets the Step value to default (Inherited from ChartAxis.)
SaveViewState | Saves axis settings to a state bag (Overrides ChartAxis..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position. (Inherited from ChartAxis.)
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value (Inherited from ChartAxis.)
SetMinValue | Sets the min axis range value (Inherited from ChartAxis.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeMinValue | The axis MinValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeStep | The axis Step design time serialization reason (Inherited from ChartAxis.)
TrackViewState | Tracks view state changes (Overrides ChartAxis..::.TrackViewState()()().)

Fields

Name | Description
chartAxisAppearance | ChartAxis style (Inherited from ChartAxis.)
chartAxisItems | ChartAxis items (Inherited from ChartAxis.)
chartAxisLabel | ChartAxis main label (Inherited from ChartAxis.)
chartAxisMaxAxisValue | Maximum series value (Inherited from ChartAxis.)
chartAxisMaxItemValue | Max axis item value (Inherited from ChartAxis.)
chartAxisMinAxisValue | Minimum series value (Inherited from ChartAxis.)
chartAxisMinItemValue | Min axis item value (Inherited from ChartAxis.)
chartAxisParent | Parent element (Inherited from ChartAxis.)
chartAxisPointEnd | Axis zero value end point (Inherited from ChartAxis.)
chartAxisPointStart | Axis start point (Inherited from ChartAxis.)
chartAxisRealIsZeroBased | Is axis zero based (Inherited from ChartAxis.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field. (Inherited from ChartAxis.)
zeroCoord | Cached zero coordinate value. (Inherited from ChartAxis.)

Properties

Name Description
Appearance
ChartAxis style
(Inherited from ChartAxis.)
AutoScale
Enables or disables automatic axis scaling.
(Inherited from ChartAxis.)
AxisLabel
ChartAxis label
(Inherited from ChartAxis.)
AxisMode
Gets or sets the style of the Y axis.
Container
Link to container element
(Inherited from RenderedObject.)
IsLogarithmic
Use Logarithmic scale or not.
IsZeroBased
Specifies whether the axis begins from 0.
(Inherited from ChartAxis.)
Item
Returns the axis item at the specified position.
(Inherited from ChartAxis.)
Items
Returns a collection of axis items.
(Inherited from ChartAxis.)
LabelStep
Draw each 1,2,...,n item
(Inherited from ChartAxis.)
LogarithmBase
Logarithm base.

Remarks

Min possible value is 2
MaxItemsCount
Gets or sets maximal count of the axis items when auto scaling.
(Inherited from ChartAxis.)
MaxValue
Specifies the max value of the axis range.
(Overrides ChartAxis..::.MaxValue.)
MinValue
Specifies the min value of the axis range.
(Overrides ChartAxis..::.MinValue.)
Parent
Parent element (PlotArea)
(Inherited from ChartAxis.)
ScaleBreaks
Scale breaks settings
Segments
Segments collection
Step
Specifies the step at which axis values are calculated
(Overrides ChartAxis..::.Step.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies whether the axis should be rendered.
(Inherited from ChartAxis.)
VisibleValues
Determines the type of shown values
(Inherited from ChartAxis.)
YAxisType
Defines a type of YAxis

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Constructor

[image]

Telerik Reporting Q2 2012
ChartYAxis Constructor
ChartYAxis Class See Also Send Feedback
Creates a new instance of the ChartYAxis class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxis(
    ChartPlotArea parent,
    ChartYAxisType type
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea, _
    type As ChartYAxisType _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
type
Type: Telerik.Reporting.Charting..::.ChartYAxisType

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Fields

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis Fields
ChartYAxis Class See Also Send Feedback

The ChartYAxis type exposes the following members.

Fields

Name | Description
chartAxisAppearance | ChartAxis style (Inherited from ChartAxis.)
chartAxisItems | ChartAxis items (Inherited from ChartAxis.)
chartAxisLabel | ChartAxis main label (Inherited from ChartAxis.)
chartAxisMaxAxisValue | Maximum series value (Inherited from ChartAxis.)
chartAxisMaxItemValue | Max axis item value (Inherited from ChartAxis.)
chartAxisMinAxisValue | Minimum series value (Inherited from ChartAxis.)
chartAxisMinItemValue | Min axis item value (Inherited from ChartAxis.)
chartAxisParent | Parent element (Inherited from ChartAxis.)
chartAxisPointEnd | Axis zero value end point (Inherited from ChartAxis.)
chartAxisPointStart | Axis start point (Inherited from ChartAxis.)
chartAxisRealIsZeroBased | Is axis zero based (Inherited from ChartAxis.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
pixelsPerValue | Pixels per value field. (Inherited from ChartAxis.)
zeroCoord | Cached zero coordinate value. (Inherited from ChartAxis.)

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Methods

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis Methods
ChartYAxis Class See Also Send Feedback

The ChartYAxis type exposes the following members.

Methods

Name | Description
AddItem | Overloaded.
AddRange | Automatically adds new axis items in AutoScale mode. (Inherited from ChartAxis.)
AutoCalcAxisExtents | Auto determines the min and max value of the axis (Inherited from ChartAxis.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clears data values of the axis. (Inherited from ChartAxis.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
DisableCachedValues | Restores initial values of cached axis settings (Inherited from ChartAxis.)
Dispose | Overloaded.
GetAxisEndCoord | Gets the end value coordinate (Overrides ChartAxis..::.GetAxisEndCoord()()().)
GetAxisStartCoord | Gets the start value coordinate (Overrides ChartAxis..::.GetAxisStartCoord()()().)
GetDistance | Gets distance between points (Inherited from ChartAxis.)
GetItem | Gets the item at the specified index. (Inherited from ChartAxis.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads Y axis settings from view state (Overrides ChartAxis..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
RemoveAllItems | Removes all items (Inherited from ChartAxis.)
RemoveItem | Overloaded.
RemoveLastItem | Removes the last item from the axis. (Inherited from ChartAxis.)
ResetMaxValue | Resets the MaxValue to default (Inherited from ChartAxis.)
ResetMinValue | Resets the MinValue to default (Inherited from ChartAxis.)
ResetStep | Resets the Step value to default (Inherited from ChartAxis.)
SaveViewState | Saves axis settings to a state bag (Overrides ChartAxis..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetItemColor | Sets new color for the axis item text at the specified position. (Inherited from ChartAxis.)
SetItemLabel | Overloaded.
SetMaxValue | Sets the maximum axis range value (Inherited from ChartAxis.)
SetMinValue | Sets the min axis range value (Inherited from ChartAxis.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
ShouldSerializeMaxValue | The axis MaxValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeMinValue | The axis MinValue design time serialization reason (Inherited from ChartAxis.)
ShouldSerializeStep | The axis Step design time serialization reason (Inherited from ChartAxis.)
TrackViewState | Tracks view state changes (Overrides ChartAxis..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


AddItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis..::.AddItem Method
ChartYAxis Class See Also Send Feedback

Overload List

Name | Description
AddItem(List<(Of <(ChartAxisItem>)>)) | Adds ChartAxisItems to the axis. (Inherited from ChartAxis.)
AddItem(array<ChartAxisItem>[]()[]) | Adds ChartAxisItems to the axis. (Inherited from ChartAxis.)
AddItem(ChartAxisItemsCollection) | Adds a ChartAxisItemsCollection to the axis. (Inherited from ChartAxis.)
AddItem(String, Color) | Adds a new ChartAxisItem object to the axis with the specified label and color. (Inherited from ChartAxis.)
AddItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Adds a ChartAxisItem to the axis. (Inherited from ChartAxis.)
AddItem(String, Color, Boolean) | Adds a new ChartAxisItem object to the axis with the specified label and color. (Inherited from ChartAxis.)

See Also

ChartYAxis Class
ChartYAxis Members
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis..::.Dispose Method
ChartYAxis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartAxis.)

See Also

ChartYAxis Class
ChartYAxis Members
Telerik.Reporting.Charting Namespace


GetAxisEndCoord Method

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.GetAxisEndCoord Method
ChartYAxis Class See Also Send Feedback
Gets the end value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal override float GetAxisEndCoord()
Visual Basic (Declaration)
Protected Friend Overrides Function GetAxisEndCoord As Single

Return Value

Coordinate

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


GetAxisStartCoord Method

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.GetAxisStartCoord Method
ChartYAxis Class See Also Send Feedback
Gets the start value coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal override float GetAxisStartCoord()
Visual Basic (Declaration)
Protected Friend Overrides Function GetAxisStartCoord As Single

Return Value

Coordinate

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.LoadViewState Method
ChartYAxis Class See Also Send Feedback
Loads Y axis settings from view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
View state

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


RemoveItem Method

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis..::.RemoveItem Method
ChartYAxis Class See Also Send Feedback

Overload List

Name | Description
RemoveItem(Int32) | Removes the ChartAxisItem at the specified index. (Inherited from ChartAxis.)
RemoveItem(Int32, array<Int32>[]()[]) | Removes the ChartAxisItems at the specified indexes. (Inherited from ChartAxis.)
RemoveItem(ChartAxisItem, array<ChartAxisItem>[]()[]) | Removes the ChartAxisItem specified. (Inherited from ChartAxis.)

See Also

ChartYAxis Class
ChartYAxis Members
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.SaveViewState Method
ChartYAxis Class See Also Send Feedback
Saves axis settings to a state bag

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


SetItemLabel Method

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis..::.SetItemLabel Method
ChartYAxis Class See Also Send Feedback

Overload List

Name | Description
SetItemLabel(Int32, String) | Sets new label text for the axis item at the specified position. (Inherited from ChartAxis.)
SetItemLabel(Int32, ChartAxisItem) | Sets new label for the axis item at the specified position. (Inherited from ChartAxis.)

See Also

ChartYAxis Class
ChartYAxis Members
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.TrackViewState Method
ChartYAxis Class See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxis Properties

[image] [image]

Telerik Reporting Q2 2012
ChartYAxis Properties
ChartYAxis Class See Also Send Feedback

The ChartYAxis type exposes the following members.

Properties

Name Description
Appearance
ChartAxis style
(Inherited from ChartAxis.)
AutoScale
Enables or disables automatic axis scaling.
(Inherited from ChartAxis.)
AxisLabel
ChartAxis label
(Inherited from ChartAxis.)
AxisMode
Gets or sets the style of the Y axis.
Container
Link to container element
(Inherited from RenderedObject.)
IsLogarithmic
Use Logarithmic scale or not.
IsZeroBased
Specifies whether the axis begins from 0.
(Inherited from ChartAxis.)
Item
Returns the axis item at the specified position.
(Inherited from ChartAxis.)
Items
Returns a collection of axis items.
(Inherited from ChartAxis.)
LabelStep
Draw each 1,2,...,n item
(Inherited from ChartAxis.)
LogarithmBase
Logarithm base.

Remarks

Min possible value is 2
MaxItemsCount
Gets or sets maximal count of the axis items when auto scaling.
(Inherited from ChartAxis.)
MaxValue
Specifies the max value of the axis range.
(Overrides ChartAxis..::.MaxValue.)
MinValue
Specifies the min value of the axis range.
(Overrides ChartAxis..::.MinValue.)
Parent
Parent element (PlotArea)
(Inherited from ChartAxis.)
ScaleBreaks
Scale breaks settings
Segments
Segments collection
Step
Specifies the step at which axis values are calculated
(Overrides ChartAxis..::.Step.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies whether the axis should be rendered.
(Inherited from ChartAxis.)
VisibleValues
Determines the type of shown values
(Inherited from ChartAxis.)
YAxisType
Defines a type of YAxis

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


AxisMode Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.AxisMode Property
ChartYAxis Class See Also Send Feedback
Gets or sets the style of the Y axis.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxisMode AxisMode { get; set; }
Visual Basic (Declaration)
Public Property AxisMode As ChartYAxisMode

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


IsLogarithmic Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.IsLogarithmic Property
ChartYAxis Class See Also Send Feedback
Use Logarithmic scale or not.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsLogarithmic { get; set; }
Visual Basic (Declaration)
Public Property IsLogarithmic As Boolean

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


LogarithmBase Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.LogarithmBase Property
ChartYAxis Class See Also Send Feedback
Logarithm base.

Remarks

Min possible value is 2

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double LogarithmBase { get; set; }
Visual Basic (Declaration)
Public Property LogarithmBase As Double

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


MaxValue Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.MaxValue Property
ChartYAxis Class See Also Send Feedback
Specifies the max value of the axis range.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override double MaxValue { get; set; }
Visual Basic (Declaration)
Public Overrides Property MaxValue As Double

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


MinValue Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.MinValue Property
ChartYAxis Class See Also Send Feedback
Specifies the min value of the axis range.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override double MinValue { get; set; }
Visual Basic (Declaration)
Public Overrides Property MinValue As Double

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ScaleBreaks Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.ScaleBreaks Property
ChartYAxis Class See Also Send Feedback
Scale breaks settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ScaleBreak ScaleBreaks { get; }
Visual Basic (Declaration)
Public ReadOnly Property ScaleBreaks As ScaleBreak

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


Segments Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.Segments Property
ChartYAxis Class See Also Send Feedback
Segments collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisSegmentCollection Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As AxisSegmentCollection

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


Step Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.Step Property
ChartYAxis Class See Also Send Feedback
Specifies the step at which axis values are calculated

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override double Step { get; set; }
Visual Basic (Declaration)
Public Overrides Property Step As Double

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


YAxisType Property

[image]

Telerik Reporting Q2 2012
ChartYAxis..::.YAxisType Property
ChartYAxis Class See Also Send Feedback
Defines a type of YAxis

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartYAxisType YAxisType { get; set; }
Visual Basic (Declaration)
Public Property YAxisType As ChartYAxisType

See Also

ChartYAxis Class
Telerik.Reporting.Charting Namespace


ChartYAxisMode Enumeration

[image]

Telerik Reporting Q2 2012
ChartYAxisMode Enumeration
See Also Send Feedback
Specifies the Y axis modes.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartYAxisMode
Visual Basic (Declaration)
Public Enumeration ChartYAxisMode

Members

Member name | Description
Normal | Sets default Y axis mode.
Extended | Extends the axis when AutoScale property is set to true.

See Also

Telerik.Reporting.Charting Namespace


ChartYAxisType Enumeration

[image]

Telerik Reporting Q2 2012
ChartYAxisType Enumeration
See Also Send Feedback
Primary or Secondary

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartYAxisType
Visual Basic (Declaration)
Public Enumeration ChartYAxisType

Members

Member name | Description
Primary | Specifies primary Y-Axis
Secondary | Specifies secondary Y-Axis

See Also

Telerik.Reporting.Charting Namespace


ChartZoomEventArgs Class

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs Class
Members See Also Send Feedback
Provides data for RadChart.Zoom event.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartZoomEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ChartZoomEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting.Charting..::.ChartZoomEventArgs

See Also

ChartZoomEventArgs Members
Telerik.Reporting.Charting Namespace


ChartZoomEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ChartZoomEventArgs Members
ChartZoomEventArgs Class Constructors Properties See Also Send Feedback

The ChartZoomEventArgs type exposes the following members.

Constructors

Name | Description
ChartZoomEventArgs | Initializes a new instance of the ChartZoomEventArgs class

Properties

Name | Description
XScaleNew |
XScaleOld |
YScaleNew |
YScaleOld |

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


ChartZoomEventArgs Constructor

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs Constructor
ChartZoomEventArgs Class See Also Send Feedback
Initializes a new instance of the ChartZoomEventArgs class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartZoomEventArgs(
    double xScaleOld,
    double xScaleNew,
    double yScaleOld,
    double yScaleNew
)
Visual Basic (Declaration)
Public Sub New ( _
    xScaleOld As Double, _
    xScaleNew As Double, _
    yScaleOld As Double, _
    yScaleNew As Double _
)

Parameters

xScaleOld
Type: System..::.Double
xScaleNew
Type: System..::.Double
yScaleOld
Type: System..::.Double
yScaleNew
Type: System..::.Double

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


ChartZoomEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ChartZoomEventArgs Properties
ChartZoomEventArgs Class See Also Send Feedback

The ChartZoomEventArgs type exposes the following members.

Properties

Name | Description
XScaleNew |
XScaleOld |
YScaleNew |
YScaleOld |

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


XScaleNew Property

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs..::.XScaleNew Property
ChartZoomEventArgs Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double XScaleNew { get; set; }
Visual Basic (Declaration)
Public Property XScaleNew As Double

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


XScaleOld Property

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs..::.XScaleOld Property
ChartZoomEventArgs Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double XScaleOld { get; set; }
Visual Basic (Declaration)
Public Property XScaleOld As Double

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


YScaleNew Property

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs..::.YScaleNew Property
ChartZoomEventArgs Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YScaleNew { get; set; }
Visual Basic (Declaration)
Public Property YScaleNew As Double

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


YScaleOld Property

[image]

Telerik Reporting Q2 2012
ChartZoomEventArgs..::.YScaleOld Property
ChartZoomEventArgs Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double YScaleOld { get; set; }
Visual Basic (Declaration)
Public Property YScaleOld As Double

See Also

ChartZoomEventArgs Class
Telerik.Reporting.Charting Namespace


ColorBlend Class

[image]

Telerik Reporting Q2 2012
ColorBlend Class
Members See Also Send Feedback
Defines arrays of elements and positions used for interpolating GradientElement blending in a multicolor gradient.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ColorBlend : ChartingStateManagedCollection<GradientElement>,
    ICloneable
Visual Basic (Declaration)
Public Class ColorBlend _
    Inherits ChartingStateManagedCollection(Of GradientElement) _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' GradientElement >)>)>
Telerik.Reporting.Charting..::.ColorBlend

See Also

ColorBlend Members
Telerik.Reporting.Charting Namespace


ColorBlend Members

[image] [image]

Telerik Reporting Q2 2012
ColorBlend Members
ColorBlend Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ColorBlend type exposes the following members.

Constructors

Name | Description
ColorBlend | Overloaded.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Overloaded.
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clone | Clone this object.
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Equals | Comparing two objects. (Overrides Object..::.Equals(Object).)
GetBrush | Returns gradient brush
GetColor | Gets color at specified position.
GetColors | Gets ColorBlend's colors.
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetPositions | Gets ColorBlend's positions.
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadFrom | Load pairs colors\positions from specified object.
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


ColorBlend Constructor

[image] [image]

Telerik Reporting Q2 2012
ColorBlend Constructor
ColorBlend Class See Also Send Feedback

Overload List

Name | Description
ColorBlend()()() | Create new instance of ColorBlend class.
ColorBlend(array<Color>[]()[]) | Create new instance of ColorBlend class.
ColorBlend(Object) | Create new instance of ColorBlend class.
ColorBlend(array<Color>[]()[], Object) | Create new instance of ColorBlend class.
ColorBlend(array<Color>[]()[], array<Single>[]()[]) | Create new instance of ColorBlend class.
ColorBlend(array<Color>[]()[], array<Single>[]()[], Object) | Create new instance of ColorBlend class.

See Also

ColorBlend Class
ColorBlend Members
Telerik.Reporting.Charting Namespace


ColorBlend Constructor

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend()
Visual Basic (Declaration)
Public Sub New

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Constructor (Color[])

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor (array<Color>[]()[][])
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend(
    Color[] colors
)
Visual Basic (Declaration)
Public Sub New ( _
    colors As Color() _
)

Parameters

colors
Type: array< System.Drawing..::.Color >[]()[][]
Colors to add

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Constructor (Object)

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor (Object)
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element.

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Constructor (Color[], Object)

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor (array<Color>[]()[][], Object)
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend(
    Color[] colors,
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    colors As Color(), _
    containerObject As Object _
)

Parameters

colors
Type: array< System.Drawing..::.Color >[]()[][]
Colors to add to the object
containerObject
Type: System..::.Object
Container element

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Constructor (Color[], Single[])

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor (array<Color>[]()[][], array<Single>[]()[][])
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend(
    Color[] colors,
    float[] positions
)
Visual Basic (Declaration)
Public Sub New ( _
    colors As Color(), _
    positions As Single() _
)

Parameters

colors
Type: array< System.Drawing..::.Color >[]()[][]
Colors to add to the object
positions
Type: array< System..::.Single >[]()[][]
Positions of colors

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Constructor (Color[], Single[], Object)

[image]

Telerik Reporting Q2 2012
ColorBlend Constructor (array<Color>[]()[][], array<Single>[]()[][], Object)
ColorBlend Class See Also Send Feedback
Create new instance of ColorBlend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend(
    Color[] colors,
    float[] positions,
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    colors As Color(), _
    positions As Single(), _
    containerObject As Object _
)

Parameters

colors
Type: array< System.Drawing..::.Color >[]()[][]
Colors to add to the object.
positions
Type: array< System..::.Single >[]()[][]
Positions of colors.
containerObject
Type: System..::.Object
Container element

See Also

ColorBlend Class
ColorBlend Overload
Telerik.Reporting.Charting Namespace


ColorBlend Methods

[image] [image]

Telerik Reporting Q2 2012
ColorBlend Methods
ColorBlend Class See Also Send Feedback

The ColorBlend type exposes the following members.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Overloaded.
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clone | Clone this object.
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Equals | Comparing two objects. (Overrides Object..::.Equals(Object).)
GetBrush | Returns gradient brush
GetColor | Gets color at specified position.
GetColors | Gets ColorBlend's colors.
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetPositions | Gets ColorBlend's positions.
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadFrom | Load pairs colors\positions from specified object.
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


AddRange Method

[image] [image]

Telerik Reporting Q2 2012
ColorBlend..::.AddRange Method
ColorBlend Class See Also Send Feedback

Overload List

Name | Description
AddRange(array<T>[]()[]) | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange(ColorBlend) | Adds a range of elements to the collection.

See Also

ColorBlend Class
ColorBlend Members
Telerik.Reporting.Charting Namespace


AddRange Method (ColorBlend)

[image]

Telerik Reporting Q2 2012
ColorBlend..::.AddRange Method (ColorBlend)
ColorBlend Class See Also Send Feedback
Adds a range of elements to the collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    ColorBlend blend
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    blend As ColorBlend _
)

Parameters

blend
Type: Telerik.Reporting.Charting..::.ColorBlend
Object that contains element to add

See Also

ColorBlend Class
AddRange Overload
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.Clone Method
ColorBlend Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of ColorBlend class with the same fields as this one.

Implements

ICloneable..::.Clone()()()

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.Equals Method
ColorBlend Class See Also Send Feedback
Comparing two objects.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare.

Return Value

Whether objects equal or not

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


GetBrush Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.GetBrush Method
ColorBlend Class See Also Send Feedback
Returns gradient brush

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LinearGradientBrush GetBrush(
    RectangleF rectangle,
    float angle
)
Visual Basic (Declaration)
Public Function GetBrush ( _
    rectangle As RectangleF, _
    angle As Single _
) As LinearGradientBrush

Parameters

rectangle
Type: System.Drawing..::.RectangleF
Rectangle of brush
angle
Type: System..::.Single
Angle of brush.

Return Value

Gradient brush

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


GetColor Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.GetColor Method
ColorBlend Class See Also Send Feedback
Gets color at specified position.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color GetColor(
    float pos
)
Visual Basic (Declaration)
Public Function GetColor ( _
    pos As Single _
) As Color

Parameters

pos
Type: System..::.Single
Position to get color.

Return Value

Color at specified position.

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


GetColors Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.GetColors Method
ColorBlend Class See Also Send Feedback
Gets ColorBlend's colors.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color[] GetColors()
Visual Basic (Declaration)
Public Function GetColors As Color()

Return Value

ColorBlend's colors.

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.GetHashCode Method
ColorBlend Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


GetPositions Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.GetPositions Method
ColorBlend Class See Also Send Feedback
Gets ColorBlend's positions.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float[] GetPositions()
Visual Basic (Declaration)
Public Function GetPositions As Single()

Return Value

ColorBlend's positions.

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


LoadFrom Method

[image]

Telerik Reporting Q2 2012
ColorBlend..::.LoadFrom Method
ColorBlend Class See Also Send Feedback
Load pairs colors\positions from specified object.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void LoadFrom(
    ColorBlend blend
)
Visual Basic (Declaration)
Public Sub LoadFrom ( _
    blend As ColorBlend _
)

Parameters

blend
Type: Telerik.Reporting.Charting..::.ColorBlend
Object to load from.

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


ColorBlend Properties

[image] [image]

Telerik Reporting Q2 2012
ColorBlend Properties
ColorBlend Class See Also Send Feedback

The ColorBlend type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

ColorBlend Class
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Class

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass Class
Members See Also Send Feedback
Sample class returns DataSet with several columns which could be used as Y values source. Used for a data binding demonstration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ComplexDataSetClass : IDisposable
Visual Basic (Declaration)
Public Class ComplexDataSetClass _
    Implements IDisposable

Remarks

Shows products sales by month.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ComplexDataSetClass

See Also

ComplexDataSetClass Members
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Members

[image] [image]

Telerik Reporting Q2 2012
ComplexDataSetClass Members
ComplexDataSetClass Class Constructors Methods See Also Send Feedback

The ComplexDataSetClass type exposes the following members.

Constructors

Name | Description
ComplexDataSetClass | Constructor. Loads sample data in DataSet

Methods

Name | Description
Dispose | Overloaded.
Finalize | Class destructor (Overrides Object..::.Finalize()()().)
GetData | Gets data

See Also

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Constructor

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass Constructor
ComplexDataSetClass Class See Also Send Feedback
Constructor. Loads sample data in DataSet

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ComplexDataSetClass()
Visual Basic (Declaration)
Public Sub New

See Also

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


ComplexDataSetClass Methods

[image] [image]

Telerik Reporting Q2 2012
ComplexDataSetClass Methods
ComplexDataSetClass Class See Also Send Feedback

The ComplexDataSetClass type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Finalize | Class destructor (Overrides Object..::.Finalize()()().)
GetData | Gets data

See Also

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ComplexDataSetClass..::.Dispose Method
ComplexDataSetClass Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the ComplexDataSetClass
Dispose(Boolean) | Releases the unmanaged resources used by the ComplexDataSetClass and optionally releases the managed resources

See Also

ComplexDataSetClass Class
ComplexDataSetClass Members
Telerik.Reporting.Charting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass..::.Dispose Method
ComplexDataSetClass Class See Also Send Feedback
Releases all resources used by the ComplexDataSetClass

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

ComplexDataSetClass Class
Dispose Overload
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass..::.Dispose Method (Boolean)
ComplexDataSetClass Class See Also Send Feedback
Releases the unmanaged resources used by the ComplexDataSetClass and optionally releases the managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ComplexDataSetClass Class
Dispose Overload
Telerik.Reporting.Charting Namespace


Finalize Method

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass..::.Finalize Method
ComplexDataSetClass Class See Also Send Feedback
Class destructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


GetData Method

[image]

Telerik Reporting Q2 2012
ComplexDataSetClass..::.GetData Method
ComplexDataSetClass Class See Also Send Feedback
Gets data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSet GetData()
Visual Basic (Declaration)
Public Function GetData As DataSet

Return Value

DataSet with sample multicolumn data

See Also

ComplexDataSetClass Class
Telerik.Reporting.Charting Namespace


ContentHorizontalAlign Enumeration

[image]

Telerik Reporting Q2 2012
ContentHorizontalAlign Enumeration
See Also Send Feedback
Horizontal Alignment of text in DataTable cells

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ContentHorizontalAlign
Visual Basic (Declaration)
Public Enumeration ContentHorizontalAlign

Members

Member name | Description
Left |
Center |
Right |

See Also

Telerik.Reporting.Charting Namespace


ContentVerticalAlign Enumeration

[image]

Telerik Reporting Q2 2012
ContentVerticalAlign Enumeration
See Also Send Feedback
Vertical Alignment of text in DataTable cells

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ContentVerticalAlign
Visual Basic (Declaration)
Public Enumeration ContentVerticalAlign

Members

Member name | Description
Top |
Middle |
Bottom |

See Also

Telerik.Reporting.Charting Namespace


CustomFigure Class

[image]

Telerik Reporting Q2 2012
CustomFigure Class
Members See Also Send Feedback
User-defined figure

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CustomFigure : StateManagedObject
Visual Basic (Declaration)
Public Class CustomFigure _
    Inherits StateManagedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.CustomFigure

See Also

CustomFigure Members
Telerik.Reporting.Charting Namespace


CustomFigure Members

[image] [image]

Telerik Reporting Q2 2012
CustomFigure Members
CustomFigure Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CustomFigure type exposes the following members.

Constructors

Name | Description
CustomFigure | Overloaded.

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets String representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Description | Gets and sets Figure's source
Name | Gets and sets Figure's name
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


CustomFigure Constructor

[image] [image]

Telerik Reporting Q2 2012
CustomFigure Constructor
CustomFigure Class See Also Send Feedback

Overload List

Name | Description
CustomFigure()()() | Creates new instance of CustomFigure class.
CustomFigure(String, String) | Creates new instance of CustomFigure class.

See Also

CustomFigure Class
CustomFigure Members
Telerik.Reporting.Charting Namespace


CustomFigure Constructor

[image]

Telerik Reporting Q2 2012
CustomFigure Constructor
CustomFigure Class See Also Send Feedback
Creates new instance of CustomFigure class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomFigure()
Visual Basic (Declaration)
Public Sub New

See Also

CustomFigure Class
CustomFigure Overload
Telerik.Reporting.Charting Namespace


CustomFigure Constructor (String, String)

[image]

Telerik Reporting Q2 2012
CustomFigure Constructor (String, String)
CustomFigure Class See Also Send Feedback
Creates new instance of CustomFigure class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomFigure(
    string name,
    string description
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    description As String _
)

Parameters

name
Type: System..::.String
Name of figure
description
Type: System..::.String
Data in string format used for figure creation

See Also

CustomFigure Class
CustomFigure Overload
Telerik.Reporting.Charting Namespace


CustomFigure Methods

[image] [image]

Telerik Reporting Q2 2012
CustomFigure Methods
CustomFigure Class See Also Send Feedback

The CustomFigure type exposes the following members.

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets String representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
CustomFigure..::.Dispose Method
CustomFigure Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

CustomFigure Class
CustomFigure Members
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
CustomFigure..::.ToString Method
CustomFigure Class See Also Send Feedback
Gets String representation

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

String representation

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


CustomFigure Properties

[image] [image]

Telerik Reporting Q2 2012
CustomFigure Properties
CustomFigure Class See Also Send Feedback

The CustomFigure type exposes the following members.

Properties

Name | Description
Description | Gets and sets Figure's source
Name | Gets and sets Figure's name
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


Description Property

[image]

Telerik Reporting Q2 2012
CustomFigure..::.Description Property
CustomFigure Class See Also Send Feedback
Gets and sets Figure's source

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

Field Value

Data in string format needed to restore object

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
CustomFigure..::.Name Property
CustomFigure Class See Also Send Feedback
Gets and sets Figure's name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

Name of figure

See Also

CustomFigure Class
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Class

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection Class
Members See Also Send Feedback
Custom figures collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CustomFiguresCollection : ChartingStateManagedCollection<CustomFigure>
Visual Basic (Declaration)
Public Class CustomFiguresCollection _
    Inherits ChartingStateManagedCollection(Of CustomFigure)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' CustomFigure >)>)>
Telerik.Reporting.Charting..::.CustomFiguresCollection

See Also

CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Members

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection Members
CustomFiguresCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CustomFiguresCollection type exposes the following members.

Constructors

Name | Description
CustomFiguresCollection | Initializes a new instance of the CustomFiguresCollection class

Methods

Name | Description
Add | Adds a custom figure to the collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds an array of figure items to the figures collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.AddRange(array<T>[]()[]).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Overloaded.
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetFigure | Overloaded.
IndexOf | Overloaded.
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Overloaded.
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Constructor

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection Constructor
CustomFiguresCollection Class See Also Send Feedback
Initializes a new instance of the CustomFiguresCollection class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomFiguresCollection()
Visual Basic (Declaration)
Public Sub New

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Methods

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection Methods
CustomFiguresCollection Class See Also Send Feedback

The CustomFiguresCollection type exposes the following members.

Methods

Name | Description
Add | Adds a custom figure to the collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.Add(T).)
AddRange | Adds an array of figure items to the figures collection. (Overrides ChartingStateManagedCollection<(Of <(T>)>)..::.AddRange(array<T>[]()[]).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Overloaded.
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetFigure | Overloaded.
IndexOf | Overloaded.
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Overloaded.
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.Add Method
CustomFiguresCollection Class See Also Send Feedback
Adds a custom figure to the collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void Add(
    CustomFigure figure
)
Visual Basic (Declaration)
Public Overrides Sub Add ( _
    figure As CustomFigure _
)

Parameters

figure
Type: Telerik.Reporting.Charting..::.CustomFigure
Figure for adding

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.AddRange Method
CustomFiguresCollection Class See Also Send Feedback
Adds an array of figure items to the figures collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override void AddRange(
    CustomFigure[] figure
)
Visual Basic (Declaration)
Public Overrides Sub AddRange ( _
    figure As CustomFigure() _
)

Parameters

figure
Type: array< Telerik.Reporting.Charting..::.CustomFigure >[]()[][]
Figures for adding

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


Contains Method

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.Contains Method
CustomFiguresCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains(String) | Indicates whether the specified figure item exists in the collection.

See Also

CustomFiguresCollection Class
CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


Contains Method (String)

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.Contains Method (String)
CustomFiguresCollection Class See Also Send Feedback
Indicates whether the specified figure item exists in the collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string figureName
)
Visual Basic (Declaration)
Public Function Contains ( _
    figureName As String _
) As Boolean

Parameters

figureName
Type: System..::.String
Figure name

Return Value

Whether the specified figure item exists in the collection or not

See Also

CustomFiguresCollection Class
Contains Overload
Telerik.Reporting.Charting Namespace


GetFigure Method

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.GetFigure Method
CustomFiguresCollection Class See Also Send Feedback

Overload List

Name | Description
GetFigure(Int32) | Gets or sets a custom figures collection item.
GetFigure(String) | Gets or sets a custom figures collection item.

See Also

CustomFiguresCollection Class
CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


GetFigure Method (Int32)

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.GetFigure Method (Int32)
CustomFiguresCollection Class See Also Send Feedback
Gets or sets a custom figures collection item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomFigure GetFigure(
    int index
)
Visual Basic (Declaration)
Public Function GetFigure ( _
    index As Integer _
) As CustomFigure

Parameters

index
Type: System..::.Int32
Index to get figure

Return Value

Figure at specified index

See Also

CustomFiguresCollection Class
GetFigure Overload
Telerik.Reporting.Charting Namespace


GetFigure Method (String)

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.GetFigure Method (String)
CustomFiguresCollection Class See Also Send Feedback
Gets or sets a custom figures collection item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomFigure GetFigure(
    string name
)
Visual Basic (Declaration)
Public Function GetFigure ( _
    name As String _
) As CustomFigure

Parameters

name
Type: System..::.String
Name of figure to get

Return Value

Figure with specified name

See Also

CustomFiguresCollection Class
GetFigure Overload
Telerik.Reporting.Charting Namespace


IndexOf Method

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.IndexOf Method
CustomFiguresCollection Class See Also Send Feedback

Overload List

Name | Description
IndexOf(T) | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf(String) | Returns the index of the specified figure item.

See Also

CustomFiguresCollection Class
CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


IndexOf Method (String)

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.IndexOf Method (String)
CustomFiguresCollection Class See Also Send Feedback
Returns the index of the specified figure item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    string figureName
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    figureName As String _
) As Integer

Parameters

figureName
Type: System..::.String
Name of figure

Return Value

Index of figure with specified name

See Also

CustomFiguresCollection Class
IndexOf Overload
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.Remove Method
CustomFiguresCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(T) | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove(String) | Removes figure with specified name

See Also

CustomFiguresCollection Class
CustomFiguresCollection Members
Telerik.Reporting.Charting Namespace


Remove Method (String)

[image]

Telerik Reporting Q2 2012
CustomFiguresCollection..::.Remove Method (String)
CustomFiguresCollection Class See Also Send Feedback
Removes figure with specified name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    string figureName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    figureName As String _
)

Parameters

figureName
Type: System..::.String
Name of figure

See Also

CustomFiguresCollection Class
Remove Overload
Telerik.Reporting.Charting Namespace


CustomFiguresCollection Properties

[image] [image]

Telerik Reporting Q2 2012
CustomFiguresCollection Properties
CustomFiguresCollection Class See Also Send Feedback

The CustomFiguresCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomFiguresCollection Class
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Class

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection Class
Members See Also Send Feedback
User-defined palettes collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CustomPalettesCollection : ChartingStateManagedCollection<Palette>
Visual Basic (Declaration)
Public Class CustomPalettesCollection _
    Inherits ChartingStateManagedCollection(Of Palette)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' Palette >)>)>
Telerik.Reporting.Charting..::.CustomPalettesCollection

See Also

CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Members

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection Members
CustomPalettesCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CustomPalettesCollection type exposes the following members.

Constructors

Name | Description
CustomPalettesCollection | Create new instance of CustomPalettesCollection class.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Overloaded.
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetPalette | Overloaded.
IndexOf | Overloaded.
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Overloaded.
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Constructor

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection Constructor
CustomPalettesCollection Class See Also Send Feedback
Create new instance of CustomPalettesCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CustomPalettesCollection()
Visual Basic (Declaration)
Public Sub New

See Also

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Methods

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection Methods
CustomPalettesCollection Class See Also Send Feedback

The CustomPalettesCollection type exposes the following members.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Overloaded.
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetPalette | Overloaded.
IndexOf | Overloaded.
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Overloaded.
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


Contains Method

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.Contains Method
CustomPalettesCollection Class See Also Send Feedback

Overload List

Name | Description
Contains(T) | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains(String) | Indicates whether the specified palette item exists in the collection.

See Also

CustomPalettesCollection Class
CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


Contains Method (String)

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.Contains Method (String)
CustomPalettesCollection Class See Also Send Feedback
Indicates whether the specified palette item exists in the collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    string paletteName
)
Visual Basic (Declaration)
Public Function Contains ( _
    paletteName As String _
) As Boolean

Parameters

paletteName
Type: System..::.String
Name of palette

Return Value

Whether the specified palette item exists in the collection

See Also

CustomPalettesCollection Class
Contains Overload
Telerik.Reporting.Charting Namespace


GetPalette Method

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.GetPalette Method
CustomPalettesCollection Class See Also Send Feedback

Overload List

Name | Description
GetPalette(Int32) | Returns a reference to the Palette object at the specified index.
GetPalette(String) | Returns a reference to the Palette object by the specified name.

See Also

CustomPalettesCollection Class
CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


GetPalette Method (Int32)

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.GetPalette Method (Int32)
CustomPalettesCollection Class See Also Send Feedback
Returns a reference to the Palette object at the specified index.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette GetPalette(
    int index
)
Visual Basic (Declaration)
Public Function GetPalette ( _
    index As Integer _
) As Palette

Parameters

index
Type: System..::.Int32
Index to get palette

Return Value

Palette at specified index

See Also

CustomPalettesCollection Class
GetPalette Overload
Telerik.Reporting.Charting Namespace


GetPalette Method (String)

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.GetPalette Method (String)
CustomPalettesCollection Class See Also Send Feedback
Returns a reference to the Palette object by the specified name.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette GetPalette(
    string name
)
Visual Basic (Declaration)
Public Function GetPalette ( _
    name As String _
) As Palette

Parameters

name
Type: System..::.String
Name of palette

Return Value

Palette object with specified name

See Also

CustomPalettesCollection Class
GetPalette Overload
Telerik.Reporting.Charting Namespace


IndexOf Method

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.IndexOf Method
CustomPalettesCollection Class See Also Send Feedback

Overload List

Name | Description
IndexOf(T) | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IndexOf(String) | Returns the index of the specified palette item.

See Also

CustomPalettesCollection Class
CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


IndexOf Method (String)

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.IndexOf Method (String)
CustomPalettesCollection Class See Also Send Feedback
Returns the index of the specified palette item.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    string paletteName
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    paletteName As String _
) As Integer

Parameters

paletteName
Type: System..::.String
Name of palette

Return Value

Index of the specified palette item

See Also

CustomPalettesCollection Class
IndexOf Overload
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.Remove Method
CustomPalettesCollection Class See Also Send Feedback

Overload List

Name | Description
Remove(T) | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove(String) | Removes palette with specified name from collection

See Also

CustomPalettesCollection Class
CustomPalettesCollection Members
Telerik.Reporting.Charting Namespace


Remove Method (String)

[image]

Telerik Reporting Q2 2012
CustomPalettesCollection..::.Remove Method (String)
CustomPalettesCollection Class See Also Send Feedback
Removes palette with specified name from collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    string paletteName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    paletteName As String _
)

Parameters

paletteName
Type: System..::.String
Name of palette

See Also

CustomPalettesCollection Class
Remove Overload
Telerik.Reporting.Charting Namespace


CustomPalettesCollection Properties

[image] [image]

Telerik Reporting Q2 2012
CustomPalettesCollection Properties
CustomPalettesCollection Class See Also Send Feedback

The CustomPalettesCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

CustomPalettesCollection Class
Telerik.Reporting.Charting Namespace


DataManager Class

[image]

Telerik Reporting Q2 2012
DataManager Class
Members See Also Send Feedback
Acquires and manipulates data from databases or other sources. Populates the SeriesCollection of the chart control.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class DataManager
Visual Basic (Declaration)
Public NotInheritable Class DataManager

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.DataManager

See Also

DataManager Members
Telerik.Reporting.Charting Namespace


DataManager Members

[image] [image]

Telerik Reporting Q2 2012
DataManager Members
DataManager Class Methods Properties Events See Also Send Feedback

The DataManager type exposes the following members.

Methods

Name | Description
ClearDataSource | Clears the Data Source used
CopyFrom | Copies settings from another data manager
DataBind | Forces the data to be refreshed

Properties

Name | Description
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items.
DataSource | Chart Data Source object
IsDataBindCalled | Returns true if DataBind method has been called
LabelsColumn | The data source column used as chart labels source
UseSeriesGrouping | Enables or disables the series grouping feature
ValuesXColumn | The data source column used as series items X coordinate
ValuesYColumns | The data source columns array used as series items Y coordinate source

Events

Name | Description
ItemDataBound | Event raised after the each series item's data binding

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataManager Methods

[image] [image]

Telerik Reporting Q2 2012
DataManager Methods
DataManager Class See Also Send Feedback

The DataManager type exposes the following members.

Methods

Name | Description
ClearDataSource | Clears the Data Source used
CopyFrom | Copies settings from another data manager
DataBind | Forces the data to be refreshed

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


ClearDataSource Method

[image]

Telerik Reporting Q2 2012
DataManager..::.ClearDataSource Method
DataManager Class See Also Send Feedback
Clears the Data Source used

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ClearDataSource()
Visual Basic (Declaration)
Public Sub ClearDataSource

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
DataManager..::.CopyFrom Method
DataManager Class See Also Send Feedback
Copies settings from another data manager

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CopyFrom(
    DataManager manager
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    manager As DataManager _
)

Parameters

manager
Type: Telerik.Reporting.Charting..::.DataManager
Source DataManager to copy settings from

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataBind Method

[image]

Telerik Reporting Q2 2012
DataManager..::.DataBind Method
DataManager Class See Also Send Feedback
Forces the data to be refreshed

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void DataBind()
Visual Basic (Declaration)
Public Sub DataBind

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataManager Properties

[image] [image]

Telerik Reporting Q2 2012
DataManager Properties
DataManager Class See Also Send Feedback

The DataManager type exposes the following members.

Properties

Name | Description
DataMember | Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items.
DataSource | Chart Data Source object
IsDataBindCalled | Returns true if DataBind method has been called
LabelsColumn | The data source column used as chart labels source
UseSeriesGrouping | Enables or disables the series grouping feature
ValuesXColumn | The data source column used as series items X coordinate
ValuesYColumns | The data source columns array used as series items Y coordinate source

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
DataManager..::.DataMember Property
DataManager Class See Also Send Feedback
Gets or sets the name of the list of data that the data-bound control binds to, in cases where the data source contains more than one distinct list of data items.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DataMember { get; set; }
Visual Basic (Declaration)
Public Property DataMember As String

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
DataManager..::.DataSource Property
DataManager Class See Also Send Feedback
Chart Data Source object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


IsDataBindCalled Property

[image]

Telerik Reporting Q2 2012
DataManager..::.IsDataBindCalled Property
DataManager Class See Also Send Feedback
Returns true if DataBind method has been called

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsDataBindCalled { get; set; }
Visual Basic (Declaration)
Public Property IsDataBindCalled As Boolean

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


LabelsColumn Property

[image]

Telerik Reporting Q2 2012
DataManager..::.LabelsColumn Property
DataManager Class See Also Send Feedback
The data source column used as chart labels source

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string LabelsColumn { get; set; }
Visual Basic (Declaration)
Public Property LabelsColumn As String

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


UseSeriesGrouping Property

[image]

Telerik Reporting Q2 2012
DataManager..::.UseSeriesGrouping Property
DataManager Class See Also Send Feedback
Enables or disables the series grouping feature

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool UseSeriesGrouping { get; set; }
Visual Basic (Declaration)
Public Property UseSeriesGrouping As Boolean

Remarks

Default value is True

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


ValuesXColumn Property

[image]

Telerik Reporting Q2 2012
DataManager..::.ValuesXColumn Property
DataManager Class See Also Send Feedback
The data source column used as series items X coordinate

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ValuesXColumn { get; set; }
Visual Basic (Declaration)
Public Property ValuesXColumn As String

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


ValuesYColumns Property

[image]

Telerik Reporting Q2 2012
DataManager..::.ValuesYColumns Property
DataManager Class See Also Send Feedback
The data source columns array used as series items Y coordinate source

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string[] ValuesYColumns { get; set; }
Visual Basic (Declaration)
Public Property ValuesYColumns As String()

Remarks

This array could be used to set the Gantt chart data source columns. The columns should be added in the following order: X, Y, X2, Y2

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataManager Events

[image] [image]

Telerik Reporting Q2 2012
DataManager Events
DataManager Class See Also Send Feedback

The DataManager type exposes the following members.

Events

Name | Description
ItemDataBound | Event raised after the each series item's data binding

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


ItemDataBound Event

[image]

Telerik Reporting Q2 2012
DataManager..::.ItemDataBound Event
DataManager Class See Also Send Feedback
Event raised after the each series item's data binding

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event EventHandler<ChartItemDataBoundEventArgs> ItemDataBound
Visual Basic (Declaration)
Public Event ItemDataBound As EventHandler(Of ChartItemDataBoundEventArgs)

See Also

DataManager Class
Telerik.Reporting.Charting Namespace


DataSetClass Class

[image]

Telerik Reporting Q2 2012
DataSetClass Class
Members See Also Send Feedback
Sample class returns DataSet for an ObjectDataSource data binding demo

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DataSetClass : IDisposable
Visual Basic (Declaration)
Public Class DataSetClass _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.DataSetClass

See Also

DataSetClass Members
Telerik.Reporting.Charting Namespace


DataSetClass Members

[image] [image]

Telerik Reporting Q2 2012
DataSetClass Members
DataSetClass Class Constructors Methods See Also Send Feedback

The DataSetClass type exposes the following members.

Constructors

Name | Description
DataSetClass | Constructor. Loads sample data in DataSet

Methods

Name | Description
Dispose | Overloaded.
Finalize | Destructor (Overrides Object..::.Finalize()()().)
GetData | Gets data as DataSet object

See Also

DataSetClass Class
Telerik.Reporting.Charting Namespace


DataSetClass Constructor

[image]

Telerik Reporting Q2 2012
DataSetClass Constructor
DataSetClass Class See Also Send Feedback
Constructor. Loads sample data in DataSet

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSetClass()
Visual Basic (Declaration)
Public Sub New

See Also

DataSetClass Class
Telerik.Reporting.Charting Namespace


DataSetClass Methods

[image] [image]

Telerik Reporting Q2 2012
DataSetClass Methods
DataSetClass Class See Also Send Feedback

The DataSetClass type exposes the following members.

Methods

Name | Description
Dispose | Overloaded.
Finalize | Destructor (Overrides Object..::.Finalize()()().)
GetData | Gets data as DataSet object

See Also

DataSetClass Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DataSetClass..::.Dispose Method
DataSetClass Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the DataSetClass
Dispose(Boolean) | Releases the unmanaged resources used by the DataSetClass and optionally releases the managed resources

See Also

DataSetClass Class
DataSetClass Members
Telerik.Reporting.Charting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
DataSetClass..::.Dispose Method
DataSetClass Class See Also Send Feedback
Releases all resources used by the DataSetClass

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

DataSetClass Class
Dispose Overload
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
DataSetClass..::.Dispose Method (Boolean)
DataSetClass Class See Also Send Feedback
Releases the unmanaged resources used by the DataSetClass and optionally releases the managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

DataSetClass Class
Dispose Overload
Telerik.Reporting.Charting Namespace


Finalize Method

[image]

Telerik Reporting Q2 2012
DataSetClass..::.Finalize Method
DataSetClass Class See Also Send Feedback
Destructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

DataSetClass Class
Telerik.Reporting.Charting Namespace


GetData Method

[image]

Telerik Reporting Q2 2012
DataSetClass..::.GetData Method
DataSetClass Class See Also Send Feedback
Gets data as DataSet object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DataSet GetData()
Visual Basic (Declaration)
Public Function GetData As DataSet

Return Value

DataSet with sample data

See Also

DataSetClass Class
Telerik.Reporting.Charting Namespace


DemoData Class

[image]

Telerik Reporting Q2 2012
DemoData Class
Members See Also Send Feedback
Simple data sources examples class. Used for a data binding demonstration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DemoData
Visual Basic (Declaration)
Public Class DemoData

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.DemoData

See Also

DemoData Members
Telerik.Reporting.Charting Namespace


DemoData Members

[image] [image]

Telerik Reporting Q2 2012
DemoData Members
DemoData Class Constructors Fields Properties See Also Send Feedback

The DemoData type exposes the following members.

Constructors

Name | Description
DemoData | Main class constructor

Fields

Name | Description
DoubleArray | Double Array example
ObjectsArray | Object array without groups column example
ObjectsArrayCat | Object array with groups column example

Properties

Name | Description
DoubleList | Strong typed double list example

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DemoData Constructor

[image]

Telerik Reporting Q2 2012
DemoData Constructor
DemoData Class See Also Send Feedback
Main class constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DemoData()
Visual Basic (Declaration)
Public Sub New

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DemoData Fields

[image] [image]

Telerik Reporting Q2 2012
DemoData Fields
DemoData Class See Also Send Feedback

The DemoData type exposes the following members.

Fields

Name | Description
DoubleArray | Double Array example
ObjectsArray | Object array without groups column example
ObjectsArrayCat | Object array with groups column example

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DoubleArray Field

[image]

Telerik Reporting Q2 2012
DemoData..::.DoubleArray Field
DemoData Class See Also Send Feedback
Double Array example

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double[] DoubleArray
Visual Basic (Declaration)
Public DoubleArray As Double()

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


ObjectsArray Field

[image]

Telerik Reporting Q2 2012
DemoData..::.ObjectsArray Field
DemoData Class See Also Send Feedback
Object array without groups column example

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object[,] ObjectsArray
Visual Basic (Declaration)
Public ObjectsArray As Object(,)

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


ObjectsArrayCat Field

[image]

Telerik Reporting Q2 2012
DemoData..::.ObjectsArrayCat Field
DemoData Class See Also Send Feedback
Object array with groups column example

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object[,] ObjectsArrayCat
Visual Basic (Declaration)
Public ObjectsArrayCat As Object(,)

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DemoData Properties

[image] [image]

Telerik Reporting Q2 2012
DemoData Properties
DemoData Class See Also Send Feedback

The DemoData type exposes the following members.

Properties

Name | Description
DoubleList | Strong typed double list example

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DoubleList Property

[image]

Telerik Reporting Q2 2012
DemoData..::.DoubleList Property
DemoData Class See Also Send Feedback
Strong typed double list example

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List<double> DoubleList { get; }
Visual Basic (Declaration)
Public ReadOnly Property DoubleList As List(Of Double)

See Also

DemoData Class
Telerik.Reporting.Charting Namespace


DoubleCollection Class

[image]

Telerik Reporting Q2 2012
DoubleCollection Class
Members See Also Send Feedback
Collection base object example. Used for a data binding demostration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DoubleCollection : CollectionBase
Visual Basic (Declaration)
Public Class DoubleCollection _
    Inherits CollectionBase

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
Telerik.Reporting.Charting..::.DoubleCollection

See Also

DoubleCollection Members
Telerik.Reporting.Charting Namespace


DoubleCollection Members

[image] [image]

Telerik Reporting Q2 2012
DoubleCollection Members
DoubleCollection Class Constructors Methods Properties See Also Send Feedback

The DoubleCollection type exposes the following members.

Constructors

Name | Description
DoubleCollection | Initializes a new instance of the DoubleCollection class

Methods

Name | Description
Add |
Contains |
IndexOf |
InitData | Data load method
Insert |
OnInsert | (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnRemove | (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnSet | (Overrides CollectionBase..::.OnSet(Int32, Object, Object).)
OnValidate | (Overrides CollectionBase..::.OnValidate(Object).)
Remove |

Properties

Name | Description
Item |

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


DoubleCollection Constructor

[image]

Telerik Reporting Q2 2012
DoubleCollection Constructor
DoubleCollection Class See Also Send Feedback
Initializes a new instance of the DoubleCollection class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DoubleCollection()
Visual Basic (Declaration)
Public Sub New

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


DoubleCollection Methods

[image] [image]

Telerik Reporting Q2 2012
DoubleCollection Methods
DoubleCollection Class See Also Send Feedback

The DoubleCollection type exposes the following members.

Methods

Name | Description
Add |
Contains |
IndexOf |
InitData | Data load method
Insert |
OnInsert | (Overrides CollectionBase..::.OnInsert(Int32, Object).)
OnRemove | (Overrides CollectionBase..::.OnRemove(Int32, Object).)
OnSet | (Overrides CollectionBase..::.OnSet(Int32, Object, Object).)
OnValidate | (Overrides CollectionBase..::.OnValidate(Object).)
Remove |

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.Add Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Add(
    double value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Double _
) As Integer

Parameters

value
Type: System..::.Double

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.Contains Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    double value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Double _
) As Boolean

Parameters

value
Type: System..::.Double

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


IndexOf Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.IndexOf Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOf(
    double value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Double _
) As Integer

Parameters

value
Type: System..::.Double

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


InitData Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.InitData Method
DoubleCollection Class See Also Send Feedback
Data load method

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void InitData()
Visual Basic (Declaration)
Public Sub InitData

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.Insert Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Insert(
    int index,
    double value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Double _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Double

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


OnInsert Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.OnInsert Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnInsert(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsert ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


OnRemove Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.OnRemove Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnRemove(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemove ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


OnSet Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.OnSet Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnSet(
    int index,
    Object oldValue,
    Object newValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnSet ( _
    index As Integer, _
    oldValue As Object, _
    newValue As Object _
)

Parameters

index
Type: System..::.Int32
oldValue
Type: System..::.Object
newValue
Type: System..::.Object

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


OnValidate Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.OnValidate Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnValidate(
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnValidate ( _
    value As Object _
)

Parameters

value
Type: System..::.Object

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.Remove Method
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    double value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Double _
)

Parameters

value
Type: System..::.Double

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


DoubleCollection Properties

[image] [image]

Telerik Reporting Q2 2012
DoubleCollection Properties
DoubleCollection Class See Also Send Feedback

The DoubleCollection type exposes the following members.

Properties

Name | Description
Item |

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
DoubleCollection..::.Item Property
DoubleCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Double

Parameters

index
Type: System..::.Int32

See Also

DoubleCollection Class
Telerik.Reporting.Charting Namespace


DummyWebControl Class

[image]

Telerik Reporting Q2 2012
DummyWebControl Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DummyWebControl : WebControl
Visual Basic (Declaration)
Public Class DummyWebControl _
    Inherits WebControl

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
Telerik.Reporting.Charting..::.DummyWebControl

See Also

DummyWebControl Members
Telerik.Reporting.Charting Namespace


DummyWebControl Members

[image] [image]

Telerik Reporting Q2 2012
DummyWebControl Members
DummyWebControl Class Constructors See Also Send Feedback

The DummyWebControl type exposes the following members.

Constructors

Name | Description
DummyWebControl | Initializes a new instance of the DummyWebControl class

See Also

DummyWebControl Class
Telerik.Reporting.Charting Namespace


DummyWebControl Constructor

[image]

Telerik Reporting Q2 2012
DummyWebControl Constructor
DummyWebControl Class See Also Send Feedback
Initializes a new instance of the DummyWebControl class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DummyWebControl()
Visual Basic (Declaration)
Public Sub New

See Also

DummyWebControl Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Class

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage Class
Members See Also Send Feedback
Empty series message

Remarks

Visible if no or empty series present

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class EmptySeriesMessage : ChartLabel
Visual Basic (Declaration)
Public Class EmptySeriesMessage _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.EmptySeriesMessage

See Also

EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Members

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage Members
EmptySeriesMessage Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The EmptySeriesMessage type exposes the following members.

Constructors

Name | Description
EmptySeriesMessage | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage Constructor
EmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
EmptySeriesMessage()()() | Create instance of the class
EmptySeriesMessage(ChartPlotArea) | Create instance of the class
EmptySeriesMessage(IContainer) | Create instance of the class
EmptySeriesMessage(ChartPlotArea, IContainer) | Create instance of the class

See Also

EmptySeriesMessage Class
EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage Constructor
EmptySeriesMessage Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptySeriesMessage()
Visual Basic (Declaration)
Public Sub New

See Also

EmptySeriesMessage Class
EmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor (ChartPlotArea)

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage Constructor (ChartPlotArea)
EmptySeriesMessage Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptySeriesMessage(
    ChartPlotArea parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
Plot area

See Also

EmptySeriesMessage Class
EmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage Constructor (IContainer)
EmptySeriesMessage Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptySeriesMessage(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer
Rendering container element

See Also

EmptySeriesMessage Class
EmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Constructor (ChartPlotArea, IContainer)

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage Constructor (ChartPlotArea, IContainer)
EmptySeriesMessage Class See Also Send Feedback
Create instance of the class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptySeriesMessage(
    ChartPlotArea parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartPlotArea, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartPlotArea
Plot area
container
Type: Telerik.Reporting.Charting..::.IContainer
Rendering container element

See Also

EmptySeriesMessage Class
EmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Fields

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage Fields
EmptySeriesMessage Class See Also Send Feedback

The EmptySeriesMessage type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Methods

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage Methods
EmptySeriesMessage Class See Also Send Feedback

The EmptySeriesMessage type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage..::.Dispose Method
EmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

EmptySeriesMessage Class
EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage..::.GetOrder Method
EmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

EmptySeriesMessage Class
EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage..::.Remove Method
EmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

EmptySeriesMessage Class
EmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


EmptySeriesMessage Properties

[image] [image]

Telerik Reporting Q2 2012
EmptySeriesMessage Properties
EmptySeriesMessage Class See Also Send Feedback

The EmptySeriesMessage type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Overrides ChartBaseLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
EmptySeriesMessage..::.Visible Property
EmptySeriesMessage Class See Also Send Feedback
Visibility

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

EmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


ExtendedLabel Class

[image]

Telerik Reporting Q2 2012
ExtendedLabel Class
Members See Also Send Feedback
Base class for extended labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtendedLabel : ChartBaseLabel
Visual Basic (Declaration)
Public Class ExtendedLabel _
    Inherits ChartBaseLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ExtendedLabel
Telerik.Reporting.Charting..::.ChartLegend

See Also

ExtendedLabel Members
Telerik.Reporting.Charting Namespace


ExtendedLabel Members

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel Members
ExtendedLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ExtendedLabel type exposes the following members.

Constructors

Name | Description
ExtendedLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
AddLabel | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clear LabelItems collection
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetLabel | Get inner label at specified position
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | load ViewState (Overrides ChartBaseLabel..::.LoadViewState(Object).)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAllLabels | Removes all inner labels
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
RemoveLabel | Overloaded.
SaveViewState | Save ViewState (Overrides ChartBaseLabel..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides ChartBaseLabel..::.TrackViewState()()().)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
extendedLabelItems | Inside labels collection
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Gets style of label
Container | Link to container element (Inherited from RenderedObject.)
Item | Gets and sets LabelItem at specified position
Items | Items collection.
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
ExtendedLabel()()() | Create new instance of Extended label class.
ExtendedLabel(Object) | Create new instance of Extended label class.
ExtendedLabel(String) | Create new instance of Extended label class.
ExtendedLabel(StyleExtendedLabel) | Create new instance of Extended label class.
ExtendedLabel(TextBlock) | Create new instance of Extended label class.
ExtendedLabel(StyleExtendedLabel, Object) | Create new instance of Extended label class.
ExtendedLabel(StyleExtendedLabel, String) | Create new instance of Extended label class.
ExtendedLabel(Object, IContainer, TextBlock) | Create new instance of Extended label class.
ExtendedLabel(Object, IContainer, StyleExtendedLabel, TextBlock, String) | Create new instance of Extended label class.

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel()
Visual Basic (Declaration)
Public Sub New

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (Object)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (Object)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent element

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (String)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (String)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text of label

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (StyleExtendedLabel)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (StyleExtendedLabel)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    StyleExtendedLabel appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleExtendedLabel _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Style of label

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (TextBlock)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (TextBlock)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    textBlock As TextBlock _
)

Parameters

textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (StyleExtendedLabel, Object)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (StyleExtendedLabel, Object)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    StyleExtendedLabel appearance,
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleExtendedLabel, _
    parent As Object _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Style of label
parent
Type: System..::.Object
Parent element

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (StyleExtendedLabel, String)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (StyleExtendedLabel, String)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    StyleExtendedLabel appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleExtendedLabel, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Style of label
text
Type: System..::.String
Text

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (Object, IContainer, TextBlock)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (Object, IContainer, TextBlock)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    Object parent,
    IContainer container,
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    textBlock As TextBlock _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Constructor (Object, IContainer, StyleExtendedLabel, TextBlock, String)

[image]

Telerik Reporting Q2 2012
ExtendedLabel Constructor (Object, IContainer, StyleExtendedLabel, TextBlock, String)
ExtendedLabel Class See Also Send Feedback
Create new instance of Extended label class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtendedLabel(
    Object parent,
    IContainer container,
    StyleExtendedLabel appearance,
    TextBlock textBlock,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    container As IContainer, _
    appearance As StyleExtendedLabel, _
    textBlock As TextBlock, _
    text As String _
)

Parameters

parent
Type: System..::.Object
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Style of label
textBlock
Type: Telerik.Reporting.Charting..::.TextBlock
TextBlock
text
Type: System..::.String
Text of elemnt

See Also

ExtendedLabel Class
ExtendedLabel Overload
Telerik.Reporting.Charting Namespace


ExtendedLabel Fields

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel Fields
ExtendedLabel Class See Also Send Feedback

The ExtendedLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
extendedLabelItems | Inside labels collection
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


extendedLabelItems Field

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.extendedLabelItems Field
ExtendedLabel Class See Also Send Feedback
Inside labels collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartLabelsCollection extendedLabelItems
Visual Basic (Declaration)
Protected extendedLabelItems As ChartLabelsCollection

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


ExtendedLabel Methods

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel Methods
ExtendedLabel Class See Also Send Feedback

The ExtendedLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
AddLabel | Overloaded.
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clear | Clear LabelItems collection
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetLabel | Get inner label at specified position
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | load ViewState (Overrides ChartBaseLabel..::.LoadViewState(Object).)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAllLabels | Removes all inner labels
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
RemoveLabel | Overloaded.
SaveViewState | Save ViewState (Overrides ChartBaseLabel..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Overrides ChartBaseLabel..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


AddLabel Method

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel..::.AddLabel Method
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
AddLabel(ChartLabelsCollection) | Add inside labels
AddLabel(List<(Of <(LabelItem>)>)) | Add inside labels
AddLabel(array<LabelItem>[]()[]) | Add inside labels
AddLabel(LabelItem, array<LabelItem>[]()[]) | Add inside labels

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


AddLabel Method (ChartLabelsCollection)

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.AddLabel Method (ChartLabelsCollection)
ExtendedLabel Class See Also Send Feedback
Add inside labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLabel(
    ChartLabelsCollection chartLabels
)
Visual Basic (Declaration)
Public Sub AddLabel ( _
    chartLabels As ChartLabelsCollection _
)

Parameters

chartLabels
Type: Telerik.Reporting.Charting..::.ChartLabelsCollection
Inside labels to add

See Also

ExtendedLabel Class
AddLabel Overload
Telerik.Reporting.Charting Namespace


AddLabel Method (List(LabelItem))

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.AddLabel Method (List<(Of <(<'LabelItem>)>)>)
ExtendedLabel Class See Also Send Feedback
Add inside labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLabel(
    List<LabelItem> labels
)
Visual Basic (Declaration)
Public Sub AddLabel ( _
    labels As List(Of LabelItem) _
)

Parameters

labels
Type: System.Collections.Generic..::.List <(Of <(<' LabelItem >)>)>

See Also

ExtendedLabel Class
AddLabel Overload
Telerik.Reporting.Charting Namespace


AddLabel Method (LabelItem[])

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.AddLabel Method (array<LabelItem>[]()[][])
ExtendedLabel Class See Also Send Feedback
Add inside labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLabel(
    LabelItem[] chartLabels
)
Visual Basic (Declaration)
Public Sub AddLabel ( _
    chartLabels As LabelItem() _
)

Parameters

chartLabels
Type: array< Telerik.Reporting.Charting..::.LabelItem >[]()[][]
Inside labels to add

See Also

ExtendedLabel Class
AddLabel Overload
Telerik.Reporting.Charting Namespace


AddLabel Method (LabelItem, LabelItem[])

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.AddLabel Method (LabelItem, array<LabelItem>[]()[][])
ExtendedLabel Class See Also Send Feedback
Add inside labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLabel(
    LabelItem Label,
    params LabelItem[] chartLabels
)
Visual Basic (Declaration)
Public Sub AddLabel ( _
    Label As LabelItem, _
    ParamArray chartLabels As LabelItem() _
)

Parameters

Label
Type: Telerik.Reporting.Charting..::.LabelItem
Inside label to add
chartLabels
Type: array< Telerik.Reporting.Charting..::.LabelItem >[]()[][]
Inside labels to add

See Also

ExtendedLabel Class
AddLabel Overload
Telerik.Reporting.Charting Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Clear Method
ExtendedLabel Class See Also Send Feedback
Clear LabelItems collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Dispose Method
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides ChartBaseLabel..::.Dispose(Boolean).)

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Dispose Method (Boolean)
ExtendedLabel Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ExtendedLabel Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetLabel Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.GetLabel Method
ExtendedLabel Class See Also Send Feedback
Get inner label at specified position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem GetLabel(
    int index
)
Visual Basic (Declaration)
Public Function GetLabel ( _
    index As Integer _
) As LabelItem

Parameters

index
Type: System..::.Int32
Position to get label

Return Value

Label at specified position

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel..::.GetOrder Method
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.LoadViewState Method
ExtendedLabel Class See Also Send Feedback
load ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Remove Method
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


RemoveAllLabels Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.RemoveAllLabels Method
ExtendedLabel Class See Also Send Feedback
Removes all inner labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveAllLabels()
Visual Basic (Declaration)
Public Sub RemoveAllLabels

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


RemoveLabel Method

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel..::.RemoveLabel Method
ExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
RemoveLabel(Int32, array<Int32>[]()[]) | Removes inner labels
RemoveLabel(LabelItem, array<LabelItem>[]()[]) | Removes inner labels

See Also

ExtendedLabel Class
ExtendedLabel Members
Telerik.Reporting.Charting Namespace


RemoveLabel Method (Int32, Int32[])

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.RemoveLabel Method (Int32, array<Int32>[]()[][])
ExtendedLabel Class See Also Send Feedback
Removes inner labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveLabel(
    int index,
    params int[] indexes
)
Visual Basic (Declaration)
Public Sub RemoveLabel ( _
    index As Integer, _
    ParamArray indexes As Integer() _
)

Parameters

index
Type: System..::.Int32
Position where label should be removed
indexes
Type: array< System..::.Int32 >[]()[][]
Positions where labels should be removed

See Also

ExtendedLabel Class
RemoveLabel Overload
Telerik.Reporting.Charting Namespace


RemoveLabel Method (LabelItem, LabelItem[])

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.RemoveLabel Method (LabelItem, array<LabelItem>[]()[][])
ExtendedLabel Class See Also Send Feedback
Removes inner labels

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void RemoveLabel(
    LabelItem Label,
    params LabelItem[] chartLabels
)
Visual Basic (Declaration)
Public Sub RemoveLabel ( _
    Label As LabelItem, _
    ParamArray chartLabels As LabelItem() _
)

Parameters

Label
Type: Telerik.Reporting.Charting..::.LabelItem
Label to remove
chartLabels
Type: array< Telerik.Reporting.Charting..::.LabelItem >[]()[][]
Labels to remove

See Also

ExtendedLabel Class
RemoveLabel Overload
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.SaveViewState Method
ExtendedLabel Class See Also Send Feedback
Save ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.TrackViewState Method
ExtendedLabel Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


ExtendedLabel Properties

[image] [image]

Telerik Reporting Q2 2012
ExtendedLabel Properties
ExtendedLabel Class See Also Send Feedback

The ExtendedLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Gets style of label
Container | Link to container element (Inherited from RenderedObject.)
Item | Gets and sets LabelItem at specified position
Items | Items collection.
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Appearance Property
ExtendedLabel Class See Also Send Feedback
Gets style of label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleExtendedLabel

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Item Property
ExtendedLabel Class See Also Send Feedback
Gets and sets LabelItem at specified position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual LabelItem this[
    int itemIndex
] { get; set; }
Visual Basic (Declaration)
Public Overridable Default Property Item ( _
    itemIndex As Integer _
) As LabelItem

Parameters

itemIndex
Type: System..::.Int32
Item position

Field Value

Item to set at specified position

Return Value

Item at specified position

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


Items Property

[image]

Telerik Reporting Q2 2012
ExtendedLabel..::.Items Property
ExtendedLabel Class See Also Send Feedback
Items collection.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartLabelsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As ChartLabelsCollection

See Also

ExtendedLabel Class
Telerik.Reporting.Charting Namespace


GradientElement Class

[image]

Telerik Reporting Q2 2012
GradientElement Class
Members See Also Send Feedback
Gradient element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GradientElement : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class GradientElement _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.GradientElement

See Also

GradientElement Members
Telerik.Reporting.Charting Namespace


GradientElement Members

[image] [image]

Telerik Reporting Q2 2012
GradientElement Members
GradientElement Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The GradientElement type exposes the following members.

Constructors

Name | Description
GradientElement | Overloaded.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing to objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets Color
Position | Gets and sets Position
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


GradientElement Constructor

[image] [image]

Telerik Reporting Q2 2012
GradientElement Constructor
GradientElement Class See Also Send Feedback

Overload List

Name | Description
GradientElement()()() | Create new instance of GradientElement class.
GradientElement(Color, Single) | Create new instance of GradientElement class.

See Also

GradientElement Class
GradientElement Members
Telerik.Reporting.Charting Namespace


GradientElement Constructor

[image]

Telerik Reporting Q2 2012
GradientElement Constructor
GradientElement Class See Also Send Feedback
Create new instance of GradientElement class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GradientElement()
Visual Basic (Declaration)
Public Sub New

See Also

GradientElement Class
GradientElement Overload
Telerik.Reporting.Charting Namespace


GradientElement Constructor (Color, Single)

[image]

Telerik Reporting Q2 2012
GradientElement Constructor (Color, Single)
GradientElement Class See Also Send Feedback
Create new instance of GradientElement class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GradientElement(
    Color color,
    float position
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    position As Single _
)

Parameters

color
Type: System.Drawing..::.Color
Color
position
Type: System..::.Single
Position

See Also

GradientElement Class
GradientElement Overload
Telerik.Reporting.Charting Namespace


GradientElement Methods

[image] [image]

Telerik Reporting Q2 2012
GradientElement Methods
GradientElement Class See Also Send Feedback

The GradientElement type exposes the following members.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing to objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | (Overrides StateManagedObjectToString()()().)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
GradientElement..::.Clone Method
GradientElement Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of GradientElement class with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
GradientElement..::.Dispose Method
GradientElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

GradientElement Class
GradientElement Members
Telerik.Reporting.Charting Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
GradientElement..::.Equals Method
GradientElement Class See Also Send Feedback
Comparing to objects

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object for comparing

Return Value

Whether objects are equal or not

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
GradientElement..::.GetHashCode Method
GradientElement Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
GradientElement..::.ToString Method
GradientElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


GradientElement Properties

[image] [image]

Telerik Reporting Q2 2012
GradientElement Properties
GradientElement Class See Also Send Feedback

The GradientElement type exposes the following members.

Properties

Name | Description
Color | Gets and sets Color
Position | Gets and sets Position
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


Color Property

[image]

Telerik Reporting Q2 2012
GradientElement..::.Color Property
GradientElement Class See Also Send Feedback
Gets and sets Color

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color

Field Value

Color

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


Position Property

[image]

Telerik Reporting Q2 2012
GradientElement..::.Position Property
GradientElement Class See Also Send Feedback
Gets and sets Position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float Position { get; set; }
Visual Basic (Declaration)
Public Property Position As Single

Field Value

Position

See Also

GradientElement Class
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Interface

[image]

Telerik Reporting Q2 2012
IChartingStateManagedItem Interface
Members See Also Send Feedback
Common interface for a State managed collection items

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IChartingStateManagedItem : IChartingStateManager
Visual Basic (Declaration)
Public Interface IChartingStateManagedItem _
    Implements IChartingStateManager

See Also

IChartingStateManagedItem Members
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Members

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManagedItem Members
IChartingStateManagedItem Interface Methods Properties See Also Send Feedback

The IChartingStateManagedItem type exposes the following members.

Methods

Name | Description
LoadViewState | Loads data from a View State (Inherited from IChartingStateManager.)
SaveViewState | Saves object data to a View State (Inherited from IChartingStateManager.)
SetDirty | Sets item dirty state
TrackViewState | Tracks view state changes (Inherited from IChartingStateManager.)

Properties

Name | Description
IsTrackingViewState | (Inherited from IChartingStateManager.)

See Also

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Methods

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManagedItem Methods
IChartingStateManagedItem Interface See Also Send Feedback

The IChartingStateManagedItem type exposes the following members.

Methods

Name | Description
LoadViewState | Loads data from a View State (Inherited from IChartingStateManager.)
SaveViewState | Saves object data to a View State (Inherited from IChartingStateManager.)
SetDirty | Sets item dirty state
TrackViewState | Tracks view state changes (Inherited from IChartingStateManager.)

See Also

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


SetDirty Method

[image]

Telerik Reporting Q2 2012
IChartingStateManagedItem..::.SetDirty Method
IChartingStateManagedItem Interface See Also Send Feedback
Sets item dirty state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void SetDirty()
Visual Basic (Declaration)
Sub SetDirty

See Also

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


IChartingStateManagedItem Properties

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManagedItem Properties
IChartingStateManagedItem Interface See Also Send Feedback

The IChartingStateManagedItem type exposes the following members.

Properties

Name | Description
IsTrackingViewState | (Inherited from IChartingStateManager.)

See Also

IChartingStateManagedItem Interface
Telerik.Reporting.Charting Namespace


IChartingStateManager Interface

[image]

Telerik Reporting Q2 2012
IChartingStateManager Interface
Members See Also Send Feedback
The common interface for all chart elements support View State tracking

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IChartingStateManager
Visual Basic (Declaration)
Public Interface IChartingStateManager

See Also

IChartingStateManager Members
Telerik.Reporting.Charting Namespace


IChartingStateManager Members

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManager Members
IChartingStateManager Interface Methods Properties See Also Send Feedback

The IChartingStateManager type exposes the following members.

Methods

Name | Description
LoadViewState | Loads data from a View State
SaveViewState | Saves object data to a View State
TrackViewState | Tracks view state changes

Properties

Name | Description
IsTrackingViewState |

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IChartingStateManager Methods

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManager Methods
IChartingStateManager Interface See Also Send Feedback

The IChartingStateManager type exposes the following members.

Methods

Name | Description
LoadViewState | Loads data from a View State
SaveViewState | Saves object data to a View State
TrackViewState | Tracks view state changes

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
IChartingStateManager..::.LoadViewState Method
IChartingStateManager Interface See Also Send Feedback
Loads data from a View State

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
View Sate to load data from

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
IChartingStateManager..::.SaveViewState Method
IChartingStateManager Interface See Also Send Feedback
Saves object data to a View State

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object SaveViewState()
Visual Basic (Declaration)
Function SaveViewState As Object

Return Value

Saved View State

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
IChartingStateManager..::.TrackViewState Method
IChartingStateManager Interface See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void TrackViewState()
Visual Basic (Declaration)
Sub TrackViewState

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IChartingStateManager Properties

[image] [image]

Telerik Reporting Q2 2012
IChartingStateManager Properties
IChartingStateManager Interface See Also Send Feedback

The IChartingStateManager type exposes the following members.

Properties

Name | Description
IsTrackingViewState |

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IsTrackingViewState Property

[image]

Telerik Reporting Q2 2012
IChartingStateManager..::.IsTrackingViewState Property
IChartingStateManager Interface See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IsTrackingViewState { get; }
Visual Basic (Declaration)
ReadOnly Property IsTrackingViewState As Boolean

See Also

IChartingStateManager Interface
Telerik.Reporting.Charting Namespace


IContainer Interface

[image]

Telerik Reporting Q2 2012
IContainer Interface
Members See Also Send Feedback
Common interface for a rendering container objects

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IContainer
Visual Basic (Declaration)
Public Interface IContainer

See Also

IContainer Members
Telerik.Reporting.Charting Namespace


IContainer Members

[image] [image]

Telerik Reporting Q2 2012
IContainer Members
IContainer Interface Methods Properties See Also Send Feedback

The IContainer type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
GetOrder | Get elements order position
Insert | Insert element at specific position in list
ReIndex | Re index order list
Remove | Remove element from list
RemoveAt | Remove element from list by it's index

Properties

Name | Description
NextPosition | Get a next free order position
OrderList | List, that is represent the render order for taken up elements

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


IContainer Methods

[image] [image]

Telerik Reporting Q2 2012
IContainer Methods
IContainer Interface See Also Send Feedback

The IContainer type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list
GetOrder | Get elements order position
Insert | Insert element at specific position in list
ReIndex | Re index order list
Remove | Remove element from list
RemoveAt | Remove element from list by it's index

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
IContainer..::.Add Method
IContainer Interface See Also Send Feedback
Add element at the end of list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Add(
    IOrdering element
)
Visual Basic (Declaration)
Sub Add ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


GetOrder Method

[image]

Telerik Reporting Q2 2012
IContainer..::.GetOrder Method
IContainer Interface See Also Send Feedback
Get elements order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int GetOrder(
    IOrdering element
)
Visual Basic (Declaration)
Function GetOrder ( _
    element As IOrdering _
) As Integer

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


Insert Method

[image]

Telerik Reporting Q2 2012
IContainer..::.Insert Method
IContainer Interface See Also Send Feedback
Insert element at specific position in list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Insert(
    int order,
    IOrdering element
)
Visual Basic (Declaration)
Sub Insert ( _
    order As Integer, _
    element As IOrdering _
)

Parameters

order
Type: System..::.Int32
Element
element
Type: Telerik.Reporting.Charting..::.IOrdering
Position index

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


ReIndex Method

[image]

Telerik Reporting Q2 2012
IContainer..::.ReIndex Method
IContainer Interface See Also Send Feedback
Re index order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ReIndex()
Visual Basic (Declaration)
Sub ReIndex

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
IContainer..::.Remove Method
IContainer Interface See Also Send Feedback
Remove element from list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Remove(
    IOrdering element
)
Visual Basic (Declaration)
Sub Remove ( _
    element As IOrdering _
)

Parameters

element
Type: Telerik.Reporting.Charting..::.IOrdering
Element for removing

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


RemoveAt Method

[image]

Telerik Reporting Q2 2012
IContainer..::.RemoveAt Method
IContainer Interface See Also Send Feedback
Remove element from list by it's index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void RemoveAt(
    int index
)
Visual Basic (Declaration)
Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Elements index for remove

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


IContainer Properties

[image] [image]

Telerik Reporting Q2 2012
IContainer Properties
IContainer Interface See Also Send Feedback

The IContainer type exposes the following members.

Properties

Name | Description
NextPosition | Get a next free order position
OrderList | List, that is represent the render order for taken up elements

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


NextPosition Property

[image]

Telerik Reporting Q2 2012
IContainer..::.NextPosition Property
IContainer Interface See Also Send Feedback
Get a next free order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int NextPosition { get; }
Visual Basic (Declaration)
ReadOnly Property NextPosition As Integer

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


OrderList Property

[image]

Telerik Reporting Q2 2012
IContainer..::.OrderList Property
IContainer Interface See Also Send Feedback
List, that is represent the render order for taken up elements

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
List<IOrdering> OrderList { get; }
Visual Basic (Declaration)
ReadOnly Property OrderList As List(Of IOrdering)

See Also

IContainer Interface
Telerik.Reporting.Charting Namespace


IOrdering Interface

[image]

Telerik Reporting Q2 2012
IOrdering Interface
Members See Also Send Feedback
Common interface for an order list element of rendering container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IOrdering
Visual Basic (Declaration)
Public Interface IOrdering

See Also

IOrdering Members
Telerik.Reporting.Charting Namespace


IOrdering Members

[image] [image]

Telerik Reporting Q2 2012
IOrdering Members
IOrdering Interface Methods Properties See Also Send Feedback

The IOrdering type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list
BringToFront | Sets element at the first position in render order list
GetOrder | Gets elements order position
Remove | Remove element from render order list
SendBackward | Send element at one step back in the render order list
SendToBack | Send element at the end of render order list
SetOrder | Sets this object in new render order position

Properties

Name | Description
Container | Gets or sets the container element

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


IOrdering Methods

[image] [image]

Telerik Reporting Q2 2012
IOrdering Methods
IOrdering Interface See Also Send Feedback

The IOrdering type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list
BringToFront | Sets element at the first position in render order list
GetOrder | Gets elements order position
Remove | Remove element from render order list
SendBackward | Send element at one step back in the render order list
SendToBack | Send element at the end of render order list
SetOrder | Sets this object in new render order position

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


BringForward Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.BringForward Method
IOrdering Interface See Also Send Feedback
Send element at one step forward in the render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void BringForward()
Visual Basic (Declaration)
Sub BringForward

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


BringToFront Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.BringToFront Method
IOrdering Interface See Also Send Feedback
Sets element at the first position in render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void BringToFront()
Visual Basic (Declaration)
Sub BringToFront

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


GetOrder Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.GetOrder Method
IOrdering Interface See Also Send Feedback
Gets elements order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int GetOrder()
Visual Basic (Declaration)
Function GetOrder As Integer

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.Remove Method
IOrdering Interface See Also Send Feedback
Remove element from render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Remove()
Visual Basic (Declaration)
Sub Remove

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


SendBackward Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.SendBackward Method
IOrdering Interface See Also Send Feedback
Send element at one step back in the render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void SendBackward()
Visual Basic (Declaration)
Sub SendBackward

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


SendToBack Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.SendToBack Method
IOrdering Interface See Also Send Feedback
Send element at the end of render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void SendToBack()
Visual Basic (Declaration)
Sub SendToBack

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


SetOrder Method

[image]

Telerik Reporting Q2 2012
IOrdering..::.SetOrder Method
IOrdering Interface See Also Send Feedback
Sets this object in new render order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void SetOrder(
    int index
)
Visual Basic (Declaration)
Sub SetOrder ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
new position

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


IOrdering Properties

[image] [image]

Telerik Reporting Q2 2012
IOrdering Properties
IOrdering Interface See Also Send Feedback

The IOrdering type exposes the following members.

Properties

Name | Description
Container | Gets or sets the container element

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


Container Property

[image]

Telerik Reporting Q2 2012
IOrdering..::.Container Property
IOrdering Interface See Also Send Feedback
Gets or sets the container element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IContainer Container { get; set; }
Visual Basic (Declaration)
Property Container As IContainer

See Also

IOrdering Interface
Telerik.Reporting.Charting Namespace


LabelItem Class

[image]

Telerik Reporting Q2 2012
LabelItem Class
Members See Also Send Feedback
Base class for labels in label collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class LabelItem : ChartLabel
Visual Basic (Declaration)
Public Class LabelItem _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.LabelItem
Telerik.Reporting.Charting..::.BindableLegendItem

See Also

LabelItem Members
Telerik.Reporting.Charting Namespace


LabelItem Members

[image] [image]

Telerik Reporting Q2 2012
LabelItem Members
LabelItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The LabelItem type exposes the following members.

Constructors

Name | Description
LabelItem | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
Name | Gets and sets Label name in collection
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LabelItem Class
Telerik.Reporting.Charting Namespace


LabelItem Constructor

[image] [image]

Telerik Reporting Q2 2012
LabelItem Constructor
LabelItem Class See Also Send Feedback

Overload List

Name | Description
LabelItem()()() | New instance of LabelItem class.
LabelItem(Object) | New instance of LabelItem class.
LabelItem(String) | New instance of LabelItem class.
LabelItem(StyleLabel) | New instance of LabelItem class.
LabelItem(StyleLabel, Object) | New instance of LabelItem class.
LabelItem(StyleLabel, String) | New instance of LabelItem class.
LabelItem(StyleLabel, TextBlockLabelItem) | New instance of LabelItem class.
LabelItem(Object, StyleLabel, TextBlockLabelItem, String) | New instance of LabelItem class.

See Also

LabelItem Class
LabelItem Members
Telerik.Reporting.Charting Namespace


LabelItem Constructor

[image]

Telerik Reporting Q2 2012
LabelItem Constructor
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem()
Visual Basic (Declaration)
Public Sub New

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (Object)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (Object)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object _
)

Parameters

parent
Type: System..::.Object
Parent element

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (String)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (String)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text of label

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (StyleLabel)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (StyleLabel)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    StyleLabel appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (StyleLabel, Object)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (StyleLabel, Object)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    StyleLabel appearance,
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    parent As Object _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
parent
Type: System..::.Object
Parent element

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (StyleLabel, String)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (StyleLabel, String)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    StyleLabel appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of chart
text
Type: System..::.String
Text

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (StyleLabel, TextBlockLabelItem)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (StyleLabel, TextBlockLabelItem)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    StyleLabel appearance,
    TextBlockLabelItem textBlock
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    textBlock As TextBlockLabelItem _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of chart
textBlock
Type: Telerik.Reporting.Charting..::.TextBlockLabelItem
TextBlock

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Constructor (Object, StyleLabel, TextBlockLabelItem, String)

[image]

Telerik Reporting Q2 2012
LabelItem Constructor (Object, StyleLabel, TextBlockLabelItem, String)
LabelItem Class See Also Send Feedback
New instance of LabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelItem(
    Object parent,
    StyleLabel appearance,
    TextBlockLabelItem textBlock,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Object, _
    appearance As StyleLabel, _
    textBlock As TextBlockLabelItem, _
    text As String _
)

Parameters

parent
Type: System..::.Object
Parent element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of chart
textBlock
Type: Telerik.Reporting.Charting..::.TextBlockLabelItem
TextBlock
text
Type: System..::.String
Text of label

See Also

LabelItem Class
LabelItem Overload
Telerik.Reporting.Charting Namespace


LabelItem Fields

[image] [image]

Telerik Reporting Q2 2012
LabelItem Fields
LabelItem Class See Also Send Feedback

The LabelItem type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

LabelItem Class
Telerik.Reporting.Charting Namespace


LabelItem Methods

[image] [image]

Telerik Reporting Q2 2012
LabelItem Methods
LabelItem Class See Also Send Feedback

The LabelItem type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LabelItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
LabelItem..::.Dispose Method
LabelItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

LabelItem Class
LabelItem Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
LabelItem..::.GetOrder Method
LabelItem Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

LabelItem Class
LabelItem Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
LabelItem..::.Remove Method
LabelItem Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

LabelItem Class
LabelItem Members
Telerik.Reporting.Charting Namespace


LabelItem Properties

[image] [image]

Telerik Reporting Q2 2012
LabelItem Properties
LabelItem Class See Also Send Feedback

The LabelItem type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
Name | Gets and sets Label name in collection
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

LabelItem Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
LabelItem..::.Name Property
LabelItem Class See Also Send Feedback
Gets and sets Label name in collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

Name of label

See Also

LabelItem Class
Telerik.Reporting.Charting Namespace


LayoutElement Class

[image]

Telerik Reporting Q2 2012
LayoutElement Class
Members See Also Send Feedback
Base class for all objects being calculated

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class LayoutElement : RenderedObject
Visual Basic (Declaration)
Public MustInherit Class LayoutElement _
    Inherits RenderedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.Chart
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartDataTable
Telerik.Reporting.Charting..::.ChartMarker
Telerik.Reporting.Charting..::.ChartPlotArea
Telerik.Reporting.Charting..::.TextBlock

See Also

LayoutElement Members
Telerik.Reporting.Charting Namespace


LayoutElement Members

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Members
LayoutElement Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The LayoutElement type exposes the following members.

Constructors

Name | Description
LayoutElement | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset
GetOffsetLeft | Gets left offset
GetOffsetRight | Gets right offset
GetOffsetTop | Gets top offset
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
Container | Link to container element (Inherited from RenderedObject.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


LayoutElement Constructor

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Constructor
LayoutElement Class See Also Send Feedback

Overload List

Name | Description
LayoutElement(IContainer) | Creates new class instance
LayoutElement(LayoutStyle, IContainer) | Creates new class instance

See Also

LayoutElement Class
LayoutElement Members
Telerik.Reporting.Charting Namespace


LayoutElement Constructor (IContainer)

[image]

Telerik Reporting Q2 2012
LayoutElement Constructor (IContainer)
LayoutElement Class See Also Send Feedback
Creates new class instance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutElement(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer
Container

See Also

LayoutElement Class
LayoutElement Overload
Telerik.Reporting.Charting Namespace


LayoutElement Constructor (LayoutStyle, IContainer)

[image]

Telerik Reporting Q2 2012
LayoutElement Constructor (LayoutStyle, IContainer)
LayoutElement Class See Also Send Feedback
Creates new class instance

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutElement(
    LayoutStyle appearance,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As LayoutStyle, _
    container As IContainer _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.LayoutStyle
Appearance
container
Type: Telerik.Reporting.Charting..::.IContainer
Container object

See Also

LayoutElement Class
LayoutElement Overload
Telerik.Reporting.Charting Namespace


LayoutElement Fields

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Fields
LayoutElement Class See Also Send Feedback

The LayoutElement type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


LayoutElement Methods

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Methods
LayoutElement Class See Also Send Feedback

The LayoutElement type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset
GetOffsetLeft | Gets left offset
GetOffsetRight | Gets right offset
GetOffsetTop | Gets top offset
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Overrides StateManagedObject..::.LoadViewState(Object).)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Overrides StateManagedObject..::.SaveViewState()()().)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
LayoutElement..::.Dispose Method
LayoutElement Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

LayoutElement Class
LayoutElement Members
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
LayoutElement..::.Dispose Method (Boolean)
LayoutElement Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

LayoutElement Class
Dispose Overload
Telerik.Reporting.Charting Namespace


GetOffsetBottom Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.GetOffsetBottom Method
LayoutElement Class See Also Send Feedback
Gets bottom offset

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float GetOffsetBottom(
    Object element
)
Visual Basic (Declaration)
Protected Function GetOffsetBottom ( _
    element As Object _
) As Single

Parameters

element
Type: System..::.Object
Element to get an offset of

Return Value

Offset value

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


GetOffsetLeft Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.GetOffsetLeft Method
LayoutElement Class See Also Send Feedback
Gets left offset

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float GetOffsetLeft(
    Object oelement
)
Visual Basic (Declaration)
Protected Function GetOffsetLeft ( _
    oelement As Object _
) As Single

Parameters

oelement
Type: System..::.Object
Element to get an offset of

Return Value

Offset value

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


GetOffsetRight Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.GetOffsetRight Method
LayoutElement Class See Also Send Feedback
Gets right offset

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float GetOffsetRight(
    Object element
)
Visual Basic (Declaration)
Protected Function GetOffsetRight ( _
    element As Object _
) As Single

Parameters

element
Type: System..::.Object
Element to get an offset of

Return Value

Offset value

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


GetOffsetTop Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.GetOffsetTop Method
LayoutElement Class See Also Send Feedback
Gets top offset

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float GetOffsetTop(
    Object element
)
Visual Basic (Declaration)
Protected Function GetOffsetTop ( _
    element As Object _
) As Single

Parameters

element
Type: System..::.Object
Element to get an offset of

Return Value

Offset value

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.LoadViewState Method
LayoutElement Class See Also Send Feedback
Loads data from a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
Views state to load from

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.SaveViewState Method
LayoutElement Class See Also Send Feedback
Saves settings to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved view state

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.TrackViewState Method
LayoutElement Class See Also Send Feedback
Tracking view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


LayoutElement Properties

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Properties
LayoutElement Class See Also Send Feedback

The LayoutElement type exposes the following members.

Properties

Name | Description
Container | Link to container element (Inherited from RenderedObject.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

LayoutElement Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Class

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Class
Members See Also Send Feedback
MarkedZone label class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class MarkedZoneLabel : ChartLabel
Visual Basic (Declaration)
Public Class MarkedZoneLabel _
    Inherits ChartLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.ChartLabel
Telerik.Reporting.Charting..::.MarkedZoneLabel

See Also

MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Members

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel Members
MarkedZoneLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The MarkedZoneLabel type exposes the following members.

Constructors

Name | Description
MarkedZoneLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor
MarkedZoneLabel Class See Also Send Feedback

Overload List

Name | Description
MarkedZoneLabel()()() | Create new instance of MarkedZoneLabel
MarkedZoneLabel(StyleLabel) | Create new instance of MarkedZoneLabel
MarkedZoneLabel(Chart, IContainer) | Create new instance of MarkedZoneLabel
MarkedZoneLabel(StyleLabel, Object) | Create new instance of MarkedZoneLabel
MarkedZoneLabel(StyleLabel, String) | Create new instance of MarkedZoneLabel

See Also

MarkedZoneLabel Class
MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor
MarkedZoneLabel Class See Also Send Feedback
Create new instance of MarkedZoneLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarkedZoneLabel()
Visual Basic (Declaration)
Public Sub New

See Also

MarkedZoneLabel Class
MarkedZoneLabel Overload
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor (StyleLabel)

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor (StyleLabel)
MarkedZoneLabel Class See Also Send Feedback
Create new instance of MarkedZoneLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarkedZoneLabel(
    StyleLabel appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label

See Also

MarkedZoneLabel Class
MarkedZoneLabel Overload
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor (Chart, IContainer)

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor (Chart, IContainer)
MarkedZoneLabel Class See Also Send Feedback
Create new instance of MarkedZoneLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarkedZoneLabel(
    Chart parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

MarkedZoneLabel Class
MarkedZoneLabel Overload
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor (StyleLabel, Object)

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor (StyleLabel, Object)
MarkedZoneLabel Class See Also Send Feedback
Create new instance of MarkedZoneLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarkedZoneLabel(
    StyleLabel appearance,
    Object parent
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    parent As Object _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
parent
Type: System..::.Object
Parent element

See Also

MarkedZoneLabel Class
MarkedZoneLabel Overload
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Constructor (StyleLabel, String)

[image]

Telerik Reporting Q2 2012
MarkedZoneLabel Constructor (StyleLabel, String)
MarkedZoneLabel Class See Also Send Feedback
Create new instance of MarkedZoneLabel

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarkedZoneLabel(
    StyleLabel appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleLabel, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleLabel
Style of label
text
Type: System..::.String
Text

See Also

MarkedZoneLabel Class
MarkedZoneLabel Overload
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Fields

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel Fields
MarkedZoneLabel Class See Also Send Feedback

The MarkedZoneLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Methods

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel Methods
MarkedZoneLabel Class See Also Send Feedback

The MarkedZoneLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Inherited from ChartBaseLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel..::.Dispose Method
MarkedZoneLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

MarkedZoneLabel Class
MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel..::.GetOrder Method
MarkedZoneLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

MarkedZoneLabel Class
MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel..::.Remove Method
MarkedZoneLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

MarkedZoneLabel Class
MarkedZoneLabel Members
Telerik.Reporting.Charting Namespace


MarkedZoneLabel Properties

[image] [image]

Telerik Reporting Q2 2012
MarkedZoneLabel Properties
MarkedZoneLabel Class See Also Send Feedback

The MarkedZoneLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Link to visualization and design properties (Inherited from ChartLabel.)
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

MarkedZoneLabel Class
Telerik.Reporting.Charting Namespace


Palette Class

[image]

Telerik Reporting Q2 2012
Palette Class
Members See Also Send Feedback
Series color palette. Used for an automatic series items colors assignment

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Palette : StateManagedObject, ICloneable
Visual Basic (Declaration)
Public Class Palette _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.Palette

See Also

Palette Members
Telerik.Reporting.Charting Namespace


Palette Members

[image] [image]

Telerik Reporting Q2 2012
Palette Members
Palette Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Palette type exposes the following members.

Constructors

Name | Description
Palette | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets string representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Properties

Name | Description
Item | Gets and sets Palette item at specified index
Items | Gets Palette Items Collection
Name | Specifies the palette name
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Palette Constructor

[image] [image]

Telerik Reporting Q2 2012
Palette Constructor
Palette Class See Also Send Feedback

Overload List

Name | Description
Palette()()() | Create new instance of Palette class.
Palette(String) | Create new instance of Palette class.
Palette(String, array<ColorBlend>[]()[]) | Create new instance of Palette class.
Palette(String, array<Color>[]()[], Boolean) | Create new instance of Palette class.
Palette(String, array<Color>[]()[], array<Color>[]()[]) | Create new instance of Palette class.

See Also

Palette Class
Palette Members
Telerik.Reporting.Charting Namespace


Palette Constructor

[image]

Telerik Reporting Q2 2012
Palette Constructor
Palette Class See Also Send Feedback
Create new instance of Palette class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette()
Visual Basic (Declaration)
Public Sub New

See Also

Palette Class
Palette Overload
Telerik.Reporting.Charting Namespace


Palette Constructor (String)

[image]

Telerik Reporting Q2 2012
Palette Constructor (String)
Palette Class See Also Send Feedback
Create new instance of Palette class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Name of palette

See Also

Palette Class
Palette Overload
Telerik.Reporting.Charting Namespace


Palette Constructor (String, ColorBlend[])

[image]

Telerik Reporting Q2 2012
Palette Constructor (String, array<ColorBlend>[]()[][])
Palette Class See Also Send Feedback
Create new instance of Palette class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette(
    string name,
    ColorBlend[] addtionalColors
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    addtionalColors As ColorBlend() _
)

Parameters

name
Type: System..::.String
Name of Palette
addtionalColors
Type: array< Telerik.Reporting.Charting..::.ColorBlend >[]()[][]
Additional colors of palette

See Also

Palette Class
Palette Overload
Telerik.Reporting.Charting Namespace


Palette Constructor (String, Color[], Boolean)

[image]

Telerik Reporting Q2 2012
Palette Constructor (String, array<Color>[]()[][], Boolean)
Palette Class See Also Send Feedback
Create new instance of Palette class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette(
    string name,
    Color[] colors,
    bool twoColors
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    colors As Color(), _
    twoColors As Boolean _
)

Parameters

name
Type: System..::.String
Name
colors
Type: array< System.Drawing..::.Color >[]()[][]
Colors of items
twoColors
Type: System..::.Boolean
If true than second and main colors are equal

See Also

Palette Class
Palette Overload
Telerik.Reporting.Charting Namespace


Palette Constructor (String, Color[], Color[])

[image]

Telerik Reporting Q2 2012
Palette Constructor (String, array<Color>[]()[][], array<Color>[]()[][])
Palette Class See Also Send Feedback
Create new instance of Palette class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Palette(
    string name,
    Color[] mainColors,
    Color[] secondColors
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    mainColors As Color(), _
    secondColors As Color() _
)

Parameters

name
Type: System..::.String
Name of palette
mainColors
Type: array< System.Drawing..::.Color >[]()[][]
Main colors of palette items
secondColors
Type: array< System.Drawing..::.Color >[]()[][]
Second colors of palette items

See Also

Palette Class
Palette Overload
Telerik.Reporting.Charting Namespace


Palette Methods

[image] [image]

Telerik Reporting Q2 2012
Palette Methods
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets string representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Palette..::.Clone Method
Palette Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Palette..::.Dispose Method
Palette Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

Palette Class
Palette Members
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
Palette..::.LoadViewState Method
Palette Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState data

See Also

Palette Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
Palette..::.SaveViewState Method
Palette Class See Also Send Feedback
Save data into ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

Palette Class
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Palette..::.ToString Method
Palette Class See Also Send Feedback
Gets string representation

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

String representation

See Also

Palette Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
Palette..::.TrackViewState Method
Palette Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Palette Properties

[image] [image]

Telerik Reporting Q2 2012
Palette Properties
Palette Class See Also Send Feedback

The Palette type exposes the following members.

Properties

Name | Description
Item | Gets and sets Palette item at specified index
Items | Gets Palette Items Collection
Name | Specifies the palette name
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
Palette..::.Item Property
Palette Class See Also Send Feedback
Gets and sets Palette item at specified index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As PaletteItem

Parameters

index
Type: System..::.Int32
Index to get palette item

Field Value

Palette item

Return Value

Palette item at specified index

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Items Property

[image]

Telerik Reporting Q2 2012
Palette..::.Items Property
Palette Class See Also Send Feedback
Gets Palette Items Collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItemsCollection Items { get; }
Visual Basic (Declaration)
Public ReadOnly Property Items As PaletteItemsCollection

See Also

Palette Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Palette..::.Name Property
Palette Class See Also Send Feedback
Specifies the palette name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

Palette name

See Also

Palette Class
Telerik.Reporting.Charting Namespace


PaletteItem Class

[image]

Telerik Reporting Q2 2012
PaletteItem Class
Members See Also Send Feedback
Palette item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PaletteItem : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class PaletteItem _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.PaletteItem

See Also

PaletteItem Members
Telerik.Reporting.Charting Namespace


PaletteItem Members

[image] [image]

Telerik Reporting Q2 2012
PaletteItem Members
PaletteItem Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PaletteItem type exposes the following members.

Constructors

Name | Description
PaletteItem | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets string representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Properties

Name | Description
AdditionalColors | Defines arrays of colors and positions used for interpolating color blending
MainColor | Specifies the main color for palette item
Name | Specifies the name for palette item
SecondColor | Specifies the second color for palette item
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


PaletteItem Constructor

[image] [image]

Telerik Reporting Q2 2012
PaletteItem Constructor
PaletteItem Class See Also Send Feedback

Overload List

Name | Description
PaletteItem()()() | Create new instance of PaletteItem class.
PaletteItem(ColorBlend) | Create new instance of PaletteItem class.
PaletteItem(Color, Color) | Create new instance of PaletteItem class.
PaletteItem(String, ColorBlend) | Create new instance of PaletteItem class.
PaletteItem(String, Color, Color) | Create new instance of PaletteItem class.

See Also

PaletteItem Class
PaletteItem Members
Telerik.Reporting.Charting Namespace


PaletteItem Constructor

[image]

Telerik Reporting Q2 2012
PaletteItem Constructor
PaletteItem Class See Also Send Feedback
Create new instance of PaletteItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem()
Visual Basic (Declaration)
Public Sub New

See Also

PaletteItem Class
PaletteItem Overload
Telerik.Reporting.Charting Namespace


PaletteItem Constructor (ColorBlend)

[image]

Telerik Reporting Q2 2012
PaletteItem Constructor (ColorBlend)
PaletteItem Class See Also Send Feedback
Create new instance of PaletteItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem(
    ColorBlend additionalColors
)
Visual Basic (Declaration)
Public Sub New ( _
    additionalColors As ColorBlend _
)

Parameters

additionalColors
Type: Telerik.Reporting.Charting..::.ColorBlend
Colors with positions

See Also

PaletteItem Class
PaletteItem Overload
Telerik.Reporting.Charting Namespace


PaletteItem Constructor (Color, Color)

[image]

Telerik Reporting Q2 2012
PaletteItem Constructor (Color, Color)
PaletteItem Class See Also Send Feedback
Create new instance of PaletteItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem(
    Color mainColor,
    Color secondColor
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color, _
    secondColor As Color _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color of item
secondColor
Type: System.Drawing..::.Color
Second color of item

See Also

PaletteItem Class
PaletteItem Overload
Telerik.Reporting.Charting Namespace


PaletteItem Constructor (String, ColorBlend)

[image]

Telerik Reporting Q2 2012
PaletteItem Constructor (String, ColorBlend)
PaletteItem Class See Also Send Feedback
Create new instance of PaletteItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem(
    string name,
    ColorBlend additionalColors
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    additionalColors As ColorBlend _
)

Parameters

name
Type: System..::.String
Name of item
additionalColors
Type: Telerik.Reporting.Charting..::.ColorBlend
Colors with positions

See Also

PaletteItem Class
PaletteItem Overload
Telerik.Reporting.Charting Namespace


PaletteItem Constructor (String, Color, Color)

[image]

Telerik Reporting Q2 2012
PaletteItem Constructor (String, Color, Color)
PaletteItem Class See Also Send Feedback
Create new instance of PaletteItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem(
    string name,
    Color mainColor,
    Color secondColor
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    mainColor As Color, _
    secondColor As Color _
)

Parameters

name
Type: System..::.String
Name of item
mainColor
Type: System.Drawing..::.Color
Main color of item
secondColor
Type: System.Drawing..::.Color
Second color of item

See Also

PaletteItem Class
PaletteItem Overload
Telerik.Reporting.Charting Namespace


PaletteItem Methods

[image] [image]

Telerik Reporting Q2 2012
PaletteItem Methods
PaletteItem Class See Also Send Feedback

The PaletteItem type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data into ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ToString | Gets string representation (Overrides StateManagedObjectToString()()().)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
PaletteItem..::.Clone Method
PaletteItem Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance with fields equal to these ones

Implements

ICloneable..::.Clone()()()

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PaletteItem..::.Dispose Method
PaletteItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PaletteItem Class
PaletteItem Members
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
PaletteItem..::.LoadViewState Method
PaletteItem Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
PaletteItem..::.SaveViewState Method
PaletteItem Class See Also Send Feedback
Save data into ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
PaletteItem..::.ToString Method
PaletteItem Class See Also Send Feedback
Gets string representation

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

String representation

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
PaletteItem..::.TrackViewState Method
PaletteItem Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


PaletteItem Properties

[image] [image]

Telerik Reporting Q2 2012
PaletteItem Properties
PaletteItem Class See Also Send Feedback

The PaletteItem type exposes the following members.

Properties

Name | Description
AdditionalColors | Defines arrays of colors and positions used for interpolating color blending
MainColor | Specifies the main color for palette item
Name | Specifies the name for palette item
SecondColor | Specifies the second color for palette item
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


AdditionalColors Property

[image]

Telerik Reporting Q2 2012
PaletteItem..::.AdditionalColors Property
PaletteItem Class See Also Send Feedback
Defines arrays of colors and positions used for interpolating color blending

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend AdditionalColors { get; }
Visual Basic (Declaration)
Public ReadOnly Property AdditionalColors As ColorBlend

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
PaletteItem..::.MainColor Property
PaletteItem Class See Also Send Feedback
Specifies the main color for palette item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color MainColor { get; set; }
Visual Basic (Declaration)
Public Property MainColor As Color

Field Value

Main color of item

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
PaletteItem..::.Name Property
PaletteItem Class See Also Send Feedback
Specifies the name for palette item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

Name of item

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


SecondColor Property

[image]

Telerik Reporting Q2 2012
PaletteItem..::.SecondColor Property
PaletteItem Class See Also Send Feedback
Specifies the second color for palette item

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color SecondColor { get; set; }
Visual Basic (Declaration)
Public Property SecondColor As Color

Field Value

Second color of item

See Also

PaletteItem Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Class

[image]

Telerik Reporting Q2 2012
PaletteItemsCollection Class
Members See Also Send Feedback
Palette items collection

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PaletteItemsCollection : ChartingStateManagedCollection<PaletteItem>
Visual Basic (Declaration)
Public Class PaletteItemsCollection _
    Inherits ChartingStateManagedCollection(Of PaletteItem)

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ChartingStateManagedCollection <(Of <(<' PaletteItem >)>)>
Telerik.Reporting.Charting..::.PaletteItemsCollection

See Also

PaletteItemsCollection Members
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Members

[image] [image]

Telerik Reporting Q2 2012
PaletteItemsCollection Members
PaletteItemsCollection Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PaletteItemsCollection type exposes the following members.

Constructors

Name | Description
PaletteItemsCollection | Create new instance of PaletteItemsCollection class.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetItem | Gets Palette item at specified index
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Constructor

[image]

Telerik Reporting Q2 2012
PaletteItemsCollection Constructor
PaletteItemsCollection Class See Also Send Feedback
Create new instance of PaletteItemsCollection class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItemsCollection()
Visual Basic (Declaration)
Public Sub New

See Also

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Methods

[image] [image]

Telerik Reporting Q2 2012
PaletteItemsCollection Methods
PaletteItemsCollection Class See Also Send Feedback

The PaletteItemsCollection type exposes the following members.

Methods

Name | Description
Add | Adds new item in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
AddRange | Adds items range in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Clear | Clears collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Contains | Checks does collection contain the given item (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
CopyTo | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetEnumerator | (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
GetItem | Gets Palette item at specified index
IndexOf | Item index in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Insert | Inserts item at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClear | Before collection clearing event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnClearComplete | Collection after clean event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsert | Item before insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnInsertComplete | Item after insert event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemove | Item before remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
OnRemoveComplete | Item after remove event (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Remove | Removes item from collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
RemoveAt | Removes item from collection at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
SetItemDirty | Marks collection item dirty (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
IList..::.Add | Adds new item in the IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Clear | Clears IList items (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Contains | Checks does IList contain the given value (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.CopyTo | Copies the entire ICollection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IEnumerable..::.GetEnumerator | Returns an enumerator that iterates through the collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IndexOf | Gets the index of the object value in an IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Insert | Inserts new value in IList at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.LoadViewState | Loads collection from view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Remove | Removes value from IList (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.RemoveAt | Removes value from IList at the given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.SaveViewState | Saves collection to a view state (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


GetItem Method

[image]

Telerik Reporting Q2 2012
PaletteItemsCollection..::.GetItem Method
PaletteItemsCollection Class See Also Send Feedback
Gets Palette item at specified index

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaletteItem GetItem(
    int index
)
Visual Basic (Declaration)
Public Function GetItem ( _
    index As Integer _
) As PaletteItem

Parameters

index
Type: System..::.Int32
Index to get palette item

Return Value

Palette item at specified index

See Also

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


PaletteItemsCollection Properties

[image] [image]

Telerik Reporting Q2 2012
PaletteItemsCollection Properties
PaletteItemsCollection Class See Also Send Feedback

The PaletteItemsCollection type exposes the following members.

Properties

Name | Description
Count | Gets items count in collection (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IsReadOnly | Gets true if collection is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
Item | Gets the collection item at given index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
List | Items list (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

Explicit Interface Implementations

Name | Description
ICollection..::.Count | Gets the collection items count (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsFixedSize | Is IList fixed size. Returns False (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.IsReadOnly | Is IList is read-only (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.IsSynchronized | Checks is collection synchronized (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IChartingStateManager..::.IsTrackingViewState | Gets the view state tracking status (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
IList..::.Item | Gets or sets the value from/to IList at the give index (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)
ICollection..::.SyncRoot | Gets the collection root (Inherited from ChartingStateManagedCollection<(Of <(T>)>).)

See Also

PaletteItemsCollection Class
Telerik.Reporting.Charting Namespace


PalettesCollection Structure

[image]

Telerik Reporting Q2 2012
PalettesCollection Structure
Members See Also Send Feedback
Default palettes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public struct PalettesCollection
Visual Basic (Declaration)
Public Structure PalettesCollection

See Also

PalettesCollection Members
Telerik.Reporting.Charting Namespace


PalettesCollection Members

[image] [image]

Telerik Reporting Q2 2012
PalettesCollection Members
PalettesCollection Structure Methods Fields See Also Send Feedback

The PalettesCollection type exposes the following members.

Methods

Name | Description
Contains | Checks whether palette name exist in default palettes list
GetPalette | Overloaded.

Fields

Name | Description
Palettes | Default color palettes listing

See Also

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


PalettesCollection Fields

[image] [image]

Telerik Reporting Q2 2012
PalettesCollection Fields
PalettesCollection Structure See Also Send Feedback

The PalettesCollection type exposes the following members.

Fields

Name | Description
Palettes | Default color palettes listing

See Also

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


Palettes Field

[image]

Telerik Reporting Q2 2012
PalettesCollection..::.Palettes Field
PalettesCollection Structure See Also Send Feedback
Default color palettes listing

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static List<string> Palettes
Visual Basic (Declaration)
Public Shared Palettes As List(Of String)

See Also

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


PalettesCollection Methods

[image] [image]

Telerik Reporting Q2 2012
PalettesCollection Methods
PalettesCollection Structure See Also Send Feedback

The PalettesCollection type exposes the following members.

Methods

Name | Description
Contains | Checks whether palette name exist in default palettes list
GetPalette | Overloaded.

See Also

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
PalettesCollection..::.Contains Method
PalettesCollection Structure See Also Send Feedback
Checks whether palette name exist in default palettes list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool Contains(
    string name
)
Visual Basic (Declaration)
Public Shared Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Name of palette

Return Value

Whether palette name exist in default palettes list or not

See Also

PalettesCollection Structure
Telerik.Reporting.Charting Namespace


GetPalette Method

[image] [image]

Telerik Reporting Q2 2012
PalettesCollection..::.GetPalette Method
PalettesCollection Structure See Also Send Feedback

Overload List

Name | Description
GetPalette(String) | Returns default palette by name
GetPalette(String, Chart) | Returns custom palette by name

See Also

PalettesCollection Structure
PalettesCollection Members
Telerik.Reporting.Charting Namespace


GetPalette Method (String)

[image]

Telerik Reporting Q2 2012
PalettesCollection..::.GetPalette Method (String)
PalettesCollection Structure See Also Send Feedback
Returns default palette by name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Palette GetPalette(
    string name
)
Visual Basic (Declaration)
Public Shared Function GetPalette ( _
    name As String _
) As Palette

Parameters

name
Type: System..::.String
Name of palette

See Also

PalettesCollection Structure
GetPalette Overload
Telerik.Reporting.Charting Namespace


GetPalette Method (String, Chart)

[image]

Telerik Reporting Q2 2012
PalettesCollection..::.GetPalette Method (String, Chart)
PalettesCollection Structure See Also Send Feedback
Returns custom palette by name

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Palette GetPalette(
    string name,
    Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetPalette ( _
    name As String, _
    chart As Chart _
) As Palette

Parameters

name
Type: System..::.String
Name of palette
chart
Type: Telerik.Reporting.Charting..::.Chart
Chart to get custom palettes

Return Value

See Also

PalettesCollection Structure
GetPalette Overload
Telerik.Reporting.Charting Namespace


Product Class

[image]

Telerik Reporting Q2 2012
Product Class
Members See Also Send Feedback
Sample object. Used for a data binding demonstration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Product
Visual Basic (Declaration)
Public Class Product

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.Product

See Also

Product Members
Telerik.Reporting.Charting Namespace


Product Members

[image] [image]

Telerik Reporting Q2 2012
Product Members
Product Class Constructors Properties See Also Send Feedback

The Product type exposes the following members.

Constructors

Name | Description
Product | Overloaded.

Properties

Name | Description
Amount |
ID |
Name |

See Also

Product Class
Telerik.Reporting.Charting Namespace


Product Constructor

[image] [image]

Telerik Reporting Q2 2012
Product Constructor
Product Class See Also Send Feedback

Overload List

Name | Description
Product(Int32) | Initializes a new instance of the Product class
Product(Int32, String, Int32) | Initializes a new instance of the Product class

See Also

Product Class
Product Members
Telerik.Reporting.Charting Namespace


Product Constructor (Int32)

[image]

Telerik Reporting Q2 2012
Product Constructor (Int32)
Product Class See Also Send Feedback
Initializes a new instance of the Product class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Product(
    int idIn
)
Visual Basic (Declaration)
Public Sub New ( _
    idIn As Integer _
)

Parameters

idIn
Type: System..::.Int32

See Also

Product Class
Product Overload
Telerik.Reporting.Charting Namespace


Product Constructor (Int32, String, Int32)

[image]

Telerik Reporting Q2 2012
Product Constructor (Int32, String, Int32)
Product Class See Also Send Feedback
Initializes a new instance of the Product class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Product(
    int idIn,
    string name,
    int val
)
Visual Basic (Declaration)
Public Sub New ( _
    idIn As Integer, _
    name As String, _
    val As Integer _
)

Parameters

idIn
Type: System..::.Int32
name
Type: System..::.String
val
Type: System..::.Int32

See Also

Product Class
Product Overload
Telerik.Reporting.Charting Namespace


Product Properties

[image] [image]

Telerik Reporting Q2 2012
Product Properties
Product Class See Also Send Feedback

The Product type exposes the following members.

Properties

Name | Description
Amount |
ID |
Name |

See Also

Product Class
Telerik.Reporting.Charting Namespace


Amount Property

[image]

Telerik Reporting Q2 2012
Product..::.Amount Property
Product Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Amount { get; set; }
Visual Basic (Declaration)
Public Property Amount As Integer

See Also

Product Class
Telerik.Reporting.Charting Namespace


ID Property

[image]

Telerik Reporting Q2 2012
Product..::.ID Property
Product Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ID { get; set; }
Visual Basic (Declaration)
Public Property ID As Integer

See Also

Product Class
Telerik.Reporting.Charting Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Product..::.Name Property
Product Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

Product Class
Telerik.Reporting.Charting Namespace


ProductsBL Class

[image]

Telerik Reporting Q2 2012
ProductsBL Class
Members See Also Send Feedback
Sample business logic object. Used for a data binding demonstration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ProductsBL
Visual Basic (Declaration)
Public Class ProductsBL

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.ProductsBL

See Also

ProductsBL Members
Telerik.Reporting.Charting Namespace


ProductsBL Members

[image] [image]

Telerik Reporting Q2 2012
ProductsBL Members
ProductsBL Class Constructors Methods See Also Send Feedback

The ProductsBL type exposes the following members.

Constructors

Name | Description
ProductsBL | Initializes a new instance of the ProductsBL class

Methods

Name | Description
GetProductsList | Returns products list

See Also

ProductsBL Class
Telerik.Reporting.Charting Namespace


ProductsBL Constructor

[image]

Telerik Reporting Q2 2012
ProductsBL Constructor
ProductsBL Class See Also Send Feedback
Initializes a new instance of the ProductsBL class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProductsBL()
Visual Basic (Declaration)
Public Sub New

See Also

ProductsBL Class
Telerik.Reporting.Charting Namespace


ProductsBL Methods

[image] [image]

Telerik Reporting Q2 2012
ProductsBL Methods
ProductsBL Class See Also Send Feedback

The ProductsBL type exposes the following members.

Methods

Name | Description
GetProductsList | Returns products list

See Also

ProductsBL Class
Telerik.Reporting.Charting Namespace


GetProductsList Method

[image]

Telerik Reporting Q2 2012
ProductsBL..::.GetProductsList Method
ProductsBL Class See Also Send Feedback
Returns products list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static List<Product> GetProductsList()
Visual Basic (Declaration)
Public Shared Function GetProductsList As List(Of Product)

Return Value

See Also

ProductsBL Class
Telerik.Reporting.Charting Namespace


ProductsList Class

[image]

Telerik Reporting Q2 2012
ProductsList Class
Members See Also Send Feedback
IBindingList example. Used for a data binding demonstration only

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ProductsList : CollectionBase,
    IBindingList, IList, ICollection, IEnumerable
Visual Basic (Declaration)
Public Class ProductsList _
    Inherits CollectionBase _
    Implements IBindingList, IList, ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
System.Collections..::.CollectionBase
Telerik.Reporting.Charting..::.ProductsList

See Also

ProductsList Members
Telerik.Reporting.Charting Namespace


ProductsList Members

[image] [image]

Telerik Reporting Q2 2012
ProductsList Members
ProductsList Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The ProductsList type exposes the following members.

Constructors

Name | Description
ProductsList | Initializes a new instance of the ProductsList class

Methods

Name | Description
Add |
AddNew |
LoadProducts |
OnClear | (Overrides CollectionBase..::.OnClear()()().)
OnClearComplete | (Overrides CollectionBase..::.OnClearComplete()()().)
OnInsertComplete | (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnListChanged |
OnRemoveComplete | (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSetComplete | (Overrides CollectionBase..::.OnSetComplete(Int32, Object, Object).)
Remove |

Properties

Name | Description
Item |

Events

Name | Description
ListChanged |

Explicit Interface Implementations

Name | Description
IBindingList..::.AddIndex |
IBindingList..::.AddNew |
IBindingList..::.AllowEdit |
IBindingList..::.AllowNew |
IBindingList..::.AllowRemove |
IBindingList..::.ApplySort |
IBindingList..::.Find |
IBindingList..::.IsSorted |
IBindingList..::.RemoveIndex |
IBindingList..::.RemoveSort |
IBindingList..::.SortDirection |
IBindingList..::.SortProperty |
IBindingList..::.SupportsChangeNotification |
IBindingList..::.SupportsSearching |
IBindingList..::.SupportsSorting |

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


ProductsList Constructor

[image]

Telerik Reporting Q2 2012
ProductsList Constructor
ProductsList Class See Also Send Feedback
Initializes a new instance of the ProductsList class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProductsList()
Visual Basic (Declaration)
Public Sub New

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


ProductsList Methods

[image] [image]

Telerik Reporting Q2 2012
ProductsList Methods
ProductsList Class See Also Send Feedback

The ProductsList type exposes the following members.

Methods

Name | Description
Add |
AddNew |
LoadProducts |
OnClear | (Overrides CollectionBase..::.OnClear()()().)
OnClearComplete | (Overrides CollectionBase..::.OnClearComplete()()().)
OnInsertComplete | (Overrides CollectionBase..::.OnInsertComplete(Int32, Object).)
OnListChanged |
OnRemoveComplete | (Overrides CollectionBase..::.OnRemoveComplete(Int32, Object).)
OnSetComplete | (Overrides CollectionBase..::.OnSetComplete(Int32, Object, Object).)
Remove |

Explicit Interface Implementations

Name | Description
IBindingList..::.AddIndex |
IBindingList..::.AddNew |
IBindingList..::.ApplySort |
IBindingList..::.Find |
IBindingList..::.RemoveIndex |
IBindingList..::.RemoveSort |

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.AddIndex Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.AddIndex Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IBindingList.AddIndex(
    PropertyDescriptor property
)
Visual Basic (Declaration)
Private Sub AddIndex ( _
    property As PropertyDescriptor _
) Implements IBindingList.AddIndex

Parameters

property
Type: System.ComponentModel..::.PropertyDescriptor

Implements

IBindingList..::.AddIndex(PropertyDescriptor)

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.AddNew Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.AddNew Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object IBindingList.AddNew()
Visual Basic (Declaration)
Private Function AddNew As Object Implements IBindingList.AddNew

Implements

IBindingList..::.AddNew()()()

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.ApplySort Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.ApplySort Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IBindingList.ApplySort(
    PropertyDescriptor property,
    ListSortDirection direction
)
Visual Basic (Declaration)
Private Sub ApplySort ( _
    property As PropertyDescriptor, _
    direction As ListSortDirection _
) Implements IBindingList.ApplySort

Parameters

property
Type: System.ComponentModel..::.PropertyDescriptor
direction
Type: System.ComponentModel..::.ListSortDirection

Implements

IBindingList..::.ApplySort(PropertyDescriptor, ListSortDirection)

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.Find Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.Find Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int IBindingList.Find(
    PropertyDescriptor property,
    Object key
)
Visual Basic (Declaration)
Private Function Find ( _
    property As PropertyDescriptor, _
    key As Object _
) As Integer Implements IBindingList.Find

Parameters

property
Type: System.ComponentModel..::.PropertyDescriptor
key
Type: System..::.Object

Implements

IBindingList..::.Find(PropertyDescriptor, Object)

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.RemoveIndex Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.RemoveIndex Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IBindingList.RemoveIndex(
    PropertyDescriptor property
)
Visual Basic (Declaration)
Private Sub RemoveIndex ( _
    property As PropertyDescriptor _
) Implements IBindingList.RemoveIndex

Parameters

property
Type: System.ComponentModel..::.PropertyDescriptor

Implements

IBindingList..::.RemoveIndex(PropertyDescriptor)

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.RemoveSort Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.RemoveSort Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IBindingList.RemoveSort()
Visual Basic (Declaration)
Private Sub RemoveSort Implements IBindingList.RemoveSort

Implements

IBindingList..::.RemoveSort()()()

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.Add Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Add(
    Product value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Product _
) As Integer

Parameters

value
Type: Telerik.Reporting.Charting..::.Product

Return Value

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


AddNew Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.AddNew Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Product AddNew()
Visual Basic (Declaration)
Public Function AddNew As Product

Return Value

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


LoadProducts Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.LoadProducts Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void LoadProducts()
Visual Basic (Declaration)
Public Sub LoadProducts

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnClear Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnClear Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnClear()
Visual Basic (Declaration)
Protected Overrides Sub OnClear

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnClearComplete Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnClearComplete Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnClearComplete()
Visual Basic (Declaration)
Protected Overrides Sub OnClearComplete

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnInsertComplete Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnInsertComplete Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnInsertComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnListChanged Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnListChanged Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnListChanged(
    ListChangedEventArgs ev
)
Visual Basic (Declaration)
Protected Overridable Sub OnListChanged ( _
    ev As ListChangedEventArgs _
)

Parameters

ev
Type: System.ComponentModel..::.ListChangedEventArgs

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnRemoveComplete Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnRemoveComplete Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnRemoveComplete(
    int index,
    Object value
)
Visual Basic (Declaration)
Protected Overrides Sub OnRemoveComplete ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


OnSetComplete Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.OnSetComplete Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnSetComplete(
    int index,
    Object oldValue,
    Object newValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnSetComplete ( _
    index As Integer, _
    oldValue As Object, _
    newValue As Object _
)

Parameters

index
Type: System..::.Int32
oldValue
Type: System..::.Object
newValue
Type: System..::.Object

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
ProductsList..::.Remove Method
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove(
    Product value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Product _
)

Parameters

value
Type: Telerik.Reporting.Charting..::.Product

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


ProductsList Properties

[image] [image]

Telerik Reporting Q2 2012
ProductsList Properties
ProductsList Class See Also Send Feedback

The ProductsList type exposes the following members.

Properties

Name | Description
Item |

Explicit Interface Implementations

Name | Description
IBindingList..::.AllowEdit |
IBindingList..::.AllowNew |
IBindingList..::.AllowRemove |
IBindingList..::.IsSorted |
IBindingList..::.SortDirection |
IBindingList..::.SortProperty |
IBindingList..::.SupportsChangeNotification |
IBindingList..::.SupportsSearching |
IBindingList..::.SupportsSorting |

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.AllowEdit Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.AllowEdit Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.AllowEdit { get; }
Visual Basic (Declaration)
Private ReadOnly Property AllowEdit As Boolean
    Implements IBindingList.AllowEdit

Implements

IBindingList..::.AllowEdit

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.AllowNew Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.AllowNew Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.AllowNew { get; }
Visual Basic (Declaration)
Private ReadOnly Property AllowNew As Boolean
    Implements IBindingList.AllowNew

Implements

IBindingList..::.AllowNew

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.AllowRemove Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.AllowRemove Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.AllowRemove { get; }
Visual Basic (Declaration)
Private ReadOnly Property AllowRemove As Boolean
    Implements IBindingList.AllowRemove

Implements

IBindingList..::.AllowRemove

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.IsSorted Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.IsSorted Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.IsSorted { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsSorted As Boolean
    Implements IBindingList.IsSorted

Implements

IBindingList..::.IsSorted

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.SortDirection Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.SortDirection Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ListSortDirection IBindingList.SortDirection { get; }
Visual Basic (Declaration)
Private ReadOnly Property SortDirection As ListSortDirection
    Implements IBindingList.SortDirection

Implements

IBindingList..::.SortDirection

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.SortProperty Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.SortProperty Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PropertyDescriptor IBindingList.SortProperty { get; }
Visual Basic (Declaration)
Private ReadOnly Property SortProperty As PropertyDescriptor
    Implements IBindingList.SortProperty

Implements

IBindingList..::.SortProperty

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.SupportsChangeNotification Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.SupportsChangeNotification Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.SupportsChangeNotification { get; }
Visual Basic (Declaration)
Private ReadOnly Property SupportsChangeNotification As Boolean
    Implements IBindingList.SupportsChangeNotification

Implements

IBindingList..::.SupportsChangeNotification

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.SupportsSearching Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.SupportsSearching Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.SupportsSearching { get; }
Visual Basic (Declaration)
Private ReadOnly Property SupportsSearching As Boolean
    Implements IBindingList.SupportsSearching

Implements

IBindingList..::.SupportsSearching

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


IBindingList.SupportsSorting Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.IBindingList..::.SupportsSorting Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IBindingList.SupportsSorting { get; }
Visual Basic (Declaration)
Private ReadOnly Property SupportsSorting As Boolean
    Implements IBindingList.SupportsSorting

Implements

IBindingList..::.SupportsSorting

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ProductsList..::.Item Property
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Product this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Product

Parameters

index
Type: System..::.Int32

Return Value

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


ProductsList Events

[image] [image]

Telerik Reporting Q2 2012
ProductsList Events
ProductsList Class See Also Send Feedback

The ProductsList type exposes the following members.

Events

Name | Description
ListChanged |

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


ListChanged Event

[image]

Telerik Reporting Q2 2012
ProductsList..::.ListChanged Event
ProductsList Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event ListChangedEventHandler ListChanged
Visual Basic (Declaration)
Public Event ListChanged As ListChangedEventHandler

Implements

IBindingList..::.ListChanged

See Also

ProductsList Class
Telerik.Reporting.Charting Namespace


RegionClickEventArgs Class

[image]

Telerik Reporting Q2 2012
RegionClickEventArgs Class
Members See Also Send Feedback
Event arguments when a chart element is clicked.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class RegionClickEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RegionClickEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
Telerik.Reporting.Charting..::.RegionClickEventArgs

See Also

RegionClickEventArgs Members
Telerik.Reporting.Charting Namespace


RegionClickEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
RegionClickEventArgs Members
RegionClickEventArgs Class Constructors Properties See Also Send Feedback

The RegionClickEventArgs type exposes the following members.

Constructors

Name | Description
RegionClickEventArgs | Initializes a new instance of the RegionClickEventArgs class.

Properties

Name | Description
Element | Reverse link to a parent

See Also

RegionClickEventArgs Class
Telerik.Reporting.Charting Namespace


RegionClickEventArgs Constructor

[image]

Telerik Reporting Q2 2012
RegionClickEventArgs Constructor
RegionClickEventArgs Class See Also Send Feedback
Initializes a new instance of the RegionClickEventArgs class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RegionClickEventArgs(
    IActiveRegion element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As IActiveRegion _
)

Parameters

element
Type: IActiveRegion
The element.

See Also

RegionClickEventArgs Class
Telerik.Reporting.Charting Namespace


RegionClickEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
RegionClickEventArgs Properties
RegionClickEventArgs Class See Also Send Feedback

The RegionClickEventArgs type exposes the following members.

Properties

Name | Description
Element | Reverse link to a parent

See Also

RegionClickEventArgs Class
Telerik.Reporting.Charting Namespace


Element Property

[image]

Telerik Reporting Q2 2012
RegionClickEventArgs..::.Element Property
RegionClickEventArgs Class See Also Send Feedback
Reverse link to a parent

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IActiveRegion Element { get; set; }
Visual Basic (Declaration)
Public Property Element As IActiveRegion

See Also

RegionClickEventArgs Class
Telerik.Reporting.Charting Namespace


RegionClickEventHandler Delegate

[image]

Telerik Reporting Q2 2012
RegionClickEventHandler Delegate
See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate void RegionClickEventHandler(
    Object sender,
    RegionClickEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub RegionClickEventHandler ( _
    sender As Object, _
    args As RegionClickEventArgs _
)

Parameters

sender
Type: System..::.Object
args
Type: Telerik.Reporting.Charting..::.RegionClickEventArgs

See Also

Telerik.Reporting.Charting Namespace


RenderedObject Class

[image]

Telerik Reporting Q2 2012
RenderedObject Class
Members See Also Send Feedback
Base class for all objects being rendered

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class RenderedObject : StateManagedObject,
    IOrdering
Visual Basic (Declaration)
Public MustInherit Class RenderedObject _
    Inherits StateManagedObject _
    Implements IOrdering

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ChartAxis
Telerik.Reporting.Charting..::.ChartMarkedZone
Telerik.Reporting.Charting..::.ChartSeries
Telerik.Reporting.Charting..::.ChartSeriesItem
Telerik.Reporting.Charting..::.LayoutElement

See Also

RenderedObject Members
Telerik.Reporting.Charting Namespace


RenderedObject Members

[image] [image]

Telerik Reporting Q2 2012
RenderedObject Members
RenderedObject Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The RenderedObject type exposes the following members.

Constructors

Name | Description
RenderedObject | Initializes a new instance of the RenderedObject class

Methods

Name | Description
BringForward | Send element at one step forward in the render order list
BringToFront | Set element at the first position in render order list
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Remove | Remove this element from render order list
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SendBackward | Send element at one step back in the render order list
SendToBack | Send element at the end of render order list
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property)

Properties

Name | Description
Container | Link to container element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


RenderedObject Constructor

[image]

Telerik Reporting Q2 2012
RenderedObject Constructor
RenderedObject Class See Also Send Feedback
Initializes a new instance of the RenderedObject class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RenderedObject(
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As IContainer _
)

Parameters

container
Type: Telerik.Reporting.Charting..::.IContainer

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


RenderedObject Fields

[image] [image]

Telerik Reporting Q2 2012
RenderedObject Fields
RenderedObject Class See Also Send Feedback

The RenderedObject type exposes the following members.

Fields

Name | Description
objectContainer | Container, that contains the render order for taken up elements (For property)

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


objectContainer Field

[image]

Telerik Reporting Q2 2012
RenderedObject..::.objectContainer Field
RenderedObject Class See Also Send Feedback
Container, that contains the render order for taken up elements (For property)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected IContainer objectContainer
Visual Basic (Declaration)
Protected objectContainer As IContainer

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


RenderedObject Methods

[image] [image]

Telerik Reporting Q2 2012
RenderedObject Methods
RenderedObject Class See Also Send Feedback

The RenderedObject type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list
BringToFront | Set element at the first position in render order list
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOrder | Get this elements order position in container
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Remove | Remove this element from render order list
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SendBackward | Send element at one step back in the render order list
SendToBack | Send element at the end of render order list
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


BringForward Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.BringForward Method
RenderedObject Class See Also Send Feedback
Send element at one step forward in the render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void BringForward()
Visual Basic (Declaration)
Public Sub BringForward

Implements

IOrdering..::.BringForward()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


BringToFront Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.BringToFront Method
RenderedObject Class See Also Send Feedback
Set element at the first position in render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void BringToFront()
Visual Basic (Declaration)
Public Sub BringToFront

Implements

IOrdering..::.BringToFront()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
RenderedObject..::.Dispose Method
RenderedObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

RenderedObject Class
RenderedObject Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.GetOrder Method
RenderedObject Class See Also Send Feedback
Get this elements order position in container

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int GetOrder()
Visual Basic (Declaration)
Public Function GetOrder As Integer

Implements

IOrdering..::.GetOrder()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.Remove Method
RenderedObject Class See Also Send Feedback
Remove this element from render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove

Implements

IOrdering..::.Remove()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


SendBackward Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.SendBackward Method
RenderedObject Class See Also Send Feedback
Send element at one step back in the render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SendBackward()
Visual Basic (Declaration)
Public Sub SendBackward

Implements

IOrdering..::.SendBackward()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


SendToBack Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.SendToBack Method
RenderedObject Class See Also Send Feedback
Send element at the end of render order list

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SendToBack()
Visual Basic (Declaration)
Public Sub SendToBack

Implements

IOrdering..::.SendToBack()()()

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


SetOrder Method

[image]

Telerik Reporting Q2 2012
RenderedObject..::.SetOrder Method
RenderedObject Class See Also Send Feedback
Set this object in new render order position

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetOrder(
    int index
)
Visual Basic (Declaration)
Public Sub SetOrder ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
New position

Implements

IOrdering..::.SetOrder(Int32)

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


RenderedObject Properties

[image] [image]

Telerik Reporting Q2 2012
RenderedObject Properties
RenderedObject Class See Also Send Feedback

The RenderedObject type exposes the following members.

Properties

Name | Description
Container | Link to container element
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


Container Property

[image]

Telerik Reporting Q2 2012
RenderedObject..::.Container Property
RenderedObject Class See Also Send Feedback
Link to container element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IContainer Container { get; set; }
Visual Basic (Declaration)
Public Property Container As IContainer

Implements

IOrdering..::.Container

See Also

RenderedObject Class
Telerik.Reporting.Charting Namespace


ScaleBreak Class

[image]

Telerik Reporting Q2 2012
ScaleBreak Class
Members See Also Send Feedback
Y Axis scale break

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ScaleBreak : StateManagedObject
Visual Basic (Declaration)
Public Class ScaleBreak _
    Inherits StateManagedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.ScaleBreak

See Also

ScaleBreak Members
Telerik.Reporting.Charting Namespace


ScaleBreak Members

[image] [image]

Telerik Reporting Q2 2012
ScaleBreak Members
ScaleBreak Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ScaleBreak type exposes the following members.

Constructors

Name | Description
ScaleBreak | Constructor

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads settings from a view state (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Saves settings to a view state (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracking view state changes (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
scaleBreakParent | Parent element

Properties

Name | Description
Enabled | Is scale break feature enabled
Line | Break line appearance settings
LineStyle | Break line's appearance settings
MaxCount | Max scale breaks count
Parent | Parent element reference (ChartAxis)
Segments | Segments collection. Used with ScaleBreak feature enabled
ValueTolerance | Value tolerance in percents
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Space width between two break lines

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreak Constructor

[image]

Telerik Reporting Q2 2012
ScaleBreak Constructor
ScaleBreak Class See Also Send Feedback
Constructor

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ScaleBreak(
    ChartAxis parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartAxis _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartAxis

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreak Fields

[image] [image]

Telerik Reporting Q2 2012
ScaleBreak Fields
ScaleBreak Class See Also Send Feedback

The ScaleBreak type exposes the following members.

Fields

Name | Description
scaleBreakParent | Parent element

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


scaleBreakParent Field

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.scaleBreakParent Field
ScaleBreak Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartAxis scaleBreakParent
Visual Basic (Declaration)
Protected scaleBreakParent As ChartAxis

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreak Methods

[image] [image]

Telerik Reporting Q2 2012
ScaleBreak Methods
ScaleBreak Class See Also Send Feedback

The ScaleBreak type exposes the following members.

Methods

Name | Description
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads settings from a view state (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Saves settings to a view state (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracking view state changes (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ScaleBreak..::.Dispose Method
ScaleBreak Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ScaleBreak Class
ScaleBreak Members
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.LoadViewState Method
ScaleBreak Class See Also Send Feedback
Loads settings from a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
Saved state bag

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.SaveViewState Method
ScaleBreak Class See Also Send Feedback
Saves settings to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved state bag

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.TrackViewState Method
ScaleBreak Class See Also Send Feedback
Tracking view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreak Properties

[image] [image]

Telerik Reporting Q2 2012
ScaleBreak Properties
ScaleBreak Class See Also Send Feedback

The ScaleBreak type exposes the following members.

Properties

Name | Description
Enabled | Is scale break feature enabled
Line | Break line appearance settings
LineStyle | Break line's appearance settings
MaxCount | Max scale breaks count
Parent | Parent element reference (ChartAxis)
Segments | Segments collection. Used with ScaleBreak feature enabled
ValueTolerance | Value tolerance in percents
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Space width between two break lines

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Enabled Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.Enabled Property
ScaleBreak Class See Also Send Feedback
Is scale break feature enabled

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic (Declaration)
Public Property Enabled As Boolean

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Line Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.Line Property
ScaleBreak Class See Also Send Feedback
Break line appearance settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle Line { get; set; }
Visual Basic (Declaration)
Public Property Line As LineStyle

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


LineStyle Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.LineStyle Property
ScaleBreak Class See Also Send Feedback
Break line's appearance settings

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ScaleBreakLineType LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As ScaleBreakLineType

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


MaxCount Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.MaxCount Property
ScaleBreak Class See Also Send Feedback
Max scale breaks count

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int MaxCount { get; set; }
Visual Basic (Declaration)
Public Property MaxCount As Integer

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.Parent Property
ScaleBreak Class See Also Send Feedback
Parent element reference (ChartAxis)

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxis Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As ChartAxis

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Segments Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.Segments Property
ScaleBreak Class See Also Send Feedback
Segments collection. Used with ScaleBreak feature enabled

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AxisSegmentCollection Segments { get; }
Visual Basic (Declaration)
Public ReadOnly Property Segments As AxisSegmentCollection

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ValueTolerance Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.ValueTolerance Property
ScaleBreak Class See Also Send Feedback
Value tolerance in percents

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public byte ValueTolerance { get; set; }
Visual Basic (Declaration)
Public Property ValueTolerance As Byte

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ScaleBreak..::.Width Property
ScaleBreak Class See Also Send Feedback
Space width between two break lines

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer

See Also

ScaleBreak Class
Telerik.Reporting.Charting Namespace


ScaleBreakLineType Enumeration

[image]

Telerik Reporting Q2 2012
ScaleBreakLineType Enumeration
See Also Send Feedback
Possible axis scale break's line types

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ScaleBreakLineType
Visual Basic (Declaration)
Public Enumeration ScaleBreakLineType

Members

Member name | Description
Straight |
Curve |
JaggedCurve |
Sinusoid |

See Also

Telerik.Reporting.Charting Namespace


SeriesItemLabel Class

[image]

Telerik Reporting Q2 2012
SeriesItemLabel Class
Members See Also Send Feedback
Series item label

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class SeriesItemLabel : ChartBaseLabel
Visual Basic (Declaration)
Public Class SeriesItemLabel _
    Inherits ChartBaseLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.ChartBaseLabel
Telerik.Reporting.Charting..::.SeriesItemLabel

See Also

SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


SeriesItemLabel Members

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel Members
SeriesItemLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The SeriesItemLabel type exposes the following members.

Constructors

Name | Description
SeriesItemLabel | Overloaded.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Overrides ChartBaseLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


SeriesItemLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel Constructor
SeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
SeriesItemLabel()()() | Create new instance of SeriesItemLabel class.
SeriesItemLabel(ChartSeries) | Create new instance of SeriesItemLabel class.

See Also

SeriesItemLabel Class
SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


SeriesItemLabel Constructor

[image]

Telerik Reporting Q2 2012
SeriesItemLabel Constructor
SeriesItemLabel Class See Also Send Feedback
Create new instance of SeriesItemLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SeriesItemLabel()
Visual Basic (Declaration)
Public Sub New

See Also

SeriesItemLabel Class
SeriesItemLabel Overload
Telerik.Reporting.Charting Namespace


SeriesItemLabel Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
SeriesItemLabel Constructor (ChartSeries)
SeriesItemLabel Class See Also Send Feedback
Create new instance of SeriesItemLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SeriesItemLabel(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Series to which label belongs

See Also

SeriesItemLabel Class
SeriesItemLabel Overload
Telerik.Reporting.Charting Namespace


SeriesItemLabel Fields

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel Fields
SeriesItemLabel Class See Also Send Feedback

The SeriesItemLabel type exposes the following members.

Fields

Name | Description
chartBaseLabelActiveRegion | Active region (Inherited from ChartBaseLabel.)
chartBaseLabelOrderList | List, that represent the render order for taken up elements (For IContainer.OrderList property) (Inherited from ChartBaseLabel.)
chartBaseLabelParent | Parent element (Inherited from ChartBaseLabel.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


SeriesItemLabel Methods

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel Methods
SeriesItemLabel Class See Also Send Feedback

The SeriesItemLabel type exposes the following members.

Methods

Name | Description
Add | Add element at the end of list (Inherited from ChartBaseLabel.)
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
Clone | Clone this object (Overrides ChartBaseLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Overloaded.
Insert | Insert element at specific position in list (Inherited from ChartBaseLabel.)
LoadViewState | Load ViewState (Inherited from ChartBaseLabel.)
ReIndex | Re-index order list (Inherited from ChartBaseLabel.)
Remove | Overloaded.
RemoveAt | Remove element from list by it's index (Inherited from ChartBaseLabel.)
SaveViewState | Save to ViewState (Inherited from ChartBaseLabel.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Track ViewState (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
SeriesItemLabel..::.Clone Method
SeriesItemLabel Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Create new instance of SeriesItemLabel class with the same fields as this object

Implements

ICloneable..::.Clone()()()

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel..::.Dispose Method
SeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from ChartBaseLabel.)

See Also

SeriesItemLabel Class
SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


GetOrder Method

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel..::.GetOrder Method
SeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
GetOrder()()() | Get this elements order position in container (Inherited from RenderedObject.)
GetOrder(IOrdering) | Gets elements order position (Inherited from ChartBaseLabel.)

See Also

SeriesItemLabel Class
SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


Remove Method

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel..::.Remove Method
SeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove this element from render order list (Inherited from RenderedObject.)
Remove(IOrdering) | Remove element from list (Inherited from ChartBaseLabel.)

See Also

SeriesItemLabel Class
SeriesItemLabel Members
Telerik.Reporting.Charting Namespace


SeriesItemLabel Properties

[image] [image]

Telerik Reporting Q2 2012
SeriesItemLabel Properties
SeriesItemLabel Class See Also Send Feedback

The SeriesItemLabel type exposes the following members.

Properties

Name | Description
ActiveRegion | Gets and sets Active region (Inherited from ChartBaseLabel.)
Appearance | Visualization and design properties
Container | Link to container element (Inherited from RenderedObject.)
Marker | Graphic marker of label (Inherited from ChartBaseLabel.)
NextPosition | Gets a next free order position (Inherited from ChartBaseLabel.)
OrderList | List, that represent the render order for taken up elements (Inherited from ChartBaseLabel.)
Parent | Gets and sets Parent element (Inherited from ChartBaseLabel.)
TextBlock | ChartLabel TextBlock (Inherited from ChartBaseLabel.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets label's visibility (Inherited from ChartBaseLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
SeriesItemLabel..::.Appearance Property
SeriesItemLabel Class See Also Send Feedback
Visualization and design properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemLabel Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleSeriesItemLabel

See Also

SeriesItemLabel Class
Telerik.Reporting.Charting Namespace


StateManagedObject Class

[image]

Telerik Reporting Q2 2012
StateManagedObject Class
Members See Also Send Feedback
Base class implements IStateManager

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class StateManagedObject : IChartingStateManagedItem,
    IChartingStateManager, IDisposable
Visual Basic (Declaration)
Public MustInherit Class StateManagedObject _
    Implements IChartingStateManagedItem, IChartingStateManager, IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.ActiveRegion
Telerik.Reporting.Charting..::.AxisSegment
Telerik.Reporting.Charting..::.CustomFigure
Telerik.Reporting.Charting..::.GradientElement
Telerik.Reporting.Charting..::.Palette
Telerik.Reporting.Charting..::.PaletteItem
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.ScaleBreak
Telerik.Reporting.Charting.Styles..::.Corners
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.EmptyValue
Telerik.Reporting.Charting.Styles..::.FillSettings
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.ShadowStyle
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.TextProperties

See Also

StateManagedObject Members
Telerik.Reporting.Charting Namespace


StateManagedObject Members

[image] [image]

Telerik Reporting Q2 2012
StateManagedObject Members
StateManagedObject Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StateManagedObject type exposes the following members.

Constructors

Name | Description
StateManagedObject | Initializes a new instance of the StateManagedObject class

Methods

Name | Description
CloneState | Makes a view state clone
Dispose | Overloaded.
LoadViewState | Loads data from a view state
SaveViewState | Saves object data to a view state
SetDirty | Sets the item dirty state
TrackViewState | Tracks view state changes

Properties

Name | Description
ViewStateIgnoresCase | Gets if view sate should ignore case

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes
IChartingStateManager..::.LoadViewState | Loads data from a view state
IChartingStateManager..::.SaveViewState | Saves object data to a view state
IChartingStateManager..::.TrackViewState | Tracks view state changes

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


StateManagedObject Constructor

[image]

Telerik Reporting Q2 2012
StateManagedObject Constructor
StateManagedObject Class See Also Send Feedback
Initializes a new instance of the StateManagedObject class

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StateManagedObject()
Visual Basic (Declaration)
Protected Sub New

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


StateManagedObject Methods

[image] [image]

Telerik Reporting Q2 2012
StateManagedObject Methods
StateManagedObject Class See Also Send Feedback

The StateManagedObject type exposes the following members.

Methods

Name | Description
CloneState | Makes a view state clone
Dispose | Overloaded.
LoadViewState | Loads data from a view state
SaveViewState | Saves object data to a view state
SetDirty | Sets the item dirty state
TrackViewState | Tracks view state changes

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state
IChartingStateManager..::.SaveViewState | Saves object data to a view state
IChartingStateManager..::.TrackViewState | Tracks view state changes

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


CloneState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.CloneState Method
StateManagedObject Class See Also Send Feedback
Makes a view state clone

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StateBag CloneState()
Visual Basic (Declaration)
Protected Function CloneState As StateBag

Return Value

StateBag

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StateManagedObject..::.Dispose Method
StateManagedObject Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Releases all resources used by the StateManagedObject
Dispose(Boolean) | Releases the unmanaged resources used by the StateManagedObject and optionally releases the managed resources

See Also

StateManagedObject Class
StateManagedObject Members
Telerik.Reporting.Charting Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.Dispose Method
StateManagedObject Class See Also Send Feedback
Releases all resources used by the StateManagedObject

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

StateManagedObject Class
Dispose Overload
Telerik.Reporting.Charting Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.Dispose Method (Boolean)
StateManagedObject Class See Also Send Feedback
Releases the unmanaged resources used by the StateManagedObject and optionally releases the managed resources

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

StateManagedObject Class
Dispose Overload
Telerik.Reporting.Charting Namespace


IChartingStateManager.LoadViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.IChartingStateManager..::.LoadViewState Method
StateManagedObject Class See Also Send Feedback
Loads data from a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IChartingStateManager.LoadViewState(
    Object state
)
Visual Basic (Declaration)
Private Sub LoadViewState ( _
    state As Object _
) Implements IChartingStateManager.LoadViewState

Parameters

state
Type: System..::.Object
View state to load data from

Implements

IChartingStateManager..::.LoadViewState(Object)

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.SaveViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.IChartingStateManager..::.SaveViewState Method
StateManagedObject Class See Also Send Feedback
Saves object data to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object IChartingStateManager.SaveViewState()
Visual Basic (Declaration)
Private Function SaveViewState As Object
    Implements IChartingStateManager.SaveViewState

Return Value

Saved view state object

Implements

IChartingStateManager..::.SaveViewState()()()

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.TrackViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.IChartingStateManager..::.TrackViewState Method
StateManagedObject Class See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IChartingStateManager.TrackViewState()
Visual Basic (Declaration)
Private Sub TrackViewState Implements IChartingStateManager.TrackViewState

Implements

IChartingStateManager..::.TrackViewState()()()

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.LoadViewState Method
StateManagedObject Class See Also Send Feedback
Loads data from a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void LoadViewState(
    Object state
)
Visual Basic (Declaration)
Protected Overridable Sub LoadViewState ( _
    state As Object _
)

Parameters

state
Type: System..::.Object
View state to load data from

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.SaveViewState Method
StateManagedObject Class See Also Send Feedback
Saves object data to a view state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual Object SaveViewState()
Visual Basic (Declaration)
Protected Overridable Function SaveViewState As Object

Return Value

Saved view state object

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


SetDirty Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.SetDirty Method
StateManagedObject Class See Also Send Feedback
Sets the item dirty state

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetDirty()
Visual Basic (Declaration)
Public Sub SetDirty

Implements

IChartingStateManagedItem..::.SetDirty()()()

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.TrackViewState Method
StateManagedObject Class See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void TrackViewState()
Visual Basic (Declaration)
Protected Overridable Sub TrackViewState

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


StateManagedObject Properties

[image] [image]

Telerik Reporting Q2 2012
StateManagedObject Properties
StateManagedObject Class See Also Send Feedback

The StateManagedObject type exposes the following members.

Properties

Name | Description
ViewStateIgnoresCase | Gets if view sate should ignore case

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


IChartingStateManager.IsTrackingViewState Property

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.IChartingStateManager..::.IsTrackingViewState Property
StateManagedObject Class See Also Send Feedback
Is view state tracking changes

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool IChartingStateManager.IsTrackingViewState { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsTrackingViewState As Boolean
    Implements IChartingStateManager.IsTrackingViewState

Implements

IChartingStateManager..::.IsTrackingViewState

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


ViewStateIgnoresCase Property

[image]

Telerik Reporting Q2 2012
StateManagedObject..::.ViewStateIgnoresCase Property
StateManagedObject Class See Also Send Feedback
Gets if view sate should ignore case

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ViewStateIgnoresCase { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property ViewStateIgnoresCase As Boolean

See Also

StateManagedObject Class
Telerik.Reporting.Charting Namespace


TableRenderType Enumeration

[image]

Telerik Reporting Q2 2012
TableRenderType Enumeration
See Also Send Feedback
RenderType of DataTable

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum TableRenderType
Visual Basic (Declaration)
Public Enumeration TableRenderType

Members

Member name | Description
AutoSize |
CellFixedSize |
TableFixedSize |
PlotAreaRelative |

See Also

Telerik.Reporting.Charting Namespace


TextBlock Class

[image]

Telerik Reporting Q2 2012
TextBlock Class
Members See Also Send Feedback
Label text properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlock : LayoutElement, IDisposable
Visual Basic (Declaration)
Public Class TextBlock _
    Inherits LayoutElement _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockAxisItem
Telerik.Reporting.Charting..::.TextBlockEmptySeriesMessage
Telerik.Reporting.Charting..::.TextBlockHidden
Telerik.Reporting.Charting..::.TextBlockLabelItem
Telerik.Reporting.Charting..::.TextBlockMarkedZone
Telerik.Reporting.Charting..::.TextBlockSeriesItem
Telerik.Reporting.Charting..::.TextBlockTitle
Telerik.Reporting.Charting..::.TextBlockXAxisLabel
Telerik.Reporting.Charting..::.TextBlockYAxisLabel

See Also

TextBlock Members
Telerik.Reporting.Charting Namespace


TextBlock Members

[image] [image]

Telerik Reporting Q2 2012
TextBlock Members
TextBlock Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlock type exposes the following members.

Constructors

Name | Description
TextBlock | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom |
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text
textBlockParent | Parent element

Properties

Name | Description
Appearance | Text field style
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element
Text | Contained text data
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


TextBlock Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlock Constructor
TextBlock Class See Also Send Feedback

Overload List

Name | Description
TextBlock()()() | Create new instance of TextBlock class.
TextBlock(String) | Create new instance of TextBlock class.
TextBlock(StyleTextBlock) | Create new instance of TextBlock class.
TextBlock(ChartBaseLabel, IContainer) | Create new instance of TextBlock class.
TextBlock(StyleTextBlock, String) | Create new instance of TextBlock class.
TextBlock(ChartBaseLabel, IContainer, String) | Create new instance of TextBlock class.
TextBlock(ChartBaseLabel, IContainer, StyleTextBlock) | Create new instance of TextBlock class.
TextBlock(ChartBaseLabel, IContainer, StyleTextBlock, String) | Create new instance of TextBlock class.

See Also

TextBlock Class
TextBlock Members
Telerik.Reporting.Charting Namespace


TextBlock Constructor

[image]

Telerik Reporting Q2 2012
TextBlock Constructor
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (String)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (String)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (StyleTextBlock)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (StyleTextBlock)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    StyleTextBlock appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleTextBlock _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (ChartBaseLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (ChartBaseLabel, IContainer)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    ChartBaseLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (StyleTextBlock, String)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (StyleTextBlock, String)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    StyleTextBlock appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleTextBlock, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock
text
Type: System..::.String
Text

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (ChartBaseLabel, IContainer, String)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (ChartBaseLabel, IContainer, String)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    ChartBaseLabel parent,
    IContainer container,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    text As String _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
text
Type: System..::.String
Text

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (ChartBaseLabel, IContainer, StyleTextBlock)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (ChartBaseLabel, IContainer, StyleTextBlock)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    ChartBaseLabel parent,
    IContainer container,
    StyleTextBlock appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    appearance As StyleTextBlock _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Constructor (ChartBaseLabel, IContainer, StyleTextBlock, String)

[image]

Telerik Reporting Q2 2012
TextBlock Constructor (ChartBaseLabel, IContainer, StyleTextBlock, String)
TextBlock Class See Also Send Feedback
Create new instance of TextBlock class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlock(
    ChartBaseLabel parent,
    IContainer container,
    StyleTextBlock appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    appearance As StyleTextBlock, _
    text As String _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of textblock
text
Type: System..::.String
Text

See Also

TextBlock Class
TextBlock Overload
Telerik.Reporting.Charting Namespace


TextBlock Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlock Fields
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text
textBlockParent | Parent element

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


DEFAULT_TEXT Field

[image]

Telerik Reporting Q2 2012
TextBlock..::.DEFAULT_TEXT Field
TextBlock Class See Also Send Feedback
Default text of text block

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected string DEFAULT_TEXT
Visual Basic (Declaration)
Protected DEFAULT_TEXT As String

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


textBlockCalculatedMaxLength Field

[image]

Telerik Reporting Q2 2012
TextBlock..::.textBlockCalculatedMaxLength Field
TextBlock Class See Also Send Feedback
Max length of text

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected int textBlockCalculatedMaxLength
Visual Basic (Declaration)
Protected textBlockCalculatedMaxLength As Integer

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


textBlockParent Field

[image]

Telerik Reporting Q2 2012
TextBlock..::.textBlockParent Field
TextBlock Class See Also Send Feedback
Parent element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartBaseLabel textBlockParent
Visual Basic (Declaration)
Protected textBlockParent As ChartBaseLabel

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


TextBlock Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlock Methods
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom |
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
TextBlock..::.CopyFrom Method
TextBlock Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CopyFrom(
    TextBlock textBlock
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    textBlock As TextBlock _
)

Parameters

textBlock
Type: Telerik.Reporting.Charting..::.TextBlock

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlock..::.Dispose Method
TextBlock Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlock Class
TextBlock Members
Telerik.Reporting.Charting Namespace


TextBlock Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlock Properties
TextBlock Class See Also Send Feedback

The TextBlock type exposes the following members.

Properties

Name | Description
Appearance | Text field style
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element
Text | Contained text data
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


Appearance Property

[image]

Telerik Reporting Q2 2012
TextBlock..::.Appearance Property
TextBlock Class See Also Send Feedback
Text field style

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock Appearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property Appearance As StyleTextBlock

Field Value

Style of TextBlock

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
TextBlock..::.Parent Property
TextBlock Class See Also Send Feedback
Parent chart element

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartBaseLabel Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As ChartBaseLabel

Field Value

Parent element

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBlock..::.Text Property
TextBlock Class See Also Send Feedback
Contained text data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual string Text { get; set; }
Visual Basic (Declaration)
Public Overridable Property Text As String

Field Value

Text

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
TextBlock..::.Visible Property
TextBlock Class See Also Send Feedback
get a and sets visibility of TextBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean

Field Value

Visibility of TextBlock

See Also

TextBlock Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Class

[image]

Telerik Reporting Q2 2012
TextBlockAxisItem Class
Members See Also Send Feedback
Axis item text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockAxisItem : TextBlock
Visual Basic (Declaration)
Public Class TextBlockAxisItem _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockAxisItem

See Also

TextBlockAxisItem Members
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem Members
TextBlockAxisItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockAxisItem type exposes the following members.

Constructors

Name | Description
TextBlockAxisItem | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem Constructor
TextBlockAxisItem Class See Also Send Feedback

Overload List

Name | Description
TextBlockAxisItem()()() | Create new instance of TextBlockAxisItem class.
TextBlockAxisItem(ChartAxisItem, IContainer) | Create new instance of TextBlockAxisItem class.

See Also

TextBlockAxisItem Class
TextBlockAxisItem Members
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Constructor

[image]

Telerik Reporting Q2 2012
TextBlockAxisItem Constructor
TextBlockAxisItem Class See Also Send Feedback
Create new instance of TextBlockAxisItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockAxisItem()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockAxisItem Class
TextBlockAxisItem Overload
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Constructor (ChartAxisItem, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockAxisItem Constructor (ChartAxisItem, IContainer)
TextBlockAxisItem Class See Also Send Feedback
Create new instance of TextBlockAxisItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockAxisItem(
    ChartAxisItem parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartAxisItem, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartAxisItem
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockAxisItem Class
TextBlockAxisItem Overload
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem Fields
TextBlockAxisItem Class See Also Send Feedback

The TextBlockAxisItem type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem Methods
TextBlockAxisItem Class See Also Send Feedback

The TextBlockAxisItem type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem..::.Dispose Method
TextBlockAxisItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockAxisItem Class
TextBlockAxisItem Members
Telerik.Reporting.Charting Namespace


TextBlockAxisItem Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockAxisItem Properties
TextBlockAxisItem Class See Also Send Feedback

The TextBlockAxisItem type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockAxisItem Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Class

[image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Class
Members See Also Send Feedback
Empty Series message text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockEmptySeriesMessage : TextBlock
Visual Basic (Declaration)
Public Class TextBlockEmptySeriesMessage _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockEmptySeriesMessage

See Also

TextBlockEmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Members
TextBlockEmptySeriesMessage Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockEmptySeriesMessage type exposes the following members.

Constructors

Name | Description
TextBlockEmptySeriesMessage | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Constructor
TextBlockEmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
TextBlockEmptySeriesMessage()()() | Create new instance of TextBlockEmptySeriesMessage class.
TextBlockEmptySeriesMessage(EmptySeriesMessage, IContainer) | Create new instance of TextBlockEmptySeriesMessage class.

See Also

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Constructor

[image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Constructor
TextBlockEmptySeriesMessage Class See Also Send Feedback
Create new instance of TextBlockEmptySeriesMessage class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockEmptySeriesMessage()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Constructor (EmptySeriesMessage, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Constructor (EmptySeriesMessage, IContainer)
TextBlockEmptySeriesMessage Class See Also Send Feedback
Create new instance of TextBlockEmptySeriesMessage class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockEmptySeriesMessage(
    EmptySeriesMessage parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As EmptySeriesMessage, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.EmptySeriesMessage
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Overload
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Fields
TextBlockEmptySeriesMessage Class See Also Send Feedback

The TextBlockEmptySeriesMessage type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Methods
TextBlockEmptySeriesMessage Class See Also Send Feedback

The TextBlockEmptySeriesMessage type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage..::.Dispose Method
TextBlockEmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockEmptySeriesMessage Class
TextBlockEmptySeriesMessage Members
Telerik.Reporting.Charting Namespace


TextBlockEmptySeriesMessage Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage Properties
TextBlockEmptySeriesMessage Class See Also Send Feedback

The TextBlockEmptySeriesMessage type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBlockEmptySeriesMessage..::.Text Property
TextBlockEmptySeriesMessage Class See Also Send Feedback
Contained text data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String

See Also

TextBlockEmptySeriesMessage Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Class

[image]

Telerik Reporting Q2 2012
TextBlockHidden Class
Members See Also Send Feedback
Chart title text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockHidden : TextBlock
Visual Basic (Declaration)
Public Class TextBlockHidden _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockHidden
Telerik.Reporting.Charting..::.TextBlockLegend

See Also

TextBlockHidden Members
Telerik.Reporting.Charting Namespace


TextBlockHidden Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden Members
TextBlockHidden Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockHidden type exposes the following members.

Constructors

Name | Description
TextBlockHidden | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility of TextBlock (Overrides TextBlock..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden Constructor
TextBlockHidden Class See Also Send Feedback

Overload List

Name | Description
TextBlockHidden()()() | Create new instance of TextBlockHidden class.
TextBlockHidden(ChartBaseLabel, IContainer) | Create new instance of TextBlockHidden class.

See Also

TextBlockHidden Class
TextBlockHidden Members
Telerik.Reporting.Charting Namespace


TextBlockHidden Constructor

[image]

Telerik Reporting Q2 2012
TextBlockHidden Constructor
TextBlockHidden Class See Also Send Feedback
Create new instance of TextBlockHidden class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockHidden()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockHidden Class
TextBlockHidden Overload
Telerik.Reporting.Charting Namespace


TextBlockHidden Constructor (ChartBaseLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockHidden Constructor (ChartBaseLabel, IContainer)
TextBlockHidden Class See Also Send Feedback
Create new instance of TextBlockHidden class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockHidden(
    ChartBaseLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockHidden Class
TextBlockHidden Overload
Telerik.Reporting.Charting Namespace


TextBlockHidden Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden Fields
TextBlockHidden Class See Also Send Feedback

The TextBlockHidden type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockHidden Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden Methods
TextBlockHidden Class See Also Send Feedback

The TextBlockHidden type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden..::.Dispose Method
TextBlockHidden Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockHidden Class
TextBlockHidden Members
Telerik.Reporting.Charting Namespace


TextBlockHidden Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockHidden Properties
TextBlockHidden Class See Also Send Feedback

The TextBlockHidden type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility of TextBlock (Overrides TextBlock..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
TextBlockHidden..::.Visible Property
TextBlockHidden Class See Also Send Feedback
Gets and sets visibility of TextBlock

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

Field Value

Visibility of TextBlock

See Also

TextBlockHidden Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Class

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Class
Members See Also Send Feedback
Legend item's text block

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockLabelItem : TextBlock
Visual Basic (Declaration)
Public Class TextBlockLabelItem _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockLabelItem

See Also

TextBlockLabelItem Members
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem Members
TextBlockLabelItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockLabelItem type exposes the following members.

Constructors

Name | Description
TextBlockLabelItem | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor
TextBlockLabelItem Class See Also Send Feedback

Overload List

Name | Description
TextBlockLabelItem()()() | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(String) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(StyleTextBlock) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(ChartBaseLabel, IContainer) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(StyleTextBlock, String) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(ChartBaseLabel, IContainer, String) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(ChartBaseLabel, IContainer, StyleTextBlock) | Create new instance of TextBlockLabelItem class.
TextBlockLabelItem(ChartBaseLabel, IContainer, StyleTextBlock, String) | Create new instance of TextBlockLabelItem class.

See Also

TextBlockLabelItem Class
TextBlockLabelItem Members
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (String)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (String)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)

Parameters

text
Type: System..::.String
Text

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (StyleTextBlock)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (StyleTextBlock)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    StyleTextBlock appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleTextBlock _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (ChartBaseLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (ChartBaseLabel, IContainer)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    ChartBaseLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (StyleTextBlock, String)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (StyleTextBlock, String)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    StyleTextBlock appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    appearance As StyleTextBlock, _
    text As String _
)

Parameters

appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of chart
text
Type: System..::.String
Text

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, String)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, String)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    ChartBaseLabel parent,
    IContainer container,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    text As String _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
text
Type: System..::.String
Text

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, StyleTextBlock)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, StyleTextBlock)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    ChartBaseLabel parent,
    IContainer container,
    StyleTextBlock appearance
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    appearance As StyleTextBlock _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, StyleTextBlock, String)

[image]

Telerik Reporting Q2 2012
TextBlockLabelItem Constructor (ChartBaseLabel, IContainer, StyleTextBlock, String)
TextBlockLabelItem Class See Also Send Feedback
Create new instance of TextBlockLabelItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLabelItem(
    ChartBaseLabel parent,
    IContainer container,
    StyleTextBlock appearance,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartBaseLabel, _
    container As IContainer, _
    appearance As StyleTextBlock, _
    text As String _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartBaseLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element
appearance
Type: Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Style of TextBlock
text
Type: System..::.String
Text

See Also

TextBlockLabelItem Class
TextBlockLabelItem Overload
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem Fields
TextBlockLabelItem Class See Also Send Feedback

The TextBlockLabelItem type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem Methods
TextBlockLabelItem Class See Also Send Feedback

The TextBlockLabelItem type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem..::.Dispose Method
TextBlockLabelItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockLabelItem Class
TextBlockLabelItem Members
Telerik.Reporting.Charting Namespace


TextBlockLabelItem Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockLabelItem Properties
TextBlockLabelItem Class See Also Send Feedback

The TextBlockLabelItem type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockLabelItem Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Class

[image]

Telerik Reporting Q2 2012
TextBlockLegend Class
Members See Also Send Feedback
Chart title text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockLegend : TextBlockHidden
Visual Basic (Declaration)
Public Class TextBlockLegend _
    Inherits TextBlockHidden

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockHidden
Telerik.Reporting.Charting..::.TextBlockLegend

See Also

TextBlockLegend Members
Telerik.Reporting.Charting Namespace


TextBlockLegend Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend Members
TextBlockLegend Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockLegend type exposes the following members.

Constructors

Name | Description
TextBlockLegend | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility of TextBlock (Inherited from TextBlockHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend Constructor
TextBlockLegend Class See Also Send Feedback

Overload List

Name | Description
TextBlockLegend()()() | Create new instance of TextBlockLegend class.
TextBlockLegend(ExtendedLabel, IContainer) | Create new instance of TextBlockLegend class.

See Also

TextBlockLegend Class
TextBlockLegend Members
Telerik.Reporting.Charting Namespace


TextBlockLegend Constructor

[image]

Telerik Reporting Q2 2012
TextBlockLegend Constructor
TextBlockLegend Class See Also Send Feedback
Create new instance of TextBlockLegend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLegend()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockLegend Class
TextBlockLegend Overload
Telerik.Reporting.Charting Namespace


TextBlockLegend Constructor (ExtendedLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockLegend Constructor (ExtendedLabel, IContainer)
TextBlockLegend Class See Also Send Feedback
Create new instance of TextBlockLegend class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockLegend(
    ExtendedLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ExtendedLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ExtendedLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockLegend Class
TextBlockLegend Overload
Telerik.Reporting.Charting Namespace


TextBlockLegend Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend Fields
TextBlockLegend Class See Also Send Feedback

The TextBlockLegend type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockLegend Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend Methods
TextBlockLegend Class See Also Send Feedback

The TextBlockLegend type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend..::.Dispose Method
TextBlockLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockLegend Class
TextBlockLegend Members
Telerik.Reporting.Charting Namespace


TextBlockLegend Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockLegend Properties
TextBlockLegend Class See Also Send Feedback

The TextBlockLegend type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets visibility of TextBlock (Inherited from TextBlockHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockLegend Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Class

[image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Class
Members See Also Send Feedback
MarkedZone label's text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockMarkedZone : TextBlock
Visual Basic (Declaration)
Public Class TextBlockMarkedZone _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockMarkedZone

See Also

TextBlockMarkedZone Members
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Members
TextBlockMarkedZone Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockMarkedZone type exposes the following members.

Constructors

Name | Description
TextBlockMarkedZone | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Constructor
TextBlockMarkedZone Class See Also Send Feedback

Overload List

Name | Description
TextBlockMarkedZone()()() | Create new instance of TextBlockMarkedZone class.
TextBlockMarkedZone(MarkedZoneLabel, IContainer) | Create new instance of TextBlockMarkedZone class.

See Also

TextBlockMarkedZone Class
TextBlockMarkedZone Members
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Constructor

[image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Constructor
TextBlockMarkedZone Class See Also Send Feedback
Create new instance of TextBlockMarkedZone class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockMarkedZone()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockMarkedZone Class
TextBlockMarkedZone Overload
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Constructor (MarkedZoneLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Constructor (MarkedZoneLabel, IContainer)
TextBlockMarkedZone Class See Also Send Feedback
Create new instance of TextBlockMarkedZone class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockMarkedZone(
    MarkedZoneLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As MarkedZoneLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.MarkedZoneLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockMarkedZone Class
TextBlockMarkedZone Overload
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Fields
TextBlockMarkedZone Class See Also Send Feedback

The TextBlockMarkedZone type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Methods
TextBlockMarkedZone Class See Also Send Feedback

The TextBlockMarkedZone type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone..::.Dispose Method
TextBlockMarkedZone Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockMarkedZone Class
TextBlockMarkedZone Members
Telerik.Reporting.Charting Namespace


TextBlockMarkedZone Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockMarkedZone Properties
TextBlockMarkedZone Class See Also Send Feedback

The TextBlockMarkedZone type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockMarkedZone Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Class

[image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Class
Members See Also Send Feedback
Series label text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockSeriesItem : TextBlock
Visual Basic (Declaration)
Public Class TextBlockSeriesItem _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockSeriesItem

See Also

TextBlockSeriesItem Members
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Members
TextBlockSeriesItem Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockSeriesItem type exposes the following members.

Constructors

Name | Description
TextBlockSeriesItem | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Constructor
TextBlockSeriesItem Class See Also Send Feedback

Overload List

Name | Description
TextBlockSeriesItem()()() | Create new instance of TextBlockSeriesItem class.
TextBlockSeriesItem(SeriesItemLabel, IContainer) | Create new instance of TextBlockSeriesItem class.

See Also

TextBlockSeriesItem Class
TextBlockSeriesItem Members
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Constructor

[image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Constructor
TextBlockSeriesItem Class See Also Send Feedback
Create new instance of TextBlockSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockSeriesItem()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockSeriesItem Class
TextBlockSeriesItem Overload
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Constructor (SeriesItemLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Constructor (SeriesItemLabel, IContainer)
TextBlockSeriesItem Class See Also Send Feedback
Create new instance of TextBlockSeriesItem class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockSeriesItem(
    SeriesItemLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As SeriesItemLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.SeriesItemLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockSeriesItem Class
TextBlockSeriesItem Overload
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Fields
TextBlockSeriesItem Class See Also Send Feedback

The TextBlockSeriesItem type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Methods
TextBlockSeriesItem Class See Also Send Feedback

The TextBlockSeriesItem type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem..::.Dispose Method
TextBlockSeriesItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockSeriesItem Class
TextBlockSeriesItem Members
Telerik.Reporting.Charting Namespace


TextBlockSeriesItem Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockSeriesItem Properties
TextBlockSeriesItem Class See Also Send Feedback

The TextBlockSeriesItem type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Inherited from TextBlock.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockSeriesItem Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Class

[image]

Telerik Reporting Q2 2012
TextBlockTitle Class
Members See Also Send Feedback
Chart title text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockTitle : TextBlock
Visual Basic (Declaration)
Public Class TextBlockTitle _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockTitle

See Also

TextBlockTitle Members
Telerik.Reporting.Charting Namespace


TextBlockTitle Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle Members
TextBlockTitle Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockTitle type exposes the following members.

Constructors

Name | Description
TextBlockTitle | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle Constructor
TextBlockTitle Class See Also Send Feedback

Overload List

Name | Description
TextBlockTitle()()() | Create new instance of TextBlockTitle class.
TextBlockTitle(ChartTitle, IContainer) | Create new instance of TextBlockTitle class.

See Also

TextBlockTitle Class
TextBlockTitle Members
Telerik.Reporting.Charting Namespace


TextBlockTitle Constructor

[image]

Telerik Reporting Q2 2012
TextBlockTitle Constructor
TextBlockTitle Class See Also Send Feedback
Create new instance of TextBlockTitle class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockTitle()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockTitle Class
TextBlockTitle Overload
Telerik.Reporting.Charting Namespace


TextBlockTitle Constructor (ChartTitle, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockTitle Constructor (ChartTitle, IContainer)
TextBlockTitle Class See Also Send Feedback
Create new instance of TextBlockTitle class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockTitle(
    ChartTitle parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartTitle, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartTitle
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockTitle Class
TextBlockTitle Overload
Telerik.Reporting.Charting Namespace


TextBlockTitle Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle Fields
TextBlockTitle Class See Also Send Feedback

The TextBlockTitle type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockTitle Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle Methods
TextBlockTitle Class See Also Send Feedback

The TextBlockTitle type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle..::.Dispose Method
TextBlockTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockTitle Class
TextBlockTitle Members
Telerik.Reporting.Charting Namespace


TextBlockTitle Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockTitle Properties
TextBlockTitle Class See Also Send Feedback

The TextBlockTitle type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBlockTitle..::.Text Property
TextBlockTitle Class See Also Send Feedback
Contained text data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String

See Also

TextBlockTitle Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Class

[image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Class
Members See Also Send Feedback
Chart X Axis text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockXAxisLabel : TextBlock
Visual Basic (Declaration)
Public Class TextBlockXAxisLabel _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockXAxisLabel

See Also

TextBlockXAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Members
TextBlockXAxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockXAxisLabel type exposes the following members.

Constructors

Name | Description
TextBlockXAxisLabel | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Constructor
TextBlockXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
TextBlockXAxisLabel()()() | Create new instance of TextBlockXAxisLabel class.
TextBlockXAxisLabel(AxisLabel, IContainer) | Create new instance of TextBlockXAxisLabel class.

See Also

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Constructor
TextBlockXAxisLabel Class See Also Send Feedback
Create new instance of TextBlockXAxisLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockXAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockXAxisLabel Class
TextBlockXAxisLabel Overload
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Constructor (AxisLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Constructor (AxisLabel, IContainer)
TextBlockXAxisLabel Class See Also Send Feedback
Create new instance of TextBlockXAxisLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockXAxisLabel(
    AxisLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As AxisLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.AxisLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockXAxisLabel Class
TextBlockXAxisLabel Overload
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Fields
TextBlockXAxisLabel Class See Also Send Feedback

The TextBlockXAxisLabel type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Methods
TextBlockXAxisLabel Class See Also Send Feedback

The TextBlockXAxisLabel type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel..::.Dispose Method
TextBlockXAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockXAxisLabel Class
TextBlockXAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockXAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel Properties
TextBlockXAxisLabel Class See Also Send Feedback

The TextBlockXAxisLabel type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBlockXAxisLabel..::.Text Property
TextBlockXAxisLabel Class See Also Send Feedback
Contained text data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String

See Also

TextBlockXAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Class

[image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Class
Members See Also Send Feedback
Chart Y Axis text container properties

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBlockYAxisLabel : TextBlock
Visual Basic (Declaration)
Public Class TextBlockYAxisLabel _
    Inherits TextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting..::.RenderedObject
Telerik.Reporting.Charting..::.LayoutElement
Telerik.Reporting.Charting..::.TextBlock
Telerik.Reporting.Charting..::.TextBlockYAxisLabel

See Also

TextBlockYAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Members
TextBlockYAxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TextBlockYAxisLabel type exposes the following members.

Constructors

Name | Description
TextBlockYAxisLabel | Overloaded.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Constructor
TextBlockYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
TextBlockYAxisLabel()()() | Create new instance of TextBlockYAxisLabel class.
TextBlockYAxisLabel(AxisYLabel, IContainer) | Create new instance of TextBlockYAxisLabel class.

See Also

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Constructor
TextBlockYAxisLabel Class See Also Send Feedback
Create new instance of TextBlockYAxisLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockYAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

TextBlockYAxisLabel Class
TextBlockYAxisLabel Overload
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Constructor (AxisYLabel, IContainer)

[image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Constructor (AxisYLabel, IContainer)
TextBlockYAxisLabel Class See Also Send Feedback
Create new instance of TextBlockYAxisLabel class.

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextBlockYAxisLabel(
    AxisYLabel parent,
    IContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As AxisYLabel, _
    container As IContainer _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.AxisYLabel
Parent element
container
Type: Telerik.Reporting.Charting..::.IContainer
Container element

See Also

TextBlockYAxisLabel Class
TextBlockYAxisLabel Overload
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Fields
TextBlockYAxisLabel Class See Also Send Feedback

The TextBlockYAxisLabel type exposes the following members.

Fields

Name | Description
DEFAULT_TEXT | Default text of text block (Inherited from TextBlock.)
objectContainer | Container, that contains the render order for taken up elements (For property) (Inherited from RenderedObject.)
textBlockCalculatedMaxLength | Max length of text (Inherited from TextBlock.)
textBlockParent | Parent element (Inherited from TextBlock.)

See Also

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Methods
TextBlockYAxisLabel Class See Also Send Feedback

The TextBlockYAxisLabel type exposes the following members.

Methods

Name | Description
BringForward | Send element at one step forward in the render order list (Inherited from RenderedObject.)
BringToFront | Set element at the first position in render order list (Inherited from RenderedObject.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | (Inherited from TextBlock.)
Dispose | Overloaded.
GetOffsetBottom | Gets bottom offset (Inherited from LayoutElement.)
GetOffsetLeft | Gets left offset (Inherited from LayoutElement.)
GetOffsetRight | Gets right offset (Inherited from LayoutElement.)
GetOffsetTop | Gets top offset (Inherited from LayoutElement.)
GetOrder | Get this elements order position in container (Inherited from RenderedObject.)
LoadViewState | Loads data from a view state (Inherited from LayoutElement.)
Remove | Remove this element from render order list (Inherited from RenderedObject.)
SaveViewState | Saves settings to a view state (Inherited from LayoutElement.)
SendBackward | Send element at one step back in the render order list (Inherited from RenderedObject.)
SendToBack | Send element at the end of render order list (Inherited from RenderedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
SetOrder | Set this object in new render order position (Inherited from RenderedObject.)
TrackViewState | Tracking view state changes (Inherited from LayoutElement.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel..::.Dispose Method
TextBlockYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutElement.)

See Also

TextBlockYAxisLabel Class
TextBlockYAxisLabel Members
Telerik.Reporting.Charting Namespace


TextBlockYAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel Properties
TextBlockYAxisLabel Class See Also Send Feedback

The TextBlockYAxisLabel type exposes the following members.

Properties

Name | Description
Appearance | Text field style (Inherited from TextBlock.)
Container | Link to container element (Inherited from RenderedObject.)
Parent | Parent chart element (Inherited from TextBlock.)
Text | Contained text data (Overrides TextBlock..::.Text.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | get a and sets visibility of TextBlock (Inherited from TextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBlockYAxisLabel..::.Text Property
TextBlockYAxisLabel Class See Also Send Feedback
Contained text data

Namespace: Telerik.Reporting.Charting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Text { get; set; }
Visual Basic (Declaration)
Public Overrides Property Text As String

See Also

TextBlockYAxisLabel Class
Telerik.Reporting.Charting Namespace


Telerik.Reporting.Charting.Styles Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Charting.Styles Namespace
Send Feedback

Classes

Class | Description
ChartMargins | Margins base class
ChartMarginsLegend | Legend's margins
ChartMarginsPlotArea | Plot area's margins
ChartMarginsTitle | Title's margins
ChartPaddings | Base paddings class
ChartPaddingsLegend | Chart title's paddings
ChartPaddingsTitle | Chart title's paddings
ChartSkin | Chart skin
Corners | Sets the edge type of rectangular shapes.
CornersConverter |
Dimensions | Dimensions base class
DimensionsChart | Chart's dimensions
DimensionsLegend | Legend's dimensions
DimensionsMarker | Marker's default dimensions
DimensionsPlotArea | Default plot area's dimensions
DimensionsPointMarker | PointMark's default dimensions
DimensionsSeriesPointMark | Specific series point marks dimensions
DimensionsTitle | Chart title's dimensions
EmptyValue | Empty value
FiguresCollection | Default figures
FillSettings | Fill settings
FillSettingsVerticalGradient | Vertical gradient default fill settings
FillStyle | Fill style base class
FillStyleChart | Chart's background fill style
FillStyleMarkedZones | Marked zone fill style
FillStylePlotArea |
FillStyleSeries | Series fill style
FillStyleSeriesPoint | Series points fill style
FillStyleTitle | Title's background fill style
LayoutDecoratorBase | Base class for a chart Margins and Paddings
LayoutStyle | Base appearance settings for any element being calculated
LineStyle | Common lines style
MarginsConverter | Provides a unified way of converting ChartMargins type values to other types, as well as for accessing standard values and sub properties.
PaddingsConverter | Provides a unified way of converting ChartMargins type values to other types, as well as for accessing standard values and sub properties.
Position | Represents the element position in the container
PositionBottom | Specific Position object with predefined AlignedPosition.Bottom
PositionCenter | Specific Position object with predefined AlignedPosition.Center
PositionLeft | Specific Position object with predefined AlignedPosition.Left
PositionRight | Specific Position object with predefined AlignedPosition.Right
PositionTop | Specific Position object with predefined AlignedPosition.Top
PositionTopLeft | Specific Position object with predefined AlignedPosition.TopLeft
PositionTopRight | Specific Position object with predefined AlignedPosition.TopRight
ScaleBreaksLineStyle | Scale breaks line specific style
ShadowStyle | Shadow settings
ShadowStyleChart | Common shadow settings
SkinnablePropertyAttribute | Represents the custom property attribute used to mark property as skinable and being used with a skin application
Style | Base style class
StyleAxis | Axis appearance
StyleAxisItemText | Axis item label text block's appearance
StyleAxisLabel | Axis label style
StyleAxisX | X axis specific style
StyleAxisY | Y axis specific style
StyleBorder | Border style
StyleChart | Main chart appearance settings
StyleChartBorder | Chart border specific style
StyleChartDataTable | DataTable appearance settings
StyleDataTableBorder | Data table's border specific style
StyleEmptyLineSeries | Empty Line series specific style
StyleExtendedLabel |
StyleGridLine | Grid line specific style
StyleGridLineHidden |
StyleGridLineMajor |
StyleGridLineMajorXAxis |
StyleItemLabelConnector | Series item label connector line specific style
StyleLabel | Base label appearance style
StyleLabelEmptySeriesMessage | Empty series message style
StyleLabelHidden |
StyleLabelLegend | Legend appearance style
StyleLabelTitle | Chart title style
StyleLegendBorder | Legend border specific style
StyleLineSeries | Line series specific style
StyleMarkedZone | Marked zone. Used to mark the values ranges at the plot area.
StyleMarker | Base marker's style
StyleMarkerEmptyValue | Specific empty point marker style
StyleMarkerLegend | Specific series point markers style
StyleMarkerPositionNone | Specific empty point marker style
StyleMarkerSeriesPoint | Specific series point markers style
StylePlotArea | Plot area's appearance
StyleSeries | Series appearance
StyleSeriesBorder | Series border specific style
StyleSeriesItem | Series item appearance
StyleSeriesItemLabel | Series item appearance style
StyleSeriesItemTextBlock | Series item label text block's appearance
StyleTextBlock | Text block appearance
StyleTextBlockAxisLabel | Hidden text block's default appearance
StyleTextBlockError | Error text block's appearance
StyleTextBlockHidden | Hidden text block's default appearance
StyleTextBlockTitle | Title text block's appearance
StyleTick | Base axis ticks appearance settings
StyleTickMajor | Major ticks visual style
StyleTickMinor | Minor ticks style
StyleTitleBorder | Title border specific style
StyleYAxisLabel | Axis label style
TextProperties | Base text appearance settings class (Font, Color)
TextPropertiesAxisItem | Axis item label text properties
TextPropertiesAxisLabel | Axis item label text properties
TextPropertiesError | Errors text properties
TextPropertiesSeriesItem | Series item label text properties
TextPropertiesTitle | Default Title's text properties
Unit | Represents a length measurement.

Structures

Structure | Description
DefaultFigures |

Enumerations

Enumeration | Description
AlignedPositions | Aligned positions listing
AutoTextWrap | Define auto wrap option for text
ChartAxisLayoutMode | Specifies different axis styles for positioning of item labels and marks.
ChartAxisVisibility | Define visibility option for axis
ChartAxisVisibleValues | Axis visible values range positive / negative
ChartValueFormat |
CornerType | Corner type
DrawType | Types for drawing figures
EmtyValuesMode | Empty values representation mode
FillType | Fill types listing
GradientFillStyle | Specifies the direction of a linear gradient.
ImageAlignModes |
ImageDrawMode |
ImageQuality | Specifies the quality at which image is rendered.
ImageTileModes |
LabelItemsCompositionTypes | Specifies how marker and text block are situated related to each other.
LabelLocation |
Orientation |
Overflow |
PlacementDirection | Direction of label position in auto mode
ShadowPosition | Possible shadow positions listing
StyleSeriesItemLabel..::.ItemLabelLocation |
TextQuality | Specifies the quality at which text is rendered.
TickLocation | Specifies the axis Ticks location relatively to plot area
UnitType | Specifies the unit of measurement.


AlignedPositions Enumeration

[image]

Telerik Reporting Q2 2012
AlignedPositions Enumeration
See Also Send Feedback
Aligned positions listing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum AlignedPositions
Visual Basic (Declaration)
Public Enumeration AlignedPositions

Members

Member name | Description
None |
Right | Assign the right position for element
Left | Assign the left position for element
Top | Assign the top position for element
Bottom | Assign the bottom position for element
Center | Assign the center position for element
TopRight | Assign the top right position for element
TopLeft | Assign the top left position for element
BottomRight | Assign the bottom right position for element
BottomLeft | Assign the bottom left position for element

See Also

Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Enumeration

[image]

Telerik Reporting Q2 2012
AutoTextWrap Enumeration
See Also Send Feedback
Define auto wrap option for text

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum AutoTextWrap
Visual Basic (Declaration)
Public Enumeration AutoTextWrap

Members

Member name | Description
Auto | Means that value of auto text wrap will be inherit of parent element.
True | Means that auto text wrap will be applied.
False | Means that auto text wrap will not be applied.

See Also

Telerik.Reporting.Charting.Styles Namespace


ChartAxisLayoutMode Enumeration

[image]

Telerik Reporting Q2 2012
ChartAxisLayoutMode Enumeration
See Also Send Feedback
Specifies different axis styles for positioning of item labels and marks.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartAxisLayoutMode
Visual Basic (Declaration)
Public Enumeration ChartAxisLayoutMode

Members

Member name | Description
Normal | Sets the default axis layout style.
Inside | Sets the endmost axis items inside the axis.
Between | Sets axis items between axis marks.

See Also

Telerik.Reporting.Charting.Styles Namespace


ChartAxisVisibility Enumeration

[image]

Telerik Reporting Q2 2012
ChartAxisVisibility Enumeration
See Also Send Feedback
Define visibility option for axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartAxisVisibility
Visual Basic (Declaration)
Public Enumeration ChartAxisVisibility

Members

Member name | Description
Auto | Means that axis will be visible if it is XAxis or any series belongs to it.
True | Means that axis will be visible.
False | Means that axis will be not visible.

See Also

Telerik.Reporting.Charting.Styles Namespace


ChartAxisVisibleValues Enumeration

[image]

Telerik Reporting Q2 2012
ChartAxisVisibleValues Enumeration
See Also Send Feedback
Axis visible values range positive / negative

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartAxisVisibleValues
Visual Basic (Declaration)
Public Enumeration ChartAxisVisibleValues

Members

Member name | Description
All | All values will be visible.
Positive | Only positive values will be visible.
Negative | Only negative values will be visible.

See Also

Telerik.Reporting.Charting.Styles Namespace


ChartMargins Class

[image]

Telerik Reporting Q2 2012
ChartMargins Class
Members See Also Send Feedback
Margins base class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMargins : LayoutDecoratorBase
Visual Basic (Declaration)
Public Class ChartMargins _
    Inherits LayoutDecoratorBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartMargins
Telerik.Reporting.Charting.Styles..::.ChartMarginsLegend
Telerik.Reporting.Charting.Styles..::.ChartMarginsPlotArea
Telerik.Reporting.Charting.Styles..::.ChartMarginsTitle

See Also

ChartMargins Members
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Members

[image] [image]

Telerik Reporting Q2 2012
ChartMargins Members
ChartMargins Class Constructors Methods Operators Properties Explicit Interface Implementations See Also Send Feedback

The ChartMargins type exposes the following members.

Constructors

Name | Description
ChartMargins | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Operators

Name | Description
Implicit | Implicitly creates a new instance of ChartMargins from the specified string.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartMargins Constructor
ChartMargins Class See Also Send Feedback

Overload List

Name | Description
ChartMargins()()() | Creates new instance of ChartMargins class.
ChartMargins(Object) | Creates new instance of ChartMargins class.
ChartMargins(Unit) | Creates new instance of ChartMargins class.
ChartMargins(Int32, Int32, Int32, Int32) | Creates new instance of ChartMargins class.
ChartMargins(Unit, Unit, Unit, Unit) | Creates new instance of ChartMargins class.
ChartMargins(Object, Unit, Unit, Unit, Unit) | Creates new instance of ChartMargins class.

See Also

ChartMargins Class
ChartMargins Members
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor (Object)

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor (Object)
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor (Unit)

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor (Unit)
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins(
    Unit margin
)
Visual Basic (Declaration)
Public Sub New ( _
    margin As Unit _
)

Parameters

margin
Type: Telerik.Reporting.Charting.Styles..::.Unit
Value to set for all margins

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor (Int32, Int32, Int32, Int32)

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor (Int32, Int32, Int32, Int32)
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins(
    int top,
    int right,
    int bottom,
    int left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    left As Integer _
)

Parameters

top
Type: System..::.Int32
Top margin in pixels
right
Type: System..::.Int32
Right margin in pixels
bottom
Type: System..::.Int32
Bottom margin in pixels
left
Type: System..::.Int32
Left margin in pixels

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor (Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor (Unit, Unit, Unit, Unit)
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins(
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top margin in pixels or percents
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right margin in pixels or percents
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom margin in pixels or percents
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left margin in pixels or percents

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Constructor (Object, Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
ChartMargins Constructor (Object, Unit, Unit, Unit, Unit)
ChartMargins Class See Also Send Feedback
Creates new instance of ChartMargins class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMargins(
    Object containerObject,
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object, _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

containerObject
Type: System..::.Object
Container object
top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top margin in pixels or percents
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right margin in pixels or percents
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom margin in pixels or percents
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left margin in pixels or percents

See Also

ChartMargins Class
ChartMargins Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMargins Methods
ChartMargins Class See Also Send Feedback

The ChartMargins type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMargins..::.Dispose Method
ChartMargins Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartMargins Class
ChartMargins Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method

[image] [image]

Telerik Reporting Q2 2012
ChartMargins..::.Parse Method
ChartMargins Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Converts the specified string to an instance of ChartMargins.
Parse(String, CultureInfo) | Converts the specified string to an instance of ChartMargins.

See Also

ChartMargins Class
ChartMargins Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String)

[image]

Telerik Reporting Q2 2012
ChartMargins..::.Parse Method (String)
ChartMargins Class See Also Send Feedback
Converts the specified string to an instance of ChartMargins.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static ChartMargins Parse(
    string value
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String _
) As ChartMargins

Parameters

value
Type: System..::.String
The string to convert from.

Return Value

New instance of ChartMargins from the specified string

See Also

ChartMargins Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
ChartMargins..::.Parse Method (String, CultureInfo)
ChartMargins Class See Also Send Feedback
Converts the specified string to an instance of ChartMargins.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static ChartMargins Parse(
    string value,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String, _
    culture As CultureInfo _
) As ChartMargins

Parameters

value
Type: System..::.String
The string to convert from.
culture
Type: System.Globalization..::.CultureInfo
Culture info

Return Value

New instance of ChartMargins from the specified string

See Also

ChartMargins Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Operators

[image] [image]

Telerik Reporting Q2 2012
ChartMargins Operators
ChartMargins Class See Also Send Feedback

The ChartMargins type exposes the following members.

Operators

Name | Description
Implicit | Implicitly creates a new instance of ChartMargins from the specified string.

See Also

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


Implicit Operator

[image]

Telerik Reporting Q2 2012
ChartMargins..::.Implicit Operator
ChartMargins Class See Also Send Feedback
Implicitly creates a new instance of ChartMargins from the specified string.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static implicit operator ChartMargins (
    string value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As String _
) As ChartMargins

Parameters

value
Type: System..::.String
The string to parse

Return Value

New instance of ChartMargins from the specified string

See Also

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


ChartMargins Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMargins Properties
ChartMargins Class See Also Send Feedback

The ChartMargins type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMargins Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Class

[image]

Telerik Reporting Q2 2012
ChartMarginsLegend Class
Members See Also Send Feedback
Legend's margins

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarginsLegend : ChartMargins
Visual Basic (Declaration)
Public Class ChartMarginsLegend _
    Inherits ChartMargins

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartMargins
Telerik.Reporting.Charting.Styles..::.ChartMarginsLegend

See Also

ChartMarginsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsLegend Members
ChartMarginsLegend Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarginsLegend type exposes the following members.

Constructors

Name | Description
ChartMarginsLegend | Creates new instance of ChartMarginsLegend class.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Constructor

[image]

Telerik Reporting Q2 2012
ChartMarginsLegend Constructor
ChartMarginsLegend Class See Also Send Feedback
Creates new instance of ChartMarginsLegend class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarginsLegend()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsLegend Methods
ChartMarginsLegend Class See Also Send Feedback

The ChartMarginsLegend type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsLegend..::.Dispose Method
ChartMarginsLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartMarginsLegend Class
ChartMarginsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsLegend Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsLegend Properties
ChartMarginsLegend Class See Also Send Feedback

The ChartMarginsLegend type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ChartMarginsLegend..::.Right Property
ChartMarginsLegend Class See Also Send Feedback
Sets the right margin in pixels or percent of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Right { get; set; }
Visual Basic (Declaration)
Public Overrides Property Right As Unit

See Also

ChartMarginsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Class

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea Class
Members See Also Send Feedback
Plot area's margins

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarginsPlotArea : ChartMargins
Visual Basic (Declaration)
Public Class ChartMarginsPlotArea _
    Inherits ChartMargins

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartMargins
Telerik.Reporting.Charting.Styles..::.ChartMarginsPlotArea

See Also

ChartMarginsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea Members
ChartMarginsPlotArea Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarginsPlotArea type exposes the following members.

Constructors

Name | Description
ChartMarginsPlotArea | Creates new instance of ChartMarginsPlotArea class.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Bottom | Sets the bottom margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Sets the left margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Left.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Constructor

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea Constructor
ChartMarginsPlotArea Class See Also Send Feedback
Creates new instance of ChartMarginsPlotArea class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarginsPlotArea()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea Methods
ChartMarginsPlotArea Class See Also Send Feedback

The ChartMarginsPlotArea type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea..::.Dispose Method
ChartMarginsPlotArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartMarginsPlotArea Class
ChartMarginsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsPlotArea Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea Properties
ChartMarginsPlotArea Class See Also Send Feedback

The ChartMarginsPlotArea type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Sets the left margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Left.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea..::.Bottom Property
ChartMarginsPlotArea Class See Also Send Feedback
Sets the bottom margin in pixels or percent of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Bottom As Unit

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea..::.Left Property
ChartMarginsPlotArea Class See Also Send Feedback
Sets the left margin in pixels or percent of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Unit

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea..::.Right Property
ChartMarginsPlotArea Class See Also Send Feedback
Sets the right margin in pixels or percent of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Right { get; set; }
Visual Basic (Declaration)
Public Overrides Property Right As Unit

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ChartMarginsPlotArea..::.Top Property
ChartMarginsPlotArea Class See Also Send Feedback
Sets the top margin in pixels or percent of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Unit

See Also

ChartMarginsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Class

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle Class
Members See Also Send Feedback
Title's margins

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartMarginsTitle : ChartMargins
Visual Basic (Declaration)
Public Class ChartMarginsTitle _
    Inherits ChartMargins

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartMargins
Telerik.Reporting.Charting.Styles..::.ChartMarginsTitle

See Also

ChartMarginsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Members

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsTitle Members
ChartMarginsTitle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartMarginsTitle type exposes the following members.

Constructors

Name | Description
ChartMarginsTitle | Creates new instance of ChartMarginsTitle class.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Bottom | Sets the bottom margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Sets the left margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Left.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Constructor

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle Constructor
ChartMarginsTitle Class See Also Send Feedback
Creates new instance of ChartMarginsTitle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartMarginsTitle()
Visual Basic (Declaration)
Public Sub New

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Methods

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsTitle Methods
ChartMarginsTitle Class See Also Send Feedback

The ChartMarginsTitle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsTitle..::.Dispose Method
ChartMarginsTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartMarginsTitle Class
ChartMarginsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartMarginsTitle Properties

[image] [image]

Telerik Reporting Q2 2012
ChartMarginsTitle Properties
ChartMarginsTitle Class See Also Send Feedback

The ChartMarginsTitle type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Sets the left margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Left.)
Right | Sets the right margin in pixels or percent of the chart's width. (Overrides LayoutDecoratorBase..::.Right.)
Top | Sets the top margin in pixels or percent of the chart's height. (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle..::.Bottom Property
ChartMarginsTitle Class See Also Send Feedback
Sets the bottom margin in pixels or percent of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Bottom As Unit

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle..::.Left Property
ChartMarginsTitle Class See Also Send Feedback
Sets the left margin in pixels or percent of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Unit

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle..::.Right Property
ChartMarginsTitle Class See Also Send Feedback
Sets the right margin in pixels or percent of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Right { get; set; }
Visual Basic (Declaration)
Public Overrides Property Right As Unit

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ChartMarginsTitle..::.Top Property
ChartMarginsTitle Class See Also Send Feedback
Sets the top margin in pixels or percent of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Unit

See Also

ChartMarginsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Class

[image]

Telerik Reporting Q2 2012
ChartPaddings Class
Members See Also Send Feedback
Base paddings class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartPaddings : LayoutDecoratorBase
Visual Basic (Declaration)
Public Class ChartPaddings _
    Inherits LayoutDecoratorBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartPaddings
Telerik.Reporting.Charting.Styles..::.ChartPaddingsLegend
Telerik.Reporting.Charting.Styles..::.ChartPaddingsTitle

See Also

ChartPaddings Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Members

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings Members
ChartPaddings Class Constructors Methods Operators Properties Explicit Interface Implementations See Also Send Feedback

The ChartPaddings type exposes the following members.

Constructors

Name | Description
ChartPaddings | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Operators

Name | Description
Implicit | Implicitly creates an instance of ChartPaddings class from the specified string.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings Constructor
ChartPaddings Class See Also Send Feedback

Overload List

Name | Description
ChartPaddings()()() | Creates new instance of ChartPaddings class.
ChartPaddings(Object) | Creates new instance of ChartPaddings class.
ChartPaddings(Unit) | Creates new instance of ChartPaddings class.
ChartPaddings(Int32, Int32, Int32, Int32) | Creates new instance of ChartPaddings class.
ChartPaddings(Unit, Unit, Unit, Unit) | Creates new instance of ChartPaddings class.
ChartPaddings(Object, Unit, Unit, Unit, Unit) | Creates new instance of ChartPaddings class.

See Also

ChartPaddings Class
ChartPaddings Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings()
Visual Basic (Declaration)
Public Sub New

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor (Object)

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor (Object)
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor (Unit)

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor (Unit)
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings(
    Unit margin
)
Visual Basic (Declaration)
Public Sub New ( _
    margin As Unit _
)

Parameters

margin
Type: Telerik.Reporting.Charting.Styles..::.Unit
Value to set for all paddings

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor (Int32, Int32, Int32, Int32)

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor (Int32, Int32, Int32, Int32)
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings(
    int top,
    int right,
    int bottom,
    int left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    left As Integer _
)

Parameters

top
Type: System..::.Int32
Top padding in pixels
right
Type: System..::.Int32
Right padding in pixels
bottom
Type: System..::.Int32
Bottom padding in pixels
left
Type: System..::.Int32
Left padding in pixels

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor (Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor (Unit, Unit, Unit, Unit)
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings(
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top padding in pixels or percents
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right padding in pixels or percents
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom padding in pixels or percents
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left padding in pixels or percents

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Constructor (Object, Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
ChartPaddings Constructor (Object, Unit, Unit, Unit, Unit)
ChartPaddings Class See Also Send Feedback
Creates new instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddings(
    Object containerObject,
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object, _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

containerObject
Type: System..::.Object
Container object
top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top padding in pixels or percents
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right padding in pixels or percents
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom padding in pixels or percents
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left padding in pixels or percents

See Also

ChartPaddings Class
ChartPaddings Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Methods

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings Methods
ChartPaddings Class See Also Send Feedback

The ChartPaddings type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings..::.Dispose Method
ChartPaddings Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartPaddings Class
ChartPaddings Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings..::.Parse Method
ChartPaddings Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Converts the specified string to an instance of ChartPaddings class.
Parse(String, CultureInfo) | Converts the specified string to an instance of ChartPaddings class.

See Also

ChartPaddings Class
ChartPaddings Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String)

[image]

Telerik Reporting Q2 2012
ChartPaddings..::.Parse Method (String)
ChartPaddings Class See Also Send Feedback
Converts the specified string to an instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static ChartPaddings Parse(
    string value
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String _
) As ChartPaddings

Parameters

value
Type: System..::.String
The string to convert from.

Return Value

Instance of ChartPaddings class from the specified string

See Also

ChartPaddings Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
ChartPaddings..::.Parse Method (String, CultureInfo)
ChartPaddings Class See Also Send Feedback
Converts the specified string to an instance of ChartPaddings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static ChartPaddings Parse(
    string value,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String, _
    culture As CultureInfo _
) As ChartPaddings

Parameters

value
Type: System..::.String
The string to convert from.
culture
Type: System.Globalization..::.CultureInfo
Culture info

Return Value

Instance of ChartPaddings class from the specified string

See Also

ChartPaddings Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Operators

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings Operators
ChartPaddings Class See Also Send Feedback

The ChartPaddings type exposes the following members.

Operators

Name | Description
Implicit | Implicitly creates an instance of ChartPaddings class from the specified string.

See Also

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


Implicit Operator

[image]

Telerik Reporting Q2 2012
ChartPaddings..::.Implicit Operator
ChartPaddings Class See Also Send Feedback
Implicitly creates an instance of ChartPaddings class from the specified string.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static implicit operator ChartPaddings (
    string value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As String _
) As ChartPaddings

Parameters

value
Type: System..::.String
The string to parse

Return Value

Instance of ChartPaddings class from the specified string

See Also

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddings Properties

[image] [image]

Telerik Reporting Q2 2012
ChartPaddings Properties
ChartPaddings Class See Also Send Feedback

The ChartPaddings type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
Left | Sets the left side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Right | Sets the right side in pixels or percents of the chart's width. (Inherited from LayoutDecoratorBase.)
Top | Sets the top side in pixels or percents of the chart's height. (Inherited from LayoutDecoratorBase.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartPaddings Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Class

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend Class
Members See Also Send Feedback
Chart title's paddings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartPaddingsLegend : ChartPaddings
Visual Basic (Declaration)
Public Class ChartPaddingsLegend _
    Inherits ChartPaddings

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartPaddings
Telerik.Reporting.Charting.Styles..::.ChartPaddingsLegend

See Also

ChartPaddingsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Members

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsLegend Members
ChartPaddingsLegend Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartPaddingsLegend type exposes the following members.

Constructors

Name | Description
ChartPaddingsLegend | Creates new instance of ChartPaddingsLegend class.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Bottom | Specifies the bottom padding (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Specifies the left padding (Overrides LayoutDecoratorBase..::.Left.)
Right | Specifies the right padding (Overrides LayoutDecoratorBase..::.Right.)
Top | Specifies the top padding (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Constructor

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend Constructor
ChartPaddingsLegend Class See Also Send Feedback
Creates new instance of ChartPaddingsLegend class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddingsLegend()
Visual Basic (Declaration)
Public Sub New

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Methods

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsLegend Methods
ChartPaddingsLegend Class See Also Send Feedback

The ChartPaddingsLegend type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsLegend..::.Dispose Method
ChartPaddingsLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartPaddingsLegend Class
ChartPaddingsLegend Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsLegend Properties

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsLegend Properties
ChartPaddingsLegend Class See Also Send Feedback

The ChartPaddingsLegend type exposes the following members.

Properties

Name | Description
Bottom | Specifies the bottom padding (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Specifies the left padding (Overrides LayoutDecoratorBase..::.Left.)
Right | Specifies the right padding (Overrides LayoutDecoratorBase..::.Right.)
Top | Specifies the top padding (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend..::.Bottom Property
ChartPaddingsLegend Class See Also Send Feedback
Specifies the bottom padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Bottom As Unit

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend..::.Left Property
ChartPaddingsLegend Class See Also Send Feedback
Specifies the left padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Unit

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend..::.Right Property
ChartPaddingsLegend Class See Also Send Feedback
Specifies the right padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Right { get; set; }
Visual Basic (Declaration)
Public Overrides Property Right As Unit

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsLegend..::.Top Property
ChartPaddingsLegend Class See Also Send Feedback
Specifies the top padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Unit

See Also

ChartPaddingsLegend Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Class

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle Class
Members See Also Send Feedback
Chart title's paddings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartPaddingsTitle : ChartPaddings
Visual Basic (Declaration)
Public Class ChartPaddingsTitle _
    Inherits ChartPaddings

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartPaddings
Telerik.Reporting.Charting.Styles..::.ChartPaddingsTitle

See Also

ChartPaddingsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Members

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsTitle Members
ChartPaddingsTitle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ChartPaddingsTitle type exposes the following members.

Constructors

Name | Description
ChartPaddingsTitle | Creates new instance of ChartPaddingsTitle class.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Bottom | Specifies the bottom padding (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Specifies the left padding (Overrides LayoutDecoratorBase..::.Left.)
Right | Specifies the right padding (Overrides LayoutDecoratorBase..::.Right.)
Top | Specifies the top padding (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Constructor

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle Constructor
ChartPaddingsTitle Class See Also Send Feedback
Creates new instance of ChartPaddingsTitle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartPaddingsTitle()
Visual Basic (Declaration)
Public Sub New

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Methods

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsTitle Methods
ChartPaddingsTitle Class See Also Send Feedback

The ChartPaddingsTitle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LayoutDecoratorBase.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object (Inherited from LayoutDecoratorBase.)
Dispose | Overloaded.
Equals | Checks whether objects are equal (Inherited from LayoutDecoratorBase.)
GetHashCode | Gets hash code (Inherited from LayoutDecoratorBase.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsTitle..::.Dispose Method
ChartPaddingsTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ChartPaddingsTitle Class
ChartPaddingsTitle Members
Telerik.Reporting.Charting.Styles Namespace


ChartPaddingsTitle Properties

[image] [image]

Telerik Reporting Q2 2012
ChartPaddingsTitle Properties
ChartPaddingsTitle Class See Also Send Feedback

The ChartPaddingsTitle type exposes the following members.

Properties

Name | Description
Bottom | Specifies the bottom padding (Overrides LayoutDecoratorBase..::.Bottom.)
Left | Specifies the left padding (Overrides LayoutDecoratorBase..::.Left.)
Right | Specifies the right padding (Overrides LayoutDecoratorBase..::.Right.)
Top | Specifies the top padding (Overrides LayoutDecoratorBase..::.Top.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle..::.Bottom Property
ChartPaddingsTitle Class See Also Send Feedback
Specifies the bottom padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Overrides Property Bottom As Unit

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle..::.Left Property
ChartPaddingsTitle Class See Also Send Feedback
Specifies the left padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Left { get; set; }
Visual Basic (Declaration)
Public Overrides Property Left As Unit

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle..::.Right Property
ChartPaddingsTitle Class See Also Send Feedback
Specifies the right padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Right { get; set; }
Visual Basic (Declaration)
Public Overrides Property Right As Unit

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ChartPaddingsTitle..::.Top Property
ChartPaddingsTitle Class See Also Send Feedback
Specifies the top padding

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Top { get; set; }
Visual Basic (Declaration)
Public Overrides Property Top As Unit

See Also

ChartPaddingsTitle Class
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Class

[image]

Telerik Reporting Q2 2012
ChartSkin Class
Members See Also Send Feedback
Chart skin

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ChartSkin
Visual Basic (Declaration)
Public Class ChartSkin

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting.Styles..::.ChartSkin

See Also

ChartSkin Members
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Members

[image] [image]

Telerik Reporting Q2 2012
ChartSkin Members
ChartSkin Class Constructors Methods Properties See Also Send Feedback

The ChartSkin type exposes the following members.

Constructors

Name | Description
ChartSkin | Overloaded.

Methods

Name | Description
ApplyTo | Applies skin to given chart
CreateFromChart | Grabs skin from given chart

Properties

Name | Description
Name | Gets and sets skin name.
XmlSource | Gets and sets XML document that contains skin properties.

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Constructor

[image] [image]

Telerik Reporting Q2 2012
ChartSkin Constructor
ChartSkin Class See Also Send Feedback

Overload List

Name | Description
ChartSkin()()() | Create new instance of ChartSkin class.
ChartSkin(String) | Create new instance of ChartSkin class with specified name.
ChartSkin(XmlDocument) | Create new instance of ChartSkin class.

See Also

ChartSkin Class
ChartSkin Members
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Constructor

[image]

Telerik Reporting Q2 2012
ChartSkin Constructor
ChartSkin Class See Also Send Feedback
Create new instance of ChartSkin class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSkin()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSkin Class
ChartSkin Overload
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Constructor (String)

[image]

Telerik Reporting Q2 2012
ChartSkin Constructor (String)
ChartSkin Class See Also Send Feedback
Create new instance of ChartSkin class with specified name.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSkin(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
Name of skin.

See Also

ChartSkin Class
ChartSkin Overload
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Constructor (XmlDocument)

[image]

Telerik Reporting Q2 2012
ChartSkin Constructor (XmlDocument)
ChartSkin Class See Also Send Feedback
Create new instance of ChartSkin class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSkin(
    XmlDocument source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As XmlDocument _
)

Parameters

source
Type: System.Xml..::.XmlDocument
XML document that contains skin properties.

See Also

ChartSkin Class
ChartSkin Overload
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Methods

[image] [image]

Telerik Reporting Q2 2012
ChartSkin Methods
ChartSkin Class See Also Send Feedback

The ChartSkin type exposes the following members.

Methods

Name | Description
ApplyTo | Applies skin to given chart
CreateFromChart | Grabs skin from given chart

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ApplyTo Method

[image]

Telerik Reporting Q2 2012
ChartSkin..::.ApplyTo Method
ChartSkin Class See Also Send Feedback
Applies skin to given chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void ApplyTo(
    Chart chart
)
Visual Basic (Declaration)
Public Sub ApplyTo ( _
    chart As Chart _
)

Parameters

chart
Type: Telerik.Reporting.Charting..::.Chart
Chart to apply skin

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


CreateFromChart Method

[image]

Telerik Reporting Q2 2012
ChartSkin..::.CreateFromChart Method
ChartSkin Class See Also Send Feedback
Grabs skin from given chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CreateFromChart(
    Chart chart,
    string name
)
Visual Basic (Declaration)
Public Sub CreateFromChart ( _
    chart As Chart, _
    name As String _
)

Parameters

chart
Type: Telerik.Reporting.Charting..::.Chart
Chart to get skin
name
Type: System..::.String
Skin name

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ChartSkin Properties

[image] [image]

Telerik Reporting Q2 2012
ChartSkin Properties
ChartSkin Class See Also Send Feedback

The ChartSkin type exposes the following members.

Properties

Name | Description
Name | Gets and sets skin name.
XmlSource | Gets and sets XML document that contains skin properties.

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ChartSkin..::.Name Property
ChartSkin Class See Also Send Feedback
Gets and sets skin name.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

Name of skin

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


XmlSource Property

[image]

Telerik Reporting Q2 2012
ChartSkin..::.XmlSource Property
ChartSkin Class See Also Send Feedback
Gets and sets XML document that contains skin properties.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public XmlDocument XmlSource { get; set; }
Visual Basic (Declaration)
Public Property XmlSource As XmlDocument

See Also

ChartSkin Class
Telerik.Reporting.Charting.Styles Namespace


ChartValueFormat Enumeration

[image]

Telerik Reporting Q2 2012
ChartValueFormat Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ChartValueFormat
Visual Basic (Declaration)
Public Enumeration ChartValueFormat

Members

Member name | Description
None | Specifies that no default format string is specified. Uses CustomFormat if is .
Currency | Default format string is set to currency : "C".
Scientific | Default format string is set to scientific : "E".
General | Default format string is set to general : "G".
Number | Default format string is set to number : "N".
Percent | Default format string is set to percent : "P".
ShortDate | Converts to short date using ShortDatePattern set in CurrentCulture. Uses CustomFormat if is set.
ShortTime | Converts to short time using ShortTimePattern set in CurrentCulture. Uses CustomFormat if is set.
LongDate | Converts to long date using LongDatePattern set in CurrentCulture. Uses CustomFormat if is set.
LongTime | Converts to long time using LongTimePattern set in CurrentCulture. Uses CustomFormat if is set.

See Also

Telerik.Reporting.Charting.Styles Namespace


Corners Class

[image]

Telerik Reporting Q2 2012
Corners Class
Members See Also Send Feedback
Sets the edge type of rectangular shapes.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Corners : StateManagedObject
Visual Basic (Declaration)
Public Class Corners _
    Inherits StateManagedObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Corners

See Also

Corners Members
Telerik.Reporting.Charting.Styles Namespace


Corners Members

[image] [image]

Telerik Reporting Q2 2012
Corners Members
Corners Class Constructors Methods Operators Properties Explicit Interface Implementations See Also Send Feedback

The Corners type exposes the following members.

Constructors

Name | Description
Corners | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from specified object
Dispose | Overloaded.
Equals | Compare two objects of Corners type (Overrides Object..::.Equals(Object).)
GetHashCode | Gets HashCode (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetCornersType | Set specified type for all corners
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Operators

Name | Description
Implicit | Implicitly creates a Corners from the specified string.

Properties

Name | Description
BottomLeft | Gets and sets the type of the bottom left corner of the rectangular shape.
BottomRight | Gets and sets the type of the bottom right corner of the rectangular shape.
RoundSize | Gets and sets the round size of the corner.
TopLeft | Gets and sets the type of the top left corner of the rectangular shape.
TopRight | Gets and sets the type of the top right corner of the rectangular shape.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor

[image] [image]

Telerik Reporting Q2 2012
Corners Constructor
Corners Class See Also Send Feedback

Overload List

Name | Description
Corners()()() | Create new instance of Corners class.
Corners(Int32) | Create new instance of Corners class.
Corners(Object) | Create new instance of Corners class.
Corners(CornerType, CornerType, CornerType, CornerType, Int32) | Create new instance of Corners class.

See Also

Corners Class
Corners Members
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor

[image]

Telerik Reporting Q2 2012
Corners Constructor
Corners Class See Also Send Feedback
Create new instance of Corners class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners()
Visual Basic (Declaration)
Public Sub New

See Also

Corners Class
Corners Overload
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor (Int32)

[image]

Telerik Reporting Q2 2012
Corners Constructor (Int32)
Corners Class See Also Send Feedback
Create new instance of Corners class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners(
    int roundSize
)
Visual Basic (Declaration)
Public Sub New ( _
    roundSize As Integer _
)

Parameters

roundSize
Type: System..::.Int32
RoundSize for coners

See Also

Corners Class
Corners Overload
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor (Object)

[image]

Telerik Reporting Q2 2012
Corners Constructor (Object)
Corners Class See Also Send Feedback
Create new instance of Corners class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

Corners Class
Corners Overload
Telerik.Reporting.Charting.Styles Namespace


Corners Constructor (CornerType, CornerType, CornerType, CornerType, Int32)

[image]

Telerik Reporting Q2 2012
Corners Constructor (CornerType, CornerType, CornerType, CornerType, Int32)
Corners Class See Also Send Feedback
Create new instance of Corners class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners(
    CornerType topLeft,
    CornerType topRight,
    CornerType bottomLeft,
    CornerType bottomRight,
    int roundSize
)
Visual Basic (Declaration)
Public Sub New ( _
    topLeft As CornerType, _
    topRight As CornerType, _
    bottomLeft As CornerType, _
    bottomRight As CornerType, _
    roundSize As Integer _
)

Parameters

topLeft
Type: Telerik.Reporting.Charting.Styles..::.CornerType
Type of top left corner
topRight
Type: Telerik.Reporting.Charting.Styles..::.CornerType
Type of top right corner
bottomLeft
Type: Telerik.Reporting.Charting.Styles..::.CornerType
Type of bottom left corner
bottomRight
Type: Telerik.Reporting.Charting.Styles..::.CornerType
Type of bottom right corner
roundSize
Type: System..::.Int32
RoundSize of corners

See Also

Corners Class
Corners Overload
Telerik.Reporting.Charting.Styles Namespace


Corners Methods

[image] [image]

Telerik Reporting Q2 2012
Corners Methods
Corners Class See Also Send Feedback

The Corners type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from specified object
Dispose | Overloaded.
Equals | Compare two objects of Corners type (Overrides Object..::.Equals(Object).)
GetHashCode | Gets HashCode (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
Parse | Overloaded.
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetCornersType | Set specified type for all corners
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Corners..::.Clone Method
Corners Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of Corners type

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
Corners..::.CopyFrom Method
Corners Class See Also Send Feedback
Copy fields from specified object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected internal void CopyFrom(
    Corners sourceCorners
)
Visual Basic (Declaration)
Protected Friend Sub CopyFrom ( _
    sourceCorners As Corners _
)

Parameters

sourceCorners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Object to copy from

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Corners..::.Dispose Method
Corners Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

Corners Class
Corners Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
Corners..::.Equals Method
Corners Class See Also Send Feedback
Compare two objects of Corners type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare with

Return Value

Whether objects equal

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Corners..::.GetHashCode Method
Corners Class See Also Send Feedback
Gets HashCode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

HashCode

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Parse Method

[image] [image]

Telerik Reporting Q2 2012
Corners..::.Parse Method
Corners Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Converts the specified string to Corners.
Parse(String, CultureInfo) | Converts the specified string to a Corners.

See Also

Corners Class
Corners Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String)

[image]

Telerik Reporting Q2 2012
Corners..::.Parse Method (String)
Corners Class See Also Send Feedback
Converts the specified string to Corners.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Corners Parse(
    string value
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String _
) As Corners

Parameters

value
Type: System..::.String
The string to convert.

Return Value

Corners that represents the specified string.

See Also

Corners Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
Corners..::.Parse Method (String, CultureInfo)
Corners Class See Also Send Feedback
Converts the specified string to a Corners.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Corners Parse(
    string value,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    value As String, _
    culture As CultureInfo _
) As Corners

Parameters

value
Type: System..::.String
The string to convert.
culture
Type: System.Globalization..::.CultureInfo
CultureInfo used

Return Value

Object of corners type

See Also

Corners Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


SetCornersType Method

[image]

Telerik Reporting Q2 2012
Corners..::.SetCornersType Method
Corners Class See Also Send Feedback
Set specified type for all corners

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetCornersType(
    CornerType cornerType
)
Visual Basic (Declaration)
Public Sub SetCornersType ( _
    cornerType As CornerType _
)

Parameters

cornerType
Type: Telerik.Reporting.Charting.Styles..::.CornerType
Type of corners

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Corners Operators

[image] [image]

Telerik Reporting Q2 2012
Corners Operators
Corners Class See Also Send Feedback

The Corners type exposes the following members.

Operators

Name | Description
Implicit | Implicitly creates a Corners from the specified string.

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Implicit Operator

[image]

Telerik Reporting Q2 2012
Corners..::.Implicit Operator
Corners Class See Also Send Feedback
Implicitly creates a Corners from the specified string.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static implicit operator Corners (
    string value
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    value As String _
) As Corners

Parameters

value
Type: System..::.String
The string to parse

Return Value

Object of corners type

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


Corners Properties

[image] [image]

Telerik Reporting Q2 2012
Corners Properties
Corners Class See Also Send Feedback

The Corners type exposes the following members.

Properties

Name | Description
BottomLeft | Gets and sets the type of the bottom left corner of the rectangular shape.
BottomRight | Gets and sets the type of the bottom right corner of the rectangular shape.
RoundSize | Gets and sets the round size of the corner.
TopLeft | Gets and sets the type of the top left corner of the rectangular shape.
TopRight | Gets and sets the type of the top right corner of the rectangular shape.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


BottomLeft Property

[image]

Telerik Reporting Q2 2012
Corners..::.BottomLeft Property
Corners Class See Also Send Feedback
Gets and sets the type of the bottom left corner of the rectangular shape.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CornerType BottomLeft { get; set; }
Visual Basic (Declaration)
Public Property BottomLeft As CornerType

Field Value

Type of bottom left corner

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


BottomRight Property

[image]

Telerik Reporting Q2 2012
Corners..::.BottomRight Property
Corners Class See Also Send Feedback
Gets and sets the type of the bottom right corner of the rectangular shape.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CornerType BottomRight { get; set; }
Visual Basic (Declaration)
Public Property BottomRight As CornerType

Field Value

Type of bottom right corner

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


RoundSize Property

[image]

Telerik Reporting Q2 2012
Corners..::.RoundSize Property
Corners Class See Also Send Feedback
Gets and sets the round size of the corner.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int RoundSize { get; set; }
Visual Basic (Declaration)
Public Property RoundSize As Integer

Field Value

Round size of corners

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


TopLeft Property

[image]

Telerik Reporting Q2 2012
Corners..::.TopLeft Property
Corners Class See Also Send Feedback
Gets and sets the type of the top left corner of the rectangular shape.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CornerType TopLeft { get; set; }
Visual Basic (Declaration)
Public Property TopLeft As CornerType

Field Value

Type of top left corner

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


TopRight Property

[image]

Telerik Reporting Q2 2012
Corners..::.TopRight Property
Corners Class See Also Send Feedback
Gets and sets the type of the top right corner of the rectangular shape.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CornerType TopRight { get; set; }
Visual Basic (Declaration)
Public Property TopRight As CornerType

Field Value

Type of top right corner

See Also

Corners Class
Telerik.Reporting.Charting.Styles Namespace


CornersConverter Class

[image]

Telerik Reporting Q2 2012
CornersConverter Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CornersConverter : TypeConverter
Visual Basic (Declaration)
Public Class CornersConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Telerik.Reporting.Charting.Styles..::.CornersConverter

See Also

CornersConverter Members
Telerik.Reporting.Charting.Styles Namespace


CornersConverter Members

[image] [image]

Telerik Reporting Q2 2012
CornersConverter Members
CornersConverter Class Constructors Methods See Also Send Feedback

The CornersConverter type exposes the following members.

Constructors

Name | Description
CornersConverter | Initializes a new instance of the CornersConverter class

Methods

Name | Description
CanConvertFrom | Check whether can convert an object of the given type to the type of this converter, using the specified context (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Conversion of an object to the type of this converter (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | Conversion of an object to the specified type (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Create new instance (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Get Create Instance Supported (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Gets Properties of type (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Get Properties Supported (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


CornersConverter Constructor

[image]

Telerik Reporting Q2 2012
CornersConverter Constructor
CornersConverter Class See Also Send Feedback
Initializes a new instance of the CornersConverter class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CornersConverter()
Visual Basic (Declaration)
Public Sub New

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


CornersConverter Methods

[image] [image]

Telerik Reporting Q2 2012
CornersConverter Methods
CornersConverter Class See Also Send Feedback

The CornersConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Check whether can convert an object of the given type to the type of this converter, using the specified context (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Conversion of an object to the type of this converter (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | Conversion of an object to the specified type (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Create new instance (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Get Create Instance Supported (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Gets Properties of type (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Get Properties Supported (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


CanConvertFrom Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.CanConvertFrom Method
CornersConverter Class See Also Send Feedback
Check whether can convert an object of the given type to the type of this converter, using the specified context

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context for types converting
sourceType
Type: System..::.Type
Type to convert

Return Value

Can convert an object or not

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertFrom Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.ConvertFrom Method
CornersConverter Class See Also Send Feedback
Conversion of an object to the type of this converter

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context for types converting
culture
Type: System.Globalization..::.CultureInfo
To use at the current culture
value
Type: System..::.Object
Object to convert

Return Value

Converted object

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertTo Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.ConvertTo Method
CornersConverter Class See Also Send Feedback
Conversion of an object to the specified type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context for types converting
culture
Type: System.Globalization..::.CultureInfo
To use at the current culture
value
Type: System..::.Object
Object to convert
destinationType
Type: System..::.Type
Type to convert the value parameter to

Return Value

converted object

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


CreateInstance Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.CreateInstance Method
CornersConverter Class See Also Send Feedback
Create new instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual Basic (Declaration)
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context
propertyValues
Type: System.Collections..::.IDictionary
Properties

Return Value

New instance

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetCreateInstanceSupported Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.GetCreateInstanceSupported Method
CornersConverter Class See Also Send Feedback
Get Create Instance Supported

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetCreateInstanceSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context

Return Value

Get Create Instance Supported

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetProperties Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.GetProperties Method
CornersConverter Class See Also Send Feedback
Gets Properties of type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context
value
Type: System..::.Object
attributes
Type: array< System..::.Attribute >[]()[][]

Return Value

Properties of this type

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetPropertiesSupported Method

[image]

Telerik Reporting Q2 2012
CornersConverter..::.GetPropertiesSupported Method
CornersConverter Class See Also Send Feedback
Get Properties Supported

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
Context

Return Value

Properties Supported

See Also

CornersConverter Class
Telerik.Reporting.Charting.Styles Namespace


CornerType Enumeration

[image]

Telerik Reporting Q2 2012
CornerType Enumeration
See Also Send Feedback
Corner type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum CornerType
Visual Basic (Declaration)
Public Enumeration CornerType

Members

Member name | Description
Rectangle | Specifies a sharp corner.
Round | Specifies a rounded corner.

See Also

Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Structure

[image]

Telerik Reporting Q2 2012
DefaultFigures Structure
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public struct DefaultFigures
Visual Basic (Declaration)
Public Structure DefaultFigures

See Also

DefaultFigures Members
Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Members

[image] [image]

Telerik Reporting Q2 2012
DefaultFigures Members
DefaultFigures Structure Methods Fields See Also Send Feedback

The DefaultFigures type exposes the following members.

Methods

Name | Description
Contains | Gets whether list contains figure with specified name

Fields

Name | Description
Circle |
Cross | Default figures' names
Diamond |
Ellipse |
FiguresList | List of default figures' names
Rectangle |
Star3 |
Star4 |
Star5 |
Star6 |
Star7 |
Triangle |

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Fields

[image] [image]

Telerik Reporting Q2 2012
DefaultFigures Fields
DefaultFigures Structure See Also Send Feedback

The DefaultFigures type exposes the following members.

Fields

Name | Description
Circle |
Cross | Default figures' names
Diamond |
Ellipse |
FiguresList | List of default figures' names
Rectangle |
Star3 |
Star4 |
Star5 |
Star6 |
Star7 |
Triangle |

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Circle Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Circle Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Circle
Visual Basic (Declaration)
Public Const Circle As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Cross Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Cross Field
DefaultFigures Structure See Also Send Feedback
Default figures' names

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Cross
Visual Basic (Declaration)
Public Const Cross As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Diamond Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Diamond Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Diamond
Visual Basic (Declaration)
Public Const Diamond As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Ellipse Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Ellipse Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Ellipse
Visual Basic (Declaration)
Public Const Ellipse As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


FiguresList Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.FiguresList Field
DefaultFigures Structure See Also Send Feedback
List of default figures' names

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static List<string> FiguresList
Visual Basic (Declaration)
Public Shared FiguresList As List(Of String)

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Rectangle Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Rectangle Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Rectangle
Visual Basic (Declaration)
Public Const Rectangle As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Star3 Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Star3 Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Star3
Visual Basic (Declaration)
Public Const Star3 As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Star4 Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Star4 Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Star4
Visual Basic (Declaration)
Public Const Star4 As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Star5 Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Star5 Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Star5
Visual Basic (Declaration)
Public Const Star5 As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Star6 Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Star6 Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Star6
Visual Basic (Declaration)
Public Const Star6 As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Star7 Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Star7 Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Star7
Visual Basic (Declaration)
Public Const Star7 As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Triangle Field

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Triangle Field
DefaultFigures Structure See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public const string Triangle
Visual Basic (Declaration)
Public Const Triangle As String

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


DefaultFigures Methods

[image] [image]

Telerik Reporting Q2 2012
DefaultFigures Methods
DefaultFigures Structure See Also Send Feedback

The DefaultFigures type exposes the following members.

Methods

Name | Description
Contains | Gets whether list contains figure with specified name

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
DefaultFigures..::.Contains Method
DefaultFigures Structure See Also Send Feedback
Gets whether list contains figure with specified name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool Contains(
    string name
)
Visual Basic (Declaration)
Public Shared Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Name of figure

Return Value

Whether list contains figure with specified name or not

See Also

DefaultFigures Structure
Telerik.Reporting.Charting.Styles Namespace


Dimensions Class

[image]

Telerik Reporting Q2 2012
Dimensions Class
Members See Also Send Feedback
Dimensions base class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Dimensions : StateManagedObject, ICloneable
Visual Basic (Declaration)
Public Class Dimensions _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsChart
Telerik.Reporting.Charting.Styles..::.DimensionsLegend
Telerik.Reporting.Charting.Styles..::.DimensionsMarker
Telerik.Reporting.Charting.Styles..::.DimensionsPlotArea
Telerik.Reporting.Charting.Styles..::.DimensionsSeriesPointMark
Telerik.Reporting.Charting.Styles..::.DimensionsTitle

See Also

Dimensions Members
Telerik.Reporting.Charting.Styles Namespace


Dimensions Members

[image] [image]

Telerik Reporting Q2 2012
Dimensions Members
Dimensions Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The Dimensions type exposes the following members.

Constructors

Name | Description
Dimensions | Overloaded.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code. (Overrides Object..::.GetHashCode()()().)
IsZero | Returns True if dimensions width and height are zero values
LoadViewState | Load data from ViewState. (Overrides StateManagedObject..::.LoadViewState(Object).)
ResetHeight | Reset Height to default value.
ResetWidth | Gets if Width property should be serializable.
SaveViewState | Save data to ViewState. (Overrides StateManagedObject..::.SaveViewState()()().)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable.
ShouldSerializeWidth | Gets if Width property should be serializable.
TrackViewState | Track ViewState. (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties
dimensionsPaddings | Specifies the paddings properties

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode
Height | Specifies the height property
Margins | Specifies the margins properties
Paddings | Specifies the paddings properties
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor

[image] [image]

Telerik Reporting Q2 2012
Dimensions Constructor
Dimensions Class See Also Send Feedback

Overload List

Name | Description
Dimensions()()() | Create new instance of Dimensions class.
Dimensions(Object) | Create new instance of Dimensions class.
Dimensions(ChartMargins) | Create new instance of Dimensions class.
Dimensions(ChartPaddings) | Create new instance of Dimensions class.
Dimensions(Single, Single) | Create new instance of Dimensions class.
Dimensions(ChartMargins, ChartPaddings) | Create new instance of Dimensions class.
Dimensions(Unit, Unit) | Create new instance of Dimensions class.

See Also

Dimensions Class
Dimensions Members
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor

[image]

Telerik Reporting Q2 2012
Dimensions Constructor
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions()
Visual Basic (Declaration)
Public Sub New

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (Object)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (Object)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (ChartMargins)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (ChartMargins)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    ChartMargins margins
)
Visual Basic (Declaration)
Public Sub New ( _
    margins As ChartMargins _
)

Parameters

margins
Type: Telerik.Reporting.Charting.Styles..::.ChartMargins
Margins of element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (ChartPaddings)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (ChartPaddings)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    ChartPaddings paddings
)
Visual Basic (Declaration)
Public Sub New ( _
    paddings As ChartPaddings _
)

Parameters

paddings
Type: Telerik.Reporting.Charting.Styles..::.ChartPaddings
Paddings of element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (Single, Single)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (Single, Single)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    float width,
    float height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Single, _
    height As Single _
)

Parameters

width
Type: System..::.Single
Width of element
height
Type: System..::.Single
Height of element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (ChartMargins, ChartPaddings)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (ChartMargins, ChartPaddings)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    ChartMargins margins,
    ChartPaddings paddings
)
Visual Basic (Declaration)
Public Sub New ( _
    margins As ChartMargins, _
    paddings As ChartPaddings _
)

Parameters

margins
Type: Telerik.Reporting.Charting.Styles..::.ChartMargins
Margins of element
paddings
Type: Telerik.Reporting.Charting.Styles..::.ChartPaddings
Paddings of element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Constructor (Unit, Unit)

[image]

Telerik Reporting Q2 2012
Dimensions Constructor (Unit, Unit)
Dimensions Class See Also Send Feedback
Create new instance of Dimensions class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Dimensions(
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Unit, _
    height As Unit _
)

Parameters

width
Type: Telerik.Reporting.Charting.Styles..::.Unit
Width of element
height
Type: Telerik.Reporting.Charting.Styles..::.Unit
Height of element

See Also

Dimensions Class
Dimensions Overload
Telerik.Reporting.Charting.Styles Namespace


Dimensions Fields

[image] [image]

Telerik Reporting Q2 2012
Dimensions Fields
Dimensions Class See Also Send Feedback

The Dimensions type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties
dimensionsPaddings | Specifies the paddings properties

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


dimensionsMargins Field

[image]

Telerik Reporting Q2 2012
Dimensions..::.dimensionsMargins Field
Dimensions Class See Also Send Feedback
Specifies the margins properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartMargins dimensionsMargins
Visual Basic (Declaration)
Protected dimensionsMargins As ChartMargins

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


dimensionsPaddings Field

[image]

Telerik Reporting Q2 2012
Dimensions..::.dimensionsPaddings Field
Dimensions Class See Also Send Feedback
Specifies the paddings properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ChartPaddings dimensionsPaddings
Visual Basic (Declaration)
Protected dimensionsPaddings As ChartPaddings

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Methods

[image] [image]

Telerik Reporting Q2 2012
Dimensions Methods
Dimensions Class See Also Send Feedback

The Dimensions type exposes the following members.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code. (Overrides Object..::.GetHashCode()()().)
IsZero | Returns True if dimensions width and height are zero values
LoadViewState | Load data from ViewState. (Overrides StateManagedObject..::.LoadViewState(Object).)
ResetHeight | Reset Height to default value.
ResetWidth | Gets if Width property should be serializable.
SaveViewState | Save data to ViewState. (Overrides StateManagedObject..::.SaveViewState()()().)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable.
ShouldSerializeWidth | Gets if Width property should be serializable.
TrackViewState | Track ViewState. (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.Clone Method
Dimensions Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

New instance of Dimensions class with the same fields as this object.

Implements

ICloneable..::.Clone()()()

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Dimensions..::.Dispose Method
Dimensions Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

Dimensions Class
Dimensions Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
Dimensions..::.Dispose Method (Boolean)
Dimensions Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Dimensions Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.Equals Method
Dimensions Class See Also Send Feedback
Comparing of two objects.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare with.

Return Value

Whether objects are equal.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.GetHashCode Method
Dimensions Class See Also Send Feedback
Gets hash code.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


IsZero Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.IsZero Method
Dimensions Class See Also Send Feedback
Returns True if dimensions width and height are zero values

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsZero()
Visual Basic (Declaration)
Public Function IsZero As Boolean

Return Value

True if dimensions width and height are zero values

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.LoadViewState Method
Dimensions Class See Also Send Feedback
Load data from ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.ResetHeight Method
Dimensions Class See Also Send Feedback
Reset Height to default value.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void ResetHeight()
Visual Basic (Declaration)
Protected Overridable Sub ResetHeight

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


ResetWidth Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.ResetWidth Method
Dimensions Class See Also Send Feedback
Gets if Width property should be serializable.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void ResetWidth()
Visual Basic (Declaration)
Protected Overridable Sub ResetWidth

Return Value

If Width property should be serializable.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.SaveViewState Method
Dimensions Class See Also Send Feedback
Save data to ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
Dimensions..::.SetDimensions Method
Dimensions Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object.
SetDimensions(Single, Single) | Sets the new Width and Height values
SetDimensions(Unit, Unit) | Sets the new Width and Height values

See Also

Dimensions Class
Dimensions Members
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method (Dimensions)

[image]

Telerik Reporting Q2 2012
Dimensions..::.SetDimensions Method (Dimensions)
Dimensions Class See Also Send Feedback
Copy dimensions from the object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetDimensions(
    Dimensions source
)
Visual Basic (Declaration)
Public Sub SetDimensions ( _
    source As Dimensions _
)

Parameters

source
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Object tot copy from.

See Also

Dimensions Class
SetDimensions Overload
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method (Single, Single)

[image]

Telerik Reporting Q2 2012
Dimensions..::.SetDimensions Method (Single, Single)
Dimensions Class See Also Send Feedback
Sets the new Width and Height values

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetDimensions(
    float width,
    float height
)
Visual Basic (Declaration)
Public Sub SetDimensions ( _
    width As Single, _
    height As Single _
)

Parameters

width
Type: System..::.Single
Width of element
height
Type: System..::.Single
Height of element

See Also

Dimensions Class
SetDimensions Overload
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method (Unit, Unit)

[image]

Telerik Reporting Q2 2012
Dimensions..::.SetDimensions Method (Unit, Unit)
Dimensions Class See Also Send Feedback
Sets the new Width and Height values

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void SetDimensions(
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Sub SetDimensions ( _
    width As Unit, _
    height As Unit _
)

Parameters

width
Type: Telerik.Reporting.Charting.Styles..::.Unit
Width of element
height
Type: Telerik.Reporting.Charting.Styles..::.Unit
Height of element

See Also

Dimensions Class
SetDimensions Overload
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeHeight Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.ShouldSerializeHeight Method
Dimensions Class See Also Send Feedback
Gets if Height property should be serializable.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ShouldSerializeHeight()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeHeight As Boolean

Return Value

If Height property should be serializable.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeWidth Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.ShouldSerializeWidth Method
Dimensions Class See Also Send Feedback
Gets if Width property should be serializable.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ShouldSerializeWidth()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeWidth As Boolean

Return Value

If Width property should be serializable.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
Dimensions..::.TrackViewState Method
Dimensions Class See Also Send Feedback
Track ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Properties

[image] [image]

Telerik Reporting Q2 2012
Dimensions Properties
Dimensions Class See Also Send Feedback

The Dimensions type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode
Height | Specifies the height property
Margins | Specifies the margins properties
Paddings | Specifies the paddings properties
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


AutoSize Property

[image]

Telerik Reporting Q2 2012
Dimensions..::.AutoSize Property
Dimensions Class See Also Send Feedback
Gets and sets Auto sizing mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Overridable Property AutoSize As Boolean

Field Value

True if auto size, false - if not.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

[image]

Telerik Reporting Q2 2012
Dimensions..::.Height Property
Dimensions Class See Also Send Feedback
Specifies the height property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Unit

Field Value

Height value of Unit type.

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
Dimensions..::.Margins Property
Dimensions Class See Also Send Feedback
Specifies the margins properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overridable Property Margins As ChartMargins

Field Value

Margins for element

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Paddings Property

[image]

Telerik Reporting Q2 2012
Dimensions..::.Paddings Property
Dimensions Class See Also Send Feedback
Specifies the paddings properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ChartPaddings Paddings { get; set; }
Visual Basic (Declaration)
Public Overridable Property Paddings As ChartPaddings

Field Value

Paddings for element

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
Dimensions..::.Width Property
Dimensions Class See Also Send Feedback
Specifies the width property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Unit

Field Value

Width value of Unit type

See Also

Dimensions Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Class

[image]

Telerik Reporting Q2 2012
DimensionsChart Class
Members See Also Send Feedback
Chart's dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsChart : Dimensions
Visual Basic (Declaration)
Public Class DimensionsChart _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsChart

See Also

DimensionsChart Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart Members
DimensionsChart Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsChart type exposes the following members.

Constructors

Name | Description
DimensionsChart | Initializes a new instance of the DimensionsChart class

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Reset Width to default settings (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies Height of element (Overrides Dimensions..::.Height.)
Margins | Specifies the margins properties (Inherited from Dimensions.)
Paddings | Specifies the paddings properties (Inherited from Dimensions.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies Width of element (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Constructor

[image]

Telerik Reporting Q2 2012
DimensionsChart Constructor
DimensionsChart Class See Also Send Feedback
Initializes a new instance of the DimensionsChart class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsChart()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart Fields
DimensionsChart Class See Also Send Feedback

The DimensionsChart type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart Methods
DimensionsChart Class See Also Send Feedback

The DimensionsChart type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Reset Width to default settings (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart..::.Dispose Method
DimensionsChart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsChart Class
DimensionsChart Members
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

[image]

Telerik Reporting Q2 2012
DimensionsChart..::.ResetHeight Method
DimensionsChart Class See Also Send Feedback
Reset Height to default settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetHeight()
Visual Basic (Declaration)
Protected Overrides Sub ResetHeight

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


ResetWidth Method

[image]

Telerik Reporting Q2 2012
DimensionsChart..::.ResetWidth Method
DimensionsChart Class See Also Send Feedback
Reset Width to default settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetWidth()
Visual Basic (Declaration)
Protected Overrides Sub ResetWidth

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart..::.SetDimensions Method
DimensionsChart Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsChart Class
DimensionsChart Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsChart Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsChart Properties
DimensionsChart Class See Also Send Feedback

The DimensionsChart type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies Height of element (Overrides Dimensions..::.Height.)
Margins | Specifies the margins properties (Inherited from Dimensions.)
Paddings | Specifies the paddings properties (Inherited from Dimensions.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies Width of element (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

[image]

Telerik Reporting Q2 2012
DimensionsChart..::.Height Property
DimensionsChart Class See Also Send Feedback
Specifies Height of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Unit

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
DimensionsChart..::.Width Property
DimensionsChart Class See Also Send Feedback
Specifies Width of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Unit

See Also

DimensionsChart Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Class

[image]

Telerik Reporting Q2 2012
DimensionsLegend Class
Members See Also Send Feedback
Legend's dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsLegend : Dimensions
Visual Basic (Declaration)
Public Class DimensionsLegend _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsLegend

See Also

DimensionsLegend Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend Members
DimensionsLegend Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsLegend type exposes the following members.

Constructors

Name | Description
DimensionsLegend | Create new instance of DimensionsLegend

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element (Overrides Dimensions..::.Margins.)
Paddings | Specified paddings of element (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Constructor

[image]

Telerik Reporting Q2 2012
DimensionsLegend Constructor
DimensionsLegend Class See Also Send Feedback
Create new instance of DimensionsLegend

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsLegend()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend Fields
DimensionsLegend Class See Also Send Feedback

The DimensionsLegend type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend Methods
DimensionsLegend Class See Also Send Feedback

The DimensionsLegend type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend..::.Dispose Method
DimensionsLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsLegend Class
DimensionsLegend Members
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend..::.SetDimensions Method
DimensionsLegend Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsLegend Class
DimensionsLegend Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsLegend Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsLegend Properties
DimensionsLegend Class See Also Send Feedback

The DimensionsLegend type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element (Overrides Dimensions..::.Margins.)
Paddings | Specified paddings of element (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
DimensionsLegend..::.Margins Property
DimensionsLegend Class See Also Send Feedback
Specifies margins of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overrides Property Margins As ChartMargins

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


Paddings Property

[image]

Telerik Reporting Q2 2012
DimensionsLegend..::.Paddings Property
DimensionsLegend Class See Also Send Feedback
Specified paddings of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartPaddings Paddings { get; set; }
Visual Basic (Declaration)
Public Overrides Property Paddings As ChartPaddings

See Also

DimensionsLegend Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Class

[image]

Telerik Reporting Q2 2012
DimensionsMarker Class
Members See Also Send Feedback
Marker's default dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsMarker : Dimensions
Visual Basic (Declaration)
Public Class DimensionsMarker _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsMarker
Telerik.Reporting.Charting.Styles..::.DimensionsPointMarker

See Also

DimensionsMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker Members
DimensionsMarker Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsMarker type exposes the following members.

Constructors

Name | Description
DimensionsMarker | Overloaded.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Reset Width to default settings (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto size mode of element (Overrides Dimensions..::.AutoSize.)
Height | Specifies height of element (Overrides Dimensions..::.Height.)
Margins | Specifies the margins properties (Inherited from Dimensions.)
Paddings | Specifies paddings of element (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies width of element (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Constructor

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker Constructor
DimensionsMarker Class See Also Send Feedback

Overload List

Name | Description
DimensionsMarker()()() | Create new instance of DimensionsMarker class.
DimensionsMarker(Object) | Create new instance of DimensionsMarker class.
DimensionsMarker(Single, Single) | Create new instance of DimensionsMarker class.

See Also

DimensionsMarker Class
DimensionsMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Constructor

[image]

Telerik Reporting Q2 2012
DimensionsMarker Constructor
DimensionsMarker Class See Also Send Feedback
Create new instance of DimensionsMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsMarker()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsMarker Class
DimensionsMarker Overload
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Constructor (Object)

[image]

Telerik Reporting Q2 2012
DimensionsMarker Constructor (Object)
DimensionsMarker Class See Also Send Feedback
Create new instance of DimensionsMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsMarker(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

DimensionsMarker Class
DimensionsMarker Overload
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Constructor (Single, Single)

[image]

Telerik Reporting Q2 2012
DimensionsMarker Constructor (Single, Single)
DimensionsMarker Class See Also Send Feedback
Create new instance of DimensionsMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsMarker(
    float width,
    float height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Single, _
    height As Single _
)

Parameters

width
Type: System..::.Single
Width of element
height
Type: System..::.Single
Height of element

See Also

DimensionsMarker Class
DimensionsMarker Overload
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker Fields
DimensionsMarker Class See Also Send Feedback

The DimensionsMarker type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker Methods
DimensionsMarker Class See Also Send Feedback

The DimensionsMarker type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Reset Width to default settings (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker..::.Dispose Method
DimensionsMarker Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsMarker Class
DimensionsMarker Members
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.ResetHeight Method
DimensionsMarker Class See Also Send Feedback
Reset Height to default settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetHeight()
Visual Basic (Declaration)
Protected Overrides Sub ResetHeight

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


ResetWidth Method

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.ResetWidth Method
DimensionsMarker Class See Also Send Feedback
Reset Width to default settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetWidth()
Visual Basic (Declaration)
Protected Overrides Sub ResetWidth

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker..::.SetDimensions Method
DimensionsMarker Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsMarker Class
DimensionsMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsMarker Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsMarker Properties
DimensionsMarker Class See Also Send Feedback

The DimensionsMarker type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto size mode of element (Overrides Dimensions..::.AutoSize.)
Height | Specifies height of element (Overrides Dimensions..::.Height.)
Margins | Specifies the margins properties (Inherited from Dimensions.)
Paddings | Specifies paddings of element (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies width of element (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


AutoSize Property

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.AutoSize Property
DimensionsMarker Class See Also Send Feedback
Gets and sets Auto size mode of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Overrides Property AutoSize As Boolean

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.Height Property
DimensionsMarker Class See Also Send Feedback
Specifies height of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Unit

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


Paddings Property

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.Paddings Property
DimensionsMarker Class See Also Send Feedback
Specifies paddings of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartPaddings Paddings { get; set; }
Visual Basic (Declaration)
Public Overrides Property Paddings As ChartPaddings

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
DimensionsMarker..::.Width Property
DimensionsMarker Class See Also Send Feedback
Specifies width of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Unit

See Also

DimensionsMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Class

[image]

Telerik Reporting Q2 2012
DimensionsPlotArea Class
Members See Also Send Feedback
Default plot area's dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsPlotArea : Dimensions
Visual Basic (Declaration)
Public Class DimensionsPlotArea _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsPlotArea

See Also

DimensionsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea Members
DimensionsPlotArea Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsPlotArea type exposes the following members.

Constructors

Name | Description
DimensionsPlotArea | Create new instance of DimensionsPlotArea class.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies the paddings properties (Inherited from Dimensions.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Constructor

[image]

Telerik Reporting Q2 2012
DimensionsPlotArea Constructor
DimensionsPlotArea Class See Also Send Feedback
Create new instance of DimensionsPlotArea class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsPlotArea()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea Fields
DimensionsPlotArea Class See Also Send Feedback

The DimensionsPlotArea type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea Methods
DimensionsPlotArea Class See Also Send Feedback

The DimensionsPlotArea type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea..::.Dispose Method
DimensionsPlotArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsPlotArea Class
DimensionsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea..::.SetDimensions Method
DimensionsPlotArea Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsPlotArea Class
DimensionsPlotArea Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPlotArea Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsPlotArea Properties
DimensionsPlotArea Class See Also Send Feedback

The DimensionsPlotArea type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies the paddings properties (Inherited from Dimensions.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
DimensionsPlotArea..::.Margins Property
DimensionsPlotArea Class See Also Send Feedback
Specifies margins of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overrides Property Margins As ChartMargins

See Also

DimensionsPlotArea Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Class

[image]

Telerik Reporting Q2 2012
DimensionsPointMarker Class
Members See Also Send Feedback
PointMark's default dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsPointMarker : DimensionsMarker
Visual Basic (Declaration)
Public Class DimensionsPointMarker _
    Inherits DimensionsMarker

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsMarker
Telerik.Reporting.Charting.Styles..::.DimensionsPointMarker

See Also

DimensionsPointMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker Members
DimensionsPointMarker Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsPointMarker type exposes the following members.

Constructors

Name | Description
DimensionsPointMarker | Initializes a new instance of the DimensionsPointMarker class

Methods

Name | Description
Clone | Clone this object. (Overrides Dimensions..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Inherited from DimensionsMarker.)
ResetWidth | Reset Width to default settings (Inherited from DimensionsMarker.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto size mode of element (Inherited from DimensionsMarker.)
Height | Specifies height of element (Inherited from DimensionsMarker.)
Margins | Specifies margins of element (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element (Inherited from DimensionsMarker.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies width of element (Inherited from DimensionsMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Constructor

[image]

Telerik Reporting Q2 2012
DimensionsPointMarker Constructor
DimensionsPointMarker Class See Also Send Feedback
Initializes a new instance of the DimensionsPointMarker class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsPointMarker()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker Fields
DimensionsPointMarker Class See Also Send Feedback

The DimensionsPointMarker type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker Methods
DimensionsPointMarker Class See Also Send Feedback

The DimensionsPointMarker type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Overrides Dimensions..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default settings (Inherited from DimensionsMarker.)
ResetWidth | Reset Width to default settings (Inherited from DimensionsMarker.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
DimensionsPointMarker..::.Clone Method
DimensionsPointMarker Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

New instance of DimensionsPointMarker class with the same fields as this object.

Implements

ICloneable..::.Clone()()()

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker..::.Dispose Method
DimensionsPointMarker Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsPointMarker Class
DimensionsPointMarker Members
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker..::.SetDimensions Method
DimensionsPointMarker Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsPointMarker Class
DimensionsPointMarker Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsPointMarker Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsPointMarker Properties
DimensionsPointMarker Class See Also Send Feedback

The DimensionsPointMarker type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto size mode of element (Inherited from DimensionsMarker.)
Height | Specifies height of element (Inherited from DimensionsMarker.)
Margins | Specifies margins of element (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element (Inherited from DimensionsMarker.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies width of element (Inherited from DimensionsMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
DimensionsPointMarker..::.Margins Property
DimensionsPointMarker Class See Also Send Feedback
Specifies margins of element

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overrides Property Margins As ChartMargins

See Also

DimensionsPointMarker Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Class

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Class
Members See Also Send Feedback
Specific series point marks dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsSeriesPointMark : Dimensions
Visual Basic (Declaration)
Public Class DimensionsSeriesPointMark _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsSeriesPointMark

See Also

DimensionsSeriesPointMark Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Members
DimensionsSeriesPointMark Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsSeriesPointMark type exposes the following members.

Constructors

Name | Description
DimensionsSeriesPointMark | Overloaded.

Methods

Name | Description
Clone | Clone this object. (Overrides Dimensions..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Resets Height to default values (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Resets Width to default values (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies Height of element. (Overrides Dimensions..::.Height.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element. (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies Width of element. (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Constructor

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Constructor
DimensionsSeriesPointMark Class See Also Send Feedback

Overload List

Name | Description
DimensionsSeriesPointMark()()() | Create new instance of DimensionsSeriesPointMark class.
DimensionsSeriesPointMark(Object) | Create new instance of DimensionsSeriesPointMark class.

See Also

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Constructor

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Constructor
DimensionsSeriesPointMark Class See Also Send Feedback
Create new instance of DimensionsSeriesPointMark class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsSeriesPointMark()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Overload
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Constructor (Object)

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Constructor (Object)
DimensionsSeriesPointMark Class See Also Send Feedback
Create new instance of DimensionsSeriesPointMark class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsSeriesPointMark(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element.

See Also

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Overload
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Fields
DimensionsSeriesPointMark Class See Also Send Feedback

The DimensionsSeriesPointMark type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Methods
DimensionsSeriesPointMark Class See Also Send Feedback

The DimensionsSeriesPointMark type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Overrides Dimensions..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Resets Height to default values (Overrides Dimensions..::.ResetHeight()()().)
ResetWidth | Resets Width to default values (Overrides Dimensions..::.ResetWidth()()().)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Clone Method
DimensionsSeriesPointMark Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

New instance of DimensionsSeriesPointMark class with the same fields as this object.

Implements

ICloneable..::.Clone()()()

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Dispose Method
DimensionsSeriesPointMark Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members
Telerik.Reporting.Charting.Styles Namespace


ResetHeight Method

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.ResetHeight Method
DimensionsSeriesPointMark Class See Also Send Feedback
Resets Height to default values

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetHeight()
Visual Basic (Declaration)
Protected Overrides Sub ResetHeight

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


ResetWidth Method

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.ResetWidth Method
DimensionsSeriesPointMark Class See Also Send Feedback
Resets Width to default values

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetWidth()
Visual Basic (Declaration)
Protected Overrides Sub ResetWidth

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.SetDimensions Method
DimensionsSeriesPointMark Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsSeriesPointMark Class
DimensionsSeriesPointMark Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsSeriesPointMark Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark Properties
DimensionsSeriesPointMark Class See Also Send Feedback

The DimensionsSeriesPointMark type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies Height of element. (Overrides Dimensions..::.Height.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element. (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies Width of element. (Overrides Dimensions..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Height Property

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Height Property
DimensionsSeriesPointMark Class See Also Send Feedback
Specifies Height of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Unit

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Margins Property
DimensionsSeriesPointMark Class See Also Send Feedback
Specifies margins of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overrides Property Margins As ChartMargins

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Paddings Property

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Paddings Property
DimensionsSeriesPointMark Class See Also Send Feedback
Specifies paddings of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartPaddings Paddings { get; set; }
Visual Basic (Declaration)
Public Overrides Property Paddings As ChartPaddings

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
DimensionsSeriesPointMark..::.Width Property
DimensionsSeriesPointMark Class See Also Send Feedback
Specifies Width of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Unit Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Unit

See Also

DimensionsSeriesPointMark Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Class

[image]

Telerik Reporting Q2 2012
DimensionsTitle Class
Members See Also Send Feedback
Chart title's dimensions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DimensionsTitle : Dimensions
Visual Basic (Declaration)
Public Class DimensionsTitle _
    Inherits Dimensions

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Dimensions
Telerik.Reporting.Charting.Styles..::.DimensionsTitle

See Also

DimensionsTitle Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Members

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle Members
DimensionsTitle Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The DimensionsTitle type exposes the following members.

Constructors

Name | Description
DimensionsTitle | Create new instance of DimensionsTitle class.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element. (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Constructor

[image]

Telerik Reporting Q2 2012
DimensionsTitle Constructor
DimensionsTitle Class See Also Send Feedback
Create new instance of DimensionsTitle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsTitle()
Visual Basic (Declaration)
Public Sub New

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Fields

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle Fields
DimensionsTitle Class See Also Send Feedback

The DimensionsTitle type exposes the following members.

Fields

Name | Description
dimensionsMargins | Specifies the margins properties (Inherited from Dimensions.)
dimensionsPaddings | Specifies the paddings properties (Inherited from Dimensions.)

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Methods

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle Methods
DimensionsTitle Class See Also Send Feedback

The DimensionsTitle type exposes the following members.

Methods

Name | Description
Clone | Clone this object. (Inherited from Dimensions.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects. (Inherited from Dimensions.)
GetHashCode | Gets hash code. (Inherited from Dimensions.)
IsZero | Returns True if dimensions width and height are zero values (Inherited from Dimensions.)
LoadViewState | Load data from ViewState. (Inherited from Dimensions.)
ResetHeight | Reset Height to default value. (Inherited from Dimensions.)
ResetWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
SaveViewState | Save data to ViewState. (Inherited from Dimensions.)
SetDimensions | Overloaded.
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeHeight | Gets if Height property should be serializable. (Inherited from Dimensions.)
ShouldSerializeWidth | Gets if Width property should be serializable. (Inherited from Dimensions.)
TrackViewState | Track ViewState. (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle..::.Dispose Method
DimensionsTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from Dimensions.)

See Also

DimensionsTitle Class
DimensionsTitle Members
Telerik.Reporting.Charting.Styles Namespace


SetDimensions Method

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle..::.SetDimensions Method
DimensionsTitle Class See Also Send Feedback

Overload List

Name | Description
SetDimensions(Dimensions) | Copy dimensions from the object. (Inherited from Dimensions.)
SetDimensions(Single, Single) | Sets the new Width and Height values (Inherited from Dimensions.)
SetDimensions(Unit, Unit) | Sets the new Width and Height values (Inherited from Dimensions.)

See Also

DimensionsTitle Class
DimensionsTitle Members
Telerik.Reporting.Charting.Styles Namespace


DimensionsTitle Properties

[image] [image]

Telerik Reporting Q2 2012
DimensionsTitle Properties
DimensionsTitle Class See Also Send Feedback

The DimensionsTitle type exposes the following members.

Properties

Name | Description
AutoSize | Gets and sets Auto sizing mode (Inherited from Dimensions.)
Height | Specifies the height property (Inherited from Dimensions.)
Margins | Specifies margins of element. (Overrides Dimensions..::.Margins.)
Paddings | Specifies paddings of element. (Overrides Dimensions..::.Paddings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Width | Specifies the width property (Inherited from Dimensions.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
DimensionsTitle..::.Margins Property
DimensionsTitle Class See Also Send Feedback
Specifies margins of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartMargins Margins { get; set; }
Visual Basic (Declaration)
Public Overrides Property Margins As ChartMargins

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


Paddings Property

[image]

Telerik Reporting Q2 2012
DimensionsTitle..::.Paddings Property
DimensionsTitle Class See Also Send Feedback
Specifies paddings of element.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ChartPaddings Paddings { get; set; }
Visual Basic (Declaration)
Public Overrides Property Paddings As ChartPaddings

See Also

DimensionsTitle Class
Telerik.Reporting.Charting.Styles Namespace


DrawType Enumeration

[image]

Telerik Reporting Q2 2012
DrawType Enumeration
See Also Send Feedback
Types for drawing figures

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum DrawType
Visual Basic (Declaration)
Public Enumeration DrawType

Members

Member name | Description
Line | Only lines
Fill | Only fills
LineAndFill | Lines and fills

See Also

Telerik.Reporting.Charting.Styles Namespace


EmptyValue Class

[image]

Telerik Reporting Q2 2012
EmptyValue Class
Members See Also Send Feedback
Empty value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class EmptyValue : StateManagedObject, ICloneable
Visual Basic (Declaration)
Public Class EmptyValue _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.EmptyValue

See Also

EmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Members

[image] [image]

Telerik Reporting Q2 2012
EmptyValue Members
EmptyValue Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The EmptyValue type exposes the following members.

Constructors

Name | Description
EmptyValue | Create new instance of EmptyValue class.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState. (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState. (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState. (Overrides StateManagedObject..::.TrackViewState()()().)

Properties

Name | Description
FillStyle | Specifies an empty bar fill style
Line | Gets and sets Empty line style
Mode | Gets and sets Empty values representation mode
PointMark | Gets and sets Empty value point mark
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Constructor

[image]

Telerik Reporting Q2 2012
EmptyValue Constructor
EmptyValue Class See Also Send Feedback
Create new instance of EmptyValue class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptyValue()
Visual Basic (Declaration)
Public Sub New

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Methods

[image] [image]

Telerik Reporting Q2 2012
EmptyValue Methods
EmptyValue Class See Also Send Feedback

The EmptyValue type exposes the following members.

Methods

Name | Description
Clone | Clone this object.
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState. (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState. (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState. (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
EmptyValue..::.Clone Method
EmptyValue Class See Also Send Feedback
Clone this object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of the object EmptyValue with the same fields as this object has.

Implements

ICloneable..::.Clone()()()

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
EmptyValue..::.Dispose Method
EmptyValue Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

EmptyValue Class
EmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
EmptyValue..::.Dispose Method (Boolean)
EmptyValue Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

EmptyValue Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
EmptyValue..::.LoadViewState Method
EmptyValue Class See Also Send Feedback
Load data from ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
EmptyValue..::.SaveViewState Method
EmptyValue Class See Also Send Feedback
Save data to ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data.

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
EmptyValue..::.TrackViewState Method
EmptyValue Class See Also Send Feedback
Track ViewState.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Properties

[image] [image]

Telerik Reporting Q2 2012
EmptyValue Properties
EmptyValue Class See Also Send Feedback

The EmptyValue type exposes the following members.

Properties

Name | Description
FillStyle | Specifies an empty bar fill style
Line | Gets and sets Empty line style
Mode | Gets and sets Empty values representation mode
PointMark | Gets and sets Empty value point mark
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
EmptyValue..::.FillStyle Property
EmptyValue Class See Also Send Feedback
Specifies an empty bar fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyle

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Line Property

[image]

Telerik Reporting Q2 2012
EmptyValue..::.Line Property
EmptyValue Class See Also Send Feedback
Gets and sets Empty line style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleEmptyLineSeries Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As StyleEmptyLineSeries

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Mode Property

[image]

Telerik Reporting Q2 2012
EmptyValue..::.Mode Property
EmptyValue Class See Also Send Feedback
Gets and sets Empty values representation mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmtyValuesMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As EmtyValuesMode

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


PointMark Property

[image]

Telerik Reporting Q2 2012
EmptyValue..::.PointMark Property
EmptyValue Class See Also Send Feedback
Gets and sets Empty value point mark

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerEmptyValue PointMark { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointMark As StyleMarkerEmptyValue

See Also

EmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


EmtyValuesMode Enumeration

[image]

Telerik Reporting Q2 2012
EmtyValuesMode Enumeration
See Also Send Feedback
Empty values representation mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum EmtyValuesMode
Visual Basic (Declaration)
Public Enumeration EmtyValuesMode

Members

Member name | Description
Zero |
Approximation |

See Also

Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Class

[image]

Telerik Reporting Q2 2012
FiguresCollection Class
Members See Also Send Feedback
Default figures

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FiguresCollection
Visual Basic (Declaration)
Public Class FiguresCollection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting.Styles..::.FiguresCollection

See Also

FiguresCollection Members
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Members

[image] [image]

Telerik Reporting Q2 2012
FiguresCollection Members
FiguresCollection Class Constructors Methods Properties See Also Send Feedback

The FiguresCollection type exposes the following members.

Constructors

Name | Description
FiguresCollection | Overloaded.

Methods

Name | Description
Add | Overloaded.

Properties

Name | Description
Figures | Gets list of figures

See Also

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
FiguresCollection Constructor
FiguresCollection Class See Also Send Feedback

Overload List

Name | Description
FiguresCollection()()() | Create new instance of FiguresCollection class.
FiguresCollection(Chart) | Create new instance of FiguresCollection class.

See Also

FiguresCollection Class
FiguresCollection Members
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Constructor

[image]

Telerik Reporting Q2 2012
FiguresCollection Constructor
FiguresCollection Class See Also Send Feedback
Create new instance of FiguresCollection class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FiguresCollection()
Visual Basic (Declaration)
Public Sub New

See Also

FiguresCollection Class
FiguresCollection Overload
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Constructor (Chart)

[image]

Telerik Reporting Q2 2012
FiguresCollection Constructor (Chart)
FiguresCollection Class See Also Send Feedback
Create new instance of FiguresCollection class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FiguresCollection(
    Chart chart
)
Visual Basic (Declaration)
Public Sub New ( _
    chart As Chart _
)

Parameters

chart
Type: Telerik.Reporting.Charting..::.Chart
Chart to add figures into collection

See Also

FiguresCollection Class
FiguresCollection Overload
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Methods

[image] [image]

Telerik Reporting Q2 2012
FiguresCollection Methods
FiguresCollection Class See Also Send Feedback

Methods

Name | Description
Add | Overloaded.

See Also

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


Add Method

[image] [image]

Telerik Reporting Q2 2012
FiguresCollection..::.Add Method
FiguresCollection Class See Also Send Feedback

Overload List

Name | Description
Add(String) | Add figure with specified name
Add(List<(Of <(CustomFigure>)>)) | Add list of figures into collection

See Also

FiguresCollection Class
FiguresCollection Members
Telerik.Reporting.Charting.Styles Namespace


Add Method (String)

[image]

Telerik Reporting Q2 2012
FiguresCollection..::.Add Method (String)
FiguresCollection Class See Also Send Feedback
Add figure with specified name

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    string name
)
Visual Basic (Declaration)
Public Sub Add ( _
    name As String _
)

Parameters

name
Type: System..::.String
Name figure for adding

See Also

FiguresCollection Class
Add Overload
Telerik.Reporting.Charting.Styles Namespace


Add Method (List(CustomFigure))

[image]

Telerik Reporting Q2 2012
FiguresCollection..::.Add Method (List<(Of <(<'CustomFigure>)>)>)
FiguresCollection Class See Also Send Feedback
Add list of figures into collection

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Add(
    List<CustomFigure> list
)
Visual Basic (Declaration)
Public Sub Add ( _
    list As List(Of CustomFigure) _
)

Parameters

list
Type: System.Collections.Generic..::.List <(Of <(<' CustomFigure >)>)>
List of figures

See Also

FiguresCollection Class
Add Overload
Telerik.Reporting.Charting.Styles Namespace


FiguresCollection Properties

[image] [image]

Telerik Reporting Q2 2012
FiguresCollection Properties
FiguresCollection Class See Also Send Feedback

The FiguresCollection type exposes the following members.

Properties

Name | Description
Figures | Gets list of figures

See Also

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


Figures Property

[image]

Telerik Reporting Q2 2012
FiguresCollection..::.Figures Property
FiguresCollection Class See Also Send Feedback
Gets list of figures

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List<string> Figures { get; }
Visual Basic (Declaration)
Public ReadOnly Property Figures As List(Of String)

See Also

FiguresCollection Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Class

[image]

Telerik Reporting Q2 2012
FillSettings Class
Members See Also Send Feedback
Fill settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillSettings : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class FillSettings _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillSettings
Telerik.Reporting.Charting.Styles..::.FillSettingsVerticalGradient

See Also

FillSettings Members
Telerik.Reporting.Charting.Styles Namespace


FillSettings Members

[image] [image]

Telerik Reporting Q2 2012
FillSettings Members
FillSettings Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The FillSettings type exposes the following members.

Constructors

Name | Description
FillSettings | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing two objects. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
fillSettingsComplexGradient | Specifies the blend colors for Gradient fill

Properties

Name | Description
BackgroundImage | Specifies the URL of Image file
ComplexGradient | Specifies the blend colors for Gradient fill
GradientAngle | Specifies the Linear gradient fill angle
GradientMode | Specifies the Linear gradient fill mode
HatchStyle | Specifies the style of hatch fill type
ImageAlign | Specifies the Image align mode
ImageDrawMode | Specifies how image should be drawing
ImageFlip | Specifies the image flip settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor

[image] [image]

Telerik Reporting Q2 2012
FillSettings Constructor
FillSettings Class See Also Send Feedback

Overload List

Name | Description
FillSettings()()() | Create new instance of FillSettings class.
FillSettings(HatchStyle) | Constructor for FillSettings for the Hatch fill mode
FillSettings(Object) | Create new instance of FillSettings class.
FillSettings(GradientFillStyle, Single, ColorBlend) | Constructor for FillSettings for the Linear gradient fill mode
FillSettings(ImageDrawMode, String, ImageAlignModes, ImageTileModes) | Constructor for FillSettings for the Image fill mode

See Also

FillSettings Class
FillSettings Members
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor

[image]

Telerik Reporting Q2 2012
FillSettings Constructor
FillSettings Class See Also Send Feedback
Create new instance of FillSettings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettings()
Visual Basic (Declaration)
Public Sub New

See Also

FillSettings Class
FillSettings Overload
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor (HatchStyle)

[image]

Telerik Reporting Q2 2012
FillSettings Constructor (HatchStyle)
FillSettings Class See Also Send Feedback
Constructor for FillSettings for the Hatch fill mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettings(
    HatchStyle style
)
Visual Basic (Declaration)
Public Sub New ( _
    style As HatchStyle _
)

Parameters

style
Type: System.Drawing.Drawing2D..::.HatchStyle
Hatch style

See Also

FillSettings Class
FillSettings Overload
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor (Object)

[image]

Telerik Reporting Q2 2012
FillSettings Constructor (Object)
FillSettings Class See Also Send Feedback
Create new instance of FillSettings class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettings(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

FillSettings Class
FillSettings Overload
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor (GradientFillStyle, Single, ColorBlend)

[image]

Telerik Reporting Q2 2012
FillSettings Constructor (GradientFillStyle, Single, ColorBlend)
FillSettings Class See Also Send Feedback
Constructor for FillSettings for the Linear gradient fill mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettings(
    GradientFillStyle lgMode,
    float lgAngle,
    ColorBlend blend
)
Visual Basic (Declaration)
Public Sub New ( _
    lgMode As GradientFillStyle, _
    lgAngle As Single, _
    blend As ColorBlend _
)

Parameters

lgMode
Type: Telerik.Reporting.Charting.Styles..::.GradientFillStyle
Linear gradient fill mode
lgAngle
Type: System..::.Single
Linear gradient fill angle
blend
Type: Telerik.Reporting.Charting..::.ColorBlend
Specifies the blend colors for Gradient fill

See Also

FillSettings Class
FillSettings Overload
Telerik.Reporting.Charting.Styles Namespace


FillSettings Constructor (ImageDrawMode, String, ImageAlignModes, ImageTileModes)

[image]

Telerik Reporting Q2 2012
FillSettings Constructor (ImageDrawMode, String, ImageAlignModes, ImageTileModes)
FillSettings Class See Also Send Feedback
Constructor for FillSettings for the Image fill mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettings(
    ImageDrawMode idMode,
    string imageURL,
    ImageAlignModes aligneMode,
    ImageTileModes flip
)
Visual Basic (Declaration)
Public Sub New ( _
    idMode As ImageDrawMode, _
    imageURL As String, _
    aligneMode As ImageAlignModes, _
    flip As ImageTileModes _
)

Parameters

idMode
Type: Telerik.Reporting.Charting.Styles..::.ImageDrawMode
Image mode
imageURL
Type: System..::.String
Image path
aligneMode
Type: Telerik.Reporting.Charting.Styles..::.ImageAlignModes
Alignment of image
flip
Type: Telerik.Reporting.Charting.Styles..::.ImageTileModes
Flip mode

See Also

FillSettings Class
FillSettings Overload
Telerik.Reporting.Charting.Styles Namespace


FillSettings Fields

[image] [image]

Telerik Reporting Q2 2012
FillSettings Fields
FillSettings Class See Also Send Feedback

The FillSettings type exposes the following members.

Fields

Name | Description
fillSettingsComplexGradient | Specifies the blend colors for Gradient fill

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


fillSettingsComplexGradient Field

[image]

Telerik Reporting Q2 2012
FillSettings..::.fillSettingsComplexGradient Field
FillSettings Class See Also Send Feedback
Specifies the blend colors for Gradient fill

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ColorBlend fillSettingsComplexGradient
Visual Basic (Declaration)
Protected fillSettingsComplexGradient As ColorBlend

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Methods

[image] [image]

Telerik Reporting Q2 2012
FillSettings Methods
FillSettings Class See Also Send Feedback

The FillSettings type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing two objects. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.Clone Method
FillSettings Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of FillSettings class with the same fields as this object.

Implements

ICloneable..::.Clone()()()

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillSettings..::.Dispose Method
FillSettings Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

FillSettings Class
FillSettings Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.Equals Method
FillSettings Class See Also Send Feedback
Comparing two objects.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object for comparing

Return Value

Whether objects are equal or not

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.GetHashCode Method
FillSettings Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.LoadViewState Method
FillSettings Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.SaveViewState Method
FillSettings Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
FillSettings..::.TrackViewState Method
FillSettings Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Properties

[image] [image]

Telerik Reporting Q2 2012
FillSettings Properties
FillSettings Class See Also Send Feedback

The FillSettings type exposes the following members.

Properties

Name | Description
BackgroundImage | Specifies the URL of Image file
ComplexGradient | Specifies the blend colors for Gradient fill
GradientAngle | Specifies the Linear gradient fill angle
GradientMode | Specifies the Linear gradient fill mode
HatchStyle | Specifies the style of hatch fill type
ImageAlign | Specifies the Image align mode
ImageDrawMode | Specifies how image should be drawing
ImageFlip | Specifies the image flip settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


BackgroundImage Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.BackgroundImage Property
FillSettings Class See Also Send Feedback
Specifies the URL of Image file

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string BackgroundImage { get; set; }
Visual Basic (Declaration)
Public Property BackgroundImage As String

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


ComplexGradient Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.ComplexGradient Property
FillSettings Class See Also Send Feedback
Specifies the blend colors for Gradient fill

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ColorBlend ComplexGradient { get; }
Visual Basic (Declaration)
Public ReadOnly Property ComplexGradient As ColorBlend

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


GradientAngle Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.GradientAngle Property
FillSettings Class See Also Send Feedback
Specifies the Linear gradient fill angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float GradientAngle { get; set; }
Visual Basic (Declaration)
Public Property GradientAngle As Single

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


GradientMode Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.GradientMode Property
FillSettings Class See Also Send Feedback
Specifies the Linear gradient fill mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual GradientFillStyle GradientMode { get; set; }
Visual Basic (Declaration)
Public Overridable Property GradientMode As GradientFillStyle

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


HatchStyle Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.HatchStyle Property
FillSettings Class See Also Send Feedback
Specifies the style of hatch fill type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public HatchStyle HatchStyle { get; set; }
Visual Basic (Declaration)
Public Property HatchStyle As HatchStyle

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


ImageAlign Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.ImageAlign Property
FillSettings Class See Also Send Feedback
Specifies the Image align mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageAlignModes ImageAlign { get; set; }
Visual Basic (Declaration)
Public Property ImageAlign As ImageAlignModes

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


ImageDrawMode Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.ImageDrawMode Property
FillSettings Class See Also Send Feedback
Specifies how image should be drawing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageDrawMode ImageDrawMode { get; set; }
Visual Basic (Declaration)
Public Property ImageDrawMode As ImageDrawMode

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


ImageFlip Property

[image]

Telerik Reporting Q2 2012
FillSettings..::.ImageFlip Property
FillSettings Class See Also Send Feedback
Specifies the image flip settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageTileModes ImageFlip { get; set; }
Visual Basic (Declaration)
Public Property ImageFlip As ImageTileModes

See Also

FillSettings Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Class

[image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Class
Members See Also Send Feedback
Vertical gradient default fill settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillSettingsVerticalGradient : FillSettings
Visual Basic (Declaration)
Public Class FillSettingsVerticalGradient _
    Inherits FillSettings

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillSettings
Telerik.Reporting.Charting.Styles..::.FillSettingsVerticalGradient

See Also

FillSettingsVerticalGradient Members
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Members

[image] [image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Members
FillSettingsVerticalGradient Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The FillSettingsVerticalGradient type exposes the following members.

Constructors

Name | Description
FillSettingsVerticalGradient | Initializes a new instance of the FillSettingsVerticalGradient class

Methods

Name | Description
Clone | Clone this object (Inherited from FillSettings.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing two objects. (Inherited from FillSettings.)
GetHashCode | Gets hash code (Inherited from FillSettings.)
LoadViewState | Load data from ViewState (Inherited from FillSettings.)
SaveViewState | Save data to ViewState (Inherited from FillSettings.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillSettings.)

Fields

Name | Description
fillSettingsComplexGradient | Specifies the blend colors for Gradient fill (Inherited from FillSettings.)

Properties

Name | Description
BackgroundImage | Specifies the URL of Image file (Inherited from FillSettings.)
ComplexGradient | Specifies the blend colors for Gradient fill (Inherited from FillSettings.)
GradientAngle | Specifies the Linear gradient fill angle (Inherited from FillSettings.)
GradientMode | Specifies the Linear gradient fill mode (Overrides FillSettings..::.GradientMode.)
HatchStyle | Specifies the style of hatch fill type (Inherited from FillSettings.)
ImageAlign | Specifies the Image align mode (Inherited from FillSettings.)
ImageDrawMode | Specifies how image should be drawing (Inherited from FillSettings.)
ImageFlip | Specifies the image flip settings (Inherited from FillSettings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Constructor

[image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Constructor
FillSettingsVerticalGradient Class See Also Send Feedback
Initializes a new instance of the FillSettingsVerticalGradient class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillSettingsVerticalGradient()
Visual Basic (Declaration)
Public Sub New

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Fields

[image] [image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Fields
FillSettingsVerticalGradient Class See Also Send Feedback

The FillSettingsVerticalGradient type exposes the following members.

Fields

Name | Description
fillSettingsComplexGradient | Specifies the blend colors for Gradient fill (Inherited from FillSettings.)

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Methods

[image] [image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Methods
FillSettingsVerticalGradient Class See Also Send Feedback

The FillSettingsVerticalGradient type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from FillSettings.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing two objects. (Inherited from FillSettings.)
GetHashCode | Gets hash code (Inherited from FillSettings.)
LoadViewState | Load data from ViewState (Inherited from FillSettings.)
SaveViewState | Save data to ViewState (Inherited from FillSettings.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillSettings.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient..::.Dispose Method
FillSettingsVerticalGradient Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

FillSettingsVerticalGradient Class
FillSettingsVerticalGradient Members
Telerik.Reporting.Charting.Styles Namespace


FillSettingsVerticalGradient Properties

[image] [image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient Properties
FillSettingsVerticalGradient Class See Also Send Feedback

The FillSettingsVerticalGradient type exposes the following members.

Properties

Name | Description
BackgroundImage | Specifies the URL of Image file (Inherited from FillSettings.)
ComplexGradient | Specifies the blend colors for Gradient fill (Inherited from FillSettings.)
GradientAngle | Specifies the Linear gradient fill angle (Inherited from FillSettings.)
GradientMode | Specifies the Linear gradient fill mode (Overrides FillSettings..::.GradientMode.)
HatchStyle | Specifies the style of hatch fill type (Inherited from FillSettings.)
ImageAlign | Specifies the Image align mode (Inherited from FillSettings.)
ImageDrawMode | Specifies how image should be drawing (Inherited from FillSettings.)
ImageFlip | Specifies the image flip settings (Inherited from FillSettings.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


GradientMode Property

[image]

Telerik Reporting Q2 2012
FillSettingsVerticalGradient..::.GradientMode Property
FillSettingsVerticalGradient Class See Also Send Feedback
Specifies the Linear gradient fill mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override GradientFillStyle GradientMode { get; set; }
Visual Basic (Declaration)
Public Overrides Property GradientMode As GradientFillStyle

See Also

FillSettingsVerticalGradient Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Class

[image]

Telerik Reporting Q2 2012
FillStyle Class
Members See Also Send Feedback
Fill style base class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyle : StateManagedObject, ICloneable
Visual Basic (Declaration)
Public Class FillStyle _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleChart
Telerik.Reporting.Charting.Styles..::.FillStyleMarkedZones
Telerik.Reporting.Charting.Styles..::.FillStylePlotArea
Telerik.Reporting.Charting.Styles..::.FillStyleSeries
Telerik.Reporting.Charting.Styles..::.FillStyleSeriesPoint
Telerik.Reporting.Charting.Styles..::.FillStyleTitle

See Also

FillStyle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyle Members

[image] [image]

Telerik Reporting Q2 2012
FillStyle Members
FillStyle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStyle type exposes the following members.

Constructors

Name | Description
FillStyle | Overloaded.

Methods

Name | Description
Clone | Clone of this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Properties

Name | Description
FillSettings | Gets and sets fill settings
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used
GammaCorrection | Specifies whether gamma correction should be used
MainColor | Gets and sets the main color of figure background
MainColorOpacity | Gets and sets the main color opacity coefficient
SecondColor | Gets and sets the second color of figure background
SecondColorOpacity | Gets and sets the second color opacity coefficient
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor

[image] [image]

Telerik Reporting Q2 2012
FillStyle Constructor
FillStyle Class See Also Send Feedback

Overload List

Name | Description
FillStyle()()() | Create new instance of FillStyle class.
FillStyle(Color) | Create new instance of FillStyle class.
FillStyle(Object) | Create new instance of FillStyle class.
FillStyle(Color, Color) | Create new instance of FillStyle class.
FillStyle(Color, FillType) | Create new instance of FillStyle class.
FillStyle(Color, Color, FillType) | Create new instance of FillStyle class.
FillStyle(Color, Color, FillSettings, Boolean, FillType) | Create new instance of FillStyle class.

See Also

FillStyle Class
FillStyle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor

[image]

Telerik Reporting Q2 2012
FillStyle Constructor
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Color)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Color)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Color mainColor
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Object)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Object)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Object container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object _
)

Parameters

container
Type: System..::.Object
Container element

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Color, Color)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Color, Color)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Color mainColor,
    Color secondColor
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color, _
    secondColor As Color _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color
secondColor
Type: System.Drawing..::.Color
Second color

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Color, FillType)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Color, FillType)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Color mainColor,
    FillType fillType
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color, _
    fillType As FillType _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color
fillType
Type: Telerik.Reporting.Charting.Styles..::.FillType
One of FillType values(Solid, Gradient, ComplexGradient, Image,Hatch)

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Color, Color, FillType)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Color, Color, FillType)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Color mainColor,
    Color secondColor,
    FillType fillType
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color, _
    secondColor As Color, _
    fillType As FillType _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color
secondColor
Type: System.Drawing..::.Color
Second color
fillType
Type: Telerik.Reporting.Charting.Styles..::.FillType
One of FillType values(Solid, Gradient, ComplexGradient, Image,Hatch)

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Constructor (Color, Color, FillSettings, Boolean, FillType)

[image]

Telerik Reporting Q2 2012
FillStyle Constructor (Color, Color, FillSettings, Boolean, FillType)
FillStyle Class See Also Send Feedback
Create new instance of FillStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle(
    Color mainColor,
    Color secondColor,
    FillSettings fillSettings,
    bool gammaCorrection,
    FillType fillType
)
Visual Basic (Declaration)
Public Sub New ( _
    mainColor As Color, _
    secondColor As Color, _
    fillSettings As FillSettings, _
    gammaCorrection As Boolean, _
    fillType As FillType _
)

Parameters

mainColor
Type: System.Drawing..::.Color
Main color
secondColor
Type: System.Drawing..::.Color
Second color
fillSettings
Type: Telerik.Reporting.Charting.Styles..::.FillSettings
Fill settings
gammaCorrection
Type: System..::.Boolean
Specifies whether gamma correction should be used
fillType
Type: Telerik.Reporting.Charting.Styles..::.FillType
One of FillType values(Solid, Gradient, ComplexGradient, Image,Hatch)

See Also

FillStyle Class
FillStyle Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyle Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyle Methods
FillStyle Class See Also Send Feedback

The FillStyle type exposes the following members.

Methods

Name | Description
Clone | Clone of this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.Clone Method
FillStyle Class See Also Send Feedback
Clone of this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

New instance of FillStyle class with the same fields as this object

Implements

ICloneable..::.Clone()()()

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyle..::.Dispose Method
FillStyle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

FillStyle Class
FillStyle Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
FillStyle..::.Dispose Method (Boolean)
FillStyle Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

FillStyle Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.Equals Method
FillStyle Class See Also Send Feedback
Comparing of two objects

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare

Return Value

Whether objects are equal or not

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.GetHashCode Method
FillStyle Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.LoadViewState Method
FillStyle Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.SaveViewState Method
FillStyle Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
FillStyle..::.TrackViewState Method
FillStyle Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyle Properties
FillStyle Class See Also Send Feedback

The FillStyle type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used
GammaCorrection | Specifies whether gamma correction should be used
MainColor | Gets and sets the main color of figure background
MainColorOpacity | Gets and sets the main color opacity coefficient
SecondColor | Gets and sets the second color of figure background
SecondColorOpacity | Gets and sets the second color opacity coefficient
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillSettings Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.FillSettings Property
FillStyle Class See Also Send Feedback
Gets and sets fill settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual FillSettings FillSettings { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FillSettings As FillSettings

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.FillType Property
FillStyle Class See Also Send Feedback
Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual FillType FillType { get; set; }
Visual Basic (Declaration)
Public Overridable Property FillType As FillType

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


GammaCorrection Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.GammaCorrection Property
FillStyle Class See Also Send Feedback
Specifies whether gamma correction should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool GammaCorrection { get; set; }
Visual Basic (Declaration)
Public Property GammaCorrection As Boolean

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.MainColor Property
FillStyle Class See Also Send Feedback
Gets and sets the main color of figure background

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overridable Property MainColor As Color

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


MainColorOpacity Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.MainColorOpacity Property
FillStyle Class See Also Send Feedback
Gets and sets the main color opacity coefficient

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public byte MainColorOpacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property MainColorOpacity As Byte

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


SecondColor Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.SecondColor Property
FillStyle Class See Also Send Feedback
Gets and sets the second color of figure background

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Color SecondColor { get; set; }
Visual Basic (Declaration)
Public Overridable Property SecondColor As Color

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


SecondColorOpacity Property

[image]

Telerik Reporting Q2 2012
FillStyle..::.SecondColorOpacity Property
FillStyle Class See Also Send Feedback
Gets and sets the second color opacity coefficient

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public byte SecondColorOpacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property SecondColorOpacity As Byte

See Also

FillStyle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Class

[image]

Telerik Reporting Q2 2012
FillStyleChart Class
Members See Also Send Feedback
Chart's background fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyleChart : FillStyle
Visual Basic (Declaration)
Public Class FillStyleChart _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleChart

See Also

FillStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Members

[image] [image]

Telerik Reporting Q2 2012
FillStyleChart Members
FillStyleChart Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStyleChart type exposes the following members.

Constructors

Name | Description
FillStyleChart | Create new instance of FillStyleChart class.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets or sets the color of the data series. (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Constructor

[image]

Telerik Reporting Q2 2012
FillStyleChart Constructor
FillStyleChart Class See Also Send Feedback
Create new instance of FillStyleChart class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleChart()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyleChart Methods
FillStyleChart Class See Also Send Feedback

The FillStyleChart type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyleChart..::.Dispose Method
FillStyleChart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStyleChart Class
FillStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleChart Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyleChart Properties
FillStyleChart Class See Also Send Feedback

The FillStyleChart type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets or sets the color of the data series. (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

[image]

Telerik Reporting Q2 2012
FillStyleChart..::.FillType Property
FillStyleChart Class See Also Send Feedback
Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override FillType FillType { get; set; }
Visual Basic (Declaration)
Public Overrides Property FillType As FillType

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStyleChart..::.MainColor Property
FillStyleChart Class See Also Send Feedback
Gets or sets the color of the data series.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property MainColor As Color

See Also

FillStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Class

[image]

Telerik Reporting Q2 2012
FillStyleMarkedZones Class
Members See Also Send Feedback
Marked zone fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyleMarkedZones : FillStyle
Visual Basic (Declaration)
Public Class FillStyleMarkedZones _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleMarkedZones

See Also

FillStyleMarkedZones Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Members

[image] [image]

Telerik Reporting Q2 2012
FillStyleMarkedZones Members
FillStyleMarkedZones Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStyleMarkedZones type exposes the following members.

Constructors

Name | Description
FillStyleMarkedZones | Initializes a new instance of the FillStyleMarkedZones class

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart marked zone main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Constructor

[image]

Telerik Reporting Q2 2012
FillStyleMarkedZones Constructor
FillStyleMarkedZones Class See Also Send Feedback
Initializes a new instance of the FillStyleMarkedZones class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleMarkedZones()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyleMarkedZones Methods
FillStyleMarkedZones Class See Also Send Feedback

The FillStyleMarkedZones type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyleMarkedZones..::.Dispose Method
FillStyleMarkedZones Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStyleMarkedZones Class
FillStyleMarkedZones Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleMarkedZones Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyleMarkedZones Properties
FillStyleMarkedZones Class See Also Send Feedback

The FillStyleMarkedZones type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart marked zone main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

[image]

Telerik Reporting Q2 2012
FillStyleMarkedZones..::.FillType Property
FillStyleMarkedZones Class See Also Send Feedback
Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override FillType FillType { get; set; }
Visual Basic (Declaration)
Public Overrides Property FillType As FillType

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStyleMarkedZones..::.MainColor Property
FillStyleMarkedZones Class See Also Send Feedback
Chart marked zone main color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property MainColor As Color

See Also

FillStyleMarkedZones Class
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Class

[image]

Telerik Reporting Q2 2012
FillStylePlotArea Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStylePlotArea : FillStyle
Visual Basic (Declaration)
Public Class FillStylePlotArea _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStylePlotArea

See Also

FillStylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Members

[image] [image]

Telerik Reporting Q2 2012
FillStylePlotArea Members
FillStylePlotArea Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStylePlotArea type exposes the following members.

Constructors

Name | Description
FillStylePlotArea | Create new instance of FillStylePlotArea class.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart plot area main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Chart plot area second color (Overrides FillStyle..::.SecondColor.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Constructor

[image]

Telerik Reporting Q2 2012
FillStylePlotArea Constructor
FillStylePlotArea Class See Also Send Feedback
Create new instance of FillStylePlotArea class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStylePlotArea()
Visual Basic (Declaration)
Public Sub New

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Methods

[image] [image]

Telerik Reporting Q2 2012
FillStylePlotArea Methods
FillStylePlotArea Class See Also Send Feedback

The FillStylePlotArea type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStylePlotArea..::.Dispose Method
FillStylePlotArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStylePlotArea Class
FillStylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


FillStylePlotArea Properties

[image] [image]

Telerik Reporting Q2 2012
FillStylePlotArea Properties
FillStylePlotArea Class See Also Send Feedback

The FillStylePlotArea type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart plot area main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Chart plot area second color (Overrides FillStyle..::.SecondColor.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

[image]

Telerik Reporting Q2 2012
FillStylePlotArea..::.FillType Property
FillStylePlotArea Class See Also Send Feedback
Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override FillType FillType { get; set; }
Visual Basic (Declaration)
Public Overrides Property FillType As FillType

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStylePlotArea..::.MainColor Property
FillStylePlotArea Class See Also Send Feedback
Chart plot area main color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property MainColor As Color

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


SecondColor Property

[image]

Telerik Reporting Q2 2012
FillStylePlotArea..::.SecondColor Property
FillStylePlotArea Class See Also Send Feedback
Chart plot area second color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color SecondColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property SecondColor As Color

See Also

FillStylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Class

[image]

Telerik Reporting Q2 2012
FillStyleSeries Class
Members See Also Send Feedback
Series fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyleSeries : FillStyle
Visual Basic (Declaration)
Public Class FillStyleSeries _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleSeries

See Also

FillStyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Members

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries Members
FillStyleSeries Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The FillStyleSeries type exposes the following members.

Constructors

Name | Description
FillStyleSeries | Overloaded.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Fields

Name | Description
Empty | FillStyleSeries with default settings

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Inherited from FillStyle.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets or sets the color of the data series. (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets or sets the color of the data series. (Overrides FillStyle..::.SecondColor.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Constructor

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries Constructor
FillStyleSeries Class See Also Send Feedback

Overload List

Name | Description
FillStyleSeries()()() | Create new instance of FillStyleSeries class.
FillStyleSeries(ChartSeries) | Create new instance of FillStyleSeries class.

See Also

FillStyleSeries Class
FillStyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Constructor

[image]

Telerik Reporting Q2 2012
FillStyleSeries Constructor
FillStyleSeries Class See Also Send Feedback
Create new instance of FillStyleSeries class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeries()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyleSeries Class
FillStyleSeries Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
FillStyleSeries Constructor (ChartSeries)
FillStyleSeries Class See Also Send Feedback
Create new instance of FillStyleSeries class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeries(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Container element(series)

See Also

FillStyleSeries Class
FillStyleSeries Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Fields

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries Fields
FillStyleSeries Class See Also Send Feedback

The FillStyleSeries type exposes the following members.

Fields

Name | Description
Empty | FillStyleSeries with default settings

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
FillStyleSeries..::.Empty Field
FillStyleSeries Class See Also Send Feedback
FillStyleSeries with default settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly FillStyleSeries Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As FillStyleSeries

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries Methods
FillStyleSeries Class See Also Send Feedback

The FillStyleSeries type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries..::.Dispose Method
FillStyleSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStyleSeries Class
FillStyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeries Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeries Properties
FillStyleSeries Class See Also Send Feedback

The FillStyleSeries type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Inherited from FillStyle.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets or sets the color of the data series. (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets or sets the color of the data series. (Overrides FillStyle..::.SecondColor.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStyleSeries..::.MainColor Property
FillStyleSeries Class See Also Send Feedback
Gets or sets the color of the data series.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property MainColor As Color

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


SecondColor Property

[image]

Telerik Reporting Q2 2012
FillStyleSeries..::.SecondColor Property
FillStyleSeries Class See Also Send Feedback
Gets or sets the color of the data series.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color SecondColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property SecondColor As Color

See Also

FillStyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Class

[image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Class
Members See Also Send Feedback
Series points fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyleSeriesPoint : FillStyle
Visual Basic (Declaration)
Public Class FillStyleSeriesPoint _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleSeriesPoint

See Also

FillStyleSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Members

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Members
FillStyleSeriesPoint Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStyleSeriesPoint type exposes the following members.

Constructors

Name | Description
FillStyleSeriesPoint | Overloaded.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Inherited from FillStyle.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets and sets the main color of figure background (Inherited from FillStyle.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Constructor

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Constructor
FillStyleSeriesPoint Class See Also Send Feedback

Overload List

Name | Description
FillStyleSeriesPoint()()() | Create new instance of FillStyleSeriesPoint class.
FillStyleSeriesPoint(Object) | Create new instance of FillStyleSeriesPoint class.

See Also

FillStyleSeriesPoint Class
FillStyleSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Constructor

[image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Constructor
FillStyleSeriesPoint Class See Also Send Feedback
Create new instance of FillStyleSeriesPoint class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeriesPoint()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyleSeriesPoint Class
FillStyleSeriesPoint Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Constructor (Object)

[image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Constructor (Object)
FillStyleSeriesPoint Class See Also Send Feedback
Create new instance of FillStyleSeriesPoint class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeriesPoint(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

FillStyleSeriesPoint Class
FillStyleSeriesPoint Overload
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Methods
FillStyleSeriesPoint Class See Also Send Feedback

The FillStyleSeriesPoint type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint..::.Dispose Method
FillStyleSeriesPoint Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStyleSeriesPoint Class
FillStyleSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleSeriesPoint Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyleSeriesPoint Properties
FillStyleSeriesPoint Class See Also Send Feedback

The FillStyleSeriesPoint type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Inherited from FillStyle.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Gets and sets the main color of figure background (Inherited from FillStyle.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyleSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Class

[image]

Telerik Reporting Q2 2012
FillStyleTitle Class
Members See Also Send Feedback
Title's background fill style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FillStyleTitle : FillStyle
Visual Basic (Declaration)
Public Class FillStyleTitle _
    Inherits FillStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.FillStyle
Telerik.Reporting.Charting.Styles..::.FillStyleTitle

See Also

FillStyleTitle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Members

[image] [image]

Telerik Reporting Q2 2012
FillStyleTitle Members
FillStyleTitle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FillStyleTitle type exposes the following members.

Constructors

Name | Description
FillStyleTitle | Initializes a new instance of the FillStyleTitle class

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart title main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Constructor

[image]

Telerik Reporting Q2 2012
FillStyleTitle Constructor
FillStyleTitle Class See Also Send Feedback
Initializes a new instance of the FillStyleTitle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleTitle()
Visual Basic (Declaration)
Public Sub New

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Methods

[image] [image]

Telerik Reporting Q2 2012
FillStyleTitle Methods
FillStyleTitle Class See Also Send Feedback

The FillStyleTitle type exposes the following members.

Methods

Name | Description
Clone | Clone of this object (Inherited from FillStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from FillStyle.)
GetHashCode | Gets hash code (Inherited from FillStyle.)
LoadViewState | Load data from ViewState (Inherited from FillStyle.)
SaveViewState | Save data to ViewState (Inherited from FillStyle.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from FillStyle.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
FillStyleTitle..::.Dispose Method
FillStyleTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from FillStyle.)

See Also

FillStyleTitle Class
FillStyleTitle Members
Telerik.Reporting.Charting.Styles Namespace


FillStyleTitle Properties

[image] [image]

Telerik Reporting Q2 2012
FillStyleTitle Properties
FillStyleTitle Class See Also Send Feedback

The FillStyleTitle type exposes the following members.

Properties

Name | Description
FillSettings | Gets and sets fill settings (Inherited from FillStyle.)
FillType | Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used (Overrides FillStyle..::.FillType.)
GammaCorrection | Specifies whether gamma correction should be used (Inherited from FillStyle.)
MainColor | Chart title main color (Overrides FillStyle..::.MainColor.)
MainColorOpacity | Gets and sets the main color opacity coefficient (Inherited from FillStyle.)
SecondColor | Gets and sets the second color of figure background (Inherited from FillStyle.)
SecondColorOpacity | Gets and sets the second color opacity coefficient (Inherited from FillStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillType Property

[image]

Telerik Reporting Q2 2012
FillStyleTitle..::.FillType Property
FillStyleTitle Class See Also Send Feedback
Specifies which of fill styles (Hatch, Solid, Image, Gradient) should be used

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override FillType FillType { get; set; }
Visual Basic (Declaration)
Public Overrides Property FillType As FillType

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


MainColor Property

[image]

Telerik Reporting Q2 2012
FillStyleTitle..::.MainColor Property
FillStyleTitle Class See Also Send Feedback
Chart title main color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color MainColor { get; set; }
Visual Basic (Declaration)
Public Overrides Property MainColor As Color

See Also

FillStyleTitle Class
Telerik.Reporting.Charting.Styles Namespace


FillType Enumeration

[image]

Telerik Reporting Q2 2012
FillType Enumeration
See Also Send Feedback
Fill types listing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum FillType
Visual Basic (Declaration)
Public Enumeration FillType

Members

Member name | Description
Solid | Element is filled by one color.
Gradient | Element is filled by two color.
ComplexGradient | Element is filled by colors at specified positions.
Hatch | Element is filled by Hatch type(standard).
Image | Element is filled by image.

See Also

Telerik.Reporting.Charting.Styles Namespace


GradientFillStyle Enumeration

[image]

Telerik Reporting Q2 2012
GradientFillStyle Enumeration
See Also Send Feedback
Specifies the direction of a linear gradient.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum GradientFillStyle
Visual Basic (Declaration)
Public Enumeration GradientFillStyle

Members

Member name | Description
Horizontal |
Vertical |
ForwardDiagonal |
BackwardDiagonal |
Center |
Circle |

See Also

Telerik.Reporting.Charting.Styles Namespace


ImageAlignModes Enumeration

[image]

Telerik Reporting Q2 2012
ImageAlignModes Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ImageAlignModes
Visual Basic (Declaration)
Public Enumeration ImageAlignModes

Members

Member name | Description
Top | Image is located at Top of element.
Bottom | Image is located at Bottom of element.
Right | Image is located at Right of element.
Left | Image is located at Left of element.
Center | Image is located at Center of element.
TopRight | Image is located at TopRight of element.
TopLeft | Image is located at TopLeft of element.
BottomRight | Image is located at BottomRight of element.
BottomLeft | Image is located at BottomLeft of element.

See Also

Telerik.Reporting.Charting.Styles Namespace


ImageDrawMode Enumeration

[image]

Telerik Reporting Q2 2012
ImageDrawMode Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ImageDrawMode
Visual Basic (Declaration)
Public Enumeration ImageDrawMode

Members

Member name | Description
Align | Image is aligned by specified alignment.
Stretch | Stretch image.
Flip | Flip image.

See Also

Telerik.Reporting.Charting.Styles Namespace


ImageQuality Enumeration

[image]

Telerik Reporting Q2 2012
ImageQuality Enumeration
See Also Send Feedback
Specifies the quality at which image is rendered.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ImageQuality
Visual Basic (Declaration)
Public Enumeration ImageQuality

Members

Member name | Description
Default | Specifies the default mode.
AntiAlias | Specifies anti aliased rendering.
HighQuality | Specifies high quality, low speed rendering.
None | Specifies no anti aliasing.

See Also

Telerik.Reporting.Charting.Styles Namespace


ImageTileModes Enumeration

[image]

Telerik Reporting Q2 2012
ImageTileModes Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ImageTileModes
Visual Basic (Declaration)
Public Enumeration ImageTileModes

Members

Member name | Description
Flip | Fill element by image that repeats by X and Y.
FlipX | Fill element by image that flips by X.
FlipY | Fill element by image that flips by Y.
FlipXY | Fill element by image that flips by X and Y.

See Also

Telerik.Reporting.Charting.Styles Namespace


LabelItemsCompositionTypes Enumeration

[image]

Telerik Reporting Q2 2012
LabelItemsCompositionTypes Enumeration
See Also Send Feedback
Specifies how marker and text block are situated related to each other.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum LabelItemsCompositionTypes
Visual Basic (Declaration)
Public Enumeration LabelItemsCompositionTypes

Members

Member name | Description
ColumnImageText | Marker at left, TextBlock - at right
ColumnTextImage | Marker at right, TextBlock - at left
RowImageText | Marker at top, TextBlock - at bottom
RowTextImage | Marker at bottom, TextBlock - at top
None | Marker and TextBlock use Position-AlignedPosition. Default value.

See Also

Telerik.Reporting.Charting.Styles Namespace


LabelLocation Enumeration

[image]

Telerik Reporting Q2 2012
LabelLocation Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum LabelLocation
Visual Basic (Declaration)
Public Enumeration LabelLocation

Members

Member name | Description
InsidePlotArea | Inside PlotArea location
OutsidePlotArea | Outside PlotArea location

See Also

Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Class

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Class
Members See Also Send Feedback
Base class for a chart Margins and Paddings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class LayoutDecoratorBase : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class LayoutDecoratorBase _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Telerik.Reporting.Charting.Styles..::.ChartMargins
Telerik.Reporting.Charting.Styles..::.ChartPaddings

See Also

LayoutDecoratorBase Members
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Members

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Members
LayoutDecoratorBase Class Constructors Methods Operators Properties Explicit Interface Implementations See Also Send Feedback

The LayoutDecoratorBase type exposes the following members.

Constructors

Name | Description
LayoutDecoratorBase | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object
Dispose | Overloaded.
Equals | Checks whether objects are equal (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Operators

Name | Description
Equality | Operator comparing
Inequality | Operator not equal

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height.
Left | Sets the left side in pixels or percents of the chart's width.
Right | Sets the right side in pixels or percents of the chart's width.
Top | Sets the top side in pixels or percents of the chart's height.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor
LayoutDecoratorBase Class See Also Send Feedback

Overload List

Name | Description
LayoutDecoratorBase()()() | Creates new instance of LayoutDecoratorBase class.
LayoutDecoratorBase(Object) | Creates new instance of LayoutDecoratorBase class.
LayoutDecoratorBase(Unit) | Creates new instance of LayoutDecoratorBase class.
LayoutDecoratorBase(Int32, Int32, Int32, Int32) | Creates new instance of LayoutDecoratorBase class.
LayoutDecoratorBase(Unit, Unit, Unit, Unit) | Creates new instance of LayoutDecoratorBase class.
LayoutDecoratorBase(Object, Unit, Unit, Unit, Unit) | Creates new instance of LayoutDecoratorBase class.

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase()
Visual Basic (Declaration)
Public Sub New

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor (Object)

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor (Object)
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor (Unit)

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor (Unit)
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase(
    Unit value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Unit _
)

Parameters

value
Type: Telerik.Reporting.Charting.Styles..::.Unit

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor (Int32, Int32, Int32, Int32)

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor (Int32, Int32, Int32, Int32)
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase(
    int top,
    int right,
    int bottom,
    int left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Integer, _
    right As Integer, _
    bottom As Integer, _
    left As Integer _
)

Parameters

top
Type: System..::.Int32
Top side
right
Type: System..::.Int32
Right side
bottom
Type: System..::.Int32
Bottom side
left
Type: System..::.Int32
Left side

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor (Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor (Unit, Unit, Unit, Unit)
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase(
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top side
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right side
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom side
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left side

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Constructor (Object, Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Constructor (Object, Unit, Unit, Unit, Unit)
LayoutDecoratorBase Class See Also Send Feedback
Creates new instance of LayoutDecoratorBase class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutDecoratorBase(
    Object containerObject,
    Unit top,
    Unit right,
    Unit bottom,
    Unit left
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object, _
    top As Unit, _
    right As Unit, _
    bottom As Unit, _
    left As Unit _
)

Parameters

containerObject
Type: System..::.Object
Container element
top
Type: Telerik.Reporting.Charting.Styles..::.Unit
Top side
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
Right side
bottom
Type: Telerik.Reporting.Charting.Styles..::.Unit
Bottom side
left
Type: Telerik.Reporting.Charting.Styles..::.Unit
Left side

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Methods

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Methods
LayoutDecoratorBase Class See Also Send Feedback

The LayoutDecoratorBase type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
CopyFrom | Copy fields from object
Dispose | Overloaded.
Equals | Checks whether objects are equal (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Clone Method
LayoutDecoratorBase Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

New instance of LayoutDecoratorBase class with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


CopyFrom Method

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.CopyFrom Method
LayoutDecoratorBase Class See Also Send Feedback
Copy fields from object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void CopyFrom(
    LayoutDecoratorBase layoutDecorator
)
Visual Basic (Declaration)
Public Sub CopyFrom ( _
    layoutDecorator As LayoutDecoratorBase _
)

Parameters

layoutDecorator
Type: Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Object to copy from

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Dispose Method
LayoutDecoratorBase Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

LayoutDecoratorBase Class
LayoutDecoratorBase Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Equals Method
LayoutDecoratorBase Class See Also Send Feedback
Checks whether objects are equal

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare

Return Value

Result of comparing

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.GetHashCode Method
LayoutDecoratorBase Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Operators

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Operators
LayoutDecoratorBase Class See Also Send Feedback

The LayoutDecoratorBase type exposes the following members.

Operators

Name | Description
Equality | Operator comparing
Inequality | Operator not equal

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Equality Operator
LayoutDecoratorBase Class See Also Send Feedback
Operator comparing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    LayoutDecoratorBase layoutDecoratorOne,
    LayoutDecoratorBase layoutDecoratorTwo
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    layoutDecoratorOne As LayoutDecoratorBase, _
    layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean

Parameters

layoutDecoratorOne
Type: Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
First object for comparing
layoutDecoratorTwo
Type: Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Second object for comparing

Return Value

Result of comparing

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Inequality Operator
LayoutDecoratorBase Class See Also Send Feedback
Operator not equal

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    LayoutDecoratorBase layoutDecoratorOne,
    LayoutDecoratorBase layoutDecoratorTwo
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    layoutDecoratorOne As LayoutDecoratorBase, _
    layoutDecoratorTwo As LayoutDecoratorBase _
) As Boolean

Parameters

layoutDecoratorOne
Type: Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
First object for comparing
layoutDecoratorTwo
Type: Telerik.Reporting.Charting.Styles..::.LayoutDecoratorBase
Second object for comparing

Return Value

Whether objects are not equal

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


LayoutDecoratorBase Properties

[image] [image]

Telerik Reporting Q2 2012
LayoutDecoratorBase Properties
LayoutDecoratorBase Class See Also Send Feedback

The LayoutDecoratorBase type exposes the following members.

Properties

Name | Description
Bottom | Sets the bottom side in pixels or percents of the chart's height.
Left | Sets the left side in pixels or percents of the chart's width.
Right | Sets the right side in pixels or percents of the chart's width.
Top | Sets the top side in pixels or percents of the chart's height.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Bottom Property
LayoutDecoratorBase Class See Also Send Feedback
Sets the bottom side in pixels or percents of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Overridable Property Bottom As Unit

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Left Property

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Left Property
LayoutDecoratorBase Class See Also Send Feedback
Sets the left side in pixels or percents of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Left { get; set; }
Visual Basic (Declaration)
Public Overridable Property Left As Unit

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Right Property

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Right Property
LayoutDecoratorBase Class See Also Send Feedback
Sets the right side in pixels or percents of the chart's width.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Right { get; set; }
Visual Basic (Declaration)
Public Overridable Property Right As Unit

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


Top Property

[image]

Telerik Reporting Q2 2012
LayoutDecoratorBase..::.Top Property
LayoutDecoratorBase Class See Also Send Feedback
Sets the top side in pixels or percents of the chart's height.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Unit Top { get; set; }
Visual Basic (Declaration)
Public Overridable Property Top As Unit

See Also

LayoutDecoratorBase Class
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Class

[image]

Telerik Reporting Q2 2012
LayoutStyle Class
Members See Also Send Feedback
Base appearance settings for any element being calculated

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class LayoutStyle : Style
Visual Basic (Declaration)
Public Class LayoutStyle _
    Inherits Style

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleChart
Telerik.Reporting.Charting.Styles..::.StyleChartDataTable
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StylePlotArea
Telerik.Reporting.Charting.Styles..::.StyleTextBlock

See Also

LayoutStyle Members
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Members

[image] [image]

Telerik Reporting Q2 2012
LayoutStyle Members
LayoutStyle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LayoutStyle type exposes the following members.

Constructors

Name | Description
LayoutStyle | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from Style.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Dimensions | Specifies the elements Dimensions property
Position | Specifies the elements Position property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor

[image] [image]

Telerik Reporting Q2 2012
LayoutStyle Constructor
LayoutStyle Class See Also Send Feedback

Overload List

Name | Description
LayoutStyle(Object) | Creates new instance of LayoutStyle class.
LayoutStyle(Dimensions) | Creates new instance of LayoutStyle class.
LayoutStyle(Position) | Creates new instance of LayoutStyle class.
LayoutStyle(Position, Dimensions) | Creates new instance of LayoutStyle class.
LayoutStyle(StyleBorder, Boolean, ShadowStyle, Position, Dimensions) | Creates new instance of LayoutStyle class.

See Also

LayoutStyle Class
LayoutStyle Members
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor (Object)

[image]

Telerik Reporting Q2 2012
LayoutStyle Constructor (Object)
LayoutStyle Class See Also Send Feedback
Creates new instance of LayoutStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutStyle(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

LayoutStyle Class
LayoutStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor (Dimensions)

[image]

Telerik Reporting Q2 2012
LayoutStyle Constructor (Dimensions)
LayoutStyle Class See Also Send Feedback
Creates new instance of LayoutStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutStyle(
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As Dimensions _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions of element.

See Also

LayoutStyle Class
LayoutStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor (Position)

[image]

Telerik Reporting Q2 2012
LayoutStyle Constructor (Position)
LayoutStyle Class See Also Send Feedback
Creates new instance of LayoutStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutStyle(
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Position _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position of element

See Also

LayoutStyle Class
LayoutStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor (Position, Dimensions)

[image]

Telerik Reporting Q2 2012
LayoutStyle Constructor (Position, Dimensions)
LayoutStyle Class See Also Send Feedback
Creates new instance of LayoutStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutStyle(
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position of element
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions of element.

See Also

LayoutStyle Class
LayoutStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Constructor (StyleBorder, Boolean, ShadowStyle, Position, Dimensions)

[image]

Telerik Reporting Q2 2012
LayoutStyle Constructor (StyleBorder, Boolean, ShadowStyle, Position, Dimensions)
LayoutStyle Class See Also Send Feedback
Creates new instance of LayoutStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutStyle(
    StyleBorder border,
    bool visible,
    ShadowStyle shadowStyle,
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    border As StyleBorder, _
    visible As Boolean, _
    shadowStyle As ShadowStyle, _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Border of element
visible
Type: System..::.Boolean
Visibility of element
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Shadow
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions

See Also

LayoutStyle Class
LayoutStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Methods

[image] [image]

Telerik Reporting Q2 2012
LayoutStyle Methods
LayoutStyle Class See Also Send Feedback

The LayoutStyle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Style.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
LayoutStyle..::.Dispose Method
LayoutStyle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides Style..::.Dispose(Boolean).)

See Also

LayoutStyle Class
LayoutStyle Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.Dispose Method (Boolean)
LayoutStyle Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

LayoutStyle Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.LoadViewState Method
LayoutStyle Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.SaveViewState Method
LayoutStyle Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.TrackViewState Method
LayoutStyle Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


LayoutStyle Properties

[image] [image]

Telerik Reporting Q2 2012
LayoutStyle Properties
LayoutStyle Class See Also Send Feedback

The LayoutStyle type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Dimensions | Specifies the elements Dimensions property
Position | Specifies the elements Position property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dimensions Property

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.Dimensions Property
LayoutStyle Class See Also Send Feedback
Specifies the elements Dimensions property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Dimensions Dimensions { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Dimensions As Dimensions

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


Position Property

[image]

Telerik Reporting Q2 2012
LayoutStyle..::.Position Property
LayoutStyle Class See Also Send Feedback
Specifies the elements Position property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Position Position { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Position As Position

See Also

LayoutStyle Class
Telerik.Reporting.Charting.Styles Namespace


LineStyle Class

[image]

Telerik Reporting Q2 2012
LineStyle Class
Members See Also Send Feedback
Common lines style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class LineStyle : StyleBorder
Visual Basic (Declaration)
Public Class LineStyle _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.ScaleBreaksLineStyle
Telerik.Reporting.Charting.Styles..::.StyleAxis
Telerik.Reporting.Charting.Styles..::.StyleGridLine
Telerik.Reporting.Charting.Styles..::.StyleItemLabelConnector
Telerik.Reporting.Charting.Styles..::.StyleLineSeries
Telerik.Reporting.Charting.Styles..::.StyleTick

See Also

LineStyle Members
Telerik.Reporting.Charting.Styles Namespace


LineStyle Members

[image] [image]

Telerik Reporting Q2 2012
LineStyle Members
LineStyle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LineStyle type exposes the following members.

Constructors

Name | Description
LineStyle | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides StyleBorder..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Overrides StyleBorder..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides StyleBorder..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the line color property (Inherited from StyleBorder.)
EndCap | Specifies the end cap property
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor

[image] [image]

Telerik Reporting Q2 2012
LineStyle Constructor
LineStyle Class See Also Send Feedback

Overload List

Name | Description
LineStyle()()() | Creates new instance of LineStyle class
LineStyle(Boolean) | Creates new instance of LineStyle class
LineStyle(Color) | Creates new instance of LineStyle class
LineStyle(Object) | Creates new instance of LineStyle class
LineStyle(Color, Single) | Creates new instance of LineStyle class
LineStyle(Color, Single, DashStyle) | Creates new instance of LineStyle class
LineStyle(Color, Single, DashStyle, LineCap) | Creates new instance of LineStyle class

See Also

LineStyle Class
LineStyle Members
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor

[image]

Telerik Reporting Q2 2012
LineStyle Constructor
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle()
Visual Basic (Declaration)
Public Sub New

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Boolean)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Boolean)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean _
)

Parameters

visible
Type: System..::.Boolean
Line visibility

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Color)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Color)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)

Parameters

color
Type: System.Drawing..::.Color
Line color

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Object)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Object)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Color, Single)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Color, Single)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    Color color,
    float width
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    width As Single _
)

Parameters

color
Type: System.Drawing..::.Color
Line color
width
Type: System..::.Single
Line width

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Color, Single, DashStyle)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Color, Single, DashStyle)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    Color color,
    float width,
    DashStyle penStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    width As Single, _
    penStyle As DashStyle _
)

Parameters

color
Type: System.Drawing..::.Color
Line color
width
Type: System..::.Single
Line width
penStyle
Type: System.Drawing.Drawing2D..::.DashStyle
Line PenStyle

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Constructor (Color, Single, DashStyle, LineCap)

[image]

Telerik Reporting Q2 2012
LineStyle Constructor (Color, Single, DashStyle, LineCap)
LineStyle Class See Also Send Feedback
Creates new instance of LineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle(
    Color color,
    float width,
    DashStyle penStyle,
    LineCap endCap
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    width As Single, _
    penStyle As DashStyle, _
    endCap As LineCap _
)

Parameters

color
Type: System.Drawing..::.Color
Line color
width
Type: System..::.Single
Line width
penStyle
Type: System.Drawing.Drawing2D..::.DashStyle
Line PenStyle
endCap
Type: System.Drawing.Drawing2D..::.LineCap
Line end cap

See Also

LineStyle Class
LineStyle Overload
Telerik.Reporting.Charting.Styles Namespace


LineStyle Methods

[image] [image]

Telerik Reporting Q2 2012
LineStyle Methods
LineStyle Class See Also Send Feedback

The LineStyle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides StyleBorder..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Overrides StyleBorder..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides StyleBorder..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
LineStyle..::.Clone Method
LineStyle Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Object with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
LineStyle..::.Dispose Method
LineStyle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

LineStyle Class
LineStyle Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
LineStyle..::.Equals Method
LineStyle Class See Also Send Feedback
Compare two objects

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object tot compare

Return Value

Result of comparing

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
LineStyle..::.GetHashCode Method
LineStyle Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


LineStyle Properties

[image] [image]

Telerik Reporting Q2 2012
LineStyle Properties
LineStyle Class See Also Send Feedback

The LineStyle type exposes the following members.

Properties

Name | Description
Color | Specifies the line color property (Inherited from StyleBorder.)
EndCap | Specifies the end cap property
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


EndCap Property

[image]

Telerik Reporting Q2 2012
LineStyle..::.EndCap Property
LineStyle Class See Also Send Feedback
Specifies the end cap property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual LineCap EndCap { get; set; }
Visual Basic (Declaration)
Public Overridable Property EndCap As LineCap

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


StartCap Property

[image]

Telerik Reporting Q2 2012
LineStyle..::.StartCap Property
LineStyle Class See Also Send Feedback
Specifies the start cap property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual LineCap StartCap { get; set; }
Visual Basic (Declaration)
Public Overridable Property StartCap As LineCap

See Also

LineStyle Class
Telerik.Reporting.Charting.Styles Namespace


MarginsConverter Class

[image]

Telerik Reporting Q2 2012
MarginsConverter Class
Members See Also Send Feedback
Provides a unified way of converting ChartMargins type values to other types, as well as for accessing standard values and sub properties.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class MarginsConverter : TypeConverter
Visual Basic (Declaration)
Public Class MarginsConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Telerik.Reporting.Charting.Styles..::.MarginsConverter

See Also

MarginsConverter Members
Telerik.Reporting.Charting.Styles Namespace


MarginsConverter Members

[image] [image]

Telerik Reporting Q2 2012
MarginsConverter Members
MarginsConverter Class Constructors Methods See Also Send Feedback

The MarginsConverter type exposes the following members.

Constructors

Name | Description
MarginsConverter | Initializes a new instance of the MarginsConverter class

Methods

Name | Description
CanConvertFrom | Checks the possibility to convert from a different object type (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Converts the given object to the ChartMargins, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Creates an instance of the type that this MarginsConverter is associated with, using the specified context, given a set of property values for the object. (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context. (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


MarginsConverter Constructor

[image]

Telerik Reporting Q2 2012
MarginsConverter Constructor
MarginsConverter Class See Also Send Feedback
Initializes a new instance of the MarginsConverter class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsConverter()
Visual Basic (Declaration)
Public Sub New

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


MarginsConverter Methods

[image] [image]

Telerik Reporting Q2 2012
MarginsConverter Methods
MarginsConverter Class See Also Send Feedback

The MarginsConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Checks the possibility to convert from a different object type (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Converts the given object to the ChartMargins, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Creates an instance of the type that this MarginsConverter is associated with, using the specified context, given a set of property values for the object. (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context. (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


CanConvertFrom Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.CanConvertFrom Method
MarginsConverter Class See Also Send Feedback
Checks the possibility to convert from a different object type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
The type to convert from

Return Value

True if conversion is possible

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertFrom Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.ConvertFrom Method
MarginsConverter Class See Also Send Feedback
Converts the given object to the ChartMargins, using the specified context and culture information.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
Current culture settings
value
Type: System..::.Object

Return Value

An System.Object that represents the converted value.

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertTo Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.ConvertTo Method
MarginsConverter Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type
The System.Type to convert the value parameter to.

Return Value

An System.Object that represents the converted value.

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


CreateInstance Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.CreateInstance Method
MarginsConverter Class See Also Send Feedback
Creates an instance of the type that this MarginsConverter is associated with, using the specified context, given a set of property values for the object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual Basic (Declaration)
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
propertyValues
Type: System.Collections..::.IDictionary
An System.Collections.IDictionary of new property values.

Return Value

An System.Object representing the given System.Collections.IDictionary, or null if the object cannot be created.

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetCreateInstanceSupported Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.GetCreateInstanceSupported Method
MarginsConverter Class See Also Send Feedback
Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetCreateInstanceSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetProperties Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.GetProperties Method
MarginsConverter Class See Also Send Feedback
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
value
Type: System..::.Object
An System.Object that specifies the type of array for which to get properties.
attributes
Type: array< System..::.Attribute >[]()[][]
An array of type System.Attribute that is used as a filter.

Return Value

A System.ComponentModel.PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetPropertiesSupported Method

[image]

Telerik Reporting Q2 2012
MarginsConverter..::.GetPropertiesSupported Method
MarginsConverter Class See Also Send Feedback
Returns whether this object supports properties, using the specified context.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true

See Also

MarginsConverter Class
Telerik.Reporting.Charting.Styles Namespace


Orientation Enumeration

[image]

Telerik Reporting Q2 2012
Orientation Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum Orientation
Visual Basic (Declaration)
Public Enumeration Orientation

Members

Member name | Description
Horizontal | Specifies a horizontal drawing
Vertical | Specifies a vertical drawing
Undefined | Not set

See Also

Telerik.Reporting.Charting.Styles Namespace


Overflow Enumeration

[image]

Telerik Reporting Q2 2012
Overflow Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum Overflow
Visual Basic (Declaration)
Public Enumeration Overflow

Members

Member name | Description
Auto | Full auto resizing by contents
Row | Horizontal auto resizing by contents
Column | Vertical auto resizing by contents
Manual | No auto resizing

See Also

Telerik.Reporting.Charting.Styles Namespace


PaddingsConverter Class

[image]

Telerik Reporting Q2 2012
PaddingsConverter Class
Members See Also Send Feedback
Provides a unified way of converting ChartMargins type values to other types, as well as for accessing standard values and sub properties.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PaddingsConverter : TypeConverter
Visual Basic (Declaration)
Public Class PaddingsConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Telerik.Reporting.Charting.Styles..::.PaddingsConverter

See Also

PaddingsConverter Members
Telerik.Reporting.Charting.Styles Namespace


PaddingsConverter Members

[image] [image]

Telerik Reporting Q2 2012
PaddingsConverter Members
PaddingsConverter Class Constructors Methods See Also Send Feedback

The PaddingsConverter type exposes the following members.

Constructors

Name | Description
PaddingsConverter | Initializes a new instance of the PaddingsConverter class

Methods

Name | Description
CanConvertFrom | Checks the possibility to convert from a different object type (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Converts the given object to the ChartPaddings, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Creates an instance of the type that this PaddingsConverter is associated with, using the specified context, given a set of property values for the object. (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context. (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


PaddingsConverter Constructor

[image]

Telerik Reporting Q2 2012
PaddingsConverter Constructor
PaddingsConverter Class See Also Send Feedback
Initializes a new instance of the PaddingsConverter class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaddingsConverter()
Visual Basic (Declaration)
Public Sub New

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


PaddingsConverter Methods

[image] [image]

Telerik Reporting Q2 2012
PaddingsConverter Methods
PaddingsConverter Class See Also Send Feedback

The PaddingsConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Checks the possibility to convert from a different object type (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)
ConvertFrom | Converts the given object to the ChartPaddings, using the specified context and culture information. (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
ConvertTo | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
CreateInstance | Creates an instance of the type that this PaddingsConverter is associated with, using the specified context, given a set of property values for the object. (Overrides TypeConverter..::.CreateInstance(ITypeDescriptorContext, IDictionary).)
GetCreateInstanceSupported | Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context. (Overrides TypeConverter..::.GetCreateInstanceSupported(ITypeDescriptorContext).)
GetProperties | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter..::.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]).)
GetPropertiesSupported | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter..::.GetPropertiesSupported(ITypeDescriptorContext).)

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


CanConvertFrom Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.CanConvertFrom Method
PaddingsConverter Class See Also Send Feedback
Checks the possibility to convert from a different object type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
Type: System..::.Type
The type to convert from

Return Value

True if conversion is possible

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertFrom Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.ConvertFrom Method
PaddingsConverter Class See Also Send Feedback
Converts the given object to the ChartPaddings, using the specified context and culture information.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
Type: System.Globalization..::.CultureInfo
Current culture settings
value
Type: System..::.Object

Return Value

An System.Object that represents the converted value.

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


ConvertTo Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.ConvertTo Method
PaddingsConverter Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type
The System.Type to convert the value parameter to.

Return Value

An System.Object that represents the converted value.

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


CreateInstance Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.CreateInstance Method
PaddingsConverter Class See Also Send Feedback
Creates an instance of the type that this PaddingsConverter is associated with, using the specified context, given a set of property values for the object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object CreateInstance(
    ITypeDescriptorContext context,
    IDictionary propertyValues
)
Visual Basic (Declaration)
Public Overrides Function CreateInstance ( _
    context As ITypeDescriptorContext, _
    propertyValues As IDictionary _
) As Object

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
propertyValues
Type: System.Collections..::.IDictionary
An System.Collections.IDictionary of new property values.

Return Value

An System.Object representing the given System.Collections.IDictionary, or null if the object cannot be created.

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetCreateInstanceSupported Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.GetCreateInstanceSupported Method
PaddingsConverter Class See Also Send Feedback
Returns whether changing a value on this object requires a call to System.ComponentModel.TypeConverter.CreateInstance(System.Collections.IDictionary) to create a new value, using the specified context.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetCreateInstanceSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetCreateInstanceSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetProperties Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.GetProperties Method
PaddingsConverter Class See Also Send Feedback
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Visual Basic (Declaration)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
value
Type: System..::.Object
An System.Object that specifies the type of array for which to get properties.
attributes
Type: array< System..::.Attribute >[]()[][]
An array of type System.Attribute that is used as a filter.

Return Value

A System.ComponentModel.PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


GetPropertiesSupported Method

[image]

Telerik Reporting Q2 2012
PaddingsConverter..::.GetPropertiesSupported Method
PaddingsConverter Class See Also Send Feedback
Returns whether this object supports properties, using the specified context.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Visual Basic (Declaration)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
An System.ComponentModel.ITypeDescriptorContext that provides a format context.

Return Value

true

See Also

PaddingsConverter Class
Telerik.Reporting.Charting.Styles Namespace


PlacementDirection Enumeration

[image]

Telerik Reporting Q2 2012
PlacementDirection Enumeration
See Also Send Feedback
Direction of label position in auto mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum PlacementDirection
Visual Basic (Declaration)
Public Enumeration PlacementDirection

Members

Member name | Description
Horizontal | Horizontal label's direction
Vertical | Vertical label's direction

See Also

Telerik.Reporting.Charting.Styles Namespace


Position Class

[image]

Telerik Reporting Q2 2012
Position Class
Members See Also Send Feedback
Represents the element position in the container

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Position : StateManagedObject, ICloneable
Visual Basic (Declaration)
Public Class Position _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionBottom
Telerik.Reporting.Charting.Styles..::.PositionCenter
Telerik.Reporting.Charting.Styles..::.PositionLeft
Telerik.Reporting.Charting.Styles..::.PositionRight
Telerik.Reporting.Charting.Styles..::.PositionTop
Telerik.Reporting.Charting.Styles..::.PositionTopLeft
Telerik.Reporting.Charting.Styles..::.PositionTopRight

See Also

Position Members
Telerik.Reporting.Charting.Styles Namespace


Position Members

[image] [image]

Telerik Reporting Q2 2012
Position Members
Position Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Position type exposes the following members.

Constructors

Name | Description
Position | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default
ResetY | Reset Y coordinate to default
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X
ShouldSerializeY | Manages design-time serialization of Y
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure
Auto | Automatic positioning
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position
Y | Specifies the Y coordinate of the figure position

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Position Constructor

[image] [image]

Telerik Reporting Q2 2012
Position Constructor
Position Class See Also Send Feedback

Overload List

Name | Description
Position()()() | Creates an instance of Position class.
Position(Object) | Creates an instance of Position class.
Position(AlignedPositions) | Creates an instance of Position class.
Position(Single, Single) | Creates an instance of Position class.
Position(AlignedPositions, Single, Single) | Creates an instance of Position class.

See Also

Position Class
Position Members
Telerik.Reporting.Charting.Styles Namespace


Position Constructor

[image]

Telerik Reporting Q2 2012
Position Constructor
Position Class See Also Send Feedback
Creates an instance of Position class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Position()
Visual Basic (Declaration)
Public Sub New

See Also

Position Class
Position Overload
Telerik.Reporting.Charting.Styles Namespace


Position Constructor (Object)

[image]

Telerik Reporting Q2 2012
Position Constructor (Object)
Position Class See Also Send Feedback
Creates an instance of Position class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Position(
    Object container
)
Visual Basic (Declaration)
Public Sub New ( _
    container As Object _
)

Parameters

container
Type: System..::.Object
Container element

See Also

Position Class
Position Overload
Telerik.Reporting.Charting.Styles Namespace


Position Constructor (AlignedPositions)

[image]

Telerik Reporting Q2 2012
Position Constructor (AlignedPositions)
Position Class See Also Send Feedback
Creates an instance of Position class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Position(
    AlignedPositions position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As AlignedPositions _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.AlignedPositions
Aligned position of element

See Also

Position Class
Position Overload
Telerik.Reporting.Charting.Styles Namespace


Position Constructor (Single, Single)

[image]

Telerik Reporting Q2 2012
Position Constructor (Single, Single)
Position Class See Also Send Feedback
Creates an instance of Position class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Position(
    float x,
    float y
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Single, _
    y As Single _
)

Parameters

x
Type: System..::.Single
X coordinate
y
Type: System..::.Single
Y coordinate

See Also

Position Class
Position Overload
Telerik.Reporting.Charting.Styles Namespace


Position Constructor (AlignedPositions, Single, Single)

[image]

Telerik Reporting Q2 2012
Position Constructor (AlignedPositions, Single, Single)
Position Class See Also Send Feedback
Creates an instance of Position class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Position(
    AlignedPositions position,
    float x,
    float y
)
Visual Basic (Declaration)
Public Sub New ( _
    position As AlignedPositions, _
    x As Single, _
    y As Single _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.AlignedPositions
Aligned position of element
x
Type: System..::.Single
X coordinate
y
Type: System..::.Single
Y coordinate

See Also

Position Class
Position Overload
Telerik.Reporting.Charting.Styles Namespace


Position Methods

[image] [image]

Telerik Reporting Q2 2012
Position Methods
Position Class See Also Send Feedback

The Position type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default
ResetY | Reset Y coordinate to default
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X
ShouldSerializeY | Manages design-time serialization of Y
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Position..::.Clone Method
Position Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Position..::.Dispose Method
Position Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

Position Class
Position Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
Position..::.Equals Method
Position Class See Also Send Feedback
Determines whether the specified System.Object is equal to the current System.Object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare

Return Value

Result of comparing

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Position..::.GetHashCode Method
Position Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


ResetX Method

[image]

Telerik Reporting Q2 2012
Position..::.ResetX Method
Position Class See Also Send Feedback
Reset X coordinate to default

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void ResetX()
Visual Basic (Declaration)
Protected Overridable Sub ResetX

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


ResetY Method

[image]

Telerik Reporting Q2 2012
Position..::.ResetY Method
Position Class See Also Send Feedback
Reset Y coordinate to default

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void ResetY()
Visual Basic (Declaration)
Protected Overridable Sub ResetY

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeX Method

[image]

Telerik Reporting Q2 2012
Position..::.ShouldSerializeX Method
Position Class See Also Send Feedback
Manages design-time serialization of X

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ShouldSerializeX()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeX As Boolean

Return Value

True if value should be serialized

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeY Method

[image]

Telerik Reporting Q2 2012
Position..::.ShouldSerializeY Method
Position Class See Also Send Feedback
Manages design-time serialization of Y

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ShouldSerializeY()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeY As Boolean

Return Value

True if value should be serialized

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Position Properties

[image] [image]

Telerik Reporting Q2 2012
Position Properties
Position Class See Also Send Feedback

The Position type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure
Auto | Automatic positioning
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position
Y | Specifies the Y coordinate of the figure position

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
Position..::.AlignedPosition Property
Position Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual AlignedPositions AlignedPosition { get; set; }
Visual Basic (Declaration)
Public Overridable Property AlignedPosition As AlignedPositions

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Auto Property

[image]

Telerik Reporting Q2 2012
Position..::.Auto Property
Position Class See Also Send Feedback
Automatic positioning

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Auto { get; set; }
Visual Basic (Declaration)
Public Overridable Property Auto As Boolean

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


X Property

[image]

Telerik Reporting Q2 2012
Position..::.X Property
Position Class See Also Send Feedback
Specifies the X coordinate of the figure position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float X { get; set; }
Visual Basic (Declaration)
Public Overridable Property X As Single

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


Y Property

[image]

Telerik Reporting Q2 2012
Position..::.Y Property
Position Class See Also Send Feedback
Specifies the Y coordinate of the figure position

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float Y { get; set; }
Visual Basic (Declaration)
Public Overridable Property Y As Single

See Also

Position Class
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Class

[image]

Telerik Reporting Q2 2012
PositionBottom Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.Bottom

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionBottom : Position
Visual Basic (Declaration)
Public Class PositionBottom _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionBottom

See Also

PositionBottom Members
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Members

[image] [image]

Telerik Reporting Q2 2012
PositionBottom Members
PositionBottom Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionBottom type exposes the following members.

Constructors

Name | Description
PositionBottom | Initializes a new instance of the PositionBottom class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Constructor

[image]

Telerik Reporting Q2 2012
PositionBottom Constructor
PositionBottom Class See Also Send Feedback
Initializes a new instance of the PositionBottom class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionBottom()
Visual Basic (Declaration)
Public Sub New

See Also

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Methods

[image] [image]

Telerik Reporting Q2 2012
PositionBottom Methods
PositionBottom Class See Also Send Feedback

The PositionBottom type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionBottom..::.Dispose Method
PositionBottom Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionBottom Class
PositionBottom Members
Telerik.Reporting.Charting.Styles Namespace


PositionBottom Properties

[image] [image]

Telerik Reporting Q2 2012
PositionBottom Properties
PositionBottom Class See Also Send Feedback

The PositionBottom type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionBottom..::.AlignedPosition Property
PositionBottom Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionBottom Class
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Class

[image]

Telerik Reporting Q2 2012
PositionCenter Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.Center

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionCenter : Position
Visual Basic (Declaration)
Public Class PositionCenter _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionCenter

See Also

PositionCenter Members
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Members

[image] [image]

Telerik Reporting Q2 2012
PositionCenter Members
PositionCenter Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionCenter type exposes the following members.

Constructors

Name | Description
PositionCenter | Initializes a new instance of the PositionCenter class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Constructor

[image]

Telerik Reporting Q2 2012
PositionCenter Constructor
PositionCenter Class See Also Send Feedback
Initializes a new instance of the PositionCenter class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionCenter()
Visual Basic (Declaration)
Public Sub New

See Also

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Methods

[image] [image]

Telerik Reporting Q2 2012
PositionCenter Methods
PositionCenter Class See Also Send Feedback

The PositionCenter type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionCenter..::.Dispose Method
PositionCenter Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionCenter Class
PositionCenter Members
Telerik.Reporting.Charting.Styles Namespace


PositionCenter Properties

[image] [image]

Telerik Reporting Q2 2012
PositionCenter Properties
PositionCenter Class See Also Send Feedback

The PositionCenter type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionCenter..::.AlignedPosition Property
PositionCenter Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionCenter Class
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Class

[image]

Telerik Reporting Q2 2012
PositionLeft Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.Left

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionLeft : Position
Visual Basic (Declaration)
Public Class PositionLeft _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionLeft

See Also

PositionLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Members

[image] [image]

Telerik Reporting Q2 2012
PositionLeft Members
PositionLeft Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionLeft type exposes the following members.

Constructors

Name | Description
PositionLeft | Initializes a new instance of the PositionLeft class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Constructor

[image]

Telerik Reporting Q2 2012
PositionLeft Constructor
PositionLeft Class See Also Send Feedback
Initializes a new instance of the PositionLeft class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionLeft()
Visual Basic (Declaration)
Public Sub New

See Also

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Methods

[image] [image]

Telerik Reporting Q2 2012
PositionLeft Methods
PositionLeft Class See Also Send Feedback

The PositionLeft type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionLeft..::.Dispose Method
PositionLeft Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionLeft Class
PositionLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionLeft Properties

[image] [image]

Telerik Reporting Q2 2012
PositionLeft Properties
PositionLeft Class See Also Send Feedback

The PositionLeft type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionLeft..::.AlignedPosition Property
PositionLeft Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionRight Class

[image]

Telerik Reporting Q2 2012
PositionRight Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.Right

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionRight : Position
Visual Basic (Declaration)
Public Class PositionRight _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionRight

See Also

PositionRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionRight Members

[image] [image]

Telerik Reporting Q2 2012
PositionRight Members
PositionRight Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionRight type exposes the following members.

Constructors

Name | Description
PositionRight | Initializes a new instance of the PositionRight class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionRight Constructor

[image]

Telerik Reporting Q2 2012
PositionRight Constructor
PositionRight Class See Also Send Feedback
Initializes a new instance of the PositionRight class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionRight()
Visual Basic (Declaration)
Public Sub New

See Also

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionRight Methods

[image] [image]

Telerik Reporting Q2 2012
PositionRight Methods
PositionRight Class See Also Send Feedback

The PositionRight type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionRight..::.Dispose Method
PositionRight Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionRight Class
PositionRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionRight Properties

[image] [image]

Telerik Reporting Q2 2012
PositionRight Properties
PositionRight Class See Also Send Feedback

The PositionRight type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionRight..::.AlignedPosition Property
PositionRight Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionTop Class

[image]

Telerik Reporting Q2 2012
PositionTop Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.Top

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionTop : Position
Visual Basic (Declaration)
Public Class PositionTop _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionTop

See Also

PositionTop Members
Telerik.Reporting.Charting.Styles Namespace


PositionTop Members

[image] [image]

Telerik Reporting Q2 2012
PositionTop Members
PositionTop Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionTop type exposes the following members.

Constructors

Name | Description
PositionTop | Initializes a new instance of the PositionTop class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


PositionTop Constructor

[image]

Telerik Reporting Q2 2012
PositionTop Constructor
PositionTop Class See Also Send Feedback
Initializes a new instance of the PositionTop class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionTop()
Visual Basic (Declaration)
Public Sub New

See Also

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


PositionTop Methods

[image] [image]

Telerik Reporting Q2 2012
PositionTop Methods
PositionTop Class See Also Send Feedback

The PositionTop type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionTop..::.Dispose Method
PositionTop Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionTop Class
PositionTop Members
Telerik.Reporting.Charting.Styles Namespace


PositionTop Properties

[image] [image]

Telerik Reporting Q2 2012
PositionTop Properties
PositionTop Class See Also Send Feedback

The PositionTop type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionTop..::.AlignedPosition Property
PositionTop Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionTop Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Class

[image]

Telerik Reporting Q2 2012
PositionTopLeft Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.TopLeft

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionTopLeft : Position
Visual Basic (Declaration)
Public Class PositionTopLeft _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionTopLeft

See Also

PositionTopLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Members

[image] [image]

Telerik Reporting Q2 2012
PositionTopLeft Members
PositionTopLeft Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionTopLeft type exposes the following members.

Constructors

Name | Description
PositionTopLeft | Initializes a new instance of the PositionTopLeft class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Constructor

[image]

Telerik Reporting Q2 2012
PositionTopLeft Constructor
PositionTopLeft Class See Also Send Feedback
Initializes a new instance of the PositionTopLeft class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionTopLeft()
Visual Basic (Declaration)
Public Sub New

See Also

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Methods

[image] [image]

Telerik Reporting Q2 2012
PositionTopLeft Methods
PositionTopLeft Class See Also Send Feedback

The PositionTopLeft type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionTopLeft..::.Dispose Method
PositionTopLeft Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionTopLeft Class
PositionTopLeft Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopLeft Properties

[image] [image]

Telerik Reporting Q2 2012
PositionTopLeft Properties
PositionTopLeft Class See Also Send Feedback

The PositionTopLeft type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionTopLeft..::.AlignedPosition Property
PositionTopLeft Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionTopLeft Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Class

[image]

Telerik Reporting Q2 2012
PositionTopRight Class
Members See Also Send Feedback
Specific Position object with predefined AlignedPosition.TopRight

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PositionTopRight : Position
Visual Basic (Declaration)
Public Class PositionTopRight _
    Inherits Position

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Position
Telerik.Reporting.Charting.Styles..::.PositionTopRight

See Also

PositionTopRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Members

[image] [image]

Telerik Reporting Q2 2012
PositionTopRight Members
PositionTopRight Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PositionTopRight type exposes the following members.

Constructors

Name | Description
PositionTopRight | Initializes a new instance of the PositionTopRight class

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Constructor

[image]

Telerik Reporting Q2 2012
PositionTopRight Constructor
PositionTopRight Class See Also Send Feedback
Initializes a new instance of the PositionTopRight class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PositionTopRight()
Visual Basic (Declaration)
Public Sub New

See Also

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Methods

[image] [image]

Telerik Reporting Q2 2012
PositionTopRight Methods
PositionTopRight Class See Also Send Feedback

The PositionTopRight type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Position.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from Position.)
GetHashCode | Gets hash code (Inherited from Position.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
ResetX | Reset X coordinate to default (Inherited from Position.)
ResetY | Reset Y coordinate to default (Inherited from Position.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeX | Manages design-time serialization of X (Inherited from Position.)
ShouldSerializeY | Manages design-time serialization of Y (Inherited from Position.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
PositionTopRight..::.Dispose Method
PositionTopRight Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

PositionTopRight Class
PositionTopRight Members
Telerik.Reporting.Charting.Styles Namespace


PositionTopRight Properties

[image] [image]

Telerik Reporting Q2 2012
PositionTopRight Properties
PositionTopRight Class See Also Send Feedback

The PositionTopRight type exposes the following members.

Properties

Name | Description
AlignedPosition | Specifies aligned position in comprehensive figure (Overrides Position..::.AlignedPosition.)
Auto | Automatic positioning (Inherited from Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
X | Specifies the X coordinate of the figure position (Inherited from Position.)
Y | Specifies the Y coordinate of the figure position (Inherited from Position.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


AlignedPosition Property

[image]

Telerik Reporting Q2 2012
PositionTopRight..::.AlignedPosition Property
PositionTopRight Class See Also Send Feedback
Specifies aligned position in comprehensive figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override AlignedPositions AlignedPosition { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AlignedPosition As AlignedPositions

See Also

PositionTopRight Class
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Class

[image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle Class
Members See Also Send Feedback
Scale breaks line specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ScaleBreaksLineStyle : LineStyle
Visual Basic (Declaration)
Public Class ScaleBreaksLineStyle _
    Inherits LineStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.ScaleBreaksLineStyle

See Also

ScaleBreaksLineStyle Members
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Members

[image] [image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle Members
ScaleBreaksLineStyle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ScaleBreaksLineStyle type exposes the following members.

Constructors

Name | Description
ScaleBreaksLineStyle | Initializes a new instance of the ScaleBreaksLineStyle class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets ScaleBreak's color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Constructor

[image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle Constructor
ScaleBreaksLineStyle Class See Also Send Feedback
Initializes a new instance of the ScaleBreaksLineStyle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ScaleBreaksLineStyle()
Visual Basic (Declaration)
Public Sub New

See Also

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Methods

[image] [image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle Methods
ScaleBreaksLineStyle Class See Also Send Feedback

The ScaleBreaksLineStyle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle..::.Dispose Method
ScaleBreaksLineStyle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ScaleBreaksLineStyle Class
ScaleBreaksLineStyle Members
Telerik.Reporting.Charting.Styles Namespace


ScaleBreaksLineStyle Properties

[image] [image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle Properties
ScaleBreaksLineStyle Class See Also Send Feedback

The ScaleBreaksLineStyle type exposes the following members.

Properties

Name | Description
Color | Gets and sets ScaleBreak's color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
ScaleBreaksLineStyle..::.Color Property
ScaleBreaksLineStyle Class See Also Send Feedback
Gets and sets ScaleBreak's color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

ScaleBreak's color

See Also

ScaleBreaksLineStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowPosition Enumeration

[image]

Telerik Reporting Q2 2012
ShadowPosition Enumeration
See Also Send Feedback
Possible shadow positions listing

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ShadowPosition
Visual Basic (Declaration)
Public Enumeration ShadowPosition

Members

Member name | Description
Right | Assign the right position for shadow
Left | Assign the left position for shadow
Top | Assign the top position for shadow
Bottom | Assign the bottom position for shadow
TopRight | Assign the top right position for shadow
TopLeft | Assign the top left position for shadow
BottomRight | Assign the bottom right position for shadow
BottomLeft | Assign the bottom left position for shadow
Behind | Assign the behind position for shadow

See Also

Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Class

[image]

Telerik Reporting Q2 2012
ShadowStyle Class
Members See Also Send Feedback
Shadow settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ShadowStyle : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class ShadowStyle _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.ShadowStyle
Telerik.Reporting.Charting.Styles..::.ShadowStyleChart

See Also

ShadowStyle Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Members

[image] [image]

Telerik Reporting Q2 2012
ShadowStyle Members
ShadowStyle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ShadowStyle type exposes the following members.

Constructors

Name | Description
ShadowStyle | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Blur | Specifies the shadow blur property
Color | Specifies the shadow color property
ColorOpacity | The main color opacity coefficient
Distance | Specifies the shadow distance property
Position | Specifies the shadow position property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Constructor

[image] [image]

Telerik Reporting Q2 2012
ShadowStyle Constructor
ShadowStyle Class See Also Send Feedback

Overload List

Name | Description
ShadowStyle()()() | Create new instance of ShadowStyle class.
ShadowStyle(Color, Single, Single, ShadowPosition) | Create new instance of ShadowStyle class.

See Also

ShadowStyle Class
ShadowStyle Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Constructor

[image]

Telerik Reporting Q2 2012
ShadowStyle Constructor
ShadowStyle Class See Also Send Feedback
Create new instance of ShadowStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ShadowStyle()
Visual Basic (Declaration)
Public Sub New

See Also

ShadowStyle Class
ShadowStyle Overload
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Constructor (Color, Single, Single, ShadowPosition)

[image]

Telerik Reporting Q2 2012
ShadowStyle Constructor (Color, Single, Single, ShadowPosition)
ShadowStyle Class See Also Send Feedback
Create new instance of ShadowStyle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ShadowStyle(
    Color shadowColor,
    float shadowBlur,
    float shadowDistance,
    ShadowPosition shadowPosition
)
Visual Basic (Declaration)
Public Sub New ( _
    shadowColor As Color, _
    shadowBlur As Single, _
    shadowDistance As Single, _
    shadowPosition As ShadowPosition _
)

Parameters

shadowColor
Type: System.Drawing..::.Color
Shadow color
shadowBlur
Type: System..::.Single
Shadow blur
shadowDistance
Type: System..::.Single
Shadow distance
shadowPosition
Type: Telerik.Reporting.Charting.Styles..::.ShadowPosition
Shadow position

See Also

ShadowStyle Class
ShadowStyle Overload
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Methods

[image] [image]

Telerik Reporting Q2 2012
ShadowStyle Methods
ShadowStyle Class See Also Send Feedback

The ShadowStyle type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Clone Method
ShadowStyle Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

New instance with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ShadowStyle..::.Dispose Method
ShadowStyle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ShadowStyle Class
ShadowStyle Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Equals Method
ShadowStyle Class See Also Send Feedback
Comparing of two objects

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare

Return Value

Result of comparing

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.GetHashCode Method
ShadowStyle Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyle Properties

[image] [image]

Telerik Reporting Q2 2012
ShadowStyle Properties
ShadowStyle Class See Also Send Feedback

The ShadowStyle type exposes the following members.

Properties

Name | Description
Blur | Specifies the shadow blur property
Color | Specifies the shadow color property
ColorOpacity | The main color opacity coefficient
Distance | Specifies the shadow distance property
Position | Specifies the shadow position property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Blur Property

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Blur Property
ShadowStyle Class See Also Send Feedback
Specifies the shadow blur property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float Blur { get; set; }
Visual Basic (Declaration)
Public Overridable Property Blur As Single

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Color Property
ShadowStyle Class See Also Send Feedback
Specifies the shadow color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Color Color { get; set; }
Visual Basic (Declaration)
Public Overridable Property Color As Color

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


ColorOpacity Property

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.ColorOpacity Property
ShadowStyle Class See Also Send Feedback
The main color opacity coefficient

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public byte ColorOpacity { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorOpacity As Byte

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Distance Property

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Distance Property
ShadowStyle Class See Also Send Feedback
Specifies the shadow distance property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float Distance { get; set; }
Visual Basic (Declaration)
Public Overridable Property Distance As Single

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


Position Property

[image]

Telerik Reporting Q2 2012
ShadowStyle..::.Position Property
ShadowStyle Class See Also Send Feedback
Specifies the shadow position property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ShadowPosition Position { get; set; }
Visual Basic (Declaration)
Public Overridable Property Position As ShadowPosition

See Also

ShadowStyle Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Class

[image]

Telerik Reporting Q2 2012
ShadowStyleChart Class
Members See Also Send Feedback
Common shadow settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ShadowStyleChart : ShadowStyle
Visual Basic (Declaration)
Public Class ShadowStyleChart _
    Inherits ShadowStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.ShadowStyle
Telerik.Reporting.Charting.Styles..::.ShadowStyleChart

See Also

ShadowStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Members

[image] [image]

Telerik Reporting Q2 2012
ShadowStyleChart Members
ShadowStyleChart Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ShadowStyleChart type exposes the following members.

Constructors

Name | Description
ShadowStyleChart | Create new instance of ShadowStyleChart class.

Methods

Name | Description
Clone | Clone this object (Inherited from ShadowStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from ShadowStyle.)
GetHashCode | Gets hash code (Inherited from ShadowStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Blur | Specifies the shadow blur property (Overrides ShadowStyle..::.Blur.)
Color | Specifies the shadow color property (Overrides ShadowStyle..::.Color.)
ColorOpacity | The main color opacity coefficient (Inherited from ShadowStyle.)
Distance | Specifies the shadow distance property (Overrides ShadowStyle..::.Distance.)
Position | Specifies the shadow position property (Overrides ShadowStyle..::.Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Constructor

[image]

Telerik Reporting Q2 2012
ShadowStyleChart Constructor
ShadowStyleChart Class See Also Send Feedback
Create new instance of ShadowStyleChart class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ShadowStyleChart(
    Chart parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As Chart _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.Chart
Parent chart element

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Methods

[image] [image]

Telerik Reporting Q2 2012
ShadowStyleChart Methods
ShadowStyleChart Class See Also Send Feedback

The ShadowStyleChart type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from ShadowStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from ShadowStyle.)
GetHashCode | Gets hash code (Inherited from ShadowStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
ShadowStyleChart..::.Dispose Method
ShadowStyleChart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

ShadowStyleChart Class
ShadowStyleChart Members
Telerik.Reporting.Charting.Styles Namespace


ShadowStyleChart Properties

[image] [image]

Telerik Reporting Q2 2012
ShadowStyleChart Properties
ShadowStyleChart Class See Also Send Feedback

The ShadowStyleChart type exposes the following members.

Properties

Name | Description
Blur | Specifies the shadow blur property (Overrides ShadowStyle..::.Blur.)
Color | Specifies the shadow color property (Overrides ShadowStyle..::.Color.)
ColorOpacity | The main color opacity coefficient (Inherited from ShadowStyle.)
Distance | Specifies the shadow distance property (Overrides ShadowStyle..::.Distance.)
Position | Specifies the shadow position property (Overrides ShadowStyle..::.Position.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Blur Property

[image]

Telerik Reporting Q2 2012
ShadowStyleChart..::.Blur Property
ShadowStyleChart Class See Also Send Feedback
Specifies the shadow blur property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Blur { get; set; }
Visual Basic (Declaration)
Public Overrides Property Blur As Single

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
ShadowStyleChart..::.Color Property
ShadowStyleChart Class See Also Send Feedback
Specifies the shadow color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Distance Property

[image]

Telerik Reporting Q2 2012
ShadowStyleChart..::.Distance Property
ShadowStyleChart Class See Also Send Feedback
Specifies the shadow distance property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Distance { get; set; }
Visual Basic (Declaration)
Public Overrides Property Distance As Single

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Position Property

[image]

Telerik Reporting Q2 2012
ShadowStyleChart..::.Position Property
ShadowStyleChart Class See Also Send Feedback
Specifies the shadow position property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ShadowPosition Position { get; set; }
Visual Basic (Declaration)
Public Overrides Property Position As ShadowPosition

See Also

ShadowStyleChart Class
Telerik.Reporting.Charting.Styles Namespace


SkinnablePropertyAttribute Class

[image]

Telerik Reporting Q2 2012
SkinnablePropertyAttribute Class
Members See Also Send Feedback
Represents the custom property attribute used to mark property as skinable and being used with a skin application

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class SkinnablePropertyAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class SkinnablePropertyAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Charting.Styles..::.SkinnablePropertyAttribute

See Also

SkinnablePropertyAttribute Members
Telerik.Reporting.Charting.Styles Namespace


SkinnablePropertyAttribute Members

[image] [image]

Telerik Reporting Q2 2012
SkinnablePropertyAttribute Members
SkinnablePropertyAttribute Class Constructors Properties See Also Send Feedback

The SkinnablePropertyAttribute type exposes the following members.

Constructors

Name | Description
SkinnablePropertyAttribute | Create new instance of SkinnablePropertyAttribute class.

Properties

Name | Description
IsSkinnable | Gets whether attribute is skinable

See Also

SkinnablePropertyAttribute Class
Telerik.Reporting.Charting.Styles Namespace


SkinnablePropertyAttribute Constructor

[image]

Telerik Reporting Q2 2012
SkinnablePropertyAttribute Constructor
SkinnablePropertyAttribute Class See Also Send Feedback
Create new instance of SkinnablePropertyAttribute class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SkinnablePropertyAttribute()
Visual Basic (Declaration)
Public Sub New

See Also

SkinnablePropertyAttribute Class
Telerik.Reporting.Charting.Styles Namespace


SkinnablePropertyAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
SkinnablePropertyAttribute Properties
SkinnablePropertyAttribute Class See Also Send Feedback

The SkinnablePropertyAttribute type exposes the following members.

Properties

Name | Description
IsSkinnable | Gets whether attribute is skinable

See Also

SkinnablePropertyAttribute Class
Telerik.Reporting.Charting.Styles Namespace


IsSkinnable Property

[image]

Telerik Reporting Q2 2012
SkinnablePropertyAttribute..::.IsSkinnable Property
SkinnablePropertyAttribute Class See Also Send Feedback
Gets whether attribute is skinable

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsSkinnable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSkinnable As Boolean

See Also

SkinnablePropertyAttribute Class
Telerik.Reporting.Charting.Styles Namespace


Style Class

[image]

Telerik Reporting Q2 2012
Style Class
Members See Also Send Feedback
Base style class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class Style : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public MustInherit Class Style _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarkedZone
Telerik.Reporting.Charting.Styles..::.StyleSeries
Telerik.Reporting.Charting.Styles..::.StyleSeriesItem

See Also

Style Members
Telerik.Reporting.Charting.Styles Namespace


Style Members

[image] [image]

Telerik Reporting Q2 2012
Style Members
Style Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Style type exposes the following members.

Constructors

Name | Description
Style | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style
Shadow | Specifies the shadow settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Style Constructor

[image] [image]

Telerik Reporting Q2 2012
Style Constructor
Style Class See Also Send Feedback

Overload List

Name | Description
Style()()() | Creates new instance of Style class.
Style(Object) | Creates new instance of Style class.
Style(StyleBorder) | Creates new instance of Style class.
Style(StyleBorder, Boolean) | Creates new instance of Style class.
Style(StyleBorder, Boolean, ShadowStyle) | Creates new instance of Style class.

See Also

Style Class
Style Members
Telerik.Reporting.Charting.Styles Namespace


Style Constructor

[image]

Telerik Reporting Q2 2012
Style Constructor
Style Class See Also Send Feedback
Creates new instance of Style class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style()
Visual Basic (Declaration)
Public Sub New

See Also

Style Class
Style Overload
Telerik.Reporting.Charting.Styles Namespace


Style Constructor (Object)

[image]

Telerik Reporting Q2 2012
Style Constructor (Object)
Style Class See Also Send Feedback
Creates new instance of Style class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object element

See Also

Style Class
Style Overload
Telerik.Reporting.Charting.Styles Namespace


Style Constructor (StyleBorder)

[image]

Telerik Reporting Q2 2012
Style Constructor (StyleBorder)
Style Class See Also Send Feedback
Creates new instance of Style class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style(
    StyleBorder border
)
Visual Basic (Declaration)
Public Sub New ( _
    border As StyleBorder _
)

Parameters

border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Style border

See Also

Style Class
Style Overload
Telerik.Reporting.Charting.Styles Namespace


Style Constructor (StyleBorder, Boolean)

[image]

Telerik Reporting Q2 2012
Style Constructor (StyleBorder, Boolean)
Style Class See Also Send Feedback
Creates new instance of Style class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style(
    StyleBorder border,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    border As StyleBorder, _
    visible As Boolean _
)

Parameters

border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Style border
visible
Type: System..::.Boolean
Visibility

See Also

Style Class
Style Overload
Telerik.Reporting.Charting.Styles Namespace


Style Constructor (StyleBorder, Boolean, ShadowStyle)

[image]

Telerik Reporting Q2 2012
Style Constructor (StyleBorder, Boolean, ShadowStyle)
Style Class See Also Send Feedback
Creates new instance of Style class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style(
    StyleBorder border,
    bool visible,
    ShadowStyle shadowStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    border As StyleBorder, _
    visible As Boolean, _
    shadowStyle As ShadowStyle _
)

Parameters

border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Style border
visible
Type: System..::.Boolean
Visibility
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Shadow style

See Also

Style Class
Style Overload
Telerik.Reporting.Charting.Styles Namespace


Style Methods

[image] [image]

Telerik Reporting Q2 2012
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
Style..::.Clone Method
Style Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
Style..::.Dispose Method
Style Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

Style Class
Style Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
Style..::.Dispose Method (Boolean)
Style Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Style Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
Style..::.LoadViewState Method
Style Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState to load data

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
Style..::.SaveViewState Method
Style Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
Style..::.TrackViewState Method
Style Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Style Properties

[image] [image]

Telerik Reporting Q2 2012
Style Properties
Style Class See Also Send Feedback

The Style type exposes the following members.

Properties

Name | Description
Border | Specifies the border style
Shadow | Specifies the shadow settings
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Border Property

[image]

Telerik Reporting Q2 2012
Style..::.Border Property
Style Class See Also Send Feedback
Specifies the border style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleBorder Border { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Border As StyleBorder

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Shadow Property

[image]

Telerik Reporting Q2 2012
Style..::.Shadow Property
Style Class See Also Send Feedback
Specifies the shadow settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ShadowStyle Shadow { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Shadow As ShadowStyle

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
Style..::.Visible Property
Style Class See Also Send Feedback
Specifies visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean

See Also

Style Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Class

[image]

Telerik Reporting Q2 2012
StyleAxis Class
Members See Also Send Feedback
Axis appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleAxis : LineStyle, IDisposable
Visual Basic (Declaration)
Public Class StyleAxis _
    Inherits LineStyle _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleAxis
Telerik.Reporting.Charting.Styles..::.StyleAxisX
Telerik.Reporting.Charting.Styles..::.StyleAxisY

See Also

StyleAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Members

[image] [image]

Telerik Reporting Q2 2012
StyleAxis Members
StyleAxis Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleAxis type exposes the following members.

Constructors

Name | Description
StyleAxis | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label
styleAxisMajorGridLines | Major Grid Lines options
styleAxisMajorTick | Axis major ticks style
styleAxisMinorGridLines | Minor Grid Lines options
styleAxisMinorTick | Axis minor ticks style
styleAxisOrientation | Specifies the orientation property
styleAxisTextAppearance | Default axis items text properties style

Properties

Name | Description
Color | Color of Axis (Overrides StyleBorder..::.Color.)
CustomFormat | Specifies a custom numerical format string.
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items
MajorGridLines | Major Grid Lines options
MajorTick | ChartAxis major ticks style
MinorGridLines | Minor Grid Lines options
MinorTick | ChartAxis minor ticks style
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings
ValueFormat | Specifies a predefined numerical format string.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option
Width | Specifies the width of the axis. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleAxis Constructor
StyleAxis Class See Also Send Feedback

Overload List

Name | Description
StyleAxis()()() | Creates new instance of StyleAxis class
StyleAxis(ChartAxis) | Creates new instance of StyleAxis class
StyleAxis(Orientation) | Creates new instance of StyleAxis class
StyleAxis(Orientation, ChartAxis) | Creates new instance of StyleAxis class
StyleAxis(Orientation, ChartAxisVisibility) | Creates new instance of StyleAxis class
StyleAxis(Orientation, ChartAxisVisibility, ChartAxis) | Creates new instance of StyleAxis class
StyleAxis(Orientation, ChartAxisVisibility, LineStyle) | Creates new instance of StyleAxis class

See Also

StyleAxis Class
StyleAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis()
Visual Basic (Declaration)
Public Sub New

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (ChartAxis)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (ChartAxis)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    ChartAxis axis
)
Visual Basic (Declaration)
Public Sub New ( _
    axis As ChartAxis _
)

Parameters

axis
Type: Telerik.Reporting.Charting..::.ChartAxis
Axis related to

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (Orientation)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (Orientation)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    Orientation orientation
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As Orientation _
)

Parameters

orientation
Type: Telerik.Reporting.Charting.Styles..::.Orientation
Axis orientation

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (Orientation, ChartAxis)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (Orientation, ChartAxis)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    Orientation orientation,
    ChartAxis axis
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As Orientation, _
    axis As ChartAxis _
)

Parameters

orientation
Type: Telerik.Reporting.Charting.Styles..::.Orientation
Axis orientation
axis
Type: Telerik.Reporting.Charting..::.ChartAxis
Axis related to

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (Orientation, ChartAxisVisibility)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (Orientation, ChartAxisVisibility)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    Orientation orientation,
    ChartAxisVisibility visibility
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As Orientation, _
    visibility As ChartAxisVisibility _
)

Parameters

orientation
Type: Telerik.Reporting.Charting.Styles..::.Orientation
Axis orientation
visibility
Type: Telerik.Reporting.Charting.Styles..::.ChartAxisVisibility
Visibility of axis

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (Orientation, ChartAxisVisibility, ChartAxis)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (Orientation, ChartAxisVisibility, ChartAxis)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    Orientation orientation,
    ChartAxisVisibility visibility,
    ChartAxis axis
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As Orientation, _
    visibility As ChartAxisVisibility, _
    axis As ChartAxis _
)

Parameters

orientation
Type: Telerik.Reporting.Charting.Styles..::.Orientation
Axis orientation
visibility
Type: Telerik.Reporting.Charting.Styles..::.ChartAxisVisibility
Visibility of axis
axis
Type: Telerik.Reporting.Charting..::.ChartAxis
Axis orientation

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Constructor (Orientation, ChartAxisVisibility, LineStyle)

[image]

Telerik Reporting Q2 2012
StyleAxis Constructor (Orientation, ChartAxisVisibility, LineStyle)
StyleAxis Class See Also Send Feedback
Creates new instance of StyleAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxis(
    Orientation orientation,
    ChartAxisVisibility visibility,
    LineStyle lineStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As Orientation, _
    visibility As ChartAxisVisibility, _
    lineStyle As LineStyle _
)

Parameters

orientation
Type: Telerik.Reporting.Charting.Styles..::.Orientation
Axis orientation
visibility
Type: Telerik.Reporting.Charting.Styles..::.ChartAxisVisibility
Visisbility of axis
lineStyle
Type: Telerik.Reporting.Charting.Styles..::.LineStyle
Line style of axis

See Also

StyleAxis Class
StyleAxis Overload
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Fields

[image] [image]

Telerik Reporting Q2 2012
StyleAxis Fields
StyleAxis Class See Also Send Feedback

The StyleAxis type exposes the following members.

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label
styleAxisMajorGridLines | Major Grid Lines options
styleAxisMajorTick | Axis major ticks style
styleAxisMinorGridLines | Minor Grid Lines options
styleAxisMinorTick | Axis minor ticks style
styleAxisOrientation | Specifies the orientation property
styleAxisTextAppearance | Default axis items text properties style

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisLabelAppearance Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisLabelAppearance Field
StyleAxis Class See Also Send Feedback
Default style for axis label

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleLabel styleAxisLabelAppearance
Visual Basic (Declaration)
Protected styleAxisLabelAppearance As StyleLabel

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisMajorGridLines Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisMajorGridLines Field
StyleAxis Class See Also Send Feedback
Major Grid Lines options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleGridLine styleAxisMajorGridLines
Visual Basic (Declaration)
Protected styleAxisMajorGridLines As StyleGridLine

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisMajorTick Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisMajorTick Field
StyleAxis Class See Also Send Feedback
Axis major ticks style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleTickMajor styleAxisMajorTick
Visual Basic (Declaration)
Protected styleAxisMajorTick As StyleTickMajor

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisMinorGridLines Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisMinorGridLines Field
StyleAxis Class See Also Send Feedback
Minor Grid Lines options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleGridLine styleAxisMinorGridLines
Visual Basic (Declaration)
Protected styleAxisMinorGridLines As StyleGridLine

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisMinorTick Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisMinorTick Field
StyleAxis Class See Also Send Feedback
Axis minor ticks style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleTickMinor styleAxisMinorTick
Visual Basic (Declaration)
Protected styleAxisMinorTick As StyleTickMinor

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisOrientation Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisOrientation Field
StyleAxis Class See Also Send Feedback
Specifies the orientation property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Orientation styleAxisOrientation
Visual Basic (Declaration)
Protected styleAxisOrientation As Orientation

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


styleAxisTextAppearance Field

[image]

Telerik Reporting Q2 2012
StyleAxis..::.styleAxisTextAppearance Field
StyleAxis Class See Also Send Feedback
Default axis items text properties style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleAxisItemText styleAxisTextAppearance
Visual Basic (Declaration)
Protected styleAxisTextAppearance As StyleAxisItemText

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Methods

[image] [image]

Telerik Reporting Q2 2012
StyleAxis Methods
StyleAxis Class See Also Send Feedback

The StyleAxis type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Overrides StateManagedObject..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StateManagedObject..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StateManagedObject..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleAxis..::.Dispose Method
StyleAxis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides StateManagedObject..::.Dispose(Boolean).)

See Also

StyleAxis Class
StyleAxis Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleAxis..::.Dispose Method (Boolean)
StyleAxis Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleAxis Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleAxis..::.LoadViewState Method
StyleAxis Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleAxis..::.SaveViewState Method
StyleAxis Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleAxis..::.TrackViewState Method
StyleAxis Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxis Properties

[image] [image]

Telerik Reporting Q2 2012
StyleAxis Properties
StyleAxis Class See Also Send Feedback

The StyleAxis type exposes the following members.

Properties

Name | Description
Color | Color of Axis (Overrides StyleBorder..::.Color.)
CustomFormat | Specifies a custom numerical format string.
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items
MajorGridLines | Major Grid Lines options
MajorTick | ChartAxis major ticks style
MinorGridLines | Minor Grid Lines options
MinorTick | ChartAxis minor ticks style
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings
ValueFormat | Specifies a predefined numerical format string.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option
Width | Specifies the width of the axis. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.Color Property
StyleAxis Class See Also Send Feedback
Color of Axis

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


CustomFormat Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.CustomFormat Property
StyleAxis Class See Also Send Feedback
Specifies a custom numerical format string.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string CustomFormat { get; set; }
Visual Basic (Declaration)
Public Property CustomFormat As String

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


LabelAppearance Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.LabelAppearance Property
StyleAxis Class See Also Send Feedback
Default style for all axis items

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleLabel LabelAppearance { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property LabelAppearance As StyleLabel

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


MajorGridLines Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.MajorGridLines Property
StyleAxis Class See Also Send Feedback
Major Grid Lines options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleGridLine MajorGridLines { get; }
Visual Basic (Declaration)
Public ReadOnly Property MajorGridLines As StyleGridLine

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


MajorTick Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.MajorTick Property
StyleAxis Class See Also Send Feedback
ChartAxis major ticks style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMajor MajorTick { get; }
Visual Basic (Declaration)
Public ReadOnly Property MajorTick As StyleTickMajor

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


MinorGridLines Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.MinorGridLines Property
StyleAxis Class See Also Send Feedback
Minor Grid Lines options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleGridLine MinorGridLines { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property MinorGridLines As StyleGridLine

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


MinorTick Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.MinorTick Property
StyleAxis Class See Also Send Feedback
ChartAxis minor ticks style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleTickMinor MinorTick { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property MinorTick As StyleTickMinor

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


TextAppearance Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.TextAppearance Property
StyleAxis Class See Also Send Feedback
Common axis items labels text blocks settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxisItemText TextAppearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextAppearance As StyleAxisItemText

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


ValueFormat Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.ValueFormat Property
StyleAxis Class See Also Send Feedback
Specifies a predefined numerical format string.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartValueFormat ValueFormat { get; set; }
Visual Basic (Declaration)
Public Property ValueFormat As ChartValueFormat

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.Visible Property
StyleAxis Class See Also Send Feedback
Specifies the axis visibility option

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartAxisVisibility Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As ChartAxisVisibility

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
StyleAxis..::.Width Property
StyleAxis Class See Also Send Feedback
Specifies the width of the axis.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single

See Also

StyleAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Class

[image]

Telerik Reporting Q2 2012
StyleAxisItemText Class
Members See Also Send Feedback
Axis item label text block's appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleAxisItemText : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleAxisItemText _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleAxisItemText

See Also

StyleAxisItemText Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Members

[image] [image]

Telerik Reporting Q2 2012
StyleAxisItemText Members
StyleAxisItemText Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleAxisItemText type exposes the following members.

Constructors

Name | Description
StyleAxisItemText | Creates a new class instance

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value (Overrides StyleTextBlock..::.ResetMaxLength()()().)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Gets should the MaxLength value be serialized (Overrides StyleTextBlock..::.ShouldSerializeMaxLength()()().)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Constructor

[image]

Telerik Reporting Q2 2012
StyleAxisItemText Constructor
StyleAxisItemText Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxisItemText()
Visual Basic (Declaration)
Public Sub New

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Fields

[image] [image]

Telerik Reporting Q2 2012
StyleAxisItemText Fields
StyleAxisItemText Class See Also Send Feedback

The StyleAxisItemText type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Methods

[image] [image]

Telerik Reporting Q2 2012
StyleAxisItemText Methods
StyleAxisItemText Class See Also Send Feedback

The StyleAxisItemText type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value (Overrides StyleTextBlock..::.ResetMaxLength()()().)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Gets should the MaxLength value be serialized (Overrides StyleTextBlock..::.ShouldSerializeMaxLength()()().)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleAxisItemText..::.Dispose Method
StyleAxisItemText Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleAxisItemText Class
StyleAxisItemText Members
Telerik.Reporting.Charting.Styles Namespace


ResetMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleAxisItemText..::.ResetMaxLength Method
StyleAxisItemText Class See Also Send Feedback
Sets the default value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetMaxLength()
Visual Basic (Declaration)
Protected Overrides Sub ResetMaxLength

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleAxisItemText..::.ShouldSerializeMaxLength Method
StyleAxisItemText Class See Also Send Feedback
Gets should the MaxLength value be serialized

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override bool ShouldSerializeMaxLength()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeMaxLength As Boolean

Return Value

True if can be serialized, overwise returns false

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisItemText Properties

[image] [image]

Telerik Reporting Q2 2012
StyleAxisItemText Properties
StyleAxisItemText Class See Also Send Feedback

The StyleAxisItemText type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleAxisItemText Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Class

[image]

Telerik Reporting Q2 2012
StyleAxisLabel Class
Members See Also Send Feedback
Axis label style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleAxisLabel : StyleLabelHidden
Visual Basic (Declaration)
Public Class StyleAxisLabel _
    Inherits StyleLabelHidden

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelHidden
Telerik.Reporting.Charting.Styles..::.StyleAxisLabel
Telerik.Reporting.Charting.Styles..::.StyleYAxisLabel

See Also

StyleAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleAxisLabel Members
StyleAxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleAxisLabel type exposes the following members.

Constructors

Name | Description
StyleAxisLabel | Creates new instance of StyleAxisLabel class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleAxisLabel Constructor
StyleAxisLabel Class See Also Send Feedback
Creates new instance of StyleAxisLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleAxisLabel Fields
StyleAxisLabel Class See Also Send Feedback

The StyleAxisLabel type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleAxisLabel Methods
StyleAxisLabel Class See Also Send Feedback

The StyleAxisLabel type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleAxisLabel..::.Dispose Method
StyleAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleAxisLabel Class
StyleAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleAxisLabel Properties
StyleAxisLabel Class See Also Send Feedback

The StyleAxisLabel type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Class

[image]

Telerik Reporting Q2 2012
StyleAxisX Class
Members See Also Send Feedback
X axis specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleAxisX : StyleAxis
Visual Basic (Declaration)
Public Class StyleAxisX _
    Inherits StyleAxis

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleAxis
Telerik.Reporting.Charting.Styles..::.StyleAxisX

See Also

StyleAxisX Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Members

[image] [image]

Telerik Reporting Q2 2012
StyleAxisX Members
StyleAxisX Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleAxisX type exposes the following members.

Constructors

Name | Description
StyleAxisX | Creates new instance of StyleAxisX class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Inherited from StyleAxis.)
SaveViewState | Save data to ViewState (Inherited from StyleAxis.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleAxis.)

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label (Inherited from StyleAxis.)
styleAxisMajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
styleAxisMajorTick | Axis major ticks style (Inherited from StyleAxis.)
styleAxisMinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
styleAxisMinorTick | Axis minor ticks style (Inherited from StyleAxis.)
styleAxisOrientation | Specifies the orientation property (Inherited from StyleAxis.)
styleAxisTextAppearance | Default axis items text properties style (Inherited from StyleAxis.)

Properties

Name | Description
Color | Color of Axis (Inherited from StyleAxis.)
CustomFormat | Specifies a custom numerical format string. (Inherited from StyleAxis.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items (Inherited from StyleAxis.)
MajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
MajorTick | ChartAxis major ticks style (Inherited from StyleAxis.)
MinorGridLines | Specifies major ticks options (Overrides StyleAxis..::.MinorGridLines.)
MinorTick | Specifies minor ticks options (Overrides StyleAxis..::.MinorTick.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings (Inherited from StyleAxis.)
ValueFormat | Specifies a predefined numerical format string. (Inherited from StyleAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option (Inherited from StyleAxis.)
Width | Specifies the width of the axis. (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Constructor

[image]

Telerik Reporting Q2 2012
StyleAxisX Constructor
StyleAxisX Class See Also Send Feedback
Creates new instance of StyleAxisX class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxisX(
    ChartXAxis axis
)
Visual Basic (Declaration)
Public Sub New ( _
    axis As ChartXAxis _
)

Parameters

axis
Type: Telerik.Reporting.Charting..::.ChartXAxis
Axis related to

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Fields

[image] [image]

Telerik Reporting Q2 2012
StyleAxisX Fields
StyleAxisX Class See Also Send Feedback

The StyleAxisX type exposes the following members.

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label (Inherited from StyleAxis.)
styleAxisMajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
styleAxisMajorTick | Axis major ticks style (Inherited from StyleAxis.)
styleAxisMinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
styleAxisMinorTick | Axis minor ticks style (Inherited from StyleAxis.)
styleAxisOrientation | Specifies the orientation property (Inherited from StyleAxis.)
styleAxisTextAppearance | Default axis items text properties style (Inherited from StyleAxis.)

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Methods

[image] [image]

Telerik Reporting Q2 2012
StyleAxisX Methods
StyleAxisX Class See Also Send Feedback

The StyleAxisX type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Inherited from StyleAxis.)
SaveViewState | Save data to ViewState (Inherited from StyleAxis.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleAxisX..::.Dispose Method
StyleAxisX Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleAxis.)

See Also

StyleAxisX Class
StyleAxisX Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisX Properties

[image] [image]

Telerik Reporting Q2 2012
StyleAxisX Properties
StyleAxisX Class See Also Send Feedback

The StyleAxisX type exposes the following members.

Properties

Name | Description
Color | Color of Axis (Inherited from StyleAxis.)
CustomFormat | Specifies a custom numerical format string. (Inherited from StyleAxis.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items (Inherited from StyleAxis.)
MajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
MajorTick | ChartAxis major ticks style (Inherited from StyleAxis.)
MinorGridLines | Specifies major ticks options (Overrides StyleAxis..::.MinorGridLines.)
MinorTick | Specifies minor ticks options (Overrides StyleAxis..::.MinorTick.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings (Inherited from StyleAxis.)
ValueFormat | Specifies a predefined numerical format string. (Inherited from StyleAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option (Inherited from StyleAxis.)
Width | Specifies the width of the axis. (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


MinorGridLines Property

[image]

Telerik Reporting Q2 2012
StyleAxisX..::.MinorGridLines Property
StyleAxisX Class See Also Send Feedback
Specifies major ticks options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override StyleGridLine MinorGridLines { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MinorGridLines As StyleGridLine

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


MinorTick Property

[image]

Telerik Reporting Q2 2012
StyleAxisX..::.MinorTick Property
StyleAxisX Class See Also Send Feedback
Specifies minor ticks options

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override StyleTickMinor MinorTick { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MinorTick As StyleTickMinor

See Also

StyleAxisX Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Class

[image]

Telerik Reporting Q2 2012
StyleAxisY Class
Members See Also Send Feedback
Y axis specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleAxisY : StyleAxis
Visual Basic (Declaration)
Public Class StyleAxisY _
    Inherits StyleAxis

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleAxis
Telerik.Reporting.Charting.Styles..::.StyleAxisY

See Also

StyleAxisY Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Members

[image] [image]

Telerik Reporting Q2 2012
StyleAxisY Members
StyleAxisY Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleAxisY type exposes the following members.

Constructors

Name | Description
StyleAxisY | Creates new instance of StyleAxisY class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Inherited from StyleAxis.)
SaveViewState | Save data to ViewState (Inherited from StyleAxis.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleAxis.)

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label (Inherited from StyleAxis.)
styleAxisMajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
styleAxisMajorTick | Axis major ticks style (Inherited from StyleAxis.)
styleAxisMinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
styleAxisMinorTick | Axis minor ticks style (Inherited from StyleAxis.)
styleAxisOrientation | Specifies the orientation property (Inherited from StyleAxis.)
styleAxisTextAppearance | Default axis items text properties style (Inherited from StyleAxis.)

Properties

Name | Description
Color | Color of Axis (Inherited from StyleAxis.)
CustomFormat | Specifies a custom numerical format string. (Inherited from StyleAxis.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items (Inherited from StyleAxis.)
MajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
MajorTick | ChartAxis major ticks style (Inherited from StyleAxis.)
MinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
MinorTick | ChartAxis minor ticks style (Inherited from StyleAxis.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings (Inherited from StyleAxis.)
ValueFormat | Specifies a predefined numerical format string. (Inherited from StyleAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option (Inherited from StyleAxis.)
Width | Specifies the width of the axis. (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Constructor

[image]

Telerik Reporting Q2 2012
StyleAxisY Constructor
StyleAxisY Class See Also Send Feedback
Creates new instance of StyleAxisY class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleAxisY(
    ChartYAxis axis
)
Visual Basic (Declaration)
Public Sub New ( _
    axis As ChartYAxis _
)

Parameters

axis
Type: Telerik.Reporting.Charting..::.ChartYAxis
Axis related to

See Also

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Fields

[image] [image]

Telerik Reporting Q2 2012
StyleAxisY Fields
StyleAxisY Class See Also Send Feedback

The StyleAxisY type exposes the following members.

Fields

Name | Description
styleAxisLabelAppearance | Default style for axis label (Inherited from StyleAxis.)
styleAxisMajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
styleAxisMajorTick | Axis major ticks style (Inherited from StyleAxis.)
styleAxisMinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
styleAxisMinorTick | Axis minor ticks style (Inherited from StyleAxis.)
styleAxisOrientation | Specifies the orientation property (Inherited from StyleAxis.)
styleAxisTextAppearance | Default axis items text properties style (Inherited from StyleAxis.)

See Also

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Methods

[image] [image]

Telerik Reporting Q2 2012
StyleAxisY Methods
StyleAxisY Class See Also Send Feedback

The StyleAxisY type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Load data from ViewState (Inherited from StyleAxis.)
SaveViewState | Save data to ViewState (Inherited from StyleAxis.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleAxisY..::.Dispose Method
StyleAxisY Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleAxis.)

See Also

StyleAxisY Class
StyleAxisY Members
Telerik.Reporting.Charting.Styles Namespace


StyleAxisY Properties

[image] [image]

Telerik Reporting Q2 2012
StyleAxisY Properties
StyleAxisY Class See Also Send Feedback

The StyleAxisY type exposes the following members.

Properties

Name | Description
Color | Color of Axis (Inherited from StyleAxis.)
CustomFormat | Specifies a custom numerical format string. (Inherited from StyleAxis.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
LabelAppearance | Default style for all axis items (Inherited from StyleAxis.)
MajorGridLines | Major Grid Lines options (Inherited from StyleAxis.)
MajorTick | ChartAxis major ticks style (Inherited from StyleAxis.)
MinorGridLines | Minor Grid Lines options (Inherited from StyleAxis.)
MinorTick | ChartAxis minor ticks style (Inherited from StyleAxis.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
TextAppearance | Common axis items labels text blocks settings (Inherited from StyleAxis.)
ValueFormat | Specifies a predefined numerical format string. (Inherited from StyleAxis.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies the axis visibility option (Inherited from StyleAxis.)
Width | Specifies the width of the axis. (Inherited from StyleAxis.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleAxisY Class
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Class

[image]

Telerik Reporting Q2 2012
StyleBorder Class
Members See Also Send Feedback
Border style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleBorder : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class StyleBorder _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleChartBorder
Telerik.Reporting.Charting.Styles..::.StyleDataTableBorder
Telerik.Reporting.Charting.Styles..::.StyleLegendBorder
Telerik.Reporting.Charting.Styles..::.StyleSeriesBorder
Telerik.Reporting.Charting.Styles..::.StyleTitleBorder

See Also

StyleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleBorder Members
StyleBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleBorder type exposes the following members.

Constructors

Name | Description
StyleBorder | Overloaded.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the line color property
PenStyle | Specifies the pen style property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
Width | Specifies the width property

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleBorder Constructor
StyleBorder Class See Also Send Feedback

Overload List

Name | Description
StyleBorder()()() | Creates new instance of StyleBorder class
StyleBorder(Boolean) | Creates new instance of StyleBorder class
StyleBorder(Color) | Creates new instance of StyleBorder class
StyleBorder(Object) | Creates new instance of StyleBorder class
StyleBorder(Color, Single) | Creates new instance of StyleBorder class
StyleBorder(Color, Single, DashStyle) | Creates new instance of StyleBorder class

See Also

StyleBorder Class
StyleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor (Boolean)

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor (Boolean)
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder(
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean _
)

Parameters

visible
Type: System..::.Boolean
Border visibility

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor (Color)

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor (Color)
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)

Parameters

color
Type: System.Drawing..::.Color
Border color

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor (Object)

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor (Object)
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container object

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor (Color, Single)

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor (Color, Single)
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder(
    Color color,
    float width
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    width As Single _
)

Parameters

color
Type: System.Drawing..::.Color
Border color
width
Type: System..::.Single
Border width

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Constructor (Color, Single, DashStyle)

[image]

Telerik Reporting Q2 2012
StyleBorder Constructor (Color, Single, DashStyle)
StyleBorder Class See Also Send Feedback
Creates new instance of StyleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleBorder(
    Color color,
    float width,
    DashStyle penStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    width As Single, _
    penStyle As DashStyle _
)

Parameters

color
Type: System.Drawing..::.Color
Border color
width
Type: System..::.Single
Border width
penStyle
Type: System.Drawing.Drawing2D..::.DashStyle
Border PenStyle

See Also

StyleBorder Class
StyleBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleBorder Methods
StyleBorder Class See Also Send Feedback

The StyleBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleBorder..::.Clone Method
StyleBorder Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Object Clone()
Visual Basic (Declaration)
Public Overridable Function Clone As Object

Return Value

Object with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleBorder..::.Dispose Method
StyleBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleBorder Class
StyleBorder Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
StyleBorder..::.Equals Method
StyleBorder Class See Also Send Feedback
Compare two objects

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object tot compare

Return Value

Result of comparing

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
StyleBorder..::.GetHashCode Method
StyleBorder Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleBorder Properties
StyleBorder Class See Also Send Feedback

The StyleBorder type exposes the following members.

Properties

Name | Description
Color | Specifies the line color property
PenStyle | Specifies the pen style property
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility
Width | Specifies the width property

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleBorder..::.Color Property
StyleBorder Class See Also Send Feedback
Specifies the line color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Color Color { get; set; }
Visual Basic (Declaration)
Public Overridable Property Color As Color

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleBorder..::.PenStyle Property
StyleBorder Class See Also Send Feedback
Specifies the pen style property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overridable Property PenStyle As DashStyle

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleBorder..::.Visible Property
StyleBorder Class See Also Send Feedback
Visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Visible { get; set; }
Visual Basic (Declaration)
Public Overridable Property Visible As Boolean

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
StyleBorder..::.Width Property
StyleBorder Class See Also Send Feedback
Specifies the width property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Single

See Also

StyleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleChart Class

[image]

Telerik Reporting Q2 2012
StyleChart Class
Members See Also Send Feedback
Main chart appearance settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleChart : LayoutStyle
Visual Basic (Declaration)
Public Class StyleChart _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleChart

See Also

StyleChart Members
Telerik.Reporting.Charting.Styles Namespace


StyleChart Members

[image] [image]

Telerik Reporting Q2 2012
StyleChart Members
StyleChart Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleChart type exposes the following members.

Constructors

Name | Description
StyleChart | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Properties

Name | Description
BarOverlapPercent | Determines how much of the bar's area is overlapped in multiple bar charts.
BarWidthPercent | Determines the width of bars.
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
FillStyle | Specifies the background property
ImageQuality | Specifies the quality at which chart image is rendered.
Position | Obsolete. Gets positions (Overrides LayoutStyle..::.Position.)
Shadow | Specifies the shadow settings (Inherited from Style.)
TextQuality | Specifies the quality at which text in chart is rendered.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets visibility of chart (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


StyleChart Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleChart Constructor
StyleChart Class See Also Send Feedback

Overload List

Name | Description
StyleChart(Chart) | Creates new instance of StyleChart class.
StyleChart(DimensionsChart, FillStyleChart, Corners, StyleBorder, ShadowStyle, Boolean) | Creates new instance of StyleChart class.

See Also

StyleChart Class
StyleChart Members
Telerik.Reporting.Charting.Styles Namespace


StyleChart Constructor (Chart)

[image]

Telerik Reporting Q2 2012
StyleChart Constructor (Chart)
StyleChart Class See Also Send Feedback
Creates new instance of StyleChart class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChart(
    Chart chart
)
Visual Basic (Declaration)
Public Sub New ( _
    chart As Chart _
)

Parameters

chart
Type: Telerik.Reporting.Charting..::.Chart
Chart related to.

See Also

StyleChart Class
StyleChart Overload
Telerik.Reporting.Charting.Styles Namespace


StyleChart Constructor (DimensionsChart, FillStyleChart, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleChart Constructor (DimensionsChart, FillStyleChart, Corners, StyleBorder, ShadowStyle, Boolean)
StyleChart Class See Also Send Feedback
Creates new instance of StyleChart class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChart(
    DimensionsChart dimensions,
    FillStyleChart fillStyle,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As DimensionsChart, _
    fillStyle As FillStyleChart, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.DimensionsChart
Chart dimensions
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyleChart
FillStyle of chart
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Corners of chart
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Chart border style
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Chart shadow style
visible
Type: System..::.Boolean
Visibility of chart

See Also

StyleChart Class
StyleChart Overload
Telerik.Reporting.Charting.Styles Namespace


StyleChart Methods

[image] [image]

Telerik Reporting Q2 2012
StyleChart Methods
StyleChart Class See Also Send Feedback

The StyleChart type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleChart..::.Clone Method
StyleChart Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleChart..::.Dispose Method
StyleChart Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutStyle..::.Dispose(Boolean).)

See Also

StyleChart Class
StyleChart Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleChart..::.Dispose Method (Boolean)
StyleChart Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleChart Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleChart..::.LoadViewState Method
StyleChart Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewSatate with data

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleChart..::.SaveViewState Method
StyleChart Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleChart..::.TrackViewState Method
StyleChart Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


StyleChart Properties

[image] [image]

Telerik Reporting Q2 2012
StyleChart Properties
StyleChart Class See Also Send Feedback

The StyleChart type exposes the following members.

Properties

Name | Description
BarOverlapPercent | Determines how much of the bar's area is overlapped in multiple bar charts.
BarWidthPercent | Determines the width of bars.
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
FillStyle | Specifies the background property
ImageQuality | Specifies the quality at which chart image is rendered.
Position | Obsolete. Gets positions (Overrides LayoutStyle..::.Position.)
Shadow | Specifies the shadow settings (Inherited from Style.)
TextQuality | Specifies the quality at which text in chart is rendered.
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets visibility of chart (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


BarOverlapPercent Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.BarOverlapPercent Property
StyleChart Class See Also Send Feedback
Determines how much of the bar's area is overlapped in multiple bar charts.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public decimal BarOverlapPercent { get; set; }
Visual Basic (Declaration)
Public Property BarOverlapPercent As Decimal

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


BarWidthPercent Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.BarWidthPercent Property
StyleChart Class See Also Send Feedback
Determines the width of bars.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public decimal BarWidthPercent { get; set; }
Visual Basic (Declaration)
Public Property BarWidthPercent As Decimal

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.Corners Property
StyleChart Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.FillStyle Property
StyleChart Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleChart FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleChart

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


ImageQuality Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.ImageQuality Property
StyleChart Class See Also Send Feedback
Specifies the quality at which chart image is rendered.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageQuality ImageQuality { get; set; }
Visual Basic (Declaration)
Public Property ImageQuality As ImageQuality

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Position Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.Position Property
StyleChart Class See Also Send Feedback
Gets positions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Is not applicable")]
public override Position Position { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Is not applicable")> _
Public Overrides ReadOnly Property Position As Position

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


TextQuality Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.TextQuality Property
StyleChart Class See Also Send Feedback
Specifies the quality at which text in chart is rendered.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextQuality TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextQuality

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleChart..::.Visible Property
StyleChart Class See Also Send Feedback
Gets visibility of chart

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Visible As Boolean

See Also

StyleChart Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Class

[image]

Telerik Reporting Q2 2012
StyleChartBorder Class
Members See Also Send Feedback
Chart border specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleChartBorder : StyleBorder
Visual Basic (Declaration)
Public Class StyleChartBorder _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.StyleChartBorder

See Also

StyleChartBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleChartBorder Members
StyleChartBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleChartBorder type exposes the following members.

Constructors

Name | Description
StyleChartBorder | Initializes a new instance of the StyleChartBorder class

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleChartBorder Constructor
StyleChartBorder Class See Also Send Feedback
Initializes a new instance of the StyleChartBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChartBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleChartBorder Methods
StyleChartBorder Class See Also Send Feedback

The StyleChartBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleChartBorder..::.Dispose Method
StyleChartBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleChartBorder Class
StyleChartBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleChartBorder Properties
StyleChartBorder Class See Also Send Feedback

The StyleChartBorder type exposes the following members.

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleChartBorder..::.Color Property
StyleChartBorder Class See Also Send Feedback
Gets and sets border color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Chart's border color

See Also

StyleChartBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Class

[image]

Telerik Reporting Q2 2012
StyleChartDataTable Class
Members See Also Send Feedback
DataTable appearance settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleChartDataTable : LayoutStyle
Visual Basic (Declaration)
Public Class StyleChartDataTable _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleChartDataTable

See Also

StyleChartDataTable Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Members

[image] [image]

Telerik Reporting Q2 2012
StyleChartDataTable Members
StyleChartDataTable Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleChartDataTable type exposes the following members.

Constructors

Name | Description
StyleChartDataTable | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Properties

Name | Description
AutoTextWrap | Specifies text wrap property for texts in Data Table
Border | Specifies the border style (Inherited from Style.)
CellHeight | Specifies data table cell height
CellWidth | Specifies data table cell width
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
DrawHorizontalLines | Should horizontal lines be rendered
DrawLines | Hide/show all lines
DrawVerticalLines | Should vertical lines be rendered
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RenderType | Specifies data table rendering type
Shadow | Specifies the shadow settings (Inherited from Style.)
TextHorizontalAlign | Specifies text horizontal alignment
TextProperties | Specifies the text properties
TextVerticalAlign | Specifies text vertical alignment
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies DataTable visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleChartDataTable Constructor
StyleChartDataTable Class See Also Send Feedback

Overload List

Name | Description
StyleChartDataTable()()() | Creates a new instance of StyleChartDataTable class.
StyleChartDataTable(ChartDataTable) | Creates a new instance of StyleChartDataTable class.
StyleChartDataTable(Dimensions, FillStyle, Position, TextProperties, StyleBorder, ShadowStyle, Boolean) | Creates a new instance of StyleChartDataTable class.

See Also

StyleChartDataTable Class
StyleChartDataTable Members
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Constructor

[image]

Telerik Reporting Q2 2012
StyleChartDataTable Constructor
StyleChartDataTable Class See Also Send Feedback
Creates a new instance of StyleChartDataTable class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChartDataTable()
Visual Basic (Declaration)
Public Sub New

See Also

StyleChartDataTable Class
StyleChartDataTable Overload
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Constructor (ChartDataTable)

[image]

Telerik Reporting Q2 2012
StyleChartDataTable Constructor (ChartDataTable)
StyleChartDataTable Class See Also Send Feedback
Creates a new instance of StyleChartDataTable class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChartDataTable(
    ChartDataTable parent
)
Visual Basic (Declaration)
Public Sub New ( _
    parent As ChartDataTable _
)

Parameters

parent
Type: Telerik.Reporting.Charting..::.ChartDataTable
Parent element

See Also

StyleChartDataTable Class
StyleChartDataTable Overload
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Constructor (Dimensions, FillStyle, Position, TextProperties, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleChartDataTable Constructor (Dimensions, FillStyle, Position, TextProperties, StyleBorder, ShadowStyle, Boolean)
StyleChartDataTable Class See Also Send Feedback
Creates a new instance of StyleChartDataTable class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleChartDataTable(
    Dimensions dimensions,
    FillStyle fillStyle,
    Position position,
    TextProperties textProperties,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As Dimensions, _
    fillStyle As FillStyle, _
    position As Position, _
    textProperties As TextProperties, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
DataTable's dimensions
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
DataTable's fillStyle
position
Type: Telerik.Reporting.Charting.Styles..::.Position
DataTable's position
textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
DataTable's textProperties
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
DataTable's border
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
DataTable's shadowStyle
visible
Type: System..::.Boolean
DataTable's visiblity

See Also

StyleChartDataTable Class
StyleChartDataTable Overload
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Methods

[image] [image]

Telerik Reporting Q2 2012
StyleChartDataTable Methods
StyleChartDataTable Class See Also Send Feedback

The StyleChartDataTable type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.Clone Method
StyleChartDataTable Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.Dispose Method
StyleChartDataTable Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from LayoutStyle.)

See Also

StyleChartDataTable Class
StyleChartDataTable Members
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.LoadViewState Method
StyleChartDataTable Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.SaveViewState Method
StyleChartDataTable Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.TrackViewState Method
StyleChartDataTable Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


StyleChartDataTable Properties

[image] [image]

Telerik Reporting Q2 2012
StyleChartDataTable Properties
StyleChartDataTable Class See Also Send Feedback

The StyleChartDataTable type exposes the following members.

Properties

Name | Description
AutoTextWrap | Specifies text wrap property for texts in Data Table
Border | Specifies the border style (Inherited from Style.)
CellHeight | Specifies data table cell height
CellWidth | Specifies data table cell width
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
DrawHorizontalLines | Should horizontal lines be rendered
DrawLines | Hide/show all lines
DrawVerticalLines | Should vertical lines be rendered
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RenderType | Specifies data table rendering type
Shadow | Specifies the shadow settings (Inherited from Style.)
TextHorizontalAlign | Specifies text horizontal alignment
TextProperties | Specifies the text properties
TextVerticalAlign | Specifies text vertical alignment
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies DataTable visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.AutoTextWrap Property
StyleChartDataTable Class See Also Send Feedback
Specifies text wrap property for texts in Data Table

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AutoTextWrap AutoTextWrap { get; set; }
Visual Basic (Declaration)
Public Property AutoTextWrap As AutoTextWrap

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


CellHeight Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.CellHeight Property
StyleChartDataTable Class See Also Send Feedback
Specifies data table cell height

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CellHeight { get; set; }
Visual Basic (Declaration)
Public Property CellHeight As Integer

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


CellWidth Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.CellWidth Property
StyleChartDataTable Class See Also Send Feedback
Specifies data table cell width

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CellWidth { get; set; }
Visual Basic (Declaration)
Public Property CellWidth As Integer

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


DrawHorizontalLines Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.DrawHorizontalLines Property
StyleChartDataTable Class See Also Send Feedback
Should horizontal lines be rendered

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool DrawHorizontalLines { get; set; }
Visual Basic (Declaration)
Public Property DrawHorizontalLines As Boolean

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


DrawLines Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.DrawLines Property
StyleChartDataTable Class See Also Send Feedback
Hide/show all lines

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool DrawLines { get; set; }
Visual Basic (Declaration)
Public Property DrawLines As Boolean

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


DrawVerticalLines Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.DrawVerticalLines Property
StyleChartDataTable Class See Also Send Feedback
Should vertical lines be rendered

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool DrawVerticalLines { get; set; }
Visual Basic (Declaration)
Public Property DrawVerticalLines As Boolean

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.Figure Property
StyleChartDataTable Class See Also Send Feedback
Specifies the figure property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Figure { get; }
Visual Basic (Declaration)
Public ReadOnly Property Figure As String

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.FillStyle Property
StyleChartDataTable Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyle FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyle

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


RenderType Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.RenderType Property
StyleChartDataTable Class See Also Send Feedback
Specifies data table rendering type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TableRenderType RenderType { get; set; }
Visual Basic (Declaration)
Public Property RenderType As TableRenderType

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


TextHorizontalAlign Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.TextHorizontalAlign Property
StyleChartDataTable Class See Also Send Feedback
Specifies text horizontal alignment

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ContentHorizontalAlign TextHorizontalAlign { get; set; }
Visual Basic (Declaration)
Public Property TextHorizontalAlign As ContentHorizontalAlign

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.TextProperties Property
StyleChartDataTable Class See Also Send Feedback
Specifies the text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextProperties TextProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextProperties As TextProperties

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


TextVerticalAlign Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.TextVerticalAlign Property
StyleChartDataTable Class See Also Send Feedback
Specifies text vertical alignment

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ContentVerticalAlign TextVerticalAlign { get; set; }
Visual Basic (Declaration)
Public Property TextVerticalAlign As ContentVerticalAlign

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleChartDataTable..::.Visible Property
StyleChartDataTable Class See Also Send Feedback
Specifies DataTable visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleChartDataTable Class
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Class

[image]

Telerik Reporting Q2 2012
StyleDataTableBorder Class
Members See Also Send Feedback
Data table's border specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleDataTableBorder : StyleBorder
Visual Basic (Declaration)
Public Class StyleDataTableBorder _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.StyleDataTableBorder

See Also

StyleDataTableBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleDataTableBorder Members
StyleDataTableBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleDataTableBorder type exposes the following members.

Constructors

Name | Description
StyleDataTableBorder | Initializes a new instance of the StyleDataTableBorder class

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleDataTableBorder Constructor
StyleDataTableBorder Class See Also Send Feedback
Initializes a new instance of the StyleDataTableBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleDataTableBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleDataTableBorder Methods
StyleDataTableBorder Class See Also Send Feedback

The StyleDataTableBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleDataTableBorder..::.Dispose Method
StyleDataTableBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleDataTableBorder Class
StyleDataTableBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleDataTableBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleDataTableBorder Properties
StyleDataTableBorder Class See Also Send Feedback

The StyleDataTableBorder type exposes the following members.

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleDataTableBorder..::.Color Property
StyleDataTableBorder Class See Also Send Feedback
Gets and sets border color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

DataTable's border color

See Also

StyleDataTableBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Class

[image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries Class
Members See Also Send Feedback
Empty Line series specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleEmptyLineSeries : StyleLineSeries
Visual Basic (Declaration)
Public Class StyleEmptyLineSeries _
    Inherits StyleLineSeries

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleLineSeries
Telerik.Reporting.Charting.Styles..::.StyleEmptyLineSeries

See Also

StyleEmptyLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Members

[image] [image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries Members
StyleEmptyLineSeries Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleEmptyLineSeries type exposes the following members.

Constructors

Name | Description
StyleEmptyLineSeries | Initializes a new instance of the StyleEmptyLineSeries class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets or sets color of the series line (Overrides StyleLineSeries..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
IsEmptyLine | Checks if line belongs to StyleEmptyLineSeries class. (Inherited from StyleLineSeries.)
PenStyle | Gets or sets PenStyle of the series line (Overrides StyleLineSeries..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Line series visibility (same as Series.Visible) (Inherited from StyleLineSeries.)
Width | Gets or sets the width of the series line. (Inherited from StyleLineSeries.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Constructor

[image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries Constructor
StyleEmptyLineSeries Class See Also Send Feedback
Initializes a new instance of the StyleEmptyLineSeries class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleEmptyLineSeries()
Visual Basic (Declaration)
Public Sub New

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Methods

[image] [image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries Methods
StyleEmptyLineSeries Class See Also Send Feedback

The StyleEmptyLineSeries type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries..::.Dispose Method
StyleEmptyLineSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleEmptyLineSeries Class
StyleEmptyLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleEmptyLineSeries Properties

[image] [image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries Properties
StyleEmptyLineSeries Class See Also Send Feedback

The StyleEmptyLineSeries type exposes the following members.

Properties

Name | Description
Color | Gets or sets color of the series line (Overrides StyleLineSeries..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
IsEmptyLine | Checks if line belongs to StyleEmptyLineSeries class. (Inherited from StyleLineSeries.)
PenStyle | Gets or sets PenStyle of the series line (Overrides StyleLineSeries..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Line series visibility (same as Series.Visible) (Inherited from StyleLineSeries.)
Width | Gets or sets the width of the series line. (Inherited from StyleLineSeries.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries..::.Color Property
StyleEmptyLineSeries Class See Also Send Feedback
Gets or sets color of the series line

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Color of line

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleEmptyLineSeries..::.PenStyle Property
StyleEmptyLineSeries Class See Also Send Feedback
Gets or sets PenStyle of the series line

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property PenStyle As DashStyle

Field Value

PenStyle of line

See Also

StyleEmptyLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Class

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleExtendedLabel : StyleLabel
Visual Basic (Declaration)
Public Class StyleExtendedLabel _
    Inherits StyleLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelLegend

See Also

StyleExtendedLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel Members
StyleExtendedLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleExtendedLabel type exposes the following members.

Constructors

Name | Description
StyleExtendedLabel | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides StyleLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StyleLabel..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StyleLabel..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StyleLabel..::.TrackViewState()()().)

Fields

Name | Description
styleExtendedLabelItemAppearance | Specifies label item's style
styleExtendedLabelItemMarkerAppearance | Specifies label item's marker's style
styleExtendedLabelItemTextAppearance | Specifies label item's textblock's style
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
GroupNameFormat | Specifies the series names format shown in Legend when data grouping being used and names are digits.
ItemAppearance | Specifies item label's style
ItemMarkerAppearance | Specifies item label's marker's style
ItemTextAppearance | Specifies item label's text's style
Location | Specifies label location (InsidePlotArea, OutsidePlotArea)
Overflow | Specifies the behavior when overflow occurred
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor
StyleExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
StyleExtendedLabel()()() | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(ChartSeries) | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(FillStyle) | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(Position) | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(FillStyle, Position) | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(FillStyle, Position, Dimensions) | Creates new instance of StyleExtendedLabel class
StyleExtendedLabel(LabelItemsCompositionTypes, Dimensions, String, FillStyle, Overflow, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean) | Creates new instance of StyleExtendedLabel class

See Also

StyleExtendedLabel Class
StyleExtendedLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (ChartSeries)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Container element

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (FillStyle)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (FillStyle)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    FillStyle fillStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (Position)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (Position)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Position _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position of label

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (FillStyle, Position)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (FillStyle, Position)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    FillStyle fillStyle,
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position of label

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (FillStyle, Position, Dimensions)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (FillStyle, Position, Dimensions)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    FillStyle fillStyle,
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position of label
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Constructor (LabelItemsCompositionTypes, Dimensions, String, FillStyle, Overflow, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel Constructor (LabelItemsCompositionTypes, Dimensions, String, FillStyle, Overflow, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)
StyleExtendedLabel Class See Also Send Feedback
Creates new instance of StyleExtendedLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleExtendedLabel(
    LabelItemsCompositionTypes compositionType,
    Dimensions dimensions,
    string figure,
    FillStyle fillStyle,
    Overflow overflow,
    Position position,
    float rotationAngle,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    compositionType As LabelItemsCompositionTypes, _
    dimensions As Dimensions, _
    figure As String, _
    fillStyle As FillStyle, _
    overflow As Overflow, _
    position As Position, _
    rotationAngle As Single, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

compositionType
Type: Telerik.Reporting.Charting.Styles..::.LabelItemsCompositionTypes
Composition type of label items
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions
figure
Type: System..::.String
Label's figure
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Label's fillstyle settings
overflow
Type: Telerik.Reporting.Charting.Styles..::.Overflow
Layout of label items
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position
rotationAngle
Type: System..::.Single
Label's rotation angle
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Label's corners
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Label's border
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Label's shadow style
visible
Type: System..::.Boolean
Label's visibility

See Also

StyleExtendedLabel Class
StyleExtendedLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel Fields
StyleExtendedLabel Class See Also Send Feedback

The StyleExtendedLabel type exposes the following members.

Fields

Name | Description
styleExtendedLabelItemAppearance | Specifies label item's style
styleExtendedLabelItemMarkerAppearance | Specifies label item's marker's style
styleExtendedLabelItemTextAppearance | Specifies label item's textblock's style
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleExtendedLabelItemAppearance Field

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.styleExtendedLabelItemAppearance Field
StyleExtendedLabel Class See Also Send Feedback
Specifies label item's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleLabel styleExtendedLabelItemAppearance
Visual Basic (Declaration)
Protected styleExtendedLabelItemAppearance As StyleLabel

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleExtendedLabelItemMarkerAppearance Field

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.styleExtendedLabelItemMarkerAppearance Field
StyleExtendedLabel Class See Also Send Feedback
Specifies label item's marker's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleMarker styleExtendedLabelItemMarkerAppearance
Visual Basic (Declaration)
Protected styleExtendedLabelItemMarkerAppearance As StyleMarker

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleExtendedLabelItemTextAppearance Field

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.styleExtendedLabelItemTextAppearance Field
StyleExtendedLabel Class See Also Send Feedback
Specifies label item's textblock's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected StyleTextBlock styleExtendedLabelItemTextAppearance
Visual Basic (Declaration)
Protected styleExtendedLabelItemTextAppearance As StyleTextBlock

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel Methods
StyleExtendedLabel Class See Also Send Feedback

The StyleExtendedLabel type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides StyleLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StyleLabel..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StyleLabel..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StyleLabel..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.Clone Method
StyleExtendedLabel Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.Dispose Method
StyleExtendedLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases the unmanaged resources used by the StyleExtendedLabel and optionally releases the managed resources (Overrides StyleLabel..::.Dispose(Boolean).)

See Also

StyleExtendedLabel Class
StyleExtendedLabel Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.Dispose Method (Boolean)
StyleExtendedLabel Class See Also Send Feedback
Releases the unmanaged resources used by the StyleExtendedLabel and optionally releases the managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

StyleExtendedLabel Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.LoadViewState Method
StyleExtendedLabel Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.SaveViewState Method
StyleExtendedLabel Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.TrackViewState Method
StyleExtendedLabel Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleExtendedLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleExtendedLabel Properties
StyleExtendedLabel Class See Also Send Feedback

The StyleExtendedLabel type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
GroupNameFormat | Specifies the series names format shown in Legend when data grouping being used and names are digits.
ItemAppearance | Specifies item label's style
ItemMarkerAppearance | Specifies item label's marker's style
ItemTextAppearance | Specifies item label's text's style
Location | Specifies label location (InsidePlotArea, OutsidePlotArea)
Overflow | Specifies the behavior when overflow occurred
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


GroupNameFormat Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.GroupNameFormat Property
StyleExtendedLabel Class See Also Send Feedback
Specifies the series names format shown in Legend when data grouping being used and names are digits.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string GroupNameFormat { get; set; }
Visual Basic (Declaration)
Public Property GroupNameFormat As String

Remarks

Supported format strings as "#VALUE" / "#NAME"

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


ItemAppearance Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.ItemAppearance Property
StyleExtendedLabel Class See Also Send Feedback
Specifies item label's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleLabel ItemAppearance { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemAppearance As StyleLabel

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


ItemMarkerAppearance Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.ItemMarkerAppearance Property
StyleExtendedLabel Class See Also Send Feedback
Specifies item label's marker's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleMarker ItemMarkerAppearance { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemMarkerAppearance As StyleMarker

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


ItemTextAppearance Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.ItemTextAppearance Property
StyleExtendedLabel Class See Also Send Feedback
Specifies item label's text's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual StyleTextBlock ItemTextAppearance { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ItemTextAppearance As StyleTextBlock

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


Location Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.Location Property
StyleExtendedLabel Class See Also Send Feedback
Specifies label location (InsidePlotArea, OutsidePlotArea)

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LabelLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As LabelLocation

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


Overflow Property

[image]

Telerik Reporting Q2 2012
StyleExtendedLabel..::.Overflow Property
StyleExtendedLabel Class See Also Send Feedback
Specifies the behavior when overflow occurred

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Overflow Overflow { get; set; }
Visual Basic (Declaration)
Public Overridable Property Overflow As Overflow

See Also

StyleExtendedLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Class

[image]

Telerik Reporting Q2 2012
StyleGridLine Class
Members See Also Send Feedback
Grid line specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleGridLine : LineStyle
Visual Basic (Declaration)
Public Class StyleGridLine _
    Inherits LineStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleGridLine
Telerik.Reporting.Charting.Styles..::.StyleGridLineHidden
Telerik.Reporting.Charting.Styles..::.StyleGridLineMajor

See Also

StyleGridLine Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Members

[image] [image]

Telerik Reporting Q2 2012
StyleGridLine Members
StyleGridLine Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleGridLine type exposes the following members.

Constructors

Name | Description
StyleGridLine | Initializes a new instance of the StyleGridLine class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the color of the grid lines. (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not
PenStyle | Specifies the pen style used for grid lines' drawing. (Overrides StyleBorder..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Constructor

[image]

Telerik Reporting Q2 2012
StyleGridLine Constructor
StyleGridLine Class See Also Send Feedback
Initializes a new instance of the StyleGridLine class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleGridLine()
Visual Basic (Declaration)
Public Sub New

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Methods

[image] [image]

Telerik Reporting Q2 2012
StyleGridLine Methods
StyleGridLine Class See Also Send Feedback

The StyleGridLine type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleGridLine..::.Dispose Method
StyleGridLine Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleGridLine Class
StyleGridLine Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLine Properties

[image] [image]

Telerik Reporting Q2 2012
StyleGridLine Properties
StyleGridLine Class See Also Send Feedback

The StyleGridLine type exposes the following members.

Properties

Name | Description
Color | Specifies the color of the grid lines. (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not
PenStyle | Specifies the pen style used for grid lines' drawing. (Overrides StyleBorder..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleGridLine..::.Color Property
StyleGridLine Class See Also Send Feedback
Specifies the color of the grid lines.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


HideWithAxis Property

[image]

Telerik Reporting Q2 2012
StyleGridLine..::.HideWithAxis Property
StyleGridLine Class See Also Send Feedback
Should grid lines be hidden with axis or not

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool HideWithAxis { get; set; }
Visual Basic (Declaration)
Public Property HideWithAxis As Boolean

Remarks

Default value is true

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleGridLine..::.PenStyle Property
StyleGridLine Class See Also Send Feedback
Specifies the pen style used for grid lines' drawing.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property PenStyle As DashStyle

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
StyleGridLine..::.Width Property
StyleGridLine Class See Also Send Feedback
Gets or sets the width of the grid line.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single

See Also

StyleGridLine Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Class

[image]

Telerik Reporting Q2 2012
StyleGridLineHidden Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleGridLineHidden : StyleGridLine
Visual Basic (Declaration)
Public Class StyleGridLineHidden _
    Inherits StyleGridLine

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleGridLine
Telerik.Reporting.Charting.Styles..::.StyleGridLineHidden

See Also

StyleGridLineHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Members

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineHidden Members
StyleGridLineHidden Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleGridLineHidden type exposes the following members.

Constructors

Name | Description
StyleGridLineHidden | Initializes a new instance of the StyleGridLineHidden class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Inherited from StyleGridLine.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets grid lines' visibility (Overrides StyleBorder..::.Visible.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Constructor

[image]

Telerik Reporting Q2 2012
StyleGridLineHidden Constructor
StyleGridLineHidden Class See Also Send Feedback
Initializes a new instance of the StyleGridLineHidden class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleGridLineHidden()
Visual Basic (Declaration)
Public Sub New

See Also

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Methods

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineHidden Methods
StyleGridLineHidden Class See Also Send Feedback

The StyleGridLineHidden type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineHidden..::.Dispose Method
StyleGridLineHidden Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleGridLineHidden Class
StyleGridLineHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineHidden Properties

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineHidden Properties
StyleGridLineHidden Class See Also Send Feedback

The StyleGridLineHidden type exposes the following members.

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Inherited from StyleGridLine.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Gets and sets grid lines' visibility (Overrides StyleBorder..::.Visible.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleGridLineHidden..::.Visible Property
StyleGridLineHidden Class See Also Send Feedback
Gets and sets grid lines' visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleGridLineHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Class

[image]

Telerik Reporting Q2 2012
StyleGridLineMajor Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleGridLineMajor : StyleGridLine
Visual Basic (Declaration)
Public Class StyleGridLineMajor _
    Inherits StyleGridLine

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleGridLine
Telerik.Reporting.Charting.Styles..::.StyleGridLineMajor
Telerik.Reporting.Charting.Styles..::.StyleGridLineMajorXAxis

See Also

StyleGridLineMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Members

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajor Members
StyleGridLineMajor Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleGridLineMajor type exposes the following members.

Constructors

Name | Description
StyleGridLineMajor | Initializes a new instance of the StyleGridLineMajor class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Inherited from StyleGridLine.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Constructor

[image]

Telerik Reporting Q2 2012
StyleGridLineMajor Constructor
StyleGridLineMajor Class See Also Send Feedback
Initializes a new instance of the StyleGridLineMajor class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleGridLineMajor()
Visual Basic (Declaration)
Public Sub New

See Also

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Methods

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajor Methods
StyleGridLineMajor Class See Also Send Feedback

The StyleGridLineMajor type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajor..::.Dispose Method
StyleGridLineMajor Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleGridLineMajor Class
StyleGridLineMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajor Properties

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajor Properties
StyleGridLineMajor Class See Also Send Feedback

The StyleGridLineMajor type exposes the following members.

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Inherited from StyleGridLine.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Class

[image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleGridLineMajorXAxis : StyleGridLineMajor
Visual Basic (Declaration)
Public Class StyleGridLineMajorXAxis _
    Inherits StyleGridLineMajor

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleGridLine
Telerik.Reporting.Charting.Styles..::.StyleGridLineMajor
Telerik.Reporting.Charting.Styles..::.StyleGridLineMajorXAxis

See Also

StyleGridLineMajorXAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Members

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis Members
StyleGridLineMajorXAxis Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleGridLineMajorXAxis type exposes the following members.

Constructors

Name | Description
StyleGridLineMajorXAxis | Initializes a new instance of the StyleGridLineMajorXAxis class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Overrides StyleGridLine..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Constructor

[image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis Constructor
StyleGridLineMajorXAxis Class See Also Send Feedback
Initializes a new instance of the StyleGridLineMajorXAxis class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleGridLineMajorXAxis()
Visual Basic (Declaration)
Public Sub New

See Also

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Methods

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis Methods
StyleGridLineMajorXAxis Class See Also Send Feedback

The StyleGridLineMajorXAxis type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis..::.Dispose Method
StyleGridLineMajorXAxis Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleGridLineMajorXAxis Class
StyleGridLineMajorXAxis Members
Telerik.Reporting.Charting.Styles Namespace


StyleGridLineMajorXAxis Properties

[image] [image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis Properties
StyleGridLineMajorXAxis Class See Also Send Feedback

The StyleGridLineMajorXAxis type exposes the following members.

Properties

Name | Description
Color | Specifies the color of the grid lines. (Inherited from StyleGridLine.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
HideWithAxis | Should grid lines be hidden with axis or not (Inherited from StyleGridLine.)
PenStyle | Specifies the pen style used for grid lines' drawing. (Overrides StyleGridLine..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Gets or sets the width of the grid line. (Inherited from StyleGridLine.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleGridLineMajorXAxis..::.PenStyle Property
StyleGridLineMajorXAxis Class See Also Send Feedback
Specifies the pen style used for grid lines' drawing.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property PenStyle As DashStyle

See Also

StyleGridLineMajorXAxis Class
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Class

[image]

Telerik Reporting Q2 2012
StyleItemLabelConnector Class
Members See Also Send Feedback
Series item label connector line specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleItemLabelConnector : LineStyle
Visual Basic (Declaration)
Public Class StyleItemLabelConnector _
    Inherits LineStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleItemLabelConnector

See Also

StyleItemLabelConnector Members
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Members

[image] [image]

Telerik Reporting Q2 2012
StyleItemLabelConnector Members
StyleItemLabelConnector Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleItemLabelConnector type exposes the following members.

Constructors

Name | Description
StyleItemLabelConnector | Creates new instance of StyleItemLabelConnector class.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets item label connector's color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Constructor

[image]

Telerik Reporting Q2 2012
StyleItemLabelConnector Constructor
StyleItemLabelConnector Class See Also Send Feedback
Creates new instance of StyleItemLabelConnector class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleItemLabelConnector()
Visual Basic (Declaration)
Public Sub New

See Also

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Methods

[image] [image]

Telerik Reporting Q2 2012
StyleItemLabelConnector Methods
StyleItemLabelConnector Class See Also Send Feedback

The StyleItemLabelConnector type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleItemLabelConnector..::.Dispose Method
StyleItemLabelConnector Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleItemLabelConnector Class
StyleItemLabelConnector Members
Telerik.Reporting.Charting.Styles Namespace


StyleItemLabelConnector Properties

[image] [image]

Telerik Reporting Q2 2012
StyleItemLabelConnector Properties
StyleItemLabelConnector Class See Also Send Feedback

The StyleItemLabelConnector type exposes the following members.

Properties

Name | Description
Color | Gets and sets item label connector's color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleItemLabelConnector..::.Color Property
StyleItemLabelConnector Class See Also Send Feedback
Gets and sets item label connector's color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Item label connector'scolor

See Also

StyleItemLabelConnector Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Class

[image]

Telerik Reporting Q2 2012
StyleLabel Class
Members See Also Send Feedback
Base label appearance style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLabel : LayoutStyle
Visual Basic (Declaration)
Public Class StyleLabel _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelEmptySeriesMessage
Telerik.Reporting.Charting.Styles..::.StyleLabelHidden
Telerik.Reporting.Charting.Styles..::.StyleLabelTitle
Telerik.Reporting.Charting.Styles..::.StyleSeriesItemLabel

See Also

StyleLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleLabel Members
StyleLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleLabel type exposes the following members.

Constructors

Name | Description
StyleLabel | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleLabel Constructor
StyleLabel Class See Also Send Feedback

Overload List

Name | Description
StyleLabel()()() | Creates new instance of StyleLabel class.
StyleLabel(Object) | Creates new instance of StyleLabel class.
StyleLabel(FillStyle) | Creates new instance of StyleLabel class.
StyleLabel(Position) | Creates new instance of StyleLabel class.
StyleLabel(FillStyle, Position) | Creates new instance of StyleLabel class.
StyleLabel(FillStyle, Position, Dimensions) | Creates new instance of StyleLabel class.
StyleLabel(FillStyle, Corners, Position, Dimensions) | Creates new instance of StyleLabel class.
StyleLabel(LabelItemsCompositionTypes, Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean) | Creates new instance of StyleLabel class.

See Also

StyleLabel Class
StyleLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (Object)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (Object)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Style container element

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (FillStyle)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (FillStyle)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    FillStyle fillStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (Position)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (Position)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Position _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (FillStyle, Position)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (FillStyle, Position)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    FillStyle fillStyle,
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (FillStyle, Position, Dimensions)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (FillStyle, Position, Dimensions)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    FillStyle fillStyle,
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (FillStyle, Corners, Position, Dimensions)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (FillStyle, Corners, Position, Dimensions)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    FillStyle fillStyle,
    Corners corners,
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    corners As Corners, _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Corners of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Constructor (LabelItemsCompositionTypes, Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleLabel Constructor (LabelItemsCompositionTypes, Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)
StyleLabel Class See Also Send Feedback
Creates new instance of StyleLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabel(
    LabelItemsCompositionTypes compositionType,
    Dimensions dimensions,
    string figure,
    FillStyle fillStyle,
    Position position,
    float rotationAngle,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    compositionType As LabelItemsCompositionTypes, _
    dimensions As Dimensions, _
    figure As String, _
    fillStyle As FillStyle, _
    position As Position, _
    rotationAngle As Single, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

compositionType
Type: Telerik.Reporting.Charting.Styles..::.LabelItemsCompositionTypes
CompositionType to specify textblock and marker positions
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions
figure
Type: System..::.String
Label's figure
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position
rotationAngle
Type: System..::.Single
Rotation angle
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Corners of label
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Label's border
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Shadow style of label
visible
Type: System..::.Boolean
Label's visibility

See Also

StyleLabel Class
StyleLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleLabel Fields
StyleLabel Class See Also Send Feedback

The StyleLabel type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


styleLabelCorners Field

[image]

Telerik Reporting Q2 2012
StyleLabel..::.styleLabelCorners Field
StyleLabel Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Corners styleLabelCorners
Visual Basic (Declaration)
Protected styleLabelCorners As Corners

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLabel Methods
StyleLabel Class See Also Send Feedback

The StyleLabel type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleLabel..::.Clone Method
StyleLabel Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLabel..::.Dispose Method
StyleLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutStyle..::.Dispose(Boolean).)

See Also

StyleLabel Class
StyleLabel Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleLabel..::.Dispose Method (Boolean)
StyleLabel Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleLabel Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleLabel..::.LoadViewState Method
StyleLabel Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleLabel..::.SaveViewState Method
StyleLabel Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleLabel..::.TrackViewState Method
StyleLabel Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLabel Properties
StyleLabel Class See Also Send Feedback

The StyleLabel type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


CompositionType Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.CompositionType Property
StyleLabel Class See Also Send Feedback
Specifies the label's items composition type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual LabelItemsCompositionTypes CompositionType { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompositionType As LabelItemsCompositionTypes

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.Corners Property
StyleLabel Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.Figure Property
StyleLabel Class See Also Send Feedback
Specifies the figure property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual string Figure { get; set; }
Visual Basic (Declaration)
Public Overridable Property Figure As String

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.FillStyle Property
StyleLabel Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual FillStyle FillStyle { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


RotationAngle Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.RotationAngle Property
StyleLabel Class See Also Send Feedback
Specifies the rotation angle property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float RotationAngle { get; set; }
Visual Basic (Declaration)
Public Overridable Property RotationAngle As Single

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleLabel..::.Visible Property
StyleLabel Class See Also Send Feedback
Specifies tha label's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Class

[image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Class
Members See Also Send Feedback
Empty series message style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLabelEmptySeriesMessage : StyleLabel
Visual Basic (Declaration)
Public Class StyleLabelEmptySeriesMessage _
    Inherits StyleLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelEmptySeriesMessage

See Also

StyleLabelEmptySeriesMessage Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Members

[image] [image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Members
StyleLabelEmptySeriesMessage Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleLabelEmptySeriesMessage type exposes the following members.

Constructors

Name | Description
StyleLabelEmptySeriesMessage | Creates new instance of StyleLabelEmptySeriesMessage class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies label' visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Constructor

[image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Constructor
StyleLabelEmptySeriesMessage Class See Also Send Feedback
Creates new instance of StyleLabelEmptySeriesMessage class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelEmptySeriesMessage()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Fields

[image] [image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Fields
StyleLabelEmptySeriesMessage Class See Also Send Feedback

The StyleLabelEmptySeriesMessage type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Methods
StyleLabelEmptySeriesMessage Class See Also Send Feedback

The StyleLabelEmptySeriesMessage type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage..::.Dispose Method
StyleLabelEmptySeriesMessage Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleLabelEmptySeriesMessage Class
StyleLabelEmptySeriesMessage Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelEmptySeriesMessage Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage Properties
StyleLabelEmptySeriesMessage Class See Also Send Feedback

The StyleLabelEmptySeriesMessage type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies label' visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleLabelEmptySeriesMessage..::.Visible Property
StyleLabelEmptySeriesMessage Class See Also Send Feedback
Specifies label' visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleLabelEmptySeriesMessage Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Class

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLabelHidden : StyleLabel
Visual Basic (Declaration)
Public Class StyleLabelHidden _
    Inherits StyleLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelHidden
Telerik.Reporting.Charting.Styles..::.StyleAxisLabel

See Also

StyleLabelHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Members

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden Members
StyleLabelHidden Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleLabelHidden type exposes the following members.

Constructors

Name | Description
StyleLabelHidden | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor
StyleLabelHidden Class See Also Send Feedback

Overload List

Name | Description
StyleLabelHidden()()() | Creates new instance of StyleLabelHidden class.
StyleLabelHidden(Object) | Creates new instance of StyleLabelHidden class.
StyleLabelHidden(FillStyle) | Creates new instance of StyleLabelHidden class.
StyleLabelHidden(Position) | Creates new instance of StyleLabelHidden class.
StyleLabelHidden(FillStyle, Position) | Creates new instance of StyleLabelHidden class.
StyleLabelHidden(FillStyle, Position, Dimensions) | Creates new instance of StyleLabelHidden class.

See Also

StyleLabelHidden Class
StyleLabelHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor (Object)

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor (Object)
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Container element

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor (FillStyle)

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor (FillStyle)
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden(
    FillStyle fillStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor (Position)

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor (Position)
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden(
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As Position _
)

Parameters

position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor (FillStyle, Position)

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor (FillStyle, Position)
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden(
    FillStyle fillStyle,
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Constructor (FillStyle, Position, Dimensions)

[image]

Telerik Reporting Q2 2012
StyleLabelHidden Constructor (FillStyle, Position, Dimensions)
StyleLabelHidden Class See Also Send Feedback
Creates new instance of StyleLabelHidden class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelHidden(
    FillStyle fillStyle,
    Position position,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position, _
    dimensions As Dimensions _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
FillStyle of label
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Label's position
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Label's dimensions

See Also

StyleLabelHidden Class
StyleLabelHidden Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Fields

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden Fields
StyleLabelHidden Class See Also Send Feedback

The StyleLabelHidden type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden Methods
StyleLabelHidden Class See Also Send Feedback

The StyleLabelHidden type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden..::.Dispose Method
StyleLabelHidden Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleLabelHidden Class
StyleLabelHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelHidden Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLabelHidden Properties
StyleLabelHidden Class See Also Send Feedback

The StyleLabelHidden type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleLabelHidden..::.Visible Property
StyleLabelHidden Class See Also Send Feedback
Specifies tha label's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleLabelHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Class

[image]

Telerik Reporting Q2 2012
StyleLabelLegend Class
Members See Also Send Feedback
Legend appearance style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLabelLegend : StyleExtendedLabel
Visual Basic (Declaration)
Public Class StyleLabelLegend _
    Inherits StyleExtendedLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleExtendedLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelLegend

See Also

StyleLabelLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Members

[image] [image]

Telerik Reporting Q2 2012
StyleLabelLegend Members
StyleLabelLegend Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleLabelLegend type exposes the following members.

Constructors

Name | Description
StyleLabelLegend | Creates new instance of StyleLabelLegend class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleExtendedLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleExtendedLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleExtendedLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleExtendedLabel.)

Fields

Name | Description
styleExtendedLabelItemAppearance | Specifies label item's style (Inherited from StyleExtendedLabel.)
styleExtendedLabelItemMarkerAppearance | Specifies label item's marker's style (Inherited from StyleExtendedLabel.)
styleExtendedLabelItemTextAppearance | Specifies label item's textblock's style (Inherited from StyleExtendedLabel.)
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Gets label's figure (Overrides StyleLabel..::.Figure.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
GroupNameFormat | Specifies the series names format shown in Legend when data grouping being used and names are digits. (Inherited from StyleExtendedLabel.)
ItemAppearance | Specifies item label's style (Inherited from StyleExtendedLabel.)
ItemMarkerAppearance | Specifies item label's marker's style (Inherited from StyleExtendedLabel.)
ItemTextAppearance | Specifies item label's text's style (Inherited from StyleExtendedLabel.)
Location | Specifies label location (InsidePlotArea, OutsidePlotArea) (Inherited from StyleExtendedLabel.)
Overflow | Specifies label's overflow (Overrides StyleExtendedLabel..::.Overflow.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Constructor

[image]

Telerik Reporting Q2 2012
StyleLabelLegend Constructor
StyleLabelLegend Class See Also Send Feedback
Creates new instance of StyleLabelLegend class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelLegend()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Fields

[image] [image]

Telerik Reporting Q2 2012
StyleLabelLegend Fields
StyleLabelLegend Class See Also Send Feedback

The StyleLabelLegend type exposes the following members.

Fields

Name | Description
styleExtendedLabelItemAppearance | Specifies label item's style (Inherited from StyleExtendedLabel.)
styleExtendedLabelItemMarkerAppearance | Specifies label item's marker's style (Inherited from StyleExtendedLabel.)
styleExtendedLabelItemTextAppearance | Specifies label item's textblock's style (Inherited from StyleExtendedLabel.)
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLabelLegend Methods
StyleLabelLegend Class See Also Send Feedback

The StyleLabelLegend type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleExtendedLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleExtendedLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleExtendedLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleExtendedLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLabelLegend..::.Dispose Method
StyleLabelLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StyleExtendedLabel.)

See Also

StyleLabelLegend Class
StyleLabelLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelLegend Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLabelLegend Properties
StyleLabelLegend Class See Also Send Feedback

The StyleLabelLegend type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Gets label's figure (Overrides StyleLabel..::.Figure.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
GroupNameFormat | Specifies the series names format shown in Legend when data grouping being used and names are digits. (Inherited from StyleExtendedLabel.)
ItemAppearance | Specifies item label's style (Inherited from StyleExtendedLabel.)
ItemMarkerAppearance | Specifies item label's marker's style (Inherited from StyleExtendedLabel.)
ItemTextAppearance | Specifies item label's text's style (Inherited from StyleExtendedLabel.)
Location | Specifies label location (InsidePlotArea, OutsidePlotArea) (Inherited from StyleExtendedLabel.)
Overflow | Specifies label's overflow (Overrides StyleExtendedLabel..::.Overflow.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleLabelLegend..::.Figure Property
StyleLabelLegend Class See Also Send Feedback
Gets label's figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Figure { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Figure As String

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


Overflow Property

[image]

Telerik Reporting Q2 2012
StyleLabelLegend..::.Overflow Property
StyleLabelLegend Class See Also Send Feedback
Specifies label's overflow

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Overflow Overflow { get; set; }
Visual Basic (Declaration)
Public Overrides Property Overflow As Overflow

See Also

StyleLabelLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Class

[image]

Telerik Reporting Q2 2012
StyleLabelTitle Class
Members See Also Send Feedback
Chart title style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLabelTitle : StyleLabel
Visual Basic (Declaration)
Public Class StyleLabelTitle _
    Inherits StyleLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelTitle

See Also

StyleLabelTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Members

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle Members
StyleLabelTitle Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleLabelTitle type exposes the following members.

Constructors

Name | Description
StyleLabelTitle | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle Constructor
StyleLabelTitle Class See Also Send Feedback

Overload List

Name | Description
StyleLabelTitle()()() | Creates new instance of StyleLabelTitle class.
StyleLabelTitle(Chart) | Creates new instance of StyleLabelTitle class.

See Also

StyleLabelTitle Class
StyleLabelTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Constructor

[image]

Telerik Reporting Q2 2012
StyleLabelTitle Constructor
StyleLabelTitle Class See Also Send Feedback
Creates new instance of StyleLabelTitle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelTitle()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLabelTitle Class
StyleLabelTitle Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Constructor (Chart)

[image]

Telerik Reporting Q2 2012
StyleLabelTitle Constructor (Chart)
StyleLabelTitle Class See Also Send Feedback
Creates new instance of StyleLabelTitle class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLabelTitle(
    Chart chart
)
Visual Basic (Declaration)
Public Sub New ( _
    chart As Chart _
)

Parameters

chart
Type: Telerik.Reporting.Charting..::.Chart
Style container object

See Also

StyleLabelTitle Class
StyleLabelTitle Overload
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Fields

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle Fields
StyleLabelTitle Class See Also Send Feedback

The StyleLabelTitle type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle Methods
StyleLabelTitle Class See Also Send Feedback

The StyleLabelTitle type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle..::.Dispose Method
StyleLabelTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleLabelTitle Class
StyleLabelTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleLabelTitle Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLabelTitle Properties
StyleLabelTitle Class See Also Send Feedback

The StyleLabelTitle type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLabelTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Class

[image]

Telerik Reporting Q2 2012
StyleLegendBorder Class
Members See Also Send Feedback
Legend border specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLegendBorder : StyleBorder
Visual Basic (Declaration)
Public Class StyleLegendBorder _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.StyleLegendBorder

See Also

StyleLegendBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleLegendBorder Members
StyleLegendBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleLegendBorder type exposes the following members.

Constructors

Name | Description
StyleLegendBorder | Initializes a new instance of the StyleLegendBorder class

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleLegendBorder Constructor
StyleLegendBorder Class See Also Send Feedback
Initializes a new instance of the StyleLegendBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLegendBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLegendBorder Methods
StyleLegendBorder Class See Also Send Feedback

The StyleLegendBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLegendBorder..::.Dispose Method
StyleLegendBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleLegendBorder Class
StyleLegendBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleLegendBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLegendBorder Properties
StyleLegendBorder Class See Also Send Feedback

The StyleLegendBorder type exposes the following members.

Properties

Name | Description
Color | Gets and sets border color (Overrides StyleBorder..::.Color.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleLegendBorder..::.Color Property
StyleLegendBorder Class See Also Send Feedback
Gets and sets border color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Legend's border color

See Also

StyleLegendBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Class

[image]

Telerik Reporting Q2 2012
StyleLineSeries Class
Members See Also Send Feedback
Line series specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleLineSeries : LineStyle
Visual Basic (Declaration)
Public Class StyleLineSeries _
    Inherits LineStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleLineSeries
Telerik.Reporting.Charting.Styles..::.StyleEmptyLineSeries

See Also

StyleLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Members

[image] [image]

Telerik Reporting Q2 2012
StyleLineSeries Members
StyleLineSeries Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleLineSeries type exposes the following members.

Constructors

Name | Description
StyleLineSeries | Initializes a new instance of the StyleLineSeries class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets or sets color of the series line (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
IsEmptyLine | Checks if line belongs to StyleEmptyLineSeries class.
PenStyle | Gets or sets PenStyle of the series line (Overrides StyleBorder..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Line series visibility (same as Series.Visible) (Overrides StyleBorder..::.Visible.)
Width | Gets or sets the width of the series line. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Constructor

[image]

Telerik Reporting Q2 2012
StyleLineSeries Constructor
StyleLineSeries Class See Also Send Feedback
Initializes a new instance of the StyleLineSeries class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLineSeries()
Visual Basic (Declaration)
Public Sub New

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Methods

[image] [image]

Telerik Reporting Q2 2012
StyleLineSeries Methods
StyleLineSeries Class See Also Send Feedback

The StyleLineSeries type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleLineSeries..::.Dispose Method
StyleLineSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleLineSeries Class
StyleLineSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleLineSeries Properties

[image] [image]

Telerik Reporting Q2 2012
StyleLineSeries Properties
StyleLineSeries Class See Also Send Feedback

The StyleLineSeries type exposes the following members.

Properties

Name | Description
Color | Gets or sets color of the series line (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
IsEmptyLine | Checks if line belongs to StyleEmptyLineSeries class.
PenStyle | Gets or sets PenStyle of the series line (Overrides StyleBorder..::.PenStyle.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Line series visibility (same as Series.Visible) (Overrides StyleBorder..::.Visible.)
Width | Gets or sets the width of the series line. (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleLineSeries..::.Color Property
StyleLineSeries Class See Also Send Feedback
Gets or sets color of the series line

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Color of line

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


IsEmptyLine Property

[image]

Telerik Reporting Q2 2012
StyleLineSeries..::.IsEmptyLine Property
StyleLineSeries Class See Also Send Feedback
Checks if line belongs to StyleEmptyLineSeries class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool IsEmptyLine { get; }
Visual Basic (Declaration)
Protected ReadOnly Property IsEmptyLine As Boolean

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleLineSeries..::.PenStyle Property
StyleLineSeries Class See Also Send Feedback
Gets or sets PenStyle of the series line

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property PenStyle As DashStyle

Field Value

PenStyle of line

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleLineSeries..::.Visible Property
StyleLineSeries Class See Also Send Feedback
Line series visibility (same as Series.Visible)

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

Field Value

Visibility of line

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
StyleLineSeries..::.Width Property
StyleLineSeries Class See Also Send Feedback
Gets or sets the width of the series line.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single

Field Value

Width of line

See Also

StyleLineSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Class

[image]

Telerik Reporting Q2 2012
StyleMarkedZone Class
Members See Also Send Feedback
Marked zone. Used to mark the values ranges at the plot area.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarkedZone : Style
Visual Basic (Declaration)
Public Class StyleMarkedZone _
    Inherits Style

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.StyleMarkedZone

See Also

StyleMarkedZone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarkedZone Members
StyleMarkedZone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarkedZone type exposes the following members.

Constructors

Name | Description
StyleMarkedZone | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from Style.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
FillStyle | Specifies the FillStyle property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleMarkedZone Constructor
StyleMarkedZone Class See Also Send Feedback

Overload List

Name | Description
StyleMarkedZone()()() | Creates a new instance of StyleMarkedZoneclass.
StyleMarkedZone(FillStyleMarkedZones, StyleBorder, ShadowStyle, Boolean) | Creates a new instance of StyleMarkedZoneclass.

See Also

StyleMarkedZone Class
StyleMarkedZone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Constructor

[image]

Telerik Reporting Q2 2012
StyleMarkedZone Constructor
StyleMarkedZone Class See Also Send Feedback
Creates a new instance of StyleMarkedZoneclass.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkedZone()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarkedZone Class
StyleMarkedZone Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Constructor (FillStyleMarkedZones, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleMarkedZone Constructor (FillStyleMarkedZones, StyleBorder, ShadowStyle, Boolean)
StyleMarkedZone Class See Also Send Feedback
Creates a new instance of StyleMarkedZoneclass.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkedZone(
    FillStyleMarkedZones fillStyle,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyleMarkedZones, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyleMarkedZones
FillStyle of Marked Zone
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Marked Zone's border
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Marked Zone's shadow style
visible
Type: System..::.Boolean
Visibility of Marked Zone

See Also

StyleMarkedZone Class
StyleMarkedZone Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarkedZone Methods
StyleMarkedZone Class See Also Send Feedback

The StyleMarkedZone type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from Style.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.Dispose Method
StyleMarkedZone Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides Style..::.Dispose(Boolean).)

See Also

StyleMarkedZone Class
StyleMarkedZone Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.Dispose Method (Boolean)
StyleMarkedZone Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleMarkedZone Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.LoadViewState Method
StyleMarkedZone Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.SaveViewState Method
StyleMarkedZone Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.TrackViewState Method
StyleMarkedZone Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkedZone Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarkedZone Properties
StyleMarkedZone Class See Also Send Feedback

The StyleMarkedZone type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
FillStyle | Specifies the FillStyle property
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleMarkedZone..::.FillStyle Property
StyleMarkedZone Class See Also Send Feedback
Specifies the FillStyle property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleMarkedZones FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleMarkedZones

See Also

StyleMarkedZone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Class

[image]

Telerik Reporting Q2 2012
StyleMarker Class
Members See Also Send Feedback
Base marker's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarker : LayoutStyle
Visual Basic (Declaration)
Public Class StyleMarker _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StyleMarkerEmptyValue
Telerik.Reporting.Charting.Styles..::.StyleMarkerLegend
Telerik.Reporting.Charting.Styles..::.StyleMarkerPositionNone
Telerik.Reporting.Charting.Styles..::.StyleMarkerSeriesPoint

See Also

StyleMarker Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarker Members
StyleMarker Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarker type exposes the following members.

Constructors

Name | Description
StyleMarker | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the Figure property
FillStyle | Specifies the FillStyle property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleMarker Constructor
StyleMarker Class See Also Send Feedback

Overload List

Name | Description
StyleMarker()()() | Creates a new instance of StyleMarker class.
StyleMarker(Object) | Creates a new instance of StyleMarker class.
StyleMarker(String) | Creates a new instance of StyleMarker class.
StyleMarker(String, Int32) | Creates a new instance of StyleMarker class.
StyleMarker(String, Dimensions, FillStyle) | Creates a new instance of StyleMarker class.
StyleMarker(Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean) | Creates a new instance of StyleMarker class.

See Also

StyleMarker Class
StyleMarker Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor (Object)

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor (Object)
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker(
    Object containerObject
)
Visual Basic (Declaration)
Public Sub New ( _
    containerObject As Object _
)

Parameters

containerObject
Type: System..::.Object
Style container object

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor (String)

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor (String)
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker(
    string figureType
)
Visual Basic (Declaration)
Public Sub New ( _
    figureType As String _
)

Parameters

figureType
Type: System..::.String
Marker's figure name

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor (String, Int32)

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor (String, Int32)
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker(
    string figureType,
    int pointSize
)
Visual Basic (Declaration)
Public Sub New ( _
    figureType As String, _
    pointSize As Integer _
)

Parameters

figureType
Type: System..::.String
Marker's figure name
pointSize
Type: System..::.Int32
Width and height of marker

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor (String, Dimensions, FillStyle)

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor (String, Dimensions, FillStyle)
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker(
    string figureType,
    Dimensions dimensions,
    FillStyle fillStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    figureType As String, _
    dimensions As Dimensions, _
    fillStyle As FillStyle _
)

Parameters

figureType
Type: System..::.String
Marker's figure name
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions of marker
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Marker's fillstyle settings

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Constructor (Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleMarker Constructor (Dimensions, String, FillStyle, Position, Single, Corners, StyleBorder, ShadowStyle, Boolean)
StyleMarker Class See Also Send Feedback
Creates a new instance of StyleMarker class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarker(
    Dimensions dimensions,
    string figure,
    FillStyle fillStyle,
    Position position,
    float rotationAngle,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As Dimensions, _
    figure As String, _
    fillStyle As FillStyle, _
    position As Position, _
    rotationAngle As Single, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions of marker
figure
Type: System..::.String
Marker's figure name
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Marker's fillstyle settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Marker's positions
rotationAngle
Type: System..::.Single
Marker's rotation angle
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Corners of marker
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Border of marker
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Marker's shadow style
visible
Type: System..::.Boolean
Marker's visibility

See Also

StyleMarker Class
StyleMarker Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarker Methods
StyleMarker Class See Also Send Feedback

The StyleMarker type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Overrides Object..::.Equals(Object).)
GetHashCode | Gets hash code (Overrides Object..::.GetHashCode()()().)
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Clone Method
StyleMarker Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarker..::.Dispose Method
StyleMarker Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutStyle..::.Dispose(Boolean).)

See Also

StyleMarker Class
StyleMarker Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Dispose Method (Boolean)
StyleMarker Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleMarker Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Equals Method
StyleMarker Class See Also Send Feedback
Comparing of two objects

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Object to compare

Return Value

Result of comparing

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.GetHashCode Method
StyleMarker Class See Also Send Feedback
Gets hash code

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.LoadViewState Method
StyleMarker Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.SaveViewState Method
StyleMarker Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleMarker..::.TrackViewState Method
StyleMarker Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarker Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarker Properties
StyleMarker Class See Also Send Feedback

The StyleMarker type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the Figure property
FillStyle | Specifies the FillStyle property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Corners Property
StyleMarker Class See Also Send Feedback
Specifies the corners of background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Corners Corners { get; set; }
Visual Basic (Declaration)
Public Overridable Property Corners As Corners

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Figure Property
StyleMarker Class See Also Send Feedback
Specifies the Figure property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual string Figure { get; set; }
Visual Basic (Declaration)
Public Overridable Property Figure As String

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleMarker..::.FillStyle Property
StyleMarker Class See Also Send Feedback
Specifies the FillStyle property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual FillStyle FillStyle { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


RotationAngle Property

[image]

Telerik Reporting Q2 2012
StyleMarker..::.RotationAngle Property
StyleMarker Class See Also Send Feedback
Specifies the Rotation angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float RotationAngle { get; set; }
Visual Basic (Declaration)
Public Overridable Property RotationAngle As Single

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleMarker..::.Visible Property
StyleMarker Class See Also Send Feedback
Specifies marker's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleMarker Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Class

[image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue Class
Members See Also Send Feedback
Specific empty point marker style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarkerEmptyValue : StyleMarker
Visual Basic (Declaration)
Public Class StyleMarkerEmptyValue _
    Inherits StyleMarker

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StyleMarkerEmptyValue

See Also

StyleMarkerEmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue Members
StyleMarkerEmptyValue Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarkerEmptyValue type exposes the following members.

Constructors

Name | Description
StyleMarkerEmptyValue | Creates a new instance of StyleMarkerEmptyValue class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies marker's figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Constructor

[image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue Constructor
StyleMarkerEmptyValue Class See Also Send Feedback
Creates a new instance of StyleMarkerEmptyValue class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerEmptyValue()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue Methods
StyleMarkerEmptyValue Class See Also Send Feedback

The StyleMarkerEmptyValue type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue..::.Dispose Method
StyleMarkerEmptyValue Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleMarker.)

See Also

StyleMarkerEmptyValue Class
StyleMarkerEmptyValue Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerEmptyValue Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue Properties
StyleMarkerEmptyValue Class See Also Send Feedback

The StyleMarkerEmptyValue type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies marker's figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue..::.Figure Property
StyleMarkerEmptyValue Class See Also Send Feedback
Specifies marker's figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Figure { get; set; }
Visual Basic (Declaration)
Public Overrides Property Figure As String

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleMarkerEmptyValue..::.Visible Property
StyleMarkerEmptyValue Class See Also Send Feedback
Specifies marker's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleMarkerEmptyValue Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Class

[image]

Telerik Reporting Q2 2012
StyleMarkerLegend Class
Members See Also Send Feedback
Specific series point markers style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarkerLegend : StyleMarker
Visual Basic (Declaration)
Public Class StyleMarkerLegend _
    Inherits StyleMarker

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StyleMarkerLegend

See Also

StyleMarkerLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerLegend Members
StyleMarkerLegend Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarkerLegend type exposes the following members.

Constructors

Name | Description
StyleMarkerLegend | Creates a new instance of StyleMarkerLegend class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies marker's figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Constructor

[image]

Telerik Reporting Q2 2012
StyleMarkerLegend Constructor
StyleMarkerLegend Class See Also Send Feedback
Creates a new instance of StyleMarkerLegend class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerLegend()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerLegend Methods
StyleMarkerLegend Class See Also Send Feedback

The StyleMarkerLegend type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerLegend..::.Dispose Method
StyleMarkerLegend Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleMarker.)

See Also

StyleMarkerLegend Class
StyleMarkerLegend Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerLegend Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerLegend Properties
StyleMarkerLegend Class See Also Send Feedback

The StyleMarkerLegend type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies marker's figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleMarkerLegend..::.Figure Property
StyleMarkerLegend Class See Also Send Feedback
Specifies marker's figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Figure { get; set; }
Visual Basic (Declaration)
Public Overrides Property Figure As String

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleMarkerLegend..::.Visible Property
StyleMarkerLegend Class See Also Send Feedback
Specifies marker's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleMarkerLegend Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Class

[image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone Class
Members See Also Send Feedback
Specific empty point marker style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarkerPositionNone : StyleMarker
Visual Basic (Declaration)
Public Class StyleMarkerPositionNone _
    Inherits StyleMarker

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StyleMarkerPositionNone

See Also

StyleMarkerPositionNone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone Members
StyleMarkerPositionNone Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarkerPositionNone type exposes the following members.

Constructors

Name | Description
StyleMarkerPositionNone | Creates a new instance of StyleMarkerPositionNone class.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the Figure property (Inherited from StyleMarker.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Constructor

[image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone Constructor
StyleMarkerPositionNone Class See Also Send Feedback
Creates a new instance of StyleMarkerPositionNone class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerPositionNone()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone Methods
StyleMarkerPositionNone Class See Also Send Feedback

The StyleMarkerPositionNone type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone..::.Dispose Method
StyleMarkerPositionNone Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleMarker.)

See Also

StyleMarkerPositionNone Class
StyleMarkerPositionNone Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerPositionNone Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone Properties
StyleMarkerPositionNone Class See Also Send Feedback

The StyleMarkerPositionNone type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the Figure property (Inherited from StyleMarker.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleMarkerPositionNone..::.Visible Property
StyleMarkerPositionNone Class See Also Send Feedback
Specifies marker's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleMarkerPositionNone Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Class

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Class
Members See Also Send Feedback
Specific series point markers style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleMarkerSeriesPoint : StyleMarker
Visual Basic (Declaration)
Public Class StyleMarkerSeriesPoint _
    Inherits StyleMarker

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleMarker
Telerik.Reporting.Charting.Styles..::.StyleMarkerSeriesPoint

See Also

StyleMarkerSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Members

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Members
StyleMarkerSeriesPoint Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleMarkerSeriesPoint type exposes the following members.

Constructors

Name | Description
StyleMarkerSeriesPoint | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies Figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies marker's positions (Overrides LayoutStyle..::.Position.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Constructor
StyleMarkerSeriesPoint Class See Also Send Feedback

Overload List

Name | Description
StyleMarkerSeriesPoint()()() | Creates a new instance of StyleMarkerSeriesPoint class.
StyleMarkerSeriesPoint(ChartSeries, String) | Creates a new instance of StyleMarkerSeriesPoint class.

See Also

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Constructor

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Constructor
StyleMarkerSeriesPoint Class See Also Send Feedback
Creates a new instance of StyleMarkerSeriesPoint class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerSeriesPoint()
Visual Basic (Declaration)
Public Sub New

See Also

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Constructor (ChartSeries, String)

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Constructor (ChartSeries, String)
StyleMarkerSeriesPoint Class See Also Send Feedback
Creates a new instance of StyleMarkerSeriesPoint class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerSeriesPoint(
    ChartSeries series,
    string subPropertyName
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries, _
    subPropertyName As String _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Series that is style container object
subPropertyName
Type: System..::.String

See Also

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Overload
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Methods

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Methods
StyleMarkerSeriesPoint Class See Also Send Feedback

The StyleMarkerSeriesPoint type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleMarker.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Comparing of two objects (Inherited from StyleMarker.)
GetHashCode | Gets hash code (Inherited from StyleMarker.)
LoadViewState | Load data from ViewState (Inherited from StyleMarker.)
SaveViewState | Saved data to ViewState (Inherited from StyleMarker.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleMarker.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint..::.Dispose Method
StyleMarkerSeriesPoint Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleMarker.)

See Also

StyleMarkerSeriesPoint Class
StyleMarkerSeriesPoint Members
Telerik.Reporting.Charting.Styles Namespace


StyleMarkerSeriesPoint Properties

[image] [image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint Properties
StyleMarkerSeriesPoint Class See Also Send Feedback

The StyleMarkerSeriesPoint type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners of background rectangle (Inherited from StyleMarker.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies Figure (Overrides StyleMarker..::.Figure.)
FillStyle | Specifies the FillStyle property (Inherited from StyleMarker.)
Position | Specifies marker's positions (Overrides LayoutStyle..::.Position.)
RotationAngle | Specifies the Rotation angle (Inherited from StyleMarker.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies marker's visibility (Overrides StyleMarker..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint..::.Figure Property
StyleMarkerSeriesPoint Class See Also Send Feedback
Specifies Figure

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Figure { get; set; }
Visual Basic (Declaration)
Public Overrides Property Figure As String

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Position Property

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint..::.Position Property
StyleMarkerSeriesPoint Class See Also Send Feedback
Specifies marker's positions

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Position Position { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Position As Position

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleMarkerSeriesPoint..::.Visible Property
StyleMarkerSeriesPoint Class See Also Send Feedback
Specifies marker's visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleMarkerSeriesPoint Class
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Class

[image]

Telerik Reporting Q2 2012
StylePlotArea Class
Members See Also Send Feedback
Plot area's appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StylePlotArea : LayoutStyle
Visual Basic (Declaration)
Public Class StylePlotArea _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StylePlotArea

See Also

StylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Members

[image] [image]

Telerik Reporting Q2 2012
StylePlotArea Members
StylePlotArea Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StylePlotArea type exposes the following members.

Constructors

Name | Description
StylePlotArea | Overloaded.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
SeriesPalette | Specifies the series palette
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Constructor

[image] [image]

Telerik Reporting Q2 2012
StylePlotArea Constructor
StylePlotArea Class See Also Send Feedback

Overload List

Name | Description
StylePlotArea()()() | Creates a new instance of StylePlotArea class.
StylePlotArea(Dimensions, FillStylePlotArea, Position, String, Corners, StyleBorder, ShadowStyle, Boolean) | Creates a new instance of StylePlotArea class.

See Also

StylePlotArea Class
StylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Constructor

[image]

Telerik Reporting Q2 2012
StylePlotArea Constructor
StylePlotArea Class See Also Send Feedback
Creates a new instance of StylePlotArea class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StylePlotArea()
Visual Basic (Declaration)
Public Sub New

See Also

StylePlotArea Class
StylePlotArea Overload
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Constructor (Dimensions, FillStylePlotArea, Position, String, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StylePlotArea Constructor (Dimensions, FillStylePlotArea, Position, String, Corners, StyleBorder, ShadowStyle, Boolean)
StylePlotArea Class See Also Send Feedback
Creates a new instance of StylePlotArea class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StylePlotArea(
    Dimensions dimensions,
    FillStylePlotArea fillStyle,
    Position position,
    string palette,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As Dimensions, _
    fillStyle As FillStylePlotArea, _
    position As Position, _
    palette As String, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions of PlotArea
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStylePlotArea
FillStyle settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
PlotArea's position
palette
Type: System..::.String
Palette used in PlotArea
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
PlotArea's corners
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Border of PlotArea
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
PlotArea's shadow style
visible
Type: System..::.Boolean
PlotArea's visibility

See Also

StylePlotArea Class
StylePlotArea Overload
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Methods

[image] [image]

Telerik Reporting Q2 2012
StylePlotArea Methods
StylePlotArea Class See Also Send Feedback

The StylePlotArea type exposes the following members.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides LayoutStyle..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.Clone Method
StylePlotArea Class See Also Send Feedback
Cloned this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

New instance of StylePlotArea class with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StylePlotArea..::.Dispose Method
StylePlotArea Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutStyle..::.Dispose(Boolean).)

See Also

StylePlotArea Class
StylePlotArea Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.Dispose Method (Boolean)
StylePlotArea Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StylePlotArea Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.LoadViewState Method
StylePlotArea Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.SaveViewState Method
StylePlotArea Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.TrackViewState Method
StylePlotArea Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


StylePlotArea Properties

[image] [image]

Telerik Reporting Q2 2012
StylePlotArea Properties
StylePlotArea Class See Also Send Feedback

The StylePlotArea type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property
FillStyle | Specifies the background property
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
SeriesPalette | Specifies the series palette
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.Corners Property
StylePlotArea Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.Figure Property
StylePlotArea Class See Also Send Feedback
Specifies the figure property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Figure { get; }
Visual Basic (Declaration)
Public ReadOnly Property Figure As String

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.FillStyle Property
StylePlotArea Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStylePlotArea FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStylePlotArea

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


SeriesPalette Property

[image]

Telerik Reporting Q2 2012
StylePlotArea..::.SeriesPalette Property
StylePlotArea Class See Also Send Feedback
Specifies the series palette

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string SeriesPalette { get; set; }
Visual Basic (Declaration)
Public Property SeriesPalette As String

See Also

StylePlotArea Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Class

[image]

Telerik Reporting Q2 2012
StyleSeries Class
Members See Also Send Feedback
Series appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSeries : Style
Visual Basic (Declaration)
Public Class StyleSeries _
    Inherits Style

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.StyleSeries

See Also

StyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Members

[image] [image]

Telerik Reporting Q2 2012
StyleSeries Members
StyleSeries Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleSeries type exposes the following members.

Constructors

Name | Description
StyleSeries | Overloaded.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Properties

Name | Description
BarWidthPercent | Determines the width of bars.
Border | Specifies the border (Overrides Style..::.Border.)
BubbleSize | Default bubble size
CenterXOffset | Specifies the x offset of the pie center.
CenterYOffset | Specifies the y offset of the pie center.
Corners | Specifies the corners for background rectangle
DiameterScale | Gets or sets the pie's diameter length according to the size of the plot area.
EmptyValue | Empty value point mark
ExplodePercent | Gets or sets the explode percent of the exploded items.
FillStyle | Specifies the background property
LabelAppearance | Gets or sets the common settings for the series items labels
LegendDisplayMode | Legend visualization mode
LineSeriesAppearance | Line, Spline, Bezier series line style
PointDimentions | Specifies the dimensions of points in point series
PointMark | Series points appearance
PointRotationAngle | Specifies the Rotation angle
PointShape | Specifies the shape for point series
Shadow | Specifies the shadow settings (Inherited from Style.)
ShowLabelConnectors | Specifies whether a line should be drawn between the label and the item.
ShowLabels | Specifies whether the item labels should be shown or not.
StartAngle | Gets or sets the start angle of the pie. Zero angle is identical with the X axis direction.
TextAppearance | Gets or sets the common text settings for the series items
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility of series (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSeries Constructor
StyleSeries Class See Also Send Feedback

Overload List

Name | Description
StyleSeries()()() | Creates new instance of StyleSeries class.
StyleSeries(ChartSeries) | Constructor for Series's style
StyleSeries(FillStyleSeries, StyleSeriesItemLabel, StyleMarkerSeriesPoint, Corners, StyleBorder, ShadowStyle, Boolean) | Creates new instance of StyleSeries class.

See Also

StyleSeries Class
StyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Constructor

[image]

Telerik Reporting Q2 2012
StyleSeries Constructor
StyleSeries Class See Also Send Feedback
Creates new instance of StyleSeries class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeries()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSeries Class
StyleSeries Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleSeries Constructor (ChartSeries)
StyleSeries Class See Also Send Feedback
Constructor for Series's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeries(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Parent series element

See Also

StyleSeries Class
StyleSeries Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Constructor (FillStyleSeries, StyleSeriesItemLabel, StyleMarkerSeriesPoint, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleSeries Constructor (FillStyleSeries, StyleSeriesItemLabel, StyleMarkerSeriesPoint, Corners, StyleBorder, ShadowStyle, Boolean)
StyleSeries Class See Also Send Feedback
Creates new instance of StyleSeries class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeries(
    FillStyleSeries fillStyle,
    StyleSeriesItemLabel styleSeriesLabel,
    StyleMarkerSeriesPoint stylePointMarker,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyleSeries, _
    styleSeriesLabel As StyleSeriesItemLabel, _
    stylePointMarker As StyleMarkerSeriesPoint, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyleSeries
FillStyle of series
styleSeriesLabel
Type: Telerik.Reporting.Charting.Styles..::.StyleSeriesItemLabel
Series default labels' settings
stylePointMarker
Type: Telerik.Reporting.Charting.Styles..::.StyleMarkerSeriesPoint
Style of Point marker
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Items' corners
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Border of series
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Series' shadow style
visible
Type: System..::.Boolean
Visibility of series

See Also

StyleSeries Class
StyleSeries Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSeries Methods
StyleSeries Class See Also Send Feedback

The StyleSeries type exposes the following members.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleSeries..::.Clone Method
StyleSeries Class See Also Send Feedback
Cloned this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

New instance of StyleSeries class with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleSeries..::.Dispose Method
StyleSeries Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides Style..::.Dispose(Boolean).)

See Also

StyleSeries Class
StyleSeries Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleSeries..::.Dispose Method (Boolean)
StyleSeries Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleSeries Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeries..::.LoadViewState Method
StyleSeries Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeries..::.SaveViewState Method
StyleSeries Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeries..::.TrackViewState Method
StyleSeries Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeries Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSeries Properties
StyleSeries Class See Also Send Feedback

The StyleSeries type exposes the following members.

Properties

Name | Description
BarWidthPercent | Determines the width of bars.
Border | Specifies the border (Overrides Style..::.Border.)
BubbleSize | Default bubble size
CenterXOffset | Specifies the x offset of the pie center.
CenterYOffset | Specifies the y offset of the pie center.
Corners | Specifies the corners for background rectangle
DiameterScale | Gets or sets the pie's diameter length according to the size of the plot area.
EmptyValue | Empty value point mark
ExplodePercent | Gets or sets the explode percent of the exploded items.
FillStyle | Specifies the background property
LabelAppearance | Gets or sets the common settings for the series items labels
LegendDisplayMode | Legend visualization mode
LineSeriesAppearance | Line, Spline, Bezier series line style
PointDimentions | Specifies the dimensions of points in point series
PointMark | Series points appearance
PointRotationAngle | Specifies the Rotation angle
PointShape | Specifies the shape for point series
Shadow | Specifies the shadow settings (Inherited from Style.)
ShowLabelConnectors | Specifies whether a line should be drawn between the label and the item.
ShowLabels | Specifies whether the item labels should be shown or not.
StartAngle | Gets or sets the start angle of the pie. Zero angle is identical with the X axis direction.
TextAppearance | Gets or sets the common text settings for the series items
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility of series (Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


BarWidthPercent Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.BarWidthPercent Property
StyleSeries Class See Also Send Feedback
Determines the width of bars.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public decimal BarWidthPercent { get; set; }
Visual Basic (Declaration)
Public Property BarWidthPercent As Decimal

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Border Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.Border Property
StyleSeries Class See Also Send Feedback
Specifies the border

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override StyleBorder Border { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Border As StyleBorder

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


BubbleSize Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.BubbleSize Property
StyleSeries Class See Also Send Feedback
Default bubble size

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int BubbleSize { get; set; }
Visual Basic (Declaration)
Public Property BubbleSize As Integer

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


CenterXOffset Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.CenterXOffset Property
StyleSeries Class See Also Send Feedback
Specifies the x offset of the pie center.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CenterXOffset { get; set; }
Visual Basic (Declaration)
Public Property CenterXOffset As Integer

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


CenterYOffset Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.CenterYOffset Property
StyleSeries Class See Also Send Feedback
Specifies the y offset of the pie center.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CenterYOffset { get; set; }
Visual Basic (Declaration)
Public Property CenterYOffset As Integer

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.Corners Property
StyleSeries Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


DiameterScale Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.DiameterScale Property
StyleSeries Class See Also Send Feedback
Gets or sets the pie's diameter length according to the size of the plot area.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double DiameterScale { get; set; }
Visual Basic (Declaration)
Public Property DiameterScale As Double

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


EmptyValue Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.EmptyValue Property
StyleSeries Class See Also Send Feedback
Empty value point mark

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EmptyValue EmptyValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptyValue As EmptyValue

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


ExplodePercent Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.ExplodePercent Property
StyleSeries Class See Also Send Feedback
Gets or sets the explode percent of the exploded items.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ExplodePercent { get; set; }
Visual Basic (Declaration)
Public Property ExplodePercent As Integer

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.FillStyle Property
StyleSeries Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeries FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleSeries

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


LabelAppearance Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.LabelAppearance Property
StyleSeries Class See Also Send Feedback
Gets or sets the common settings for the series items labels

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemLabel LabelAppearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelAppearance As StyleSeriesItemLabel

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


LegendDisplayMode Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.LegendDisplayMode Property
StyleSeries Class See Also Send Feedback
Legend visualization mode

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ChartSeriesLegendDisplayMode LegendDisplayMode { get; set; }
Visual Basic (Declaration)
Public Property LegendDisplayMode As ChartSeriesLegendDisplayMode

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


LineSeriesAppearance Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.LineSeriesAppearance Property
StyleSeries Class See Also Send Feedback
Line, Spline, Bezier series line style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleLineSeries LineSeriesAppearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property LineSeriesAppearance As StyleLineSeries

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


PointDimentions Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.PointDimentions Property
StyleSeries Class See Also Send Feedback
Specifies the dimensions of points in point series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsPointMarker PointDimentions { get; set; }
Visual Basic (Declaration)
Public Property PointDimentions As DimensionsPointMarker

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


PointMark Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.PointMark Property
StyleSeries Class See Also Send Feedback
Series points appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleMarkerSeriesPoint PointMark { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointMark As StyleMarkerSeriesPoint

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


PointRotationAngle Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.PointRotationAngle Property
StyleSeries Class See Also Send Feedback
Specifies the Rotation angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float PointRotationAngle { get; set; }
Visual Basic (Declaration)
Public Overridable Property PointRotationAngle As Single

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


PointShape Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.PointShape Property
StyleSeries Class See Also Send Feedback
Specifies the shape for point series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string PointShape { get; set; }
Visual Basic (Declaration)
Public Property PointShape As String

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


ShowLabelConnectors Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.ShowLabelConnectors Property
StyleSeries Class See Also Send Feedback
Specifies whether a line should be drawn between the label and the item.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ShowLabelConnectors { get; set; }
Visual Basic (Declaration)
Public Property ShowLabelConnectors As Boolean

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


ShowLabels Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.ShowLabels Property
StyleSeries Class See Also Send Feedback
Specifies whether the item labels should be shown or not.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ShowLabels { get; set; }
Visual Basic (Declaration)
Public Property ShowLabels As Boolean

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


StartAngle Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.StartAngle Property
StyleSeries Class See Also Send Feedback
Gets or sets the start angle of the pie. Zero angle is identical with the X axis direction.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


TextAppearance Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.TextAppearance Property
StyleSeries Class See Also Send Feedback
Gets or sets the common text settings for the series items

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemTextBlock TextAppearance { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextAppearance As StyleSeriesItemTextBlock

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleSeries..::.Visible Property
StyleSeries Class See Also Send Feedback
Specifies visibility of series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleSeries Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Class

[image]

Telerik Reporting Q2 2012
StyleSeriesBorder Class
Members See Also Send Feedback
Series border specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSeriesBorder : StyleBorder
Visual Basic (Declaration)
Public Class StyleSeriesBorder _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.StyleSeriesBorder

See Also

StyleSeriesBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesBorder Members
StyleSeriesBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleSeriesBorder type exposes the following members.

Constructors

Name | Description
StyleSeriesBorder | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Gets or sets color of the series border (Overrides StyleBorder..::.Color.)
PenStyle | Gets or sets PenStyle of the series border (Overrides StyleBorder..::.PenStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesBorder Constructor
StyleSeriesBorder Class See Also Send Feedback

Overload List

Name | Description
StyleSeriesBorder()()() | Initializes a new instance of the StyleSeriesBorder class
StyleSeriesBorder(ChartSeries) | Creates new instance of StyleSeriesBorder class.

See Also

StyleSeriesBorder Class
StyleSeriesBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleSeriesBorder Constructor
StyleSeriesBorder Class See Also Send Feedback
Initializes a new instance of the StyleSeriesBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSeriesBorder Class
StyleSeriesBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleSeriesBorder Constructor (ChartSeries)
StyleSeriesBorder Class See Also Send Feedback
Creates new instance of StyleSeriesBorder class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesBorder(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Series object

See Also

StyleSeriesBorder Class
StyleSeriesBorder Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesBorder Methods
StyleSeriesBorder Class See Also Send Feedback

The StyleSeriesBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesBorder..::.Dispose Method
StyleSeriesBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleSeriesBorder Class
StyleSeriesBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesBorder Properties
StyleSeriesBorder Class See Also Send Feedback

The StyleSeriesBorder type exposes the following members.

Properties

Name | Description
Color | Gets or sets color of the series border (Overrides StyleBorder..::.Color.)
PenStyle | Gets or sets PenStyle of the series border (Overrides StyleBorder..::.PenStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleSeriesBorder..::.Color Property
StyleSeriesBorder Class See Also Send Feedback
Gets or sets color of the series border

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

Field Value

Color of line

See Also

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


PenStyle Property

[image]

Telerik Reporting Q2 2012
StyleSeriesBorder..::.PenStyle Property
StyleSeriesBorder Class See Also Send Feedback
Gets or sets PenStyle of the series border

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override DashStyle PenStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property PenStyle As DashStyle

Field Value

PenStyle of line

See Also

StyleSeriesBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Class

[image]

Telerik Reporting Q2 2012
StyleSeriesItem Class
Members See Also Send Feedback
Series item appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSeriesItem : Style
Visual Basic (Declaration)
Public Class StyleSeriesItem _
    Inherits Style

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.StyleSeriesItem

See Also

StyleSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Members

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItem Members
StyleSeriesItem Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleSeriesItem type exposes the following members.

Constructors

Name | Description
StyleSeriesItem | Overloaded.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Exploded | Exploded of item in Pie series
FillStyle | Specifies the background property
PointDimentions | Specifies the dimensions of points in point series
PointRotationAngle | Specifies the Rotation angle
PointShape | Specifies the figure property for point series
Shadow | Specifies item's shadow (Overrides Style..::.Shadow.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItem Constructor
StyleSeriesItem Class See Also Send Feedback

Overload List

Name | Description
StyleSeriesItem()()() | Creates new instance of StyleSeriesItem class.
StyleSeriesItem(ChartSeries) | Creates new instance of StyleSeriesItem class.

See Also

StyleSeriesItem Class
StyleSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Constructor

[image]

Telerik Reporting Q2 2012
StyleSeriesItem Constructor
StyleSeriesItem Class See Also Send Feedback
Creates new instance of StyleSeriesItem class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItem()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSeriesItem Class
StyleSeriesItem Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleSeriesItem Constructor (ChartSeries)
StyleSeriesItem Class See Also Send Feedback
Creates new instance of StyleSeriesItem class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItem(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Style container object

See Also

StyleSeriesItem Class
StyleSeriesItem Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItem Methods
StyleSeriesItem Class See Also Send Feedback

The StyleSeriesItem type exposes the following members.

Methods

Name | Description
Clone | Cloned this object (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides Style..::.LoadViewState(Object).)
SaveViewState | Saved data to ViewState (Overrides Style..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides Style..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Clone Method
StyleSeriesItem Class See Also Send Feedback
Cloned this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

New instance of StyleSeriesItem class with the same fields as this one

Implements

ICloneable..::.Clone()()()

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Dispose Method
StyleSeriesItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases the unmanaged resources used by the StyleSeriesItem and optionally releases the managed resources (Overrides Style..::.Dispose(Boolean).)

See Also

StyleSeriesItem Class
StyleSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Dispose Method (Boolean)
StyleSeriesItem Class See Also Send Feedback
Releases the unmanaged resources used by the StyleSeriesItem and optionally releases the managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

StyleSeriesItem Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.LoadViewState Method
StyleSeriesItem Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.SaveViewState Method
StyleSeriesItem Class See Also Send Feedback
Saved data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

saved data

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.TrackViewState Method
StyleSeriesItem Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItem Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItem Properties
StyleSeriesItem Class See Also Send Feedback

The StyleSeriesItem type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
Corners | Specifies the corners for background rectangle
Exploded | Exploded of item in Pie series
FillStyle | Specifies the background property
PointDimentions | Specifies the dimensions of points in point series
PointRotationAngle | Specifies the Rotation angle
PointShape | Specifies the figure property for point series
Shadow | Specifies item's shadow (Overrides Style..::.Shadow.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies visibility (Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Corners Property
StyleSeriesItem Class See Also Send Feedback
Specifies the corners for background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Exploded Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Exploded Property
StyleSeriesItem Class See Also Send Feedback
Exploded of item in Pie series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Exploded { get; set; }
Visual Basic (Declaration)
Public Property Exploded As Boolean

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.FillStyle Property
StyleSeriesItem Class See Also Send Feedback
Specifies the background property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FillStyleSeries FillStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillStyle As FillStyleSeries

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


PointDimentions Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.PointDimentions Property
StyleSeriesItem Class See Also Send Feedback
Specifies the dimensions of points in point series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DimensionsPointMarker PointDimentions { get; set; }
Visual Basic (Declaration)
Public Property PointDimentions As DimensionsPointMarker

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


PointRotationAngle Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.PointRotationAngle Property
StyleSeriesItem Class See Also Send Feedback
Specifies the Rotation angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual float PointRotationAngle { get; set; }
Visual Basic (Declaration)
Public Overridable Property PointRotationAngle As Single

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


PointShape Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.PointShape Property
StyleSeriesItem Class See Also Send Feedback
Specifies the figure property for point series

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string PointShape { get; set; }
Visual Basic (Declaration)
Public Property PointShape As String

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Shadow Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItem..::.Shadow Property
StyleSeriesItem Class See Also Send Feedback
Specifies item's shadow

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ShadowStyle Shadow { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Shadow As ShadowStyle

See Also

StyleSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Class

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Class
Members See Also Send Feedback
Series item appearance style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSeriesItemLabel : StyleLabel
Visual Basic (Declaration)
Public Class StyleSeriesItemLabel _
    Inherits StyleLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleSeriesItemLabel

See Also

StyleSeriesItemLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Members
StyleSeriesItemLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleSeriesItemLabel type exposes the following members.

Constructors

Name | Description
StyleSeriesItemLabel | Overloaded.

Methods

Name | Description
Clone | Clone this object (Overrides StyleLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StyleLabel..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StyleLabel..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StyleLabel..::.TrackViewState()()().)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Distance | Label distance from series when LabelLocation equals Auto
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
LabelConnectorStyle | Gets label's connector's style
LabelLocation | Specifies label's layout
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies labels' visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Constructor
StyleSeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
StyleSeriesItemLabel()()() | Creates new instance of StyleSeriesItemLabel class.
StyleSeriesItemLabel(ChartSeries) | Creates new instance of StyleSeriesItemLabel class.

See Also

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Constructor
StyleSeriesItemLabel Class See Also Send Feedback
Creates new instance of StyleSeriesItemLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSeriesItemLabel Class
StyleSeriesItemLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Constructor (ChartSeries)
StyleSeriesItemLabel Class See Also Send Feedback
Creates new instance of StyleSeriesItemLabel class.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemLabel(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Style container element

See Also

StyleSeriesItemLabel Class
StyleSeriesItemLabel Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Fields
StyleSeriesItemLabel Class See Also Send Feedback

The StyleSeriesItemLabel type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Methods
StyleSeriesItemLabel Class See Also Send Feedback

The StyleSeriesItemLabel type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Overrides StyleLabel..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Overrides StyleLabel..::.LoadViewState(Object).)
SaveViewState | Save data to ViewState (Overrides StyleLabel..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Overrides StyleLabel..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.Clone Method
StyleSeriesItemLabel Class See Also Send Feedback
Clone this object

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Cloned object

Implements

ICloneable..::.Clone()()()

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.Dispose Method
StyleSeriesItemLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleSeriesItemLabel Class
StyleSeriesItemLabel Members
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.LoadViewState Method
StyleSeriesItemLabel Class See Also Send Feedback
Load data from ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState with data

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.SaveViewState Method
StyleSeriesItemLabel Class See Also Send Feedback
Save data to ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved data

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.TrackViewState Method
StyleSeriesItemLabel Class See Also Send Feedback
Track ViewState

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel Properties
StyleSeriesItemLabel Class See Also Send Feedback

The StyleSeriesItemLabel type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Distance | Label distance from series when LabelLocation equals Auto
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
LabelConnectorStyle | Gets label's connector's style
LabelLocation | Specifies label's layout
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies the rotation angle property (Inherited from StyleLabel.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies labels' visibility (Overrides StyleLabel..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Distance Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.Distance Property
StyleSeriesItemLabel Class See Also Send Feedback
Label distance from series when LabelLocation equals Auto

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Integer

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


LabelConnectorStyle Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.LabelConnectorStyle Property
StyleSeriesItemLabel Class See Also Send Feedback
Gets label's connector's style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle LabelConnectorStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property LabelConnectorStyle As LineStyle

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


LabelLocation Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.LabelLocation Property
StyleSeriesItemLabel Class See Also Send Feedback
Specifies label's layout

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemLabel..::.ItemLabelLocation LabelLocation { get; set; }
Visual Basic (Declaration)
Public Property LabelLocation As StyleSeriesItemLabel..::.ItemLabelLocation

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::.Visible Property
StyleSeriesItemLabel Class See Also Send Feedback
Specifies labels' visibility

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleSeriesItemLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemLabel.ItemLabelLocation Enumeration

[image]

Telerik Reporting Q2 2012
StyleSeriesItemLabel..::..ItemLabelLocation Enumeration
StyleSeriesItemLabel Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ItemLabelLocation
Visual Basic (Declaration)
Public Enumeration ItemLabelLocation

Members

Member name | Description
Inside | Inside item
Outside | Outside item
Auto | Auto

See Also

Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Class

[image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Class
Members See Also Send Feedback
Series item label text block's appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSeriesItemTextBlock : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleSeriesItemTextBlock _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleSeriesItemTextBlock

See Also

StyleSeriesItemTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Members

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Members
StyleSeriesItemTextBlock Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleSeriesItemTextBlock type exposes the following members.

Constructors

Name | Description
StyleSeriesItemTextBlock | Overloaded.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value (Overrides StyleTextBlock..::.ResetMaxLength()()().)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Gets should the MaxLength value be serialized (Overrides StyleTextBlock..::.ShouldSerializeMaxLength()()().)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Constructor
StyleSeriesItemTextBlock Class See Also Send Feedback

Overload List

Name | Description
StyleSeriesItemTextBlock()()() | Creates a new class instance
StyleSeriesItemTextBlock(ChartSeries) | Creates a new class instance

See Also

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Constructor

[image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Constructor
StyleSeriesItemTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemTextBlock()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Constructor (ChartSeries)

[image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Constructor (ChartSeries)
StyleSeriesItemTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSeriesItemTextBlock(
    ChartSeries series
)
Visual Basic (Declaration)
Public Sub New ( _
    series As ChartSeries _
)

Parameters

series
Type: Telerik.Reporting.Charting..::.ChartSeries
Chart series

See Also

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Fields

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Fields
StyleSeriesItemTextBlock Class See Also Send Feedback

The StyleSeriesItemTextBlock type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Methods
StyleSeriesItemTextBlock Class See Also Send Feedback

The StyleSeriesItemTextBlock type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value (Overrides StyleTextBlock..::.ResetMaxLength()()().)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Gets should the MaxLength value be serialized (Overrides StyleTextBlock..::.ShouldSerializeMaxLength()()().)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock..::.Dispose Method
StyleSeriesItemTextBlock Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleSeriesItemTextBlock Class
StyleSeriesItemTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


ResetMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock..::.ResetMaxLength Method
StyleSeriesItemTextBlock Class See Also Send Feedback
Sets the default value

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ResetMaxLength()
Visual Basic (Declaration)
Protected Overrides Sub ResetMaxLength

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock..::.ShouldSerializeMaxLength Method
StyleSeriesItemTextBlock Class See Also Send Feedback
Gets should the MaxLength value be serialized

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override bool ShouldSerializeMaxLength()
Visual Basic (Declaration)
Protected Overrides Function ShouldSerializeMaxLength As Boolean

Return Value

True if can be serialized, overwise returns false

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleSeriesItemTextBlock Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSeriesItemTextBlock Properties
StyleSeriesItemTextBlock Class See Also Send Feedback

The StyleSeriesItemTextBlock type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleSeriesItemTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Class

[image]

Telerik Reporting Q2 2012
StyleTextBlock Class
Members See Also Send Feedback
Text block appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTextBlock : LayoutStyle
Visual Basic (Declaration)
Public Class StyleTextBlock _
    Inherits LayoutStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleAxisItemText
Telerik.Reporting.Charting.Styles..::.StyleSeriesItemTextBlock
Telerik.Reporting.Charting.Styles..::.StyleTextBlockAxisLabel
Telerik.Reporting.Charting.Styles..::.StyleTextBlockError
Telerik.Reporting.Charting.Styles..::.StyleTextBlockHidden
Telerik.Reporting.Charting.Styles..::.StyleTextBlockTitle

See Also

StyleTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Members

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock Members
StyleTextBlock Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleTextBlock type exposes the following members.

Constructors

Name | Description
StyleTextBlock | Overloaded.

Methods

Name | Description
Clone | Creates the object's clone (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Overrides LayoutStyle..::.LoadViewState(Object).)
ResetMaxLength | Sets the default value for a MaxLength property
SaveViewState | Saves class data to a view state (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not
TrackViewState | Tracks view state changes (Overrides LayoutStyle..::.TrackViewState()()().)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle
styleTextBlockOverflow | Specifiers the overflow behavior
styleTextBlockRotationAngle | Specifies the Rotation angle

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
FillStyle
Specifies the FillStyle property
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor
StyleTextBlock Class See Also Send Feedback

Overload List

Name | Description
StyleTextBlock()()() | Creates a new class instance
StyleTextBlock(FillStyle) | Creates a new class instance
StyleTextBlock(TextProperties) | Creates a new class instance
StyleTextBlock(FillStyle, Position) | Creates a new class instance
StyleTextBlock(FillStyle, TextProperties) | Creates a new class instance
StyleTextBlock(FillStyle, Position, TextProperties) | Creates a new class instance
StyleTextBlock(FillStyle, Position, TextProperties, Dimensions) | Creates a new class instance
StyleTextBlock(Dimensions, FillStyle, Position, Single, TextProperties, Corners, StyleBorder, ShadowStyle, Boolean) | Creates a new class instance

See Also

StyleTextBlock Class
StyleTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (FillStyle)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (FillStyle)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    FillStyle fillStyle
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (TextProperties)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (TextProperties)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    TextProperties textProperties
)
Visual Basic (Declaration)
Public Sub New ( _
    textProperties As TextProperties _
)

Parameters

textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
Text appearance settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (FillStyle, Position)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (FillStyle, Position)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    FillStyle fillStyle,
    Position position
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (FillStyle, TextProperties)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (FillStyle, TextProperties)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    FillStyle fillStyle,
    TextProperties textProperties
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    textProperties As TextProperties _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings
textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
Text appearance settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (FillStyle, Position, TextProperties)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (FillStyle, Position, TextProperties)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    FillStyle fillStyle,
    Position position,
    TextProperties textProperties
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position, _
    textProperties As TextProperties _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position settings
textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
Text appearance settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (FillStyle, Position, TextProperties, Dimensions)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (FillStyle, Position, TextProperties, Dimensions)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    FillStyle fillStyle,
    Position position,
    TextProperties textProperties,
    Dimensions dimensions
)
Visual Basic (Declaration)
Public Sub New ( _
    fillStyle As FillStyle, _
    position As Position, _
    textProperties As TextProperties, _
    dimensions As Dimensions _
)

Parameters

fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position settings
textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
Text appearance settings
dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Constructor (Dimensions, FillStyle, Position, Single, TextProperties, Corners, StyleBorder, ShadowStyle, Boolean)

[image]

Telerik Reporting Q2 2012
StyleTextBlock Constructor (Dimensions, FillStyle, Position, Single, TextProperties, Corners, StyleBorder, ShadowStyle, Boolean)
StyleTextBlock Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlock(
    Dimensions dimensions,
    FillStyle fillStyle,
    Position position,
    float rotationAngle,
    TextProperties textProperties,
    Corners corners,
    StyleBorder border,
    ShadowStyle shadowStyle,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    dimensions As Dimensions, _
    fillStyle As FillStyle, _
    position As Position, _
    rotationAngle As Single, _
    textProperties As TextProperties, _
    corners As Corners, _
    border As StyleBorder, _
    shadowStyle As ShadowStyle, _
    visible As Boolean _
)

Parameters

dimensions
Type: Telerik.Reporting.Charting.Styles..::.Dimensions
Dimensions
fillStyle
Type: Telerik.Reporting.Charting.Styles..::.FillStyle
Fill style settings
position
Type: Telerik.Reporting.Charting.Styles..::.Position
Position settings
rotationAngle
Type: System..::.Single
Rotation angle
textProperties
Type: Telerik.Reporting.Charting.Styles..::.TextProperties
Text appearance settings
corners
Type: Telerik.Reporting.Charting.Styles..::.Corners
Corners appearance
border
Type: Telerik.Reporting.Charting.Styles..::.StyleBorder
Border settings
shadowStyle
Type: Telerik.Reporting.Charting.Styles..::.ShadowStyle
Shadow settings
visible
Type: System..::.Boolean
Visibility settings

See Also

StyleTextBlock Class
StyleTextBlock Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Fields

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock Fields
StyleTextBlock Class See Also Send Feedback

The StyleTextBlock type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle
styleTextBlockOverflow | Specifiers the overflow behavior
styleTextBlockRotationAngle | Specifies the Rotation angle

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


styleTextBlockCorners Field

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.styleTextBlockCorners Field
StyleTextBlock Class See Also Send Feedback
Specifies the corners of background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Corners styleTextBlockCorners
Visual Basic (Declaration)
Protected styleTextBlockCorners As Corners

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


styleTextBlockOverflow Field

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.styleTextBlockOverflow Field
StyleTextBlock Class See Also Send Feedback
Specifiers the overflow behavior

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Overflow styleTextBlockOverflow
Visual Basic (Declaration)
Protected styleTextBlockOverflow As Overflow

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


styleTextBlockRotationAngle Field

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.styleTextBlockRotationAngle Field
StyleTextBlock Class See Also Send Feedback
Specifies the Rotation angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected float styleTextBlockRotationAngle
Visual Basic (Declaration)
Protected styleTextBlockRotationAngle As Single

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock Methods
StyleTextBlock Class See Also Send Feedback

The StyleTextBlock type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Overrides Style..::.Clone()()().)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Overrides LayoutStyle..::.LoadViewState(Object).)
ResetMaxLength | Sets the default value for a MaxLength property
SaveViewState | Saves class data to a view state (Overrides LayoutStyle..::.SaveViewState()()().)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not
TrackViewState | Tracks view state changes (Overrides LayoutStyle..::.TrackViewState()()().)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.Clone Method
StyleTextBlock Class See Also Send Feedback
Creates the object's clone

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Return Value

Clone

Implements

ICloneable..::.Clone()()()

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock..::.Dispose Method
StyleTextBlock Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Overrides LayoutStyle..::.Dispose(Boolean).)

See Also

StyleTextBlock Class
StyleTextBlock Members
Telerik.Reporting.Charting.Styles Namespace


Dispose Method (Boolean)

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.Dispose Method (Boolean)
StyleTextBlock Class See Also Send Feedback
Releases unmanaged and - optionally - managed resources

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

StyleTextBlock Class
Dispose Overload
Telerik.Reporting.Charting.Styles Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.LoadViewState Method
StyleTextBlock Class See Also Send Feedback
Loads class settings from a view state

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object
ViewState to load from

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


ResetMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.ResetMaxLength Method
StyleTextBlock Class See Also Send Feedback
Sets the default value for a MaxLength property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void ResetMaxLength()
Visual Basic (Declaration)
Protected Overridable Sub ResetMaxLength

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.SaveViewState Method
StyleTextBlock Class See Also Send Feedback
Saves class data to a view state

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

Return Value

Saved view state

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


ShouldSerializeMaxLength Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.ShouldSerializeMaxLength Method
StyleTextBlock Class See Also Send Feedback
Should the MaxLength property be serialized or not

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual bool ShouldSerializeMaxLength()
Visual Basic (Declaration)
Protected Overridable Function ShouldSerializeMaxLength As Boolean

Return Value

True if should be serialized

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


TrackViewState Method

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.TrackViewState Method
StyleTextBlock Class See Also Send Feedback
Tracks view state changes

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void TrackViewState()
Visual Basic (Declaration)
Protected Overrides Sub TrackViewState

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlock Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlock Properties
StyleTextBlock Class See Also Send Feedback

The StyleTextBlock type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
FillStyle
Specifies the FillStyle property
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


AutoTextWrap Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.AutoTextWrap Property
StyleTextBlock Class See Also Send Feedback
Gets or sets the automatic text wrapping functionality switch

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual AutoTextWrap AutoTextWrap { get; set; }
Visual Basic (Declaration)
Public Overridable Property AutoTextWrap As AutoTextWrap

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Corners Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.Corners Property
StyleTextBlock Class See Also Send Feedback
Specifies the corners of background rectangle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


Figure Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.Figure Property
StyleTextBlock Class See Also Send Feedback
Specifies the Figure property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Figure { get; }
Visual Basic (Declaration)
Public ReadOnly Property Figure As String

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


FillStyle Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.FillStyle Property
StyleTextBlock Class See Also Send Feedback
Specifies the FillStyle property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual FillStyle FillStyle { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property FillStyle As FillStyle

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


MaxLength Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.MaxLength Property
StyleTextBlock Class See Also Send Feedback
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int MaxLength { get; set; }
Visual Basic (Declaration)
Public Property MaxLength As Integer

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Property

[image]

Telerik Reporting Q2 2012
StyleTextBlock..::.TextProperties Property
StyleTextBlock Class See Also Send Feedback
Specifies the Text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual TextProperties TextProperties { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property TextProperties As TextProperties

See Also

StyleTextBlock Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Class

[image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Class
Members See Also Send Feedback
Hidden text block's default appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTextBlockAxisLabel : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleTextBlockAxisLabel _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleTextBlockAxisLabel

See Also

StyleTextBlockAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Members
StyleTextBlockAxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleTextBlockAxisLabel type exposes the following members.

Constructors

Name | Description
StyleTextBlockAxisLabel | Creates a new class instance

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Constructor
StyleTextBlockAxisLabel Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlockAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Fields
StyleTextBlockAxisLabel Class See Also Send Feedback

The StyleTextBlockAxisLabel type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Methods
StyleTextBlockAxisLabel Class See Also Send Feedback

The StyleTextBlockAxisLabel type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel..::.Dispose Method
StyleTextBlockAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleTextBlockAxisLabel Class
StyleTextBlockAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockAxisLabel Properties
StyleTextBlockAxisLabel Class See Also Send Feedback

The StyleTextBlockAxisLabel type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Class

[image]

Telerik Reporting Q2 2012
StyleTextBlockError Class
Members See Also Send Feedback
Error text block's appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTextBlockError : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleTextBlockError _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleTextBlockError

See Also

StyleTextBlockError Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Members

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockError Members
StyleTextBlockError Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleTextBlockError type exposes the following members.

Constructors

Name | Description
StyleTextBlockError | Creates a new class instance

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Constructor

[image]

Telerik Reporting Q2 2012
StyleTextBlockError Constructor
StyleTextBlockError Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlockError()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Fields

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockError Fields
StyleTextBlockError Class See Also Send Feedback

The StyleTextBlockError type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockError Methods
StyleTextBlockError Class See Also Send Feedback

The StyleTextBlockError type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockError..::.Dispose Method
StyleTextBlockError Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleTextBlockError Class
StyleTextBlockError Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockError Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockError Properties
StyleTextBlockError Class See Also Send Feedback

The StyleTextBlockError type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockError Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Class

[image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Class
Members See Also Send Feedback
Hidden text block's default appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTextBlockHidden : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleTextBlockHidden _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleTextBlockHidden

See Also

StyleTextBlockHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Members

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Members
StyleTextBlockHidden Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleTextBlockHidden type exposes the following members.

Constructors

Name | Description
StyleTextBlockHidden | Initializes a new instance of the StyleTextBlockHidden class

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Visibility. False by default
(Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Constructor

[image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Constructor
StyleTextBlockHidden Class See Also Send Feedback
Initializes a new instance of the StyleTextBlockHidden class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlockHidden()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Fields

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Fields
StyleTextBlockHidden Class See Also Send Feedback

The StyleTextBlockHidden type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Methods
StyleTextBlockHidden Class See Also Send Feedback

The StyleTextBlockHidden type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockHidden..::.Dispose Method
StyleTextBlockHidden Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleTextBlockHidden Class
StyleTextBlockHidden Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockHidden Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockHidden Properties
StyleTextBlockHidden Class See Also Send Feedback

The StyleTextBlockHidden type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Visibility. False by default
(Overrides Style..::.Visible.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
StyleTextBlockHidden..::.Visible Property
StyleTextBlockHidden Class See Also Send Feedback
Visibility. False by default

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Visible { get; set; }
Visual Basic (Declaration)
Public Overrides Property Visible As Boolean

See Also

StyleTextBlockHidden Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Class

[image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Class
Members See Also Send Feedback
Title text block's appearance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTextBlockTitle : StyleTextBlock
Visual Basic (Declaration)
Public Class StyleTextBlockTitle _
    Inherits StyleTextBlock

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleTextBlock
Telerik.Reporting.Charting.Styles..::.StyleTextBlockTitle

See Also

StyleTextBlockTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Members

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Members
StyleTextBlockTitle Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleTextBlockTitle type exposes the following members.

Constructors

Name | Description
StyleTextBlockTitle | Creates a new class instance

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Constructor

[image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Constructor
StyleTextBlockTitle Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTextBlockTitle()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Fields

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Fields
StyleTextBlockTitle Class See Also Send Feedback

The StyleTextBlockTitle type exposes the following members.

Fields

Name | Description
styleTextBlockCorners | Specifies the corners of background rectangle (Inherited from StyleTextBlock.)
styleTextBlockOverflow | Specifiers the overflow behavior (Inherited from StyleTextBlock.)
styleTextBlockRotationAngle | Specifies the Rotation angle (Inherited from StyleTextBlock.)

See Also

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Methods
StyleTextBlockTitle Class See Also Send Feedback

The StyleTextBlockTitle type exposes the following members.

Methods

Name | Description
Clone | Creates the object's clone (Inherited from StyleTextBlock.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Loads class settings from a view state (Inherited from StyleTextBlock.)
ResetMaxLength | Sets the default value for a MaxLength property (Inherited from StyleTextBlock.)
SaveViewState | Saves class data to a view state (Inherited from StyleTextBlock.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
ShouldSerializeMaxLength | Should the MaxLength property be serialized or not (Inherited from StyleTextBlock.)
TrackViewState | Tracks view state changes (Inherited from StyleTextBlock.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockTitle..::.Dispose Method
StyleTextBlockTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleTextBlock.)

See Also

StyleTextBlockTitle Class
StyleTextBlockTitle Members
Telerik.Reporting.Charting.Styles Namespace


StyleTextBlockTitle Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTextBlockTitle Properties
StyleTextBlockTitle Class See Also Send Feedback

The StyleTextBlockTitle type exposes the following members.

Properties

Name Description
AutoTextWrap
Gets or sets the automatic text wrapping functionality switch
(Inherited from StyleTextBlock.)
Border
Specifies the border style
(Inherited from Style.)
Corners
Specifies the corners of background rectangle
(Inherited from StyleTextBlock.)
Dimensions
Specifies the elements Dimensions property
(Inherited from LayoutStyle.)
Figure
Specifies the Figure property
(Inherited from StyleTextBlock.)
FillStyle
Specifies the FillStyle property
(Inherited from StyleTextBlock.)
MaxLength
Max number of visible characters. Rest will be truncated

Remarks

Full string will be added to parent label's ActiveRegion.Tooltip
(Inherited from StyleTextBlock.)
Position
Specifies the elements Position property
(Inherited from LayoutStyle.)
Shadow
Specifies the shadow settings
(Inherited from Style.)
TextProperties
Specifies the Text properties
(Inherited from StyleTextBlock.)
ViewStateIgnoresCase
Gets if view sate should ignore case
(Inherited from StateManagedObject.)
Visible
Specifies visibility
(Inherited from Style.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTextBlockTitle Class
Telerik.Reporting.Charting.Styles Namespace


StyleTick Class

[image]

Telerik Reporting Q2 2012
StyleTick Class
Members See Also Send Feedback
Base axis ticks appearance settings

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTick : LineStyle
Visual Basic (Declaration)
Public Class StyleTick _
    Inherits LineStyle

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleTick
Telerik.Reporting.Charting.Styles..::.StyleTickMajor
Telerik.Reporting.Charting.Styles..::.StyleTickMinor

See Also

StyleTick Members
Telerik.Reporting.Charting.Styles Namespace


StyleTick Members

[image] [image]

Telerik Reporting Q2 2012
StyleTick Members
StyleTick Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleTick type exposes the following members.

Constructors

Name | Description
StyleTick | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Tick line color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleTick Constructor
StyleTick Class See Also Send Feedback

Overload List

Name | Description
StyleTick()()() | Creates the new class instance
StyleTick(Int32) | Creates the new class instance
StyleTick(Int32, Boolean) | Creates the new class instance
StyleTick(Boolean, Int32, Color) | Creates the new class instance

See Also

StyleTick Class
StyleTick Members
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor

[image]

Telerik Reporting Q2 2012
StyleTick Constructor
StyleTick Class See Also Send Feedback
Creates the new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTick()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTick Class
StyleTick Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor (Int32)

[image]

Telerik Reporting Q2 2012
StyleTick Constructor (Int32)
StyleTick Class See Also Send Feedback
Creates the new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTick(
    int length
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer _
)

Parameters

length
Type: System..::.Int32
Tick length in pixels

See Also

StyleTick Class
StyleTick Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor (Int32, Boolean)

[image]

Telerik Reporting Q2 2012
StyleTick Constructor (Int32, Boolean)
StyleTick Class See Also Send Feedback
Creates the new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTick(
    int length,
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    visible As Boolean _
)

Parameters

length
Type: System..::.Int32
Tick length in pixels
visible
Type: System..::.Boolean
Tick visibility

See Also

StyleTick Class
StyleTick Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTick Constructor (Boolean, Int32, Color)

[image]

Telerik Reporting Q2 2012
StyleTick Constructor (Boolean, Int32, Color)
StyleTick Class See Also Send Feedback
Creates the new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTick(
    bool visible,
    int length,
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean, _
    length As Integer, _
    color As Color _
)

Parameters

visible
Type: System..::.Boolean
Tick visibility
length
Type: System..::.Int32
Tick length in pixels
color
Type: System.Drawing..::.Color
Tick line color

See Also

StyleTick Class
StyleTick Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTick Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTick Methods
StyleTick Class See Also Send Feedback

The StyleTick type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTick..::.Dispose Method
StyleTick Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleTick Class
StyleTick Members
Telerik.Reporting.Charting.Styles Namespace


StyleTick Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTick Properties
StyleTick Class See Also Send Feedback

The StyleTick type exposes the following members.

Properties

Name | Description
Color | Tick line color (Overrides StyleBorder..::.Color.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Overrides StyleBorder..::.Width.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
StyleTick..::.Color Property
StyleTick Class See Also Send Feedback
Tick line color

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


Length Property

[image]

Telerik Reporting Q2 2012
StyleTick..::.Length Property
StyleTick Class See Also Send Feedback
Specifies the Length of tick

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual int Length { get; set; }
Visual Basic (Declaration)
Public Overridable Property Length As Integer

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


Width Property

[image]

Telerik Reporting Q2 2012
StyleTick..::.Width Property
StyleTick Class See Also Send Feedback
Tick line width

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Single

See Also

StyleTick Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Class

[image]

Telerik Reporting Q2 2012
StyleTickMajor Class
Members See Also Send Feedback
Major ticks visual style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTickMajor : StyleTick
Visual Basic (Declaration)
Public Class StyleTickMajor _
    Inherits StyleTick

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleTick
Telerik.Reporting.Charting.Styles..::.StyleTickMajor

See Also

StyleTickMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Members

[image] [image]

Telerik Reporting Q2 2012
StyleTickMajor Members
StyleTickMajor Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleTickMajor type exposes the following members.

Constructors

Name | Description
StyleTickMajor | Initializes a new instance of the StyleTickMajor class

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Tick line color (Inherited from StyleTick.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick (Inherited from StyleTick.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Inherited from StyleTick.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Constructor

[image]

Telerik Reporting Q2 2012
StyleTickMajor Constructor
StyleTickMajor Class See Also Send Feedback
Initializes a new instance of the StyleTickMajor class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMajor()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTickMajor Methods
StyleTickMajor Class See Also Send Feedback

The StyleTickMajor type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTickMajor..::.Dispose Method
StyleTickMajor Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleTickMajor Class
StyleTickMajor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMajor Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTickMajor Properties
StyleTickMajor Class See Also Send Feedback

The StyleTickMajor type exposes the following members.

Properties

Name | Description
Color | Tick line color (Inherited from StyleTick.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick (Inherited from StyleTick.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Inherited from StyleTick.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTickMajor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Class

[image]

Telerik Reporting Q2 2012
StyleTickMinor Class
Members See Also Send Feedback
Minor ticks style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTickMinor : StyleTick
Visual Basic (Declaration)
Public Class StyleTickMinor _
    Inherits StyleTick

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.LineStyle
Telerik.Reporting.Charting.Styles..::.StyleTick
Telerik.Reporting.Charting.Styles..::.StyleTickMinor

See Also

StyleTickMinor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Members

[image] [image]

Telerik Reporting Q2 2012
StyleTickMinor Members
StyleTickMinor Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleTickMinor type exposes the following members.

Constructors

Name | Description
StyleTickMinor | Overloaded.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Tick line color (Inherited from StyleTick.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick (Overrides StyleTick..::.Length.)
MinorTickCount | Minor ticks count between the two major ticks
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Inherited from StyleTick.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleTickMinor Constructor
StyleTickMinor Class See Also Send Feedback

Overload List

Name | Description
StyleTickMinor()()() | Creates a new class instance
StyleTickMinor(Boolean) | Creates a new class instance
StyleTickMinor(Int32) | Creates a new class instance
StyleTickMinor(Boolean, Int32, Int32) | Creates a new class instance

See Also

StyleTickMinor Class
StyleTickMinor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor

[image]

Telerik Reporting Q2 2012
StyleTickMinor Constructor
StyleTickMinor Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMinor()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTickMinor Class
StyleTickMinor Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor (Boolean)

[image]

Telerik Reporting Q2 2012
StyleTickMinor Constructor (Boolean)
StyleTickMinor Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMinor(
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean _
)

Parameters

visible
Type: System..::.Boolean
Visibility value

See Also

StyleTickMinor Class
StyleTickMinor Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor (Int32)

[image]

Telerik Reporting Q2 2012
StyleTickMinor Constructor (Int32)
StyleTickMinor Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMinor(
    int count
)
Visual Basic (Declaration)
Public Sub New ( _
    count As Integer _
)

Parameters

count
Type: System..::.Int32
Minor ticks count

See Also

StyleTickMinor Class
StyleTickMinor Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Constructor (Boolean, Int32, Int32)

[image]

Telerik Reporting Q2 2012
StyleTickMinor Constructor (Boolean, Int32, Int32)
StyleTickMinor Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTickMinor(
    bool visible,
    int length,
    int count
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean, _
    length As Integer, _
    count As Integer _
)

Parameters

visible
Type: System..::.Boolean
Minor tick visibility
length
Type: System..::.Int32
Minor tick length
count
Type: System..::.Int32
Minor ticks count between two major ticks

See Also

StyleTickMinor Class
StyleTickMinor Overload
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTickMinor Methods
StyleTickMinor Class See Also Send Feedback

The StyleTickMinor type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from LineStyle.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from LineStyle.)
GetHashCode | Gets hash code (Inherited from LineStyle.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTickMinor..::.Dispose Method
StyleTickMinor Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleTickMinor Class
StyleTickMinor Members
Telerik.Reporting.Charting.Styles Namespace


StyleTickMinor Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTickMinor Properties
StyleTickMinor Class See Also Send Feedback

The StyleTickMinor type exposes the following members.

Properties

Name | Description
Color | Tick line color (Inherited from StyleTick.)
EndCap | Specifies the end cap property (Inherited from LineStyle.)
Length | Specifies the Length of tick (Overrides StyleTick..::.Length.)
MinorTickCount | Minor ticks count between the two major ticks
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
StartCap | Specifies the start cap property (Inherited from LineStyle.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Tick line width (Inherited from StyleTick.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


Length Property

[image]

Telerik Reporting Q2 2012
StyleTickMinor..::.Length Property
StyleTickMinor Class See Also Send Feedback
Specifies the Length of tick

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int Length { get; set; }
Visual Basic (Declaration)
Public Overrides Property Length As Integer

See Also

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


MinorTickCount Property

[image]

Telerik Reporting Q2 2012
StyleTickMinor..::.MinorTickCount Property
StyleTickMinor Class See Also Send Feedback
Minor ticks count between the two major ticks

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int MinorTickCount { get; set; }
Visual Basic (Declaration)
Public Property MinorTickCount As Integer

See Also

StyleTickMinor Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Class

[image]

Telerik Reporting Q2 2012
StyleTitleBorder Class
Members See Also Send Feedback
Title border specific style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleTitleBorder : StyleBorder
Visual Basic (Declaration)
Public Class StyleTitleBorder _
    Inherits StyleBorder

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.StyleBorder
Telerik.Reporting.Charting.Styles..::.StyleTitleBorder

See Also

StyleTitleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Members

[image] [image]

Telerik Reporting Q2 2012
StyleTitleBorder Members
StyleTitleBorder Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StyleTitleBorder type exposes the following members.

Constructors

Name | Description
StyleTitleBorder | Initializes a new instance of the StyleTitleBorder class

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the line color property (Inherited from StyleBorder.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Constructor

[image]

Telerik Reporting Q2 2012
StyleTitleBorder Constructor
StyleTitleBorder Class See Also Send Feedback
Initializes a new instance of the StyleTitleBorder class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleTitleBorder()
Visual Basic (Declaration)
Public Sub New

See Also

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Methods

[image] [image]

Telerik Reporting Q2 2012
StyleTitleBorder Methods
StyleTitleBorder Class See Also Send Feedback

The StyleTitleBorder type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleBorder.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Compare two objects (Inherited from StyleBorder.)
GetHashCode | Gets hash code (Inherited from StyleBorder.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleTitleBorder..::.Dispose Method
StyleTitleBorder Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

StyleTitleBorder Class
StyleTitleBorder Members
Telerik.Reporting.Charting.Styles Namespace


StyleTitleBorder Properties

[image] [image]

Telerik Reporting Q2 2012
StyleTitleBorder Properties
StyleTitleBorder Class See Also Send Feedback

The StyleTitleBorder type exposes the following members.

Properties

Name | Description
Color | Specifies the line color property (Inherited from StyleBorder.)
PenStyle | Specifies the pen style property (Inherited from StyleBorder.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Visibility (Inherited from StyleBorder.)
Width | Specifies the width property (Inherited from StyleBorder.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleTitleBorder Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Class

[image]

Telerik Reporting Q2 2012
StyleYAxisLabel Class
Members See Also Send Feedback
Axis label style

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleYAxisLabel : StyleAxisLabel
Visual Basic (Declaration)
Public Class StyleYAxisLabel _
    Inherits StyleAxisLabel

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.Style
Telerik.Reporting.Charting.Styles..::.LayoutStyle
Telerik.Reporting.Charting.Styles..::.StyleLabel
Telerik.Reporting.Charting.Styles..::.StyleLabelHidden
Telerik.Reporting.Charting.Styles..::.StyleAxisLabel
Telerik.Reporting.Charting.Styles..::.StyleYAxisLabel

See Also

StyleYAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
StyleYAxisLabel Members
StyleYAxisLabel Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleYAxisLabel type exposes the following members.

Constructors

Name | Description
StyleYAxisLabel | Initializes a new instance of the StyleYAxisLabel class

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies label's rotation angle (Overrides StyleLabel..::.RotationAngle.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
StyleYAxisLabel Constructor
StyleYAxisLabel Class See Also Send Feedback
Initializes a new instance of the StyleYAxisLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleYAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Fields

[image] [image]

Telerik Reporting Q2 2012
StyleYAxisLabel Fields
StyleYAxisLabel Class See Also Send Feedback

The StyleYAxisLabel type exposes the following members.

Fields

Name | Description
styleLabelCorners | Specifies the corners for background rectangle (Inherited from StyleLabel.)

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
StyleYAxisLabel Methods
StyleYAxisLabel Class See Also Send Feedback

The StyleYAxisLabel type exposes the following members.

Methods

Name | Description
Clone | Clone this object (Inherited from StyleLabel.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
LoadViewState | Load data from ViewState (Inherited from StyleLabel.)
SaveViewState | Save data to ViewState (Inherited from StyleLabel.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Track ViewState (Inherited from StyleLabel.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
StyleYAxisLabel..::.Dispose Method
StyleYAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | Releases unmanaged and - optionally - managed resources (Inherited from StyleLabel.)

See Also

StyleYAxisLabel Class
StyleYAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


StyleYAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
StyleYAxisLabel Properties
StyleYAxisLabel Class See Also Send Feedback

The StyleYAxisLabel type exposes the following members.

Properties

Name | Description
Border | Specifies the border style (Inherited from Style.)
CompositionType | Specifies the label's items composition type (Inherited from StyleLabel.)
Corners | Specifies the corners for background rectangle (Inherited from StyleLabel.)
Dimensions | Specifies the elements Dimensions property (Inherited from LayoutStyle.)
Figure | Specifies the figure property (Inherited from StyleLabel.)
FillStyle | Specifies the background property (Inherited from StyleLabel.)
Position | Specifies the elements Position property (Inherited from LayoutStyle.)
RotationAngle | Specifies label's rotation angle (Overrides StyleLabel..::.RotationAngle.)
Shadow | Specifies the shadow settings (Inherited from Style.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)
Visible | Specifies tha label's visibility (Inherited from StyleLabelHidden.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


RotationAngle Property

[image]

Telerik Reporting Q2 2012
StyleYAxisLabel..::.RotationAngle Property
StyleYAxisLabel Class See Also Send Feedback
Specifies label's rotation angle

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override float RotationAngle { get; set; }
Visual Basic (Declaration)
Public Overrides Property RotationAngle As Single

See Also

StyleYAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Class

[image]

Telerik Reporting Q2 2012
TextProperties Class
Members See Also Send Feedback
Base text appearance settings class (Font, Color)

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextProperties : StateManagedObject,
    ICloneable
Visual Basic (Declaration)
Public Class TextProperties _
    Inherits StateManagedObject _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesAxisItem
Telerik.Reporting.Charting.Styles..::.TextPropertiesAxisLabel
Telerik.Reporting.Charting.Styles..::.TextPropertiesError
Telerik.Reporting.Charting.Styles..::.TextPropertiesSeriesItem
Telerik.Reporting.Charting.Styles..::.TextPropertiesTitle

See Also

TextProperties Members
Telerik.Reporting.Charting.Styles Namespace


TextProperties Members

[image] [image]

Telerik Reporting Q2 2012
TextProperties Members
TextProperties Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextProperties type exposes the following members.

Constructors

Name | Description
TextProperties | Overloaded.

Methods

Name | Description
Clone | Creates an object clone
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a TextProperties type. (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property
Font | Specifies the text font properties
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor

[image] [image]

Telerik Reporting Q2 2012
TextProperties Constructor
TextProperties Class See Also Send Feedback

Overload List

Name | Description
TextProperties()()() | Creates a new class instance
TextProperties(Color) | Creates a new class instance
TextProperties(Color, Font) | Creates a new class instance
TextProperties(Color, String, Single, FontStyle, GraphicsUnit) | Creates a new class instance

See Also

TextProperties Class
TextProperties Members
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor

[image]

Telerik Reporting Q2 2012
TextProperties Constructor
TextProperties Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextProperties()
Visual Basic (Declaration)
Public Sub New

See Also

TextProperties Class
TextProperties Overload
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor (Color)

[image]

Telerik Reporting Q2 2012
TextProperties Constructor (Color)
TextProperties Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextProperties(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)

Parameters

color
Type: System.Drawing..::.Color
Text color

See Also

TextProperties Class
TextProperties Overload
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor (Color, Font)

[image]

Telerik Reporting Q2 2012
TextProperties Constructor (Color, Font)
TextProperties Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextProperties(
    Color color,
    Font font
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    font As Font _
)

Parameters

color
Type: System.Drawing..::.Color
Text color
font
Type: System.Drawing..::.Font
Text font

See Also

TextProperties Class
TextProperties Overload
Telerik.Reporting.Charting.Styles Namespace


TextProperties Constructor (Color, String, Single, FontStyle, GraphicsUnit)

[image]

Telerik Reporting Q2 2012
TextProperties Constructor (Color, String, Single, FontStyle, GraphicsUnit)
TextProperties Class See Also Send Feedback
Creates a new class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextProperties(
    Color color,
    string familyName,
    float emSize,
    FontStyle fontStyle,
    GraphicsUnit grUnit
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    familyName As String, _
    emSize As Single, _
    fontStyle As FontStyle, _
    grUnit As GraphicsUnit _
)

Parameters

color
Type: System.Drawing..::.Color
Text color
familyName
Type: System..::.String
Font family
emSize
Type: System..::.Single
Font size in EM
fontStyle
Type: System.Drawing..::.FontStyle
Font style
grUnit
Type: System.Drawing..::.GraphicsUnit
Graphics measurement unit

See Also

TextProperties Class
TextProperties Overload
Telerik.Reporting.Charting.Styles Namespace


TextProperties Methods

[image] [image]

Telerik Reporting Q2 2012
TextProperties Methods
TextProperties Class See Also Send Feedback

The TextProperties type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Overrides Object..::.Equals(Object).)
GetHashCode | Serves as a hash function for a TextProperties type. (Overrides Object..::.GetHashCode()()().)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
TextProperties..::.Clone Method
TextProperties Class See Also Send Feedback
Creates an object clone

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

object

Implements

ICloneable..::.Clone()()()

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextProperties..::.Dispose Method
TextProperties Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextProperties Class
TextProperties Members
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
TextProperties..::.Equals Method
TextProperties Class See Also Send Feedback
Determines whether the specified System.Object is equal to the current System.Object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The System.Object to compare with the current System.Object

Return Value

true if the specified System.Object is equal to the current System.Object; otherwise, false.

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
TextProperties..::.GetHashCode Method
TextProperties Class See Also Send Feedback
Serves as a hash function for a TextProperties type.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

A hash code for the current class instance

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


TextProperties Properties

[image] [image]

Telerik Reporting Q2 2012
TextProperties Properties
TextProperties Class See Also Send Feedback

The TextProperties type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property
Font | Specifies the text font properties
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextProperties..::.Color Property
TextProperties Class See Also Send Feedback
Specifies the text color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Color Color { get; set; }
Visual Basic (Declaration)
Public Overridable Property Color As Color

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


Font Property

[image]

Telerik Reporting Q2 2012
TextProperties..::.Font Property
TextProperties Class See Also Send Feedback
Specifies the text font properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual Font Font { get; set; }
Visual Basic (Declaration)
Public Overridable Property Font As Font

See Also

TextProperties Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Class

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem Class
Members See Also Send Feedback
Axis item label text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextPropertiesAxisItem : TextProperties
Visual Basic (Declaration)
Public Class TextPropertiesAxisItem _
    Inherits TextProperties

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesAxisItem

See Also

TextPropertiesAxisItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Members

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem Members
TextPropertiesAxisItem Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextPropertiesAxisItem type exposes the following members.

Constructors

Name | Description
TextPropertiesAxisItem | Initializes a new instance of the TextPropertiesAxisItem class

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Constructor

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem Constructor
TextPropertiesAxisItem Class See Also Send Feedback
Initializes a new instance of the TextPropertiesAxisItem class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextPropertiesAxisItem()
Visual Basic (Declaration)
Public Sub New

See Also

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Methods

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem Methods
TextPropertiesAxisItem Class See Also Send Feedback

The TextPropertiesAxisItem type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem..::.Dispose Method
TextPropertiesAxisItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisItem Class
TextPropertiesAxisItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisItem Properties

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem Properties
TextPropertiesAxisItem Class See Also Send Feedback

The TextPropertiesAxisItem type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisItem..::.Color Property
TextPropertiesAxisItem Class See Also Send Feedback
Specifies the text color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

TextPropertiesAxisItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Class

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel Class
Members See Also Send Feedback
Axis item label text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextPropertiesAxisLabel : TextProperties
Visual Basic (Declaration)
Public Class TextPropertiesAxisLabel _
    Inherits TextProperties

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesAxisLabel

See Also

TextPropertiesAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Members

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel Members
TextPropertiesAxisLabel Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextPropertiesAxisLabel type exposes the following members.

Constructors

Name | Description
TextPropertiesAxisLabel | Initializes a new instance of the TextPropertiesAxisLabel class

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Constructor

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel Constructor
TextPropertiesAxisLabel Class See Also Send Feedback
Initializes a new instance of the TextPropertiesAxisLabel class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextPropertiesAxisLabel()
Visual Basic (Declaration)
Public Sub New

See Also

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Methods

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel Methods
TextPropertiesAxisLabel Class See Also Send Feedback

The TextPropertiesAxisLabel type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel..::.Dispose Method
TextPropertiesAxisLabel Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisLabel Class
TextPropertiesAxisLabel Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesAxisLabel Properties

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel Properties
TextPropertiesAxisLabel Class See Also Send Feedback

The TextPropertiesAxisLabel type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextPropertiesAxisLabel..::.Color Property
TextPropertiesAxisLabel Class See Also Send Feedback
Specifies the text color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

TextPropertiesAxisLabel Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Class

[image]

Telerik Reporting Q2 2012
TextPropertiesError Class
Members See Also Send Feedback
Errors text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextPropertiesError : TextProperties
Visual Basic (Declaration)
Public Class TextPropertiesError _
    Inherits TextProperties

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesError

See Also

TextPropertiesError Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Members

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesError Members
TextPropertiesError Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextPropertiesError type exposes the following members.

Constructors

Name | Description
TextPropertiesError | Initializes a new instance of the TextPropertiesError class

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Overrides TextProperties..::.Font.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Constructor

[image]

Telerik Reporting Q2 2012
TextPropertiesError Constructor
TextPropertiesError Class See Also Send Feedback
Initializes a new instance of the TextPropertiesError class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextPropertiesError()
Visual Basic (Declaration)
Public Sub New

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Methods

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesError Methods
TextPropertiesError Class See Also Send Feedback

The TextPropertiesError type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesError..::.Dispose Method
TextPropertiesError Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextPropertiesError Class
TextPropertiesError Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesError Properties

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesError Properties
TextPropertiesError Class See Also Send Feedback

The TextPropertiesError type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Overrides TextProperties..::.Font.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextPropertiesError..::.Color Property
TextPropertiesError Class See Also Send Feedback
Specifies the text color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


Font Property

[image]

Telerik Reporting Q2 2012
TextPropertiesError..::.Font Property
TextPropertiesError Class See Also Send Feedback
Specifies the text font properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Font Font { get; set; }
Visual Basic (Declaration)
Public Overrides Property Font As Font

Remarks

Default value is Verdana, 10pt, style=Bold

See Also

TextPropertiesError Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Class

[image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem Class
Members See Also Send Feedback
Series item label text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextPropertiesSeriesItem : TextProperties
Visual Basic (Declaration)
Public Class TextPropertiesSeriesItem _
    Inherits TextProperties

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesSeriesItem

See Also

TextPropertiesSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Members

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem Members
TextPropertiesSeriesItem Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextPropertiesSeriesItem type exposes the following members.

Constructors

Name | Description
TextPropertiesSeriesItem | Initializes a new instance of the TextPropertiesSeriesItem class

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Constructor

[image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem Constructor
TextPropertiesSeriesItem Class See Also Send Feedback
Initializes a new instance of the TextPropertiesSeriesItem class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextPropertiesSeriesItem()
Visual Basic (Declaration)
Public Sub New

See Also

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Methods

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem Methods
TextPropertiesSeriesItem Class See Also Send Feedback

The TextPropertiesSeriesItem type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem..::.Dispose Method
TextPropertiesSeriesItem Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextPropertiesSeriesItem Class
TextPropertiesSeriesItem Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesSeriesItem Properties

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem Properties
TextPropertiesSeriesItem Class See Also Send Feedback

The TextPropertiesSeriesItem type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property (Overrides TextProperties..::.Color.)
Font | Specifies the text font properties (Inherited from TextProperties.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextPropertiesSeriesItem..::.Color Property
TextPropertiesSeriesItem Class See Also Send Feedback
Specifies the text color property

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Color Color { get; set; }
Visual Basic (Declaration)
Public Overrides Property Color As Color

See Also

TextPropertiesSeriesItem Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Class

[image]

Telerik Reporting Q2 2012
TextPropertiesTitle Class
Members See Also Send Feedback
Default Title's text properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextPropertiesTitle : TextProperties
Visual Basic (Declaration)
Public Class TextPropertiesTitle _
    Inherits TextProperties

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting..::.StateManagedObject
Telerik.Reporting.Charting.Styles..::.TextProperties
Telerik.Reporting.Charting.Styles..::.TextPropertiesTitle

See Also

TextPropertiesTitle Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Members

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesTitle Members
TextPropertiesTitle Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextPropertiesTitle type exposes the following members.

Constructors

Name | Description
TextPropertiesTitle | Initializes a new instance of the TextPropertiesTitle class

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Properties

Name | Description
Color | Specifies the text color property (Inherited from TextProperties.)
Font | Specifies the text font properties (Overrides TextProperties..::.Font.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Constructor

[image]

Telerik Reporting Q2 2012
TextPropertiesTitle Constructor
TextPropertiesTitle Class See Also Send Feedback
Initializes a new instance of the TextPropertiesTitle class

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextPropertiesTitle()
Visual Basic (Declaration)
Public Sub New

See Also

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Methods

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesTitle Methods
TextPropertiesTitle Class See Also Send Feedback

The TextPropertiesTitle type exposes the following members.

Methods

Name | Description
Clone | Creates an object clone (Inherited from TextProperties.)
CloneState | Makes a view state clone (Inherited from StateManagedObject.)
Dispose | Overloaded.
Equals | Determines whether the specified System.Object is equal to the current System.Object. (Inherited from TextProperties.)
GetHashCode | Serves as a hash function for a TextProperties type. (Inherited from TextProperties.)
LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
SetDirty | Sets the item dirty state (Inherited from StateManagedObject.)
TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.LoadViewState | Loads data from a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.SaveViewState | Saves object data to a view state (Inherited from StateManagedObject.)
IChartingStateManager..::.TrackViewState | Tracks view state changes (Inherited from StateManagedObject.)

See Also

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


Dispose Method

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesTitle..::.Dispose Method
TextPropertiesTitle Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | (Inherited from StateManagedObject.)
Dispose(Boolean) | (Inherited from StateManagedObject.)

See Also

TextPropertiesTitle Class
TextPropertiesTitle Members
Telerik.Reporting.Charting.Styles Namespace


TextPropertiesTitle Properties

[image] [image]

Telerik Reporting Q2 2012
TextPropertiesTitle Properties
TextPropertiesTitle Class See Also Send Feedback

The TextPropertiesTitle type exposes the following members.

Properties

Name | Description
Color | Specifies the text color property (Inherited from TextProperties.)
Font | Specifies the text font properties (Overrides TextProperties..::.Font.)
ViewStateIgnoresCase | Gets if view sate should ignore case (Inherited from StateManagedObject.)

Explicit Interface Implementations

Name | Description
IChartingStateManager..::.IsTrackingViewState | Is view state tracking changes (Inherited from StateManagedObject.)

See Also

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


Font Property

[image]

Telerik Reporting Q2 2012
TextPropertiesTitle..::.Font Property
TextPropertiesTitle Class See Also Send Feedback
Specifies the text font properties

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Font Font { get; set; }
Visual Basic (Declaration)
Public Overrides Property Font As Font

Remarks

Default value is Verdana, 15pt

See Also

TextPropertiesTitle Class
Telerik.Reporting.Charting.Styles Namespace


TextQuality Enumeration

[image]

Telerik Reporting Q2 2012
TextQuality Enumeration
See Also Send Feedback
Specifies the quality at which text is rendered.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum TextQuality
Visual Basic (Declaration)
Public Enumeration TextQuality

Members

Member name | Description
SystemDefault | Specifies that each character is drawn using its glyph bitmap, with the system default rendering hint. The text will be drawn using whatever font smoothing settings the user has selected for the system.
SingleBitPerPixel | Specifies that each character is drawn using its glyph bitmap. Hinting is not used.
SingleBitPerPixelGridFit | Specifies that each character is drawn using its glyph bitmap. Hinting is used to improve character appearance on stems and curvature.
AntiAlias | Specifies that each character is drawn using its anti aliased glyph bitmap without hinting. Better quality due to anti aliasing. Stem width differences may be noticeable because hinting is turned off.
AntiAliasGridFit | Specifies that each character is drawn using its anti aliased glyph bitmap with hinting. Much better quality due to anti aliasing, but at a higher performance cost.
ClearTypeGridFit | Specifies that each character is drawn using its glyph CT bitmap with hinting. The highest quality setting. Used to take advantage of ClearType font features.

See Also

Telerik.Reporting.Charting.Styles Namespace


TickLocation Enumeration

[image]

Telerik Reporting Q2 2012
TickLocation Enumeration
See Also Send Feedback
Specifies the axis Ticks location relatively to plot area

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum TickLocation
Visual Basic (Declaration)
Public Enumeration TickLocation

Members

Member name | Description
Inside | Inside of plot area
Outside | Outside of plot area (default value)
Cross | Tick line crosses the axis line

See Also

Telerik.Reporting.Charting.Styles Namespace


Unit Class

[image]

Telerik Reporting Q2 2012
Unit Class
Members See Also Send Feedback
Represents a length measurement.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class Unit
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class Unit

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Charting.Styles..::.Unit

See Also

Unit Members
Telerik.Reporting.Charting.Styles Namespace


Unit Members

[image] [image]

Telerik Reporting Q2 2012
Unit Members
Unit Class Constructors Methods Operators Fields Properties See Also Send Feedback

The Unit type exposes the following members.

Constructors

Name | Description
Unit | Overloaded.

Methods

Name | Description
Equals | Compares this Unit with the specified object. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns a hash code for this Unit. (Overrides Object..::.GetHashCode()()().)
Parse | Overloaded.
Percentage | Creates a Unit of type Percentage from the specified double-precision floating-point number.
Pixel | Creates a Unit of type Pixel from the specified 32-bit signed integer.
ToString | Overloaded.

Operators

Name | Description
Equality | Compares two Unit objects to determine whether they are equal.
Implicit | Implicitly creates a Unit of type Pixel from the specified float.
Inequality | Compares two Unit objects to determine whether they are not equal.

Fields

Name | Description
Empty | Represents an empty Unit. This field is read-only.

Properties

Name | Description
IsEmpty | Gets whether Unit is empty
Type | Gets or sets the unit type of the Unit.
Value | Gets or sets the length of the Unit.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor

[image] [image]

Telerik Reporting Q2 2012
Unit Constructor
Unit Class See Also Send Feedback

Overload List

Name | Description
Unit()()() | Creates a class instance
Unit(Double) | Initializes a new instance of the Unit with the specified double precision floating point number.
Unit(Int32) | Initializes a new instance of the Unit with the specified 32-bit signed integer.
Unit(Single) | Initializes a new instance of the Unit with the specified double precision floating point number.
Unit(String) | Initializes a new instance of the Unit with the specified length.
Unit(UnitType) | Creates a class instance
Unit(Double, UnitType) | Initializes a new instance of the Unit with the specified double precision floating point number and the target type
Unit(Int32, UnitType) | Initializes a new instance of the Unit with the specified 32-bit signed integer and the target type
Unit(Single, UnitType) | Initializes a new instance of the Unit with the specified double precision floating point number and the target type.
Unit(String, CultureInfo) | Initializes a new instance of the Unit with the specified length.

See Also

Unit Class
Unit Members
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor

[image]

Telerik Reporting Q2 2012
Unit Constructor
Unit Class See Also Send Feedback
Creates a class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit()
Visual Basic (Declaration)
Public Sub New

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Double)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Double)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified double precision floating point number.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    double value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double _
)

Parameters

value
Type: System..::.Double
A double precision floating point number that represents the length of the Unit in pixels.

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Int32)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Int32)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified 32-bit signed integer.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    int value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Integer _
)

Parameters

value
Type: System..::.Int32
A 32-bit signed integer that represents the length of the Unit in pixels.

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Single)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Single)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified double precision floating point number.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    float value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Single _
)

Parameters

value
Type: System..::.Single
A float precision floating point number that represents the length of the Unit in pixels.

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (String)

[image]

Telerik Reporting Q2 2012
Unit Constructor (String)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified length.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)

Parameters

value
Type: System..::.String
A string that represents the length of the Unit.

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (UnitType)
Unit Class See Also Send Feedback
Creates a class instance

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As UnitType _
)

Parameters

type
Type: Telerik.Reporting.Charting.Styles..::.UnitType
UnitType specifies the target Unit type

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Double, UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Double, UnitType)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified double precision floating point number and the target type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    double value,
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double, _
    type As UnitType _
)

Parameters

value
Type: System..::.Double
A double precision floating point number that represents the length of the Unit in pixels.
type
Type: Telerik.Reporting.Charting.Styles..::.UnitType
Unit type

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Int32, UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Int32, UnitType)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified 32-bit signed integer and the target type

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    int value,
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Integer, _
    type As UnitType _
)

Parameters

value
Type: System..::.Int32
A 32-bit signed integer that represents the length of the Unit in pixels.
type
Type: Telerik.Reporting.Charting.Styles..::.UnitType
Unit type

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (Single, UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Single, UnitType)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified double precision floating point number and the target type.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    float value,
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Single, _
    type As UnitType _
)

Parameters

value
Type: System..::.Single
A float precision floating point number that represents the length of the Unit in pixels.
type
Type: Telerik.Reporting.Charting.Styles..::.UnitType
Unit type (Pixel / Percentage)

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Constructor (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
Unit Constructor (String, CultureInfo)
Unit Class See Also Send Feedback
Initializes a new instance of the Unit with the specified length.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    string value,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String, _
    culture As CultureInfo _
)

Parameters

value
Type: System..::.String
A string that represents the length of the Unit.
culture
Type: System.Globalization..::.CultureInfo
CultureInfo

See Also

Unit Class
Unit Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Fields

[image] [image]

Telerik Reporting Q2 2012
Unit Fields
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Fields

Name | Description
Empty | Represents an empty Unit. This field is read-only.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
Unit..::.Empty Field
Unit Class See Also Send Feedback
Represents an empty Unit. This field is read-only.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly Unit Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As Unit

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Unit Methods

[image] [image]

Telerik Reporting Q2 2012
Unit Methods
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Methods

Name | Description
Equals | Compares this Unit with the specified object. (Overrides Object..::.Equals(Object).)
GetHashCode | Returns a hash code for this Unit. (Overrides Object..::.GetHashCode()()().)
Parse | Overloaded.
Percentage | Creates a Unit of type Percentage from the specified double-precision floating-point number.
Pixel | Creates a Unit of type Pixel from the specified 32-bit signed integer.
ToString | Overloaded.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
Unit..::.Equals Method
Unit Class See Also Send Feedback
Compares this Unit with the specified object.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The specified object for comparison.

Return Value

true if the Unit that this method is called from is equal to the specified object; otherwise, false.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Unit..::.GetHashCode Method
Unit Class See Also Send Feedback
Returns a hash code for this Unit.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

Hash code

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Parse Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Parse Method
Unit Class See Also Send Feedback

Overload List

Name | Description
Parse(String) | Converts the specified string to a Unit.
Parse(String, CultureInfo) |

See Also

Unit Class
Unit Members
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String)

[image]

Telerik Reporting Q2 2012
Unit..::.Parse Method (String)
Unit Class See Also Send Feedback
Converts the specified string to a Unit.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Parse(
    string s
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String _
) As Unit

Parameters

s
Type: System..::.String
The string to convert.

Return Value

A Unit that represents the specified string.

See Also

Unit Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


Parse Method (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
Unit..::.Parse Method (String, CultureInfo)
Unit Class See Also Send Feedback

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Parse(
    string s,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    s As String, _
    culture As CultureInfo _
) As Unit

Parameters

s
Type: System..::.String
culture
Type: System.Globalization..::.CultureInfo

See Also

Unit Class
Parse Overload
Telerik.Reporting.Charting.Styles Namespace


Percentage Method

[image]

Telerik Reporting Q2 2012
Unit..::.Percentage Method
Unit Class See Also Send Feedback
Creates a Unit of type Percentage from the specified double-precision floating-point number.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Percentage(
    double n
)
Visual Basic (Declaration)
Public Shared Function Percentage ( _
    n As Double _
) As Unit

Parameters

n
Type: System..::.Double
A double-precision floating-point number that represents the length of the Unit

Return Value

A Unit of type Percentage that represents the length specified by the double-precision floating-point number.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Pixel Method

[image]

Telerik Reporting Q2 2012
Unit..::.Pixel Method
Unit Class See Also Send Feedback
Creates a Unit of type Pixel from the specified 32-bit signed integer.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Pixel(
    float n
)
Visual Basic (Declaration)
Public Shared Function Pixel ( _
    n As Single _
) As Unit

Parameters

n
Type: System..::.Single
A 32-bit signed integer that represents the length of the Unit.

Return Value

A Unit of type Pixel that represents the length specified by the n parameter.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.ToString Method
Unit Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Base ToString override (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Base ToString override

See Also

Unit Class
Unit Members
Telerik.Reporting.Charting.Styles Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Unit..::.ToString Method
Unit Class See Also Send Feedback
Base ToString override

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

String representation of the Unit instance

See Also

Unit Class
ToString Overload
Telerik.Reporting.Charting.Styles Namespace


ToString Method (CultureInfo)

[image]

Telerik Reporting Q2 2012
Unit..::.ToString Method (CultureInfo)
Unit Class See Also Send Feedback
Base ToString override

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::.CultureInfo
CultureInfo

Return Value

String representation of the Unit instance

See Also

Unit Class
ToString Overload
Telerik.Reporting.Charting.Styles Namespace


Unit Operators

[image] [image]

Telerik Reporting Q2 2012
Unit Operators
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Operators

Name | Description
Equality | Compares two Unit objects to determine whether they are equal.
Implicit | Implicitly creates a Unit of type Pixel from the specified float.
Inequality | Compares two Unit objects to determine whether they are not equal.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Equality Operator
Unit Class See Also Send Feedback
Compares two Unit objects to determine whether they are equal.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    Unit left,
    Unit right
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    left As Unit, _
    right As Unit _
) As Boolean

Parameters

left
Type: Telerik.Reporting.Charting.Styles..::.Unit
The Unit on the left side of the operator.
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
The Unit on the right side of the operator.

Return Value

true if both Unit objects are equal; otherwise, false.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Implicit Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Implicit Operator
Unit Class See Also Send Feedback
Implicitly creates a Unit of type Pixel from the specified float.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static implicit operator Unit (
    float n
)
Visual Basic (Declaration)
Public Shared Widening Operator CType ( _
    n As Single _
) As Unit

Parameters

n
Type: System..::.Single
A float that represents the length of the Unit.

Return Value

A Unit of type Pixel that represents the specified by the n parameter.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Inequality Operator
Unit Class See Also Send Feedback
Compares two Unit objects to determine whether they are not equal.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    Unit left,
    Unit right
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    left As Unit, _
    right As Unit _
) As Boolean

Parameters

left
Type: Telerik.Reporting.Charting.Styles..::.Unit
The Unit on the left side of the operator.
right
Type: Telerik.Reporting.Charting.Styles..::.Unit
The Unit on the right side of the operator.

Return Value

true if the Unit objects are not equal; otherwise, false.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Unit Properties

[image] [image]

Telerik Reporting Q2 2012
Unit Properties
Unit Class See Also Send Feedback

The Unit type exposes the following members.

Properties

Name | Description
IsEmpty | Gets whether Unit is empty
Type | Gets or sets the unit type of the Unit.
Value | Gets or sets the length of the Unit.

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
Unit..::.IsEmpty Property
Unit Class See Also Send Feedback
Gets whether Unit is empty

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Type Property

[image]

Telerik Reporting Q2 2012
Unit..::.Type Property
Unit Class See Also Send Feedback
Gets or sets the unit type of the Unit.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public UnitType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As UnitType

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Unit..::.Value Property
Unit Class See Also Send Feedback
Gets or sets the length of the Unit.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Single

See Also

Unit Class
Telerik.Reporting.Charting.Styles Namespace


UnitType Enumeration

[image]

Telerik Reporting Q2 2012
UnitType Enumeration
See Also Send Feedback
Specifies the unit of measurement.

Namespace: Telerik.Reporting.Charting.Styles
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum UnitType
Visual Basic (Declaration)
Public Enumeration UnitType

Members

Member name | Description
Pixel | Measurement is in pixels.
Percentage | Measurement is a percentage relative to the parent element.

See Also

Telerik.Reporting.Charting.Styles Namespace


Telerik.Reporting.Data Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Data Namespace
Send Feedback

Classes

Class | Description
Filter | Obsolete.
Grouping | Obsolete.
Sorting | Obsolete.

Enumerations

Enumeration | Description
FilterOperator | Obsolete.
SortDirection | Obsolete.


Filter Class

[image]

Telerik Reporting Q2 2012
Filter Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Class Telerik.Reporting.Data.Filter is now obsolete. Please use Telerik.Reporting.Filter instead.")]
public class Filter : Filter
Visual Basic (Declaration)
<ObsoleteAttribute("Class Telerik.Reporting.Data.Filter is now obsolete. Please use Telerik.Reporting.Filter instead.")> _
Public Class Filter _
    Inherits Filter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Filter
Telerik.Reporting.Data..::.Filter

See Also

Filter Members
Telerik.Reporting.Data Namespace


Filter Members

[image] [image]

Telerik Reporting Q2 2012
Filter Members
Filter Class Constructors Methods Properties Events See Also Send Feedback

The Filter type exposes the following members.

Constructors

Name | Description
Filter | Overloaded.

Methods

Name | Description
Clone | (Inherited from Filter.)
GetHashCode | (Inherited from Filter.)
ToString | (Inherited from Filter.)

Properties

Name | Description
Expression | (Inherited from Filter.)
Operator | (Inherited from Filter.)
Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7. (Inherited from Filter.)

Events

Name | Description
PropertyChanged | (Inherited from Filter.)

See Also

Filter Class
Telerik.Reporting.Data Namespace


Filter Constructor

[image] [image]

Telerik Reporting Q2 2012
Filter Constructor
Filter Class See Also Send Feedback

Overload List

Name | Description
Filter()()() | Initializes a new instance of the Filter class
Filter(String, FilterOperator, String) | Initializes a new instance of the Filter class

See Also

Filter Class
Filter Members
Telerik.Reporting.Data Namespace


Filter Constructor

[image]

Telerik Reporting Q2 2012
Filter Constructor
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Filter()
Visual Basic (Declaration)
Public Sub New

See Also

Filter Class
Filter Overload
Telerik.Reporting.Data Namespace


Filter Constructor (String, FilterOperator, String)

[image]

Telerik Reporting Q2 2012
Filter Constructor (String, FilterOperator, String)
Filter Class See Also Send Feedback
Initializes a new instance of the Filter class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Filter(
    string expression,
    FilterOperator operator,
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    operator As FilterOperator, _
    value As String _
)

Parameters

expression
Type: System..::.String
operator
Type: Telerik.Reporting.Data..::.FilterOperator
value
Type: System..::.String

See Also

Filter Class
Filter Overload
Telerik.Reporting.Data Namespace


Filter Methods

[image] [image]

Telerik Reporting Q2 2012
Filter Methods
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Methods

Name | Description
Clone | (Inherited from Filter.)
GetHashCode | (Inherited from Filter.)
ToString | (Inherited from Filter.)

See Also

Filter Class
Telerik.Reporting.Data Namespace


Filter Properties

[image] [image]

Telerik Reporting Q2 2012
Filter Properties
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Properties

Name | Description
Expression | (Inherited from Filter.)
Operator | (Inherited from Filter.)
Value | If the Value starts with the equal (=) sign, it will be evaluated as an expression otherwise - as string value. For ex. if the value is 7 it is interpreted as the string "7"; To compare a numeric expression with the number 7, use the expression syntax which begins with the equal sign: =7. (Inherited from Filter.)

See Also

Filter Class
Telerik.Reporting.Data Namespace


Filter Events

[image] [image]

Telerik Reporting Q2 2012
Filter Events
Filter Class See Also Send Feedback

The Filter type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from Filter.)

See Also

Filter Class
Telerik.Reporting.Data Namespace


FilterOperator Enumeration

[image]

Telerik Reporting Q2 2012
FilterOperator Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Enumeration Telerik.Reporting.Data.FilterOperator is now obsolete. Please use Telerik.Reporting.FilterOperator instead.")]
public enum FilterOperator
Visual Basic (Declaration)
<ObsoleteAttribute("Enumeration Telerik.Reporting.Data.FilterOperator is now obsolete. Please use Telerik.Reporting.FilterOperator instead.")> _
Public Enumeration FilterOperator

Members

Member name | Description
Equal |
NotEqual |
GreaterThan |
GreaterOrEqual |
LessThan |
LessOrEqual |
TopN |
BottomN |
TopPercent |
BottomPercent |
In |
Like |
NotLike |

See Also

Telerik.Reporting.Data Namespace


Grouping Class

[image]

Telerik Reporting Q2 2012
Grouping Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Class Telerik.Reporting.Data.Grouping is now obsolete. Please use Telerik.Reporting.Grouping instead.")]
public class Grouping : Grouping
Visual Basic (Declaration)
<ObsoleteAttribute("Class Telerik.Reporting.Data.Grouping is now obsolete. Please use Telerik.Reporting.Grouping instead.")> _
Public Class Grouping _
    Inherits Grouping

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Grouping
Telerik.Reporting.Data..::.Grouping

See Also

Grouping Members
Telerik.Reporting.Data Namespace


Grouping Members

[image] [image]

Telerik Reporting Q2 2012
Grouping Members
Grouping Class Constructors Methods Properties Events See Also Send Feedback

The Grouping type exposes the following members.

Constructors

Name | Description
Grouping | Overloaded.

Methods

Name | Description
ToString | (Inherited from Grouping.)

Properties

Name | Description
Expression | (Inherited from Grouping.)
IsEmpty | (Inherited from Grouping.)

Events

Name | Description
PropertyChanged | (Inherited from Grouping.)

See Also

Grouping Class
Telerik.Reporting.Data Namespace


Grouping Constructor

[image] [image]

Telerik Reporting Q2 2012
Grouping Constructor
Grouping Class See Also Send Feedback

Overload List

Name | Description
Grouping()()() | Initializes a new instance of the Grouping class
Grouping(String) | Initializes a new instance of the Grouping class

See Also

Grouping Class
Grouping Members
Telerik.Reporting.Data Namespace


Grouping Constructor

[image]

Telerik Reporting Q2 2012
Grouping Constructor
Grouping Class See Also Send Feedback
Initializes a new instance of the Grouping class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Grouping()
Visual Basic (Declaration)
Public Sub New

See Also

Grouping Class
Grouping Overload
Telerik.Reporting.Data Namespace


Grouping Constructor (String)

[image]

Telerik Reporting Q2 2012
Grouping Constructor (String)
Grouping Class See Also Send Feedback
Initializes a new instance of the Grouping class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Grouping(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)

Parameters

expression
Type: System..::.String

See Also

Grouping Class
Grouping Overload
Telerik.Reporting.Data Namespace


Grouping Methods

[image] [image]

Telerik Reporting Q2 2012
Grouping Methods
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Methods

Name | Description
ToString | (Inherited from Grouping.)

See Also

Grouping Class
Telerik.Reporting.Data Namespace


Grouping Properties

[image] [image]

Telerik Reporting Q2 2012
Grouping Properties
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Properties

Name | Description
Expression | (Inherited from Grouping.)
IsEmpty | (Inherited from Grouping.)

See Also

Grouping Class
Telerik.Reporting.Data Namespace


Grouping Events

[image] [image]

Telerik Reporting Q2 2012
Grouping Events
Grouping Class See Also Send Feedback

The Grouping type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from Grouping.)

See Also

Grouping Class
Telerik.Reporting.Data Namespace


SortDirection Enumeration

[image]

Telerik Reporting Q2 2012
SortDirection Enumeration
See Also Send Feedback

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Enumeration Telerik.Reporting.Data.SortDirection is now obsolete. Please use Telerik.Reporting.SortDirection instead.")]
public enum SortDirection
Visual Basic (Declaration)
<ObsoleteAttribute("Enumeration Telerik.Reporting.Data.SortDirection is now obsolete. Please use Telerik.Reporting.SortDirection instead.")> _
Public Enumeration SortDirection

Members

Member name | Description
Asc |
Desc |

See Also

Telerik.Reporting.Data Namespace


Sorting Class

[image]

Telerik Reporting Q2 2012
Sorting Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Class Telerik.Reporting.Data.Sorting is now obsolete. Please use Telerik.Reporting.Sorting instead.")]
public class Sorting : Sorting
Visual Basic (Declaration)
<ObsoleteAttribute("Class Telerik.Reporting.Data.Sorting is now obsolete. Please use Telerik.Reporting.Sorting instead.")> _
Public Class Sorting _
    Inherits Sorting

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.Sorting
Telerik.Reporting.Data..::.Sorting

See Also

Sorting Members
Telerik.Reporting.Data Namespace


Sorting Members

[image] [image]

Telerik Reporting Q2 2012
Sorting Members
Sorting Class Constructors Methods Properties Events See Also Send Feedback

The Sorting type exposes the following members.

Constructors

Name | Description
Sorting | Overloaded.

Methods

Name | Description
ToString | (Inherited from Sorting.)

Properties

Name | Description
Direction | (Inherited from Sorting.)
Expression | (Inherited from Sorting.)
IsEmpty | (Inherited from Sorting.)

Events

Name | Description
PropertyChanged | (Inherited from Sorting.)

See Also

Sorting Class
Telerik.Reporting.Data Namespace


Sorting Constructor

[image] [image]

Telerik Reporting Q2 2012
Sorting Constructor
Sorting Class See Also Send Feedback

Overload List

Name | Description
Sorting()()() | Initializes a new instance of the Sorting class
Sorting(String) | Initializes a new instance of the Sorting class
Sorting(String, SortDirection) | Initializes a new instance of the Sorting class

See Also

Sorting Class
Sorting Members
Telerik.Reporting.Data Namespace


Sorting Constructor

[image]

Telerik Reporting Q2 2012
Sorting Constructor
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting()
Visual Basic (Declaration)
Public Sub New

See Also

Sorting Class
Sorting Overload
Telerik.Reporting.Data Namespace


Sorting Constructor (String)

[image]

Telerik Reporting Q2 2012
Sorting Constructor (String)
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting(
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String _
)

Parameters

expression
Type: System..::.String

See Also

Sorting Class
Sorting Overload
Telerik.Reporting.Data Namespace


Sorting Constructor (String, SortDirection)

[image]

Telerik Reporting Q2 2012
Sorting Constructor (String, SortDirection)
Sorting Class See Also Send Feedback
Initializes a new instance of the Sorting class

Namespace: Telerik.Reporting.Data
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Sorting(
    string expression,
    SortDirection direction
)
Visual Basic (Declaration)
Public Sub New ( _
    expression As String, _
    direction As SortDirection _
)

Parameters

expression
Type: System..::.String
direction
Type: Telerik.Reporting.Data..::.SortDirection

See Also

Sorting Class
Sorting Overload
Telerik.Reporting.Data Namespace


Sorting Methods

[image] [image]

Telerik Reporting Q2 2012
Sorting Methods
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Methods

Name | Description
ToString | (Inherited from Sorting.)

See Also

Sorting Class
Telerik.Reporting.Data Namespace


Sorting Properties

[image] [image]

Telerik Reporting Q2 2012
Sorting Properties
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Properties

Name | Description
Direction | (Inherited from Sorting.)
Expression | (Inherited from Sorting.)
IsEmpty | (Inherited from Sorting.)

See Also

Sorting Class
Telerik.Reporting.Data Namespace


Sorting Events

[image] [image]

Telerik Reporting Q2 2012
Sorting Events
Sorting Class See Also Send Feedback

The Sorting type exposes the following members.

Events

Name | Description
PropertyChanged | (Inherited from Sorting.)

See Also

Sorting Class
Telerik.Reporting.Data Namespace


Telerik.Reporting.Drawing Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Drawing Namespace
Send Feedback

Classes

Class | Description
AttributeSelector | Represents a selector that matches a property value of a report item.
AttributeSelectorBase | Provides the abstract base class for an attribute selector.
BackgroundImage | Represents a background image associated with a Style
BorderBase |
BorderColor | A class used to specify the color of the border of an item.
BorderStyle | A class used to specify the style of the border of an item.
BorderWidth | A class used to specify the width of the border of an item.
ConditionalFormatting |
DescendantSelector | Represents a selector that matches an item that is a descendant of another item.
ExternalStyleSheet | Represents an external style sheet used to style a report.
ExternalStyleSheetCollection | Represents a collection of ExternalStyleSheet objects.
Font | Defines a particular format for text, including font face, size, and style attributes.
FormattingRule |
MarginsU |
Padding | Represents padding information associated with a report item.
PageSettings | Specifies settings that apply to a single, printed page.
PictureWatermark | Represents a picture watermark on a printable page.
SelectorCollection | Represents a collection of objects that implement ISelector
Style | Represents the style of a report item.
StyleRule | Represents a style rule to be applied.
StyleRuleCollection | Represents a collection of StyleRule objects.
StyleSelector | An attribute selector based on the style name property.
StyleSheet | Represents a collection of styles for a ReportItemBase
TextWatermark | Represents a text watermark on a printable page.
TypeSelector | Represents a selector base on a Type
Watermark | Represents a watermark on a printable page.
WatermarkCollection | Represents a collection of watermarks on a printable page.

Structures

Structure | Description
PointU | Represents an ordered pair of unit-based point x- and y-coordinates that defines a point in a two-dimensional plane.
RectangleU | Stores a set of four Unit-based numbers that represent the location and size of a rectangle.
SizeU | Stores an ordered pair of Unit-based numbers, typically the width and height of a rectangle.
Unit | A structure representing a unit of measure.

Interfaces

Interface | Description
ISelector | Allows an object to implement a style selector, and represents a set of methods to match a ReportItemBase and clone the selector.

Enumerations

Enumeration | Description
BackgroundRepeat | Indicates how a background image will be repeated.
BorderType | Specifies the type of a border.
HorizontalAlign | Specifies the vertical alignment of an object or text in a report item.
ImageSizeMode | Specifies how an image is positioned within an item.
LineStyle | Specifies the type of a line item
UnitType | Represents the type of a Unit.
VerticalAlign | Specifies the vertical alignment of an object or text in an report item.
WatermarkOrientation | Defines the orientation of the watermark text on the printable page.
WatermarkPosition | Defines the position of the watermark relative to the other items on the printable page.
WatermarkSizeMode | Defines the sizing mode of the watermark image on the printable page.


AttributeSelector Class

[image]

Telerik Reporting Q2 2012
AttributeSelector Class
Members See Also Send Feedback
Represents a selector that matches a property value of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class AttributeSelector : AttributeSelectorBase,
    ICustomTypeDescriptor
Visual Basic (Declaration)
Public Class AttributeSelector _
    Inherits AttributeSelectorBase _
    Implements ICustomTypeDescriptor

Remarks

Selectors are defined for each StyleRule in the StyleSheet.

AttributeSelector should be used when you want to match all report items of a certain Type that have a property set to a certain value.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.TypeSelector
Telerik.Reporting.Drawing..::.AttributeSelectorBase
Telerik.Reporting.Drawing..::.AttributeSelector

See Also

AttributeSelector Members
Telerik.Reporting.Drawing Namespace


AttributeSelector Members

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector Members
AttributeSelector Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AttributeSelector type exposes the following members.

Constructors

Name | Description
AttributeSelector | Initializes a new instance of the AttributeSelector class

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase.)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase.)
OnTypeChange | This member overrides OnTypeChange()()(). The method resets the selector. (Overrides TypeSelector..::.OnTypeChange()()().)
ToString | This member overrides ToString()()() (Overrides TypeSelector..::.ToString()()().)

Fields

Name | Description
attributeName | The name of the property to match. (Inherited from AttributeSelectorBase.)
attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase.)
descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase.)
initialized | (Inherited from TypeSelector.)

Properties

Name | Description
PropertyName | Gets or sets the name of the property to match.
PropertyValue | Gets or sets the value of the property to match.
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)
ICustomTypeDescriptor..::.GetAttributes |
ICustomTypeDescriptor..::.GetClassName |
ICustomTypeDescriptor..::.GetComponentName |
ICustomTypeDescriptor..::.GetConverter |
ICustomTypeDescriptor..::.GetDefaultEvent |
ICustomTypeDescriptor..::.GetDefaultProperty |
ICustomTypeDescriptor..::.GetEditor |
GetEvents | Overloaded.
GetProperties | Overloaded.
ICustomTypeDescriptor..::.GetPropertyOwner |

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelector Constructor

[image]

Telerik Reporting Q2 2012
AttributeSelector Constructor
AttributeSelector Class See Also Send Feedback
Initializes a new instance of the AttributeSelector class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AttributeSelector()
Visual Basic (Declaration)
Public Sub New

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelector Fields

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector Fields
AttributeSelector Class See Also Send Feedback

The AttributeSelector type exposes the following members.

Fields

Name | Description
attributeName | The name of the property to match. (Inherited from AttributeSelectorBase.)
attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase.)
descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase.)
initialized | (Inherited from TypeSelector.)

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelector Methods

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector Methods
AttributeSelector Class See Also Send Feedback

The AttributeSelector type exposes the following members.

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase.)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase.)
OnTypeChange | This member overrides OnTypeChange()()(). The method resets the selector. (Overrides TypeSelector..::.OnTypeChange()()().)
ToString | This member overrides ToString()()() (Overrides TypeSelector..::.ToString()()().)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)
ICustomTypeDescriptor..::.GetAttributes |
ICustomTypeDescriptor..::.GetClassName |
ICustomTypeDescriptor..::.GetComponentName |
ICustomTypeDescriptor..::.GetConverter |
ICustomTypeDescriptor..::.GetDefaultEvent |
ICustomTypeDescriptor..::.GetDefaultProperty |
ICustomTypeDescriptor..::.GetEditor |
GetEvents | Overloaded.
GetProperties | Overloaded.
ICustomTypeDescriptor..::.GetPropertyOwner |

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetAttributes Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetAttributes Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
AttributeCollection ICustomTypeDescriptor.GetAttributes()
Visual Basic (Declaration)
Private Function GetAttributes As AttributeCollection
    Implements ICustomTypeDescriptor.GetAttributes

Implements

ICustomTypeDescriptor..::.GetAttributes()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetClassName Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetClassName Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string ICustomTypeDescriptor.GetClassName()
Visual Basic (Declaration)
Private Function GetClassName As String
    Implements ICustomTypeDescriptor.GetClassName

Implements

ICustomTypeDescriptor..::.GetClassName()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetComponentName Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetComponentName Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
string ICustomTypeDescriptor.GetComponentName()
Visual Basic (Declaration)
Private Function GetComponentName As String
    Implements ICustomTypeDescriptor.GetComponentName

Implements

ICustomTypeDescriptor..::.GetComponentName()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetConverter Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetConverter Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
TypeConverter ICustomTypeDescriptor.GetConverter()
Visual Basic (Declaration)
Private Function GetConverter As TypeConverter
    Implements ICustomTypeDescriptor.GetConverter

Implements

ICustomTypeDescriptor..::.GetConverter()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetDefaultEvent Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetDefaultEvent Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
EventDescriptor ICustomTypeDescriptor.GetDefaultEvent()
Visual Basic (Declaration)
Private Function GetDefaultEvent As EventDescriptor
    Implements ICustomTypeDescriptor.GetDefaultEvent

Implements

ICustomTypeDescriptor..::.GetDefaultEvent()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetDefaultProperty Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetDefaultProperty Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PropertyDescriptor ICustomTypeDescriptor.GetDefaultProperty()
Visual Basic (Declaration)
Private Function GetDefaultProperty As PropertyDescriptor
    Implements ICustomTypeDescriptor.GetDefaultProperty

Implements

ICustomTypeDescriptor..::.GetDefaultProperty()()()

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetEditor Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetEditor Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICustomTypeDescriptor.GetEditor(
    Type editorBaseType
)
Visual Basic (Declaration)
Private Function GetEditor ( _
    editorBaseType As Type _
) As Object Implements ICustomTypeDescriptor.GetEditor

Parameters

editorBaseType
Type: System..::.Type

Implements

ICustomTypeDescriptor..::.GetEditor(Type)

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetPropertyOwner Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetPropertyOwner Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICustomTypeDescriptor.GetPropertyOwner(
    PropertyDescriptor pd
)
Visual Basic (Declaration)
Private Function GetPropertyOwner ( _
    pd As PropertyDescriptor _
) As Object Implements ICustomTypeDescriptor.GetPropertyOwner

Parameters

pd
Type: System.ComponentModel..::.PropertyDescriptor

Implements

ICustomTypeDescriptor..::.GetPropertyOwner(PropertyDescriptor)

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


GetEvents Method

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector..::.GetEvents Method
AttributeSelector Class See Also Send Feedback

Overload List

Name | Description
ICustomTypeDescriptor..::.GetEvents()()() |
ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[]) |

See Also

AttributeSelector Class
AttributeSelector Members
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetEvents Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetEvents Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
EventDescriptorCollection ICustomTypeDescriptor.GetEvents()
Visual Basic (Declaration)
Private Function GetEvents As EventDescriptorCollection
    Implements ICustomTypeDescriptor.GetEvents

Implements

ICustomTypeDescriptor..::.GetEvents()()()

See Also

AttributeSelector Class
GetEvents Overload
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetEvents Method (Attribute[])

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetEvents Method (array<Attribute>[]()[][])
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
EventDescriptorCollection ICustomTypeDescriptor.GetEvents(
    Attribute[] attributes
)
Visual Basic (Declaration)
Private Function GetEvents ( _
    attributes As Attribute() _
) As EventDescriptorCollection Implements ICustomTypeDescriptor.GetEvents

Parameters

attributes
Type: array< System..::.Attribute >[]()[][]

Implements

ICustomTypeDescriptor..::.GetEvents(array<Attribute>[]()[])

See Also

AttributeSelector Class
GetEvents Overload
Telerik.Reporting.Drawing Namespace


GetProperties Method

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector..::.GetProperties Method
AttributeSelector Class See Also Send Feedback

Overload List

Name | Description
ICustomTypeDescriptor..::.GetProperties()()() |
ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[]) |

See Also

AttributeSelector Class
AttributeSelector Members
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetProperties Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetProperties Method
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PropertyDescriptorCollection ICustomTypeDescriptor.GetProperties()
Visual Basic (Declaration)
Private Function GetProperties As PropertyDescriptorCollection
    Implements ICustomTypeDescriptor.GetProperties

Implements

ICustomTypeDescriptor..::.GetProperties()()()

See Also

AttributeSelector Class
GetProperties Overload
Telerik.Reporting.Drawing Namespace


ICustomTypeDescriptor.GetProperties Method (Attribute[])

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ICustomTypeDescriptor..::.GetProperties Method (array<Attribute>[]()[][])
AttributeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PropertyDescriptorCollection ICustomTypeDescriptor.GetProperties(
    Attribute[] attributes
)
Visual Basic (Declaration)
Private Function GetProperties ( _
    attributes As Attribute() _
) As PropertyDescriptorCollection Implements ICustomTypeDescriptor.GetProperties

Parameters

attributes
Type: array< System..::.Attribute >[]()[][]

Implements

ICustomTypeDescriptor..::.GetProperties(array<Attribute>[]()[])

See Also

AttributeSelector Class
GetProperties Overload
Telerik.Reporting.Drawing Namespace


OnTypeChange Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.OnTypeChange Method
AttributeSelector Class See Also Send Feedback
This member overrides OnTypeChange()()(). The method resets the selector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnTypeChange()
Visual Basic (Declaration)
Protected Overrides Sub OnTypeChange

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.ToString Method
AttributeSelector Class See Also Send Feedback
This member overrides ToString()()()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string value describing the selector.

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelector Properties

[image] [image]

Telerik Reporting Q2 2012
AttributeSelector Properties
AttributeSelector Class See Also Send Feedback

The AttributeSelector type exposes the following members.

Properties

Name | Description
PropertyName | Gets or sets the name of the property to match.
PropertyValue | Gets or sets the value of the property to match.
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


PropertyName Property

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.PropertyName Property
AttributeSelector Class See Also Send Feedback
Gets or sets the name of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String

Field Value

The name of the property to match.

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


PropertyValue Property

[image]

Telerik Reporting Q2 2012
AttributeSelector..::.PropertyValue Property
AttributeSelector Class See Also Send Feedback
Gets or sets the value of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object PropertyValue { get; set; }
Visual Basic (Declaration)
Public Property PropertyValue As Object

Field Value

The value of the property to match.

See Also

AttributeSelector Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Class

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase Class
Members See Also Send Feedback
Provides the abstract base class for an attribute selector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class AttributeSelectorBase : TypeSelector
Visual Basic (Declaration)
Public MustInherit Class AttributeSelectorBase _
    Inherits TypeSelector

Remarks

Selectors are defined for each StyleRule in the StyleSheet.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.TypeSelector
Telerik.Reporting.Drawing..::.AttributeSelectorBase
Telerik.Reporting.Drawing..::.AttributeSelector
Telerik.Reporting.Drawing..::.StyleSelector

See Also

AttributeSelectorBase Members
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Members

[image] [image]

Telerik Reporting Q2 2012
AttributeSelectorBase Members
AttributeSelectorBase Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The AttributeSelectorBase type exposes the following members.

Constructors

Name | Description
AttributeSelectorBase | Overloaded.

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Overrides TypeSelector..::.CopyTo(TypeSelector).)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Overrides TypeSelector..::.Match(ReportItemBase).)
OnTypeChange | Called when the Type of this selector changes. (Inherited from TypeSelector.)
ToString | Creates a human-readable string that represents this TypeSelector. (Inherited from TypeSelector.)

Fields

Name | Description
attributeName | The name of the property to match.
attributeValue | The value of the property to match.
descriptor | The property descriptor associated with the property that this selector matches.
initialized | (Inherited from TypeSelector.)

Properties

Name | Description
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Constructor

[image] [image]

Telerik Reporting Q2 2012
AttributeSelectorBase Constructor
AttributeSelectorBase Class See Also Send Feedback

Overload List

Name | Description
AttributeSelectorBase()()() | Initializes a new instance of the AttributeSelectorBase class with an empty property name and value, that matches all ReportItemBase objects.
AttributeSelectorBase(String, Object) | Initializes a new instance of the AttributeSelectorBase class with the specified property name and value, that matches all ReportItemBase objects.
AttributeSelectorBase(Type, String, Object) | Initializes a new instance of the AttributeSelectorBase class with the specified property name and value, that matches items of the specified type.

See Also

AttributeSelectorBase Class
AttributeSelectorBase Members
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Constructor

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase Constructor
AttributeSelectorBase Class See Also Send Feedback
Initializes a new instance of the AttributeSelectorBase class with an empty property name and value, that matches all ReportItemBase objects.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AttributeSelectorBase()
Visual Basic (Declaration)
Public Sub New

See Also

AttributeSelectorBase Class
AttributeSelectorBase Overload
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Constructor (String, Object)

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase Constructor (String, Object)
AttributeSelectorBase Class See Also Send Feedback
Initializes a new instance of the AttributeSelectorBase class with the specified property name and value, that matches all ReportItemBase objects.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AttributeSelectorBase(
    string propertyName,
    Object propertyValue
)
Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String, _
    propertyValue As Object _
)

Parameters

propertyName
Type: System..::.String
A string value indicating the property name to match.
propertyValue
Type: System..::.Object
A string value indicating the property value to match.

See Also

AttributeSelectorBase Class
AttributeSelectorBase Overload
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Constructor (Type, String, Object)

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase Constructor (Type, String, Object)
AttributeSelectorBase Class See Also Send Feedback
Initializes a new instance of the AttributeSelectorBase class with the specified property name and value, that matches items of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AttributeSelectorBase(
    Type type,
    string propertyName,
    Object propertyValue
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type, _
    propertyName As String, _
    propertyValue As Object _
)

Parameters

type
Type: System..::.Type
A Type value indicating the type of the items to match.
propertyName
Type: System..::.String
A string value indicating the property name to match.
propertyValue
Type: System..::.Object
A string value indicating the property value to match.

See Also

AttributeSelectorBase Class
AttributeSelectorBase Overload
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Fields

[image] [image]

Telerik Reporting Q2 2012
AttributeSelectorBase Fields
AttributeSelectorBase Class See Also Send Feedback

The AttributeSelectorBase type exposes the following members.

Fields

Name | Description
attributeName | The name of the property to match.
attributeValue | The value of the property to match.
descriptor | The property descriptor associated with the property that this selector matches.
initialized | (Inherited from TypeSelector.)

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


attributeName Field

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase..::.attributeName Field
AttributeSelectorBase Class See Also Send Feedback
The name of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected string attributeName
Visual Basic (Declaration)
Protected attributeName As String

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


attributeValue Field

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase..::.attributeValue Field
AttributeSelectorBase Class See Also Send Feedback
The value of the property to match.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Object attributeValue
Visual Basic (Declaration)
Protected attributeValue As Object

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


descriptor Field

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase..::.descriptor Field
AttributeSelectorBase Class See Also Send Feedback
The property descriptor associated with the property that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PropertyDescriptor descriptor
Visual Basic (Declaration)
Protected descriptor As PropertyDescriptor

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Methods

[image] [image]

Telerik Reporting Q2 2012
AttributeSelectorBase Methods
AttributeSelectorBase Class See Also Send Feedback

The AttributeSelectorBase type exposes the following members.

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Overrides TypeSelector..::.CopyTo(TypeSelector).)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Overrides TypeSelector..::.Match(ReportItemBase).)
OnTypeChange | Called when the Type of this selector changes. (Inherited from TypeSelector.)
ToString | Creates a human-readable string that represents this TypeSelector. (Inherited from TypeSelector.)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


CopyTo Method

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase..::.CopyTo Method
AttributeSelectorBase Class See Also Send Feedback
Copies the property name and value of the selector to the target typeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CopyTo(
    TypeSelector typeSelector
)
Visual Basic (Declaration)
Protected Overrides Sub CopyTo ( _
    typeSelector As TypeSelector _
)

Parameters

typeSelector
Type: Telerik.Reporting.Drawing..::.TypeSelector
The TypeSelector to copy to.

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


Match Method

[image]

Telerik Reporting Q2 2012
AttributeSelectorBase..::.Match Method
AttributeSelectorBase Class See Also Send Feedback
Matches a report item by the value of its property.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Match(
    ReportItemBase item
)
Visual Basic (Declaration)
Public Overrides Function Match ( _
    item As ReportItemBase _
) As Boolean

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to match.

Return Value

true if the item's property value matches.

Implements

ISelector..::.Match(ReportItemBase)

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


AttributeSelectorBase Properties

[image] [image]

Telerik Reporting Q2 2012
AttributeSelectorBase Properties
AttributeSelectorBase Class See Also Send Feedback

The AttributeSelectorBase type exposes the following members.

Properties

Name | Description
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

See Also

AttributeSelectorBase Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Class

[image]

Telerik Reporting Q2 2012
BackgroundImage Class
Members See Also Send Feedback
Represents a background image associated with a Style

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BackgroundImage
Visual Basic (Declaration)
Public Class BackgroundImage

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.BackgroundImage

See Also

BackgroundImage Members
Telerik.Reporting.Drawing Namespace


BackgroundImage Members

[image] [image]

Telerik Reporting Q2 2012
BackgroundImage Members
BackgroundImage Class Methods Properties See Also Send Feedback

The BackgroundImage type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
ImageData | Gets or sets a Image containing the image data of this BackgroundImage.
MimeType | Gets or sets the MIME type of the current BackgroundImage object.
Repeat | Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Methods

[image] [image]

Telerik Reporting Q2 2012
BackgroundImage Methods
BackgroundImage Class See Also Send Feedback

The BackgroundImage type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
BackgroundImage..::.ToString Method
BackgroundImage Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Properties

[image] [image]

Telerik Reporting Q2 2012
BackgroundImage Properties
BackgroundImage Class See Also Send Feedback

The BackgroundImage type exposes the following members.

Properties

Name | Description
ImageData | Gets or sets a Image containing the image data of this BackgroundImage.
MimeType | Gets or sets the MIME type of the current BackgroundImage object.
Repeat | Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


ImageData Property

[image]

Telerik Reporting Q2 2012
BackgroundImage..::.ImageData Property
BackgroundImage Class See Also Send Feedback
Gets or sets a Image containing the image data of this BackgroundImage.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Image ImageData { get; set; }
Visual Basic (Declaration)
Public Property ImageData As Image

Field Value

A Image object containing the image data of this BackgroundImage.

Remarks

Use this property if you want to bind the BackgroundImage to an image that is not in the data source.

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


MimeType Property

[image]

Telerik Reporting Q2 2012
BackgroundImage..::.MimeType Property
BackgroundImage Class See Also Send Feedback
Gets or sets the MIME type of the current BackgroundImage object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string MimeType { get; set; }
Visual Basic (Declaration)
Public Property MimeType As String

Field Value

The MIME type of the current BackgroundImage object.

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


Repeat Property

[image]

Telerik Reporting Q2 2012
BackgroundImage..::.Repeat Property
BackgroundImage Class See Also Send Feedback
Gets or sets a BackgroundRepeat value defining the repeat style of the BackgroundImage.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BackgroundRepeat Repeat { get; set; }
Visual Basic (Declaration)
Public Property Repeat As BackgroundRepeat

Field Value

A BackgroundRepeat value representing the repeat style of the BackgroundImage.

See Also

BackgroundImage Class
Telerik.Reporting.Drawing Namespace


BackgroundRepeat Enumeration

[image]

Telerik Reporting Q2 2012
BackgroundRepeat Enumeration
See Also Send Feedback
Indicates how a background image will be repeated.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum BackgroundRepeat
Visual Basic (Declaration)
Public Enumeration BackgroundRepeat

Members

Member name | Description
NoRepeat | The background-image will be displayed only once.
RepeatX | The background image will be repeated horizontally.
RepeatY | The background image will be repeated vertically.
Repeat | The background image will be repeated vertically and horizontally.

See Also

Telerik.Reporting.Drawing Namespace


BorderBase Class

[image]

Telerik Reporting Q2 2012
BorderBase Class
See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class BorderBase
Visual Basic (Declaration)
Public MustInherit Class BorderBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.BorderBase
Telerik.Reporting.Drawing..::.BorderColor
Telerik.Reporting.Drawing..::.BorderStyle
Telerik.Reporting.Drawing..::.BorderWidth

See Also

Telerik.Reporting.Drawing Namespace


BorderColor Class

[image]

Telerik Reporting Q2 2012
BorderColor Class
Members See Also Send Feedback
A class used to specify the color of the border of an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BorderColor : BorderBase
Visual Basic (Declaration)
Public Class BorderColor _
    Inherits BorderBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.BorderBase
Telerik.Reporting.Drawing..::.BorderColor

See Also

BorderColor Members
Telerik.Reporting.Drawing Namespace


BorderColor Members

[image] [image]

Telerik Reporting Q2 2012
BorderColor Members
BorderColor Class Methods Properties See Also Send Feedback

The BorderColor type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Bottom | Gets or sets the bottom color of the border.
Default | Gets or sets the default color of the border.
Left | Gets or sets the left color of the border.
Right | Gets or sets the right color of the border.
Top | Gets or sets the top color of the border.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


BorderColor Methods

[image] [image]

Telerik Reporting Q2 2012
BorderColor Methods
BorderColor Class See Also Send Feedback

The BorderColor type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
BorderColor..::.ToString Method
BorderColor Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


BorderColor Properties

[image] [image]

Telerik Reporting Q2 2012
BorderColor Properties
BorderColor Class See Also Send Feedback

The BorderColor type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the bottom color of the border.
Default | Gets or sets the default color of the border.
Left | Gets or sets the left color of the border.
Right | Gets or sets the right color of the border.
Top | Gets or sets the top color of the border.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
BorderColor..::.Bottom Property
BorderColor Class See Also Send Feedback
Gets or sets the bottom color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Color

Field Value

The bottom border Color.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


Default Property

[image]

Telerik Reporting Q2 2012
BorderColor..::.Default Property
BorderColor Class See Also Send Feedback
Gets or sets the default color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Default { get; set; }
Visual Basic (Declaration)
Public Property Default As Color

Field Value

The default border Color.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
BorderColor..::.Left Property
BorderColor Class See Also Send Feedback
Gets or sets the left color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Color

Field Value

The left border Color.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
BorderColor..::.Right Property
BorderColor Class See Also Send Feedback
Gets or sets the right color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Color

Field Value

The right border Color.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
BorderColor..::.Top Property
BorderColor Class See Also Send Feedback
Gets or sets the top color of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Color

Field Value

The top border Color.

See Also

BorderColor Class
Telerik.Reporting.Drawing Namespace


BorderStyle Class

[image]

Telerik Reporting Q2 2012
BorderStyle Class
Members See Also Send Feedback
A class used to specify the style of the border of an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BorderStyle : BorderBase
Visual Basic (Declaration)
Public Class BorderStyle _
    Inherits BorderBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.BorderBase
Telerik.Reporting.Drawing..::.BorderStyle

See Also

BorderStyle Members
Telerik.Reporting.Drawing Namespace


BorderStyle Members

[image] [image]

Telerik Reporting Q2 2012
BorderStyle Members
BorderStyle Class Methods Properties See Also Send Feedback

The BorderStyle type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Bottom | Gets or sets the bottom style of the border.
Default | Gets or sets the default style of the border.
Left | Gets or sets the left style of the border.
Right | Gets or sets the right style of the border.
Top | Gets or sets the top style of the border.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


BorderStyle Methods

[image] [image]

Telerik Reporting Q2 2012
BorderStyle Methods
BorderStyle Class See Also Send Feedback

The BorderStyle type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
BorderStyle..::.ToString Method
BorderStyle Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


BorderStyle Properties

[image] [image]

Telerik Reporting Q2 2012
BorderStyle Properties
BorderStyle Class See Also Send Feedback

The BorderStyle type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the bottom style of the border.
Default | Gets or sets the default style of the border.
Left | Gets or sets the left style of the border.
Right | Gets or sets the right style of the border.
Top | Gets or sets the top style of the border.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
BorderStyle..::.Bottom Property
BorderStyle Class See Also Send Feedback
Gets or sets the bottom style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderType Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As BorderType

Field Value

A BorderType object specifying the bottom border style.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Default Property

[image]

Telerik Reporting Q2 2012
BorderStyle..::.Default Property
BorderStyle Class See Also Send Feedback
Gets or sets the default style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderType Default { get; set; }
Visual Basic (Declaration)
Public Property Default As BorderType

Field Value

A BorderType object specifying the default border style.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
BorderStyle..::.Left Property
BorderStyle Class See Also Send Feedback
Gets or sets the left style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderType Left { get; set; }
Visual Basic (Declaration)
Public Property Left As BorderType

Field Value

A BorderType object specifying the left border style.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
BorderStyle..::.Right Property
BorderStyle Class See Also Send Feedback
Gets or sets the right style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderType Right { get; set; }
Visual Basic (Declaration)
Public Property Right As BorderType

Field Value

A BorderType object specifying the right border style.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
BorderStyle..::.Top Property
BorderStyle Class See Also Send Feedback
Gets or sets the top style of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderType Top { get; set; }
Visual Basic (Declaration)
Public Property Top As BorderType

Field Value

A BorderType object specifying the top border style.

See Also

BorderStyle Class
Telerik.Reporting.Drawing Namespace


BorderType Enumeration

[image]

Telerik Reporting Q2 2012
BorderType Enumeration
See Also Send Feedback
Specifies the type of a border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum BorderType
Visual Basic (Declaration)
Public Enumeration BorderType

Members

Member name | Description
None | No line.
Dotted | A dotted line.
Dashed | A dashed line.
Solid | A solid line.
Double | A double solid line.
Groove | A grooved line for a sunken border appearance.
Ridge | A ridged line for a raised border appearance.
Inset | An inset line for a sunken item appearance.
Outset | An outset line for a raised item appearance.

See Also

Telerik.Reporting.Drawing Namespace


BorderWidth Class

[image]

Telerik Reporting Q2 2012
BorderWidth Class
Members See Also Send Feedback
A class used to specify the width of the border of an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BorderWidth : BorderBase
Visual Basic (Declaration)
Public Class BorderWidth _
    Inherits BorderBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.BorderBase
Telerik.Reporting.Drawing..::.BorderWidth

See Also

BorderWidth Members
Telerik.Reporting.Drawing Namespace


BorderWidth Members

[image] [image]

Telerik Reporting Q2 2012
BorderWidth Members
BorderWidth Class Methods Properties See Also Send Feedback

The BorderWidth type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Bottom | Gets or sets the bottom width of the border.
Default | Gets or sets the default width of the border.
Left | Gets or sets the left width of the border.
Right | Gets or sets the right width of the border.
Top | Gets or sets the top width of the border.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


BorderWidth Methods

[image] [image]

Telerik Reporting Q2 2012
BorderWidth Methods
BorderWidth Class See Also Send Feedback

The BorderWidth type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
BorderWidth..::.ToString Method
BorderWidth Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


BorderWidth Properties

[image] [image]

Telerik Reporting Q2 2012
BorderWidth Properties
BorderWidth Class See Also Send Feedback

The BorderWidth type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the bottom width of the border.
Default | Gets or sets the default width of the border.
Left | Gets or sets the left width of the border.
Right | Gets or sets the right width of the border.
Top | Gets or sets the top width of the border.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
BorderWidth..::.Bottom Property
BorderWidth Class See Also Send Feedback
Gets or sets the bottom width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Unit

Field Value

A Unit specifying the bottom border width.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Default Property

[image]

Telerik Reporting Q2 2012
BorderWidth..::.Default Property
BorderWidth Class See Also Send Feedback
Gets or sets the default width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Default { get; set; }
Visual Basic (Declaration)
Public Property Default As Unit

Field Value

A Unit specifying the default border width.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
BorderWidth..::.Left Property
BorderWidth Class See Also Send Feedback
Gets or sets the left width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Unit

Field Value

A Unit specifying the left border width.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
BorderWidth..::.Right Property
BorderWidth Class See Also Send Feedback
Gets or sets the right width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Unit

Field Value

A Unit specifying the right border width.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
BorderWidth..::.Top Property
BorderWidth Class See Also Send Feedback
Gets or sets the top width of the border.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Unit

Field Value

A Unit specifying the top border width.

See Also

BorderWidth Class
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Class

[image]

Telerik Reporting Q2 2012
ConditionalFormatting Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ConditionalFormatting : Collection<FormattingRule>
Visual Basic (Declaration)
Public Class ConditionalFormatting _
    Inherits Collection(Of FormattingRule)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' FormattingRule >)>)>
Telerik.Reporting.Drawing..::.ConditionalFormatting

See Also

ConditionalFormatting Members
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Members

[image] [image]

Telerik Reporting Q2 2012
ConditionalFormatting Members
ConditionalFormatting Class Constructors Methods See Also Send Feedback

The ConditionalFormatting type exposes the following members.

Constructors

Name | Description
ConditionalFormatting | Initializes a new instance of the ConditionalFormatting class

Methods

Name | Description
AddRange |

See Also

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Constructor

[image]

Telerik Reporting Q2 2012
ConditionalFormatting Constructor
ConditionalFormatting Class See Also Send Feedback
Initializes a new instance of the ConditionalFormatting class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ConditionalFormatting()
Visual Basic (Declaration)
Public Sub New

See Also

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


ConditionalFormatting Methods

[image] [image]

Telerik Reporting Q2 2012
ConditionalFormatting Methods
ConditionalFormatting Class See Also Send Feedback

The ConditionalFormatting type exposes the following members.

Methods

Name | Description
AddRange |

See Also

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
ConditionalFormatting..::.AddRange Method
ConditionalFormatting Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    FormattingRule[] items
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    items As FormattingRule() _
)

Parameters

items
Type: array< Telerik.Reporting.Drawing..::.FormattingRule >[]()[][]

See Also

ConditionalFormatting Class
Telerik.Reporting.Drawing Namespace


DescendantSelector Class

[image]

Telerik Reporting Q2 2012
DescendantSelector Class
Members See Also Send Feedback
Represents a selector that matches an item that is a descendant of another item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DescendantSelector : ISelector
Visual Basic (Declaration)
Public Class DescendantSelector _
    Implements ISelector

Remarks

At times, authors may want selectors to match an item that is the descendant of another item in the report item tree (e.g., "Match those TextBox elements that are contained by a Panel element"). Descendant selectors express such a relationship in a pattern.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.DescendantSelector

See Also

DescendantSelector Members
Telerik.Reporting.Drawing Namespace


DescendantSelector Members

[image] [image]

Telerik Reporting Q2 2012
DescendantSelector Members
DescendantSelector Class Constructors Methods Properties See Also Send Feedback

The DescendantSelector type exposes the following members.

Constructors

Name | Description
DescendantSelector | Overloaded.

Methods

Name | Description
Match | Matches a report item based on the descendance pattern defined by the Selectors
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

Properties

Name | Description
Selectors | Gets a SelectorCollection containing the selectors that define the descendance pattern used to match the item.

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


DescendantSelector Constructor

[image] [image]

Telerik Reporting Q2 2012
DescendantSelector Constructor
DescendantSelector Class See Also Send Feedback

Overload List

Name | Description
DescendantSelector()()() | Initializes a new instance of the DescendantSelector.
DescendantSelector(array<ISelector>[]()[]) | Initializes a new instance of the DescendantSelector class with the specified selectors.

See Also

DescendantSelector Class
DescendantSelector Members
Telerik.Reporting.Drawing Namespace


DescendantSelector Constructor

[image]

Telerik Reporting Q2 2012
DescendantSelector Constructor
DescendantSelector Class See Also Send Feedback
Initializes a new instance of the DescendantSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DescendantSelector()
Visual Basic (Declaration)
Public Sub New

See Also

DescendantSelector Class
DescendantSelector Overload
Telerik.Reporting.Drawing Namespace


DescendantSelector Constructor (ISelector[])

[image]

Telerik Reporting Q2 2012
DescendantSelector Constructor (array<ISelector>[]()[][])
DescendantSelector Class See Also Send Feedback
Initializes a new instance of the DescendantSelector class with the specified selectors.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DescendantSelector(
    ISelector[] selectors
)
Visual Basic (Declaration)
Public Sub New ( _
    selectors As ISelector() _
)

Parameters

selectors
Type: array< Telerik.Reporting.Drawing..::.ISelector >[]()[][]
A ISelector array containing the selectors that define the descendance pattern used to match the item.

See Also

DescendantSelector Class
DescendantSelector Overload
Telerik.Reporting.Drawing Namespace


DescendantSelector Methods

[image] [image]

Telerik Reporting Q2 2012
DescendantSelector Methods
DescendantSelector Class See Also Send Feedback

The DescendantSelector type exposes the following members.

Methods

Name | Description
Match | Matches a report item based on the descendance pattern defined by the Selectors
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


Match Method

[image]

Telerik Reporting Q2 2012
DescendantSelector..::.Match Method
DescendantSelector Class See Also Send Feedback
Matches a report item based on the descendance pattern defined by the Selectors

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Match(
    ReportItemBase item
)
Visual Basic (Declaration)
Public Function Match ( _
    item As ReportItemBase _
) As Boolean

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to match.

Return Value

true if the item matches the descendance pattern.

Implements

ISelector..::.Match(ReportItemBase)

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
DescendantSelector..::.ToString Method
DescendantSelector Class See Also Send Feedback
This member overrides ToString()()()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string value describing the selector.

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


DescendantSelector Properties

[image] [image]

Telerik Reporting Q2 2012
DescendantSelector Properties
DescendantSelector Class See Also Send Feedback

The DescendantSelector type exposes the following members.

Properties

Name | Description
Selectors | Gets a SelectorCollection containing the selectors that define the descendance pattern used to match the item.

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


Selectors Property

[image]

Telerik Reporting Q2 2012
DescendantSelector..::.Selectors Property
DescendantSelector Class See Also Send Feedback
Gets a SelectorCollection containing the selectors that define the descendance pattern used to match the item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SelectorCollection Selectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selectors As SelectorCollection

See Also

DescendantSelector Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Class

[image]

Telerik Reporting Q2 2012
ExternalStyleSheet Class
Members See Also Send Feedback
Represents an external style sheet used to style a report.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExternalStyleSheet
Visual Basic (Declaration)
Public Class ExternalStyleSheet

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.ExternalStyleSheet

See Also

ExternalStyleSheet Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Members

[image] [image]

Telerik Reporting Q2 2012
ExternalStyleSheet Members
ExternalStyleSheet Class Constructors See Also Send Feedback

Constructors

Name | Description
ExternalStyleSheet | Overloaded.

See Also

ExternalStyleSheet Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Constructor

[image] [image]

Telerik Reporting Q2 2012
ExternalStyleSheet Constructor
ExternalStyleSheet Class See Also Send Feedback

Overload List

Name | Description
ExternalStyleSheet(Stream) | Creates a new ExternalStyleSheet by loading it from the specified stream.
ExternalStyleSheet(String) | Creates a new ExternalStyleSheet with the given resource identifier.
ExternalStyleSheet(Uri) | Creates a new ExternalStyleSheet by loading it from the specified Uri.

See Also

ExternalStyleSheet Class
ExternalStyleSheet Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Constructor (Stream)

[image]

Telerik Reporting Q2 2012
ExternalStyleSheet Constructor (Stream)
ExternalStyleSheet Class See Also Send Feedback
Creates a new ExternalStyleSheet by loading it from the specified stream.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExternalStyleSheet(
    Stream stream
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream
The stream to load from.

See Also

ExternalStyleSheet Class
ExternalStyleSheet Overload
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Constructor (String)

[image]

Telerik Reporting Q2 2012
ExternalStyleSheet Constructor (String)
ExternalStyleSheet Class See Also Send Feedback
Creates a new ExternalStyleSheet with the given resource identifier.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExternalStyleSheet(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
The identifier for the resource containing the external style sheet. This parameter can be an absolute or relative filepath, an absolute or relative URL, or the name of an embedded resource.

See Also

ExternalStyleSheet Class
ExternalStyleSheet Overload
Telerik.Reporting.Drawing Namespace


ExternalStyleSheet Constructor (Uri)

[image]

Telerik Reporting Q2 2012
ExternalStyleSheet Constructor (Uri)
ExternalStyleSheet Class See Also Send Feedback
Creates a new ExternalStyleSheet by loading it from the specified Uri.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExternalStyleSheet(
    Uri uri
)
Visual Basic (Declaration)
Public Sub New ( _
    uri As Uri _
)

Parameters

uri
Type: System..::.Uri
The Uri to load from.

See Also

ExternalStyleSheet Class
ExternalStyleSheet Overload
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Class

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection Class
Members See Also Send Feedback
Represents a collection of ExternalStyleSheet objects.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExternalStyleSheetCollection : Collection<ExternalStyleSheet>,
    ICollection<string>, IEnumerable<string>, IEnumerable
Visual Basic (Declaration)
Public Class ExternalStyleSheetCollection _
    Inherits Collection(Of ExternalStyleSheet) _
    Implements ICollection(Of String), IEnumerable(Of String),  _
    IEnumerable

Remarks

Each time an ExternalStyleSheet object is inserted, deleted or set in this collection, the Report that owns the collection is refreshed by re-applying or internal and external style sheets.

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ExternalStyleSheet >)>)>
Telerik.Reporting.Drawing..::.ExternalStyleSheetCollection

See Also

ExternalStyleSheetCollection Members
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Members

[image] [image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection Members
ExternalStyleSheetCollection Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The ExternalStyleSheetCollection type exposes the following members.

Constructors

Name | Description
ExternalStyleSheetCollection | Initializes a new instance of the ExternalStyleSheetCollection class

Methods

Name | Description
Add | Obsolete.
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Obsolete.
CopyTo | Obsolete.
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
Remove | Obsolete.
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

Properties

Name Description

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(String>)>)..::.GetEnumerator | Obsolete.
ICollection<(Of <(String>)>)..::.IsReadOnly | Obsolete.

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Constructor

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection Constructor
ExternalStyleSheetCollection Class See Also Send Feedback
Initializes a new instance of the ExternalStyleSheetCollection class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExternalStyleSheetCollection(
    Report report
)
Visual Basic (Declaration)
Public Sub New ( _
    report As Report _
)

Parameters

report
Type: Telerik.Reporting..::.Report

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection Methods
ExternalStyleSheetCollection Class See Also Send Feedback

The ExternalStyleSheetCollection type exposes the following members.

Methods

Name | Description
Add | Obsolete.
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Obsolete.
CopyTo | Obsolete.
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
Remove | Obsolete.
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(String>)>)..::.GetEnumerator | Obsolete.

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


IEnumerable(String).GetEnumerator Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.IEnumerable<(Of <(<'String>)>)>..::.GetEnumerator Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the method IEnumerable<ExternalStyleSheet>.GetEnumerator() instead")]
IEnumerator<string> IEnumerable<string>.GetEnumerator()
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the method IEnumerable<ExternalStyleSheet>.GetEnumerator() instead")> _
Private Function GetEnumerator As IEnumerator(Of String)
    Implements IEnumerable(Of String).GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


Add Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.Add Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the method Add(ExternalStyleSheet item) instead.")]
public void Add(
    string item
)
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the method Add(ExternalStyleSheet item) instead.")> _
Public Sub Add ( _
    item As String _
)

Parameters

item
Type: System..::.String

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.ClearItems Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


Contains Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.Contains Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the method Contains(ExternalStyleSheet item) instead.")]
public bool Contains(
    string item
)
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the method Contains(ExternalStyleSheet item) instead.")> _
Public Function Contains ( _
    item As String _
) As Boolean

Parameters

item
Type: System..::.String

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


CopyTo Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.CopyTo Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the method CopyTo(ExternalStyleSheet[] array, int arrayIndex) instead.")]
public void CopyTo(
    string[] array,
    int arrayIndex
)
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the method CopyTo(ExternalStyleSheet[] array, int arrayIndex) instead.")> _
Public Sub CopyTo ( _
    array As String(), _
    arrayIndex As Integer _
)

Parameters

array
Type: array< System..::.String >[]()[][]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.InsertItem Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    ExternalStyleSheet ess
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    ess As ExternalStyleSheet _
)

Parameters

index
Type: System..::.Int32
ess
Type: Telerik.Reporting.Drawing..::.ExternalStyleSheet

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


Remove Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.Remove Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use the method Remove(ExternalStyleSheet item) instead")]
public bool Remove(
    string item
)
Visual Basic (Declaration)
<ObsoleteAttribute("Please use the method Remove(ExternalStyleSheet item) instead")> _
Public Function Remove ( _
    item As String _
) As Boolean

Parameters

item
Type: System..::.String

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


RemoveItem Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.RemoveItem Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


SetItem Method

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.SetItem Method
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void SetItem(
    int index,
    ExternalStyleSheet ess
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    ess As ExternalStyleSheet _
)

Parameters

index
Type: System..::.Int32
ess
Type: Telerik.Reporting.Drawing..::.ExternalStyleSheet

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ExternalStyleSheetCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection Properties
ExternalStyleSheetCollection Class See Also Send Feedback

Properties

Name Description

Explicit Interface Implementations

Name | Description
ICollection<(Of <(String>)>)..::.IsReadOnly | Obsolete.

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


ICollection(String).IsReadOnly Property

[image]

Telerik Reporting Q2 2012
ExternalStyleSheetCollection..::.ICollection<(Of <(<'String>)>)>..::.IsReadOnly Property
ExternalStyleSheetCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("")]
bool ICollection<string>.IsReadOnly { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("")> _
Private ReadOnly Property IsReadOnly As Boolean
    Implements ICollection(Of String).IsReadOnly

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

See Also

ExternalStyleSheetCollection Class
Telerik.Reporting.Drawing Namespace


Font Class

[image]

Telerik Reporting Q2 2012
Font Class
Members See Also Send Feedback
Defines a particular format for text, including font face, size, and style attributes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Font
Visual Basic (Declaration)
Public Class Font

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.Font

See Also

Font Members
Telerik.Reporting.Drawing Namespace


Font Members

[image] [image]

Telerik Reporting Q2 2012
Font Members
Font Class Methods Operators Properties See Also Send Feedback

The Font type exposes the following members.

Methods

Name | Description
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

Operators

Name | Description
Explicit | Obsolete. Converts the specified reporting Font to a Font.

Properties

Name | Description
Bold | Gets a value that indicates whether this Font is bold.
Italic | Gets a value that indicates whether this Font is italic.
Name | Gets or sets the face name of this Font.
Size | Gets or sets the size of this Font measured in Units.
Strikeout | Gets a value that indicates whether this Font specifies a horizontal line through the font.
Style | Gets or sets style information for this Font.
Underline | Gets a value that indicates whether this Font is underlined.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Font Methods

[image] [image]

Telerik Reporting Q2 2012
Font Methods
Font Class See Also Send Feedback

The Font type exposes the following members.

Methods

Name | Description
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

See Also

Font Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Font..::.ToString Method
Font Class See Also Send Feedback
This member overrides ToString()()()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string value describing the Font.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Font Operators

[image] [image]

Telerik Reporting Q2 2012
Font Operators
Font Class See Also Send Feedback

The Font type exposes the following members.

Operators

Name | Description
Explicit | Obsolete. Converts the specified reporting Font to a Font.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Explicit Operator

[image]

Telerik Reporting Q2 2012
Font..::.Explicit Operator
Font Class See Also Send Feedback
Converts the specified reporting Font to a Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator Font (
    Font font
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    font As Font _
) As Font

Parameters

font
Type: Telerik.Reporting.Drawing..::.Font
The Font to convert.

Return Value

The Font that is converted from the specified reporting Font structure.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Font Properties

[image] [image]

Telerik Reporting Q2 2012
Font Properties
Font Class See Also Send Feedback

The Font type exposes the following members.

Properties

Name | Description
Bold | Gets a value that indicates whether this Font is bold.
Italic | Gets a value that indicates whether this Font is italic.
Name | Gets or sets the face name of this Font.
Size | Gets or sets the size of this Font measured in Units.
Strikeout | Gets a value that indicates whether this Font specifies a horizontal line through the font.
Style | Gets or sets style information for this Font.
Underline | Gets a value that indicates whether this Font is underlined.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Bold Property

[image]

Telerik Reporting Q2 2012
Font..::.Bold Property
Font Class See Also Send Feedback
Gets a value that indicates whether this Font is bold.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Bold { get; set; }
Visual Basic (Declaration)
Public Property Bold As Boolean

Field Value

true if this Font is bold; otherwise, false.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Italic Property

[image]

Telerik Reporting Q2 2012
Font..::.Italic Property
Font Class See Also Send Feedback
Gets a value that indicates whether this Font is italic.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Italic { get; set; }
Visual Basic (Declaration)
Public Property Italic As Boolean

Field Value

true if this Font is italic; otherwise, false.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Font..::.Name Property
Font Class See Also Send Feedback
Gets or sets the face name of this Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

Field Value

A string representation of the face name of this Font.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Size Property

[image]

Telerik Reporting Q2 2012
Font..::.Size Property
Font Class See Also Send Feedback
Gets or sets the size of this Font measured in Units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Unit

Field Value

The Unit size of this Font.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Strikeout Property

[image]

Telerik Reporting Q2 2012
Font..::.Strikeout Property
Font Class See Also Send Feedback
Gets a value that indicates whether this Font specifies a horizontal line through the font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Strikeout { get; set; }
Visual Basic (Declaration)
Public Property Strikeout As Boolean

Field Value

true if this Font has a horizontal line through it; otherwise, false.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Style Property

[image]

Telerik Reporting Q2 2012
Font..::.Style Property
Font Class See Also Send Feedback
Gets or sets style information for this Font.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FontStyle Style { get; set; }
Visual Basic (Declaration)
Public Property Style As FontStyle

Field Value

A FontStyle enumeration that contains style information for this Font.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


Underline Property

[image]

Telerik Reporting Q2 2012
Font..::.Underline Property
Font Class See Also Send Feedback
Gets a value that indicates whether this Font is underlined.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Underline { get; set; }
Visual Basic (Declaration)
Public Property Underline As Boolean

Field Value

true if this Font is underlined; otherwise, false.

See Also

Font Class
Telerik.Reporting.Drawing Namespace


FormattingRule Class

[image]

Telerik Reporting Q2 2012
FormattingRule Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class FormattingRule : ReportObject
Visual Basic (Declaration)
Public Class FormattingRule _
    Inherits ReportObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.FormattingRule

See Also

FormattingRule Members
Telerik.Reporting.Drawing Namespace


FormattingRule Members

[image] [image]

Telerik Reporting Q2 2012
FormattingRule Members
FormattingRule Class Constructors Methods Properties See Also Send Feedback

The FormattingRule type exposes the following members.

Constructors

Name | Description
FormattingRule | Initializes a new instance of the FormattingRule class

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Properties

Name | Description
Filters |
StopIfTrue | Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.
Style |

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


FormattingRule Constructor

[image]

Telerik Reporting Q2 2012
FormattingRule Constructor
FormattingRule Class See Also Send Feedback
Initializes a new instance of the FormattingRule class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FormattingRule()
Visual Basic (Declaration)
Public Sub New

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


FormattingRule Methods

[image] [image]

Telerik Reporting Q2 2012
FormattingRule Methods
FormattingRule Class See Also Send Feedback

The FormattingRule type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


FormattingRule Properties

[image] [image]

Telerik Reporting Q2 2012
FormattingRule Properties
FormattingRule Class See Also Send Feedback

The FormattingRule type exposes the following members.

Properties

Name | Description
Filters |
StopIfTrue | Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.
Style |

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


Filters Property

[image]

Telerik Reporting Q2 2012
FormattingRule..::.Filters Property
FormattingRule Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public FilterCollection Filters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filters As FilterCollection

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


StopIfTrue Property

[image]

Telerik Reporting Q2 2012
FormattingRule..::.StopIfTrue Property
FormattingRule Class See Also Send Feedback
Indicates whether if the current rule is applied to proceed with the next FormattingRule in the ReportItemBase.ConditionalFormattings collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool StopIfTrue { get; set; }
Visual Basic (Declaration)
Public Property StopIfTrue As Boolean

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


Style Property

[image]

Telerik Reporting Q2 2012
FormattingRule..::.Style Property
FormattingRule Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As Style

See Also

FormattingRule Class
Telerik.Reporting.Drawing Namespace


HorizontalAlign Enumeration

[image]

Telerik Reporting Q2 2012
HorizontalAlign Enumeration
See Also Send Feedback
Specifies the vertical alignment of an object or text in a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum HorizontalAlign
Visual Basic (Declaration)
Public Enumeration HorizontalAlign

Members

Member name | Description
Left | Specifies that the object is aligned to the left.
Center | Specifies that the object is aligned to the center.
Right | Specifies that the object is aligned to the right.

See Also

Telerik.Reporting.Drawing Namespace


ImageSizeMode Enumeration

[image]

Telerik Reporting Q2 2012
ImageSizeMode Enumeration
See Also Send Feedback
Specifies how an image is positioned within an item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum ImageSizeMode
Visual Basic (Declaration)
Public Enumeration ImageSizeMode

Members

Member name | Description
AutoSize | Grows or shrinks borders of the image item to fit the image.
Center | The image is displayed in the center of the item. If the image is larger than the item, the image is clipped
Normal | Clips the image to fit the height and width of the item.
Stretch | Resizes the image to match the height and width of the item.
ScaleProportional | Resizes the image to match the height and width of the item, preserving the aspect ratio.

See Also

Telerik.Reporting.Drawing Namespace


ISelector Interface

[image]

Telerik Reporting Q2 2012
ISelector Interface
Members See Also Send Feedback
Allows an object to implement a style selector, and represents a set of methods to match a ReportItemBase and clone the selector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface ISelector
Visual Basic (Declaration)
Public Interface ISelector

See Also

ISelector Members
Telerik.Reporting.Drawing Namespace


ISelector Members

[image] [image]

Telerik Reporting Q2 2012
ISelector Members
ISelector Interface Methods See Also Send Feedback

The ISelector type exposes the following members.

Methods

Name | Description
Match | Matches a ReportItemBase based on certain criteria.

See Also

ISelector Interface
Telerik.Reporting.Drawing Namespace


ISelector Methods

[image] [image]

Telerik Reporting Q2 2012
ISelector Methods
ISelector Interface See Also Send Feedback

The ISelector type exposes the following members.

Methods

Name | Description
Match | Matches a ReportItemBase based on certain criteria.

See Also

ISelector Interface
Telerik.Reporting.Drawing Namespace


Match Method

[image]

Telerik Reporting Q2 2012
ISelector..::.Match Method
ISelector Interface See Also Send Feedback
Matches a ReportItemBase based on certain criteria.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool Match(
    ReportItemBase item
)
Visual Basic (Declaration)
Function Match ( _
    item As ReportItemBase _
) As Boolean

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to match.

Return Value

true if item matches; otherwise false.

See Also

ISelector Interface
Telerik.Reporting.Drawing Namespace


LineStyle Enumeration

[image]

Telerik Reporting Q2 2012
LineStyle Enumeration
See Also Send Feedback
Specifies the type of a line item

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum LineStyle
Visual Basic (Declaration)
Public Enumeration LineStyle

Members

Member name | Description
Solid |
Dashed |
Dotted |

See Also

Telerik.Reporting.Drawing Namespace


MarginsU Class

[image]

Telerik Reporting Q2 2012
MarginsU Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class MarginsU
Visual Basic (Declaration)
Public Class MarginsU

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.MarginsU

See Also

MarginsU Members
Telerik.Reporting.Drawing Namespace


MarginsU Members

[image] [image]

Telerik Reporting Q2 2012
MarginsU Members
MarginsU Class Constructors Properties See Also Send Feedback

The MarginsU type exposes the following members.

Constructors

Name | Description
MarginsU | Overloaded.

Properties

Name | Description
Bottom |
Left |
Right |
Top |

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


MarginsU Constructor

[image] [image]

Telerik Reporting Q2 2012
MarginsU Constructor
MarginsU Class See Also Send Feedback

Overload List

Name | Description
MarginsU()()() | Initializes a new instance of the MarginsU class
MarginsU(MarginsU) | Initializes a new instance of the MarginsU class
MarginsU(Unit) | Initializes a new instance of the MarginsU class
MarginsU(Unit, Unit, Unit, Unit) | Initializes a new instance of the MarginsU class

See Also

MarginsU Class
MarginsU Members
Telerik.Reporting.Drawing Namespace


MarginsU Constructor

[image]

Telerik Reporting Q2 2012
MarginsU Constructor
MarginsU Class See Also Send Feedback
Initializes a new instance of the MarginsU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsU()
Visual Basic (Declaration)
Public Sub New

See Also

MarginsU Class
MarginsU Overload
Telerik.Reporting.Drawing Namespace


MarginsU Constructor (MarginsU)

[image]

Telerik Reporting Q2 2012
MarginsU Constructor (MarginsU)
MarginsU Class See Also Send Feedback
Initializes a new instance of the MarginsU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsU(
    MarginsU margins
)
Visual Basic (Declaration)
Public Sub New ( _
    margins As MarginsU _
)

Parameters

margins
Type: Telerik.Reporting.Drawing..::.MarginsU

See Also

MarginsU Class
MarginsU Overload
Telerik.Reporting.Drawing Namespace


MarginsU Constructor (Unit)

[image]

Telerik Reporting Q2 2012
MarginsU Constructor (Unit)
MarginsU Class See Also Send Feedback
Initializes a new instance of the MarginsU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsU(
    Unit value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Unit _
)

Parameters

value
Type: Telerik.Reporting.Drawing..::.Unit

See Also

MarginsU Class
MarginsU Overload
Telerik.Reporting.Drawing Namespace


MarginsU Constructor (Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
MarginsU Constructor (Unit, Unit, Unit, Unit)
MarginsU Class See Also Send Feedback
Initializes a new instance of the MarginsU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsU(
    Unit left,
    Unit right,
    Unit top,
    Unit bottom
)
Visual Basic (Declaration)
Public Sub New ( _
    left As Unit, _
    right As Unit, _
    top As Unit, _
    bottom As Unit _
)

Parameters

left
Type: Telerik.Reporting.Drawing..::.Unit
right
Type: Telerik.Reporting.Drawing..::.Unit
top
Type: Telerik.Reporting.Drawing..::.Unit
bottom
Type: Telerik.Reporting.Drawing..::.Unit

See Also

MarginsU Class
MarginsU Overload
Telerik.Reporting.Drawing Namespace


MarginsU Properties

[image] [image]

Telerik Reporting Q2 2012
MarginsU Properties
MarginsU Class See Also Send Feedback

The MarginsU type exposes the following members.

Properties

Name | Description
Bottom |
Left |
Right |
Top |

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
MarginsU..::.Bottom Property
MarginsU Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Unit

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
MarginsU..::.Left Property
MarginsU Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Unit

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
MarginsU..::.Right Property
MarginsU Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Unit

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
MarginsU..::.Top Property
MarginsU Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Unit

See Also

MarginsU Class
Telerik.Reporting.Drawing Namespace


Padding Class

[image]

Telerik Reporting Q2 2012
Padding Class
Members See Also Send Feedback
Represents padding information associated with a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Padding
Visual Basic (Declaration)
Public Class Padding

Remarks

The padding is the internal space between the body of the item and its edge.

Padding has a different effect on report items that are containers than on report items that are not. For example, in a Panel item, the Padding property defines the spacing between the border of the Panel and its child items. For a TextBox item, the Padding property defines the spacing between the border of the TextBox item and its contained text.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.Padding

See Also

Padding Members
Telerik.Reporting.Drawing Namespace


Padding Members

[image] [image]

Telerik Reporting Q2 2012
Padding Members
Padding Class Methods Properties See Also Send Feedback

The Padding type exposes the following members.

Methods

Name | Description
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

Properties

Name | Description
Bottom | Gets or sets the padding value for the bottom edge.
Left | Gets or sets the padding value for the left edge.
Right | Gets or sets the padding value for the right edge.
Top | Gets or sets the padding value for the top edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Padding Methods

[image] [image]

Telerik Reporting Q2 2012
Padding Methods
Padding Class See Also Send Feedback

The Padding type exposes the following members.

Methods

Name | Description
ToString | This member overrides ToString()()() (Overrides Object..::.ToString()()().)

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Padding..::.ToString Method
Padding Class See Also Send Feedback
This member overrides ToString()()()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string value listing the Padding's members.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Padding Properties

[image] [image]

Telerik Reporting Q2 2012
Padding Properties
Padding Class See Also Send Feedback

The Padding type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the padding value for the bottom edge.
Left | Gets or sets the padding value for the left edge.
Right | Gets or sets the padding value for the right edge.
Top | Gets or sets the padding value for the top edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
Padding..::.Bottom Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the bottom edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Unit

Field Value

The padding, in Units, for the bottom edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
Padding..::.Left Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the left edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Unit

Field Value

The padding, in Units, for the left edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
Padding..::.Right Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the right edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Unit

Field Value

The padding, in Units, for the right edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
Padding..::.Top Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the top edge.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Unit

Field Value

The padding, in Units, for the top edge.

See Also

Padding Class
Telerik.Reporting.Drawing Namespace


PageSettings Class

[image]

Telerik Reporting Q2 2012
PageSettings Class
Members See Also Send Feedback
Specifies settings that apply to a single, printed page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PageSettings : ReportObject,
    ICloneable
Visual Basic (Declaration)
Public Class PageSettings _
    Inherits ReportObject _
    Implements ICloneable

Remarks

The PageSettings class is used to specify settings that modify the way a page will be printed.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.PageSettings

See Also

PageSettings Members
Telerik.Reporting.Drawing Namespace


PageSettings Members

[image] [image]

Telerik Reporting Q2 2012
PageSettings Members
PageSettings Class Constructors Methods Properties See Also Send Feedback

The PageSettings type exposes the following members.

Constructors

Name | Description
PageSettings | Overloaded.

Methods

Name | Description
Clone | This member implements Clone()()()
ToPageSettings | Returns a PageSettings object based on the given PrinterSettings parameter.
ToString | (Inherited from ReportObject.)

Properties

Name | Description
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Margins | Gets or sets the margins for this page.
PaperKind | Gets or sets the paper kind for the page.
PaperSize | Gets or sets the paper size for the page.
Watermarks | Specifies a collection of watermarks for the page.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


PageSettings Constructor

[image] [image]

Telerik Reporting Q2 2012
PageSettings Constructor
PageSettings Class See Also Send Feedback

Overload List

Name | Description
PageSettings()()() | Initializes a new instance of the PageSettings class
PageSettings(PageSettings, PrinterSettings) | Initializes a new instance of the PageSettings class with the specified PageSettings and PrinterSettings.

See Also

PageSettings Class
PageSettings Members
Telerik.Reporting.Drawing Namespace


PageSettings Constructor

[image]

Telerik Reporting Q2 2012
PageSettings Constructor
PageSettings Class See Also Send Feedback
Initializes a new instance of the PageSettings class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSettings()
Visual Basic (Declaration)
Public Sub New

See Also

PageSettings Class
PageSettings Overload
Telerik.Reporting.Drawing Namespace


PageSettings Constructor (PageSettings, PrinterSettings)

[image]

Telerik Reporting Q2 2012
PageSettings Constructor (PageSettings, PrinterSettings)
PageSettings Class See Also Send Feedback
Initializes a new instance of the PageSettings class with the specified PageSettings and PrinterSettings.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSettings(
    PageSettings pageSettings,
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Sub New ( _
    pageSettings As PageSettings, _
    printerSettings As PrinterSettings _
)

Parameters

pageSettings
Type: System.Drawing.Printing..::.PageSettings
A PageSettings object specifying the landscape and paper kind.
printerSettings
Type: System.Drawing.Printing..::.PrinterSettings
A PrinterSettings object specifying the papers size and margins.

See Also

PageSettings Class
PageSettings Overload
Telerik.Reporting.Drawing Namespace


PageSettings Methods

[image] [image]

Telerik Reporting Q2 2012
PageSettings Methods
PageSettings Class See Also Send Feedback

The PageSettings type exposes the following members.

Methods

Name | Description
Clone | This member implements Clone()()()
ToPageSettings | Returns a PageSettings object based on the given PrinterSettings parameter.
ToString | (Inherited from ReportObject.)

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
PageSettings..::.Clone Method
PageSettings Class See Also Send Feedback
This member implements Clone()()()

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object

Return Value

The cloned PageSettings.

Implements

ICloneable..::.Clone()()()

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


ToPageSettings Method

[image]

Telerik Reporting Q2 2012
PageSettings..::.ToPageSettings Method
PageSettings Class See Also Send Feedback
Returns a PageSettings object based on the given PrinterSettings parameter.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSettings ToPageSettings(
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Function ToPageSettings ( _
    printerSettings As PrinterSettings _
) As PageSettings

Parameters

printerSettings
Type: System.Drawing.Printing..::.PrinterSettings
A PrinterSettings object from which to create the PageSettings.

Return Value

A PageSettings object initialized from the printerSettings.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


PageSettings Properties

[image] [image]

Telerik Reporting Q2 2012
PageSettings Properties
PageSettings Class See Also Send Feedback

The PageSettings type exposes the following members.

Properties

Name | Description
Landscape | Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.
Margins | Gets or sets the margins for this page.
PaperKind | Gets or sets the paper kind for the page.
PaperSize | Gets or sets the paper size for the page.
Watermarks | Specifies a collection of watermarks for the page.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


Landscape Property

[image]

Telerik Reporting Q2 2012
PageSettings..::.Landscape Property
PageSettings Class See Also Send Feedback
Gets or sets a value indicating whether the page is printed in landscape or portrait orientation.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Landscape { get; set; }
Visual Basic (Declaration)
Public Property Landscape As Boolean

Field Value

true if the page should be printed in landscape orientation; otherwise, false.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


Margins Property

[image]

Telerik Reporting Q2 2012
PageSettings..::.Margins Property
PageSettings Class See Also Send Feedback
Gets or sets the margins for this page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public MarginsU Margins { get; set; }
Visual Basic (Declaration)
Public Property Margins As MarginsU

Field Value

A MarginsU that represents the margins for the page.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


PaperKind Property

[image]

Telerik Reporting Q2 2012
PageSettings..::.PaperKind Property
PageSettings Class See Also Send Feedback
Gets or sets the paper kind for the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PaperKind PaperKind { get; set; }
Visual Basic (Declaration)
Public Property PaperKind As PaperKind

Field Value

A PaperKind that represents the kind of the paper.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


PaperSize Property

[image]

Telerik Reporting Q2 2012
PageSettings..::.PaperSize Property
PageSettings Class See Also Send Feedback
Gets or sets the paper size for the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU PaperSize { get; set; }
Visual Basic (Declaration)
Public Property PaperSize As SizeU

Field Value

A SizeU that represents the size of the paper.

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


Watermarks Property

[image]

Telerik Reporting Q2 2012
PageSettings..::.Watermarks Property
PageSettings Class See Also Send Feedback
Specifies a collection of watermarks for the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkCollection Watermarks { get; private set; }
Visual Basic (Declaration)
Public Property Watermarks As WatermarkCollection

See Also

PageSettings Class
Telerik.Reporting.Drawing Namespace


PictureWatermark Class

[image]

Telerik Reporting Q2 2012
PictureWatermark Class
Members See Also Send Feedback
Represents a picture watermark on a printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PictureWatermark : Watermark,
    ICloneable
Visual Basic (Declaration)
Public Class PictureWatermark _
    Inherits Watermark _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.Watermark
Telerik.Reporting.Drawing..::.PictureWatermark

See Also

PictureWatermark Members
Telerik.Reporting.Drawing Namespace


PictureWatermark Members

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Members
PictureWatermark Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PictureWatermark type exposes the following members.

Constructors

Name | Description
PictureWatermark | Overloaded.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Properties

Name | Description
Image | Gets or sets the image of the watermark to be printed on the page.
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page. (Inherited from Watermark.)
Position | Gets or sets the position of the watermark relative to the other items on the printable page. (Inherited from Watermark.)
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report. (Inherited from Watermark.)
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report. (Inherited from Watermark.)
Sizing | Gets or sets the sizing mode of the watermark image on the printable page.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


PictureWatermark Constructor

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Constructor
PictureWatermark Class See Also Send Feedback

Overload List

Name | Description
PictureWatermark()()() | Initializes a new instance of the PictureWatermark class
PictureWatermark(PictureWatermark) | Initializes a new instance of the PictureWatermark class

See Also

PictureWatermark Class
PictureWatermark Members
Telerik.Reporting.Drawing Namespace


PictureWatermark Constructor

[image]

Telerik Reporting Q2 2012
PictureWatermark Constructor
PictureWatermark Class See Also Send Feedback
Initializes a new instance of the PictureWatermark class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PictureWatermark()
Visual Basic (Declaration)
Public Sub New

See Also

PictureWatermark Class
PictureWatermark Overload
Telerik.Reporting.Drawing Namespace


PictureWatermark Constructor (PictureWatermark)

[image]

Telerik Reporting Q2 2012
PictureWatermark Constructor (PictureWatermark)
PictureWatermark Class See Also Send Feedback
Initializes a new instance of the PictureWatermark class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PictureWatermark(
    PictureWatermark watermark
)
Visual Basic (Declaration)
Public Sub New ( _
    watermark As PictureWatermark _
)

Parameters

watermark
Type: Telerik.Reporting.Drawing..::.PictureWatermark

See Also

PictureWatermark Class
PictureWatermark Overload
Telerik.Reporting.Drawing Namespace


PictureWatermark Methods

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Methods
PictureWatermark Class See Also Send Feedback

The PictureWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


ICloneable.Clone Method

[image]

Telerik Reporting Q2 2012
PictureWatermark..::.ICloneable..::.Clone Method
PictureWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICloneable.Clone()
Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone

Implements

ICloneable..::.Clone()()()

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


PictureWatermark Properties

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Properties
PictureWatermark Class See Also Send Feedback

The PictureWatermark type exposes the following members.

Properties

Name | Description
Image | Gets or sets the image of the watermark to be printed on the page.
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page. (Inherited from Watermark.)
Position | Gets or sets the position of the watermark relative to the other items on the printable page. (Inherited from Watermark.)
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report. (Inherited from Watermark.)
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report. (Inherited from Watermark.)
Sizing | Gets or sets the sizing mode of the watermark image on the printable page.

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


Image Property

[image]

Telerik Reporting Q2 2012
PictureWatermark..::.Image Property
PictureWatermark Class Example See Also Send Feedback
Gets or sets the image of the watermark to be printed on the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Object

Field Value

The image of the watermark to be printed on the page.

Remarks

The specified image can be in one of the following supported formats: an object instance inherited from Image; an array of bytes containing binary image data; a local file path or an URL to an external image file. Instead of providing the image directly, it is possible to specify it indirectly as an expression that is evaluated at runtime for each printable page. If the image is null (Nothing in Visual Basic), or if the specified expression evaluates to null (Nothing in Visual Basic), the watermark is not printed on the current page.

Examples

The following expression prints a watermark on every second page:
CopyC#
= IIf(PageNumber % 2 = 0, "Watermark.png", Null)

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


Sizing Property

[image]

Telerik Reporting Q2 2012
PictureWatermark..::.Sizing Property
PictureWatermark Class See Also Send Feedback
Gets or sets the sizing mode of the watermark image on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkSizeMode Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As WatermarkSizeMode

Field Value

A ImageSizeMode value that specifies the sizing mode of the watermark image on the printable page.

See Also

PictureWatermark Class
Telerik.Reporting.Drawing Namespace


PointU Structure

[image]

Telerik Reporting Q2 2012
PointU Structure
Members See Also Send Feedback
Represents an ordered pair of unit-based point x- and y-coordinates that defines a point in a two-dimensional plane.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public struct PointU
Visual Basic (Declaration)
Public Structure PointU

See Also

PointU Members
Telerik.Reporting.Drawing Namespace


PointU Members

[image] [image]

Telerik Reporting Q2 2012
PointU Members
PointU Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The PointU type exposes the following members.

Constructors

Name | Description
PointU | Overloaded.

Methods

Name | Description
Equals | Specifies whether this PointU contains the same coordinates as the specified Object. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this PointU structure. (Overrides ValueType..::.GetHashCode()()().)
Offset | Offsets this PointU structure by a specified amount in the x- and y-direction.
ToString | Overloaded.

Operators

Name | Description
Addition | Translates the PointU by the specified SizeU.
Equality | Compares two PointU structures. The result specifies whether the values of the X and Y properties of the two PointU structures are equal.
Explicit | Overloaded.
Inequality | Determines whether the coordinates of the specified points are not equal.
Subtraction | Translates the PointU by the negative of a specified SizeU.

Fields

Name | Description
Empty | Represents a new instance of the PointU class with member data left uninitialized.

Properties

Name | Description
IsEmpty | Gets a value indicating whether this PointU is empty.
X | Gets or sets the x-coordinate of this PointU
Y | Gets or sets the y-coordinate of this PointU

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


PointU Constructor

[image] [image]

Telerik Reporting Q2 2012
PointU Constructor
PointU Structure See Also Send Feedback

Overload List

Name | Description
PointU(Point) | Initializes a new instance of the PointU class
PointU(PointF) | Initializes a new instance of the PointU class
PointU(Unit, Unit) | Initializes a new instance of the PointU class with the specified coordinates.

See Also

PointU Structure
PointU Members
Telerik.Reporting.Drawing Namespace


PointU Constructor (Point)

[image]

Telerik Reporting Q2 2012
PointU Constructor (Point)
PointU Structure See Also Send Feedback
Initializes a new instance of the PointU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU(
    Point pt
)
Visual Basic (Declaration)
Public Sub New ( _
    pt As Point _
)

Parameters

pt
Type: System.Drawing..::.Point

See Also

PointU Structure
PointU Overload
Telerik.Reporting.Drawing Namespace


PointU Constructor (PointF)

[image]

Telerik Reporting Q2 2012
PointU Constructor (PointF)
PointU Structure See Also Send Feedback
Initializes a new instance of the PointU class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU(
    PointF pt
)
Visual Basic (Declaration)
Public Sub New ( _
    pt As PointF _
)

Parameters

pt
Type: System.Drawing..::.PointF

See Also

PointU Structure
PointU Overload
Telerik.Reporting.Drawing Namespace


PointU Constructor (Unit, Unit)

[image]

Telerik Reporting Q2 2012
PointU Constructor (Unit, Unit)
PointU Structure See Also Send Feedback
Initializes a new instance of the PointU class with the specified coordinates.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU(
    Unit x,
    Unit y
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Unit, _
    y As Unit _
)

Parameters

x
Type: Telerik.Reporting.Drawing..::.Unit
The horizontal position of the point.
y
Type: Telerik.Reporting.Drawing..::.Unit
The vertical position of the point.

See Also

PointU Structure
PointU Overload
Telerik.Reporting.Drawing Namespace


PointU Fields

[image] [image]

Telerik Reporting Q2 2012
PointU Fields
PointU Structure See Also Send Feedback

The PointU type exposes the following members.

Fields

Name | Description
Empty | Represents a new instance of the PointU class with member data left uninitialized.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
PointU..::.Empty Field
PointU Structure See Also Send Feedback
Represents a new instance of the PointU class with member data left uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly PointU Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As PointU

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


PointU Methods

[image] [image]

Telerik Reporting Q2 2012
PointU Methods
PointU Structure See Also Send Feedback

The PointU type exposes the following members.

Methods

Name | Description
Equals | Specifies whether this PointU contains the same coordinates as the specified Object. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this PointU structure. (Overrides ValueType..::.GetHashCode()()().)
Offset | Offsets this PointU structure by a specified amount in the x- and y-direction.
ToString | Overloaded.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
PointU..::.Equals Method
PointU Structure See Also Send Feedback
Specifies whether this PointU contains the same coordinates as the specified Object.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to test.

Return Value

This method returns true if obj is a PointU and has the same coordinates as this PointU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
PointU..::.GetHashCode Method
PointU Structure See Also Send Feedback
Returns a hash code for this PointU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

An integer value that specifies a hash value for this PointU structure.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Offset Method

[image]

Telerik Reporting Q2 2012
PointU..::.Offset Method
PointU Structure See Also Send Feedback
Offsets this PointU structure by a specified amount in the x- and y-direction.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Offset(
    Unit dx,
    Unit dy
)
Visual Basic (Declaration)
Public Sub Offset ( _
    dx As Unit, _
    dy As Unit _
)

Parameters

dx
Type: Telerik.Reporting.Drawing..::.Unit
A Unit value specifying the amount to offset in the horizontal direction.
dy
Type: Telerik.Reporting.Drawing..::.Unit
A Unit value specifying the amount to offset in the vertical direction.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PointU..::.ToString Method
PointU Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts this PointU to a human readable string. (Overrides ValueType..::.ToString()()().)
ToString(CultureInfo) | Converts this PointU to a human readable string according to the CultureInfo specified.

See Also

PointU Structure
PointU Members
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
PointU..::.ToString Method
PointU Structure See Also Send Feedback
Converts this PointU to a human readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string that represents this PointU.

See Also

PointU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


ToString Method (CultureInfo)

[image]

Telerik Reporting Q2 2012
PointU..::.ToString Method (CultureInfo)
PointU Structure See Also Send Feedback
Converts this PointU to a human readable string according to the CultureInfo specified.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that is used to format the string.

Return Value

A string that represents this PointU.

See Also

PointU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


PointU Operators

[image] [image]

Telerik Reporting Q2 2012
PointU Operators
PointU Structure See Also Send Feedback

The PointU type exposes the following members.

Operators

Name | Description
Addition | Translates the PointU by the specified SizeU.
Equality | Compares two PointU structures. The result specifies whether the values of the X and Y properties of the two PointU structures are equal.
Explicit | Overloaded.
Inequality | Determines whether the coordinates of the specified points are not equal.
Subtraction | Translates the PointU by the negative of a specified SizeU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Addition Operator

[image]

Telerik Reporting Q2 2012
PointU..::.Addition Operator
PointU Structure See Also Send Feedback
Translates the PointU by the specified SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static PointU operator +(
    PointU pt,
    SizeU size
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    pt As PointU, _
    size As SizeU _
) As PointU

Parameters

pt
Type: Telerik.Reporting.Drawing..::.PointU
The PointU to translate.
size
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU that specifies the numbers to add to the x- and y-coordinates of the PointU.

Return Value

The translated PointU.

Remarks

The op_Addition operator adds the Width of the specified size to the x-coordinate of the PointU and the Height to the y-coordinate of the PointU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
PointU..::.Equality Operator
PointU Structure See Also Send Feedback
Compares two PointU structures. The result specifies whether the values of the X and Y properties of the two PointU structures are equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    PointU pt1,
    PointU pt2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    pt1 As PointU, _
    pt2 As PointU _
) As Boolean

Parameters

pt1
Type: Telerik.Reporting.Drawing..::.PointU
A PointU to compare.
pt2
Type: Telerik.Reporting.Drawing..::.PointU
A PointU to compare.

Return Value

true if the X and Y values of the left and right PointU structures are equal; otherwise, false.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Explicit Method

[image] [image]

Telerik Reporting Q2 2012
PointU..::.Explicit Method
PointU Structure See Also Send Feedback

Overload List

Name | Description
Explicit(PointU) | Converts the specified reporting PointU to a Point.
Explicit(PointU) | Converts the specified reporting PointU to a PointF.

See Also

PointU Structure
PointU Members
Telerik.Reporting.Drawing Namespace


Explicit Operator (PointU)

[image]

Telerik Reporting Q2 2012
PointU..::.Explicit Operator (PointU)
PointU Structure See Also Send Feedback
Converts the specified reporting PointU to a Point.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator Point (
    PointU point
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    point As PointU _
) As Point

Parameters

point
Type: Telerik.Reporting.Drawing..::.PointU
The PointU to convert.

Return Value

The Point that is converted from the specified reporting Point structure.

See Also

PointU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Explicit Operator (PointU)

[image]

Telerik Reporting Q2 2012
PointU..::.Explicit Operator (PointU)
PointU Structure See Also Send Feedback
Converts the specified reporting PointU to a PointF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator PointF (
    PointU point
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    point As PointU _
) As PointF

Parameters

point
Type: Telerik.Reporting.Drawing..::.PointU
The PointU to convert.

Return Value

The PointF that is converted from the specified reporting Point structure.

See Also

PointU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
PointU..::.Inequality Operator
PointU Structure See Also Send Feedback
Determines whether the coordinates of the specified points are not equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    PointU pt1,
    PointU pt2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    pt1 As PointU, _
    pt2 As PointU _
) As Boolean

Parameters

pt1
Type: Telerik.Reporting.Drawing..::.PointU
A PointU to compare.
pt2
Type: Telerik.Reporting.Drawing..::.PointU
A PointU to compare.

Return Value

true to indicate the X and Y values of pt1 and pt2 are not equal; otherwise, false.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Subtraction Operator

[image]

Telerik Reporting Q2 2012
PointU..::.Subtraction Operator
PointU Structure See Also Send Feedback
Translates the PointU by the negative of a specified SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static PointU operator -(
    PointU pt,
    SizeU size
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    pt As PointU, _
    size As SizeU _
) As PointU

Parameters

pt
Type: Telerik.Reporting.Drawing..::.PointU
The PointU to translate.
size
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU that specifies the numbers to subtract from the x- and y-coordinates of the PointU.

Return Value

The translated PointU.

Remarks

The op_Subtraction operator subtracts the Width of the specified size from the x-coordinate of the PointU and the Height from the y-coordinate of the PointU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


PointU Properties

[image] [image]

Telerik Reporting Q2 2012
PointU Properties
PointU Structure See Also Send Feedback

The PointU type exposes the following members.

Properties

Name | Description
IsEmpty | Gets a value indicating whether this PointU is empty.
X | Gets or sets the x-coordinate of this PointU
Y | Gets or sets the y-coordinate of this PointU

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
PointU..::.IsEmpty Property
PointU Structure See Also Send Feedback
Gets a value indicating whether this PointU is empty.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

Field Value

true if both X and Y are equal to zero; otherwise, false.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


X Property

[image]

Telerik Reporting Q2 2012
PointU..::.X Property
PointU Structure See Also Send Feedback
Gets or sets the x-coordinate of this PointU

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit X { get; set; }
Visual Basic (Declaration)
Public Property X As Unit

Field Value

The x-coordinate of this PointU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


Y Property

[image]

Telerik Reporting Q2 2012
PointU..::.Y Property
PointU Structure See Also Send Feedback
Gets or sets the y-coordinate of this PointU

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Unit

Field Value

The y-coordinate of this PointU.

See Also

PointU Structure
Telerik.Reporting.Drawing Namespace


RectangleU Structure

[image]

Telerik Reporting Q2 2012
RectangleU Structure
Members See Also Send Feedback
Stores a set of four Unit-based numbers that represent the location and size of a rectangle.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public struct RectangleU
Visual Basic (Declaration)
Public Structure RectangleU

Remarks

A RectangleU is defined by its width, height, and upper-left corner.

See Also

RectangleU Members
Telerik.Reporting.Drawing Namespace


RectangleU Members

[image] [image]

Telerik Reporting Q2 2012
RectangleU Members
RectangleU Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The RectangleU type exposes the following members.

Constructors

Name | Description
RectangleU | Overloaded.

Methods

Name | Description
Contains | Overloaded.
Equals | Tests whether obj is a RectangleU with the same location and size of this RectangleU. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this RectangleU structure. (Overrides ValueType..::.GetHashCode()()().)
Inflate | Overloaded.
IntersectsWith | Determines if this rectangle intersects with rect.
Offset | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Equality | Tests whether two RectangleU structures have equal location and size.
Explicit | Overloaded.
Inequality | Tests whether two RectangleU structures differ in location or size.

Fields

Name | Description
Empty | Represents an instance of the RectangleU class with its members uninitialized.

Properties

Name | Description
Bottom | Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.
Height | Gets or sets the height of this RectangleU structure.
IsEmpty | Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.
Left | Gets the x-coordinate of the left edge of this RectangleU structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleU structure.
Right | Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.
Size | Gets or sets the size of this RectangleU.
Top | Gets the y-coordinate of the left edge of this RectangleU structure.
Width | Gets or sets the width of this RectangleU structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


RectangleU Constructor

[image] [image]

Telerik Reporting Q2 2012
RectangleU Constructor
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
RectangleU(Rectangle) | Initializes a new instance of the RectangleU class from the specified Rectangle.
RectangleU(RectangleF) | Initializes a new instance of the RectangleU class from the specified RectangleF.
RectangleU(PointU, SizeU) | Initializes a new instance of the RectangleU class with the specified location and size.
RectangleU(Unit, Unit, Unit, Unit) | Initializes a new instance of the RectangleU class with the specified location and size.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


RectangleU Constructor (Rectangle)

[image]

Telerik Reporting Q2 2012
RectangleU Constructor (Rectangle)
RectangleU Structure See Also Send Feedback
Initializes a new instance of the RectangleU class from the specified Rectangle.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU(
    Rectangle rect
)
Visual Basic (Declaration)
Public Sub New ( _
    rect As Rectangle _
)

Parameters

rect
Type: System.Drawing..::.Rectangle
A Rectangle that represents the rectangular region.

See Also

RectangleU Structure
RectangleU Overload
Telerik.Reporting.Drawing Namespace


RectangleU Constructor (RectangleF)

[image]

Telerik Reporting Q2 2012
RectangleU Constructor (RectangleF)
RectangleU Structure See Also Send Feedback
Initializes a new instance of the RectangleU class from the specified RectangleF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU(
    RectangleF rect
)
Visual Basic (Declaration)
Public Sub New ( _
    rect As RectangleF _
)

Parameters

rect
Type: System.Drawing..::.RectangleF
A RectangleF that represents the rectangular region.

See Also

RectangleU Structure
RectangleU Overload
Telerik.Reporting.Drawing Namespace


RectangleU Constructor (PointU, SizeU)

[image]

Telerik Reporting Q2 2012
RectangleU Constructor (PointU, SizeU)
RectangleU Structure See Also Send Feedback
Initializes a new instance of the RectangleU class with the specified location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU(
    PointU location,
    SizeU size
)
Visual Basic (Declaration)
Public Sub New ( _
    location As PointU, _
    size As SizeU _
)

Parameters

location
Type: Telerik.Reporting.Drawing..::.PointU
A PointU that represents the upper-left corner of the rectangular region.
size
Type: Telerik.Reporting.Drawing..::.SizeU
A SizeU that represents the width and height of the rectangular region.

See Also

RectangleU Structure
RectangleU Overload
Telerik.Reporting.Drawing Namespace


RectangleU Constructor (Unit, Unit, Unit, Unit)

[image]

Telerik Reporting Q2 2012
RectangleU Constructor (Unit, Unit, Unit, Unit)
RectangleU Structure See Also Send Feedback
Initializes a new instance of the RectangleU class with the specified location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU(
    Unit x,
    Unit y,
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Unit, _
    y As Unit, _
    width As Unit, _
    height As Unit _
)

Parameters

x
Type: Telerik.Reporting.Drawing..::.Unit
The x-coordinate of the upper-left corner of the rectangle.
y
Type: Telerik.Reporting.Drawing..::.Unit
The y-coordinate of the upper-left corner of the rectangle.
width
Type: Telerik.Reporting.Drawing..::.Unit
The width of the rectangle.
height
Type: Telerik.Reporting.Drawing..::.Unit
The height of the rectangle.

See Also

RectangleU Structure
RectangleU Overload
Telerik.Reporting.Drawing Namespace


RectangleU Fields

[image] [image]

Telerik Reporting Q2 2012
RectangleU Fields
RectangleU Structure See Also Send Feedback

The RectangleU type exposes the following members.

Fields

Name | Description
Empty | Represents an instance of the RectangleU class with its members uninitialized.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
RectangleU..::.Empty Field
RectangleU Structure See Also Send Feedback
Represents an instance of the RectangleU class with its members uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly RectangleU Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As RectangleU

Remarks

The members of the new RectangleU are left uninitialized.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


RectangleU Methods

[image] [image]

Telerik Reporting Q2 2012
RectangleU Methods
RectangleU Structure See Also Send Feedback

The RectangleU type exposes the following members.

Methods

Name | Description
Contains | Overloaded.
Equals | Tests whether obj is a RectangleU with the same location and size of this RectangleU. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this RectangleU structure. (Overrides ValueType..::.GetHashCode()()().)
Inflate | Overloaded.
IntersectsWith | Determines if this rectangle intersects with rect.
Offset | Overloaded.
ToString | Overloaded.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Contains Method

[image] [image]

Telerik Reporting Q2 2012
RectangleU..::.Contains Method
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
Contains(PointU) | Determines if the specified point is contained within this RectangleU structure.
Contains(RectangleU) | Determines if the rectangular region represented by rect is entirely contained within this RectangleU structure.
Contains(Unit, Unit) | Determines if the specified point is contained within this RectangleU structure.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


Contains Method (PointU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Contains Method (PointU)
RectangleU Structure See Also Send Feedback
Determines if the specified point is contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    PointU pt
)
Visual Basic (Declaration)
Public Function Contains ( _
    pt As PointU _
) As Boolean

Parameters

pt
Type: Telerik.Reporting.Drawing..::.PointU
The PointU to test.

Return Value

This method returns true if the point represented by the pt parameter is contained within this RectangleU structure; otherwise false.

See Also

RectangleU Structure
Contains Overload
Telerik.Reporting.Drawing Namespace


Contains Method (RectangleU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Contains Method (RectangleU)
RectangleU Structure See Also Send Feedback
Determines if the rectangular region represented by rect is entirely contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    RectangleU rect
)
Visual Basic (Declaration)
Public Function Contains ( _
    rect As RectangleU _
) As Boolean

Parameters

rect
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleF to test.

Return Value

This method returns true if the rectangular region represented by rect is entirely contained within the rectangular region represented by this RectangleU; otherwise false.

See Also

RectangleU Structure
Contains Overload
Telerik.Reporting.Drawing Namespace


Contains Method (Unit, Unit)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Contains Method (Unit, Unit)
RectangleU Structure See Also Send Feedback
Determines if the specified point is contained within this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Contains(
    Unit x,
    Unit y
)
Visual Basic (Declaration)
Public Function Contains ( _
    x As Unit, _
    y As Unit _
) As Boolean

Parameters

x
Type: Telerik.Reporting.Drawing..::.Unit
The x-coordinate of the point to test.
y
Type: Telerik.Reporting.Drawing..::.Unit
The x-coordinate of the point to test.

Return Value

This method returns true if the point defined by x and y is contained within this RectangleU structure; otherwise false.

See Also

RectangleU Structure
Contains Overload
Telerik.Reporting.Drawing Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
RectangleU..::.Equals Method
RectangleU Structure See Also Send Feedback
Tests whether obj is a RectangleU with the same location and size of this RectangleU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to test.

Return Value

This method returns true if obj is a RectangleU and its X, Y, Width, and Height properties are equal to the corresponding properties of this RectangleU; otherwise, false.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
RectangleU..::.GetHashCode Method
RectangleU Structure See Also Send Feedback
Returns a hash code for this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

An integer value that specifies a hash value for this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Inflate Method

[image] [image]

Telerik Reporting Q2 2012
RectangleU..::.Inflate Method
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
Inflate(SizeU) | Inflates this RectangleU structure by the specified amount.
Inflate(Unit, Unit) | Inflates this RectangleU structure by the specified amount.
Inflate(RectangleU, Unit, Unit) | Inflates rect by the specified amount.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


Inflate Method (SizeU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Inflate Method (SizeU)
RectangleU Structure See Also Send Feedback
Inflates this RectangleU structure by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Inflate(
    SizeU size
)
Visual Basic (Declaration)
Public Sub Inflate ( _
    size As SizeU _
)

Parameters

size
Type: Telerik.Reporting.Drawing..::.SizeU
The amount to inflate this rectangle.

See Also

RectangleU Structure
Inflate Overload
Telerik.Reporting.Drawing Namespace


Inflate Method (Unit, Unit)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Inflate Method (Unit, Unit)
RectangleU Structure See Also Send Feedback
Inflates this RectangleU structure by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Inflate(
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Sub Inflate ( _
    width As Unit, _
    height As Unit _
)

Parameters

width
Type: Telerik.Reporting.Drawing..::.Unit
The amount to inflate this RectangleU structure horizontally.
height
Type: Telerik.Reporting.Drawing..::.Unit
The amount to inflate this RectangleU structure vertically.

See Also

RectangleU Structure
Inflate Overload
Telerik.Reporting.Drawing Namespace


Inflate Method (RectangleU, Unit, Unit)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Inflate Method (RectangleU, Unit, Unit)
RectangleU Structure See Also Send Feedback
Inflates rect by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static RectangleU Inflate(
    RectangleU rect,
    Unit x,
    Unit y
)
Visual Basic (Declaration)
Public Shared Function Inflate ( _
    rect As RectangleU, _
    x As Unit, _
    y As Unit _
) As RectangleU

Parameters

rect
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure to inflate.
x
Type: Telerik.Reporting.Drawing..::.Unit
The amount to inflate this RectangleU structure horizontally.
y
Type: Telerik.Reporting.Drawing..::.Unit
The amount to inflate this RectangleU structure vertically.

Return Value

The inflated RectangleU structure.

See Also

RectangleU Structure
Inflate Overload
Telerik.Reporting.Drawing Namespace


IntersectsWith Method

[image]

Telerik Reporting Q2 2012
RectangleU..::.IntersectsWith Method
RectangleU Structure See Also Send Feedback
Determines if this rectangle intersects with rect.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IntersectsWith(
    RectangleU rect
)
Visual Basic (Declaration)
Public Function IntersectsWith ( _
    rect As RectangleU _
) As Boolean

Parameters

rect
Type: Telerik.Reporting.Drawing..::.RectangleU
The rectangle to test.

Return Value

This method returns true if there is any intersection; otherwise false.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Offset Method

[image] [image]

Telerik Reporting Q2 2012
RectangleU..::.Offset Method
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
Offset(PointU) | Adjusts the location of this rectangle by the specified amount.
Offset(Unit, Unit) | Adjusts the location of this rectangle by the specified amount.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


Offset Method (PointU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Offset Method (PointU)
RectangleU Structure See Also Send Feedback
Adjusts the location of this rectangle by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Offset(
    PointU pos
)
Visual Basic (Declaration)
Public Sub Offset ( _
    pos As PointU _
)

Parameters

pos
Type: Telerik.Reporting.Drawing..::.PointU
The amount to offset the location.

See Also

RectangleU Structure
Offset Overload
Telerik.Reporting.Drawing Namespace


Offset Method (Unit, Unit)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Offset Method (Unit, Unit)
RectangleU Structure See Also Send Feedback
Adjusts the location of this rectangle by the specified amount.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Offset(
    Unit x,
    Unit y
)
Visual Basic (Declaration)
Public Sub Offset ( _
    x As Unit, _
    y As Unit _
)

Parameters

x
Type: Telerik.Reporting.Drawing..::.Unit
The amount to offset the location horizontally.
y
Type: Telerik.Reporting.Drawing..::.Unit
The amount to offset the location vertically.

See Also

RectangleU Structure
Offset Overload
Telerik.Reporting.Drawing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
RectangleU..::.ToString Method
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the Location and Size of this RectangleU to a human-readable string. (Overrides ValueType..::.ToString()()().)
ToString(CultureInfo) | Converts the Location and Size of this RectangleU to a human-readable string.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
RectangleU..::.ToString Method
RectangleU Structure See Also Send Feedback
Converts the Location and Size of this RectangleU to a human-readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation of the rectangle.

See Also

RectangleU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


ToString Method (CultureInfo)

[image]

Telerik Reporting Q2 2012
RectangleU..::.ToString Method (CultureInfo)
RectangleU Structure See Also Send Feedback
Converts the Location and Size of this RectangleU to a human-readable string.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo object according to which to format the string.

Return Value

A human-readable representation of the rectangle.

See Also

RectangleU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


RectangleU Operators

[image] [image]

Telerik Reporting Q2 2012
RectangleU Operators
RectangleU Structure See Also Send Feedback

The RectangleU type exposes the following members.

Operators

Name | Description
Equality | Tests whether two RectangleU structures have equal location and size.
Explicit | Overloaded.
Inequality | Tests whether two RectangleU structures differ in location or size.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
RectangleU..::.Equality Operator
RectangleU Structure See Also Send Feedback
Tests whether two RectangleU structures have equal location and size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    RectangleU rect1,
    RectangleU rect2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    rect1 As RectangleU, _
    rect2 As RectangleU _
) As Boolean

Parameters

rect1
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure that is to the left of the equality operator.
rect2
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure that is to the right of the equality operator.

Return Value

This operator returns true if the two specified RectangleU structures have equal X, Y, Width, and Height properties.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Explicit Method

[image] [image]

Telerik Reporting Q2 2012
RectangleU..::.Explicit Method
RectangleU Structure See Also Send Feedback

Overload List

Name | Description
Explicit(RectangleU) | Converts the specified RectangleU structure to a Rectangle structure.
Explicit(RectangleU) | Converts the specified RectangleU structure to a RectangleF structure.

See Also

RectangleU Structure
RectangleU Members
Telerik.Reporting.Drawing Namespace


Explicit Operator (RectangleU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Explicit Operator (RectangleU)
RectangleU Structure See Also Send Feedback
Converts the specified RectangleU structure to a Rectangle structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator Rectangle (
    RectangleU rect
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    rect As RectangleU _
) As Rectangle

Parameters

rect
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure to convert.

Return Value

The Rectangle structure that is converted from the specified RectangleU structure.

See Also

RectangleU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Explicit Operator (RectangleU)

[image]

Telerik Reporting Q2 2012
RectangleU..::.Explicit Operator (RectangleU)
RectangleU Structure See Also Send Feedback
Converts the specified RectangleU structure to a RectangleF structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator RectangleF (
    RectangleU rect
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    rect As RectangleU _
) As RectangleF

Parameters

rect
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure to convert.

Return Value

The RectangleF structure that is converted from the specified RectangleU structure.

See Also

RectangleU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
RectangleU..::.Inequality Operator
RectangleU Structure See Also Send Feedback
Tests whether two RectangleU structures differ in location or size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    RectangleU rect1,
    RectangleU rect2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    rect1 As RectangleU, _
    rect2 As RectangleU _
) As Boolean

Parameters

rect1
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure that is to the left of the equality operator.
rect2
Type: Telerik.Reporting.Drawing..::.RectangleU
The RectangleU structure that is to the right of the equality operator.

Return Value

This operator returns true if any of the X, Y, Width, or Height properties of the two RectangleU structures are unequal; otherwise false.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


RectangleU Properties

[image] [image]

Telerik Reporting Q2 2012
RectangleU Properties
RectangleU Structure See Also Send Feedback

The RectangleU type exposes the following members.

Properties

Name | Description
Bottom | Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.
Height | Gets or sets the height of this RectangleU structure.
IsEmpty | Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.
Left | Gets the x-coordinate of the left edge of this RectangleU structure.
Location | Gets or sets the coordinates of the upper-left corner of this RectangleU structure.
Right | Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.
Size | Gets or sets the size of this RectangleU.
Top | Gets the y-coordinate of the left edge of this RectangleU structure.
Width | Gets or sets the width of this RectangleU structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Bottom Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Bottom Property
RectangleU Structure See Also Send Feedback
Gets the y-coordinate that is the sum of Y and Height of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Bottom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bottom As Unit

Field Value

The y-coordinate that is the sum of Y and Height of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Height Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Height Property
RectangleU Structure See Also Send Feedback
Gets or sets the height of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

Field Value

The height of this RectangleF structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.IsEmpty Property
RectangleU Structure See Also Send Feedback
Tests whether the X, Y, Width, and Height properties of this RectangleU have a value of zero.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

Field Value

This property returns true if the X, Y, Width, and Height properties of this RectangleU have a value of zero; otherwise, false.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Left Property
RectangleU Structure See Also Send Feedback
Gets the x-coordinate of the left edge of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; }
Visual Basic (Declaration)
Public ReadOnly Property Left As Unit

Field Value

The x-coordinate of the left edge of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Location Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Location Property
RectangleU Structure See Also Send Feedback
Gets or sets the coordinates of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU Location { get; set; }
Visual Basic (Declaration)
Public Property Location As PointU

Field Value

A PointU that represents the upper-left corner of this RectangleF structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Right Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Right Property
RectangleU Structure See Also Send Feedback
Gets the x-coordinate that is the sum of X and Width of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Right { get; }
Visual Basic (Declaration)
Public ReadOnly Property Right As Unit

Field Value

The x-coordinate that is the sum of X and Width of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Size Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Size Property
RectangleU Structure See Also Send Feedback
Gets or sets the size of this RectangleU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU Size { get; set; }
Visual Basic (Declaration)
Public Property Size As SizeU

Field Value

A SizeU that represents the width and height of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Top Property
RectangleU Structure See Also Send Feedback
Gets the y-coordinate of the left edge of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; }
Visual Basic (Declaration)
Public ReadOnly Property Top As Unit

Field Value

The y-coordinate of the left edge of this RectangleU structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Width Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Width Property
RectangleU Structure See Also Send Feedback
Gets or sets the width of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

Field Value

The width of this RectangleF structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


X Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.X Property
RectangleU Structure See Also Send Feedback
Gets or sets the x-coordinate of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit X { get; set; }
Visual Basic (Declaration)
Public Property X As Unit

Field Value

The x-coordinate of the upper-left corner of this RectangleF structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


Y Property

[image]

Telerik Reporting Q2 2012
RectangleU..::.Y Property
RectangleU Structure See Also Send Feedback
Gets or sets the y-coordinate of the upper-left corner of this RectangleU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Unit

Field Value

The y-coordinate of the upper-left corner of this RectangleF structure.

See Also

RectangleU Structure
Telerik.Reporting.Drawing Namespace


SelectorCollection Class

[image]

Telerik Reporting Q2 2012
SelectorCollection Class
Members See Also Send Feedback
Represents a collection of objects that implement ISelector

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class SelectorCollection : Collection<ISelector>
Visual Basic (Declaration)
Public Class SelectorCollection _
    Inherits Collection(Of ISelector)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ISelector >)>)>
Telerik.Reporting.Drawing..::.SelectorCollection

See Also

SelectorCollection Members
Telerik.Reporting.Drawing Namespace


SelectorCollection Members

[image] [image]

Telerik Reporting Q2 2012
SelectorCollection Members
SelectorCollection Class Constructors Methods See Also Send Feedback

The SelectorCollection type exposes the following members.

Constructors

Name | Description
SelectorCollection | Overloaded.

Methods

Name | Description
AddRange | Adds an array of selector objects to the collection.

See Also

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


SelectorCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
SelectorCollection Constructor
SelectorCollection Class See Also Send Feedback

Overload List

Name | Description
SelectorCollection()()() | Initializes a new instance of the SelectorCollection class.
SelectorCollection(array<ISelector>[]()[]) | Initializes a new instance of the SelectorCollection class

See Also

SelectorCollection Class
SelectorCollection Members
Telerik.Reporting.Drawing Namespace


SelectorCollection Constructor

[image]

Telerik Reporting Q2 2012
SelectorCollection Constructor
SelectorCollection Class See Also Send Feedback
Initializes a new instance of the SelectorCollection class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SelectorCollection()
Visual Basic (Declaration)
Public Sub New

See Also

SelectorCollection Class
SelectorCollection Overload
Telerik.Reporting.Drawing Namespace


SelectorCollection Constructor (ISelector[])

[image]

Telerik Reporting Q2 2012
SelectorCollection Constructor (array<ISelector>[]()[][])
SelectorCollection Class See Also Send Feedback
Initializes a new instance of the SelectorCollection class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SelectorCollection(
    ISelector[] selectors
)
Visual Basic (Declaration)
Public Sub New ( _
    selectors As ISelector() _
)

Parameters

selectors
Type: array< Telerik.Reporting.Drawing..::.ISelector >[]()[][]

See Also

SelectorCollection Class
SelectorCollection Overload
Telerik.Reporting.Drawing Namespace


SelectorCollection Methods

[image] [image]

Telerik Reporting Q2 2012
SelectorCollection Methods
SelectorCollection Class See Also Send Feedback

The SelectorCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds an array of selector objects to the collection.

See Also

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
SelectorCollection..::.AddRange Method
SelectorCollection Class See Also Send Feedback
Adds an array of selector objects to the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    ISelector[] selectors
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    selectors As ISelector() _
)

Parameters

selectors
Type: array< Telerik.Reporting.Drawing..::.ISelector >[]()[][]
An array of ISelector objects to add to the collection.

Remarks

The ISelector objects contained in the selectors array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of ISelector objects to the collection instead of manually adding each ISelector to the collection using the [!:Telerik.Reporting.Drawing.SelectorCollection.Add(Telerik.Reporting.Drawing.ISelector)] method.

To remove a ISelector that you previously added, use the [!:Telerik.Reporting.Drawing.SelectorCollection.Remove(Telerik.Reporting.Drawing.ISelector)], RemoveAt(Int32), or Clear()()() methods.

See Also

SelectorCollection Class
Telerik.Reporting.Drawing Namespace


SizeU Structure

[image]

Telerik Reporting Q2 2012
SizeU Structure
Members See Also Send Feedback
Stores an ordered pair of Unit-based numbers, typically the width and height of a rectangle.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public struct SizeU
Visual Basic (Declaration)
Public Structure SizeU

See Also

SizeU Members
Telerik.Reporting.Drawing Namespace


SizeU Members

[image] [image]

Telerik Reporting Q2 2012
SizeU Members
SizeU Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The SizeU type exposes the following members.

Constructors

Name | Description
SizeU | Overloaded.

Methods

Name | Description
Equals | Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this SizeU structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.

Operators

Name | Description
Addition | Adds the width and height of one SizeU structure to the width and height of another SizeU structure.
Equality | Tests whether two SizeU structures are equal.
Explicit | Overloaded.
Inequality | Tests whether two SizeU structures are different.
Subtraction | Subtracts the width and height of one SizeU structure from the width and height of another SizeU structure.

Fields

Name | Description
Empty | Initializes a new instance of the SizeU class.

Properties

Name | Description
Height | Gets or sets the vertical component of this SizeU.
IsEmpty | Gets a value indicating whether this SizeU has zero width and height.
Width | Gets or sets the horizontal component of this SizeU.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


SizeU Constructor

[image] [image]

Telerik Reporting Q2 2012
SizeU Constructor
SizeU Structure See Also Send Feedback

Overload List

Name | Description
SizeU(Size) | Initializes a new instance of the SizeU class from the specified existing Size.
SizeU(SizeF) | Initializes a new instance of the SizeU class from the specified existing SizeF.
SizeU(Unit, Unit) | Initializes a new instance of the SizeU class from the specified dimensions.

See Also

SizeU Structure
SizeU Members
Telerik.Reporting.Drawing Namespace


SizeU Constructor (Size)

[image]

Telerik Reporting Q2 2012
SizeU Constructor (Size)
SizeU Structure See Also Send Feedback
Initializes a new instance of the SizeU class from the specified existing Size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU(
    Size size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As Size _
)

Parameters

size
Type: System.Drawing..::.Size
The Size from which to create the new SizeU.

See Also

SizeU Structure
SizeU Overload
Telerik.Reporting.Drawing Namespace


SizeU Constructor (SizeF)

[image]

Telerik Reporting Q2 2012
SizeU Constructor (SizeF)
SizeU Structure See Also Send Feedback
Initializes a new instance of the SizeU class from the specified existing SizeF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU(
    SizeF size
)
Visual Basic (Declaration)
Public Sub New ( _
    size As SizeF _
)

Parameters

size
Type: System.Drawing..::.SizeF
The SizeF from which to create the new SizeU.

See Also

SizeU Structure
SizeU Overload
Telerik.Reporting.Drawing Namespace


SizeU Constructor (Unit, Unit)

[image]

Telerik Reporting Q2 2012
SizeU Constructor (Unit, Unit)
SizeU Structure See Also Send Feedback
Initializes a new instance of the SizeU class from the specified dimensions.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU(
    Unit width,
    Unit height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Unit, _
    height As Unit _
)

Parameters

width
Type: Telerik.Reporting.Drawing..::.Unit
The width component of the new SizeU.
height
Type: Telerik.Reporting.Drawing..::.Unit
The height component of the new SizeU.

See Also

SizeU Structure
SizeU Overload
Telerik.Reporting.Drawing Namespace


SizeU Fields

[image] [image]

Telerik Reporting Q2 2012
SizeU Fields
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Fields

Name | Description
Empty | Initializes a new instance of the SizeU class.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
SizeU..::.Empty Field
SizeU Structure See Also Send Feedback
Initializes a new instance of the SizeU class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly SizeU Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As SizeU

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


SizeU Methods

[image] [image]

Telerik Reporting Q2 2012
SizeU Methods
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Methods

Name | Description
Equals | Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU. (Overrides ValueType..::.Equals(Object).)
GetHashCode | Returns a hash code for this SizeU structure. (Overrides ValueType..::.GetHashCode()()().)
ToString | Overloaded.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
SizeU..::.Equals Method
SizeU Structure See Also Send Feedback
Tests to see whether the specified object is a SizeU with the same dimensions as this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to test.

Return Value

This method returns true if obj is a SizeU and has the same width and height as this SizeU; otherwise, false.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
SizeU..::.GetHashCode Method
SizeU Structure See Also Send Feedback
Returns a hash code for this SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

An integer value that specifies a hash value for this SizeU structure.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
SizeU..::.ToString Method
SizeU Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Creates a human-readable string that represents this SizeU. (Overrides ValueType..::.ToString()()().)
ToString(CultureInfo) | Creates a human-readable string that represents this SizeU.

See Also

SizeU Structure
SizeU Members
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
SizeU..::.ToString Method
SizeU Structure See Also Send Feedback
Creates a human-readable string that represents this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string that represents this SizeU.

See Also

SizeU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


ToString Method (CultureInfo)

[image]

Telerik Reporting Q2 2012
SizeU..::.ToString Method (CultureInfo)
SizeU Structure See Also Send Feedback
Creates a human-readable string that represents this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo object according to which to format the string.

Return Value

A string that represents this SizeU.

See Also

SizeU Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


SizeU Operators

[image] [image]

Telerik Reporting Q2 2012
SizeU Operators
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Operators

Name | Description
Addition | Adds the width and height of one SizeU structure to the width and height of another SizeU structure.
Equality | Tests whether two SizeU structures are equal.
Explicit | Overloaded.
Inequality | Tests whether two SizeU structures are different.
Subtraction | Subtracts the width and height of one SizeU structure from the width and height of another SizeU structure.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Addition Operator

[image]

Telerik Reporting Q2 2012
SizeU..::.Addition Operator
SizeU Structure See Also Send Feedback
Adds the width and height of one SizeU structure to the width and height of another SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static SizeU operator +(
    SizeU size1,
    SizeU size2
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    size1 As SizeU, _
    size2 As SizeU _
) As SizeU

Parameters

size1
Type: Telerik.Reporting.Drawing..::.SizeU
The first SizeU to add.
size2
Type: Telerik.Reporting.Drawing..::.SizeU
The second SizeU to add.

Return Value

A SizeU structure that is the result of the addition operation.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
SizeU..::.Equality Operator
SizeU Structure See Also Send Feedback
Tests whether two SizeU structures are equal.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    SizeU size1,
    SizeU size2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    size1 As SizeU, _
    size2 As SizeU _
) As Boolean

Parameters

size1
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure on the left side of the equality operator.
size2
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure on the right side of the equality operator.

Return Value

This operator returns true if size1 and size2 have equal width and height; otherwise, false.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Explicit Method

[image] [image]

Telerik Reporting Q2 2012
SizeU..::.Explicit Method
SizeU Structure See Also Send Feedback

Overload List

Name | Description
Explicit(SizeU) | Converts the specified SizeU to a Size.
Explicit(SizeU) | Converts the specified SizeU to a SizeF.

See Also

SizeU Structure
SizeU Members
Telerik.Reporting.Drawing Namespace


Explicit Operator (SizeU)

[image]

Telerik Reporting Q2 2012
SizeU..::.Explicit Operator (SizeU)
SizeU Structure See Also Send Feedback
Converts the specified SizeU to a Size.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator Size (
    SizeU size
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    size As SizeU _
) As Size

Parameters

size
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure to be converted.

Return Value

The Size structure to which this operator converts.

See Also

SizeU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Explicit Operator (SizeU)

[image]

Telerik Reporting Q2 2012
SizeU..::.Explicit Operator (SizeU)
SizeU Structure See Also Send Feedback
Converts the specified SizeU to a SizeF.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static explicit operator SizeF (
    SizeU size
)
Visual Basic (Declaration)
Public Shared Narrowing Operator CType ( _
    size As SizeU _
) As SizeF

Parameters

size
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure to be converted.

Return Value

The SizeF structure to which this operator converts.

See Also

SizeU Structure
Explicit Overload
Telerik.Reporting.Drawing Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
SizeU..::.Inequality Operator
SizeU Structure See Also Send Feedback
Tests whether two SizeU structures are different.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    SizeU size1,
    SizeU size2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    size1 As SizeU, _
    size2 As SizeU _
) As Boolean

Parameters

size1
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure on the left side of the equality operator.
size2
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU structure on the right side of the equality operator.

Return Value

This operator returns true if size1 and size2 differ either in width or height; false if size1 and size2 are equal.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Subtraction Operator

[image]

Telerik Reporting Q2 2012
SizeU..::.Subtraction Operator
SizeU Structure See Also Send Feedback
Subtracts the width and height of one SizeU structure from the width and height of another SizeU structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static SizeU operator -(
    SizeU size1,
    SizeU size2
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    size1 As SizeU, _
    size2 As SizeU _
) As SizeU

Parameters

size1
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU on the left side of the subtraction operator.
size2
Type: Telerik.Reporting.Drawing..::.SizeU
The SizeU on the right side of the subtraction operator.

Return Value

A SizeU structure that is the result of the subtraction operation.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


SizeU Properties

[image] [image]

Telerik Reporting Q2 2012
SizeU Properties
SizeU Structure See Also Send Feedback

The SizeU type exposes the following members.

Properties

Name | Description
Height | Gets or sets the vertical component of this SizeU.
IsEmpty | Gets a value indicating whether this SizeU has zero width and height.
Width | Gets or sets the horizontal component of this SizeU.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Height Property

[image]

Telerik Reporting Q2 2012
SizeU..::.Height Property
SizeU Structure See Also Send Feedback
Gets or sets the vertical component of this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

Field Value

The vertical component of this SizeU.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
SizeU..::.IsEmpty Property
SizeU Structure See Also Send Feedback
Gets a value indicating whether this SizeU has zero width and height.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

Field Value

This property returns true when this SizeU has both a width and height of zero; otherwise, false.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Width Property

[image]

Telerik Reporting Q2 2012
SizeU..::.Width Property
SizeU Structure See Also Send Feedback
Gets or sets the horizontal component of this SizeU.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

Field Value

The horizontal component of this SizeU.

See Also

SizeU Structure
Telerik.Reporting.Drawing Namespace


Style Class

[image]

Telerik Reporting Q2 2012
Style Class
Members See Also Send Feedback
Represents the style of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Style
Visual Basic (Declaration)
Public Class Style

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.Style

See Also

Style Members
Telerik.Reporting.Drawing Namespace


Style Members

[image] [image]

Telerik Reporting Q2 2012
Style Members
Style Class Methods Properties See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
BackgroundColor | Gets or sets the background color of the report item.
BackgroundImage | Gets a BackgroundImage object that controls the image displayed in the background of the report item.
BorderColor | Gets a BorderColor object used to define the border color of a report item.
BorderStyle | Gets a BorderStyle object used to define the border style of a report item.
BorderWidth | Gets a BorderWidth object used to define the border width of a report item.
Color | Gets or sets the foreground color of the report item.
Font | Gets a Font object representing the font of the report item.
LineStyle | Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.
LineWidth | Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.
Padding | Gets a Padding object used to define the padding of a report item.
TextAlign | Gets or sets the horizontal alignment of text in the report item.
VerticalAlign | Gets or sets the vertical alignment of text in the report item.
Visible | Gets or sets a value indicating whether the report item is displayed.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Style Methods

[image] [image]

Telerik Reporting Q2 2012
Style Methods
Style Class See Also Send Feedback

The Style type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

Style Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Style..::.ToString Method
Style Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Style Properties

[image] [image]

Telerik Reporting Q2 2012
Style Properties
Style Class See Also Send Feedback

The Style type exposes the following members.

Properties

Name | Description
BackgroundColor | Gets or sets the background color of the report item.
BackgroundImage | Gets a BackgroundImage object that controls the image displayed in the background of the report item.
BorderColor | Gets a BorderColor object used to define the border color of a report item.
BorderStyle | Gets a BorderStyle object used to define the border style of a report item.
BorderWidth | Gets a BorderWidth object used to define the border width of a report item.
Color | Gets or sets the foreground color of the report item.
Font | Gets a Font object representing the font of the report item.
LineStyle | Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.
LineWidth | Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.
Padding | Gets a Padding object used to define the padding of a report item.
TextAlign | Gets or sets the horizontal alignment of text in the report item.
VerticalAlign | Gets or sets the vertical alignment of text in the report item.
Visible | Gets or sets a value indicating whether the report item is displayed.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


BackgroundColor Property

[image]

Telerik Reporting Q2 2012
Style..::.BackgroundColor Property
Style Class See Also Send Feedback
Gets or sets the background color of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Color

Field Value

A Color that represents the background color of the report item. The default is Empty, which indicates that this property is not set.

Remarks

Use the BackColor property to specify the background color of the report item. This property is set using a Color object.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


BackgroundImage Property

[image]

Telerik Reporting Q2 2012
Style..::.BackgroundImage Property
Style Class See Also Send Feedback
Gets a BackgroundImage object that controls the image displayed in the background of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BackgroundImage BackgroundImage { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackgroundImage As BackgroundImage

Field Value

An BackgroundImage that represents the image to display in the background of the report item. Report items have no background image by default.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


BorderColor Property

[image]

Telerik Reporting Q2 2012
Style..::.BorderColor Property
Style Class See Also Send Feedback
Gets a BorderColor object used to define the border color of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderColor BorderColor { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderColor As BorderColor

Field Value

A BorderColor representing the border color of the report item.

Remarks

You can set the border color of the item by using the properties Default, Left, Right, Top, and Bottom. The Default property is used to set all borders colors at once. All borders are Black by default.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


BorderStyle Property

[image]

Telerik Reporting Q2 2012
Style..::.BorderStyle Property
Style Class See Also Send Feedback
Gets a BorderStyle object used to define the border style of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderStyle BorderStyle { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderStyle As BorderStyle

Field Value

A BorderStyle representing the border style of the report item.

Remarks

You can set the border style of the item by using the properties Default, Left, Right, Top, and Bottom. The Default property is used to set all borders styles at once. All borders are BorderType.None by default.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


BorderWidth Property

[image]

Telerik Reporting Q2 2012
Style..::.BorderWidth Property
Style Class See Also Send Feedback
Gets a BorderWidth object used to define the border width of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BorderWidth BorderWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderWidth As BorderWidth

Field Value

A BorderWidth representing the border width of the report item.

Remarks

You can set the border width of the item by using the properties Default, Left, Right, Top, and Bottom. The Default property is used to set all borders widths at once. All borders are 1pt wide by default.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Color Property

[image]

Telerik Reporting Q2 2012
Style..::.Color Property
Style Class See Also Send Feedback
Gets or sets the foreground color of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color

Field Value

The foreground Color of the report item. The default is Black.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Font Property

[image]

Telerik Reporting Q2 2012
Style..::.Font Property
Style Class See Also Send Feedback
Gets a Font object representing the font of the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Font Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As Font

Field Value

A Font object used to define the font of a report item. By default the font of a report item is Arial-Regular, 10pts.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


LineStyle Property

[image]

Telerik Reporting Q2 2012
Style..::.LineStyle Property
Style Class See Also Send Feedback
Gets or sets a LineStyle object used to define the line style of report items that support it, such as lines and shapes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineStyle LineStyle { get; set; }
Visual Basic (Declaration)
Public Property LineStyle As LineStyle

Field Value

A LineStyle object representing the line style of the report item. By default the line style is LineStyle.Solid.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


LineWidth Property

[image]

Telerik Reporting Q2 2012
Style..::.LineWidth Property
Style Class See Also Send Feedback
Gets or sets a Unit representing the line width of report items that support it, such as lines and shapes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit LineWidth { get; set; }
Visual Basic (Declaration)
Public Property LineWidth As Unit

Field Value

A Unit value representing the line width of the report item. By default the width is 1pt.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Padding Property

[image]

Telerik Reporting Q2 2012
Style..::.Padding Property
Style Class See Also Send Feedback
Gets a Padding object used to define the padding of a report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Padding Padding { get; }
Visual Basic (Declaration)
Public ReadOnly Property Padding As Padding

Field Value

A Padding object representing the padding of the report item.

Remarks

You can set the padding of the item by using the properties Left, Right, Top, and Bottom. Padding on all sides is Zero by default.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


TextAlign Property

[image]

Telerik Reporting Q2 2012
Style..::.TextAlign Property
Style Class See Also Send Feedback
Gets or sets the horizontal alignment of text in the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public HorizontalAlign TextAlign { get; set; }
Visual Basic (Declaration)
Public Property TextAlign As HorizontalAlign

Field Value

One of the HorizontalAlign values. The default is HorizontalAlign.Left.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


VerticalAlign Property

[image]

Telerik Reporting Q2 2012
Style..::.VerticalAlign Property
Style Class See Also Send Feedback
Gets or sets the vertical alignment of text in the report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public VerticalAlign VerticalAlign { get; set; }
Visual Basic (Declaration)
Public Property VerticalAlign As VerticalAlign

Field Value

One of the VerticalAlign values. The default is VerticalAlign.Top.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
Style..::.Visible Property
Style Class See Also Send Feedback
Gets or sets a value indicating whether the report item is displayed.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

Field Value

true if the report item is displayed; otherwise, false. The default is true.

See Also

Style Class
Telerik.Reporting.Drawing Namespace


StyleRule Class

[image]

Telerik Reporting Q2 2012
StyleRule Class
Members See Also Send Feedback
Represents a style rule to be applied.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleRule : ReportObject
Visual Basic (Declaration)
Public Class StyleRule _
    Inherits ReportObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.StyleRule

See Also

StyleRule Members
Telerik.Reporting.Drawing Namespace


StyleRule Members

[image] [image]

Telerik Reporting Q2 2012
StyleRule Members
StyleRule Class Constructors Methods Properties See Also Send Feedback

The StyleRule type exposes the following members.

Constructors

Name | Description
StyleRule | Initializes a new empty StyleRule.

Methods

Name | Description
ToString | Overloaded.

Properties

Name | Description
Selectors | A collection of selectors that determine which report items the style applies to.
Style | The Style to apply to all report items selected by the Selectors

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


StyleRule Constructor

[image]

Telerik Reporting Q2 2012
StyleRule Constructor
StyleRule Class See Also Send Feedback
Initializes a new empty StyleRule.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleRule()
Visual Basic (Declaration)
Public Sub New

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


StyleRule Methods

[image] [image]

Telerik Reporting Q2 2012
StyleRule Methods
StyleRule Class See Also Send Feedback

Methods

Name | Description
ToString | Overloaded.

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
StyleRule..::.ToString Method
StyleRule Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a human-readable representation ot this StyleRule. (Overrides Object..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

StyleRule Class
StyleRule Members
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
StyleRule..::.ToString Method
StyleRule Class See Also Send Feedback
Returns a human-readable representation ot this StyleRule.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this StyleRule.

See Also

StyleRule Class
ToString Overload
Telerik.Reporting.Drawing Namespace


StyleRule Properties

[image] [image]

Telerik Reporting Q2 2012
StyleRule Properties
StyleRule Class See Also Send Feedback

The StyleRule type exposes the following members.

Properties

Name | Description
Selectors | A collection of selectors that determine which report items the style applies to.
Style | The Style to apply to all report items selected by the Selectors

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


Selectors Property

[image]

Telerik Reporting Q2 2012
StyleRule..::.Selectors Property
StyleRule Class See Also Send Feedback
A collection of selectors that determine which report items the style applies to.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SelectorCollection Selectors { get; }
Visual Basic (Declaration)
Public ReadOnly Property Selectors As SelectorCollection

Field Value

A SelectorCollection object containing all of the selectors for this rule.

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


Style Property

[image]

Telerik Reporting Q2 2012
StyleRule..::.Style Property
StyleRule Class See Also Send Feedback
The Style to apply to all report items selected by the Selectors

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As Style

Field Value

A Style object defining the style of this StyleRule

See Also

StyleRule Class
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Class

[image]

Telerik Reporting Q2 2012
StyleRuleCollection Class
Members See Also Send Feedback
Represents a collection of StyleRule objects.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleRuleCollection : Collection<StyleRule>
Visual Basic (Declaration)
Public Class StyleRuleCollection _
    Inherits Collection(Of StyleRule)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' StyleRule >)>)>
Telerik.Reporting.Drawing..::.StyleRuleCollection
Telerik.Reporting.Drawing..::.StyleSheet

See Also

StyleRuleCollection Members
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Members

[image] [image]

Telerik Reporting Q2 2012
StyleRuleCollection Members
StyleRuleCollection Class Constructors Methods See Also Send Feedback

The StyleRuleCollection type exposes the following members.

Constructors

Name | Description
StyleRuleCollection | Overloaded.

Methods

Name | Description
AddRange | Adds an array of style rule objects to the collection.

See Also

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleRuleCollection Constructor
StyleRuleCollection Class See Also Send Feedback

Overload List

Name | Description
StyleRuleCollection()()() | Initializes a new instance of the StyleRuleCollection class.
StyleRuleCollection(array<StyleRule>[]()[]) | Initializes a new instance of the StyleRuleCollection class

See Also

StyleRuleCollection Class
StyleRuleCollection Members
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Constructor

[image]

Telerik Reporting Q2 2012
StyleRuleCollection Constructor
StyleRuleCollection Class See Also Send Feedback
Initializes a new instance of the StyleRuleCollection class.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleRuleCollection()
Visual Basic (Declaration)
Public Sub New

See Also

StyleRuleCollection Class
StyleRuleCollection Overload
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Constructor (StyleRule[])

[image]

Telerik Reporting Q2 2012
StyleRuleCollection Constructor (array<StyleRule>[]()[][])
StyleRuleCollection Class See Also Send Feedback
Initializes a new instance of the StyleRuleCollection class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleRuleCollection(
    StyleRule[] rules
)
Visual Basic (Declaration)
Public Sub New ( _
    rules As StyleRule() _
)

Parameters

rules
Type: array< Telerik.Reporting.Drawing..::.StyleRule >[]()[][]

See Also

StyleRuleCollection Class
StyleRuleCollection Overload
Telerik.Reporting.Drawing Namespace


StyleRuleCollection Methods

[image] [image]

Telerik Reporting Q2 2012
StyleRuleCollection Methods
StyleRuleCollection Class See Also Send Feedback

The StyleRuleCollection type exposes the following members.

Methods

Name | Description
AddRange | Adds an array of style rule objects to the collection.

See Also

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
StyleRuleCollection..::.AddRange Method
StyleRuleCollection Class See Also Send Feedback
Adds an array of style rule objects to the collection.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    StyleRule[] rules
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    rules As StyleRule() _
)

Parameters

rules
Type: array< Telerik.Reporting.Drawing..::.StyleRule >[]()[][]
An array of StyleRule objects to add to the collection.

Remarks

The StyleRule objects contained in the rules array are appended to the end of the collection.

You can use the AddRange method to quickly add a group of StyleRule objects to the collection instead of manually adding each StyleRule to the collection using the [!:Telerik.Reporting.Drawing.StyleRuleCollection.Add(Telerik.Reporting.Drawing.StyleRule)] method.

To remove a StyleRule that you previously added, use the [!:Telerik.Reporting.Drawing.StyleRuleCollection.Remove(Telerik.Reporting.Drawing.StyleRule)], RemoveAt(Int32), or Clear()()() methods.

See Also

StyleRuleCollection Class
Telerik.Reporting.Drawing Namespace


StyleSelector Class

[image]

Telerik Reporting Q2 2012
StyleSelector Class
Members See Also Send Feedback
An attribute selector based on the style name property.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSelector : AttributeSelectorBase
Visual Basic (Declaration)
Public Class StyleSelector _
    Inherits AttributeSelectorBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.TypeSelector
Telerik.Reporting.Drawing..::.AttributeSelectorBase
Telerik.Reporting.Drawing..::.StyleSelector

See Also

StyleSelector Members
Telerik.Reporting.Drawing Namespace


StyleSelector Members

[image] [image]

Telerik Reporting Q2 2012
StyleSelector Members
StyleSelector Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The StyleSelector type exposes the following members.

Constructors

Name | Description
StyleSelector | Overloaded.

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase.)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase.)
OnTypeChange | Called when the Type of this selector changes. (Inherited from TypeSelector.)
ToString | Returns a human-readable representation of this StyleSelector. (Overrides TypeSelector..::.ToString()()().)

Fields

Name | Description
attributeName | The name of the property to match. (Inherited from AttributeSelectorBase.)
attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase.)
descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase.)
initialized | (Inherited from TypeSelector.)

Properties

Name | Description
StyleName | Gets or sets the name of the style that this selector matches.
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSelector Constructor

[image] [image]

Telerik Reporting Q2 2012
StyleSelector Constructor
StyleSelector Class See Also Send Feedback

Overload List

Name | Description
StyleSelector()()() | Initializes a new StyleSelector.
StyleSelector(String) | Initializes a new StyleSelector with the specified style name.
StyleSelector(Type, String) | Initializes a new StyleSelector with the specified style name, that matches items of the specified Type

See Also

StyleSelector Class
StyleSelector Members
Telerik.Reporting.Drawing Namespace


StyleSelector Constructor

[image]

Telerik Reporting Q2 2012
StyleSelector Constructor
StyleSelector Class See Also Send Feedback
Initializes a new StyleSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSelector Class
StyleSelector Overload
Telerik.Reporting.Drawing Namespace


StyleSelector Constructor (String)

[image]

Telerik Reporting Q2 2012
StyleSelector Constructor (String)
StyleSelector Class See Also Send Feedback
Initializes a new StyleSelector with the specified style name.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSelector(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String
A string value specifying the style name to match.

See Also

StyleSelector Class
StyleSelector Overload
Telerik.Reporting.Drawing Namespace


StyleSelector Constructor (Type, String)

[image]

Telerik Reporting Q2 2012
StyleSelector Constructor (Type, String)
StyleSelector Class See Also Send Feedback
Initializes a new StyleSelector with the specified style name, that matches items of the specified Type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSelector(
    Type type,
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type, _
    name As String _
)

Parameters

type
Type: System..::.Type
The Type of items to match.
name
Type: System..::.String
A string value specifying the style name to match.

See Also

StyleSelector Class
StyleSelector Overload
Telerik.Reporting.Drawing Namespace


StyleSelector Fields

[image] [image]

Telerik Reporting Q2 2012
StyleSelector Fields
StyleSelector Class See Also Send Feedback

The StyleSelector type exposes the following members.

Fields

Name | Description
attributeName | The name of the property to match. (Inherited from AttributeSelectorBase.)
attributeValue | The value of the property to match. (Inherited from AttributeSelectorBase.)
descriptor | The property descriptor associated with the property that this selector matches. (Inherited from AttributeSelectorBase.)
initialized | (Inherited from TypeSelector.)

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSelector Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSelector Methods
StyleSelector Class See Also Send Feedback

The StyleSelector type exposes the following members.

Methods

Name | Description
CopyTo | Copies the property name and value of the selector to the target typeSelector. (Inherited from AttributeSelectorBase.)
DeepClone | Performs a deep clone of the TypeSelector. (Inherited from TypeSelector.)
Match | Matches a report item by the value of its property. (Inherited from AttributeSelectorBase.)
OnTypeChange | Called when the Type of this selector changes. (Inherited from TypeSelector.)
ToString | Returns a human-readable representation of this StyleSelector. (Overrides TypeSelector..::.ToString()()().)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit | (Inherited from TypeSelector.)
ISupportInitialize..::.EndInit | (Inherited from TypeSelector.)

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
StyleSelector..::.ToString Method
StyleSelector Class See Also Send Feedback
Returns a human-readable representation of this StyleSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation of this StyleSelector.

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSelector Properties

[image] [image]

Telerik Reporting Q2 2012
StyleSelector Properties
StyleSelector Class See Also Send Feedback

The StyleSelector type exposes the following members.

Properties

Name | Description
StyleName | Gets or sets the name of the style that this selector matches.
Type | Gets or sets the Type that this selector matches. (Inherited from TypeSelector.)

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleName Property

[image]

Telerik Reporting Q2 2012
StyleSelector..::.StyleName Property
StyleSelector Class See Also Send Feedback
Gets or sets the name of the style that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string StyleName { get; set; }
Visual Basic (Declaration)
Public Property StyleName As String

Field Value

A string value representing the style name to match.

See Also

StyleSelector Class
Telerik.Reporting.Drawing Namespace


StyleSheet Class

[image]

Telerik Reporting Q2 2012
StyleSheet Class
Members See Also Send Feedback
Represents a collection of styles for a ReportItemBase

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class StyleSheet : StyleRuleCollection
Visual Basic (Declaration)
Public Class StyleSheet _
    Inherits StyleRuleCollection

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' StyleRule >)>)>
Telerik.Reporting.Drawing..::.StyleRuleCollection
Telerik.Reporting.Drawing..::.StyleSheet

See Also

StyleSheet Members
Telerik.Reporting.Drawing Namespace


StyleSheet Members

[image] [image]

Telerik Reporting Q2 2012
StyleSheet Members
StyleSheet Class Constructors Methods See Also Send Feedback

The StyleSheet type exposes the following members.

Constructors

Name | Description
StyleSheet | Initializes a new instance of the StyleSheet class

Methods

Name | Description
AddRange | Adds an array of style rule objects to the collection. (Inherited from StyleRuleCollection.)
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
OnChanged |
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


StyleSheet Constructor

[image]

Telerik Reporting Q2 2012
StyleSheet Constructor
StyleSheet Class See Also Send Feedback
Initializes a new instance of the StyleSheet class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StyleSheet()
Visual Basic (Declaration)
Public Sub New

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


StyleSheet Methods

[image] [image]

Telerik Reporting Q2 2012
StyleSheet Methods
StyleSheet Class See Also Send Feedback

The StyleSheet type exposes the following members.

Methods

Name | Description
AddRange | Adds an array of style rule objects to the collection. (Inherited from StyleRuleCollection.)
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
OnChanged |
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
StyleSheet..::.ClearItems Method
StyleSheet Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
StyleSheet..::.InsertItem Method
StyleSheet Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    StyleRule item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As StyleRule _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting.Drawing..::.StyleRule

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


OnChanged Method

[image]

Telerik Reporting Q2 2012
StyleSheet..::.OnChanged Method
StyleSheet Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


RemoveItem Method

[image]

Telerik Reporting Q2 2012
StyleSheet..::.RemoveItem Method
StyleSheet Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


SetItem Method

[image]

Telerik Reporting Q2 2012
StyleSheet..::.SetItem Method
StyleSheet Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void SetItem(
    int index,
    StyleRule item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As StyleRule _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.Reporting.Drawing..::.StyleRule

See Also

StyleSheet Class
Telerik.Reporting.Drawing Namespace


TextWatermark Class

[image]

Telerik Reporting Q2 2012
TextWatermark Class
Members See Also Send Feedback
Represents a text watermark on a printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextWatermark : Watermark,
    ICloneable
Visual Basic (Declaration)
Public Class TextWatermark _
    Inherits Watermark _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.Watermark
Telerik.Reporting.Drawing..::.TextWatermark

See Also

TextWatermark Members
Telerik.Reporting.Drawing Namespace


TextWatermark Members

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Members
TextWatermark Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextWatermark type exposes the following members.

Constructors

Name | Description
TextWatermark | Initializes a new instance of the TextWatermark class

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Properties

Name | Description
Color | Gets or sets the color of the watermark text.
Font | Gets the font settings of the watermark text.
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page. (Inherited from Watermark.)
Orientation | Gets or sets the orientation of the watermark text on the printable page.
Position | Gets or sets the position of the watermark relative to the other items on the printable page. (Inherited from Watermark.)
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report. (Inherited from Watermark.)
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report. (Inherited from Watermark.)
Text | Gets or sets the text of the watermark to be printed on the page.

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


TextWatermark Constructor

[image]

Telerik Reporting Q2 2012
TextWatermark Constructor
TextWatermark Class See Also Send Feedback
Initializes a new instance of the TextWatermark class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TextWatermark()
Visual Basic (Declaration)
Public Sub New

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


TextWatermark Methods

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Methods
TextWatermark Class See Also Send Feedback

The TextWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


ICloneable.Clone Method

[image]

Telerik Reporting Q2 2012
TextWatermark..::.ICloneable..::.Clone Method
TextWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICloneable.Clone()
Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone

Implements

ICloneable..::.Clone()()()

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


TextWatermark Properties

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Properties
TextWatermark Class See Also Send Feedback

The TextWatermark type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color of the watermark text.
Font | Gets the font settings of the watermark text.
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page. (Inherited from Watermark.)
Orientation | Gets or sets the orientation of the watermark text on the printable page.
Position | Gets or sets the position of the watermark relative to the other items on the printable page. (Inherited from Watermark.)
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report. (Inherited from Watermark.)
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report. (Inherited from Watermark.)
Text | Gets or sets the text of the watermark to be printed on the page.

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Color Property
TextWatermark Class See Also Send Feedback
Gets or sets the color of the watermark text.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color

Field Value

A Color value that specifies the color of the watermark text without the transparency.

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


Font Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Font Property
TextWatermark Class See Also Send Feedback
Gets the font settings of the watermark text.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Font Font { get; private set; }
Visual Basic (Declaration)
Public Property Font As Font

Field Value

A Font value that specifies the font settings of the watermark text.

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


Orientation Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Orientation Property
TextWatermark Class See Also Send Feedback
Gets or sets the orientation of the watermark text on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As WatermarkOrientation

Field Value

A WatermarkOrientation value that specifies the orientation of the watermark text on the printable page.

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Text Property
TextWatermark Class Example See Also Send Feedback
Gets or sets the text of the watermark to be printed on the page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

Field Value

The text of the watermark to be printed on the page.

Remarks

The text can be specified either directly as a string literal or indirectly as an expression that is evaluated at runtime for each printable page. If the text is null (Nothing in Visual Basic) or an empty string, or if the specified expression evaluates to null (Nothing in Visual Basic) or an empty string, the watermark is not printed on the current page.

Examples

The following expression prints a watermark on every second page:
CopyC#
= IIf(PageNumber % 2 = 0, "Watermark", Null)

See Also

TextWatermark Class
Telerik.Reporting.Drawing Namespace


TypeSelector Class

[image]

Telerik Reporting Q2 2012
TypeSelector Class
Members See Also Send Feedback
Represents a selector base on a Type

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TypeSelector : ISelector,
    ISupportInitialize
Visual Basic (Declaration)
Public Class TypeSelector _
    Implements ISelector, ISupportInitialize

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing..::.TypeSelector
Telerik.Reporting.Drawing..::.AttributeSelectorBase

See Also

TypeSelector Members
Telerik.Reporting.Drawing Namespace


TypeSelector Members

[image] [image]

Telerik Reporting Q2 2012
TypeSelector Members
TypeSelector Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The TypeSelector type exposes the following members.

Constructors

Name | Description
TypeSelector | Overloaded.

Methods

Name | Description
CopyTo | Copies this TypeSelector to the specified typeSelector.
DeepClone | Performs a deep clone of the TypeSelector.
Lookup |
Match | Matches a ReportItemBase based on its type.
OnTypeChange | Called when the Type of this selector changes.
ToString | Creates a human-readable string that represents this TypeSelector. (Overrides Object..::.ToString()()().)

Fields

Name | Description
AnyType | Initializes a new type that matches any type of report item.
initialized |

Properties

Name | Description
Type | Gets or sets the Type that this selector matches.

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit |
ISupportInitialize..::.EndInit |

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


TypeSelector Constructor

[image] [image]

Telerik Reporting Q2 2012
TypeSelector Constructor
TypeSelector Class See Also Send Feedback

Overload List

Name | Description
TypeSelector()()() | Initializes a new instance of the TypeSelector class that matches any type of report item.
TypeSelector(Type) | Initializes a new instance of the TypeSelector class that matches items of the specified type.

See Also

TypeSelector Class
TypeSelector Members
Telerik.Reporting.Drawing Namespace


TypeSelector Constructor

[image]

Telerik Reporting Q2 2012
TypeSelector Constructor
TypeSelector Class See Also Send Feedback
Initializes a new instance of the TypeSelector class that matches any type of report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TypeSelector()
Visual Basic (Declaration)
Public Sub New

See Also

TypeSelector Class
TypeSelector Overload
Telerik.Reporting.Drawing Namespace


TypeSelector Constructor (Type)

[image]

Telerik Reporting Q2 2012
TypeSelector Constructor (Type)
TypeSelector Class See Also Send Feedback
Initializes a new instance of the TypeSelector class that matches items of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public TypeSelector(
    Type type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As Type _
)

Parameters

type
Type: System..::.Type
The Type that this selector matches.

See Also

TypeSelector Class
TypeSelector Overload
Telerik.Reporting.Drawing Namespace


TypeSelector Fields

[image] [image]

Telerik Reporting Q2 2012
TypeSelector Fields
TypeSelector Class See Also Send Feedback

The TypeSelector type exposes the following members.

Fields

Name | Description
AnyType | Initializes a new type that matches any type of report item.
initialized |

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


AnyType Field

[image]

Telerik Reporting Q2 2012
TypeSelector..::.AnyType Field
TypeSelector Class See Also Send Feedback
Initializes a new type that matches any type of report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly Type AnyType
Visual Basic (Declaration)
Public Shared ReadOnly AnyType As Type

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


initialized Field

[image]

Telerik Reporting Q2 2012
TypeSelector..::.initialized Field
TypeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected bool initialized
Visual Basic (Declaration)
Protected initialized As Boolean

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


TypeSelector Methods

[image] [image]

Telerik Reporting Q2 2012
TypeSelector Methods
TypeSelector Class See Also Send Feedback

The TypeSelector type exposes the following members.

Methods

Name | Description
CopyTo | Copies this TypeSelector to the specified typeSelector.
DeepClone | Performs a deep clone of the TypeSelector.
Lookup |
Match | Matches a ReportItemBase based on its type.
OnTypeChange | Called when the Type of this selector changes.
ToString | Creates a human-readable string that represents this TypeSelector. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
ISupportInitialize..::.BeginInit |
ISupportInitialize..::.EndInit |

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


ISupportInitialize.BeginInit Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.ISupportInitialize..::.BeginInit Method
TypeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ISupportInitialize.BeginInit()
Visual Basic (Declaration)
Private Sub BeginInit Implements ISupportInitialize.BeginInit

Implements

ISupportInitialize..::.BeginInit()()()

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


ISupportInitialize.EndInit Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.ISupportInitialize..::.EndInit Method
TypeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void ISupportInitialize.EndInit()
Visual Basic (Declaration)
Private Sub EndInit Implements ISupportInitialize.EndInit

Implements

ISupportInitialize..::.EndInit()()()

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


CopyTo Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.CopyTo Method
TypeSelector Class See Also Send Feedback
Copies this TypeSelector to the specified typeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void CopyTo(
    TypeSelector typeSelector
)
Visual Basic (Declaration)
Protected Overridable Sub CopyTo ( _
    typeSelector As TypeSelector _
)

Parameters

typeSelector
Type: Telerik.Reporting.Drawing..::.TypeSelector
The TypeSelector to copy to.

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


DeepClone Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.DeepClone Method
TypeSelector Class See Also Send Feedback
Performs a deep clone of the TypeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual ISelector DeepClone()
Visual Basic (Declaration)
Public Overridable Function DeepClone As ISelector

Return Value

The cloned TypeSelector

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


Lookup Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.Lookup Method
TypeSelector Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Type Lookup(
    string name
)
Visual Basic (Declaration)
Public Shared Function Lookup ( _
    name As String _
) As Type

Parameters

name
Type: System..::.String

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


Match Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.Match Method
TypeSelector Class See Also Send Feedback
Matches a ReportItemBase based on its type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual bool Match(
    ReportItemBase item
)
Visual Basic (Declaration)
Public Overridable Function Match ( _
    item As ReportItemBase _
) As Boolean

Parameters

item
Type: Telerik.Reporting..::.ReportItemBase
The ReportItemBase to match.

Return Value

true if item matches; otherwise false.

Implements

ISelector..::.Match(ReportItemBase)

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


OnTypeChange Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.OnTypeChange Method
TypeSelector Class See Also Send Feedback
Called when the Type of this selector changes.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnTypeChange()
Visual Basic (Declaration)
Protected Overridable Sub OnTypeChange

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TypeSelector..::.ToString Method
TypeSelector Class See Also Send Feedback
Creates a human-readable string that represents this TypeSelector.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A string that represents this TypeSelector.

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


TypeSelector Properties

[image] [image]

Telerik Reporting Q2 2012
TypeSelector Properties
TypeSelector Class See Also Send Feedback

The TypeSelector type exposes the following members.

Properties

Name | Description
Type | Gets or sets the Type that this selector matches.

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


Type Property

[image]

Telerik Reporting Q2 2012
TypeSelector..::.Type Property
TypeSelector Class See Also Send Feedback
Gets or sets the Type that this selector matches.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Type Type { get; set; }
Visual Basic (Declaration)
Public Property Type As Type

Field Value

A Type value to match.

See Also

TypeSelector Class
Telerik.Reporting.Drawing Namespace


Unit Structure

[image]

Telerik Reporting Q2 2012
Unit Structure
Members See Also Send Feedback
A structure representing a unit of measure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public struct Unit : IComparable, IComparable<Unit>
Visual Basic (Declaration)
<SerializableAttribute> _
Public Structure Unit _
    Implements IComparable, IComparable(Of Unit)

See Also

Unit Members
Telerik.Reporting.Drawing Namespace


Unit Members

[image] [image]

Telerik Reporting Q2 2012
Unit Members
Unit Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The Unit type exposes the following members.

Constructors

Name | Description
Unit | Overloaded.

Methods

Name | Description
Add | Overloaded.
Cm | Overloaded.
CompareTo | Overloaded.
Divide | Overloaded.
Equals | Tests whether obj is a Unit that equals this Unit. (Overrides ValueType..::.Equals(Object).)
FromPixels |
GetHashCode | Returns a hash code for this Unit structure. (Overrides ValueType..::.GetHashCode()()().)
Inch | Overloaded.
Max | Returns the larger of two units.
Min | Returns the smaller of two units.
Mm | Overloaded.
Multiply | Multiplies this Unit by a specified value.
Pica | Overloaded.
Pixel | Overloaded.
Point | Overloaded.
Subtract | Overloaded.
ToString | Overloaded.

Operators

Name | Description
Addition | Adds one Unit to another.
Division | Overloaded.
Equality | Compares two units.
GreaterThan | Compares two units.
GreaterThanOrEqual | Compares two units.
Inequality | Compares two units.
LessThan | Compares two units.
LessThanOrEqual | Compares two units.
Multiply | Overloaded.
Subtraction | Subtract one Unit from another.
UnaryNegation | Unary minus. Reverses the sign of Unit

Fields

Name | Description
Empty | Initializes a new instance of the Unit structure.
Zero | Initializes a new instance of the Unit structure equal to zero.

Properties

Name | Description
DefaultType | Gets or sets a UnitType representing the default units of measure for a Report.
DotsPerInch | Gets a double value representing the dpi of the current graphics context.
IsEmpty | Specifies whether this Unit structure is uninitialized.
Type | Gets the type of the Unit.
Value | Gets the magnitude of this Unit.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Unit Constructor

[image] [image]

Telerik Reporting Q2 2012
Unit Constructor
Unit Structure See Also Send Feedback

Overload List

Name | Description
Unit(Double) | Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType
Unit(String) | Initializes a new instance of the Unit structure from the specified string value.
Unit(Double, UnitType) | Initializes a new instance of the Unit structure with the specified value and type.
Unit(String, CultureInfo) | Initializes a new instance of the Unit structure from the specified string value and using the specified CultureInfo.
Unit(String, CultureInfo, UnitType) | Initializes a new instance of the Unit structure from the specified string value, culture, and type.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Unit Constructor (Double)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Double)
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure from the specified pixels. The Unit's type is DefaultType

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    double pixels
)
Visual Basic (Declaration)
Public Sub New ( _
    pixels As Double _
)

Parameters

pixels
Type: System..::.Double
A double value specifying the magnitude of the Unit in pixels.

See Also

Unit Structure
Unit Overload
Telerik.Reporting.Drawing Namespace


Unit Constructor (String)

[image]

Telerik Reporting Q2 2012
Unit Constructor (String)
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure from the specified string value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)

Parameters

value
Type: System..::.String
A string value representing the magnitude and type of the Unit.

Remarks

Parameters passed to this constructor should be of the form "2px", "3.4in", "4cm", "2mm", "12.5pt", "4pc", etc. For more information on string representations of units see UnitType.

See Also

Unit Structure
Unit Overload
Telerik.Reporting.Drawing Namespace


Unit Constructor (Double, UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (Double, UnitType)
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure with the specified value and type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    double value,
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Double, _
    type As UnitType _
)

Parameters

value
Type: System..::.Double
A double value representing the magnitude of the Unit.
type
Type: Telerik.Reporting.Drawing..::.UnitType
A UnitType specifying the type of the Unit.

See Also

Unit Structure
Unit Overload
Telerik.Reporting.Drawing Namespace


Unit Constructor (String, CultureInfo)

[image]

Telerik Reporting Q2 2012
Unit Constructor (String, CultureInfo)
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure from the specified string value and using the specified CultureInfo.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    string value,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String, _
    culture As CultureInfo _
)

Parameters

value
Type: System..::.String
A string value representing the magnitude and type of the Unit.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.

Remarks

The culture parameters is used to parse the string value.

See Also

Unit Structure
Unit Overload
Telerik.Reporting.Drawing Namespace


Unit Constructor (String, CultureInfo, UnitType)

[image]

Telerik Reporting Q2 2012
Unit Constructor (String, CultureInfo, UnitType)
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure from the specified string value, culture, and type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit(
    string value,
    CultureInfo culture,
    UnitType type
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String, _
    culture As CultureInfo, _
    type As UnitType _
)

Parameters

value
Type: System..::.String
A string value representing the magnitude of the Unit.
culture
Type: System.Globalization..::.CultureInfo
A CultureInfo. If a null reference (Nothing in Visual Basic) is passed, the current culture is assumed.
type
Type: Telerik.Reporting.Drawing..::.UnitType
A UnitType specifying the type of the Unit.

See Also

Unit Structure
Unit Overload
Telerik.Reporting.Drawing Namespace


Unit Fields

[image] [image]

Telerik Reporting Q2 2012
Unit Fields
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Fields

Name | Description
Empty | Initializes a new instance of the Unit structure.
Zero | Initializes a new instance of the Unit structure equal to zero.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Empty Field

[image]

Telerik Reporting Q2 2012
Unit..::.Empty Field
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly Unit Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As Unit

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Zero Field

[image]

Telerik Reporting Q2 2012
Unit..::.Zero Field
Unit Structure See Also Send Feedback
Initializes a new instance of the Unit structure equal to zero.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static readonly Unit Zero
Visual Basic (Declaration)
Public Shared ReadOnly Zero As Unit

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Unit Methods

[image] [image]

Telerik Reporting Q2 2012
Unit Methods
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Cm | Overloaded.
CompareTo | Overloaded.
Divide | Overloaded.
Equals | Tests whether obj is a Unit that equals this Unit. (Overrides ValueType..::.Equals(Object).)
FromPixels |
GetHashCode | Returns a hash code for this Unit structure. (Overrides ValueType..::.GetHashCode()()().)
Inch | Overloaded.
Max | Returns the larger of two units.
Min | Returns the smaller of two units.
Mm | Overloaded.
Multiply | Multiplies this Unit by a specified value.
Pica | Overloaded.
Pixel | Overloaded.
Point | Overloaded.
Subtract | Overloaded.
ToString | Overloaded.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Add Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Add Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Add(Unit) | Adds a unit to this Unit.
Add(Unit, Unit, UnitType) | Returns a Unit that is the sum of two units and is of the specified type.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Add Method (Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.Add Method (Unit)
Unit Structure See Also Send Feedback
Adds a unit to this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Add(
    Unit unit1
)
Visual Basic (Declaration)
Public Function Add ( _
    unit1 As Unit _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to add.

Return Value

The sum of unit1 and this Unit in this Unit's type.

See Also

Unit Structure
Add Overload
Telerik.Reporting.Drawing Namespace


Add Method (Unit, Unit, UnitType)

[image]

Telerik Reporting Q2 2012
Unit..::.Add Method (Unit, Unit, UnitType)
Unit Structure See Also Send Feedback
Returns a Unit that is the sum of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Add(
    Unit unit1,
    Unit unit2,
    UnitType type
)
Visual Basic (Declaration)
Public Shared Function Add ( _
    unit1 As Unit, _
    unit2 As Unit, _
    type As UnitType _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first Unit.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second Unit.
type
Type: Telerik.Reporting.Drawing..::.UnitType
A UnitType specifying the type of the resultant unit.

Return Value

The sum of the two units.

See Also

Unit Structure
Add Overload
Telerik.Reporting.Drawing Namespace


Cm Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Cm Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Cm(Double) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.
Cm(Int32) | Creates a new Unit of type UnitType.Cm and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Cm Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Cm Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Cm(
    double value
)
Visual Basic (Declaration)
Public Shared Function Cm ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Cm Overload
Telerik.Reporting.Drawing Namespace


Cm Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Cm Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Cm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Cm(
    int value
)
Visual Basic (Declaration)
Public Shared Function Cm ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Cm Overload
Telerik.Reporting.Drawing Namespace


CompareTo Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.CompareTo Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
CompareTo(Object) |
CompareTo(Unit) |

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


CompareTo Method (Object)

[image]

Telerik Reporting Q2 2012
Unit..::.CompareTo Method (Object)
Unit Structure See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CompareTo(
    Object value
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    value As Object _
) As Integer

Parameters

value
Type: System..::.Object

Implements

IComparable..::.CompareTo(Object)

See Also

Unit Structure
CompareTo Overload
Telerik.Reporting.Drawing Namespace


CompareTo Method (Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.CompareTo Method (Unit)
Unit Structure See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int CompareTo(
    Unit value
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    value As Unit _
) As Integer

Parameters

value
Type: Telerik.Reporting.Drawing..::.Unit

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

See Also

Unit Structure
CompareTo Overload
Telerik.Reporting.Drawing Namespace


Divide Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Divide Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Divide(Double) | Divides this Unit by a specified value.
Divide(Unit) | Divides this Unit by another.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Divide Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Divide Method (Double)
Unit Structure See Also Send Feedback
Divides this Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Divide(
    double value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value to divide by.

Return Value

The quotient resulting by dividing this Unit by the specified value.

See Also

Unit Structure
Divide Overload
Telerik.Reporting.Drawing Namespace


Divide Method (Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.Divide Method (Unit)
Unit Structure See Also Send Feedback
Divides this Unit by another.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float Divide(
    Unit value
)
Visual Basic (Declaration)
Public Function Divide ( _
    value As Unit _
) As Single

Parameters

value
Type: Telerik.Reporting.Drawing..::.Unit
A Unit value to divide by.

Return Value

The quotient resulting by dividing this Unit by the specified Unit.

See Also

Unit Structure
Divide Overload
Telerik.Reporting.Drawing Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
Unit..::.Equals Method
Unit Structure See Also Send Feedback
Tests whether obj is a Unit that equals this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
The Object to test.

Return Value

This method returns true if obj is a Unit and its magnitude is equal to this Unit's magnitude; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


FromPixels Method

[image]

Telerik Reporting Q2 2012
Unit..::.FromPixels Method
Unit Structure See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit FromPixels(
    double pixels,
    UnitType type
)
Visual Basic (Declaration)
Public Shared Function FromPixels ( _
    pixels As Double, _
    type As UnitType _
) As Unit

Parameters

pixels
Type: System..::.Double
type
Type: Telerik.Reporting.Drawing..::.UnitType

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
Unit..::.GetHashCode Method
Unit Structure See Also Send Feedback
Returns a hash code for this Unit structure.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

An integer value that specifies a hash value for this Unit structure.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Inch Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Inch Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Inch(Double) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.
Inch(Int32) | Creates a new Unit of type UnitType.Inch and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Inch Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Inch Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Inch(
    double value
)
Visual Basic (Declaration)
Public Shared Function Inch ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Inch Overload
Telerik.Reporting.Drawing Namespace


Inch Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Inch Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Inch and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Inch(
    int value
)
Visual Basic (Declaration)
Public Shared Function Inch ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Inch Overload
Telerik.Reporting.Drawing Namespace


Max Method

[image]

Telerik Reporting Q2 2012
Unit..::.Max Method
Unit Structure See Also Send Feedback
Returns the larger of two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Max(
    Unit val1,
    Unit val2
)
Visual Basic (Declaration)
Public Shared Function Max ( _
    val1 As Unit, _
    val2 As Unit _
) As Unit

Parameters

val1
Type: Telerik.Reporting.Drawing..::.Unit
The first of two units to compare.
val2
Type: Telerik.Reporting.Drawing..::.Unit
The second of two units to compare.

Return Value

Parameter val1 or val2, whichever is larger.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Min Method

[image]

Telerik Reporting Q2 2012
Unit..::.Min Method
Unit Structure See Also Send Feedback
Returns the smaller of two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Min(
    Unit val1,
    Unit val2
)
Visual Basic (Declaration)
Public Shared Function Min ( _
    val1 As Unit, _
    val2 As Unit _
) As Unit

Parameters

val1
Type: Telerik.Reporting.Drawing..::.Unit
The first of two units to compare.
val2
Type: Telerik.Reporting.Drawing..::.Unit
The second of two units to compare.

Return Value

Parameter val1 or val2, whichever is smaller.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Mm Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Mm Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Mm(Double) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.
Mm(Int32) | Creates a new Unit of type UnitType.Mm and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Mm Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Mm Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Mm(
    double value
)
Visual Basic (Declaration)
Public Shared Function Mm ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Mm Overload
Telerik.Reporting.Drawing Namespace


Mm Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Mm Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Mm and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Mm(
    int value
)
Visual Basic (Declaration)
Public Shared Function Mm ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Mm Overload
Telerik.Reporting.Drawing Namespace


Multiply Method

[image]

Telerik Reporting Q2 2012
Unit..::.Multiply Method
Unit Structure See Also Send Feedback
Multiplies this Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Multiply(
    double value
)
Visual Basic (Declaration)
Public Function Multiply ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value to multiply by.

Return Value

The product of multiplying this Unit by the specified value.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Pica Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Pica Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Pica(Double) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.
Pica(Int32) | Creates a new Unit of type UnitType.Pica and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Pica Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Pica Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Pica(
    double value
)
Visual Basic (Declaration)
Public Shared Function Pica ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Pica Overload
Telerik.Reporting.Drawing Namespace


Pica Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Pica Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Pica and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Pica(
    int value
)
Visual Basic (Declaration)
Public Shared Function Pica ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Pica Overload
Telerik.Reporting.Drawing Namespace


Pixel Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Pixel Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Pixel(Double) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.
Pixel(Int32) | Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Pixel Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Pixel Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Pixel(
    double value
)
Visual Basic (Declaration)
Public Shared Function Pixel ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Pixel Overload
Telerik.Reporting.Drawing Namespace


Pixel Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Pixel Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Pixel and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Pixel(
    int value
)
Visual Basic (Declaration)
Public Shared Function Pixel ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Pixel Overload
Telerik.Reporting.Drawing Namespace


Point Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Point Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Point(Double) | Creates a new Unit of type UnitType.Point and magnitude equal to value.
Point(Int32) | Creates a new Unit of type UnitType.Point and magnitude equal to value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Point Method (Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Point Method (Double)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Point and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Point(
    double value
)
Visual Basic (Declaration)
Public Shared Function Point ( _
    value As Double _
) As Unit

Parameters

value
Type: System..::.Double
A double value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Point Overload
Telerik.Reporting.Drawing Namespace


Point Method (Int32)

[image]

Telerik Reporting Q2 2012
Unit..::.Point Method (Int32)
Unit Structure See Also Send Feedback
Creates a new Unit of type UnitType.Point and magnitude equal to value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Point(
    int value
)
Visual Basic (Declaration)
Public Shared Function Point ( _
    value As Integer _
) As Unit

Parameters

value
Type: System..::.Int32
An int value specifying the magnitude of the Unit.

Return Value

The created Unit.

See Also

Unit Structure
Point Overload
Telerik.Reporting.Drawing Namespace


Subtract Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Subtract Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Subtract(Unit) | Subtracts a unit from this Unit.
Subtract(Unit, Unit, UnitType) | Returns a Unit that is the difference of two units and is of the specified type.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Subtract Method (Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.Subtract Method (Unit)
Unit Structure See Also Send Feedback
Subtracts a unit from this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Subtract(
    Unit unit1
)
Visual Basic (Declaration)
Public Function Subtract ( _
    unit1 As Unit _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to subtract.

Return Value

The difference of this Unit and unit1 in this Unit's type.

See Also

Unit Structure
Subtract Overload
Telerik.Reporting.Drawing Namespace


Subtract Method (Unit, Unit, UnitType)

[image]

Telerik Reporting Q2 2012
Unit..::.Subtract Method (Unit, Unit, UnitType)
Unit Structure See Also Send Feedback
Returns a Unit that is the difference of two units and is of the specified type.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit Subtract(
    Unit unit1,
    Unit unit2,
    UnitType type
)
Visual Basic (Declaration)
Public Shared Function Subtract ( _
    unit1 As Unit, _
    unit2 As Unit, _
    type As UnitType _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to subtract from.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to subtract.
type
Type: Telerik.Reporting.Drawing..::.UnitType
A UnitType specifying the type of the resultant unit.

Return Value

The difference of the two units in the specified unit type.

See Also

Unit Structure
Subtract Overload
Telerik.Reporting.Drawing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.ToString Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
ToString()()() | Returns a human-readable representation of this Unit. (Overrides ValueType..::.ToString()()().)
ToString(CultureInfo) | Returns a human-readable representation of this Unit.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Unit..::.ToString Method
Unit Structure See Also Send Feedback
Returns a human-readable representation of this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation of this Unit.

See Also

Unit Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


ToString Method (CultureInfo)

[image]

Telerik Reporting Q2 2012
Unit..::.ToString Method (CultureInfo)
Unit Structure See Also Send Feedback
Returns a human-readable representation of this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo specifying the culture to use.

Return Value

A human-readable representation of this Unit.

See Also

Unit Structure
ToString Overload
Telerik.Reporting.Drawing Namespace


Unit Operators

[image] [image]

Telerik Reporting Q2 2012
Unit Operators
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Operators

Name | Description
Addition | Adds one Unit to another.
Division | Overloaded.
Equality | Compares two units.
GreaterThan | Compares two units.
GreaterThanOrEqual | Compares two units.
Inequality | Compares two units.
LessThan | Compares two units.
LessThanOrEqual | Compares two units.
Multiply | Overloaded.
Subtraction | Subtract one Unit from another.
UnaryNegation | Unary minus. Reverses the sign of Unit

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Addition Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Addition Operator
Unit Structure See Also Send Feedback
Adds one Unit to another.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator +(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator + ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first Unit.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second Unit.

Return Value

The sum of the two units.

Remarks

If unit1 is empty the method returns unit2. If unit2 is empty the method returns unit1. Otherwise, the method returns the sum of the two units in unit1's type.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Division Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Division Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Division(Unit, Double) | Divides a Unit by a specified value.
Division(Unit, Unit) | Divides the first Unit by the second.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Division Operator (Unit, Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Division Operator (Unit, Double)
Unit Structure See Also Send Feedback
Divides a Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator /(
    Unit unit1,
    double value
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    unit1 As Unit, _
    value As Double _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to divide.
value
Type: System..::.Double
A double value to divide by.

Return Value

A Unit that is the quotient of unit1 and value.

See Also

Unit Structure
Division Overload
Telerik.Reporting.Drawing Namespace


Division Operator (Unit, Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.Division Operator (Unit, Unit)
Unit Structure See Also Send Feedback
Divides the first Unit by the second.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static float operator /(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator / ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Single

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
A Unit to divide.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
A Unit to divide by.

Return Value

The quotient resulting by dividing of two Units.

See Also

Unit Structure
Division Overload
Telerik.Reporting.Drawing Namespace


Equality Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Equality Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator ==(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is equal to unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


GreaterThan Operator

[image]

Telerik Reporting Q2 2012
Unit..::.GreaterThan Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator >(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is greater than unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


GreaterThanOrEqual Operator

[image]

Telerik Reporting Q2 2012
Unit..::.GreaterThanOrEqual Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator >=(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is greater than or equal to unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Inequality Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Inequality Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator !=(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is not equal to unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


LessThan Operator

[image]

Telerik Reporting Q2 2012
Unit..::.LessThan Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator <(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is less than unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


LessThanOrEqual Operator

[image]

Telerik Reporting Q2 2012
Unit..::.LessThanOrEqual Operator
Unit Structure See Also Send Feedback
Compares two units.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool operator <=(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Boolean

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The first unit to compare.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The second unit to compare.

Return Value

true if unit1 is less than or equal to unit2; otherwise false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Multiply Method

[image] [image]

Telerik Reporting Q2 2012
Unit..::.Multiply Method
Unit Structure See Also Send Feedback

Overload List

Name | Description
Multiply(Double, Unit) | Multiplies a value by a Unit.
Multiply(Unit, Double) | Multiplies a Unit by a specified value.

See Also

Unit Structure
Unit Members
Telerik.Reporting.Drawing Namespace


Multiply Operator (Double, Unit)

[image]

Telerik Reporting Q2 2012
Unit..::.Multiply Operator (Double, Unit)
Unit Structure See Also Send Feedback
Multiplies a value by a Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator *(
    double value,
    Unit unit1
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    value As Double, _
    unit1 As Unit _
) As Unit

Parameters

value
Type: System..::.Double
The double value to multiply.
unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to multiply by.

Return Value

A Unit that is the product of value and unit1.

See Also

Unit Structure
Multiply Overload
Telerik.Reporting.Drawing Namespace


Multiply Operator (Unit, Double)

[image]

Telerik Reporting Q2 2012
Unit..::.Multiply Operator (Unit, Double)
Unit Structure See Also Send Feedback
Multiplies a Unit by a specified value.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator *(
    Unit unit1,
    double value
)
Visual Basic (Declaration)
Public Shared Operator * ( _
    unit1 As Unit, _
    value As Double _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to multiply.
value
Type: System..::.Double
A double value to multiply by.

Return Value

The product of unit1 and value.

See Also

Unit Structure
Multiply Overload
Telerik.Reporting.Drawing Namespace


Subtraction Operator

[image]

Telerik Reporting Q2 2012
Unit..::.Subtraction Operator
Unit Structure See Also Send Feedback
Subtract one Unit from another.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator -(
    Unit unit1,
    Unit unit2
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    unit1 As Unit, _
    unit2 As Unit _
) As Unit

Parameters

unit1
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to subtract from.
unit2
Type: Telerik.Reporting.Drawing..::.Unit
The Unit to subtract.

Return Value

The difference of the two units.

Remarks

If unit2 is empty the method returns unit1. Otherwise, the method returns the difference of the two units in unit1's type.

Exceptions

Exception | Condition
System..::.ArgumentException | Thrown when unit1 is empty.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


UnaryNegation Operator

[image]

Telerik Reporting Q2 2012
Unit..::.UnaryNegation Operator
Unit Structure See Also Send Feedback
Unary minus. Reverses the sign of Unit

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static Unit operator -(
    Unit unit
)
Visual Basic (Declaration)
Public Shared Operator - ( _
    unit As Unit _
) As Unit

Parameters

unit
Type: Telerik.Reporting.Drawing..::.Unit
The unit to negate.

Return Value

A Unit of the same type as unit but with opposite sign.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Unit Properties

[image] [image]

Telerik Reporting Q2 2012
Unit Properties
Unit Structure See Also Send Feedback

The Unit type exposes the following members.

Properties

Name | Description
DefaultType | Gets or sets a UnitType representing the default units of measure for a Report.
DotsPerInch | Gets a double value representing the dpi of the current graphics context.
IsEmpty | Specifies whether this Unit structure is uninitialized.
Type | Gets the type of the Unit.
Value | Gets the magnitude of this Unit.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


DefaultType Property

[image]

Telerik Reporting Q2 2012
Unit..::.DefaultType Property
Unit Structure See Also Send Feedback
Gets or sets a UnitType representing the default units of measure for a Report.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static UnitType DefaultType { get; set; }
Visual Basic (Declaration)
Public Shared Property DefaultType As UnitType

Field Value

A UnitType value that defines the default units of measure for a Report.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


DotsPerInch Property

[image]

Telerik Reporting Q2 2012
Unit..::.DotsPerInch Property
Unit Structure See Also Send Feedback
Gets a double value representing the dpi of the current graphics context.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static double DotsPerInch { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property DotsPerInch As Double

Field Value

A double value representing the dpi of the current graphics context.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


IsEmpty Property

[image]

Telerik Reporting Q2 2012
Unit..::.IsEmpty Property
Unit Structure See Also Send Feedback
Specifies whether this Unit structure is uninitialized.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

Field Value

This property returns true if this unit is uninitialized; otherwise, false.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Type Property

[image]

Telerik Reporting Q2 2012
Unit..::.Type Property
Unit Structure See Also Send Feedback
Gets the type of the Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public UnitType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As UnitType

Field Value

A UnitType specifying the type of this Unit.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Unit..::.Value Property
Unit Structure See Also Send Feedback
Gets the magnitude of this Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Single

Field Value

A float value indicating the magnitude of the Unit.

Remarks

This property makes sense only in combination with the Type property.

See Also

Unit Structure
Telerik.Reporting.Drawing Namespace


UnitType Enumeration

[image]

Telerik Reporting Q2 2012
UnitType Enumeration
See Also Send Feedback
Represents the type of a Unit.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum UnitType
Visual Basic (Declaration)
Public Enumeration UnitType

Members

Member name | Description
Pixel | Represents pixels. String equivalent used in Unit's contructor should be "px".
Point | Represents points. String equivalent used in Unit's contructor should be "pt".
Pica | Represents picas. String equivalent used in Unit's contructor should be "pc".
Inch | Represents inches. String equivalent used in Unit's contructor should be "in".
Mm | Represents millimeters. String equivalent used in Unit's contructor should be "mm".
Cm | Represents centimeters. String equivalent used in Unit's contructor should be "cm".

Remarks

1 inch = 6 picas = 72 points.

1 centimeter = 10 millimeters.

Pixels convert to and from other units based on the dpi of the currrent graphics context.

See Also

Telerik.Reporting.Drawing Namespace


VerticalAlign Enumeration

[image]

Telerik Reporting Q2 2012
VerticalAlign Enumeration
See Also Send Feedback
Specifies the vertical alignment of an object or text in an report item.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum VerticalAlign
Visual Basic (Declaration)
Public Enumeration VerticalAlign

Members

Member name | Description
Top | Specifies that the object is aligned to the top.
Middle | Specifies that the object is aligned to the middle.
Bottom | Specifies that the object is aligned to the bottom.

See Also

Telerik.Reporting.Drawing Namespace


Watermark Class

[image]

Telerik Reporting Q2 2012
Watermark Class
Members See Also Send Feedback
Represents a watermark on a printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class Watermark : ReportObject
Visual Basic (Declaration)
Public MustInherit Class Watermark _
    Inherits ReportObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Drawing..::.Watermark
Telerik.Reporting.Drawing..::.PictureWatermark
Telerik.Reporting.Drawing..::.TextWatermark

See Also

Watermark Members
Telerik.Reporting.Drawing Namespace


Watermark Members

[image] [image]

Telerik Reporting Q2 2012
Watermark Members
Watermark Class Constructors Methods Properties See Also Send Feedback

The Watermark type exposes the following members.

Constructors

Name | Description
Watermark | Overloaded.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Properties

Name | Description
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page.
Position | Gets or sets the position of the watermark relative to the other items on the printable page.
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report.
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


Watermark Constructor

[image] [image]

Telerik Reporting Q2 2012
Watermark Constructor
Watermark Class See Also Send Feedback

Overload List

Name | Description
Watermark()()() | Initializes a new instance of the Watermark class
Watermark(Watermark) | Initializes a new instance of the Watermark class

See Also

Watermark Class
Watermark Members
Telerik.Reporting.Drawing Namespace


Watermark Constructor

[image]

Telerik Reporting Q2 2012
Watermark Constructor
Watermark Class See Also Send Feedback
Initializes a new instance of the Watermark class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Watermark()
Visual Basic (Declaration)
Protected Sub New

See Also

Watermark Class
Watermark Overload
Telerik.Reporting.Drawing Namespace


Watermark Constructor (Watermark)

[image]

Telerik Reporting Q2 2012
Watermark Constructor (Watermark)
Watermark Class See Also Send Feedback
Initializes a new instance of the Watermark class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Watermark(
    Watermark watermark
)
Visual Basic (Declaration)
Protected Sub New ( _
    watermark As Watermark _
)

Parameters

watermark
Type: Telerik.Reporting.Drawing..::.Watermark

See Also

Watermark Class
Watermark Overload
Telerik.Reporting.Drawing Namespace


Watermark Methods

[image] [image]

Telerik Reporting Q2 2012
Watermark Methods
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


Watermark Properties

[image] [image]

Telerik Reporting Q2 2012
Watermark Properties
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Properties

Name | Description
Opacity | Gets or sets the opacity of the watermark when combining it with the other items on the printable page.
Position | Gets or sets the position of the watermark relative to the other items on the printable page.
PrintOnFirstPage | Gets or sets a value indicating whether to print the watermark on the first printable page of the report.
PrintOnLastPage | Gets or sets a value indicating whether to print the watermark on the last printable page of the report.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


Opacity Property

[image]

Telerik Reporting Q2 2012
Watermark..::.Opacity Property
Watermark Class See Also Send Feedback
Gets or sets the opacity of the watermark when combining it with the other items on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Double

Field Value

A value that specifies the opacity of the watermark when combining it with the other items on the printable page.

Remarks

The value can be specified in the range from 0.0 to 1.0, where 0.0 is completely transparent, while 1.0 is completely opaque. Any other value outside that range is clamped to the closest allowed value.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


Position Property

[image]

Telerik Reporting Q2 2012
Watermark..::.Position Property
Watermark Class See Also Send Feedback
Gets or sets the position of the watermark relative to the other items on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As WatermarkPosition

Field Value

A WatermarkPosition value that specifies the position of the watermark relative to the other items on the printable page.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


PrintOnFirstPage Property

[image]

Telerik Reporting Q2 2012
Watermark..::.PrintOnFirstPage Property
Watermark Class See Also Send Feedback
Gets or sets a value indicating whether to print the watermark on the first printable page of the report.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnFirstPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean

Field Value

A boolean value indicating whether to print the watermark on the first printable page of the report.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


PrintOnLastPage Property

[image]

Telerik Reporting Q2 2012
Watermark..::.PrintOnLastPage Property
Watermark Class See Also Send Feedback
Gets or sets a value indicating whether to print the watermark on the last printable page of the report.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnLastPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean

Field Value

A boolean value indicating whether to print the watermark on the last printable page of the report.

See Also

Watermark Class
Telerik.Reporting.Drawing Namespace


WatermarkCollection Class

[image]

Telerik Reporting Q2 2012
WatermarkCollection Class
Members See Also Send Feedback
Represents a collection of watermarks on a printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class WatermarkCollection : Collection<Watermark>,
    ICloneable
Visual Basic (Declaration)
Public Class WatermarkCollection _
    Inherits Collection(Of Watermark) _
    Implements ICloneable

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Watermark >)>)>
Telerik.Reporting.Drawing..::.WatermarkCollection

See Also

WatermarkCollection Members
Telerik.Reporting.Drawing Namespace


WatermarkCollection Members

[image] [image]

Telerik Reporting Q2 2012
WatermarkCollection Members
WatermarkCollection Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The WatermarkCollection type exposes the following members.

Constructors

Name | Description
WatermarkCollection | Initializes a new instance of the WatermarkCollection class

Methods

Name | Description
AddRange |

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

WatermarkCollection Class
Telerik.Reporting.Drawing Namespace


WatermarkCollection Constructor

[image]

Telerik Reporting Q2 2012
WatermarkCollection Constructor
WatermarkCollection Class See Also Send Feedback
Initializes a new instance of the WatermarkCollection class

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkCollection()
Visual Basic (Declaration)
Public Sub New

See Also

WatermarkCollection Class
Telerik.Reporting.Drawing Namespace


WatermarkCollection Methods

[image] [image]

Telerik Reporting Q2 2012
WatermarkCollection Methods
WatermarkCollection Class See Also Send Feedback

The WatermarkCollection type exposes the following members.

Methods

Name | Description
AddRange |

Explicit Interface Implementations

Name | Description
ICloneable..::.Clone |

See Also

WatermarkCollection Class
Telerik.Reporting.Drawing Namespace


ICloneable.Clone Method

[image]

Telerik Reporting Q2 2012
WatermarkCollection..::.ICloneable..::.Clone Method
WatermarkCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object ICloneable.Clone()
Visual Basic (Declaration)
Private Function Clone As Object Implements ICloneable.Clone

Implements

ICloneable..::.Clone()()()

See Also

WatermarkCollection Class
Telerik.Reporting.Drawing Namespace


AddRange Method

[image]

Telerik Reporting Q2 2012
WatermarkCollection..::.AddRange Method
WatermarkCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddRange(
    IEnumerable<Watermark> source
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    source As IEnumerable(Of Watermark) _
)

Parameters

source
Type: System.Collections.Generic..::.IEnumerable <(Of <(<' Watermark >)>)>

See Also

WatermarkCollection Class
Telerik.Reporting.Drawing Namespace


WatermarkOrientation Enumeration

[image]

Telerik Reporting Q2 2012
WatermarkOrientation Enumeration
See Also Send Feedback
Defines the orientation of the watermark text on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum WatermarkOrientation
Visual Basic (Declaration)
Public Enumeration WatermarkOrientation

Members

Member name | Description
Horizontal | The watermark text is oriented horizontally on the printable page.
Vertical | The watermark text is oriented vertically on the printable page.
Diagonal | The watermark text is oriented diagonally on the printable page.

See Also

Telerik.Reporting.Drawing Namespace


WatermarkPosition Enumeration

[image]

Telerik Reporting Q2 2012
WatermarkPosition Enumeration
See Also Send Feedback
Defines the position of the watermark relative to the other items on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum WatermarkPosition
Visual Basic (Declaration)
Public Enumeration WatermarkPosition

Members

Member name | Description
Behind | Specifies that the watermark is behind the other items on the printable page.
Front | Specifies that the watermark is in front of the other items on the printable page.

See Also

Telerik.Reporting.Drawing Namespace


WatermarkSizeMode Enumeration

[image]

Telerik Reporting Q2 2012
WatermarkSizeMode Enumeration
See Also Send Feedback
Defines the sizing mode of the watermark image on the printable page.

Namespace: Telerik.Reporting.Drawing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum WatermarkSizeMode
Visual Basic (Declaration)
Public Enumeration WatermarkSizeMode

Members

Member name | Description
Normal | The watermark image is centered on the printable area of the page.
Stretch | The watermark image is stretched to fill the printable area of the page without preserving its original proportions.
ScaleProportional | The watermark image is scaled to fill the printable area of the page while preserving its original proportions.

See Also

Telerik.Reporting.Drawing Namespace


Telerik.Reporting.Drawing.Shapes Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Drawing.Shapes Namespace
Send Feedback

Classes

Class | Description
ArrowShape | Represents an arrow shape.
BezierSegment | Represents a Bezier curve segment of a shape.
CrossShape | Represents an cross shape.
Ellipse | Represents an ellipse segment of a shape.
EllipseShape | Represents an ellipse shape.
LineSegment | Represents line segment of a shape.
LineShape | Represents a line shape.
PolygonShape | Represents a polygon shape.
PolygonShapeBase | Represents the base class for all polygon shapes.
RoundedCornerShape | Represents shape with rounded corners.
ShapeBase | Base class for all shape types.
StarShape | Represents a star shape.

Interfaces

Interface | Description
IShapeSegment | Represents a shape segment.

Enumerations

Enumeration | Description
LineDirection | Represents the direction of a line in a shape.


ArrowShape Class

[image]

Telerik Reporting Q2 2012
ArrowShape Class
Members See Also Send Feedback
Represents an arrow shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class ArrowShape : RoundedCornerShape
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class ArrowShape _
    Inherits RoundedCornerShape

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.ArrowShape

See Also

ArrowShape Members
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Members

[image] [image]

Telerik Reporting Q2 2012
ArrowShape Members
ArrowShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ArrowShape type exposes the following members.

Constructors

Name | Description
ArrowShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this ArrowShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Constructor

[image] [image]

Telerik Reporting Q2 2012
ArrowShape Constructor
ArrowShape Class See Also Send Feedback

Overload List

Name | Description
ArrowShape()()() | Initializes a new instance of the ArrowShape with zero angle of rotation.
ArrowShape(Double, Int32) | Initializes a new instance of the ArrowShape with the specified angle of rotation in degrees.

See Also

ArrowShape Class
ArrowShape Members
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Constructor

[image]

Telerik Reporting Q2 2012
ArrowShape Constructor
ArrowShape Class See Also Send Feedback
Initializes a new instance of the ArrowShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ArrowShape()
Visual Basic (Declaration)
Public Sub New

See Also

ArrowShape Class
ArrowShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Constructor (Double, Int32)

[image]

Telerik Reporting Q2 2012
ArrowShape Constructor (Double, Int32)
ArrowShape Class See Also Send Feedback
Initializes a new instance of the ArrowShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ArrowShape(
    double angle,
    int rounding
)
Visual Basic (Declaration)
Public Sub New ( _
    angle As Double, _
    rounding As Integer _
)

Parameters

angle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

ArrowShape Class
ArrowShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Methods

[image] [image]

Telerik Reporting Q2 2012
ArrowShape Methods
ArrowShape Class See Also Send Feedback

The ArrowShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this ArrowShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ArrowShape..::.Clone Method
ArrowShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

[image]

Telerik Reporting Q2 2012
ArrowShape..::.CreateRawShape Method
ArrowShape Class See Also Send Feedback
Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateRawShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateRawShape

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ArrowShape..::.ToString Method
ArrowShape Class See Also Send Feedback
Returns a human-readable representation ot this ArrowShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this ArrowShape.

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ArrowShape Properties

[image] [image]

Telerik Reporting Q2 2012
ArrowShape Properties
ArrowShape Class See Also Send Feedback

The ArrowShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)

See Also

ArrowShape Class
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Class

[image]

Telerik Reporting Q2 2012
BezierSegment Class
Members See Also Send Feedback
Represents a Bezier curve segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class BezierSegment : IShapeSegment
Visual Basic (Declaration)
Public Class BezierSegment _
    Implements IShapeSegment

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.BezierSegment

See Also

BezierSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Members

[image] [image]

Telerik Reporting Q2 2012
BezierSegment Members
BezierSegment Class Constructors Properties See Also Send Feedback

The BezierSegment type exposes the following members.

Constructors

Name | Description
BezierSegment | Initializes a new instance of the BezierSegment class with the specified points.

Properties

Name | Description
ControlPoint1 | Gets the first control point of this segment.
ControlPoint2 | Gets the second control point of this segment.
EndPoint | Gets the end point of this segment.
Points | Gets the points of this segment.
StartPoint | Gets the start point of this segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Constructor

[image]

Telerik Reporting Q2 2012
BezierSegment Constructor
BezierSegment Class See Also Send Feedback
Initializes a new instance of the BezierSegment class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BezierSegment(
    PointF[] points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As PointF() _
)

Parameters

points
Type: array< System.Drawing..::.PointF >[]()[][]
A point array representing the points of the segment. The array should contain 4 points -- start, control1, control2 and end.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


BezierSegment Properties

[image] [image]

Telerik Reporting Q2 2012
BezierSegment Properties
BezierSegment Class See Also Send Feedback

The BezierSegment type exposes the following members.

Properties

Name | Description
ControlPoint1 | Gets the first control point of this segment.
ControlPoint2 | Gets the second control point of this segment.
EndPoint | Gets the end point of this segment.
Points | Gets the points of this segment.
StartPoint | Gets the start point of this segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


ControlPoint1 Property

[image]

Telerik Reporting Q2 2012
BezierSegment..::.ControlPoint1 Property
BezierSegment Class See Also Send Feedback
Gets the first control point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF ControlPoint1 { get; }
Visual Basic (Declaration)
Public ReadOnly Property ControlPoint1 As PointF

Field Value

The first control point of the segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


ControlPoint2 Property

[image]

Telerik Reporting Q2 2012
BezierSegment..::.ControlPoint2 Property
BezierSegment Class See Also Send Feedback
Gets the second control point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF ControlPoint2 { get; }
Visual Basic (Declaration)
Public ReadOnly Property ControlPoint2 As PointF

Field Value

The second control point of the segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


EndPoint Property

[image]

Telerik Reporting Q2 2012
BezierSegment..::.EndPoint Property
BezierSegment Class See Also Send Feedback
Gets the end point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF EndPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property EndPoint As PointF

Field Value

The end point of the segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

[image]

Telerik Reporting Q2 2012
BezierSegment..::.Points Property
BezierSegment Class See Also Send Feedback
Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF[] Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()

Field Value

A point array representing the points of the segment.

Implements

IShapeSegment..::.Points

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


StartPoint Property

[image]

Telerik Reporting Q2 2012
BezierSegment..::.StartPoint Property
BezierSegment Class See Also Send Feedback
Gets the start point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As PointF

Field Value

The start point of the segment.

See Also

BezierSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Class

[image]

Telerik Reporting Q2 2012
CrossShape Class
Members See Also Send Feedback
Represents an cross shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class CrossShape : RoundedCornerShape
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class CrossShape _
    Inherits RoundedCornerShape

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.CrossShape

See Also

CrossShape Members
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Members

[image] [image]

Telerik Reporting Q2 2012
CrossShape Members
CrossShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The CrossShape type exposes the following members.

Constructors

Name | Description
CrossShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this CrossShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Constructor

[image] [image]

Telerik Reporting Q2 2012
CrossShape Constructor
CrossShape Class See Also Send Feedback

Overload List

Name | Description
CrossShape()()() | Initializes a new instance of the CrossShape with zero angle of rotation.
CrossShape(Double, Int32) | Initializes a new instance of the CrossShape with the specified angle of rotation in degrees.

See Also

CrossShape Class
CrossShape Members
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Constructor

[image]

Telerik Reporting Q2 2012
CrossShape Constructor
CrossShape Class See Also Send Feedback
Initializes a new instance of the CrossShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CrossShape()
Visual Basic (Declaration)
Public Sub New

See Also

CrossShape Class
CrossShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Constructor (Double, Int32)

[image]

Telerik Reporting Q2 2012
CrossShape Constructor (Double, Int32)
CrossShape Class See Also Send Feedback
Initializes a new instance of the CrossShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public CrossShape(
    double angle,
    int rounding
)
Visual Basic (Declaration)
Public Sub New ( _
    angle As Double, _
    rounding As Integer _
)

Parameters

angle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

CrossShape Class
CrossShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Methods

[image] [image]

Telerik Reporting Q2 2012
CrossShape Methods
CrossShape Class See Also Send Feedback

The CrossShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this CrossShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
CrossShape..::.Clone Method
CrossShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

[image]

Telerik Reporting Q2 2012
CrossShape..::.CreateRawShape Method
CrossShape Class See Also Send Feedback
Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateRawShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateRawShape

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
CrossShape..::.ToString Method
CrossShape Class See Also Send Feedback
Returns a human-readable representation ot this CrossShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this CrossShape.

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CrossShape Properties

[image] [image]

Telerik Reporting Q2 2012
CrossShape Properties
CrossShape Class See Also Send Feedback

The CrossShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)

See Also

CrossShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Class

[image]

Telerik Reporting Q2 2012
Ellipse Class
Members See Also Send Feedback
Represents an ellipse segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Ellipse : IShapeSegment
Visual Basic (Declaration)
Public Class Ellipse _
    Implements IShapeSegment

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.Ellipse

See Also

Ellipse Members
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Members

[image] [image]

Telerik Reporting Q2 2012
Ellipse Members
Ellipse Class Constructors Properties See Also Send Feedback

The Ellipse type exposes the following members.

Constructors

Name | Description
Ellipse | Initializes a new instance of the Ellipse class with the specified points.

Properties

Name | Description
Points | Gets the points of this segment.
Rectangle | Gets the bounding rectangle of the segment.

See Also

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Constructor

[image]

Telerik Reporting Q2 2012
Ellipse Constructor
Ellipse Class See Also Send Feedback
Initializes a new instance of the Ellipse class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Ellipse(
    RectangleF rectangle
)
Visual Basic (Declaration)
Public Sub New ( _
    rectangle As RectangleF _
)

Parameters

rectangle
Type: System.Drawing..::.RectangleF
A RectangleF structure representing the bounding rectangle of the segment.

See Also

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Ellipse Properties

[image] [image]

Telerik Reporting Q2 2012
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

Name | Description
Points | Gets the points of this segment.
Rectangle | Gets the bounding rectangle of the segment.

See Also

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

[image]

Telerik Reporting Q2 2012
Ellipse..::.Points Property
Ellipse Class See Also Send Feedback
Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF[] Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()

Field Value

A point array representing the points of the segment.

Implements

IShapeSegment..::.Points

See Also

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


Rectangle Property

[image]

Telerik Reporting Q2 2012
Ellipse..::.Rectangle Property
Ellipse Class See Also Send Feedback
Gets the bounding rectangle of the segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleF Rectangle { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rectangle As RectangleF

Field Value

A RectangleF structure representing the bounding rectangle of the segment.

See Also

Ellipse Class
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Class

[image]

Telerik Reporting Q2 2012
EllipseShape Class
Members See Also Send Feedback
Represents an ellipse shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class EllipseShape : ShapeBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class EllipseShape _
    Inherits ShapeBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.EllipseShape

See Also

EllipseShape Members
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Members

[image] [image]

Telerik Reporting Q2 2012
EllipseShape Members
EllipseShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The EllipseShape type exposes the following members.

Constructors

Name | Description
EllipseShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this EllipseShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
StartAngle | (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Constructor

[image] [image]

Telerik Reporting Q2 2012
EllipseShape Constructor
EllipseShape Class See Also Send Feedback

Overload List

Name | Description
EllipseShape()()() | Initializes a new instance of the EllipseShape with zero angle of rotation.
EllipseShape(Double) | Initializes a new instance of the EllipseShape with the specified angle of rotation in degrees.

See Also

EllipseShape Class
EllipseShape Members
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Constructor

[image]

Telerik Reporting Q2 2012
EllipseShape Constructor
EllipseShape Class See Also Send Feedback
Initializes a new instance of the EllipseShape with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EllipseShape()
Visual Basic (Declaration)
Public Sub New

See Also

EllipseShape Class
EllipseShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Constructor (Double)

[image]

Telerik Reporting Q2 2012
EllipseShape Constructor (Double)
EllipseShape Class See Also Send Feedback
Initializes a new instance of the EllipseShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public EllipseShape(
    double startAngle
)
Visual Basic (Declaration)
Public Sub New ( _
    startAngle As Double _
)

Parameters

startAngle
Type: System..::.Double

See Also

EllipseShape Class
EllipseShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Methods

[image] [image]

Telerik Reporting Q2 2012
EllipseShape Methods
EllipseShape Class See Also Send Feedback

The EllipseShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this EllipseShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
EllipseShape..::.Clone Method
EllipseShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

[image]

Telerik Reporting Q2 2012
EllipseShape..::.CreateShape Method
EllipseShape Class See Also Send Feedback
Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateShape

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
EllipseShape..::.ToString Method
EllipseShape Class See Also Send Feedback
Returns a human-readable representation ot this EllipseShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this EllipseShape.

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


EllipseShape Properties

[image] [image]

Telerik Reporting Q2 2012
EllipseShape Properties
EllipseShape Class See Also Send Feedback

The EllipseShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
StartAngle | (Inherited from ShapeBase.)

See Also

EllipseShape Class
Telerik.Reporting.Drawing.Shapes Namespace


IShapeSegment Interface

[image]

Telerik Reporting Q2 2012
IShapeSegment Interface
Members See Also Send Feedback
Represents a shape segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IShapeSegment
Visual Basic (Declaration)
Public Interface IShapeSegment

See Also

IShapeSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


IShapeSegment Members

[image] [image]

Telerik Reporting Q2 2012
IShapeSegment Members
IShapeSegment Interface Properties See Also Send Feedback

The IShapeSegment type exposes the following members.

Properties

Name | Description
Points | Gets the points of this segment.

See Also

IShapeSegment Interface
Telerik.Reporting.Drawing.Shapes Namespace


IShapeSegment Properties

[image] [image]

Telerik Reporting Q2 2012
IShapeSegment Properties
IShapeSegment Interface See Also Send Feedback

The IShapeSegment type exposes the following members.

Properties

Name | Description
Points | Gets the points of this segment.

See Also

IShapeSegment Interface
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

[image]

Telerik Reporting Q2 2012
IShapeSegment..::.Points Property
IShapeSegment Interface See Also Send Feedback
Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PointF[] Points { get; }
Visual Basic (Declaration)
ReadOnly Property Points As PointF()

Field Value

A point array representing the points of the segment.

See Also

IShapeSegment Interface
Telerik.Reporting.Drawing.Shapes Namespace


LineDirection Enumeration

[image]

Telerik Reporting Q2 2012
LineDirection Enumeration
See Also Send Feedback
Represents the direction of a line in a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public enum LineDirection
Visual Basic (Declaration)
Public Enumeration LineDirection

Members

Member name | Description
NS | Vertical line
EW | Horizontal line
NWSE | Top-Right - Bottom-Left line
NESW | Top-Left - Bottom-Right line

See Also

Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Class

[image]

Telerik Reporting Q2 2012
LineSegment Class
Members See Also Send Feedback
Represents line segment of a shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class LineSegment : IShapeSegment
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LineSegment _
    Implements IShapeSegment

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.LineSegment

See Also

LineSegment Members
Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Members

[image] [image]

Telerik Reporting Q2 2012
LineSegment Members
LineSegment Class Constructors Properties See Also Send Feedback

The LineSegment type exposes the following members.

Constructors

Name | Description
LineSegment | Initializes a new instance of the LineSegment class with the specified points.

Properties

Name | Description
EndPoint | Gets the end point of this segment.
Length | Gets the length of the line.
Points | Gets the points of this segment.
StartPoint | Gets the start point of this segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Constructor

[image]

Telerik Reporting Q2 2012
LineSegment Constructor
LineSegment Class See Also Send Feedback
Initializes a new instance of the LineSegment class with the specified points.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineSegment(
    PointF point1,
    PointF point2
)
Visual Basic (Declaration)
Public Sub New ( _
    point1 As PointF, _
    point2 As PointF _
)

Parameters

point1
Type: System.Drawing..::.PointF
The start point of the line segment.
point2
Type: System.Drawing..::.PointF
The end point of the line segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


LineSegment Properties

[image] [image]

Telerik Reporting Q2 2012
LineSegment Properties
LineSegment Class See Also Send Feedback

The LineSegment type exposes the following members.

Properties

Name | Description
EndPoint | Gets the end point of this segment.
Length | Gets the length of the line.
Points | Gets the points of this segment.
StartPoint | Gets the start point of this segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


EndPoint Property

[image]

Telerik Reporting Q2 2012
LineSegment..::.EndPoint Property
LineSegment Class See Also Send Feedback
Gets the end point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF EndPoint { get; set; }
Visual Basic (Declaration)
Public Property EndPoint As PointF

Field Value

The end point of the segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


Length Property

[image]

Telerik Reporting Q2 2012
LineSegment..::.Length Property
LineSegment Class See Also Send Feedback
Gets the length of the line.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public float Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As Single

Field Value

A float value representing the lenght of the line segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


Points Property

[image]

Telerik Reporting Q2 2012
LineSegment..::.Points Property
LineSegment Class See Also Send Feedback
Gets the points of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF[] Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As PointF()

Field Value

A point array representing the points of the segment.

Implements

IShapeSegment..::.Points

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


StartPoint Property

[image]

Telerik Reporting Q2 2012
LineSegment..::.StartPoint Property
LineSegment Class See Also Send Feedback
Gets the start point of this segment.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointF StartPoint { get; set; }
Visual Basic (Declaration)
Public Property StartPoint As PointF

Field Value

The start point of the segment.

See Also

LineSegment Class
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Class

[image]

Telerik Reporting Q2 2012
LineShape Class
Members See Also Send Feedback
Represents a line shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class LineShape : ShapeBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class LineShape _
    Inherits ShapeBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.LineShape

See Also

LineShape Members
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Members

[image] [image]

Telerik Reporting Q2 2012
LineShape Members
LineShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LineShape type exposes the following members.

Constructors

Name | Description
LineShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this LineShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Direction |
StartAngle | (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Constructor

[image] [image]

Telerik Reporting Q2 2012
LineShape Constructor
LineShape Class See Also Send Feedback

Overload List

Name | Description
LineShape()()() | Initializes a new instance of the LineShape with EW line direction.
LineShape(LineDirection) | Initializes a new instance of the LineShape with specified line direction.

See Also

LineShape Class
LineShape Members
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Constructor

[image]

Telerik Reporting Q2 2012
LineShape Constructor
LineShape Class See Also Send Feedback
Initializes a new instance of the LineShape with EW line direction.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineShape()
Visual Basic (Declaration)
Public Sub New

See Also

LineShape Class
LineShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Constructor (LineDirection)

[image]

Telerik Reporting Q2 2012
LineShape Constructor (LineDirection)
LineShape Class See Also Send Feedback
Initializes a new instance of the LineShape with specified line direction.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineShape(
    LineDirection lineDirection
)
Visual Basic (Declaration)
Public Sub New ( _
    lineDirection As LineDirection _
)

Parameters

lineDirection
Type: Telerik.Reporting.Drawing.Shapes..::.LineDirection
The direction of the line.

See Also

LineShape Class
LineShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Methods

[image] [image]

Telerik Reporting Q2 2012
LineShape Methods
LineShape Class See Also Send Feedback

The LineShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this LineShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
LineShape..::.Clone Method
LineShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

[image]

Telerik Reporting Q2 2012
LineShape..::.CreateShape Method
LineShape Class See Also Send Feedback
Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateShape

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
LineShape..::.ToString Method
LineShape Class See Also Send Feedback
Returns a human-readable representation ot this LineShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this LineShape.

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


LineShape Properties

[image] [image]

Telerik Reporting Q2 2012
LineShape Properties
LineShape Class See Also Send Feedback

The LineShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Direction |
StartAngle | (Inherited from ShapeBase.)

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Direction Property

[image]

Telerik Reporting Q2 2012
LineShape..::.Direction Property
LineShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LineDirection Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As LineDirection

See Also

LineShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Class

[image]

Telerik Reporting Q2 2012
PolygonShape Class
Members See Also Send Feedback
Represents a polygon shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class PolygonShape : PolygonShapeBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class PolygonShape _
    Inherits PolygonShapeBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes..::.PolygonShape

See Also

PolygonShape Members
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Members

[image] [image]

Telerik Reporting Q2 2012
PolygonShape Members
PolygonShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PolygonShape type exposes the following members.

Constructors

Name | Description
PolygonShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase.)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape. (Overrides PolygonShapeBase..::.GetPoints(RectangleF).)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this PolygonShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount | (Inherited from PolygonShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Constructor

[image] [image]

Telerik Reporting Q2 2012
PolygonShape Constructor
PolygonShape Class See Also Send Feedback

Overload List

Name | Description
PolygonShape()()() | Initializes a new instance of the PolygonShape with 3 vertexes and zero angle of rotation.
PolygonShape(Int32) | Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.
PolygonShape(Int32, Double, Int32) | Initializes a new instance of the PolygonShape with the specified vertex count and angle of rotation in degrees.

See Also

PolygonShape Class
PolygonShape Members
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Constructor

[image]

Telerik Reporting Q2 2012
PolygonShape Constructor
PolygonShape Class See Also Send Feedback
Initializes a new instance of the PolygonShape with 3 vertexes and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PolygonShape()
Visual Basic (Declaration)
Public Sub New

See Also

PolygonShape Class
PolygonShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Constructor (Int32)

[image]

Telerik Reporting Q2 2012
PolygonShape Constructor (Int32)
PolygonShape Class See Also Send Feedback
Initializes a new instance of the PolygonShape with the specified vertex count and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PolygonShape(
    int vertexCount
)
Visual Basic (Declaration)
Public Sub New ( _
    vertexCount As Integer _
)

Parameters

vertexCount
Type: System..::.Int32
The number of vertices of the shape.

See Also

PolygonShape Class
PolygonShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Constructor (Int32, Double, Int32)

[image]

Telerik Reporting Q2 2012
PolygonShape Constructor (Int32, Double, Int32)
PolygonShape Class See Also Send Feedback
Initializes a new instance of the PolygonShape with the specified vertex count and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PolygonShape(
    int vertexCount,
    double angle,
    int rounding
)
Visual Basic (Declaration)
Public Sub New ( _
    vertexCount As Integer, _
    angle As Double, _
    rounding As Integer _
)

Parameters

vertexCount
Type: System..::.Int32
The number of vertices of the shape.
angle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

PolygonShape Class
PolygonShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Methods

[image] [image]

Telerik Reporting Q2 2012
PolygonShape Methods
PolygonShape Class See Also Send Feedback

The PolygonShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase.)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape. (Overrides PolygonShapeBase..::.GetPoints(RectangleF).)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this PolygonShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
PolygonShape..::.Clone Method
PolygonShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPoints Method

[image]

Telerik Reporting Q2 2012
PolygonShape..::.GetPoints Method
PolygonShape Class See Also Send Feedback
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override PointF[] GetPoints(
    RectangleF bounds
)
Visual Basic (Declaration)
Protected Overrides Function GetPoints ( _
    bounds As RectangleF _
) As PointF()

Parameters

bounds
Type: System.Drawing..::.RectangleF
The bound of the shape.

Return Value

A point array representing the points of this shape.

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
PolygonShape..::.ToString Method
PolygonShape Class See Also Send Feedback
Returns a human-readable representation ot this PolygonShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this PolygonShape.

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShape Properties

[image] [image]

Telerik Reporting Q2 2012
PolygonShape Properties
PolygonShape Class See Also Send Feedback

The PolygonShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount | (Inherited from PolygonShapeBase.)

See Also

PolygonShape Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Class

[image]

Telerik Reporting Q2 2012
PolygonShapeBase Class
Members See Also Send Feedback
Represents the base class for all polygon shapes.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public abstract class PolygonShapeBase : RoundedCornerShape
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class PolygonShapeBase _
    Inherits RoundedCornerShape

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes..::.PolygonShape
Telerik.Reporting.Drawing.Shapes..::.StarShape

See Also

PolygonShapeBase Members
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Members

[image] [image]

Telerik Reporting Q2 2012
PolygonShapeBase Members
PolygonShapeBase Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The PolygonShapeBase type exposes the following members.

Constructors

Name | Description
PolygonShapeBase | Initializes a new instance of the PolygonShapeBase with the specified vertex count and angle of rotation in degrees.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Inherited from ShapeBase.)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape.
GetPointsCore | Gets the core points for this shape.
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount |

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Constructor

[image]

Telerik Reporting Q2 2012
PolygonShapeBase Constructor
PolygonShapeBase Class See Also Send Feedback
Initializes a new instance of the PolygonShapeBase with the specified vertex count and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected PolygonShapeBase(
    int vertexCount,
    double angle,
    int rounding
)
Visual Basic (Declaration)
Protected Sub New ( _
    vertexCount As Integer, _
    angle As Double, _
    rounding As Integer _
)

Parameters

vertexCount
Type: System..::.Int32
The number of vertices of the polygon.
angle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Methods

[image] [image]

Telerik Reporting Q2 2012
PolygonShapeBase Methods
PolygonShapeBase Class See Also Send Feedback

The PolygonShapeBase type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Inherited from ShapeBase.)
CreateRawShape | Creates the raw shape. (Overrides RoundedCornerShape..::.CreateRawShape()()().)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape.
GetPointsCore | Gets the core points for this shape.
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

[image]

Telerik Reporting Q2 2012
PolygonShapeBase..::.CreateRawShape Method
PolygonShapeBase Class See Also Send Feedback
Creates the raw shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateRawShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateRawShape

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPoints Method

[image]

Telerik Reporting Q2 2012
PolygonShapeBase..::.GetPoints Method
PolygonShapeBase Class See Also Send Feedback
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected abstract PointF[] GetPoints(
    RectangleF bounds
)
Visual Basic (Declaration)
Protected MustOverride Function GetPoints ( _
    bounds As RectangleF _
) As PointF()

Parameters

bounds
Type: System.Drawing..::.RectangleF
The bound of the shape.

Return Value

A point array representing the points of this shape.

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPointsCore Method

[image]

Telerik Reporting Q2 2012
PolygonShapeBase..::.GetPointsCore Method
PolygonShapeBase Class See Also Send Feedback
Gets the core points for this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected static PointF[] GetPointsCore(
    PointF center,
    int segmentCount,
    double radius,
    double angle
)
Visual Basic (Declaration)
Protected Shared Function GetPointsCore ( _
    center As PointF, _
    segmentCount As Integer, _
    radius As Double, _
    angle As Double _
) As PointF()

Parameters

center
Type: System.Drawing..::.PointF
The center of the shape.
segmentCount
Type: System..::.Int32
The number of segments of the shape.
radius
Type: System..::.Double
The radius of the shape.
angle
Type: System..::.Double
The angle of rotation of the shape.

Return Value

A point array representing the core points of this shape.

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


PolygonShapeBase Properties

[image] [image]

Telerik Reporting Q2 2012
PolygonShapeBase Properties
PolygonShapeBase Class See Also Send Feedback

The PolygonShapeBase type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount |

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


VertexCount Property

[image]

Telerik Reporting Q2 2012
PolygonShapeBase..::.VertexCount Property
PolygonShapeBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int VertexCount { get; set; }
Visual Basic (Declaration)
Public Property VertexCount As Integer

See Also

PolygonShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Class

[image]

Telerik Reporting Q2 2012
RoundedCornerShape Class
Members See Also Send Feedback
Represents shape with rounded corners.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public abstract class RoundedCornerShape : ShapeBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class RoundedCornerShape _
    Inherits ShapeBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.ArrowShape
Telerik.Reporting.Drawing.Shapes..::.CrossShape
Telerik.Reporting.Drawing.Shapes..::.PolygonShapeBase

See Also

RoundedCornerShape Members
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Members

[image] [image]

Telerik Reporting Q2 2012
RoundedCornerShape Members
RoundedCornerShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The RoundedCornerShape type exposes the following members.

Constructors

Name | Description
RoundedCornerShape | Initializes a new instance of the RoundedCornerShape with the specified angle of rotation in degrees.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Inherited from ShapeBase.)
CreateRawShape | When overriden this method should create shape that will be rounded using the RoundVertexOp operator.
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape.
StartAngle | (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Constructor

[image]

Telerik Reporting Q2 2012
RoundedCornerShape Constructor
RoundedCornerShape Class See Also Send Feedback
Initializes a new instance of the RoundedCornerShape with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected RoundedCornerShape(
    double startAngle,
    int rounding
)
Visual Basic (Declaration)
Protected Sub New ( _
    startAngle As Double, _
    rounding As Integer _
)

Parameters

startAngle
Type: System..::.Double
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Methods

[image] [image]

Telerik Reporting Q2 2012
RoundedCornerShape Methods
RoundedCornerShape Class See Also Send Feedback

The RoundedCornerShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Inherited from ShapeBase.)
CreateRawShape | When overriden this method should create shape that will be rounded using the RoundVertexOp operator.
CreateShape | Creates the shape. (Overrides ShapeBase..::.CreateShape()()().)
GetEnumerator | (Inherited from ShapeBase.)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateRawShape Method

[image]

Telerik Reporting Q2 2012
RoundedCornerShape..::.CreateRawShape Method
RoundedCornerShape Class See Also Send Feedback
When overriden this method should create shape that will be rounded using the RoundVertexOp operator.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected abstract void CreateRawShape()
Visual Basic (Declaration)
Protected MustOverride Sub CreateRawShape

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

[image]

Telerik Reporting Q2 2012
RoundedCornerShape..::.CreateShape Method
RoundedCornerShape Class See Also Send Feedback
Creates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void CreateShape()
Visual Basic (Declaration)
Protected Overrides Sub CreateShape

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


RoundedCornerShape Properties

[image] [image]

Telerik Reporting Q2 2012
RoundedCornerShape Properties
RoundedCornerShape Class See Also Send Feedback

The RoundedCornerShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Rounding | Gets or sets the rounding factor for the shape.
StartAngle | (Inherited from ShapeBase.)

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Rounding Property

[image]

Telerik Reporting Q2 2012
RoundedCornerShape..::.Rounding Property
RoundedCornerShape Class See Also Send Feedback
Gets or sets the rounding factor for the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Rounding { get; set; }
Visual Basic (Declaration)
Public Property Rounding As Integer

Field Value

A double value between 0 and 100 specifying the rounding factor of the shape. 0 means no rounding, 100 means full rounding.

See Also

RoundedCornerShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Class

[image]

Telerik Reporting Q2 2012
ShapeBase Class
Members See Also Send Feedback
Base class for all shape types.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public abstract class ShapeBase : IEnumerable<IShapeSegment>,
    IEnumerable, ICloneable
Visual Basic (Declaration)
<SerializableAttribute> _
Public MustInherit Class ShapeBase _
    Implements IEnumerable(Of IShapeSegment), IEnumerable,  _
    ICloneable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.EllipseShape
Telerik.Reporting.Drawing.Shapes..::.LineShape
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape

See Also

ShapeBase Members
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Members

[image] [image]

Telerik Reporting Q2 2012
ShapeBase Members
ShapeBase Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ShapeBase type exposes the following members.

Constructors

Name | Description
ShapeBase | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape.
AddEllipse | Adds an ellipse to the shape.
AddLine | Adds a straight line to the shape.
AddLines | Adds a series of straight lines to the shape.
Clone |
CreateShape | When overridden this method should create the shape.
GetEnumerator |
RecreateShape | Recreates the shape.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians.
Bounds | Gets or sets the bounds of this shape.
StartAngle |

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator |

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Constructor

[image] [image]

Telerik Reporting Q2 2012
ShapeBase Constructor
ShapeBase Class See Also Send Feedback

Overload List

Name | Description
ShapeBase()()() | Initializes a new instance of the ShapeBase with zero angle of rotation.
ShapeBase(Double) | Initializes a new instance of the ShapeBase with the specified angle of rotation in degrees.

See Also

ShapeBase Class
ShapeBase Members
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Constructor

[image]

Telerik Reporting Q2 2012
ShapeBase Constructor
ShapeBase Class See Also Send Feedback
Initializes a new instance of the ShapeBase with zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ShapeBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ShapeBase Class
ShapeBase Overload
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Constructor (Double)

[image]

Telerik Reporting Q2 2012
ShapeBase Constructor (Double)
ShapeBase Class See Also Send Feedback
Initializes a new instance of the ShapeBase with the specified angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ShapeBase(
    double startAngle
)
Visual Basic (Declaration)
Protected Sub New ( _
    startAngle As Double _
)

Parameters

startAngle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.

See Also

ShapeBase Class
ShapeBase Overload
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Methods

[image] [image]

Telerik Reporting Q2 2012
ShapeBase Methods
ShapeBase Class See Also Send Feedback

The ShapeBase type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape.
AddEllipse | Adds an ellipse to the shape.
AddLine | Adds a straight line to the shape.
AddLines | Adds a series of straight lines to the shape.
Clone |
CreateShape | When overridden this method should create the shape.
GetEnumerator |
RecreateShape | Recreates the shape.

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator |

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


IEnumerable(IShapeSegment).GetEnumerator Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.IEnumerable<(Of <(<'IShapeSegment>)>)>..::.GetEnumerator Method
ShapeBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerator<IShapeSegment> IEnumerable<IShapeSegment>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of IShapeSegment)
    Implements IEnumerable(Of IShapeSegment).GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AddBeziers Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.AddBeziers Method
ShapeBase Class See Also Send Feedback
Adds a Bezier curve to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddBeziers(
    PointF[] points
)
Visual Basic (Declaration)
Public Sub AddBeziers ( _
    points As PointF() _
)

Parameters

points
Type: array< System.Drawing..::.PointF >[]()[][]
A point array representing the points of the Bezier curve.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AddEllipse Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.AddEllipse Method
ShapeBase Class See Also Send Feedback
Adds an ellipse to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddEllipse(
    RectangleF bounds
)
Visual Basic (Declaration)
Public Sub AddEllipse ( _
    bounds As RectangleF _
)

Parameters

bounds
Type: System.Drawing..::.RectangleF
The bounding rectangle of the ellipse.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AddLine Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.AddLine Method
ShapeBase Class See Also Send Feedback
Adds a straight line to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLine(
    PointF point1,
    PointF point2
)
Visual Basic (Declaration)
Public Sub AddLine ( _
    point1 As PointF, _
    point2 As PointF _
)

Parameters

point1
Type: System.Drawing..::.PointF
The statr point of the line.
point2
Type: System.Drawing..::.PointF
The end point of the line.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AddLines Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.AddLines Method
ShapeBase Class See Also Send Feedback
Adds a series of straight lines to the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddLines(
    PointF[] points,
    bool close
)
Visual Basic (Declaration)
Public Sub AddLines ( _
    points As PointF(), _
    close As Boolean _
)

Parameters

points
Type: array< System.Drawing..::.PointF >[]()[][]
A point array representing the starting and ending points of the lines.
close
Type: System..::.Boolean
A boolean value specifying whether to close the shape.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.Clone Method
ShapeBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract Object Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


CreateShape Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.CreateShape Method
ShapeBase Class See Also Send Feedback
When overridden this method should create the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected abstract void CreateShape()
Visual Basic (Declaration)
Protected MustOverride Sub CreateShape

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


GetEnumerator Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.GetEnumerator Method
ShapeBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


RecreateShape Method

[image]

Telerik Reporting Q2 2012
ShapeBase..::.RecreateShape Method
ShapeBase Class See Also Send Feedback
Recreates the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected void RecreateShape()
Visual Basic (Declaration)
Protected Sub RecreateShape

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


ShapeBase Properties

[image] [image]

Telerik Reporting Q2 2012
ShapeBase Properties
ShapeBase Class See Also Send Feedback

The ShapeBase type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians.
Bounds | Gets or sets the bounds of this shape.
StartAngle |

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


AngleInRad Property

[image]

Telerik Reporting Q2 2012
ShapeBase..::.AngleInRad Property
ShapeBase Class See Also Send Feedback
Gets the angle of rotation of this shape in radians.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected double AngleInRad { get; }
Visual Basic (Declaration)
Protected ReadOnly Property AngleInRad As Double

Field Value

A double value representing the angle of rotation of this shape in radians.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


Bounds Property

[image]

Telerik Reporting Q2 2012
ShapeBase..::.Bounds Property
ShapeBase Class See Also Send Feedback
Gets or sets the bounds of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleF Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As RectangleF

Field Value

A RectangleF structure representing the bounds of this shape.

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


StartAngle Property

[image]

Telerik Reporting Q2 2012
ShapeBase..::.StartAngle Property
ShapeBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double

See Also

ShapeBase Class
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Class

[image]

Telerik Reporting Q2 2012
StarShape Class
Members See Also Send Feedback
Represents a star shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class StarShape : PolygonShapeBase
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class StarShape _
    Inherits PolygonShapeBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Drawing.Shapes..::.ShapeBase
Telerik.Reporting.Drawing.Shapes..::.RoundedCornerShape
Telerik.Reporting.Drawing.Shapes..::.PolygonShapeBase
Telerik.Reporting.Drawing.Shapes..::.StarShape

See Also

StarShape Members
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Members

[image] [image]

Telerik Reporting Q2 2012
StarShape Members
StarShape Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The StarShape type exposes the following members.

Constructors

Name | Description
StarShape | Overloaded.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase.)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape. (Overrides PolygonShapeBase..::.GetPoints(RectangleF).)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this StarShape. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Concavity | Gets or sets a percent value specifying the concavity of the shape.
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount | (Inherited from PolygonShapeBase.)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Constructor

[image] [image]

Telerik Reporting Q2 2012
StarShape Constructor
StarShape Class See Also Send Feedback

Overload List

Name | Description
StarShape()()() | Initializes a new instance of the StarShape with 3 vertexes, 50% concavity, and zero angle of rotation.
StarShape(Int32) | Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.
StarShape(Int32, Int32, Double, Int32) | Initializes a new instance of the StarShape with the specified vertex count, concavity, and angle of rotation in degrees.

See Also

StarShape Class
StarShape Members
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Constructor

[image]

Telerik Reporting Q2 2012
StarShape Constructor
StarShape Class See Also Send Feedback
Initializes a new instance of the StarShape with 3 vertexes, 50% concavity, and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StarShape()
Visual Basic (Declaration)
Public Sub New

See Also

StarShape Class
StarShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Constructor (Int32)

[image]

Telerik Reporting Q2 2012
StarShape Constructor (Int32)
StarShape Class See Also Send Feedback
Initializes a new instance of the StarShape with the specified vertex count, 50% concavity, and zero angle of rotation.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StarShape(
    int vertexCount
)
Visual Basic (Declaration)
Public Sub New ( _
    vertexCount As Integer _
)

Parameters

vertexCount
Type: System..::.Int32
The number of vertices of the shape.

See Also

StarShape Class
StarShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Constructor (Int32, Int32, Double, Int32)

[image]

Telerik Reporting Q2 2012
StarShape Constructor (Int32, Int32, Double, Int32)
StarShape Class See Also Send Feedback
Initializes a new instance of the StarShape with the specified vertex count, concavity, and angle of rotation in degrees.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public StarShape(
    int vertexCount,
    int concavity,
    double angle,
    int rounding
)
Visual Basic (Declaration)
Public Sub New ( _
    vertexCount As Integer, _
    concavity As Integer, _
    angle As Double, _
    rounding As Integer _
)

Parameters

vertexCount
Type: System..::.Int32
The number of vertices of the shape.
concavity
Type: System..::.Int32
The concavity in percent of the shape.
angle
Type: System..::.Double
A double value specifying the angle of rotation of the shape in degrees.
rounding
Type: System..::.Int32
An int value between 0 and 100 specifying the rounding of the edges in percent.

See Also

StarShape Class
StarShape Overload
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Methods

[image] [image]

Telerik Reporting Q2 2012
StarShape Methods
StarShape Class See Also Send Feedback

The StarShape type exposes the following members.

Methods

Name | Description
AddBeziers | Adds a Bezier curve to the shape. (Inherited from ShapeBase.)
AddEllipse | Adds an ellipse to the shape. (Inherited from ShapeBase.)
AddLine | Adds a straight line to the shape. (Inherited from ShapeBase.)
AddLines | Adds a series of straight lines to the shape. (Inherited from ShapeBase.)
Clone | (Overrides ShapeBase..::.Clone()()().)
CreateRawShape | Creates the raw shape. (Inherited from PolygonShapeBase.)
CreateShape | Creates the shape. (Inherited from RoundedCornerShape.)
GetEnumerator | (Inherited from ShapeBase.)
GetPoints | Gets the points of this shape. (Overrides PolygonShapeBase..::.GetPoints(RectangleF).)
RecreateShape | Recreates the shape. (Inherited from ShapeBase.)
ToString | Returns a human-readable representation ot this StarShape. (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IEnumerable<(Of <(IShapeSegment>)>)..::.GetEnumerator | (Inherited from ShapeBase.)

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Clone Method

[image]

Telerik Reporting Q2 2012
StarShape..::.Clone Method
StarShape Class See Also Send Feedback

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override Object Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Object

Implements

ICloneable..::.Clone()()()

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


GetPoints Method

[image]

Telerik Reporting Q2 2012
StarShape..::.GetPoints Method
StarShape Class See Also Send Feedback
Gets the points of this shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override PointF[] GetPoints(
    RectangleF bounds
)
Visual Basic (Declaration)
Protected Overrides Function GetPoints ( _
    bounds As RectangleF _
) As PointF()

Parameters

bounds
Type: System.Drawing..::.RectangleF
The bound of the shape.

Return Value

A point array representing the points of this shape.

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
StarShape..::.ToString Method
StarShape Class See Also Send Feedback
Returns a human-readable representation ot this StarShape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

A human-readable representation ot this StarShape.

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


StarShape Properties

[image] [image]

Telerik Reporting Q2 2012
StarShape Properties
StarShape Class See Also Send Feedback

The StarShape type exposes the following members.

Properties

Name | Description
AngleInRad | Gets the angle of rotation of this shape in radians. (Inherited from ShapeBase.)
Bounds | Gets or sets the bounds of this shape. (Inherited from ShapeBase.)
Concavity | Gets or sets a percent value specifying the concavity of the shape.
Rounding | Gets or sets the rounding factor for the shape. (Inherited from RoundedCornerShape.)
StartAngle | (Inherited from ShapeBase.)
VertexCount | (Inherited from PolygonShapeBase.)

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Concavity Property

[image]

Telerik Reporting Q2 2012
StarShape..::.Concavity Property
StarShape Class See Also Send Feedback
Gets or sets a percent value specifying the concavity of the shape.

Namespace: Telerik.Reporting.Drawing.Shapes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Concavity { get; set; }
Visual Basic (Declaration)
Public Property Concavity As Integer

Field Value

An int value between 0 and 100 specifying the concavity of the shape in percent.

See Also

StarShape Class
Telerik.Reporting.Drawing.Shapes Namespace


Telerik.Reporting.Expressions Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Expressions Namespace
Send Feedback

Classes

Class | Description
AggregateFunctionAttribute | Used to specify the usage and the design time description of the aggregate function. This class cannot be inherited.

Interfaces

Interface | Description
IAggregateFunction | Provides custom (user-defined) implementation for aggregate function.


AggregateFunctionAttribute Class

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute Class
Members Example See Also Send Feedback
Used to specify the usage and the design time description of the aggregate function. This class cannot be inherited.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class AggregateFunctionAttribute : Attribute
Visual Basic (Declaration)
Public NotInheritable Class AggregateFunctionAttribute _
    Inherits Attribute

Examples

This example shows the usage of the attribute.
CopyC#
[AggregateFunction(Description = "Concatenation aggregate. Output: (value1, value2, ...)", Name = "Concatenate")]
class ConcatenateAggregate : IAggregateFunction
{
    string result;

    public void Accumulate(object[] values)
    {
        // The aggregate function expects one parameter
        object value = values[0];

        // null values are not aggregated
        if (null == value)
        {
            return;
        }

        // The actual accumulation
        if (this.result.Length > 0)
        {
            result += ", ";
        }
        this.result += value.ToString();
    }

    public object GetValue()
    {
        return string.Format("({0})", this.result);
    }

    public void Init()
    {
        // Add aggregate function initialization code here if needed
        this.result = string.Empty;
    }

    public void Merge(IAggregateFunction aggregateFunction)
    {
        ConcatenateAggregate aggregate = (ConcatenateAggregate)aggregateFunction;

        if (aggregate.result.Length > 0)
        {
            if (this.result.Length > 0)
            {
                result += ", ";
            }
            this.result += aggregate.result;
        }
    }
}
CopyVB.NET
<AggregateFunction(Description:="Concatenation aggregate. Output: (value1, value2, ...)", Name:="Concatenate")> _
Class ConcatenateAggregate
    Implements IAggregateFunction
    Private result As String

    Public Sub Accumulate(ByVal values As Object()) Implements IAggregateFunction.Accumulate
        ' The aggregate function expects one parameter
        Dim value As Object = values(0)

        ' null values are not aggregated
        If value Is Nothing Then
            Return
        End If

        ' The actual accumulation
        If Me.result.Length > 0 Then
            result += ", "
        End If
        Me.result += value.ToString()
    End Sub

    Public Function GetValue() As Object Implements IAggregateFunction.GetValue
        Return String.Format("({0})", Me.result)
    End Function

    Public Sub Init() Implements IAggregateFunction.Init
        ' Add aggregate function initialization code here if needed
        Me.result = String.Empty
    End Sub

    Public Sub Merge(ByVal aggregateFunction As IAggregateFunction) Implements IAggregateFunction.Merge
        Dim aggregate As ConcatenateAggregate = DirectCast(aggregateFunction, ConcatenateAggregate)

        If aggregate.result.Length > 0 Then
            If Me.result.Length > 0 Then
                result += ", "
            End If
            Me.result += aggregate.result
        End If
    End Sub
End Class

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Expressions..::.AggregateFunctionAttribute

See Also

AggregateFunctionAttribute Members
Telerik.Reporting.Expressions Namespace


AggregateFunctionAttribute Members

[image] [image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute Members
AggregateFunctionAttribute Class Constructors Methods Properties See Also Send Feedback

The AggregateFunctionAttribute type exposes the following members.

Constructors

Name | Description
AggregateFunctionAttribute | Initializes a new instance of the AggregateFunctionAttribute class.

Methods

Name | Description
Equals | Indicates whether this attribute instance and a specified object are equal. (Overrides Attribute..::.Equals(Object).)
GetHashCode | Returns the hash code for this attribute instance. (Overrides Attribute..::.GetHashCode()()().)
IsDefaultAttribute | Determines if this attribute is the default. (Overrides Attribute..::.IsDefaultAttribute()()().)

Properties

Name | Description
Description | Gets the description of the aggregate function displayed in the expression builder.
Name | Gets the name of the aggregate function as it should be used in the expressions.
Visible | Gets a value indicating whether the aggregate should be shown at design time. Default value is true.

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


AggregateFunctionAttribute Constructor

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute Constructor
AggregateFunctionAttribute Class See Also Send Feedback
Initializes a new instance of the AggregateFunctionAttribute class.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AggregateFunctionAttribute()
Visual Basic (Declaration)
Public Sub New

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


AggregateFunctionAttribute Methods

[image] [image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute Methods
AggregateFunctionAttribute Class See Also Send Feedback

The AggregateFunctionAttribute type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this attribute instance and a specified object are equal. (Overrides Attribute..::.Equals(Object).)
GetHashCode | Returns the hash code for this attribute instance. (Overrides Attribute..::.GetHashCode()()().)
IsDefaultAttribute | Determines if this attribute is the default. (Overrides Attribute..::.IsDefaultAttribute()()().)

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


Equals Method

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.Equals Method
AggregateFunctionAttribute Class See Also Send Feedback
Indicates whether this attribute instance and a specified object are equal.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object
Another object to compare to.

Return Value

true if obj is equal to this instance; otherwise, false.

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


GetHashCode Method

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.GetHashCode Method
AggregateFunctionAttribute Class See Also Send Feedback
Returns the hash code for this attribute instance.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

A 32-bit signed integer hash code.

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


IsDefaultAttribute Method

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.IsDefaultAttribute Method
AggregateFunctionAttribute Class See Also Send Feedback
Determines if this attribute is the default.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override bool IsDefaultAttribute()
Visual Basic (Declaration)
Public Overrides Function IsDefaultAttribute As Boolean

Return Value

true if the attribute is the default value for this attribute class; otherwise, false.

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


AggregateFunctionAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute Properties
AggregateFunctionAttribute Class See Also Send Feedback

The AggregateFunctionAttribute type exposes the following members.

Properties

Name | Description
Description | Gets the description of the aggregate function displayed in the expression builder.
Name | Gets the name of the aggregate function as it should be used in the expressions.
Visible | Gets a value indicating whether the aggregate should be shown at design time. Default value is true.

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


Description Property

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.Description Property
AggregateFunctionAttribute Class See Also Send Feedback
Gets the description of the aggregate function displayed in the expression builder.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


Name Property

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.Name Property
AggregateFunctionAttribute Class See Also Send Feedback
Gets the name of the aggregate function as it should be used in the expressions.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
AggregateFunctionAttribute..::.Visible Property
AggregateFunctionAttribute Class See Also Send Feedback
Gets a value indicating whether the aggregate should be shown at design time. Default value is true.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

AggregateFunctionAttribute Class
Telerik.Reporting.Expressions Namespace


IAggregateFunction Interface

[image]

Telerik Reporting Q2 2012
IAggregateFunction Interface
Members Example See Also Send Feedback
Provides custom (user-defined) implementation for aggregate function.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IAggregateFunction
Visual Basic (Declaration)
Public Interface IAggregateFunction

Remarks

Implement this interface to provide custom logic when aggregating values over a set of rows from the data source. Apply the AggregateFunctionAttribute class to the aggregate implementation in order to set the name and description of the aggregate function. If no AggregateFunctionAttribute is defined, the name of the aggregate function is the name of the actual type that implements the IAggregateFunction interface. The word "Aggregate" is trimmed from the type name if it ends with it.

Examples

This example shows how to implement user-defined aggregate.
CopyC#
[AggregateFunction(Description = "Concatenation aggregate. Output: (value1, value2, ...)", Name = "Concatenate")]
class ConcatenateAggregate : IAggregateFunction
{
    string result;

    public void Accumulate(object[] values)
    {
        // The aggregate function expects one parameter
        object value = values[0];

        // null values are not aggregated
        if (null == value)
        {
            return;
        }

        // The actual accumulation
        if (this.result.Length > 0)
        {
            result += ", ";
        }
        this.result += value.ToString();
    }

    public object GetValue()
    {
        return string.Format("({0})", this.result);
    }

    public void Init()
    {
        // Add aggregate function initialization code here if needed
        this.result = string.Empty;
    }

    public void Merge(IAggregateFunction aggregateFunction)
    {
        ConcatenateAggregate aggregate = (ConcatenateAggregate)aggregateFunction;

        if (aggregate.result.Length > 0)
        {
            if (this.result.Length > 0)
            {
                result += ", ";
            }
            this.result += aggregate.result;
        }
    }
}
CopyVB.NET
<AggregateFunction(Description:="Concatenation aggregate. Output: (value1, value2, ...)", Name:="Concatenate")> _
Class ConcatenateAggregate
    Implements IAggregateFunction
    Private result As String

    Public Sub Accumulate(ByVal values As Object()) Implements IAggregateFunction.Accumulate
        ' The aggregate function expects one parameter
        Dim value As Object = values(0)

        ' null values are not aggregated
        If value Is Nothing Then
            Return
        End If

        ' The actual accumulation
        If Me.result.Length > 0 Then
            result += ", "
        End If
        Me.result += value.ToString()
    End Sub

    Public Function GetValue() As Object Implements IAggregateFunction.GetValue
        Return String.Format("({0})", Me.result)
    End Function

    Public Sub Init() Implements IAggregateFunction.Init
        ' Add aggregate function initialization code here if needed
        Me.result = String.Empty
    End Sub

    Public Sub Merge(ByVal aggregateFunction As IAggregateFunction) Implements IAggregateFunction.Merge
        Dim aggregate As ConcatenateAggregate = DirectCast(aggregateFunction, ConcatenateAggregate)

        If aggregate.result.Length > 0 Then
            If Me.result.Length > 0 Then
                result += ", "
            End If
            Me.result += aggregate.result
        End If
    End Sub
End Class

See Also

IAggregateFunction Members
Telerik.Reporting.Expressions Namespace


IAggregateFunction Members

[image] [image]

Telerik Reporting Q2 2012
IAggregateFunction Members
IAggregateFunction Interface Methods See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
Accumulate | Accumulates the passed values in the aggregate.
GetValue | Gets the value that the aggregate instance keeps currently accumulated.
Init | Initializes the aggregate function instance. Implement to set the aggregate in its initial state ready to accumulate and merge values.
Merge | Merges another instance of the same aggregate function into the current instance. Implement this method to allow the reporting engine to merge the two resulting aggregates coming from two subsets of the aggregated data source rows.

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


IAggregateFunction Methods

[image] [image]

Telerik Reporting Q2 2012
IAggregateFunction Methods
IAggregateFunction Interface See Also Send Feedback

The IAggregateFunction type exposes the following members.

Methods

Name | Description
Accumulate | Accumulates the passed values in the aggregate.
GetValue | Gets the value that the aggregate instance keeps currently accumulated.
Init | Initializes the aggregate function instance. Implement to set the aggregate in its initial state ready to accumulate and merge values.
Merge | Merges another instance of the same aggregate function into the current instance. Implement this method to allow the reporting engine to merge the two resulting aggregates coming from two subsets of the aggregated data source rows.

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


Accumulate Method

[image]

Telerik Reporting Q2 2012
IAggregateFunction..::.Accumulate Method
IAggregateFunction Interface See Also Send Feedback
Accumulates the passed values in the aggregate.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Accumulate(
    Object[] values
)
Visual Basic (Declaration)
Sub Accumulate ( _
    values As Object() _
)

Parameters

values
Type: array< System..::.Object >[]()[][]
The values that will be accumulated on a single accumulation operation. The length of the values array equals to the number of parameters that the defined aggregate expects (most common one).

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


GetValue Method

[image]

Telerik Reporting Q2 2012
IAggregateFunction..::.GetValue Method
IAggregateFunction Interface See Also Send Feedback
Gets the value that the aggregate instance keeps currently accumulated.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object GetValue()
Visual Basic (Declaration)
Function GetValue As Object

Return Value

Returns the currently accumulated value.

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


Init Method

[image]

Telerik Reporting Q2 2012
IAggregateFunction..::.Init Method
IAggregateFunction Interface See Also Send Feedback
Initializes the aggregate function instance. Implement to set the aggregate in its initial state ready to accumulate and merge values.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Init()
Visual Basic (Declaration)
Sub Init

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


Merge Method

[image]

Telerik Reporting Q2 2012
IAggregateFunction..::.Merge Method
IAggregateFunction Interface See Also Send Feedback
Merges another instance of the same aggregate function into the current instance. Implement this method to allow the reporting engine to merge the two resulting aggregates coming from two subsets of the aggregated data source rows.

Namespace: Telerik.Reporting.Expressions
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Merge(
    IAggregateFunction aggregateFunction
)
Visual Basic (Declaration)
Sub Merge ( _
    aggregateFunction As IAggregateFunction _
)

Parameters

aggregateFunction
Type: Telerik.Reporting.Expressions..::.IAggregateFunction
Another instance of the same aggregate function that will be merged in the current instance.

See Also

IAggregateFunction Interface
Telerik.Reporting.Expressions Namespace


Telerik.Reporting.Interfaces Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Interfaces Namespace
Send Feedback

Interfaces

Interface | Description
IConverterLog |
IReportConverter |


IConverterLog Interface

[image]

Telerik Reporting Q2 2012
IConverterLog Interface
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IConverterLog
Visual Basic (Declaration)
Public Interface IConverterLog

See Also

IConverterLog Members
Telerik.Reporting.Interfaces Namespace


IConverterLog Members

[image] [image]

Telerik Reporting Q2 2012
IConverterLog Members
IConverterLog Interface Methods See Also Send Feedback

The IConverterLog type exposes the following members.

Methods

Name | Description
Log |
LogError |
LogWarning |

See Also

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


IConverterLog Methods

[image] [image]

Telerik Reporting Q2 2012
IConverterLog Methods
IConverterLog Interface See Also Send Feedback

The IConverterLog type exposes the following members.

Methods

Name | Description
Log |
LogError |
LogWarning |

See Also

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


Log Method

[image]

Telerik Reporting Q2 2012
IConverterLog..::.Log Method
IConverterLog Interface See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Log(
    string message
)
Visual Basic (Declaration)
Sub Log ( _
    message As String _
)

Parameters

message
Type: System..::.String

See Also

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


LogError Method

[image]

Telerik Reporting Q2 2012
IConverterLog..::.LogError Method
IConverterLog Interface See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void LogError(
    string message
)
Visual Basic (Declaration)
Sub LogError ( _
    message As String _
)

Parameters

message
Type: System..::.String

See Also

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


LogWarning Method

[image]

Telerik Reporting Q2 2012
IConverterLog..::.LogWarning Method
IConverterLog Interface See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void LogWarning(
    string message
)
Visual Basic (Declaration)
Sub LogWarning ( _
    message As String _
)

Parameters

message
Type: System..::.String

See Also

IConverterLog Interface
Telerik.Reporting.Interfaces Namespace


IReportConverter Interface

[image]

Telerik Reporting Q2 2012
IReportConverter Interface
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IReportConverter : IExtension,
    IDisposable
Visual Basic (Declaration)
Public Interface IReportConverter _
    Implements IExtension, IDisposable

See Also

IReportConverter Members
Telerik.Reporting.Interfaces Namespace


IReportConverter Members

[image] [image]

Telerik Reporting Q2 2012
IReportConverter Members
IReportConverter Interface Methods See Also Send Feedback

The IReportConverter type exposes the following members.

Methods

Name | Description
BrowseForSource |
Convert |
Initialize | Initializes the current extension with default settings (Inherited from IExtension.)

See Also

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


IReportConverter Methods

[image] [image]

Telerik Reporting Q2 2012
IReportConverter Methods
IReportConverter Interface See Also Send Feedback

The IReportConverter type exposes the following members.

Methods

Name | Description
BrowseForSource |
Convert |
Initialize | Initializes the current extension with default settings (Inherited from IExtension.)

See Also

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


BrowseForSource Method

[image]

Telerik Reporting Q2 2012
IReportConverter..::.BrowseForSource Method
IReportConverter Interface See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object BrowseForSource(
    IServiceProvider serviceProvider
)
Visual Basic (Declaration)
Function BrowseForSource ( _
    serviceProvider As IServiceProvider _
) As Object

Parameters

serviceProvider
Type: System..::.IServiceProvider

See Also

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
IReportConverter..::.Convert Method
IReportConverter Interface See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Convert(
    Object source,
    IServiceProvider serviceProvider,
    IConverterLog log,
    Hashtable context
)
Visual Basic (Declaration)
Sub Convert ( _
    source As Object, _
    serviceProvider As IServiceProvider, _
    log As IConverterLog, _
    context As Hashtable _
)

Parameters

source
Type: System..::.Object
serviceProvider
Type: System..::.IServiceProvider
log
Type: Telerik.Reporting.Interfaces..::.IConverterLog
context
Type: System.Collections..::.Hashtable
Reserved for future use

See Also

IReportConverter Interface
Telerik.Reporting.Interfaces Namespace


Telerik.Reporting.Interfaces.Attributes Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Interfaces.Attributes Namespace
Send Feedback

Classes

Class | Description
ExtensionAttribute | The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base
ExtensionDescriptionAttribute |
ExtensionLocalizedDescriptionAttribute |
ExtensionNameAttribute |
ExtensionParameterAttribute |
ExtensionVisibleAttribute |


ExtensionAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionAttribute Class
Members See Also Send Feedback
The base attribute. This attribute intended for types which we want to use for extension. Each other attribute must derived from the base

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ExtensionAttribute : Attribute
Visual Basic (Declaration)
Public MustInherit Class ExtensionAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionNameAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionParameterAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionVisibleAttribute

See Also

ExtensionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionAttribute Members
ExtensionAttribute Class Constructors See Also Send Feedback

The ExtensionAttribute type exposes the following members.

Constructors

Name | Description
ExtensionAttribute | Initializes a new instance of the ExtensionAttribute class

See Also

ExtensionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionAttribute Constructor
ExtensionAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected ExtensionAttribute()
Visual Basic (Declaration)
Protected Sub New

See Also

ExtensionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionDescriptionAttribute Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtensionDescriptionAttribute : ExtensionAttribute
Visual Basic (Declaration)
Public Class ExtensionDescriptionAttribute _
    Inherits ExtensionAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionLocalizedDescriptionAttribute

See Also

ExtensionDescriptionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionDescriptionAttribute Members
ExtensionDescriptionAttribute Class Constructors Properties See Also Send Feedback

The ExtensionDescriptionAttribute type exposes the following members.

Constructors

Name | Description
ExtensionDescriptionAttribute | Initializes a new instance of the ExtensionDescriptionAttribute class

Properties

Name | Description
Description |

See Also

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionDescriptionAttribute Constructor
ExtensionDescriptionAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionDescriptionAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionDescriptionAttribute(
    string description
)
Visual Basic (Declaration)
Public Sub New ( _
    description As String _
)

Parameters

description
Type: System..::.String

See Also

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionDescriptionAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionDescriptionAttribute Properties
ExtensionDescriptionAttribute Class See Also Send Feedback

The ExtensionDescriptionAttribute type exposes the following members.

Properties

Name | Description
Description |

See Also

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Description Property

[image]

Telerik Reporting Q2 2012
ExtensionDescriptionAttribute..::.Description Property
ExtensionDescriptionAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Description { get; }
Visual Basic (Declaration)
Public ReadOnly Property Description As String

See Also

ExtensionDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionLocalizedDescriptionAttribute Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtensionLocalizedDescriptionAttribute : ExtensionDescriptionAttribute
Visual Basic (Declaration)
Public Class ExtensionLocalizedDescriptionAttribute _
    Inherits ExtensionDescriptionAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionDescriptionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionLocalizedDescriptionAttribute

See Also

ExtensionLocalizedDescriptionAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionLocalizedDescriptionAttribute Members
ExtensionLocalizedDescriptionAttribute Class Constructors Properties See Also Send Feedback

The ExtensionLocalizedDescriptionAttribute type exposes the following members.

Constructors

Name | Description
ExtensionLocalizedDescriptionAttribute | Initializes a new instance of the ExtensionLocalizedDescriptionAttribute class

Properties

Name | Description
Description | (Inherited from ExtensionDescriptionAttribute.)

See Also

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionLocalizedDescriptionAttribute Constructor
ExtensionLocalizedDescriptionAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionLocalizedDescriptionAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionLocalizedDescriptionAttribute(
    string description
)
Visual Basic (Declaration)
Public Sub New ( _
    description As String _
)

Parameters

description
Type: System..::.String

See Also

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionLocalizedDescriptionAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionLocalizedDescriptionAttribute Properties
ExtensionLocalizedDescriptionAttribute Class See Also Send Feedback

The ExtensionLocalizedDescriptionAttribute type exposes the following members.

Properties

Name | Description
Description | (Inherited from ExtensionDescriptionAttribute.)

See Also

ExtensionLocalizedDescriptionAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionNameAttribute Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtensionNameAttribute : ExtensionAttribute
Visual Basic (Declaration)
Public Class ExtensionNameAttribute _
    Inherits ExtensionAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionNameAttribute

See Also

ExtensionNameAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionNameAttribute Members
ExtensionNameAttribute Class Constructors Properties See Also Send Feedback

The ExtensionNameAttribute type exposes the following members.

Constructors

Name | Description
ExtensionNameAttribute | Initializes a new instance of the ExtensionNameAttribute class

Properties

Name | Description
Name |

See Also

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionNameAttribute Constructor
ExtensionNameAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionNameAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionNameAttribute(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String

See Also

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionNameAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionNameAttribute Properties
ExtensionNameAttribute Class See Also Send Feedback

The ExtensionNameAttribute type exposes the following members.

Properties

Name | Description
Name |

See Also

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ExtensionNameAttribute..::.Name Property
ExtensionNameAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ExtensionNameAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtensionParameterAttribute : ExtensionAttribute
Visual Basic (Declaration)
Public Class ExtensionParameterAttribute _
    Inherits ExtensionAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionParameterAttribute

See Also

ExtensionParameterAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute Members
ExtensionParameterAttribute Class Constructors Properties See Also Send Feedback

The ExtensionParameterAttribute type exposes the following members.

Constructors

Name | Description
ExtensionParameterAttribute | Initializes a new instance of the ExtensionParameterAttribute class

Properties

Name | Description
DefaultValue |
Name |
ParamType |

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute Constructor
ExtensionParameterAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionParameterAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionParameterAttribute(
    string name,
    Type paramType,
    Object defaultValue
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    paramType As Type, _
    defaultValue As Object _
)

Parameters

name
Type: System..::.String
paramType
Type: System..::.Type
defaultValue
Type: System..::.Object

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionParameterAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute Properties
ExtensionParameterAttribute Class See Also Send Feedback

The ExtensionParameterAttribute type exposes the following members.

Properties

Name | Description
DefaultValue |
Name |
ParamType |

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


DefaultValue Property

[image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute..::.DefaultValue Property
ExtensionParameterAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DefaultValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultValue As Object

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute..::.Name Property
ExtensionParameterAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ParamType Property

[image]

Telerik Reporting Q2 2012
ExtensionParameterAttribute..::.ParamType Property
ExtensionParameterAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Type ParamType { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParamType As Type

See Also

ExtensionParameterAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Class

[image]

Telerik Reporting Q2 2012
ExtensionVisibleAttribute Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ExtensionVisibleAttribute : ExtensionAttribute
Visual Basic (Declaration)
Public Class ExtensionVisibleAttribute _
    Inherits ExtensionAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionAttribute
Telerik.Reporting.Interfaces.Attributes..::.ExtensionVisibleAttribute

See Also

ExtensionVisibleAttribute Members
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionVisibleAttribute Members
ExtensionVisibleAttribute Class Constructors Properties See Also Send Feedback

The ExtensionVisibleAttribute type exposes the following members.

Constructors

Name | Description
ExtensionVisibleAttribute | Initializes a new instance of the ExtensionVisibleAttribute class

Properties

Name | Description
Visible |

See Also

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Constructor

[image]

Telerik Reporting Q2 2012
ExtensionVisibleAttribute Constructor
ExtensionVisibleAttribute Class See Also Send Feedback
Initializes a new instance of the ExtensionVisibleAttribute class

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionVisibleAttribute(
    bool visible
)
Visual Basic (Declaration)
Public Sub New ( _
    visible As Boolean _
)

Parameters

visible
Type: System..::.Boolean

See Also

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


ExtensionVisibleAttribute Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionVisibleAttribute Properties
ExtensionVisibleAttribute Class See Also Send Feedback

The ExtensionVisibleAttribute type exposes the following members.

Properties

Name | Description
Visible |

See Also

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ExtensionVisibleAttribute..::.Visible Property
ExtensionVisibleAttribute Class See Also Send Feedback

Namespace: Telerik.Reporting.Interfaces.Attributes
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visible As Boolean

See Also

ExtensionVisibleAttribute Class
Telerik.Reporting.Interfaces.Attributes Namespace


Telerik.Reporting.Paging.InteractiveLayout Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Paging.InteractiveLayout Namespace
Send Feedback

Classes

Class | Description
ReportSectionBehavior |


ReportSectionBehavior Class

[image]

Telerik Reporting Q2 2012
ReportSectionBehavior Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Paging.InteractiveLayout
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportSectionBehavior
Visual Basic (Declaration)
Public Class ReportSectionBehavior

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Paging.InteractiveLayout..::.ReportSectionBehavior

See Also

ReportSectionBehavior Members
Telerik.Reporting.Paging.InteractiveLayout Namespace


ReportSectionBehavior Members

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBehavior Members
ReportSectionBehavior Class Constructors See Also Send Feedback

The ReportSectionBehavior type exposes the following members.

Constructors

Name | Description
ReportSectionBehavior | Initializes a new instance of the ReportSectionBehavior class

See Also

ReportSectionBehavior Class
Telerik.Reporting.Paging.InteractiveLayout Namespace


ReportSectionBehavior Constructor

[image]

Telerik Reporting Q2 2012
ReportSectionBehavior Constructor
ReportSectionBehavior Class See Also Send Feedback
Initializes a new instance of the ReportSectionBehavior class

Namespace: Telerik.Reporting.Paging.InteractiveLayout
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportSectionBehavior()
Visual Basic (Declaration)
Public Sub New

See Also

ReportSectionBehavior Class
Telerik.Reporting.Paging.InteractiveLayout Namespace


Telerik.Reporting.Processing Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Processing Namespace
Send Feedback

Classes

Class | Description
Barcode |
BookmarkNode |
CancelProcessingException |
Chart | Summary description for ReportItem class.
CheckBox | CheckBox
DetailSection |
ElementTreeHelper | Provides utility methods that perform common tasks involving nodes in a LayoutElement tree.
Group |
GroupSection |
HtmlTextBox |
LayoutElement | Base class for all processing instances of report items.
PageSection |
Panel |
Parameter | Represents a processing instance of a ReportParameter.
ParameterValue | Represents a parameter value.
PictureBox |
PictureWatermark |
ProcessingElement |
ProcessingElement..::.ElementCollection | Obsolete.
RenderingResult | Represents a result of the report rendering.
Report |
ReportItem |
ReportItemBase | Represents a processing report item.
ReportProcessor | Represents the object responsible for printing and rendering Reports.
ReportSection |
ReportSectionBase |
Shape |
SubReport |
Table | Represents a processing Table item.
TableColumn | Represents a column in the Table()()() item.
TableRow | Represents a row in the Table()()() item.
TextBox |
TextItemBase | Base class for TextBox and CheckBox classes
TextWatermark |
VisualElement |
Watermark |
WatermarkCollection |

Interfaces

Interface | Description
IDataGroupMember | Provides an unified access to the data of a group member
IDataObject | Provides unified access to a single data record from a data source.
ILayoutElementContainer | Represents an item that may contain other LayoutElements
IRenderingExtension |
ITableCell | Provides an interface for accessing a processing Table cell.

Delegates

Delegate | Description
CreateStream |
EvaluateHeaderFooterExpressions |


Barcode Class

[image]

Telerik Reporting Q2 2012
Barcode Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Barcode : ReportItem
Visual Basic (Declaration)
Public Class Barcode _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Barcode

See Also

Barcode Members
Telerik.Reporting.Processing Namespace


Barcode Members

[image] [image]

Telerik Reporting Q2 2012
Barcode Members
Barcode Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Barcode type exposes the following members.

Constructors

Name | Description
Barcode | Initializes a new instance of the Barcode class

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Angle |
BarAlign |
Bounds | (Inherited from ReportItem.)
Checksum |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Module |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ShowText |
Size | (Inherited from ReportItem.)
Stretch |
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Value |
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Barcode Constructor

[image]

Telerik Reporting Q2 2012
Barcode Constructor
Barcode Class See Also Send Feedback
Initializes a new instance of the Barcode class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Barcode(
    ReportItemBase source
)
Visual Basic (Declaration)
Public Sub New ( _
    source As ReportItemBase _
)

Parameters

source
Type: Telerik.Reporting..::.ReportItemBase

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Barcode Methods

[image] [image]

Telerik Reporting Q2 2012
Barcode Methods
Barcode Class See Also Send Feedback

The Barcode type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Barcode..::.ToString Method
Barcode Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Barcode Class
Barcode Members
Telerik.Reporting.Processing Namespace


Barcode Properties

[image] [image]

Telerik Reporting Q2 2012
Barcode Properties
Barcode Class See Also Send Feedback

The Barcode type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Angle |
BarAlign |
Bounds | (Inherited from ReportItem.)
Checksum |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Module |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ShowText |
Size | (Inherited from ReportItem.)
Stretch |
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Value |
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Angle Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Angle Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


BarAlign Property

[image]

Telerik Reporting Q2 2012
Barcode..::.BarAlign Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public HorizontalAlign BarAlign { get; set; }
Visual Basic (Declaration)
Public Property BarAlign As HorizontalAlign

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Checksum Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Checksum Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Checksum { get; set; }
Visual Basic (Declaration)
Public Property Checksum As Boolean

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Module Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Module Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Module { get; set; }
Visual Basic (Declaration)
Public Property Module As Unit

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


ShowText Property

[image]

Telerik Reporting Q2 2012
Barcode..::.ShowText Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ShowText { get; set; }
Visual Basic (Declaration)
Public Property ShowText As Boolean

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Stretch Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Stretch Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Stretch { get; set; }
Visual Basic (Declaration)
Public Property Stretch As Boolean

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Barcode..::.Value Property
Barcode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

Barcode Class
Telerik.Reporting.Processing Namespace


BookmarkNode Class

[image]

Telerik Reporting Q2 2012
BookmarkNode Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[SerializableAttribute]
public class BookmarkNode
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class BookmarkNode

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.BookmarkNode

See Also

BookmarkNode Members
Telerik.Reporting.Processing Namespace


BookmarkNode Members

[image] [image]

Telerik Reporting Q2 2012
BookmarkNode Members
BookmarkNode Class Constructors Methods Properties See Also Send Feedback

The BookmarkNode type exposes the following members.

Constructors

Name | Description
BookmarkNode | Initializes a new instance of the BookmarkNode class

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Children |
Id |
Page |
Text |
X |
Y |

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


BookmarkNode Constructor

[image]

Telerik Reporting Q2 2012
BookmarkNode Constructor
BookmarkNode Class See Also Send Feedback
Initializes a new instance of the BookmarkNode class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public BookmarkNode()
Visual Basic (Declaration)
Public Sub New

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


BookmarkNode Methods

[image] [image]

Telerik Reporting Q2 2012
BookmarkNode Methods
BookmarkNode Class See Also Send Feedback

The BookmarkNode type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.ToString Method
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


BookmarkNode Properties

[image] [image]

Telerik Reporting Q2 2012
BookmarkNode Properties
BookmarkNode Class See Also Send Feedback

The BookmarkNode type exposes the following members.

Properties

Name | Description
Children |
Id |
Page |
Text |
X |
Y |

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


Children Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Children Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public List<BookmarkNode> Children { get; set; }
Visual Basic (Declaration)
Public Property Children As List(Of BookmarkNode)

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


Id Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Id Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


Page Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Page Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Page { get; set; }
Visual Basic (Declaration)
Public Property Page As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Text Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


X Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.X Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


Y Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Y Property
BookmarkNode Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Processing Namespace


CancelProcessingException Class

[image]

Telerik Reporting Q2 2012
CancelProcessingException Class
See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CancelProcessingException : Exception
Visual Basic (Declaration)
Public Class CancelProcessingException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Telerik.Reporting.Processing..::.CancelProcessingException

See Also

Telerik.Reporting.Processing Namespace


Chart Class

[image]

Telerik Reporting Q2 2012
Chart Class
Members See Also Send Feedback
Summary description for ReportItem class.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Chart : ReportItem
Visual Basic (Declaration)
Public Class Chart _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Chart

See Also

Chart Members
Telerik.Reporting.Processing Namespace


Chart Members

[image] [image]

Telerik Reporting Q2 2012
Chart Members
Chart Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the Chart and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataMember | Obsolete.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource |
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Chart Class
Telerik.Reporting.Processing Namespace


Chart Methods

[image] [image]

Telerik Reporting Q2 2012
Chart Methods
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Chart Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
Chart..::.Dispose Method
Chart Class See Also Send Feedback
Releases the unmanaged resources used by the Chart and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

Chart Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Chart..::.ToString Method
Chart Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Chart Class
Chart Members
Telerik.Reporting.Processing Namespace


Chart Properties

[image] [image]

Telerik Reporting Q2 2012
Chart Properties
Chart Class See Also Send Feedback

The Chart type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataMember | Obsolete.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource |
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Chart Class
Telerik.Reporting.Processing Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Chart..::.DataMember Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

See Also

Chart Class
Telerik.Reporting.Processing Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Chart..::.DataSource Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

See Also

Chart Class
Telerik.Reporting.Processing Namespace


CheckBox Class

[image]

Telerik Reporting Q2 2012
CheckBox Class
Members See Also Send Feedback
CheckBox

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class CheckBox : TextItemBase, ILayoutElementContainer
Visual Basic (Declaration)
Public Class CheckBox _
    Inherits TextItemBase _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.TextItemBase
Telerik.Reporting.Processing..::.CheckBox

See Also

CheckBox Members
Telerik.Reporting.Processing Namespace


CheckBox Members

[image] [image]

Telerik Reporting Q2 2012
CheckBox Members
CheckBox Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The CheckBox type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the CheckBox and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
CheckAlign |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
FalseValue |
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | (Inherited from ReportItem.)
IndeterminateValue |
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Text |
Top | (Inherited from ReportItem.)
TrueValue |
Value | Gets or sets the value of the processing instance of the check box. Can be set directly to CheckState value.
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


CheckBox Methods

[image] [image]

Telerik Reporting Q2 2012
CheckBox Methods
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
CheckBox..::.Dispose Method
CheckBox Class See Also Send Feedback
Releases the unmanaged resources used by the CheckBox and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
CheckBox..::.ToString Method
CheckBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides ProcessingElement..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

CheckBox Class
CheckBox Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
CheckBox..::.ToString Method
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

CheckBox Class
ToString Overload
Telerik.Reporting.Processing Namespace


CheckBox Properties

[image] [image]

Telerik Reporting Q2 2012
CheckBox Properties
CheckBox Class See Also Send Feedback

The CheckBox type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
CheckAlign |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
FalseValue |
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | (Inherited from ReportItem.)
IndeterminateValue |
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Text |
Top | (Inherited from ReportItem.)
TrueValue |
Value | Gets or sets the value of the processing instance of the check box. Can be set directly to CheckState value.
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


CheckAlign Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.CheckAlign Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ContentAlignment CheckAlign { get; set; }
Visual Basic (Declaration)
Public Property CheckAlign As ContentAlignment

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


FalseValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.FalseValue Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object FalseValue { get; set; }
Visual Basic (Declaration)
Public Property FalseValue As Object

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.ILayoutElementContainer..::.Children Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


IndeterminateValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.IndeterminateValue Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object IndeterminateValue { get; set; }
Visual Basic (Declaration)
Public Property IndeterminateValue As Object

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.Text Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


TrueValue Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.TrueValue Property
CheckBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object TrueValue { get; set; }
Visual Basic (Declaration)
Public Property TrueValue As Object

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
CheckBox..::.Value Property
CheckBox Class See Also Send Feedback
Gets or sets the value of the processing instance of the check box. Can be set directly to CheckState value.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

CheckBox Class
Telerik.Reporting.Processing Namespace


CreateStream Delegate

[image]

Telerik Reporting Q2 2012
CreateStream Delegate
See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate Stream CreateStream(
    string name,
    string extension,
    Encoding encoding,
    string mimeType
)
Visual Basic (Declaration)
Public Delegate Function CreateStream ( _
    name As String, _
    extension As String, _
    encoding As Encoding, _
    mimeType As String _
) As Stream

Parameters

name
Type: System..::.String
extension
Type: System..::.String
encoding
Type: System.Text..::.Encoding
mimeType
Type: System..::.String

See Also

Telerik.Reporting.Processing Namespace


DetailSection Class

[image]

Telerik Reporting Q2 2012
DetailSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class DetailSection : ReportSection
Visual Basic (Declaration)
Public Class DetailSection _
    Inherits ReportSection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportSectionBase
Telerik.Reporting.Processing..::.ReportSection
Telerik.Reporting.Processing..::.DetailSection

See Also

DetailSection Members
Telerik.Reporting.Processing Namespace


DetailSection Members

[image] [image]

Telerik Reporting Q2 2012
DetailSection Members
DetailSection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The DetailSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | (Inherited from ReportSection.)
Name | (Inherited from ReportItemBase.)
PageBreak | (Inherited from ReportSection.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

DetailSection Class
Telerik.Reporting.Processing Namespace


DetailSection Methods

[image] [image]

Telerik Reporting Q2 2012
DetailSection Methods
DetailSection Class See Also Send Feedback

The DetailSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

DetailSection Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
DetailSection..::.ToString Method
DetailSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

DetailSection Class
DetailSection Members
Telerik.Reporting.Processing Namespace


DetailSection Properties

[image] [image]

Telerik Reporting Q2 2012
DetailSection Properties
DetailSection Class See Also Send Feedback

The DetailSection type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | (Inherited from ReportSection.)
Name | (Inherited from ReportItemBase.)
PageBreak | (Inherited from ReportSection.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)

See Also

DetailSection Class
Telerik.Reporting.Processing Namespace


ElementTreeHelper Class

[image]

Telerik Reporting Q2 2012
ElementTreeHelper Class
Members See Also Send Feedback
Provides utility methods that perform common tasks involving nodes in a LayoutElement tree.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static class ElementTreeHelper
Visual Basic (Declaration)
Public NotInheritable Class ElementTreeHelper

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.ElementTreeHelper

See Also

ElementTreeHelper Members
Telerik.Reporting.Processing Namespace


ElementTreeHelper Members

[image] [image]

Telerik Reporting Q2 2012
ElementTreeHelper Members
ElementTreeHelper Class Methods See Also Send Feedback

The ElementTreeHelper type exposes the following members.

Methods

Name | Description
ContainsChildWithName | Determines whether a parent layout element contains immediate child having a specified name.
FindChildByName | Searches for all layout elements with a specified name within a specified parent.
GetChildByIndex | Returns the immediate child layout element within a specified parent at specified index.
GetChildByName | Returns the first immediate child layout element within a specified parent having a specified name.
GetChildElements | Returns all immediate child layout elements within a specified parent.
IndexOfChildWithName | Returns the zero-based index of the first occurrence of a layout element with a specified name within a parent.

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


ElementTreeHelper Methods

[image] [image]

Telerik Reporting Q2 2012
ElementTreeHelper Methods
ElementTreeHelper Class See Also Send Feedback

The ElementTreeHelper type exposes the following members.

Methods

Name | Description
ContainsChildWithName | Determines whether a parent layout element contains immediate child having a specified name.
FindChildByName | Searches for all layout elements with a specified name within a specified parent.
GetChildByIndex | Returns the immediate child layout element within a specified parent at specified index.
GetChildByName | Returns the first immediate child layout element within a specified parent having a specified name.
GetChildElements | Returns all immediate child layout elements within a specified parent.
IndexOfChildWithName | Returns the zero-based index of the first occurrence of a layout element with a specified name within a parent.

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


ContainsChildWithName Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.ContainsChildWithName Method
ElementTreeHelper Class Example See Also Send Feedback
Determines whether a parent layout element contains immediate child having a specified name.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static bool ContainsChildWithName(
    LayoutElement parent,
    string name
)
Visual Basic (Declaration)
Public Shared Function ContainsChildWithName ( _
    parent As LayoutElement, _
    name As String _
) As Boolean

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element to search within.
name
Type: System..::.String
The name to search for.

Return Value

true if an layout element having the specified parent and name is found; Otherwise, false.

Examples

This example shows how to determine if a child with name is contained in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_ContainsChildWithName(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    if (Processing.ElementTreeHelper.ContainsChildWithName(processingInstance, "textBox1"))
    {
        processingInstance.Style.BackgroundColor = System.Drawing.Color.Blue;
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_ContainsChildWithName(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    If Processing.ElementTreeHelper.ContainsChildWithName(processingInstance, "textBox1") Then
        processingInstance.Style.BackgroundColor = System.Drawing.Color.Blue
    End If
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


FindChildByName Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.FindChildByName Method
ElementTreeHelper Class Example See Also Send Feedback
Searches for all layout elements with a specified name within a specified parent.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static LayoutElement[] FindChildByName(
    LayoutElement parent,
    string name,
    bool searchAllChildren
)
Visual Basic (Declaration)
Public Shared Function FindChildByName ( _
    parent As LayoutElement, _
    name As String, _
    searchAllChildren As Boolean _
) As LayoutElement()

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element to search within.
name
Type: System..::.String
The name to search for.
searchAllChildren
Type: System..::.Boolean
If true, all descendants within the specified parent are matched (deep search). Otherwise, only immediate children are matched.

Return Value

Array containing all matching by name children / descendants. If no elements are found an empty array is returned

Examples

This example shows how to find all children with name in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_FindChildByName(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    Processing.LayoutElement[] elements = Processing.ElementTreeHelper.FindChildByName(processingInstance, "textBox1", true);
    foreach (Processing.LayoutElement child in elements)
    {
        Processing.VisualElement visualChild = child as Processing.VisualElement;
        if (null != visualChild)
        {
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_FindChildByName(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim elements As Processing.LayoutElement() = Processing.ElementTreeHelper.FindChildByName(processingInstance, "textBox1", True)
    For Each child As Processing.LayoutElement In elements
        Dim visualChild As Processing.VisualElement = TryCast(child, Processing.VisualElement)
        If visualChild IsNot Nothing Then
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
        End If
    Next
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


GetChildByIndex Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.GetChildByIndex Method
ElementTreeHelper Class Example See Also Send Feedback
Returns the immediate child layout element within a specified parent at specified index.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static LayoutElement GetChildByIndex(
    LayoutElement parent,
    int index
)
Visual Basic (Declaration)
Public Shared Function GetChildByIndex ( _
    parent As LayoutElement, _
    index As Integer _
) As LayoutElement

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element to search within.
index
Type: System..::.Int32
The zero-based index of the child to get.

Return Value

Layout element having the specified parent at the specified index.

Examples

This example shows how to access a child by index in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_IndexOfChildWithName_And_GetChildByIndex(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    int index = Processing.ElementTreeHelper.IndexOfChildWithName(processingInstance, "textBox1");
    if (index >= 0)
    {
        Processing.LayoutElement child = Processing.ElementTreeHelper.GetChildByIndex(processingInstance, index);
        Processing.VisualElement visualChild = child as Processing.VisualElement;
        if (null != visualChild)
        {
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_IndexOfChildWithName_And_GetChildByIndex(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim index As Integer = Processing.ElementTreeHelper.IndexOfChildWithName(processingInstance, "textBox1")
    If index >= 0 Then
        Dim child As Processing.LayoutElement = Processing.ElementTreeHelper.GetChildByIndex(processingInstance, index)
        Dim visualChild As Processing.VisualElement = TryCast(child, Processing.VisualElement)
        If visualChild IsNot Nothing Then
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
        End If
    End If
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


GetChildByName Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.GetChildByName Method
ElementTreeHelper Class Example See Also Send Feedback
Returns the first immediate child layout element within a specified parent having a specified name.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static LayoutElement GetChildByName(
    LayoutElement parent,
    string name
)
Visual Basic (Declaration)
Public Shared Function GetChildByName ( _
    parent As LayoutElement, _
    name As String _
) As LayoutElement

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element to search within.
name
Type: System..::.String
The name to search for.

Return Value

Layout element having the specified name and parent.

Examples

This example shows how to get a child by name in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_GetChildByName(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    Processing.LayoutElement child = Processing.ElementTreeHelper.GetChildByName(processingInstance, "textBox1");
    Processing.VisualElement visualChild = child as Processing.VisualElement;
    if (null != visualChild)
    {
        visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_GetChildByName(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim child As Processing.LayoutElement = Processing.ElementTreeHelper.GetChildByName(processingInstance, "textBox1")
    Dim visualChild As Processing.VisualElement = TryCast(child, Processing.VisualElement)
    If visualChild IsNot Nothing Then
        visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
    End If
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


GetChildElements Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.GetChildElements Method
ElementTreeHelper Class Example See Also Send Feedback
Returns all immediate child layout elements within a specified parent.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static IEnumerable<LayoutElement> GetChildElements(
    LayoutElement parent
)
Visual Basic (Declaration)
Public Shared Function GetChildElements ( _
    parent As LayoutElement _
) As IEnumerable(Of LayoutElement)

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element.

Return Value

Enumerable of all layout elements having the specified parent. If the parent does not have children, an empty enumeration is returned.

Examples

This example shows how to access all children of a parent layout element in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_GetChildElements(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    IEnumerable<Processing.LayoutElement> elements = Processing.ElementTreeHelper.GetChildElements(processingInstance);
    foreach (Processing.LayoutElement child in elements)
    {
        Processing.VisualElement visualChild = child as Processing.VisualElement;
        if (null != visualChild)
        {
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_GetChildElements(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim elements As System.Collections.Generic.IEnumerable(Of Processing.LayoutElement) = Processing.ElementTreeHelper.GetChildElements(processingInstance)
    For Each child As Processing.LayoutElement In elements
        Dim visualChild As Processing.VisualElement = TryCast(child, Processing.VisualElement)
        If visualChild IsNot Nothing Then
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
        End If
    Next
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


IndexOfChildWithName Method

[image]

Telerik Reporting Q2 2012
ElementTreeHelper..::.IndexOfChildWithName Method
ElementTreeHelper Class Example See Also Send Feedback
Returns the zero-based index of the first occurrence of a layout element with a specified name within a parent.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public static int IndexOfChildWithName(
    LayoutElement parent,
    string name
)
Visual Basic (Declaration)
Public Shared Function IndexOfChildWithName ( _
    parent As LayoutElement, _
    name As String _
) As Integer

Parameters

parent
Type: Telerik.Reporting.Processing..::.LayoutElement
The parent element to search within.
name
Type: System..::.String
The name to search for.

Return Value

The zero-based index of the first occurrence of a layout element having the specified name within the specified parent.

Examples

This example shows how to get the index of a child in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_IndexOfChildWithName_And_GetChildByIndex(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    int index = Processing.ElementTreeHelper.IndexOfChildWithName(processingInstance, "textBox1");
    if (index >= 0)
    {
        Processing.LayoutElement child = Processing.ElementTreeHelper.GetChildByIndex(processingInstance, index);
        Processing.VisualElement visualChild = child as Processing.VisualElement;
        if (null != visualChild)
        {
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_IndexOfChildWithName_And_GetChildByIndex(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim index As Integer = Processing.ElementTreeHelper.IndexOfChildWithName(processingInstance, "textBox1")
    If index >= 0 Then
        Dim child As Processing.LayoutElement = Processing.ElementTreeHelper.GetChildByIndex(processingInstance, index)
        Dim visualChild As Processing.VisualElement = TryCast(child, Processing.VisualElement)
        If visualChild IsNot Nothing Then
            visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
        End If
    End If
End Sub

See Also

ElementTreeHelper Class
Telerik.Reporting.Processing Namespace


EvaluateHeaderFooterExpressions Delegate

[image]

Telerik Reporting Q2 2012
EvaluateHeaderFooterExpressions Delegate
See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public delegate void EvaluateHeaderFooterExpressions(
    int pageNumber,
    int pageCount,
    Report report
)
Visual Basic (Declaration)
Public Delegate Sub EvaluateHeaderFooterExpressions ( _
    pageNumber As Integer, _
    pageCount As Integer, _
    report As Report _
)

Parameters

pageNumber
Type: System..::.Int32
pageCount
Type: System..::.Int32
report
Type: Telerik.Reporting.Processing..::.Report

See Also

Telerik.Reporting.Processing Namespace


Group Class

[image]

Telerik Reporting Q2 2012
Group Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Group : ProcessingElement, ILayoutElementContainer
Visual Basic (Declaration)
Public Class Group _
    Inherits ProcessingElement _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.Group

See Also

Group Members
Telerik.Reporting.Processing Namespace


Group Members

[image] [image]

Telerik Reporting Q2 2012
Group Members
Group Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The Group type exposes the following members.

Constructors

Name | Description
Group | Initializes a new instance of the Group class

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the Group and optionally releases the managed resources (Overrides ProcessingElement..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ProcessingElement.)
OnItemProcessing | (Inherited from ProcessingElement.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
GroupFooter |
GroupHeader |
GroupKeepTogether |
Name | (Overrides ProcessingElement..::.Name.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Group Class
Telerik.Reporting.Processing Namespace


Group Constructor

[image]

Telerik Reporting Q2 2012
Group Constructor
Group Class See Also Send Feedback
Initializes a new instance of the Group class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Group(
    Group groupDef
)
Visual Basic (Declaration)
Public Sub New ( _
    groupDef As Group _
)

Parameters

groupDef
Type: Telerik.Reporting..::.Group

See Also

Group Class
Telerik.Reporting.Processing Namespace


Group Methods

[image] [image]

Telerik Reporting Q2 2012
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ProcessingElement..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ProcessingElement.)
OnItemProcessing | (Inherited from ProcessingElement.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Group Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
Group..::.Dispose Method
Group Class See Also Send Feedback
Releases the unmanaged resources used by the Group and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

Group Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Group..::.ToString Method
Group Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides ProcessingElement..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Group Class
Group Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Group..::.ToString Method
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Group Class
ToString Overload
Telerik.Reporting.Processing Namespace


Group Properties

[image] [image]

Telerik Reporting Q2 2012
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
GroupFooter |
GroupHeader |
GroupKeepTogether |
Name | (Overrides ProcessingElement..::.Name.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |

See Also

Group Class
Telerik.Reporting.Processing Namespace


GroupFooter Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupFooter Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupSection GroupFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupFooter As GroupSection

See Also

Group Class
Telerik.Reporting.Processing Namespace


GroupHeader Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupHeader Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupSection GroupHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupHeader As GroupSection

See Also

Group Class
Telerik.Reporting.Processing Namespace


GroupKeepTogether Property

[image]

Telerik Reporting Q2 2012
Group..::.GroupKeepTogether Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public GroupKeepTogether GroupKeepTogether { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupKeepTogether As GroupKeepTogether

See Also

Group Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
Group..::.ILayoutElementContainer..::.Children Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

Group Class
Telerik.Reporting.Processing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Group..::.Name Property
Group Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String

See Also

Group Class
Telerik.Reporting.Processing Namespace


GroupSection Class

[image]

Telerik Reporting Q2 2012
GroupSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class GroupSection : ReportSection
Visual Basic (Declaration)
Public Class GroupSection _
    Inherits ReportSection

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportSectionBase
Telerik.Reporting.Processing..::.ReportSection
Telerik.Reporting.Processing..::.GroupSection

See Also

GroupSection Members
Telerik.Reporting.Processing Namespace


GroupSection Members

[image] [image]

Telerik Reporting Q2 2012
GroupSection Members
GroupSection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The GroupSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | (Inherited from ReportSection.)
Name | (Inherited from ReportItemBase.)
PageBreak | (Inherited from ReportSection.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
PrintOnEveryPage |
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

GroupSection Class
Telerik.Reporting.Processing Namespace


GroupSection Methods

[image] [image]

Telerik Reporting Q2 2012
GroupSection Methods
GroupSection Class See Also Send Feedback

The GroupSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

GroupSection Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
GroupSection..::.ToString Method
GroupSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

GroupSection Class
GroupSection Members
Telerik.Reporting.Processing Namespace


GroupSection Properties

[image] [image]

Telerik Reporting Q2 2012
GroupSection Properties
GroupSection Class See Also Send Feedback

The GroupSection type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | (Inherited from ReportSection.)
Name | (Inherited from ReportItemBase.)
PageBreak | (Inherited from ReportSection.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
PrintOnEveryPage |
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)

See Also

GroupSection Class
Telerik.Reporting.Processing Namespace


PrintOnEveryPage Property

[image]

Telerik Reporting Q2 2012
GroupSection..::.PrintOnEveryPage Property
GroupSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnEveryPage { get; internal set; }
Visual Basic (Declaration)
Public Property PrintOnEveryPage As Boolean

See Also

GroupSection Class
Telerik.Reporting.Processing Namespace


HtmlTextBox Class

[image]

Telerik Reporting Q2 2012
HtmlTextBox Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class HtmlTextBox : ReportItem,
    ILayoutElementContainer
Visual Basic (Declaration)
Public Class HtmlTextBox _
    Inherits ReportItem _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.HtmlTextBox

See Also

HtmlTextBox Members
Telerik.Reporting.Processing Namespace


HtmlTextBox Members

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Members
HtmlTextBox Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The HtmlTextBox type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the HtmlTextBox and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
IsValidXhtml | Determines if the provided value is valid xhtml that HtmlTextBox can parse. If the provided value is an expression, true is returned.
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | Indicates whether the rendering engine should try to keep the item on one page if possible.
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Value | Gets or sets the value of the HtmlTextBox item
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


HtmlTextBox Methods

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Methods
HtmlTextBox Class See Also Send Feedback

The HtmlTextBox type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
IsValidXhtml | Determines if the provided value is valid xhtml that HtmlTextBox can parse. If the provided value is an expression, true is returned.
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.Dispose Method
HtmlTextBox Class See Also Send Feedback
Releases the unmanaged resources used by the HtmlTextBox and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


IsValidXhtml Method

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.IsValidXhtml Method
HtmlTextBox Class See Also Send Feedback
Determines if the provided value is valid xhtml that HtmlTextBox can parse. If the provided value is an expression, true is returned.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsValidXhtml(
    string value
)
Visual Basic (Declaration)
Public Function IsValidXhtml ( _
    value As String _
) As Boolean

Parameters

value
Type: System..::.String

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox..::.ToString Method
HtmlTextBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides ProcessingElement..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

HtmlTextBox Class
HtmlTextBox Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.ToString Method
HtmlTextBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

HtmlTextBox Class
ToString Overload
Telerik.Reporting.Processing Namespace


HtmlTextBox Properties

[image] [image]

Telerik Reporting Q2 2012
HtmlTextBox Properties
HtmlTextBox Class See Also Send Feedback

The HtmlTextBox type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether | Indicates whether the rendering engine should try to keep the item on one page if possible.
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Value | Gets or sets the value of the HtmlTextBox item
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.ILayoutElementContainer..::.Children Property
HtmlTextBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.KeepTogether Property
HtmlTextBox Class See Also Send Feedback
Indicates whether the rendering engine should try to keep the item on one page if possible.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; internal set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
HtmlTextBox..::.Value Property
HtmlTextBox Class See Also Send Feedback
Gets or sets the value of the HtmlTextBox item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

HtmlTextBox Class
Telerik.Reporting.Processing Namespace


IDataGroupMember Interface

[image]

Telerik Reporting Q2 2012
IDataGroupMember Interface
Members See Also Send Feedback
Provides an unified access to the data of a group member

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IDataGroupMember : IDataObject
Visual Basic (Declaration)
Public Interface IDataGroupMember _
    Implements IDataObject

See Also

IDataGroupMember Members
Telerik.Reporting.Processing Namespace


IDataGroupMember Members

[image] [image]

Telerik Reporting Q2 2012
IDataGroupMember Members
IDataGroupMember Interface Methods Properties See Also Send Feedback

The IDataGroupMember type exposes the following members.

Methods

Name | Description
EnumerateRawData | Enumerates all data items (details) that belongs to the current group member.
GetProperties | Returns a collection of the available properties for the underlaying object. To get the actual data object use RawData. (Inherited from IDataObject.)

Properties

Name | Description
Item | Gets the value of the specified member. (Inherited from IDataObject.)
RawData | Gets the actual object that the current IDataObject wraps. (Inherited from IDataObject.)

See Also

IDataGroupMember Interface
Telerik.Reporting.Processing Namespace


IDataGroupMember Methods

[image] [image]

Telerik Reporting Q2 2012
IDataGroupMember Methods
IDataGroupMember Interface See Also Send Feedback

The IDataGroupMember type exposes the following members.

Methods

Name | Description
EnumerateRawData | Enumerates all data items (details) that belongs to the current group member.
GetProperties | Returns a collection of the available properties for the underlaying object. To get the actual data object use RawData. (Inherited from IDataObject.)

See Also

IDataGroupMember Interface
Telerik.Reporting.Processing Namespace


EnumerateRawData Method

[image]

Telerik Reporting Q2 2012
IDataGroupMember..::.EnumerateRawData Method
IDataGroupMember Interface Example See Also Send Feedback
Enumerates all data items (details) that belongs to the current group member.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable EnumerateRawData()
Visual Basic (Declaration)
Function EnumerateRawData As IEnumerable

Return Value

A set of raw data items that belongs to the current group member.

Examples

The following example, uses the IDataGroupMember.EnumerateRawData() to display the detail items for each member of the Country group.
CopyC#
public class Address
{
    string country;
    string city;

    public string City
    {
        get { return this.city; }
        set { this.city = value; }
    }

    public string Country
    {
        get { return this.country; }
        set { this.country = value; }
    }

    public Address(string country, string city)
    {
        this.country = country;
        this.city = city;
    }
}

public class Report1 : Telerik.Reporting.Report
{
    public Report1()
    {
        this.InitializeComponent();

        this.DataSource = new Address[]
                               {
                                   new Address("UK", "London"),
                                   new Address("USA", "Boston"),
                                   new Address("UK", "Manchester"),
                                   new Address("UK", "Liverpool"),
                                   new Address("USA", "New York"),
                                   new Address("USA", "Houston"),
                                };
    }

    private void InitializeComponent()
    {
        ((System.ComponentModel.ISupportInitialize)this).BeginInit();

        this.detailSection = new Telerik.Reporting.DetailSection();
        this.groupHeaderSection = new Telerik.Reporting.GroupHeaderSection();
        this.groupFooterSection = new Telerik.Reporting.GroupFooterSection();

        this.groupHeaderSection.ItemDataBound += new System.EventHandler(groupHeaderSection_ItemDataBound);

        this.groupFooterSection.ItemDataBound += new System.EventHandler(groupFooterSection_ItemDataBound);

        this.Items.AddRange(new Telerik.Reporting.ReportItemBase[]
                                {
                                    this.groupHeaderSection,
                                    this.detailSection,
                                    this.groupFooterSection,
                                });

        Telerik.Reporting.Group group1 = new Telerik.Reporting.Group();
        group1.Name = "Country";
        group1.GroupHeader = this.groupHeaderSection;
        group1.GroupFooter = this.groupFooterSection;
        group1.Groupings.AddRange(new Telerik.Reporting.Grouping[] { new Telerik.Reporting.Grouping("=Fields.Country"), });

        this.Groups.AddRange(new Telerik.Reporting.Group[] { group1 });

        ((System.ComponentModel.ISupportInitialize)this).EndInit();
    }

    void groupHeaderSection_ItemDataBound(object sender, System.EventArgs e)
    {
        Telerik.Reporting.Processing.GroupSection groupSection = sender as Telerik.Reporting.Processing.GroupSection;
        Telerik.Reporting.Processing.IDataGroupMember dataGroupMember = groupSection.DataObject as Telerik.Reporting.Processing.IDataGroupMember;

        Console.WriteLine("--- Begin '{0}' ---", groupSection.DataObject["Country"]);
        Console.WriteLine("(header)");
        EnumerateGroupMemberRawData(dataGroupMember);
    }

    void groupFooterSection_ItemDataBound(object sender, System.EventArgs e)
    {
        Telerik.Reporting.Processing.GroupSection groupSection = sender as Telerik.Reporting.Processing.GroupSection;
        Telerik.Reporting.Processing.IDataGroupMember dataGroupMember = groupSection.DataObject as Telerik.Reporting.Processing.IDataGroupMember;

        Console.WriteLine("(footer)");
        EnumerateGroupMemberRawData(dataGroupMember);
        Console.WriteLine("--- End '{0}'  ---", groupSection.DataObject["Country"]);
    }

    static void EnumerateGroupMemberRawData(Telerik.Reporting.Processing.IDataGroupMember dataGroupMember)
    {
        foreach (Address address in dataGroupMember.EnumerateRawData())
        {
            Console.WriteLine(string.Format("  {0} - {1}", address.Country, address.City));
        }
    }

    Telerik.Reporting.DetailSection detailSection;
    Telerik.Reporting.GroupHeaderSection groupHeaderSection;
    Telerik.Reporting.GroupFooterSection groupFooterSection;
}
CopyVB.NET
Public Class Address

    Public Sub New(ByVal country As String, ByVal city As String)
        _country = country
        _city = city
    End Sub

    Public Property City() As String
        Get
            Return _city
        End Get
        Set(ByVal value As String)
            _city = value
        End Set
    End Property

    Public Property Country() As String
        Get
            Return _country
        End Get
        Set(ByVal value As String)
            _country = value
        End Set
    End Property

    Private _city As String
    Private _country As String
End Class

Public Class Report1
    Inherits Report

    Public Sub New()
        Me.InitializeComponent()
        MyBase.DataSource = New Address() {New Address("UK", "London"), _
                                           New Address("USA", "Boston"), _
                                           New Address("UK", "Manchester"), _
                                           New Address("UK", "Liverpool"), _
                                           New Address("USA", "New York"), _
                                           New Address("USA", "Houston")}
    End Sub

    Private Shared Sub EnumerateRawData(ByVal dataGroupMember As Telerik.Reporting.Processing.IDataGroupMember)
        Dim address As Address
        For Each address In dataGroupMember.EnumerateRawData
            Console.WriteLine(String.Format("  {0} - {1}", address.Country, address.City))
        Next
    End Sub

    Private Sub groupFooterSection_ItemDataBound(ByVal sender As Object, ByVal e As EventArgs)
        Dim groupSection As Telerik.Reporting.Processing.GroupSection = TryCast(sender, Telerik.Reporting.Processing.GroupSection)
        Dim dataGroupMember As Telerik.Reporting.Processing.IDataGroupMember = TryCast(groupSection.DataObject, Telerik.Reporting.Processing.IDataGroupMember)
        Console.WriteLine("(footer)")
        Report1.EnumerateRawData(dataGroupMember)
        Console.WriteLine("--- End '{0}'  ---", groupSection.DataObject.Item("Country"))
    End Sub

    Private Sub groupHeaderSection_ItemDataBound(ByVal sender As Object, ByVal e As EventArgs)
        Dim groupSection As Telerik.Reporting.Processing.GroupSection = TryCast(sender, Telerik.Reporting.Processing.GroupSection)
        Dim dataGroupMember As Telerik.Reporting.Processing.IDataGroupMember = TryCast(groupSection.DataObject, Telerik.Reporting.Processing.IDataGroupMember)
        Console.WriteLine("--- Begin '{0}' ---", groupSection.DataObject.Item("Country"))
        Console.WriteLine("(header)")
        Report1.EnumerateRawData(dataGroupMember)
    End Sub

    Private Sub InitializeComponent()
        DirectCast(Me, System.ComponentModel.ISupportInitialize).BeginInit()
        Me.detailSection = New DetailSection
        Me.groupHeaderSection = New GroupHeaderSection
        Me.groupFooterSection = New GroupFooterSection
        AddHandler Me.groupHeaderSection.ItemDataBound, New EventHandler(AddressOf Me.groupHeaderSection_ItemDataBound)
        AddHandler Me.groupFooterSection.ItemDataBound, New EventHandler(AddressOf Me.groupFooterSection_ItemDataBound)
        MyBase.Items.AddRange(New ReportItemBase() {Me.groupHeaderSection, Me.detailSection, Me.groupFooterSection})
        Dim group1 As New Group
        group1.Name = "Country"
        group1.GroupHeader = Me.groupHeaderSection
        group1.GroupFooter = Me.groupFooterSection
        group1.Groupings.AddRange(New Telerik.Reporting.Grouping() {New Telerik.Reporting.Grouping("=Fields.Country")})
        MyBase.Groups.AddRange(New Group() {group1})
        DirectCast(Me, System.ComponentModel.ISupportInitialize).EndInit()
    End Sub

    Private detailSection As DetailSection
    Private groupFooterSection As GroupFooterSection
    Private groupHeaderSection As GroupHeaderSection
End Class

See Also

IDataGroupMember Interface
Telerik.Reporting.Processing Namespace


IDataGroupMember Properties

[image] [image]

Telerik Reporting Q2 2012
IDataGroupMember Properties
IDataGroupMember Interface See Also Send Feedback

The IDataGroupMember type exposes the following members.

Properties

Name | Description
Item | Gets the value of the specified member. (Inherited from IDataObject.)
RawData | Gets the actual object that the current IDataObject wraps. (Inherited from IDataObject.)

See Also

IDataGroupMember Interface
Telerik.Reporting.Processing Namespace


IDataObject Interface

[image]

Telerik Reporting Q2 2012
IDataObject Interface
Members See Also Send Feedback
Provides unified access to a single data record from a data source.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IDataObject
Visual Basic (Declaration)
Public Interface IDataObject

See Also

IDataObject Members
Telerik.Reporting.Processing Namespace


IDataObject Members

[image] [image]

Telerik Reporting Q2 2012
IDataObject Members
IDataObject Interface Methods Properties See Also Send Feedback

The IDataObject type exposes the following members.

Methods

Name | Description
GetProperties | Returns a collection of the available properties for the underlaying object. To get the actual data object use RawData.

Properties

Name | Description
Item | Gets the value of the specified member.
RawData | Gets the actual object that the current IDataObject wraps.

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


IDataObject Methods

[image] [image]

Telerik Reporting Q2 2012
IDataObject Methods
IDataObject Interface See Also Send Feedback

The IDataObject type exposes the following members.

Methods

Name | Description
GetProperties | Returns a collection of the available properties for the underlaying object. To get the actual data object use RawData.

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


GetProperties Method

[image]

Telerik Reporting Q2 2012
IDataObject..::.GetProperties Method
IDataObject Interface See Also Send Feedback
Returns a collection of the available properties for the underlaying object. To get the actual data object use RawData.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
PropertyDescriptorCollection GetProperties()
Visual Basic (Declaration)
Function GetProperties As PropertyDescriptorCollection

Field Value

A PropertyDescriptorCollection with the properties of the underlaying data object.

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


IDataObject Properties

[image] [image]

Telerik Reporting Q2 2012
IDataObject Properties
IDataObject Interface See Also Send Feedback

The IDataObject type exposes the following members.

Properties

Name | Description
Item | Gets the value of the specified member.
RawData | Gets the actual object that the current IDataObject wraps.

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


Item Property

[image]

Telerik Reporting Q2 2012
IDataObject..::.Item Property
IDataObject Interface See Also Send Feedback
Gets the value of the specified member.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object this[
    string member
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    member As String _
) As Object

Parameters

member
Type: System..::.String
The name of the member

Field Value

The value of the member.

Remarks

Depending on the type of the data source the member may refer to a DataColumn (when the report is bound to a DataTable or DataSet) or a public property (when bound to an IEnumerable or a ITypedList). To get the list of the available members use GetProperties()()().

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


RawData Property

[image]

Telerik Reporting Q2 2012
IDataObject..::.RawData Property
IDataObject Interface See Also Send Feedback
Gets the actual object that the current IDataObject wraps.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Object RawData { get; }
Visual Basic (Declaration)
ReadOnly Property RawData As Object

Field Value

The actual data.

Remarks

Depending on the type of the data source the member may refer to a DataRow (when the report is bound to a DataTable or DataSet) or an object (when bound to an IEnumerable).

See Also

IDataObject Interface
Telerik.Reporting.Processing Namespace


ILayoutElementContainer Interface

[image]

Telerik Reporting Q2 2012
ILayoutElementContainer Interface
Members See Also Send Feedback
Represents an item that may contain other LayoutElements

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface ILayoutElementContainer
Visual Basic (Declaration)
Public Interface ILayoutElementContainer

See Also

ILayoutElementContainer Members
Telerik.Reporting.Processing Namespace


ILayoutElementContainer Members

[image] [image]

Telerik Reporting Q2 2012
ILayoutElementContainer Members
ILayoutElementContainer Interface Properties See Also Send Feedback

The ILayoutElementContainer type exposes the following members.

Properties

Name | Description
Children | Gets a read-only enumeration containing the immediate children of the current container.

See Also

ILayoutElementContainer Interface
Telerik.Reporting.Processing Namespace


ILayoutElementContainer Properties

[image] [image]

Telerik Reporting Q2 2012
ILayoutElementContainer Properties
ILayoutElementContainer Interface See Also Send Feedback

The ILayoutElementContainer type exposes the following members.

Properties

Name | Description
Children | Gets a read-only enumeration containing the immediate children of the current container.

See Also

ILayoutElementContainer Interface
Telerik.Reporting.Processing Namespace


Children Property

[image]

Telerik Reporting Q2 2012
ILayoutElementContainer..::.Children Property
ILayoutElementContainer Interface Example See Also Send Feedback
Gets a read-only enumeration containing the immediate children of the current container.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> Children { get; }
Visual Basic (Declaration)
ReadOnly Property Children As IEnumerable(Of LayoutElement)

Examples

This example shows how to access all children of a container in a ItemDataBinding event handler.
CopyC#
void DetailSection_ItemDataBinding_Using_ILayoutElementContainer_Children(object sender, EventArgs e)
{
    Processing.DetailSection processingInstance = (Processing.DetailSection)sender;
    Processing.ILayoutElementContainer processingContainer = processingInstance as Processing.ILayoutElementContainer;
    if (null != processingContainer)
    {
        foreach (Processing.LayoutElement processingChild in processingContainer.Children)
        {
            Processing.VisualElement visualChild = processingChild as Processing.VisualElement;
            if (null != visualChild)
            {
                visualChild.Style.BackgroundColor = System.Drawing.Color.Blue;
            }
        }
    }
}
CopyVB.NET
Private Sub DetailSection_ItemDataBinding_Using_ILayoutElementContainer_Children(sender As Object, e As EventArgs)
    Dim processingInstance As Processing.DetailSection = DirectCast(sender, Processing.DetailSection)
    Dim processingContainer As Processing.ILayoutElementContainer = TryCast(processingInstance, Processing.ILayoutElementContainer)
    If processingContainer IsNot Nothing Then
        For Each processingChild As Processing.LayoutElement In processingContainer.Children
            Dim visualChild As Processing.VisualElement = TryCast(processingChild, Processing.VisualElement)
            If visualChild IsNot Nothing Then
                visualChild.Style.BackgroundColor = System.Drawing.Color.Blue
            End If
        Next
    End If
End Sub

See Also

ILayoutElementContainer Interface
Telerik.Reporting.Processing Namespace


IRenderingExtension Interface

[image]

Telerik Reporting Q2 2012
IRenderingExtension Interface
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface IRenderingExtension : IExtension,
    IDisposable
Visual Basic (Declaration)
Public Interface IRenderingExtension _
    Implements IExtension, IDisposable

See Also

IRenderingExtension Members
Telerik.Reporting.Processing Namespace


IRenderingExtension Members

[image] [image]

Telerik Reporting Q2 2012
IRenderingExtension Members
IRenderingExtension Interface Methods See Also Send Feedback

The IRenderingExtension type exposes the following members.

Methods

Name | Description
Initialize | Initializes the current extension with default settings (Inherited from IExtension.)
Render |

See Also

IRenderingExtension Interface
Telerik.Reporting.Processing Namespace


IRenderingExtension Methods

[image] [image]

Telerik Reporting Q2 2012
IRenderingExtension Methods
IRenderingExtension Interface See Also Send Feedback

The IRenderingExtension type exposes the following members.

Methods

Name | Description
Initialize | Initializes the current extension with default settings (Inherited from IExtension.)
Render |

See Also

IRenderingExtension Interface
Telerik.Reporting.Processing Namespace


Render Method

[image]

Telerik Reporting Q2 2012
IRenderingExtension..::.Render Method
IRenderingExtension Interface See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool Render(
    Report report,
    Hashtable renderingContext,
    Hashtable deviceInfo,
    CreateStream createStreamCallback,
    EvaluateHeaderFooterExpressions evalHeaderFooterCallback
)
Visual Basic (Declaration)
Function Render ( _
    report As Report, _
    renderingContext As Hashtable, _
    deviceInfo As Hashtable, _
    createStreamCallback As CreateStream, _
    evalHeaderFooterCallback As EvaluateHeaderFooterExpressions _
) As Boolean

Parameters

report
Type: Telerik.Reporting.Processing..::.Report
renderingContext
Type: System.Collections..::.Hashtable
deviceInfo
Type: System.Collections..::.Hashtable
createStreamCallback
Type: Telerik.Reporting.Processing..::.CreateStream
evalHeaderFooterCallback
Type: Telerik.Reporting.Processing..::.EvaluateHeaderFooterExpressions

See Also

IRenderingExtension Interface
Telerik.Reporting.Processing Namespace


ITableCell Interface

[image]

Telerik Reporting Q2 2012
ITableCell Interface
Members See Also Send Feedback
Provides an interface for accessing a processing Table cell.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface ITableCell
Visual Basic (Declaration)
Public Interface ITableCell

See Also

ITableCell Members
Telerik.Reporting.Processing Namespace


ITableCell Members

[image] [image]

Telerik Reporting Q2 2012
ITableCell Members
ITableCell Interface Properties See Also Send Feedback

The ITableCell type exposes the following members.

Properties

Name | Description
ColumnIndex | Gets the index of the column that contains the cell.
ColumnSpan | Gets a value that indicates the total number of columns that the cell spans within the table.
Item | Gets the ReportItem in the cell.
RowIndex | Gets the index of the row that contains the cell.
RowSpan | Gets a value that indicates the total number of rows that the cell spans within the table.
Table | Gets the Table this cell belongs to.

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


ITableCell Properties

[image] [image]

Telerik Reporting Q2 2012
ITableCell Properties
ITableCell Interface See Also Send Feedback

The ITableCell type exposes the following members.

Properties

Name | Description
ColumnIndex | Gets the index of the column that contains the cell.
ColumnSpan | Gets a value that indicates the total number of columns that the cell spans within the table.
Item | Gets the ReportItem in the cell.
RowIndex | Gets the index of the row that contains the cell.
RowSpan | Gets a value that indicates the total number of rows that the cell spans within the table.
Table | Gets the Table this cell belongs to.

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


ColumnIndex Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.ColumnIndex Property
ITableCell Interface See Also Send Feedback
Gets the index of the column that contains the cell.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ColumnIndex { get; }
Visual Basic (Declaration)
ReadOnly Property ColumnIndex As Integer

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


ColumnSpan Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.ColumnSpan Property
ITableCell Interface See Also Send Feedback
Gets a value that indicates the total number of columns that the cell spans within the table.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ColumnSpan { get; }
Visual Basic (Declaration)
ReadOnly Property ColumnSpan As Integer

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.Item Property
ITableCell Interface See Also Send Feedback
Gets the ReportItem in the cell.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ReportItem Item { get; }
Visual Basic (Declaration)
ReadOnly Property Item As ReportItem

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


RowIndex Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.RowIndex Property
ITableCell Interface See Also Send Feedback
Gets the index of the row that contains the cell.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int RowIndex { get; }
Visual Basic (Declaration)
ReadOnly Property RowIndex As Integer

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


RowSpan Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.RowSpan Property
ITableCell Interface See Also Send Feedback
Gets a value that indicates the total number of rows that the cell spans within the table.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int RowSpan { get; }
Visual Basic (Declaration)
ReadOnly Property RowSpan As Integer

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


Table Property

[image]

Telerik Reporting Q2 2012
ITableCell..::.Table Property
ITableCell Interface See Also Send Feedback
Gets the Table this cell belongs to.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Table Table { get; }
Visual Basic (Declaration)
ReadOnly Property Table As Table

Field Value

A Table object which the item belongs to.

See Also

ITableCell Interface
Telerik.Reporting.Processing Namespace


LayoutElement Class

[image]

Telerik Reporting Q2 2012
LayoutElement Class
Members See Also Send Feedback
Base class for all processing instances of report items.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class LayoutElement : ReportObject,
    IDisposable
Visual Basic (Declaration)
Public MustInherit Class LayoutElement _
    Inherits ReportObject _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement

See Also

LayoutElement Members
Telerik.Reporting.Processing Namespace


LayoutElement Members

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Members
LayoutElement Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The LayoutElement type exposes the following members.

Constructors

Name | Description
LayoutElement | Initializes a new instance of the LayoutElement class

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the LayoutElement and optionally releases the managed resources
ToString | Overloaded.

Properties

Name | Description
ParentElement | Gets the parent element of the current layout element.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose |

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


LayoutElement Constructor

[image]

Telerik Reporting Q2 2012
LayoutElement Constructor
LayoutElement Class See Also Send Feedback
Initializes a new instance of the LayoutElement class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected LayoutElement()
Visual Basic (Declaration)
Protected Sub New

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


LayoutElement Methods

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Methods
LayoutElement Class See Also Send Feedback

The LayoutElement type exposes the following members.

Methods

Name | Description
Dispose |
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose |

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


IDisposable.Dispose Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.IDisposable..::.Dispose Method
LayoutElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void IDisposable.Dispose()
Visual Basic (Declaration)
Private Sub Dispose Implements IDisposable.Dispose

Implements

IDisposable..::.Dispose()()()

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.Dispose Method
LayoutElement Class See Also Send Feedback
Releases the unmanaged resources used by the LayoutElement and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
LayoutElement..::.ToString Method
LayoutElement Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides Object..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

LayoutElement Class
LayoutElement Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
LayoutElement..::.ToString Method
LayoutElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

LayoutElement Class
ToString Overload
Telerik.Reporting.Processing Namespace


LayoutElement Properties

[image] [image]

Telerik Reporting Q2 2012
LayoutElement Properties
LayoutElement Class See Also Send Feedback

The LayoutElement type exposes the following members.

Properties

Name | Description
ParentElement | Gets the parent element of the current layout element.

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


ParentElement Property

[image]

Telerik Reporting Q2 2012
LayoutElement..::.ParentElement Property
LayoutElement Class See Also Send Feedback
Gets the parent element of the current layout element.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public LayoutElement ParentElement { get; internal set; }
Visual Basic (Declaration)
Public Property ParentElement As LayoutElement

See Also

LayoutElement Class
Telerik.Reporting.Processing Namespace


PageSection Class

[image]

Telerik Reporting Q2 2012
PageSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PageSection : ReportSectionBase
Visual Basic (Declaration)
Public Class PageSection _
    Inherits ReportSectionBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportSectionBase
Telerik.Reporting.Processing..::.PageSection

See Also

PageSection Members
Telerik.Reporting.Processing Namespace


PageSection Members

[image] [image]

Telerik Reporting Q2 2012
PageSection Members
PageSection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PageSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Overrides ReportItemBase..::.OnItemProcessing()()().)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
PrintOnFirstPage |
PrintOnLastPage |
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


PageSection Methods

[image] [image]

Telerik Reporting Q2 2012
PageSection Methods
PageSection Class See Also Send Feedback

The PageSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Overrides ReportItemBase..::.OnItemProcessing()()().)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


OnItemProcessing Method

[image]

Telerik Reporting Q2 2012
PageSection..::.OnItemProcessing Method
PageSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnItemProcessing()
Visual Basic (Declaration)
Protected Overrides Sub OnItemProcessing

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PageSection..::.ToString Method
PageSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PageSection Class
PageSection Members
Telerik.Reporting.Processing Namespace


PageSection Properties

[image] [image]

Telerik Reporting Q2 2012
PageSection Properties
PageSection Class See Also Send Feedback

The PageSection type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
PrintOnFirstPage |
PrintOnLastPage |
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


PrintOnFirstPage Property

[image]

Telerik Reporting Q2 2012
PageSection..::.PrintOnFirstPage Property
PageSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnFirstPage { get; internal set; }
Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


PrintOnLastPage Property

[image]

Telerik Reporting Q2 2012
PageSection..::.PrintOnLastPage Property
PageSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnLastPage { get; internal set; }
Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean

See Also

PageSection Class
Telerik.Reporting.Processing Namespace


Panel Class

[image]

Telerik Reporting Q2 2012
Panel Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Panel : ReportItem, ILayoutElementContainer
Visual Basic (Declaration)
Public Class Panel _
    Inherits ReportItem _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Panel

See Also

Panel Members
Telerik.Reporting.Processing Namespace


Panel Members

[image] [image]

Telerik Reporting Q2 2012
Panel Members
Panel Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the Panel and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Panel Class
Telerik.Reporting.Processing Namespace


Panel Methods

[image] [image]

Telerik Reporting Q2 2012
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Panel Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
Panel..::.Dispose Method
Panel Class See Also Send Feedback
Releases the unmanaged resources used by the Panel and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

Panel Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Panel..::.ToString Method
Panel Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Panel Class
Panel Members
Telerik.Reporting.Processing Namespace


Panel Properties

[image] [image]

Telerik Reporting Q2 2012
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Panel Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
Panel..::.ILayoutElementContainer..::.Children Property
Panel Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

Panel Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
Panel..::.KeepTogether Property
Panel Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; internal set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

Panel Class
Telerik.Reporting.Processing Namespace


Parameter Class

[image]

Telerik Reporting Q2 2012
Parameter Class
Members See Also Send Feedback
Represents a processing instance of a ReportParameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.Parameter
Telerik.Reporting.Service..::.Parameter

See Also

Parameter Members
Telerik.Reporting.Processing Namespace


Parameter Members

[image] [image]

Telerik Reporting Q2 2012
Parameter Members
Parameter Class Constructors Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Initializes a new instance of the Parameter class.

Properties

Name | Description
AllowBlank | Determines if the parameter allows an empty string to be passed. Only for parameters of type string.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether the report viewer should auto-update the report when the parameter value is changed.
AvailableValues | Gets or sets the list of the available values for the current parameter.
ChildParameters | Gets or sets the list of the parameters that depends on the current parameter.
IsVisible | Determines if the parameter should be displayed in the report viewer.
Label | Gets the label of the parameter. Returns a string that contains the label of the current parameter's Value or an array of strings that contains the labels of all values when multivalue parameter.
Multivalue | Determines if the parameter can hold more then one value.
Name | Gets or sets the Name of the parameters
Text | Gets or sets the text for the parameter to be displayed in the report viewer.
Type | Gets or sets the type of the parameter.
Value | Gets or sets the value of the parameter.

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Parameter Constructor

[image]

Telerik Reporting Q2 2012
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Parameter Properties

[image] [image]

Telerik Reporting Q2 2012
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
AllowBlank | Determines if the parameter allows an empty string to be passed. Only for parameters of type string.
AllowNull | Determines if the parameter allows no value to be passed from it's editor.
AutoRefresh | Determines whether the report viewer should auto-update the report when the parameter value is changed.
AvailableValues | Gets or sets the list of the available values for the current parameter.
ChildParameters | Gets or sets the list of the parameters that depends on the current parameter.
IsVisible | Determines if the parameter should be displayed in the report viewer.
Label | Gets the label of the parameter. Returns a string that contains the label of the current parameter's Value or an array of strings that contains the labels of all values when multivalue parameter.
Multivalue | Determines if the parameter can hold more then one value.
Name | Gets or sets the Name of the parameters
Text | Gets or sets the text for the parameter to be displayed in the report viewer.
Type | Gets or sets the type of the parameter.
Value | Gets or sets the value of the parameter.

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


AllowBlank Property

[image]

Telerik Reporting Q2 2012
Parameter..::.AllowBlank Property
Parameter Class See Also Send Feedback
Determines if the parameter allows an empty string to be passed. Only for parameters of type string.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AllowBlank { get; set; }
Visual Basic (Declaration)
Public Property AllowBlank As Boolean

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


AllowNull Property

[image]

Telerik Reporting Q2 2012
Parameter..::.AllowNull Property
Parameter Class See Also Send Feedback
Determines if the parameter allows no value to be passed from it's editor.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AllowNull { get; set; }
Visual Basic (Declaration)
Public Property AllowNull As Boolean

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


AutoRefresh Property

[image]

Telerik Reporting Q2 2012
Parameter..::.AutoRefresh Property
Parameter Class See Also Send Feedback
Determines whether the report viewer should auto-update the report when the parameter value is changed.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AutoRefresh { get; set; }
Visual Basic (Declaration)
Public Property AutoRefresh As Boolean

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
Parameter..::.AvailableValues Property
Parameter Class See Also Send Feedback
Gets or sets the list of the available values for the current parameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<ParameterValue> AvailableValues { get; set; }
Visual Basic (Declaration)
Public Property AvailableValues As List(Of ParameterValue)

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


ChildParameters Property

[image]

Telerik Reporting Q2 2012
Parameter..::.ChildParameters Property
Parameter Class See Also Send Feedback
Gets or sets the list of the parameters that depends on the current parameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<string> ChildParameters { get; set; }
Visual Basic (Declaration)
Public Property ChildParameters As List(Of String)

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


IsVisible Property

[image]

Telerik Reporting Q2 2012
Parameter..::.IsVisible Property
Parameter Class See Also Send Feedback
Determines if the parameter should be displayed in the report viewer.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic (Declaration)
Public Property IsVisible As Boolean

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Label Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Label Property
Parameter Class See Also Send Feedback
Gets the label of the parameter. Returns a string that contains the label of the current parameter's Value or an array of strings that contains the labels of all values when multivalue parameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As Object

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Multivalue Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Multivalue Property
Parameter Class See Also Send Feedback
Determines if the parameter can hold more then one value.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool Multivalue { get; set; }
Visual Basic (Declaration)
Public Property Multivalue As Boolean

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Name Property
Parameter Class See Also Send Feedback
Gets or sets the Name of the parameters

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Text Property
Parameter Class See Also Send Feedback
Gets or sets the text for the parameter to be displayed in the report viewer.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Type Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Type Property
Parameter Class See Also Send Feedback
Gets or sets the type of the parameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String

Remarks

The string that represents the parameter type should be the FullName of the CLR type corresponding to the ReportParameterType.

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
Parameter..::.Value Property
Parameter Class See Also Send Feedback
Gets or sets the value of the parameter.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

Remarks

Value should of the allowed types, or IEnumerable containing values of the allowed types.

See Also

Parameter Class
Telerik.Reporting.Processing Namespace


ParameterValue Class

[image]

Telerik Reporting Q2 2012
ParameterValue Class
Members See Also Send Feedback
Represents a parameter value.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ParameterValue
Visual Basic (Declaration)
Public Class ParameterValue

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.ParameterValue

See Also

ParameterValue Members
Telerik.Reporting.Processing Namespace


ParameterValue Members

[image] [image]

Telerik Reporting Q2 2012
ParameterValue Members
ParameterValue Class Constructors Properties See Also Send Feedback

The ParameterValue type exposes the following members.

Constructors

Name | Description
ParameterValue | Initializes a new instance of the ParameterValue class

Properties

Name | Description
Name | Gets or sets the name of the ParameterValue.
Value | Gets or sets the value of the ParameterValue.

See Also

ParameterValue Class
Telerik.Reporting.Processing Namespace


ParameterValue Constructor

[image]

Telerik Reporting Q2 2012
ParameterValue Constructor
ParameterValue Class See Also Send Feedback
Initializes a new instance of the ParameterValue class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ParameterValue()
Visual Basic (Declaration)
Public Sub New

See Also

ParameterValue Class
Telerik.Reporting.Processing Namespace


ParameterValue Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterValue Properties
ParameterValue Class See Also Send Feedback

The ParameterValue type exposes the following members.

Properties

Name | Description
Name | Gets or sets the name of the ParameterValue.
Value | Gets or sets the value of the ParameterValue.

See Also

ParameterValue Class
Telerik.Reporting.Processing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ParameterValue..::.Name Property
ParameterValue Class See Also Send Feedback
Gets or sets the name of the ParameterValue.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ParameterValue Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ParameterValue..::.Value Property
ParameterValue Class See Also Send Feedback
Gets or sets the value of the ParameterValue.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

ParameterValue Class
Telerik.Reporting.Processing Namespace


PictureBox Class

[image]

Telerik Reporting Q2 2012
PictureBox Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PictureBox : ReportItem
Visual Basic (Declaration)
Public Class PictureBox _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.PictureBox

See Also

PictureBox Members
Telerik.Reporting.Processing Namespace


PictureBox Members

[image] [image]

Telerik Reporting Q2 2012
PictureBox Members
PictureBox Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The PictureBox type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
Image |
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
MimeType |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Sizing |
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


PictureBox Methods

[image] [image]

Telerik Reporting Q2 2012
PictureBox Methods
PictureBox Class See Also Send Feedback

The PictureBox type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
PictureBox..::.ToString Method
PictureBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

PictureBox Class
PictureBox Members
Telerik.Reporting.Processing Namespace


PictureBox Properties

[image] [image]

Telerik Reporting Q2 2012
PictureBox Properties
PictureBox Class See Also Send Feedback

The PictureBox type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
Image |
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
MimeType |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Sizing |
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


Image Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.Image Property
PictureBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Image Image { set; }
Visual Basic (Declaration)
Public WriteOnly Property Image As Image

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


MimeType Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.MimeType Property
PictureBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string MimeType { get; internal set; }
Visual Basic (Declaration)
Public Property MimeType As String

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


Sizing Property

[image]

Telerik Reporting Q2 2012
PictureBox..::.Sizing Property
PictureBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ImageSizeMode Sizing { get; internal set; }
Visual Basic (Declaration)
Public Property Sizing As ImageSizeMode

See Also

PictureBox Class
Telerik.Reporting.Processing Namespace


PictureWatermark Class

[image]

Telerik Reporting Q2 2012
PictureWatermark Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class PictureWatermark : Watermark
Visual Basic (Declaration)
Public Class PictureWatermark _
    Inherits Watermark

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.Watermark
Telerik.Reporting.Processing..::.PictureWatermark

See Also

PictureWatermark Members
Telerik.Reporting.Processing Namespace


PictureWatermark Members

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Members
PictureWatermark Class Methods Fields Properties See Also Send Feedback

The PictureWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Fields

Name | Description
owner | (Inherited from Watermark.)
watermarkDefinition | (Inherited from Watermark.)

Properties

Name | Description
Image |
Opacity | (Inherited from Watermark.)
Position | (Inherited from Watermark.)
PrintOnFirstPage | (Inherited from Watermark.)
PrintOnLastPage | (Inherited from Watermark.)
Sizing |

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


PictureWatermark Fields

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Fields
PictureWatermark Class See Also Send Feedback

The PictureWatermark type exposes the following members.

Fields

Name | Description
owner | (Inherited from Watermark.)
watermarkDefinition | (Inherited from Watermark.)

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


PictureWatermark Methods

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Methods
PictureWatermark Class See Also Send Feedback

The PictureWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


PictureWatermark Properties

[image] [image]

Telerik Reporting Q2 2012
PictureWatermark Properties
PictureWatermark Class See Also Send Feedback

The PictureWatermark type exposes the following members.

Properties

Name | Description
Image |
Opacity | (Inherited from Watermark.)
Position | (Inherited from Watermark.)
PrintOnFirstPage | (Inherited from Watermark.)
PrintOnLastPage | (Inherited from Watermark.)
Sizing |

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


Image Property

[image]

Telerik Reporting Q2 2012
PictureWatermark..::.Image Property
PictureWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Object

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


Sizing Property

[image]

Telerik Reporting Q2 2012
PictureWatermark..::.Sizing Property
PictureWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkSizeMode Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As WatermarkSizeMode

See Also

PictureWatermark Class
Telerik.Reporting.Processing Namespace


ProcessingElement Class

[image]

Telerik Reporting Q2 2012
ProcessingElement Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ProcessingElement : VisualElement
Visual Basic (Declaration)
Public MustInherit Class ProcessingElement _
    Inherits VisualElement

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.Group
Telerik.Reporting.Processing..::.ReportItemBase

See Also

ProcessingElement Members
Telerik.Reporting.Processing Namespace


ProcessingElement Members

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement Members
ProcessingElement Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ProcessingElement type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the ProcessingElement and optionally releases the managed resources (Overrides LayoutElement..::.Dispose(Boolean).)
OnItemProcessed |
OnItemProcessing |
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete.
DataObject | Gets the IDataObject that is bound to this report item.
Exception | Gets or sets the exception that has occurred during the processing.
Name |
Parent | Obsolete.
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report.
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


ProcessingElement Methods

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement Methods
ProcessingElement Class See Also Send Feedback

The ProcessingElement type exposes the following members.

Methods

Name | Description
Dispose | (Overrides LayoutElement..::.Dispose(Boolean).)
OnItemProcessed |
OnItemProcessing |
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.Dispose Method
ProcessingElement Class See Also Send Feedback
Releases the unmanaged resources used by the ProcessingElement and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


OnItemProcessed Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.OnItemProcessed Method
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnItemProcessed()
Visual Basic (Declaration)
Protected Overridable Sub OnItemProcessed

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


OnItemProcessing Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.OnItemProcessing Method
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected virtual void OnItemProcessing()
Visual Basic (Declaration)
Protected Overridable Sub OnItemProcessing

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement..::.ToString Method
ProcessingElement Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides LayoutElement..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ProcessingElement Class
ProcessingElement Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.ToString Method
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ProcessingElement Class
ToString Overload
Telerik.Reporting.Processing Namespace


ProcessingElement Properties

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement Properties
ProcessingElement Class See Also Send Feedback

The ProcessingElement type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete.
DataObject | Gets the IDataObject that is bound to this report item.
Exception | Gets or sets the exception that has occurred during the processing.
Name |
Parent | Obsolete.
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report.
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


ChildElements Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.ChildElements Property
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The Telerik.Reporting.Processing.ProcessingElement.ChildElements property is now obsolete. Use Telerik.Reporting.Processing.ElementTreeHelper.GetChildElements() method instead.")]
public ProcessingElement..::.ElementCollection ChildElements { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Telerik.Reporting.Processing.ProcessingElement.ChildElements property is now obsolete. Use Telerik.Reporting.Processing.ElementTreeHelper.GetChildElements() method instead.")> _
Public ReadOnly Property ChildElements As ProcessingElement..::.ElementCollection

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


DataObject Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.DataObject Property
ProcessingElement Class See Also Send Feedback
Gets the IDataObject that is bound to this report item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IDataObject DataObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataObject As IDataObject

Field Value

An IDataObject associated with this item.

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Exception Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.Exception Property
ProcessingElement Class See Also Send Feedback
Gets or sets the exception that has occurred during the processing.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Exception Exception { get; set; }
Visual Basic (Declaration)
Public Property Exception As Exception

Remarks

Use this property in a ErrorEventHandler handler to inspect or clear the current processing error.

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.Name Property
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public virtual string Name { get; internal set; }
Visual Basic (Declaration)
Public Overridable Property Name As String

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Parent Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.Parent Property
ProcessingElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The Telerik.Reporting.Processing.ProcessingElement.Parent property is now obsolete. Use Telerik.Reporting.Processing.LayoutElement.ParentElement instead.")]
public ProcessingElement Parent { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Telerik.Reporting.Processing.ProcessingElement.Parent property is now obsolete. Use Telerik.Reporting.Processing.LayoutElement.ParentElement instead.")> _
Public ReadOnly Property Parent As ProcessingElement

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::.Report Property
ProcessingElement Class See Also Send Feedback
Nested report's Report points to itself - not the master report.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Report Report { get; internal set; }
Visual Basic (Declaration)
Public Property Report As Report

See Also

ProcessingElement Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementCollection Class

[image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection Class
ProcessingElement Class Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Telerik.Reporting.Processing.ElementCollection class is now obsolete. Use Telerik.Reporting.Processing.ElementTreeHelper utility class instead.")]
public class ElementCollection : Collection<ProcessingElement>
Visual Basic (Declaration)
<ObsoleteAttribute("Telerik.Reporting.Processing.ElementCollection class is now obsolete. Use Telerik.Reporting.Processing.ElementTreeHelper utility class instead.")> _
Public Class ElementCollection _
    Inherits Collection(Of ProcessingElement)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ProcessingElement >)>)>
Telerik.Reporting.Processing..::.ProcessingElement..::.ElementCollection

See Also

ProcessingElement..::.ElementCollection Members
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementCollection Members

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection Members
ProcessingElement..::.ElementCollection Class Methods Properties See Also Send Feedback

The ProcessingElement..::.ElementCollection type exposes the following members.

Methods

Name | Description
ContainsKey |
Find |
IndexOfKey |

Properties

Name | Description
Item |

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection Methods
ProcessingElement..::.ElementCollection Class See Also Send Feedback

The ProcessingElement..::.ElementCollection type exposes the following members.

Methods

Name | Description
ContainsKey |
Find |
IndexOfKey |

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


ContainsKey Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection..::.ContainsKey Method
ProcessingElement..::.ElementCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


Find Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection..::.Find Method
ProcessingElement..::.ElementCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProcessingElement[] Find(
    string key,
    bool searchAllChildren
)
Visual Basic (Declaration)
Public Function Find ( _
    key As String, _
    searchAllChildren As Boolean _
) As ProcessingElement()

Parameters

key
Type: System..::.String
searchAllChildren
Type: System..::.Boolean

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


IndexOfKey Method

[image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection..::.IndexOfKey Method
ProcessingElement..::.ElementCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int IndexOfKey(
    string key
)
Visual Basic (Declaration)
Public Function IndexOfKey ( _
    key As String _
) As Integer

Parameters

key
Type: System..::.String

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


ProcessingElement.ElementCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection Properties
ProcessingElement..::.ElementCollection Class See Also Send Feedback

The ProcessingElement..::.ElementCollection type exposes the following members.

Properties

Name | Description
Item |

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


Item Property

[image]

Telerik Reporting Q2 2012
ProcessingElement..::..ElementCollection..::.Item Property
ProcessingElement..::.ElementCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProcessingElement this[
    string key
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    key As String _
) As ProcessingElement

Parameters

key
Type: System..::.String

See Also

ProcessingElement..::.ElementCollection Class
Telerik.Reporting.Processing Namespace


RenderingResult Class

[image]

Telerik Reporting Q2 2012
RenderingResult Class
Members See Also Send Feedback
Represents a result of the report rendering.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class RenderingResult
Visual Basic (Declaration)
Public NotInheritable Class RenderingResult

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.RenderingResult

See Also

RenderingResult Members
Telerik.Reporting.Processing Namespace


RenderingResult Members

[image] [image]

Telerik Reporting Q2 2012
RenderingResult Members
RenderingResult Class Properties See Also Send Feedback

The RenderingResult type exposes the following members.

Properties

Name | Description
DocumentBytes | Gets a byte array that contains the rendered report.
DocumentName | Gets the name of the created document.
Encoding | Gets the character encoding of the document.
Errors | Gets an array of exceptions that has occurred during the report processing.
Extension | Gets the file extension of the document.
HasErrors | Gets a value that indicates whether the collection contains errors.
MimeType | Gets the the MIME type of the document.

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


RenderingResult Properties

[image] [image]

Telerik Reporting Q2 2012
RenderingResult Properties
RenderingResult Class See Also Send Feedback

The RenderingResult type exposes the following members.

Properties

Name | Description
DocumentBytes | Gets a byte array that contains the rendered report.
DocumentName | Gets the name of the created document.
Encoding | Gets the character encoding of the document.
Errors | Gets an array of exceptions that has occurred during the report processing.
Extension | Gets the file extension of the document.
HasErrors | Gets a value that indicates whether the collection contains errors.
MimeType | Gets the the MIME type of the document.

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


DocumentBytes Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.DocumentBytes Property
RenderingResult Class See Also Send Feedback
Gets a byte array that contains the rendered report.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public byte[] DocumentBytes { get; internal set; }
Visual Basic (Declaration)
Public Property DocumentBytes As Byte()

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.DocumentName Property
RenderingResult Class See Also Send Feedback
Gets the name of the created document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentName { get; internal set; }
Visual Basic (Declaration)
Public Property DocumentName As String

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


Encoding Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.Encoding Property
RenderingResult Class See Also Send Feedback
Gets the character encoding of the document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Encoding Encoding { get; internal set; }
Visual Basic (Declaration)
Public Property Encoding As Encoding

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


Errors Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.Errors Property
RenderingResult Class See Also Send Feedback
Gets an array of exceptions that has occurred during the report processing.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Exception[] Errors { get; internal set; }
Visual Basic (Declaration)
Public Property Errors As Exception()

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


Extension Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.Extension Property
RenderingResult Class See Also Send Feedback
Gets the file extension of the document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Extension { get; internal set; }
Visual Basic (Declaration)
Public Property Extension As String

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


HasErrors Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.HasErrors Property
RenderingResult Class See Also Send Feedback
Gets a value that indicates whether the collection contains errors.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool HasErrors { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasErrors As Boolean

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


MimeType Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.MimeType Property
RenderingResult Class See Also Send Feedback
Gets the the MIME type of the document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string MimeType { get; internal set; }
Visual Basic (Declaration)
Public Property MimeType As String

See Also

RenderingResult Class
Telerik.Reporting.Processing Namespace


Report Class

[image]

Telerik Reporting Q2 2012
Report Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Report : ReportItemBase, ILayoutElementContainer
Visual Basic (Declaration)
Public Class Report _
    Inherits ReportItemBase _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.Report

See Also

Report Members
Telerik.Reporting.Processing Namespace


Report Members

[image] [image]

Telerik Reporting Q2 2012
Report Members
Report Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Report type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the Report and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Overrides ReportItemBase..::.OnItemProcessed()()().)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
ColumnCount |
ColumnSpacing |
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Report will render.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource | Gets or sets the data source that the Report is displaying data for.
DocumentName | Gets or sets a String representing the name of the report document.
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
IsNestedReport |
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
PageFooter |
PageHeader |
PageSettings |
Parameters | Returns a collection of runtime report Parameters.
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ReportFooter |
ReportHeader |
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Report Class
Telerik.Reporting.Processing Namespace


Report Methods

[image] [image]

Telerik Reporting Q2 2012
Report Methods
Report Class See Also Send Feedback

The Report type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Overrides ReportItemBase..::.OnItemProcessed()()().)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Report Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
Report..::.Dispose Method
Report Class See Also Send Feedback
Releases the unmanaged resources used by the Report and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

Report Class
Telerik.Reporting.Processing Namespace


OnItemProcessed Method

[image]

Telerik Reporting Q2 2012
Report..::.OnItemProcessed Method
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnItemProcessed()
Visual Basic (Declaration)
Protected Overrides Sub OnItemProcessed

See Also

Report Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Report..::.ToString Method
Report Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Report Class
Report Members
Telerik.Reporting.Processing Namespace


Report Properties

[image] [image]

Telerik Reporting Q2 2012
Report Properties
Report Class See Also Send Feedback

The Report type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
ColumnCount |
ColumnSpacing |
DataMember | Obsolete. Gets or sets the specific list in a DataSource which the Report will render.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource | Gets or sets the data source that the Report is displaying data for.
DocumentName | Gets or sets a String representing the name of the report document.
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
IsNestedReport |
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
PageFooter |
PageHeader |
PageSettings |
Parameters | Returns a collection of runtime report Parameters.
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ReportFooter |
ReportHeader |
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |

See Also

Report Class
Telerik.Reporting.Processing Namespace


ColumnCount Property

[image]

Telerik Reporting Q2 2012
Report..::.ColumnCount Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int ColumnCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnCount As Integer

See Also

Report Class
Telerik.Reporting.Processing Namespace


ColumnSpacing Property

[image]

Telerik Reporting Q2 2012
Report..::.ColumnSpacing Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit ColumnSpacing { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColumnSpacing As Unit

See Also

Report Class
Telerik.Reporting.Processing Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Report..::.DataMember Property
Report Class See Also Send Feedback
Gets or sets the specific list in a DataSource which the Report will render.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

See Also

Report Class
Telerik.Reporting.Processing Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Report..::.DataSource Property
Report Class See Also Send Feedback
Gets or sets the data source that the Report is displaying data for.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

See Also

Report Class
Telerik.Reporting.Processing Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
Report..::.DocumentName Property
Report Class See Also Send Feedback
Gets or sets a String representing the name of the report document.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

Field Value

A String representing the document name. The default value is the name of the Report this property belongs to.

Remarks

The value of this property is used to suggest a file name when exporting a report to one of the available export formats.

See Also

Report Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
Report..::.ILayoutElementContainer..::.Children Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

Report Class
Telerik.Reporting.Processing Namespace


IsNestedReport Property

[image]

Telerik Reporting Q2 2012
Report..::.IsNestedReport Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool IsNestedReport { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsNestedReport As Boolean

See Also

Report Class
Telerik.Reporting.Processing Namespace


PageFooter Property

[image]

Telerik Reporting Q2 2012
Report..::.PageFooter Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSection PageFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageFooter As PageSection

See Also

Report Class
Telerik.Reporting.Processing Namespace


PageHeader Property

[image]

Telerik Reporting Q2 2012
Report..::.PageHeader Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSection PageHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageHeader As PageSection

See Also

Report Class
Telerik.Reporting.Processing Namespace


PageSettings Property

[image]

Telerik Reporting Q2 2012
Report..::.PageSettings Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageSettings PageSettings { get; internal set; }
Visual Basic (Declaration)
Public Property PageSettings As PageSettings

See Also

Report Class
Telerik.Reporting.Processing Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
Report..::.Parameters Property
Report Class See Also Send Feedback
Returns a collection of runtime report Parameters.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IDictionary<string, Parameter> Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As IDictionary(Of String, Parameter)

See Also

Report Class
Telerik.Reporting.Processing Namespace


ReportFooter Property

[image]

Telerik Reporting Q2 2012
Report..::.ReportFooter Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportSection ReportFooter { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportFooter As ReportSection

See Also

Report Class
Telerik.Reporting.Processing Namespace


ReportHeader Property

[image]

Telerik Reporting Q2 2012
Report..::.ReportHeader Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportSection ReportHeader { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReportHeader As ReportSection

See Also

Report Class
Telerik.Reporting.Processing Namespace


Width Property

[image]

Telerik Reporting Q2 2012
Report..::.Width Property
Report Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

See Also

Report Class
Telerik.Reporting.Processing Namespace


ReportItem Class

[image]

Telerik Reporting Q2 2012
ReportItem Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportItem : ReportItemBase, ITableCell
Visual Basic (Declaration)
Public Class ReportItem _
    Inherits ReportItemBase _
    Implements ITableCell

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Barcode
Telerik.Reporting.Processing..::.Chart
Telerik.Reporting.Processing..::.HtmlTextBox
Telerik.Reporting.Processing..::.Panel
Telerik.Reporting.Processing..::.PictureBox
Telerik.Reporting.Processing..::.Shape
Telerik.Reporting.Processing..::.SubReport
Telerik.Reporting.Processing..::.Table
Telerik.Reporting.Processing..::.TextItemBase

See Also

ReportItem Members
Telerik.Reporting.Processing Namespace


ReportItem Members

[image] [image]

Telerik Reporting Q2 2012
ReportItem Members
ReportItem Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportItem type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete.
Anchoring |
Bounds |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete.
Docking |
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height |
ItemDefinition | (Inherited from ReportItemBase.)
Left |
Location |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size |
Style | (Inherited from VisualElement.)
Top |
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex |
ITableCell..::.ColumnSpan |
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item |
ITableCell..::.RowIndex |
ITableCell..::.RowSpan |
ITableCell..::.Table |

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ReportItem Methods

[image] [image]

Telerik Reporting Q2 2012
ReportItem Methods
ReportItem Class See Also Send Feedback

The ReportItem type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportItem..::.ToString Method
ReportItem Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportItem Class
ReportItem Members
Telerik.Reporting.Processing Namespace


ReportItem Properties

[image] [image]

Telerik Reporting Q2 2012
ReportItem Properties
ReportItem Class See Also Send Feedback

The ReportItem type exposes the following members.

Properties

Name | Description
Anchor | Obsolete.
Anchoring |
Bounds |
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete.
Docking |
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height |
ItemDefinition | (Inherited from ReportItemBase.)
Left |
Location |
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size |
Style | (Inherited from VisualElement.)
Top |
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex |
ITableCell..::.ColumnSpan |
ITableCell..::.Item |
ITableCell..::.RowIndex |
ITableCell..::.RowSpan |
ITableCell..::.Table |

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Anchor Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Anchor Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Use the Anchoring property instead.")]
public AnchorStyles Anchor { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use the Anchoring property instead.")> _
Public Property Anchor As AnchorStyles

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Anchoring Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Anchoring Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public AnchoringStyles Anchoring { get; internal set; }
Visual Basic (Declaration)
Public Property Anchoring As AnchoringStyles

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Bounds Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Bounds Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RectangleU Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As RectangleU

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Dock Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Dock Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Use the Docking property instead.")]
public DockStyle Dock { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use the Docking property instead.")> _
Public Property Dock As DockStyle

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Docking Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Docking Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public DockingStyle Docking { get; internal set; }
Visual Basic (Declaration)
Public Property Docking As DockingStyle

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Height Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.ColumnIndex Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.ColumnIndex Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ITableCell.ColumnIndex { get; }
Visual Basic (Declaration)
Private ReadOnly Property ColumnIndex As Integer
    Implements ITableCell.ColumnIndex

Implements

ITableCell..::.ColumnIndex

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.ColumnSpan Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.ColumnSpan Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ITableCell.ColumnSpan { get; }
Visual Basic (Declaration)
Private ReadOnly Property ColumnSpan As Integer
    Implements ITableCell.ColumnSpan

Implements

ITableCell..::.ColumnSpan

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.Item Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.Item Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ReportItem ITableCell.Item { get; }
Visual Basic (Declaration)
Private ReadOnly Property Item As ReportItem
    Implements ITableCell.Item

Implements

ITableCell..::.Item

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.RowIndex Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.RowIndex Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ITableCell.RowIndex { get; }
Visual Basic (Declaration)
Private ReadOnly Property RowIndex As Integer
    Implements ITableCell.RowIndex

Implements

ITableCell..::.RowIndex

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.RowSpan Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.RowSpan Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
int ITableCell.RowSpan { get; }
Visual Basic (Declaration)
Private ReadOnly Property RowSpan As Integer
    Implements ITableCell.RowSpan

Implements

ITableCell..::.RowSpan

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ITableCell.Table Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.ITableCell..::.Table Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
Table ITableCell.Table { get; }
Visual Basic (Declaration)
Private ReadOnly Property Table As Table
    Implements ITableCell.Table

Implements

ITableCell..::.Table

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Left Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Left Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Unit

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Location Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Location Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PointU Location { get; set; }
Visual Basic (Declaration)
Public Property Location As PointU

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Size Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Size Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SizeU Size { get; set; }
Visual Basic (Declaration)
Public Property Size As SizeU

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Top Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Top Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Unit

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ReportItem..::.Width Property
ReportItem Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Unit

See Also

ReportItem Class
Telerik.Reporting.Processing Namespace


ReportItemBase Class

[image]

Telerik Reporting Q2 2012
ReportItemBase Class
Members See Also Send Feedback
Represents a processing report item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class ReportItemBase : ProcessingElement
Visual Basic (Declaration)
Public MustInherit Class ReportItemBase _
    Inherits ProcessingElement

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.Report
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.ReportSectionBase

See Also

ReportItemBase Members
Telerik.Reporting.Processing Namespace


ReportItemBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Members
ReportItemBase Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportItemBase type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the ReportItemBase and optionally releases the managed resources (Overrides ProcessingElement..::.Dispose(Boolean).)
OnItemProcessed | (Overrides ProcessingElement..::.OnItemProcessed()()().)
OnItemProcessing | (Overrides ProcessingElement..::.OnItemProcessing()()().)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
ItemDefinition |
Name | (Overrides ProcessingElement..::.Name.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


ReportItemBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Methods
ReportItemBase Class See Also Send Feedback

The ReportItemBase type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ProcessingElement..::.Dispose(Boolean).)
OnItemProcessed | (Overrides ProcessingElement..::.OnItemProcessed()()().)
OnItemProcessing | (Overrides ProcessingElement..::.OnItemProcessing()()().)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Dispose Method
ReportItemBase Class See Also Send Feedback
Releases the unmanaged resources used by the ReportItemBase and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


OnItemProcessed Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.OnItemProcessed Method
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnItemProcessed()
Visual Basic (Declaration)
Protected Overrides Sub OnItemProcessed

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


OnItemProcessing Method

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.OnItemProcessing Method
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void OnItemProcessing()
Visual Basic (Declaration)
Protected Overrides Sub OnItemProcessing

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase..::.ToString Method
ReportItemBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportItemBase Class
ReportItemBase Members
Telerik.Reporting.Processing Namespace


ReportItemBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportItemBase Properties
ReportItemBase Class See Also Send Feedback

The ReportItemBase type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
ItemDefinition |
Name | (Overrides ProcessingElement..::.Name.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


ItemDefinition Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.ItemDefinition Property
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportItemBase ItemDefinition { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemDefinition As ReportItemBase

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ReportItemBase..::.Name Property
ReportItemBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string Name { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Name As String

See Also

ReportItemBase Class
Telerik.Reporting.Processing Namespace


ReportProcessor Class

[image]

Telerik Reporting Q2 2012
ReportProcessor Class
Members See Also Send Feedback
Represents the object responsible for printing and rendering Reports.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ReportProcessor
Visual Basic (Declaration)
Public NotInheritable Class ReportProcessor

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.ReportProcessor

See Also

ReportProcessor Members
Telerik.Reporting.Processing Namespace


ReportProcessor Members

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor Members
ReportProcessor Class Constructors Methods Properties Events See Also Send Feedback

The ReportProcessor type exposes the following members.

Constructors

Name | Description
ReportProcessor | Initializes a new instance of the ReportProcessor class.

Methods

Name | Description
Print | Obsolete. Prints a report document using the specified printer settings.
PrintReport | Prints a report document using the specified printer settings.
Render | Overloaded.
RenderReport | Overloaded.

Properties

Name | Description
PrintController | Specifies a print controller to be used when printing a Report. If a null value is specified, a default print controller is used, which displays the Print Progress dialog.

Events

Name | Description
Error | Occurs when a processing exception is raised.

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ReportProcessor Constructor

[image]

Telerik Reporting Q2 2012
ReportProcessor Constructor
ReportProcessor Class See Also Send Feedback
Initializes a new instance of the ReportProcessor class.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportProcessor()
Visual Basic (Declaration)
Public Sub New

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ReportProcessor Methods

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor Methods
ReportProcessor Class See Also Send Feedback

The ReportProcessor type exposes the following members.

Methods

Name | Description
Print | Obsolete. Prints a report document using the specified printer settings.
PrintReport | Prints a report document using the specified printer settings.
Render | Overloaded.
RenderReport | Overloaded.

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


Print Method

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Print Method
ReportProcessor Class See Also Send Feedback
Prints a report document using the specified printer settings.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The static (Shared) ReportProcessor.Print method is now obsolete. Please create an instance of the ReportProcessor class and use the PrintReport method.")]
public static void Print(
    IReportDocument reportDocument,
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
<ObsoleteAttribute("The static (Shared) ReportProcessor.Print method is now obsolete. Please create an instance of the ReportProcessor class and use the PrintReport method.")> _
Public Shared Sub Print ( _
    reportDocument As IReportDocument, _
    printerSettings As PrinterSettings _
)

Parameters

reportDocument
Type: Telerik.Reporting..::.IReportDocument
Specifies an instance of a report document to print. Both Report and ReportBook documents are supported.
printerSettings
Type: System.Drawing.Printing..::.PrinterSettings
Specifies the printer settings to be used when printing the document. If null or invalid settings are specified, the Print Dialog appears.

Remarks

To prevent the Print Dialog from appearing, you should specify valid printer settings to this method.

Examples

This example illustrates how to prevent the standard Print Dialog from appearing in a batch print operation or when printing from a service.
CopyC#
// Create an instance of the report to print.
IReportDocument reportDocument = new MyReport();
// Obtain the settings of the default printer.
PrinterSettings printerSettings = new PrinterSettings();
// Adjust the printer settings if necessary...

// Print the report using the printer settings.
ReportProcessor.Print(reportDocument, printerSettings);
CopyVB
' Create an instance of the report to print.
Dim reportDocument As IReportDocument = New MyReport()
' Obtain the settings of the default printer.
Dim printerSettings As New PrinterSettings()
' Adjust the printer settings if necessary...

' Print the report using the printer settings.
ReportProcessor.Print(reportDocument, printerSettings)

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


PrintReport Method

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.PrintReport Method
ReportProcessor Class See Also Send Feedback
Prints a report document using the specified printer settings.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void PrintReport(
    ReportSource reportSource,
    PrinterSettings printerSettings
)
Visual Basic (Declaration)
Public Sub PrintReport ( _
    reportSource As ReportSource, _
    printerSettings As PrinterSettings _
)

Parameters

reportSource
Type: Telerik.Reporting..::.ReportSource
Specifies the ReportSource for the report document to print.
printerSettings
Type: System.Drawing.Printing..::.PrinterSettings
Specifies the printer settings to be used when printing the document. If null or invalid settings are specified, the Print Dialog appears.

Remarks

To prevent the Print Dialog from appearing, you should specify valid printer settings to this method.

Examples

This example illustrates how to prevent the standard Print Dialog from appearing in a batch print operation or when printing from a service.
CopyC#
Telerik.Reporting.IReportDocument myReport = new MyReport();

// Obtain the settings of the default printer
System.Drawing.Printing.PrinterSettings printerSettings
    = new System.Drawing.Printing.PrinterSettings();

// The standard print controller comes with no UI
System.Drawing.Printing.PrintController standardPrintController =
    new System.Drawing.Printing.StandardPrintController();

// Print the report using the custom print controller
Telerik.Reporting.Processing.ReportProcessor reportProcessor
    = new Telerik.Reporting.Processing.ReportProcessor();

reportProcessor.PrintController = standardPrintController;

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

instanceReportSource.ReportDocument = myReport;

reportProcessor.PrintReport(instanceReportSource, printerSettings);
CopyVB.NET
Dim report1 As New MyReport

' Obtain the settings of the default printer
Dim printerSettings As New System.Drawing.Printing.PrinterSettings

' The standard print controller comes with no UI
Dim standardPrintController As New System.Drawing.Printing.StandardPrintController

' Create an instance report source to pass the report to the report processor
Dim instanceReportSource as new Telerik.Reporting.InstanceReportSource()
instanceReportSource.ReportDocument = report1

' Print the report using the custom print controller
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor
reportProcessor.PrintController = standardPrintController
reportProcessor.PrintReport(instanceReportSource, printerSettings)

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


Render Method

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor..::.Render Method
ReportProcessor Class See Also Send Feedback

Overload List

Name | Description
Render(String, IReportDocument, Hashtable, CreateStream) | Obsolete. Renders a report in the specified format
Render(String, IReportDocument, Hashtable, CreateStream, String%) | Obsolete. Renders a report in the specified format
Render(String, IReportDocument, Hashtable, String%, String%, Encoding%) | Obsolete. Renders a report in the specified format
Render(String, IReportDocument, Hashtable, String%, String%, String%, Encoding%) | Obsolete. Renders a report in the specified format

See Also

ReportProcessor Class
ReportProcessor Members
Telerik.Reporting.Processing Namespace


Render Method (String, IReportDocument, Hashtable, CreateStream)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Render Method (String, IReportDocument, Hashtable, CreateStream)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")]
public static bool Render(
    string format,
    IReportDocument report,
    Hashtable deviceInfo,
    CreateStream createStreamCallback
)
Visual Basic (Declaration)
<ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")> _
Public Shared Function Render ( _
    format As String, _
    report As IReportDocument, _
    deviceInfo As Hashtable, _
    createStreamCallback As CreateStream _
) As Boolean

Parameters

format
Type: System..::.String
Export format
report
Type: Telerik.Reporting..::.IReportDocument
Report document to render
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.
createStreamCallback
Type: Telerik.Reporting.Processing..::.CreateStream
The delegate function to call to get a stream to render into.

Return Value

True if the rendering succeeds.

See Also

ReportProcessor Class
Render Overload
Telerik.Reporting.Processing Namespace


Render Method (String, IReportDocument, Hashtable, CreateStream, String)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Render Method (String, IReportDocument, Hashtable, CreateStream, String%)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")]
public static bool Render(
    string format,
    IReportDocument reportDocument,
    Hashtable deviceInfo,
    CreateStream createStreamCallback,
    out string documentName
)
Visual Basic (Declaration)
<ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")> _
Public Shared Function Render ( _
    format As String, _
    reportDocument As IReportDocument, _
    deviceInfo As Hashtable, _
    createStreamCallback As CreateStream, _
    <OutAttribute> ByRef documentName As String _
) As Boolean

Parameters

format
Type: System..::.String
Export format
reportDocument
Type: Telerik.Reporting..::.IReportDocument
Report document to render
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.
createStreamCallback
Type: Telerik.Reporting.Processing..::.CreateStream
The delegate function to call to get a stream to render into.
documentName
Type: System..::.String %
The name of the created document.

Return Value

True if the rendering succeeds.

See Also

ReportProcessor Class
Render Overload
Telerik.Reporting.Processing Namespace


Render Method (String, IReportDocument, Hashtable, String, String, Encoding)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Render Method (String, IReportDocument, Hashtable, String%, String%, Encoding%)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")]
public static byte[] Render(
    string format,
    IReportDocument report,
    Hashtable deviceInfo,
    out string mimeType,
    out string extension,
    out Encoding encoding
)
Visual Basic (Declaration)
<ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")> _
Public Shared Function Render ( _
    format As String, _
    report As IReportDocument, _
    deviceInfo As Hashtable, _
    <OutAttribute> ByRef mimeType As String, _
    <OutAttribute> ByRef extension As String, _
    <OutAttribute> ByRef encoding As Encoding _
) As Byte()

Parameters

format
Type: System..::.String
Export format
report
Type: Telerik.Reporting..::.IReportDocument
Report document to render.
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.
mimeType
Type: System..::.String %
The MIME type of the result buffer.
extension
Type: System..::.String %
The file extension of the result buffer.
encoding
Type: System.Text..::.Encoding %
The character encoding of the result buffer.

Return Value

Byte array that contains the rendered report.

See Also

ReportProcessor Class
Render Overload
Telerik.Reporting.Processing Namespace


Render Method (String, IReportDocument, Hashtable, String, String, String, Encoding)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Render Method (String, IReportDocument, Hashtable, String%, String%, String%, Encoding%)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")]
public static byte[] Render(
    string format,
    IReportDocument report,
    Hashtable deviceInfo,
    out string mimeType,
    out string documentName,
    out string extension,
    out Encoding encoding
)
Visual Basic (Declaration)
<ObsoleteAttribute("The static (Shared) ReportProcessor.Render method is now obsolete. Please create an instance of the ReportProcessor class and use the RenderReport method.")> _
Public Shared Function Render ( _
    format As String, _
    report As IReportDocument, _
    deviceInfo As Hashtable, _
    <OutAttribute> ByRef mimeType As String, _
    <OutAttribute> ByRef documentName As String, _
    <OutAttribute> ByRef extension As String, _
    <OutAttribute> ByRef encoding As Encoding _
) As Byte()

Parameters

format
Type: System..::.String
Export format
report
Type: Telerik.Reporting..::.IReportDocument
Report document to render.
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.
mimeType
Type: System..::.String %
The MIME type of the result buffer.
documentName
Type: System..::.String %
The name of the created document.
extension
Type: System..::.String %
The file extension of the result buffer.
encoding
Type: System.Text..::.Encoding %
The character encoding of the result buffer.

Return Value

Byte array that contains the rendered report.

See Also

ReportProcessor Class
Render Overload
Telerik.Reporting.Processing Namespace


RenderReport Method

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor..::.RenderReport Method
ReportProcessor Class See Also Send Feedback

Overload List

Name | Description
RenderReport(String, ReportSource, Hashtable) | Renders a report in the specified format
RenderReport(String, ReportSource, Hashtable, CreateStream, String%) | Renders a report in the specified format

See Also

ReportProcessor Class
ReportProcessor Members
Telerik.Reporting.Processing Namespace


RenderReport Method (String, ReportSource, Hashtable)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.RenderReport Method (String, ReportSource, Hashtable)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public RenderingResult RenderReport(
    string format,
    ReportSource reportSource,
    Hashtable deviceInfo
)
Visual Basic (Declaration)
Public Function RenderReport ( _
    format As String, _
    reportSource As ReportSource, _
    deviceInfo As Hashtable _
) As RenderingResult

Parameters

format
Type: System..::.String
Export format
reportSource
Type: Telerik.Reporting..::.ReportSource
The ReportSource for the report document to render.
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.

See Also

ReportProcessor Class
RenderReport Overload
Telerik.Reporting.Processing Namespace


RenderReport Method (String, ReportSource, Hashtable, CreateStream, String)

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.RenderReport Method (String, ReportSource, Hashtable, CreateStream, String%)
ReportProcessor Class See Also Send Feedback
Renders a report in the specified format

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool RenderReport(
    string format,
    ReportSource reportSource,
    Hashtable deviceInfo,
    CreateStream createStreamCallback,
    out string documentName
)
Visual Basic (Declaration)
Public Function RenderReport ( _
    format As String, _
    reportSource As ReportSource, _
    deviceInfo As Hashtable, _
    createStreamCallback As CreateStream, _
    <OutAttribute> ByRef documentName As String _
) As Boolean

Parameters

format
Type: System..::.String
Export format
reportSource
Type: Telerik.Reporting..::.ReportSource
The ReportSource for the report document to render.
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.
createStreamCallback
Type: Telerik.Reporting.Processing..::.CreateStream
The delegate function to call to get a stream to render into.
documentName
Type: System..::.String %
The name of the created document.

Return Value

True if the rendering succeeds.

See Also

ReportProcessor Class
RenderReport Overload
Telerik.Reporting.Processing Namespace


ReportProcessor Properties

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor Properties
ReportProcessor Class See Also Send Feedback

The ReportProcessor type exposes the following members.

Properties

Name | Description
PrintController | Specifies a print controller to be used when printing a Report. If a null value is specified, a default print controller is used, which displays the Print Progress dialog.

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


PrintController Property

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.PrintController Property
ReportProcessor Class See Also Send Feedback
Specifies a print controller to be used when printing a Report. If a null value is specified, a default print controller is used, which displays the Print Progress dialog.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PrintController PrintController { get; set; }
Visual Basic (Declaration)
Public Property PrintController As PrintController

Remarks

If you need a better control over the printing process, or simply to customize the appearance of the print UI, you should specify a custom print controller to this method.

Examples

This example shows how to customize the title of the Print Progress dialog with a custom provided print controller.
CopyC#
Telerik.Reporting.IReportDocument reportDocument = new MyReport();

// Obtain the settings of the default printer
System.Drawing.Printing.PrinterSettings printerSettings =
    new System.Drawing.Printing.PrinterSettings();

// Create a custom print controller based on the StandardPrintController with title: Print Progress
System.Drawing.Printing.PrintController standardPrintController =
    new System.Drawing.Printing.StandardPrintController();

System.Drawing.Printing.PrintController customPrintController =
    new System.Windows.Forms.PrintControllerWithStatusDialog(standardPrintController, "Print Progress");

// Print the report using the custom print controller
Telerik.Reporting.Processing.ReportProcessor reportProcessor =
    new Telerik.Reporting.Processing.ReportProcessor();

reportProcessor.PrintController = customPrintController;

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();
instanceReportSource.ReportDocument = reportDocument;

reportProcessor.PrintReport(instanceReportSource, printerSettings);
CopyVB.NET
Dim report1 As New MyReport

' Obtain the settings of the default printer
Dim printerSettings As New System.Drawing.Printing.PrinterSettings

' Create a custom print controller based on the StandardPrintController with title: Print Progress
Dim standardPrintController As New System.Drawing.Printing.StandardPrintController
Dim customPrintController As New System.Windows.Forms.PrintControllerWithStatusDialog(standardPrintController, "Print Progress")

' Create an instance report source to pass the report to the report processor
Dim instanceReportSource as new Telerik.Reporting.InstanceReportSource
instanceReportSource.ReportDocument = report1

'Print the report using the custom print controller
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor
reportProcessor.PrintController = customPrintController
reportProcessor.PrintReport(instanceReportSource, printerSettings)
To prevent the print UI from appearing, you should specify valid printer settings and a standard print controller to this method.

Examples

This example illustrates how to prevent the print UI from appearing in a batch print operation or when printing from a service.
CopyC#
Telerik.Reporting.IReportDocument myReport = new MyReport();

// Obtain the settings of the default printer
System.Drawing.Printing.PrinterSettings printerSettings
    = new System.Drawing.Printing.PrinterSettings();

// The standard print controller comes with no UI
System.Drawing.Printing.PrintController standardPrintController =
    new System.Drawing.Printing.StandardPrintController();

// Print the report using the custom print controller
Telerik.Reporting.Processing.ReportProcessor reportProcessor
    = new Telerik.Reporting.Processing.ReportProcessor();

reportProcessor.PrintController = standardPrintController;

Telerik.Reporting.InstanceReportSource instanceReportSource =
    new Telerik.Reporting.InstanceReportSource();

instanceReportSource.ReportDocument = myReport;

reportProcessor.PrintReport(instanceReportSource, printerSettings);
CopyVB.NET
Dim report1 As New MyReport

' Obtain the settings of the default printer
Dim printerSettings As New System.Drawing.Printing.PrinterSettings

' The standard print controller comes with no UI
Dim standardPrintController As New System.Drawing.Printing.StandardPrintController

' Create an instance report source to pass the report to the report processor
Dim instanceReportSource as new Telerik.Reporting.InstanceReportSource()
instanceReportSource.ReportDocument = report1

' Print the report using the custom print controller
Dim reportProcessor As New Telerik.Reporting.Processing.ReportProcessor
reportProcessor.PrintController = standardPrintController
reportProcessor.PrintReport(instanceReportSource, printerSettings)

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ReportProcessor Events

[image] [image]

Telerik Reporting Q2 2012
ReportProcessor Events
ReportProcessor Class See Also Send Feedback

The ReportProcessor type exposes the following members.

Events

Name | Description
Error | Occurs when a processing exception is raised.

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


Error Event

[image]

Telerik Reporting Q2 2012
ReportProcessor..::.Error Event
ReportProcessor Class See Also Send Feedback
Occurs when a processing exception is raised.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public event ErrorEventHandler Error
Visual Basic (Declaration)
Public Event Error As ErrorEventHandler

See Also

ReportProcessor Class
Telerik.Reporting.Processing Namespace


ReportSection Class

[image]

Telerik Reporting Q2 2012
ReportSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportSection : ReportSectionBase
Visual Basic (Declaration)
Public Class ReportSection _
    Inherits ReportSectionBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportSectionBase
Telerik.Reporting.Processing..::.ReportSection
Telerik.Reporting.Processing..::.DetailSection
Telerik.Reporting.Processing..::.GroupSection

See Also

ReportSection Members
Telerik.Reporting.Processing Namespace


ReportSection Members

[image] [image]

Telerik Reporting Q2 2012
ReportSection Members
ReportSection Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Name | (Inherited from ReportItemBase.)
PageBreak |
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportSection Class
Telerik.Reporting.Processing Namespace


ReportSection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportSection Methods
ReportSection Class See Also Send Feedback

The ReportSection type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportSectionBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportSection Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportSection..::.ToString Method
ReportSection Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportSection Class
ReportSection Members
Telerik.Reporting.Processing Namespace


ReportSection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportSection Properties
ReportSection Class See Also Send Feedback

The ReportSection type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportSectionBase.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Name | (Inherited from ReportItemBase.)
PageBreak |
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportSectionBase.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children | (Inherited from ReportSectionBase.)

See Also

ReportSection Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
ReportSection..::.KeepTogether Property
ReportSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

ReportSection Class
Telerik.Reporting.Processing Namespace


PageBreak Property

[image]

Telerik Reporting Q2 2012
ReportSection..::.PageBreak Property
ReportSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public PageBreak PageBreak { get; set; }
Visual Basic (Declaration)
Public Property PageBreak As PageBreak

See Also

ReportSection Class
Telerik.Reporting.Processing Namespace


ReportSectionBase Class

[image]

Telerik Reporting Q2 2012
ReportSectionBase Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportSectionBase : ReportItemBase,
    ILayoutElementContainer
Visual Basic (Declaration)
Public Class ReportSectionBase _
    Inherits ReportItemBase _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportSectionBase
Telerik.Reporting.Processing..::.PageSection
Telerik.Reporting.Processing..::.ReportSection

See Also

ReportSectionBase Members
Telerik.Reporting.Processing Namespace


ReportSectionBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Members
ReportSectionBase Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportSectionBase type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the ReportSectionBase and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height |
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


ReportSectionBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Methods
ReportSectionBase Class See Also Send Feedback

The ReportSectionBase type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ReportSectionBase..::.Dispose Method
ReportSectionBase Class See Also Send Feedback
Releases the unmanaged resources used by the ReportSectionBase and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase..::.ToString Method
ReportSectionBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

ReportSectionBase Class
ReportSectionBase Members
Telerik.Reporting.Processing Namespace


ReportSectionBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportSectionBase Properties
ReportSectionBase Class See Also Send Feedback

The ReportSectionBase type exposes the following members.

Properties

Name | Description
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height |
ItemDefinition | (Inherited from ReportItemBase.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Style | (Inherited from VisualElement.)
Visible | (Inherited from VisualElement.)
Width |

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ReportSectionBase..::.Height Property
ReportSectionBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Unit

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
ReportSectionBase..::.ILayoutElementContainer..::.Children Property
ReportSectionBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ReportSectionBase..::.Width Property
ReportSectionBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Unit Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Unit

See Also

ReportSectionBase Class
Telerik.Reporting.Processing Namespace


Shape Class

[image]

Telerik Reporting Q2 2012
Shape Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Shape : ReportItem
Visual Basic (Declaration)
Public Class Shape _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Shape

See Also

Shape Members
Telerik.Reporting.Processing Namespace


Shape Members

[image] [image]

Telerik Reporting Q2 2012
Shape Members
Shape Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Shape type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ShapeType |
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Shape Class
Telerik.Reporting.Processing Namespace


Shape Methods

[image] [image]

Telerik Reporting Q2 2012
Shape Methods
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Shape Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Shape..::.ToString Method
Shape Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Shape Class
Shape Members
Telerik.Reporting.Processing Namespace


Shape Properties

[image] [image]

Telerik Reporting Q2 2012
Shape Properties
Shape Class See Also Send Feedback

The Shape type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
ShapeType |
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Shape Class
Telerik.Reporting.Processing Namespace


ShapeType Property

[image]

Telerik Reporting Q2 2012
Shape..::.ShapeType Property
Shape Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ShapeBase ShapeType { get; internal set; }
Visual Basic (Declaration)
Public Property ShapeType As ShapeBase

See Also

Shape Class
Telerik.Reporting.Processing Namespace


SubReport Class

[image]

Telerik Reporting Q2 2012
SubReport Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class SubReport : ReportItem, ILayoutElementContainer
Visual Basic (Declaration)
Public Class SubReport _
    Inherits ReportItem _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.SubReport

See Also

SubReport Members
Telerik.Reporting.Processing Namespace


SubReport Members

[image] [image]

Telerik Reporting Q2 2012
SubReport Members
SubReport Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The SubReport type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the SubReport and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
InnerReport |
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


SubReport Methods

[image] [image]

Telerik Reporting Q2 2012
SubReport Methods
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
SubReport..::.Dispose Method
SubReport Class See Also Send Feedback
Releases the unmanaged resources used by the SubReport and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
SubReport..::.ToString Method
SubReport Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

SubReport Class
SubReport Members
Telerik.Reporting.Processing Namespace


SubReport Properties

[image] [image]

Telerik Reporting Q2 2012
SubReport Properties
SubReport Class See Also Send Feedback

The SubReport type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
InnerReport |
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
SubReport..::.ILayoutElementContainer..::.Children Property
SubReport Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


InnerReport Property

[image]

Telerik Reporting Q2 2012
SubReport..::.InnerReport Property
SubReport Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Report InnerReport { get; }
Visual Basic (Declaration)
Public ReadOnly Property InnerReport As Report

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
SubReport..::.KeepTogether Property
SubReport Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; internal set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

SubReport Class
Telerik.Reporting.Processing Namespace


Table Class

[image]

Telerik Reporting Q2 2012
Table Class
Members See Also Send Feedback
Represents a processing Table item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class Table : ReportItem, ILayoutElementContainer
Visual Basic (Declaration)
Public Class Table _
    Inherits ReportItem _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.Table

See Also

Table Members
Telerik.Reporting.Processing Namespace


Table Members

[image] [image]

Telerik Reporting Q2 2012
Table Members
Table Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The Table type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the Table and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
GetCell | Gets an ITableCell at the specified row and column index.
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
Columns | Gets a list of TableColumn objects that represents the columns in a Table item.
DataMember | Obsolete. Gets or sets the specific list in a DataMemberInternal()()() which the Report will render.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource | Gets or sets the data source that the Table is displaying data for.
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Rows | Gets a list of TableRow objects that represents the rows in a Table item.
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Table Class
Telerik.Reporting.Processing Namespace


Table Methods

[image] [image]

Telerik Reporting Q2 2012
Table Methods
Table Class See Also Send Feedback

The Table type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
GetCell | Gets an ITableCell at the specified row and column index.
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

Table Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
Table..::.Dispose Method
Table Class See Also Send Feedback
Releases the unmanaged resources used by the Table and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

Table Class
Telerik.Reporting.Processing Namespace


GetCell Method

[image]

Telerik Reporting Q2 2012
Table..::.GetCell Method
Table Class Example See Also Send Feedback
Gets an ITableCell at the specified row and column index.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ITableCell GetCell(
    int rowIndex,
    int columnIndex
)
Visual Basic (Declaration)
Public Function GetCell ( _
    rowIndex As Integer, _
    columnIndex As Integer _
) As ITableCell

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32

Return Value

ITableCell

Remarks

This method should be used after the Table item is data bound.

Examples

The following code snippet demonstrates a sample usage of the GetCell method:
CopyC#
var tableDef = new Telerik.Reporting.Table();

tableDef.ItemDataBound += delegate(object sender, EventArgs args)
{
    Telerik.Reporting.Processing.Table table = (Telerik.Reporting.Processing.Table)sender;

    for (int rowIndex = 0; rowIndex < table.Rows.Count; rowIndex++)
    {
        for (int columnIndex = 0; columnIndex < table.Columns.Count; columnIndex++)
        {
            Telerik.Reporting.Processing.ITableCell cell = table.GetCell(rowIndex, columnIndex);

            if (cell.RowIndex == rowIndex
                && cell.ColumnIndex == columnIndex)
            {
                Telerik.Reporting.Processing.ReportItem item = cell.Item;

                // Here you can do something with the report item
            }
            else
            {
                // Do nothing. This is part of a merged table cell.
            }
        }
    }
};
CopyVB.NET
Private Sub TableDef_ItemDataBound1(ByVal sender As Object, ByVal e As EventArgs) Handles tableDef.ItemDataBound
    Dim table As Telerik.Reporting.Processing.Table = DirectCast(sender, Telerik.Reporting.Processing.Table)

    For rowIndex = 0 To table.Rows.Count - 1
        For columnIndex = 0 To table.Columns.Count - 1
            Dim cell = table.GetCell(rowIndex, columnIndex)

            If cell.RowIndex = rowIndex AndAlso cell.ColumnIndex = columnIndex Then
                Dim item As Telerik.Reporting.Processing.ReportItem = cell.Item
                ' Here you can do something with the report item
            Else
                ' Do nothing. This is part of a merged table cell
            End If
        Next
    Next
End Sub

See Also

Table Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
Table..::.ToString Method
Table Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

Table Class
Table Members
Telerik.Reporting.Processing Namespace


Table Properties

[image] [image]

Telerik Reporting Q2 2012
Table Properties
Table Class See Also Send Feedback

The Table type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
Columns | Gets a list of TableColumn objects that represents the columns in a Table item.
DataMember | Obsolete. Gets or sets the specific list in a DataMemberInternal()()() which the Report will render.
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
DataSource | Gets or sets the data source that the Table is displaying data for.
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Rows | Gets a list of TableRow objects that represents the rows in a Table item.
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

Table Class
Telerik.Reporting.Processing Namespace


Columns Property

[image]

Telerik Reporting Q2 2012
Table..::.Columns Property
Table Class See Also Send Feedback
Gets a list of TableColumn objects that represents the columns in a Table item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IList<TableColumn> Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As IList(Of TableColumn)

See Also

Table Class
Telerik.Reporting.Processing Namespace


DataMember Property

[image]

Telerik Reporting Q2 2012
Table..::.DataMember Property
Table Class See Also Send Feedback
Gets or sets the specific list in a DataMemberInternal()()() which the Report will render.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
[ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")]
public string DataMember { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Please use ObjectDataSource as DataSource and set its DataMember instead.")> _
Public Property DataMember As String

See Also

Table Class
Telerik.Reporting.Processing Namespace


DataSource Property

[image]

Telerik Reporting Q2 2012
Table..::.DataSource Property
Table Class See Also Send Feedback
Gets or sets the data source that the Table is displaying data for.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As Object

See Also

Table Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
Table..::.ILayoutElementContainer..::.Children Property
Table Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

Table Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
Table..::.KeepTogether Property
Table Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; internal set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

Table Class
Telerik.Reporting.Processing Namespace


Rows Property

[image]

Telerik Reporting Q2 2012
Table..::.Rows Property
Table Class See Also Send Feedback
Gets a list of TableRow objects that represents the rows in a Table item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public IList<TableRow> Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As IList(Of TableRow)

See Also

Table Class
Telerik.Reporting.Processing Namespace


TableColumn Class

[image]

Telerik Reporting Q2 2012
TableColumn Class
Members See Also Send Feedback
Represents a column in the Table()()() item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class TableColumn : IDisposable
Visual Basic (Declaration)
Public NotInheritable Class TableColumn _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.TableColumn

See Also

TableColumn Members
Telerik.Reporting.Processing Namespace


TableColumn Members

[image] [image]

Telerik Reporting Q2 2012
TableColumn Members
TableColumn Class Methods Properties See Also Send Feedback

The TableColumn type exposes the following members.

Methods

Name | Description
Dispose | Releases all resources used by the TableColumn
GetCell | Gets an ITableCell at the specified row index.
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Index | Gets the index of the current TableColumn in the [!:Table.Columns] collection of the Table()()() item.

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


TableColumn Methods

[image] [image]

Telerik Reporting Q2 2012
TableColumn Methods
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Methods

Name | Description
Dispose |
GetCell | Gets an ITableCell at the specified row index.
ToString | (Overrides Object..::.ToString()()().)

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
TableColumn..::.Dispose Method
TableColumn Class See Also Send Feedback
Releases all resources used by the TableColumn

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


GetCell Method

[image]

Telerik Reporting Q2 2012
TableColumn..::.GetCell Method
TableColumn Class Example See Also Send Feedback
Gets an ITableCell at the specified row index.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ITableCell GetCell(
    int rowIndex
)
Visual Basic (Declaration)
Public Function GetCell ( _
    rowIndex As Integer _
) As ITableCell

Parameters

rowIndex
Type: System..::.Int32

Return Value

An ITableCell instance.

Remarks

This method should be used after the Table item is data bound.

Examples

The following code snippet demonstrates a sample usage of the GetCell method:
CopyC#
var tableDef = new Telerik.Reporting.Table();

tableDef.ItemDataBound += delegate(object sender, EventArgs args)
{
    Telerik.Reporting.Processing.Table table = (Telerik.Reporting.Processing.Table)sender;

    foreach (Telerik.Reporting.Processing.TableColumn column in table.Columns)
    {
        for (int rowIndex = 0; rowIndex < table.Rows.Count; rowIndex++)
        {
            Telerik.Reporting.Processing.ITableCell cell = column.GetCell(rowIndex);

            if (cell.RowIndex == rowIndex
                && cell.ColumnIndex == column.Index)
            {
                Telerik.Reporting.Processing.ReportItem item = cell.Item;

                // Here you can do something with the report item
            }
            else
            {
                // Do nothing. This is part of a merged table cell.
            }
        }
    }
};
CopyVB.NET
Private Sub TableDef_ItemDataBound2(ByVal sender As Object, ByVal e As EventArgs) Handles tableDef.ItemDataBound
    Dim table As Telerik.Reporting.Processing.Table = DirectCast(sender, Telerik.Reporting.Processing.Table)

    For Each column As Telerik.Reporting.Processing.TableColumn In table.Columns
        For rowIndex As Integer = 0 To table.Rows.Count - 1
            Dim cell As Telerik.Reporting.Processing.ITableCell = column.GetCell(rowIndex)

            If cell.RowIndex = rowIndex AndAlso cell.ColumnIndex = column.Index Then
                Dim item As Telerik.Reporting.Processing.ReportItem = cell.Item
                ' Here you can do something with the report item
            Else
                ' Do nothing. This is part of a merged table cell
            End If
        Next
    Next
End Sub

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TableColumn..::.ToString Method
TableColumn Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


TableColumn Properties

[image] [image]

Telerik Reporting Q2 2012
TableColumn Properties
TableColumn Class See Also Send Feedback

The TableColumn type exposes the following members.

Properties

Name | Description
Index | Gets the index of the current TableColumn in the [!:Table.Columns] collection of the Table()()() item.

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


Index Property

[image]

Telerik Reporting Q2 2012
TableColumn..::.Index Property
TableColumn Class See Also Send Feedback
Gets the index of the current TableColumn in the [!:Table.Columns] collection of the Table()()() item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Index { get; internal set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

TableColumn Class
Telerik.Reporting.Processing Namespace


TableRow Class

[image]

Telerik Reporting Q2 2012
TableRow Class
Members See Also Send Feedback
Represents a row in the Table()()() item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class TableRow : IDisposable
Visual Basic (Declaration)
Public NotInheritable Class TableRow _
    Implements IDisposable

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.TableRow

See Also

TableRow Members
Telerik.Reporting.Processing Namespace


TableRow Members

[image] [image]

Telerik Reporting Q2 2012
TableRow Members
TableRow Class Methods Properties See Also Send Feedback

The TableRow type exposes the following members.

Methods

Name | Description
Dispose | Releases all resources used by the TableRow
GetCell | Gets an ITableCell at the specified column index.
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Index | Gets the index of the current TableRow in the [!:Table.Rows] collection of the Table()()() item.

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


TableRow Methods

[image] [image]

Telerik Reporting Q2 2012
TableRow Methods
TableRow Class See Also Send Feedback

The TableRow type exposes the following members.

Methods

Name | Description
Dispose |
GetCell | Gets an ITableCell at the specified column index.
ToString | (Overrides Object..::.ToString()()().)

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
TableRow..::.Dispose Method
TableRow Class See Also Send Feedback
Releases all resources used by the TableRow

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IDisposable..::.Dispose()()()

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


GetCell Method

[image]

Telerik Reporting Q2 2012
TableRow..::.GetCell Method
TableRow Class Example See Also Send Feedback
Gets an ITableCell at the specified column index.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ITableCell GetCell(
    int columnIndex
)
Visual Basic (Declaration)
Public Function GetCell ( _
    columnIndex As Integer _
) As ITableCell

Parameters

columnIndex
Type: System..::.Int32

Return Value

An ITableCell instance.

Remarks

This method should be used after the Table item is data bound.

Examples

The following code snippet demonstrates a sample usage of the GetCell method:
CopyC#
var tableDef = new Telerik.Reporting.Table();

tableDef.ItemDataBound += delegate(object sender, EventArgs args)
{
    Telerik.Reporting.Processing.Table table = (Telerik.Reporting.Processing.Table)sender;

    foreach (Telerik.Reporting.Processing.TableRow row in table.Rows)
    {
        for (int colIndex = 0; colIndex < table.Rows.Count; colIndex++)
        {
            Telerik.Reporting.Processing.ITableCell cell = row.GetCell(colIndex);

            if (cell.RowIndex == row.Index
                && cell.ColumnIndex == colIndex)
            {
                Telerik.Reporting.Processing.ReportItem item = cell.Item;

                // Here you can do something with the report item
            }
            else
            {
                // Do nothing. This is part of a merged table cell.
            }
        }
    }
};
CopyVB.NET
Private Sub TableDef_ItemDataBound3(ByVal sender As Object, ByVal e As EventArgs) Handles tableDef.ItemDataBound
    Dim table As Telerik.Reporting.Processing.Table = DirectCast(sender, Telerik.Reporting.Processing.Table)

    For Each row As Telerik.Reporting.Processing.TableRow In table.Rows
        For colIndex As Integer = 0 To table.Rows.Count - 1
            Dim cell As Telerik.Reporting.Processing.ITableCell = row.GetCell(colIndex)

            If cell.RowIndex = row.Index AndAlso cell.ColumnIndex = colIndex Then
                Dim item As Telerik.Reporting.Processing.ReportItem = cell.Item
                ' Here you can do something with the report item
            Else
                ' Do nothing. This is part of a merged table cell
            End If
        Next
    Next
End Sub

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TableRow..::.ToString Method
TableRow Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


TableRow Properties

[image] [image]

Telerik Reporting Q2 2012
TableRow Properties
TableRow Class See Also Send Feedback

The TableRow type exposes the following members.

Properties

Name | Description
Index | Gets the index of the current TableRow in the [!:Table.Rows] collection of the Table()()() item.

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


Index Property

[image]

Telerik Reporting Q2 2012
TableRow..::.Index Property
TableRow Class See Also Send Feedback
Gets the index of the current TableRow in the [!:Table.Rows] collection of the Table()()() item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public int Index { get; internal set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

TableRow Class
Telerik.Reporting.Processing Namespace


TextBox Class

[image]

Telerik Reporting Q2 2012
TextBox Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextBox : TextItemBase, ILayoutElementContainer
Visual Basic (Declaration)
Public Class TextBox _
    Inherits TextItemBase _
    Implements ILayoutElementContainer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.TextItemBase
Telerik.Reporting.Processing..::.TextBox

See Also

TextBox Members
Telerik.Reporting.Processing Namespace


TextBox Members

[image] [image]

Telerik Reporting Q2 2012
TextBox Members
TextBox Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
Dispose | Releases the unmanaged resources used by the TextBox and optionally releases the managed resources (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Text | Gets the formatted value of the current TextBox processing item.
Top | (Inherited from ReportItem.)
Value | Gets or sets the value of the TextBox item
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


TextBox Methods

[image] [image]

Telerik Reporting Q2 2012
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

Name | Description
Dispose | (Overrides ReportItemBase..::.Dispose(Boolean).)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
TextBox..::.Dispose Method
TextBox Class See Also Send Feedback
Releases the unmanaged resources used by the TextBox and optionally releases the managed resources

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
TextBox..::.ToString Method
TextBox Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Overrides ProcessingElement..::.ToString()()().)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

TextBox Class
TextBox Members
Telerik.Reporting.Processing Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TextBox..::.ToString Method
TextBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TextBox Class
ToString Overload
Telerik.Reporting.Processing Namespace


TextBox Properties

[image] [image]

Telerik Reporting Q2 2012
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Format | Gets or sets the character(s) that specify how text is formatted. (Inherited from TextItemBase.)
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
KeepTogether |
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Text | Gets the formatted value of the current TextBox processing item.
Top | (Inherited from ReportItem.)
Value | Gets or sets the value of the TextBox item
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ILayoutElementContainer..::.Children |
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


ILayoutElementContainer.Children Property

[image]

Telerik Reporting Q2 2012
TextBox..::.ILayoutElementContainer..::.Children Property
TextBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
IEnumerable<LayoutElement> ILayoutElementContainer.Children { get; }
Visual Basic (Declaration)
Private ReadOnly Property Children As IEnumerable(Of LayoutElement)
    Implements ILayoutElementContainer.Children

Implements

ILayoutElementContainer..::.Children

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


KeepTogether Property

[image]

Telerik Reporting Q2 2012
TextBox..::.KeepTogether Property
TextBox Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool KeepTogether { get; internal set; }
Visual Basic (Declaration)
Public Property KeepTogether As Boolean

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextBox..::.Text Property
TextBox Class See Also Send Feedback
Gets the formatted value of the current TextBox processing item.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


Value Property

[image]

Telerik Reporting Q2 2012
TextBox..::.Value Property
TextBox Class See Also Send Feedback
Gets or sets the value of the TextBox item

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

TextBox Class
Telerik.Reporting.Processing Namespace


TextItemBase Class

[image]

Telerik Reporting Q2 2012
TextItemBase Class
Members See Also Send Feedback
Base class for TextBox and CheckBox classes

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class TextItemBase : ReportItem
Visual Basic (Declaration)
Public MustInherit Class TextItemBase _
    Inherits ReportItem

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement
Telerik.Reporting.Processing..::.ReportItemBase
Telerik.Reporting.Processing..::.ReportItem
Telerik.Reporting.Processing..::.TextItemBase
Telerik.Reporting.Processing..::.CheckBox
Telerik.Reporting.Processing..::.TextBox

See Also

TextItemBase Members
Telerik.Reporting.Processing Namespace


TextItemBase Members

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Members
TextItemBase Class Methods Properties Explicit Interface Implementations See Also Send Feedback

The TextItemBase type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Format | Gets or sets the character(s) that specify how text is formatted.
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
IDisposable..::.Dispose | (Inherited from LayoutElement.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

TextItemBase Class
Telerik.Reporting.Processing Namespace


TextItemBase Methods

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Methods
TextItemBase Class See Also Send Feedback

The TextItemBase type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from ReportItemBase.)
OnItemProcessed | (Inherited from ReportItemBase.)
OnItemProcessing | (Inherited from ReportItemBase.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

TextItemBase Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
TextItemBase..::.ToString Method
TextItemBase Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from ProcessingElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

TextItemBase Class
TextItemBase Members
Telerik.Reporting.Processing Namespace


TextItemBase Properties

[image] [image]

Telerik Reporting Q2 2012
TextItemBase Properties
TextItemBase Class See Also Send Feedback

The TextItemBase type exposes the following members.

Properties

Name | Description
Anchor | Obsolete. (Inherited from ReportItem.)
Anchoring | (Inherited from ReportItem.)
Bounds | (Inherited from ReportItem.)
ChildElements | Obsolete. (Inherited from ProcessingElement.)
DataObject | Gets the IDataObject that is bound to this report item. (Inherited from ProcessingElement.)
Dock | Obsolete. (Inherited from ReportItem.)
Docking | (Inherited from ReportItem.)
Exception | Gets or sets the exception that has occurred during the processing. (Inherited from ProcessingElement.)
Format | Gets or sets the character(s) that specify how text is formatted.
Height | (Inherited from ReportItem.)
ItemDefinition | (Inherited from ReportItemBase.)
Left | (Inherited from ReportItem.)
Location | (Inherited from ReportItem.)
Name | (Inherited from ReportItemBase.)
Parent | Obsolete. (Inherited from ProcessingElement.)
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Report | Nested report's Report points to itself - not the master report. (Inherited from ProcessingElement.)
Size | (Inherited from ReportItem.)
Style | (Inherited from VisualElement.)
Top | (Inherited from ReportItem.)
Visible | (Inherited from VisualElement.)
Width | (Inherited from ReportItem.)

Explicit Interface Implementations

Name | Description
ITableCell..::.ColumnIndex | (Inherited from ReportItem.)
ITableCell..::.ColumnSpan | (Inherited from ReportItem.)
ITableCell..::.Item | (Inherited from ReportItem.)
ITableCell..::.RowIndex | (Inherited from ReportItem.)
ITableCell..::.RowSpan | (Inherited from ReportItem.)
ITableCell..::.Table | (Inherited from ReportItem.)

See Also

TextItemBase Class
Telerik.Reporting.Processing Namespace


Format Property

[image]

Telerik Reporting Q2 2012
TextItemBase..::.Format Property
TextItemBase Class See Also Send Feedback
Gets or sets the character(s) that specify how text is formatted.

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String

See Also

TextItemBase Class
Telerik.Reporting.Processing Namespace


TextWatermark Class

[image]

Telerik Reporting Q2 2012
TextWatermark Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class TextWatermark : Watermark
Visual Basic (Declaration)
Public Class TextWatermark _
    Inherits Watermark

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.Watermark
Telerik.Reporting.Processing..::.TextWatermark

See Also

TextWatermark Members
Telerik.Reporting.Processing Namespace


TextWatermark Members

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Members
TextWatermark Class Methods Fields Properties See Also Send Feedback

The TextWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Fields

Name | Description
owner | (Inherited from Watermark.)
watermarkDefinition | (Inherited from Watermark.)

Properties

Name | Description
Color |
Opacity | (Inherited from Watermark.)
Orientation |
Position | (Inherited from Watermark.)
PrintOnFirstPage | (Inherited from Watermark.)
PrintOnLastPage | (Inherited from Watermark.)
Text |

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


TextWatermark Fields

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Fields
TextWatermark Class See Also Send Feedback

The TextWatermark type exposes the following members.

Fields

Name | Description
owner | (Inherited from Watermark.)
watermarkDefinition | (Inherited from Watermark.)

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


TextWatermark Methods

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Methods
TextWatermark Class See Also Send Feedback

The TextWatermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


TextWatermark Properties

[image] [image]

Telerik Reporting Q2 2012
TextWatermark Properties
TextWatermark Class See Also Send Feedback

The TextWatermark type exposes the following members.

Properties

Name | Description
Color |
Opacity | (Inherited from Watermark.)
Orientation |
Position | (Inherited from Watermark.)
PrintOnFirstPage | (Inherited from Watermark.)
PrintOnLastPage | (Inherited from Watermark.)
Text |

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


Color Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Color Property
TextWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


Orientation Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Orientation Property
TextWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As WatermarkOrientation

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


Text Property

[image]

Telerik Reporting Q2 2012
TextWatermark..::.Text Property
TextWatermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

TextWatermark Class
Telerik.Reporting.Processing Namespace


VisualElement Class

[image]

Telerik Reporting Q2 2012
VisualElement Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class VisualElement : LayoutElement
Visual Basic (Declaration)
Public MustInherit Class VisualElement _
    Inherits LayoutElement

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.LayoutElement
Telerik.Reporting.Processing..::.VisualElement
Telerik.Reporting.Processing..::.ProcessingElement

See Also

VisualElement Members
Telerik.Reporting.Processing Namespace


VisualElement Members

[image] [image]

Telerik Reporting Q2 2012
VisualElement Members
VisualElement Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The VisualElement type exposes the following members.

Constructors

Name | Description
VisualElement | Initializes a new instance of the VisualElement class

Methods

Name | Description
Dispose | (Inherited from LayoutElement.)
ToString | Overloaded.

Properties

Name | Description
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Style |
Visible |

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


VisualElement Constructor

[image]

Telerik Reporting Q2 2012
VisualElement Constructor
VisualElement Class See Also Send Feedback
Initializes a new instance of the VisualElement class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected VisualElement()
Visual Basic (Declaration)
Protected Sub New

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


VisualElement Methods

[image] [image]

Telerik Reporting Q2 2012
VisualElement Methods
VisualElement Class See Also Send Feedback

The VisualElement type exposes the following members.

Methods

Name | Description
Dispose | (Inherited from LayoutElement.)
ToString | Overloaded.

Explicit Interface Implementations

Name | Description
IDisposable..::.Dispose | (Inherited from LayoutElement.)

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


ToString Method

[image] [image]

Telerik Reporting Q2 2012
VisualElement..::.ToString Method
VisualElement Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | (Inherited from LayoutElement.)
ToString(array<String>[]()[]) | (Inherited from ReportObject.)

See Also

VisualElement Class
VisualElement Members
Telerik.Reporting.Processing Namespace


VisualElement Properties

[image] [image]

Telerik Reporting Q2 2012
VisualElement Properties
VisualElement Class See Also Send Feedback

The VisualElement type exposes the following members.

Properties

Name | Description
ParentElement | Gets the parent element of the current layout element. (Inherited from LayoutElement.)
Style |
Visible |

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


Style Property

[image]

Telerik Reporting Q2 2012
VisualElement..::.Style Property
VisualElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Style Style { get; }
Visual Basic (Declaration)
Public ReadOnly Property Style As Style

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
VisualElement..::.Visible Property
VisualElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

VisualElement Class
Telerik.Reporting.Processing Namespace


Watermark Class

[image]

Telerik Reporting Q2 2012
Watermark Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public abstract class Watermark : ReportObject
Visual Basic (Declaration)
Public MustInherit Class Watermark _
    Inherits ReportObject

Inheritance Hierarchy

System..::.Object
Telerik.Reporting..::.ReportObject
Telerik.Reporting.Processing..::.Watermark
Telerik.Reporting.Processing..::.PictureWatermark
Telerik.Reporting.Processing..::.TextWatermark

See Also

Watermark Members
Telerik.Reporting.Processing Namespace


Watermark Members

[image] [image]

Telerik Reporting Q2 2012
Watermark Members
Watermark Class Constructors Methods Fields Properties See Also Send Feedback

The Watermark type exposes the following members.

Constructors

Name | Description
Watermark | Initializes a new instance of the Watermark class

Methods

Name | Description
ToString | (Inherited from ReportObject.)

Fields

Name | Description
owner |
watermarkDefinition |

Properties

Name | Description
Opacity |
Position |
PrintOnFirstPage |
PrintOnLastPage |

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Watermark Constructor

[image]

Telerik Reporting Q2 2012
Watermark Constructor
Watermark Class See Also Send Feedback
Initializes a new instance of the Watermark class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected Watermark(
    ReportItemBase owner,
    Watermark watermark
)
Visual Basic (Declaration)
Protected Sub New ( _
    owner As ReportItemBase, _
    watermark As Watermark _
)

Parameters

owner
Type: Telerik.Reporting.Processing..::.ReportItemBase
watermark
Type: Telerik.Reporting.Drawing..::.Watermark

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Watermark Fields

[image] [image]

Telerik Reporting Q2 2012
Watermark Fields
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Fields

Name | Description
owner |
watermarkDefinition |

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


owner Field

[image]

Telerik Reporting Q2 2012
Watermark..::.owner Field
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected readonly ReportItemBase owner
Visual Basic (Declaration)
Protected ReadOnly owner As ReportItemBase

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


watermarkDefinition Field

[image]

Telerik Reporting Q2 2012
Watermark..::.watermarkDefinition Field
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
protected readonly Watermark watermarkDefinition
Visual Basic (Declaration)
Protected ReadOnly watermarkDefinition As Watermark

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Watermark Methods

[image] [image]

Telerik Reporting Q2 2012
Watermark Methods
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Methods

Name | Description
ToString | (Inherited from ReportObject.)

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Watermark Properties

[image] [image]

Telerik Reporting Q2 2012
Watermark Properties
Watermark Class See Also Send Feedback

The Watermark type exposes the following members.

Properties

Name | Description
Opacity |
Position |
PrintOnFirstPage |
PrintOnLastPage |

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Opacity Property

[image]

Telerik Reporting Q2 2012
Watermark..::.Opacity Property
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public double Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Double

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


Position Property

[image]

Telerik Reporting Q2 2012
Watermark..::.Position Property
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As WatermarkPosition

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


PrintOnFirstPage Property

[image]

Telerik Reporting Q2 2012
Watermark..::.PrintOnFirstPage Property
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnFirstPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnFirstPage As Boolean

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


PrintOnLastPage Property

[image]

Telerik Reporting Q2 2012
Watermark..::.PrintOnLastPage Property
Watermark Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool PrintOnLastPage { get; set; }
Visual Basic (Declaration)
Public Property PrintOnLastPage As Boolean

See Also

Watermark Class
Telerik.Reporting.Processing Namespace


WatermarkCollection Class

[image]

Telerik Reporting Q2 2012
WatermarkCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class WatermarkCollection : Collection<Watermark>
Visual Basic (Declaration)
Public Class WatermarkCollection _
    Inherits Collection(Of Watermark)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' Watermark >)>)>
Telerik.Reporting.Processing..::.WatermarkCollection

See Also

WatermarkCollection Members
Telerik.Reporting.Processing Namespace


WatermarkCollection Members

[image] [image]

Telerik Reporting Q2 2012
WatermarkCollection Members
WatermarkCollection Class Constructors See Also Send Feedback

The WatermarkCollection type exposes the following members.

Constructors

Name | Description
WatermarkCollection | Initializes a new instance of the WatermarkCollection class

See Also

WatermarkCollection Class
Telerik.Reporting.Processing Namespace


WatermarkCollection Constructor

[image]

Telerik Reporting Q2 2012
WatermarkCollection Constructor
WatermarkCollection Class See Also Send Feedback
Initializes a new instance of the WatermarkCollection class

Namespace: Telerik.Reporting.Processing
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public WatermarkCollection()
Visual Basic (Declaration)
Public Sub New

See Also

WatermarkCollection Class
Telerik.Reporting.Processing Namespace


Telerik.Reporting.Processing.Config Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Processing.Config Namespace
Send Feedback

Classes

Class | Description
ExtensionCollection |
ExtensionElement |
ExtensionsSection |
ParameterCollection |
ParameterElement |
ProviderCollection |
ProviderElement |
ReportingConfigurationSection |
SessionSection |


ExtensionCollection Class

[image]

Telerik Reporting Q2 2012
ExtensionCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ExtensionCollection : ConfigurationElementCollection
Visual Basic (Declaration)
Public NotInheritable Class ExtensionCollection _
    Inherits ConfigurationElementCollection

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
System.Configuration..::.ConfigurationElementCollection
Telerik.Reporting.Processing.Config..::.ExtensionCollection

See Also

ExtensionCollection Members
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionCollection Members
ExtensionCollection Class Constructors Methods Properties See Also Send Feedback

The ExtensionCollection type exposes the following members.

Constructors

Name | Description
ExtensionCollection | Initializes a new instance of the ExtensionCollection class

Methods

Name | Description
AddExtensions |
ContainsKey |

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)
Item | Overloaded.

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Constructor

[image]

Telerik Reporting Q2 2012
ExtensionCollection Constructor
ExtensionCollection Class See Also Send Feedback
Initializes a new instance of the ExtensionCollection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ExtensionCollection Methods
ExtensionCollection Class See Also Send Feedback

The ExtensionCollection type exposes the following members.

Methods

Name | Description
AddExtensions |
ContainsKey |

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


AddExtensions Method

[image]

Telerik Reporting Q2 2012
ExtensionCollection..::.AddExtensions Method
ExtensionCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void AddExtensions(
    ExtensionCollection extensions
)
Visual Basic (Declaration)
Public Sub AddExtensions ( _
    extensions As ExtensionCollection _
)

Parameters

extensions
Type: Telerik.Reporting.Processing.Config..::.ExtensionCollection

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


ContainsKey Method

[image]

Telerik Reporting Q2 2012
ExtensionCollection..::.ContainsKey Method
ExtensionCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionCollection Properties
ExtensionCollection Class See Also Send Feedback

The ExtensionCollection type exposes the following members.

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)
Item | Overloaded.

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


CollectionType Property

[image]

Telerik Reporting Q2 2012
ExtensionCollection..::.CollectionType Property
ExtensionCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ConfigurationElementCollectionType CollectionType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType

See Also

ExtensionCollection Class
Telerik.Reporting.Processing.Config Namespace


Item Property

[image] [image]

Telerik Reporting Q2 2012
ExtensionCollection..::.Item Property
ExtensionCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) |

See Also

ExtensionCollection Class
ExtensionCollection Members
Telerik.Reporting.Processing.Config Namespace


Item Property (Int32)

[image]

Telerik Reporting Q2 2012
ExtensionCollection..::.Item Property (Int32)
ExtensionCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionElement this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ExtensionElement

Parameters

index
Type: System..::.Int32

See Also

ExtensionCollection Class
Item Overload
Telerik.Reporting.Processing.Config Namespace


Item Property (String)

[image]

Telerik Reporting Q2 2012
ExtensionCollection..::.Item Property (String)
ExtensionCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionElement this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ExtensionElement

Parameters

name
Type: System..::.String

See Also

ExtensionCollection Class
Item Overload
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Class

[image]

Telerik Reporting Q2 2012
ExtensionElement Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ExtensionElement : ConfigurationElement
Visual Basic (Declaration)
Public NotInheritable Class ExtensionElement _
    Inherits ConfigurationElement

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
Telerik.Reporting.Processing.Config..::.ExtensionElement

See Also

ExtensionElement Members
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionElement Members
ExtensionElement Class Constructors Properties See Also Send Feedback

The ExtensionElement type exposes the following members.

Constructors

Name | Description
ExtensionElement | Initializes a new instance of the ExtensionElement class

Properties

Name | Description
Description |
Name |
Parameters |
Type |
Visible |

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Constructor

[image]

Telerik Reporting Q2 2012
ExtensionElement Constructor
ExtensionElement Class See Also Send Feedback
Initializes a new instance of the ExtensionElement class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionElement()
Visual Basic (Declaration)
Public Sub New

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


ExtensionElement Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionElement Properties
ExtensionElement Class See Also Send Feedback

The ExtensionElement type exposes the following members.

Properties

Name | Description
Description |
Name |
Parameters |
Type |
Visible |

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Description Property

[image]

Telerik Reporting Q2 2012
ExtensionElement..::.Description Property
ExtensionElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ExtensionElement..::.Name Property
ExtensionElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
ExtensionElement..::.Parameters Property
ExtensionElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ExtensionElement..::.Type Property
ExtensionElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


Visible Property

[image]

Telerik Reporting Q2 2012
ExtensionElement..::.Visible Property
ExtensionElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

ExtensionElement Class
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Class

[image]

Telerik Reporting Q2 2012
ExtensionsSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ExtensionsSection : ConfigurationElement
Visual Basic (Declaration)
Public NotInheritable Class ExtensionsSection _
    Inherits ConfigurationElement

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
Telerik.Reporting.Processing.Config..::.ExtensionsSection

See Also

ExtensionsSection Members
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionsSection Members
ExtensionsSection Class Constructors Properties See Also Send Feedback

The ExtensionsSection type exposes the following members.

Constructors

Name | Description
ExtensionsSection | Initializes a new instance of the ExtensionsSection class

Properties

Name | Description
All | Returns all the extensions in the config file(Render, Delivery, ...)
Render |

See Also

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Constructor

[image]

Telerik Reporting Q2 2012
ExtensionsSection Constructor
ExtensionsSection Class See Also Send Feedback
Initializes a new instance of the ExtensionsSection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionsSection()
Visual Basic (Declaration)
Public Sub New

See Also

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


ExtensionsSection Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionsSection Properties
ExtensionsSection Class See Also Send Feedback

The ExtensionsSection type exposes the following members.

Properties

Name | Description
All | Returns all the extensions in the config file(Render, Delivery, ...)
Render |

See Also

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


All Property

[image]

Telerik Reporting Q2 2012
ExtensionsSection..::.All Property
ExtensionsSection Class See Also Send Feedback
Returns all the extensions in the config file(Render, Delivery, ...)

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionCollection All { get; }
Visual Basic (Declaration)
Public ReadOnly Property All As ExtensionCollection

See Also

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


Render Property

[image]

Telerik Reporting Q2 2012
ExtensionsSection..::.Render Property
ExtensionsSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionCollection Render { get; }
Visual Basic (Declaration)
Public ReadOnly Property Render As ExtensionCollection

See Also

ExtensionsSection Class
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Class

[image]

Telerik Reporting Q2 2012
ParameterCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ParameterCollection : ConfigurationElementCollection
Visual Basic (Declaration)
Public NotInheritable Class ParameterCollection _
    Inherits ConfigurationElementCollection

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
System.Configuration..::.ConfigurationElementCollection
Telerik.Reporting.Processing.Config..::.ParameterCollection

See Also

ParameterCollection Members
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Members

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Members
ParameterCollection Class Constructors Methods Properties See Also Send Feedback

The ParameterCollection type exposes the following members.

Constructors

Name | Description
ParameterCollection | Initializes a new instance of the ParameterCollection class

Methods

Name | Description
ContainsKey |

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)
Item | Overloaded.

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Constructor

[image]

Telerik Reporting Q2 2012
ParameterCollection Constructor
ParameterCollection Class See Also Send Feedback
Initializes a new instance of the ParameterCollection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Methods
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Methods

Name | Description
ContainsKey |

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ContainsKey Method

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.ContainsKey Method
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Public Function ContainsKey ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


ParameterCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection Properties
ParameterCollection Class See Also Send Feedback

The ParameterCollection type exposes the following members.

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)
Item | Overloaded.

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


CollectionType Property

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.CollectionType Property
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ConfigurationElementCollectionType CollectionType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType

See Also

ParameterCollection Class
Telerik.Reporting.Processing.Config Namespace


Item Property

[image] [image]

Telerik Reporting Q2 2012
ParameterCollection..::.Item Property
ParameterCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) |

See Also

ParameterCollection Class
ParameterCollection Members
Telerik.Reporting.Processing.Config Namespace


Item Property (Int32)

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Item Property (Int32)
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterElement this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As ParameterElement

Parameters

index
Type: System..::.Int32

See Also

ParameterCollection Class
Item Overload
Telerik.Reporting.Processing.Config Namespace


Item Property (String)

[image]

Telerik Reporting Q2 2012
ParameterCollection..::.Item Property (String)
ParameterCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterElement this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ParameterElement

Parameters

name
Type: System..::.String

See Also

ParameterCollection Class
Item Overload
Telerik.Reporting.Processing.Config Namespace


ParameterElement Class

[image]

Telerik Reporting Q2 2012
ParameterElement Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ParameterElement : ConfigurationElement
Visual Basic (Declaration)
Public NotInheritable Class ParameterElement _
    Inherits ConfigurationElement

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
Telerik.Reporting.Processing.Config..::.ParameterElement

See Also

ParameterElement Members
Telerik.Reporting.Processing.Config Namespace


ParameterElement Members

[image] [image]

Telerik Reporting Q2 2012
ParameterElement Members
ParameterElement Class Constructors Properties See Also Send Feedback

The ParameterElement type exposes the following members.

Constructors

Name | Description
ParameterElement | Initializes a new instance of the ParameterElement class

Properties

Name | Description
Name |
Value |

See Also

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


ParameterElement Constructor

[image]

Telerik Reporting Q2 2012
ParameterElement Constructor
ParameterElement Class See Also Send Feedback
Initializes a new instance of the ParameterElement class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterElement()
Visual Basic (Declaration)
Public Sub New

See Also

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


ParameterElement Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterElement Properties
ParameterElement Class See Also Send Feedback

The ParameterElement type exposes the following members.

Properties

Name | Description
Name |
Value |

See Also

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ParameterElement..::.Name Property
ParameterElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ParameterElement..::.Value Property
ParameterElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Value { get; set; }
Visual Basic (Declaration)
Public Property Value As String

See Also

ParameterElement Class
Telerik.Reporting.Processing.Config Namespace


ProviderCollection Class

[image]

Telerik Reporting Q2 2012
ProviderCollection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ProviderCollection : ConfigurationElementCollection
Visual Basic (Declaration)
Public NotInheritable Class ProviderCollection _
    Inherits ConfigurationElementCollection

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
System.Configuration..::.ConfigurationElementCollection
Telerik.Reporting.Processing.Config..::.ProviderCollection

See Also

ProviderCollection Members
Telerik.Reporting.Processing.Config Namespace


ProviderCollection Members

[image] [image]

Telerik Reporting Q2 2012
ProviderCollection Members
ProviderCollection Class Constructors Properties See Also Send Feedback

The ProviderCollection type exposes the following members.

Constructors

Name | Description
ProviderCollection | Initializes a new instance of the ProviderCollection class

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)

See Also

ProviderCollection Class
Telerik.Reporting.Processing.Config Namespace


ProviderCollection Constructor

[image]

Telerik Reporting Q2 2012
ProviderCollection Constructor
ProviderCollection Class See Also Send Feedback
Initializes a new instance of the ProviderCollection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProviderCollection()
Visual Basic (Declaration)
Public Sub New

See Also

ProviderCollection Class
Telerik.Reporting.Processing.Config Namespace


ProviderCollection Properties

[image] [image]

Telerik Reporting Q2 2012
ProviderCollection Properties
ProviderCollection Class See Also Send Feedback

The ProviderCollection type exposes the following members.

Properties

Name | Description
CollectionType | (Overrides ConfigurationElementCollection..::.CollectionType.)

See Also

ProviderCollection Class
Telerik.Reporting.Processing.Config Namespace


CollectionType Property

[image]

Telerik Reporting Q2 2012
ProviderCollection..::.CollectionType Property
ProviderCollection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public override ConfigurationElementCollectionType CollectionType { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CollectionType As ConfigurationElementCollectionType

See Also

ProviderCollection Class
Telerik.Reporting.Processing.Config Namespace


ProviderElement Class

[image]

Telerik Reporting Q2 2012
ProviderElement Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ProviderElement : ConfigurationElement
Visual Basic (Declaration)
Public NotInheritable Class ProviderElement _
    Inherits ConfigurationElement

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
Telerik.Reporting.Processing.Config..::.ProviderElement

See Also

ProviderElement Members
Telerik.Reporting.Processing.Config Namespace


ProviderElement Members

[image] [image]

Telerik Reporting Q2 2012
ProviderElement Members
ProviderElement Class Constructors Properties See Also Send Feedback

The ProviderElement type exposes the following members.

Constructors

Name | Description
ProviderElement | Initializes a new instance of the ProviderElement class

Properties

Name | Description
Name |
Parameters |
Type |

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


ProviderElement Constructor

[image]

Telerik Reporting Q2 2012
ProviderElement Constructor
ProviderElement Class See Also Send Feedback
Initializes a new instance of the ProviderElement class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProviderElement()
Visual Basic (Declaration)
Public Sub New

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


ProviderElement Properties

[image] [image]

Telerik Reporting Q2 2012
ProviderElement Properties
ProviderElement Class See Also Send Feedback

The ProviderElement type exposes the following members.

Properties

Name | Description
Name |
Parameters |
Type |

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ProviderElement..::.Name Property
ProviderElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
ProviderElement..::.Parameters Property
ProviderElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ParameterCollection Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterCollection

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ProviderElement..::.Type Property
ProviderElement Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String

See Also

ProviderElement Class
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Class

[image]

Telerik Reporting Q2 2012
ReportingConfigurationSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class ReportingConfigurationSection : ConfigurationSection
Visual Basic (Declaration)
Public NotInheritable Class ReportingConfigurationSection _
    Inherits ConfigurationSection

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
System.Configuration..::.ConfigurationSection
Telerik.Reporting.Processing.Config..::.ReportingConfigurationSection

See Also

ReportingConfigurationSection Members
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Members

[image] [image]

Telerik Reporting Q2 2012
ReportingConfigurationSection Members
ReportingConfigurationSection Class Constructors Properties See Also Send Feedback

The ReportingConfigurationSection type exposes the following members.

Constructors

Name | Description
ReportingConfigurationSection | Initializes a new instance of the ReportingConfigurationSection class

Properties

Name | Description
Extensions |
SessionState |

See Also

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Constructor

[image]

Telerik Reporting Q2 2012
ReportingConfigurationSection Constructor
ReportingConfigurationSection Class See Also Send Feedback
Initializes a new instance of the ReportingConfigurationSection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportingConfigurationSection()
Visual Basic (Declaration)
Public Sub New

See Also

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


ReportingConfigurationSection Properties

[image] [image]

Telerik Reporting Q2 2012
ReportingConfigurationSection Properties
ReportingConfigurationSection Class See Also Send Feedback

The ReportingConfigurationSection type exposes the following members.

Properties

Name | Description
Extensions |
SessionState |

See Also

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


Extensions Property

[image]

Telerik Reporting Q2 2012
ReportingConfigurationSection..::.Extensions Property
ReportingConfigurationSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ExtensionsSection Extensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Extensions As ExtensionsSection

See Also

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


SessionState Property

[image]

Telerik Reporting Q2 2012
ReportingConfigurationSection..::.SessionState Property
ReportingConfigurationSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SessionSection SessionState { get; }
Visual Basic (Declaration)
Public ReadOnly Property SessionState As SessionSection

See Also

ReportingConfigurationSection Class
Telerik.Reporting.Processing.Config Namespace


SessionSection Class

[image]

Telerik Reporting Q2 2012
SessionSection Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public sealed class SessionSection : ConfigurationElement
Visual Basic (Declaration)
Public NotInheritable Class SessionSection _
    Inherits ConfigurationElement

Inheritance Hierarchy

System..::.Object
System.Configuration..::.ConfigurationElement
Telerik.Reporting.Processing.Config..::.SessionSection

See Also

SessionSection Members
Telerik.Reporting.Processing.Config Namespace


SessionSection Members

[image] [image]

Telerik Reporting Q2 2012
SessionSection Members
SessionSection Class Constructors Properties See Also Send Feedback

The SessionSection type exposes the following members.

Constructors

Name | Description
SessionSection | Initializes a new instance of the SessionSection class

Properties

Name | Description
Provider |
Providers |

See Also

SessionSection Class
Telerik.Reporting.Processing.Config Namespace


SessionSection Constructor

[image]

Telerik Reporting Q2 2012
SessionSection Constructor
SessionSection Class See Also Send Feedback
Initializes a new instance of the SessionSection class

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public SessionSection()
Visual Basic (Declaration)
Public Sub New

See Also

SessionSection Class
Telerik.Reporting.Processing.Config Namespace


SessionSection Properties

[image] [image]

Telerik Reporting Q2 2012
SessionSection Properties
SessionSection Class See Also Send Feedback

The SessionSection type exposes the following members.

Properties

Name | Description
Provider |
Providers |

See Also

SessionSection Class
Telerik.Reporting.Processing.Config Namespace


Provider Property

[image]

Telerik Reporting Q2 2012
SessionSection..::.Provider Property
SessionSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public string Provider { get; set; }
Visual Basic (Declaration)
Public Property Provider As String

See Also

SessionSection Class
Telerik.Reporting.Processing.Config Namespace


Providers Property

[image]

Telerik Reporting Q2 2012
SessionSection..::.Providers Property
SessionSection Class See Also Send Feedback

Namespace: Telerik.Reporting.Processing.Config
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ProviderCollection Providers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Providers As ProviderCollection

See Also

SessionSection Class
Telerik.Reporting.Processing.Config Namespace


Telerik.Reporting.Processing.Session Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Processing.Session Namespace
Send Feedback

Interfaces

Interface | Description
ISessionProvider | Provides a mechanism for creating a specific instance of a session state.
ISessionState | Provides a mechanism for managing the internal session state of the report.


ISessionProvider Interface

[image]

Telerik Reporting Q2 2012
ISessionProvider Interface
Members See Also Send Feedback
Provides a mechanism for creating a specific instance of a session state.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface ISessionProvider
Visual Basic (Declaration)
Public Interface ISessionProvider

See Also

ISessionProvider Members
Telerik.Reporting.Processing.Session Namespace


ISessionProvider Members

[image] [image]

Telerik Reporting Q2 2012
ISessionProvider Members
ISessionProvider Interface Methods See Also Send Feedback

The ISessionProvider type exposes the following members.

Methods

Name | Description
CreateSessionState | Creates a new session state using the specified session information.

See Also

ISessionProvider Interface
Telerik.Reporting.Processing.Session Namespace


ISessionProvider Methods

[image] [image]

Telerik Reporting Q2 2012
ISessionProvider Methods
ISessionProvider Interface See Also Send Feedback

The ISessionProvider type exposes the following members.

Methods

Name | Description
CreateSessionState | Creates a new session state using the specified session information.

See Also

ISessionProvider Interface
Telerik.Reporting.Processing.Session Namespace


CreateSessionState Method

[image]

Telerik Reporting Q2 2012
ISessionProvider..::.CreateSessionState Method
ISessionProvider Interface See Also Send Feedback
Creates a new session state using the specified session information.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
ISessionState CreateSessionState(
    IDictionary sessionInfo
)
Visual Basic (Declaration)
Function CreateSessionState ( _
    sessionInfo As IDictionary _
) As ISessionState

Parameters

sessionInfo
Type: System.Collections..::.IDictionary
Specifies an information and parameters used to create the session state.

Return Value

The newly created instance of the session state.

See Also

ISessionProvider Interface
Telerik.Reporting.Processing.Session Namespace


ISessionState Interface

[image]

Telerik Reporting Q2 2012
ISessionState Interface
Members See Also Send Feedback
Provides a mechanism for managing the internal session state of the report.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public interface ISessionState : IDisposable
Visual Basic (Declaration)
Public Interface ISessionState _
    Implements IDisposable

See Also

ISessionState Members
Telerik.Reporting.Processing.Session Namespace


ISessionState Members

[image] [image]

Telerik Reporting Q2 2012
ISessionState Members
ISessionState Interface Methods See Also Send Feedback

The ISessionState type exposes the following members.

Methods

Name | Description
Clear | Clears all values and their corresponding keys from the session state.
GetValue | Retrieves the value with the specified key from the session state.
HasValue | Determines if a value with the specified key exists in the session state.
SetValue | Stores the specified value with the given key in the session state.

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


ISessionState Methods

[image] [image]

Telerik Reporting Q2 2012
ISessionState Methods
ISessionState Interface See Also Send Feedback

The ISessionState type exposes the following members.

Methods

Name | Description
Clear | Clears all values and their corresponding keys from the session state.
GetValue | Retrieves the value with the specified key from the session state.
HasValue | Determines if a value with the specified key exists in the session state.
SetValue | Stores the specified value with the given key in the session state.

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


Clear Method

[image]

Telerik Reporting Q2 2012
ISessionState..::.Clear Method
ISessionState Interface See Also Send Feedback
Clears all values and their corresponding keys from the session state.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


GetValue Method

[image]

Telerik Reporting Q2 2012
ISessionState..::.GetValue Method
ISessionState Interface See Also Send Feedback
Retrieves the value with the specified key from the session state.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
byte[] GetValue(
    string key
)
Visual Basic (Declaration)
Function GetValue ( _
    key As String _
) As Byte()

Parameters

key
Type: System..::.String
Specifies the key used to identify the value in the session state.

Return Value

The value with the specified key, or null if no such value exists.

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


HasValue Method

[image]

Telerik Reporting Q2 2012
ISessionState..::.HasValue Method
ISessionState Interface See Also Send Feedback
Determines if a value with the specified key exists in the session state.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
bool HasValue(
    string key
)
Visual Basic (Declaration)
Function HasValue ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String
Specifies the key used to identify the value in the session state.

Return Value

True - if a value with the specified key exists, False - otherwise.

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


SetValue Method

[image]

Telerik Reporting Q2 2012
ISessionState..::.SetValue Method
ISessionState Interface See Also Send Feedback
Stores the specified value with the given key in the session state.

Namespace: Telerik.Reporting.Processing.Session
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
void SetValue(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Sub SetValue ( _
    key As String, _
    value As Byte() _
)

Parameters

key
Type: System..::.String
Specifies the key used to identify the value in the session state.
value
Type: array< System..::.Byte >[]()[][]
Specifies the value to store in the session state with the given key.

See Also

ISessionState Interface
Telerik.Reporting.Processing.Session Namespace


Telerik.Reporting.Service Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Service Namespace
Send Feedback

Classes

Class | Description
Action | Represents an interactive action.
ActionInfo | Represents an interactive action and its coordinates defined in the document hierarchy.
BookmarkNode | Represents a bookmark in the document hierarchy.
ExtensionInfo | Represents a IExtension on the server
NameValueDictionary | Represents a Dictionary<(Of <(TKey, TValue>)>) with String key and Object value.
PageInfo | Represents the result of the GetPage service operation.
Parameter | Represents a ReportParameter ready to be displayed by a report viewer. Parameter is intended for internal use only.
RenderingResult | Represents the result of the Render service operation.
RenderingSessionInfo | Represents the result of a RenderAndCache service operation. This class is intended for internal use only.
ReportFileResolver | Resolves IReportDocument from physical path to trdx file
ReportFileResolverWeb | Resolves IReportDocument from a relative path to trdx file.
ReportInfo | Represents a Report on the server
ReportResolverBase | Base report resolver with fallback mechanism.
ReportService | The top-level class of the Telerik Reporting Web service.
ReportServiceBase | The base class of the Telerik Reporting WCF Service.
ReportServiceOperationException | Represents an error occurred during a Report Service operation.
ReportTypeResolver | Resolves IReportDocument from assembly qualified name
ServiceOperationResultBase | Represents the result of a service operation

Interfaces

Interface | Description
IClientAccessPolicy | Enables the access to the security policy required by Silverlight
IReportResolver | Resolves IReportDocument
IReportService | Represents the Telerik Reporting service.
IResourceService | Represents the Telerik Reporting resource service.

Enumerations

Enumeration | Description
ActionType | Specifies the type of an interactive action.


Action Class

[image]

Telerik Reporting Q2 2012
Action Class
Members See Also Send Feedback
Represents an interactive action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class Action
Visual Basic (Declaration)
Public Class Action

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.Action

See Also

Action Members
Telerik.Reporting.Service Namespace


Action Members

[image] [image]

Telerik Reporting Q2 2012
Action Members
Action Class Constructors Properties See Also Send Feedback

The Action type exposes the following members.

Constructors

Name | Description
Action | Initializes a new instance of the Action class

Properties

Name | Description
Parameters | The report parameters values that are passed to the target report when the action is triggered.
ReportDocumentType | The assembly qualified name of the target report type.
ServerActionIdentifier | The unique identifier of the action
Target | The Target of the action.
TargetBookmarkId | The target bookmark of the action.
Type | The type of the action
Url | The URL of the action.

See Also

Action Class
Telerik.Reporting.Service Namespace


Action Constructor

[image]

Telerik Reporting Q2 2012
Action Constructor
Action Class See Also Send Feedback
Initializes a new instance of the Action class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Action()
Visual Basic (Declaration)
Public Sub New

See Also

Action Class
Telerik.Reporting.Service Namespace


Action Properties

[image] [image]

Telerik Reporting Q2 2012
Action Properties
Action Class See Also Send Feedback

The Action type exposes the following members.

Properties

Name | Description
Parameters | The report parameters values that are passed to the target report when the action is triggered.
ReportDocumentType | The assembly qualified name of the target report type.
ServerActionIdentifier | The unique identifier of the action
Target | The Target of the action.
TargetBookmarkId | The target bookmark of the action.
Type | The type of the action
Url | The URL of the action.

See Also

Action Class
Telerik.Reporting.Service Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
Action..::.Parameters Property
Action Class See Also Send Feedback
The report parameters values that are passed to the target report when the action is triggered.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public NameValueDictionary Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As NameValueDictionary

See Also

Action Class
Telerik.Reporting.Service Namespace


ReportDocumentType Property

[image]

Telerik Reporting Q2 2012
Action..::.ReportDocumentType Property
Action Class See Also Send Feedback
The assembly qualified name of the target report type.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ReportDocumentType { get; set; }
Visual Basic (Declaration)
Public Property ReportDocumentType As String

See Also

Action Class
Telerik.Reporting.Service Namespace


ServerActionIdentifier Property

[image]

Telerik Reporting Q2 2012
Action..::.ServerActionIdentifier Property
Action Class See Also Send Feedback
The unique identifier of the action

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ServerActionIdentifier { get; set; }
Visual Basic (Declaration)
Public Property ServerActionIdentifier As String

See Also

Action Class
Telerik.Reporting.Service Namespace


Target Property

[image]

Telerik Reporting Q2 2012
Action..::.Target Property
Action Class See Also Send Feedback
The Target of the action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Target { get; set; }
Visual Basic (Declaration)
Public Property Target As String

See Also

Action Class
Telerik.Reporting.Service Namespace


TargetBookmarkId Property

[image]

Telerik Reporting Q2 2012
Action..::.TargetBookmarkId Property
Action Class See Also Send Feedback
The target bookmark of the action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string TargetBookmarkId { get; set; }
Visual Basic (Declaration)
Public Property TargetBookmarkId As String

See Also

Action Class
Telerik.Reporting.Service Namespace


Type Property

[image]

Telerik Reporting Q2 2012
Action..::.Type Property
Action Class See Also Send Feedback
The type of the action

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ActionType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As ActionType

See Also

Action Class
Telerik.Reporting.Service Namespace


Url Property

[image]

Telerik Reporting Q2 2012
Action..::.Url Property
Action Class See Also Send Feedback
The URL of the action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String

See Also

Action Class
Telerik.Reporting.Service Namespace


ActionInfo Class

[image]

Telerik Reporting Q2 2012
ActionInfo Class
Members See Also Send Feedback
Represents an interactive action and its coordinates defined in the document hierarchy.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ActionInfo
Visual Basic (Declaration)
Public Class ActionInfo

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ActionInfo

See Also

ActionInfo Members
Telerik.Reporting.Service Namespace


ActionInfo Members

[image] [image]

Telerik Reporting Q2 2012
ActionInfo Members
ActionInfo Class Constructors Properties See Also Send Feedback

The ActionInfo type exposes the following members.

Constructors

Name | Description
ActionInfo | Initializes a new instance of the ActionInfo class

Properties

Name | Description
Action | The action that will be executed.
Height | The Height of the action area on the page (in pixels).
Page | The number of the page where the action is defined.
Width | The Width of the action area on the page (in pixels).
X | The X coordinate from the position on the page of the action area (in pixels).
Y | The Y coordinate from the position on the page of the action area (in pixels).
ZOrder | The z-order of the action.

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


ActionInfo Constructor

[image]

Telerik Reporting Q2 2012
ActionInfo Constructor
ActionInfo Class See Also Send Feedback
Initializes a new instance of the ActionInfo class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ActionInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


ActionInfo Properties

[image] [image]

Telerik Reporting Q2 2012
ActionInfo Properties
ActionInfo Class See Also Send Feedback

The ActionInfo type exposes the following members.

Properties

Name | Description
Action | The action that will be executed.
Height | The Height of the action area on the page (in pixels).
Page | The number of the page where the action is defined.
Width | The Width of the action area on the page (in pixels).
X | The X coordinate from the position on the page of the action area (in pixels).
Y | The Y coordinate from the position on the page of the action area (in pixels).
ZOrder | The z-order of the action.

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


Action Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.Action Property
ActionInfo Class See Also Send Feedback
The action that will be executed.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Action Action { get; set; }
Visual Basic (Declaration)
Public Property Action As Action

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.Height Property
ActionInfo Class See Also Send Feedback
The Height of the action area on the page (in pixels).

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public float Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Single

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


Page Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.Page Property
ActionInfo Class See Also Send Feedback
The number of the page where the action is defined.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int Page { get; set; }
Visual Basic (Declaration)
Public Property Page As Integer

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.Width Property
ActionInfo Class See Also Send Feedback
The Width of the action area on the page (in pixels).

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public float Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Single

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


X Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.X Property
ActionInfo Class See Also Send Feedback
The X coordinate from the position on the page of the action area (in pixels).

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public float X { get; set; }
Visual Basic (Declaration)
Public Property X As Single

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


Y Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.Y Property
ActionInfo Class See Also Send Feedback
The Y coordinate from the position on the page of the action area (in pixels).

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public float Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Single

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


ZOrder Property

[image]

Telerik Reporting Q2 2012
ActionInfo..::.ZOrder Property
ActionInfo Class See Also Send Feedback
The z-order of the action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int ZOrder { get; set; }
Visual Basic (Declaration)
Public Property ZOrder As Integer

See Also

ActionInfo Class
Telerik.Reporting.Service Namespace


ActionType Enumeration

[image]

Telerik Reporting Q2 2012
ActionType Enumeration
See Also Send Feedback
Specifies the type of an interactive action.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public enum ActionType
Visual Basic (Declaration)
Public Enumeration ActionType

Members

Member name | Description
ReportNavigation | The action navigates to an report.
BookmarkNavigation | The action navigates to a bookmark.
UrlNavigation | The action navigates to an URL.
ServerAction | The action that is handled on the server.

See Also

Telerik.Reporting.Service Namespace


BookmarkNode Class

[image]

Telerik Reporting Q2 2012
BookmarkNode Class
Members See Also Send Feedback
Represents a bookmark in the document hierarchy.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class BookmarkNode
Visual Basic (Declaration)
Public Class BookmarkNode

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.BookmarkNode

See Also

BookmarkNode Members
Telerik.Reporting.Service Namespace


BookmarkNode Members

[image] [image]

Telerik Reporting Q2 2012
BookmarkNode Members
BookmarkNode Class Constructors Properties See Also Send Feedback

The BookmarkNode type exposes the following members.

Constructors

Name | Description
BookmarkNode | Initializes a new instance of the BookmarkNode class

Properties

Name | Description
Children | The list of all child BookmarkNodes.
Id | The identifier of the [!:BookmarkInfo] this BookmarkNode points to.
Page | The number of the page where the current bookmark appears.
Text | The label of the current BookmarkNode when displayed in the report viewer's Document Map.
X | The X-coordinate of the location in the page of the current bookmark.
Y | The Y-coordinate of the location in the page of the current bookmark.

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


BookmarkNode Constructor

[image]

Telerik Reporting Q2 2012
BookmarkNode Constructor
BookmarkNode Class See Also Send Feedback
Initializes a new instance of the BookmarkNode class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public BookmarkNode()
Visual Basic (Declaration)
Public Sub New

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


BookmarkNode Properties

[image] [image]

Telerik Reporting Q2 2012
BookmarkNode Properties
BookmarkNode Class See Also Send Feedback

The BookmarkNode type exposes the following members.

Properties

Name | Description
Children | The list of all child BookmarkNodes.
Id | The identifier of the [!:BookmarkInfo] this BookmarkNode points to.
Page | The number of the page where the current bookmark appears.
Text | The label of the current BookmarkNode when displayed in the report viewer's Document Map.
X | The X-coordinate of the location in the page of the current bookmark.
Y | The Y-coordinate of the location in the page of the current bookmark.

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


Children Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Children Property
BookmarkNode Class See Also Send Feedback
The list of all child BookmarkNodes.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<BookmarkNode> Children { get; set; }
Visual Basic (Declaration)
Public Property Children As List(Of BookmarkNode)

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


Id Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Id Property
BookmarkNode Class See Also Send Feedback
The identifier of the [!:BookmarkInfo] this BookmarkNode points to.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


Page Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Page Property
BookmarkNode Class See Also Send Feedback
The number of the page where the current bookmark appears.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int Page { get; set; }
Visual Basic (Declaration)
Public Property Page As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


Text Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Text Property
BookmarkNode Class See Also Send Feedback
The label of the current BookmarkNode when displayed in the report viewer's Document Map.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


X Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.X Property
BookmarkNode Class See Also Send Feedback
The X-coordinate of the location in the page of the current bookmark.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


Y Property

[image]

Telerik Reporting Q2 2012
BookmarkNode..::.Y Property
BookmarkNode Class See Also Send Feedback
The Y-coordinate of the location in the page of the current bookmark.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer

See Also

BookmarkNode Class
Telerik.Reporting.Service Namespace


ExtensionInfo Class

[image]

Telerik Reporting Q2 2012
ExtensionInfo Class
Members See Also Send Feedback
Represents a IExtension on the server

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ExtensionInfo
Visual Basic (Declaration)
Public Class ExtensionInfo

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ExtensionInfo

See Also

ExtensionInfo Members
Telerik.Reporting.Service Namespace


ExtensionInfo Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionInfo Members
ExtensionInfo Class Constructors Properties See Also Send Feedback

The ExtensionInfo type exposes the following members.

Constructors

Name | Description
ExtensionInfo | Initializes a new instance of the ExtensionInfo class

Properties

Name | Description
LocalizedName | The localized name of the extension.
Name | The name of the extension.

See Also

ExtensionInfo Class
Telerik.Reporting.Service Namespace


ExtensionInfo Constructor

[image]

Telerik Reporting Q2 2012
ExtensionInfo Constructor
ExtensionInfo Class See Also Send Feedback
Initializes a new instance of the ExtensionInfo class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ExtensionInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ExtensionInfo Class
Telerik.Reporting.Service Namespace


ExtensionInfo Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionInfo Properties
ExtensionInfo Class See Also Send Feedback

The ExtensionInfo type exposes the following members.

Properties

Name | Description
LocalizedName | The localized name of the extension.
Name | The name of the extension.

See Also

ExtensionInfo Class
Telerik.Reporting.Service Namespace


LocalizedName Property

[image]

Telerik Reporting Q2 2012
ExtensionInfo..::.LocalizedName Property
ExtensionInfo Class See Also Send Feedback
The localized name of the extension.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string LocalizedName { get; set; }
Visual Basic (Declaration)
Public Property LocalizedName As String

See Also

ExtensionInfo Class
Telerik.Reporting.Service Namespace
Telerik.Reporting.Interfaces.Attributes..::.ExtensionLocalizedDescriptionAttribute


Name Property

[image]

Telerik Reporting Q2 2012
ExtensionInfo..::.Name Property
ExtensionInfo Class See Also Send Feedback
The name of the extension.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ExtensionInfo Class
Telerik.Reporting.Service Namespace
Telerik.Reporting.Interfaces.Attributes..::.ExtensionNameAttribute


IClientAccessPolicy Interface

[image]

Telerik Reporting Q2 2012
IClientAccessPolicy Interface
Members See Also Send Feedback
Enables the access to the security policy required by Silverlight

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public interface IClientAccessPolicy
Visual Basic (Declaration)
Public Interface IClientAccessPolicy

Remarks

If the connection request was from a WebClient or an HTTP class to a cross-domain site, the Silverlight runtime tries to download the security policy file using the HTTP protocol. The Silverlight runtime first tries to download a Silverlight policy file with a name of "clientaccesspolicy.xml" at the root of the requested target domain using the HTTP protocol.

The default implementation of the IClientAccessPolicy interface returns a general policy that policy accepts connections from any domain and allows request headers and specifies resources that can be accessed and includes subpaths of these resources:

Copyclientaccesspolicy.xml
<?xml version="1.0" encoding="utf-8"?>
<access-policy>
  <cross-domain-access>
    <policy>
      <allow-from http-request-headers="*">
        <domain uri="*"/>
      </allow-from>
      <grant-to>
        <resource path="/" include-subpaths="true"/>
      </grant-to>
    </policy>
  </cross-domain-access>
</access-policy>

The IClientAccessPolicy service contract requres to be exposed through an endpoint configured to use a WebHttpBinding.

See Also

IClientAccessPolicy Members
Telerik.Reporting.Service Namespace


IClientAccessPolicy Members

[image] [image]

Telerik Reporting Q2 2012
IClientAccessPolicy Members
IClientAccessPolicy Interface Methods See Also Send Feedback

The IClientAccessPolicy type exposes the following members.

Methods

Name | Description
GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service.

See Also

IClientAccessPolicy Interface
Telerik.Reporting.Service Namespace


IClientAccessPolicy Methods

[image] [image]

Telerik Reporting Q2 2012
IClientAccessPolicy Methods
IClientAccessPolicy Interface See Also Send Feedback

The IClientAccessPolicy type exposes the following members.

Methods

Name | Description
GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service.

See Also

IClientAccessPolicy Interface
Telerik.Reporting.Service Namespace


GetClientAccessPolicy Method

[image]

Telerik Reporting Q2 2012
IClientAccessPolicy..::.GetClientAccessPolicy Method
IClientAccessPolicy Interface See Also Send Feedback
Returns security policy file required by Silverlight when accessing a cross-domain service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream GetClientAccessPolicy()
Visual Basic (Declaration)
Function GetClientAccessPolicy As Stream

Return Value

A Stream that contains the clientaccesspolicy.xml

Remarks

If the connection request was from a WebClient or an HTTP class to a cross-domain site, the Silverlight runtime tries to download the security policy file using the HTTP protocol. The Silverlight runtime first tries to download a Silverlight policy file with a name of "clientaccesspolicy.xml" at the root of the requested target domain using the HTTP protocol.

The default implementation of the IClientAccessPolicy interface returns a general policy that policy accepts connections from any domain and allows request headers and specifies resources that can be accessed and includes subpaths of these resources:

Copyclientaccesspolicy.xml
<?xml version="1.0" encoding="utf-8"?>
<access-policy>
  <cross-domain-access>
    <policy>
      <allow-from http-request-headers="*">
        <domain uri="*"/>
      </allow-from>
      <grant-to>
        <resource path="/" include-subpaths="true"/>
      </grant-to>
    </policy>
  </cross-domain-access>
</access-policy>

See Also

IClientAccessPolicy Interface
Telerik.Reporting.Service Namespace


IReportResolver Interface

[image]

Telerik Reporting Q2 2012
IReportResolver Interface
Members See Also Send Feedback
Resolves IReportDocument

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public interface IReportResolver
Visual Basic (Declaration)
Public Interface IReportResolver

See Also

IReportResolver Members
Telerik.Reporting.Service Namespace


IReportResolver Members

[image] [image]

Telerik Reporting Q2 2012
IReportResolver Members
IReportResolver Interface Methods See Also Send Feedback

The IReportResolver type exposes the following members.

Methods

Name | Description
Resolve | Resolves IReportDocument based on the specified report description.

See Also

IReportResolver Interface
Telerik.Reporting.Service Namespace


IReportResolver Methods

[image] [image]

Telerik Reporting Q2 2012
IReportResolver Methods
IReportResolver Interface See Also Send Feedback

The IReportResolver type exposes the following members.

Methods

Name | Description
Resolve | Resolves IReportDocument based on the specified report description.

See Also

IReportResolver Interface
Telerik.Reporting.Service Namespace


Resolve Method

[image]

Telerik Reporting Q2 2012
IReportResolver..::.Resolve Method
IReportResolver Interface See Also Send Feedback
Resolves IReportDocument based on the specified report description.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
ReportSource Resolve(
    string report
)
Visual Basic (Declaration)
Function Resolve ( _
    report As String _
) As ReportSource

Parameters

report
Type: System..::.String
The report.

Return Value

See Also

IReportResolver Interface
Telerik.Reporting.Service Namespace


IReportService Interface

[image]

Telerik Reporting Q2 2012
IReportService Interface
Members See Also Send Feedback
Represents the Telerik Reporting service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService

See Also

IReportService Members
Telerik.Reporting.Service Namespace


IReportService Members

[image] [image]

Telerik Reporting Q2 2012
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.
GetReportParameters | Retrieve a list of the report parameters for the given report and values. This operation is intended for internal use only.
ListAvailableReports | Retrieves the list of the available for the service reports.
ListRenderingExtensions | Retrieves the list of the available rendering extensions.
Render | Renders a report and returns the generated document.
RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


IReportService Methods

[image] [image]

Telerik Reporting Q2 2012
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.
GetReportParameters | Retrieve a list of the report parameters for the given report and values. This operation is intended for internal use only.
ListAvailableReports | Retrieves the list of the available for the service reports.
ListRenderingExtensions | Retrieves the list of the available rendering extensions.
Render | Renders a report and returns the generated document.
RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


GetPage Method

[image]

Telerik Reporting Q2 2012
IReportService..::.GetPage Method
IReportService Interface See Also Send Feedback
Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
PageInfo GetPage(
    string instanceID,
    int pageNumber
)
Visual Basic (Declaration)
Function GetPage ( _
    instanceID As String, _
    pageNumber As Integer _
) As PageInfo

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to a RenderAndCache operation.
pageNumber
Type: System..::.Int32
The serial number of the page to retrieve.

Return Value

A PageInfo that contains the page data.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


GetReportParameters Method

[image]

Telerik Reporting Q2 2012
IReportService..::.GetReportParameters Method
IReportService Interface See Also Send Feedback
Retrieve a list of the report parameters for the given report and values. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
List<Parameter> GetReportParameters(
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Function GetReportParameters ( _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
) As List(Of Parameter)

Parameters

report
Type: System..::.String
The AssemblyQualifiedName of the report type for which to obtain the parameters.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with settings for the current device.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with values for the report parameters.

Return Value

A list of report parameters.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


ListAvailableReports Method

[image]

Telerik Reporting Q2 2012
IReportService..::.ListAvailableReports Method
IReportService Interface See Also Send Feedback
Retrieves the list of the available for the service reports.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
IList<ReportInfo> ListAvailableReports()
Visual Basic (Declaration)
Function ListAvailableReports As IList(Of ReportInfo)

Return Value

List of the available reports.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


ListRenderingExtensions Method

[image]

Telerik Reporting Q2 2012
IReportService..::.ListRenderingExtensions Method
IReportService Interface See Also Send Feedback
Retrieves the list of the available rendering extensions.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
IList<ExtensionInfo> ListRenderingExtensions()
Visual Basic (Declaration)
Function ListRenderingExtensions As IList(Of ExtensionInfo)

Return Value

List of the available rendering extensions.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


Render Method

[image]

Telerik Reporting Q2 2012
IReportService..::.Render Method
IReportService Interface See Also Send Feedback
Renders a report and returns the generated document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
RenderingResult Render(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Function Render ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
) As RenderingResult

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with setting for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.

Return Value

A RenderingResult that contains the generated document bytes and info.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


RenderAndCache Method

[image]

Telerik Reporting Q2 2012
IReportService..::.RenderAndCache Method
IReportService Interface See Also Send Feedback
Renders a report and stores the result in the current session. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
RenderingSessionInfo RenderAndCache(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Function RenderAndCache ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
) As RenderingSessionInfo

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with setting for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.

Return Value

A RenderingSessionInfo that contains the result of the rendering operation.

Remarks

Requires ASP.NET session.

See Also

IReportService Interface
Telerik.Reporting.Service Namespace


IResourceService Interface

[image]

Telerik Reporting Q2 2012
IResourceService Interface
Members See Also Send Feedback
Represents the Telerik Reporting resource service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public interface IResourceService
Visual Basic (Declaration)
Public Interface IResourceService

Remarks

The IResourceService is intended for internal use only.

See Also

IResourceService Members
Telerik.Reporting.Service Namespace


IResourceService Members

[image] [image]

Telerik Reporting Q2 2012
IResourceService Members
IResourceService Interface Methods See Also Send Feedback

The IResourceService type exposes the following members.

Methods

Name | Description
Export | Retrieves a report document.
ExportCachedReport | Retrieves a report document for previously rendered and cached report using IReportService.RenderAndCache operation.
GetRenderStream | Retrieves a render stream created during a report rendering session.

See Also

IResourceService Interface
Telerik.Reporting.Service Namespace


IResourceService Methods

[image] [image]

Telerik Reporting Q2 2012
IResourceService Methods
IResourceService Interface See Also Send Feedback

The IResourceService type exposes the following members.

Methods

Name | Description
Export | Retrieves a report document.
ExportCachedReport | Retrieves a report document for previously rendered and cached report using IReportService.RenderAndCache operation.
GetRenderStream | Retrieves a render stream created during a report rendering session.

See Also

IResourceService Interface
Telerik.Reporting.Service Namespace


Export Method

[image]

Telerik Reporting Q2 2012
IResourceService..::.Export Method
IResourceService Interface See Also Send Feedback
Retrieves a report document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream Export(
    string format,
    string report,
    string deviceInfo,
    string parameterValues
)
Visual Basic (Declaration)
Function Export ( _
    format As String, _
    report As String, _
    deviceInfo As String, _
    parameterValues As String _
) As Stream

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: System..::.String
JSON-formatted dictionary (key/value pairs) with DeviceInfo settings for the current render format.
parameterValues
Type: System..::.String
JSON-formatter (key/value pairs) with the parameter values for the current report.

Remarks

Requires HTTP GET request.

See Also

IResourceService Interface
Telerik.Reporting.Service Namespace


ExportCachedReport Method

[image]

Telerik Reporting Q2 2012
IResourceService..::.ExportCachedReport Method
IResourceService Interface See Also Send Feedback
Retrieves a report document for previously rendered and cached report using IReportService.RenderAndCache operation.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream ExportCachedReport(
    string instanceID,
    string format,
    string deviceInfo
)
Visual Basic (Declaration)
Function ExportCachedReport ( _
    instanceID As String, _
    format As String, _
    deviceInfo As String _
) As Stream

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to a RenderAndCache operation.
format
Type: System..::.String
The render format.
deviceInfo
Type: System..::.String
JSON-formatted dictionary (key/value pairs) with DeviceInfo settings for the current render format.

Remarks

Requires HTTP GET request.

See Also

IResourceService Interface
Telerik.Reporting.Service Namespace


GetRenderStream Method

[image]

Telerik Reporting Q2 2012
IResourceService..::.GetRenderStream Method
IResourceService Interface See Also Send Feedback
Retrieves a render stream created during a report rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream GetRenderStream(
    string instanceID,
    string name
)
Visual Basic (Declaration)
Function GetRenderStream ( _
    instanceID As String, _
    name As String _
) As Stream

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session that the resource belongs to.
name
Type: System..::.String
The name of the resource.

Remarks

Requires HTTP GET request.

See Also

IResourceService Interface
Telerik.Reporting.Service Namespace


NameValueDictionary Class

[image]

Telerik Reporting Q2 2012
NameValueDictionary Class
Members See Also Send Feedback
Represents a Dictionary<(Of <(TKey, TValue>)>) with String key and Object value.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class NameValueDictionary : Dictionary<string, Object>
Visual Basic (Declaration)
Public Class NameValueDictionary _
    Inherits Dictionary(Of String, Object)

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.Dictionary <(Of <(<' String, Object >)>)>
Telerik.Reporting.Service..::.NameValueDictionary

See Also

NameValueDictionary Members
Telerik.Reporting.Service Namespace


NameValueDictionary Members

[image] [image]

Telerik Reporting Q2 2012
NameValueDictionary Members
NameValueDictionary Class Constructors See Also Send Feedback

The NameValueDictionary type exposes the following members.

Constructors

Name | Description
NameValueDictionary | Initializes a new instance of the NameValueDictionary class

See Also

NameValueDictionary Class
Telerik.Reporting.Service Namespace


NameValueDictionary Constructor

[image]

Telerik Reporting Q2 2012
NameValueDictionary Constructor
NameValueDictionary Class See Also Send Feedback
Initializes a new instance of the NameValueDictionary class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public NameValueDictionary()
Visual Basic (Declaration)
Public Sub New

See Also

NameValueDictionary Class
Telerik.Reporting.Service Namespace


PageInfo Class

[image]

Telerik Reporting Q2 2012
PageInfo Class
Members See Also Send Feedback
Represents the result of the GetPage service operation.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class PageInfo : ServiceOperationResultBase
Visual Basic (Declaration)
Public Class PageInfo _
    Inherits ServiceOperationResultBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ServiceOperationResultBase
Telerik.Reporting.Service..::.PageInfo

See Also

PageInfo Members
Telerik.Reporting.Service Namespace


PageInfo Members

[image] [image]

Telerik Reporting Q2 2012
PageInfo Members
PageInfo Class Constructors Methods Properties See Also Send Feedback

The PageInfo type exposes the following members.

Constructors

Name | Description
PageInfo | Initializes a new instance of the PageInfo class

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

Properties

Name | Description
Buffer | Gets or sets the Byte array that contains the current report page.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
PageNumber | Gets or sets the serial number of the current report page.

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


PageInfo Constructor

[image]

Telerik Reporting Q2 2012
PageInfo Constructor
PageInfo Class See Also Send Feedback
Initializes a new instance of the PageInfo class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public PageInfo()
Visual Basic (Declaration)
Public Sub New

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


PageInfo Methods

[image] [image]

Telerik Reporting Q2 2012
PageInfo Methods
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


PageInfo Properties

[image] [image]

Telerik Reporting Q2 2012
PageInfo Properties
PageInfo Class See Also Send Feedback

The PageInfo type exposes the following members.

Properties

Name | Description
Buffer | Gets or sets the Byte array that contains the current report page.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
PageNumber | Gets or sets the serial number of the current report page.

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


Buffer Property

[image]

Telerik Reporting Q2 2012
PageInfo..::.Buffer Property
PageInfo Class See Also Send Feedback
Gets or sets the Byte array that contains the current report page.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public byte[] Buffer { get; set; }
Visual Basic (Declaration)
Public Property Buffer As Byte()

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


PageNumber Property

[image]

Telerik Reporting Q2 2012
PageInfo..::.PageNumber Property
PageInfo Class See Also Send Feedback
Gets or sets the serial number of the current report page.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer

See Also

PageInfo Class
Telerik.Reporting.Service Namespace


Parameter Class

[image]

Telerik Reporting Q2 2012
Parameter Class
Members See Also Send Feedback
Represents a ReportParameter ready to be displayed by a report viewer. Parameter is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class Parameter : Parameter
Visual Basic (Declaration)
Public Class Parameter _
    Inherits Parameter

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Processing..::.Parameter
Telerik.Reporting.Service..::.Parameter

See Also

Parameter Members
Telerik.Reporting.Service Namespace


Parameter Members

[image] [image]

Telerik Reporting Q2 2012
Parameter Members
Parameter Class Constructors Properties See Also Send Feedback

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Initializes a new instance of the Parameter class

Properties

Name | Description
AllowBlank | Determines if the parameter allows an empty string to be passed. Only for parameters of type string. (Inherited from Parameter.)
AllowNull | Determines if the parameter allows no value to be passed from it's editor. (Inherited from Parameter.)
AutoRefresh | Determines whether the report viewer should auto-update the report when the parameter value is changed. (Inherited from Parameter.)
AvailableValues | Gets or sets the list of the available values for the current parameter. (Inherited from Parameter.)
ChildParameters | Gets or sets the list of the parameters that depends on the current parameter. (Inherited from Parameter.)
IsVisible | Determines if the parameter should be displayed in the report viewer. (Inherited from Parameter.)
Label | Gets the label of the parameter. Returns a string that contains the label of the current parameter's Value or an array of strings that contains the labels of all values when multivalue parameter. (Inherited from Parameter.)
Multivalue | Determines if the parameter can hold more then one value. (Inherited from Parameter.)
Name | Gets or sets the Name of the parameters (Inherited from Parameter.)
Text | Gets or sets the text for the parameter to be displayed in the report viewer. (Inherited from Parameter.)
Type | Gets or sets the type of the parameter. (Inherited from Parameter.)
Value | Gets or sets the value of the parameter. (Inherited from Parameter.)

See Also

Parameter Class
Telerik.Reporting.Service Namespace


Parameter Constructor

[image]

Telerik Reporting Q2 2012
Parameter Constructor
Parameter Class See Also Send Feedback
Initializes a new instance of the Parameter class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Parameter()
Visual Basic (Declaration)
Public Sub New

See Also

Parameter Class
Telerik.Reporting.Service Namespace


Parameter Properties

[image] [image]

Telerik Reporting Q2 2012
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

Name | Description
AllowBlank | Determines if the parameter allows an empty string to be passed. Only for parameters of type string. (Inherited from Parameter.)
AllowNull | Determines if the parameter allows no value to be passed from it's editor. (Inherited from Parameter.)
AutoRefresh | Determines whether the report viewer should auto-update the report when the parameter value is changed. (Inherited from Parameter.)
AvailableValues | Gets or sets the list of the available values for the current parameter. (Inherited from Parameter.)
ChildParameters | Gets or sets the list of the parameters that depends on the current parameter. (Inherited from Parameter.)
IsVisible | Determines if the parameter should be displayed in the report viewer. (Inherited from Parameter.)
Label | Gets the label of the parameter. Returns a string that contains the label of the current parameter's Value or an array of strings that contains the labels of all values when multivalue parameter. (Inherited from Parameter.)
Multivalue | Determines if the parameter can hold more then one value. (Inherited from Parameter.)
Name | Gets or sets the Name of the parameters (Inherited from Parameter.)
Text | Gets or sets the text for the parameter to be displayed in the report viewer. (Inherited from Parameter.)
Type | Gets or sets the type of the parameter. (Inherited from Parameter.)
Value | Gets or sets the value of the parameter. (Inherited from Parameter.)

See Also

Parameter Class
Telerik.Reporting.Service Namespace


RenderingResult Class

[image]

Telerik Reporting Q2 2012
RenderingResult Class
Members See Also Send Feedback
Represents the result of the Render service operation.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class RenderingResult : ServiceOperationResultBase
Visual Basic (Declaration)
Public Class RenderingResult _
    Inherits ServiceOperationResultBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ServiceOperationResultBase
Telerik.Reporting.Service..::.RenderingResult

See Also

RenderingResult Members
Telerik.Reporting.Service Namespace


RenderingResult Members

[image] [image]

Telerik Reporting Q2 2012
RenderingResult Members
RenderingResult Class Constructors Methods Properties See Also Send Feedback

The RenderingResult type exposes the following members.

Constructors

Name | Description
RenderingResult | Initializes a new instance of the RenderingResult class

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

Properties

Name | Description
DocumentBytes | Byte array that contains the rendered report.
DocumentName | Gets or sets the name of the created document.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
Extension | Gets or sets the file extension of the document.
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
MimeType | Gets or sets the MIME type of the document.

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


RenderingResult Constructor

[image]

Telerik Reporting Q2 2012
RenderingResult Constructor
RenderingResult Class See Also Send Feedback
Initializes a new instance of the RenderingResult class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public RenderingResult()
Visual Basic (Declaration)
Public Sub New

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


RenderingResult Methods

[image] [image]

Telerik Reporting Q2 2012
RenderingResult Methods
RenderingResult Class See Also Send Feedback

The RenderingResult type exposes the following members.

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


RenderingResult Properties

[image] [image]

Telerik Reporting Q2 2012
RenderingResult Properties
RenderingResult Class See Also Send Feedback

The RenderingResult type exposes the following members.

Properties

Name | Description
DocumentBytes | Byte array that contains the rendered report.
DocumentName | Gets or sets the name of the created document.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
Extension | Gets or sets the file extension of the document.
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
MimeType | Gets or sets the MIME type of the document.

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


DocumentBytes Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.DocumentBytes Property
RenderingResult Class See Also Send Feedback
Byte array that contains the rendered report.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public byte[] DocumentBytes { get; set; }
Visual Basic (Declaration)
Public Property DocumentBytes As Byte()

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.DocumentName Property
RenderingResult Class See Also Send Feedback
Gets or sets the name of the created document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


Extension Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.Extension Property
RenderingResult Class See Also Send Feedback
Gets or sets the file extension of the document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Extension { get; set; }
Visual Basic (Declaration)
Public Property Extension As String

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


MimeType Property

[image]

Telerik Reporting Q2 2012
RenderingResult..::.MimeType Property
RenderingResult Class See Also Send Feedback
Gets or sets the MIME type of the document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string MimeType { get; set; }
Visual Basic (Declaration)
Public Property MimeType As String

See Also

RenderingResult Class
Telerik.Reporting.Service Namespace


RenderingSessionInfo Class

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo Class
Members See Also Send Feedback
Represents the result of a RenderAndCache service operation. This class is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class RenderingSessionInfo : ServiceOperationResultBase
Visual Basic (Declaration)
Public Class RenderingSessionInfo _
    Inherits ServiceOperationResultBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ServiceOperationResultBase
Telerik.Reporting.Service..::.RenderingSessionInfo

See Also

RenderingSessionInfo Members
Telerik.Reporting.Service Namespace


RenderingSessionInfo Members

[image] [image]

Telerik Reporting Q2 2012
RenderingSessionInfo Members
RenderingSessionInfo Class Constructors Methods Properties See Also Send Feedback

The RenderingSessionInfo type exposes the following members.

Constructors

Name | Description
RenderingSessionInfo | Initializes a new instance of the RenderingSessionInfo class

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

Properties

Name | Description
Actions | Gets or sets a list of the ActionInfos for the current rendering session.
Bookmarks | Gets or sets a list of the [!:BookmarkInfo]s for the current rendering session.
DocumentName | Gets or sets the report document name of the rendered report.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
HasDocumentMap | Gets or sets a value indicating whether a document map is available for the current report.
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
InstanceID | Gets or sets the unique identifier of the current rendering session.
NavigateBackEnabled | Determines if the NavigateBack command is enabled.
NavigateForwardEnabled | Determines if the NavigateForward command is enabled.
PageCount | Gets or sets the count of the generated pages for the current rendering session.
PageNumber | Gets or sets the page that is initially shown in the viewer.
Parameters | Gets or sets a list of Parameters for the current report.
Report | Gets or sets the assembly qualified name of the rendered report.

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


RenderingSessionInfo Constructor

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo Constructor
RenderingSessionInfo Class See Also Send Feedback
Initializes a new instance of the RenderingSessionInfo class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public RenderingSessionInfo()
Visual Basic (Declaration)
Public Sub New

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


RenderingSessionInfo Methods

[image] [image]

Telerik Reporting Q2 2012
RenderingSessionInfo Methods
RenderingSessionInfo Class See Also Send Feedback

The RenderingSessionInfo type exposes the following members.

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error. (Inherited from ServiceOperationResultBase.)

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


RenderingSessionInfo Properties

[image] [image]

Telerik Reporting Q2 2012
RenderingSessionInfo Properties
RenderingSessionInfo Class See Also Send Feedback

The RenderingSessionInfo type exposes the following members.

Properties

Name | Description
Actions | Gets or sets a list of the ActionInfos for the current rendering session.
Bookmarks | Gets or sets a list of the [!:BookmarkInfo]s for the current rendering session.
DocumentName | Gets or sets the report document name of the rendered report.
Error | Gets or sets the current error message for the current service operation. (Inherited from ServiceOperationResultBase.)
HasDocumentMap | Gets or sets a value indicating whether a document map is available for the current report.
HasError | Indicates whether the current operation has ended with error. (Inherited from ServiceOperationResultBase.)
InstanceID | Gets or sets the unique identifier of the current rendering session.
NavigateBackEnabled | Determines if the NavigateBack command is enabled.
NavigateForwardEnabled | Determines if the NavigateForward command is enabled.
PageCount | Gets or sets the count of the generated pages for the current rendering session.
PageNumber | Gets or sets the page that is initially shown in the viewer.
Parameters | Gets or sets a list of Parameters for the current report.
Report | Gets or sets the assembly qualified name of the rendered report.

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


Actions Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.Actions Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets a list of the ActionInfos for the current rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<ActionInfo> Actions { get; set; }
Visual Basic (Declaration)
Public Property Actions As List(Of ActionInfo)

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


Bookmarks Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.Bookmarks Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets a list of the [!:BookmarkInfo]s for the current rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<BookmarkNode> Bookmarks { get; set; }
Visual Basic (Declaration)
Public Property Bookmarks As List(Of BookmarkNode)

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.DocumentName Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets the report document name of the rendered report.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


HasDocumentMap Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.HasDocumentMap Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets a value indicating whether a document map is available for the current report.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool HasDocumentMap { get; set; }
Visual Basic (Declaration)
Public Property HasDocumentMap As Boolean

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


InstanceID Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.InstanceID Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets the unique identifier of the current rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string InstanceID { get; set; }
Visual Basic (Declaration)
Public Property InstanceID As String

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


NavigateBackEnabled Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.NavigateBackEnabled Property
RenderingSessionInfo Class See Also Send Feedback
Determines if the NavigateBack command is enabled.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool NavigateBackEnabled { get; set; }
Visual Basic (Declaration)
Public Property NavigateBackEnabled As Boolean

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


NavigateForwardEnabled Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.NavigateForwardEnabled Property
RenderingSessionInfo Class See Also Send Feedback
Determines if the NavigateForward command is enabled.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool NavigateForwardEnabled { get; set; }
Visual Basic (Declaration)
Public Property NavigateForwardEnabled As Boolean

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


PageCount Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.PageCount Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets the count of the generated pages for the current rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageCount { get; set; }
Visual Basic (Declaration)
Public Property PageCount As Integer

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


PageNumber Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.PageNumber Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets the page that is initially shown in the viewer.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.Parameters Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets a list of Parameters for the current report.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<Parameter> Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As List(Of Parameter)

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


Report Property

[image]

Telerik Reporting Q2 2012
RenderingSessionInfo..::.Report Property
RenderingSessionInfo Class See Also Send Feedback
Gets or sets the assembly qualified name of the rendered report.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Report { get; set; }
Visual Basic (Declaration)
Public Property Report As String

See Also

RenderingSessionInfo Class
Telerik.Reporting.Service Namespace


ReportFileResolver Class

[image]

Telerik Reporting Q2 2012
ReportFileResolver Class
Members See Also Send Feedback
Resolves IReportDocument from physical path to trdx file

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public class ReportFileResolver : ReportResolverBase
Visual Basic (Declaration)
Public Class ReportFileResolver _
    Inherits ReportResolverBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportResolverBase
Telerik.Reporting.Service..::.ReportFileResolver
Telerik.Reporting.Service..::.ReportFileResolverWeb

See Also

ReportFileResolver Members
Telerik.Reporting.Service Namespace


ReportFileResolver Members

[image] [image]

Telerik Reporting Q2 2012
ReportFileResolver Members
ReportFileResolver Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The ReportFileResolver type exposes the following members.

Constructors

Name | Description
ReportFileResolver | Initializes a new instance of the ReportFileResolver class.

Methods

Name | Description
IsValidReportPath |
MapPath |
ResolveReport | (Overrides ReportResolverBase..::.ResolveReport(String).)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


ReportFileResolver Constructor

[image]

Telerik Reporting Q2 2012
ReportFileResolver Constructor
ReportFileResolver Class See Also Send Feedback
Initializes a new instance of the ReportFileResolver class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public ReportFileResolver(
    IReportResolver parentResolver
)
Visual Basic (Declaration)
Public Sub New ( _
    parentResolver As IReportResolver _
)

Parameters

parentResolver
Type: Telerik.Reporting.Service..::.IReportResolver
The fallback parent resolver.

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


ReportFileResolver Methods

[image] [image]

Telerik Reporting Q2 2012
ReportFileResolver Methods
ReportFileResolver Class See Also Send Feedback

The ReportFileResolver type exposes the following members.

Methods

Name | Description
IsValidReportPath |
MapPath |
ResolveReport | (Overrides ReportResolverBase..::.ResolveReport(String).)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


IsValidReportPath Method

[image]

Telerik Reporting Q2 2012
ReportFileResolver..::.IsValidReportPath Method
ReportFileResolver Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected virtual bool IsValidReportPath(
    string path
)
Visual Basic (Declaration)
Protected Overridable Function IsValidReportPath ( _
    path As String _
) As Boolean

Parameters

path
Type: System..::.String

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


MapPath Method

[image]

Telerik Reporting Q2 2012
ReportFileResolver..::.MapPath Method
ReportFileResolver Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected virtual string MapPath(
    string path
)
Visual Basic (Declaration)
Protected Overridable Function MapPath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


ResolveReport Method

[image]

Telerik Reporting Q2 2012
ReportFileResolver..::.ResolveReport Method
ReportFileResolver Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected override ReportSource ResolveReport(
    string report
)
Visual Basic (Declaration)
Protected Overrides Function ResolveReport ( _
    report As String _
) As ReportSource

Parameters

report
Type: System..::.String

See Also

ReportFileResolver Class
Telerik.Reporting.Service Namespace


ReportFileResolverWeb Class

[image]

Telerik Reporting Q2 2012
ReportFileResolverWeb Class
Members See Also Send Feedback
Resolves IReportDocument from a relative path to trdx file.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public class ReportFileResolverWeb : ReportFileResolver
Visual Basic (Declaration)
Public Class ReportFileResolverWeb _
    Inherits ReportFileResolver

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportResolverBase
Telerik.Reporting.Service..::.ReportFileResolver
Telerik.Reporting.Service..::.ReportFileResolverWeb

See Also

ReportFileResolverWeb Members
Telerik.Reporting.Service Namespace


ReportFileResolverWeb Members

[image] [image]

Telerik Reporting Q2 2012
ReportFileResolverWeb Members
ReportFileResolverWeb Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The ReportFileResolverWeb type exposes the following members.

Constructors

Name | Description
ReportFileResolverWeb | Initializes a new instance of the ReportFileResolverWeb class.

Methods

Name | Description
IsValidReportPath | (Inherited from ReportFileResolver.)
MapPath | (Overrides ReportFileResolver..::.MapPath(String).)
ResolveReport | (Inherited from ReportFileResolver.)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportFileResolverWeb Class
Telerik.Reporting.Service Namespace


ReportFileResolverWeb Constructor

[image]

Telerik Reporting Q2 2012
ReportFileResolverWeb Constructor
ReportFileResolverWeb Class See Also Send Feedback
Initializes a new instance of the ReportFileResolverWeb class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public ReportFileResolverWeb(
    IReportResolver parentResolver
)
Visual Basic (Declaration)
Public Sub New ( _
    parentResolver As IReportResolver _
)

Parameters

parentResolver
Type: Telerik.Reporting.Service..::.IReportResolver
The fallback parent resolver.

See Also

ReportFileResolverWeb Class
Telerik.Reporting.Service Namespace


ReportFileResolverWeb Methods

[image] [image]

Telerik Reporting Q2 2012
ReportFileResolverWeb Methods
ReportFileResolverWeb Class See Also Send Feedback

The ReportFileResolverWeb type exposes the following members.

Methods

Name | Description
IsValidReportPath | (Inherited from ReportFileResolver.)
MapPath | (Overrides ReportFileResolver..::.MapPath(String).)
ResolveReport | (Inherited from ReportFileResolver.)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportFileResolverWeb Class
Telerik.Reporting.Service Namespace


MapPath Method

[image]

Telerik Reporting Q2 2012
ReportFileResolverWeb..::.MapPath Method
ReportFileResolverWeb Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected override string MapPath(
    string path
)
Visual Basic (Declaration)
Protected Overrides Function MapPath ( _
    path As String _
) As String

Parameters

path
Type: System..::.String

See Also

ReportFileResolverWeb Class
Telerik.Reporting.Service Namespace


ReportInfo Class

[image]

Telerik Reporting Q2 2012
ReportInfo Class
Members See Also Send Feedback
Represents a Report on the server

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportInfo
Visual Basic (Declaration)
Public Class ReportInfo

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportInfo

See Also

ReportInfo Members
Telerik.Reporting.Service Namespace


ReportInfo Members

[image] [image]

Telerik Reporting Q2 2012
ReportInfo Members
ReportInfo Class Constructors Properties See Also Send Feedback

The ReportInfo type exposes the following members.

Constructors

Name | Description
ReportInfo | Initializes a new instance of the ReportInfo class

Properties

Name | Description
Description | The description of the Report, if any.
FullName | The AssemblyQualifiedName of the Report class.
Name | The [!:System.Type.Name] of the Report class.

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


ReportInfo Constructor

[image]

Telerik Reporting Q2 2012
ReportInfo Constructor
ReportInfo Class See Also Send Feedback
Initializes a new instance of the ReportInfo class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


ReportInfo Properties

[image] [image]

Telerik Reporting Q2 2012
ReportInfo Properties
ReportInfo Class See Also Send Feedback

The ReportInfo type exposes the following members.

Properties

Name | Description
Description | The description of the Report, if any.
FullName | The AssemblyQualifiedName of the Report class.
Name | The [!:System.Type.Name] of the Report class.

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


Description Property

[image]

Telerik Reporting Q2 2012
ReportInfo..::.Description Property
ReportInfo Class See Also Send Feedback
The description of the Report, if any.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

Remarks

The description of the Report is attached through the DescriptionAttribute.

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


FullName Property

[image]

Telerik Reporting Q2 2012
ReportInfo..::.FullName Property
ReportInfo Class See Also Send Feedback
The AssemblyQualifiedName of the Report class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string FullName { get; set; }
Visual Basic (Declaration)
Public Property FullName As String

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ReportInfo..::.Name Property
ReportInfo Class See Also Send Feedback
The [!:System.Type.Name] of the Report class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ReportInfo Class
Telerik.Reporting.Service Namespace


ReportResolverBase Class

[image]

Telerik Reporting Q2 2012
ReportResolverBase Class
Members See Also Send Feedback
Base report resolver with fallback mechanism.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public abstract class ReportResolverBase : IReportResolver
Visual Basic (Declaration)
Public MustInherit Class ReportResolverBase _
    Implements IReportResolver

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportResolverBase
Telerik.Reporting.Service..::.ReportFileResolver
Telerik.Reporting.Service..::.ReportTypeResolver

See Also

ReportResolverBase Members
Telerik.Reporting.Service Namespace


ReportResolverBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportResolverBase Members
ReportResolverBase Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The ReportResolverBase type exposes the following members.

Constructors

Name | Description
ReportResolverBase | Initializes a new instance of the ReportResolverBase class

Methods

Name | Description
ResolveError | Overloaded.
ResolveReport |

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve |

See Also

ReportResolverBase Class
Telerik.Reporting.Service Namespace


ReportResolverBase Constructor

[image]

Telerik Reporting Q2 2012
ReportResolverBase Constructor
ReportResolverBase Class See Also Send Feedback
Initializes a new instance of the ReportResolverBase class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected ReportResolverBase(
    IReportResolver parentResolver
)
Visual Basic (Declaration)
Protected Sub New ( _
    parentResolver As IReportResolver _
)

Parameters

parentResolver
Type: Telerik.Reporting.Service..::.IReportResolver

See Also

ReportResolverBase Class
Telerik.Reporting.Service Namespace


ReportResolverBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportResolverBase Methods
ReportResolverBase Class See Also Send Feedback

The ReportResolverBase type exposes the following members.

Methods

Name | Description
ResolveError | Overloaded.
ResolveReport |

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve |

See Also

ReportResolverBase Class
Telerik.Reporting.Service Namespace


IReportResolver.Resolve Method

[image]

Telerik Reporting Q2 2012
ReportResolverBase..::.IReportResolver..::.Resolve Method
ReportResolverBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
ReportSource IReportResolver.Resolve(
    string report
)
Visual Basic (Declaration)
Private Function Resolve ( _
    report As String _
) As ReportSource Implements IReportResolver.Resolve

Parameters

report
Type: System..::.String

Implements

IReportResolver..::.Resolve(String)

See Also

ReportResolverBase Class
Telerik.Reporting.Service Namespace


ResolveError Method

[image] [image]

Telerik Reporting Q2 2012
ReportResolverBase..::.ResolveError Method
ReportResolverBase Class See Also Send Feedback

Overload List

Name | Description
ResolveError(String) |
ResolveError(String, Exception) |

See Also

ReportResolverBase Class
ReportResolverBase Members
Telerik.Reporting.Service Namespace


ResolveError Method (String)

[image]

Telerik Reporting Q2 2012
ReportResolverBase..::.ResolveError Method (String)
ReportResolverBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected static Exception ResolveError(
    string report
)
Visual Basic (Declaration)
Protected Shared Function ResolveError ( _
    report As String _
) As Exception

Parameters

report
Type: System..::.String

See Also

ReportResolverBase Class
ResolveError Overload
Telerik.Reporting.Service Namespace


ResolveError Method (String, Exception)

[image]

Telerik Reporting Q2 2012
ReportResolverBase..::.ResolveError Method (String, Exception)
ReportResolverBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected static Exception ResolveError(
    string report,
    Exception e
)
Visual Basic (Declaration)
Protected Shared Function ResolveError ( _
    report As String, _
    e As Exception _
) As Exception

Parameters

report
Type: System..::.String
e
Type: System..::.Exception

See Also

ReportResolverBase Class
ResolveError Overload
Telerik.Reporting.Service Namespace


ResolveReport Method

[image]

Telerik Reporting Q2 2012
ReportResolverBase..::.ResolveReport Method
ReportResolverBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected abstract ReportSource ResolveReport(
    string report
)
Visual Basic (Declaration)
Protected MustOverride Function ResolveReport ( _
    report As String _
) As ReportSource

Parameters

report
Type: System..::.String

See Also

ReportResolverBase Class
Telerik.Reporting.Service Namespace


ReportService Class

[image]

Telerik Reporting Q2 2012
ReportService Class
Members See Also Send Feedback
The top-level class of the Telerik Reporting Web service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public class ReportService : ReportServiceBase
Visual Basic (Declaration)
Public Class ReportService _
    Inherits ReportServiceBase

Remarks

Use this class when hosting the Telerik Report Service in IIS. Requires ASP.NET.

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportServiceBase
Telerik.Reporting.Service..::.ReportService

See Also

ReportService Members
Telerik.Reporting.Service Namespace


ReportService Members

[image] [image]

Telerik Reporting Q2 2012
ReportService Members
ReportService Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportService type exposes the following members.

Constructors

Name | Description
ReportService | Initializes a new instance of the ReportService class

Methods

Name | Description
GetState | Gets a value from the internal storage. (Inherited from ReportServiceBase.)
Render | Renders a report and returns the generated document. (Inherited from ReportServiceBase.)
SetState | Adds a value to the internal storage. (Inherited from ReportServiceBase.)

Properties

Name | Description
BaseAddress | (Overrides ReportServiceBase..::.BaseAddress.)
HttpContext |
ReportResolver | (Inherited from ReportServiceBase.)

Explicit Interface Implementations

Name | Description
IResourceService..::.Export | Retrieves a report document. (Inherited from ReportServiceBase.)
IResourceService..::.ExportCachedReport | (Inherited from ReportServiceBase.)
IClientAccessPolicy..::.GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service. (Inherited from ReportServiceBase.)
IReportService..::.GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IResourceService..::.GetRenderStream | Retrieves a render stream created during a report rendering session. (Inherited from ReportServiceBase.)
IReportService..::.GetReportParameters | Retrieves a list of report parameters for the given report and values. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IReportService..::.ListAvailableReports | Retrieves the list of the available for the service reports. (Inherited from ReportServiceBase.)
IReportService..::.ListRenderingExtensions | Retrieves the list of available rendering extensions. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IReportService..::.RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only. (Inherited from ReportServiceBase.)

See Also

ReportService Class
Telerik.Reporting.Service Namespace


ReportService Constructor

[image]

Telerik Reporting Q2 2012
ReportService Constructor
ReportService Class See Also Send Feedback
Initializes a new instance of the ReportService class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public ReportService()
Visual Basic (Declaration)
Public Sub New

See Also

ReportService Class
Telerik.Reporting.Service Namespace


ReportService Methods

[image] [image]

Telerik Reporting Q2 2012
ReportService Methods
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Methods

Name | Description
GetState | Gets a value from the internal storage. (Inherited from ReportServiceBase.)
Render | Renders a report and returns the generated document. (Inherited from ReportServiceBase.)
SetState | Adds a value to the internal storage. (Inherited from ReportServiceBase.)

Explicit Interface Implementations

Name | Description
IResourceService..::.Export | Retrieves a report document. (Inherited from ReportServiceBase.)
IResourceService..::.ExportCachedReport | (Inherited from ReportServiceBase.)
IClientAccessPolicy..::.GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service. (Inherited from ReportServiceBase.)
IReportService..::.GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IResourceService..::.GetRenderStream | Retrieves a render stream created during a report rendering session. (Inherited from ReportServiceBase.)
IReportService..::.GetReportParameters | Retrieves a list of report parameters for the given report and values. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IReportService..::.ListAvailableReports | Retrieves the list of the available for the service reports. (Inherited from ReportServiceBase.)
IReportService..::.ListRenderingExtensions | Retrieves the list of available rendering extensions. This operation is intended for internal use only. (Inherited from ReportServiceBase.)
IReportService..::.RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only. (Inherited from ReportServiceBase.)

See Also

ReportService Class
Telerik.Reporting.Service Namespace


ReportService Properties

[image] [image]

Telerik Reporting Q2 2012
ReportService Properties
ReportService Class See Also Send Feedback

The ReportService type exposes the following members.

Properties

Name | Description
BaseAddress | (Overrides ReportServiceBase..::.BaseAddress.)
HttpContext |
ReportResolver | (Inherited from ReportServiceBase.)

See Also

ReportService Class
Telerik.Reporting.Service Namespace


BaseAddress Property

[image]

Telerik Reporting Q2 2012
ReportService..::.BaseAddress Property
ReportService Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected override Uri BaseAddress { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property BaseAddress As Uri

See Also

ReportService Class
Telerik.Reporting.Service Namespace


HttpContext Property

[image]

Telerik Reporting Q2 2012
ReportService..::.HttpContext Property
ReportService Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public HttpContext HttpContext { get; set; }
Visual Basic (Declaration)
Public Property HttpContext As HttpContext

See Also

ReportService Class
Telerik.Reporting.Service Namespace


ReportServiceBase Class

[image]

Telerik Reporting Q2 2012
ReportServiceBase Class
Members See Also Send Feedback
The base class of the Telerik Reporting WCF Service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public abstract class ReportServiceBase : IReportService,
    IResourceService, IClientAccessPolicy
Visual Basic (Declaration)
Public MustInherit Class ReportServiceBase _
    Implements IReportService, IResourceService, IClientAccessPolicy

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportServiceBase
Telerik.Reporting.Service..::.ReportService

See Also

ReportServiceBase Members
Telerik.Reporting.Service Namespace


ReportServiceBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportServiceBase Members
ReportServiceBase Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportServiceBase type exposes the following members.

Constructors

Name | Description
ReportServiceBase | Initializes a new instance of the ReportServiceBase class

Methods

Name | Description
GetState | Gets a value from the internal storage.
Render | Renders a report and returns the generated document.
SetState | Adds a value to the internal storage.

Properties

Name | Description
BaseAddress | When implemented, returns the base address of the Telerik ReportService that will be used as a base Uri for the resources
ReportResolver |

Explicit Interface Implementations

Name | Description
IResourceService..::.Export | Retrieves a report document.
IResourceService..::.ExportCachedReport |
IClientAccessPolicy..::.GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service.
IReportService..::.GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.
IResourceService..::.GetRenderStream | Retrieves a render stream created during a report rendering session.
IReportService..::.GetReportParameters | Retrieves a list of report parameters for the given report and values. This operation is intended for internal use only.
IReportService..::.ListAvailableReports | Retrieves the list of the available for the service reports.
IReportService..::.ListRenderingExtensions | Retrieves the list of available rendering extensions. This operation is intended for internal use only.
IReportService..::.RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


ReportServiceBase Constructor

[image]

Telerik Reporting Q2 2012
ReportServiceBase Constructor
ReportServiceBase Class See Also Send Feedback
Initializes a new instance of the ReportServiceBase class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected ReportServiceBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


ReportServiceBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportServiceBase Methods
ReportServiceBase Class See Also Send Feedback

The ReportServiceBase type exposes the following members.

Methods

Name | Description
GetState | Gets a value from the internal storage.
Render | Renders a report and returns the generated document.
SetState | Adds a value to the internal storage.

Explicit Interface Implementations

Name | Description
IResourceService..::.Export | Retrieves a report document.
IResourceService..::.ExportCachedReport |
IClientAccessPolicy..::.GetClientAccessPolicy | Returns security policy file required by Silverlight when accessing a cross-domain service.
IReportService..::.GetPage | Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.
IResourceService..::.GetRenderStream | Retrieves a render stream created during a report rendering session.
IReportService..::.GetReportParameters | Retrieves a list of report parameters for the given report and values. This operation is intended for internal use only.
IReportService..::.ListAvailableReports | Retrieves the list of the available for the service reports.
IReportService..::.ListRenderingExtensions | Retrieves the list of available rendering extensions. This operation is intended for internal use only.
IReportService..::.RenderAndCache | Renders a report and stores the result in the current session. This operation is intended for internal use only.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


GetState Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.GetState Method
ReportServiceBase Class See Also Send Feedback
Gets a value from the internal storage.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected virtual Object GetState(
    string name
)
Visual Basic (Declaration)
Protected Overridable Function GetState ( _
    name As String _
) As Object

Parameters

name
Type: System..::.String
The key name of the state value.

Return Value

The state value with the specified name.

Remarks

The internal storage represents a central place for storing shared data between the service calls.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IClientAccessPolicy.GetClientAccessPolicy Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IClientAccessPolicy..::.GetClientAccessPolicy Method
ReportServiceBase Class See Also Send Feedback
Returns security policy file required by Silverlight when accessing a cross-domain service.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream IClientAccessPolicy.GetClientAccessPolicy()
Visual Basic (Declaration)
Private Function GetClientAccessPolicy As Stream
    Implements IClientAccessPolicy.GetClientAccessPolicy

Return Value

A Stream that contains the clientaccesspolicy.xml

Implements

IClientAccessPolicy..::.GetClientAccessPolicy()()()

Remarks

If the connection request was from a WebClient or an HTTP class to a cross-domain site, the Silverlight runtime tries to download the security policy file using the HTTP protocol. The Silverlight runtime first tries to download a Silverlight policy file with a name of "clientaccesspolicy.xml" at the root of the requested target domain using the HTTP protocol.

Override this method in order to change the default access policy for ReportServiceBase.

The default implementation of the IClientAccessPolicy interface returns a general policy that policy accepts connections from any domain and allows request headers and specifies resources that can be accessed and includes sub-paths of these resources:

Copyclientaccesspolicy.xml
<?xml version="1.0" encoding="utf-8"?>
<access-policy>
  <cross-domain-access>
    <policy>
      <allow-from http-request-headers="*">
        <domain uri="*"/>
      </allow-from>
      <grant-to>
        <resource path="/" include-subpaths="true"/>
      </grant-to>
    </policy>
  </cross-domain-access>
</access-policy>

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IReportService.GetPage Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IReportService..::.GetPage Method
ReportServiceBase Class See Also Send Feedback
Retrieves a rendered page for the given rendering session ID and page number. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
PageInfo IReportService.GetPage(
    string instanceID,
    int pageNumber
)
Visual Basic (Declaration)
Private Function GetPage ( _
    instanceID As String, _
    pageNumber As Integer _
) As PageInfo Implements IReportService.GetPage

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to RenderAndCache operation.
pageNumber
Type: System..::.Int32
The serial number of the page to retrieve.

Return Value

A PageInfo that contains the page data.

Implements

IReportService..::.GetPage(String, Int32)

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IReportService.GetReportParameters Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IReportService..::.GetReportParameters Method
ReportServiceBase Class See Also Send Feedback
Retrieves a list of report parameters for the given report and values. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
List<Parameter> IReportService.GetReportParameters(
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameterValues
)
Visual Basic (Declaration)
Private Function GetReportParameters ( _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameterValues As NameValueDictionary _
) As List(Of Parameter) Implements IReportService.GetReportParameters

Parameters

report
Type: System..::.String
The AssemblyQualifiedName of the report type for which to obtain the parameters.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with settings for the current device.
parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with values for the report parameters.

Return Value

A list of report parameters.

Implements

IReportService..::.GetReportParameters(String, NameValueDictionary, NameValueDictionary)

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IReportService.ListAvailableReports Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IReportService..::.ListAvailableReports Method
ReportServiceBase Class See Also Send Feedback
Retrieves the list of the available for the service reports.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
IList<ReportInfo> IReportService.ListAvailableReports()
Visual Basic (Declaration)
Private Function ListAvailableReports As IList(Of ReportInfo)
    Implements IReportService.ListAvailableReports

Return Value

List of the available reports.

Implements

IReportService..::.ListAvailableReports()()()

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IReportService.ListRenderingExtensions Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IReportService..::.ListRenderingExtensions Method
ReportServiceBase Class See Also Send Feedback
Retrieves the list of available rendering extensions. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
IList<ExtensionInfo> IReportService.ListRenderingExtensions()
Visual Basic (Declaration)
Private Function ListRenderingExtensions As IList(Of ExtensionInfo)
    Implements IReportService.ListRenderingExtensions

Return Value

List of available rendering extensions.

Implements

IReportService..::.ListRenderingExtensions()()()

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IReportService.RenderAndCache Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IReportService..::.RenderAndCache Method
ReportServiceBase Class See Also Send Feedback
Renders a report and stores the result in the current session. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
RenderingSessionInfo IReportService.RenderAndCache(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameterValues
)
Visual Basic (Declaration)
Private Function RenderAndCache ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameterValues As NameValueDictionary _
) As RenderingSessionInfo Implements IReportService.RenderAndCache

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with setting for the current render format.
parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with values for the report parameters.

Return Value

A RenderingSessionInfo that contains the result of the rendering operation.

Implements

IReportService..::.RenderAndCache(String, String, NameValueDictionary, NameValueDictionary)

Remarks

Requires ASP.NET session.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IResourceService.Export Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IResourceService..::.Export Method
ReportServiceBase Class See Also Send Feedback
Retrieves a report document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream IResourceService.Export(
    string format,
    string report,
    string deviceInfo,
    string parameterValues
)
Visual Basic (Declaration)
Private Function Export ( _
    format As String, _
    report As String, _
    deviceInfo As String, _
    parameterValues As String _
) As Stream Implements IResourceService.Export

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: System..::.String
JSON-formatted dictionary (key/value pairs) with DeviceInfo settings for the current render format.
parameterValues
Type: System..::.String
JSON-formatter (key/value pairs) with the parameter values for the current report.

Implements

IResourceService..::.Export(String, String, String, String)

Remarks

Requires HTTP GET request.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IResourceService.ExportCachedReport Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IResourceService..::.ExportCachedReport Method
ReportServiceBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream IResourceService.ExportCachedReport(
    string instanceID,
    string format,
    string deviceInfo
)
Visual Basic (Declaration)
Private Function ExportCachedReport ( _
    instanceID As String, _
    format As String, _
    deviceInfo As String _
) As Stream Implements IResourceService.ExportCachedReport

Parameters

instanceID
Type: System..::.String
format
Type: System..::.String
deviceInfo
Type: System..::.String

Implements

IResourceService..::.ExportCachedReport(String, String, String)

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


IResourceService.GetRenderStream Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.IResourceService..::.GetRenderStream Method
ReportServiceBase Class See Also Send Feedback
Retrieves a render stream created during a report rendering session.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
Stream IResourceService.GetRenderStream(
    string instanceID,
    string name
)
Visual Basic (Declaration)
Private Function GetRenderStream ( _
    instanceID As String, _
    name As String _
) As Stream Implements IResourceService.GetRenderStream

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session that resource belongs to.
name
Type: System..::.String
The name of the resource.

Implements

IResourceService..::.GetRenderStream(String, String)

Remarks

Requires HTTP GET request.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


Render Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.Render Method
ReportServiceBase Class See Also Send Feedback
Renders a report and returns the generated document.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public RenderingResult Render(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameterValues
)
Visual Basic (Declaration)
Public Function Render ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameterValues As NameValueDictionary _
) As RenderingResult

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with setting for the current render format.
parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
A dictionary with values for the report parameters.

Return Value

A RenderingResult that contains the generated document bytes and info.

Implements

IReportService..::.Render(String, String, NameValueDictionary, NameValueDictionary)

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


SetState Method

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.SetState Method
ReportServiceBase Class See Also Send Feedback
Adds a value to the internal storage.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected virtual void SetState(
    string name,
    Object value
)
Visual Basic (Declaration)
Protected Overridable Sub SetState ( _
    name As String, _
    value As Object _
)

Parameters

name
Type: System..::.String
The key name of the state value.
value
Type: System..::.Object
The state value with the specified name.

Remarks

The internal storage represents a central place for storing shared data between the service calls.

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


ReportServiceBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportServiceBase Properties
ReportServiceBase Class See Also Send Feedback

The ReportServiceBase type exposes the following members.

Properties

Name | Description
BaseAddress | When implemented, returns the base address of the Telerik ReportService that will be used as a base Uri for the resources
ReportResolver |

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


BaseAddress Property

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.BaseAddress Property
ReportServiceBase Class See Also Send Feedback
When implemented, returns the base address of the Telerik ReportService that will be used as a base Uri for the resources

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected abstract Uri BaseAddress { get; }
Visual Basic (Declaration)
Protected MustOverride ReadOnly Property BaseAddress As Uri

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


ReportResolver Property

[image]

Telerik Reporting Q2 2012
ReportServiceBase..::.ReportResolver Property
ReportServiceBase Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public IReportResolver ReportResolver { get; set; }
Visual Basic (Declaration)
Public Property ReportResolver As IReportResolver

See Also

ReportServiceBase Class
Telerik.Reporting.Service Namespace


ReportServiceOperationException Class

[image]

Telerik Reporting Q2 2012
ReportServiceOperationException Class
Members See Also Send Feedback
Represents an error occurred during a Report Service operation.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportServiceOperationException : Exception
Visual Basic (Declaration)
Public Class ReportServiceOperationException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Telerik.Reporting.Service..::.ReportServiceOperationException

See Also

ReportServiceOperationException Members
Telerik.Reporting.Service Namespace


ReportServiceOperationException Members

[image] [image]

Telerik Reporting Q2 2012
ReportServiceOperationException Members
ReportServiceOperationException Class Constructors See Also Send Feedback

Constructors

Name | Description
ReportServiceOperationException | Overloaded.

See Also

ReportServiceOperationException Class
Telerik.Reporting.Service Namespace


ReportServiceOperationException Constructor

[image] [image]

Telerik Reporting Q2 2012
ReportServiceOperationException Constructor
ReportServiceOperationException Class See Also Send Feedback

Overload List

Name | Description
ReportServiceOperationException()()() | Creates an instance of the ReportServiceOperationException class.
ReportServiceOperationException(String) | Creates an instance of the ReportServiceOperationException class.

See Also

ReportServiceOperationException Class
ReportServiceOperationException Members
Telerik.Reporting.Service Namespace


ReportServiceOperationException Constructor

[image]

Telerik Reporting Q2 2012
ReportServiceOperationException Constructor
ReportServiceOperationException Class See Also Send Feedback
Creates an instance of the ReportServiceOperationException class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceOperationException()
Visual Basic (Declaration)
Public Sub New

See Also

ReportServiceOperationException Class
ReportServiceOperationException Overload
Telerik.Reporting.Service Namespace


ReportServiceOperationException Constructor (String)

[image]

Telerik Reporting Q2 2012
ReportServiceOperationException Constructor (String)
ReportServiceOperationException Class See Also Send Feedback
Creates an instance of the ReportServiceOperationException class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceOperationException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::.String
The message that describes the error.

See Also

ReportServiceOperationException Class
ReportServiceOperationException Overload
Telerik.Reporting.Service Namespace


ReportTypeResolver Class

[image]

Telerik Reporting Q2 2012
ReportTypeResolver Class
Members See Also Send Feedback
Resolves IReportDocument from assembly qualified name

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public class ReportTypeResolver : ReportResolverBase
Visual Basic (Declaration)
Public Class ReportTypeResolver _
    Inherits ReportResolverBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ReportResolverBase
Telerik.Reporting.Service..::.ReportTypeResolver

See Also

ReportTypeResolver Members
Telerik.Reporting.Service Namespace


ReportTypeResolver Members

[image] [image]

Telerik Reporting Q2 2012
ReportTypeResolver Members
ReportTypeResolver Class Constructors Methods Explicit Interface Implementations See Also Send Feedback

The ReportTypeResolver type exposes the following members.

Constructors

Name | Description
ReportTypeResolver | Initializes a new instance of the ReportTypeResolver class.

Methods

Name | Description
ResolveReport | (Overrides ReportResolverBase..::.ResolveReport(String).)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportTypeResolver Class
Telerik.Reporting.Service Namespace


ReportTypeResolver Constructor

[image]

Telerik Reporting Q2 2012
ReportTypeResolver Constructor
ReportTypeResolver Class See Also Send Feedback
Initializes a new instance of the ReportTypeResolver class.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
public ReportTypeResolver(
    IReportResolver parentResolver
)
Visual Basic (Declaration)
Public Sub New ( _
    parentResolver As IReportResolver _
)

Parameters

parentResolver
Type: Telerik.Reporting.Service..::.IReportResolver
The fallback parent resolver.

See Also

ReportTypeResolver Class
Telerik.Reporting.Service Namespace


ReportTypeResolver Methods

[image] [image]

Telerik Reporting Q2 2012
ReportTypeResolver Methods
ReportTypeResolver Class See Also Send Feedback

The ReportTypeResolver type exposes the following members.

Methods

Name | Description
ResolveReport | (Overrides ReportResolverBase..::.ResolveReport(String).)

Explicit Interface Implementations

Name | Description
IReportResolver..::.Resolve | (Inherited from ReportResolverBase.)

See Also

ReportTypeResolver Class
Telerik.Reporting.Service Namespace


ResolveReport Method

[image]

Telerik Reporting Q2 2012
ReportTypeResolver..::.ResolveReport Method
ReportTypeResolver Class See Also Send Feedback

Namespace: Telerik.Reporting.Service
Assembly: Telerik.Reporting.Service (in Telerik.Reporting.Service.dll)

Syntax

C#
protected override ReportSource ResolveReport(
    string report
)
Visual Basic (Declaration)
Protected Overrides Function ResolveReport ( _
    report As String _
) As ReportSource

Parameters

report
Type: System..::.String

See Also

ReportTypeResolver Class
Telerik.Reporting.Service Namespace


ServiceOperationResultBase Class

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase Class
Members See Also Send Feedback
Represents the result of a service operation

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ServiceOperationResultBase
Visual Basic (Declaration)
Public Class ServiceOperationResultBase

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.Service..::.ServiceOperationResultBase
Telerik.Reporting.Service..::.PageInfo
Telerik.Reporting.Service..::.RenderingResult
Telerik.Reporting.Service..::.RenderingSessionInfo

See Also

ServiceOperationResultBase Members
Telerik.Reporting.Service Namespace


ServiceOperationResultBase Members

[image] [image]

Telerik Reporting Q2 2012
ServiceOperationResultBase Members
ServiceOperationResultBase Class Constructors Methods Properties See Also Send Feedback

The ServiceOperationResultBase type exposes the following members.

Constructors

Name | Description
ServiceOperationResultBase | Initializes a new instance of the ServiceOperationResultBase class

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error.
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error.

Properties

Name | Description
Error | Gets or sets the current error message for the current service operation.
HasError | Indicates whether the current operation has ended with error.

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


ServiceOperationResultBase Constructor

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase Constructor
ServiceOperationResultBase Class See Also Send Feedback
Initializes a new instance of the ServiceOperationResultBase class

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ServiceOperationResultBase()
Visual Basic (Declaration)
Public Sub New

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


ServiceOperationResultBase Methods

[image] [image]

Telerik Reporting Q2 2012
ServiceOperationResultBase Methods
ServiceOperationResultBase Class See Also Send Feedback

The ServiceOperationResultBase type exposes the following members.

Methods

Name | Description
RaiseExceptionIfNecessary | Throws an ReportServiceOperationException if the current operation has ended with an error.
ThrowOnError | Throws an ReportServiceOperationException if the current operation has ended with an error.

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


RaiseExceptionIfNecessary Method

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase..::.RaiseExceptionIfNecessary Method
ServiceOperationResultBase Class See Also Send Feedback
Throws an ReportServiceOperationException if the current operation has ended with an error.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected void RaiseExceptionIfNecessary()
Visual Basic (Declaration)
Protected Sub RaiseExceptionIfNecessary

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


ThrowOnError Method

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase..::.ThrowOnError Method
ServiceOperationResultBase Class See Also Send Feedback
Throws an ReportServiceOperationException if the current operation has ended with an error.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void ThrowOnError()
Visual Basic (Declaration)
Public Sub ThrowOnError

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


ServiceOperationResultBase Properties

[image] [image]

Telerik Reporting Q2 2012
ServiceOperationResultBase Properties
ServiceOperationResultBase Class See Also Send Feedback

The ServiceOperationResultBase type exposes the following members.

Properties

Name | Description
Error | Gets or sets the current error message for the current service operation.
HasError | Indicates whether the current operation has ended with error.

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


Error Property

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase..::.Error Property
ServiceOperationResultBase Class See Also Send Feedback
Gets or sets the current error message for the current service operation.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Error { get; set; }
Visual Basic (Declaration)
Public Property Error As String

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


HasError Property

[image]

Telerik Reporting Q2 2012
ServiceOperationResultBase..::.HasError Property
ServiceOperationResultBase Class See Also Send Feedback
Indicates whether the current operation has ended with error.

Namespace: Telerik.Reporting.Service
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool HasError { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean

See Also

ServiceOperationResultBase Class
Telerik.Reporting.Service Namespace


Telerik.Reporting.Service.SilverlightClient Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.Service.SilverlightClient Namespace
Send Feedback

Classes

Class | Description
GetPageEventArgs | Provides data from the GetPageCompleted event.
GetReportParametersEventArgs | Provides data from the GetReportParametersCompleted event.
ListAvailableReportsEventArgs | Provides data from the ListAvailableReportsCompleted event.
ListRenderingExtensionsEventArgs | Provides data from the ListRenderingExtensionsCompleted event.
RenderAndCacheEventArgs | Provides data from the RenderAndCacheCompleted event.
RenderEventArgs | Provides data from the RenderCompleted event.
ReportServiceClient | The proxy to the Telerik Report Service.

Interfaces

Interface | Description
IReportService | The Telerik Report Service interface.


GetPageEventArgs Class

[image]

Telerik Reporting Q2 2012
GetPageEventArgs Class
Members See Also Send Feedback
Provides data from the GetPageCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class GetPageEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetPageEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.GetPageEventArgs

See Also

GetPageEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
GetPageEventArgs Members
GetPageEventArgs Class Properties See Also Send Feedback

The GetPageEventArgs type exposes the following members.

Properties

Name | Description
PageInfo | A PageInfo.

See Also

GetPageEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
GetPageEventArgs Properties
GetPageEventArgs Class See Also Send Feedback

The GetPageEventArgs type exposes the following members.

Properties

Name | Description
PageInfo | A PageInfo.

See Also

GetPageEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


PageInfo Property

[image]

Telerik Reporting Q2 2012
GetPageEventArgs..::.PageInfo Property
GetPageEventArgs Class See Also Send Feedback
A PageInfo.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public PageInfo PageInfo { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageInfo As PageInfo

See Also

GetPageEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersEventArgs Class

[image]

Telerik Reporting Q2 2012
GetReportParametersEventArgs Class
Members See Also Send Feedback
Provides data from the GetReportParametersCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class GetReportParametersEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class GetReportParametersEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.GetReportParametersEventArgs

See Also

GetReportParametersEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
GetReportParametersEventArgs Members
GetReportParametersEventArgs Class Properties See Also Send Feedback

The GetReportParametersEventArgs type exposes the following members.

Properties

Name | Description
Parameters | A list of Parameters.

See Also

GetReportParametersEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
GetReportParametersEventArgs Properties
GetReportParametersEventArgs Class See Also Send Feedback

The GetReportParametersEventArgs type exposes the following members.

Properties

Name | Description
Parameters | A list of Parameters.

See Also

GetReportParametersEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
GetReportParametersEventArgs..::.Parameters Property
GetReportParametersEventArgs Class See Also Send Feedback
A list of Parameters.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<Parameter> Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As List(Of Parameter)

See Also

GetReportParametersEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


IReportService Interface

[image]

Telerik Reporting Q2 2012
IReportService Interface
Members See Also Send Feedback
The Telerik Report Service interface.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public interface IReportService
Visual Basic (Declaration)
Public Interface IReportService

See Also

IReportService Members
Telerik.Reporting.Service.SilverlightClient Namespace


IReportService Members

[image] [image]

Telerik Reporting Q2 2012
IReportService Members
IReportService Interface Methods See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginGetPage | Starts an asynchronous GetPage operation. This operation is intended for internal use only.
BeginGetReportParameters | Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.
BeginListAvailableReports | Starts an asynchronous ListAvailableReports operation.
BeginListRenderingExtensions | Starts an asynchronous ListRenderingExtensions operation.
BeginRender | Starts an asynchronous Render operation.
BeginRenderAndCache | Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.
EndGetPage | Waits for the pending asynchronous GetPage to complete.
EndGetReportParameters | Waits for the pending asynchronous GetReportParameters to complete.
EndListAvailableReports | Waits for the pending asynchronous ListAvailableReports to complete.
EndListRenderingExtensions | Waits for the pending asynchronous ListRenderingExtensions to complete.
EndRender | Waits for the pending asynchronous Render to complete.
EndRenderAndCache | Waits for the pending asynchronous RenderAndCache to complete.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


IReportService Methods

[image] [image]

Telerik Reporting Q2 2012
IReportService Methods
IReportService Interface See Also Send Feedback

The IReportService type exposes the following members.

Methods

Name | Description
BeginGetPage | Starts an asynchronous GetPage operation. This operation is intended for internal use only.
BeginGetReportParameters | Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.
BeginListAvailableReports | Starts an asynchronous ListAvailableReports operation.
BeginListRenderingExtensions | Starts an asynchronous ListRenderingExtensions operation.
BeginRender | Starts an asynchronous Render operation.
BeginRenderAndCache | Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.
EndGetPage | Waits for the pending asynchronous GetPage to complete.
EndGetReportParameters | Waits for the pending asynchronous GetReportParameters to complete.
EndListAvailableReports | Waits for the pending asynchronous ListAvailableReports to complete.
EndListRenderingExtensions | Waits for the pending asynchronous ListRenderingExtensions to complete.
EndRender | Waits for the pending asynchronous Render to complete.
EndRenderAndCache | Waits for the pending asynchronous RenderAndCache to complete.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginGetPage Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginGetPage Method
IReportService Interface See Also Send Feedback
Starts an asynchronous GetPage operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginGetPage(
    string instanceID,
    int pageNumber,
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginGetPage ( _
    instanceID As String, _
    pageNumber As Integer, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to RenderAndCache operation.
pageNumber
Type: System..::.Int32
The serial number of the page to retrieve.
callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the GetPage is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous GetPage request from other requests.

Return Value

An IAsyncResult that represents the asynchronous GetPage, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginGetReportParameters Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginGetReportParameters Method
IReportService Interface See Also Send Feedback
Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginGetReportParameters(
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginGetReportParameters ( _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current device.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the GetReportParameters is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous GetReportParameters request from other requests.

Return Value

An IAsyncResult that represents the asynchronous GetReportParameters, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginListAvailableReports Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginListAvailableReports Method
IReportService Interface See Also Send Feedback
Starts an asynchronous ListAvailableReports operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginListAvailableReports(
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginListAvailableReports ( _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the ListAvailableReports is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous ListAvailableReports request from other requests.

Return Value

An IAsyncResult that represents the asynchronous ListAvailableReports, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginListRenderingExtensions Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginListRenderingExtensions Method
IReportService Interface See Also Send Feedback
Starts an asynchronous ListRenderingExtensions operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginListRenderingExtensions(
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginListRenderingExtensions ( _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the ListRenderingExtensions is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous ListRenderingExtensions request from other requests.

Return Value

An IAsyncResult that represents the asynchronous ListRenderingExtensions, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginRender Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginRender Method
IReportService Interface See Also Send Feedback
Starts an asynchronous Render operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginRender(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginRender ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with setting for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the Render is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous Render request from other requests.

Return Value

An IAsyncResult that represents the asynchronous Render, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


BeginRenderAndCache Method

[image]

Telerik Reporting Q2 2012
IReportService..::.BeginRenderAndCache Method
IReportService Interface See Also Send Feedback
Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IAsyncResult BeginRenderAndCache(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    AsyncCallback callback,
    Object state
)
Visual Basic (Declaration)
Function BeginRenderAndCache ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    callback As AsyncCallback, _
    state As Object _
) As IAsyncResult

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with setting for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
callback
Type: System..::.AsyncCallback
An optional asynchronous callback, to be called when the RenderAndCache is complete.
state
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous RenderAndCache request from other requests.

Return Value

An IAsyncResult that represents the asynchronous RenderAndCache, which could still be pending.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndGetPage Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndGetPage Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous GetPage to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
PageInfo EndGetPage(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetPage ( _
    result As IAsyncResult _
) As PageInfo

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A PageInfo.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndGetReportParameters Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndGetReportParameters Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous GetReportParameters to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
List<Parameter> EndGetReportParameters(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndGetReportParameters ( _
    result As IAsyncResult _
) As List(Of Parameter)

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A list of Parameter.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndListAvailableReports Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndListAvailableReports Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous ListAvailableReports to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IList<ReportInfo> EndListAvailableReports(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndListAvailableReports ( _
    result As IAsyncResult _
) As IList(Of ReportInfo)

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A list with available ReportInfo

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndListRenderingExtensions Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndListRenderingExtensions Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous ListRenderingExtensions to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
IList<ExtensionInfo> EndListRenderingExtensions(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndListRenderingExtensions ( _
    result As IAsyncResult _
) As IList(Of ExtensionInfo)

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A list with available ExtensionInfo

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndRender Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndRender Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous Render to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
RenderingResult EndRender(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndRender ( _
    result As IAsyncResult _
) As RenderingResult

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A RenderingResult.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


EndRenderAndCache Method

[image]

Telerik Reporting Q2 2012
IReportService..::.EndRenderAndCache Method
IReportService Interface See Also Send Feedback
Waits for the pending asynchronous RenderAndCache to complete.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
RenderingSessionInfo EndRenderAndCache(
    IAsyncResult result
)
Visual Basic (Declaration)
Function EndRenderAndCache ( _
    result As IAsyncResult _
) As RenderingSessionInfo

Parameters

result
Type: System..::.IAsyncResult
The reference to the pending asynchronous request to finish.

Return Value

A RenderingSessionInfo.

See Also

IReportService Interface
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsEventArgs Class

[image]

Telerik Reporting Q2 2012
ListAvailableReportsEventArgs Class
Members See Also Send Feedback
Provides data from the ListAvailableReportsCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ListAvailableReportsEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ListAvailableReportsEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.ListAvailableReportsEventArgs

See Also

ListAvailableReportsEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ListAvailableReportsEventArgs Members
ListAvailableReportsEventArgs Class Properties See Also Send Feedback

The ListAvailableReportsEventArgs type exposes the following members.

Properties

Name | Description
Reports | A list of ReportInfos.

See Also

ListAvailableReportsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ListAvailableReportsEventArgs Properties
ListAvailableReportsEventArgs Class See Also Send Feedback

The ListAvailableReportsEventArgs type exposes the following members.

Properties

Name | Description
Reports | A list of ReportInfos.

See Also

ListAvailableReportsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


Reports Property

[image]

Telerik Reporting Q2 2012
ListAvailableReportsEventArgs..::.Reports Property
ListAvailableReportsEventArgs Class See Also Send Feedback
A list of ReportInfos.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<ReportInfo> Reports { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reports As IList(Of ReportInfo)

See Also

ListAvailableReportsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsEventArgs Class

[image]

Telerik Reporting Q2 2012
ListRenderingExtensionsEventArgs Class
Members See Also Send Feedback
Provides data from the ListRenderingExtensionsCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ListRenderingExtensionsEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class ListRenderingExtensionsEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.ListRenderingExtensionsEventArgs

See Also

ListRenderingExtensionsEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ListRenderingExtensionsEventArgs Members
ListRenderingExtensionsEventArgs Class Properties See Also Send Feedback

The ListRenderingExtensionsEventArgs type exposes the following members.

Properties

Name | Description
Extensions | A list of ExtensionInfos.

See Also

ListRenderingExtensionsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ListRenderingExtensionsEventArgs Properties
ListRenderingExtensionsEventArgs Class See Also Send Feedback

The ListRenderingExtensionsEventArgs type exposes the following members.

Properties

Name | Description
Extensions | A list of ExtensionInfos.

See Also

ListRenderingExtensionsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


Extensions Property

[image]

Telerik Reporting Q2 2012
ListRenderingExtensionsEventArgs..::.Extensions Property
ListRenderingExtensionsEventArgs Class See Also Send Feedback
A list of ExtensionInfos.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<ExtensionInfo> Extensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Extensions As IList(Of ExtensionInfo)

See Also

ListRenderingExtensionsEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheEventArgs Class

[image]

Telerik Reporting Q2 2012
RenderAndCacheEventArgs Class
Members See Also Send Feedback
Provides data from the RenderAndCacheCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class RenderAndCacheEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class RenderAndCacheEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.RenderAndCacheEventArgs

See Also

RenderAndCacheEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
RenderAndCacheEventArgs Members
RenderAndCacheEventArgs Class Properties See Also Send Feedback

The RenderAndCacheEventArgs type exposes the following members.

Properties

Name | Description
RenderingResult | A RenderingSessionInfo.

See Also

RenderAndCacheEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
RenderAndCacheEventArgs Properties
RenderAndCacheEventArgs Class See Also Send Feedback

The RenderAndCacheEventArgs type exposes the following members.

Properties

Name | Description
RenderingResult | A RenderingSessionInfo.

See Also

RenderAndCacheEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderingResult Property

[image]

Telerik Reporting Q2 2012
RenderAndCacheEventArgs..::.RenderingResult Property
RenderAndCacheEventArgs Class See Also Send Feedback
A RenderingSessionInfo.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public RenderingSessionInfo RenderingResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property RenderingResult As RenderingSessionInfo

See Also

RenderAndCacheEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderEventArgs Class

[image]

Telerik Reporting Q2 2012
RenderEventArgs Class
Members See Also Send Feedback
Provides data from the RenderCompleted event.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class RenderEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class RenderEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
Telerik.Reporting.Service.SilverlightClient..::.RenderEventArgs

See Also

RenderEventArgs Members
Telerik.Reporting.Service.SilverlightClient Namespace


RenderEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
RenderEventArgs Members
RenderEventArgs Class Properties See Also Send Feedback

The RenderEventArgs type exposes the following members.

Properties

Name | Description
RenderingResult | A RenderingResult.

See Also

RenderEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
RenderEventArgs Properties
RenderEventArgs Class See Also Send Feedback

The RenderEventArgs type exposes the following members.

Properties

Name | Description
RenderingResult | A RenderingResult.

See Also

RenderEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderingResult Property

[image]

Telerik Reporting Q2 2012
RenderEventArgs..::.RenderingResult Property
RenderEventArgs Class See Also Send Feedback
A RenderingResult.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public RenderingResult RenderingResult { get; }
Visual Basic (Declaration)
Public ReadOnly Property RenderingResult As RenderingResult

See Also

RenderEventArgs Class
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Class

[image]

Telerik Reporting Q2 2012
ReportServiceClient Class
Members See Also Send Feedback
The proxy to the Telerik Report Service.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportServiceClient : ClientBase<IReportService>
Visual Basic (Declaration)
Public Class ReportServiceClient _
    Inherits ClientBase(Of IReportService)

Inheritance Hierarchy

System..::.Object
System.ServiceModel..::.ClientBase <(Of <(<' IReportService >)>)>
Telerik.Reporting.Service.SilverlightClient..::.ReportServiceClient

See Also

ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Members

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient Members
ReportServiceClient Class Constructors Methods Events See Also Send Feedback

The ReportServiceClient type exposes the following members.

Constructors

Name | Description
ReportServiceClient | Overloaded.

Methods

Name | Description
GetPageAsync | Overloaded.
GetReportParametersAsync | Overloaded.
ListAvailableReportsAsync | Overloaded.
ListRenderingExtensionsAsync | Overloaded.
RenderAndCacheAsync | Overloaded.
RenderAsync | Overloaded.

Events

Name | Description
GetPageCompleted | Occurs when the GetPage operation is completed. This event is intended for internal use only.
GetReportParametersCompleted | Occurs when the GetReportParameters operation is completed. This event is intended for internal use only.
ListAvailableReportsCompleted | Occurs when the ListAvailableReports operation is completed.
ListRenderingExtensionsCompleted | Occurs when the ListRenderingExtensions operation is completed.
RenderAndCacheCompleted | Occurs when the RenderAndCache operation is completed. This event is intended for internal use only.
RenderCompleted | Occurs when the Render operation is completed.

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ReportServiceClient()()() | Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class using the default target endpoint from the application configuration file.
ReportServiceClient(String) | Initializes a new instance of the ReportServiceClient class using the configuration information specified in the application configuration file by endpointConfigurationName.
ReportServiceClient(Uri) | Initializes a new instance of the ReportServiceClient class using a specified binding and target address and BasicHttpBinding.
ReportServiceClient(Binding, EndpointAddress) | Initializes a new instance of the ReportServiceClient class using a specified binding and target address.
ReportServiceClient(String, EndpointAddress) | Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class using the specified target address and endpoint information.
ReportServiceClient(String, String) | Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class using the default target endpoint from the application configuration file.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient()
Visual Basic (Declaration)
Public Sub New

Exceptions

Exception | Condition
System..::.InvalidOperationException | Either there is no default endpoint information in the configuration file, more than one endpoint in the file, or no configuration file.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor (String)

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor (String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class using the configuration information specified in the application configuration file by endpointConfigurationName.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String _
)

Parameters

endpointConfigurationName
Type: System..::.String
The name of the endpoint in the application configuration file.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor (Uri)

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor (Uri)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class using a specified binding and target address and BasicHttpBinding.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient(
    Uri reportServiceUri
)
Visual Basic (Declaration)
Public Sub New ( _
    reportServiceUri As Uri _
)

Parameters

reportServiceUri
Type: System..::.Uri
The address of the service endpoint.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor (Binding, EndpointAddress)

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor (Binding, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ReportServiceClient class using a specified binding and target address.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient(
    Binding binding,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    binding As Binding, _
    remoteAddress As EndpointAddress _
)

Parameters

binding
Type: System.ServiceModel.Channels..::.Binding
The binding used to configure the way that calls are made to the service.
remoteAddress
Type: System.ServiceModel..::.EndpointAddress
The address of the service endpoint.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor (String, EndpointAddress)

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor (String, EndpointAddress)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class using the specified target address and endpoint information.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    EndpointAddress remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As EndpointAddress _
)

Parameters

endpointConfigurationName
Type: System..::.String
The name of the endpoint in the application configuration file.
remoteAddress
Type: System.ServiceModel..::.EndpointAddress
The address of the service.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The endpoint is null.
System..::.ArgumentNullException | The remote address is null.
System..::.InvalidOperationException | The endpoint cannot be found or the endpoint contract is not valid.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Constructor (String, String)

[image]

Telerik Reporting Q2 2012
ReportServiceClient Constructor (String, String)
ReportServiceClient Class See Also Send Feedback
Initializes a new instance of the ClientBase<(Of <(TChannel>)>) class.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportServiceClient(
    string endpointConfigurationName,
    string remoteAddress
)
Visual Basic (Declaration)
Public Sub New ( _
    endpointConfigurationName As String, _
    remoteAddress As String _
)

Parameters

endpointConfigurationName
Type: System..::.String
The name of the endpoint in the application configuration file.
remoteAddress
Type: System..::.String
The address of the service.

Exceptions

Exception | Condition
System..::.ArgumentNullException | The endpoint is null.
System..::.ArgumentNullException | The remote address is null.
System..::.InvalidOperationException | The endpoint cannot be found or the endpoint contract is not valid.

See Also

ReportServiceClient Class
ReportServiceClient Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Methods

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient Methods
ReportServiceClient Class See Also Send Feedback

Methods

Name | Description
GetPageAsync | Overloaded.
GetReportParametersAsync | Overloaded.
ListAvailableReportsAsync | Overloaded.
ListRenderingExtensionsAsync | Overloaded.
RenderAndCacheAsync | Overloaded.
RenderAsync | Overloaded.

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetPageAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetPageAsync(String, Int32) | Starts an asynchronous GetPage operation. This operation is intended for internal use only.
GetPageAsync(String, Int32, Object) | Starts an asynchronous GetPage operation. This operation is intended for internal use only.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageAsync Method (String, Int32)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetPageAsync Method (String, Int32)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous GetPage operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void GetPageAsync(
    string instanceID,
    int pageNumber
)
Visual Basic (Declaration)
Public Sub GetPageAsync ( _
    instanceID As String, _
    pageNumber As Integer _
)

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to RenderAndCache operation.
pageNumber
Type: System..::.Int32
The serial number of the page to retrieve.

See Also

ReportServiceClient Class
GetPageAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageAsync Method (String, Int32, Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetPageAsync Method (String, Int32, Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous GetPage operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void GetPageAsync(
    string instanceID,
    int pageNumber,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetPageAsync ( _
    instanceID As String, _
    pageNumber As Integer, _
    userState As Object _
)

Parameters

instanceID
Type: System..::.String
The unique identifier of the rendering session as returned by a previous call to RenderAndCache operation.
pageNumber
Type: System..::.Int32
The serial number of the page to retrieve.
userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous GetPage request from other requests.

See Also

ReportServiceClient Class
GetPageAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetReportParametersAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
GetReportParametersAsync(String, NameValueDictionary, NameValueDictionary) | Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.
GetReportParametersAsync(String, NameValueDictionary, NameValueDictionary, Object) | Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersAsync Method (String, NameValueDictionary, NameValueDictionary)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetReportParametersAsync Method (String, NameValueDictionary, NameValueDictionary)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void GetReportParametersAsync(
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Public Sub GetReportParametersAsync ( _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
)

Parameters

report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current device.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.

See Also

ReportServiceClient Class
GetReportParametersAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersAsync Method (String, NameValueDictionary, NameValueDictionary, Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetReportParametersAsync Method (String, NameValueDictionary, NameValueDictionary, Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous GetReportParameters operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void GetReportParametersAsync(
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    Object userState
)
Visual Basic (Declaration)
Public Sub GetReportParametersAsync ( _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    userState As Object _
)

Parameters

report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current device.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous GetReportParameters request from other requests.

See Also

ReportServiceClient Class
GetReportParametersAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListAvailableReportsAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ListAvailableReportsAsync()()() | Starts an asynchronous ListAvailableReports operation.
ListAvailableReportsAsync(Object) | Starts an asynchronous ListAvailableReports operation.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsAsync Method

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListAvailableReportsAsync Method
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous ListAvailableReports operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void ListAvailableReportsAsync()
Visual Basic (Declaration)
Public Sub ListAvailableReportsAsync

See Also

ReportServiceClient Class
ListAvailableReportsAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsAsync Method (Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListAvailableReportsAsync Method (Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous ListAvailableReports operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void ListAvailableReportsAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub ListAvailableReportsAsync ( _
    userState As Object _
)

Parameters

userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous ListAvailableReports request from other requests.

See Also

ReportServiceClient Class
ListAvailableReportsAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListRenderingExtensionsAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
ListRenderingExtensionsAsync()()() | Starts an asynchronous ListRenderingExtensions operation.
ListRenderingExtensionsAsync(Object) | Starts an asynchronous ListRenderingExtensions operation.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsAsync Method

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListRenderingExtensionsAsync Method
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous ListRenderingExtensions operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void ListRenderingExtensionsAsync()
Visual Basic (Declaration)
Public Sub ListRenderingExtensionsAsync

See Also

ReportServiceClient Class
ListRenderingExtensionsAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsAsync Method (Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListRenderingExtensionsAsync Method (Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous ListRenderingExtensions operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void ListRenderingExtensionsAsync(
    Object userState
)
Visual Basic (Declaration)
Public Sub ListRenderingExtensionsAsync ( _
    userState As Object _
)

Parameters

userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous ListRenderingExtensions request from other requests.

See Also

ReportServiceClient Class
ListRenderingExtensionsAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAndCacheAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
RenderAndCacheAsync(String, String, NameValueDictionary, NameValueDictionary) | Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.
RenderAndCacheAsync(String, String, NameValueDictionary, NameValueDictionary, Object) | Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheAsync Method (String, String, NameValueDictionary, NameValueDictionary)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAndCacheAsync Method (String, String, NameValueDictionary, NameValueDictionary)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void RenderAndCacheAsync(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Public Sub RenderAndCacheAsync ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
)

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with setting for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.

See Also

ReportServiceClient Class
RenderAndCacheAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheAsync Method (String, String, NameValueDictionary, NameValueDictionary, Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAndCacheAsync Method (String, String, NameValueDictionary, NameValueDictionary, Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous RenderAndCache operation. This operation is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void RenderAndCacheAsync(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    Object userState
)
Visual Basic (Declaration)
Public Sub RenderAndCacheAsync ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    userState As Object _
)

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous RenderAndCache request from other requests.

See Also

ReportServiceClient Class
RenderAndCacheAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAsync Method

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAsync Method
ReportServiceClient Class See Also Send Feedback

Overload List

Name | Description
RenderAsync(String, String, NameValueDictionary, NameValueDictionary) | Starts an asynchronous Render operation.
RenderAsync(String, String, NameValueDictionary, NameValueDictionary, Object) | Starts an asynchronous Render operation.

See Also

ReportServiceClient Class
ReportServiceClient Members
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAsync Method (String, String, NameValueDictionary, NameValueDictionary)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAsync Method (String, String, NameValueDictionary, NameValueDictionary)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous Render operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void RenderAsync(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary _
)

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.

See Also

ReportServiceClient Class
RenderAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAsync Method (String, String, NameValueDictionary, NameValueDictionary, Object)

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAsync Method (String, String, NameValueDictionary, NameValueDictionary, Object)
ReportServiceClient Class See Also Send Feedback
Starts an asynchronous Render operation.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public void RenderAsync(
    string format,
    string report,
    NameValueDictionary deviceInfo,
    NameValueDictionary parameters,
    Object userState
)
Visual Basic (Declaration)
Public Sub RenderAsync ( _
    format As String, _
    report As String, _
    deviceInfo As NameValueDictionary, _
    parameters As NameValueDictionary, _
    userState As Object _
)

Parameters

format
Type: System..::.String
The render format.
report
Type: System..::.String
The AssemblyQualifiedName of the report type to render.
deviceInfo
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with settings for the current render format.
parameters
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with values for the report parameters.
userState
Type: System..::.Object
A user-provided object that distinguishes this particular asynchronous Render request from other requests.

See Also

ReportServiceClient Class
RenderAsync Overload
Telerik.Reporting.Service.SilverlightClient Namespace


ReportServiceClient Events

[image] [image]

Telerik Reporting Q2 2012
ReportServiceClient Events
ReportServiceClient Class See Also Send Feedback

The ReportServiceClient type exposes the following members.

Events

Name | Description
GetPageCompleted | Occurs when the GetPage operation is completed. This event is intended for internal use only.
GetReportParametersCompleted | Occurs when the GetReportParameters operation is completed. This event is intended for internal use only.
ListAvailableReportsCompleted | Occurs when the ListAvailableReports operation is completed.
ListRenderingExtensionsCompleted | Occurs when the ListRenderingExtensions operation is completed.
RenderAndCacheCompleted | Occurs when the RenderAndCache operation is completed. This event is intended for internal use only.
RenderCompleted | Occurs when the Render operation is completed.

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetPageCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetPageCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the GetPage operation is completed. This event is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<GetPageEventArgs> GetPageCompleted
Visual Basic (Declaration)
Public Event GetPageCompleted As EventHandler(Of GetPageEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


GetReportParametersCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.GetReportParametersCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the GetReportParameters operation is completed. This event is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<GetReportParametersEventArgs> GetReportParametersCompleted
Visual Basic (Declaration)
Public Event GetReportParametersCompleted As EventHandler(Of GetReportParametersEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


ListAvailableReportsCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListAvailableReportsCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the ListAvailableReports operation is completed.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<ListAvailableReportsEventArgs> ListAvailableReportsCompleted
Visual Basic (Declaration)
Public Event ListAvailableReportsCompleted As EventHandler(Of ListAvailableReportsEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


ListRenderingExtensionsCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.ListRenderingExtensionsCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the ListRenderingExtensions operation is completed.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<ListRenderingExtensionsEventArgs> ListRenderingExtensionsCompleted
Visual Basic (Declaration)
Public Event ListRenderingExtensionsCompleted As EventHandler(Of ListRenderingExtensionsEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderAndCacheCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderAndCacheCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the RenderAndCache operation is completed. This event is intended for internal use only.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<RenderAndCacheEventArgs> RenderAndCacheCompleted
Visual Basic (Declaration)
Public Event RenderAndCacheCompleted As EventHandler(Of RenderAndCacheEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


RenderCompleted Event

[image]

Telerik Reporting Q2 2012
ReportServiceClient..::.RenderCompleted Event
ReportServiceClient Class See Also Send Feedback
Occurs when the Render operation is completed.

Namespace: Telerik.Reporting.Service.SilverlightClient
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event EventHandler<RenderEventArgs> RenderCompleted
Visual Basic (Declaration)
Public Event RenderCompleted As EventHandler(Of RenderEventArgs)

See Also

ReportServiceClient Class
Telerik.Reporting.Service.SilverlightClient Namespace


Telerik.Reporting.XmlSerialization Namespace

[image]

Telerik Reporting Q2 2012
Telerik.Reporting.XmlSerialization Namespace
Send Feedback

Classes

Class | Description
ReportXmlSerializer |


ReportXmlSerializer Class

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer Class
Members See Also Send Feedback

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public class ReportXmlSerializer
Visual Basic (Declaration)
Public Class ReportXmlSerializer

Inheritance Hierarchy

System..::.Object
Telerik.Reporting.XmlSerialization..::.ReportXmlSerializer

See Also

ReportXmlSerializer Members
Telerik.Reporting.XmlSerialization Namespace


ReportXmlSerializer Members

[image] [image]

Telerik Reporting Q2 2012
ReportXmlSerializer Members
ReportXmlSerializer Class Constructors Methods See Also Send Feedback

The ReportXmlSerializer type exposes the following members.

Constructors

Name | Description
ReportXmlSerializer | Initializes a new instance of the ReportXmlSerializer class.

Methods

Name | Description
Deserialize | Overloaded.
Serialize | Overloaded.

See Also

ReportXmlSerializer Class
Telerik.Reporting.XmlSerialization Namespace


ReportXmlSerializer Constructor

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer Constructor
ReportXmlSerializer Class See Also Send Feedback
Initializes a new instance of the ReportXmlSerializer class.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public ReportXmlSerializer()
Visual Basic (Declaration)
Public Sub New

See Also

ReportXmlSerializer Class
Telerik.Reporting.XmlSerialization Namespace


ReportXmlSerializer Methods

[image] [image]

Telerik Reporting Q2 2012
ReportXmlSerializer Methods
ReportXmlSerializer Class See Also Send Feedback

Methods

Name | Description
Deserialize | Overloaded.
Serialize | Overloaded.

See Also

ReportXmlSerializer Class
Telerik.Reporting.XmlSerialization Namespace


Deserialize Method

[image] [image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Deserialize Method
ReportXmlSerializer Class See Also Send Feedback

Overload List

Name | Description
Deserialize(Stream) | Deserializes the XML document contained by the specified Stream.
Deserialize(TextReader) | Deserializes the XML document contained by the specified TextReader.
Deserialize(String) | Deserializes the XML document from the specified URI.
Deserialize(XmlReader) | Deserializes the XML document contained by the specified XmlReader.

See Also

ReportXmlSerializer Class
ReportXmlSerializer Members
Telerik.Reporting.XmlSerialization Namespace


Deserialize Method (Stream)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Deserialize Method (Stream)
ReportXmlSerializer Class Example See Also Send Feedback
Deserializes the XML document contained by the specified Stream.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Deserialize(
    Stream stream
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    stream As Stream _
) As Object

Parameters

stream
Type: System.IO..::.Stream
The Stream that contains the XML document to deserialize.

Return Value

The Telerik.Reporting object being deserialized.

Remarks

Use the stream parameter to specify an object that derives from the Stream class, which is designed to write to streams. Classes that derive from the Stream class include: BufferedStream, FileStream, MemoryStream, etc.

Examples

The following example deserializes an object using a Stream:
CopyC#
using (System.IO.FileStream fileStream = new System.IO.FileStream("SampleReport1.trdx", System.IO.FileMode.OpenOrCreate))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    Telerik.Reporting.Report report = (Telerik.Reporting.Report)
        xmlSerializer.Deserialize(fileStream);
}
CopyVB.NET
Using fileStream As New System.IO.FileStream("SampleReport1.trdx", System.IO.FileMode.OpenOrCreate)
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    Dim report As Telerik.Reporting.Report = DirectCast(xmlSerializer.Deserialize(fileStream), Telerik.Reporting.Report)
End Using

See Also

ReportXmlSerializer Class
Deserialize Overload
Telerik.Reporting.XmlSerialization Namespace


Deserialize Method (TextReader)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Deserialize Method (TextReader)
ReportXmlSerializer Class Example See Also Send Feedback
Deserializes the XML document contained by the specified TextReader.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Deserialize(
    TextReader reader
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As TextReader _
) As Object

Parameters

reader
Type: System.IO..::.TextReader
The TextReader that contains the XML document to deserialize.

Return Value

The Telerik.Reporting object being deserialized.

Remarks

Classes that inherit from TextReader include StringReader and StreamReader. If you are using a StreamReader to deserialize an object, you must construct the StreamReader with an appropriate Encoding. The encoding specified by the XML document is ignored.

Examples

The following example deserializes an object using a TextReader:
CopyC#
using (System.IO.FileStream fileStream = new System.IO.FileStream("SampleReport1.trdx", System.IO.FileMode.OpenOrCreate))
using (System.IO.TextReader textReader = new System.IO.StreamReader(fileStream))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    Telerik.Reporting.Report report = (Telerik.Reporting.Report)
        xmlSerializer.Deserialize(textReader);
}
CopyVB.NET
Using fileStream As New System.IO.FileStream("SampleReport1.trdx", System.IO.FileMode.OpenOrCreate)
    Using textReader As System.IO.TextReader = New System.IO.StreamReader(fileStream)
        Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

        Dim report As Telerik.Reporting.Report = DirectCast(xmlSerializer.Deserialize(textReader), Telerik.Reporting.Report)
    End Using
End Using

See Also

ReportXmlSerializer Class
Deserialize Overload
Telerik.Reporting.XmlSerialization Namespace


Deserialize Method (String)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Deserialize Method (String)
ReportXmlSerializer Class Example See Also Send Feedback
Deserializes the XML document from the specified URI.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Deserialize(
    string intputUri
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    intputUri As String _
) As Object

Parameters

intputUri
Type: System..::.String
The URI for the file containing the XML data.

Return Value

The Telerik.Reporting object being deserialized.

Examples

The following example deserializes an object using a URI:
CopyC#
Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
    new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

Telerik.Reporting.Report report = (Telerik.Reporting.Report)
    xmlSerializer.Deserialize("SampleReport1.trdx");
CopyVB.NET
Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

Dim report As Telerik.Reporting.Report = DirectCast(xmlSerializer.Deserialize("SampleReport1.trdx"), Telerik.Reporting.Report)

See Also

ReportXmlSerializer Class
Deserialize Overload
Telerik.Reporting.XmlSerialization Namespace


Deserialize Method (XmlReader)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Deserialize Method (XmlReader)
ReportXmlSerializer Class Example See Also Send Feedback
Deserializes the XML document contained by the specified XmlReader.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public Object Deserialize(
    XmlReader reader
)
Visual Basic (Declaration)
Public Function Deserialize ( _
    reader As XmlReader _
) As Object

Parameters

reader
Type: System.Xml..::.XmlReader
The XmlReader that contains the XML document to deserialize.

Return Value

The Telerik.Reporting object being deserialized.

Examples

The following example deserializes an object using a XmlReader:
CopyC#
System.Xml.XmlReaderSettings settings = new System.Xml.XmlReaderSettings();
settings.IgnoreWhitespace = true;

using (System.Xml.XmlReader xmlReader = System.Xml.XmlReader.Create("SampleReport1.trdx", settings))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    Telerik.Reporting.Report report = (Telerik.Reporting.Report)
        xmlSerializer.Deserialize(xmlReader);
}
CopyVB.NET
Dim settings As New XmlReaderSettings()
settings.IgnoreWhitespace = True

Using xmlReader As System.Xml.XmlReader = System.Xml.XmlReader.Create("SampleReport1.trdx", settings)
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    Dim report As Telerik.Reporting.Report = DirectCast(xmlSerializer.Deserialize(xmlReader), Telerik.Reporting.Report)
End Using

See Also

ReportXmlSerializer Class
Deserialize Overload
Telerik.Reporting.XmlSerialization Namespace


Serialize Method

[image] [image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Serialize Method
ReportXmlSerializer Class See Also Send Feedback

Overload List

Name | Description
Serialize(Stream, Object) | Serializes the specified value and writes the XML document to the specified Stream.
Serialize(TextWriter, Object) | Serializes the specified value and writes the XML document to the specified TextWriter.
Serialize(String, Object) | Serializes the specified value and writes the XML document to a file with the specified file name.
Serialize(XmlWriter, Object) | Serializes the specified value and writes the XML document to the specified XmlWriter.

See Also

ReportXmlSerializer Class
ReportXmlSerializer Members
Telerik.Reporting.XmlSerialization Namespace


Serialize Method (Stream, Object)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Serialize Method (Stream, Object)
ReportXmlSerializer Class Example See Also Send Feedback
Serializes the specified value and writes the XML document to the specified Stream.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Serialize(
    Stream stream,
    Object value
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    stream As Stream, _
    value As Object _
)

Parameters

stream
Type: System.IO..::.Stream
The Stream used to write the XML document.
value
Type: System..::.Object
The value to serialize.

Remarks

Use the stream parameter to specify an object that derives from the abstract Stream class. Classes that derive from the Stream class include: BufferedStream, FileStream, MemoryStream, etc.

Examples

The following examples serializes an object using a Stream:
CopyC#
using (System.IO.Stream stream = new System.IO.FileStream("Report.trdx", System.IO.FileMode.Create))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    xmlSerializer.Serialize(stream, report);
}
CopyVB.NET
Using stream As System.IO.Stream = New System.IO.FileStream("Report.trdx", System.IO.FileMode.Create)
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    xmlSerializer.Serialize(stream, report)
End Using

See Also

ReportXmlSerializer Class
Serialize Overload
Telerik.Reporting.XmlSerialization Namespace


Serialize Method (TextWriter, Object)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Serialize Method (TextWriter, Object)
ReportXmlSerializer Class Example See Also Send Feedback
Serializes the specified value and writes the XML document to the specified TextWriter.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Serialize(
    TextWriter writer,
    Object value
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As TextWriter, _
    value As Object _
)

Parameters

writer
Type: System.IO..::.TextWriter
The TextWriter used to write the XML document.
value
Type: System..::.Object
The value to serialize.

Remarks

In the textWriter parameter, specify an object that derives from the abstract TextWriter class. Classes that derive from the TextWriter class include: StreamWriter, StringWriter, etc.

Examples

The following examples serializes an object using a TextWriter:
CopyC#
using (System.IO.FileStream fs = new System.IO.FileStream("Report.trdx", FileMode.Create))
using (System.IO.TextWriter writer = new System.IO.StreamWriter(fs, System.Text.Encoding.UTF8))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    xmlSerializer.Serialize(writer, report);
}
CopyVB.NET
Using fs As New System.IO.FileStream("Report.trdx", System.IO.FileMode.Create)
    Using writer As System.IO.TextWriter = New System.IO.StreamWriter(fs, System.Text.Encoding.UTF8)
        Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

        xmlSerializer.Serialize(writer, report)
    End Using
End Using

See Also

ReportXmlSerializer Class
Serialize Overload
Telerik.Reporting.XmlSerialization Namespace


Serialize Method (String, Object)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Serialize Method (String, Object)
ReportXmlSerializer Class Example See Also Send Feedback
Serializes the specified value and writes the XML document to a file with the specified file name.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Serialize(
    string fileName,
    Object value
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    fileName As String, _
    value As Object _
)

Parameters

fileName
Type: System..::.String
The file which you want to write to. The ReportXmlSerializer creates a file at the specified path and writes to it in XML 1.0 text syntax. The fileName must be a file system path.
value
Type: System..::.Object
The value to serialize.

Examples

The following example serializes an object using a file path:
CopyC#
Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
    new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

xmlSerializer.Serialize("Report.trdx", report);
CopyVB.NET
Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

xmlSerializer.Serialize("Report.trdx", report)

See Also

ReportXmlSerializer Class
Serialize Overload
Telerik.Reporting.XmlSerialization Namespace


Serialize Method (XmlWriter, Object)

[image]

Telerik Reporting Q2 2012
ReportXmlSerializer..::.Serialize Method (XmlWriter, Object)
ReportXmlSerializer Class Example See Also Send Feedback
Serializes the specified value and writes the XML document to the specified XmlWriter.

Namespace: Telerik.Reporting.XmlSerialization
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
public void Serialize(
    XmlWriter writer,
    Object value
)
Visual Basic (Declaration)
Public Sub Serialize ( _
    writer As XmlWriter, _
    value As Object _
)

Parameters

writer
Type: System.Xml..::.XmlWriter
The XmlWriter used to write the XML document.
value
Type: System..::.Object
The value to serialize.

Remarks

In the xmlWriter parameter, specify an object that derives from the abstract XmlWriter class. For example you can use the XmlTextWriter class.

Examples

The following example serializes an object using a XmlWriter:
CopyC#
using (System.Xml.XmlWriter xmlWriter = System.Xml.XmlWriter.Create("report.xml"))
{
    Telerik.Reporting.XmlSerialization.ReportXmlSerializer xmlSerializer =
        new Telerik.Reporting.XmlSerialization.ReportXmlSerializer();

    xmlSerializer.Serialize(xmlWriter, report);
}
CopyVB.NET
Using xmlWriter As System.Xml.XmlWriter = System.Xml.XmlWriter.Create("report.xml")
    Dim xmlSerializer As New Telerik.Reporting.XmlSerialization.ReportXmlSerializer()

    xmlSerializer.Serialize(xmlWriter, report)
End Using

See Also

ReportXmlSerializer Class
Serialize Overload
Telerik.Reporting.XmlSerialization Namespace


Telerik.ReportViewer.Common Namespace

[image]

Telerik Reporting Q2 2012
Telerik.ReportViewer.Common Namespace
Send Feedback

Classes

Class | Description
DocumentMapNodeModel | Represents a node in the DocumentMap hierarchy. Used from SL and WPF viewers


DocumentMapNodeModel Class

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel Class
Members See Also Send Feedback
Represents a node in the DocumentMap hierarchy. Used from SL and WPF viewers

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class DocumentMapNodeModel : ObservableObject
Visual Basic (Declaration)
Public Class DocumentMapNodeModel _
    Inherits ObservableObject

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Common..::.DocumentMapNodeModel

See Also

DocumentMapNodeModel Members
Telerik.ReportViewer.Common Namespace


DocumentMapNodeModel Members

[image] [image]

Telerik Reporting Q2 2012
DocumentMapNodeModel Members
DocumentMapNodeModel Class Constructors Properties See Also Send Feedback

The DocumentMapNodeModel type exposes the following members.

Constructors

Name | Description
DocumentMapNodeModel | Creates a new instance of DocumentMapNodeModel.

Properties

Name | Description
BookmarkId | The identifier of the BookmarkNode this model points to.
Children | The list of all child BookmarkNodes.
IsExpanded | Determines if the corresponding UI node is expanded.
Label | The text of the current BookmarkNode when displayed in the report viewer's Document Map.
Page | The number of the page where the current bookmark appears.
Text | The text of the current BookmarkNode when displayed in the report viewer's Document Map.
X | The X-coordinate of the location in the page of the current bookmark.
Y | The Y-coordinate of the location in the page of the current bookmark.

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


DocumentMapNodeModel Constructor

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel Constructor
DocumentMapNodeModel Class See Also Send Feedback
Creates a new instance of DocumentMapNodeModel.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public DocumentMapNodeModel(
    BookmarkNode bookmark
)
Visual Basic (Declaration)
Public Sub New ( _
    bookmark As BookmarkNode _
)

Parameters

bookmark
Type: Telerik.Reporting.Service..::.BookmarkNode

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


DocumentMapNodeModel Properties

[image] [image]

Telerik Reporting Q2 2012
DocumentMapNodeModel Properties
DocumentMapNodeModel Class See Also Send Feedback

The DocumentMapNodeModel type exposes the following members.

Properties

Name | Description
BookmarkId | The identifier of the BookmarkNode this model points to.
Children | The list of all child BookmarkNodes.
IsExpanded | Determines if the corresponding UI node is expanded.
Label | The text of the current BookmarkNode when displayed in the report viewer's Document Map.
Page | The number of the page where the current bookmark appears.
Text | The text of the current BookmarkNode when displayed in the report viewer's Document Map.
X | The X-coordinate of the location in the page of the current bookmark.
Y | The Y-coordinate of the location in the page of the current bookmark.

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


BookmarkId Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.BookmarkId Property
DocumentMapNodeModel Class See Also Send Feedback
The identifier of the BookmarkNode this model points to.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string BookmarkId { get; private set; }
Visual Basic (Declaration)
Public Property BookmarkId As String

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Children Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.Children Property
DocumentMapNodeModel Class See Also Send Feedback
The list of all child BookmarkNodes.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<DocumentMapNodeModel> Children { get; private set; }
Visual Basic (Declaration)
Public Property Children As List(Of DocumentMapNodeModel)

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


IsExpanded Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.IsExpanded Property
DocumentMapNodeModel Class See Also Send Feedback
Determines if the corresponding UI node is expanded.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Label Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.Label Property
DocumentMapNodeModel Class See Also Send Feedback
The text of the current BookmarkNode when displayed in the report viewer's Document Map.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As String

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Page Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.Page Property
DocumentMapNodeModel Class See Also Send Feedback
The number of the page where the current bookmark appears.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int Page { get; private set; }
Visual Basic (Declaration)
Public Property Page As Integer

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Text Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.Text Property
DocumentMapNodeModel Class See Also Send Feedback
The text of the current BookmarkNode when displayed in the report viewer's Document Map.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Text { get; private set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


X Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.X Property
DocumentMapNodeModel Class See Also Send Feedback
The X-coordinate of the location in the page of the current bookmark.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int X { get; private set; }
Visual Basic (Declaration)
Public Property X As Integer

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Y Property

[image]

Telerik Reporting Q2 2012
DocumentMapNodeModel..::.Y Property
DocumentMapNodeModel Class See Also Send Feedback
The Y-coordinate of the location in the page of the current bookmark.

Namespace: Telerik.ReportViewer.Common
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int Y { get; private set; }
Visual Basic (Declaration)
Public Property Y As Integer

See Also

DocumentMapNodeModel Class
Telerik.ReportViewer.Common Namespace


Telerik.ReportViewer.Silverlight Namespace

[image]

Telerik Reporting Q2 2012
Telerik.ReportViewer.Silverlight Namespace
Send Feedback

Classes

Class | Description
DialogBox | Represents a dialog box control.
ErrorStatus | Represents a error status control
ExtensionInfoModel | ExtensionInfo wrapper for data-binding
FormatedNumberConverter | Converts a number to string according to a given format
KeyDown | Enables binding an ICommand to the FrameworkElement.KeyDown event
MultivalueAvailableValuesParameterModel |
MultivalueAvailableValuesParameterModel..::.SelectAllItem | Represents the SelectAll item in a Multivalue/AvailableValues editor
MultivalueParameterConverter | A value converter for multi-value parameters
ObservableObject | Represents an observable object.
ParameterModel | Represents the report parameter model to associate the parameter editor UI with.
ParameterModelCollection | Represents a collection of parameter models.
ParameterValueModel | Represents the parameter value model.
RenderBeginEventArgs | Provides data for the RenderBegin event.
ReportParameterEditorTemplateSelector | Represents a selector for the report parameter editor templates.
ReportParametersControl | Represents a control that holds a collection of ReportParameterTemplate.
ReportParameterTemplate | Represents a report parameter editor data template.
ReportViewer | Represents the Silverlight ReportViewer control.
ReportViewer..::.TemplateParts | Specifies the template parts names.
ReportViewerModel | Represents the report viewer model.
ReportViewerModel..::.Command | Represents a base class for a command.
ReportViewerModel..::.ReportViewerCommand | Represents a base class for the report viewer's commands.
ReportViewerStates | Defines the names of the report viewer visual states.
ScaleFactorConverter | Converts number to percent value.
TextBoxEx | TextBox that autoupdates DataBound Text property in TwoWay binding
TextResources | Provides the default tooltips and messages for the viewer.
VisibilityConverter | A value converter for visibility and boolean values.
ZoomConverter | Formats a number as % string and vice-versa

Interfaces

Interface | Description
IReportServiceClientFactory | Enables users to write activation code for ReportServiceClient.
IReportViewer | Specifies the IReportViewer interface.
ITextResources | This interface is used for customization or localization of all text resources, as alternative to localization/customization with .resx files.

Delegates

Delegate | Description
RenderBeginEventHandler | Represents the method that will handle the RenderBegin event.

Enumerations

Enumeration | Description
ViewMode | Specifies the page view mode for the ReportViewer control.
ZoomMode | Specifies the zoom mode for the ReportViewer control.


DialogBox Class

[image]

Telerik Reporting Q2 2012
DialogBox Class
Members See Also Send Feedback
Represents a dialog box control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class DialogBox : ContentControl
Visual Basic (Declaration)
Public Class DialogBox _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Telerik.ReportViewer.Silverlight..::.DialogBox

See Also

DialogBox Members
Telerik.ReportViewer.Silverlight Namespace


DialogBox Members

[image] [image]

Telerik Reporting Q2 2012
DialogBox Members
DialogBox Class Constructors See Also Send Feedback

The DialogBox type exposes the following members.

Constructors

Name | Description
DialogBox | Creates a new instance of the DialogBox class.

See Also

DialogBox Class
Telerik.ReportViewer.Silverlight Namespace


DialogBox Constructor

[image]

Telerik Reporting Q2 2012
DialogBox Constructor
DialogBox Class See Also Send Feedback
Creates a new instance of the DialogBox class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public DialogBox()
Visual Basic (Declaration)
Public Sub New

See Also

DialogBox Class
Telerik.ReportViewer.Silverlight Namespace


ErrorStatus Class

[image]

Telerik Reporting Q2 2012
ErrorStatus Class
Members See Also Send Feedback
Represents a error status control

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ErrorStatus : ContentControl
Visual Basic (Declaration)
Public Class ErrorStatus _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Telerik.ReportViewer.Silverlight..::.ErrorStatus

See Also

ErrorStatus Members
Telerik.ReportViewer.Silverlight Namespace


ErrorStatus Members

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Members
ErrorStatus Class Constructors Fields Properties See Also Send Feedback

The ErrorStatus type exposes the following members.

Constructors

Name | Description
ErrorStatus | Creates a new instance of the ErrorStatus class.

Fields

Name | Description
CurrentDataContextProperty | Helper dependency property identifying the DataContext changes. Internal use only.
PropertyNameProperty | Defines the ReportName dependency property.

Properties

Name | Description
PropertyName | Specifies the name of the property which errors should be displayed by the error status.

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


ErrorStatus Constructor

[image]

Telerik Reporting Q2 2012
ErrorStatus Constructor
ErrorStatus Class See Also Send Feedback
Creates a new instance of the ErrorStatus class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ErrorStatus()
Visual Basic (Declaration)
Public Sub New

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


ErrorStatus Fields

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Fields
ErrorStatus Class See Also Send Feedback

The ErrorStatus type exposes the following members.

Fields

Name | Description
CurrentDataContextProperty | Helper dependency property identifying the DataContext changes. Internal use only.
PropertyNameProperty | Defines the ReportName dependency property.

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


CurrentDataContextProperty Field

[image]

Telerik Reporting Q2 2012
ErrorStatus..::.CurrentDataContextProperty Field
ErrorStatus Class See Also Send Feedback
Helper dependency property identifying the DataContext changes. Internal use only.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty CurrentDataContextProperty
Visual Basic (Declaration)
Public Shared ReadOnly CurrentDataContextProperty As DependencyProperty

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


PropertyNameProperty Field

[image]

Telerik Reporting Q2 2012
ErrorStatus..::.PropertyNameProperty Field
ErrorStatus Class See Also Send Feedback
Defines the ReportName dependency property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty PropertyNameProperty
Visual Basic (Declaration)
Public Shared ReadOnly PropertyNameProperty As DependencyProperty

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


ErrorStatus Properties

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Properties
ErrorStatus Class See Also Send Feedback

The ErrorStatus type exposes the following members.

Properties

Name | Description
PropertyName | Specifies the name of the property which errors should be displayed by the error status.

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


PropertyName Property

[image]

Telerik Reporting Q2 2012
ErrorStatus..::.PropertyName Property
ErrorStatus Class See Also Send Feedback
Specifies the name of the property which errors should be displayed by the error status.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String

See Also

ErrorStatus Class
Telerik.ReportViewer.Silverlight Namespace


ExtensionInfoModel Class

[image]

Telerik Reporting Q2 2012
ExtensionInfoModel Class
Members See Also Send Feedback
ExtensionInfo wrapper for data-binding

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ExtensionInfoModel
Visual Basic (Declaration)
Public Class ExtensionInfoModel

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ExtensionInfoModel

See Also

ExtensionInfoModel Members
Telerik.ReportViewer.Silverlight Namespace


ExtensionInfoModel Members

[image] [image]

Telerik Reporting Q2 2012
ExtensionInfoModel Members
ExtensionInfoModel Class Properties See Also Send Feedback

The ExtensionInfoModel type exposes the following members.

Properties

Name | Description
ExportReportCommand | Gets the ExportReport command
LocalizedName | Gets the extension info localized name
Name | Gets the extension info name

See Also

ExtensionInfoModel Class
Telerik.ReportViewer.Silverlight Namespace


ExtensionInfoModel Properties

[image] [image]

Telerik Reporting Q2 2012
ExtensionInfoModel Properties
ExtensionInfoModel Class See Also Send Feedback

The ExtensionInfoModel type exposes the following members.

Properties

Name | Description
ExportReportCommand | Gets the ExportReport command
LocalizedName | Gets the extension info localized name
Name | Gets the extension info name

See Also

ExtensionInfoModel Class
Telerik.ReportViewer.Silverlight Namespace


ExportReportCommand Property

[image]

Telerik Reporting Q2 2012
ExtensionInfoModel..::.ExportReportCommand Property
ExtensionInfoModel Class See Also Send Feedback
Gets the ExportReport command

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand ExportReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExportReportCommand As ICommand

See Also

ExtensionInfoModel Class
Telerik.ReportViewer.Silverlight Namespace


LocalizedName Property

[image]

Telerik Reporting Q2 2012
ExtensionInfoModel..::.LocalizedName Property
ExtensionInfoModel Class See Also Send Feedback
Gets the extension info localized name

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string LocalizedName { get; }
Visual Basic (Declaration)
Public ReadOnly Property LocalizedName As String

See Also

ExtensionInfoModel Class
Telerik.ReportViewer.Silverlight Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ExtensionInfoModel..::.Name Property
ExtensionInfoModel Class See Also Send Feedback
Gets the extension info name

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ExtensionInfoModel Class
Telerik.ReportViewer.Silverlight Namespace


FormatedNumberConverter Class

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter Class
Members See Also Send Feedback
Converts a number to string according to a given format

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class FormatedNumberConverter : IValueConverter
Visual Basic (Declaration)
Public Class FormatedNumberConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.FormatedNumberConverter

See Also

FormatedNumberConverter Members
Telerik.ReportViewer.Silverlight Namespace


FormatedNumberConverter Members

[image] [image]

Telerik Reporting Q2 2012
FormatedNumberConverter Members
FormatedNumberConverter Class Constructors Methods See Also Send Feedback

The FormatedNumberConverter type exposes the following members.

Constructors

Name | Description
FormatedNumberConverter | Initializes a new instance of the FormatedNumberConverter class

Methods

Name | Description
Convert | Converts a number to string according to a given format.
ConvertBack | Converts a number to string according to a given format.

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Silverlight Namespace


FormatedNumberConverter Constructor

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter Constructor
FormatedNumberConverter Class See Also Send Feedback
Initializes a new instance of the FormatedNumberConverter class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public FormatedNumberConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Silverlight Namespace


FormatedNumberConverter Methods

[image] [image]

Telerik Reporting Q2 2012
FormatedNumberConverter Methods
FormatedNumberConverter Class See Also Send Feedback

The FormatedNumberConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a number to string according to a given format.
ConvertBack | Converts a number to string according to a given format.

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Silverlight Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter..::.Convert Method
FormatedNumberConverter Class See Also Send Feedback
Converts a number to string according to a given format.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Silverlight Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter..::.ConvertBack Method
FormatedNumberConverter Class See Also Send Feedback
Converts a number to string according to a given format.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Silverlight Namespace


IReportServiceClientFactory Interface

[image]

Telerik Reporting Q2 2012
IReportServiceClientFactory Interface
Members See Also Send Feedback
Enables users to write activation code for ReportServiceClient.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public interface IReportServiceClientFactory
Visual Basic (Declaration)
Public Interface IReportServiceClientFactory

Remarks

For additional information and example see ReportServiceClientFactory.

See Also

IReportServiceClientFactory Members
Telerik.ReportViewer.Silverlight Namespace
ReportViewer..::.ReportServiceClientFactory


IReportServiceClientFactory Members

[image] [image]

Telerik Reporting Q2 2012
IReportServiceClientFactory Members
IReportServiceClientFactory Interface Methods See Also Send Feedback

The IReportServiceClientFactory type exposes the following members.

Methods

Name | Description
Create | Creates a new instance of ReportServiceClient.

See Also

IReportServiceClientFactory Interface
Telerik.ReportViewer.Silverlight Namespace


IReportServiceClientFactory Methods

[image] [image]

Telerik Reporting Q2 2012
IReportServiceClientFactory Methods
IReportServiceClientFactory Interface See Also Send Feedback

The IReportServiceClientFactory type exposes the following members.

Methods

Name | Description
Create | Creates a new instance of ReportServiceClient.

See Also

IReportServiceClientFactory Interface
Telerik.ReportViewer.Silverlight Namespace


Create Method

[image]

Telerik Reporting Q2 2012
IReportServiceClientFactory..::.Create Method
IReportServiceClientFactory Interface See Also Send Feedback
Creates a new instance of ReportServiceClient.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
ReportServiceClient Create(
    Uri remoteAddress
)
Visual Basic (Declaration)
Function Create ( _
    remoteAddress As Uri _
) As ReportServiceClient

Parameters

remoteAddress
Type: System..::.Uri
The absolute address of the service.

Return Value

A new instance of ReportServiceClient.

Remarks

For additional information and example see ReportServiceClientFactory.

See Also

IReportServiceClientFactory Interface
Telerik.ReportViewer.Silverlight Namespace
ReportViewer..::.ReportServiceClientFactory


IReportViewer Interface

[image]

Telerik Reporting Q2 2012
IReportViewer Interface
Members See Also Send Feedback
Specifies the IReportViewer interface.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public interface IReportViewer
Visual Basic (Declaration)
Public Interface IReportViewer

See Also

IReportViewer Members
Telerik.ReportViewer.Silverlight Namespace


IReportViewer Members

[image] [image]

Telerik Reporting Q2 2012
IReportViewer Members
IReportViewer Interface Methods Properties Events See Also Send Feedback

The IReportViewer type exposes the following members.

Methods

Name | Description
OnRenderBegin | Occurs when rendering begins.

Properties

Name | Description
PageViewportSize | Returns the size of the page viewport.
UseNativePrinting | Specifies whether to use native Silverlight printing or not.

Events

Name | Description
PageViewerResize | Occurs when the PageScrollViewer size changed.

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


IReportViewer Methods

[image] [image]

Telerik Reporting Q2 2012
IReportViewer Methods
IReportViewer Interface See Also Send Feedback

The IReportViewer type exposes the following members.

Methods

Name | Description
OnRenderBegin | Occurs when rendering begins.

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


OnRenderBegin Method

[image]

Telerik Reporting Q2 2012
IReportViewer..::.OnRenderBegin Method
IReportViewer Interface See Also Send Feedback
Occurs when rendering begins.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
bool OnRenderBegin(
    NameValueDictionary parameterValues
)
Visual Basic (Declaration)
Function OnRenderBegin ( _
    parameterValues As NameValueDictionary _
) As Boolean

Parameters

parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with parameter values for the current report to render.

Return Value

Return false to cancel the rendering operation otherwise return true.

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


IReportViewer Properties

[image] [image]

Telerik Reporting Q2 2012
IReportViewer Properties
IReportViewer Interface See Also Send Feedback

The IReportViewer type exposes the following members.

Properties

Name | Description
PageViewportSize | Returns the size of the page viewport.
UseNativePrinting | Specifies whether to use native Silverlight printing or not.

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


PageViewportSize Property

[image]

Telerik Reporting Q2 2012
IReportViewer..::.PageViewportSize Property
IReportViewer Interface See Also Send Feedback
Returns the size of the page viewport.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
Size PageViewportSize { get; }
Visual Basic (Declaration)
ReadOnly Property PageViewportSize As Size

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


UseNativePrinting Property

[image]

Telerik Reporting Q2 2012
IReportViewer..::.UseNativePrinting Property
IReportViewer Interface See Also Send Feedback
Specifies whether to use native Silverlight printing or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
bool UseNativePrinting { get; set; }
Visual Basic (Declaration)
Property UseNativePrinting As Boolean

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


IReportViewer Events

[image] [image]

Telerik Reporting Q2 2012
IReportViewer Events
IReportViewer Interface See Also Send Feedback

The IReportViewer type exposes the following members.

Events

Name | Description
PageViewerResize | Occurs when the PageScrollViewer size changed.

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


PageViewerResize Event

[image]

Telerik Reporting Q2 2012
IReportViewer..::.PageViewerResize Event
IReportViewer Interface See Also Send Feedback
Occurs when the PageScrollViewer size changed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
event SizeChangedEventHandler PageViewerResize
Visual Basic (Declaration)
Event PageViewerResize As SizeChangedEventHandler

See Also

IReportViewer Interface
Telerik.ReportViewer.Silverlight Namespace


ITextResources Interface

[image]

Telerik Reporting Q2 2012
ITextResources Interface
Members See Also Send Feedback
This interface is used for customization or localization of all text resources, as alternative to localization/customization with .resx files.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public interface ITextResources
Visual Basic (Declaration)
Public Interface ITextResources

See Also

ITextResources Members
Telerik.ReportViewer.Silverlight Namespace


ITextResources Members

[image] [image]

Telerik Reporting Q2 2012
ITextResources Members
ITextResources Interface Properties See Also Send Feedback

The ITextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelExportButtonText | Specifies the text for the Export Cancel button.
CancellingPrintMessage | Specifies the text for the message that is displayed when printing is cancelled.
CancelPrintButtonText | Specifies the text for the Print Cancel button.
CannotConvertTypeError | Specifies the message for the type conversion error.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
DocumentReadyForPrintMessage | Specifies the text for the message that is displayed when the document is ready for printing.
ExportingProgressMessage | Specifies the text for the export progress message.
ExportToolTip | Specifies the tooltip for the Export button.
FileReadyToSaveMessage | Specifies the text for the message that is displayed when the file is ready to be saved.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
MultipleValuesNotSupportedError | Specifies the text for the message that is displayed when the parameter does not support multiple values.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreparingForPrintMessage | Specifies the text for the message that is displayed when the report is being prepared for printing.
PreviewButtonText | Specifies the text for the Preview button.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintButtonText | Specifies the text for the dialog Print button.
PrintingRequiresBrowserError | Specifies the text for the message that is displayed when trying to print Out-of-Browser.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintProgressMessage | Specifies the text for the message that show which page is currently being printed.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
SaveButtonText | Specifies the text for the dialog Save button.
StartingPrintMessage | Specifies the text for the message that is displayed when printing is started.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UnableToExportError | Specifies the text for the message that is displayed when the report is not exported.
UpdatingParametersDoneMessage | Specifies the text for the message that is displayed when the updating of parameters is finished.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ITextResources Properties

[image] [image]

Telerik Reporting Q2 2012
ITextResources Properties
ITextResources Interface See Also Send Feedback

The ITextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelExportButtonText | Specifies the text for the Export Cancel button.
CancellingPrintMessage | Specifies the text for the message that is displayed when printing is cancelled.
CancelPrintButtonText | Specifies the text for the Print Cancel button.
CannotConvertTypeError | Specifies the message for the type conversion error.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
DocumentReadyForPrintMessage | Specifies the text for the message that is displayed when the document is ready for printing.
ExportingProgressMessage | Specifies the text for the export progress message.
ExportToolTip | Specifies the tooltip for the Export button.
FileReadyToSaveMessage | Specifies the text for the message that is displayed when the file is ready to be saved.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
MultipleValuesNotSupportedError | Specifies the text for the message that is displayed when the parameter does not support multiple values.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreparingForPrintMessage | Specifies the text for the message that is displayed when the report is being prepared for printing.
PreviewButtonText | Specifies the text for the Preview button.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintButtonText | Specifies the text for the dialog Print button.
PrintingRequiresBrowserError | Specifies the text for the message that is displayed when trying to print Out-of-Browser.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintProgressMessage | Specifies the text for the message that show which page is currently being printed.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
SaveButtonText | Specifies the text for the dialog Save button.
StartingPrintMessage | Specifies the text for the message that is displayed when printing is started.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UnableToExportError | Specifies the text for the message that is displayed when the report is not exported.
UpdatingParametersDoneMessage | Specifies the text for the message that is displayed when the updating of parameters is finished.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


AllFiles Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.AllFiles Property
ITextResources Interface See Also Send Feedback
Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string AllFiles { get; }
Visual Basic (Declaration)
ReadOnly Property AllFiles As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


BackToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.BackToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string BackToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property BackToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


CancelExportButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CancelExportButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the Export Cancel button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string CancelExportButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property CancelExportButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


CancellingPrintMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CancellingPrintMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when printing is cancelled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string CancellingPrintMessage { get; }
Visual Basic (Declaration)
ReadOnly Property CancellingPrintMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


CancelPrintButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CancelPrintButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the Print Cancel button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string CancelPrintButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property CancelPrintButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


CannotConvertTypeError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CannotConvertTypeError Property
ITextResources Interface See Also Send Feedback
Specifies the message for the type conversion error.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string CannotConvertTypeError { get; }
Visual Basic (Declaration)
ReadOnly Property CannotConvertTypeError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CurrentPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string CurrentPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.DocumentMapToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string DocumentMapToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property DocumentMapToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


DocumentReadyForPrintMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.DocumentReadyForPrintMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the document is ready for printing.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string DocumentReadyForPrintMessage { get; }
Visual Basic (Declaration)
ReadOnly Property DocumentReadyForPrintMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ExportingProgressMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ExportingProgressMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the export progress message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ExportingProgressMessage { get; }
Visual Basic (Declaration)
ReadOnly Property ExportingProgressMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ExportToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ExportToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ExportToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


FileReadyToSaveMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.FileReadyToSaveMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the file is ready to be saved.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string FileReadyToSaveMessage { get; }
Visual Basic (Declaration)
ReadOnly Property FileReadyToSaveMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.FirstPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string FirstPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property FirstPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ForwardToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ForwardToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Forward button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ForwardToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.LastPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string LastPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property LastPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


LoadingPageMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.LoadingPageMessage Property
ITextResources Interface See Also Send Feedback
Specifies the transitional loading page message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string LoadingPageMessage { get; }
Visual Basic (Declaration)
ReadOnly Property LoadingPageMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


MultipleValuesNotSupportedError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.MultipleValuesNotSupportedError Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the parameter does not support multiple values.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string MultipleValuesNotSupportedError { get; }
Visual Basic (Declaration)
ReadOnly Property MultipleValuesNotSupportedError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.NextPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string NextPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property NextPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


NoReportError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.NoReportError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for missing report.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string NoReportError { get; }
Visual Basic (Declaration)
ReadOnly Property NoReportError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PageNumberGreaterThanRangeError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PageNumberGreaterThanRangeError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the page number is greater than the count of pages.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PageNumberGreaterThanRangeError { get; }
Visual Basic (Declaration)
ReadOnly Property PageNumberGreaterThanRangeError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PageNumberLessThanRangeError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PageNumberLessThanRangeError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the page number is less than 1.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PageNumberLessThanRangeError { get; }
Visual Basic (Declaration)
ReadOnly Property PageNumberLessThanRangeError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ParametersToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ParametersToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ParametersToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PreparingForPrintMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PreparingForPrintMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the report is being prepared for printing.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PreparingForPrintMessage { get; }
Visual Basic (Declaration)
ReadOnly Property PreparingForPrintMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PreviewButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PreviewButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PreviewButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property PreviewButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PreviousPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PreviousPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PreviousPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PrintButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the dialog Print button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PrintButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property PrintButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PrintingRequiresBrowserError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintingRequiresBrowserError Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when trying to print Out-of-Browser.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PrintingRequiresBrowserError { get; }
Visual Basic (Declaration)
ReadOnly Property PrintingRequiresBrowserError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintPreviewToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Print Preview.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PrintPreviewToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PrintPreviewToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PrintProgressMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintProgressMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that show which page is currently being printed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PrintProgressMessage { get; }
Visual Basic (Declaration)
ReadOnly Property PrintProgressMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string PrintToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PrintToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ProcessingReportMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ProcessingReportMessage { get; }
Visual Basic (Declaration)
ReadOnly Property ProcessingReportMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.RefreshToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string RefreshToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property RefreshToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ReportParametersAreaValidationError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersAreaValidationError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ReportParametersAreaValidationError { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersAreaValidationError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersNullText Property
ITextResources Interface See Also Send Feedback
Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ReportParametersNullText { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersNullText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersSelectAllText Property
ITextResources Interface See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ReportParametersSelectAllText { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersSelectAllText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


SaveButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.SaveButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the dialog Save button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string SaveButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property SaveButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


StartingPrintMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.StartingPrintMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when printing is started.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string StartingPrintMessage { get; }
Visual Basic (Declaration)
ReadOnly Property StartingPrintMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


TotalPagesToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.TotalPagesToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string TotalPagesToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property TotalPagesToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


UnableToExportError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.UnableToExportError Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the report is not exported.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string UnableToExportError { get; }
Visual Basic (Declaration)
ReadOnly Property UnableToExportError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


UpdatingParametersDoneMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.UpdatingParametersDoneMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the message that is displayed when the updating of parameters is finished.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string UpdatingParametersDoneMessage { get; }
Visual Basic (Declaration)
ReadOnly Property UpdatingParametersDoneMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


UpdatingParametersMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.UpdatingParametersMessage Property
ITextResources Interface See Also Send Feedback
Specifies the transitional updating parameters message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string UpdatingParametersMessage { get; }
Visual Basic (Declaration)
ReadOnly Property UpdatingParametersMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ZoomToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ZoomToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToPageWidth Property
ITextResources Interface See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ZoomToPageWidth { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToPageWidth As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToWholePage Property
ITextResources Interface See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
string ZoomToWholePage { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToWholePage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Silverlight Namespace


KeyDown Class

[image]

Telerik Reporting Q2 2012
KeyDown Class
Members See Also Send Feedback
Enables binding an ICommand to the FrameworkElement.KeyDown event

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class KeyDown
Visual Basic (Declaration)
Public Class KeyDown

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.KeyDown

See Also

KeyDown Members
Telerik.ReportViewer.Silverlight Namespace


KeyDown Members

[image] [image]

Telerik Reporting Q2 2012
KeyDown Members
KeyDown Class Constructors Methods Fields Attached Properties See Also Send Feedback

The KeyDown type exposes the following members.

Constructors

Name | Description
KeyDown | Initializes a new instance of the KeyDown class

Methods

Name | Description
GetCommand |
SetCommand |

Fields

Name | Description
CommandProperty |

Attached Properties

Name | Description
Command |

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


KeyDown Constructor

[image]

Telerik Reporting Q2 2012
KeyDown Constructor
KeyDown Class See Also Send Feedback
Initializes a new instance of the KeyDown class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public KeyDown()
Visual Basic (Declaration)
Public Sub New

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


KeyDown Fields

[image] [image]

Telerik Reporting Q2 2012
KeyDown Fields
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Fields

Name | Description
CommandProperty |

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


CommandProperty Field

[image]

Telerik Reporting Q2 2012
KeyDown..::.CommandProperty Field
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty CommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly CommandProperty As DependencyProperty

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


KeyDown Methods

[image] [image]

Telerik Reporting Q2 2012
KeyDown Methods
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Methods

Name | Description
GetCommand |
SetCommand |

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


GetCommand Method

[image]

Telerik Reporting Q2 2012
KeyDown..::.GetCommand Method
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static ICommand GetCommand(
    DependencyObject d
)
Visual Basic (Declaration)
Public Shared Function GetCommand ( _
    d As DependencyObject _
) As ICommand

Parameters

d
Type: System.Windows..::.DependencyObject

Return Value

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


SetCommand Method

[image]

Telerik Reporting Q2 2012
KeyDown..::.SetCommand Method
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static void SetCommand(
    DependencyObject d,
    ICommand value
)
Visual Basic (Declaration)
Public Shared Sub SetCommand ( _
    d As DependencyObject, _
    value As ICommand _
)

Parameters

d
Type: System.Windows..::.DependencyObject
value
Type: System.Windows.Input..::.ICommand

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


KeyDown Attached Properties

[image] [image]

Telerik Reporting Q2 2012
KeyDown Attached Properties
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Attached Properties

Name | Description
Command |

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


Command Attached Property

[image]

Telerik Reporting Q2 2012
KeyDown..::.Command Attached Property
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
See GetCommand, SetCommand
Visual Basic (Declaration)
See GetCommand, SetCommand

See Also

KeyDown Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel Class

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class MultivalueAvailableValuesParameterModel : ParameterModel
Visual Basic (Declaration)
Public Class MultivalueAvailableValuesParameterModel _
    Inherits ParameterModel

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ParameterModel
Telerik.ReportViewer.Silverlight..::.MultivalueAvailableValuesParameterModel

See Also

MultivalueAvailableValuesParameterModel Members
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Members
MultivalueAvailableValuesParameterModel Class Properties See Also Send Feedback

The MultivalueAvailableValuesParameterModel type exposes the following members.

Properties

Name | Description
AvailableValues | Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem. (Overrides ParameterModel..::.AvailableValues.)
IsDropDownOpen | Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.
SelectedLabels | Gets an enumerable of strings that contains the labels of all selected values.
Value | Gets or sets the Value. (Overrides ParameterModel..::.Value.)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel Properties

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Properties
MultivalueAvailableValuesParameterModel Class See Also Send Feedback

The MultivalueAvailableValuesParameterModel type exposes the following members.

Properties

Name | Description
AvailableValues | Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem. (Overrides ParameterModel..::.AvailableValues.)
IsDropDownOpen | Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.
SelectedLabels | Gets an enumerable of strings that contains the labels of all selected values.
Value | Gets or sets the Value. (Overrides ParameterModel..::.Value.)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.AvailableValues Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public override List<ParameterValueModel> AvailableValues { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AvailableValues As List(Of ParameterValueModel)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


IsDropDownOpen Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.IsDropDownOpen Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


SelectedLabels Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.SelectedLabels Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets an enumerable of strings that contains the labels of all selected values.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IEnumerable<string> SelectedLabels { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedLabels As IEnumerable(Of String)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Value Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.Value Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets or sets the Value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public override Object Value { get; set; }
Visual Basic (Declaration)
Public Overrides Property Value As Object

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Class

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Class
MultivalueAvailableValuesParameterModel Class Members See Also Send Feedback
Represents the SelectAll item in a Multivalue/AvailableValues editor

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class SelectAllItem : ParameterValueModel
Visual Basic (Declaration)
Public Class SelectAllItem _
    Inherits ParameterValueModel

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ParameterValueModel
Telerik.ReportViewer.Silverlight..::.MultivalueAvailableValuesParameterModel..::.SelectAllItem

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Members
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Members
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class Properties See Also Send Feedback

The MultivalueAvailableValuesParameterModel..::.SelectAllItem type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the item is selected. (Overrides ParameterValueModel..::.IsSelected.)

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Properties

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Properties
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class See Also Send Feedback

The MultivalueAvailableValuesParameterModel..::.SelectAllItem type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the item is selected. (Overrides ParameterValueModel..::.IsSelected.)

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Silverlight Namespace


IsSelected Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem..::.IsSelected Property
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class See Also Send Feedback
Specifies whether the item is selected.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public override bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsSelected As Boolean

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueParameterConverter Class

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Class
Members See Also Send Feedback
A value converter for multi-value parameters

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class MultivalueParameterConverter : IValueConverter
Visual Basic (Declaration)
Public Class MultivalueParameterConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.MultivalueParameterConverter

See Also

MultivalueParameterConverter Members
Telerik.ReportViewer.Silverlight Namespace


MultivalueParameterConverter Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Members
MultivalueParameterConverter Class Constructors Methods See Also Send Feedback

The MultivalueParameterConverter type exposes the following members.

Constructors

Name | Description
MultivalueParameterConverter | Creates new instance of MultivalueParameterConverter.

Methods

Name | Description
Convert | Converts a multi-value to single string value.
ConvertBack | Converts a single string value to multi-value.

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueParameterConverter Constructor

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Constructor
MultivalueParameterConverter Class See Also Send Feedback
Creates new instance of MultivalueParameterConverter.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public MultivalueParameterConverter()
Visual Basic (Declaration)
Public Sub New

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Silverlight Namespace


MultivalueParameterConverter Methods

[image] [image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Methods
MultivalueParameterConverter Class See Also Send Feedback

The MultivalueParameterConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a multi-value to single string value.
ConvertBack | Converts a single string value to multi-value.

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Silverlight Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter..::.Convert Method
MultivalueParameterConverter Class See Also Send Feedback
Converts a multi-value to single string value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Silverlight Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter..::.ConvertBack Method
MultivalueParameterConverter Class See Also Send Feedback
Converts a single string value to multi-value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Silverlight Namespace


ObservableObject Class

[image]

Telerik Reporting Q2 2012
ObservableObject Class
Members See Also Send Feedback
Represents an observable object.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ObservableObject : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ObservableObject _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Common..::.DocumentMapNodeModel
Telerik.ReportViewer.Silverlight..::.ParameterModel
Telerik.ReportViewer.Silverlight..::.ParameterValueModel
Telerik.ReportViewer.Silverlight..::.ReportViewerModel
Telerik.ReportViewer.Silverlight..::.ReportViewerModel..::.Command

See Also

ObservableObject Members
Telerik.ReportViewer.Silverlight Namespace


ObservableObject Members

[image] [image]

Telerik Reporting Q2 2012
ObservableObject Members
ObservableObject Class Constructors Methods Events See Also Send Feedback

The ObservableObject type exposes the following members.

Constructors

Name | Description
ObservableObject | Initializes a new instance of the ObservableObject class

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


ObservableObject Constructor

[image]

Telerik Reporting Q2 2012
ObservableObject Constructor
ObservableObject Class See Also Send Feedback
Initializes a new instance of the ObservableObject class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ObservableObject()
Visual Basic (Declaration)
Public Sub New

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


ObservableObject Methods

[image] [image]

Telerik Reporting Q2 2012
ObservableObject Methods
ObservableObject Class See Also Send Feedback

The ObservableObject type exposes the following members.

Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


OnPropertyChanged Method

[image]

Telerik Reporting Q2 2012
ObservableObject..::.OnPropertyChanged Method
ObservableObject Class See Also Send Feedback
Raises the PropertyChanged event.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    string propertyName
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    propertyName As String _
)

Parameters

propertyName
Type: System..::.String

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


ObservableObject Events

[image] [image]

Telerik Reporting Q2 2012
ObservableObject Events
ObservableObject Class See Also Send Feedback

The ObservableObject type exposes the following members.

Events

Name | Description
PropertyChanged | Occurs when a property value changes.

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
ObservableObject..::.PropertyChanged Event
ObservableObject Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ObservableObject Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModel Class

[image]

Telerik Reporting Q2 2012
ParameterModel Class
Members See Also Send Feedback
Represents the report parameter model to associate the parameter editor UI with.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ParameterModel : ObservableObject,
    IDataErrorInfo
Visual Basic (Declaration)
Public Class ParameterModel _
    Inherits ObservableObject _
    Implements IDataErrorInfo

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ParameterModel
Telerik.ReportViewer.Silverlight..::.MultivalueAvailableValuesParameterModel

See Also

ParameterModel Members
Telerik.ReportViewer.Silverlight Namespace


ParameterModel Members

[image] [image]

Telerik Reporting Q2 2012
ParameterModel Members
ParameterModel Class Methods Properties See Also Send Feedback

The ParameterModel type exposes the following members.

Methods

Name | Description
ConvertFrom | Converts a value to the type of the represented parameter. Throws FormatException if the specified value cannot be converted to the parameter type.
HasValidValue | Returns HasValidValue()()().

Properties

Name | Description
AllowNull | Gets the AllowNull.
AutoRefresh | Gets the AutoRefresh.
AvailableValues | Gets a list of the available ParameterValueModels.
IsEnabled | Specifies whether the parameter editor is enabled or not.
IsNull | Specifies whether the 'null' value is selected.
Multivalue | Gets the Multivalue.
Name | Gets the Name.
SelectedSingleValue | Gets or sets a single selected value.
Text | Gets the Text.
TextResources | Gets or sets all the tooltips and messages
Type | Gets the Type.
Value | Gets or sets the Value.

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModel Methods

[image] [image]

Telerik Reporting Q2 2012
ParameterModel Methods
ParameterModel Class See Also Send Feedback

The ParameterModel type exposes the following members.

Methods

Name | Description
ConvertFrom | Converts a value to the type of the represented parameter. Throws FormatException if the specified value cannot be converted to the parameter type.
HasValidValue | Returns HasValidValue()()().

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


ConvertFrom Method

[image]

Telerik Reporting Q2 2012
ParameterModel..::.ConvertFrom Method
ParameterModel Class See Also Send Feedback
Converts a value to the type of the represented parameter. Throws FormatException if the specified value cannot be converted to the parameter type.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected Object ConvertFrom(
    Object value
)
Visual Basic (Declaration)
Protected Function ConvertFrom ( _
    value As Object _
) As Object

Parameters

value
Type: System..::.Object

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


HasValidValue Method

[image]

Telerik Reporting Q2 2012
ParameterModel..::.HasValidValue Method
ParameterModel Class See Also Send Feedback
Returns HasValidValue()()().

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool HasValidValue()
Visual Basic (Declaration)
Public Function HasValidValue As Boolean

Return Value

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModel Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterModel Properties
ParameterModel Class See Also Send Feedback

The ParameterModel type exposes the following members.

Properties

Name | Description
AllowNull | Gets the AllowNull.
AutoRefresh | Gets the AutoRefresh.
AvailableValues | Gets a list of the available ParameterValueModels.
IsEnabled | Specifies whether the parameter editor is enabled or not.
IsNull | Specifies whether the 'null' value is selected.
Multivalue | Gets the Multivalue.
Name | Gets the Name.
SelectedSingleValue | Gets or sets a single selected value.
Text | Gets the Text.
TextResources | Gets or sets all the tooltips and messages
Type | Gets the Type.
Value | Gets or sets the Value.

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


AllowNull Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.AllowNull Property
ParameterModel Class See Also Send Feedback
Gets the AllowNull.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AllowNull { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowNull As Boolean

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


AutoRefresh Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.AutoRefresh Property
ParameterModel Class See Also Send Feedback
Gets the AutoRefresh.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AutoRefresh { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoRefresh As Boolean

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.AvailableValues Property
ParameterModel Class See Also Send Feedback
Gets a list of the available ParameterValueModels.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public virtual List<ParameterValueModel> AvailableValues { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property AvailableValues As List(Of ParameterValueModel)

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


IsEnabled Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.IsEnabled Property
ParameterModel Class See Also Send Feedback
Specifies whether the parameter editor is enabled or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsEnabled As Boolean

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


IsNull Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.IsNull Property
ParameterModel Class See Also Send Feedback
Specifies whether the 'null' value is selected.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsNull { get; set; }
Visual Basic (Declaration)
Public Property IsNull As Boolean

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Multivalue Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.Multivalue Property
ParameterModel Class See Also Send Feedback
Gets the Multivalue.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool Multivalue { get; }
Visual Basic (Declaration)
Public ReadOnly Property Multivalue As Boolean

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.Name Property
ParameterModel Class See Also Send Feedback
Gets the Name.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


SelectedSingleValue Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.SelectedSingleValue Property
ParameterModel Class See Also Send Feedback
Gets or sets a single selected value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ParameterValueModel SelectedSingleValue { get; set; }
Visual Basic (Declaration)
Public Property SelectedSingleValue As ParameterValueModel

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Text Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.Text Property
ParameterModel Class See Also Send Feedback
Gets the Text.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.TextResources Property
ParameterModel Class See Also Send Feedback
Gets or sets all the tooltips and messages

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ITextResources TextResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextResources As ITextResources

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.Type Property
ParameterModel Class See Also Send Feedback
Gets the Type.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As String

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.Value Property
ParameterModel Class See Also Send Feedback
Gets or sets the Value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public virtual Object Value { get; set; }
Visual Basic (Declaration)
Public Overridable Property Value As Object

See Also

ParameterModel Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModelCollection Class

[image]

Telerik Reporting Q2 2012
ParameterModelCollection Class
Members See Also Send Feedback
Represents a collection of parameter models.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ParameterModelCollection : Collection<ParameterModel>
Visual Basic (Declaration)
Public Class ParameterModelCollection _
    Inherits Collection(Of ParameterModel)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ParameterModel >)>)>
Telerik.ReportViewer.Silverlight..::.ParameterModelCollection

See Also

ParameterModelCollection Members
Telerik.ReportViewer.Silverlight Namespace


ParameterModelCollection Members

[image] [image]

Telerik Reporting Q2 2012
ParameterModelCollection Members
ParameterModelCollection Class Methods See Also Send Feedback

The ParameterModelCollection type exposes the following members.

Methods

Name | Description
InsertItem | Inserts a ParameterModel item at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

ParameterModelCollection Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModelCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ParameterModelCollection Methods
ParameterModelCollection Class See Also Send Feedback

The ParameterModelCollection type exposes the following members.

Methods

Name | Description
InsertItem | Inserts a ParameterModel item at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)

See Also

ParameterModelCollection Class
Telerik.ReportViewer.Silverlight Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
ParameterModelCollection..::.InsertItem Method
ParameterModelCollection Class See Also Send Feedback
Inserts a ParameterModel item at the specified index.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    ParameterModel item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As ParameterModel _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.ReportViewer.Silverlight..::.ParameterModel

See Also

ParameterModelCollection Class
Telerik.ReportViewer.Silverlight Namespace


ParameterValueModel Class

[image]

Telerik Reporting Q2 2012
ParameterValueModel Class
Members See Also Send Feedback
Represents the parameter value model.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ParameterValueModel : ObservableObject
Visual Basic (Declaration)
Public Class ParameterValueModel _
    Inherits ObservableObject

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ParameterValueModel
Telerik.ReportViewer.Silverlight..::.MultivalueAvailableValuesParameterModel..::.SelectAllItem

See Also

ParameterValueModel Members
Telerik.ReportViewer.Silverlight Namespace


ParameterValueModel Members

[image] [image]

Telerik Reporting Q2 2012
ParameterValueModel Members
ParameterValueModel Class Properties See Also Send Feedback

The ParameterValueModel type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the parameter value is selected.
Name | Gets the Name.
Owner | Gets the owner parameter model.
Value | Gets Value

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


ParameterValueModel Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterValueModel Properties
ParameterValueModel Class See Also Send Feedback

The ParameterValueModel type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the parameter value is selected.
Name | Gets the Name.
Owner | Gets the owner parameter model.
Value | Gets Value

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


IsSelected Property

[image]

Telerik Reporting Q2 2012
ParameterValueModel..::.IsSelected Property
ParameterValueModel Class See Also Send Feedback
Specifies whether the parameter value is selected.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public virtual bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsSelected As Boolean

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


Name Property

[image]

Telerik Reporting Q2 2012
ParameterValueModel..::.Name Property
ParameterValueModel Class See Also Send Feedback
Gets the Name.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


Owner Property

[image]

Telerik Reporting Q2 2012
ParameterValueModel..::.Owner Property
ParameterValueModel Class See Also Send Feedback
Gets the owner parameter model.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ParameterModel Owner { get; }
Visual Basic (Declaration)
Public ReadOnly Property Owner As ParameterModel

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


Value Property

[image]

Telerik Reporting Q2 2012
ParameterValueModel..::.Value Property
ParameterValueModel Class See Also Send Feedback
Gets Value

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Object

See Also

ParameterValueModel Class
Telerik.ReportViewer.Silverlight Namespace


RenderBeginEventArgs Class

[image]

Telerik Reporting Q2 2012
RenderBeginEventArgs Class
Members See Also Send Feedback
Provides data for the RenderBegin event.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class RenderBeginEventArgs
Visual Basic (Declaration)
Public Class RenderBeginEventArgs

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.RenderBeginEventArgs

See Also

RenderBeginEventArgs Members
Telerik.ReportViewer.Silverlight Namespace


RenderBeginEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
RenderBeginEventArgs Members
RenderBeginEventArgs Class Constructors Properties See Also Send Feedback

The RenderBeginEventArgs type exposes the following members.

Constructors

Name | Description
RenderBeginEventArgs | Initializes a new instance of the RenderBeginEventArgs class.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
ParameterValues | Gets a NameValueDictionary for the values of the report parameters.

See Also

RenderBeginEventArgs Class
Telerik.ReportViewer.Silverlight Namespace


RenderBeginEventArgs Constructor

[image]

Telerik Reporting Q2 2012
RenderBeginEventArgs Constructor
RenderBeginEventArgs Class See Also Send Feedback
Initializes a new instance of the RenderBeginEventArgs class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public RenderBeginEventArgs(
    NameValueDictionary parameterValues,
    bool cancel
)
Visual Basic (Declaration)
Public Sub New ( _
    parameterValues As NameValueDictionary, _
    cancel As Boolean _
)

Parameters

parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
cancel
Type: System..::.Boolean

See Also

RenderBeginEventArgs Class
Telerik.ReportViewer.Silverlight Namespace


RenderBeginEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
RenderBeginEventArgs Properties
RenderBeginEventArgs Class See Also Send Feedback

The RenderBeginEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.
ParameterValues | Gets a NameValueDictionary for the values of the report parameters.

See Also

RenderBeginEventArgs Class
Telerik.ReportViewer.Silverlight Namespace


Cancel Property

[image]

Telerik Reporting Q2 2012
RenderBeginEventArgs..::.Cancel Property
RenderBeginEventArgs Class See Also Send Feedback
Gets or sets a value indicating whether the event should be canceled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

RenderBeginEventArgs Class
Telerik.ReportViewer.Silverlight Namespace


ParameterValues Property

[image]

Telerik Reporting Q2 2012
RenderBeginEventArgs..::.ParameterValues Property
RenderBeginEventArgs Class See Also Send Feedback
Gets a NameValueDictionary for the values of the report parameters.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public NameValueDictionary ParameterValues { get; internal set; }
Visual Basic (Declaration)
Public Property ParameterValues As NameValueDictionary

See Also

RenderBeginEventArgs Class
Telerik.ReportViewer.Silverlight Namespace


RenderBeginEventHandler Delegate

[image]

Telerik Reporting Q2 2012
RenderBeginEventHandler Delegate
See Also Send Feedback
Represents the method that will handle the RenderBegin event.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public delegate void RenderBeginEventHandler(
    Object sender,
    RenderBeginEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub RenderBeginEventHandler ( _
    sender As Object, _
    args As RenderBeginEventArgs _
)

Parameters

sender
Type: System..::.Object
args
Type: Telerik.ReportViewer.Silverlight..::.RenderBeginEventArgs

See Also

Telerik.ReportViewer.Silverlight Namespace


ReportParameterEditorTemplateSelector Class

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Class
Members See Also Send Feedback
Represents a selector for the report parameter editor templates.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportParameterEditorTemplateSelector
Visual Basic (Declaration)
Public Class ReportParameterEditorTemplateSelector

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ReportParameterEditorTemplateSelector

See Also

ReportParameterEditorTemplateSelector Members
Telerik.ReportViewer.Silverlight Namespace


ReportParameterEditorTemplateSelector Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Members
ReportParameterEditorTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Constructors

Name | Description
ReportParameterEditorTemplateSelector | Initializes a new instance of the ReportParameterEditorTemplateSelector class

Methods

Name | Description
SelectTemplate | Gets the proper editor template for the given parameter model.

Properties

Name | Description
Templates | Gets a list of DataTemplate.

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterEditorTemplateSelector Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Constructor
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Initializes a new instance of the ReportParameterEditorTemplateSelector class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportParameterEditorTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterEditorTemplateSelector Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Methods
ReportParameterEditorTemplateSelector Class See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Methods

Name | Description
SelectTemplate | Gets the proper editor template for the given parameter model.

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


SelectTemplate Method

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector..::.SelectTemplate Method
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Gets the proper editor template for the given parameter model.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
An instance of ParameterModel.
container
Type: System.Windows..::.DependencyObject

Return Value

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterEditorTemplateSelector Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Properties
ReportParameterEditorTemplateSelector Class See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Properties

Name | Description
Templates | Gets a list of DataTemplate.

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


Templates Property

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector..::.Templates Property
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Gets a list of DataTemplate.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public List<DataTemplate> Templates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Templates As List(Of DataTemplate)

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Class

[image]

Telerik Reporting Q2 2012
ReportParametersControl Class
Members See Also Send Feedback
Represents a control that holds a collection of ReportParameterTemplate.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportParametersControl : ItemsControl
Visual Basic (Declaration)
Public Class ReportParametersControl _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
Telerik.ReportViewer.Silverlight..::.ReportParametersControl

See Also

ReportParametersControl Members
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Members

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Members
ReportParametersControl Class Constructors Methods Fields Properties See Also Send Feedback

The ReportParametersControl type exposes the following members.

Constructors

Name | Description
ReportParametersControl | Initializes a new instance of the ReportParametersControl class

Methods

Name | Description
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)

Fields

Name | Description
ItemTemplateSelectorProperty | Represents the ParameterTemplateSelector property.

Properties

Name | Description
ParameterTemplateSelector | Gets or sets ReportParameterEditorTemplateSelector.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Constructor

[image]

Telerik Reporting Q2 2012
ReportParametersControl Constructor
ReportParametersControl Class See Also Send Feedback
Initializes a new instance of the ReportParametersControl class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportParametersControl()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Fields

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Fields
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Fields

Name | Description
ItemTemplateSelectorProperty | Represents the ParameterTemplateSelector property.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ItemTemplateSelectorProperty Field

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.ItemTemplateSelectorProperty Field
ReportParametersControl Class See Also Send Feedback
Represents the ParameterTemplateSelector property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Methods
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Methods

Name | Description
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.PrepareContainerForItemOverride Method
ReportParametersControl Class See Also Send Feedback
Prepares the specified element to display the specified item.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersControl Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Properties
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Properties

Name | Description
ParameterTemplateSelector | Gets or sets ReportParameterEditorTemplateSelector.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ParameterTemplateSelector Property

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.ParameterTemplateSelector Property
ReportParametersControl Class See Also Send Feedback
Gets or sets ReportParameterEditorTemplateSelector.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportParameterEditorTemplateSelector ParameterTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ParameterTemplateSelector As ReportParameterEditorTemplateSelector

See Also

ReportParametersControl Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterTemplate Class

[image]

Telerik Reporting Q2 2012
ReportParameterTemplate Class
Members See Also Send Feedback
Represents a report parameter editor data template.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportParameterTemplate : DataTemplate
Visual Basic (Declaration)
Public Class ReportParameterTemplate _
    Inherits DataTemplate

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.FrameworkTemplate
System.Windows..::.DataTemplate
Telerik.ReportViewer.Silverlight..::.ReportParameterTemplate

See Also

ReportParameterTemplate Members
Telerik.ReportViewer.Silverlight Namespace


ReportParameterTemplate Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterTemplate Members
ReportParameterTemplate Class Constructors Properties See Also Send Feedback

The ReportParameterTemplate type exposes the following members.

Constructors

Name | Description
ReportParameterTemplate | Initializes a new instance of the ReportParameterTemplate class

Properties

Name | Description
AvailableValues | Specifies whether the template can be used for parameters with available values.
Multivalue | Specifies whether the template can be used for multivalue parameters.
Type | Specifies the parameter type for which this template should be used.

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterTemplate Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterTemplate Constructor
ReportParameterTemplate Class See Also Send Feedback
Initializes a new instance of the ReportParameterTemplate class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportParameterTemplate()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


ReportParameterTemplate Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterTemplate Properties
ReportParameterTemplate Class See Also Send Feedback

The ReportParameterTemplate type exposes the following members.

Properties

Name | Description
AvailableValues | Specifies whether the template can be used for parameters with available values.
Multivalue | Specifies whether the template can be used for multivalue parameters.
Type | Specifies the parameter type for which this template should be used.

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
ReportParameterTemplate..::.AvailableValues Property
ReportParameterTemplate Class See Also Send Feedback
Specifies whether the template can be used for parameters with available values.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool AvailableValues { get; set; }
Visual Basic (Declaration)
Public Property AvailableValues As Boolean

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


Multivalue Property

[image]

Telerik Reporting Q2 2012
ReportParameterTemplate..::.Multivalue Property
ReportParameterTemplate Class See Also Send Feedback
Specifies whether the template can be used for multivalue parameters.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool Multivalue { get; set; }
Visual Basic (Declaration)
Public Property Multivalue As Boolean

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ReportParameterTemplate..::.Type Property
ReportParameterTemplate Class See Also Send Feedback
Specifies the parameter type for which this template should be used.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String

See Also

ReportParameterTemplate Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Class

[image]

Telerik Reporting Q2 2012
ReportViewer Class
Members See Also Send Feedback
Represents the Silverlight ReportViewer control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportViewer : Control,
    IReportViewer, IReportServiceClientFactory
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits Control _
    Implements IReportViewer, IReportServiceClientFactory

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Telerik.ReportViewer.Silverlight..::.ReportViewer

See Also

ReportViewer Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Members
ReportViewer Class Constructors Methods Fields Properties Events See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Methods

Name | Description
EnsureAbsoluteUri | Determines whether the given Uri is absolute. If not, creates a new absolute Uri based on the combination of [!:SilverlightHost.Source] for the current application and the given relative uri.
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnRenderBegin | Occurs when rendering begins.

Fields

Name | Description
ReportProperty | Defines the Report dependency property.
ReportServiceClientFactoryProperty | Defines the ReportServiceClientFactory property.
ReportServiceUriProperty | Defines the ReportServiceUri property.
ReportSourceUriProperty | Obsolete. Defines the ReportSourceUri property.
TextResourcesProperty | Defines the TextResources property.
UseNativePrintingProperty | Defines the UseNativePrinting property.
ViewModeProperty | Defines the ViewMode property.
ZoomModeProperty | Defines the ZoomMode property.
ZoomPercentProperty | Defines the ZoomPercent property.

Properties

Name | Description
Report | Specifies the assembly qualified name of the report class which should be displayed by the viewer.
ReportServerUri | Obsolete. Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.
ReportServiceClientFactory | Gets or sets the IReportServiceClientFactory that ReportViewer will use the next time a new instance of ReportServiceClient is required.
ReportServiceUri | Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.
TextResources | Gets or sets the tooltips and the messages of the control.
UseNativePrinting | Specifies whether to use native Silverlight printing or not.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the control.
ZoomPercent | Gets or sets the zoom percentage to use when displaying the report.

Events

Name | Description
RenderBegin | Occurs when rendering of the report begins.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Constructor

[image]

Telerik Reporting Q2 2012
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Fields
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Fields

Name | Description
ReportProperty | Defines the Report dependency property.
ReportServiceClientFactoryProperty | Defines the ReportServiceClientFactory property.
ReportServiceUriProperty | Defines the ReportServiceUri property.
ReportSourceUriProperty | Obsolete. Defines the ReportSourceUri property.
TextResourcesProperty | Defines the TextResources property.
UseNativePrintingProperty | Defines the UseNativePrinting property.
ViewModeProperty | Defines the ViewMode property.
ZoomModeProperty | Defines the ZoomMode property.
ZoomPercentProperty | Defines the ZoomPercent property.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportProperty Field
ReportViewer Class See Also Send Feedback
Defines the Report dependency property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ReportProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReportProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportServiceClientFactoryProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportServiceClientFactoryProperty Field
ReportViewer Class See Also Send Feedback
Defines the ReportServiceClientFactory property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ReportServiceClientFactoryProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReportServiceClientFactoryProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportServiceUriProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportServiceUriProperty Field
ReportViewer Class See Also Send Feedback
Defines the ReportServiceUri property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ReportServiceUriProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReportServiceUriProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportSourceUriProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportSourceUriProperty Field
ReportViewer Class See Also Send Feedback
Defines the ReportSourceUri property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
[ObsoleteAttribute("Property ReportSourceUriProperty is now obsolete. Use ReportServiceUriProperty instead.")]
public static readonly DependencyProperty ReportSourceUriProperty
Visual Basic (Declaration)
<ObsoleteAttribute("Property ReportSourceUriProperty is now obsolete. Use ReportServiceUriProperty instead.")> _
Public Shared ReadOnly ReportSourceUriProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


TextResourcesProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.TextResourcesProperty Field
ReportViewer Class See Also Send Feedback
Defines the TextResources property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextResourcesProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextResourcesProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


UseNativePrintingProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.UseNativePrintingProperty Field
ReportViewer Class See Also Send Feedback
Defines the UseNativePrinting property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty UseNativePrintingProperty
Visual Basic (Declaration)
Public Shared ReadOnly UseNativePrintingProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ViewModeProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ViewModeProperty Field
ReportViewer Class See Also Send Feedback
Defines the ViewMode property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ViewModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewModeProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ZoomModeProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomModeProperty Field
ReportViewer Class See Also Send Feedback
Defines the ZoomMode property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ZoomModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomModeProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ZoomPercentProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomPercentProperty Field
ReportViewer Class See Also Send Feedback
Defines the ZoomPercent property.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ZoomPercentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomPercentProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
EnsureAbsoluteUri | Determines whether the given Uri is absolute. If not, creates a new absolute Uri based on the combination of [!:SilverlightHost.Source] for the current application and the given relative uri.
OnApplyTemplate | Invoked whenever application code or internal processes call ApplyTemplate. (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnRenderBegin | Occurs when rendering begins.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


EnsureAbsoluteUri Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.EnsureAbsoluteUri Method
ReportViewer Class Example See Also Send Feedback
Determines whether the given Uri is absolute. If not, creates a new absolute Uri based on the combination of [!:SilverlightHost.Source] for the current application and the given relative uri.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static Uri EnsureAbsoluteUri(
    Uri uri
)
Visual Basic (Declaration)
Public Shared Function EnsureAbsoluteUri ( _
    uri As Uri _
) As Uri

Parameters

uri
Type: System..::.Uri
The Uri that is being checked.

Return Value

An absolute Uri.

Remarks

If the uri is absolute, the same instance is returned.

If the uri is relative, a new absolute Uri based on the combination of [!:SilverlightHost.Source] of the current application and the given relative uri is created. The [!:SilverlightHost.Source] usually points to the application package (XAP).

Examples

The following example shows some common scenarios and the absolute Uris returned. Consider that the [!:SilverlightHost.Source] Uri points to http://mydomain/MyWebSite/ClientBin/MyApp.xap:
CopyC#
//Absolute Uri (no change):
EnsureAbsoluteUri(new Uri("http://mydomain/MyWebSite/ReportService.svc", UriKind.Absolute));    // http://mydomain/MyWebSite/ReportService.svc
//Relative Uris:
EnsureAbsoluteUri(new Uri("ReportService.svc", UriKind.Relative)); // http://mydomain/MyWebSite/ClientBin/ReportService.svc
EnsureAbsoluteUri(new Uri("../ReportService.svc", UriKind.Relative)); // http://mydomain/MyWebSite/ReportService.svc
EnsureAbsoluteUri(new Uri("/ReportService.svc", UriKind.Relative)); // http://mydomain/ReportService.svc
Copy
'Absolute Uri (no change):
EnsureAbsoluteUri(New Uri("http://mydomain/MyWebSite/ReportService.svc", UriKind.Absolute))    ' http://mydomain/MyWebSite/ReportService.svc
'Relative Uris:
EnsureAbsoluteUri(New Uri("ReportService.svc", UriKind.Relative)) ' http://mydomain/MyWebSite/ClientBin/ReportService.svc
EnsureAbsoluteUri(New Uri("../ReportService.svc", UriKind.Relative)) ' http://mydomain/MyWebSite/ReportService.svc
EnsureAbsoluteUri(New Uri("/ReportService.svc", UriKind.Relative)) ' http://mydomain/ReportService.svc

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


OnApplyTemplate Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnApplyTemplate Method
ReportViewer Class See Also Send Feedback
Invoked whenever application code or internal processes call ApplyTemplate.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


OnRenderBegin Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnRenderBegin Method
ReportViewer Class See Also Send Feedback
Occurs when rendering begins.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected virtual bool OnRenderBegin(
    NameValueDictionary parameterValues
)
Visual Basic (Declaration)
Protected Overridable Function OnRenderBegin ( _
    parameterValues As NameValueDictionary _
) As Boolean

Parameters

parameterValues
Type: Telerik.Reporting.Service..::.NameValueDictionary
A NameValueDictionary with parameter values for the current report to render.

Return Value

Return false to cancel the rendering operation otherwise return true.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
Report | Specifies the assembly qualified name of the report class which should be displayed by the viewer.
ReportServerUri | Obsolete. Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.
ReportServiceClientFactory | Gets or sets the IReportServiceClientFactory that ReportViewer will use the next time a new instance of ReportServiceClient is required.
ReportServiceUri | Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.
TextResources | Gets or sets the tooltips and the messages of the control.
UseNativePrinting | Specifies whether to use native Silverlight printing or not.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the control.
ZoomPercent | Gets or sets the zoom percentage to use when displaying the report.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Report Property
ReportViewer Class See Also Send Feedback
Specifies the assembly qualified name of the report class which should be displayed by the viewer.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Report { get; set; }
Visual Basic (Declaration)
Public Property Report As String

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportServerUri Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportServerUri Property
ReportViewer Class See Also Send Feedback
Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
[ObsoleteAttribute("Property ReportServerUri is now obsolete. Use the ReportServiceUri property instead.")]
public Uri ReportServerUri { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Property ReportServerUri is now obsolete. Use the ReportServiceUri property instead.")> _
Public Property ReportServerUri As Uri

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace
ReportViewer..::.EnsureAbsoluteUri(Uri)


ReportServiceClientFactory Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportServiceClientFactory Property
ReportViewer Class Example See Also Send Feedback
Gets or sets the IReportServiceClientFactory that ReportViewer will use the next time a new instance of ReportServiceClient is required.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IReportServiceClientFactory ReportServiceClientFactory { get; set; }
Visual Basic (Declaration)
Public Property ReportServiceClientFactory As IReportServiceClientFactory

Remarks

The ReportViewer usually passes absolute Uri to the Create(Uri) method. For more information on how ReportServiceUri is resolved to absolute see EnsureAbsoluteUri(Uri).

Examples

This example illustrates how to implement and use a custom IReportServiceClientFactory.
CopyC#
using System;
using System.ServiceModel;
using System.Windows.Controls;
using Telerik.Reporting.Service.SilverlightClient;
using Telerik.ReportViewer.Silverlight;

public partial class MainPage : UserControl, IReportServiceClientFactory
{
    public MainPage()
    {
        InitializeComponent();

        this.ReportViewer1.ReportServiceClientFactory = this;
    }

    ReportServiceClient IReportServiceClientFactory.Create(System.Uri remoteAddress)
    {
        var binding = new BasicHttpBinding() // or BasicHttpBinding(BasicHttpSecurityMode.Transport) overload if SSL is used
        {
            MaxBufferSize = int.MaxValue,
            MaxReceivedMessageSize = int.MaxValue,
            ReceiveTimeout = new TimeSpan(0, 15, 0),
            SendTimeout = new TimeSpan(0, 15, 0)
        };

        var endpointAddress = new EndpointAddress(remoteAddress);

        return new ReportServiceClient(binding, endpointAddress);

    }
}
CopyVB.NET
Imports System
Imports System.ServiceModel
Imports System.Windows.Controls
Imports Telerik.Reporting.Service.SilverlightClient
Imports Telerik.ReportViewer.Silverlight

Partial Public Class MainPage
    Inherits UserControl
    Implements IReportServiceClientFactory

    Public Sub New()
        InitializeComponent()

        Me.ReportViewer1.ReportServiceClientFactory = Me

    End Sub

    Function Create(ByVal remoteAddress As Uri) As ReportServiceClient Implements IReportServiceClientFactory.Create

        Dim binding = New BasicHttpBinding()
        binding.MaxBufferSize = Integer.MaxValue
        binding.MaxReceivedMessageSize = Integer.MaxValue
        binding.ReceiveTimeout = New TimeSpan(0, 15, 0)
        binding.SendTimeout = New TimeSpan(0, 15, 0)

        Dim endpointAddress As New EndpointAddress(remoteAddress)

        Return New ReportServiceClient(binding, endpointAddress)

    End Function
End Class

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportServiceUri Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportServiceUri Property
ReportViewer Class See Also Send Feedback
Specifies the Uri to the Telerik WCF Report service. The Uri may be absolute or relative. For complete information on how the relative Uris are resolved to absolute please see EnsureAbsoluteUri(Uri) method.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Uri ReportServiceUri { get; set; }
Visual Basic (Declaration)
Public Property ReportServiceUri As Uri

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace
ReportViewer..::.EnsureAbsoluteUri(Uri)


TextResources Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.TextResources Property
ReportViewer Class See Also Send Feedback
Gets or sets the tooltips and the messages of the control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ITextResources TextResources { get; set; }
Visual Basic (Declaration)
Public Property TextResources As ITextResources

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


UseNativePrinting Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.UseNativePrinting Property
ReportViewer Class See Also Send Feedback
Specifies whether to use native Silverlight printing or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool UseNativePrinting { get; set; }
Visual Basic (Declaration)
Public Property UseNativePrinting As Boolean

Implements

IReportViewer..::.UseNativePrinting

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ViewMode Property
ReportViewer Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomMode Property
ReportViewer Class See Also Send Feedback
Gets or sets the zoom mode of the control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ZoomPercent Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomPercent Property
ReportViewer Class See Also Send Feedback
Gets or sets the zoom percentage to use when displaying the report.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int ZoomPercent { get; set; }
Visual Basic (Declaration)
Public Property ZoomPercent As Integer

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer Events

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Events
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Events

Name | Description
RenderBegin | Occurs when rendering of the report begins.

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


RenderBegin Event

[image]

Telerik Reporting Q2 2012
ReportViewer..::.RenderBegin Event
ReportViewer Class Example See Also Send Feedback
Occurs when rendering of the report begins.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public event RenderBeginEventHandler RenderBegin
Visual Basic (Declaration)
Public Event RenderBegin As RenderBeginEventHandler

Examples

This example illustrates how to wire the RenderBegin event and set values for specific parameters in the event handler.
CopyC#
public partial class MainPage : UserControl
{
    public MainPage()
    {
        InitializeComponent();
        this.ReportViewer1.RenderBegin += new RenderBeginEventHandler(ReportViewer1_RenderBegin);
    }

    void ReportViewer1_RenderBegin(object sender, RenderBeginEventArgs args)
    {
        //single value parameter
        args.ParameterValues["ProductCategory"] = "Components";
        //multi value parameter
        args.ParameterValues["ProductSubcategory"] = new object[] { "Brakes", "Chains" };
    }
}
CopyVB
Partial Public Class MainPage
    Inherits UserControl

    Public Sub New()
        InitializeComponent()
    End Sub

    Sub ReportViewer1_RenderBegin(ByVal sender As Object, ByVal args As RenderBeginEventArgs) Handles ReportViewer1.RenderBegin
        'single value parameter
        args.ParameterValues("ProductCategory") = "Components"
        'multi value parameter
        args.ParameterValues("ProductSubcategory") = New Object() {"Brakes", "Chains"}
    End Sub
End Class

See Also

ReportViewer Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer.TemplateParts Class

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Class
ReportViewer Class Members See Also Send Feedback
Specifies the template parts names.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static class TemplateParts
Visual Basic (Declaration)
Public NotInheritable Class TemplateParts

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ReportViewer..::.TemplateParts

See Also

ReportViewer..::.TemplateParts Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewer.TemplateParts Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Members
ReportViewer..::.TemplateParts Class Fields See Also Send Feedback

Represents the Silverlight ReportViewer control.

The ReportViewer..::.TemplateParts type exposes the following members.

Fields

Name | Description
LayoutRoot | Specifies the name of the layout root template part.
PageContainer | Specifies the name of the page container template part.
PageScrollViewer | Specifies the name of the page scroll viewer template part.

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewer.TemplateParts Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Fields
ReportViewer..::.TemplateParts Class See Also Send Feedback

The ReportViewer..::.TemplateParts type exposes the following members.

Fields

Name | Description
LayoutRoot | Specifies the name of the layout root template part.
PageContainer | Specifies the name of the page container template part.
PageScrollViewer | Specifies the name of the page scroll viewer template part.

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Silverlight Namespace


LayoutRoot Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.LayoutRoot Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the layout root template part.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string LayoutRoot
Visual Basic (Declaration)
Public Const LayoutRoot As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Silverlight Namespace


PageContainer Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.PageContainer Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the page container template part.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PageContainer
Visual Basic (Declaration)
Public Const PageContainer As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Silverlight Namespace


PageScrollViewer Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.PageScrollViewer Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the page scroll viewer template part.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PageScrollViewer
Visual Basic (Declaration)
Public Const PageScrollViewer As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel Class
Members See Also Send Feedback
Represents the report viewer model.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ReportViewerModel : ObservableObject
Visual Basic (Declaration)
Public Class ReportViewerModel _
    Inherits ObservableObject

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ReportViewerModel

See Also

ReportViewerModel Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel Members
ReportViewerModel Class Properties See Also Send Feedback

The ReportViewerModel type exposes the following members.

Properties

Name | Description
ApplyReportParametersCommand | Gets the ApplyReportParamters command.
AvailableZoomValues |
BookmarkTarget | Specifies the bookmark target.
CancelExportCommand | Gets the CancelExport command.
CancelPrintDocumentCommand | Gets the CancelPrintDocument command.
DocumentMapNodes | Gets or sets a list of document map nodes.
DocumentMapToolTip | Gets the Document Map tooltip
DocumentMapWidth | Gets or sets the width of the document map column
Error | Gets or sets the error message.
ExportProgress | Gets or sets the text displayed during the export action.
ExportReportCommand | Gets the ExportReport command.
HasDocumentMap | Indicates whether there is a document map or not.
HasParameters | Specifies whether there are parameters or not.
IsDocumentMapVisible | Indicates whether the document map is visible or not.
IsExportEnabled | Specifies whether the export is enabled.
IsMoveToPageEnabled | Specifies whether there is another page you can navigate to.
IsParametersAreaVisible | Specifies whether the parameters area is visible.
IsPreviewButtonVisible | Determines the preview button visibility state
IsPrintPreviewChecked | Specifies whether the PrintPreview mode is toggled.
IsToggleDocumentMapEnabled | Indicates whether the toggle document map button is enabled or not.
IsToggleParametersAreaEnabled | Specifies whether the toggle parameters area button is enabled.
MoveToFirstPageCommand | Gets the MoveToFirstPage command.
MoveToLastPageCommand | Gets the MoveToLastPage command.
MoveToNextPageCommand | Gets the MoveToNextPage command.
MoveToPreviousPageCommand | Gets the MoveToPreviousPage command.
NavigateBackCommand | Gets the NavigateBack command.
NavigateForwardCommand | Gets the NavigateForward command.
NavigateToSpecificPageCommand | Gets the NavigateToSpecificPageCommand command.
PageCount | Specifies the total number of the report pages.
PageHeight | Gets the current page height.
PageNumber | Gets or sets the current page number.
PageNumberModel | For internal use only
PageRoot | Specifies the page root.
PageTransform | Specifies the page transform.
PageWidth | Gets the current page width.
ParameterModels | Gets or sets a list of parameter models.
Parameters | Gets or sets a list of report parameters.
ParametersToolTip | Gets the Parameters tooltip
PrintDocumentCommand | Gets the PrintDocument command.
PrintPreviewToolTip | Gets the Print Preview/Interactive view tooltip
PrintProgress | Specifies the print progress.
PrintReportCommand | Gets the PrintReport command.
ProgressMessage | Specifies the text of the progress message.
RefreshReportCommand | Gets the RefreshReport command.
RenderingExtensions | Represents a list of rendering extension infos.
SaveExportCommand | Gets the SaveExport command.
SelectedDocumentMapNode | Gets or sets the selected node of the document map.
State | Gets or sets the report viewer state.
TextResources | Gets or sets all the tooltips and messages
TogglePrintPreviewCommand | Gets the TogglePrintPreviewCommand command.
UpdateParametersProgress | Gets or sets the text of the update parameters progress message.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Zoom | Specifies the scale factor.
ZoomMode |
ZoomText |

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel Properties
ReportViewerModel Class See Also Send Feedback

The ReportViewerModel type exposes the following members.

Properties

Name | Description
ApplyReportParametersCommand | Gets the ApplyReportParamters command.
AvailableZoomValues |
BookmarkTarget | Specifies the bookmark target.
CancelExportCommand | Gets the CancelExport command.
CancelPrintDocumentCommand | Gets the CancelPrintDocument command.
DocumentMapNodes | Gets or sets a list of document map nodes.
DocumentMapToolTip | Gets the Document Map tooltip
DocumentMapWidth | Gets or sets the width of the document map column
Error | Gets or sets the error message.
ExportProgress | Gets or sets the text displayed during the export action.
ExportReportCommand | Gets the ExportReport command.
HasDocumentMap | Indicates whether there is a document map or not.
HasParameters | Specifies whether there are parameters or not.
IsDocumentMapVisible | Indicates whether the document map is visible or not.
IsExportEnabled | Specifies whether the export is enabled.
IsMoveToPageEnabled | Specifies whether there is another page you can navigate to.
IsParametersAreaVisible | Specifies whether the parameters area is visible.
IsPreviewButtonVisible | Determines the preview button visibility state
IsPrintPreviewChecked | Specifies whether the PrintPreview mode is toggled.
IsToggleDocumentMapEnabled | Indicates whether the toggle document map button is enabled or not.
IsToggleParametersAreaEnabled | Specifies whether the toggle parameters area button is enabled.
MoveToFirstPageCommand | Gets the MoveToFirstPage command.
MoveToLastPageCommand | Gets the MoveToLastPage command.
MoveToNextPageCommand | Gets the MoveToNextPage command.
MoveToPreviousPageCommand | Gets the MoveToPreviousPage command.
NavigateBackCommand | Gets the NavigateBack command.
NavigateForwardCommand | Gets the NavigateForward command.
NavigateToSpecificPageCommand | Gets the NavigateToSpecificPageCommand command.
PageCount | Specifies the total number of the report pages.
PageHeight | Gets the current page height.
PageNumber | Gets or sets the current page number.
PageNumberModel | For internal use only
PageRoot | Specifies the page root.
PageTransform | Specifies the page transform.
PageWidth | Gets the current page width.
ParameterModels | Gets or sets a list of parameter models.
Parameters | Gets or sets a list of report parameters.
ParametersToolTip | Gets the Parameters tooltip
PrintDocumentCommand | Gets the PrintDocument command.
PrintPreviewToolTip | Gets the Print Preview/Interactive view tooltip
PrintProgress | Specifies the print progress.
PrintReportCommand | Gets the PrintReport command.
ProgressMessage | Specifies the text of the progress message.
RefreshReportCommand | Gets the RefreshReport command.
RenderingExtensions | Represents a list of rendering extension infos.
SaveExportCommand | Gets the SaveExport command.
SelectedDocumentMapNode | Gets or sets the selected node of the document map.
State | Gets or sets the report viewer state.
TextResources | Gets or sets all the tooltips and messages
TogglePrintPreviewCommand | Gets the TogglePrintPreviewCommand command.
UpdateParametersProgress | Gets or sets the text of the update parameters progress message.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Zoom | Specifies the scale factor.
ZoomMode |
ZoomText |

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ApplyReportParametersCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ApplyReportParametersCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the ApplyReportParamters command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand ApplyReportParametersCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ApplyReportParametersCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


AvailableZoomValues Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.AvailableZoomValues Property
ReportViewerModel Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IEnumerable<string> AvailableZoomValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableZoomValues As IEnumerable(Of String)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


BookmarkTarget Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.BookmarkTarget Property
ReportViewerModel Class See Also Send Feedback
Specifies the bookmark target.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public FrameworkElement BookmarkTarget { get; set; }
Visual Basic (Declaration)
Public Property BookmarkTarget As FrameworkElement

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


CancelExportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.CancelExportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the CancelExport command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand CancelExportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CancelExportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


CancelPrintDocumentCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.CancelPrintDocumentCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the CancelPrintDocument command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand CancelPrintDocumentCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CancelPrintDocumentCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapNodes Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapNodes Property
ReportViewerModel Class See Also Send Feedback
Gets or sets a list of document map nodes.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<DocumentMapNodeModel> DocumentMapNodes { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapNodes As IList(Of DocumentMapNodeModel)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Document Map tooltip

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string DocumentMapToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentMapToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapWidth Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapWidth Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the width of the document map column

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public GridLength DocumentMapWidth { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapWidth As GridLength

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


Error Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.Error Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the error message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string Error { get; set; }
Visual Basic (Declaration)
Public Property Error As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ExportProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ExportProgress Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the text displayed during the export action.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ExportProgress { get; set; }
Visual Basic (Declaration)
Public Property ExportProgress As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ExportReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ExportReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the ExportReport command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand ExportReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExportReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


HasDocumentMap Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.HasDocumentMap Property
ReportViewerModel Class See Also Send Feedback
Indicates whether there is a document map or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool HasDocumentMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasDocumentMap As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


HasParameters Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.HasParameters Property
ReportViewerModel Class See Also Send Feedback
Specifies whether there are parameters or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool HasParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasParameters As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsDocumentMapVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsDocumentMapVisible Property
ReportViewerModel Class See Also Send Feedback
Indicates whether the document map is visible or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsDocumentMapVisible { get; set; }
Visual Basic (Declaration)
Public Property IsDocumentMapVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsExportEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsExportEnabled Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the export is enabled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsExportEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsExportEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsMoveToPageEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsMoveToPageEnabled Property
ReportViewerModel Class See Also Send Feedback
Specifies whether there is another page you can navigate to.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsMoveToPageEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsMoveToPageEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsParametersAreaVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsParametersAreaVisible Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the parameters area is visible.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsParametersAreaVisible { get; set; }
Visual Basic (Declaration)
Public Property IsParametersAreaVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsPreviewButtonVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsPreviewButtonVisible Property
ReportViewerModel Class See Also Send Feedback
Determines the preview button visibility state

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsPreviewButtonVisible { get; set; }
Visual Basic (Declaration)
Public Property IsPreviewButtonVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsPrintPreviewChecked Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsPrintPreviewChecked Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the PrintPreview mode is toggled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsPrintPreviewChecked { get; set; }
Visual Basic (Declaration)
Public Property IsPrintPreviewChecked As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsToggleDocumentMapEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsToggleDocumentMapEnabled Property
ReportViewerModel Class See Also Send Feedback
Indicates whether the toggle document map button is enabled or not.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsToggleDocumentMapEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsToggleDocumentMapEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


IsToggleParametersAreaEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsToggleParametersAreaEnabled Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the toggle parameters area button is enabled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsToggleParametersAreaEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsToggleParametersAreaEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


MoveToFirstPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToFirstPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToFirstPage command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand MoveToFirstPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToFirstPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


MoveToLastPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToLastPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToLastPage command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand MoveToLastPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToLastPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


MoveToNextPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToNextPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToNextPage command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand MoveToNextPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToNextPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


MoveToPreviousPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToPreviousPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToPreviousPage command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand MoveToPreviousPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToPreviousPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


NavigateBackCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateBackCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateBack command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand NavigateBackCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateBackCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


NavigateForwardCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateForwardCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateForward command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand NavigateForwardCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateForwardCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


NavigateToSpecificPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateToSpecificPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateToSpecificPageCommand command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand NavigateToSpecificPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateToSpecificPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageCount Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageCount Property
ReportViewerModel Class See Also Send Feedback
Specifies the total number of the report pages.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageCount { get; set; }
Visual Basic (Declaration)
Public Property PageCount As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageHeight Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageHeight Property
ReportViewerModel Class See Also Send Feedback
Gets the current page height.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public double PageHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageHeight As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageNumber Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageNumber Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the current page number.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageNumberModel Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageNumberModel Property
ReportViewerModel Class See Also Send Feedback
For internal use only

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public int PageNumberModel { get; set; }
Visual Basic (Declaration)
Public Property PageNumberModel As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageRoot Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageRoot Property
ReportViewerModel Class See Also Send Feedback
Specifies the page root.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public FrameworkElement PageRoot { get; set; }
Visual Basic (Declaration)
Public Property PageRoot As FrameworkElement

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageTransform Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageTransform Property
ReportViewerModel Class See Also Send Feedback
Specifies the page transform.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Transform PageTransform { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageTransform As Transform

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PageWidth Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageWidth Property
ReportViewerModel Class See Also Send Feedback
Gets the current page width.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public double PageWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageWidth As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ParameterModels Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ParameterModels Property
ReportViewerModel Class See Also Send Feedback
Gets or sets a list of parameter models.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<ParameterModel> ParameterModels { get; set; }
Visual Basic (Declaration)
Public Property ParameterModels As IList(Of ParameterModel)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


Parameters Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.Parameters Property
ReportViewerModel Class See Also Send Feedback
Gets or sets a list of report parameters.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<Parameter> Parameters { get; set; }
Visual Basic (Declaration)
Public Property Parameters As IList(Of Parameter)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ParametersToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Parameters tooltip

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ParametersToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParametersToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PrintDocumentCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintDocumentCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the PrintDocument command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand PrintDocumentCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintDocumentCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintPreviewToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Print Preview/Interactive view tooltip

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintPreviewToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintPreviewToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PrintProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintProgress Property
ReportViewerModel Class See Also Send Feedback
Specifies the print progress.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintProgress { get; set; }
Visual Basic (Declaration)
Public Property PrintProgress As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


PrintReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the PrintReport command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand PrintReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ProgressMessage Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ProgressMessage Property
ReportViewerModel Class See Also Send Feedback
Specifies the text of the progress message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ProgressMessage { get; set; }
Visual Basic (Declaration)
Public Property ProgressMessage As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


RefreshReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.RefreshReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the RefreshReport command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand RefreshReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property RefreshReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


RenderingExtensions Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.RenderingExtensions Property
ReportViewerModel Class See Also Send Feedback
Represents a list of rendering extension infos.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public IList<ExtensionInfoModel> RenderingExtensions { get; set; }
Visual Basic (Declaration)
Public Property RenderingExtensions As IList(Of ExtensionInfoModel)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


SaveExportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.SaveExportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the SaveExport command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand SaveExportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property SaveExportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


SelectedDocumentMapNode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.SelectedDocumentMapNode Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the selected node of the document map.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public DocumentMapNodeModel SelectedDocumentMapNode { get; set; }
Visual Basic (Declaration)
Public Property SelectedDocumentMapNode As DocumentMapNodeModel

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


State Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.State Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the report viewer state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.TextResources Property
ReportViewerModel Class See Also Send Feedback
Gets or sets all the tooltips and messages

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ITextResources TextResources { get; set; }
Visual Basic (Declaration)
Public Property TextResources As ITextResources

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


TogglePrintPreviewCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.TogglePrintPreviewCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the TogglePrintPreviewCommand command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ICommand TogglePrintPreviewCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property TogglePrintPreviewCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


UpdateParametersProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.UpdateParametersProgress Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the text of the update parameters progress message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string UpdateParametersProgress { get; internal set; }
Visual Basic (Declaration)
Public Property UpdateParametersProgress As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ViewMode Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


Zoom Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.Zoom Property
ReportViewerModel Class See Also Send Feedback
Specifies the scale factor.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ZoomMode Property
ReportViewerModel Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ZoomText Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ZoomText Property
ReportViewerModel Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ZoomText { get; set; }
Visual Basic (Declaration)
Public Property ZoomText As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.Command Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Class
ReportViewerModel Class Members See Also Send Feedback
Represents a base class for a command.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public abstract class Command : ObservableObject,
    ICommand
Visual Basic (Declaration)
Public MustInherit Class Command _
    Inherits ObservableObject _
    Implements ICommand

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ReportViewerModel..::.Command
Telerik.ReportViewer.Silverlight..::.ReportViewerModel..::.ReportViewerCommand

See Also

ReportViewerModel..::.Command Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.Command Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Members
ReportViewerModel..::.Command Class Constructors Methods Properties See Also Send Feedback

Represents the report viewer model.

The ReportViewerModel..::.Command type exposes the following members.

Constructors

Name | Description
ReportViewerModel..::.Command | Initializes a new instance of the ReportViewerModel..::.Command class

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked.
OnCanExecuteChanged | Raises the CanExcute .

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled.

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.Command Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Constructor
ReportViewerModel..::.Command Class See Also Send Feedback
Initializes a new instance of the ReportViewerModel..::.Command class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected Command()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.Command Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Methods
ReportViewerModel..::.Command Class See Also Send Feedback

The ReportViewerModel..::.Command type exposes the following members.

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked.
OnCanExecuteChanged | Raises the CanExcute .

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


Execute Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.Execute Method
ReportViewerModel..::.Command Class See Also Send Feedback
Defines the method to be called when the command is invoked.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected abstract void Execute(
    Object parameter
)
Visual Basic (Declaration)
Protected MustOverride Sub Execute ( _
    parameter As Object _
)

Parameters

parameter
Type: System..::.Object
Data used by the command. If the command does not require data to be passed, this object can be set to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


OnCanExecuteChanged Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.OnCanExecuteChanged Method
ReportViewerModel..::.Command Class See Also Send Feedback
Raises the CanExcute .

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected virtual void OnCanExecuteChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnCanExecuteChanged

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.Command Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Properties
ReportViewerModel..::.Command Class See Also Send Feedback

The ReportViewerModel..::.Command type exposes the following members.

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled.

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


IsEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.IsEnabled Property
ReportViewerModel..::.Command Class See Also Send Feedback
Specifies whether the command is enabled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsEnabled As Boolean

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.ReportViewerCommand Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Class
ReportViewerModel Class Members See Also Send Feedback
Represents a base class for the report viewer's commands.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public abstract class ReportViewerCommand : ReportViewerModel..::.Command
Visual Basic (Declaration)
Public MustInherit Class ReportViewerCommand _
    Inherits ReportViewerModel..::.Command

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ObservableObject
Telerik.ReportViewer.Silverlight..::.ReportViewerModel..::.Command
Telerik.ReportViewer.Silverlight..::.ReportViewerModel..::.ReportViewerCommand

See Also

ReportViewerModel..::.ReportViewerCommand Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.ReportViewerCommand Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Members
ReportViewerModel..::.ReportViewerCommand Class Constructors Properties See Also Send Feedback

Represents the report viewer model.

The ReportViewerModel..::.ReportViewerCommand type exposes the following members.

Constructors

Name | Description
ReportViewerModel..::.ReportViewerCommand | Initializes a new instance of the ReportViewerCommand class.

Properties

Name | Description
ViewerModel | Gets the report viewer model.

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.ReportViewerCommand Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Constructor
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback
Initializes a new instance of the ReportViewerCommand class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected ReportViewerCommand(
    ReportViewerModel viewerModel
)
Visual Basic (Declaration)
Protected Sub New ( _
    viewerModel As ReportViewerModel _
)

Parameters

viewerModel
Type: Telerik.ReportViewer.Silverlight..::.ReportViewerModel

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerModel.ReportViewerCommand Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Properties
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback

The ReportViewerModel..::.ReportViewerCommand type exposes the following members.

Properties

Name | Description
ViewerModel | Gets the report viewer model.

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Silverlight Namespace


ViewerModel Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand..::.ViewerModel Property
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback
Gets the report viewer model.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
protected ReportViewerModel ViewerModel { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ViewerModel As ReportViewerModel

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerStates Class

[image]

Telerik Reporting Q2 2012
ReportViewerStates Class
Members See Also Send Feedback
Defines the names of the report viewer visual states.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public static class ReportViewerStates
Visual Basic (Declaration)
Public NotInheritable Class ReportViewerStates

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ReportViewerStates

See Also

ReportViewerStates Members
Telerik.ReportViewer.Silverlight Namespace


ReportViewerStates Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerStates Members
ReportViewerStates Class Fields See Also Send Feedback

The ReportViewerStates type exposes the following members.

Fields

Name | Description
DocumentMapCollapsed | Specifies the name of the document map collapsed state.
DocumentMapStateGroup | Specifies the name of the document map visual state group.
DocumentMapVisible | Specifies the name of the document map's visible state.
ExportComplete | Specifies the name of the visual state when export is complete.
ExportInProgress | Specifies the name of the visual state when export is in progress.
ExportNoExport | Specifies the name of the visual state when there is no export.
ExportReportStateGroup | Specifies the name of the Export state visual group.
ParametersAreaCollapsed | Specifies the name of the parameters area collapsed state.
ParametersAreaStateGroup | Specifies the name of the parameters area states group.
ParametersAreaVisible | Specifies the name of the parameters area visible state.
PrintComplete | Specifies the name of the visual state when print is complete.
PrintInProgress | Specifies the name of the visual state when print is in progress.
PrintNoPrint | Specifies the name of the visual state when there is no print.
PrintReportStateGroup | Specifies the name of the Print state visual group.
UpdateParametersComplete | Specifies the name of the visual state when parameters update is complete.
UpdateParametersInProgress | Specifies the name of the visual state when parameters update is in progress.
UpdateParametersStateGroup | Specifies the name of the update parameters visual state group.
ViewerError | Specifies the name of the Error visual state.
ViewerPage | Specifies the name of the visual state when a page is displayed.
ViewerStateGroup | Specifies the name of the viewer visual states group.
ViewerWorkInProgress | Specifies the name of the InProgress visual state.

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ReportViewerStates Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewerStates Fields
ReportViewerStates Class See Also Send Feedback

The ReportViewerStates type exposes the following members.

Fields

Name | Description
DocumentMapCollapsed | Specifies the name of the document map collapsed state.
DocumentMapStateGroup | Specifies the name of the document map visual state group.
DocumentMapVisible | Specifies the name of the document map's visible state.
ExportComplete | Specifies the name of the visual state when export is complete.
ExportInProgress | Specifies the name of the visual state when export is in progress.
ExportNoExport | Specifies the name of the visual state when there is no export.
ExportReportStateGroup | Specifies the name of the Export state visual group.
ParametersAreaCollapsed | Specifies the name of the parameters area collapsed state.
ParametersAreaStateGroup | Specifies the name of the parameters area states group.
ParametersAreaVisible | Specifies the name of the parameters area visible state.
PrintComplete | Specifies the name of the visual state when print is complete.
PrintInProgress | Specifies the name of the visual state when print is in progress.
PrintNoPrint | Specifies the name of the visual state when there is no print.
PrintReportStateGroup | Specifies the name of the Print state visual group.
UpdateParametersComplete | Specifies the name of the visual state when parameters update is complete.
UpdateParametersInProgress | Specifies the name of the visual state when parameters update is in progress.
UpdateParametersStateGroup | Specifies the name of the update parameters visual state group.
ViewerError | Specifies the name of the Error visual state.
ViewerPage | Specifies the name of the visual state when a page is displayed.
ViewerStateGroup | Specifies the name of the viewer visual states group.
ViewerWorkInProgress | Specifies the name of the InProgress visual state.

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapCollapsed Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.DocumentMapCollapsed Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the document map collapsed state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string DocumentMapCollapsed
Visual Basic (Declaration)
Public Const DocumentMapCollapsed As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.DocumentMapStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the document map visual state group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string DocumentMapStateGroup
Visual Basic (Declaration)
Public Const DocumentMapStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapVisible Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.DocumentMapVisible Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the document map's visible state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string DocumentMapVisible
Visual Basic (Declaration)
Public Const DocumentMapVisible As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ExportComplete Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ExportComplete Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when export is complete.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ExportComplete
Visual Basic (Declaration)
Public Const ExportComplete As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ExportInProgress Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ExportInProgress Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when export is in progress.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ExportInProgress
Visual Basic (Declaration)
Public Const ExportInProgress As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ExportNoExport Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ExportNoExport Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when there is no export.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ExportNoExport
Visual Basic (Declaration)
Public Const ExportNoExport As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ExportReportStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ExportReportStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the Export state visual group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ExportReportStateGroup
Visual Basic (Declaration)
Public Const ExportReportStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ParametersAreaCollapsed Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ParametersAreaCollapsed Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the parameters area collapsed state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ParametersAreaCollapsed
Visual Basic (Declaration)
Public Const ParametersAreaCollapsed As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ParametersAreaStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ParametersAreaStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the parameters area states group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ParametersAreaStateGroup
Visual Basic (Declaration)
Public Const ParametersAreaStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ParametersAreaVisible Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ParametersAreaVisible Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the parameters area visible state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ParametersAreaVisible
Visual Basic (Declaration)
Public Const ParametersAreaVisible As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


PrintComplete Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.PrintComplete Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when print is complete.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PrintComplete
Visual Basic (Declaration)
Public Const PrintComplete As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


PrintInProgress Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.PrintInProgress Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when print is in progress.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PrintInProgress
Visual Basic (Declaration)
Public Const PrintInProgress As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


PrintNoPrint Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.PrintNoPrint Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when there is no print.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PrintNoPrint
Visual Basic (Declaration)
Public Const PrintNoPrint As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


PrintReportStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.PrintReportStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the Print state visual group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string PrintReportStateGroup
Visual Basic (Declaration)
Public Const PrintReportStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


UpdateParametersComplete Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.UpdateParametersComplete Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when parameters update is complete.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string UpdateParametersComplete
Visual Basic (Declaration)
Public Const UpdateParametersComplete As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


UpdateParametersInProgress Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.UpdateParametersInProgress Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when parameters update is in progress.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string UpdateParametersInProgress
Visual Basic (Declaration)
Public Const UpdateParametersInProgress As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


UpdateParametersStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.UpdateParametersStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the update parameters visual state group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string UpdateParametersStateGroup
Visual Basic (Declaration)
Public Const UpdateParametersStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ViewerError Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerError Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the Error visual state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ViewerError
Visual Basic (Declaration)
Public Const ViewerError As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ViewerPage Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerPage Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when a page is displayed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ViewerPage
Visual Basic (Declaration)
Public Const ViewerPage As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ViewerStateGroup Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerStateGroup Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the viewer visual states group.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ViewerStateGroup
Visual Basic (Declaration)
Public Const ViewerStateGroup As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ViewerWorkInProgress Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerWorkInProgress Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the InProgress visual state.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public const string ViewerWorkInProgress
Visual Basic (Declaration)
Public Const ViewerWorkInProgress As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Silverlight Namespace


ScaleFactorConverter Class

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter Class
Members See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ScaleFactorConverter : IValueConverter
Visual Basic (Declaration)
Public Class ScaleFactorConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ScaleFactorConverter

See Also

ScaleFactorConverter Members
Telerik.ReportViewer.Silverlight Namespace


ScaleFactorConverter Members

[image] [image]

Telerik Reporting Q2 2012
ScaleFactorConverter Members
ScaleFactorConverter Class Constructors Methods See Also Send Feedback

The ScaleFactorConverter type exposes the following members.

Constructors

Name | Description
ScaleFactorConverter | Initializes a new instance of the ScaleFactorConverter class

Methods

Name | Description
Convert | Converts number to percent value.
ConvertBack | Converts number to percent value.

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Silverlight Namespace


ScaleFactorConverter Constructor

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter Constructor
ScaleFactorConverter Class See Also Send Feedback
Initializes a new instance of the ScaleFactorConverter class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ScaleFactorConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Silverlight Namespace


ScaleFactorConverter Methods

[image] [image]

Telerik Reporting Q2 2012
ScaleFactorConverter Methods
ScaleFactorConverter Class See Also Send Feedback

The ScaleFactorConverter type exposes the following members.

Methods

Name | Description
Convert | Converts number to percent value.
ConvertBack | Converts number to percent value.

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Silverlight Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter..::.Convert Method
ScaleFactorConverter Class See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Silverlight Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter..::.ConvertBack Method
ScaleFactorConverter Class See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Silverlight Namespace


TextBoxEx Class

[image]

Telerik Reporting Q2 2012
TextBoxEx Class
Members See Also Send Feedback
TextBox that autoupdates DataBound Text property in TwoWay binding

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class TextBoxEx : TextBox
Visual Basic (Declaration)
Public Class TextBoxEx _
    Inherits TextBox

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.TextBox
Telerik.ReportViewer.Silverlight..::.TextBoxEx

See Also

TextBoxEx Members
Telerik.ReportViewer.Silverlight Namespace


TextBoxEx Members

[image] [image]

Telerik Reporting Q2 2012
TextBoxEx Members
TextBoxEx Class Constructors See Also Send Feedback

The TextBoxEx type exposes the following members.

Constructors

Name | Description
TextBoxEx | The default constructor

See Also

TextBoxEx Class
Telerik.ReportViewer.Silverlight Namespace


TextBoxEx Constructor

[image]

Telerik Reporting Q2 2012
TextBoxEx Constructor
TextBoxEx Class See Also Send Feedback
The default constructor

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public TextBoxEx()
Visual Basic (Declaration)
Public Sub New

See Also

TextBoxEx Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Class

[image]

Telerik Reporting Q2 2012
TextResources Class
Members See Also Send Feedback
Provides the default tooltips and messages for the viewer.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class TextResources : ITextResources
Visual Basic (Declaration)
Public Class TextResources _
    Implements ITextResources

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.TextResources

See Also

TextResources Members
Telerik.ReportViewer.Silverlight Namespace


TextResources Members

[image] [image]

Telerik Reporting Q2 2012
TextResources Members
TextResources Class Constructors Methods Properties See Also Send Feedback

The TextResources type exposes the following members.

Constructors

Name | Description
TextResources | Initializes a new instance of the TextResources class

Methods

Name | Description
ToString | In design time, for the property window to display something more meaningful than the type name. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelExportButtonText | Specifies the text for each Cancel button.
CancellingPrintMessage | Specifies the text for the message that is displayed when printing is cancelled.
CancelPrintButtonText | Specifies the text for each Cancel button.
CannotConvertTypeError | Specifies the message for the type conversion error.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
DocumentReadyForPrintMessage | Specifies the text for the message that is displayed when the document is ready for printing.
ExportingProgressMessage | Specifies the text for the export progress message.
ExportToolTip | Specifies the tooltip for the Export button.
FileReadyToSaveMessage | Specifies the text for the message that is displayed when the file is ready to be saved.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
MultipleValuesNotSupportedError | Specifies the text for the message that is displayed when the parameter does not support multiple values.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreparingForPrintMessage | Specifies the text for the message that is displayed when the report is being prepared for printing.
PreviewButtonText | Specifies the text for the Preview button.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintButtonText | Specifies the text for the dialog Print button.
PrintingRequiresBrowserError | Specifies the text for the message that is displayed when trying to print Out-of-Browser.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintProgressMessage | Specifies the text for the message that show which page is currently being printed.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
SaveButtonText | Specifies the text for the dialog Save button.
StartingPrintMessage | Specifies the text for the message that is displayed when printing is started.
SwitchToPrintPreviewMessage | Specifies the tooltip of the Print button that is displayed when trying to print from Interactive View.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UnableToExportError | Specifies the text for the message that is displayed when the report is not exported.
UpdatingParametersDoneMessage | Specifies the text for the message that is displayed when the updating of parameters is finished.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Constructor

[image]

Telerik Reporting Q2 2012
TextResources Constructor
TextResources Class See Also Send Feedback
Initializes a new instance of the TextResources class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public TextResources()
Visual Basic (Declaration)
Public Sub New

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Methods

[image] [image]

Telerik Reporting Q2 2012
TextResources Methods
TextResources Class See Also Send Feedback

The TextResources type exposes the following members.

Methods

Name | Description
ToString | In design time, for the property window to display something more meaningful than the type name. (Overrides Object..::.ToString()()().)

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TextResources..::.ToString Method
TextResources Class See Also Send Feedback
In design time, for the property window to display something more meaningful than the type name.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


TextResources Properties

[image] [image]

Telerik Reporting Q2 2012
TextResources Properties
TextResources Class See Also Send Feedback

The TextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelExportButtonText | Specifies the text for each Cancel button.
CancellingPrintMessage | Specifies the text for the message that is displayed when printing is cancelled.
CancelPrintButtonText | Specifies the text for each Cancel button.
CannotConvertTypeError | Specifies the message for the type conversion error.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
DocumentReadyForPrintMessage | Specifies the text for the message that is displayed when the document is ready for printing.
ExportingProgressMessage | Specifies the text for the export progress message.
ExportToolTip | Specifies the tooltip for the Export button.
FileReadyToSaveMessage | Specifies the text for the message that is displayed when the file is ready to be saved.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
MultipleValuesNotSupportedError | Specifies the text for the message that is displayed when the parameter does not support multiple values.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreparingForPrintMessage | Specifies the text for the message that is displayed when the report is being prepared for printing.
PreviewButtonText | Specifies the text for the Preview button.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintButtonText | Specifies the text for the dialog Print button.
PrintingRequiresBrowserError | Specifies the text for the message that is displayed when trying to print Out-of-Browser.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintProgressMessage | Specifies the text for the message that show which page is currently being printed.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
SaveButtonText | Specifies the text for the dialog Save button.
StartingPrintMessage | Specifies the text for the message that is displayed when printing is started.
SwitchToPrintPreviewMessage | Specifies the tooltip of the Print button that is displayed when trying to print from Interactive View.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UnableToExportError | Specifies the text for the message that is displayed when the report is not exported.
UpdatingParametersDoneMessage | Specifies the text for the message that is displayed when the updating of parameters is finished.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


AllFiles Property

[image]

Telerik Reporting Q2 2012
TextResources..::.AllFiles Property
TextResources Class See Also Send Feedback
Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string AllFiles { get; set; }
Visual Basic (Declaration)
Public Property AllFiles As String

Implements

ITextResources..::.AllFiles

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


BackToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.BackToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string BackToolTip { get; set; }
Visual Basic (Declaration)
Public Property BackToolTip As String

Implements

ITextResources..::.BackToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


CancelExportButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CancelExportButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for each Cancel button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string CancelExportButtonText { get; set; }
Visual Basic (Declaration)
Public Property CancelExportButtonText As String

Implements

ITextResources..::.CancelExportButtonText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


CancellingPrintMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CancellingPrintMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when printing is cancelled.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string CancellingPrintMessage { get; set; }
Visual Basic (Declaration)
Public Property CancellingPrintMessage As String

Implements

ITextResources..::.CancellingPrintMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


CancelPrintButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CancelPrintButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for each Cancel button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string CancelPrintButtonText { get; set; }
Visual Basic (Declaration)
Public Property CancelPrintButtonText As String

Implements

ITextResources..::.CancelPrintButtonText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


CannotConvertTypeError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CannotConvertTypeError Property
TextResources Class See Also Send Feedback
Specifies the message for the type conversion error.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string CannotConvertTypeError { get; set; }
Visual Basic (Declaration)
Public Property CannotConvertTypeError As String

Implements

ITextResources..::.CannotConvertTypeError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CurrentPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string CurrentPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property CurrentPageToolTip As String

Implements

ITextResources..::.CurrentPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.DocumentMapToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string DocumentMapToolTip { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapToolTip As String

Implements

ITextResources..::.DocumentMapToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


DocumentReadyForPrintMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.DocumentReadyForPrintMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the document is ready for printing.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string DocumentReadyForPrintMessage { get; set; }
Visual Basic (Declaration)
Public Property DocumentReadyForPrintMessage As String

Implements

ITextResources..::.DocumentReadyForPrintMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ExportingProgressMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ExportingProgressMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the export progress message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ExportingProgressMessage { get; set; }
Visual Basic (Declaration)
Public Property ExportingProgressMessage As String

Implements

ITextResources..::.ExportingProgressMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ExportToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ExportToolTip { get; set; }
Visual Basic (Declaration)
Public Property ExportToolTip As String

Implements

ITextResources..::.ExportToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


FileReadyToSaveMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.FileReadyToSaveMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the file is ready to be saved.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string FileReadyToSaveMessage { get; set; }
Visual Basic (Declaration)
Public Property FileReadyToSaveMessage As String

Implements

ITextResources..::.FileReadyToSaveMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.FirstPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string FirstPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property FirstPageToolTip As String

Implements

ITextResources..::.FirstPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ForwardToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ForwardToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Forward button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ForwardToolTip { get; set; }
Visual Basic (Declaration)
Public Property ForwardToolTip As String

Implements

ITextResources..::.ForwardToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.LastPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string LastPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property LastPageToolTip As String

Implements

ITextResources..::.LastPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


LoadingPageMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.LoadingPageMessage Property
TextResources Class See Also Send Feedback
Specifies the transitional loading page message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string LoadingPageMessage { get; set; }
Visual Basic (Declaration)
Public Property LoadingPageMessage As String

Implements

ITextResources..::.LoadingPageMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


MultipleValuesNotSupportedError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.MultipleValuesNotSupportedError Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the parameter does not support multiple values.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string MultipleValuesNotSupportedError { get; set; }
Visual Basic (Declaration)
Public Property MultipleValuesNotSupportedError As String

Implements

ITextResources..::.MultipleValuesNotSupportedError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.NextPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string NextPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property NextPageToolTip As String

Implements

ITextResources..::.NextPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


NoReportError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.NoReportError Property
TextResources Class See Also Send Feedback
Specifies the error message for missing report.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string NoReportError { get; set; }
Visual Basic (Declaration)
Public Property NoReportError As String

Implements

ITextResources..::.NoReportError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PageNumberGreaterThanRangeError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PageNumberGreaterThanRangeError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the page number is greater than the count of pages.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PageNumberGreaterThanRangeError { get; set; }
Visual Basic (Declaration)
Public Property PageNumberGreaterThanRangeError As String

Implements

ITextResources..::.PageNumberGreaterThanRangeError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PageNumberLessThanRangeError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PageNumberLessThanRangeError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the page number is less than 1.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PageNumberLessThanRangeError { get; set; }
Visual Basic (Declaration)
Public Property PageNumberLessThanRangeError As String

Implements

ITextResources..::.PageNumberLessThanRangeError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ParametersToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ParametersToolTip { get; set; }
Visual Basic (Declaration)
Public Property ParametersToolTip As String

Implements

ITextResources..::.ParametersToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PreparingForPrintMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PreparingForPrintMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the report is being prepared for printing.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PreparingForPrintMessage { get; set; }
Visual Basic (Declaration)
Public Property PreparingForPrintMessage As String

Implements

ITextResources..::.PreparingForPrintMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PreviewButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PreviewButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PreviewButtonText { get; set; }
Visual Basic (Declaration)
Public Property PreviewButtonText As String

Implements

ITextResources..::.PreviewButtonText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PreviousPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PreviousPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property PreviousPageToolTip As String

Implements

ITextResources..::.PreviousPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PrintButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for the dialog Print button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintButtonText { get; set; }
Visual Basic (Declaration)
Public Property PrintButtonText As String

Implements

ITextResources..::.PrintButtonText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PrintingRequiresBrowserError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintingRequiresBrowserError Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when trying to print Out-of-Browser.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintingRequiresBrowserError { get; set; }
Visual Basic (Declaration)
Public Property PrintingRequiresBrowserError As String

Implements

ITextResources..::.PrintingRequiresBrowserError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintPreviewToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Print Preview.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintPreviewToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintPreviewToolTip As String

Implements

ITextResources..::.PrintPreviewToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PrintProgressMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintProgressMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that show which page is currently being printed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintProgressMessage { get; set; }
Visual Basic (Declaration)
Public Property PrintProgressMessage As String

Implements

ITextResources..::.PrintProgressMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string PrintToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintToolTip As String

Implements

ITextResources..::.PrintToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ProcessingReportMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ProcessingReportMessage { get; set; }
Visual Basic (Declaration)
Public Property ProcessingReportMessage As String

Implements

ITextResources..::.ProcessingReportMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.RefreshToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string RefreshToolTip { get; set; }
Visual Basic (Declaration)
Public Property RefreshToolTip As String

Implements

ITextResources..::.RefreshToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersAreaValidationError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersAreaValidationError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ReportParametersAreaValidationError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersAreaValidationError As String

Implements

ITextResources..::.ReportParametersAreaValidationError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersNullText Property
TextResources Class See Also Send Feedback
Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ReportParametersNullText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNullText As String

Implements

ITextResources..::.ReportParametersNullText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersSelectAllText Property
TextResources Class See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ReportParametersSelectAllText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String

Implements

ITextResources..::.ReportParametersSelectAllText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


SaveButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.SaveButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for the dialog Save button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string SaveButtonText { get; set; }
Visual Basic (Declaration)
Public Property SaveButtonText As String

Implements

ITextResources..::.SaveButtonText

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


StartingPrintMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.StartingPrintMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when printing is started.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string StartingPrintMessage { get; set; }
Visual Basic (Declaration)
Public Property StartingPrintMessage As String

Implements

ITextResources..::.StartingPrintMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


SwitchToPrintPreviewMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.SwitchToPrintPreviewMessage Property
TextResources Class See Also Send Feedback
Specifies the tooltip of the Print button that is displayed when trying to print from Interactive View.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string SwitchToPrintPreviewMessage { get; set; }
Visual Basic (Declaration)
Public Property SwitchToPrintPreviewMessage As String

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


TotalPagesToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.TotalPagesToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string TotalPagesToolTip { get; set; }
Visual Basic (Declaration)
Public Property TotalPagesToolTip As String

Implements

ITextResources..::.TotalPagesToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


UnableToExportError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.UnableToExportError Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the report is not exported.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string UnableToExportError { get; set; }
Visual Basic (Declaration)
Public Property UnableToExportError As String

Implements

ITextResources..::.UnableToExportError

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


UpdatingParametersDoneMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.UpdatingParametersDoneMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the message that is displayed when the updating of parameters is finished.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string UpdatingParametersDoneMessage { get; set; }
Visual Basic (Declaration)
Public Property UpdatingParametersDoneMessage As String

Implements

ITextResources..::.UpdatingParametersDoneMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


UpdatingParametersMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.UpdatingParametersMessage Property
TextResources Class See Also Send Feedback
Specifies the transitional updating parameters message.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string UpdatingParametersMessage { get; set; }
Visual Basic (Declaration)
Public Property UpdatingParametersMessage As String

Implements

ITextResources..::.UpdatingParametersMessage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ZoomToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ZoomToolTip { get; set; }
Visual Basic (Declaration)
Public Property ZoomToolTip As String

Implements

ITextResources..::.ZoomToolTip

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToPageWidth Property
TextResources Class See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ZoomToPageWidth { get; set; }
Visual Basic (Declaration)
Public Property ZoomToPageWidth As String

Implements

ITextResources..::.ZoomToPageWidth

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToWholePage Property
TextResources Class See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public string ZoomToWholePage { get; set; }
Visual Basic (Declaration)
Public Property ZoomToWholePage As String

Implements

ITextResources..::.ZoomToWholePage

See Also

TextResources Class
Telerik.ReportViewer.Silverlight Namespace


ViewMode Enumeration

[image]

Telerik Reporting Q2 2012
ViewMode Enumeration
See Also Send Feedback
Specifies the page view mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode

Members

Member name | Description
Interactive | Enables Interactive page view.
PrintPreview | Enables PrintPreview page view.

See Also

Telerik.ReportViewer.Silverlight Namespace


VisibilityConverter Class

[image]

Telerik Reporting Q2 2012
VisibilityConverter Class
Members See Also Send Feedback
A value converter for visibility and boolean values.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class VisibilityConverter : IValueConverter
Visual Basic (Declaration)
Public Class VisibilityConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.VisibilityConverter

See Also

VisibilityConverter Members
Telerik.ReportViewer.Silverlight Namespace


VisibilityConverter Members

[image] [image]

Telerik Reporting Q2 2012
VisibilityConverter Members
VisibilityConverter Class Constructors Methods See Also Send Feedback

The VisibilityConverter type exposes the following members.

Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class

Methods

Name | Description
Convert | Converts Visibility value.
ConvertBack | Converts Visibility value.

See Also

VisibilityConverter Class
Telerik.ReportViewer.Silverlight Namespace


VisibilityConverter Constructor

[image]

Telerik Reporting Q2 2012
VisibilityConverter Constructor
VisibilityConverter Class See Also Send Feedback
Initializes a new instance of the VisibilityConverter class

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public VisibilityConverter()
Visual Basic (Declaration)
Public Sub New

See Also

VisibilityConverter Class
Telerik.ReportViewer.Silverlight Namespace


VisibilityConverter Methods

[image] [image]

Telerik Reporting Q2 2012
VisibilityConverter Methods
VisibilityConverter Class See Also Send Feedback

The VisibilityConverter type exposes the following members.

Methods

Name | Description
Convert | Converts Visibility value.
ConvertBack | Converts Visibility value.

See Also

VisibilityConverter Class
Telerik.ReportViewer.Silverlight Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
VisibilityConverter..::.Convert Method
VisibilityConverter Class See Also Send Feedback
Converts Visibility value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

VisibilityConverter Class
Telerik.ReportViewer.Silverlight Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
VisibilityConverter..::.ConvertBack Method
VisibilityConverter Class See Also Send Feedback
Converts Visibility value.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

VisibilityConverter Class
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Class

[image]

Telerik Reporting Q2 2012
ZoomConverter Class
Members See Also Send Feedback
Formats a number as % string and vice-versa

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public class ZoomConverter : IValueConverter
Visual Basic (Declaration)
Public Class ZoomConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Silverlight..::.ZoomConverter

See Also

ZoomConverter Members
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Members

[image] [image]

Telerik Reporting Q2 2012
ZoomConverter Members
ZoomConverter Class Constructors Methods See Also Send Feedback

The ZoomConverter type exposes the following members.

Constructors

Name | Description
ZoomConverter | Overloaded.

Methods

Name | Description
Convert | Converts a number as % string.
ConvertBack | Converts a number as % string.

See Also

ZoomConverter Class
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Constructor

[image] [image]

Telerik Reporting Q2 2012
ZoomConverter Constructor
ZoomConverter Class See Also Send Feedback

Overload List

Name | Description
ZoomConverter()()() | This is the default constructor
ZoomConverter(ITextResources) | Creates an instance of the ZoomConverter class.

See Also

ZoomConverter Class
ZoomConverter Members
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Constructor

[image]

Telerik Reporting Q2 2012
ZoomConverter Constructor
ZoomConverter Class See Also Send Feedback
This is the default constructor

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ZoomConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ZoomConverter Class
ZoomConverter Overload
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Constructor (ITextResources)

[image]

Telerik Reporting Q2 2012
ZoomConverter Constructor (ITextResources)
ZoomConverter Class See Also Send Feedback
Creates an instance of the ZoomConverter class.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public ZoomConverter(
    ITextResources textResources
)
Visual Basic (Declaration)
Public Sub New ( _
    textResources As ITextResources _
)

Parameters

textResources
Type: Telerik.ReportViewer.Silverlight..::.ITextResources

See Also

ZoomConverter Class
ZoomConverter Overload
Telerik.ReportViewer.Silverlight Namespace


ZoomConverter Methods

[image] [image]

Telerik Reporting Q2 2012
ZoomConverter Methods
ZoomConverter Class See Also Send Feedback

The ZoomConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a number as % string.
ConvertBack | Converts a number as % string.

See Also

ZoomConverter Class
Telerik.ReportViewer.Silverlight Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
ZoomConverter..::.Convert Method
ZoomConverter Class See Also Send Feedback
Converts a number as % string.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ZoomConverter Class
Telerik.ReportViewer.Silverlight Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
ZoomConverter..::.ConvertBack Method
ZoomConverter Class See Also Send Feedback
Converts a number as % string.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ZoomConverter Class
Telerik.ReportViewer.Silverlight Namespace


ZoomMode Enumeration

[image]

Telerik Reporting Q2 2012
ZoomMode Enumeration
See Also Send Feedback
Specifies the zoom mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.Silverlight
Assembly: Telerik.ReportViewer.Silverlight (in Telerik.ReportViewer.Silverlight.dll)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode

Members

Member name | Description
FullPage | Sets the zoom mode to full page.
PageWidth | Sets the zoom mode to page width.
Percent | Sets the zoom mode to a percentage.

See Also

Telerik.ReportViewer.Silverlight Namespace


Telerik.ReportViewer.WebForms Namespace

[image]

Telerik Reporting Q2 2012
Telerik.ReportViewer.WebForms Namespace
Send Feedback

Classes

Class | Description
HttpHandler |
HttpModule |
ReportBookControl |
ReportInfo |
ReportInfoCollection |
ReportViewer |
Resources |

Enumerations

Enumeration | Description
ViewMode | Specifies the page view mode for the ReportViewer control.
ZoomMode |


HttpHandler Class

[image]

Telerik Reporting Q2 2012
HttpHandler Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class HttpHandler : IHttpHandlerFactory
Visual Basic (Declaration)
Public Class HttpHandler _
    Implements IHttpHandlerFactory

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.WebForms..::.HttpHandler

See Also

HttpHandler Members
Telerik.ReportViewer.WebForms Namespace


HttpHandler Members

[image] [image]

Telerik Reporting Q2 2012
HttpHandler Members
HttpHandler Class Constructors Methods See Also Send Feedback

The HttpHandler type exposes the following members.

Constructors

Name | Description
HttpHandler | Initializes a new instance of the HttpHandler class

Methods

Name | Description
GetHandler |
ReleaseHandler |

See Also

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


HttpHandler Constructor

[image]

Telerik Reporting Q2 2012
HttpHandler Constructor
HttpHandler Class See Also Send Feedback
Initializes a new instance of the HttpHandler class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public HttpHandler()
Visual Basic (Declaration)
Public Sub New

See Also

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


HttpHandler Methods

[image] [image]

Telerik Reporting Q2 2012
HttpHandler Methods
HttpHandler Class See Also Send Feedback

The HttpHandler type exposes the following members.

Methods

Name | Description
GetHandler |
ReleaseHandler |

See Also

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


GetHandler Method

[image]

Telerik Reporting Q2 2012
HttpHandler..::.GetHandler Method
HttpHandler Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public IHttpHandler GetHandler(
    HttpContext context,
    string requestType,
    string url,
    string pathTranslated
)
Visual Basic (Declaration)
Public Function GetHandler ( _
    context As HttpContext, _
    requestType As String, _
    url As String, _
    pathTranslated As String _
) As IHttpHandler

Parameters

context
Type: System.Web..::.HttpContext
requestType
Type: System..::.String
url
Type: System..::.String
pathTranslated
Type: System..::.String

Implements

IHttpHandlerFactory..::.GetHandler(HttpContext, String, String, String)

See Also

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


ReleaseHandler Method

[image]

Telerik Reporting Q2 2012
HttpHandler..::.ReleaseHandler Method
HttpHandler Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public void ReleaseHandler(
    IHttpHandler handler
)
Visual Basic (Declaration)
Public Sub ReleaseHandler ( _
    handler As IHttpHandler _
)

Parameters

handler
Type: System.Web..::.IHttpHandler

Implements

IHttpHandlerFactory..::.ReleaseHandler(IHttpHandler)

See Also

HttpHandler Class
Telerik.ReportViewer.WebForms Namespace


HttpModule Class

[image]

Telerik Reporting Q2 2012
HttpModule Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class HttpModule : IHttpModule
Visual Basic (Declaration)
Public Class HttpModule _
    Implements IHttpModule

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.WebForms..::.HttpModule

See Also

HttpModule Members
Telerik.ReportViewer.WebForms Namespace


HttpModule Members

[image] [image]

Telerik Reporting Q2 2012
HttpModule Members
HttpModule Class Constructors Methods See Also Send Feedback

The HttpModule type exposes the following members.

Constructors

Name | Description
HttpModule | Initializes a new instance of the HttpModule class

Methods

Name | Description
Dispose | Releases all resources used by the HttpModule
Init |

See Also

HttpModule Class
Telerik.ReportViewer.WebForms Namespace


HttpModule Constructor

[image]

Telerik Reporting Q2 2012
HttpModule Constructor
HttpModule Class See Also Send Feedback
Initializes a new instance of the HttpModule class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public HttpModule()
Visual Basic (Declaration)
Public Sub New

See Also

HttpModule Class
Telerik.ReportViewer.WebForms Namespace


HttpModule Methods

[image] [image]

Telerik Reporting Q2 2012
HttpModule Methods
HttpModule Class See Also Send Feedback

The HttpModule type exposes the following members.

Methods

Name | Description
Dispose |
Init |

See Also

HttpModule Class
Telerik.ReportViewer.WebForms Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
HttpModule..::.Dispose Method
HttpModule Class See Also Send Feedback
Releases all resources used by the HttpModule

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose

Implements

IHttpModule..::.Dispose()()()

See Also

HttpModule Class
Telerik.ReportViewer.WebForms Namespace


Init Method

[image]

Telerik Reporting Q2 2012
HttpModule..::.Init Method
HttpModule Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public void Init(
    HttpApplication context
)
Visual Basic (Declaration)
Public Sub Init ( _
    context As HttpApplication _
)

Parameters

context
Type: System.Web..::.HttpApplication

Implements

IHttpModule..::.Init(HttpApplication)

See Also

HttpModule Class
Telerik.ReportViewer.WebForms Namespace


ReportBookControl Class

[image]

Telerik Reporting Q2 2012
ReportBookControl Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class ReportBookControl : Control,
    IReportDocument, IComponent, IDisposable
Visual Basic (Declaration)
Public Class ReportBookControl _
    Inherits Control _
    Implements IReportDocument, IComponent, IDisposable

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
Telerik.ReportViewer.WebForms..::.ReportBookControl

See Also

ReportBookControl Members
Telerik.ReportViewer.WebForms Namespace


ReportBookControl Members

[image] [image]

Telerik Reporting Q2 2012
ReportBookControl Members
ReportBookControl Class Constructors Properties Explicit Interface Implementations See Also Send Feedback

The ReportBookControl type exposes the following members.

Constructors

Name | Description
ReportBookControl | Initializes a new instance of the ReportBookControl class

Properties

Name | Description
DocumentName |
Reports | Gets the collection of reports that are parts of this ReportBook.

Explicit Interface Implementations

Name | Description
IReportDocument..::.PageSettings |
IReportDocument..::.ReportParameters |
IReportDocument..::.Reports |

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


ReportBookControl Constructor

[image]

Telerik Reporting Q2 2012
ReportBookControl Constructor
ReportBookControl Class See Also Send Feedback
Initializes a new instance of the ReportBookControl class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ReportBookControl()
Visual Basic (Declaration)
Public Sub New

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


ReportBookControl Properties

[image] [image]

Telerik Reporting Q2 2012
ReportBookControl Properties
ReportBookControl Class See Also Send Feedback

The ReportBookControl type exposes the following members.

Properties

Name | Description
DocumentName |
Reports | Gets the collection of reports that are parts of this ReportBook.

Explicit Interface Implementations

Name | Description
IReportDocument..::.PageSettings |
IReportDocument..::.ReportParameters |
IReportDocument..::.Reports |

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


DocumentName Property

[image]

Telerik Reporting Q2 2012
ReportBookControl..::.DocumentName Property
ReportBookControl Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string DocumentName { get; set; }
Visual Basic (Declaration)
Public Property DocumentName As String

Implements

IReportDocument..::.DocumentName

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


IReportDocument.PageSettings Property

[image]

Telerik Reporting Q2 2012
ReportBookControl..::.IReportDocument..::.PageSettings Property
ReportBookControl Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
PageSettings IReportDocument.PageSettings { get; set; }
Visual Basic (Declaration)
Private Property PageSettings As PageSettings
    Implements IReportDocument.PageSettings

Implements

IReportDocument..::.PageSettings

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


IReportDocument.ReportParameters Property

[image]

Telerik Reporting Q2 2012
ReportBookControl..::.IReportDocument..::.ReportParameters Property
ReportBookControl Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
IEnumerable<IReportParameter> IReportDocument.ReportParameters { get; }
Visual Basic (Declaration)
Private ReadOnly Property ReportParameters As IEnumerable(Of IReportParameter)
    Implements IReportDocument.ReportParameters

Implements

IReportDocument..::.ReportParameters

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


IReportDocument.Reports Property

[image]

Telerik Reporting Q2 2012
ReportBookControl..::.IReportDocument..::.Reports Property
ReportBookControl Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
IEnumerable<Report> IReportDocument.Reports { get; }
Visual Basic (Declaration)
Private ReadOnly Property Reports As IEnumerable(Of Report)
    Implements IReportDocument.Reports

Implements

IReportDocument..::.Reports

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


Reports Property

[image]

Telerik Reporting Q2 2012
ReportBookControl..::.Reports Property
ReportBookControl Class See Also Send Feedback
Gets the collection of reports that are parts of this ReportBook.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ReportInfoCollection Reports { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reports As ReportInfoCollection

See Also

ReportBookControl Class
Telerik.ReportViewer.WebForms Namespace


ReportInfo Class

[image]

Telerik Reporting Q2 2012
ReportInfo Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class ReportInfo
Visual Basic (Declaration)
Public Class ReportInfo

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.WebForms..::.ReportInfo

See Also

ReportInfo Members
Telerik.ReportViewer.WebForms Namespace


ReportInfo Members

[image] [image]

Telerik Reporting Q2 2012
ReportInfo Members
ReportInfo Class Constructors Properties See Also Send Feedback

The ReportInfo type exposes the following members.

Constructors

Name | Description
ReportInfo | Initializes a new instance of the ReportInfo class

Properties

Name | Description
Report | Specifies the assembly qualified name of the report.

See Also

ReportInfo Class
Telerik.ReportViewer.WebForms Namespace


ReportInfo Constructor

[image]

Telerik Reporting Q2 2012
ReportInfo Constructor
ReportInfo Class See Also Send Feedback
Initializes a new instance of the ReportInfo class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ReportInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ReportInfo Class
Telerik.ReportViewer.WebForms Namespace


ReportInfo Properties

[image] [image]

Telerik Reporting Q2 2012
ReportInfo Properties
ReportInfo Class See Also Send Feedback

The ReportInfo type exposes the following members.

Properties

Name | Description
Report | Specifies the assembly qualified name of the report.

See Also

ReportInfo Class
Telerik.ReportViewer.WebForms Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportInfo..::.Report Property
ReportInfo Class See Also Send Feedback
Specifies the assembly qualified name of the report.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string Report { get; set; }
Visual Basic (Declaration)
Public Property Report As String

See Also

ReportInfo Class
Telerik.ReportViewer.WebForms Namespace


ReportInfoCollection Class

[image]

Telerik Reporting Q2 2012
ReportInfoCollection Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class ReportInfoCollection : Collection<ReportInfo>
Visual Basic (Declaration)
Public Class ReportInfoCollection _
    Inherits Collection(Of ReportInfo)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(<' ReportInfo >)>)>
Telerik.ReportViewer.WebForms..::.ReportInfoCollection

See Also

ReportInfoCollection Members
Telerik.ReportViewer.WebForms Namespace


ReportInfoCollection Members

[image] [image]

Telerik Reporting Q2 2012
ReportInfoCollection Members
ReportInfoCollection Class Methods See Also Send Feedback

The ReportInfoCollection type exposes the following members.

Methods

Name | Description
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | (Overrides Object..::.ToString()()().)

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


ReportInfoCollection Methods

[image] [image]

Telerik Reporting Q2 2012
ReportInfoCollection Methods
ReportInfoCollection Class See Also Send Feedback

The ReportInfoCollection type exposes the following members.

Methods

Name | Description
ClearItems | (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
InsertItem | (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
RemoveItem | (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Overrides Collection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | (Overrides Object..::.ToString()()().)

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


ClearItems Method

[image]

Telerik Reporting Q2 2012
ReportInfoCollection..::.ClearItems Method
ReportInfoCollection Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


InsertItem Method

[image]

Telerik Reporting Q2 2012
ReportInfoCollection..::.InsertItem Method
ReportInfoCollection Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    ReportInfo item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As ReportInfo _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.ReportViewer.WebForms..::.ReportInfo

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


RemoveItem Method

[image]

Telerik Reporting Q2 2012
ReportInfoCollection..::.RemoveItem Method
ReportInfoCollection Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


SetItem Method

[image]

Telerik Reporting Q2 2012
ReportInfoCollection..::.SetItem Method
ReportInfoCollection Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void SetItem(
    int index,
    ReportInfo item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As ReportInfo _
)

Parameters

index
Type: System..::.Int32
item
Type: Telerik.ReportViewer.WebForms..::.ReportInfo

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
ReportInfoCollection..::.ToString Method
ReportInfoCollection Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

ReportInfoCollection Class
Telerik.ReportViewer.WebForms Namespace


ReportViewer Class

[image]

Telerik Reporting Q2 2012
ReportViewer Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class ReportViewer : CompositeControl,
    IParserAccessor
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits CompositeControl _
    Implements IParserAccessor

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI.WebControls..::.WebControl
System.Web.UI.WebControls..::.CompositeControl
Telerik.ReportViewer.WebForms..::.ReportViewer

See Also

ReportViewer Members
Telerik.ReportViewer.WebForms Namespace


ReportViewer Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Members
ReportViewer Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class

Methods

Name | Description
CreateChildControls | (Overrides Control..::.CreateChildControls()()().)
LoadViewState | (Overrides WebControl..::.LoadViewState(Object).)
OnInit | (Overrides Control..::.OnInit(EventArgs).)
OnLoad | (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | (Overrides Control..::.OnPreRender(EventArgs).)
RecreateChildControls | (Overrides CompositeControl..::.RecreateChildControls()()().)
RefreshReport | Causes the viewer to clear the cache and render the report again.
Render | (Overrides CompositeControl..::.Render(HtmlTextWriter).)
SaveViewState | (Overrides WebControl..::.SaveViewState()()().)

Properties

Name | Description
DocumentMapVisible | Indicates whether the DocumentMap should be visible.
Height | (Overrides WebControl..::.Height.)
ParametersAreaVisible | Indicates whether the ParametersArea should be visible.
ProgressText | Obsolete.
Report | Obsolete. Gets or sets the report displayed in the viewer.
ReportBookID |
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
Resources | Use to customize the texts for labels, tooltips and messages.
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible.
ShowExportGroup | Indicates whether Export group should be visible.
ShowHistoryButtons | Indicates whether the page navigation controls are visible.
ShowNavigationGroup | Indicates whether the page navigation controls are visible.
ShowParametersButton | Indicates whether Parameters button should be visible.
ShowPrintButton | Indicates whether Print button should be visible.
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible.
ShowRefreshButton | Indicates whether the Refresh button should be visible.
ShowZoomSelect | Obsolete. Indicates whether the Zoom input box should be visible.
Skin | Gets or sets the name of the skin that is used by the viewer.
SkinsPath | Gets or sets the relative path of the folder containing the skins.
TagKey | (Overrides WebControl..::.TagKey.)
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Width | (Overrides WebControl..::.Width.)
ZoomMode | Obsolete. Gets or sets the zoom mode of the viewer.
ZoomPercent | Obsolete. Gets or sets the percentage of zoom used for the report display.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject |

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportViewer Constructor

[image]

Telerik Reporting Q2 2012
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportViewer Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
CreateChildControls | (Overrides Control..::.CreateChildControls()()().)
LoadViewState | (Overrides WebControl..::.LoadViewState(Object).)
OnInit | (Overrides Control..::.OnInit(EventArgs).)
OnLoad | (Overrides Control..::.OnLoad(EventArgs).)
OnPreRender | (Overrides Control..::.OnPreRender(EventArgs).)
RecreateChildControls | (Overrides CompositeControl..::.RecreateChildControls()()().)
RefreshReport | Causes the viewer to clear the cache and render the report again.
Render | (Overrides CompositeControl..::.Render(HtmlTextWriter).)
SaveViewState | (Overrides WebControl..::.SaveViewState()()().)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject |

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


IParserAccessor.AddParsedSubObject Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.IParserAccessor..::.AddParsedSubObject Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
void IParserAccessor.AddParsedSubObject(
    Object o
)
Visual Basic (Declaration)
Private Sub AddParsedSubObject ( _
    o As Object _
) Implements IParserAccessor.AddParsedSubObject

Parameters

o
Type: System..::.Object

Implements

IParserAccessor..::.AddParsedSubObject(Object)

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


CreateChildControls Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.CreateChildControls Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void CreateChildControls()
Visual Basic (Declaration)
Protected Overrides Sub CreateChildControls

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


LoadViewState Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.LoadViewState Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Protected Overrides Sub LoadViewState ( _
    savedState As Object _
)

Parameters

savedState
Type: System..::.Object

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


OnInit Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnInit Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void OnInit(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnInit ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


OnLoad Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnLoad Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


OnPreRender Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnPreRender Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void OnPreRender(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPreRender ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


RecreateChildControls Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.RecreateChildControls Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void RecreateChildControls()
Visual Basic (Declaration)
Protected Overrides Sub RecreateChildControls

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


RefreshReport Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.RefreshReport Method
ReportViewer Class See Also Send Feedback
Causes the viewer to clear the cache and render the report again.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public void RefreshReport()
Visual Basic (Declaration)
Public Sub RefreshReport

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Render Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Render Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override void Render(
    HtmlTextWriter writer
)
Visual Basic (Declaration)
Protected Overrides Sub Render ( _
    writer As HtmlTextWriter _
)

Parameters

writer
Type: System.Web.UI..::.HtmlTextWriter

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


SaveViewState Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.SaveViewState Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override Object SaveViewState()
Visual Basic (Declaration)
Protected Overrides Function SaveViewState As Object

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportViewer Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
DocumentMapVisible | Indicates whether the DocumentMap should be visible.
Height | (Overrides WebControl..::.Height.)
ParametersAreaVisible | Indicates whether the ParametersArea should be visible.
ProgressText | Obsolete.
Report | Obsolete. Gets or sets the report displayed in the viewer.
ReportBookID |
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
Resources | Use to customize the texts for labels, tooltips and messages.
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible.
ShowExportGroup | Indicates whether Export group should be visible.
ShowHistoryButtons | Indicates whether the page navigation controls are visible.
ShowNavigationGroup | Indicates whether the page navigation controls are visible.
ShowParametersButton | Indicates whether Parameters button should be visible.
ShowPrintButton | Indicates whether Print button should be visible.
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible.
ShowRefreshButton | Indicates whether the Refresh button should be visible.
ShowZoomSelect | Obsolete. Indicates whether the Zoom input box should be visible.
Skin | Gets or sets the name of the skin that is used by the viewer.
SkinsPath | Gets or sets the relative path of the folder containing the skins.
TagKey | (Overrides WebControl..::.TagKey.)
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Width | (Overrides WebControl..::.Width.)
ZoomMode | Obsolete. Gets or sets the zoom mode of the viewer.
ZoomPercent | Obsolete. Gets or sets the percentage of zoom used for the report display.

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


DocumentMapVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.DocumentMapVisible Property
ReportViewer Class See Also Send Feedback
Indicates whether the DocumentMap should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool DocumentMapVisible { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapVisible As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Height Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Height Property
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public override Unit Height { get; set; }
Visual Basic (Declaration)
Public Overrides Property Height As Unit

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ParametersAreaVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ParametersAreaVisible Property
ReportViewer Class See Also Send Feedback
Indicates whether the ParametersArea should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ParametersAreaVisible { get; set; }
Visual Basic (Declaration)
Public Property ParametersAreaVisible As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ProgressText Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ProgressText Property
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
[ObsoleteAttribute("Use Resources.ProcessingReportMessage property instead or the resource file.")]
public string ProgressText { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use Resources.ProcessingReportMessage property instead or the resource file.")> _
Public Property ProgressText As String

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Report Property
ReportViewer Class See Also Send Feedback
Gets or sets the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
[ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")]
public IReportDocument Report { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")> _
Public Property Report As IReportDocument

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportBookID Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportBookID Property
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportBookID { get; set; }
Visual Basic (Declaration)
Public Property ReportBookID As String

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportSource Property
ReportViewer Class See Also Send Feedback
Gets or sets the ReportSource for the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.XmlReportSource


Resources Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Resources Property
ReportViewer Class See Also Send Feedback
Use to customize the texts for labels, tooltips and messages.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public Resources Resources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resources As Resources

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowDocumentMapButton Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowDocumentMapButton Property
ReportViewer Class See Also Send Feedback
Indicates whether DocumentMap button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowDocumentMapButton { get; set; }
Visual Basic (Declaration)
Public Property ShowDocumentMapButton As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowExportGroup Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowExportGroup Property
ReportViewer Class See Also Send Feedback
Indicates whether Export group should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowExportGroup { get; set; }
Visual Basic (Declaration)
Public Property ShowExportGroup As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowHistoryButtons Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowHistoryButtons Property
ReportViewer Class See Also Send Feedback
Indicates whether the page navigation controls are visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowHistoryButtons { get; set; }
Visual Basic (Declaration)
Public Property ShowHistoryButtons As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowNavigationGroup Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowNavigationGroup Property
ReportViewer Class See Also Send Feedback
Indicates whether the page navigation controls are visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowNavigationGroup { get; set; }
Visual Basic (Declaration)
Public Property ShowNavigationGroup As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowParametersButton Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowParametersButton Property
ReportViewer Class See Also Send Feedback
Indicates whether Parameters button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowParametersButton { get; set; }
Visual Basic (Declaration)
Public Property ShowParametersButton As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowPrintButton Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowPrintButton Property
ReportViewer Class See Also Send Feedback
Indicates whether Print button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowPrintButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintButton As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowPrintPreviewButton Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowPrintPreviewButton Property
ReportViewer Class See Also Send Feedback
Indicates whether PrintPreview button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowPrintPreviewButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintPreviewButton As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowRefreshButton Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowRefreshButton Property
ReportViewer Class See Also Send Feedback
Indicates whether the Refresh button should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ShowRefreshButton { get; set; }
Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ShowZoomSelect Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ShowZoomSelect Property
ReportViewer Class See Also Send Feedback
Indicates whether the Zoom input box should be visible.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
[ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")]
public bool ShowZoomSelect { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")> _
Public Property ShowZoomSelect As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Skin Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Skin Property
ReportViewer Class See Also Send Feedback
Gets or sets the name of the skin that is used by the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string Skin { get; set; }
Visual Basic (Declaration)
Public Property Skin As String

Field Value

A string containing the name of the currently used skin. The default value is Default.

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


SkinsPath Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.SkinsPath Property
ReportViewer Class See Also Send Feedback
Gets or sets the relative path of the folder containing the skins.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public virtual string SkinsPath { get; set; }
Visual Basic (Declaration)
Public Overridable Property SkinsPath As String

Field Value

A string specifying the relative path to the folder which contains ReportViewer skins. The default value is "~/ReportViewer/Skins".

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


TagKey Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.TagKey Property
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
protected override HtmlTextWriterTag TagKey { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ToolbarVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ToolbarVisible Property
ReportViewer Class See Also Send Feedback
Indicates whether the toolbar should be visible on the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public bool ToolbarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolbarVisible As Boolean

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ViewMode Property
ReportViewer Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Width Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Width Property
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public override Unit Width { get; set; }
Visual Basic (Declaration)
Public Overrides Property Width As Unit

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomMode Property
ReportViewer Class See Also Send Feedback
Gets or sets the zoom mode of the viewer.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
[ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")]
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")> _
Public Property ZoomMode As ZoomMode

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


ZoomPercent Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomPercent Property
ReportViewer Class See Also Send Feedback
Gets or sets the percentage of zoom used for the report display.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
[ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")]
public int ZoomPercent { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("ZoomMode/ZoomPercent is obsolete and should not be used anymore.")> _
Public Property ZoomPercent As Integer

See Also

ReportViewer Class
Telerik.ReportViewer.WebForms Namespace


Resources Class

[image]

Telerik Reporting Q2 2012
Resources Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public class Resources : IStateManager, INotifyPropertyChanged
Visual Basic (Declaration)
Public Class Resources _
    Implements IStateManager, INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.WebForms..::.Resources

See Also

Resources Members
Telerik.ReportViewer.WebForms Namespace


Resources Members

[image] [image]

Telerik Reporting Q2 2012
Resources Members
Resources Class Constructors Methods Properties Events Explicit Interface Implementations See Also Send Feedback

The Resources type exposes the following members.

Constructors

Name | Description
Resources | Initializes a new instance of the Resources class

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
CurrentPageToolTip | Specifies the tooltip for the current page label.
DocumentMapToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
ExportButtonText | Specifies the text for the Export button.
ExportSelectFormatText | Specifies the <select export format> text in the Export select input.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
LabelOf | Specifies the text for the 'of' conjunction label.
LastPageToolTip | Specifies the tooltip for the LastPage button.
NavigateBackToolTip | Specifies the tooltip for the NavigateBack button.
NavigateForwardToolTip | Specifies the tooltip for the NavigateForward button.
NextPageToolTip | Specifies the tooltip for the NextPage button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
ReportParametersNullText | Specifies the text for the NULL checkbox.
ReportParametersPreviewButtonText | Specifies the text for the Preview button.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
ReportParametersTrueValueLabel | Specifies the text for the True value label in a boolean parameter editor.
TogglePageLayoutToolTip | Specifies the tooltip for the TogglePageLayout button.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

Events

Name | Description
PropertyChanged |

Explicit Interface Implementations

Name | Description
IStateManager..::.IsTrackingViewState |
IStateManager..::.LoadViewState |
IStateManager..::.SaveViewState |
IStateManager..::.TrackViewState |

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


Resources Constructor

[image]

Telerik Reporting Q2 2012
Resources Constructor
Resources Class See Also Send Feedback
Initializes a new instance of the Resources class

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public Resources()
Visual Basic (Declaration)
Public Sub New

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


Resources Methods

[image] [image]

Telerik Reporting Q2 2012
Resources Methods
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Explicit Interface Implementations

Name | Description
IStateManager..::.LoadViewState |
IStateManager..::.SaveViewState |
IStateManager..::.TrackViewState |

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


IStateManager.LoadViewState Method

[image]

Telerik Reporting Q2 2012
Resources..::.IStateManager..::.LoadViewState Method
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
void IStateManager.LoadViewState(
    Object savedState
)
Visual Basic (Declaration)
Private Sub LoadViewState ( _
    savedState As Object _
) Implements IStateManager.LoadViewState

Parameters

savedState
Type: System..::.Object

Implements

IStateManager..::.LoadViewState(Object)

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


IStateManager.SaveViewState Method

[image]

Telerik Reporting Q2 2012
Resources..::.IStateManager..::.SaveViewState Method
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
Object IStateManager.SaveViewState()
Visual Basic (Declaration)
Private Function SaveViewState As Object
    Implements IStateManager.SaveViewState

Implements

IStateManager..::.SaveViewState()()()

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


IStateManager.TrackViewState Method

[image]

Telerik Reporting Q2 2012
Resources..::.IStateManager..::.TrackViewState Method
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
void IStateManager.TrackViewState()
Visual Basic (Declaration)
Private Sub TrackViewState Implements IStateManager.TrackViewState

Implements

IStateManager..::.TrackViewState()()()

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Resources..::.ToString Method
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


Resources Properties

[image] [image]

Telerik Reporting Q2 2012
Resources Properties
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Properties

Name | Description
CurrentPageToolTip | Specifies the tooltip for the current page label.
DocumentMapToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
ExportButtonText | Specifies the text for the Export button.
ExportSelectFormatText | Specifies the <select export format> text in the Export select input.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
LabelOf | Specifies the text for the 'of' conjunction label.
LastPageToolTip | Specifies the tooltip for the LastPage button.
NavigateBackToolTip | Specifies the tooltip for the NavigateBack button.
NavigateForwardToolTip | Specifies the tooltip for the NavigateForward button.
NextPageToolTip | Specifies the tooltip for the NextPage button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
ReportParametersNullText | Specifies the text for the NULL checkbox.
ReportParametersPreviewButtonText | Specifies the text for the Preview button.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
ReportParametersTrueValueLabel | Specifies the text for the True value label in a boolean parameter editor.
TogglePageLayoutToolTip | Specifies the tooltip for the TogglePageLayout button.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

Explicit Interface Implementations

Name | Description
IStateManager..::.IsTrackingViewState |

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


IStateManager.IsTrackingViewState Property

[image]

Telerik Reporting Q2 2012
Resources..::.IStateManager..::.IsTrackingViewState Property
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
bool IStateManager.IsTrackingViewState { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsTrackingViewState As Boolean
    Implements IStateManager.IsTrackingViewState

Implements

IStateManager..::.IsTrackingViewState

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.CurrentPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the current page label.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string CurrentPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property CurrentPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.DocumentMapToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string DocumentMapToolTip { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ExportButtonText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ExportButtonText Property
Resources Class See Also Send Feedback
Specifies the text for the Export button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ExportButtonText { get; set; }
Visual Basic (Declaration)
Public Property ExportButtonText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ExportSelectFormatText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ExportSelectFormatText Property
Resources Class See Also Send Feedback
Specifies the <select export format> text in the Export select input.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ExportSelectFormatText { get; set; }
Visual Basic (Declaration)
Public Property ExportSelectFormatText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ExportToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ExportToolTip { get; set; }
Visual Basic (Declaration)
Public Property ExportToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.FirstPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string FirstPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property FirstPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


LabelOf Property

[image]

Telerik Reporting Q2 2012
Resources..::.LabelOf Property
Resources Class See Also Send Feedback
Specifies the text for the 'of' conjunction label.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string LabelOf { get; set; }
Visual Basic (Declaration)
Public Property LabelOf As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.LastPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string LastPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property LastPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


NavigateBackToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.NavigateBackToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the NavigateBack button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string NavigateBackToolTip { get; set; }
Visual Basic (Declaration)
Public Property NavigateBackToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


NavigateForwardToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.NavigateForwardToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the NavigateForward button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string NavigateForwardToolTip { get; set; }
Visual Basic (Declaration)
Public Property NavigateForwardToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.NextPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string NextPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property NextPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ParametersToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ParametersToolTip { get; set; }
Visual Basic (Declaration)
Public Property ParametersToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PreviousPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string PreviousPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property PreviousPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PrintToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string PrintToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
Resources..::.ProcessingReportMessage Property
Resources Class See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ProcessingReportMessage { get; set; }
Visual Basic (Declaration)
Public Property ProcessingReportMessage As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.RefreshToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string RefreshToolTip { get; set; }
Visual Basic (Declaration)
Public Property RefreshToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersFalseValueLabel Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersFalseValueLabel Property
Resources Class See Also Send Feedback
Specifies the text for the False value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersFalseValueLabel { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersFalseValueLabel As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersInputDataError Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersInputDataError Property
Resources Class See Also Send Feedback
Specifies the message which appears when not all the parameters are set.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersInputDataError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersInputDataError As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersInvalidValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersInvalidValueText Property
Resources Class See Also Send Feedback
Specifies the text for the InvalidValue error.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersInvalidValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersInvalidValueText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersNoValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersNoValueText Property
Resources Class See Also Send Feedback
Specifies the message when a value should be selected for a parameter.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersNoValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNoValueText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersNullText Property
Resources Class See Also Send Feedback
Specifies the text for the NULL checkbox.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersNullText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNullText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersPreviewButtonText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersPreviewButtonText Property
Resources Class See Also Send Feedback
Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersPreviewButtonText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersPreviewButtonText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersSelectAllText Property
Resources Class See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersSelectAllText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersSelectAValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersSelectAValueText Property
Resources Class See Also Send Feedback
Specifies the <select a value> text for a dropdown parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersSelectAValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAValueText As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ReportParametersTrueValueLabel Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersTrueValueLabel Property
Resources Class See Also Send Feedback
Specifies the text for the True value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ReportParametersTrueValueLabel { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersTrueValueLabel As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


TogglePageLayoutToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.TogglePageLayoutToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the TogglePageLayout button.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string TogglePageLayoutToolTip { get; set; }
Visual Basic (Declaration)
Public Property TogglePageLayoutToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomToPageWidth Property
Resources Class See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ZoomToPageWidth { get; set; }
Visual Basic (Declaration)
Public Property ZoomToPageWidth As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomToWholePage Property
Resources Class See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public string ZoomToWholePage { get; set; }
Visual Basic (Declaration)
Public Property ZoomToWholePage As String

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


Resources Events

[image] [image]

Telerik Reporting Q2 2012
Resources Events
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


PropertyChanged Event

[image]

Telerik Reporting Q2 2012
Resources..::.PropertyChanged Event
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

Resources Class
Telerik.ReportViewer.WebForms Namespace


ViewMode Enumeration

[image]

Telerik Reporting Q2 2012
ViewMode Enumeration
See Also Send Feedback
Specifies the page view mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode

Members

Member name | Description
Interactive | Enables Interactive page view.
PrintPreview | Enables PrintPreview page view.

See Also

Telerik.ReportViewer.WebForms Namespace


ZoomMode Enumeration

[image]

Telerik Reporting Q2 2012
ZoomMode Enumeration
See Also Send Feedback

Namespace: Telerik.ReportViewer.WebForms
Assembly: Telerik.ReportViewer.WebForms (in Telerik.ReportViewer.WebForms.dll)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode

Members

Member name | Description
FullPage |
PageWidth |
Percent |

See Also

Telerik.ReportViewer.WebForms Namespace


Telerik.ReportViewer.WinForms Namespace

[image]

Telerik Reporting Q2 2012
Telerik.ReportViewer.WinForms Namespace
Send Feedback

Classes

Class | Description
ExportEventArgs |
ReportViewer |
ReportViewerAreaBase |
ReportViewerBase |
ReportViewerException |
Resources |
Resources..::.Keys |
WinViewer |

Delegates

Delegate | Description
ExportEventHandler |

Enumerations

Enumeration | Description
ProcessingState |
ReportViewerAreaBase..::.ViewType |
ToolBarFlags |
ViewMode | Specifies the page view mode for the ReportViewer control.
ZoomMode | Specifies the zoom mode for the ReportViewer control.


ExportEventArgs Class

[image]

Telerik Reporting Q2 2012
ExportEventArgs Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public sealed class ExportEventArgs : CancelEventArgs
Visual Basic (Declaration)
Public NotInheritable Class ExportEventArgs _
    Inherits CancelEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
Telerik.ReportViewer.WinForms..::.ExportEventArgs

See Also

ExportEventArgs Members
Telerik.ReportViewer.WinForms Namespace


ExportEventArgs Members

[image] [image]

Telerik Reporting Q2 2012
ExportEventArgs Members
ExportEventArgs Class Properties See Also Send Feedback

The ExportEventArgs type exposes the following members.

Properties

Name | Description
DeviceInfo |
Format |
RenderingExtension | Obsolete.

See Also

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


ExportEventArgs Properties

[image] [image]

Telerik Reporting Q2 2012
ExportEventArgs Properties
ExportEventArgs Class See Also Send Feedback

The ExportEventArgs type exposes the following members.

Properties

Name | Description
DeviceInfo |
Format |
RenderingExtension | Obsolete.

See Also

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


DeviceInfo Property

[image]

Telerik Reporting Q2 2012
ExportEventArgs..::.DeviceInfo Property
ExportEventArgs Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public Hashtable DeviceInfo { get; set; }
Visual Basic (Declaration)
Public Property DeviceInfo As Hashtable

See Also

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


Format Property

[image]

Telerik Reporting Q2 2012
ExportEventArgs..::.Format Property
ExportEventArgs Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string Format { get; }
Visual Basic (Declaration)
Public ReadOnly Property Format As String

See Also

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


RenderingExtension Property

[image]

Telerik Reporting Q2 2012
ExportEventArgs..::.RenderingExtension Property
ExportEventArgs Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
[ObsoleteAttribute("Property RenderingExtension is now obsolete; please use Format instead.")]
public string RenderingExtension { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Property RenderingExtension is now obsolete; please use Format instead.")> _
Public ReadOnly Property RenderingExtension As String

See Also

ExportEventArgs Class
Telerik.ReportViewer.WinForms Namespace


ExportEventHandler Delegate

[image]

Telerik Reporting Q2 2012
ExportEventHandler Delegate
See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public delegate void ExportEventHandler(
    Object sender,
    ExportEventArgs args
)
Visual Basic (Declaration)
Public Delegate Sub ExportEventHandler ( _
    sender As Object, _
    args As ExportEventArgs _
)

Parameters

sender
Type: System..::.Object
args
Type: Telerik.ReportViewer.WinForms..::.ExportEventArgs

See Also

Telerik.ReportViewer.WinForms Namespace


ProcessingState Enumeration

[image]

Telerik Reporting Q2 2012
ProcessingState Enumeration
See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public enum ProcessingState
Visual Basic (Declaration)
Public Enumeration ProcessingState

Members

Member name | Description
NoReport |
Processing |
Success |
Failure |
Partial |

See Also

Telerik.ReportViewer.WinForms Namespace


ReportViewer Class

[image]

Telerik Reporting Q2 2012
ReportViewer Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public class ReportViewer : ReportViewerBase
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits ReportViewerBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
Telerik.ReportViewer.WinForms..::.ReportViewerBase
Telerik.ReportViewer.WinForms..::.ReportViewer

See Also

ReportViewer Members
Telerik.ReportViewer.WinForms Namespace


ReportViewer Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Members
ReportViewer Class Constructors Methods Properties Events See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class

Methods

Name | Description
CancelRendering | Stops background processing of the report. (Inherited from ReportViewerBase.)
CanMoveToPage | Determines whether the viewer can be navigated to a specified page. (Inherited from ReportViewerBase.)
CreateRenderingDeviceInfo | (Overrides ReportViewerBase..::.CreateRenderingDeviceInfo(Int32, Int32).)
Dispose | (Inherited from ReportViewerBase.)
ExportReport | Exports the report in the specified format. (Inherited from ReportViewerBase.)
GetRenderingFormat | (Overrides ReportViewerBase..::.GetRenderingFormat(ViewMode).)
InitializeDeviceInfo | (Inherited from ReportViewerBase.)
OnExport | Raises the Export event; (Inherited from ReportViewerBase.)
OnLoad | (Inherited from ReportViewerBase.)
OnPrint | Raises the Print event; (Inherited from ReportViewerBase.)
OnRenderingBegin | Raises the RenderingBegin event; (Inherited from ReportViewerBase.)
OnUpdateUI | Raises the UpdateUI event; (Inherited from ReportViewerBase.)
Preview | Renders the report in the viewer passing the currently entered parameter values to the report. (Inherited from ReportViewerBase.)
PrintReport | Opens the print dialog for the report (Inherited from ReportViewerBase.)
RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor). (Inherited from ReportViewerBase.)
Reset | Resets the control to its default values. (Inherited from ReportViewerBase.)
ShowPageSetupDialog | Opens the page setup dialog (Inherited from ReportViewerBase.)

Properties

Name | Description
CurrentPage | Gets or sets the current page in the viewer. (Inherited from ReportViewerBase.)
DocumentMapVisible | Gets or sets a value that indicates whether the document map is displayed if any bookmark is defined. (Inherited from ReportViewerBase.)
ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists. (Inherited from ReportViewerBase.)
ProcessingState | Gets the current processing state of the viewer (Inherited from ReportViewerBase.)
Report | Obsolete. Gets or sets the report displayed in the viewer. (Inherited from ReportViewerBase.)
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer. (Inherited from ReportViewerBase.)
Resources | (Inherited from ReportViewerBase.)
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible. (Inherited from ReportViewerBase.)
ShowExportButton | Indicates whether Export button should be visible. (Inherited from ReportViewerBase.)
ShowHistoryButtons | Indicates whether the history (Back, Forward) buttons should be visible. (Inherited from ReportViewerBase.)
ShowPageNavigationControls | Indicates whether the page navigation controls are visible. (Inherited from ReportViewerBase.)
ShowPageSetup | Obsolete. Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase.)
ShowPageSetupButton | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase.)
ShowParametersButton | Indicates whether Parameters button should be visible. (Inherited from ReportViewerBase.)
ShowPrintButton | Indicates whether Print button should be visible. (Inherited from ReportViewerBase.)
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible. (Inherited from ReportViewerBase.)
ShowProgress | Indicates whether progress animation should be displayed while the report is rendered. (Inherited from ReportViewerBase.)
ShowRefreshButton | Indicates whether the Refresh button should be visible. (Inherited from ReportViewerBase.)
ShowStopButton | Indicates whether the Stop button should be visible. (Inherited from ReportViewerBase.)
ShowZoom | Indicates whether the Zoom input box should be visible. (Inherited from ReportViewerBase.)
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer. (Inherited from ReportViewerBase.)
TotalPages | Gets the count of the available pages in the viewer. (Inherited from ReportViewerBase.)
ViewMode | Specifies whether the viewer is in interactive or print preview mode. (Inherited from ReportViewerBase.)
ZoomMode | Gets or sets the zoom mode of the viewer. (Inherited from ReportViewerBase.)
ZoomPercent | Gets or sets the percentage of zoom used for the report display. (Inherited from ReportViewerBase.)

Events

Name | Description
Export | Occurs when the report in the viewer control is exported. (Inherited from ReportViewerBase.)
Print | Occurs when the report in the viewer control is printed. (Inherited from ReportViewerBase.)
RenderingBegin | Occurs when the report in the viewer control is rendered. (Inherited from ReportViewerBase.)
UpdateUI | Occurs when the UI of the report viewer control is updated. (Inherited from ReportViewerBase.)

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Constructor

[image]

Telerik Reporting Q2 2012
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
CancelRendering | Stops background processing of the report. (Inherited from ReportViewerBase.)
CanMoveToPage | Determines whether the viewer can be navigated to a specified page. (Inherited from ReportViewerBase.)
CreateRenderingDeviceInfo | (Overrides ReportViewerBase..::.CreateRenderingDeviceInfo(Int32, Int32).)
Dispose | (Inherited from ReportViewerBase.)
ExportReport | Exports the report in the specified format. (Inherited from ReportViewerBase.)
GetRenderingFormat | (Overrides ReportViewerBase..::.GetRenderingFormat(ViewMode).)
InitializeDeviceInfo | (Inherited from ReportViewerBase.)
OnExport | Raises the Export event; (Inherited from ReportViewerBase.)
OnLoad | (Inherited from ReportViewerBase.)
OnPrint | Raises the Print event; (Inherited from ReportViewerBase.)
OnRenderingBegin | Raises the RenderingBegin event; (Inherited from ReportViewerBase.)
OnUpdateUI | Raises the UpdateUI event; (Inherited from ReportViewerBase.)
Preview | Renders the report in the viewer passing the currently entered parameter values to the report. (Inherited from ReportViewerBase.)
PrintReport | Opens the print dialog for the report (Inherited from ReportViewerBase.)
RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor). (Inherited from ReportViewerBase.)
Reset | Resets the control to its default values. (Inherited from ReportViewerBase.)
ShowPageSetupDialog | Opens the page setup dialog (Inherited from ReportViewerBase.)

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


CreateRenderingDeviceInfo Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.CreateRenderingDeviceInfo Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override Hashtable CreateRenderingDeviceInfo(
    int startPage,
    int endPage
)
Visual Basic (Declaration)
Protected Overrides Function CreateRenderingDeviceInfo ( _
    startPage As Integer, _
    endPage As Integer _
) As Hashtable

Parameters

startPage
Type: System..::.Int32
endPage
Type: System..::.Int32

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


GetRenderingFormat Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.GetRenderingFormat Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override string GetRenderingFormat(
    ViewMode viewMode
)
Visual Basic (Declaration)
Protected Overrides Function GetRenderingFormat ( _
    viewMode As ViewMode _
) As String

Parameters

viewMode
Type: Telerik.ReportViewer.WinForms..::.ViewMode

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
CurrentPage | Gets or sets the current page in the viewer. (Inherited from ReportViewerBase.)
DocumentMapVisible | Gets or sets a value that indicates whether the document map is displayed if any bookmark is defined. (Inherited from ReportViewerBase.)
ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists. (Inherited from ReportViewerBase.)
ProcessingState | Gets the current processing state of the viewer (Inherited from ReportViewerBase.)
Report | Obsolete. Gets or sets the report displayed in the viewer. (Inherited from ReportViewerBase.)
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer. (Inherited from ReportViewerBase.)
Resources | (Inherited from ReportViewerBase.)
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible. (Inherited from ReportViewerBase.)
ShowExportButton | Indicates whether Export button should be visible. (Inherited from ReportViewerBase.)
ShowHistoryButtons | Indicates whether the history (Back, Forward) buttons should be visible. (Inherited from ReportViewerBase.)
ShowPageNavigationControls | Indicates whether the page navigation controls are visible. (Inherited from ReportViewerBase.)
ShowPageSetup | Obsolete. Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase.)
ShowPageSetupButton | Indicates whether PageSetup button should be visible. (Inherited from ReportViewerBase.)
ShowParametersButton | Indicates whether Parameters button should be visible. (Inherited from ReportViewerBase.)
ShowPrintButton | Indicates whether Print button should be visible. (Inherited from ReportViewerBase.)
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible. (Inherited from ReportViewerBase.)
ShowProgress | Indicates whether progress animation should be displayed while the report is rendered. (Inherited from ReportViewerBase.)
ShowRefreshButton | Indicates whether the Refresh button should be visible. (Inherited from ReportViewerBase.)
ShowStopButton | Indicates whether the Stop button should be visible. (Inherited from ReportViewerBase.)
ShowZoom | Indicates whether the Zoom input box should be visible. (Inherited from ReportViewerBase.)
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer. (Inherited from ReportViewerBase.)
TotalPages | Gets the count of the available pages in the viewer. (Inherited from ReportViewerBase.)
ViewMode | Specifies whether the viewer is in interactive or print preview mode. (Inherited from ReportViewerBase.)
ZoomMode | Gets or sets the zoom mode of the viewer. (Inherited from ReportViewerBase.)
ZoomPercent | Gets or sets the percentage of zoom used for the report display. (Inherited from ReportViewerBase.)

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewer Events

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Events
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Events

Name | Description
Export | Occurs when the report in the viewer control is exported. (Inherited from ReportViewerBase.)
Print | Occurs when the report in the viewer control is printed. (Inherited from ReportViewerBase.)
RenderingBegin | Occurs when the report in the viewer control is rendered. (Inherited from ReportViewerBase.)
UpdateUI | Occurs when the UI of the report viewer control is updated. (Inherited from ReportViewerBase.)

See Also

ReportViewer Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Class

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public abstract class ReportViewerAreaBase : UserControl
Visual Basic (Declaration)
Public MustInherit Class ReportViewerAreaBase _
    Inherits UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
Telerik.ReportViewer.WinForms..::.ReportViewerAreaBase
Telerik.ReportViewer.WinForms..::.WinViewer

See Also

ReportViewerAreaBase Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Members
ReportViewerAreaBase Class Constructors Methods Fields Properties See Also Send Feedback

The ReportViewerAreaBase type exposes the following members.

Constructors

Name | Description
ReportViewerAreaBase | Initializes a new instance of the ReportViewerAreaBase class

Methods

Name | Description
ChangeView |
OnPageNavigation |
SetZoom |
ShowMessage | Overloaded.
ShowWaitMessage |
UpdateUIState |

Fields

Name | Description
inLongRunningAction |

Properties

Name | Description
Viewer |

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Constructor
ReportViewerAreaBase Class See Also Send Feedback
Initializes a new instance of the ReportViewerAreaBase class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected ReportViewerAreaBase()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Fields
ReportViewerAreaBase Class See Also Send Feedback

The ReportViewerAreaBase type exposes the following members.

Fields

Name | Description
inLongRunningAction |

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


inLongRunningAction Field

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.inLongRunningAction Field
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected bool inLongRunningAction
Visual Basic (Declaration)
Protected inLongRunningAction As Boolean

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Methods
ReportViewerAreaBase Class See Also Send Feedback

The ReportViewerAreaBase type exposes the following members.

Methods

Name | Description
ChangeView |
OnPageNavigation |
SetZoom |
ShowMessage | Overloaded.
ShowWaitMessage |
UpdateUIState |

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ChangeView Method

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.ChangeView Method
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void ChangeView(
    ReportViewerAreaBase..::.ViewType viewType
)
Visual Basic (Declaration)
Protected Overridable Sub ChangeView ( _
    viewType As ReportViewerAreaBase..::.ViewType _
)

Parameters

viewType
Type: Telerik.ReportViewer.WinForms..::.ReportViewerAreaBase..::.ViewType

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


OnPageNavigation Method

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.OnPageNavigation Method
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void OnPageNavigation(
    int pageNumber
)
Visual Basic (Declaration)
Protected Overridable Sub OnPageNavigation ( _
    pageNumber As Integer _
)

Parameters

pageNumber
Type: System..::.Int32

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


SetZoom Method

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.SetZoom Method
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public abstract void SetZoom()
Visual Basic (Declaration)
Public MustOverride Sub SetZoom

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ShowMessage Method

[image] [image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.ShowMessage Method
ReportViewerAreaBase Class See Also Send Feedback

Overload List

Name | Description
ShowMessage(Exception) |
ShowMessage(String, Boolean) |

See Also

ReportViewerAreaBase Class
ReportViewerAreaBase Members
Telerik.ReportViewer.WinForms Namespace


ShowMessage Method (Exception)

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.ShowMessage Method (Exception)
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void ShowMessage(
    Exception exception
)
Visual Basic (Declaration)
Public Sub ShowMessage ( _
    exception As Exception _
)

Parameters

exception
Type: System..::.Exception

See Also

ReportViewerAreaBase Class
ShowMessage Overload
Telerik.ReportViewer.WinForms Namespace


ShowMessage Method (String, Boolean)

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.ShowMessage Method (String, Boolean)
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void ShowMessage(
    string text,
    bool enabled
)
Visual Basic (Declaration)
Public Sub ShowMessage ( _
    text As String, _
    enabled As Boolean _
)

Parameters

text
Type: System..::.String
enabled
Type: System..::.Boolean

See Also

ReportViewerAreaBase Class
ShowMessage Overload
Telerik.ReportViewer.WinForms Namespace


ShowWaitMessage Method

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.ShowWaitMessage Method
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void ShowWaitMessage()
Visual Basic (Declaration)
Public Sub ShowWaitMessage

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


UpdateUIState Method

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.UpdateUIState Method
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void UpdateUIState()
Visual Basic (Declaration)
Protected Overridable Sub UpdateUIState

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerAreaBase Properties
ReportViewerAreaBase Class See Also Send Feedback

The ReportViewerAreaBase type exposes the following members.

Properties

Name | Description
Viewer |

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


Viewer Property

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::.Viewer Property
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ReportViewerBase Viewer { get; set; }
Visual Basic (Declaration)
Public Property Viewer As ReportViewerBase

See Also

ReportViewerAreaBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerAreaBase.ViewType Enumeration

[image]

Telerik Reporting Q2 2012
ReportViewerAreaBase..::..ViewType Enumeration
ReportViewerAreaBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public enum ViewType
Visual Basic (Declaration)
Public Enumeration ViewType

Members

Member name | Description
Message |
Wait |
Report |

See Also

Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Class

[image]

Telerik Reporting Q2 2012
ReportViewerBase Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public abstract class ReportViewerBase : UserControl
Visual Basic (Declaration)
Public MustInherit Class ReportViewerBase _
    Inherits UserControl

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
Telerik.ReportViewer.WinForms..::.ReportViewerBase
Telerik.ReportViewer.WinForms..::.ReportViewer

See Also

ReportViewerBase Members
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerBase Members
ReportViewerBase Class Methods Properties Events See Also Send Feedback

The ReportViewerBase type exposes the following members.

Methods

Name | Description
CancelRendering | Stops background processing of the report.
CanMoveToPage | Determines whether the viewer can be navigated to a specified page.
CreateRenderingDeviceInfo |
Dispose | Releases the unmanaged resources used by the ReportViewerBase and optionally releases the managed resources (Overrides ContainerControl..::.Dispose(Boolean).)
ExportReport | Exports the report in the specified format.
GetRenderingFormat |
InitializeDeviceInfo |
OnExport | Raises the Export event;
OnLoad | (Overrides UserControl..::.OnLoad(EventArgs).)
OnPrint | Raises the Print event;
OnRenderingBegin | Raises the RenderingBegin event;
OnUpdateUI | Raises the UpdateUI event;
Preview | Renders the report in the viewer passing the currently entered parameter values to the report.
PrintReport | Opens the print dialog for the report
RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).
Reset | Resets the control to its default values.
ShowPageSetupDialog | Opens the page setup dialog

Properties

Name | Description
CurrentPage | Gets or sets the current page in the viewer.
DocumentMapVisible | Gets or sets a value that indicates whether the document map is displayed if any bookmark is defined.
ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.
ProcessingState | Gets the current processing state of the viewer
Report | Obsolete. Gets or sets the report displayed in the viewer.
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
Resources |
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible.
ShowExportButton | Indicates whether Export button should be visible.
ShowHistoryButtons | Indicates whether the history (Back, Forward) buttons should be visible.
ShowPageNavigationControls | Indicates whether the page navigation controls are visible.
ShowPageSetup | Obsolete. Indicates whether PageSetup button should be visible.
ShowPageSetupButton | Indicates whether PageSetup button should be visible.
ShowParametersButton | Indicates whether Parameters button should be visible.
ShowPrintButton | Indicates whether Print button should be visible.
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible.
ShowProgress | Indicates whether progress animation should be displayed while the report is rendered.
ShowRefreshButton | Indicates whether the Refresh button should be visible.
ShowStopButton | Indicates whether the Stop button should be visible.
ShowZoom | Indicates whether the Zoom input box should be visible.
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
TotalPages | Gets the count of the available pages in the viewer.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the viewer.
ZoomPercent | Gets or sets the percentage of zoom used for the report display.

Events

Name | Description
Export | Occurs when the report in the viewer control is exported.
Print | Occurs when the report in the viewer control is printed.
RenderingBegin | Occurs when the report in the viewer control is rendered.
UpdateUI | Occurs when the UI of the report viewer control is updated.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewerBase Methods
ReportViewerBase Class See Also Send Feedback

The ReportViewerBase type exposes the following members.

Methods

Name | Description
CancelRendering | Stops background processing of the report.
CanMoveToPage | Determines whether the viewer can be navigated to a specified page.
CreateRenderingDeviceInfo |
Dispose | (Overrides ContainerControl..::.Dispose(Boolean).)
ExportReport | Exports the report in the specified format.
GetRenderingFormat |
InitializeDeviceInfo |
OnExport | Raises the Export event;
OnLoad | (Overrides UserControl..::.OnLoad(EventArgs).)
OnPrint | Raises the Print event;
OnRenderingBegin | Raises the RenderingBegin event;
OnUpdateUI | Raises the UpdateUI event;
Preview | Renders the report in the viewer passing the currently entered parameter values to the report.
PrintReport | Opens the print dialog for the report
RefreshReport | Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).
Reset | Resets the control to its default values.
ShowPageSetupDialog | Opens the page setup dialog

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CancelRendering Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.CancelRendering Method
ReportViewerBase Class See Also Send Feedback
Stops background processing of the report.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool CancelRendering(
    int timeout
)
Visual Basic (Declaration)
Public Function CancelRendering ( _
    timeout As Integer _
) As Boolean

Parameters

timeout
Type: System..::.Int32
The number of milliseconds to wait for the background rendering to terminate. A value of -1 waits forever. A value of 0 returns immediately without waiting for the rendering to terminate.

Return Value

A Boolean value. A value of true is returned if the background rendering has terminated. A value of false is returned if background rendering has not terminated after the amount of time specified in the millisecondsTimeout parameter has elapsed, or if the millisecondsTimeout parameter was set to 0.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CanMoveToPage Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.CanMoveToPage Method
ReportViewerBase Class See Also Send Feedback
Determines whether the viewer can be navigated to a specified page.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool CanMoveToPage(
    int pageIndex
)
Visual Basic (Declaration)
Public Function CanMoveToPage ( _
    pageIndex As Integer _
) As Boolean

Parameters

pageIndex
Type: System..::.Int32
The page number to determine navigation possibility.

Return Value

Returns true if the viewer can be moved to the specified page.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CreateRenderingDeviceInfo Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.CreateRenderingDeviceInfo Method
ReportViewerBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual Hashtable CreateRenderingDeviceInfo(
    int startPage,
    int endPage
)
Visual Basic (Declaration)
Protected Overridable Function CreateRenderingDeviceInfo ( _
    startPage As Integer, _
    endPage As Integer _
) As Hashtable

Parameters

startPage
Type: System..::.Int32
endPage
Type: System..::.Int32

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Dispose Method
ReportViewerBase Class See Also Send Feedback
Releases the unmanaged resources used by the ReportViewerBase and optionally releases the managed resources

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ExportReport Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ExportReport Method
ReportViewerBase Class See Also Send Feedback
Exports the report in the specified format.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void ExportReport(
    string format,
    Hashtable deviceInfo
)
Visual Basic (Declaration)
Public Sub ExportReport ( _
    format As String, _
    deviceInfo As Hashtable _
)

Parameters

format
Type: System..::.String
Export format
deviceInfo
Type: System.Collections..::.Hashtable
Contains parameters to pass to the rendering extension.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


GetRenderingFormat Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.GetRenderingFormat Method
ReportViewerBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected abstract string GetRenderingFormat(
    ViewMode viewMode
)
Visual Basic (Declaration)
Protected MustOverride Function GetRenderingFormat ( _
    viewMode As ViewMode _
) As String

Parameters

viewMode
Type: Telerik.ReportViewer.WinForms..::.ViewMode

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


InitializeDeviceInfo Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.InitializeDeviceInfo Method
ReportViewerBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void InitializeDeviceInfo(
    Hashtable deviceInfo
)
Visual Basic (Declaration)
Protected Overridable Sub InitializeDeviceInfo ( _
    deviceInfo As Hashtable _
)

Parameters

deviceInfo
Type: System.Collections..::.Hashtable

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


OnExport Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.OnExport Method
ReportViewerBase Class See Also Send Feedback
Raises the Export event;

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void OnExport(
    ExportEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnExport ( _
    e As ExportEventArgs _
)

Parameters

e
Type: Telerik.ReportViewer.WinForms..::.ExportEventArgs
A ExportEventArgs that contains the event data.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


OnLoad Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.OnLoad Method
ReportViewerBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnLoad(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnLoad ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


OnPrint Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.OnPrint Method
ReportViewerBase Class See Also Send Feedback
Raises the Print event;

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void OnPrint(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnPrint ( _
    e As CancelEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs
A CancelEventArgs that contains the event data.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


OnRenderingBegin Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.OnRenderingBegin Method
ReportViewerBase Class See Also Send Feedback
Raises the RenderingBegin event;

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void OnRenderingBegin(
    CancelEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnRenderingBegin ( _
    e As CancelEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.CancelEventArgs
A CancelEventArgs that contains the event data.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


OnUpdateUI Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.OnUpdateUI Method
ReportViewerBase Class See Also Send Feedback
Raises the UpdateUI event;

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected virtual void OnUpdateUI(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnUpdateUI ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
A EventArgs that contains the event data.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Preview Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Preview Method
ReportViewerBase Class See Also Send Feedback
Renders the report in the viewer passing the currently entered parameter values to the report.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void Preview()
Visual Basic (Declaration)
Public Sub Preview

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


PrintReport Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.PrintReport Method
ReportViewerBase Class See Also Send Feedback
Opens the print dialog for the report

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void PrintReport()
Visual Basic (Declaration)
Public Sub PrintReport

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


RefreshReport Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.RefreshReport Method
ReportViewerBase Class See Also Send Feedback
Refreshes the report in the viewer. This method should not be called before the Form.Load() event is fired (avoid using it in the Form's constructor).

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void RefreshReport()
Visual Basic (Declaration)
Public Sub RefreshReport

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Reset Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Reset Method
ReportViewerBase Class See Also Send Feedback
Resets the control to its default values.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void Reset()
Visual Basic (Declaration)
Public Sub Reset

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPageSetupDialog Method

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPageSetupDialog Method
ReportViewerBase Class See Also Send Feedback
Opens the page setup dialog

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public void ShowPageSetupDialog()
Visual Basic (Declaration)
Public Sub ShowPageSetupDialog

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerBase Properties
ReportViewerBase Class See Also Send Feedback

The ReportViewerBase type exposes the following members.

Properties

Name | Description
CurrentPage | Gets or sets the current page in the viewer.
DocumentMapVisible | Gets or sets a value that indicates whether the document map is displayed if any bookmark is defined.
ParametersAreaVisible | Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.
ProcessingState | Gets the current processing state of the viewer
Report | Obsolete. Gets or sets the report displayed in the viewer.
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
Resources |
ShowDocumentMapButton | Indicates whether DocumentMap button should be visible.
ShowExportButton | Indicates whether Export button should be visible.
ShowHistoryButtons | Indicates whether the history (Back, Forward) buttons should be visible.
ShowPageNavigationControls | Indicates whether the page navigation controls are visible.
ShowPageSetup | Obsolete. Indicates whether PageSetup button should be visible.
ShowPageSetupButton | Indicates whether PageSetup button should be visible.
ShowParametersButton | Indicates whether Parameters button should be visible.
ShowPrintButton | Indicates whether Print button should be visible.
ShowPrintPreviewButton | Indicates whether PrintPreview button should be visible.
ShowProgress | Indicates whether progress animation should be displayed while the report is rendered.
ShowRefreshButton | Indicates whether the Refresh button should be visible.
ShowStopButton | Indicates whether the Stop button should be visible.
ShowZoom | Indicates whether the Zoom input box should be visible.
ToolbarVisible | Indicates whether the toolbar should be visible on the viewer.
TotalPages | Gets the count of the available pages in the viewer.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the viewer.
ZoomPercent | Gets or sets the percentage of zoom used for the report display.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


CurrentPage Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.CurrentPage Property
ReportViewerBase Class See Also Send Feedback
Gets or sets the current page in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic (Declaration)
Public Property CurrentPage As Integer

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


DocumentMapVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.DocumentMapVisible Property
ReportViewerBase Class See Also Send Feedback
Gets or sets a value that indicates whether the document map is displayed if any bookmark is defined.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool DocumentMapVisible { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapVisible As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ParametersAreaVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ParametersAreaVisible Property
ReportViewerBase Class See Also Send Feedback
Gets or sets a value that indicates whether the parameters area is displayed if any parameter editor exists.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ParametersAreaVisible { get; set; }
Visual Basic (Declaration)
Public Property ParametersAreaVisible As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ProcessingState Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ProcessingState Property
ReportViewerBase Class See Also Send Feedback
Gets the current processing state of the viewer

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ProcessingState ProcessingState { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProcessingState As ProcessingState

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Report Property
ReportViewerBase Class See Also Send Feedback
Gets or sets the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
[ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")]
public IReportDocument Report { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")> _
Public Property Report As IReportDocument

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ReportSource Property
ReportViewerBase Class See Also Send Feedback
Gets or sets the ReportSource for the report displayed in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.XmlReportSource


Resources Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Resources Property
ReportViewerBase Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public Resources Resources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Resources As Resources

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowDocumentMapButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowDocumentMapButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether DocumentMap button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowDocumentMapButton { get; set; }
Visual Basic (Declaration)
Public Property ShowDocumentMapButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowExportButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowExportButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether Export button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowExportButton { get; set; }
Visual Basic (Declaration)
Public Property ShowExportButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowHistoryButtons Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowHistoryButtons Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the history (Back, Forward) buttons should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowHistoryButtons { get; set; }
Visual Basic (Declaration)
Public Property ShowHistoryButtons As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPageNavigationControls Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPageNavigationControls Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the page navigation controls are visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowPageNavigationControls { get; set; }
Visual Basic (Declaration)
Public Property ShowPageNavigationControls As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPageSetup Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPageSetup Property
ReportViewerBase Class See Also Send Feedback
Indicates whether PageSetup button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
[ObsoleteAttribute("Use ReportViewerBase.ShowPageSetupButton property instead.")]
public bool ShowPageSetup { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Use ReportViewerBase.ShowPageSetupButton property instead.")> _
Public Property ShowPageSetup As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPageSetupButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPageSetupButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether PageSetup button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowPageSetupButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPageSetupButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowParametersButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowParametersButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether Parameters button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowParametersButton { get; set; }
Visual Basic (Declaration)
Public Property ShowParametersButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPrintButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPrintButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether Print button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowPrintButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowPrintPreviewButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowPrintPreviewButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether PrintPreview button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowPrintPreviewButton { get; set; }
Visual Basic (Declaration)
Public Property ShowPrintPreviewButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowProgress Property
ReportViewerBase Class See Also Send Feedback
Indicates whether progress animation should be displayed while the report is rendered.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowProgress { get; set; }
Visual Basic (Declaration)
Public Property ShowProgress As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowRefreshButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowRefreshButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the Refresh button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowRefreshButton { get; set; }
Visual Basic (Declaration)
Public Property ShowRefreshButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowStopButton Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowStopButton Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the Stop button should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowStopButton { get; set; }
Visual Basic (Declaration)
Public Property ShowStopButton As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ShowZoom Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ShowZoom Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the Zoom input box should be visible.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ShowZoom { get; set; }
Visual Basic (Declaration)
Public Property ShowZoom As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ToolbarVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ToolbarVisible Property
ReportViewerBase Class See Also Send Feedback
Indicates whether the toolbar should be visible on the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public bool ToolbarVisible { get; set; }
Visual Basic (Declaration)
Public Property ToolbarVisible As Boolean

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


TotalPages Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.TotalPages Property
ReportViewerBase Class See Also Send Feedback
Gets the count of the available pages in the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public int TotalPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalPages As Integer

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ViewMode Property
ReportViewerBase Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ZoomMode Property
ReportViewerBase Class See Also Send Feedback
Gets or sets the zoom mode of the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ZoomPercent Property

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.ZoomPercent Property
ReportViewerBase Class See Also Send Feedback
Gets or sets the percentage of zoom used for the report display.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public int ZoomPercent { get; set; }
Visual Basic (Declaration)
Public Property ZoomPercent As Integer

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerBase Events

[image] [image]

Telerik Reporting Q2 2012
ReportViewerBase Events
ReportViewerBase Class See Also Send Feedback

The ReportViewerBase type exposes the following members.

Events

Name | Description
Export | Occurs when the report in the viewer control is exported.
Print | Occurs when the report in the viewer control is printed.
RenderingBegin | Occurs when the report in the viewer control is rendered.
UpdateUI | Occurs when the UI of the report viewer control is updated.

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Export Event

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Export Event
ReportViewerBase Class See Also Send Feedback
Occurs when the report in the viewer control is exported.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public event ExportEventHandler Export
Visual Basic (Declaration)
Public Event Export As ExportEventHandler

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


Print Event

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.Print Event
ReportViewerBase Class See Also Send Feedback
Occurs when the report in the viewer control is printed.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public event CancelEventHandler Print
Visual Basic (Declaration)
Public Event Print As CancelEventHandler

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


RenderingBegin Event

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.RenderingBegin Event
ReportViewerBase Class See Also Send Feedback
Occurs when the report in the viewer control is rendered.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public event CancelEventHandler RenderingBegin
Visual Basic (Declaration)
Public Event RenderingBegin As CancelEventHandler

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


UpdateUI Event

[image]

Telerik Reporting Q2 2012
ReportViewerBase..::.UpdateUI Event
ReportViewerBase Class See Also Send Feedback
Occurs when the UI of the report viewer control is updated.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public event EventHandler UpdateUI
Visual Basic (Declaration)
Public Event UpdateUI As EventHandler

See Also

ReportViewerBase Class
Telerik.ReportViewer.WinForms Namespace


ReportViewerException Class

[image]

Telerik Reporting Q2 2012
ReportViewerException Class
See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public class ReportViewerException : Exception
Visual Basic (Declaration)
Public Class ReportViewerException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
Telerik.ReportViewer.WinForms..::.ReportViewerException

See Also

Telerik.ReportViewer.WinForms Namespace


Resources Class

[image]

Telerik Reporting Q2 2012
Resources Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public class Resources : ObservableObject
Visual Basic (Declaration)
Public Class Resources _
    Inherits ObservableObject

Inheritance Hierarchy

System..::.Object
ObservableObject
Telerik.ReportViewer.WinForms..::.Resources

See Also

Resources Members
Telerik.ReportViewer.WinForms Namespace


Resources Members

[image] [image]

Telerik Reporting Q2 2012
Resources Members
Resources Class Constructors Methods Properties See Also Send Feedback

The Resources type exposes the following members.

Constructors

Name | Description
Resources | Initializes a new instance of the Resources class

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the error message on export.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Back button.
GenericMessageBoxCaption | Specifies the caption of the message boxes shown by the viewer.
LabelOf | Specifies the text for the 'of' conjunction label.
LastPageToolTip | Specifies the tooltip for the LastPage button.
MissingReportSource | Specifies the text for the error when the Report property is not set.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoPageToDisplay | Specifies the text which appears if there are no pages to display.
PageSetupToolTip | Specifies the tooltip for the PageSetup button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersEmptyStringError | Specifies the error message when the parameter does not allow empty strings.
ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
ReportParametersNullText | Specifies the text for the NULL checkbox.
ReportParametersPreviewButtonText | Specifies the text for the Preview button.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
ReportParametersTrueValueLabel | Specifies the text for the True value label in a boolean parameter editor.
StopProcessing | Specifies the message when the report processing is canceled.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
ZoomPercentFormat | Specifies the format for the zoom percent numbers.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


Resources Constructor

[image]

Telerik Reporting Q2 2012
Resources Constructor
Resources Class See Also Send Feedback
Initializes a new instance of the Resources class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public Resources()
Visual Basic (Declaration)
Public Sub New

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


Resources Methods

[image] [image]

Telerik Reporting Q2 2012
Resources Methods
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Methods

Name | Description
ToString | (Overrides Object..::.ToString()()().)

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
Resources..::.ToString Method
Resources Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


Resources Properties

[image] [image]

Telerik Reporting Q2 2012
Resources Properties
Resources Class See Also Send Feedback

The Resources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the error message on export.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Back button.
GenericMessageBoxCaption | Specifies the caption of the message boxes shown by the viewer.
LabelOf | Specifies the text for the 'of' conjunction label.
LastPageToolTip | Specifies the tooltip for the LastPage button.
MissingReportSource | Specifies the text for the error when the Report property is not set.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoPageToDisplay | Specifies the text which appears if there are no pages to display.
PageSetupToolTip | Specifies the tooltip for the PageSetup button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersEmptyStringError | Specifies the error message when the parameter does not allow empty strings.
ReportParametersFalseValueLabel | Specifies the text for the False value label in a boolean parameter editor.
ReportParametersInputDataError | Specifies the message which appears when not all the parameters are set.
ReportParametersInvalidValueText | Specifies the text for the InvalidValue error.
ReportParametersNoValueText | Specifies the message when a value should be selected for a parameter.
ReportParametersNullText | Specifies the text for the NULL checkbox.
ReportParametersPreviewButtonText | Specifies the text for the Preview button.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersSelectAValueText | Specifies the <select a value> text for a dropdown parameter editor.
ReportParametersTrueValueLabel | Specifies the text for the True value label in a boolean parameter editor.
StopProcessing | Specifies the message when the report processing is canceled.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
ZoomPercentFormat | Specifies the format for the zoom percent numbers.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


AllFiles Property

[image]

Telerik Reporting Q2 2012
Resources..::.AllFiles Property
Resources Class See Also Send Feedback
Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string AllFiles { get; set; }
Visual Basic (Declaration)
Public Property AllFiles As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


BackToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.BackToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string BackToolTip { get; set; }
Visual Basic (Declaration)
Public Property BackToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.CurrentPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string CurrentPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property CurrentPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.DocumentMapToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string DocumentMapToolTip { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ExportError Property

[image]

Telerik Reporting Q2 2012
Resources..::.ExportError Property
Resources Class See Also Send Feedback
Specifies the error message on export.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ExportError { get; set; }
Visual Basic (Declaration)
Public Property ExportError As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ExportToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ExportToolTip { get; set; }
Visual Basic (Declaration)
Public Property ExportToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.FirstPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string FirstPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property FirstPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ForwardToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ForwardToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ForwardToolTip { get; set; }
Visual Basic (Declaration)
Public Property ForwardToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


GenericMessageBoxCaption Property

[image]

Telerik Reporting Q2 2012
Resources..::.GenericMessageBoxCaption Property
Resources Class See Also Send Feedback
Specifies the caption of the message boxes shown by the viewer.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string GenericMessageBoxCaption { get; set; }
Visual Basic (Declaration)
Public Property GenericMessageBoxCaption As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


LabelOf Property

[image]

Telerik Reporting Q2 2012
Resources..::.LabelOf Property
Resources Class See Also Send Feedback
Specifies the text for the 'of' conjunction label.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string LabelOf { get; set; }
Visual Basic (Declaration)
Public Property LabelOf As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.LastPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string LastPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property LastPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


MissingReportSource Property

[image]

Telerik Reporting Q2 2012
Resources..::.MissingReportSource Property
Resources Class See Also Send Feedback
Specifies the text for the error when the Report property is not set.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string MissingReportSource { get; set; }
Visual Basic (Declaration)
Public Property MissingReportSource As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.NextPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string NextPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property NextPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


NoPageToDisplay Property

[image]

Telerik Reporting Q2 2012
Resources..::.NoPageToDisplay Property
Resources Class See Also Send Feedback
Specifies the text which appears if there are no pages to display.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string NoPageToDisplay { get; set; }
Visual Basic (Declaration)
Public Property NoPageToDisplay As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


PageSetupToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PageSetupToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the PageSetup button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string PageSetupToolTip { get; set; }
Visual Basic (Declaration)
Public Property PageSetupToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ParametersToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ParametersToolTip { get; set; }
Visual Basic (Declaration)
Public Property ParametersToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PreviousPageToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string PreviousPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property PreviousPageToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PrintPreviewToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string PrintPreviewToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintPreviewToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.PrintToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string PrintToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
Resources..::.ProcessingReportMessage Property
Resources Class See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ProcessingReportMessage { get; set; }
Visual Basic (Declaration)
Public Property ProcessingReportMessage As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.RefreshToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string RefreshToolTip { get; set; }
Visual Basic (Declaration)
Public Property RefreshToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersEmptyStringError Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersEmptyStringError Property
Resources Class See Also Send Feedback
Specifies the error message when the parameter does not allow empty strings.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersEmptyStringError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersEmptyStringError As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersFalseValueLabel Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersFalseValueLabel Property
Resources Class See Also Send Feedback
Specifies the text for the False value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersFalseValueLabel { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersFalseValueLabel As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersInputDataError Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersInputDataError Property
Resources Class See Also Send Feedback
Specifies the message which appears when not all the parameters are set.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersInputDataError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersInputDataError As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersInvalidValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersInvalidValueText Property
Resources Class See Also Send Feedback
Specifies the text for the InvalidValue error.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersInvalidValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersInvalidValueText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersNoValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersNoValueText Property
Resources Class See Also Send Feedback
Specifies the message when a value should be selected for a parameter.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersNoValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNoValueText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersNullText Property
Resources Class See Also Send Feedback
Specifies the text for the NULL checkbox.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersNullText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNullText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersPreviewButtonText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersPreviewButtonText Property
Resources Class See Also Send Feedback
Specifies the text for the Preview button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersPreviewButtonText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersPreviewButtonText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersSelectAllText Property
Resources Class See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersSelectAllText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersSelectAValueText Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersSelectAValueText Property
Resources Class See Also Send Feedback
Specifies the <select a value> text for a dropdown parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersSelectAValueText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAValueText As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersTrueValueLabel Property

[image]

Telerik Reporting Q2 2012
Resources..::.ReportParametersTrueValueLabel Property
Resources Class See Also Send Feedback
Specifies the text for the True value label in a boolean parameter editor.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ReportParametersTrueValueLabel { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersTrueValueLabel As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


StopProcessing Property

[image]

Telerik Reporting Q2 2012
Resources..::.StopProcessing Property
Resources Class See Also Send Feedback
Specifies the message when the report processing is canceled.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string StopProcessing { get; set; }
Visual Basic (Declaration)
Public Property StopProcessing As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


StopToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.StopToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Stop button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string StopToolTip { get; set; }
Visual Basic (Declaration)
Public Property StopToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


TotalPagesToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.TotalPagesToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string TotalPagesToolTip { get; set; }
Visual Basic (Declaration)
Public Property TotalPagesToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ZoomPercentFormat Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomPercentFormat Property
Resources Class See Also Send Feedback
Specifies the format for the zoom percent numbers.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ZoomPercentFormat { get; set; }
Visual Basic (Declaration)
Public Property ZoomPercentFormat As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ZoomToolTip Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomToolTip Property
Resources Class See Also Send Feedback
Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ZoomToolTip { get; set; }
Visual Basic (Declaration)
Public Property ZoomToolTip As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomToPageWidth Property
Resources Class See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ZoomToPageWidth { get; set; }
Visual Basic (Declaration)
Public Property ZoomToPageWidth As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
Resources..::.ZoomToWholePage Property
Resources Class See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public string ZoomToWholePage { get; set; }
Visual Basic (Declaration)
Public Property ZoomToWholePage As String

See Also

Resources Class
Telerik.ReportViewer.WinForms Namespace


Resources.Keys Class

[image]

Telerik Reporting Q2 2012
Resources..::..Keys Class
Resources Class Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public static class Keys
Visual Basic (Declaration)
Public NotInheritable Class Keys

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.WinForms..::.Resources..::.Keys

See Also

Resources..::.Keys Members
Telerik.ReportViewer.WinForms Namespace


Resources.Keys Members

[image] [image]

Telerik Reporting Q2 2012
Resources..::..Keys Members
Resources..::.Keys Class Fields See Also Send Feedback

The Resources..::.Keys type exposes the following members.

Fields

Name | Description
AllFiles |
BackToolTip |
CurrentPageToolTip |
DocumentMapToolTip |
ExportError |
ExportToolTip |
FirstPageToolTip |
ForwardToolTip |
GenericMessageBoxCaption |
LabelOf |
LastPageToolTip |
MissingReportSource |
NextPageToolTip |
NoPageToDisplay |
PageSetupToolTip |
ParametersToolTip |
PreviousPageToolTip |
PrintPreviewToolTip |
PrintToolTip |
ProcessingReportMessage |
RefreshToolTip |
ReportParametersEmptyStringError |
ReportParametersFalseValueLabel |
ReportParametersInputDataError |
ReportParametersInvalidValueText |
ReportParametersNoValueText |
ReportParametersNullText |
ReportParametersPreviewButtonText |
ReportParametersSelectAllText |
ReportParametersSelectAValueText |
ReportParametersTrueValueLabel |
StopProcessing |
StopToolTip |
TotalPagesToolTip |
ZoomPercentFormat |
ZoomToolTip |
ZoomToPageWidth |
ZoomToWholePage |

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


Resources.Keys Fields

[image] [image]

Telerik Reporting Q2 2012
Resources..::..Keys Fields
Resources..::.Keys Class See Also Send Feedback

The Resources..::.Keys type exposes the following members.

Fields

Name | Description
AllFiles |
BackToolTip |
CurrentPageToolTip |
DocumentMapToolTip |
ExportError |
ExportToolTip |
FirstPageToolTip |
ForwardToolTip |
GenericMessageBoxCaption |
LabelOf |
LastPageToolTip |
MissingReportSource |
NextPageToolTip |
NoPageToDisplay |
PageSetupToolTip |
ParametersToolTip |
PreviousPageToolTip |
PrintPreviewToolTip |
PrintToolTip |
ProcessingReportMessage |
RefreshToolTip |
ReportParametersEmptyStringError |
ReportParametersFalseValueLabel |
ReportParametersInputDataError |
ReportParametersInvalidValueText |
ReportParametersNoValueText |
ReportParametersNullText |
ReportParametersPreviewButtonText |
ReportParametersSelectAllText |
ReportParametersSelectAValueText |
ReportParametersTrueValueLabel |
StopProcessing |
StopToolTip |
TotalPagesToolTip |
ZoomPercentFormat |
ZoomToolTip |
ZoomToPageWidth |
ZoomToWholePage |

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


AllFiles Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.AllFiles Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string AllFiles
Visual Basic (Declaration)
Public Const AllFiles As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


BackToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.BackToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string BackToolTip
Visual Basic (Declaration)
Public Const BackToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


CurrentPageToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.CurrentPageToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string CurrentPageToolTip
Visual Basic (Declaration)
Public Const CurrentPageToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


DocumentMapToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.DocumentMapToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string DocumentMapToolTip
Visual Basic (Declaration)
Public Const DocumentMapToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ExportError Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ExportError Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ExportError
Visual Basic (Declaration)
Public Const ExportError As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ExportToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ExportToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ExportToolTip
Visual Basic (Declaration)
Public Const ExportToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


FirstPageToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.FirstPageToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string FirstPageToolTip
Visual Basic (Declaration)
Public Const FirstPageToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ForwardToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ForwardToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ForwardToolTip
Visual Basic (Declaration)
Public Const ForwardToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


GenericMessageBoxCaption Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.GenericMessageBoxCaption Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string GenericMessageBoxCaption
Visual Basic (Declaration)
Public Const GenericMessageBoxCaption As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


LabelOf Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.LabelOf Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string LabelOf
Visual Basic (Declaration)
Public Const LabelOf As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


LastPageToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.LastPageToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string LastPageToolTip
Visual Basic (Declaration)
Public Const LastPageToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


MissingReportSource Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.MissingReportSource Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string MissingReportSource
Visual Basic (Declaration)
Public Const MissingReportSource As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


NextPageToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.NextPageToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string NextPageToolTip
Visual Basic (Declaration)
Public Const NextPageToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


NoPageToDisplay Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.NoPageToDisplay Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string NoPageToDisplay
Visual Basic (Declaration)
Public Const NoPageToDisplay As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


PageSetupToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.PageSetupToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string PageSetupToolTip
Visual Basic (Declaration)
Public Const PageSetupToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ParametersToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ParametersToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ParametersToolTip
Visual Basic (Declaration)
Public Const ParametersToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


PreviousPageToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.PreviousPageToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string PreviousPageToolTip
Visual Basic (Declaration)
Public Const PreviousPageToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


PrintPreviewToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.PrintPreviewToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string PrintPreviewToolTip
Visual Basic (Declaration)
Public Const PrintPreviewToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


PrintToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.PrintToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string PrintToolTip
Visual Basic (Declaration)
Public Const PrintToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ProcessingReportMessage Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ProcessingReportMessage Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ProcessingReportMessage
Visual Basic (Declaration)
Public Const ProcessingReportMessage As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


RefreshToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.RefreshToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string RefreshToolTip
Visual Basic (Declaration)
Public Const RefreshToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersEmptyStringError Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersEmptyStringError Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersEmptyStringError
Visual Basic (Declaration)
Public Const ReportParametersEmptyStringError As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersFalseValueLabel Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersFalseValueLabel Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersFalseValueLabel
Visual Basic (Declaration)
Public Const ReportParametersFalseValueLabel As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersInputDataError Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersInputDataError Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersInputDataError
Visual Basic (Declaration)
Public Const ReportParametersInputDataError As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersInvalidValueText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersInvalidValueText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersInvalidValueText
Visual Basic (Declaration)
Public Const ReportParametersInvalidValueText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersNoValueText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersNoValueText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersNoValueText
Visual Basic (Declaration)
Public Const ReportParametersNoValueText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersNullText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersNullText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersNullText
Visual Basic (Declaration)
Public Const ReportParametersNullText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersPreviewButtonText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersPreviewButtonText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersPreviewButtonText
Visual Basic (Declaration)
Public Const ReportParametersPreviewButtonText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersSelectAllText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersSelectAllText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersSelectAllText
Visual Basic (Declaration)
Public Const ReportParametersSelectAllText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersSelectAValueText Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersSelectAValueText Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersSelectAValueText
Visual Basic (Declaration)
Public Const ReportParametersSelectAValueText As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ReportParametersTrueValueLabel Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ReportParametersTrueValueLabel Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ReportParametersTrueValueLabel
Visual Basic (Declaration)
Public Const ReportParametersTrueValueLabel As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


StopProcessing Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.StopProcessing Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string StopProcessing
Visual Basic (Declaration)
Public Const StopProcessing As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


StopToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.StopToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string StopToolTip
Visual Basic (Declaration)
Public Const StopToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


TotalPagesToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.TotalPagesToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string TotalPagesToolTip
Visual Basic (Declaration)
Public Const TotalPagesToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ZoomPercentFormat Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ZoomPercentFormat Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ZoomPercentFormat
Visual Basic (Declaration)
Public Const ZoomPercentFormat As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ZoomToolTip Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ZoomToolTip Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ZoomToolTip
Visual Basic (Declaration)
Public Const ZoomToolTip As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ZoomToPageWidth Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ZoomToPageWidth Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ZoomToPageWidth
Visual Basic (Declaration)
Public Const ZoomToPageWidth As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ZoomToWholePage Field

[image]

Telerik Reporting Q2 2012
Resources..::..Keys..::.ZoomToWholePage Field
Resources..::.Keys Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public const string ZoomToWholePage
Visual Basic (Declaration)
Public Const ZoomToWholePage As String

See Also

Resources..::.Keys Class
Telerik.ReportViewer.WinForms Namespace


ToolBarFlags Enumeration

[image]

Telerik Reporting Q2 2012
ToolBarFlags Enumeration
See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
[FlagsAttribute]
public enum ToolBarFlags
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ToolBarFlags

Members

Member name | Description
PageNav |
Refresh |
Export |
Print |
PageSetup |
Zoom |
Stop |
Parameters |
DocumentMap |
History |
PrintPreview |
All |

See Also

Telerik.ReportViewer.WinForms Namespace


ViewMode Enumeration

[image]

Telerik Reporting Q2 2012
ViewMode Enumeration
See Also Send Feedback
Specifies the page view mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode

Members

Member name | Description
Interactive | Enables Interactive page view.
PrintPreview | Enables PrintPreview page view.

See Also

Telerik.ReportViewer.WinForms Namespace


WinViewer Class

[image]

Telerik Reporting Q2 2012
WinViewer Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public class WinViewer : ReportViewerAreaBase
Visual Basic (Declaration)
Public Class WinViewer _
    Inherits ReportViewerAreaBase

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.UserControl
Telerik.ReportViewer.WinForms..::.ReportViewerAreaBase
Telerik.ReportViewer.WinForms..::.WinViewer

See Also

WinViewer Members
Telerik.ReportViewer.WinForms Namespace


WinViewer Members

[image] [image]

Telerik Reporting Q2 2012
WinViewer Members
WinViewer Class Constructors Methods Fields Properties See Also Send Feedback

The WinViewer type exposes the following members.

Constructors

Name | Description
WinViewer | Initializes a new instance of the WinViewer class

Methods

Name | Description
ChangeView | (Overrides ReportViewerAreaBase..::.ChangeView(ReportViewerAreaBase..::.ViewType).)
Dispose | Releases the unmanaged resources used by the WinViewer and optionally releases the managed resources (Overrides ContainerControl..::.Dispose(Boolean).)
IsInputKey | (Overrides Control..::.IsInputKey(Keys).)
OnKeyDown | (Overrides Control..::.OnKeyDown(KeyEventArgs).)
OnMouseDoubleClick | (Overrides Control..::.OnMouseDoubleClick(MouseEventArgs).)
OnMouseDown | (Overrides UserControl..::.OnMouseDown(MouseEventArgs).)
OnMouseLeave | (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | (Overrides ScrollableControl..::.OnMouseWheel(MouseEventArgs).)
OnPageNavigation | (Inherited from ReportViewerAreaBase.)
OnPaint | (Overrides Control..::.OnPaint(PaintEventArgs).)
OnScroll | (Overrides ScrollableControl..::.OnScroll(ScrollEventArgs).)
OnSizeChanged | (Overrides Control..::.OnSizeChanged(EventArgs).)
SetZoom | (Overrides ReportViewerAreaBase..::.SetZoom()()().)
ShowMessage | Overloaded.
ShowWaitMessage | (Inherited from ReportViewerAreaBase.)
UpdateUIState | (Overrides ReportViewerAreaBase..::.UpdateUIState()()().)

Fields

Name | Description
inLongRunningAction | (Inherited from ReportViewerAreaBase.)

Properties

Name | Description
Viewer | (Inherited from ReportViewerAreaBase.)

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Constructor

[image]

Telerik Reporting Q2 2012
WinViewer Constructor
WinViewer Class See Also Send Feedback
Initializes a new instance of the WinViewer class

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public WinViewer()
Visual Basic (Declaration)
Public Sub New

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Fields

[image] [image]

Telerik Reporting Q2 2012
WinViewer Fields
WinViewer Class See Also Send Feedback

The WinViewer type exposes the following members.

Fields

Name | Description
inLongRunningAction | (Inherited from ReportViewerAreaBase.)

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Methods

[image] [image]

Telerik Reporting Q2 2012
WinViewer Methods
WinViewer Class See Also Send Feedback

The WinViewer type exposes the following members.

Methods

Name | Description
ChangeView | (Overrides ReportViewerAreaBase..::.ChangeView(ReportViewerAreaBase..::.ViewType).)
Dispose | (Overrides ContainerControl..::.Dispose(Boolean).)
IsInputKey | (Overrides Control..::.IsInputKey(Keys).)
OnKeyDown | (Overrides Control..::.OnKeyDown(KeyEventArgs).)
OnMouseDoubleClick | (Overrides Control..::.OnMouseDoubleClick(MouseEventArgs).)
OnMouseDown | (Overrides UserControl..::.OnMouseDown(MouseEventArgs).)
OnMouseLeave | (Overrides Control..::.OnMouseLeave(EventArgs).)
OnMouseMove | (Overrides Control..::.OnMouseMove(MouseEventArgs).)
OnMouseUp | (Overrides Control..::.OnMouseUp(MouseEventArgs).)
OnMouseWheel | (Overrides ScrollableControl..::.OnMouseWheel(MouseEventArgs).)
OnPageNavigation | (Inherited from ReportViewerAreaBase.)
OnPaint | (Overrides Control..::.OnPaint(PaintEventArgs).)
OnScroll | (Overrides ScrollableControl..::.OnScroll(ScrollEventArgs).)
OnSizeChanged | (Overrides Control..::.OnSizeChanged(EventArgs).)
SetZoom | (Overrides ReportViewerAreaBase..::.SetZoom()()().)
ShowMessage | Overloaded.
ShowWaitMessage | (Inherited from ReportViewerAreaBase.)
UpdateUIState | (Overrides ReportViewerAreaBase..::.UpdateUIState()()().)

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


ChangeView Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.ChangeView Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void ChangeView(
    ReportViewerAreaBase..::.ViewType viewType
)
Visual Basic (Declaration)
Protected Overrides Sub ChangeView ( _
    viewType As ReportViewerAreaBase..::.ViewType _
)

Parameters

viewType
Type: Telerik.ReportViewer.WinForms..::.ReportViewerAreaBase..::.ViewType

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


Dispose Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.Dispose Method
WinViewer Class See Also Send Feedback
Releases the unmanaged resources used by the WinViewer and optionally releases the managed resources

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::.Boolean
True to release both managed and unmanaged resources; false to release only unmanaged resources

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


IsInputKey Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.IsInputKey Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override bool IsInputKey(
    Keys keyData
)
Visual Basic (Declaration)
Protected Overrides Function IsInputKey ( _
    keyData As Keys _
) As Boolean

Parameters

keyData
Type: System.Windows.Forms..::.Keys

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnKeyDown Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnKeyDown Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnKeyDown(
    KeyEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnKeyDown ( _
    eventArgs As KeyEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.KeyEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseDoubleClick Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseDoubleClick Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseDoubleClick(
    MouseEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDoubleClick ( _
    eventArgs As MouseEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.MouseEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseDown Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseDown Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseDown(
    MouseEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseDown ( _
    eventArgs As MouseEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.MouseEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseLeave Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseLeave Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseLeave(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseLeave ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseMove Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseMove Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseMove(
    MouseEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseMove ( _
    eventArgs As MouseEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.MouseEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseUp Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseUp Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseUp(
    MouseEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseUp ( _
    eventArgs As MouseEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.MouseEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnMouseWheel Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnMouseWheel Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnMouseWheel(
    MouseEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnMouseWheel ( _
    eventArgs As MouseEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.MouseEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnPaint Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnPaint Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnPaint(
    PaintEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnPaint ( _
    eventArgs As PaintEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.PaintEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnScroll Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnScroll Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnScroll(
    ScrollEventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnScroll ( _
    eventArgs As ScrollEventArgs _
)

Parameters

eventArgs
Type: System.Windows.Forms..::.ScrollEventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


OnSizeChanged Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.OnSizeChanged Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void OnSizeChanged(
    EventArgs eventArgs
)
Visual Basic (Declaration)
Protected Overrides Sub OnSizeChanged ( _
    eventArgs As EventArgs _
)

Parameters

eventArgs
Type: System..::.EventArgs

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


SetZoom Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.SetZoom Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public override void SetZoom()
Visual Basic (Declaration)
Public Overrides Sub SetZoom

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


ShowMessage Method

[image] [image]

Telerik Reporting Q2 2012
WinViewer..::.ShowMessage Method
WinViewer Class See Also Send Feedback

Overload List

Name | Description
ShowMessage(Exception) | (Inherited from ReportViewerAreaBase.)
ShowMessage(String, Boolean) | (Inherited from ReportViewerAreaBase.)

See Also

WinViewer Class
WinViewer Members
Telerik.ReportViewer.WinForms Namespace


UpdateUIState Method

[image]

Telerik Reporting Q2 2012
WinViewer..::.UpdateUIState Method
WinViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
protected override void UpdateUIState()
Visual Basic (Declaration)
Protected Overrides Sub UpdateUIState

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


WinViewer Properties

[image] [image]

Telerik Reporting Q2 2012
WinViewer Properties
WinViewer Class See Also Send Feedback

The WinViewer type exposes the following members.

Properties

Name | Description
Viewer | (Inherited from ReportViewerAreaBase.)

See Also

WinViewer Class
Telerik.ReportViewer.WinForms Namespace


ZoomMode Enumeration

[image]

Telerik Reporting Q2 2012
ZoomMode Enumeration
See Also Send Feedback
Specifies the zoom mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.WinForms
Assembly: Telerik.ReportViewer.WinForms (in Telerik.ReportViewer.WinForms.dll)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode

Members

Member name | Description
FullPage | Sets the zoom mode to full page.
PageWidth | Sets the zoom mode to page width.
Percent | Sets the zoom mode to a percentage.

See Also

Telerik.ReportViewer.WinForms Namespace


Telerik.ReportViewer.Wpf Namespace

[image]

Telerik Reporting Q2 2012
Telerik.ReportViewer.Wpf Namespace
Send Feedback

Classes

Class | Description
DialogBox | Represents a dialog box control.
ErrorStatus | Represents a error status control
FormatedNumberConverter | Converts a number to string according to a given format
KeyDown | Enables binding an ICommand to the FrameworkElement.KeyDown event
MultivalueAvailableValuesParameterModel | Represents the report multi value parameter model to associate the WPF parameter editor UI with.
MultivalueAvailableValuesParameterModel..::.SelectAllItem | Represents the SelectAll item in a Multivalue/AvailableValues editor
MultivalueParameterConverter | A value converter for multi-value parameters
ParameterContentControl |
ParameterModel | Represents the report parameter model to associate the WPF parameter editor UI with.
RenderingExtension | Represents a rendering extension
ReportDocumentConverter | Converts report instance to assembly qualified name and vice versa.
ReportParameterEditorTemplateSelector | Represents a selector for the report parameter editor templates.
ReportParametersControl | Represents a control that holds a collection of ParameterContentControl.
ReportViewer | Represents the WPF ReportViewer control.
ReportViewer..::.TemplateParts | Specifies the template parts names.
ReportViewerModel | Represents the report viewer model.
ReportViewerModel..::.Command | Represents a base class for a command.
ReportViewerModel..::.ReportViewerCommand | Represents a base class for the report viewer's commands.
ReportViewerStates | Defines the names of the report viewer visual states.
ScaleFactorConverter | Converts number to percent value.
TextBoxEx | TextBox that autoupdates DataBound Text property in TwoWay binding
TextResources | Provides the default tooltips and messages for the viewer.
VisibilityConverter | A value converter for visibility and boolean values.
ZoomConverter | Formats a number as % string and vice-versa

Interfaces

Interface | Description
ITextResources | This interface is used for customization or localization of all text resources, as alternative to localization/customization with .resx files.

Enumerations

Enumeration | Description
ViewMode | Specifies the page view mode for the ReportViewer control.
ZoomMode | Specifies the zoom mode for the ReportViewer control.


DialogBox Class

[image]

Telerik Reporting Q2 2012
DialogBox Class
Members See Also Send Feedback
Represents a dialog box control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class DialogBox : ContentControl
Visual Basic (Declaration)
Public Class DialogBox _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Telerik.ReportViewer.Wpf..::.DialogBox

See Also

DialogBox Members
Telerik.ReportViewer.Wpf Namespace


DialogBox Members

[image] [image]

Telerik Reporting Q2 2012
DialogBox Members
DialogBox Class Constructors See Also Send Feedback

The DialogBox type exposes the following members.

Constructors

Name | Description
DialogBox | Creates a new instance of the DialogBox class.

See Also

DialogBox Class
Telerik.ReportViewer.Wpf Namespace


DialogBox Constructor

[image]

Telerik Reporting Q2 2012
DialogBox Constructor
DialogBox Class See Also Send Feedback
Creates a new instance of the DialogBox class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public DialogBox()
Visual Basic (Declaration)
Public Sub New

See Also

DialogBox Class
Telerik.ReportViewer.Wpf Namespace


ErrorStatus Class

[image]

Telerik Reporting Q2 2012
ErrorStatus Class
Members See Also Send Feedback
Represents a error status control

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ErrorStatus : ContentControl
Visual Basic (Declaration)
Public Class ErrorStatus _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Telerik.ReportViewer.Wpf..::.ErrorStatus

See Also

ErrorStatus Members
Telerik.ReportViewer.Wpf Namespace


ErrorStatus Members

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Members
ErrorStatus Class Constructors Fields Properties See Also Send Feedback

The ErrorStatus type exposes the following members.

Constructors

Name | Description
ErrorStatus | Creates a new instance of the ErrorStatus class.

Fields

Name | Description
PropertyNameProperty | Defines the ReportName dependency property.

Properties

Name | Description
PropertyName | Specifies the name of the property which errors should be displayed by the error status.

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


ErrorStatus Constructor

[image]

Telerik Reporting Q2 2012
ErrorStatus Constructor
ErrorStatus Class See Also Send Feedback
Creates a new instance of the ErrorStatus class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ErrorStatus()
Visual Basic (Declaration)
Public Sub New

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


ErrorStatus Fields

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Fields
ErrorStatus Class See Also Send Feedback

The ErrorStatus type exposes the following members.

Fields

Name | Description
PropertyNameProperty | Defines the ReportName dependency property.

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


PropertyNameProperty Field

[image]

Telerik Reporting Q2 2012
ErrorStatus..::.PropertyNameProperty Field
ErrorStatus Class See Also Send Feedback
Defines the ReportName dependency property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty PropertyNameProperty
Visual Basic (Declaration)
Public Shared ReadOnly PropertyNameProperty As DependencyProperty

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


ErrorStatus Properties

[image] [image]

Telerik Reporting Q2 2012
ErrorStatus Properties
ErrorStatus Class See Also Send Feedback

The ErrorStatus type exposes the following members.

Properties

Name | Description
PropertyName | Specifies the name of the property which errors should be displayed by the error status.

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


PropertyName Property

[image]

Telerik Reporting Q2 2012
ErrorStatus..::.PropertyName Property
ErrorStatus Class See Also Send Feedback
Specifies the name of the property which errors should be displayed by the error status.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String

See Also

ErrorStatus Class
Telerik.ReportViewer.Wpf Namespace


FormatedNumberConverter Class

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter Class
Members See Also Send Feedback
Converts a number to string according to a given format

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class FormatedNumberConverter : IValueConverter
Visual Basic (Declaration)
Public Class FormatedNumberConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.FormatedNumberConverter

See Also

FormatedNumberConverter Members
Telerik.ReportViewer.Wpf Namespace


FormatedNumberConverter Members

[image] [image]

Telerik Reporting Q2 2012
FormatedNumberConverter Members
FormatedNumberConverter Class Constructors Methods See Also Send Feedback

The FormatedNumberConverter type exposes the following members.

Constructors

Name | Description
FormatedNumberConverter | Initializes a new instance of the FormatedNumberConverter class

Methods

Name | Description
Convert | Converts a number to string according to a given format.
ConvertBack | Converts a number to string according to a given format.

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Wpf Namespace


FormatedNumberConverter Constructor

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter Constructor
FormatedNumberConverter Class See Also Send Feedback
Initializes a new instance of the FormatedNumberConverter class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public FormatedNumberConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Wpf Namespace


FormatedNumberConverter Methods

[image] [image]

Telerik Reporting Q2 2012
FormatedNumberConverter Methods
FormatedNumberConverter Class See Also Send Feedback

The FormatedNumberConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a number to string according to a given format.
ConvertBack | Converts a number to string according to a given format.

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter..::.Convert Method
FormatedNumberConverter Class See Also Send Feedback
Converts a number to string according to a given format.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
FormatedNumberConverter..::.ConvertBack Method
FormatedNumberConverter Class See Also Send Feedback
Converts a number to string according to a given format.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

FormatedNumberConverter Class
Telerik.ReportViewer.Wpf Namespace


ITextResources Interface

[image]

Telerik Reporting Q2 2012
ITextResources Interface
Members See Also Send Feedback
This interface is used for customization or localization of all text resources, as alternative to localization/customization with .resx files.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public interface ITextResources
Visual Basic (Declaration)
Public Interface ITextResources

See Also

ITextResources Members
Telerik.ReportViewer.Wpf Namespace


ITextResources Members

[image] [image]

Telerik Reporting Q2 2012
ITextResources Members
ITextResources Interface Properties See Also Send Feedback

The ITextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelButtonText | Specifies the text for each Cancel button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the message if there is an export error.
ExportingMessage | Specifies the transitional exporting message.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
PageSetupToolTip | Specifies the tooltip for the PageSetup button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviewButtonText | Specifies the text for the Preview button in the parameters area.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersValidationError | Specifies the error message for the case when the report parameters are wrong or missing.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ITextResources Properties

[image] [image]

Telerik Reporting Q2 2012
ITextResources Properties
ITextResources Interface See Also Send Feedback

The ITextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelButtonText | Specifies the text for each Cancel button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the message if there is an export error.
ExportingMessage | Specifies the transitional exporting message.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
PageSetupToolTip | Specifies the tooltip for the PageSetup button.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviewButtonText | Specifies the text for the Preview button in the parameters area.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersValidationError | Specifies the error message for the case when the report parameters are wrong or missing.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


AllFiles Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.AllFiles Property
ITextResources Interface See Also Send Feedback
Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string AllFiles { get; }
Visual Basic (Declaration)
ReadOnly Property AllFiles As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


BackToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.BackToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string BackToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property BackToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


CancelButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CancelButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for each Cancel button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string CancelButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property CancelButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.CurrentPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string CurrentPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.DocumentMapToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string DocumentMapToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property DocumentMapToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ExportError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ExportError Property
ITextResources Interface See Also Send Feedback
Specifies the message if there is an export error.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ExportError { get; }
Visual Basic (Declaration)
ReadOnly Property ExportError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ExportingMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ExportingMessage Property
ITextResources Interface See Also Send Feedback
Specifies the transitional exporting message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ExportingMessage { get; }
Visual Basic (Declaration)
ReadOnly Property ExportingMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ExportToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ExportToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ExportToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.FirstPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string FirstPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property FirstPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ForwardToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ForwardToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Forward button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ForwardToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.LastPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string LastPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property LastPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


LoadingPageMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.LoadingPageMessage Property
ITextResources Interface See Also Send Feedback
Specifies the transitional loading page message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string LoadingPageMessage { get; }
Visual Basic (Declaration)
ReadOnly Property LoadingPageMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.NextPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string NextPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property NextPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


NoReportError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.NoReportError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for missing report.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string NoReportError { get; }
Visual Basic (Declaration)
ReadOnly Property NoReportError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PageNumberGreaterThanRangeError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PageNumberGreaterThanRangeError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the page number is greater than the count of pages.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PageNumberGreaterThanRangeError { get; }
Visual Basic (Declaration)
ReadOnly Property PageNumberGreaterThanRangeError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PageNumberLessThanRangeError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PageNumberLessThanRangeError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the page number is less than 1.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PageNumberLessThanRangeError { get; }
Visual Basic (Declaration)
ReadOnly Property PageNumberLessThanRangeError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PageSetupToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PageSetupToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the PageSetup button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PageSetupToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PageSetupToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ParametersToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ParametersToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ParametersToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PreviewButtonText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PreviewButtonText Property
ITextResources Interface See Also Send Feedback
Specifies the text for the Preview button in the parameters area.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PreviewButtonText { get; }
Visual Basic (Declaration)
ReadOnly Property PreviewButtonText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PreviousPageToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PreviousPageToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PreviousPageToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintPreviewToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Print Preview.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PrintPreviewToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PrintPreviewToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.PrintToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string PrintToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property PrintToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ProcessingReportMessage Property
ITextResources Interface See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ProcessingReportMessage { get; }
Visual Basic (Declaration)
ReadOnly Property ProcessingReportMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.RefreshToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string RefreshToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property RefreshToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ReportParametersAreaValidationError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersAreaValidationError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ReportParametersAreaValidationError { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersAreaValidationError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersNullText Property
ITextResources Interface See Also Send Feedback
Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ReportParametersNullText { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersNullText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersSelectAllText Property
ITextResources Interface See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ReportParametersSelectAllText { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersSelectAllText As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ReportParametersValidationError Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ReportParametersValidationError Property
ITextResources Interface See Also Send Feedback
Specifies the error message for the case when the report parameters are wrong or missing.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ReportParametersValidationError { get; }
Visual Basic (Declaration)
ReadOnly Property ReportParametersValidationError As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


StopToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.StopToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Stop button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string StopToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property StopToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


TotalPagesToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.TotalPagesToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string TotalPagesToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property TotalPagesToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


UpdatingParametersMessage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.UpdatingParametersMessage Property
ITextResources Interface See Also Send Feedback
Specifies the transitional updating parameters message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string UpdatingParametersMessage { get; }
Visual Basic (Declaration)
ReadOnly Property UpdatingParametersMessage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ZoomToolTip Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToolTip Property
ITextResources Interface See Also Send Feedback
Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ZoomToolTip { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToolTip As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToPageWidth Property
ITextResources Interface See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ZoomToPageWidth { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToPageWidth As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
ITextResources..::.ZoomToWholePage Property
ITextResources Interface See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
string ZoomToWholePage { get; }
Visual Basic (Declaration)
ReadOnly Property ZoomToWholePage As String

See Also

ITextResources Interface
Telerik.ReportViewer.Wpf Namespace


KeyDown Class

[image]

Telerik Reporting Q2 2012
KeyDown Class
Members See Also Send Feedback
Enables binding an ICommand to the FrameworkElement.KeyDown event

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class KeyDown
Visual Basic (Declaration)
Public Class KeyDown

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.KeyDown

See Also

KeyDown Members
Telerik.ReportViewer.Wpf Namespace


KeyDown Members

[image] [image]

Telerik Reporting Q2 2012
KeyDown Members
KeyDown Class Constructors Methods Fields Attached Properties See Also Send Feedback

The KeyDown type exposes the following members.

Constructors

Name | Description
KeyDown | Initializes a new instance of the KeyDown class

Methods

Name | Description
GetCommand |
SetCommand |

Fields

Name | Description
CommandProperty |

Attached Properties

Name | Description
Command |

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


KeyDown Constructor

[image]

Telerik Reporting Q2 2012
KeyDown Constructor
KeyDown Class See Also Send Feedback
Initializes a new instance of the KeyDown class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public KeyDown()
Visual Basic (Declaration)
Public Sub New

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


KeyDown Fields

[image] [image]

Telerik Reporting Q2 2012
KeyDown Fields
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Fields

Name | Description
CommandProperty |

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


CommandProperty Field

[image]

Telerik Reporting Q2 2012
KeyDown..::.CommandProperty Field
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty CommandProperty
Visual Basic (Declaration)
Public Shared ReadOnly CommandProperty As DependencyProperty

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


KeyDown Methods

[image] [image]

Telerik Reporting Q2 2012
KeyDown Methods
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Methods

Name | Description
GetCommand |
SetCommand |

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


GetCommand Method

[image]

Telerik Reporting Q2 2012
KeyDown..::.GetCommand Method
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static ICommand GetCommand(
    DependencyObject d
)
Visual Basic (Declaration)
Public Shared Function GetCommand ( _
    d As DependencyObject _
) As ICommand

Parameters

d
Type: System.Windows..::.DependencyObject

Return Value

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


SetCommand Method

[image]

Telerik Reporting Q2 2012
KeyDown..::.SetCommand Method
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static void SetCommand(
    DependencyObject d,
    ICommand value
)
Visual Basic (Declaration)
Public Shared Sub SetCommand ( _
    d As DependencyObject, _
    value As ICommand _
)

Parameters

d
Type: System.Windows..::.DependencyObject
value
Type: System.Windows.Input..::.ICommand

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


KeyDown Attached Properties

[image] [image]

Telerik Reporting Q2 2012
KeyDown Attached Properties
KeyDown Class See Also Send Feedback

The KeyDown type exposes the following members.

Attached Properties

Name | Description
Command |

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


Command Attached Property

[image]

Telerik Reporting Q2 2012
KeyDown..::.Command Attached Property
KeyDown Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
See GetCommand, SetCommand
Visual Basic (Declaration)
See GetCommand, SetCommand

See Also

KeyDown Class
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel Class

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Class
Members See Also Send Feedback
Represents the report multi value parameter model to associate the WPF parameter editor UI with.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class MultivalueAvailableValuesParameterModel : ParameterModel
Visual Basic (Declaration)
Public Class MultivalueAvailableValuesParameterModel _
    Inherits ParameterModel

Inheritance Hierarchy

System..::.Object
ObservableObject
ParameterModel
Telerik.ReportViewer.Wpf..::.ParameterModel
Telerik.ReportViewer.Wpf..::.MultivalueAvailableValuesParameterModel

See Also

MultivalueAvailableValuesParameterModel Members
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Members
MultivalueAvailableValuesParameterModel Class Properties See Also Send Feedback

The MultivalueAvailableValuesParameterModel type exposes the following members.

Properties

Name | Description
AvailableValues | Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem. (Overrides ParameterModelAvailableValues()()().)
IsDropDownOpen | Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.
SelectedLabels | Gets an enumerable of strings that contains the labels of all selected values.
TextResources | Gets or sets all the tooltips and messages (Inherited from ParameterModel.)
Value | Gets or sets the Value. (Overrides ParameterModelValue()()().)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel Properties

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel Properties
MultivalueAvailableValuesParameterModel Class See Also Send Feedback

The MultivalueAvailableValuesParameterModel type exposes the following members.

Properties

Name | Description
AvailableValues | Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem. (Overrides ParameterModelAvailableValues()()().)
IsDropDownOpen | Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.
SelectedLabels | Gets an enumerable of strings that contains the labels of all selected values.
TextResources | Gets or sets all the tooltips and messages (Inherited from ParameterModel.)
Value | Gets or sets the Value. (Overrides ParameterModelValue()()().)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.AvailableValues Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets a list of the available ParameterValueModels plus the MultivalueAvailableValuesParameterModel..::.SelectAllItem.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override List<IParameterValueModel> AvailableValues { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property AvailableValues As List(Of IParameterValueModel)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


IsDropDownOpen Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.IsDropDownOpen Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets or sets the value that indicates whether the Multivalue/AvailableValues editor is currently open.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


SelectedLabels Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.SelectedLabels Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets an enumerable of strings that contains the labels of all selected values.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public IEnumerable<string> SelectedLabels { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedLabels As IEnumerable(Of String)

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


Value Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::.Value Property
MultivalueAvailableValuesParameterModel Class See Also Send Feedback
Gets or sets the Value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override Object Value { get; set; }
Visual Basic (Declaration)
Public Overrides Property Value As Object

See Also

MultivalueAvailableValuesParameterModel Class
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Class

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Class
MultivalueAvailableValuesParameterModel Class Members See Also Send Feedback
Represents the SelectAll item in a Multivalue/AvailableValues editor

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class SelectAllItem : ParameterValueModel
Visual Basic (Declaration)
Public Class SelectAllItem _
    Inherits ParameterValueModel

Inheritance Hierarchy

System..::.Object
ObservableObject
ParameterValueModel
Telerik.ReportViewer.Wpf..::.MultivalueAvailableValuesParameterModel..::.SelectAllItem

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Members
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Members
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class Properties See Also Send Feedback

Represents the report multi value parameter model to associate the WPF parameter editor UI with.

The MultivalueAvailableValuesParameterModel..::.SelectAllItem type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the item is selected. (Overrides ParameterValueModelIsSelected()()().)

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Wpf Namespace


MultivalueAvailableValuesParameterModel.SelectAllItem Properties

[image] [image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem Properties
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class See Also Send Feedback

The MultivalueAvailableValuesParameterModel..::.SelectAllItem type exposes the following members.

Properties

Name | Description
IsSelected | Specifies whether the item is selected. (Overrides ParameterValueModelIsSelected()()().)

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Wpf Namespace


IsSelected Property

[image]

Telerik Reporting Q2 2012
MultivalueAvailableValuesParameterModel..::..SelectAllItem..::.IsSelected Property
MultivalueAvailableValuesParameterModel..::.SelectAllItem Class See Also Send Feedback
Specifies whether the item is selected.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsSelected As Boolean

See Also

MultivalueAvailableValuesParameterModel..::.SelectAllItem Class
Telerik.ReportViewer.Wpf Namespace


MultivalueParameterConverter Class

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Class
Members See Also Send Feedback
A value converter for multi-value parameters

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class MultivalueParameterConverter : IValueConverter
Visual Basic (Declaration)
Public Class MultivalueParameterConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.MultivalueParameterConverter

See Also

MultivalueParameterConverter Members
Telerik.ReportViewer.Wpf Namespace


MultivalueParameterConverter Members

[image] [image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Members
MultivalueParameterConverter Class Constructors Methods See Also Send Feedback

The MultivalueParameterConverter type exposes the following members.

Constructors

Name | Description
MultivalueParameterConverter | Creates new instance of MultivalueParameterConverter.

Methods

Name | Description
Convert | Converts a multi-value to single string value.
ConvertBack | Converts a single string value to multi-value.

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Wpf Namespace


MultivalueParameterConverter Constructor

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Constructor
MultivalueParameterConverter Class See Also Send Feedback
Creates new instance of MultivalueParameterConverter.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public MultivalueParameterConverter()
Visual Basic (Declaration)
Public Sub New

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Wpf Namespace


MultivalueParameterConverter Methods

[image] [image]

Telerik Reporting Q2 2012
MultivalueParameterConverter Methods
MultivalueParameterConverter Class See Also Send Feedback

The MultivalueParameterConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a multi-value to single string value.
ConvertBack | Converts a single string value to multi-value.

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter..::.Convert Method
MultivalueParameterConverter Class See Also Send Feedback
Converts a multi-value to single string value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
MultivalueParameterConverter..::.ConvertBack Method
MultivalueParameterConverter Class See Also Send Feedback
Converts a single string value to multi-value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

MultivalueParameterConverter Class
Telerik.ReportViewer.Wpf Namespace


ParameterContentControl Class

[image]

Telerik Reporting Q2 2012
ParameterContentControl Class
Members See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ParameterContentControl : ContentControl
Visual Basic (Declaration)
Public Class ParameterContentControl _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
Telerik.ReportViewer.Wpf..::.ParameterContentControl

See Also

ParameterContentControl Members
Telerik.ReportViewer.Wpf Namespace


ParameterContentControl Members

[image] [image]

Telerik Reporting Q2 2012
ParameterContentControl Members
ParameterContentControl Class Constructors Properties See Also Send Feedback

The ParameterContentControl type exposes the following members.

Constructors

Name | Description
ParameterContentControl | Initializes a new instance of the ParameterContentControl class

Properties

Name | Description
AvailableValues | Specifies whether the template can be used for parameters with available values.
Multivalue | Specifies whether the template can be used for multivalue parameters.
Type | Specifies the parameter type for which this template should be used.

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


ParameterContentControl Constructor

[image]

Telerik Reporting Q2 2012
ParameterContentControl Constructor
ParameterContentControl Class See Also Send Feedback
Initializes a new instance of the ParameterContentControl class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ParameterContentControl()
Visual Basic (Declaration)
Public Sub New

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


ParameterContentControl Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterContentControl Properties
ParameterContentControl Class See Also Send Feedback

The ParameterContentControl type exposes the following members.

Properties

Name | Description
AvailableValues | Specifies whether the template can be used for parameters with available values.
Multivalue | Specifies whether the template can be used for multivalue parameters.
Type | Specifies the parameter type for which this template should be used.

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


AvailableValues Property

[image]

Telerik Reporting Q2 2012
ParameterContentControl..::.AvailableValues Property
ParameterContentControl Class See Also Send Feedback
Specifies whether the template can be used for parameters with available values.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool AvailableValues { get; set; }
Visual Basic (Declaration)
Public Property AvailableValues As Boolean

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


Multivalue Property

[image]

Telerik Reporting Q2 2012
ParameterContentControl..::.Multivalue Property
ParameterContentControl Class See Also Send Feedback
Specifies whether the template can be used for multivalue parameters.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool Multivalue { get; set; }
Visual Basic (Declaration)
Public Property Multivalue As Boolean

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


Type Property

[image]

Telerik Reporting Q2 2012
ParameterContentControl..::.Type Property
ParameterContentControl Class See Also Send Feedback
Specifies the parameter type for which this template should be used.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String

See Also

ParameterContentControl Class
Telerik.ReportViewer.Wpf Namespace


ParameterModel Class

[image]

Telerik Reporting Q2 2012
ParameterModel Class
Members See Also Send Feedback
Represents the report parameter model to associate the WPF parameter editor UI with.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ParameterModel : ParameterModel
Visual Basic (Declaration)
Public Class ParameterModel _
    Inherits ParameterModel

Inheritance Hierarchy

System..::.Object
ObservableObject
ParameterModel
Telerik.ReportViewer.Wpf..::.ParameterModel
Telerik.ReportViewer.Wpf..::.MultivalueAvailableValuesParameterModel

See Also

ParameterModel Members
Telerik.ReportViewer.Wpf Namespace


ParameterModel Members

[image] [image]

Telerik Reporting Q2 2012
ParameterModel Members
ParameterModel Class Properties See Also Send Feedback

The ParameterModel type exposes the following members.

Properties

Name | Description
TextResources | Gets or sets all the tooltips and messages

See Also

ParameterModel Class
Telerik.ReportViewer.Wpf Namespace


ParameterModel Properties

[image] [image]

Telerik Reporting Q2 2012
ParameterModel Properties
ParameterModel Class See Also Send Feedback

The ParameterModel type exposes the following members.

Properties

Name | Description
TextResources | Gets or sets all the tooltips and messages

See Also

ParameterModel Class
Telerik.ReportViewer.Wpf Namespace


TextResources Property

[image]

Telerik Reporting Q2 2012
ParameterModel..::.TextResources Property
ParameterModel Class See Also Send Feedback
Gets or sets all the tooltips and messages

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ITextResources TextResources { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextResources As ITextResources

See Also

ParameterModel Class
Telerik.ReportViewer.Wpf Namespace


RenderingExtension Class

[image]

Telerik Reporting Q2 2012
RenderingExtension Class
Members See Also Send Feedback
Represents a rendering extension

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class RenderingExtension
Visual Basic (Declaration)
Public Class RenderingExtension

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.RenderingExtension

See Also

RenderingExtension Members
Telerik.ReportViewer.Wpf Namespace


RenderingExtension Members

[image] [image]

Telerik Reporting Q2 2012
RenderingExtension Members
RenderingExtension Class Properties See Also Send Feedback

The RenderingExtension type exposes the following members.

Properties

Name | Description
Description | Gets the description of the RenderingExtension
Name | Gets the name of the RenderingExtension

See Also

RenderingExtension Class
Telerik.ReportViewer.Wpf Namespace


RenderingExtension Properties

[image] [image]

Telerik Reporting Q2 2012
RenderingExtension Properties
RenderingExtension Class See Also Send Feedback

The RenderingExtension type exposes the following members.

Properties

Name | Description
Description | Gets the description of the RenderingExtension
Name | Gets the name of the RenderingExtension

See Also

RenderingExtension Class
Telerik.ReportViewer.Wpf Namespace


Description Property

[image]

Telerik Reporting Q2 2012
RenderingExtension..::.Description Property
RenderingExtension Class See Also Send Feedback
Gets the description of the RenderingExtension

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string Description { get; private set; }
Visual Basic (Declaration)
Public Property Description As String

See Also

RenderingExtension Class
Telerik.ReportViewer.Wpf Namespace


Name Property

[image]

Telerik Reporting Q2 2012
RenderingExtension..::.Name Property
RenderingExtension Class See Also Send Feedback
Gets the name of the RenderingExtension

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string Name { get; private set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

RenderingExtension Class
Telerik.ReportViewer.Wpf Namespace


ReportDocumentConverter Class

[image]

Telerik Reporting Q2 2012
ReportDocumentConverter Class
Members See Also Send Feedback
Converts report instance to assembly qualified name and vice versa.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ReportDocumentConverter : IValueConverter
Visual Basic (Declaration)
Public Class ReportDocumentConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.ReportDocumentConverter

See Also

ReportDocumentConverter Members
Telerik.ReportViewer.Wpf Namespace


ReportDocumentConverter Members

[image] [image]

Telerik Reporting Q2 2012
ReportDocumentConverter Members
ReportDocumentConverter Class Constructors Methods See Also Send Feedback

The ReportDocumentConverter type exposes the following members.

Constructors

Name | Description
ReportDocumentConverter | Initializes a new instance of the ReportDocumentConverter class

Methods

Name | Description
Convert |
ConvertBack |

See Also

ReportDocumentConverter Class
Telerik.ReportViewer.Wpf Namespace


ReportDocumentConverter Constructor

[image]

Telerik Reporting Q2 2012
ReportDocumentConverter Constructor
ReportDocumentConverter Class See Also Send Feedback
Initializes a new instance of the ReportDocumentConverter class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportDocumentConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ReportDocumentConverter Class
Telerik.ReportViewer.Wpf Namespace


ReportDocumentConverter Methods

[image] [image]

Telerik Reporting Q2 2012
ReportDocumentConverter Methods
ReportDocumentConverter Class See Also Send Feedback

The ReportDocumentConverter type exposes the following members.

Methods

Name | Description
Convert |
ConvertBack |

See Also

ReportDocumentConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
ReportDocumentConverter..::.Convert Method
ReportDocumentConverter Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ReportDocumentConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
ReportDocumentConverter..::.ConvertBack Method
ReportDocumentConverter Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ReportDocumentConverter Class
Telerik.ReportViewer.Wpf Namespace


ReportParameterEditorTemplateSelector Class

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Class
Members See Also Send Feedback
Represents a selector for the report parameter editor templates.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ReportParameterEditorTemplateSelector : DataTemplateSelector
Visual Basic (Declaration)
Public Class ReportParameterEditorTemplateSelector _
    Inherits DataTemplateSelector

Inheritance Hierarchy

System..::.Object
System.Windows.Controls..::.DataTemplateSelector
Telerik.ReportViewer.Wpf..::.ReportParameterEditorTemplateSelector

See Also

ReportParameterEditorTemplateSelector Members
Telerik.ReportViewer.Wpf Namespace


ReportParameterEditorTemplateSelector Members

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Members
ReportParameterEditorTemplateSelector Class Constructors Methods Properties See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Constructors

Name | Description
ReportParameterEditorTemplateSelector | Initializes a new instance of the ReportParameterEditorTemplateSelector class

Methods

Name | Description
SelectTemplate | Gets the proper editor template for the given parameter model. (Overrides DataTemplateSelector..::.SelectTemplate(Object, DependencyObject).)

Properties

Name | Description
Templates | Gets a list of DataTemplate.

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


ReportParameterEditorTemplateSelector Constructor

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Constructor
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Initializes a new instance of the ReportParameterEditorTemplateSelector class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportParameterEditorTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


ReportParameterEditorTemplateSelector Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Methods
ReportParameterEditorTemplateSelector Class See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Methods

Name | Description
SelectTemplate | Gets the proper editor template for the given parameter model. (Overrides DataTemplateSelector..::.SelectTemplate(Object, DependencyObject).)

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


SelectTemplate Method

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector..::.SelectTemplate Method
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Gets the proper editor template for the given parameter model.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overrides Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
An instance of ParameterModel.
container
Type: System.Windows..::.DependencyObject

Return Value

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


ReportParameterEditorTemplateSelector Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector Properties
ReportParameterEditorTemplateSelector Class See Also Send Feedback

The ReportParameterEditorTemplateSelector type exposes the following members.

Properties

Name | Description
Templates | Gets a list of DataTemplate.

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


Templates Property

[image]

Telerik Reporting Q2 2012
ReportParameterEditorTemplateSelector..::.Templates Property
ReportParameterEditorTemplateSelector Class See Also Send Feedback
Gets a list of DataTemplate.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public List<DataTemplate> Templates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Templates As List(Of DataTemplate)

See Also

ReportParameterEditorTemplateSelector Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Class

[image]

Telerik Reporting Q2 2012
ReportParametersControl Class
Members See Also Send Feedback
Represents a control that holds a collection of ParameterContentControl.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ReportParametersControl : ItemsControl
Visual Basic (Declaration)
Public Class ReportParametersControl _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
Telerik.ReportViewer.Wpf..::.ReportParametersControl

See Also

ReportParametersControl Members
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Members

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Members
ReportParametersControl Class Constructors Methods Fields Properties See Also Send Feedback

The ReportParametersControl type exposes the following members.

Constructors

Name | Description
ReportParametersControl | Initializes a new instance of the ReportParametersControl class

Methods

Name | Description
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)

Fields

Name | Description
ParameterTemplateSelectorProperty | Represents the ParameterTemplateSelector property.

Properties

Name | Description
ParameterTemplateSelector | Gets or sets ReportParameterEditorTemplateSelector.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Constructor

[image]

Telerik Reporting Q2 2012
ReportParametersControl Constructor
ReportParametersControl Class See Also Send Feedback
Initializes a new instance of the ReportParametersControl class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportParametersControl()
Visual Basic (Declaration)
Public Sub New

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Fields

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Fields
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Fields

Name | Description
ParameterTemplateSelectorProperty | Represents the ParameterTemplateSelector property.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ParameterTemplateSelectorProperty Field

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.ParameterTemplateSelectorProperty Field
ReportParametersControl Class See Also Send Feedback
Represents the ParameterTemplateSelector property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty ParameterTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ParameterTemplateSelectorProperty As DependencyProperty

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Methods

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Methods
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Methods

Name | Description
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


PrepareContainerForItemOverride Method

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.PrepareContainerForItemOverride Method
ReportParametersControl Class See Also Send Feedback
Prepares the specified element to display the specified item.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersControl Properties

[image] [image]

Telerik Reporting Q2 2012
ReportParametersControl Properties
ReportParametersControl Class See Also Send Feedback

The ReportParametersControl type exposes the following members.

Properties

Name | Description
ParameterTemplateSelector | Gets or sets ReportParameterEditorTemplateSelector.

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ParameterTemplateSelector Property

[image]

Telerik Reporting Q2 2012
ReportParametersControl..::.ParameterTemplateSelector Property
ReportParametersControl Class See Also Send Feedback
Gets or sets ReportParameterEditorTemplateSelector.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportParameterEditorTemplateSelector ParameterTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ParameterTemplateSelector As ReportParameterEditorTemplateSelector

See Also

ReportParametersControl Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer Class

[image]

Telerik Reporting Q2 2012
ReportViewer Class
Members See Also Send Feedback
Represents the WPF ReportViewer control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ReportViewer : Control
Visual Basic (Declaration)
Public Class ReportViewer _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
Telerik.ReportViewer.Wpf..::.ReportViewer

See Also

ReportViewer Members
Telerik.ReportViewer.Wpf Namespace


ReportViewer Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Members
ReportViewer Class Constructors Methods Fields Properties See Also Send Feedback

The ReportViewer type exposes the following members.

Constructors

Name | Description
ReportViewer | Initializes a new instance of the ReportViewer class.

Methods

Name | Description
OnApplyTemplate | (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnPropertyChanged | (Overrides FrameworkElement..::.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
RefreshReport | Refreshes the report in the viewer.

Fields

Name | Description
ReportSourceProperty | Defines the ReportSource dependency property.
TextResourcesProperty | Defines the TextResources property.
ViewModeProperty | Defines the ViewMode property.
ZoomModeProperty | Defines the ZoomMode property.
ZoomPercentProperty | Defines the ZoomPercent property.

Properties

Name | Description
Report | Obsolete. Specifies the report source.
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
TextResources | Gets or sets the tooltips and the messages of the control.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the control.
ZoomPercent | Gets or sets the zoom percentage to use when displaying the report.

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer Constructor

[image]

Telerik Reporting Q2 2012
ReportViewer Constructor
ReportViewer Class See Also Send Feedback
Initializes a new instance of the ReportViewer class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportViewer()
Visual Basic (Declaration)
Public Sub New

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Fields
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Fields

Name | Description
ReportSourceProperty | Defines the ReportSource dependency property.
TextResourcesProperty | Defines the TextResources property.
ViewModeProperty | Defines the ViewMode property.
ZoomModeProperty | Defines the ZoomMode property.
ZoomPercentProperty | Defines the ZoomPercent property.

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportSourceProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportSourceProperty Field
ReportViewer Class See Also Send Feedback
Defines the ReportSource dependency property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty ReportSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ReportSourceProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


TextResourcesProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.TextResourcesProperty Field
ReportViewer Class See Also Send Feedback
Defines the TextResources property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty TextResourcesProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextResourcesProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ViewModeProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ViewModeProperty Field
ReportViewer Class See Also Send Feedback
Defines the ViewMode property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty ViewModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewModeProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ZoomModeProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomModeProperty Field
ReportViewer Class See Also Send Feedback
Defines the ZoomMode property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty ZoomModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomModeProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ZoomPercentProperty Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomPercentProperty Field
ReportViewer Class See Also Send Feedback
Defines the ZoomPercent property.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static readonly DependencyProperty ZoomPercentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomPercentProperty As DependencyProperty

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Methods
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Methods

Name | Description
OnApplyTemplate | (Overrides FrameworkElement..::.OnApplyTemplate()()().)
OnPropertyChanged | (Overrides FrameworkElement..::.OnPropertyChanged(DependencyPropertyChangedEventArgs).)
RefreshReport | Refreshes the report in the viewer.

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


OnApplyTemplate Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnApplyTemplate Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


OnPropertyChanged Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.OnPropertyChanged Method
ReportViewer Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected override void OnPropertyChanged(
    DependencyPropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnPropertyChanged ( _
    e As DependencyPropertyChangedEventArgs _
)

Parameters

e
Type: System.Windows..::.DependencyPropertyChangedEventArgs

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


RefreshReport Method

[image]

Telerik Reporting Q2 2012
ReportViewer..::.RefreshReport Method
ReportViewer Class See Also Send Feedback
Refreshes the report in the viewer.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public void RefreshReport()
Visual Basic (Declaration)
Public Sub RefreshReport

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewer Properties
ReportViewer Class See Also Send Feedback

The ReportViewer type exposes the following members.

Properties

Name | Description
Report | Obsolete. Specifies the report source.
ReportSource | Gets or sets the ReportSource for the report displayed in the viewer.
TextResources | Gets or sets the tooltips and the messages of the control.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
ZoomMode | Gets or sets the zoom mode of the control.
ZoomPercent | Gets or sets the zoom percentage to use when displaying the report.

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


Report Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.Report Property
ReportViewer Class See Also Send Feedback
Specifies the report source.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
[ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")]
public IReportDocument Report { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("The Report property is now obsolete. Please, use the ReportSource property instead.")> _
Public Property Report As IReportDocument

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ReportSource Property
ReportViewer Class See Also Send Feedback
Gets or sets the ReportSource for the report displayed in the viewer.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace
Telerik.Reporting..::.ReportSource
Telerik.Reporting..::.UriReportSource
Telerik.Reporting..::.TypeReportSource
Telerik.Reporting..::.InstanceReportSource
Telerik.Reporting..::.XmlReportSource


TextResources Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.TextResources Property
ReportViewer Class See Also Send Feedback
Gets or sets the tooltips and the messages of the control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ITextResources TextResources { get; set; }
Visual Basic (Declaration)
Public Property TextResources As ITextResources

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ViewMode Property
ReportViewer Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomMode Property
ReportViewer Class See Also Send Feedback
Gets or sets the zoom mode of the control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ZoomPercent Property

[image]

Telerik Reporting Q2 2012
ReportViewer..::.ZoomPercent Property
ReportViewer Class See Also Send Feedback
Gets or sets the zoom percentage to use when displaying the report.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public int ZoomPercent { get; set; }
Visual Basic (Declaration)
Public Property ZoomPercent As Integer

See Also

ReportViewer Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer.TemplateParts Class

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Class
ReportViewer Class Members See Also Send Feedback
Specifies the template parts names.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static class TemplateParts
Visual Basic (Declaration)
Public NotInheritable Class TemplateParts

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.ReportViewer..::.TemplateParts

See Also

ReportViewer..::.TemplateParts Members
Telerik.ReportViewer.Wpf Namespace


ReportViewer.TemplateParts Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Members
ReportViewer..::.TemplateParts Class Fields See Also Send Feedback

Represents the WPF ReportViewer control.

The ReportViewer..::.TemplateParts type exposes the following members.

Fields

Name | Description
LayoutRoot | Specifies the name of the layout root template part.
PageContainer | Specifies the name of the page container template part.
PageScrollViewer | Specifies the name of the page scroll viewer template part.

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Wpf Namespace


ReportViewer.TemplateParts Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts Fields
ReportViewer..::.TemplateParts Class See Also Send Feedback

The ReportViewer..::.TemplateParts type exposes the following members.

Fields

Name | Description
LayoutRoot | Specifies the name of the layout root template part.
PageContainer | Specifies the name of the page container template part.
PageScrollViewer | Specifies the name of the page scroll viewer template part.

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Wpf Namespace


LayoutRoot Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.LayoutRoot Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the layout root template part.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string LayoutRoot
Visual Basic (Declaration)
Public Const LayoutRoot As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Wpf Namespace


PageContainer Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.PageContainer Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the page container template part.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string PageContainer
Visual Basic (Declaration)
Public Const PageContainer As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Wpf Namespace


PageScrollViewer Field

[image]

Telerik Reporting Q2 2012
ReportViewer..::..TemplateParts..::.PageScrollViewer Field
ReportViewer..::.TemplateParts Class See Also Send Feedback
Specifies the name of the page scroll viewer template part.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string PageScrollViewer
Visual Basic (Declaration)
Public Const PageScrollViewer As String

See Also

ReportViewer..::.TemplateParts Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel Class
Members See Also Send Feedback
Represents the report viewer model.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ReportViewerModel : ObservableObject
Visual Basic (Declaration)
Public Class ReportViewerModel _
    Inherits ObservableObject

Inheritance Hierarchy

System..::.Object
ObservableObject
Telerik.ReportViewer.Wpf..::.ReportViewerModel

See Also

ReportViewerModel Members
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel Members
ReportViewerModel Class Constructors Properties See Also Send Feedback

The ReportViewerModel type exposes the following members.

Constructors

Name | Description
ReportViewerModel | Creates a new instance of the ReportViewerModel class.

Properties

Name | Description
AvailableZoomValues | Returns the available zoom values.
BookmarkTarget | Specifies the bookmark target.
CancelExportCommand | Gets the CancelExport command.
DocumentMapNodes | Gets or sets a list of document map nodes.
DocumentMapToolTip | Gets the Document Map tooltip
DocumentMapWidth | Gets or sets the width of the document map column
Error | Gets or sets the error message.
ExportProgress | Gets or sets the text displayed during the export action.
HasDocumentMap | Indicates whether there is a document map or not.
HasError | Indicates whether an error has occurred.
HasParameters | Specifies whether there are parameters or not.
IsDocumentMapVisible | Indicates whether the document map is visible or not.
IsExportEnabled | Specifies whether the export is enabled.
IsInProgress | Indicates whether the report viewer is working.
IsMoveToPageEnabled | Specifies whether there is another page you can navigate to.
IsParametersAreaVisible | Specifies whether the parameters area is visible.
IsPreviewButtonVisible | Determines if the Preview button in the parameters area is visible
IsPrintPreviewChecked | Specifies whether the PrintPreview mode is toggled.
IsUpdatingParameters | Determines if the parameters are being updated
MoveToFirstPageCommand | Gets the MoveToFirstPage command.
MoveToLastPageCommand | Gets the MoveToLastPage command.
MoveToNextPageCommand | Gets the MoveToNextPage command.
MoveToPreviousPageCommand | Gets the MoveToPreviousPage command.
NavigateBackCommand | Gets the NavigateBack command.
NavigateForwardCommand | Gets the NavigateForward command.
NavigateToSpecificPageCommand | Gets the NavigateToSpecificPageCommand command.
PageCount | Specifies the total number of the report pages.
PageHeight | Gets the current page height.
PageNumber | Gets or sets the current page number.
PageNumberModel | For internal use only
PageRoot | Specifies the page root.
PageSetupCommand | Gets the PageSetup command.
PageTransform | Specifies the page transform.
PageWidth | Gets the current page width.
ParameterModels | Gets or sets a list of parameter models.
ParametersToolTip | Gets the Parameters tooltip
PreviewReportCommand | Gets the PreviewReport command.
PrintPreviewToolTip | Gets the Print Preview/Interactive view tooltip
PrintReportCommand | Gets the PrintReport command.
ProgressMessage | Specifies the text of the progress message.
RefreshReportCommand | Gets the RefreshReport command.
RenderingExtensions | Represents a list of rendering extension infos.
ReportSource | Specifies the source for the report.
SelectedDocumentMapNode | Gets or sets the selected node of the document map.
SelectedRenderingExtension | Sets a specific rendering extension info.
ShowExportDialog | Determines if the export dialog has to be shown
State | Gets or sets the report viewer state.
StopRenderingCommand | Gets the StopRendering command.
TextResources | Gets or sets all the tooltips and messages
TogglePrintPreviewCommand | Gets the TogglePrintPreview command.
UpdateParametersProgress | Gets or sets the text of the update parameters progress message.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Zoom | Specifies the scale factor.
ZoomMode | Specifies the zoom mode: percent, page width or full page.
ZoomText | Gets or sets the zoom value as text.

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerModel Constructor
ReportViewerModel Class See Also Send Feedback
Creates a new instance of the ReportViewerModel class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportViewerModel(
    Size pageViewportSize,
    Dispatcher dispatcher
)
Visual Basic (Declaration)
Public Sub New ( _
    pageViewportSize As Size, _
    dispatcher As Dispatcher _
)

Parameters

pageViewportSize
Type: System.Windows..::.Size
dispatcher
Type: System.Windows.Threading..::.Dispatcher

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel Properties
ReportViewerModel Class See Also Send Feedback

The ReportViewerModel type exposes the following members.

Properties

Name | Description
AvailableZoomValues | Returns the available zoom values.
BookmarkTarget | Specifies the bookmark target.
CancelExportCommand | Gets the CancelExport command.
DocumentMapNodes | Gets or sets a list of document map nodes.
DocumentMapToolTip | Gets the Document Map tooltip
DocumentMapWidth | Gets or sets the width of the document map column
Error | Gets or sets the error message.
ExportProgress | Gets or sets the text displayed during the export action.
HasDocumentMap | Indicates whether there is a document map or not.
HasError | Indicates whether an error has occurred.
HasParameters | Specifies whether there are parameters or not.
IsDocumentMapVisible | Indicates whether the document map is visible or not.
IsExportEnabled | Specifies whether the export is enabled.
IsInProgress | Indicates whether the report viewer is working.
IsMoveToPageEnabled | Specifies whether there is another page you can navigate to.
IsParametersAreaVisible | Specifies whether the parameters area is visible.
IsPreviewButtonVisible | Determines if the Preview button in the parameters area is visible
IsPrintPreviewChecked | Specifies whether the PrintPreview mode is toggled.
IsUpdatingParameters | Determines if the parameters are being updated
MoveToFirstPageCommand | Gets the MoveToFirstPage command.
MoveToLastPageCommand | Gets the MoveToLastPage command.
MoveToNextPageCommand | Gets the MoveToNextPage command.
MoveToPreviousPageCommand | Gets the MoveToPreviousPage command.
NavigateBackCommand | Gets the NavigateBack command.
NavigateForwardCommand | Gets the NavigateForward command.
NavigateToSpecificPageCommand | Gets the NavigateToSpecificPageCommand command.
PageCount | Specifies the total number of the report pages.
PageHeight | Gets the current page height.
PageNumber | Gets or sets the current page number.
PageNumberModel | For internal use only
PageRoot | Specifies the page root.
PageSetupCommand | Gets the PageSetup command.
PageTransform | Specifies the page transform.
PageWidth | Gets the current page width.
ParameterModels | Gets or sets a list of parameter models.
ParametersToolTip | Gets the Parameters tooltip
PreviewReportCommand | Gets the PreviewReport command.
PrintPreviewToolTip | Gets the Print Preview/Interactive view tooltip
PrintReportCommand | Gets the PrintReport command.
ProgressMessage | Specifies the text of the progress message.
RefreshReportCommand | Gets the RefreshReport command.
RenderingExtensions | Represents a list of rendering extension infos.
ReportSource | Specifies the source for the report.
SelectedDocumentMapNode | Gets or sets the selected node of the document map.
SelectedRenderingExtension | Sets a specific rendering extension info.
ShowExportDialog | Determines if the export dialog has to be shown
State | Gets or sets the report viewer state.
StopRenderingCommand | Gets the StopRendering command.
TextResources | Gets or sets all the tooltips and messages
TogglePrintPreviewCommand | Gets the TogglePrintPreview command.
UpdateParametersProgress | Gets or sets the text of the update parameters progress message.
ViewMode | Specifies whether the viewer is in interactive or print preview mode.
Zoom | Specifies the scale factor.
ZoomMode | Specifies the zoom mode: percent, page width or full page.
ZoomText | Gets or sets the zoom value as text.

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


AvailableZoomValues Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.AvailableZoomValues Property
ReportViewerModel Class See Also Send Feedback
Returns the available zoom values.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public IEnumerable<string> AvailableZoomValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property AvailableZoomValues As IEnumerable(Of String)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


BookmarkTarget Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.BookmarkTarget Property
ReportViewerModel Class See Also Send Feedback
Specifies the bookmark target.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public FrameworkElement BookmarkTarget { get; set; }
Visual Basic (Declaration)
Public Property BookmarkTarget As FrameworkElement

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


CancelExportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.CancelExportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the CancelExport command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand CancelExportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property CancelExportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


DocumentMapNodes Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapNodes Property
ReportViewerModel Class See Also Send Feedback
Gets or sets a list of document map nodes.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public IList<DocumentMapNodeModel> DocumentMapNodes { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapNodes As IList(Of DocumentMapNodeModel)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Document Map tooltip

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string DocumentMapToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property DocumentMapToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


DocumentMapWidth Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.DocumentMapWidth Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the width of the document map column

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public GridLength DocumentMapWidth { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapWidth As GridLength

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


Error Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.Error Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the error message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string Error { get; set; }
Visual Basic (Declaration)
Public Property Error As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ExportProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ExportProgress Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the text displayed during the export action.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ExportProgress { get; set; }
Visual Basic (Declaration)
Public Property ExportProgress As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


HasDocumentMap Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.HasDocumentMap Property
ReportViewerModel Class See Also Send Feedback
Indicates whether there is a document map or not.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool HasDocumentMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasDocumentMap As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


HasError Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.HasError Property
ReportViewerModel Class See Also Send Feedback
Indicates whether an error has occurred.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool HasError { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasError As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


HasParameters Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.HasParameters Property
ReportViewerModel Class See Also Send Feedback
Specifies whether there are parameters or not.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool HasParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasParameters As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsDocumentMapVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsDocumentMapVisible Property
ReportViewerModel Class See Also Send Feedback
Indicates whether the document map is visible or not.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsDocumentMapVisible { get; set; }
Visual Basic (Declaration)
Public Property IsDocumentMapVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsExportEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsExportEnabled Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the export is enabled.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsExportEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsExportEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsInProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsInProgress Property
ReportViewerModel Class See Also Send Feedback
Indicates whether the report viewer is working.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsInProgress { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsInProgress As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsMoveToPageEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsMoveToPageEnabled Property
ReportViewerModel Class See Also Send Feedback
Specifies whether there is another page you can navigate to.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsMoveToPageEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsMoveToPageEnabled As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsParametersAreaVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsParametersAreaVisible Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the parameters area is visible.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsParametersAreaVisible { get; set; }
Visual Basic (Declaration)
Public Property IsParametersAreaVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsPreviewButtonVisible Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsPreviewButtonVisible Property
ReportViewerModel Class See Also Send Feedback
Determines if the Preview button in the parameters area is visible

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsPreviewButtonVisible { get; set; }
Visual Basic (Declaration)
Public Property IsPreviewButtonVisible As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsPrintPreviewChecked Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsPrintPreviewChecked Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the PrintPreview mode is toggled.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsPrintPreviewChecked { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsPrintPreviewChecked As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


IsUpdatingParameters Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.IsUpdatingParameters Property
ReportViewerModel Class See Also Send Feedback
Determines if the parameters are being updated

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsUpdatingParameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsUpdatingParameters As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


MoveToFirstPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToFirstPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToFirstPage command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand MoveToFirstPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToFirstPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


MoveToLastPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToLastPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToLastPage command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand MoveToLastPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToLastPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


MoveToNextPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToNextPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToNextPage command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand MoveToNextPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToNextPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


MoveToPreviousPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.MoveToPreviousPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the MoveToPreviousPage command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand MoveToPreviousPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property MoveToPreviousPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


NavigateBackCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateBackCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateBack command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand NavigateBackCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateBackCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


NavigateForwardCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateForwardCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateForward command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand NavigateForwardCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateForwardCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


NavigateToSpecificPageCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.NavigateToSpecificPageCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the NavigateToSpecificPageCommand command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand NavigateToSpecificPageCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property NavigateToSpecificPageCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageCount Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageCount Property
ReportViewerModel Class See Also Send Feedback
Specifies the total number of the report pages.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public int PageCount { get; set; }
Visual Basic (Declaration)
Public Property PageCount As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageHeight Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageHeight Property
ReportViewerModel Class See Also Send Feedback
Gets the current page height.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public double PageHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageHeight As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageNumber Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageNumber Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the current page number.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public int PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageNumberModel Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageNumberModel Property
ReportViewerModel Class See Also Send Feedback
For internal use only

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public int PageNumberModel { get; set; }
Visual Basic (Declaration)
Public Property PageNumberModel As Integer

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageRoot Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageRoot Property
ReportViewerModel Class See Also Send Feedback
Specifies the page root.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public FrameworkElement PageRoot { get; set; }
Visual Basic (Declaration)
Public Property PageRoot As FrameworkElement

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageSetupCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageSetupCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the PageSetup command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand PageSetupCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSetupCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageTransform Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageTransform Property
ReportViewerModel Class See Also Send Feedback
Specifies the page transform.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Transform PageTransform { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageTransform As Transform

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PageWidth Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PageWidth Property
ReportViewerModel Class See Also Send Feedback
Gets the current page width.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public double PageWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageWidth As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ParameterModels Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ParameterModels Property
ReportViewerModel Class See Also Send Feedback
Gets or sets a list of parameter models.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ParameterModelCollection<ParameterModel> ParameterModels { get; set; }
Visual Basic (Declaration)
Public Property ParameterModels As ParameterModelCollection(Of ParameterModel)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ParametersToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Parameters tooltip

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ParametersToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParametersToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PreviewReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PreviewReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the PreviewReport command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand PreviewReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviewReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintPreviewToolTip Property
ReportViewerModel Class See Also Send Feedback
Gets the Print Preview/Interactive view tooltip

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PrintPreviewToolTip { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintPreviewToolTip As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


PrintReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.PrintReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the PrintReport command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand PrintReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrintReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ProgressMessage Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ProgressMessage Property
ReportViewerModel Class See Also Send Feedback
Specifies the text of the progress message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ProgressMessage { get; set; }
Visual Basic (Declaration)
Public Property ProgressMessage As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


RefreshReportCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.RefreshReportCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the RefreshReport command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand RefreshReportCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property RefreshReportCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


RenderingExtensions Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.RenderingExtensions Property
ReportViewerModel Class See Also Send Feedback
Represents a list of rendering extension infos.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public IEnumerable<RenderingExtension> RenderingExtensions { get; }
Visual Basic (Declaration)
Public ReadOnly Property RenderingExtensions As IEnumerable(Of RenderingExtension)

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ReportSource Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ReportSource Property
ReportViewerModel Class See Also Send Feedback
Specifies the source for the report.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ReportSource ReportSource { get; set; }
Visual Basic (Declaration)
Public Property ReportSource As ReportSource

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


SelectedDocumentMapNode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.SelectedDocumentMapNode Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the selected node of the document map.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public DocumentMapNodeModel SelectedDocumentMapNode { get; set; }
Visual Basic (Declaration)
Public Property SelectedDocumentMapNode As DocumentMapNodeModel

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


SelectedRenderingExtension Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.SelectedRenderingExtension Property
ReportViewerModel Class See Also Send Feedback
Sets a specific rendering extension info.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public RenderingExtension SelectedRenderingExtension { get; set; }
Visual Basic (Declaration)
Public Property SelectedRenderingExtension As RenderingExtension

Remarks

Setting the property triggers the export operation automatically. The new value is not stored and the getter always returns null (Nothing in Visual Basic).

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ShowExportDialog Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ShowExportDialog Property
ReportViewerModel Class See Also Send Feedback
Determines if the export dialog has to be shown

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool ShowExportDialog { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShowExportDialog As Boolean

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


State Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.State Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the report viewer state.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


StopRenderingCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.StopRenderingCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the StopRendering command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand StopRenderingCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property StopRenderingCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


TextResources Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.TextResources Property
ReportViewerModel Class See Also Send Feedback
Gets or sets all the tooltips and messages

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ITextResources TextResources { get; set; }
Visual Basic (Declaration)
Public Property TextResources As ITextResources

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


TogglePrintPreviewCommand Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.TogglePrintPreviewCommand Property
ReportViewerModel Class See Also Send Feedback
Gets the TogglePrintPreview command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ICommand TogglePrintPreviewCommand { get; }
Visual Basic (Declaration)
Public ReadOnly Property TogglePrintPreviewCommand As ICommand

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


UpdateParametersProgress Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.UpdateParametersProgress Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the text of the update parameters progress message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string UpdateParametersProgress { get; internal set; }
Visual Basic (Declaration)
Public Property UpdateParametersProgress As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ViewMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ViewMode Property
ReportViewerModel Class See Also Send Feedback
Specifies whether the viewer is in interactive or print preview mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ViewMode ViewMode { get; set; }
Visual Basic (Declaration)
Public Property ViewMode As ViewMode

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


Zoom Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.Zoom Property
ReportViewerModel Class See Also Send Feedback
Specifies the scale factor.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ZoomMode Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ZoomMode Property
ReportViewerModel Class See Also Send Feedback
Specifies the zoom mode: percent, page width or full page.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ZoomMode ZoomMode { get; set; }
Visual Basic (Declaration)
Public Property ZoomMode As ZoomMode

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ZoomText Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::.ZoomText Property
ReportViewerModel Class See Also Send Feedback
Gets or sets the zoom value as text.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ZoomText { get; set; }
Visual Basic (Declaration)
Public Property ZoomText As String

See Also

ReportViewerModel Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Class
ReportViewerModel Class Members See Also Send Feedback
Represents a base class for a command.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public abstract class Command : ObservableObject,
    ICommand
Visual Basic (Declaration)
Public MustInherit Class Command _
    Inherits ObservableObject _
    Implements ICommand

Inheritance Hierarchy

System..::.Object
ObservableObject
Telerik.ReportViewer.Wpf..::.ReportViewerModel..::.Command
Telerik.ReportViewer.Wpf..::.ReportViewerModel..::.ReportViewerCommand

See Also

ReportViewerModel..::.Command Members
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Members
ReportViewerModel..::.Command Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

Represents the report viewer model.

The ReportViewerModel..::.Command type exposes the following members.

Constructors

Name | Description
ReportViewerModel..::.Command | Initializes a new instance of the ReportViewerModel..::.Command class

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked.
OnCanExecuteChanged | Raises the CanExcute .

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled.

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecute |
ICommand..::.CanExecuteChanged |
ICommand..::.Execute |

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Constructor
ReportViewerModel..::.Command Class See Also Send Feedback
Initializes a new instance of the ReportViewerModel..::.Command class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected Command()
Visual Basic (Declaration)
Protected Sub New

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Methods
ReportViewerModel..::.Command Class See Also Send Feedback

The ReportViewerModel..::.Command type exposes the following members.

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked.
OnCanExecuteChanged | Raises the CanExcute .

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecute |
ICommand..::.Execute |

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ICommand.CanExecute Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.ICommand..::.CanExecute Method
ReportViewerModel..::.Command Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
bool ICommand.CanExecute(
    Object parameter
)
Visual Basic (Declaration)
Private Function CanExecute ( _
    parameter As Object _
) As Boolean Implements ICommand.CanExecute

Parameters

parameter
Type: System..::.Object

Implements

ICommand..::.CanExecute(Object)

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ICommand.Execute Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.ICommand..::.Execute Method
ReportViewerModel..::.Command Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
void ICommand.Execute(
    Object parameter
)
Visual Basic (Declaration)
Private Sub Execute ( _
    parameter As Object _
) Implements ICommand.Execute

Parameters

parameter
Type: System..::.Object

Implements

ICommand..::.Execute(Object)

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


Execute Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.Execute Method
ReportViewerModel..::.Command Class See Also Send Feedback
Defines the method to be called when the command is invoked.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected abstract void Execute(
    Object parameter
)
Visual Basic (Declaration)
Protected MustOverride Sub Execute ( _
    parameter As Object _
)

Parameters

parameter
Type: System..::.Object
Data used by the command. If the command does not require data to be passed, this object can be set to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


OnCanExecuteChanged Method

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.OnCanExecuteChanged Method
ReportViewerModel..::.Command Class See Also Send Feedback
Raises the CanExcute .

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected virtual void OnCanExecuteChanged()
Visual Basic (Declaration)
Protected Overridable Sub OnCanExecuteChanged

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Properties
ReportViewerModel..::.Command Class See Also Send Feedback

The ReportViewerModel..::.Command type exposes the following members.

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled.

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


IsEnabled Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.IsEnabled Property
ReportViewerModel..::.Command Class See Also Send Feedback
Specifies whether the command is enabled.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic (Declaration)
Public Property IsEnabled As Boolean

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.Command Events

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command Events
ReportViewerModel..::.Command Class See Also Send Feedback

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecuteChanged |

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ICommand.CanExecuteChanged Event

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..Command..::.ICommand..::.CanExecuteChanged Event
ReportViewerModel..::.Command Class See Also Send Feedback

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
event EventHandler ICommand.CanExecuteChanged
Visual Basic (Declaration)
Private Event CanExecuteChanged As EventHandler
    Implements ICommand.CanExecuteChanged

Implements

ICommand..::.CanExecuteChanged

See Also

ReportViewerModel..::.Command Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Class

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Class
ReportViewerModel Class Members See Also Send Feedback
Represents a base class for the report viewer's commands.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public abstract class ReportViewerCommand : ReportViewerModel..::.Command
Visual Basic (Declaration)
Public MustInherit Class ReportViewerCommand _
    Inherits ReportViewerModel..::.Command

Inheritance Hierarchy

System..::.Object
ObservableObject
Telerik.ReportViewer.Wpf..::.ReportViewerModel..::.Command
Telerik.ReportViewer.Wpf..::.ReportViewerModel..::.ReportViewerCommand

See Also

ReportViewerModel..::.ReportViewerCommand Members
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Members
ReportViewerModel..::.ReportViewerCommand Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

Represents the report viewer model.

The ReportViewerModel..::.ReportViewerCommand type exposes the following members.

Constructors

Name | Description
ReportViewerModel..::.ReportViewerCommand | Initializes a new instance of the ReportViewerCommand class.

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked. (Inherited from ReportViewerModel..::.Command.)
OnCanExecuteChanged | Raises the CanExcute . (Inherited from ReportViewerModel..::.Command.)

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled. (Inherited from ReportViewerModel..::.Command.)
ViewerModel | Gets the report viewer model.

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecute | (Inherited from ReportViewerModel..::.Command.)
ICommand..::.CanExecuteChanged | (Inherited from ReportViewerModel..::.Command.)
ICommand..::.Execute | (Inherited from ReportViewerModel..::.Command.)

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Constructor

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Constructor
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback
Initializes a new instance of the ReportViewerCommand class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected ReportViewerCommand(
    ReportViewerModel viewerModel
)
Visual Basic (Declaration)
Protected Sub New ( _
    viewerModel As ReportViewerModel _
)

Parameters

viewerModel
Type: Telerik.ReportViewer.Wpf..::.ReportViewerModel

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Methods

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Methods
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback

The ReportViewerModel..::.ReportViewerCommand type exposes the following members.

Methods

Name | Description
Execute | Defines the method to be called when the command is invoked. (Inherited from ReportViewerModel..::.Command.)
OnCanExecuteChanged | Raises the CanExcute . (Inherited from ReportViewerModel..::.Command.)

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecute | (Inherited from ReportViewerModel..::.Command.)
ICommand..::.Execute | (Inherited from ReportViewerModel..::.Command.)

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Properties

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Properties
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback

The ReportViewerModel..::.ReportViewerCommand type exposes the following members.

Properties

Name | Description
IsEnabled | Specifies whether the command is enabled. (Inherited from ReportViewerModel..::.Command.)
ViewerModel | Gets the report viewer model.

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ViewerModel Property

[image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand..::.ViewerModel Property
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback
Gets the report viewer model.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
protected ReportViewerModel ViewerModel { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ViewerModel As ReportViewerModel

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerModel.ReportViewerCommand Events

[image] [image]

Telerik Reporting Q2 2012
ReportViewerModel..::..ReportViewerCommand Events
ReportViewerModel..::.ReportViewerCommand Class See Also Send Feedback

Events

Name Description

Explicit Interface Implementations

Name | Description
ICommand..::.CanExecuteChanged | (Inherited from ReportViewerModel..::.Command.)

See Also

ReportViewerModel..::.ReportViewerCommand Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerStates Class

[image]

Telerik Reporting Q2 2012
ReportViewerStates Class
Members See Also Send Feedback
Defines the names of the report viewer visual states.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public static class ReportViewerStates
Visual Basic (Declaration)
Public NotInheritable Class ReportViewerStates

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.ReportViewerStates

See Also

ReportViewerStates Members
Telerik.ReportViewer.Wpf Namespace


ReportViewerStates Members

[image] [image]

Telerik Reporting Q2 2012
ReportViewerStates Members
ReportViewerStates Class Fields See Also Send Feedback

The ReportViewerStates type exposes the following members.

Fields

Name | Description
ViewerError | Specifies the name of the Error visual state.
ViewerPage | Specifies the name of the visual state when a page is displayed.
ViewerWorkInProgress | Specifies the name of the InProgress visual state.

See Also

ReportViewerStates Class
Telerik.ReportViewer.Wpf Namespace


ReportViewerStates Fields

[image] [image]

Telerik Reporting Q2 2012
ReportViewerStates Fields
ReportViewerStates Class See Also Send Feedback

The ReportViewerStates type exposes the following members.

Fields

Name | Description
ViewerError | Specifies the name of the Error visual state.
ViewerPage | Specifies the name of the visual state when a page is displayed.
ViewerWorkInProgress | Specifies the name of the InProgress visual state.

See Also

ReportViewerStates Class
Telerik.ReportViewer.Wpf Namespace


ViewerError Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerError Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the Error visual state.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string ViewerError
Visual Basic (Declaration)
Public Const ViewerError As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Wpf Namespace


ViewerPage Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerPage Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the visual state when a page is displayed.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string ViewerPage
Visual Basic (Declaration)
Public Const ViewerPage As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Wpf Namespace


ViewerWorkInProgress Field

[image]

Telerik Reporting Q2 2012
ReportViewerStates..::.ViewerWorkInProgress Field
ReportViewerStates Class See Also Send Feedback
Specifies the name of the InProgress visual state.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public const string ViewerWorkInProgress
Visual Basic (Declaration)
Public Const ViewerWorkInProgress As String

See Also

ReportViewerStates Class
Telerik.ReportViewer.Wpf Namespace


ScaleFactorConverter Class

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter Class
Members See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ScaleFactorConverter : IValueConverter
Visual Basic (Declaration)
Public Class ScaleFactorConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.ScaleFactorConverter

See Also

ScaleFactorConverter Members
Telerik.ReportViewer.Wpf Namespace


ScaleFactorConverter Members

[image] [image]

Telerik Reporting Q2 2012
ScaleFactorConverter Members
ScaleFactorConverter Class Constructors Methods See Also Send Feedback

The ScaleFactorConverter type exposes the following members.

Constructors

Name | Description
ScaleFactorConverter | Initializes a new instance of the ScaleFactorConverter class

Methods

Name | Description
Convert | Converts number to percent value.
ConvertBack | Converts number to percent value.

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Wpf Namespace


ScaleFactorConverter Constructor

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter Constructor
ScaleFactorConverter Class See Also Send Feedback
Initializes a new instance of the ScaleFactorConverter class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ScaleFactorConverter()
Visual Basic (Declaration)
Public Sub New

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Wpf Namespace


ScaleFactorConverter Methods

[image] [image]

Telerik Reporting Q2 2012
ScaleFactorConverter Methods
ScaleFactorConverter Class See Also Send Feedback

The ScaleFactorConverter type exposes the following members.

Methods

Name | Description
Convert | Converts number to percent value.
ConvertBack | Converts number to percent value.

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter..::.Convert Method
ScaleFactorConverter Class See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
ScaleFactorConverter..::.ConvertBack Method
ScaleFactorConverter Class See Also Send Feedback
Converts number to percent value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ScaleFactorConverter Class
Telerik.ReportViewer.Wpf Namespace


TextBoxEx Class

[image]

Telerik Reporting Q2 2012
TextBoxEx Class
Members See Also Send Feedback
TextBox that autoupdates DataBound Text property in TwoWay binding

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class TextBoxEx : TextBox
Visual Basic (Declaration)
Public Class TextBoxEx _
    Inherits TextBox

Inheritance Hierarchy

System..::.Object
System.Windows.Threading..::.DispatcherObject
System.Windows..::.DependencyObject
System.Windows.Media..::.Visual
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls.Primitives..::.TextBoxBase
System.Windows.Controls..::.TextBox
Telerik.ReportViewer.Wpf..::.TextBoxEx

See Also

TextBoxEx Members
Telerik.ReportViewer.Wpf Namespace


TextBoxEx Members

[image] [image]

Telerik Reporting Q2 2012
TextBoxEx Members
TextBoxEx Class Constructors See Also Send Feedback

The TextBoxEx type exposes the following members.

Constructors

Name | Description
TextBoxEx | The default constructor

See Also

TextBoxEx Class
Telerik.ReportViewer.Wpf Namespace


TextBoxEx Constructor

[image]

Telerik Reporting Q2 2012
TextBoxEx Constructor
TextBoxEx Class See Also Send Feedback
The default constructor

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public TextBoxEx()
Visual Basic (Declaration)
Public Sub New

See Also

TextBoxEx Class
Telerik.ReportViewer.Wpf Namespace


TextResources Class

[image]

Telerik Reporting Q2 2012
TextResources Class
Members See Also Send Feedback
Provides the default tooltips and messages for the viewer.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class TextResources : ITextResources
Visual Basic (Declaration)
Public Class TextResources _
    Implements ITextResources

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.TextResources

See Also

TextResources Members
Telerik.ReportViewer.Wpf Namespace


TextResources Members

[image] [image]

Telerik Reporting Q2 2012
TextResources Members
TextResources Class Constructors Methods Properties See Also Send Feedback

The TextResources type exposes the following members.

Constructors

Name | Description
TextResources | Initializes a new instance of the TextResources class

Methods

Name | Description
ToString | In design time, for the property window to display something more meaningful than the type name. (Overrides Object..::.ToString()()().)

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelButtonText | Specifies the text for each Cancel button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the message if there is an export error.
ExportingMessage | Specifies the transitional exporting message.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
PageSetupToolTip | Specifies the Page Setup tooltip.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviewButtonText | Specifies the text for the Preview button in the parameters area.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersValidationError | Specifies the error message for the case when the report parameters are wrong or missing.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


TextResources Constructor

[image]

Telerik Reporting Q2 2012
TextResources Constructor
TextResources Class See Also Send Feedback
Initializes a new instance of the TextResources class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public TextResources()
Visual Basic (Declaration)
Public Sub New

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


TextResources Methods

[image] [image]

Telerik Reporting Q2 2012
TextResources Methods
TextResources Class See Also Send Feedback

The TextResources type exposes the following members.

Methods

Name | Description
ToString | In design time, for the property window to display something more meaningful than the type name. (Overrides Object..::.ToString()()().)

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ToString Method

[image]

Telerik Reporting Q2 2012
TextResources..::.ToString Method
TextResources Class See Also Send Feedback
In design time, for the property window to display something more meaningful than the type name.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


TextResources Properties

[image] [image]

Telerik Reporting Q2 2012
TextResources Properties
TextResources Class See Also Send Feedback

The TextResources type exposes the following members.

Properties

Name | Description
AllFiles | Specifies the text for the AllFiles filter in the SaveFileDialog.
BackToolTip | Specifies the tooltip for the Back button.
CancelButtonText | Specifies the text for each Cancel button.
CurrentPageToolTip | Specifies the tooltip for the CurrentPage label.
DocumentMapToolTip | Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.
ExportError | Specifies the message if there is an export error.
ExportingMessage | Specifies the transitional exporting message.
ExportToolTip | Specifies the tooltip for the Export button.
FirstPageToolTip | Specifies the tooltip for the FirstPage button.
ForwardToolTip | Specifies the tooltip for the Forward button.
LastPageToolTip | Specifies the tooltip for the LastPage button.
LoadingPageMessage | Specifies the transitional loading page message.
NextPageToolTip | Specifies the tooltip for the NextPage button.
NoReportError | Specifies the error message for missing report.
PageNumberGreaterThanRangeError | Specifies the error message for the case when the page number is greater than the count of pages.
PageNumberLessThanRangeError | Specifies the error message for the case when the page number is less than 1.
PageSetupToolTip | Specifies the Page Setup tooltip.
ParametersToolTip | Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.
PreviewButtonText | Specifies the text for the Preview button in the parameters area.
PreviousPageToolTip | Specifies the tooltip for the PreviousPage button.
PrintPreviewToolTip | Specifies the tooltip for the Print Preview.
PrintToolTip | Specifies the tooltip for the Print button.
ProcessingReportMessage | Specifies the text for the wait message shown while the report is being processed.
RefreshToolTip | Specifies the tooltip for the Refresh button.
ReportParametersAreaValidationError | Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.
ReportParametersNullText | Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.
ReportParametersSelectAllText | Specifies the <select all> text for a multivalue parameter editor.
ReportParametersValidationError | Specifies the error message for the case when the report parameters are wrong or missing.
StopToolTip | Specifies the tooltip for the Stop button.
TotalPagesToolTip | Specifies the tooltip for the TotalPages button.
UpdatingParametersMessage | Specifies the transitional updating parameters message.
ZoomToolTip | Specifies the tooltip for the Zoom select.
ZoomToPageWidth | Specifies the name for the PageWidth zoom mode.
ZoomToWholePage | Specifies the name for the WholePage zoom mode.

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


AllFiles Property

[image]

Telerik Reporting Q2 2012
TextResources..::.AllFiles Property
TextResources Class See Also Send Feedback
Specifies the text for the AllFiles filter in the SaveFileDialog.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string AllFiles { get; set; }
Visual Basic (Declaration)
Public Property AllFiles As String

Implements

ITextResources..::.AllFiles

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


BackToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.BackToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Back button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string BackToolTip { get; set; }
Visual Basic (Declaration)
Public Property BackToolTip As String

Implements

ITextResources..::.BackToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


CancelButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CancelButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for each Cancel button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string CancelButtonText { get; set; }
Visual Basic (Declaration)
Public Property CancelButtonText As String

Implements

ITextResources..::.CancelButtonText

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


CurrentPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.CurrentPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the CurrentPage label.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string CurrentPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property CurrentPageToolTip As String

Implements

ITextResources..::.CurrentPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


DocumentMapToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.DocumentMapToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltips for the toggle document map area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string DocumentMapToolTip { get; set; }
Visual Basic (Declaration)
Public Property DocumentMapToolTip As String

Implements

ITextResources..::.DocumentMapToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ExportError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ExportError Property
TextResources Class See Also Send Feedback
Specifies the message if there is an export error.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ExportError { get; set; }
Visual Basic (Declaration)
Public Property ExportError As String

Implements

ITextResources..::.ExportError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ExportingMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ExportingMessage Property
TextResources Class See Also Send Feedback
Specifies the transitional exporting message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ExportingMessage { get; set; }
Visual Basic (Declaration)
Public Property ExportingMessage As String

Implements

ITextResources..::.ExportingMessage

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ExportToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ExportToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Export button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ExportToolTip { get; set; }
Visual Basic (Declaration)
Public Property ExportToolTip As String

Implements

ITextResources..::.ExportToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


FirstPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.FirstPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the FirstPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string FirstPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property FirstPageToolTip As String

Implements

ITextResources..::.FirstPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ForwardToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ForwardToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Forward button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ForwardToolTip { get; set; }
Visual Basic (Declaration)
Public Property ForwardToolTip As String

Implements

ITextResources..::.ForwardToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


LastPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.LastPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the LastPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string LastPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property LastPageToolTip As String

Implements

ITextResources..::.LastPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


LoadingPageMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.LoadingPageMessage Property
TextResources Class See Also Send Feedback
Specifies the transitional loading page message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string LoadingPageMessage { get; set; }
Visual Basic (Declaration)
Public Property LoadingPageMessage As String

Implements

ITextResources..::.LoadingPageMessage

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


NextPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.NextPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the NextPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string NextPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property NextPageToolTip As String

Implements

ITextResources..::.NextPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


NoReportError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.NoReportError Property
TextResources Class See Also Send Feedback
Specifies the error message for missing report.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string NoReportError { get; set; }
Visual Basic (Declaration)
Public Property NoReportError As String

Implements

ITextResources..::.NoReportError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PageNumberGreaterThanRangeError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PageNumberGreaterThanRangeError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the page number is greater than the count of pages.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PageNumberGreaterThanRangeError { get; set; }
Visual Basic (Declaration)
Public Property PageNumberGreaterThanRangeError As String

Implements

ITextResources..::.PageNumberGreaterThanRangeError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PageNumberLessThanRangeError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PageNumberLessThanRangeError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the page number is less than 1.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PageNumberLessThanRangeError { get; set; }
Visual Basic (Declaration)
Public Property PageNumberLessThanRangeError As String

Implements

ITextResources..::.PageNumberLessThanRangeError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PageSetupToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PageSetupToolTip Property
TextResources Class See Also Send Feedback
Specifies the Page Setup tooltip.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PageSetupToolTip { get; set; }
Visual Basic (Declaration)
Public Property PageSetupToolTip As String

Implements

ITextResources..::.PageSetupToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ParametersToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ParametersToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltips for the toggle parameters area button. The two texts are separated by '|'.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ParametersToolTip { get; set; }
Visual Basic (Declaration)
Public Property ParametersToolTip As String

Implements

ITextResources..::.ParametersToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PreviewButtonText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PreviewButtonText Property
TextResources Class See Also Send Feedback
Specifies the text for the Preview button in the parameters area.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PreviewButtonText { get; set; }
Visual Basic (Declaration)
Public Property PreviewButtonText As String

Implements

ITextResources..::.PreviewButtonText

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PreviousPageToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PreviousPageToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the PreviousPage button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PreviousPageToolTip { get; set; }
Visual Basic (Declaration)
Public Property PreviousPageToolTip As String

Implements

ITextResources..::.PreviousPageToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PrintPreviewToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintPreviewToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Print Preview.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PrintPreviewToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintPreviewToolTip As String

Implements

ITextResources..::.PrintPreviewToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


PrintToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.PrintToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Print button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string PrintToolTip { get; set; }
Visual Basic (Declaration)
Public Property PrintToolTip As String

Implements

ITextResources..::.PrintToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ProcessingReportMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ProcessingReportMessage Property
TextResources Class See Also Send Feedback
Specifies the text for the wait message shown while the report is being processed.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ProcessingReportMessage { get; set; }
Visual Basic (Declaration)
Public Property ProcessingReportMessage As String

Implements

ITextResources..::.ProcessingReportMessage

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


RefreshToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.RefreshToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Refresh button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string RefreshToolTip { get; set; }
Visual Basic (Declaration)
Public Property RefreshToolTip As String

Implements

ITextResources..::.RefreshToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersAreaValidationError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersAreaValidationError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the report parameters are set from the parameters area in the report viewer.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ReportParametersAreaValidationError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersAreaValidationError As String

Implements

ITextResources..::.ReportParametersAreaValidationError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersNullText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersNullText Property
TextResources Class See Also Send Feedback
Specifies the checkbox text for the parameters area for the case when nulls are allowed as parameters.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ReportParametersNullText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersNullText As String

Implements

ITextResources..::.ReportParametersNullText

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersSelectAllText Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersSelectAllText Property
TextResources Class See Also Send Feedback
Specifies the <select all> text for a multivalue parameter editor.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ReportParametersSelectAllText { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersSelectAllText As String

Implements

ITextResources..::.ReportParametersSelectAllText

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ReportParametersValidationError Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ReportParametersValidationError Property
TextResources Class See Also Send Feedback
Specifies the error message for the case when the report parameters are wrong or missing.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ReportParametersValidationError { get; set; }
Visual Basic (Declaration)
Public Property ReportParametersValidationError As String

Implements

ITextResources..::.ReportParametersValidationError

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


StopToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.StopToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Stop button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string StopToolTip { get; set; }
Visual Basic (Declaration)
Public Property StopToolTip As String

Implements

ITextResources..::.StopToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


TotalPagesToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.TotalPagesToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the TotalPages button.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string TotalPagesToolTip { get; set; }
Visual Basic (Declaration)
Public Property TotalPagesToolTip As String

Implements

ITextResources..::.TotalPagesToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


UpdatingParametersMessage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.UpdatingParametersMessage Property
TextResources Class See Also Send Feedback
Specifies the transitional updating parameters message.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string UpdatingParametersMessage { get; set; }
Visual Basic (Declaration)
Public Property UpdatingParametersMessage As String

Implements

ITextResources..::.UpdatingParametersMessage

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ZoomToolTip Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToolTip Property
TextResources Class See Also Send Feedback
Specifies the tooltip for the Zoom select.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ZoomToolTip { get; set; }
Visual Basic (Declaration)
Public Property ZoomToolTip As String

Implements

ITextResources..::.ZoomToolTip

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ZoomToPageWidth Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToPageWidth Property
TextResources Class See Also Send Feedback
Specifies the name for the PageWidth zoom mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ZoomToPageWidth { get; set; }
Visual Basic (Declaration)
Public Property ZoomToPageWidth As String

Implements

ITextResources..::.ZoomToPageWidth

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ZoomToWholePage Property

[image]

Telerik Reporting Q2 2012
TextResources..::.ZoomToWholePage Property
TextResources Class See Also Send Feedback
Specifies the name for the WholePage zoom mode.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public string ZoomToWholePage { get; set; }
Visual Basic (Declaration)
Public Property ZoomToWholePage As String

Implements

ITextResources..::.ZoomToWholePage

See Also

TextResources Class
Telerik.ReportViewer.Wpf Namespace


ViewMode Enumeration

[image]

Telerik Reporting Q2 2012
ViewMode Enumeration
See Also Send Feedback
Specifies the page view mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public enum ViewMode
Visual Basic (Declaration)
Public Enumeration ViewMode

Members

Member name | Description
Interactive | Enables Interactive page view.
PrintPreview | Enables PrintPreview page view.

See Also

Telerik.ReportViewer.Wpf Namespace


VisibilityConverter Class

[image]

Telerik Reporting Q2 2012
VisibilityConverter Class
Members See Also Send Feedback
A value converter for visibility and boolean values.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class VisibilityConverter : IValueConverter
Visual Basic (Declaration)
Public Class VisibilityConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.VisibilityConverter

See Also

VisibilityConverter Members
Telerik.ReportViewer.Wpf Namespace


VisibilityConverter Members

[image] [image]

Telerik Reporting Q2 2012
VisibilityConverter Members
VisibilityConverter Class Constructors Methods See Also Send Feedback

The VisibilityConverter type exposes the following members.

Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class

Methods

Name | Description
Convert | Converts Visibility value.
ConvertBack | Converts Visibility value.

See Also

VisibilityConverter Class
Telerik.ReportViewer.Wpf Namespace


VisibilityConverter Constructor

[image]

Telerik Reporting Q2 2012
VisibilityConverter Constructor
VisibilityConverter Class See Also Send Feedback
Initializes a new instance of the VisibilityConverter class

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public VisibilityConverter()
Visual Basic (Declaration)
Public Sub New

See Also

VisibilityConverter Class
Telerik.ReportViewer.Wpf Namespace


VisibilityConverter Methods

[image] [image]

Telerik Reporting Q2 2012
VisibilityConverter Methods
VisibilityConverter Class See Also Send Feedback

The VisibilityConverter type exposes the following members.

Methods

Name | Description
Convert | Converts Visibility value.
ConvertBack | Converts Visibility value.

See Also

VisibilityConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
VisibilityConverter..::.Convert Method
VisibilityConverter Class See Also Send Feedback
Converts Visibility value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

VisibilityConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
VisibilityConverter..::.ConvertBack Method
VisibilityConverter Class See Also Send Feedback
Converts Visibility value.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

VisibilityConverter Class
Telerik.ReportViewer.Wpf Namespace


ZoomConverter Class

[image]

Telerik Reporting Q2 2012
ZoomConverter Class
Members See Also Send Feedback
Formats a number as % string and vice-versa

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public class ZoomConverter : IValueConverter
Visual Basic (Declaration)
Public Class ZoomConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
Telerik.ReportViewer.Wpf..::.ZoomConverter

See Also

ZoomConverter Members
Telerik.ReportViewer.Wpf Namespace


ZoomConverter Members

[image] [image]

Telerik Reporting Q2 2012
ZoomConverter Members
ZoomConverter Class Constructors Methods See Also Send Feedback

The ZoomConverter type exposes the following members.

Constructors

Name | Description
ZoomConverter | Creates an instance of the ZoomConverter class.

Methods

Name | Description
Convert | Converts a number as % string.
ConvertBack | Converts a number as % string.

See Also

ZoomConverter Class
Telerik.ReportViewer.Wpf Namespace


ZoomConverter Constructor

[image]

Telerik Reporting Q2 2012
ZoomConverter Constructor
ZoomConverter Class See Also Send Feedback
Creates an instance of the ZoomConverter class.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public ZoomConverter(
    ITextResources textResources
)
Visual Basic (Declaration)
Public Sub New ( _
    textResources As ITextResources _
)

Parameters

textResources
Type: Telerik.ReportViewer.Wpf..::.ITextResources

See Also

ZoomConverter Class
Telerik.ReportViewer.Wpf Namespace


ZoomConverter Methods

[image] [image]

Telerik Reporting Q2 2012
ZoomConverter Methods
ZoomConverter Class See Also Send Feedback

The ZoomConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a number as % string.
ConvertBack | Converts a number as % string.

See Also

ZoomConverter Class
Telerik.ReportViewer.Wpf Namespace


Convert Method

[image]

Telerik Reporting Q2 2012
ZoomConverter..::.Convert Method
ZoomConverter Class See Also Send Feedback
Converts a number as % string.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

ZoomConverter Class
Telerik.ReportViewer.Wpf Namespace


ConvertBack Method

[image]

Telerik Reporting Q2 2012
ZoomConverter..::.ConvertBack Method
ZoomConverter Class See Also Send Feedback
Converts a number as % string.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

ZoomConverter Class
Telerik.ReportViewer.Wpf Namespace


ZoomMode Enumeration

[image]

Telerik Reporting Q2 2012
ZoomMode Enumeration
See Also Send Feedback
Specifies the zoom mode for the ReportViewer control.

Namespace: Telerik.ReportViewer.Wpf
Assembly: Telerik.ReportViewer.Wpf (in Telerik.ReportViewer.Wpf.dll)

Syntax

C#
public enum ZoomMode
Visual Basic (Declaration)
Public Enumeration ZoomMode

Members

Member name | Description
FullPage | Sets the zoom mode to full page.
PageWidth | Sets the zoom mode to page width.
Percent | Sets the zoom mode to a percentage.

See Also

Telerik.ReportViewer.Wpf Namespace


Data Binding Chart to ObjectDataSource at Design-Time

[image]

Telerik Reporting Q2 2012
Data Binding Chart to ObjectDataSource at Design-Time
See Also Send Feedback

Use the Data Source Configuration Wizard to bind ObjectDataSource at design time:

  1. Click the Chart Smart Tag "Choose Data Source" | "<New Data Source>".

Smart Tag Choose Data Source

  1. From the "Choose a data source type" page of the wizard select "Object" and click "OK".

Choose a data source type

  1. From the "Choose a Business Object" page of the wizard, select your business object from the drop down list. Click Next.

Choose a business object

  1. On the "Define data methods" page choose the select method from the drop down list. Click Finish. A new ObjectDataSource component will be visible on the page and the Chart DataSource property will point to it.

See Also

Other Resources

[49475AAC-174C-4EB8-B470-8A6C06B387DF]
[FFEB4D39-AECD-42E6-8246-2F628D2217FA]
[BBD6FB59-B7B5-49F7-B0E9-31A812D276D7]


Data Binding Chart to an XML file

[image]

Telerik Reporting Q2 2012
Data Binding Chart to an XML file
See Also Send Feedback

To bind RadChart Telerik.Reporting.Charting..::.Chart to XML data you can:

  1. Bind directly to the XML file itself programmatically at run-time.
  2. Bind to XML data by using an XMLDataSource at design-time.

Products.XML is used for both examples. The XML file is located in the same directory as the default page used to display it.

CopyXML
&lt;?xml version="1.0" encoding="utf-8" ?&gt;
&lt;Products&gt;
&lt;Product Name="Parka L" QuantityInStock="123"&gt;&lt;/Product&gt;
&lt;Product Name="Parka M" QuantityInStock="56"&gt;&lt;/Product&gt;
&lt;Product Name="Parka S" QuantityInStock="92"&gt;&lt;/Product&gt;
&lt;Product Name="Mittens" QuantityInStock="12"&gt;&lt;/Product&gt;
&lt;/Products&gt;

See Also

Other Resources

Binding to XML at Design-Time using an XMLDataSource
Binding to XML Directly at Run-Time
Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Database Object
Data Binding Chart to a Generic List
[49475AAC-174C-4EB8-B470-8A6C06B387DF]


Data Binding Chart to a Generic List

[image]

Telerik Reporting Q2 2012
Data Binding Chart to a Generic List
See Also Send Feedback

Because the Chart Telerik.Reporting.Charting..::.Chart can be bound to objects that implement the IList interface, and generic lists implement IList, it follows that you can bind Chart Telerik.Reporting.Charting..::.Chart to generic lists. These lists can be of simple types, e.g. int and double types, or the lists can be composed of complex objects containing multiple properties.

  • See Data Binding Chart to a Generic List of Simple Types for a minimal example binding to a list of type double.
  • See Data Binding Chart to a Generic List of Objects for a more complex example where multiple properties are used for data and labeling.

See Also

Other Resources

Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Database Object
Data Binding Chart to a Generic List of Simple Types
How-To: Programmatically Data Binding Chart to a Generic List of Objects
Data Binding Chart to an XML file


How-To: Add groups to Chart item??

[image]

Telerik Reporting Q2 2012
How-To: Add groups to Chart item??
Send Feedback

Required introduction

Procedure title

  1. First step

  2. Second step


Data Binding Chart to an Array

[image]

Telerik Reporting Q2 2012
Data Binding Chart to an Array
See Also Send Feedback

To bind a chart to an Array object, assign the chart DataManager..::.DataSource property to the array. The example below demonstrates data binding to an array of integers.

Databinding to an array
CopyC#
private void chart3_NeedDataSource(object sender, System.EventArgs e)
{
    Telerik.Reporting.Processing.Chart chart = sender as Telerik.Reporting.Processing.Chart;
    int[] intArray = new int[4] { 10, 12, 13, 5 };
    chart.DataSource = intArray;
}
CopyVB.NET
Private Sub chart3_NeedDataSource(ByVal sender As Object, ByVal e As System.EventArgs)
    Dim chart As Telerik.Reporting.Processing.Chart = TryCast(sender, Telerik.Reporting.Processing.Chart)
    Dim intArray As Integer() = New Integer(4) {10, 12, 13, 5}
    chart.DataSource = intArray
End Sub

See Also

Other Resources

Data Binding Chart to a Database Object
Data Binding Chart to a Generic List
Data Binding Chart to an XML file
Data Binding Chart


===new-topics===

[image]

Telerik Reporting Q2 2012
===new-topics===
Send Feedback

This topics are grabbed from http://msdn.microsoft.com/en-us/library/bb418434(SQL.10).aspx


Binding to XML Directly at Run-Time

[image]

Telerik Reporting Q2 2012
Binding to XML Directly at Run-Time
See Also Send Feedback

To bind to the data in code at runtime to the XML file directly, use the Server.MapPath property to locate the XML on disk. The example code below has code that assigns the data and data labels columns as well as massaging the general appearance of the chart.  The two critical lines of code that you must have to minimally bind to the XML file are the assignment of the  DataSource
DataManager..::.DataSource
 and the call to  DataBind()
DataManager..::.DataBind
.

CopyC#
// assign the data source
        RadChart1.DataSource = "..\\Chart\\DataBinding\\XMLBinding\\Products.xml";
        RadChart1.Series[0].DataYColumn = "QuantityInStock";
        RadChart1.PlotArea.XAxis.DataLabelsColumn = "Name";

        // assign appearance related properties
        RadChart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300;
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font =
          new System.Drawing.Font("Verdana", 6, System.Drawing.FontStyle.Bold);
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color =
          System.Drawing.Color.BlueViolet;
        RadChart1.PlotArea.Appearance.Dimensions.Margins.Bottom =
          Telerik.Reporting.Charting.Styles.Unit.Percentage(20);

        // bind to the chart
        RadChart1.DataBind();
CopyVB.NET
' assign the data source
        RadChart1.DataSource = "..\Chart\DataBinding\XMLBinding\Products.xml"
        RadChart1.Series(0).DataYColumn = "QuantityInStock"
        RadChart1.PlotArea.XAxis.DataLabelsColumn = "Name"
' assign appearance related properties
        RadChart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font = New System.Drawing.Font("Verdana", 6, System.Drawing.FontStyle.Bold)
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color = System.Drawing.Color.BlueViolet
        RadChart1.PlotArea.Appearance.Dimensions.Margins.Bottom = Telerik.Reporting.Charting.Styles.Unit.Percentage(20)
' bind to the chart
        RadChart1.DataBind()
CopyC#
// assign the data source
        RadChart1.DataSource = Server.MapPath("~/Products.xml");
        RadChart1.Series[0].DataYColumn = "QuantityInStock";
        RadChart1.PlotArea.XAxis.DataLabelsColumn = "Name";

        // assign appearance related properties
        RadChart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300;
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font =
          new System.Drawing.Font("Verdana", 6, System.Drawing.FontStyle.Bold);
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color =
          System.Drawing.Color.BlueViolet;
        RadChart1.PlotArea.Appearance.Dimensions.Margins.Bottom =
          Telerik.Reporting.Charting.Styles.Unit.Percentage(20);

        // bind to the chart
        RadChart1.DataBind();
CopyVB.NET
' assign the data source
        RadChart1.DataSource = Server.MapPath("~/Products.xml")
        RadChart1.Series(0).DataYColumn = "QuantityInStock"
        RadChart1.PlotArea.XAxis.DataLabelsColumn = "Name"
' assign appearance related properties
        RadChart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Font = New System.Drawing.Font("Verdana", 6, System.Drawing.FontStyle.Bold)
        RadChart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color = System.Drawing.Color.BlueViolet
        RadChart1.PlotArea.Appearance.Dimensions.Margins.Bottom = Telerik.Reporting.Charting.Styles.Unit.Percentage(20)
' bind to the chart
        RadChart1.DataBind()

The running application looks something like the figure shown below.

Binding to XML Data

See Also

Other Resources

Data Binding Chart to an XML file
Binding to XML at Design-Time using an XMLDataSource


Data Binding Chart to a Generic List of Simple Types

[image]

Telerik Reporting Q2 2012
Data Binding Chart to a Generic List of Simple Types
See Also Send Feedback

The example below is the result of binding a generic List<> of double to the Chart Telerik.Reporting.Charting..::.Chart DataSource DataManager..::.DataSource property.

Binding to IList

CopyC#
 private void chart1_NeedDataSource(object sender, EventArgs e)
                {
                    chart1.Series.Clear();
                    List&lt;double&gt; chartData = new List&lt;double&gt;();
                    chartData.Add(34);
                    chartData.Add(45);
                    chartData.Add(56);
                    chartData.Add(67);
                    chartData.Add(78);
            Telerik.Reporting.Processing.Chart procChart = (Telerik.Reporting.Processing.Chart)sender;
                    Telerik.Reporting.Chart defChart = (Telerik.Reporting.Chart)procChart.ItemDefinition;
                    procChart.DataSource = chartData;
                }
CopyVB.NET
Private Sub chart1_NeedDataSource(sender As Object, e As EventArgs)
         chart1.Series.Clear()
         Dim chartData As New List(Of Double)()
         chartData.Add(34)
         chartData.Add(45)
         chartData.Add(56)
         chartData.Add(67)
         chartData.Add(78)
 Dim procChart As Telerik.Reporting.Processing.Chart = DirectCast(sender, Telerik.Reporting.Processing.Chart)
         Dim defChart As Telerik.Reporting.Chart = DirectCast(procChart.ItemDefinition, Telerik.Reporting.Chart)
         procChart.DataSource = chartData
        End Sub

See Also

Other Resources

Data Binding Chart to a Generic List
How-To: Programmatically Data Binding Chart to a Generic List of Objects


How-To: Creating Master-Detail Reports Using Table

[image]

Telerik Reporting Q2 2012
How-To: Creating Master-Detail Reports Using Table
Send Feedback

Required introduction

Optional section title

Add one or more sections with content


Binding to XML at Design-Time using an XMLDataSource

[image]

Telerik Reporting Q2 2012
Binding to XML at Design-Time using an XMLDataSource
See Also Send Feedback

To bind to XML at design-time using an XMLDataSource control:

  1. Click the Chart Smart Tag "Choose Data Source" | "<New Data Source>".

Selecting the Smart Tag

  1. From the "Choose a data source type" page of the wizard select "XML File" and click "OK".

Choosing the Data Source Type

  1. Using the Browse button locate and select the XML file. Click OK.

Selecting the XML File

See Also

Other Resources

Data Binding Chart to an XML file
Binding to XML Directly at Run-Time


Data Binding Chart to a Database Object

[image]

Telerik Reporting Q2 2012
Data Binding Chart to a Database Object
See Also Send Feedback
Chart bound to a SqlDataSource"

The figure above shows a running example that starts with a default Telerik.Reporting.Charting..::.Chart with a single Series. The example code:

  • Displays data for a database column by assigning the series ChartSeries..::.DataYColumn or ChartSeries..::.DataXColumn properties. In the example the "TotalSales" column is assigned to the ChartSeries..::.DataYColumn property.

  • Displays database column data in the X axis labels by assigning the column name to the ChartXAxis..::.DataLabelsColumn. The example assigns "CategoryName" to the ChartXAxis..::.DataLabelsColumn property.

Note

Also note how the example sets the ChartMarginsPlotArea..::.Bottom to 30% and the StyleLabel..::.RotationAngle to 300 in order to provide room for the axis labels.

CopyC#
using System;
using Telerik.Reporting.Chart;

public partial class Report1 : Report
{
    public Report1()
    {
        /// <summary>
        /// Required for telerik Reporting designer support
        /// </summary>
        InitializeComponent();
    }

    private void chart1_NeedDataSource(object sender, EventArgs e)
    {
        Telerik.Reporting.Processing.Chart procChart = (Telerik.Reporting.Processing.Chart)sender;
        string sql = @"SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName";
        string connectionString = "Data Source=(local);Initial Catalog=NorthWind;Integrated Security=True";
        SqlDataAdapter adapter = new SqlDataAdapter(sql, connectionString);
        DataSet dataSet = new DataSet();
        adapter.Fill(dataSet);
        procChart.DataSource = dataSet;
        // Set the column for data and data labels:
        // Each bar will show "TotalSales", each label along
        // X-axis will show "CategoryName.
        chart1.Series[0].DataYColumn = "TotalSales";
        chart1.PlotArea.XAxis.DataLabelsColumn = "CategoryName";
        // assign appearance related properties
        chart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300;
        chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color = System.Drawing.Color.BlueViolet;
        chart1.PlotArea.Appearance.Dimensions.Margins.Bottom =
        Telerik.Reporting.Charting.Styles.Unit.Percentage(30);
    }
}
CopyVB.NET
Imports System
Imports Telerik.Reporting.Chart

Public Partial Class Report1
        Inherits Report

    Public Sub New()
        ''' <summary>
        ''' Required for telerik Reporting designer support
        ''' </summary>
        InitializeComponent()
    End Sub

    Private Sub chart1_NeedDataSource(sender As Object, e As EventArgs)
        Dim procChart As Telerik.Reporting.Processing.Chart = DirectCast(sender, Telerik.Reporting.Processing.Chart)
        Dim sql As String = "SELECT CategoryName, SUM(ProductSales) AS TotalSales FROM [Product Sales for 1997] GROUP BY CategoryName"
        Dim connectionString As String = "Data Source=(local);Initial Catalog=NorthWind;Integrated Security=True"
        Dim adapter As New SqlDataAdapter(sql, connectionString)
        Dim dataSet As New DataSet()
        adapter.Fill(dataSet)
        procChart.DataSource = dataSet
        ' Set the column for data and data labels:
        ' Each bar will show "TotalSales", each label along
        ' X-axis will show "CategoryName.
        chart1.Series(0).DataYColumn = "TotalSales"
        chart1.PlotArea.XAxis.DataLabelsColumn = "CategoryName"
        ' assign appearance related properties
        chart1.PlotArea.XAxis.Appearance.LabelAppearance.RotationAngle = 300
        chart1.PlotArea.XAxis.Appearance.TextAppearance.TextProperties.Color = System.Drawing.Color.BlueViolet
        chart1.PlotArea.Appearance.Dimensions.Margins.Bottom = Telerik.Reporting.Charting.Styles.Unit.Percentage(30)
    End Sub
End Class

See Also

Other Resources

Data Binding Chart
Data Binding Chart to an Array
Data Binding Chart to a Generic List
Data Binding Chart to an XML file


Property

[image]

Telerik Reporting Q2 2012
Chart..::. Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
private Chart Chart { get; }
Visual Basic (Declaration)
Private ReadOnly Property Chart As Chart

See Also

Chart Class
Telerik.Reporting Namespace


Property

[image]

Telerik Reporting Q2 2012
Chart..::. Property
Chart Class See Also Send Feedback

Namespace: Telerik.Reporting
Assembly: Telerik.Reporting (in Telerik.Reporting.dll)

Syntax

C#
private string TempImagesFolder { get; set; }
Visual Basic (Declaration)
Private Property TempImagesFolder As String

See Also

Chart Class
Telerik.Reporting Namespace